Environment
Novell iPrint Client for Windows
Situation
When the HP Universal Print Driver version 5.8 is assigned to iPrint printers and the ShortInstallName feature is used, long delays are observed when doing the following operations:
- Installing iPrint printers
- Accessing the properties of an iPrint printer installed to a workstation
- Listing the printers within an application's print dialog
- Submitting a print job
Resolution
Novell is investigating this issue. The following workarounds are currently available:
Similar steps to "Change the ShortInstallName value back to the default value of DEFAULT", but instead of changing the value to DEFAULT, prepend ipp:// to whatever Short Name you have defined. For example, if mycompany is the ShortInstallName value, change it to ipp://mycompany
As with workaround 2, the printer must be uninstalled and reinstalled for the change to take effect.
- Assign a different driver to the iPrint printer.
- Change the ShortInstallName value back to the default value of DEFAULT
- Prepend ipp:// to the existing ShortInstallName
- Upload a different driver to the Driver Store. A different driver could include:
- The 5.7 version of the HP UPD to the Driver Store
- A discrete printer driver (driver specific to the model printer) to the iPrint printer
- A universal driver from a different manufacturer
- Note: the Xerox Global Driver is known to work well with HP printers.
- Assign the "different driver" to the iPrint printers.
- Enable the Auto Driver Update feature for the printers needing to have the driver changed on the workstation.
- See TID 7002435 to learn more about the Auto Driver Update feature
- Open the /var/opt/novell/iprint/htdocs/iprint.ini
- Change the value which follows ShortInstallName to DEFAULT (in all caps).
- Once this change is made the printers must be uninstalled and reinstalled to the workstations for the change to take effect. This can be accomplished by:
- end users manually remove their iPrint printers and re-install them. Or,
- the administrator can follow TID 7008329 to automate that process.
- To make this automated process "silent" to end users, see TID 3476106
Similar steps to "Change the ShortInstallName value back to the default value of DEFAULT", but instead of changing the value to DEFAULT, prepend ipp:// to whatever Short Name you have defined. For example, if mycompany is the ShortInstallName value, change it to ipp://mycompany
As with workaround 2, the printer must be uninstalled and reinstalled for the change to take effect.
Cause
Because the degradation in performance is observed when changing the between versions 5.7 and 5.8 of the HP UPD, it is possible HP introduced a change which is responsible for this issue. Novell is in conversations with HP regarding this.
The HP UPD version 5.8 assumes the ShortInstallName must be resolved on the network. The delay is increased when additional name resolution protocols are registered to the Microsoft TCP/IP stack. Each name resolution protocol has a timeout which must expire before moving on. The Novell Client for Windows installs the SLP and NDS resolution protocols. Therefore, the delays are significantly increased when the Novell Client for Windows is installed to the workstation.
The HP UPD version 5.8 assumes the ShortInstallName must be resolved on the network. The delay is increased when additional name resolution protocols are registered to the Microsoft TCP/IP stack. Each name resolution protocol has a timeout which must expire before moving on. The Novell Client for Windows installs the SLP and NDS resolution protocols. Therefore, the delays are significantly increased when the Novell Client for Windows is installed to the workstation.