User sync failed in Mobility

  • 7012824
  • 10-Jul-2013
  • 10-Dec-2013

Environment

Novell Data Synchronizer Mobility Pack

Situation

WebAdmin | Mobility Connector Settings | User with Sync State Failed
Unable to add user to Mobility, other users add fine
Adding user to DataSync Sync State Failed
WebAdmin | Users | reports LDAP DN with a '\' character, such as 'cn=user\ ,o=novell'
Application User Name also displays incorrectly

Resolution

Although there are other reasons for a user to Fail during sync, the below is a resolution to one found situation preventing sync for a specific user with the Mobility server. Otherwise, see the Resolution steps provided in TID 7012677 for a common fix.

  1. Remove user from the Mobility server (see documentation for Managing Users)
  2. Completely remove all references of the user from Mobility databases (see TID 7008852)
  3. The user object has a space at the end of the name. Rename the user-object - eliminate the trailing space.
    From ConsoleOne, right-click the user-object and select Rename.
  4. Synchronize the user-object.
    From ConsoleOne, right-click the user-object | GroupWise Utilities | Synchronize
  5. Add user to the Mobility server (see documentation for Managing Users)

Cause

LDAP DN of user had a space at the end showing up in datasync as 'cn=userid\ ,ou=users,o=organization'. Rename user and remove the space, then resync with Mobility corrects this issue.