Summary
Performance Center 12.00 and later versions cannot be installed on the a machine that previously hosted Performance Center 11.52 or Performance Center 11.52 Patch 1.
The problem is related to the Performance Center 11.52 installer. It was resolved in Performance Center 11.52 Patch 2.
Error
There is no error message while uninstalling Performance Center 11.52 or Performance Center 11.52 Patch 1.
However, when attempting to install a later version of Performance Center on the same machine, the following message occurs during the installation:
However, when attempting to install a later version of Performance Center on the same machine, the following message occurs during the installation:
Setup has detected files from a previous installation.
Erase all files and restart the installation.
For more details, see KM01174822.
Cause
When uninstalling Performance Center 11.52 or Performance Center 11.52 Patch 1, the Performance Center installer removes the software from the machine but does not remove the related configuration settings such as services, system user and IIS configuration.
Fix
The following solutions are available:
- Apply a hotfix (proactive solution) - To be used before uninstalling Performance Center 11.52
- Manually remove the configuration - To be used after uninstalling Performance Center 11.52 (and before installing a newer version)
Hotfix:
-
Before uninstalling Performance Center 11.52, download and extract the appropriate zip file:
-
Replace the run_before_modify.bat file under the <PC Install Directory> on each of the Performance Center machine
-
After uninstalling Performance Center 11.52, download the Workaround.zip and extract its content.
-
Follow the steps described in the extracted document.