"Error initializing VBA components..." when loading a Reflection or InfoConnect Workspace or a host session

  • 7024868
  • 15-Oct-2020
  • 10-Nov-2020

Environment

InfoConnect Desktop 16.0 or higher
Reflection Desktop (including Pro, for X, for IBM, or for UNIX and OpenVMS) 16.0 and higher
Reflection 2014
Reflection Pro 2014
Reflection for IBM 2014
Reflection for UNIX and OpenVMS 2014
Reflection for IBM 2011
Reflection for UNIX and OpenVMS 2011
Reflection Standard Suite 2011

Situation

When loading the Reflection or InfoConnect Workspace or when loading a Reflection host session (3270, 5250, or Unix and OpenVMS), a dialog appears which says "Error initializing VBA components. One of the VBA components is missing or corrupt. VBA needs to be reinstalled." as shown below:

https://support.microfocus.com/images/2605_0.gif

The user can dismiss the error dialog and continue using the product, but the VBA programming language and VBA macros will be unavailable for use.

This error will occur with any version of Reflection or InfoConnect Desktop, after any of the following October 2020 updates for Microsoft Office are installed:
        KB4484417
        KB4484435
        KB4486682
        KB4486688
        KB4486700

See this web page for details on the October 2020 Updates for Microsoft Office:
https://support.microsoft.com/en-us/help/4583495/october-2020-updates-for-microsoft-office

The following web pages describe the Microsoft products which were patched and will be impacted by this issue:
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-16930
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-16929

Resolution

Hotfix and Update releases for the affected Micro Focus products are available according to the following table:

Release

Version

Release Date

Reflection and InfoConnect Desktop 16.0

16.0.1.549 or 16.0 SP1 Hotfix (Build 549)

03-Nov-2020

Reflection and InfoConnect Desktop 16.1

16.1.1.530 or 16.1 SP1 Update2 Hotfix (Build 530)

23-Oct-2020

Reflection and InfoConnect Desktop 16.2

16.2 Update5

29-Oct-2020

Reflection and InfoConnect Desktop 17.0

17.0 Update1

09-Nov-2020

Effective 23 October 2020:

A Hotfix for Reflection and InfoConnect Desktop version 16.1 was released on 23 October 2020. 
To obtain a download link to this Hotfixes, contact the Micro Focus Host Connectivity Technical Support group via one of the methods below:

    • Call 800-688-3270 (toll-free in USA) or your regional support office
    • Email
    • Online Portal

Effective 29 October 2020:
An Update for Reflection and InfoConnect Desktop versions 16.2 was released on 29 October 2020. 
Maintained customers are eligible to download Reflection Desktop 16.2 Update 5 at:


You will be prompted to login and accept the Software License Agreement before you can download a file.

Effective 03 November 2020:
A new Hotfix for Reflection and InfoConnect Desktop version 16.0 was released on 03 November 2020.  An original Hotfix, labeled version 16.0 SP1 HF19, was released on 23 October 2020, but this Hotfix, while fixing the VBA initialization issue, may experience issues in some environments with running legacy-ExtraBasic macros.  A new Hotfix (labeled HF20) has thus been issued to replace HF19.  To obtain a download link to this Hotfix, contact the Micro Focus Host Connectivity Technical Support group via one of the methods below:

    • Call 800-688-3270 (toll-free in USA) or your regional support office
    • Email
    • Online Portal

Effective 09 November 2020:
An Update for Reflection and InfoConnect Desktop versions 17.0 was released on 09 November 2020. 
Maintained customers are eligible to download Reflection Desktop 17.0 Update 1 at:


You will be prompted to login and accept the Software License Agreement before you can download a file.


A HotFix (HF) for Reflection Desktop is a cumulatively built product update, intended for limited distribution, which addresses specific customer issues and enhancement requests; outside the regular Development release cycle. It is only available to Micro Focus customers with current software support and maintenance contracts, and only after contacting Micro Focus Technical Support directly.  A HotFix undergoes limited stability and quality testing and is intended for quick release to address specific product issues and should not be deployed to production environments without thorough testing.  It is recommended to upgrade to a full-release or a Service Pack version of Reflection Desktop when it becomes available.

Cause

The Micro Focus Development organization has investigated this issue and the compatibility of this Microsoft Office security vulnerability update with our products.  It appears that the Microsoft Office updates apply a newer version of the Microsoft VBA modules (VBE71.DLL version 7.1.11.0) which was incompatible with all versions of Reflection and InfoConnect Desktop, thus product updates were released to resolve this issue.

Status

Reported to Engineering
Top Issue

Additional Information

Applying the suggested solutions in the following Micro Focus knowledge-base articles will NOT resolve the issue:

Alternative Workaround:
Remove the Microsoft Office updates listed above or else run the Reflection and InfoConnect Desktop products without VBA macro support by dismissing the error dialog as the product loads.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.