Environment
GroupWise 2014
GroupWise 2014 R2
GroupWise 2014 R2
GroupWise 18
Situation
After a few minutes of being in the admin console shows this
error and locks the user out from being able to do anything, or see
anything. The error can be forced by navigating around the
Administration Console rapidly.
Additional logging will be required. Use this
to enable debug log levels for the admin service.
The admin service logs are in
/var/log/novell/groupwise/gwadmin. Open the gwadmin-service.log
file. It contains an entry like the following:
UserAgent: "GwAdminConsole/14.2.0 (Linux; 1.8.0_92)"; }; Not granted any authorities' could not be authenticated. Reason
is '{56172}: Intruder lockout is enforced'
[DEBUG]
Login exception type:
com.novell/gw/directory.exception.GwAdminLoginException: Intruder
lockout is enforced
Resolution
There are two possible
resolutions
Option 1:
Web Browser has saved old credentials and is attempting to log in
- Set the POA logs to verbose
-
- POA | Log Settings | Logging level: verbose
- Open the POA http console
- Search the logs for login attempts
-
- Log files | Events containing: admin | View Events
- "User admin has logged in Web Console from <IP Adress>
- if you see more than what is actually happening then:
-
- clear browser cache
- Use a different web browser
Option 2:
It's possible the admin user account password is corrupted and needs to be reset
- Admin Console | System | Record
Enumerations
- In the Record Type select System by ID
- Select the local system | Click Information
- Two fields determine the intruder
lockout: 61256 and 63281. If these fields exist, note their values.
These should get cleaned up each time there is a successful
login.
- Reset the admin account password
-
- At the server terminal running the following command
-
- note: replace "/groupwise/domain/" with the path to your domain directory
- note: replace "admin" with
your super admin user. It's possibly 'gwadmin'
- gwadminutil setadmin -d /groupwise/domain/ -a admin -p
Cause
There must be corruption to the super
admin account. Open a Service Request with Customer Support to
learn more about a bug fix.