Licensing ZENworks during ZCM Upgrade or Migration

  • 7023323
  • 31-Aug-2018
  • 05-Nov-2019

Environment

ZENworks Configuration Management 2017
ZENworks Configuration Management 2017 Migration
ZENworks Configuration Management 2020
ZENworks Configuration Management 2020 Migration

Situation

Understanding the licensing scenarios when Upgrading or Migrating to a newer version of ZENworks Configuration Management.
Suite or Product Licenses will be requested during the upgrade wizard process or appliance migration process.
This example refers to upgrading from ZCM 11.4.x to ZCM 2017.
Similar licensing would apply when upgrading from ZCM 2017 to ZCM 2020.

Resolution

Scenario A If ZENworks 11 SP4 Zone has ZENworks Suite as "Not Licensed" state, and one or more Products are in "Active" state under
ZCC > Configuration | Product Licensing
  • Ensure ZENworks 2017 license keys are available for the same ZENworks Product in the Micro Focus Customer Center prior to ZENworks 2017 upgrade (or appliance migration).
Scenario B:  If ZENworks 11 SP4 Zone has ZENworks Suite as"Active" state under
ZCC > Configuration | Suite Licensing
  • Ensure "ZENworks Suite 2017" license is available in Micro Focus Customer Center prior to ZENworks 2017 upgrade (or appliance migration).
  • If "ZENworks Suite 2017" license is not available in the Micro Focus Customer Center and only the Product licenses for ZENworks 2017 are available, then "Deactivate" the ZENworks Suite in ZENworks 11 SP4 zone in ZCC, and "Activate" the same Product Licenses for ZENworks 11 SP4 zone in ZCC, prior to ZENworks 2017 upgrade (or appliance migration).
  • Refer to the ZENworks Documentation for Activating and/or Deactivating products.
Scenario C: If "ZENworks Suite 2017" license is available in the Micro Focus Customer Center but only Product licenses are "Active" in the ZENworks 11SP4 zone under
ZCC > Configuration | Product Licensing
  • Then Activate "ZENworks Suite" license for ZENworks 11 SP4 version in ZCC, prior to ZENworks 2017 upgrade (or appliance migration).
  • Refer to the ZENworks documentation for Activating Licenses.
Scenario D: If ZENworks 2017 Product license(s) available in the Micro Focus Customer Center are different than ZENworks 11 SP4 Product licenses "Active" in the ZENworks 11 SP4 zone under
ZCC > Configuration | Product Licensing
  • Then "Deactivate" the same Product(s) in ZENworks 11 SP4 ZCC that are not licensed for ZENworks 2017, prior to ZENworks 2017 upgrade (or appliance migration).
  • Refer to ZENworks documentation for deactivating specific product licenses in ZCC.

Cause

Upgrading from ZENworks 11 SP4 to ZENworks 2017, the same licenses "Active" in the Zone (ZENworks 11 SP4), must be available for the ZENworks 2017 version in Micro Focus Customer Center.
Fixed in next major version ZENworks 2020 where customer can move between the two different categories during  the upgrade 2017 ZCM and 2017 ZCM Suite.



Additional Information

Agent Spokes Disabled:
If Agent spokes (ZCM components) are disabled when Suite License option is selected during the upgrade process. 
For example: upgrading from ZCM 2017 zone w/eval licensing TO ZCM 2020 Suite, the agent spokes may be disabled and the devices might be rebooted.
Check ZCC > Configuration | Device management > ZENworks Agent and enable the required agent features and/or change the reboot options.

ZCM 2017U4FRU1 Agents Baselined (TID 7024215):
In some cases having ZENworks 2017 Update 4 FRU1 (17.4.1) assigned to devices, then upgrading primary servers to 2020 will cause the 2017 Update 4 FRU1 (17.4.1) update to be automatically assigned to all devices in the zone and baseline.  This will cause all of the devices in the zone that had not already updated to FRU1 to apply FRU1 immediately.


Example: To check ZENworks Suite 2017 License in Customer Center


Example:  To check ZCM 2017 Product License in Customer Center

NOTE:  If any assistance is required in the case where ZENworks 2017 licenses in the Micro Focus Customer Center is not the same type as ZENworks Product or Suite Licenses enabled for ZENworks 11 SP4;
You may contact Micro Focus Customer Support here, to chat with a representative regarding licensing.
If there are any questions on Product licenses, refer to Micro Focus Customer Center FAQ for most answers and all licensing help, email entitlements@microfocus.com for assistance.