Logon issues to Windows 10 1703 or Later if ZCM Agent installed prior to Initial Windows Reboot

  • 7022942
  • 10-May-2018
  • 19-Mar-2019

Environment

ZENworks Configuration Management 2017 Update 1
ZENworks Configuration Management 2017 Update 2

Situation

If Windows 10 1703 (or Later) is not rebooted once after install prior to installing the ZCM Agent, the Windows logon dialogue may not appear.
This has specifically been confirmed in versions 1703, 1709, and 1803.
 
MDT Deployments may exhibit this issue as well, if the ZCM agent is installed during one of the Task Sequences.
 

Resolution

This is fixed in version ZENworks Configuration Management 2017 Update 3 - see KB 7023221 "ZENworks Configuration Management 2017 Update 3 update information and list of fixes" which can be found at https://support.microfocus.com/kb/doc.php?id=7023221 

There are two ways to avoid this issue.
Currently there are two workarounds....
 
#1 - Reboot Windows 10 after initial install prior to installing the ZCM Agent.
 
#2 - Set the "DisableZENCredentialProvider" registry key when installing the ZCM Agent.
 
This key can be removed after the first logon to Windows.
 
Note: ZCM 2017 Update 3 is tentatively expected to resolve this issue.
 

Cause

Some of the Registry Keys the ZCM Credential Provider depends upon are not fully initialized until after Windows 10 1803 reboots and initial user logon occurs.