Memory Allocation Error [F03E] during QuickFinder Indexing

  • 7022175
  • 25-Oct-2017
  • 17-Feb-2021

Environment

GroupWise 2014 
GroupWise 18.0
GroupWise 18.1
GroupWise 18.2
GroupWise 18.3

Situation

The following is seen in the POA log file during QuickFinder Indexing:

12:01:13 97FF Error: Memory Allocation error [F03E] in Squeeze.QFSqzIndex ()
12:01:13 97FF Error: Memory Allocation error [F03E] in Squeeze.QFSqzIndex ()
12:01:13 97FF The database function 87 reported error [F03E] on userc7a.db
12:01:13 97FF Error updating QuickFinder indexes: [F03E]

User's email is not indexed despite QuickFinder indexing running on the POA.
Rebuilding the individual user's QuickFinder indexes still results in the [F03E] error.

Resolution

Determine what .idc and .idx files are associated with the user database the error is being reported on.  This can be done by running GWCheck against the user account, only a Structure check is necessary.  In the resultant gwcheck.log file look for the following information:

Quickfinder:  Pending jobs = 868995   Files = 59e67369.idx, 59ed0882.inc

In this example the user has 868995 items still to be indexed and the 59e67369.idx, 59ed0882.inc are associated with the user.
On the GroupWise server navigate to /path_to_poa/ofuser/index/ and delete the .idx and .inc files identified above.
Rebuild the individual user's QuickFinder index by following the steps in TID 7012997.

Cause

Corrupted index files.

Additional Information

When rebuilding the user's QuickFinder index the first time an error indicating that the index files for the user are missing will be in the POA log file.  This is as a result of them being deleted.