Reflection 14.1 Installation Stops if Reflection 2014 Detected

  • 7021737
  • 07-Mar-2014
  • 31-Mar-2018

Environment

Reflection 2014
Reflection Pro 2014
Reflection X 2014
Reflection for IBM 2014
Reflection for UNIX and OpenVMS 2014
Reflection for HP with NS/VT version 14.1
Reflection X version 14.1
Reflection for IBM version 14.1
Reflection for UNIX and OpenVMS version 14.1
Reflection for the Multi-Host Enterprise Standard Edition version 14.1
Reflection for the Multi-Host Enterprise Professional Edition version 14.1

Situation

Reflection 14.1 products cannot be installed on workstations where a Reflection 2014 product already is installed. If Reflection 2014 is detected, the Reflection 14.1 installation stops and the following error displays, "Installation of this product will be compromised because of incompatibility with one or more products."

Resolution

Note the following:

  • One exception to this behavior occurs if you install Reflection for HP 14.1 on a workstation where one of the following Reflection 2014 products is installed:
Reflection 2014
Reflection Pro 2014
Reflection for IBM 2014
Reflection for UNIX and OpenVMS2014

Reflection for HP with NS/VT 14.1 can be installed and will coexist with these Reflection 2014 products. You must install Reflection for HP with NS/VT 14.1 after you install Reflection 2014. See KB 7021440.

  • Reflection X 14.1 is included as a feature in Reflection X 2014 and Reflection Pro 2014 . If you have either of these products, you can install and run Reflection X 14.1 in addition to, or instead of Reflection X Advantage. Reflection X Advantage (Attachmate's newer X server) is included in a default installation; Reflection X 14.1 is not.

Reflection 14.1 Installation Stops if Reflection 2014 Is Detected

Reflection 14.1 products (with the exception of Reflection for HP with NS/VT) cannot coexist on a workstation where a Reflection 2014 product already is installed because of conflicts with shared components. Because of this incompatibility, the installation of Reflection 14.1 products will be blocked on workstations where a Reflection 2014 product already is installed and an error displays:

"Installation of this product will be compromised because of incompatibility with one or more products."

If you need to install Reflection 14.1 on a system on which Reflection 20`4 has been installed, you must uninstall Reflection 2014 first.

Reflection 2014 Upgrade Behavior

Alternately, if you install a Reflection 2014 product on a workstation where a Reflection 14.1 product already is installed, Reflection 2014 will remove and upgrade Reflection 14.1 depending on which product you are installing and which Reflection 14.1 product is installed.

For more information, see the "Upgrading from Earlier Versions of Reflection or EXTRA!" section in KB 7021447.

Additional Information

Legacy KB ID

This document was originally published as Attachmate Technical Note 2711.

Feedback service temporarily unavailable. For content questions or problems, please contact Support.