Mac bundle system requirements fail to properly calculate application version

  • 7015557
  • 19-Aug-2014
  • 23-Dec-2014

Environment

Novell ZENworks Configuration Management 11.3.1 Bundles

Situation

When creating a Mac bundle that has system requirements using Version of Application as the requirement, the agent will not calculate the requirement properly when comparing an installed version of x.x.x against a system requirement version of x.x.xx.

An example of this scenario would be that the installed version of the application on the Mac device is version 3.7.4 and the system requirements are looking for a version that is < 3.7.13. The system requirements are calculated and fail, when they should not.

Resolution

This is fixed in version 11.3.2 - see KB 7015776 "ZENworks Configuration Management 11.3.2 - update information and list of fixes" which can be found at https://support.microfocus.com/kb/doc.php?id=7015776

Feedback service temporarily unavailable. For content questions or problems, please contact Support.