Environment
Novell ZENworks Configuration Management 11.3
Novell Service Desk
Microsoft Windows Primary Server
Novell Service Desk
Microsoft Windows Primary Server
Situation
See TID 7014716 for a somewhat similar issue where
the service fails to start.
More debug information can be found with the following steps:
ERROR:
org.apache.coyote.AbstractProtocol init
SEVERE: Failed to initialize end point associated with ProtocolHandler ["ajp-bio-8009"]
java.net.BindException: Address already in use: JVM_Bind <null>:8009
The following can be seen when running the command "netstat -nab":
TCP 127.0.0.1:8009 0.0.0.0:0 LISTENING
[tomcat7.exe]
- ZENworks Control Center (ZCC) is unavailable
- The Novell ZENworks Server Service will start without error
- Refreshing the services window shows that the service has stopped again
- The Novell ZENworks Loader Service will start and stay started as opposed to the situation in the above mentioned TID
More debug information can be found with the following steps:
- Run zenserverw.exe
- Select the Logging tab
- Change Level to Debug
- Specify the Log path as %ZENWORKS_HOME%\logs
- Specify Redirect Stdout as %ZENWORKS_HOME%\logs\zenserver-out.log
- Specify Redirect Stderror as %ZENWORKS_HOME%\logs\zenserver-error.log
- Restart the Novell ZENworks Server Service
ERROR:
org.apache.coyote.AbstractProtocol init
SEVERE: Failed to initialize end point associated with ProtocolHandler ["ajp-bio-8009"]
java.net.BindException: Address already in use: JVM_Bind <null>:8009
The following can be seen when running the command "netstat -nab":
TCP 127.0.0.1:8009 0.0.0.0:0 LISTENING
[tomcat7.exe]
Resolution
Do one of the following:
- Disable the LiveTime service
- Move the Service Desk installation to another server.
Cause
Service Desk and ZENworks are conflicting with each other as they
both use the same port (8009) for Tomcat by default.