Environment
Novell ZENworks Configuration Management 11.3
Linux Primary Server
Windows Primary Server
Windows Primary Server
Situation
ZENworks Configuration Center (ZCC) can not be found after
upgrading or installing the ZENworks primary server to ZENworks Configuration
Management 11 SP3 (ZCM 11.3).
zenloader and/or zenserver service not running.
The Upgrade or Install to ZCM 11.3 shows as either successful or a
warning appears in the ZENworks_Upgrade_<date>.log.xml during the
SystemStatusConfigureAction.
Linux:
ERROR (from catalina.out for zenserver debug):
Error
occurred during initialization of VM
Incompatible minimum and
maximum heap sizes specified
Windows:
ERROR (from commons-daemon.<date>.log)
FindClass org/apache/catalina/startup/Bootstrap failed
Java Worker thread finished org/apache/catalina/startup/Bootstrap:main with status=3
Failed to start Java
ServiceStart returned 4
reportServiceStatusE: 1, 1066, 0, 4
Check and see if the Novell ZENworks Server and the Novell
ZENworks Loader services are running:
Linux:
Windows:
Start > [right click Computer] > Configuration > Services
Linux:
Windows:
Run zenserverw.exe
Select the Logging tab
Change Level to Debug
Specify the Log path as %ZENWORKS_HOME%\logs
Specify Redirect Stdout as %ZENWORKS_HOME%\logs\zenserver-out.log
Specify Redirect Stderror as %ZENWORKS_HOME%\logs\zenserver-error.log
Restart the Novell ZENworks Server Service
Linux:
/etc/init.d/novell-zenserver
status
/etc/init.d/novell-zenloader
status
Windows:
Start > [right click Computer] > Configuration > Services
If they are not running, try restarting them and check again.
To restart the service, run the following commands and look for
catalina.out errors:
Linux:
/etc/init.d/novell-zenmntr
stop
/etc/init.d/novell-zenserver
stop
/etc/init.d/novell-zenserver
debug
Windows:
Run zenserverw.exe
Select the Logging tab
Change Level to Debug
Specify the Log path as %ZENWORKS_HOME%\logs
Specify Redirect Stdout as %ZENWORKS_HOME%\logs\zenserver-out.log
Specify Redirect Stderror as %ZENWORKS_HOME%\logs\zenserver-error.log
Restart the Novell ZENworks Server Service
If they are still not running, please contact Novell
Support.
Resolution
This is fixed in version 11.4.3 - see KB 7017820 "ZENworks Configuration Management 11.4.3 - update information and list of fixes" which can be found at https://support.microfocus.com/kb/doc.php?id=7017820
Workaround for 11.3x and 11.4.x
Do the following on the Primary server where the issue was seen:
Linux:
Linux:
- Verify that at least 4 GB of RAM are allocated to the Primary server
- Check the JAVA_MAX_HEAP size for both the
ZENServer and ZENLoader services. Make sure the JAVA_MAX_HEAP is equal to or
larger than the JAVA_MIN_HEAP.
To see the JAVA_MAX_HEAP size on Linux servers:
/opt/novell/zenworks/bin/zenserversettings.sh
/opt/novell/zenworks/bin/zenloaderserttings.sh - If the JAVA_MAX_HEAP size is less than the JAVA_MIN_HEAP size, do one of the following:
- Manually change the JAVA_MAX_HEAP to be equal or larger than the JAVA_MIN_HEAP.
- To automatically use recommended settings, run the command: novell-zenworks-configure -c tools.ZenConfigureUtility
- Restart the ZENworks services.
- Run zenserverw.exe
- Select the Java tab
- Add the following to the end of the Java Classpath field: ;C:\Program Files
(x86)\Novell\ZENworks\share\tomcat\bin\tomcat-juli.jar
NOTE: Change the above path to match the path of %ZENWORKS_HOME% on that primary server
Cause
For Linux, zenserversettings.sh and/or zenloadersettings.sh were
set incorrectly for max heap size and min heap size. The installer will do this automatically if the server has less than the recommended 4 GB of RAM.
For Windows, there was a jar file missing from the Java Classpath.
For Windows, there was a jar file missing from the Java Classpath.
Status
Reported to EngineeringAdditional Information
The error in the ZENworks_Upgrade_<date>.log.xml log
will show as follows if the System Status check was done after the
update:
Unable to establish an HTTP
connection to http://localhost:80/zenworks/zccstatus. Ensure
that the web server is started.] [java.net.ConnectException:
Connection refused
at
java.net.PlainSocketImpl.socketConnect(Native Method)
at
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
at
java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
at
java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
at
java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at
java.net.Socket.connect(Socket.java:579)
at
java.net.Socket.connect(Socket.java:528)
at
java.net.Socket.<init>(Socket.java:425)
at
java.net.Socket.<init>(Socket.java:280)
at
org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:79)
at
org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:121)
at
org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:706)
at
org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:386)
at
org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:170)
at
org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:396)
at
org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:324)
at
com.novell.zenworks.configure.actions.SystemStatusConfigureAction.pingHttp(SystemStatusConfigureAction.java:368)
at
com.novell.zenworks.configure.actions.SystemStatusConfigureAction.pingHttp(SystemStatusConfigureAction.java:353)
at
com.novell.zenworks.configure.actions.SystemStatusConfigureAction.configure(SystemStatusConfigureAction.java:249)
at
com.novell.zenworks.configure.actions.SystemStatusConfigureAction.main(SystemStatusConfigureAction.java:428)