Environment
Novell GroupWise 2014
Novell GroupWise 2014 R2
Novell GroupWise 2014 R2
Situation
Mailbox changes don't appear in WebAccess - auto-refresh is not working (autorefresh, auto refresh)
New messages and/or deleting messages in WebAcccess does not refresh the screen.
When you receive a message, it does not appear until you refresh the page.
When you delete a message, it does not disappear until you refresh the page.
New messages and/or deleting messages in WebAcccess does not refresh the screen.
When you receive a message, it does not appear until you refresh the page.
When you delete a message, it does not disappear until you refresh the page.
Resolution
- Verify WebAccess is properly configured for Auto-Refresh Functionality.
- Login to WebAccess as a user, verify the Poll thread is listening in the WebAccess logs (/var/opt/novell/groupwise/webaccess/logs/<mostRecentLog>):
17:59:34, <SOAP>, -, INFO, <system>, Poll thread listenening on: 151.155.215.40:8500
-
Verify the service is listening:
lsof -i :8500; netstat -tulpn | grep 8500
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
java 32727 tomcat 173u IPv6 326182 0t0 UDP <hostname>:fmtp
udp 0 0 <webaccessIP>:8500 :::* 32727/java -
Check the top two lines in the /etc/opt/novell/groupwise/webaccess/gw.conf file. They should display as follows on an OES Linux box:
ProxyPass /gw/webacc/poll ajp://localhost:9009/gw/webacc/poll
ProxyPass /gw/webacc ajp://localhost:9009/gw/webaccSubstitute port 9009 for port 8009 on SLES 11 or 12 server.Restart apache and tomcat after the change.
Cause
Service may not be listening properly. At the time of writing this TID, GroupWise 2014 SP1 has been released officially. Please update to this released version as it contains fixes related to auto-refresh (see TID 7015350 - Auto-refresh is not working GroupWise 2014).