Serial number in device summary is not updating

  • 7014394
  • 10-Jan-2014
  • 11-Jan-2014

Environment

Novell ZENworks Configuration Management 11.2 Registration

Situation

Device has hardware related problem and gets replaced with a different one of same model. The hard disk is reused from the original device.
Later, the broken device gets fixed and gets put back to production with new hard disk.

The device can not get imaged by hardware rules any more but keeps getting back no work to do.
If manually imaged/installed, both device objects have same serial number showing in device summary in ZCC.

Resolution

Allow the registration service to update the serial number on already existing device objects:
Edit the config.xml in /opt/novell/zenworks/share/tomcat/webapps/zenworks-registration/WEB-INF (Linux) or %zenworks_home%\share\tomcat\webapps\zenworks-registration\WEB-INF (Windows) on the primary servers and change the line:
<AllowSerialNumberUpdate>false</AllowSerialNumberUpdate>
to
<AllowSerialNumberUpdate>true</AllowSerialNumberUpdate>

Please note, this config.xml might reset to original settings when applying a ZCM update, when the zenworks-registration.war file gets re-extracted to rebuild the zenworks-preboot sub folder.

Cause

The ZCM registration service does not change the serial number as showing in the devices summary information in ZCC with default configuration. This is the serial number being used for device reconciliation.

Additional Information

Please note in this case the "good" serial number is showing in the device inventory information while the "old" serial number is still showing in the device summary.

With respect to imaging, it is also possible to have it skipping device conciliation while trying match hardware rules as described in TID 7008848