System Update fails to apply with time out error cross platform (e.g., Linux)

  • 7014137
  • 19-Nov-2013
  • 26-Feb-2014

Environment

Novell ZENworks Configuration Management 11.2

Situation

System update fails on xplat (cross platform) agents with timeout error.

ERROR (from zmd-messages.log):

[SystemUpdateModule] [Getting content for INSTALL steps of update] [] []
[SystemUpdateModule] [Read timed out] [] []
[SystemUpdateModule] [org.apache.axis2.AxisFault: Read timed out] [] []
[SystemUpdateModule] [***************** Exception Dump ***********************] [] []
[ZenworksAgent] [60] [SystemUpdateModule] [Unexpected error occured during system update] [] []

Resolution

This is fixed in version 11.3 - see KB 7014213 "ZENworks Configuration Management 11.3 - update information and list of fixes", which can be found at https://support.microfocus.com/kb/doc.php?id=7014213
Workaround:
  1. Modify /etc/opt/novell/zenworks/conf/xplatzmd.properties
  2. Add lines:
    connection-timeout=xyz
    socket-timeout=xyz
    Where xyz is the maximum number of milliseconds to wait before timing out.  See services-messages.log per Additional Information in this TID to see how long the server is taking to respond.  Make it a bit above the max seen there.
  3. Restart the xplat agent:  /etc/init.d/novell-zenworks-xplatzmd restart
  4. Reapply the failed system update assignment.

Cause

The primary server is taking too long to respond to the request getAssignedSystemUpdateCommands.

See services-messages.log System Update response time for the same guid as the device failing. Example:

[System Update Web Service] [30077] [] [getAssignedSystemUpdateCommands complete, time: 240000ms, update commands count: 260, thread: 30077, deviceId: b727359eaf79fd61625d93fea6b91556, updateId: 5011020400fc50000000002013102513, commandLocation: INSTALL] [] []

Additional Information

To determine why primary responses are taking so long see TIDs for troubleshooting performance at support.novell.com.