Running out of disk space on Mobility server

  • 7013456
  • 15-Oct-2013
  • 02-Jul-2014

Environment

Novell Data Synchronizer Mobility Pack

Situation

Attachments not cleaned up in /var/lib/datasync/mobility/attachments directory.
Attachments growing, taking up or consuming available disk space.
How to manually cleanup DataSync Mobility attachments.
Mobility server running out of disk space, critical.

Resolution

Nightly Maintenance should be cleaning up the /var/lib/datasync/mobility/attachments directory.
Please consider the following:
  • TID 7013192 - How to check Nightly Maintenance is completing on Mobility server.
  • Increasing the duration of Nightly Maintenance by extending the StopHour time.
    See Resolution steps in TID 7012712.

In rare occassions, the attachments folder can be manually cleaned up. It is recommended for Nightly Maintenance to be responsible for cleanup only; however, the following unsupported tool can be used to attempt manual cleanup:

  1. See TID 7015282  - How to install dsapp on a Mobility server.
    Note: Once dsapp is loaded, proceed with the steps below.
  2. Select Checks & Queries | Check Mobility Attachments.
    Note: It now analyzes the attachments directory for files that are beyond the sync limit (files that should not be there).
  3. Select Y or N to Check Nightly Maintenance as desired.
    Note: This can take a long time and isn't required, suggest skipping. It essentially verifies Nightly Maintenance is configured and finishing, which can also be determined from the TID mentioned above.
  4. Select Y to attempt manual cleanup. Something similar to the following will then be displayed:
    DROP TABLE
    NOTICE:  CREATE TABLE will create implicit sequence "dsapp_oldattachments_id_seq" for serial column "dsapp_oldattachments.id"
    NOTICE:  CREATE TABLE / PRIMARY KEY will create implicit index "dsapp_oldattachments_pkey" for table "dsapp_oldattachments"
    CREATE TABLE
    1:  removed `/var/lib/datasync/mobility/attachments/932/50ad880f379011e3ba72000c29fa7cc3'
    2:  removed `/var/lib/datasync/mobility/attachments/50ad8813379011e3ba72000c29fa7cc3'
    DELETE 1
    DELETE 1

    Files removed: 2
    db references removed: DELETE 1

    See /tmp/dsapp-attachment.log for log information.

  5. The above signifies, for example, that 2 attachments were removed from the local filestore (/var/lib/datasync/mobility/attachments directory) and that only 1 of those files had database references. It is not vital for these files to have database references removed, as perhaps the files are orphaned. 

    See /tmp/dsapp-attachment.log for further details.

Cause

Attachments not being cleaned up automatically with Nightly Maintenance.