Environment
Novell Data Synchronizer Connector for GroupWise
Situation
Can't start GroupWise connector
GroupWise connector Status shows Stopped
Starting the GroupWise connector from WebAdmin displays the following error:
An error has occurred starting the connector.
Error: Please verify that the Connector Manager is running and that the connectors.xml is correctly configured.
Solution A - /var/log/datasync/connectors/default.pipeline1.groupwise-AppInterface.log has the following errors:
GroupWise connector Status shows Stopped
Starting the GroupWise connector from WebAdmin displays the following error:
An error has occurred starting the connector.
Error: Please verify that the Connector Manager is running and that the connectors.xml is correctly configured.
Solution A - /var/log/datasync/connectors/default.pipeline1.groupwise-AppInterface.log has the following errors:
- Failure parsing soap response. Response string: None; Exception: <urlopen error [Errno 111] Connection refused>
- Failure Initializing: <urlopen error [Errno 111] Connection refused>
- URLError: <urlopen error [Errno 111] Connection refused>
Solution B - /var/log/datasync/connectors/default.pipeline1.groupwise-AppInterface.log has the following errors:
- Failure Initializing: Problem with GroupWise POA or Trusted App Name or Key: 53364
- Exception: Problem with GroupWise POA or Trusted App Name or Key: 53364
Resolution
Solution A - From ConsoleOne, enable SOAP on the Post Office Agent (POA):
- Open the Properties of the POA
- GroupWise | Agent Settings | Enable SOAP
- GroupWise | Network Address | Internal SOAP Port
- Select OK
- Restart POA:
rcgrpwise restart <nameOfPOA>.<nameOfMTA>
(ex: rcgrpwise restart PO.DOM)
Solution B - Properly define and configure the Trusted Application and Key:
- See GroupWise System Operations - Trusted Applications
- WebAdmin - GroupWise Connector Settings | GroupWise Trusted Application Key
Cause
SOAP is not enabled on the specified GroupWise POA, the specified SOAP URL address is incorrect, or the POA is otherwise not listening via SOAP due to other agent conflicts. Alternatively, the Trusted Application Key is incorrect.
Additional Information
Troubleshooting Steps:
- Determine the specified SOAP address:
- From WebAdmin:
GroupWise Connector Settings | GroupWise POA SOAP URL - From Terminal:
grep soap /etc/datasync/configengine/engines/default/pipelines/pipeline1/connectors/groupwise/connector.xml - For example, 151.155.215.91 is the ipAddress, 7191 is the defined SOAP port:
<soapServer>http://151.155.215.91:7191/soap</soapServer> - From the DataSync Mobility server, for example: telnet <poaServerIP> :<soapPort>
Trying <poaServerIP>...
telnet: connect to address <poaServerIP>: Connection refused - On the GroupWise POA server:
- From a terminal window: netstat -peanut | grep :<soapPort>
- If nothing shows, the POA is not listening on the specified SOAP port.
- If the POA is listening on SOAP from step 3, verify there is no firewall/network configuration blocking communication.
See TID 7009520 for a list of commonly used ports.