Unable to save files to Novell server after installing Novell Client 2 SP2 for Windows (IR4)

  • 7010659
  • 21-Aug-2012
  • 22-Aug-2012

Environment

Novell Client 2 SP2 for Windows 7 (IR4)
Novell Client 2 SP2 for Windows Server 2008 (IR4)
Novell Client 2 SP2 for Windows Server 2008 R2 (IR4)
Novell Client 2 SP2 for Windows Vista (IR4)

Situation

When saving files to an NSS volume, an error is returned, and the file save operation fails. The specific error message or failure condition depends on the application being used at the time. Specific applications reported include:

1. Microsoft Office 2003, including Word and Excel:
Error: The save failed due to out of memory or disk space. (<filename>)

2. Adobe InDesign CS6:
Error: The file <filename> is damaged (Error code: 0)

3. Adobe Acrobat:
Refuses to print a .pdf file.

4. Intuit QuickBooks Accountant 2010:
Error: QuickBooks is unable to backup the company file
when selecting "Save Copy or Backup" from the "File" menu.  (Note: Accessing company files directly on a Novell path fails. See KB 7010102.)

5. CCH ProSystem fx Suite:
The system will "freeze," apparently when creating a .pdf and launching Adobe Acrobat.

Resolution

Apply Novell Client 2 SP2 for Windows (IR4a). This build includes an updated NCPFSP.SYS which resolves the problem.

Cause

The problem was introduced with a fix included in the IR4 client release. When an application executes the "FlushBuffersFile" operation, the error STATUS_NOT_SUPPORTED is returned, and the operation fails..