Environment
Novell ZENworks Configuration Management 11
Situation
Attempting to deploy a ZCM Agent to a discovered device via a deployment task that had its DNS/IP changed, resulted in an error message "Target not Available."
Resolution
This is fixed in version 11.1 - see KB 7008746 "ZENworks Configuration Management 11.1 - update information and list of fixes" which can be found at https://www.novell.com/support
Cause
The DNS name was always used first for deployment. This caused problems in case of discovered devices were deployed after a period a time in which the IP/DNS had been changed. Also, only the DNS name was sent to the proxy. This failed in cases where the proxy was not able to resolve the dns name.