Environment
Novell ZENworks Configuration Management 11.2
Situation
WARNING (in ZCC console):
ChildActionError
with message, for example:
Action [guid] of the child bundle "Adobe APSB12-13 Shockwave Player 11.6.5.635 for Wi-)528435225" failed.
ERROR (in zmd-messages.log):
[DEBUG] [05/29/2012 07:38:16.171] [1700] [ZenworksWindowsService] [12] [] [BundleManager] [] [Error Processing Bundle Action for bundle: Adobe APSB12-13 Shockwave Player 11.6.5.635 for Windows (Update) (All Languages)528435225] [] []
[DEBUG] [05/29/2012 07:38:16.171] [1700] [ZenworksWindowsService] [12] [] [BundleManager] [] [Error is: Failed to launch C:\Program Files (x86)\Novell\ZENworks/zpm/Remediate.exe. Exit code: 40] [] []
[DEBUG] [05/29/2012 07:38:16.171] [1700] [ZenworksWindowsService] [12] [] [BundleManager] [] [Error is: Failed to launch C:\Program Files (x86)\Novell\ZENworks/zpm/Remediate.exe. Exit code: 40] [] []
[DEBUG] [05/29/2012 07:46:40.262] [1700] [ZenworksWindowsService] [12] [] [BundleManager] [] [Error Processing Bundle Action for bundle: MS12-034 2681578 2676562 Security Update for Windows 7 and Windows Server 2008 R2 (All Languages)-1835207171] [] []
[DEBUG] [05/29/2012 07:46:40.272] [1700] [ZenworksWindowsService] [12] [] [BundleManager] [] [Error is: Failed to launch C:\Program Files (x86)\Novell\ZENworks/zpm/Remediate.exe. Exit code: 40] [] []
[DEBUG] [05/29/2012 07:46:40.272] [1700] [ZenworksWindowsService] [12] [] [BundleManager] [] [Error is: Failed to launch C:\Program Files (x86)\Novell\ZENworks/zpm/Remediate.exe. Exit code: 40] [] []
[DEBUG] [05/29/2012 07:54:58.923] [1700] [ZenworksWindowsService] [12] [] [BundleManager] [] [Error Processing Bundle Action for bundle: Apple QuickTime 7.7.2 Player for Windows (Update) (All Languages) (See Notes)413427848] [] []
[DEBUG] [05/29/2012 07:54:58.924] [1700] [ZenworksWindowsService] [12] [] [BundleManager] [] [Error is: Failed to launch C:\Program Files (x86)\Novell\ZENworks/zpm/Remediate.exe. Exit code: 40] [] []
[DEBUG] [05/29/2012 07:54:58.924] [1700] [ZenworksWindowsService] [12] [] [BundleManager] [] [Error is: Failed to launch C:\Program Files (x86)\Novell\ZENworks/zpm/Remediate.exe. Exit code: 40] [] []
Resolution
This is fixed in version 11.2.1 - see KB 7010042 "ZENworks Configuration Management 11.21 - update information and list of fixes" which can be found at https://support.microfocus.com/kb/doc.php?id=7010042 This fix is for the second scenario below.
If this results in a bundle ERROR (red in ZCC), see standard troubleshooting below.
For some specific patches, however, it has been reported to Engineering that they fail consistently despite valid checksums. This results in a bundle WARNING (yellow in ZCC):
In the latter case, it is due to a patch that may apply to more than one operating system. For example:
Adobe APSB12-13 Shockwave Player 11.6.5.635 for Windows (Update) (All
Languages)528435225
Languages)528435225
Adobe APSB12-13 Shockwave Player 11.6.5.635 for Windows (Update) (All
Languages)-621925734
Languages)-621925734
In this case, one of the actions will result in trying to confirm a checksum of a plp file that doesn't exist and need not exist on this platform. In these cases the result is a warning on the bundle, not an error, and the patch does apply.
Cause
Typically this error indicates that a local plp file has a bad checksum or is corrupt for some reason. In most cases, re-caching the patch, giving time for the content to synchronize to content servers and redeploying should resolve as the file is pushed out again.