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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As 
a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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Welcome to the 
HP QuickTest Professional
Installation Guide 

This chapter includes:

➤ "HP QuickTest Professional Installation Guide Overview" on page 7

➤ "Documentation Library Contents" on page 8

➤ "Additional Online Resources" on page 11

HP QuickTest Professional Installation Guide Overview

Welcome to the HP QuickTest Professional Installation Guide. 

This guide describes how to install and set up QuickTest Professional on a 
standalone computer.

Prerequisite Background

This guide is intended for users who need to install and set up 
QuickTest Professional.

Readers of this guide should have some knowledge of system 
administration.
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Documentation Library Contents

This guide is part of the QuickTest Professional Documentation Library. The 
Documentation Library provides a single point of access for all 
QuickTest Professional documentation.

You can access the Documentation Library by using the following:

➤ Select Help > QuickTest Professional Help.

➤ In the Start menu, select Program Files > HP QuickTest Professional > 
Documentation > HP QuickTest Professional Help.

➤ Click in selected QuickTest windows and dialog boxes or press F1.

➤ View a description, syntax, and examples for a QuickTest test object, 
method, or property by placing the cursor on it and pressing F1.

The Documentation Library includes the following:

Type Included Documentation

Getting Started 
Documentation

➤ Readme provides the latest news and information about 
QuickTest. Select Start > Programs > HP QuickTest 
Professional > Readme.

➤ HP QuickTest Professional Installation Guide explains how 
to install and set up QuickTest. Select Help > 
QuickTest Professional Help and click the link to the 
Installation Guide from the Documentation Library Home 
page.

➤ HP QuickTest Professional Tutorial teaches you basic 
QuickTest skills and shows you how to design tests for your 
applications. Select Help > QuickTest Professional Tutorial.

➤ Product Feature Movies provide an overview and step-by-
step instructions describing how to use selected QuickTest 
features. Select Help > Product Feature Movies.

➤ What’s New provides an overview of the features, 
enhancements and supported environments that are new in 
the current version of QuickTest. Choose Help > What’s 
New.
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Feature 
Documentation

QuickTest Professional Help includes:

➤ Home provides links to the Documentation Library guides 
in each available format (Help, PDF, and/or HTML).

➤ What’s New in QuickTest Professional describes the newest 
features, enhancements, and supported environments in 
the latest version of QuickTest.

➤ HP QuickTest Professional User Guide describes how to use 
QuickTest to test your application.

➤ HP QuickTest Professional for Business Process Testing User 
Guide provides step-by-step instructions for using QuickTest 
to create and manage assets for use with Business Process 
Testing.

➤ HP QuickTest Professional Add-ins Guide describes how to 
work with supported environments using QuickTest 
add-ins, and provides environment-specific information for 
each add-in.

➤ HP QuickTest Professional Object Model Reference 
describes QuickTest test objects, lists the methods and 
properties associated with each object, and provides syntax 
information and examples for each method and property.

Type Included Documentation
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Reference 
Documentation

➤ HP QuickTest Professional Advanced References contains 
documentation for the following QuickTest COM and XML 
references:

➤ HP QuickTest Professional Automation Object Model 
provides syntax, descriptive information, and examples 
for the automation objects, methods, and properties. It 
also contains a detailed overview to help you get started 
writing QuickTest automation scripts. The automation 
object model assists you in automating test management, 
by providing objects, methods and properties that enable 
you to control virtually every QuickTest feature and 
capability.

➤ HP QuickTest Professional Run Results Schema 
documents the run results XML schema, which provides 
the information you need to customize your run results.

➤ HP QuickTest Professional Test Object Schema 
documents the test object XML schema, which provides 
the information you need to extend test object support 
in different environments.

➤ HP QuickTest Professional Object Repository Schema 
documents the object repository XML schema, which 
provides the information you need to edit an object 
repository file that was exported to XML.

➤ HP QuickTest Professional Object Repository Automation 
documents the Object Repository automation object 
model, which provides the information you need to 
manipulate QuickTest object repositories and their 
contents from outside of QuickTest.

➤ VBScript Reference contains Microsoft VBScript 
documentation, including VBScript, Script Runtime, and 
Windows Script Host.

Type Included Documentation
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Additional Online Resources

Sample applications. The following sample applications are the basis for 
many examples in this guide:

➤ Mercury Tours sample Web site. The URL for this Web site is 
newtours.demoaut.com. 

➤ Mercury Flight application. To access from the Start menu, select Program 
Files > HP QuickTest Professional > Sample Applications > Flight. 

Troubleshooting & Knowledge Base accesses the Troubleshooting page on 
the HP Software Support Web site where you can search the Self-solve 
knowledge base. Choose Help > Troubleshooting & Knowledge Base. The 
URL for this Web site is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software Support accesses the HP Software Support Web site. This site 
enables you to browse the Self-solve knowledge base. You can also post to 
and search user discussion forums, submit support requests, download 
patches and updated documentation, and more. Choose Help > HP Software 
Support. The URL for this Web site is www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an HP Passport user 
and sign in. Many also require a support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

HP Software Web site accesses the HP Software Web site. This site provides 
you with the most up-to-date information on HP Software products. This 
includes new software releases, seminars and trade shows, customer support, 
and more. Choose Help > HP Software Web site. The URL for this Web site 
is www.hp.com/go/software.
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1
Before You Install

Welcome to HP QuickTest Professional, the advanced keyword-driven 
testing solution for functional test and regression test automation. 
QuickTest Professional is part of HP Quality Center. This guide describes 
everything you need to know to install QuickTest Professional on a 
standalone computer.

Note: Unless otherwise specified, references to Quality Center in this guide 
apply to all currently supported versions of Quality Center and HP ALM. 
Note that some features and options may not be supported in the specific 
edition of Quality Center or HP ALM that you are using.

For a list of the supported versions of Quality Center or HP ALM, see the 
HP QuickTest Professional Product Availability Matrix, available from the 
Documentation Library Home page or the root folder of the 
QuickTest Professional DVD.

For details on Quality Center or HP ALM editions, see the HP Quality Center 
User Guide or the HP Application Lifecycle Management User Guide. 

Before you install QuickTest Professional, confirm that your computer meets 
all system requirements. For details, see the HP QuickTest Professional 
Readme. For the most updated listing of supported system configurations, 
visit www.hp.com/go/QTP_SysReq. 
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You can upgrade to QuickTest Professional 11.00 only from QuickTest 
version 9.5 or later. If you are using a version earlier than QuickTest 9.5, you 
must first manually uninstall your current QuickTest version and the 
QuickTest Add-in for ALM/QC. For more information, see "Considerations 
When Upgrading from an Earlier Version of QuickTest" on page 15.

You must not run any other installation at the same time as you run the 
QuickTest Professional installation. In addition, you should ensure before 
you install QuickTest that your computer is not in a state that requires a 
restart. If this is the case, the installation will not run.

This chapter includes:

➤ Setting Required Access Permissions on page 14

➤ Considerations When Upgrading from an Earlier Version of QuickTest 
on page 15

Setting Required Access Permissions

You must make sure the following access permissions are set to install and 
run QuickTest Professional.

Permissions Required to Install QuickTest Professional

You must have administrator permissions on the computer on which you 
are installing QuickTest. You also need administrator rights for any other 
installation tasks, for example, uninstalling QuickTest, repairing or 
modifying the installation, or installing a patch. 

In some circumstances, the installation may require a system restart. If a 
computer restart is required, your administrator permissions must include 
the part of the installation that occurs after the restart.
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Permissions Required to Run QuickTest Professional

You must have the following file system permissions:

➤ Full read and write permissions for all the files and folders under the 
folder in which QuickTest is installed

➤ Full read and write permissions to the Temp folder

➤ Read permissions to the Windows folder and to the System folder

You must have the following registry key permissions:

➤ Full read and write permissions to all the keys under 
HKEY_CURRENT_USER\Software\Mercury Interactive

➤ Read and Query Value  permissions to all the HKEY_LOCAL_MACHINE 
and HKEY_CLASSES_ROOT keys

Permissions Required When Working with Quality Center

You must have the following permissions to use QuickTest with 
Quality Center:

➤ Full read and write permissions to the Quality Center cache folder

➤ Full read and write permissions to the QuickTest Add-in for ALM/QC 
installation folder

Considerations When Upgrading from an Earlier Version of 
QuickTest

➤ You can upgrade to QuickTest Professional 11.00 only from QuickTest 
version 9.5 or later. The previous version of QuickTest is automatically 
uninstalled.

➤ If you are upgrading to QuickTest Professional 11.00 from a version earlier 
than QuickTest 9.5, you must first manually uninstall your current 
QuickTest version and the QuickTest Add-in for ALM/QC. Otherwise, the 
installation process will not run. At the end of the uninstall process, 
restart your computer and install the new version and add-in. 
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Note: The Save and Restore Settings utility enables you to save existing 
customization settings and registry keys before you uninstall an old 
QuickTest version, and then restore them after you install the new 
version. For more information, see "Saving and Restoring Your QuickTest 
Settings" on page 113.

➤ QuickTest Professional supports the Sentinel RMS License Manager 
version 8.3.0 as its concurrent license server. If you are upgrading to 
QuickTest Professional with a concurrent license, you must also upgrade 
your concurrent license server. For details on setting up a concurrent 
license server, see the HP Functional Testing Concurrent License Server 
Installation Guide. 

➤ License data is retained when upgrading from QuickTest Professional 
version 9.5 or later. However, if you have not installed a license before the 
upgrade, you must run the QuickTest Professional License Wizard as part 
of the installation. For more information, see step 11 on page 30.

➤ All add-ins that were installed in version 9.5 are identified during the 
upgrade and checked by default in the feature selection page of the 
installation. You can add or remove add-ins during the installation.

➤ The layout of the main QuickTest user interface, such as the size and 
position of various panes, is retained. 

➤ All settings defined in Tools > Options are retained.

➤ Recent tests opened by QuickTest before the upgrade are displayed in the 
File menu.

➤ Connection settings to Quality Center are not retained by the upgrade 
process. If required, you must reconnect to Quality Center after the 
installation. To install the latest version of the ALM/QC Add-in, you must 
manually uninstall the previous version of the Add-in before installing 
the latest version.
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2
Setting Up QuickTest Professional

When you install QuickTest Professional, you must know which features 
and add-ins to you want to use. The installation process automatically 
installs QuickTest and the Web, Visual Basic, and ActiveX Add-ins, and also 
enables you to select which additional features and add-ins to install. For 
more information on add-ins, see the HP QuickTest Professional Add-ins 
Guide.

You must also know which type of license you want to install. A Seat license 
is a permanent license that is specific to the computer on which it is 
installed, and a Concurrent license is a per session license that is available 
only if your company has an HP Functional Testing Concurrent License 
Server. For more information, see "Understanding the QuickTest Professional 
Setup for Different License Types" on page 18.

Your QuickTest Professional license enables all QuickTest features, including 
the use of all QuickTest add-ins. You can use the latest released version of all 
QuickTest add-ins with QuickTest Professional. If upgrading from a previous 
version, only previously licensed add-ins will be available.

You can also set up QuickTest to install silently (in the background), and on 
remote computers. 

Note: When you open QuickTest Professional, a silent check for updates to 
the application is performed in the background. You can check online for 
updates to all HP products installed on your computer at any time by 
choosing Start > Programs > QuickTest Professional > HP Update. You can 
then choose which updates you want to download and (optionally) install. 
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This chapter includes:

➤ Understanding the QuickTest Professional Setup for Different License 
Types on page 18

➤ Considerations for Installing QuickTest Professional on page 21

➤ Installing QuickTest Professional on page 22

➤ Working with the Additional Installation Requirements Utility 
on page 35

➤ QuickTest Professional Setup Window Options on page 45

➤ Browsing the QuickTest Professional Program Folder on page 47

➤ Setting Up a Silent Installation on page 48

➤ QuickTest Professional User Interface Pack Installation on page 59

➤ Troubleshooting and Limitations - Installing QuickTest on page 61

Understanding the QuickTest Professional Setup for 
Different License Types

The general procedures for installing QuickTest Professional and activating a 
license differ for the various license types: Seat, and Concurrent. This 
section summarizes the procedures required for the different license types 
and directs you to the detailed information for each step.

Setting Up QuickTest Professional with a Seat License
This section summarizes the procedure for setting up QuickTest Professional 
with a seat license. A seat license is a permanent license that is specific to the 
computer on which it is installed. The seat license includes a 30-day demo 
period, during which you may use all of the available QuickTest features, 
including Unified Functional Testing. Before the demo period ends, you 
must contact HP to obtain a permanent seat license key. 
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Note: 

➤ If you want to run QuickTest using the demo license, do not run the 
License Installation wizard. The first time you open QuickTest, you are 
notified that the demo period started.

➤ Seat licenses are not available for operating systems that have session 
capabilities, for example, Windows servers or Citrix.

To set up QuickTest Professional with a seat license:

 1 After you install QuickTest Professional, the Additional Installation 
Requirements screen opens. Make sure that Run License Installation 
Wizard is selected, and click Run. 

 2 When the License Installation wizard opens to the License Type screen, 
select Seat. For more information, see step 13 of “Installing 
QuickTest Professional” on page 31.

 3 Run QuickTest Professional. Click Install License on the displayed 
warning message and request a seat license key from HP, as described in 
"Requesting a Seat License Key" on page 65.

 4 After you receive the license key from HP, run the license installation 
wizard again to install your license key. For more information, see 
"Installing a Seat License Key" on page 68.
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Setting Up QuickTest Professional with a Concurrent 
License
This section summarizes the procedure for setting up QuickTest Professional 
with a concurrent license. A concurrent license is a per session license that is 
available only if your company has an HP Functional Testing Concurrent 
License Server, your computer has access to that server, and a free 
concurrent license is available for your use. 

To set up QuickTest Professional with a concurrent license:

 1 Install the HP Functional Testing Concurrent License Server on a network 
computer and activate the HP Functional Testing Concurrent License 
Server license. For more information, see the HP Functional Testing 
Concurrent License Server Installation Guide. This guide is installed on the 
computer where the HP Functional Testing Concurrent License Server is 
installed, and is called MerLicSvr.pdf.

 2 Run the QuickTest Professional setup program on each client computer. 
In the License Type screen, select Concurrent License. For more 
information, see step 13 of “Installing QuickTest Professional” on 
page 31.

 3 Begin using QuickTest Professional. When QuickTest Professional opens, 
it automatically searches for the specified license server and connects to 
it.

Note: If your computer cannot find and connect to the license server, you 
may need to set the LSHOST or LSFORCEHOST variable. For more 
information, see the HP Functional Testing Concurrent License Server 
Installation Guide.
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Considerations for Installing QuickTest Professional

➤ If you are upgrading to QuickTest Professional from 
QuickTest Professional version 9.2 or earlier, you need to first uninstall 
your current QuickTest version and the QuickTest Add-in for ALM/QC. 
Otherwise, the installation process will not run. At the end of the 
uninstall process, restart your computer and install the new version and 
add-in. The Save and Restore Settings utility enables you to save existing 
customization settings and registry keys before you uninstall an old 
QuickTest version, and then restore them after you install the new 
version. For more information, see "Saving and Restoring Your QuickTest 
Settings" on page 113.

➤ If you are upgrading to QuickTest Professional from version 9.5 or later, 
the installation wizard automatically upgrades your previous version of 
QuickTest and installs QuickTest Professional. The upgrade retains your 
existing configuration settings and preferences, such as your Options 
settings and window layout, as well as all your tests. 

➤ QuickTest Professional supports the Sentinel RMS License Manager 
version 8.3.0 as its concurrent license server. If you are upgrading to 
QuickTest Professional with a concurrent license, you must also upgrade 
your concurrent license server. For details on setting up a concurrent 
license server, see the HP Functional Testing Concurrent License Server 
Installation Guide. 

➤ If you have Astra QuickTest and/or Astra LoadTest installed, you must 
uninstall them before installing QuickTest Professional. After you install 
QuickTest Professional, you can then reinstall your other HP products.

➤ If the HP QuickTest Professional Files in Use dialog box is displayed 
during the installation process:

➤ Close the applications listed in the dialog box and click Try Again.

➤ If the HP QuickTest Professional Files in Use dialog box is displayed 
again, click the Exit Installation button and restart your computer. 
After the restart is complete, do not open any applications. Run the 
QuickTest Professional Setup program again. 

➤ If after restarting, the HP QuickTest Professional Files in Use dialog box 
lists Explorer as the open application, click Continue. If prompted, 
restart your computer at the end of the installation.
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Installing QuickTest Professional

Your QuickTest Professional DVD includes an installation program that 
guides you through the installation process.

To install QuickTest Professional:

 1 Prerequisites: 

 a Make sure you are logged on with Administrator privileges.

 b Select a local drive on which to install QuickTest Professional. 
(Do not install QuickTest Professional on a network drive.)

 c Close any instances of QuickTest Professional. It is also recommended 
to close all other open applications.

 2 Insert the QuickTest Professional installation DVD into the DVD drive. 

➤ If the DVD drive is on your local computer, and Autoplay is enabled, 
the QuickTest Professional Setup window opens. If Autoplay is 
disabled on your computer, right-click the DVD drive and select 
Autoplay.

➤ If you are installing from a network drive, double-click setup.exe in 
the root folder of the DVD. 
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The Setup window opens. 

See "QuickTest Professional Setup Window Options" on page 45 for more 
information on the various options available in the 
QuickTest Professional setup window.

 3 Click QuickTest Professional Setup to start the QuickTest Professional 
Setup program. 
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 4 QuickTest requires specific software, for example, Microsoft Visual C++ 
Runtime components, to be installed before you install QuickTest. If 
Setup finds that the prerequisite software is not already installed on your 
computer, the following screen opens.

Tip: Select an item in the list to display a description of the program.

Click OK and follow the on-screen instructions to install the listed 
software before continuing with the QuickTest installation. If you click 
Cancel, Setup will stop because QuickTest cannot be installed without the 
prerequisite software. 

In some situations, you may be prompted to restart your computer after 
installing the prerequisite software. To continue with the installation after 
restarting your computer, run the Setup program again.
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Note: If you are upgrading from version 9.5 or later, a message is 
displayed informing you that a previous version of QuickTest exists on 
your computer and that the setup program will upgrade the previous 
version, saving all your settings and tests, before continuing with the 
installation. The upgrade process saves all your settings, including your 
QuickTest window layout and all your settings in the Options and 
Settings dialog boxes. In addition, it saves the files and settings that are 
listed in the section on Saved Files and Setting in "Saving and Restoring 
Your QuickTest Settings" on page 113. Click OK to continue.

 5 The Welcome to the HP QuickTest Professional Setup Wizard opens. Click 
Next to proceed.

 6 The License Agreement screen opens. Read the agreement.
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To install QuickTest Professional, you must accept the terms of the license 
agreement by selecting I Agree and clicking Next. 

 7 In the Customer Information screen, type your name and the name of 
your organization. 

Click Next to proceed. 
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 8 In the Custom Setup screen, select the QuickTest components and add-ins 
you want to install.

Note: Loading QuickTest add-ins enables QuickTest to work with the 
corresponding environments. You can install the add-ins you require 
when you install QuickTest Professional, or you can install them at a later 
time by running the installation again. When QuickTest opens, you can 
choose which of the installed add-ins you want to load using the 
QuickTest Professional Add-In Manager dialog box. For more information 
on the Add-in Manager, see the HP QuickTest Professional Add-ins Guide.
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You can select an item in the list to see a description of the feature as well 
as the space requirement for the feature on your drive. 

Click an icon to view a menu and select how that feature is installed on 
your computer. The following options are available, depending on the 
feature:

➤ Will be installed on local hard drive. Installs the selected feature on 
your local hard drive. Sub-features of the selected feature are not 
installed.

➤ Entire feature will be installed on local hard drive. Installs the entire 
selected feature and its sub-features on your local hard drive. For 
example, you can instruct QuickTest to install the .NET Add-in with its 
sub add-ins, Silverlight and Windows Presentation Foundation.

➤ Entire feature will be unavailable. Excludes the feature from the 
installation and it is not available in QuickTest.

Note: QuickTest Professional, its Core Components, and the Run Results 
Viewer option, cannot be deselected. 

Click Next. If you are upgrading from version 9.5 or later, the upgrade 
installation automatically installs QuickTest Professional in the same 
folder in which the previous version of QuickTest was installed. Proceed 
to step 10. 
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 9 In the Select Installation Folder screen, choose the location where you 
want to install QuickTest Professional.   

➤ To select a different location, click Browse, choose a folder, and then 
click OK. You must specify a folder on a mapped drive (not a UNC 
path). If the destination folder does not exist, the setup program 
creates it.

➤ To view the required and available space on each of your mapped 
drives, click Disk Cost. 

Ensure that you install QuickTest Professional on a drive with a 
sufficient amount of free disk space. For more information, see the 
system requirements, as described in the HP QuickTest Professional 
Readme.

Click Next to proceed.

 10 The Confirm Installation screen opens. Click Next to proceed, and the 
installation process begins. The Installing HP QuickTest Professional 
screen displays the progress of the installation. 
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 11 When the installation is complete, click Finish. 

The Additional Installation Requirements screen opens. 

Note: After the QuickTest installation is complete, the HP Run Results 
Viewer installation is performed in the background. Therefore, it make 
take some time before the Additional Installation Requirements screen 
opens.

In addition to options to configure Internet Explorer and DCOM settings, 
and to run the License Wizard, the Additional Installation Requirements 
screen displays any prerequisite software that must be installed or 
configured to work with QuickTest, according to the options selected 
during installation.
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Select the required installation options. For more information on these 
options, see "Working with the Additional Installation Requirements 
Utility" on page 35.

Tip: Select an option name to display a description of the feature.

 12 Click Run in the Additional Installation Requirements screen to install or 
configure your selections. 

 13 If you selected to run the License Installation Wizard, the 
QuickTest Professional License Installation - License Type screen opens. 
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Select a license type. (For information on the process required to set up 
various license types, see "Understanding the QuickTest Professional 
Setup for Different License Types" on page 18. For information on 
working with licenses, see "Working with QuickTest Professional Licenses" 
on page 63.)

➤ Seat license. Uses a license created for this computer.

A seat license is a permanent license that is specific to the computer on 
which it is installed. When you select this option, you also get a 30-
day demo period during which you must request a permanent seat 
license key from the HP Webware License Key Delivery Service. After 
you receive the seat license key, you can activate it to work with 
QuickTest Professional permanently. For more information, see 
"Requesting a Seat License Key" on page 65.

If you select Seat license, proceed to step 14 on page 33.

➤ Concurrent license. Uses a network-based license.

A license server on the network regulates the number of concurrent 
QuickTest Professional users. You can work with a concurrent license 
only if a concurrent license server is installed on your local network, 
and that license server has at least one available license that is not 
currently in use.

Click Next to open the License Installation - Concurrent License Server 
dialog box and, if you know the name of the concurrent license server 
to which you want to connect, you can specify it in the text box. You 
can click Check Connection to verify that the license server is 
accessible from your network. 

If you select this option but do not specify a concurrent license server, 
QuickTest will try to locate one for you when you open QuickTest.

For more information, see the HP Functional Testing Concurrent License 
Server Installation Guide.
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 14 If you chose to install QuickTest with a seat license, the 
QuickTest Professional License Installation - Welcome screen opens. 

If you have a seat license key, proceed to step 3 on page 72 to install the 
seat license key. 

If you do not have a license key, make a record of the displayed locking 
code for your computer. You will need it to request your license key. Click 
the link on the QuickTest Professional License Installation - Welcome 
screen for the HP Webware License Key Delivery Service to request your 
license key. Follow the instructions as described in "Requesting a License 
Key via the HP Webware License Key Delivery Service" on page 67 and 
then click Cancel. (You will be prompted to install the seat license when 
you open QuickTest.)

 15 The installation continues with installing the options you selected in the 
Additional Installation Requirements screen. When these options are 
installed and configured on your computer, the screen reopens. 
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A checkmark is displayed next to the options that were successfully 
installed or configured.

Tip: You can run the Additional Installation Requirements utility at any 
time by choosing Start > Programs > QuickTest Professional > Tools > 
Additional Installation Requirements. 

 16 Click Show Readme if you want the HP QuickTest Professional Readme to 
open at the end of the installation. 

 17 Click Close. The Installation Complete screen opens.

 18 Click Finish. 
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Note: In some situations, you may be prompted to restart your computer 
after you have installed QuickTest. It is recommended that you restart your 
computer as soon as possible if you are prompted to do so. Delaying the 
system restart may result in unexpected QuickTest behavior.

Working with the Additional Installation Requirements 
Utility

Several prerequisites for working with QuickTest must be installed and 
configured after QuickTest is installed. In addition, to take advantage of 
QuickTest Professional debugging and remote access features, certain 
Internet Explorer and DCOM settings need to be configured. 

The Additional Installation Requirements screen displays any prerequisite 
software that must be installed or configured to work with QuickTest, 
according to the options selected when QuickTest is installed or the 
installation is modified. For more information, see "Additional Installation 
Prerequisites" on page 36.

The Additional Installation Requirements utility enables you to configure 
the required settings automatically, and to run the License Installation 
Wizard and Microsoft Debugger installation during the QuickTest 
installation. 

➤ Select an option name in the Additional Installation Requirements dialog 
box to display a description of the feature. 

➤ Select the check box of one or more required options and click Run.

You can run the Additional Installation Requirements utility at any time by 
choosing Start > Programs > HP QuickTest Professional > Tools > Additional 
Installation Requirements. In addition to the options to configure Internet 
Explorer and DCOM settings, and to run the License Wizard, the dialog box 
displays any prerequisite software that is still required to be installed to work 
with QuickTest. 
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Additional Installation Prerequisites

Additional installation requirements listed in the Additional Installation 
Requirements dialog box can include the following, according to the 
options selected when QuickTest is installed or the installation is modified:

➤ Microsoft Visual C++ 2008 Redistributable. Displayed only when the 
Stingray Add-in is installed. 

➤ Microsoft WSE 3.0 Runtime. Provides a foundation for running 
applications based on published Web services specifications. This item is 
displayed only when not currently installed, and when the Web Services 
Add-in is installed.

➤ Microsoft SOAP Toolkit 3.0. Provides Web Services capabilities for COM 
components and applications. This item is displayed only when not 
currently installed, and when the Web Services Add-in is installed.

➤ Microsoft Script Debugger. Provides the debugging environment that 
QuickTest uses during test runs. This item is displayed only when not 
currently installed.

➤ Terminal Emulator Wizard. Provides a wizard that enables you to 
configure terminal emulator identifying settings. This item is displayed 
only when the Terminal Emulator (TE) Add-in is installed.

➤ Stingray Wizard. Provides a wizard that enables you configure QuickTest 
to work with your Stingray application. This item is displayed only when 
the Stingray Add-in is installed.

In addition, the Additional Installation Requirements utility enables you to 
perform the following:

➤ Configure Internet Explorer settings. Select this check box to 
automatically configure the Internet Explorer options that enable 
QuickTest to use the Microsoft Script Debugger application during test 
runs. 

You can configure these options manually before running QuickTest. In 
Internet Explorer, select Tools > Internet Options > Advanced. Then select 
Disable script debugging and Enable third-party browser extensions.
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➤ Configure DCOM settings. Select this check box to automatically change 
DCOM permissions and security settings and open a firewall port on your 
QuickTest computer. 

These changes are only required if you want to run QuickTest tests 
remotely from Quality Center, and are running QuickTest on 
Windows XP Service Pack 2 or later, Windows 2003 Server, Windows 
Vista, or Windows 7.

For more information about the changes that QuickTest makes when you 
choose to set these options automatically, see the steps described in 
"Modifying DCOM Permissions Manually to Enable Remote QuickTest 
Execution" on page 38.  

If you choose not to automatically set remote execution options during 
the QuickTest installation, you can, before attempting to remotely run 
QuickTest tests from Quality Center:

➤ Run the Additional Installation Requirements utility at a later time 
from Start > Programs > HP QuickTest Professional > Tools > 
Additional Installation Requirements.

➤ Make the required changes manually. For more information on 
making these changes manually, see "Modifying DCOM Permissions 
Manually to Enable Remote QuickTest Execution" on page 38.  

➤ Make the required changes automatically, by running the Remote 
Agent <QuickTest Professional installation>\bin\AQTRmtAgent.exe at 
a later time. 

Note: Contact Microsoft Support if you have questions regarding changes 
in DCOM securities on Windows XP Service Pack 2 or later, 
Windows 2003 Server, or Windows Vista. 

➤ Run License Installation Wizard. Select this check box to run the 
QuickTest Professional License Wizard. If you want to run QuickTest using 
the Unified Functional Testing demo license for up to 30 days, do not 
select this check box. 
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Note: This option is not automatically selected when upgrading from 
QuickTest Professional version 9.5 or later because license data is retained. 
If you did not install a license before the upgrade, select this check box to 
run the QuickTest Professional License Wizard.

Modifying DCOM Permissions Manually to Enable Remote 
QuickTest Execution
This section describes how to manually change DCOM permissions and 
open firewall ports to enable remote execution of QuickTest. These changes 
are only required if you are running QuickTest on Windows XP Service 
Pack 2, Windows 2003 Server Service Pack 1 or later, Windows Vista, or 
Windows 7. 

If you chose to automatically make these changes during the QuickTest 
installation, you do not need to make these manual changes. If you do not 
intend to execute QuickTest tests remotely from Quality Center, you do not 
need to make these manual changes.

Note: The security changes described in this section should be performed by 
your System Administrator. Please contact Microsoft Support if you have 
questions regarding changes in DCOM securities on Windows XP Service 
Pack 2, Windows 2003 Server Service Pack 1 or later, or Windows Vista. 

Tip: The HP Support Knowledge Base provides utilities to assist you in 
making these changes. For more information, see the HP Software Self-solve 
knowledge base (http://h20230.www2.hp.com/selfsolve/document/KM196144) 
and search for Problem ID 43245. The Knowledge Base area requires that you 
register as an HP Passport user and sign in. 
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To manually enable remote execution of QuickTest, perform the following 
procedures:

➤ Enable Windows to authenticate the remote user (described on page 39)

➤ Configure the Windows Firewall to enable port 135 for DCOM (described 
on page 39)

➤ Modify DCOM security properties (described on page 40)

➤ Configure security settings for the QuickTest Remote Agent DCOM 
applications (described on page 42)

In addition, before remotely running a test you must also make sure that the 
Allow other HP products to run tests and components option is selected in 
the Run tab of the QuickTest Options dialog box. For more information, see 
the HP QuickTest Professional User Guide.

To enable Windows to authenticate the remote user:

 1 Add both computers to the same domain. 

 2 For domain users logged into both computers, add these domain users to 
the Local Administrators group on the QuickTest computer. This enables 
Windows to authenticate the remote user executing the tests against the 
DCOM objects.

To configure the Windows Firewall to enable port 135 for DCOM:

Note: If you disabled the firewall installed with Windows XP Service Pack 
2, Windows 2003 Server, or Windows Vista, you do not need to open port 
135 for DCOM, as described in this procedure. 

 1 On the QuickTest computer, select Start > Settings > Control Panel > 
Windows Firewall. The Windows Firewall dialog box opens.

 2 Select the Exceptions tab.

 3 Click Add Program. The Add a Program dialog box opens.
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 4 Select or browse to the Remote Agent (<QuickTest Professional 
installation>\bin\AQTRmtAgent.exe) and click OK.

Note: If you do not configure the Remote Agent as an exception as 
described above, a Windows Security Alert message will appear while 
running a test remotely. Click Unblock to solve this problem. The next 
time you remotely execute an automated test, the warning will not 
appear.

 5 Click OK to close the Windows Firewall dialog box.

Note: For more information, a list of port assignments for commonly-
used services can be found at: http://www.microsoft.com/resources/
documentation/Windows/2000/server/reskit/en-us/Default.asp?url=/
resources/documentation/windows/2000/server/reskit/en-us/cnet/
cnfc_por_SIMW.asp.

To modify DCOM security properties:

 1 Select Start > Run, type dcomcnfg, and press ENTER. The Component 
Services window opens.

 2 Navigate to Console Root > Component Services > Computers > 
My Computer.

Note: If a Windows Security Alert message opens, click Ask me later or 
Unblock.

 3 Right-click My Computer and select Properties.
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 4 Select the Default Properties tab.

 5 Make sure the Default Impersonation Level is Identify and click Apply.

 6 Select the COM Security tab.

 7 In the Access Permissions area, click Edit Limits. The Access Permission 
dialog box opens.

 8 Click Add. The Select Users or Groups dialog box opens.

 9 Click Advanced.

 10 Click Locations. In the displayed dialog box, select your computer name 
and click OK.

 11 Click Find Now.

 12 Select the following users and groups from the local computer and click 
OK:

➤ Administrator

➤ Administrators

➤ Authenticated Users

➤ Anonymous Logon

➤ Everyone

➤ Interactive

➤ Network

➤ System

 13 Add the following users from the domain and click OK:

➤ <domain user logged into the QuickTest computer>

➤ <domain user logged into the Quality Center computer that is 
performing the remote execution>

 14 In the Access Permission dialog box, assign Local Access and Remote 
Access permissions to the groups and users in the list and click OK.

 15 In the Launch and Activation Permissions area, click Edit Limits. The 
Launch Permission dialog box opens.
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 16 Repeat steps 8 to 13.

 17 In the Access Permission dialog box, assign Local Launch, Remote Launch, 
Local Activation, and Remote Activation permissions to the groups and 
users in the list and click OK.

To configure security settings for the QuickTest Remote Agent DCOM 
applications:

 1 In the Component Services window, navigate to Console Root > 
Component Services > Computers > My Computer > DCOM Config.

 2 Right-click the AQTRmtAgent item and select Properties. The 
AQTRmtAgent Properties dialog box opens.

 3 In the Identity tab, select The interactive user. This enables the DCOM 
application to authenticate the process against the logged-in Windows 
user and run the process in that security context.

 4 Select the Security tab.

 5 In the Launch and Activation Permissions area, select Customize and click 
Edit. The Launch Permission dialog box opens.

 6 Click Add. The Select Users or Groups dialog box opens.

 7 Click Advanced.

 8 Click Locations. In the displayed dialog box, select your computer name 
and click OK.

 9 Click Find Now.
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 10 Select the following users and groups from the local computer and click 
OK:

➤ Administrator

➤ Administrators

➤ Authenticated Users

➤ Anonymous Logon

➤ Everyone

➤ Interactive

➤ Network

➤ System

 11 Add the following users from the domain and click OK:

➤ <domain user logged into the QuickTest computer>

➤ <domain user logged into the Quality Center computer that is 
performing the remote execution>

 12 In the Launch Permission dialog box, for all the groups and users in the 
list, select Allow for all permissions and click OK.

 13 In the Access Permissions area, select Customize and click Edit. The Access 
Permission dialog box opens.

 14 Repeat steps 6 to 12.

 15 Click Apply to save the changes and click OK to close the dialog box.

 16 Close the Component Services window.

 17 You can now remotely execute a QuickTest test from Quality Center.

Note: Before remotely running a test, you must also make sure that the 
Allow other HP products to run tests and components option is selected in 
the Run tab of the QuickTest Options dialog box. For more information, see 
the HP QuickTest Professional User Guide.
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Modifying User Account Control Settings to Connect with 
Quality Center (Windows Vista, Windows 7, Windows 
Server 2008, and Windows Server 2008 R2)
If you are running QuickTest on Windows Vista, Windows 7, Server 2008, or 
Server 2008 R2, you must disable User Account Control (UAC) before the 
first time you connect with Quality Center. After you have connected with 
Quality Center for the first time, you can enable User Account Control 
(UAC) again if required.

This change is required only if you are running QuickTest on one of the 
operating systems listed above. If you do not intend to execute QuickTest 
tests remotely from Quality Center, you do not need to make these changes.

Note: The security changes described in this section should be performed by 
your System Administrator. Please contact Microsoft Support if you have 
questions regarding changes in User Account Control (UAC) on any of these 
operating systems.

To temporarily turn off the UAC option, do the following:

For Microsoft Windows Vista and Windows Server 2008:

 1 Log in as an administrator.

 2 From the Control Panel, select User Accounts > Change Security Settings, 
and clear the Use User Account Control (UAC) to help protect your 
computer check box. 

For Microsoft Windows 7 and Windows Server 2008 R2:

 1 Log in as an administrator.

 2 From the Control Panel, select User Accounts > User Accounts > Change 
User Account Settings. 

 3 In the User Account Control Settings window, move the slider to Never 
notify.
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QuickTest Professional Setup Window Options

The QuickTest Professional Setup window contains the following options: 

Option Description

QuickTest 
Professional Setup

 Starts the QuickTest Professional Setup program.

Installation Guide Opens a PDF copy of the HP QuickTest Professional Installation Guide, which is 
suitable for printing. To download Adobe, Reader click Download Adobe 
Reader.

Readme Opens the Readme file. 

QuickTest Add-in 
for ALM/QC

Enables features in the Quality Center client installed on your computer.

If you do not install the QuickTest Add-in for ALM/QC, you can perform only 
the following QuickTest operations in Quality Center:

➤ Running tests remotely.

➤ Configuring test execution parameters.

To perform any other operations on QuickTest assets in Quality Center, you 
must install the QuickTest Add-in for ALM/QC. For example, the add-in 
enables you to:

➤ View test and component scripts from Quality Center.

➤ View run results in the Run Results window from Quality Center.

➤ Create new tests and components from Quality Center.

➤ Perform other operations in Quality Center that involve QuickTest user 
interface elements.

For additional information on the QuickTest Add-in for ALM/QC, or to 
download the latest version of the add-in, see the QuickTest Professional 
Add-in screen in Quality Center (Help > Add-ins Page > More HP 
Quality Center Add-ins > QuickTest Professional Add-in).

Note: QuickTest Professional 11.00 supports integration with 
Quality Center 9.0 or later. For Business Process Testing, 
QuickTest Professional 11.00 supports integration only with 
Quality Center 10.00 or later. You can install the Add-in for ALM/QC with all 
currently supported versions of Quality Center. For a list of supported 
versions, see the HP QuickTest Professional Product Availability Matrix, available 
from the Documentation Library Home page or the root folder of the 
QuickTest Professional DVD.
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Included Utilities and Features
The utilities, features, and information that were available in the QuickTest 
Plus Toolkit in previous versions of QuickTest have been incorporated into 
the main QuickTest Professional application. These include:

➤ Code and SDK samples, which can now be installed by selecting Samples 
in the Select Features screen during the QuickTest custom installation. For 
more information, see step 8 on page 27.

➤ Object repository merge functionality, which is now available in the 
QuickTest Object Repository Merge Tool. 

Add-in 
Extensibility and 
Web 2.0 Toolkits

Enables you to install the following:

➤ QuickTest Professional Java Add-in Extensibility SDK

➤ QuickTest Professional .NET Add-in Extensibility SDK

➤ QuickTest Professional WPF and Silverlight Add-in Extensibility SDK

➤ Extensibility Accelerator for Functional Testing (includes Web Add-in 
Extensibility SDK) 

➤ Web 2.0 Toolkit Support

Functional Testing 
License Server 
Setup

Enables you to install the HP Functional Testing Concurrent License Server 
or a concurrent license on the server. From the dialog box that opens you 
can also open a PDF copy of the HP Functional Testing Concurrent License 
Server Installation Guide.

Download Adobe 
Reader.

Downloads Adobe Reader.

Contact HP Opens the contact information page on the HP Web site (http://
welcome.hp.com/country/us/en/prodserv/software.html). Click Contact HP in 
the upper left corner.

Support Opens the HP Software Support Web site (http://www.hp.com/go/
hpsoftwaresupport).

Browse DVD Enables you to view the contents of the QuickTest Professional DVD.

Option Description
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➤ External Action Call Modification utility, which is now handled by the 
QuickTest Missing Resources pane. 

➤ The Register Browser Control utility. 

➤ The License Validation utility. 

For more information about these utilities and features, and answers to 
frequently asked questions, see the HP QuickTest Professional User Guide and 
the HP Software Self-solve knowledge base (http://www.hp.com/go/
hpsoftwaresupport), available by clicking Support on the 
QuickTest Professional Setup window.

Browsing the QuickTest Professional Program Folder

After the QuickTest Professional setup process is complete, a number of 
items are added to your QuickTest Professional program folder (Start > 
Programs > QuickTest Professional).

For a description of each of these items, see the HP QuickTest Professional User 
Guide.

Note: If you uninstalled a previous version of QuickTest Professional before 
installing this version, you may have additional (outdated) items in your 
QuickTest Professional program folder. In addition, if you have 
QuickTest Professional add-ins installed, you may have items in your 
program folder that relate specifically to these add-ins.
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Setting Up a Silent Installation

A silent installation (or quiet installation) is an installation that is performed 
in the background. You can install QuickTest Professional, QuickTest 
Add-ins, and the ALM/QC Add-in silently on your computer, without the 
need to navigate through setup screens or for user interaction. You can also 
install QuickTest Professional, QuickTest Add-ins, and the ALM/QC Add-in 
on remote computers.

For more information, see:

➤ "Before You Install QuickTest Silently" on page 48

➤ "Installing QuickTest Silently" on page 51

➤ "Installing the QuickTest Add-in for ALM/QC Silently" on page 55

Before You Install QuickTest Silently
You must have administrator privileges to install QuickTest Professional and 
the ALM/QC Add-in. (You also need administrator rights for any other 
installation tasks, for example, uninstalling QuickTest, repairing or 
modifying the installation, or installing a patch.)

The following sections list the prerequisite software that must be installed 
on your computer before running a silent installation of 
QuickTest Professional and QuickTest Add-ins.
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Prerequisite Software for QuickTest Professional and the 
QuickTest Add-ins

The following prerequisite software is required to be installed on your 
computer before you install QuickTest Professional and QuickTest Add-ins. 
This software is available on the QuickTest installation DVD, and can be 
installed from the command line.

Prerequisite Silent Command Line Syntax

Windows Installer 3.1 QuickTest\EN\prerequisites\msi31\WindowsInstaller-
KB893803-v2-x86.exe /quiet

Microsoft Data Access 
Components 2.8 SP1

QuickTest\EN\prerequisites\mdac28\mdac28.exe /Q

Microsoft Windows 
Script 5.6 for Windows XP 
and Windows 2000

QuickTest\EN\prerequisites\wscript_56_win2k\wscript_
56_win2k.exe /Q

Microsoft Visual C++ 2005 
SP1 Run-time 
Components

QuickTest\EN\prerequisites\vc2005_sp1_redist /Q

Microsoft .NET 
Framework 3.5 Service 
Pack 1

QuickTest\Common\dotnet35_sp1\dotnetfx35_sp1.exe 
/quiet

Visual Studio Tools for 
Office redistributable

QuickTest\Common\vstor30\vstor30.exe /q
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Prerequisite Software for ALM/QC 

The following prerequisite software is required to be installed on your 
computer before you install the ALM/QC Add-in. This software is available 
on the QuickTest installation DVD, and can be installed from the command 
line.

Caution: The prerequisite software must be installed locally, even if the 
silent installation is performed remotely. You can begin the silent 
installation only after all the required prerequisite software is installed.

Prerequisite Command Line Syntax

Windows Installer 3.1 QuickTest\EN\prerequisites\msi31\WindowsInstaller-
KB893803-v2-x86.exe /quiet

Microsoft Visual C++ 2005 
SP1 Run-time 
Components

QuickTest\EN\prerequisites\vc2005_sp1_redist /Q

Microsoft .NET Framework 
3.5 Service Pack 1

QuickTest\Common\dotnet35_sp1\dotnetfx35_sp1.exe 
/quiet

Visual Studio Tools for 
Office redistributable

QuickTest\Common\vstor30\vstor30.exe /q
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Installing QuickTest Silently
This section describes how to install the following QuickTest features 
silently on your computer:

➤ QuickTest Professional

➤ QuickTest Add-ins

➤ Additional Installation Requirements

If you want to install the QuickTest Professional Add-in for ALM/QC, see 
"Installing the QuickTest Add-in for ALM/QC Silently" on page 55.

Note: You can use most standard MSI command line options when 
installing QuickTest from the command line. For more information about 
performing a silent, or quiet, MSI installation, see the relevant Microsoft 
documentation.

Prerequisites

 1 It is recommended to save any open files and close all open applications 
before running the silent installation. 

 2 Install the prerequisite software for QuickTest Professional. For the full list 
of prerequisite software, see "Before You Install QuickTest Silently" on 
page 48. You can begin the silent installation only after all the required 
prerequisite software is installed.

Caution: The prerequisite software must be installed locally, even if the 
silent installation is performed remotely. You can begin the silent 
installation only after all the required prerequisite software is installed.
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Performing a standard installation of QuickTest, QuickTest Add-ins, 
and Additional Installation Requirements silently

In the command line, run the QTPSilentInstaller.bat file, which performs 
msiexec.exe commands to install QuickTest, using the following format:

<QTP_DVD_PATH>\QTPSilentInstaller 
ConcurrentLicenseServer [MsiProperties] [MsiFlags]

Note: If you do not specify an installation folder, QuickTest is installed in 
the default installation folder.

For a description of the silent installation commands, see "Silent installation 
commands" on page 57.

Upgrading QuickTest, QuickTest Add-ins, and Additional Installation 
Requirements silently

In the command line, run the QTPSilentInstaller.bat file with the 
ALLOW_UPGRADE MSI property, using the following format:

<QTP_DVD_PATH>\QTPSilentInstaller 
ConcurrentLicenseServer "ALLOW_UPGRADE=1" [MsiProperties] [MsiFlags]

Note: When you upgrade from version 9.5 or later, the upgrade process 
saves all your settings, including your QuickTest window layout and all your 
settings in the Options and Settings dialog boxes. In addition, it saves the 
files and settings that are listed in the section on Saved Files and Setting in 
"Saving and Restoring Your QuickTest Settings" on page 113. 

For a description of the silent installation commands, see "Silent installation 
commands" on page 57.
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Specifying which QuickTest features to install

You can use the ADDLOCAL MSI property in the silent installation 
command line to specify the QuickTest features and add-ins that you want 
to install. If you want to install only the QuickTest core components, you do 
not need to use this option.

If you use this command, the following mandatory options must be 
included:

➤ Core_Components (parent: QuickTest_Professional) 

➤ Test_Results_Viewer (parent: QuickTest_Professional) 

➤ Web_Add-in 

Note: Notes: When installing a feature using the ADDLOCAL property, its 
parent always gets installed as well.

In addition to the mandatory options, you can install the following 
QuickTest features and add-ins:

➤ .NET_Add-in 

➤ ActiveX_Add-in

➤ Java_Add-in

➤ Oracle_Add-in

➤ PeopleSoft_Add-in

➤ PowerBuilder_Add-in

➤ SAP_Solutions_Add-in 

➤ SAP_eCATT_integration (parent: SAP_Solutions_Add-in) 

➤ Samples (parent: QuickTest_Professional) 

➤ Siebel_Add-in 

➤ Stingray_Add-in 

➤ TE_Add-in
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➤ VisualAge_Add-in

➤ Visual_Basic_Add-in 

➤ Web_Services_Add-in

Examples of the QuickTest core silent installation

The following examples illustrate the different silent installation options, 
depending on whether upgrading or performing a complete installation.

Standard installation:

Upgrade:

Standard installation with the Java Add-in:

Additional installation requirements limitations

➤ The following additional installation prerequisites are not installed when 
using silent installation:

QTPSilentInstaller QtpLicServer "TARGETDIR=C:\Progra~1\QTP" 
/l*vx C:\Temp\QtpInstall.log 

QTPSilentInstaller QtpLicServer “ALLOW_UPGRADE=1” 
"TARGETDIR=<QTP_Folder>" 

QTPSilentInstaller QtpLicServer 
“ADDLOCAL=Core_Components,Test_Results_Viewer,Web_Add-in,Java_Add-in” 
"TARGETDIR=<QTP_Folder>"

Prerequisite Related Add-in

Terminal Emulator Wizard Terminal Emulator

Stingray Wizard Stingray

Microsoft WSE 3.0 Runtime Web Services

SOAP Toolkit Web Services
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You must manually install these prerequisites using Additional 
Installation Requirements Utility. For details on installing additional 
requirements, "Working with the Additional Installation Requirements 
Utility" on page 35.

➤ The QuickTest Add-in for ALM/QC is installed using a separate silent 
installation. For details, see "Installing the QuickTest Add-in for ALM/QC 
Silently" on page 55.

Installing the QuickTest Add-in for ALM/QC Silently
You can use the silent installation mechanism to install the QuickTest 
Add-in for ALM/QC. Unlike the QuickTest Professional core silent 
installation (described in "Installing QuickTest Silently" on page 51), you 
perform a silent installation of the ALM/QC Add-in by directly entering 
msiexec.exe commands in the command line.

Installing the QuickTest Add-in for ALM/QC silently

 1 It is recommended to save any open files and close all open applications 
before running the silent installation. 

 2 Run the appropriate Microsoft MSI installation from the command line, 
using one of the following formats:

➤ New installation (any previous versions have already been 
uninstalled):

msiexec /i "<QTP_DVD_Path>\QCPlugin\MSI\<QC_Plugin_File>" /qn

➤ Upgrade (from version 9.5 or later):

msiexec /qn /i "<QTP_DVD_Path\QCPlugin\MSI\<QC_Plugin_File>" 
ALLOW_UPGRADE=1 TARGETDIR=<QT4QCAddin_Folder>

For a description of the silent installation commands, see "Silent installation 
commands" on page 57.
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Examples of the QuickTest Add-in for ALM/QC silent installation

The following examples illustrate the different silent installation options, 
depending on whether upgrading or performing a complete installation:

Standard installation:

Upgrade:

msiexec /i "<QTP_DVD_Path\QCPlugin\MSI>
\QuickTest_Add-in_for_ALM-QC.msi" /qn 

Or:

msiexec /qn /i "<QTP_DVD_Path\QCPlugin\MSI>\
QuickTest_Add-in_for_ALM-QC.msi" 

msiexec /i "<QTP_DVD_Path\QCPlugin\MSI>
\QuickTest_Add-in_for_ALM-QC.msi" /qn ALLOW_UPGRADE=1 
TARGETDIR=<QT4QCAddin_Folder>

Or:

msiexec /qn /i "<QTP_DVD_Path\QCPlugin\MSI>\
QuickTest_Add-in_for_ALM-QC.msi" ALLOW_UPGRADE=1 
TARGETDIR=<QT4QCAddin_Folder>
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Silent installation commands
The following table lists commands, arguments, and options used for silent 
installation (in alphabetical order): 

Command / Argument Description

ADDLOCAL
(QuickTest core 
installation only)

Optional. Instructs the silent installation to 
install specific QuickTest features and add-ins. For 
more information and a list of available features, 
see "Specifying which QuickTest features to 
install" on page 53. 

Note: 

➤ If you do not use this argument, QuickTest is 
installed with the default add-ins. 

➤ You must include Test_Results_Viewer, 
Web_Add-in, and Core_Components in the 
ADDLOCAL command. 

➤ Values must be separated by commas and must 
not contain spaces.

ALLOW_UPGRADE (Upgrade only) Mandatory. Instructs the silent 
installation to perform an upgrade instead of a 
complete installation. 

ConcurrentLicenseServer Mandatory. The name or IP address of the license 
server to specify when installing QuickTest 
licenses.

MsiFlags Optional. Any MSI options, flags, and other 
instructions that are not included in the 
MsiProperties arguments, such as logging 
commands.

MsiProperties Optional. Any MSI properties or parameters, such 
as TARGETDIR. Each MSI property and its 
definition must be contained in quotes ("") and 
must not contain spaces.

QC_Plugin_File
(QuickTest Add-in for 
ALM/QC installation only)

Mandatory. The name of the MSI installation file.

Note: There is a different MSI file for each 
available language.
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For details on silent installation, see:

➤ "Installing QuickTest Silently" on page 51

➤ "Installing the QuickTest Add-in for ALM/QC Silently" on page 55

QT4QC_Folder 
(QuickTest Add-in for 
ALM/QC installation only)

(Upgrade only) Mandatory. The full path string 
(in quotes) of the folder in which the previous 
version of QuickTest Professional is currently 
installed.

QTP_DVD_Path The path to the QuickTest Installation DVD or 
network location. The QuickTest Professional .bat 
file is located on the installation DVD in the root 
folder.

QTP_Folder 
(QuickTest core 
installation only)

(Upgrade only) Mandatory. The full path string 
(in quotes) of the folder in which the previous 
version of QuickTest Professional is currently 
installed.

Caution: If you specify a folder other than the 
folder in which QuickTest Professional 9.5 is 
installed, the silent installation will perform a 
complete uninstallation of the previous version 
and install QuickTest Professional 11.00. All your 
settings will not be saved.

QTPSilentInstaller The name of the QuickTest silent installation .bat 
file.

Command / Argument Description
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QuickTest Professional User Interface Pack Installation

The QuickTest Professional User Interface Pack enables you to view the 
QuickTest, Run Results Viewer, and QuickTest Add-in for ALM/QC program 
user interface in your local language. You install the User Interface Pack 
from the <Language> User Interface Pack CD-ROM. 

The User Interface Pack installation also enables you to install a localized 
version of the Functional Testing Concurrent License Server.

This section includes:

➤ "Prerequisites for the QuickTest Professional User Interface Pack 
Installation" on page 59

➤ "Installing the QuickTest Professional User Interface Pack" on page 60

Prerequisites for the QuickTest Professional 
User Interface Pack Installation

➤ You must have QuickTest Professional installed before installing the 
User Interface Pack. For more information, see "Installing 
QuickTest Professional" on page 22. 

➤ If you are installing the QuickTest Add-in for ALM/QC 
User Interface Pack, you must also have the QuickTest Add-in for ALM/
QC installed. For installation information, see "QuickTest Professional 
Setup Window Options" on page 45.

Note: If you are installing the Functional Testing Concurrent License 
Server (<Language> Edition), you do not need to first install the English 
edition of the Functional Testing Concurrent License Server. 
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Installing the QuickTest Professional User Interface Pack
The following describes how to install a User Interface Pack for 
QuickTest Professional, Run Results Viewer, and QuickTest Add-in for ALM/
QC, and how to install the localized Functional Testing Concurrent License 
Server.

To install the User Interface Pack:

 1 Make sure that the prerequisites are met, as described in "Prerequisites for 
the QuickTest Professional User Interface Pack Installation" on page 59. 

 2 Insert the <Language> User Interface Pack CD into the CD-ROM drive. 
The QuickTest Professional <Language> User Interface Pack Setup 
window opens.

Note: If the CD-ROM drive is on a network computer, map the network 
drive, navigate to the root folder of the mapped network path, and 
double-click setup.exe.

 3 In the main QuickTest Professional <Language> User Interface Pack setup 
window, do one or more of the following:

➤ Click the QuickTest Professional User Interface Pack Setup link and 
follow the on-screen instructions.

The <Language> User Interface Pack is installed in the 
<QuickTest Professional installation> folder.

➤ Click the Run Results Viewer User Interface Pack Setup link and follow 
the on-screen instructions.

The <Language> User Interface Pack is installed in the <Run Results 
Viewer installation> folder. 

➤ Click the QuickTest Add-in for ALM/QC User Interface Pack Setup link 
and follow the on-screen instructions.

The <Language> User Interface Pack is installed in the <QuickTest 
Add-in for ALM/QC installation> folder.
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➤ Click the Functional Testing License Server Setup 
(<Language> Edition) link and follow the on-screen instructions. 

The Functional Testing License Server (<Language> Edition) is 
installed in <Functional Testing License Server installation folder>.

Troubleshooting and Limitations - Installing QuickTest

This section describes troubleshooting and limitations for installing 
QuickTest.

The security settings in Windows Vista, Windows 7, Server 2008, or 
Server 2008 R2, may prevent you from performing a QuickTest Professional-
related installation, such as a patch installation, or connecting to a 
Quality Center project (either directly or from QuickTest Professional). This 
can occur when the UAC (User Account Control) option is set to ON, and 
you have not yet connected to a Quality Center project (if relevant).  

Workaround: Temporarily turn off the UAC option, as described in 
"Modifying User Account Control Settings to Connect with Quality Center 
(Windows Vista, Windows 7, Windows Server 2008, and Windows 
Server 2008 R2)" on page 44.
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3
Working with QuickTest Professional 
Licenses

You can install QuickTest Professional using a seat license (formerly known 
as a local or standalone license) or a concurrent license (formerly known as a 
floating license). 

This chapter includes:

➤ Understanding QuickTest License Types on page 64

➤ Requesting a Seat License Key on page 65

➤ Installing a Seat License Key on page 68

➤ Working with a Concurrent License on page 75

➤ Modifying License Information on page 80

➤ Working with Commuter Licenses on page 82

➤ Validating QuickTest Licenses on page 95

➤ Troubleshooting Concurrent Licensing Issues on page 100
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Understanding QuickTest License Types

To use QuickTest Professional, you must have a valid license. There are two 
types of licenses: seat and concurrent. The table below summarizes the 
differences between the two license types.

Topic Seat License Concurrent License

General 
description

The license is specific to the 
computer on which it is 
installed. 

Each license entitles the 
organization to one 
additional concurrent user. 

Number of 
installations 
per license 
key

Each installation of 
QuickTest Professional requires a 
distinct license key.

There is no limit to the 
number of 
QuickTest Professional 
installations on the 
network, but a special 
concurrent license server 
regulates the number of 
computers that can run a 
copy of 
QuickTest Professional at 
any time.

Other issues The license key is based partially 
on the locking code, which is a 
code that identifies the computer 
on which QuickTest Professional 
is installed. The supplied license 
key works only for the computer 
on which the locking code was 
generated.

Note: A computer with multiple 
bootable partitions may generate 
a different locking code for each 
partition. If a different locking 
code is generated for a partition, 
you will need to request a unique 
license key for it.

Not supported for Unix 
networks.

It is recommended that the 
concurrent license server 
has a fixed IP address.

QuickTest Professional 
client computers must have 
TCP/IP installed.

To use concurrent licenses 
across networks, UDP port 
5093 must be open on the 
server.
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You can view and copy license information and license validation 
information, if needed. For example, you may want to retrieve license 
information for administrative or troubleshooting purposes. For more 
information, see "Validating QuickTest Licenses" on page 95.

Requesting a Seat License Key

When you install QuickTest Professional with a seat license for the first 
time, it includes a 30-day demo license. To use QuickTest Professional 
beyond the 30-day period, you must request and activate a license key for 
your copy of QuickTest Professional.

To request a seat license key:

 1 Perform one of the following:

➤ From the license warning message displayed when you start 
QuickTest Professional, click Install License.

➤ From within QuickTest Professional, select Help > About 
QuickTest Professional. The About QuickTest Professional dialog box 
opens. Click License. The License Summary dialog box opens. Click 
Modify License. 

Entering 
license key

At the end of the installation 
procedure, QuickTest asks you to 
enter the license key. If you do 
not have a license key at that 
point, QuickTest asks you to 
enter the key the first time you 
open QuickTest.

Each time QuickTest opens, 
it automatically searches the 
same subnet for the 
concurrent license server. 
You do not need to enter a 
license key for your 
QuickTest client 
installation.

Topic Seat License Concurrent License
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The License Type screen opens. Select Seat license and click Next. Click 
Yes to install a new license key. The Welcome screen opens.  

 2 Make a record of the displayed locking code for your computer. You will 
need it to request your license key. Click the link on the 
QuickTest Professional License Installation - Welcome screen for the HP 
Webware License Key Delivery Service to request your license key. Follow 
the instructions as described in "Requesting a License Key via the HP 
Webware License Key Delivery Service" on page 67.
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Requesting a License Key via the HP Webware License Key 
Delivery Service
The HP Webware License Key Delivery Service assists you in requesting a 
license key. This procedure provides an overview of this process as it 
specifically relates to requesting QuickTest Professional license keys. 

For details on the individual fields in the License Key Delivery Service form, 
download the ESD and Webware License Management Guide. (Click the 
Webware User Guide link in the Support section of the HP License Key 
Delivery Service Welcome page.)

To request a license key:

 1 Click the link on the QuickTest Professional License Installation - 
Welcome screen for the HP Webware License Key Delivery Service. The 
HP License Key Delivery Service Welcome page is displayed. 

 2 Click Generate New Licenses. The Generate license(s) page is displayed.

 3 Enter the order number from the Software Entitlement Certificate you 
received in your LTU or ELTU package. 

 4 Click Next. The Product Selection page is displayed. 

 5 Select the check box next to the product for which you are requesting a 
license key.

 6 Click Next. The Order Product Detail(s) page is displayed.

 7 Enter the locking code for your computer. The locking code is found in 
the QuickTest Professional License Installation - Welcome screen.

 8 Click Next. The Member sign-in page is displayed. 

 9 If you have used the Webware Licensing service before, enter your e-mail 
address and password. Otherwise, login as a new user.

 10 Click Sign-in. The Address information page is displayed. If you are a 
returning user, Webware automatically populates the fields with your 
information. If you are a new user, fill in the information according to the 
on-screen instruction. For information on filling in the Address 
information page, see the ESD and Webware License Management Guide. 
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 11 If you are a customer representative requesting a license key on behalf of a 
customer and do not want them to receive a copy of the transaction, 
deselect the E-mail a copy of this license transaction to the license owner 
check box. 

 12 If you are the end-user customer select the I am the License owner check 
box. The License owner (End-user) information section is disabled. 

 13 If you are a customer representative requesting a license key on behalf of a 
customer, deselect the I am the License owner check box. Complete the 
information requested in the License owner (End-User) information 
section.

 14 Click Next. The License/Password page is displayed. Keep a record of your 
Session ID and click Main Menu to return to the Welcome page. A 
Permanent Password Certificate will be e-mailed to the address you 
provided, containing your license key.

 15 Click Cancel and wait for your Permanent Password Certificate to arrive 
by e-mail. When it arrives, follow the instructions as described in 
"Installing a Seat License Key" on page 68.

Installing a Seat License Key

In the License Key screen, you enter the license key you received from HP. 
The license key is included in the .dat file attached to the e-mail containing 
your Permanent Password Certificate. 

Caution: 

➤ You must have Administrator privileges to install a license key.

➤ After installing the seat license key, do not change your computer's date 
or time. This triggers a Clock Tamper lock on the license information, 
preventing you from using the license.
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To install a seat license key:

 1 Perform one of the following:

➤ From the warning message displayed when you start 
QuickTest Professional, click Install License. 

➤ From within QuickTest Professional, select Help > About 
QuickTest Professional. In the About QuickTest Professional dialog 
box, click License. Then in the License Summary dialog box, click 
Modify License.

Note: You can also activate the seat license as part of the QuickTest 
installation. After you click Finish in the final installation screen, the 
QuickTest Professional License Installation - Welcome screen opens, as 
described below.
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The License Type screen opens.
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 2 Select Seat license and click Next. In the confirmation box, click Yes to 
install a new license key. The Welcome screen opens.  

Tip: Check that the locking code in the above screen matches the locking 
code you sent to HP when you requested a license key.
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 3 Click Next to begin installing the license. The License Key screen opens.

Notes:

➤ The license key is valid only for the computer with the locking code 
that you entered in the HP Software Support license request form. 

➤ A computer with multiple bootable partitions may generate a different 
locking code for each partition. If a different locking code is generated 
for a partition, you will need to request a unique license key for it.

 4 Open the .dat file attached to the email containing your Permanent 
Password Certificate using any text editor. The license key is also included 
in the Permanent Password Certificate.
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 5 Copy the license key (with or without the # character) from the .dat file 
to the clipboard.

 6 Paste the key into the QuickTest Professional License Installation - License 
Key screen by clicking the Paste From Clipboard button.

 7 Click Next. The Install Summary screen opens.
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 8 Verify that the information is correct and click Next. The Finish screen 
opens.

If you entered a valid license key, the Finish screen confirms that your 
license key was successfully installed. 

If the license could not be installed successfully, a message is displayed 
describing why. For example, if a seat license was previously installed on 
your computer, and you try to install a seat license again using the same 
license key, the license installation will not succeed. If the license could 
not be installed, a Send to Support button is displayed. You can click 
Send to Support to create an e-mail with licensing information and send 
it to your nearest HP Software Support location. Make sure that you fill in 
the required information in the e-mail so that Software Support can assist 
you.
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Tip: You can install another license by selecting the Install another license 
check box, clicking Finish and continuing with step 2 on page 71.

 9 If you do not want to install another QuickTest license, click Finish to 
complete the license activation process and close the wizard.

Working with a Concurrent License

If there is an accessible concurrent license server on your network with an 
available license, you can connect to it. This enables you to use a concurrent 
license instead of a seat license. For more information on working with 
concurrent license servers, and the supported versions, see the HP Functional 
Testing Concurrent License Server Installation Guide.

Note: You can also specify a concurrent license server during the QuickTest 
installation procedure. For more information, see "Installing 
QuickTest Professional" on page 22.

To work with a concurrent license:

 1 Perform one of the following:

➤ From the license warning message displayed when you start 
QuickTest Professional, click Install License.

➤ From the Start menu, select Start > Programs > 
HP QuickTest Professional > Tools > Additional Installation 
Requirements, and select Install License.

➤ From within QuickTest Professional, select Help > About 
QuickTest Professional. The About QuickTest Professional dialog box 
opens. Click License. The License Summary dialog box opens. Click 
Modify License.
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The License Type screen opens.
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 2 Select Concurrent license and click Next. The Concurrent License Server 
screen opens.  

 3 In the edit box, either enter the name or IP address of the concurrent 
license server to which you want to connect, or leave the box blank to 
instruct QuickTest to search for an available server on your local network. 

Tip: When you activate a concurrent license using the License Wizard and 
specify a single server name, the LSFORCEHOST user variable is 
automatically defined with the concurrent license server you specified. 
You can modify the concurrent license server either by running the 
License Wizard or by setting the LSHOST or LSFORCEHOST user variable. 
For more information, see the HP Functional Testing Concurrent License 
Server Installation Guide.
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 4 Click Check Connection. If QuickTest can connect to the concurrent 
license server, a success message is displayed.

Note: If the installation cannot connect to a concurrent license server, the 
Concurrent License Server screen informs you of this.
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Tip: If you want to specify the name of a concurrent license server that is 
currently unavailable, but will be available later, you can enter the name 
of the concurrent license server in the edit box. Even though the 
Concurrent License Server screen informs you that the specified server is 
not available for connection, the next time you open QuickTest, 
QuickTest will try to locate the server you specified.

 5 Click Next. The installation informs you that the concurrent license 
activation was successful.

 6 Click Finish to close the wizard. If QuickTest Professional is open, you 
must close and restart it to use the concurrent license server.
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Modifying License Information

After you install QuickTest Professional, you can modify your license key 
and/or change your license type at any time. For more information on 
requesting a new license key, see "Requesting a Seat License Key" on page 65.

Note: You must be logged in with administrator privileges to change the 
license type used by your QuickTest installation from seat to concurrent or 
vice versa.

To modify your license information:

 1 Open QuickTest Professional.

 2 Click Help > About QuickTest Professional. The About 
QuickTest Professional dialog box opens.

 3 Click License. The License Summary dialog box opens.  
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 4 Click Modify License. The License Type screen opens. 

➤ To change your license type from concurrent to seat, select Seat license 
and click Next. A confirmation box opens.

➤ If you already have a valid seat license key installed, click No to save 
your selected license type. 

➤ If you checked out a commuter license and want to use it now, 
click No.

➤ If you do not have a seat license key installed, click Yes. 

The Welcome screen opens. Follow steps 4 to 9 in Installing a Seat 
License Key.
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➤ To change your license type from seat to concurrent, select Concurrent 
license and click Next. Follow steps 2 to 6 in Working with a 
Concurrent License. 

Note: To work with a concurrent license, a concurrent license server 
must be installed on and accessible from the network, and a 
concurrent license must be available. For information on installing a 
concurrent license server, see the HP Functional Testing Concurrent 
License Server Installation Guide.

 5 Click Close to close the About QuickTest Professional dialog box.

 6 Restart QuickTest Professional to apply your changes.

Working with Commuter Licenses

If you use QuickTest with a concurrent license, but cannot connect your 
computer to your network (for example, during a business trip), you can 
install a commuter license. Commuter licenses are available in companies 
that have only concurrent licenses (not seat licenses). 

For example, suppose you need to travel on business with your laptop 
computer and you want to use QuickTest while you are away. You can check 
out a QuickTest license from the concurrent license server to use for the 
duration of your trip, and then check the license back in upon your return. 
Commuter licenses are valid for up to 180 days, according to your 
requirements. 

Tip: If you have a concurrent license and are located far from the concurrent 
license server, you can also use a commuter license if you encounter 
network traffic.

For more information, see "Checking Out a Commuter License" below, and 
"Checking In a Commuter License" on page 86.
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Note: Installing a commuter license requires administrator permissions for 
the computer on which you want to use the license.

In addition, if you are unable to check out a license before you disconnect 
from the network (that is, leave for your trip), or if you checked out a license 
but it expired because your return was delayed, you can ask a local network 
user to check out a commuter license and send it to you remotely. For more 
information, see "Obtaining a Commuter License Remotely" on page 87.

Note: If you have upgraded to HP Functional Testing Concurrent License 
from a version earlier than 7.6, you need to request a new server license key 
to enable the commuter licensing functionality. For details, contact 
HP Software Support or your local representative.
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Checking Out a Commuter License
Before you check out a commuter license, ensure that the computer (for 
example, a laptop) on which you want to install the commuter license has 
QuickTest installed, is connected to the network, and has access to a 
concurrent license server with an available QuickTest license. After you have 
checked out the license, you can disconnect the computer from the 
network.

To check out a commuter license:

 1 Run the WCommute.exe file located in <QuickTest installation 
folder>\bin. The WCommute dialog box opens.

 2 To see commuter licenses available on all concurrent license servers 
located within your subnet, click Search Subnet. If you want to specify a 
particular concurrent license server, or if you want to select a concurrent 
license server outside of your subnet, click Single Server.

➤ If you click Search Subnet, the WCommute utility searches the subnet 
for concurrent license servers that support commuter licensing and 
displays them in the WCommute dialog box. Note that this process 
may take several minutes.
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➤ If you click Single Server, a dialog box opens enabling you to specify 
the concurrent license server you want to locate. Enter the concurrent 
license server computer’s host name, IP address, or IPX address and 
click OK. The specified concurrent license server is located and 
displayed in the WCommute dialog box.

For each concurrent license server, a list of available commuter licenses is 
displayed. A red check mark next to a commuter license means that the 
license is already checked out to your computer. You cannot check out 
multiple licenses for the same application to the same computer. Click a 
license to view the license details in the right pane of the dialog box.

 3 Select the license that you want to check out.

 4 In the Enter number of days until the commuter authorization expires 
box, specify the maximum number of days to check out the license. The 
maximum number of days is 180. 

Note: 

➤ QuickTest Professional supports the Sentinel RMS License Manager 
version 8.3.0 as its concurrent license server. If you are upgrading to 
QuickTest Professional with a concurrent license, you must also 
upgrade your concurrent license server. 

➤ When you check out a license, it decreases the number of licenses 
available for use by others. Therefore, you should specify the absolute 
minimum number of days that you require. 

 5 Click Check Out. The selected license is saved locally on your computer. 

 6 To use the new checked-out license, open QuickTest and change your 
license type from concurrent to seat. In the confirmation message that 
opens after you change the license type, click No to use the commuter 
license. For more information, see "Modifying License Information" on 
page 80.
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Checking In a Commuter License
When you finish using the commuter license, you should check it in from 
your computer to the concurrent license server from which you checked it 
out. This makes the license available to other users.

Note: If your license expires, you do not need to check it in. When a license 
expires, you can no longer use it. The license is automatically returned to 
the concurrent license server, even if your computer is not connected to the 
concurrent license server network.

To check in a commuter license:

 1 Run the WCommute.exe file located in <QuickTest installation 
folder>\bin. The WCommute dialog box opens.

 2 Locate the concurrent license server for the commuter license you want to 
check in, as described in step 2 of “Checking Out a Commuter License” 
on page 84. You must check in the license to the same concurrent license 
server from which you checked it out.
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 3 Select the license you previously checked out. 

Tip: The checked-out license is indicated by a red check mark.

 4 Click Check In. The license is returned to the concurrent license server, 
and is made available for use by others. 

Note: Before you can use QuickTest again, you must change your license 
type from seat to concurrent. For more information, see "Modifying 
License Information" on page 80.

Obtaining a Commuter License Remotely
A local network user can locally check out a QuickTest commuter license 
and send it to you for installation on a remote computer. This is useful in 
situations in which you are currently not connected to the concurrent 
license server network. For example, you may be out of the office on an 
extended business trip, but need to be able to use QuickTest.

To obtain a commuter license remotely:

 1 Run the WRCommute utility to generate a commuter locking code for 
your computer and send the commuter locking code to a local user who 
has access to the concurrent license server. For more information, see 
"Step 1: Generating a Remote Computer Locking Code" on page 88.

 2 Ask the local user to run the WCommute utility (entering the commuter 
locking code you generated) to check out a remote commuter license, and 
send it to you. For more information, see "Step 2: Checking Out a 
Commuter License for a Remote Computer" on page 90.

 3 Run the WRCommute utility to install the remote commuter license on 
your computer. For more information, see "Step 3: Installing a Commuter 
License on a Remote Computer" on page 93.
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 4 Open QuickTest and change your license type from concurrent to seat. In 
the confirmation message that opens after you change the license type, 
click No to use the commuter license. For more information, see 
"Modifying License Information" on page 80.

Step 1: Generating a Remote Computer Locking Code

The first step in remotely obtaining a commuter license is to generate a 
locking code on your computer using the WRCommute utility, and transfer 
it (by e-mail) to a network user who has access to the concurrent license 
server.

Note: The remote computer locking code used to lock a commuter license is 
not the same as the locking code displayed by the ECHOID utility. You must 
use the WRCommute utility to obtain the commuter license locking code.

To generate a locking code on a remote computer:

 1 Run the WRCommute.exe file located in <QuickTest installation 
folder>\bin. The WRCommute dialog box opens.
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The Locking code string for the current machine box contains the locking 
code that you need to e-mail to a network user who has access to the 
concurrent license server containing the QuickTest licenses.

 2 Send the locking code to the local network user in one of the following 
ways:

➤ Select the locking code string and click the Copy to clipboard button 
to copy the string to your Windows clipboard. Then open your e-mail 
program and paste the string into a new e-mail message and e-mail it 
to the local network user.

➤ Click the Save lock code string to file button to save the locking code 
in a file. Specify the name and location for the file, and then attach the 
file to a new e-mail message and e-mail it to the local network user.

➤ Click the Display locking code string button to display the entire 
locking code in another dialog box. You can then select the locking 
code string, right-click it and select Copy to copy it to your Windows 
clipboard. Then open your e-mail program and paste the string into a 
new e-mail message and e-mail it to the local network user. 

➤ In the E-mail address box, enter the e-mail address of the local network 
user and click Send. Note that this option is supported only if 
Microsoft Outlook Express is set up as your e-mail client.
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Step 2: Checking Out a Commuter License for a Remote 
Computer

After a local network user receives the locking code, the user can check out 
the license and transfer it to you (by e-mail). To do this, the user must have 
QuickTest installed on his or her computer and also have access to the 
concurrent license server with an available QuickTest license. 

To check out a commuter license for a remote computer:

 1 Run the WCommute.exe file located in <QuickTest installation 
folder>\bin. The WCommute dialog box opens.

 2 Locate the concurrent license server from which you want to check out a 
remote commuter license, as described in step 2 of “Checking Out a 
Commuter License” on page 84.

For each concurrent license server, a list of commuter licenses that you 
can check out is displayed. 

 3 Select the license that you want to check out. 

 4 Select the Check out authorization for remote machine check box.
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 5 In the Enter the number of days until the authorization expires box, 
specify the number of days to check out the license. The maximum 
number of days is 180. 

Note: 

➤ QuickTest Professional supports the Sentinel RMS License Manager 
version 8.3.0 as its concurrent license server. If you are upgrading to 
QuickTest Professional with a concurrent license, you must also 
upgrade your concurrent license server. 

➤ When you check out a license for a remote computer, it cannot be 
checked in and remains in use (unavailable to other users) for the 
entire number of days specified. Therefore, you should specify the 
absolute minimum number of days required.

 6 Click Check Out. The Locking Code for Remote Machine dialog box 
opens.



Chapter 3 • Working with QuickTest Professional Licenses

92

 7 Enter the locking code that the remote user e-mailed you in one of the 
following ways:

➤ If the locking code was e-mailed to you in the body of an e-mail, copy 
it to your Windows clipboard. In the Locking Code for Remote 
Machine dialog box, select Enter the locking code string for remote 
machine and then click the Paste from clipboard button.

➤ If the locking code was e-mailed to you as an attached file, save the 
attachment and then select Get locking code string for remote 
machine from file. Click the Load button. Select the file that contains 
the locking code and click Open.

 8 Click OK. The Remote Commuter Licensing dialog box opens.

 9 Send the commuter license to the remote user in one of the following 
ways:

➤ Click the Save button to save the locking code in a file. Specify the 
name and location for the file, click Save and then click OK. Attach the 
file to a new e-mail message and e-mail it to the remote user.

➤ In the E-mail address box, enter the e-mail address of the remote user. 
Click Send and then click OK. Note that this option is supported only 
if Microsoft Outlook Express is set up as your e-mail client.
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Step 3: Installing a Commuter License on a Remote Computer

The final step in remotely obtaining a commuter license is to install the 
license that was sent to you by the network user on your computer.

To install a commuter license on a remote computer:

 1 Ensure that you are logged in to your computer with administrator 
privileges.

 2 Run the WRCommute.exe file located in <QuickTest installation 
folder>\bin. The WRCommute dialog box opens.

 3 Click the Install Remote Authorization Code tab.
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 4 Enter the commuter license that the network user e-mailed you, as 
follows:

➤ If the commuter license was e-mailed to you in the body of an e-mail, 
copy it to your Windows clipboard. In the Install Remote 
Authorization Code tab of the WRCommute dialog box, select Enter 
remote authorization code and then click the Paste from clipboard 
button.

➤ If the commuter license was e-mailed to you as an attached file, save 
the attachment and then select Get remote authorization code(s) 
from file. Click the Load button. Select the file that contains the 
locking code and click the Open button.

 5 Click Install. The new license code is installed on your computer.

Step 4: Modifying the License Type on the Remote Computer

Open QuickTest and change your license type from concurrent to seat. In 
the confirmation message that opens after you change the license type, click 
No to use the commuter license. For more information, see "Modifying 
License Information" on page 80.

Note: A remote commuter license cannot be checked in to the concurrent 
license server when you have finished using it—it simply expires on the 
remote computer. After you return to your office and are reconnected to the 
network, you should change your license type from seat to concurrent. For 
more information, see "Modifying License Information" on page 80.
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Validating QuickTest Licenses

The License Validation Utility decodes and validates QuickTest Professional 
license strings. This enables you to view and copy license information and 
license validation information for troubleshooting purposes. 

The License Validation Utility performs the following operations:

➤ Decodes the license string and retrieves important information regarding 
the license. For more information, see "License Information" on page 98.

➤ Validates the license according to a predefined set of checks. For more 
information, see "Validation Checks" on page 99.

If required, you can copy the decoding and validation results to the 
clipboard. For more information, see "Copying your License Validation 
Result to the Clipboard" on page 99.
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To decode and validate a license:

 1 Select Start > Programs > HP QuickTest Professional > Tools > License 
Validation Utility.

 2 In the License Key box, enter the license code you want to decode and 
validate. You can find the license code already installed on a QuickTest 
computer in the lservrc file. The location of this file is specified by the 
lservrc environment variable. 
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Tips: 

➤ When you enter the license code, ensure that a # character is inserted 
at the end of the license code, or an error will be reported in the 
License validation results area. The # indicates the end of the license 
code, and any string after the # character is ignored by the License 
Validation Utility.

➤ To find the path of the lservrc file in the environment variable, 
right-click My Computer and select Properties. In the System 
Properties dialog box, select the Advanced tab, and then click 
Environment Variables. The path is displayed in the User variables for 
<user> box of the Environment Variables window for the LSERVRC 
variable. For example, C:\Program Files\Common Files\HP\License 
Manager\lservrc.

 3 Click Validate. The license string is decoded.

License information is displayed in the License information area. For 
more information, see "License Information" on page 98.

The result of the validation is displayed in the License validation results 
area. For more information, see "Validation Checks" on page 99.

 4 If required, click Copy to copy the information to the clipboard. The 
copied information includes the current computer locking code, the 
license string that was decoded, and the decoding and validation results. 
For more information, see "Copying your License Validation Result to the 
Clipboard" on page 99.

 5 Click Close to close the utility. 



Chapter 3 • Working with QuickTest Professional Licenses

98

License Information
The result of the decoding operation includes the following information 
about the license.

Note: Some information provided by the operation is intended for 
HP Software Support only and is not described here. 

➤ Feature Name. The QuickTest feature name specified when the license 
was created.

➤ Feature Version. The license version specified when the license was 
created. This is not the QuickTest Professional version number.

➤ Seat/Concurrent. The license type. This can be either a Seat license that is 
specific to the computer on which it is installed, or a Concurrent license, 
which references a current license server that can be used by multiple 
QuickTest users.

➤ Trial/Normal. The license type. It can be either a Trial license, which is a 
demo license that has a limited period of use, or a Normal license.

➤ Trial Days Count. Applicable only for trial licenses. Specifies the number 
of days until the trial period is over. The count is started from the date the 
QuickTest core components are installed.

➤ Locking Code. The locking code specified when the license was created. 
This code uniquely identifies the computer on which QuickTest is 
installed.

➤ Clock Tamper. Indicates whether a license can be issued, based on 
whether any date changes have been made to the computer on which 
QuickTest is installed.

➤ Commuter License. Indicates whether commuter licenses are supported. A 
commuter license enables you to work with QuickTest Professional when 
you are not connected to the QuickTest concurrent license server. 
Commuter licenses are available only with concurrent licenses. For more 
information, see "Working with Commuter Licenses" on page 82.
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Validation Checks
The validation checks performed by the License Validation Utility include 
the following:

 1 Does the QuickTest feature name match one of the existing features?

 2 Does the license version match one of the existing versions?

 3 Does the locking code match the locking code of the computer on which 
QuickTest is installed?

 4 Has the trial period specified in the license string ended?

 5 If the license is a concurrent license, does it support commuter licenses?

Copying your License Validation Result to the Clipboard
In some cases, you may need a copy of the information provided by this 
utility. For example, you may need to forward this information to 
HP Software Support.

When the validation operation is complete, click the Copy button to copy 
the information to the clipboard. Then paste the information as required.
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Troubleshooting Concurrent Licensing Issues

In certain circumstances, QuickTest Professional cannot connect to the 
license server, and a License Error message opens.

Check whether one or more of the following are causing the error: 

➤ "There is no network connection between the server and client 
computers" on page 100

➤ "The license server is not running" on page 101

➤ "Licenses are not installed on the license server" on page 101

➤ "The license key file (lservrc) cannot be found on the server" on page 102

➤ "The license server is being used by the maximum number of users" on 
page 102

➤ "Two or more versions of the license server are running" on page 103

➤ "The client computer is configured to use a seat license" on page 103

➤ "The license key does not match the license server locking code" on 
page 103

➤ "The client computer cannot identify the license keys on the server 
computer" on page 104

➤ "The LSHOST or LSFORCEHOST variables are not set" on page 105

➤ "The LSERVRC system variable is set on the client computer" on page 105

➤ "The client computer connects through VPN software" on page 105

There is no network connection between the server and 
client computers
You can check the network connection between the client and server 
machines by pinging the license server machine in a command prompt 
window. 

For example: c:\ ping <license server name> 



Chapter 3 • Working with QuickTest Professional Licenses

101

If there are no replies from the ping command, or if there are timeouts in 
the replies, there may be a network problem. If required, contact your 
Computer or Network Administrator. 

The license server is not running
You may need to start or restart the license server service.

To start or restart the license server service:

 1 Open the Control Panel (Start > Settings > Control Panel).

 2 Select Services. 

Note: On some operating systems, such as Windows 2000, the Services 
utility is located in the Administrative Tools section (folder) of the 
Control Panel. 

 3 Select SentinelRMS service.

 4 Click Start the Service (or Restart the Service), or right-click and select 
Start (or Restart). 

Licenses are not installed on the license server
Use the WlmAdmin utility to check that licenses are installed on the license 
server. For more information on the WlmAdmin utility, see the Utilities 
chapter in the HP Functional Testing Concurrent License Server Installation 
Guide.

To check licenses on the license server: 

 1 Run SrvUtils.exe in the LicenseServer\utils folder of the 
QuickTest Professional installation DVD.

 2 Select WlmAdmin.

 3 Enter the license server name as a defined server.

 4 Try to expand the license server branch. 
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If no license key information is displayed, then the installed licenses are 
invalid, or the license key file (lservrc) cannot be found. If license key 
information is displayed, then the installed licenses are valid. You can check 
whether the licenses are all in use by selecting a license and checking the 
Statistics pane in the WlmAdmin utility. 

The license key file (lservrc) cannot be found on the 
server
The lservrc file should be located in the following directory: 

<drive>\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS 
License Manager\WinNT 

If the file is not there, the license server will not be able to locate licenses. 
Search the license server computer for the file. If found, move the file to the 
correct directory and restart the SentinelLM service. If the file is not found, 
licenses are not installed. 

The license server is being used by the maximum number 
of users

➤ If all licenses are in use, the License Server Manager will not be able to 
issue another license until a license is released. You can use the 
WlmAdmin utility to determine which users are currently using the 
licenses. Run SrvUtils.exe in the LicenseServer\utils folder of the 
QuickTest Professional installation DVD, and select WlmAdmin.

For more information on the WlmAdmin utility, see the Utilities chapter 
in the HP Functional Testing Concurrent License Server Installation Guide. 

➤ There may be cases where QuickTest closes unexpectedly and does not 
release the license automatically. If this happens, you can wait for the 
license to timeout, or you can restart the license server. 

For more information, see the HP Software Self-solve knowledge base 
(http://h20230.www2.hp.com/selfsolve/document) (the Knowledge Base area 
requires that you register as an HP Passport user and sign in). In the 
knowledge base, search for:

Document ID 18428. "What happens if AQT/QTP crashes on a client 
machine while using a Floating license". 
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Two or more versions of the license server are running
Only one version of the license server should be installed and running on 
the same computer. If there are more versions, use Add/Remove Programs to 
uninstall all of the license server instances. Then install the latest version of 
the license server software and reinstall the license code keys. 

The client computer is configured to use a seat license
For information on how to check and modify concurrent license or seat 
license configuration, see "Modifying License Information" on page 80. 

The license key does not match the license server locking 
code
Use the lsdecode.exe utility to check the locking code for a license key.

To check the license key locking code:

 1 Copy the lsdecode.exe utility from the LicenseServer\utils folder of the 
QuickTest Professional installation DVD to the location of the lservrc file 
(<drive>\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS 
License Manager\WinNT).

 2 Run the lsdecode.exe utility. A command prompt window will open with 
the decoded key information. 

The locking code for the license key is displayed on the Server locking 
code line. 

 3 Run the inst_key.exe utility from the LicenseServer\KeyInstallation folder 
of the QuickTest Professional installation DVD. 

The license server computer’s locking code will be displayed on the 
Welcome screen. 

Note: This step must be done on the license server computer. Accessing 
the license server computer remotely can generate an invalid license code. 
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 4 Compare the locking code for the license key and from the server 
computer. 

If the locking codes do not match, you will need to determine why the 
locking code has changed. Reinstalling the operating system, renaming 
the computer, using a dynamic IP address, retrieving the locking code 
through a terminal session, or installing the license keys through a 
terminal session can cause the locking code to be changed and the license 
keys to become invalid. 

After you have determined why the locking code has changed, you can 
submit a License Request to have a new license key generated. 

The client computer cannot identify the license keys on 
the server computer
Use the WlmAdmin utility to check the licenses on the client computer. For 
more information on the WlmAdmin utility, see the Utilities chapter in the 
HP Functional Testing Concurrent License Server Installation Guide. 

To check licenses on the client computer:

 1 Run SrvUtils.exe in the LicenseServer\utils folder of the 
QuickTest Professional installation DVD.

 2 Select WlmAdmin.

 3 Enter the license server name as a defined server.

 4 Try to expand the license server branch. 

If license keys are not identified, then either UDP Port 5093 is blocked 
between the client and server, or the IP address of the license server is using 
Network Address Translation (NAT), which is not supported. If required, 
contact your Computer or Network Administrator. 
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For more information, see the HP Software Self-solve knowledge base (http://
h20230.www2.hp.com/selfsolve/document) (the Knowledge Base area requires 
that you register as an HP Passport user and sign in). In the knowledge base, 
search for:

➤ Document ID 18402. "What is port 5093 in the license mechanism 
used for?"

➤ Document ID 41449. "Does UDP port 5093 need to be bi-directional?"

➤ Document ID 18424. "How to set up the License Manager for machines 
running on different subnets." 

The LSHOST or LSFORCEHOST variables are not set
For information on how to set these variables, see the HP Functional Testing 
Concurrent License Server Installation Guide. 

The LSERVRC system variable is set on the client computer
The LSERVRC variable is used for seat licenses and may have been created 
for the demo license when QuickTest was installed. If this variable exists, it 
must be removed so it does not interfere with locating the license server. 

To remove The LSERVRC system variable:

 1 On your desktop, right-click My Computer and select Properties.

 2 Select the Advanced tab and click Environment Variables.

 3 Check the System Variables list for the LSERVRC variable. If it exists, click 
Delete.

 4 Click OK to close the windows.

 5 Reboot the client computer to implement the changes. 

The client computer connects through VPN software
If the client computer is connecting through VPN software, verify that VPN 
has not been configured to use IPSec over UDP. This configures the network 
to use Network Address Translation (NAT), which is not supported. 
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4
Maintaining and Uninstalling 
QuickTest Professional

You can install and uninstall individual QuickTest Professional features, or 
uninstall all QuickTest Professional software and files (including add-ins). 
You can also repair a QuickTest Professional installation that has become 
corrupted.

Note: In some situations, you may be prompted to restart your computer 
after you have installed or made changes to the QuickTest installation. It is 
recommended that you restart your computer as soon as possible if you are 
prompted to do so. Delaying the system restart may result in unexpected 
QuickTest behavior.

This chapter includes:

➤ Installing and Uninstalling Specific QuickTest Professional Features 
on page 108

➤ Repairing Your QuickTest Professional Installation on page 110

➤ Uninstalling QuickTest Professional on page 111

➤ Saving and Restoring Your QuickTest Settings on page 113

➤ Troubleshooting and Limitations - Uninstalling QuickTest on page 117
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Installing and Uninstalling Specific QuickTest Professional 
Features

Your QuickTest Professional DVD enables you to install or uninstall specific 
QuickTest Professional features. For example, you can install or uninstall an 
add-in or the sample applications provided with QuickTest Professional.

Note: You can also install or uninstall specific QuickTest Professional 
features by choosing Start > Settings > Control Panel > Add or Remove 
Programs, and then clicking the Change button for QuickTest Professional.

The procedure for installing or uninstalling features is similar to the 
procedure for performing a Custom installation. For more information on 
the specific screens mentioned in the procedure below, see "Installing 
QuickTest Professional" on page 22.

Note: Before uninstalling QuickTest Professional features, make sure that 
you have a minimum of 50 MB free disk space.

To install or uninstall QuickTest Professional features:

 1 Insert the QuickTest Professional DVD into the DVD drive. If the DVD 
drive is on your local computer, the QuickTest Professional Setup window 
opens.

If the DVD is in a network drive, double-click setup.exe in the root folder 
of the DVD. The QuickTest Professional Setup window opens.

Note: You must use the same QuickTest Professional version that you 
used for the original installation.
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 2 Click QuickTest Professional Setup. The Welcome to the HP QuickTest 
Professional Setup Wizard opens. Click Next to proceed.

 3 The Maintenance Type screen opens. Select Modify and click Next. 

 4 In the Custom Setup screen, click an icon to view a menu and select how 
that feature is installed on your computer. The following options are 
available, depending on the feature:

➤ Will be installed on local hard drive. Installs the selected feature on 
your local hard drive.

➤ Entire feature will be installed on local hard drive. Installs the entire 
selected feature on your local hard drive.

➤ Entire feature will be unavailable. Excludes the feature from the 
installation and it is not available in QuickTest.

You can select an item in the list to see a description of the feature as well 
as the space requirement on your drive for the feature, or how much 
space will be freed up if the feature is uninstalled. 

Click Next to proceed.

 5 Click Next in the Confirm Installation screen. The Installing 
HP QuickTest Professional screen displays the progress of the application 
modification.

 6 The Installation Complete screen opens. Click Finish.

Note: If you install a feature that has prerequisites for use with QuickTest, 
the Additional Installation Requirements dialog box will open after the 
feature is installed. For more information, see "Working with the 
Additional Installation Requirements Utility" on page 35.
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Repairing Your QuickTest Professional Installation

Your QuickTest Professional DVD enables you to repair an existing 
QuickTest Professional installation, by replacing any missing or damaged 
files from your previous QuickTest Professional installation.

Note: You can also repair an existing QuickTest Professional installation by 
choosing Start > Settings > Control Panel > Add or Remove Programs, and 
then clicking the Change button for QuickTest Professional.

To repair your QuickTest Professional installation:

 1 Insert the QuickTest Professional DVD into the DVD drive. If the DVD 
drive is on your local computer, the QuickTest Professional Setup window 
opens.

If the DVD is in a network drive, double-click setup.exe in the root folder 
of the DVD. The QuickTest Professional Setup window opens.

Note: You must use the same QuickTest Professional version that you 
used for the original installation.

 2 Click QuickTest Professional Setup. The Welcome to the 
HP QuickTest Professional Setup Wizard opens.

 3 Click Next to proceed. The Maintenance Type screen opens.

 4 Select Repair and click Next. Then click Next on the Confirm Repair 
screen. The Setup Status screen displays the progress of the repair process.
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Note: The repair process might take some time to start. During this time, 
the wizard might not respond. Afterwards, the Run Setup screens open 
and the repair process continues.

 5 Click Finish in the Installation Complete screen.

Uninstalling QuickTest Professional

You can uninstall QuickTest Professional using the Add or Remove 
Programs option in the Windows Control Panel or using the QuickTest 
Professional DVD.

You can save your existing customization settings and registry keys before 
you uninstall QuickTest Professional, and then if required, restore them 
after you install a new version. For more information, see "Saving and 
Restoring Your QuickTest Settings" on page 113. 

Before uninstalling QuickTest, make sure that you have a minimum of 
50 MB free disk space.

Notes:

➤ You can uninstall specific QuickTest Professional features as described in 
"Installing and Uninstalling Specific QuickTest Professional Features" on 
page 108. 

➤ You can uninstall individual QuickTest Professional hotfixes (patches) 
using the Add or Remove Programs option in the Windows Control 
Panel.
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To uninstall QuickTest Professional using the Add or Remove Programs 
option in the Windows Control Panel:

 1 Select Start > Settings > Control Panel > Add or Remove Programs. The 
list of currently installed programs opens.

 2 Select QuickTest Professional and click Remove. A message prompts you 
to confirm your decision to uninstall QuickTest Professional. Click Yes 
and follow the on-screen instructions to uninstall QuickTest Professional. 
Click No to keep QuickTest Professional installed on your computer.

The uninstall program removes all QuickTest Professional features from 
your computer (including any QuickTest Professional add-ins).

To uninstall QuickTest Professional using the QuickTest Professional DVD:

 1 Insert the QuickTest Professional DVD into the DVD drive. If the DVD 
drive is on your local computer, the QuickTest Professional Setup window 
opens.

If the DVD is in a network drive, double-click setup.exe in the root folder 
of the DVD. The QuickTest Professional Setup window opens.

Note: You must use the same QuickTest Professional version that you 
used for the original installation.

 2 Click QuickTest Professional Setup. The Welcome to 
HP QuickTest Professional Setup Wizard opens.

 3 Click Next. The Maintenance Type screen opens.

 4 Select Remove and click Next. Click Next in the Confirm Uninstall 
screen.

The uninstall program removes all QuickTest Professional features from 
your computer (including any QuickTest Professional add-ins).

 5 Click Finish in the Removal Complete screen.
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Note: Uninstalling QuickTest Professional does not uninstall any 
non-HP applications that you install as part of the QuickTest Professional 
installation, for example, the Microsoft Script Debugger or the Microsoft 
.NET Framework. You can uninstall these applications using the Add or 
Remove Programs dialog box in the Control Panel.

Saving and Restoring Your QuickTest Settings

If you are upgrading from QuickTest Professional 9.2 or earlier, you need to 
first uninstall your previous version. The Save and Restore Settings utility 
enables you to save some existing customization settings and registry keys 
before you uninstall an old QuickTest version, and then restore them after 
you install the new version.

The Save and Restore Settings utility is particularly useful for saving the 
manual customizations made to Web event recording configuration .xml 
files.

For a list of the files and settings saved by the Save and Restore Settings 
utility, see "Saved Files And Settings" on page 115.

The Save and Restore Settings utility does not backup your tests folder. 
Although the uninstall process does not delete QuickTest tests, you may 
want to create a backup copy of your tests folder before uninstalling.



Chapter 4 • Maintaining and Uninstalling QuickTest Professional

114

To save existing settings:

 1 Before uninstalling your previous QuickTest version, run the 
SaveRestoreSettings.exe file located in the root of the QuickTest 
installation DVD.

Note: After installing QuickTest Professional, the Save and Restore 
Settings utility is also available from Start > Programs > 
HP QuickTest Professional > Tools > Save and Restore Settings.

The Save and Restore Settings dialog box opens. 

 2 Select the Save settings to radio button option and enter the location and 
.zip file name in which you want to save your existing 
QuickTest Professional customization settings, and registry keys.

 3 Click OK to save your settings.
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To restore saved settings:

 1 After installing QuickTest Professional, select Start > Programs > 
HP QuickTest Professional > Tools > Save and Restore Settings. The Save 
and Restore Settings dialog box opens.

 2 Select the Restore settings from radio button option and enter the 
location and .zip file name in which your QuickTest Professional 
customization settings, and registry keys are saved.

 3 Click OK to restore your settings.

Saved Files And Settings

The Save and Restore Settings utility saves specific files from the bin and dat 
folders in the QuickTest Professional installation folder, and specific 
QuickTest registry keys.

Bin Folder Files

The following files in the <QuickTest Professional installation>\bin folder 
are saved by the Save and Restore Settings utility:

➤ Mic.ini

➤ Qtreport.ini

Dat Folder Files

The following files from the <QuickTest Professional installation>\dat folder 
are saved by the Save and Restore Settings utility, if they exist (depending on 
the installed add-ins):

Related Add-in File Name

Siebel SiebelConfiguration.xml*

Siebel SiebelEventConfiguration.xml*

Siebel SiebelExceptionConfig.xml*

Siebel SiebelPatterns.xml*

Siebel CASConfiguration.xml*

Siebel CASEventConfiguration.xml*
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Note: Files marked with an asterisk are copied only if they were changed by 
the user, but are not copied if no changes were made.

Registry Keys

The following registry key is saved by the Save and Restore Settings utility:

HKEY_LOCAL_MACHINE\SOFTWARE\Mercury Interactive\QuickTest 
Professional\MicTest\Packages\TEAPackage

SAP PropertyPatternConfigSAP.xml*

SAP SAPConfiguration.xml*

SAP SAPLearnFilter.xml*

SAP SapEventConfiguration.xml*

PeopleSoft PSConfiguration.xml*

PeopleSoft PSEventConfiguration.xml*

PeopleSoft PSLearnFilter.xml*

.NET SwfConfig.xml

.NET WebFormsConfiguration.xml*

.NET WebFormsEventConfiguration.xml*

.NET WebFormsLearnFilter.xml*

Related Add-in File Name
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Troubleshooting and Limitations - Uninstalling QuickTest

This section describes troubleshooting and limitations for uninstalling 
QuickTest Professional.

➤ When a Quality Center client is installed on the same computer as 
QuickTest Professional, uninstalling QuickTest Professional may remove 
the association of movie (FBR) files. This may prevent you from viewing 
movies associated with defects in Quality Center using the HP Micro 
Player.  

Workaround: Re-associate the movie files with the HP Micro Player, as 
follows:

 a Select Start > Programs > QuickTest Professional > Tools > HP Micro 
Player to open the HP Micro Player.

 b Select File > Options to open the HP Micro Player Options dialog box. 
Then select the Associate FBR files with this Player check box to 
associate the files directly with the HP Micro Player.
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