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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As 
a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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Welcome to Extensibility Accelerator for 
HP Functional Testing

QuickTest Web Add-in Extensibility enables you to develop support for 
testing third-party and custom Web controls that are not supported 
out-of-the-box by the QuickTest Professional Web Add-in. 

Extensibility Accelerator for HP Functional Testing is an IDE that facilitates 
the design, development, and deployment of this support. This IDE is 
powered by the Microsoft Visual Studio Shell and therefore provides the 
same look and feel as Visual Studio, as well as many of the Visual Studio 
basic IDE functionalities.

Extensibility Accelerator provides a user interface that helps you define new 
test object classes, map those test object classes to the controls in your 
application, and teach QuickTest how to identify the controls, perform 
operations on the controls and retrieve their properties. 

This information is stored in XML files and JavaScript files, which comprise 
a toolkit support set that you deploy to QuickTest to extend the Web Add-in 
to support the custom controls. For details on toolkit support sets, see 
"Custom Toolkit Support Sets" on page 24.

To use Extensibility Accelerator, you should be familiar with:

➤ QuickTest Professional (and the Web Add-in)

➤ XML

➤ JavaScript programming
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Extensibility Accelerator Documentation

This user guide explains how to use Extensibility Accelerator. You can open 
it by selecting Help > Extensibility Accelerator User Guide or pressing F1 on 
extensibility-specific windows. 

For details on Web Add-in Extensibility, see the HP QuickTest Professional 
Web Add-in Extensibility Developer Guide (Help > Web Add-in Extensibility 
Developer Guide). 

These guides is also available in printer-friendly (PDF) format, in the 
<Extensibility Accelerator installation>\Help folder.

For details on the Visual Studio standard functionalities and windows in 
Extensibility Accelerator, see the online MSDN Visual Studio Help (http://
msdn.microsoft.com/en-us/library/aa187919.aspx). If you are connected to the 
Internet while using Extensibility Accelerator, you can access this Help by 
selecting Help > Contents or pressing F1 on standard windows in the 
product. 

http://msdn.microsoft.com/en-us/library/aa187919.aspx
http://msdn.microsoft.com/en-us/library/aa187919.aspx
WebExtensibility.chm::/WebExtensibility.htm
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1
Introducing Extensibility Accelerator

This chapter includes:

Concepts

➤ QuickTest Web Add-in Extensibility - Overview on page 9

➤ What Extensibility Accelerator Helps You Do on page 11

Tasks

➤ Enable Schema-Based XML Editing on page 12

Reference

➤ Extensibility Accelerator at a Glance on page 13
Concepts

QuickTest Web Add-in Extensibility - Overview

The QuickTest Professional Web Add-in provides built-in support for a 
number of commonly used Web controls. The add-in provides test object 
classes, operations (methods), and properties that can be used when testing 
Web applications.

Web Add-in Extensibility enables you to develop support for testing 
third-party and custom Web controls that are not supported out-of-the-box 
by the QuickTest Professional Web Add-in.

When QuickTest learns an object in an application, it recognizes the object 
as belonging to a specific test object class. This determines the identification 
properties and test object operations of the test object that represents the 
application’s object in QuickTest. 



Chapter 1 • Introducing Extensibility Accelerator

10

The type of test object that QuickTest uses might not have certain 
characteristics that are specific to the Web control you are testing. Therefore, 
when you try to create test steps with this test object, the available 
identification properties and test object operations might not be sufficient. 

For example, consider a custom Web control that is a special type of table 
that QuickTest recognizes as a plain WebElement. WebElement test objects 
do not support GetCellData operations. To create a test step that retrieves 
the data from a cell in the table, you would need to create test objects to 
represent each cell in the table, and create a complex test that accesses the 
relevant cell’s test object to retrieve the data.

To create support for Web controls using Web Add-in Extensibility, you 
create new test object classes, based on the Web Add-in ones. You can then 
direct QuickTest to recognize each control as belonging to a specific test 
object class, and you can specify the behavior of each test object class. This 
enables you to create tests that fully support the specific behavior of your 
custom Web controls.

For more details on Web Add-in Extensibility, see the HP QuickTest 
Professional Web Add-in Extensibility Developer Guide, available in the 
<Extensibility Accelerator installation>\Help folder.

WebExtensibility.chm::/WebExtensibility.htm
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What Extensibility Accelerator Helps You Do

To extend the QuickTest Web Add-in to support custom Web toolkits, you 
create custom toolkit support sets and deploy them to QuickTest. The 
toolkit support set is comprised of XML configuration files and JavaScript 
functions. For details, see "Custom Toolkit Support Sets" on page 24.

Creating support for a custom toolkit is comprised of the following stages:

 1 Planning how you want QuickTest to operate on your 
controls.

This is a preliminary stage that you perform by using QuickTest on your 
application and determining what aspects of QuickTest’s behavior you 
would like to customize. 

For details, see the section on planning QuickTest support for your toolkit 
in the HP QuickTest Professional Web Add-in Extensibility Developer Guide. 

 2 Creating and defining the test object classes, operations, 
properties and settings.

The Extensibility Accelerator IDE simplifies creating and editing the XML 
files required for a toolkit support set, by providing designers in which 
you specify the relevant information. This enables you to invest your 
main efforts in the development of the JavaScript functions.

 3 Writing and debugging JavaScript implementation 
functions.

The JavaScript functions that you write as part of the toolkit support set 
enable QuickTest to work with your custom Web controls. Extensibility 
Accelerator creates the necessary JavaScript files and adds stubs for the 
functions that you must implement. In addition, Extensibility Accelerator 
provides JavaScript editing capabilities and debugging tools to facilitate 
writing these functions.

WebExtensibility.chm::/WebExtPlan.htm


Chapter 1 • Introducing Extensibility Accelerator

12

 4 Deploying the toolkit support so it can be used on QuickTest.

Extensibility Accelerator deployment capabilities enable you to 
automatically deploy your new toolkit support set to QuickTest or to 
package it so that you can share it with other QuickTest users. 

For task details, see "Create or Update Support for a Custom Toolkit" on 
page 27.

Tasks

Enable Schema-Based XML Editing

This task describes how to add the Web Add-in Extensibility XML schemas 
to the Extensibility Accelerator schema set. This enables schema-based XML 
editing capabilities, such as IntelliSense. You only have to perform this 
procedure once.  

 1 Open an XML file.

 2 Select XML > Schemas. The XML Schemas dialog box opens.

 3 Use the Add button to add the following schema files:

➤ <Extensibility Accelerator installation>\dat\Toolkit.xsd

This is the schema file for the toolkit configuration XML file.

➤ <Extensibility Accelerator installation>\dat\ClassesDefinitions.xsd

This is the schema file for the test object configuration XML file.

 4 In the Use column in the XML Schemas dialog box, make sure that Use 
this schema is selected for these two schema files (a green check mark is 
displayed). Click OK.

Reference
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Extensibility Accelerator at a Glance

Extensibility Accelerator for HP Functional Testing is a Visual Studio-like IDE 
that facilitates the design, development, and deployment of Web Add-in 
Extensibility toolkit support sets. 

You develop a toolkit support set in an extensibility project. The main 
Extensibility Accelerator functionalities are available only when you have a 
project open. You can open only one project at a time.

This section introduces the Extensibility Accelerator window and lists the 
main areas in comprises and how you can use them.

You can customize the appearance of this window by moving and docking 
the windows it contains and by customizing toolbars, in the same ways as 
you would in Visual Studio.

Note: If your computer’s display is set to the Windows Classic style, the 
colors and appearance of some tabs will differ from the intended design.
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The Extensibility Accelerator window contains:

➤ Main Area (described on page 15)

➤ Additional Windows (described on page 17)

➤ Menus and Toolbars (described on page 18)
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Main Area

The main area of the Extensibility Accelerator window can display the 
following:

Start Pages

Extensibility Accelerator displays two Start Pages:

➤ The Extensibility Accelerator Start Page. Displayed when no projects are 
open. This page describes the Extensibility Accelerator product, and 
provides access to some basic functionalities, such as creating a new 
project, opening recent projects or sample projects, or viewing a movie 
about Extensibility Accelerator. 

➤ The Project Start Page. Displayed when you create or open a project. It 
explains the steps that comprise defining a test object class. These steps 
correspond to the tabs in the test object class designer.

In addition, this Start Page provides a link that you can click to create a 
new test object class.

Toolkit Support Properties Designer

This designer enables you to define settings that affect how QuickTest treats 
this toolkit support set. The information that you define in this designer is 
stored in the toolkit support set’s XML files.

For details, see "Toolkit Support Properties Designer" on page 37.

Test Object Class Designer

The test object class designer is the main designer in Extensibility 
Accelerator. It enables you to define all of the details about the test object 
class that you want QuickTest to use for the custom control. For example, 
the name of the test object class, the types of controls that it represents, and 
the operations and properties that it supports.

Make sure to visit all of the tabs in this designer.
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For details, see:

➤ "General Tab (Test Object Class Designer)" on page 65.

➤ "Map to Controls Tab (Test Object Class Designer)" on page 74

➤ "Operations Tab (Test Object Class Designer)" on page 81

➤ "Properties Tab (Test Object Class Designer)" on page 90

Enumerations Designer

This designer enables you to define lists of values that can be used for test 
object operation arguments. This information is stored in the test object 
configuration XML file.

For details, see "Enumerations Designer" on page 40.

JavaScript Editor

When you open a JavaScript file, it opens in an editor that provides standard 
JavaScript editing capabilities, such as full syntax highlighting and 
IntelliSense features. For details, see the online MSDN Visual Studio Help.  

IntelliSense is not provided for the _elem and _util tokens.   

XML Editor

When you open an XML file, it opens in an editor that provides standard 
XML editing capabilities, such as color-coded display and syntax 
completion features. For details, see the online MSDN Visual Studio Help.  

This editor can also provide XML IntelliSense and validation based on the 
relevant schemas. Extensibility Accelerator provides the XML schemas that 
you need for editing the toolkit configuration XML file and the test object 
configuration XML file. 

To enable XML schema based editing, add the schemas to your schema set, 
as described in "Enable Schema-Based XML Editing" on page 12.
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Caution: In extensibility projects, there is a strong connection between file 
names, the location of the files in the project, and the content of different 
files. Therefore, if you edit XML files manually, make sure you do not create 
discrepancies.

Additional Windows

In addition to the main area, the following windows are available. (You can 
show them by selecting them in the View menu.)

➤ Workflow. Displays the development stages required to create and deploy 
support for a custom toolkit, highlighting the current stage. 

You can click on the relevant stage to create a new test object class or 
deploy the toolkit support set. For details, see "Workflow Window" on 
page 30.

➤ Class View. Displays the test object classes defined in the open project, 
and the operations defined for each test object class.

This window also provides access to common activities such as adding or 
editing classes and editing or debugging operations. For details, see "Class 
View" on page 32.

➤ Project Explorer. Displays the folders and files that make up the open 
extensibility project. 

You can double-click files in the project tree to open them. For details, see 
"Project Explorer" on page 34.

➤ Error List. Displays error, warning, or information messages when 
mandatory data is missing in your project or if conflicts or discrepancies 
are found between information in the different files.

Standard Visual Studio windows are available as well, such as: Task List and 
Find Results, and debugging related windows such as Breakpoints and 
Command Window.
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Menus and Toolbars

The menus and toolbars available in Extensibility Accelerator are similar to 
the ones in Visual Studio, and change according to the type of designer or 
file that you are working in. For example: 

➤ The File, Edit, View, Tools, Window, and Help menus are always available.

➤ The Project menu is available when a project is open. 

➤ The XML menu is available when an XML file is open.
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2
Installing the Extensibility Accelerator

This chapter includes:

Concepts

➤ Installed Components on page 19

➤ Installation Prerequisites on page 21

➤ Installing on a Non-QuickTest Computer on page 22
Concepts

Installed Components

The Extensibility Accelerator for HP Functional Testing installation program 
installs the following:

➤ Extensibility Accelerator.

You can access this program from the icon installed on your desktop or 
from the QuickTest Professional program group (Start > Program Files > 
QuickTest Professional > Extensibility Accelerator).

➤ A demo movie.

This movie demonstrates the basic capabilities of Extensibility Accelerator 
by walking you through the process of customizing QuickTest's support 
for a specific Web control.

You can access the demo movie from the Extensibility Accelerator Start 
Page or Help menu (Help > Demo Movie).
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➤ Documentation.

The HP Extensibility Accelerator for HP Functional Testing User Guide, and the 
HP QuickTest Professional Web Add-in Extensibility Developer Guide, in both 
online Help format and printable (PDF) format.

You can access the guides directly in the <Extensibility Accelerator 
installation folder>\Help folder or you can open the online Help from the 
Extensibility Accelerator Help menu.

➤ Sample Web Add-in Extensibility projects.

These projects contain completed toolkit support sets, which were 
developed to provide support for some public Web 2.0 toolkits.

The samples are installed in the %ALLUSERSPROFILE%\Documents\
ExtAccTool\Samples folder, and are also accessible from the Extensibility 
Accelerator Start Page. You can open these projects and browse through 
the files, functions, and comments to learn more about how these 
support sets are designed. You can also modify these sample projects and 
experiment with them. Backup copies of the sample projects are installed 
in the <Extensibility Accelerator installation folder>\Help\Samples folder.
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Installation Prerequisites

The following prerequisites must be installed before you can install the 
Extensibility Accelerator for HP Functional Testing:

➤ .NET Framework v3.5 SP1

➤ Microsoft Visual C++ 2008 Run-time Components

➤ Visual Studio 2008 Shell (isolated mode) with SP1 Redistributable Package

The Extensibility Accelerator installation is available in two formats: A large 
installation package that includes the installation programs for these 
prerequisites and a smaller package that includes only Extensibility 
Accelerator. 

If you run the installation from the large package, the program runs the 
installation programs for any missing prerequisites before installing 
Extensibility Accelerator. 

To run the installation from the smaller package, first ensure that you have 
all of the prerequisites installed.

Note: If you have Visual Studio 2008 installed on your computer, you must 
also have Service Pack 1 installed before you can install Extensibility 
Accelerator.
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Installing on a Non-QuickTest Computer

QuickTest Professional does not have to be installed on the computer in 
order to install and use Extensibility Accelerator to create toolkit support 
sets for your Web controls. 

Extensibility Accelerator includes a debugging mechanism for test object 
operations that you design, which simulates running the operations using 
QuickTest. You can use this functionality even on a computer where 
QuickTest is not installed. The debugging mechanism enables you to debug 
part of your JavaScript functions locally, without deploying the toolkit 
support set to QuickTest.

Installing the Extensibility Accelerator on a QuickTest computer enables you 
to automatically deploy your toolkit support set to QuickTest, making it 
simpler to complete the debugging and testing of your toolkit support set. 
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3
Supporting a Custom Toolkit

This chapter includes:

Concepts

➤ Custom Toolkit Support Sets on page 24

➤ When Are Your Changes Applied and Saved on page 26

Tasks

➤ Create or Update Support for a Custom Toolkit on page 27

➤ Import an Existing Toolkit Support Set on page 29

Reference

➤ Workflow Window on page 30

➤ Class View on page 32

➤ Project Explorer on page 34

➤ Import Toolkit Support Set Dialog Box on page 36

➤ Toolkit Support Properties Designer on page 37

➤ Enumerations Designer on page 40
Concepts
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Custom Toolkit Support Sets

To extend the QuickTest Web Add-in to support custom Web toolkits, you 
create custom toolkit support sets and deploy them to QuickTest. The 
toolkit support set is comprised of XML configuration files and JavaScript 
functions. 

The XML configuration files define the test object classes that you create to 
support the custom Web controls and map them to the controls. In 
addition, they define how QuickTest operates on the custom controls. The 
JavaScript functions provide an interface between QuickTest and the 
application being tested, retrieving information about the control and 
performing operations on it.

In Extensibility Accelerator, when you create an extensibility project, the 
project contains the mandatory files for a toolkit support set. A project can 
contain the following types of files:

➤ XML files. Extensibility Accelerator provides designers (such as the test 
object class designer) to guide and assist you in editing information stored 
in the test object configuration and toolkit configuration XML files.

➤ JavaScript files. For each test object class that you create, Extensibility 
Accelerator creates a corresponding JavaScript file. Within the file, 
Extensibility Accelerator creates function stubs for the functions that you 
have to implement. You can jump to these files from Extensibility 
Accelerator to add the code necessary for implementing these functions.

➤ Additional files. Extensibility Accelerator provides Import buttons to add 
additional files to the project. 

For task details, see "Create or Update Support for a Custom Toolkit" on 
page 27.
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A toolkit support set contains the following:

➤ A test object configuration XML file. This file describes the test object 
classes that you create to support the custom controls, and the 
identification properties and test object operations that need to be 
supported for those test objects. 

For details on the structure and syntax of this XML, see the QuickTest Test 
Object Schema Help, available in the Extensibility Accelerator Help. 

➤ A toolkit configuration XML file. This file maps the test object classes that 
you create to the relevant controls, and provides implementation details 
for how QuickTest operates on the control. Some implementation details 
are contained in this configuration file, others are in JavaScript files that 
this file references.

For details on the structure and syntax of this XML, see the Toolkit 
Configuration Schema Help, available in the Extensibility Accelerator 
Help.

➤ JavaScript files. These files contain the implementation functions 
referenced from the toolkit configuration XML file. QuickTest calls these 
functions to retrieve information from or perform operations on the 
custom controls.

For details, see the section on designing JavaScript functions for your 
toolkit support set in the HP QuickTest Professional Web Add-in Extensibility 
Developer Guide. 

➤ Icon and Help files (Optional). 

The icon files contain icons used in QuickTest to represent your test 
object classes. (Supported file types: .ico, .exe, .dll)

The Help files are used for context-sensitive Help for your test object 
classes and their methods and properties. (Supported file type: .chm)

For details on the structure of an extensibility project, see "Project Explorer" 
on page 34.

For details on the structure of a toolkit support set deployed to QuickTest, 
see "Deployment File Structure" on page 104.

WebExtensibility.chm::/WebExtDev_JS.htm
WebExtensibility.chm::/WebExtDev_JS.htm
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When Are Your Changes Applied and Saved

Information that you define in the designers provided by Extensibility 
Accelerator is stored in different files in your toolkit support set. There is a 
strong connection between the information in the different files, therefore 
it is important that you save your changes frequently and consistently. This 
is especially true when you make changes that affect more than one file or 
designer, such as adding or renaming test object classes or operations. 

Using the Save Commands 

➤ Save All. Saves any changes you made in designers or file editors. All of 
the XML and JavaScript files are saved.

➤ Save (file). If you use the Save command when a file editor is selected, 
only the file currently open in the editor is saved. If you subsequently 
discard corresponding changes in another file, this can result in 
discrepancies within your toolkit support set. These discrepancies are 
reported in the Error List window. 

➤ Save (designer). If you use the Save command when a designer is 
selected, the changes that you made in the designer are updated in all 
relevant XML and JavaScript files.

Considerations When Editing Multiple Test Object Classes

The XML information for all test object classes is stored in one XML file. If 
the XML file is closed while you make changes in the designers, the relevant 
changes are applied to the file only when you save them. This ensures that 
only information pertaining to the designer on which you performed the 
Save command is saved. 

However, if the XML file is open while you make changes in the designers, 
the changes are immediately written to the XML editor (not to the file). If 
change more than one test object class and then save one, the XML file in 
the editor is saved with the changes made for all of the test object classes. If 
discrepancies are subsequently created, they are reported in the Error List 
window.

It is therefore recommended to keep the XML files closed while you work in 
the Extensibility Accelerator designers, or to make sure to finish changing 
one test object class before beginning to change another.
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Changes Made Automatically to JavaScript Files

When you modify definitions in the Operations Tab (Test Object Class 
Designer), function stubs are added or updated in the relevant JavaScript 
files. The JavaScript files are modified when you save your changes, or when 
you leave the designer and move the focus to another designer, file, or 
window.

If a JavaScript file is open when the functions in it are modified, the changes 
are made in the JavaScript editor. They are saved to the file system only 
when you use the Save command. 

If the files are closed, the changes are made directly in the file system. If you 
later decide not to save the changes that you made in the test object 
designer, the changes made in the JavaScript files remain.

Tasks

Create or Update Support for a Custom Toolkit

This task describes the overall process of creating, designing, and deploying 
a toolkit support set using Extensibility Accelerator.

This task includes the following steps:

➤ "Prerequisites - Plan your support" on page 28

➤ "Open, create, or import an extensibility project" on page 28

➤ "Define the toolkit support properties - Optional" on page 28

➤ "Create or update support for a single control" on page 28

➤ "Deploy the toolkit support to QuickTest, or package it for distribution" 
on page 28
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 1 Prerequisites - Plan your support

For details, see the section on planning QuickTest support for your toolkit 
in the HP QuickTest Professional Web Add-in Extensibility Developer Guide.  

 2 Open, create, or import an extensibility project

Create a new extensibility project, or open an existing one. 

➤ To open an existing project, select File > Open > Project/Solution and 
browse to the .weproj project file.

➤ To create a new empty project, select File > New > Project, and use the 
Web Add-in Extensibility template available in the New Project dialog 
box that opens.

➤ To import an existing toolkit support set and create a new extensibility 
project, select File > Import Toolkit Support Set. For details, see "Import 
an Existing Toolkit Support Set" on page 29.

Note: You can have only one project open at a time. 

 3 Define the toolkit support properties - Optional

For details, see "Toolkit Support Properties Designer" on page 37.

 4 Create or update support for a single control

See "Create or Update Support for a Single Control" on page 46.

 5 Deploy the toolkit support to QuickTest, or package it for 
distribution

For details, see "Deploy a Toolkit Support Set" on page 105.

WebExtensibility.chm::/WebExtPlan.htm
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Import an Existing Toolkit Support Set

This task describes how to import an existing Web Add-in Extensibility 
toolkit support set. This creates a new Extensibility Accelerator project that 
contains the support set’s files.

Note: This task is part of a higher-level task. For details, see "Create or 
Update Support for a Custom Toolkit" on page 27.

This task includes the following steps:

➤ "Prerequisites" on page 29

➤ "Import the toolkit support set" on page 30

➤ "Results" on page 30

 1 Prerequisites

The Web Add-in Extensibility toolkit support set that you want to import 
must have the structure of a toolkit support set deployed to QuickTest, as 
described in the section on deploying toolkit support sets in the 
HP QuickTest Professional Web Add-in Extensibility Developer Guide. 

This means that the XML files are in specific locations, and the locations 
of the rest of the files, such as JavaScript files, icon files, and Help files, are 
specified in the XML files.

A standard toolkit support set will have the following structure:

Parent folder (e.g. <QuickTest installation>\dat\Extensibility\Web)
|
|---<ToolkitName>TestObjects.xml file
|---Toolkits folder:

|
|---<ToolkitName> folder

|
|---<ToolkitName>.xml file
|---JavaScript files (optionally stored in JavaScript subfolder)
|---Res folder with icon files (optional)
|---Help folder with .chm files (optional)

WebExtensibility.chm::/Deploying.htm
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 2 Import the toolkit support set

Select File > Import Toolkit Support Set and use the Import Toolkit 
Support Set Dialog Box that opens to browse to the toolkit support set and 
import it.

 3 Results

The toolkit support set files are copied into a newly created Extensibility 
Accelerator project. For details on the project file structure, see "Project 
Explorer" on page 34. 

If Open imported project was selected in the Import Toolkit Support Set 
Dialog Box, the new extensibility project opens. Otherwise, the dialog 
box remains open, enabling you to import additional support sets.

Reference

Workflow Window

This window guides you through the workflow you need to follow when 
working in an Extensibility Accelerator project. It displays the development 
stages required to create and deploy support for a custom toolkit, 
highlighting the current stage. 

 

To access Select View > Workflow

Relevant tasks "Create or Update Support for a Custom Toolkit" on 
page 27
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User interface elements are described below:

UI Elements Description

Add Test Object Class Clicking in this area creates a new test object class. 

For more details, see "Create or Update Support for a 
Single Control" on page 46.

Highlighted when: No test object classes are defined in 
the project.

Edit Test Object Class When this area is highlighted, it indicates that you are in 
the developing stage of your project.

During this stage, you can create additional test object 
classes, edit the test object class details, implementation 
files, toolkit support properties, and so on.

Highlighted when: At least one test object class is defined 
in the project.

Deploy Toolkit 
Support

Clicking in this area deploys the toolkit support set to a 
.zip file.

For more details, see "Deploy a Toolkit Support Set" on 
page 105.

Available when: At least one test object class is defined in 
the project.

Highlighted when: A deploy command is in progress.
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Class View

This window displays the test object classes defined in the open project, and 
the operations defined for each test object class. 

 

To access Select View > Class View

Important 
information

This window enables you to do the following:

➤ Add or delete test object classes.

➤ Open the test object class designer.

➤ Open the implementation code for a test object 
operation.

➤ Start a debug session for a test object operation.
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User interface elements are described below:

UI Elements Description

Test Object Classes The list of test object classes defined in the open project.

In this area, you can:

➤ Use the toolbar buttons to add and delete test object 
classes.

➤ Double-click a test object class to open its designer.

Operations The operations defined for the selected test object class. 

In this area, you can:

➤ Double-click an operation to open the test object class 
designer. It opens to the Operations tab (described on 
page 81) with the relevant operation selected.

➤ Right-click and select Implementation Code to open 
the file containing the JavaScript implementation 
function for the operation. The file opens to the 
relevant function.

➤ Right-click and select Debug to open the Debug Test 
Object Operation Dialog Box (described on page 98). 
The test object class and operation are automatically 
selected in the dialog box.
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Project Explorer

This window displays the folders and files that make up the open Web 
Add-in extensibility project. You can double-click files in the project tree to 
open them.

 

To access Select View > Project Explorer

Important 
information

Some standard Visual Studio Shell commands are 
available when you right-click items in the project tree. 
In extensibility projects, there is a strong connection 
between file names, file content, and the location of the 
files. Therefore, commands to add or rename files in the 
project are not available, as this should be done using the 
test object class designers.

For the same reason, you should also avoid using the 
Exclude From Project command, which is available when 
you right-click.
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The Project Explorer tree contains the following:

Tree Node Description

<Project Name> The Web Add-in Extensibility project’s top level node.

Help folder A folder that optionally contains Help (.chm) files.

The files in this folder are referenced from the project’s 
test object configuration XML file.

<Help files> Optional. Help files for QuickTest to use for 
context-sensitive Help for the test object classes you 
define.

Supported file type: .chm

JavaScript folder A folder that contains the project’s JavaScript files. 

The files in this folder are referenced from the project’s 
toolkit configuration XML file.

<Test Object Class 
Name>.js files

The files that contain your extensibility implementation 
JavaScript functions. One JavaScript file is created for 
each test object class that you define.

Note: Any additional JavaScript implementation files 
that you import are also stored in the JavaScript folder.

Res A folder that optionally contains icon files.

The files in this folder are referenced from the project’s 
test object configuration XML file.

<Icon files> Optional. Icon files for QuickTest to use for the test 
object classes you define.

Supported file types: .ico, .exe, .dll

<Project Name>.xml 
file

The project’s toolkit configuration XML file.

<Project 
Name>TestObjects.x
ml file

The project’s test object configuration XML file.
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Import Toolkit Support Set Dialog Box

This dialog box enables you to create a new Extensibility Accelerator project 
based on an existing Web Add-in Extensibility toolkit support set.

 

User interface elements are described below:

To access Select File > Import Toolkit Support Set

Important 
information

The toolkit support set that you want to import must 
have the structure described in "Prerequisites" on 
page 29. 

Relevant tasks "Import an Existing Toolkit Support Set" on page 29

UI Elements Description

Test objects XML file The test object configuration XML file of the toolkit 
support set that you want to import.

New project folder The folder in which to create the new project.

Open imported 
project

Specifies whether to open the new project after the 
import process is completed successfully.

If this option is cleared, then after the import is 
completed, the dialog box remains open, enabling you to 
import and convert additional toolkit support sets to 
Extensibility Accelerator projects.
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Toolkit Support Properties Designer

This designer enables you to define settings that affect how QuickTest treats 
this toolkit support set.

 

To access Select View > Toolkit Support Properties

Important 
information

➤ The information you define in this dialog box is stored 
in the XML files in your toolkit support set.

➤ The settings in this dialog box are optional. If you do 
not set them, QuickTest uses default values.

Relevant tasks "Create or Update Support for a Custom Toolkit" on 
page 27
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User interface elements are described below:

UI Elements Description

Common 
implementation file

The name of a file that contains shared JavaScript 
functions called from your other implementation 
functions. (Optional)

You cannot modify this value directly. 

Use the Import File  button to browse to and select 
the relevant file. If you select a file that is not located in 
the project’s JavaScript folder, a local copy is created in 
that folder. The file must be located in the project’s 
JavaScript folder to be properly deployed.

Stored in: A Control\Settings\Variable element named 
common_file in the toolkit configuration XML file

Toolkit priority The priority of the toolkit. When QuickTest attempts to 
identify the test object class mapped to a custom control, 
it searches in the different toolkits in the order of their 
priority (highest number first).

Note: In this edit box, you can type only numeric 
characters.

Default: 100

Stored in: priority attribute of the Controls element in 
the toolkit configuration XML file

Toolkit description A description of the toolkit. QuickTest displays this 
description in the Add-in Manager dialog box when the 
toolkit support set's environment name is selected.

If you are developing this toolkit support set for 
distribution, include a Provided by clause indicating the 
relevant person or company.

Additionally, you might want to include a version 
number in this description.

Stored in: Controls\Description elements in the toolkit 
configuration XML file
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Test object class 
priority

The priority of the test object classes defined in the test 
object configuration XML file. The priority is used if 
there are conflicts with other XML files (multiple test 
object classes defined with the same name).

Note: In this edit box, you can type only numeric 
characters.

Default: 0 (the lowest priority)

Stored in: Priority attribute of the TypeInformation 
element in the test object configuration XML file

Development mode - 
Override QuickTest 
Object Identification 
definitions

Specifies whether the user is in development mode. 

➤ Select this option when you deploy the toolkit support 
set during development stages. This ensures that if you 
modified attributes of IdentificationProperty elements 
in the test object configuration XML file, QuickTest 
uses all of the changes you made.

➤ Make sure to clear this option before deploying the 
toolkit support set for regular use. This prevents the 
settings in the test object configuration XML file from 
overwriting any changes that the QuickTest user 
makes in the Object Identification dialog box.

For details, see the section on modifying deployed 
support in the HP QuickTest Professional Web Add-in 
Extensibility Developer Guide. 

Stored in: DevelopmentMode attribute of the 
TypeInformation element in the test object configuration 
XML file

UI Elements Description

WebExtensibility.chm::/DeployModify.htm
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Enumerations Designer

This designer enables you to define lists of values that can be used for test 
object operation arguments in the current project.

 

To access Select View > View Enumerations  

Relevant tasks "Design and Debug Test Object Class Operations" on 
page 57

See also "Operations Tab (Test Object Class Designer)" on page 81
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Elements Description

Enumeration Names The name for the list of values.

This area includes:

➤  A toolbar that enables you to add or delete 
enumeration lists.

➤ Name. The name of the enumeration list. 
Click in this box to edit the name.

Stored in: ListOfValues element in the test object 
configuration XML file

Enumeration Values The names and values of the items in the list that is 
currently selected in the Enumeration Names area.

This area includes:

➤  A toolbar that enables you to add, 
delete, or change the order of items in the list.

Adding a value always adds it to the bottom of the list.

➤ Name. The name of the enumeration item. 
Click in this box to edit the name.

➤ Value. The integer value of the enumeration item. 
Click in this box to edit the value.

Default value: The value of the last item in the list + 1

Stored in: ListOfValues\EnumValue element in the test 
object configuration XML file
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4
Supporting a Custom Control

This chapter includes:

Concepts

➤ Base Class Selection on page 44

Tasks

➤ Create or Update Support for a Single Control on page 46

➤ Map a Test Object Class to Application Controls on page 49

➤ Design and Debug Test Object Class Operations on page 57

➤ Design Test Object Class Identification Properties on page 59

➤ Debug Your Test Object Operation Support on page 61

Reference

➤ General Tab (Test Object Class Designer) on page 65

➤ Map to Controls Tab (Test Object Class Designer) on page 74

➤ Operations Tab (Test Object Class Designer) on page 81

➤ Properties Tab (Test Object Class Designer) on page 90

➤ Debug Test Object Operation Dialog Box on page 98
Concepts
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Base Class Selection

When you define a test object class in the General Tab (Test Object Class 
Designer) (described on page 65), you define a base class: a test object class 
that your new one extends. By default, all Web test object classes extend 
WebElement.

The base class that you select determines the test object class’ generic type 
and default operation (unless you define them specifically) and provides the 
following:

➤ An initial set of test object operations, inherited from the base class. Some 
of these are displayed in the Operations tab (described on page 81), in 
which you can override them or add your own test object operations. 

➤ A list of identification properties that you can choose to include in your 
test object class. Some of these are displayed in the Properties tab 
(described on page 90), in which you can also add or modify 
identification property definitions.

➤ If the control you are supporting contains the type of HTML element 
supported by the base class, your test object class also inherits the 
implementation that supports the inherited operations and properties. 
For more information, see the section on extending an existing test object 
class in the HP QuickTest Professional Web Add-in Extensibility Developer 
Guide.

Therefore:

➤ Select a base class that provides operations and properties that are 
relevant to the behavior of the control you are supporting.

➤ Make sure that the control contains an HTML element of the type 
supported by the base class. Otherwise, you need to provide 
implementation for all of the inherited test object operations and 
properties not supported by WebElement.

➤ If the control you are supporting contains the type of HTML element 
supported by the base class, but this is not the element that represents the 
control itself, you must implement a JavaScript function that returns the 
relevant base element.

WebExtensibility.chm::/WebExtDev_extend.htm
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Changing the Base Class

When you change the base class for a test object class, the list of inherited 
operations in the Operations tab and the list of base class properties in the 
Properties tab is automatically updated. Any operations or properties that 
you added, modified, or overrode remain unchanged.

Therefore, if you select a different base class after defining your lists of 
operations and properties, be sure to carefully reconsider these lists. 
Consider the following:

➤ You may have implemented operations or properties that are no longer 
relevant for the new type of class you are extending.

➤ Your test object class might no longer be inheriting test object operations 
that you wanted it to support.

➤ Your test object class might include identification properties that 
previously inherited their implementation from the old base class. You 
must now make sure that the new base class supports this property, 
remove that property from the list, or implement your 
get_property_value function to retrieve its value.

➤ Keep in mind that you inherit the implementation for the operations and 
properties of the new base class only if the control you are supporting 
contains the HTML element supported by that base class, and that you 
must implement a JavaScript function to return the relevant HTML 
element, if that element is not the HTML element representing the 
control.

Tasks
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Create or Update Support for a Single Control

A toolkit support set usually provides support for more than one type of 
custom control.

This task describes how to create support for one type. Perform this task for 
each type of control that you want to support. 

When you save your changes, Extensibility Accelerator validates the 
information. If mandatory data is missing or if conflicts or discrepancies are 
found between information in the different files, the Error List window 
displays messages that explain the problems encountered.  

See also "When Are Your Changes Applied and Saved" on page 26.

This task includes the following steps:

➤ "Prerequisite - Open an existing project or create a new one" on page 47

➤ "Design a test object class to represent your control in QuickTest" on 
page 47

➤ "Map the test object class to the relevant type of controls" on page 47

➤ "Design and debug the test object class operations" on page 47

➤ "Design the test object class’s identification properties" on page 47

➤ "Implement support for recording on the control - Optional" on page 48

➤ "Deploy and test your support" on page 48
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 1 Prerequisite - Open an existing project or create a new one

For details, see "Open, create, or import an extensibility project" on 
page 28.

 2 Design a test object class to represent your control in 
QuickTest

 a Create a new test object class or open an existing one. 

➤ To create a new test object class, click the Add button in the Class 
View.

➤ To open an existing test object class, double-click it in the Class 
View.

 b The General tab of the test object class designer opens. Define a name 
for your test object class, specify the test object class it extends, and 
optionally, define additional general information.

For details, see "General Tab (Test Object Class Designer)" on page 65.

 3 Map the test object class to the relevant type of controls

For details, see "Map a Test Object Class to Application Controls" on 
page 49.

 4 Design and debug the test object class operations

For details, see "Design and Debug Test Object Class Operations" on 
page 57.

 5 Design the test object class’s identification properties

For details, see "Design Test Object Class Identification Properties" on 
page 59.
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 6 Implement support for recording on the control - Optional

If you want to support recording operations on the custom control, you 
must develop that support manually, as described in the section on 
implementing support for recording in the HP QuickTest Professional Web 
Add-in Extensibility Developer Guide.

Caution: In extensibility projects, there is a strong connection between 
file names, the location of the files in the project, and the content of 
different files. Therefore, when you edit files manually, make sure you do 
not create discrepancies.

 7 Deploy and test your support

For details, see "Deploy a Toolkit Support Set" on page 105.

WebExtensibility.chm::/WebExtDev_record.htm
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Map a Test Object Class to Application Controls

This task describes how to define the mapping rules for a test object class. 
The mapping rules indicate the types of controls for which QuickTest should 
use the test object class. 

Note: This task is part of a higher-level task. For details, see "Create or 
Update Support for a Single Control" on page 46.

This task includes the following steps:

➤ "Prerequisites" on page 49

➤ "Create mapping rules automatically" on page 50

➤ "Edit mapping rules manually - Optional" on page 55

➤ "Manually add advanced types of identification information - Optional" 
on page 55

➤ "Test your mapping rules on an application and update them if necessary" 
on page 56

 1 Prerequisites

 a Plan your support. 

For details, see the section on planning QuickTest support for your 
toolkit in the HP QuickTest Professional Web Add-in Extensibility 
Developer Guide.

 b Open an application that contains the relevant controls.

With an Extensibility Accelerator project open, run one or more 
applications that contain the controls you want to support. Make sure 
that the page is fully loaded and the relevant controls are visible. (You 
must run Extensibility Accelerator and open a project before you open 
the Web browsers.)

WebExtensibility.chm::/WebExtPlan.htm
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 2 Create mapping rules automatically

 a In the Map to Controls Tab (Test Object Class Designer) (described on 
page 74), click Select Controls. Extensibility Accelerator is hidden, and 
two buttons are displayed at the top of the screen: Create Rules and 
Cancel. 

 b Move your mouse over your open applications. The mouse pointer is 
converted to a pointing hand. 

Each control that you move over is highlighted in the application, and 
the name of the HTML element that represents the control is 
displayed. In the image below, the INPUT HTML element is displayed 
for a highlighted radio button control.
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Tip: In many cases, you can hold the left CTRL key to change the 
pointing hand to a standard pointer and perform operations in your 
application, such as navigating to different Web pages, clicking links, 
selecting edit boxes to enter information, selecting from drop-down 
lists and so on. (Keep in mind that the browser behavior might be 
affected by the fact that the CTRL key is pressed.)

If a specific page does not load properly when navigating to it this way, 
load that page in an additional browser before beginning the session 
for selecting controls.

If you navigate to a different Web page, the highlighting process 
continues on the page that opens, after it is fully loaded.  
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 c Click on a control of a type that you want to support with this test 
object class. A Selection Dialog Box (described on page 79) opens, 
displaying the properties of the HTML element that represents the 
selected control. 

The top part of this dialog box displays additional elements in the 
control’s HTML hierarchy. 

 d To view the properties of a different HTML element, or to select it to 
represent the control, select the element from the displayed hierarchy.
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 e Click Select. The selected control is highlighted in the application. In 
the image below, the radio button controls are selected.

 f Select additional controls that need to be supported by the same test 
object class. 

Try to select several controls that need to be treated as the same type of 
control and share common properties, but are not identically 
implemented. The quality and accuracy of the rules that Extensibility 
Accelerator creates is affected by the number of controls you select, 
and their diversity.

 g To deselect a control, click the control and then click Delete in the 
Selection Dialog Box. 

 h To specify a different HTML element to represent a selected control, 
click the control, select the appropriate element from the hierarchy 
displayed in the Selection Dialog Box, and click Apply.
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 i To complete the process, click Create Rules. 

The following happens: 

➤ Extensibility Accelerator creates the mapping rules for this test 
object class based on properties that are common to all of the 
controls you selected. If a large majority of the selected controls 
share common properties, the remaining controls might be ignored 
when creating the rules.  

Caution: Any rules previously contained in the Map to Controls tab 
are now replaced.

➤ If the controls do not have enough properties in common, no rules 
are created. 

Tip: If you want to use the same test object class to support different 
types of controls, use this automatic process to create rules that 
identify one type of control. Then edit the rules manually to include 
additional types, for example, by adding rules with Or or And 
NotEqual logic.

➤ The highlighting is removed from the application.

➤ The rules are displayed in the rule editor area in the Map to Controls 
tab and added to the relevant Identification element in the toolkit 
configuration XML file, in Conditions elements with 
type=IdentifyIfPropMatch.

Alternatively, click Cancel to end the process without creating rules.
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 3 Edit mapping rules manually - Optional

In the Rule Editor Area (Map to Controls tab), you can make manual 
changes to the automatically created rules, or create your own rules. 

For example, you can:

➤ Add and delete rules.

➤ Change the order or logic of rules.

➤ Generalize the rules by defining regular expressions for the property 
values.

The rules are stored in the relevant Identification element in the toolkit 
configuration XML file, in Conditions elements with 
type=IdentifyIfPropMatch.

For information on the options in the rule editor, see the Rule Editor Area 
section in "Map to Controls Tab (Test Object Class Designer)" on page 74.

 4 Manually add advanced types of identification information - 
Optional

The rules that you create in the Map to Controls tab are stored in 
Conditions elements with type=IdentifyIfPropMatch in the Identification 
element for the test object class.

If you need to create HTMLTags elements or different types of Conditions 
elements, or to use a JavaScript identification function, you must define 
these manually in the XML and JavaScript files. For details, see the section 
on teaching QuickTest to identify the test object class to use for a custom 
Web control in the HP QuickTest Professional Web Add-in Extensibility 
Developer Guide.

WebExtensibility.chm::/WebExtDev_identify.htm
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 5 Test your mapping rules on an application and update them 
if necessary

Follow one of the procedures described below:

To test your rules without modifying:
1  In the Map to Controls Tab (Test Object Class Designer) described on 

page 74, click Test Rules. 

The following happens:

➤ Extensibility Accelerator is hidden.

➤ All of the controls that match the mapping rules in all open Web 
applications, are highlighted. 
In many cases you can open or navigate to additional applications or 
Web pages at this point. Once the application or page loads 
successfully, the matching controls are highlighted in it as well.  
If a specific page does not load properly when navigating to it at this 
point, load that page in an additional browser before beginning the 
session for testing the rules.
Note: Controls are highlighted only in browsers that are opened after 
you open a project in Extensibility Accelerator.

➤ A Done button is displayed at the top of the screen.

2  Click Done. The Map to Controls tab opens and the highlighting is 
removed from the applications.

To test your rules and update them if necessary:
1  Open the applications on which you want to test the rules, and make 

sure that the page is fully loaded and the relevant controls are visible. 
(You must run Extensibility Accelerator and open a project before you 
open the Web browsers.)

2  In the Map to Controls Tab (Test Object Class Designer) described on 
page 74, click Test & Refine. 

The following happens:

➤ Extensibility Accelerator is hidden.

➤ The Create Rules and Close buttons are displayed at the top of the 
screen.

➤ A session for automatically creating rules begins. All of the controls 
that match the existing mapping rules are marked as selected in all 
open Web applications. 

3  Continue as described in step 2 b, above.



Chapter 4 • Supporting a Custom Control

57

Design and Debug Test Object Class Operations 

This task describes how to define, implement, and debug the operations that 
your test object class supports.

Note: This task is part of a higher-level task. For details, see "Create or 
Update Support for a Single Control" on page 46.

This task includes the following steps:

➤ "Define the list of operations supported by this test object class" on 
page 57

➤ "Design the JavaScript functions that implement the test object 
operations" on page 58

➤ "Debug the operations" on page 59

 1 Define the list of operations supported by this test object 
class 

In the Operations Tab (Test Object Class Designer) described on page 81, 
do the following:

➤ Add or remove operations, or select base class operations to override. 

Keep in mind that if the following conditions are met, you need to 
override all of the base class operations that are not supported by the 
WebElement test object class:

➤ The control you are supporting is not represented by the type of 
HTML element supported by the base class.

➤ You did not implement a get base element function that returns 
such an element to QuickTest.

In this case, operations that you do not override will be available when 
editing tests, but will not be implemented. Including these operations 
in test steps will result in run-time errors. For more information, see 
the section on extending an existing test object class in the 
HP QuickTest Professional Web Add-in Extensibility Developer Guide.

WebExtJavaScriptReference.chm::/js_get_base_element.htm
WebExtensibility.chm::/WebExtDev_extend.htm


Chapter 4 • Supporting a Custom Control

58

➤ For operations that you add or override, define the method signature 
and optionally, additional information.

➤ Specify the default operation for this test object class (optional). 

If you do not select a default operation, the base class’s default 
operation is used.

How these definitions affect the files:

➤ The information defined in this tab is stored in the toolkit support set 
XML files. 

➤ JavaScript function stubs for new operations are added to the relevant 
JavaScript file.

➤ JavaScript function signatures for operations whose signature you 
modify are updated.

➤ JavaScript functions for deleted operations are not removed from the 
JavaScript file.

For more details, see "When Are Your Changes Applied and Saved" on 
page 26.

 2 Design the JavaScript functions that implement the test 
object operations

 a In the Operations Tab (Test Object Class Designer) described on 
page 81, select the relevant operation and click the Implementation 
Code button. The JavaScript file opens to the relevant JavaScript 
function in a JavaScript Editor, described on page 16. 

Alternatively, you can open the relevant JavaScript file by 
double-clicking it in the Project Explorer.

By default, the name of the JavaScript file is <test object class 
name>.js, and the name of the function you need to implement is the 
same as the test object operation name. You can modify these names 
in the advanced options in the Operations Tab (Test Object Class 
Designer). If you update the function name in the designer or in the 
JavaScript file, ensure that you update it in the other location as well.
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 b Implement the JavaScript functions to perform the test object 
operations on the control. For details, see the section on implementing 
support for test object methods in the HP QuickTest Professional Web 
Add-in Extensibility Developer Guide. 

You must implement JavaScript functions for all new and overridden 
operations. 

 3 Debug the operations

For details, see "Debug Your Test Object Operation Support" on page 61.

Design Test Object Class Identification Properties

This task describes how to define and implement support for the 
identification properties of your test object class.

Note: This task is part of a higher-level task. For details, see "Create or 
Update Support for a Single Control" on page 46.

This task includes the following steps:

➤ "Define the list of identification properties for your test object class" on 
page 60

➤ "Specify the QuickTest functionalities for which the properties are used" 
on page 60

➤ "Define advanced options for identification property support - Optional" 
on page 60

➤ "Implement the JavaScript function that retrieves the identification 
property values from the run-time object" on page 60

WebExtensibility.chm::/Implement_Support_TO_Methods.htm
WebExtensibility.chm::/Implement_Support_TO_Methods.htm
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 1 Define the list of identification properties for your test 
object class

In the Properties Tab (Test Object Class Designer) described on page 90, 
add or remove properties or select base class properties to inherit and 
include in the list. 

 2 Specify the QuickTest functionalities for which the properties 
are used

Add properties from the Properties list on the left side of the Properties 
Tab to the different groups on the right. This indicates which properties 
are included in test object descriptions, which can be verified in 
checkpoints and used in output values, which should be used for Smart 
Identification, and so on.

 3 Define advanced options for identification property support 
- Optional

For details, see the Advanced Options section of the Properties Tab (Test 
Object Class Designer) described on page 97.

 4 Implement the JavaScript function that retrieves the 
identification property values from the run-time object

 a In the Project Explorer, double-click the relevant JavaScript file. 
The file opens in a JavaScript Editor.

By default, the name of the JavaScript file is <test object class 
name>.js, and the name of the function you need to implement is 
get_property_value. You can modify these names in the advanced 
options in the Properties Tab (Test Object Class Designer).
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 b Implement the JavaScript function to retrieve the run-time values for 
the identification properties. For details, see the section on 
implementing support for identification properties in the HP QuickTest 
Professional Web Add-in Extensibility Developer Guide. 

If the following conditions are met, the test object class inherits the 
get_property_value implementation from the base class. In that case, 
the function that you write does not have to retrieve a value for this 
property.

➤ The control you are supporting is represented by the type of HTML 
element supported by the base class, or it contains such an element 
and you implemented a function that returns that element to 
QuickTest.

➤ The base class supports an identification property by the same 
name. 

Debug Your Test Object Operation Support

This task describes how to run your test object operations from within 
Extensibility Accelerator, so that you can debug your JavaScript 
implementation functions using the Microsoft Visual Studio Shell 
debugging tools.

Extensibility Accelerator performs the test object operation on a control that 
you select in an application, simulating the way QuickTest performs the 
operation in a step. This runs the JavaScript function that you designed to 
support the operation, enabling you to debug it. You do not need to have 
QuickTest installed to use the Extensibility Accelerator debugging 
capabilities.

Note: This task is part of a higher-level task. For details, see "Create or 
Update Support for a Single Control" on page 46.

WebExtensibility.chm::/WebExtDev_IDProps.htm
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 1 Prerequisites

 a Enable script debugging in your browser.

For example: In Internet Explorer 6.0 or 7.0, select Tools > Internet 
Options. In the Advanced tab, clear the Disable Script Debugging 
options in the Browsing group.

 b Open the application on which you want to run and debug your 
operation, and make sure that the page is fully loaded and the relevant 
control is visible. (You must run Extensibility Accelerator and open a 
project before you open the Web browser.)

 c Make sure that the rules displayed in the rule editor for your test object 
class correctly identify the control on which you want to debug the 
operation.

You can click Test Rules in the Map to Controls Tab (Test Object Class 
Designer) described on page 74 and verify that the control is 
highlighted in the application.

 2 Prepare your JavaScript function for debugging

In the JavaScript function that you want to debug, add the following line 
at the point where you want the debugging session to begin.

debugger;

 3 In the Debug Test Object Operation dialog box, select the 
test object class operation to run

 a Do one of the following to open the dialog box (described on page 98):

➤ Right-click the operation in the Class View and select Debug. In this 
case, the dialog box opens with the test object class and operation 
selected.

➤ Select Project > Debug Test Object Operation. In the dialog box that 
opens, select the test object class and the operation that you want to 
run. 
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 b If the operation you selected receives arguments, a table displays the 
argument names, whether they are optional, and the type of value 
they require. If necessary, enter the argument values to pass to the 
operation.

 4 Select an application control on which to run the operation

 a In the Debug Test Object Operation Dialog Box, click Select Control. 
Extensibility Accelerator is hidden, all of the controls that match the 
mapping rules in all open Web applications, are highlighted, and a 
Cancel button is displayed at the top of the screen. 

In many cases you can open or navigate to additional applications or 
Web pages at this point. Once the application or page loads 
successfully, the matching controls are highlighted in it as well. (To 
navigate at this point, you need to hold down the CTRL key.) 

If a specific page does not load properly when navigating to it at this 
point, load that page in an additional browser before clicking Select 
Control.

Note: Controls are highlighted only in browsers that are opened after 
you open a project in Extensibility Accelerator.

 b Click the control on which you want to run the operation. You must 
select one of the highlighted controls.

The highlighting is removed from the application, Extensibility 
Accelerator opens and the Debug Test Object Operation Dialog Box is 
displayed. If Extensibility Accelerator does not come back into focus, 
activate it from the Task Bar.  
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 5 Run the Operation

In the Debug Test Object Operation Dialog Box, click Run Operation. 
Extensibility Accelerator begins to run the test object operation on the 
control you selected, calling the operation’s JavaScript implementation 
function. 

The run session pauses at the debugger; line in the JavaScript file.

From this point, you can debug your JavaScript functions as you would in 
a regular Microsoft Visual Studio JavaScript debugging session. 

For example, you can add breakpoints, use step commands and other 
Debug menu commands and toolbars, use the various debugging-related 
windows such as Watch and Output, and so on. For more information, 
see the MSDN Visual Studio Help.  

Note: _util methods are relevant only when running in the QuickTest 
context. Therefore, if the JavaScript functions that you run include calls 
to _util methods, these calls are not carried out when they are 
encountered during the debugging process. Instead, a message is printed 
in the Output window specifying the method call and the parameters it 
passed. 

 6 End the debugging session

To end the debugging session, allow the operation to run until 
completion, or select Debug > Stop Debugging in Extensibility 
Accelerator.

When you are finished debugging, make sure to remove all debugger; 
lines from your JavaScript functions.

Reference
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General Tab (Test Object Class Designer)

This tab enables you to define general details about the test object class that 
you want QuickTest to use for a custom control.

The information you define in this tab is stored in the XML files in your 
toolkit support set. The options in the main part of this tab are stored in the 
test object configuration XML file. The advanced options are stored in the 
toolkit configuration XML file.
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The image below displays the advanced options available in the General tab 
of the Test Object Class designer.
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The General tab contains the following:

➤ "Basic Options" on page 68

➤ "Advanced Options" on page 71

To access In the Class View, add a new test object class or 
double-click an existing one.

Important 
information

Make sure to visit each tab in the test object class 
designer to ensure that all of the test object class details 
are defined correctly.

A red asterisk next to the name of the tab acts as a 
reminder that you have not yet visited this tab.

Relevant tasks "Create or Update Support for a Single Control" on 
page 46

See also "Custom Toolkit Support Sets" on page 24
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Basic Options

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Elements Description

Name The name of the test object class that you want QuickTest to 
use to represent the custom control.

This name is fundamental to the infrastructure of the 
support you are creating for the custom control. It 
determines:

➤ The name of the JavaScript file created for this test 
object’s implementation functions. This file name is 
displayed in the Default implementation file advanced 
option. It is stored in the relevant Settings\Variable 
element in the toolkit configuration XML file.

➤ The Name attribute of the ClassInfo element in the test 
object configuration XML file.

➤ The TestObjectClass attribute of the Control element in 
the toolkit configuration XML file.

If you rename the test object class, all of the above are 
modified automatically. (It is therefore recommended to 
save such a change immediately.)

Note: This edit box supports only English letters, numeric 
characters, spaces, hyphens, and underscores. If you enter 
other characters, they are ignored.

Description A description of the custom control you are supporting. 

This description is intended for your internal 
documentation purposes, it is not displayed in 
QuickTest Professional.

Note: This edit box supports only English letters, numeric 
characters, spaces, hyphens, and underscores. If you enter 
other characters, they are ignored.

Stored in: ClassInfo\Description element in the test object 
configuration XML file
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Icon file The name of the icon file that you want QuickTest to display 
for this test object class in tests, dialog boxes, and run 
session results.

Use the Import Icon button to specify the relevant file. 

Default icon: QuickTest’s WebElement icon  

Stored in: ClassInfo\IconInfo element in the test object 
configuration XML file

Import Icon Enables you to browse to and select the icon file. You can 
select an icon from an .ico, .dll, or .exe file. 

If the icon you select is not currently stored in the project’s 
Res folder, a local copy is created in that folder. The file must 
be located in the project’s Res folder to be properly 
deployed.

Note: Avoid importing large .exe or .dll files, as these are 
added to your toolkit support set and deployed with it.

<icon> An image of the icon you selected or the default icon.

Help file The name of the .chm Help file that you want QuickTest to 
use for context-sensitive Help on this test object class.

Use the Import Help button to specify the relevant file. 

Stored in: ClassInfo\HelpInfo element in the test object 
configuration XML file

Import Help Enables you to browse to and select the .chm Help file.

If the file you select is not currently stored in the project’s 
Help folder, a local copy is created in that folder. The file 
must be located in the project’s Help folder to be properly 
deployed.

Context ID The numeric value that indicates the help topic to open 
within the specified Help file.

Stored in: ClassInfo\HelpInfo element in the test object 
configuration XML file

UI Elements Description
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Base class The test object class this class extends. By default all Web 
test object classes extend WebElement.

The base class that you select determines the default Generic 
type, the initial set of operations that your test object class 
includes, and a list of identification properties that you can 
choose to include in your test object class.

If the control you are supporting contains the type of HTML 
element supported by the base class, the test object class also 
inherits the implementation that supports the inherited 
operations and properties.

For more information, see "Base Class Selection" on page 44.

Note: If the control contains an HTML element of the type 
supported by the base class, but this is not the element that 
represents the control itself, be sure to define the Function to 
get base element in the advanced options.

Stored in: BaseClassInfoName attribute of the ClassInfo 
element in the test object configuration XML file

Generic type The type of control you are supporting.

The generic type is used for object filtering in QuickTest and 
for creating documentation strings for the Documentation 
column of the Keyword View (unless you define them 
specifically in the test object operation definition).

Default: The base test object class’s generic type (this value is 
selected automatically when you select a base class)

Stored in: GenericTypeID attribute of the ClassInfo element 
in the test object configuration XML file

Advanced Options Expands to display the advanced options. If you do not 
define these options, QuickTest uses their default values.

UI Elements Description
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Advanced Options

User interface elements are described below:

UI Elements Description

Default 
implementation file

The file from which QuickTest calls implementation 
functions for this test object class by default. 

This is a read only option, set by Extensibility Accelerator 
to: JavaScript\<test object class name>.js. 

If you modify the name of the test object class, this 
option is automatically updated to match the new name.

If when the file is created or renamed, a file by that name 
already exists in the file system, a number (for example, 
_2) is appended to the file name.

Stored in: A Control\Settings\Variable element named 
default_imp_file in the toolkit configuration XML file

File to get base 
element

The file that contains the function that returns the base 
element (optional).

You cannot modify this value directly. 

Use the Import File  button to browse to and select 
the relevant file. If you select a file that is not located in 
the project’s JavaScript folder, a local copy is created in 
that folder. The file must be located in the project’s 
JavaScript folder to be properly deployed.

Use the Clear  button to clear the edit box. 

The corresponding XML attribute in the toolkit 
configuration XML file is cleared, but the JavaScript file is 
not removed from the project.

Default: The Default implementation file

Stored in: A Control\Settings\Variable element named 
file_for_func_to_get_base_elem in the toolkit 
configuration XML file
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Function to get base 
element

The function that you implement to return the base 
element. Access to the base element enables QuickTest to 
use the base class’s implementation for inherited test 
object operations and properties. 

You need to specify and implement this function if the 
control you are supporting contains an HTML element of 
the type supported by the base class, but this is not the 
element that represents the control itself. If you do not 
provide this function, you need to provide 
implementation for any inherited test object operations 
and properties that are not supported by WebElement 
and you want to support. 

Stored in: A Control\Settings\Variable element named 
func_to_get_base_elem in the toolkit configuration XML 
file

Learn test objects of 
this class

Indicates whether QuickTest should learn this control.

Possible values: 

➤ Yes

➤ No

➤ IfChildren - learn the control only if it has children.

Default: Yes

Stored in: learn_control attribute of the Learn element in 
the toolkit configuration XML file

Learn test object’s 
children

Indicates whether QuickTest should learn the children of 
this control.

Possible values: 

➤ Yes

➤ No

➤ CallFilterFunc - the function specified below performs 
the filtering. 

Default: Yes

Stored in: learn_children attribute of the Learn element 
in the toolkit configuration XML file

UI Elements Description
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Filter function file 
name

The file that contains the filter function (optional).

You cannot modify this value directly. 

Use the Import File  button to browse to and select 
the relevant file. If you select a file that is not located in 
the project’s JavaScript folder, a local copy is created in 
that folder. The file must be located in the project’s 
JavaScript folder to be properly deployed.

Use the Clear  button to clear the edit box. 

The corresponding XML attribute in the toolkit 
configuration XML file is cleared, but the JavaScript file is 
not removed from the project.

Default: The Default implementation file

Stored in: file_name attribute of the Learn element in the 
toolkit configuration XML file

Filter function name The function that performs the filtering.

You need to specify and implement this function if you 
selected the CallFilterFunc value for the Learn test 
object’s children option. 

Stored in: function attribute of the Learn element in the 
toolkit configuration XML file

Display this test 
object class in the 
Object Spy

Indicates whether the Object Spy displays this test object 
class. 

Default: Yes 

UI Elements Description
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Map to Controls Tab (Test Object Class Designer)

This tab enables you to define rules that indicate the types of controls this 
test object class supports. The tab contains a rule editor area and buttons 
that you can use to create rules automatically and to test the rules on an 
application.

➤ To create the rules automatically and to test rules, follow the process 
described in "Map a Test Object Class to Application Controls" on 
page 49.

➤ To edit the rules manually, use the toolbar and UI elements within the 
rule editor area. 
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The Map to Controls tab contains the following:

➤ "Buttons" on page 76 

➤ "Rule Editor Area" on page 76

To access 1  In the Class View, add a new test object class or 
double-click an existing one.

The test object class designer opens.

2  In the test object class designer, select the Map to 
Controls tab.

Important 
information

➤ The rules that you create in this tab are stored in the 
toolkit configuration XML file. They are stored in 
Conditions elements with type=IdentifyIfPropMatch in 
the Identification element for this test object class.

➤ If you need to create HTMLTags elements or 
different types of Conditions elements, or to use a 
JavaScript identification function, you must define 
these manually in the XML and JavaScript files. For 
details, see the reference in See also below. 

➤ If the toolkit configuration XML file contains other 
types of identification information for the test 
object class, such as HTMLTags elements, or other 
types of Conditions elements, that information is 
not displayed in this tab.

➤ Make sure to visit each tab in the test object class 
designer to ensure that all of the test object class 
details are defined correctly.

A red asterisk next to the name of the tab acts as a 
reminder that you have not yet visited this tab.

Relevant tasks "Map a Test Object Class to Application Controls" on 
page 49

See also ➤ The section on teaching QuickTest to identify the test 
object class to use for a custom Web control in the 
HP QuickTest Professional Web Add-in Extensibility 
Developer Guide. 

➤ "Selection Dialog Box" on page 79

WebExtensibility.chm::/WebExtDev_identify.htm
WebExtensibility.chm::/WebExtDev_identify.htm


Chapter 4 • Supporting a Custom Control

76

Buttons

Rule Editor Area

This area displays the mapping rules and enables you to edit them manually. 
For example, you can:

➤ Add and delete rules.

➤ Change the order or logic of rules.

➤ Generalize the rules by defining regular expressions for the property 
values.

UI Elements Description

Select Controls Starts a session for automatically creating mapping rules. 
You create the rules by pointing to controls of the 
relevant type in your application.

For task details, see "Create mapping rules automatically" 
on page 50.

Clear Rules Deletes all of the rules in the rule editor area (and in the 
corresponding Identification element in the toolkit 
configuration XML file).

Test Rules Highlights all of the controls that match the mapping 
rules in all open Web applications.  

For task details, see "Test your mapping rules on an 
application and update them if necessary" on page 56.

Test & Refine Starts a session for automatically creating rules. All of the 
controls that match the currently defined rules are 
marked as selected in all open Web applications. 

For task details, see "Test your mapping rules on an 
application and update them if necessary" on page 56.
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Elements Description

This toolbar contains the following buttons: 

➤ Add Single Condition Below.

➤ Add Single Condition Above.

➤ Add Grouped Conditions Below.

➤ Add Grouped Conditions Above.

➤ Delete Selected Element.

➤ Move Selected Element Down.

➤ Move Selected Element Up.

<rule containers> Rectangles that contain single rules or grouped rules. To 
select a rule or group of rules, click its container.
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<rules> A single rule is made up of the following elements:

➤ <property name>. The name of the HTML property 
checked in this rule.

Click to select from a list of common property names 
or edit this value.

➤ Equal / Not Equal. Indicates whether the value of the 
property must be equal or not equal to the expected 
value to conform to the rule.

Click to switch between Equal and Not Equal.

➤ <expected value>. The value to compare to the value 
of the control’s HTML property in the application.

A regular expression icon  is displayed if you 
specified that this value should be treated as a regular 
expression.

Click to edit this value. When you edit the expected 
value, additional options are displayed:

➤ RegExp. Indicates whether the expected value 
should be treated as a regular expression.
Default: false

➤ Trim. Indicates whether QuickTest should remove 
leading and trailing spaces from the property value 
and the expected value before evaluating the rule.
Default: true

Click to switch between true and false values for these 
rule attributes. (A toggle button that is on indicates 
the value true.)

AND/OR Indicates whether to use And or Or logic for the set of 
rules in the group.

Click to switch between AND and OR.

UI Elements Description
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Selection Dialog Box
This dialog box opens when you click a Web control during a session for 
selecting controls to automatically create mapping rules for a test object 
class. It enables you to specify whether to include the control in the set of 
controls that determines the rules that are created.

The dialog box displays the HTML details for the control. You can specify a 
different HTML element to represent this control by selecting it in the 
displayed hierarchy.

 

To access Click Select Controls in the Map to Controls tab of the 
test object class designer, and then click on a control in a 
Web application.

Relevant tasks "Map a Test Object Class to Application Controls" on 
page 49

See also "Map to Controls Tab (Test Object Class Designer)" on 
page 74
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Elements Description

<HTML element 
tree>

The name of the HTML element that represents the 
selected application control (highlighted). If relevant, 
additional elements in the HTML hierarchy are displayed 
as well.

You can select a different HTML element in the hierarchy 
to represent the application control. 

Properties The selected HTML element’s property names and values.

Select Selects this control and include it in the set of controls 
that determines the rules that are created in this session.

The dialog box closes and the control is highlighted in 
the application.

Available when: The control is not currently selected.

Apply Updates the set of selected controls, to use the HTML 
element selected in the hierarchy to represent this 
control.

The dialog box closes and the control is highlighted in 
the application.

Available when: The control is currently selected.

Delete Removes this control from the set of controls that 
determines the rules that are created in this session.

The dialog box closes and the control is not highlighted 
in the application. 

Available when: The control is currently selected.

Cancel Closes this dialog box without changing the set of 
selected controls.
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Operations Tab (Test Object Class Designer)

This tab enables you to design the operations your test object class supports. 
You can:

➤ Define the list of operations supported by this test object class. 

You can add or remove operations or select base class operations to 
override. 

➤ For operations that you add or override, you can edit the method 
signature and define additional information.

➤ Specify the default operation for this test object class (optional). 

The information you define in this tab is stored in the XML files in your 
toolkit support set. 
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JavaScript function stubs are added to the relevant JavaScript file for each 
operation that you add or override. Click the Implementation Code button 
to access the function and implement it to support the operation.
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The image below displays the advanced options available in the Operations 
tab of the Test Object Class designer.

 

To access 1  In the Class View, add a new test object class or 
double-click an existing one. 

The test object class designer opens.

2  In the test object class designer, select the Operations 
tab.

Important 
information

➤ You can select an inherited operation as the test object 
class’s default operation.

➤ You cannot modify any definitions of an inherited 
operation.

➤ Advanced options are not available for inherited 
operations.

➤ Make sure to visit each tab in the test object class 
designer to ensure that all of the test object class 
details are defined correctly.

A red asterisk next to the name of the tab acts as a 
reminder that you have not yet visited this tab.

Relevant tasks "Design and Debug Test Object Class Operations" on 
page 57

See also The section on implementing support for test object 
methods in the HP QuickTest Professional Web Add-in 
Extensibility Developer Guide. 

WebExtensibility.chm::/Implement_Support_TO_Methods.htm
WebExtensibility.chm::/Implement_Support_TO_Methods.htm
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The Operations tab contains the following areas:

➤ "Operation List Area" on page 84

➤ "Operation Details Area" on page 85

➤ "Operation Arguments Area" on page 86

➤ "Advanced Options Area" on page 88

Operation List Area

Displays operations you add to the test object class, and some base class 
operations you can choose to override. 

➤ Inherited operations appear in italic font and cannot be modified.

➤ New or overridden operations appear in regular font. You can edit the 
methods signature in other areas of this tab.

Stored in: Operation elements in the test object configuration XML file. 
A JavaScript function stub is added to the relevant JavaScript file for each 
new or overridden operation. You must implement this function to 
support the operation.

This area also contains a toolbar with the following buttons: 

UI Elements Description

Add. Adds a new operation to the test object class 
definition. 

Delete. Deletes the selected operation from the test object 
definition in the test object configuration XML file.

The corresponding JavaScript functions are not deleted.

If you delete an overriding operation, its signature 
appears in italic font again. 

Override Creates a new operation that will override the one 
inherited from the base class. 

The operation signature font changes to regular text and 
the operation details in this tab become editable.
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Operation Details Area

In this area you define (or view) the name, description, and return type of 
the operation selected in the operation list area.

In addition, you can select the default operation and access the JavaScript 
function that implements the operation.

User interface elements are described below:

UI Elements Description

Name The test object operation’s name. 

If you rename an operation, the name of it’s JavaScript 
implementation function is changed as well. (It is 
therefore recommended to save this change 
immediately.)

Note: This edit box supports only English letters, 
numeric characters, spaces, hyphens, and underscores. If 
you enter other characters, they are ignored.

Stored in: 

➤ Operation element in the test object configuration 
XML file

➤ Method element in the toolkit configuration XML file 
- mapped to the JavaScript implementation function

Description A description of the operation. This description is 
displayed in QuickTest tooltips.

Note: This edit box supports only English letters, 
numeric characters, spaces, hyphens, and underscores. If 
you enter other characters, they are ignored.

Stored in: Operation\Description element in the test 
object configuration XML file

Return type The type of value that the operation returns.

Stored in: Operation\ReturnValueType\Type element in 
the test object configuration XML file
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Operation Arguments Area

In this area you define (or view) the arguments of the operation selected in 
the operation list area. 

Stored in: Argument element in the test object configuration XML file

User interface elements are described below:

Implementation Code Opens the JavaScript file to the relevant JavaScript 
function. 

A JavaScript function stub is added to the file for each 
new or overridden operation.

Default operation Indicates whether the operation is the default operation 
for this test object class.

Default: The base class’s default operation

Stored in: DefaultOperationName attribute of ClassInfo 
element in the test object configuration XML file

UI Elements Description

This toolbar contains Add and Delete buttons, and Up 
and Down buttons, used to set the order of the 
arguments.

Name The argument name.

Stored in: Name attribute of the Argument element

Direction Specifies whether this argument is an input argument or 
an output argument.

Stored in: Direction attribute of the Argument element

Type The type of the argument’s value. 

This option displays a list of possible types from which 
you can choose. The list also includes any enumerations 
that you define in the Enumerations Designer (described 
on page 40).

Stored in: Type element within the Argument element

UI Elements Description
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Optional Specifies whether the argument is optional. 

If you define optional arguments, the must come after 
any mandatory arguments that the operation has.

Stored in: IsMandatory attribute of the Argument 
element

Default The default value for the argument. Only relevant if the 
argument is optional.

Stored in: DefaultValue attribute of the Argument 
element

LOV Indicates whether QuickTest dynamically displays a list 
of possible values for this argument when editing tests. 

If you select this option, you must implement a 
get_list_of_values JavaScript function to return the 
possible values from the control. By default, QuickTest 
calls this function from the default implementation file 
defined for this test object class (General tab, advanced 
options).

Stored in: DynamicListOfValues attribute of the 
Argument element

Description A description of the argument. 

This description is intended for your internal 
documentation purposes, it is not displayed in 
QuickTest Professional.

Stored in: Description attribute of the Argument element

UI Elements Description
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Advanced Options Area

Click the Advanced Options panel to expand it. 

This area enables you to set advanced options for the operation currently 
selected in the operation list. If you do not define these options, QuickTest 
uses their default values.

User interface elements are described below:

UI Elements Description

Icon file The name of the icon file that you want QuickTest to 
display for this operation in the run session results.

Use the Import Icon button to specify the relevant file. 

Default: A QuickTest default icon

Stored in: Operation\IconInfo element in the test object 
configuration XML file

If you select an icon within a .dll or .exe file, the index of 
the icon’s location in the file is also stored in the IconInfo 
element.

Import Icon Enables you to browse to and select the icon file. You can 
select an icon from an .ico, .dll, or .exe file. 

If the icon you select is not located in the project’s Res 
folder, a local copy is created in that folder. The file must 
be located in the project’s Res folder to be properly 
deployed.

Note: Avoid importing large .exe or .dll files, as these are 
added to your toolkit support set and deployed with it.

<icon> An image of the icon you selected or the default icon.

Help file The name of the .chm Help file that you want QuickTest 
to use for context-sensitive Help on this test object class.

Use the Import Help button to specify the relevant file. 

Stored in: ClassInfo\HelpInfo element in the test object 
configuration XML file
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Import Help Enables you to browse to and select the .chm Help file.

If the file you select is not located in the project’s Help 
folder, a local copy is created in that folder. The file must 
be located in the project’s Help folder to be properly 
deployed.

Implementation file 
name

The file that contains the implementation function 
(optional).

You cannot modify this value directly. 

Use the Import File  button to browse to and select 
the relevant file. If you select a file that is not located in 
the project’s JavaScript folder, a local copy is created in 
that folder. The file must be located in the project’s 
JavaScript folder to be properly deployed.

Use the Clear  button to clear the edit box. 

The corresponding XML attribute in the toolkit 
configuration XML file is cleared, but the JavaScript file is 
not removed from the project.

Default: The Default implementation file defined in the 
general tab

Stored in: Method element in the toolkit configuration 
XML file

Implementation 
function name

The name of the function that you implement to 
perform the test object operation on the control.

Default: The operation name

Note: If you modify this name, you must update the 
function name in the JavaScript file as well.

Stored in: Method element in the toolkit configuration 
XML file

UI Elements Description
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Properties Tab (Test Object Class Designer)

This tab enables you to design the identification properties of your test 
object class. You can:

➤ Define the list of identification properties for your test object class.

Add or remove properties or select base class properties to inherit and 
include in the list. 

➤ Decide which properties are included in test object descriptions, which 
can be verified in checkpoints, and used in output values, which should 
be used for Smart Identification, and so on. 

➤ Optionally, define advanced options.

The information you define in this tab is stored in the XML files in your 
toolkit support set. 

Note: You must also implement a JavaScript function that retrieves the 
values of the properties from the control. For details, see "Implement the 
JavaScript function that retrieves the identification property values from the 
run-time object" on page 60.
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To access 1  In the Class View, add a new test object class or 
double-click an existing one. 
The test object class designer opens.

2  In the test object class designer, select the Properties 
tab.

Important 
information

➤ To prevent the property grouping that you define in 
this tab from overwriting changes that the QuickTest 
user makes in the Object Identification dialog box, 
clear the Development mode option in the Toolkit 
Support Properties Designer (described on page 37) 
before deploying the toolkit support set for regular 
use.
For a more detailed explanation, see the HP QuickTest 
Professional Web Add-in Extensibility Developer Guide. 

➤ Make sure to visit each tab in the test object class 
designer to ensure that all of the test object class 
details are defined correctly.
A red asterisk next to the name of the tab acts as a 
reminder that you have not yet visited this tab.

Relevant tasks "Design Test Object Class Identification Properties" on 
page 59

See also The section on implementing support for identification 
properties in the HP QuickTest Professional Web Add-in 
Extensibility Developer Guide. 

WebExtensibility.chm::/WebExtensibility.htm
WebExtensibility.chm::/WebExtDev_IDProps.htm
WebExtensibility.chm::/WebExtDev_IDProps.htm
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The Properties tab contains the following:

➤ "Property List" on page 93

➤ "Property Usage Groups" on page 94

➤ "Advanced Options" on page 97

Property List

Displays properties that you add to the test object class, and some base class 
properties you can choose to inherit and include in the list. 

➤ Base class properties appear in italic font and are not supported by your 
test object class unless you choose to inherit them. 

➤ New or inherited properties appear in regular font and are editable. 
Stored in: IdentificationProperty elements in the test object configuration 
XML file  

This area also contains a toolbar with the following buttons: 

Buttons Description

Add. Adds a new editable identification property to the 
test object class definition. 

Delete. Deletes the selected property from the test object 
definition in the test object configuration XML file.

If you delete an inherited property, its appears in italic 
font again. 

Inherit Adds the selected base class property to the list of the test 
object class’s properties. In some cases, the property is 
also added by default to specific property groups.

The property name font changes to regular text and 
becomes editable. You can then add or remove the 
property to or from the different groups as needed.
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Property Usage Groups

Add identification properties to the different groups in this area, to inform 
QuickTest of the purposes for which the properties should be used.

To add a property from the list of properties on the left to a group on the 
right, select the property and the group and click the >> button. 

Base class property grouping cannot be modified unless the property is new 
or inherited.

Stored in: The properties’ group associations are stored in the test object 
configuration XML file. They are indicated by attributes of the 
IdentificationProperty elements.

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Elements Description

Each group has a toolbar. 

➤ The toolbars all include a Delete button, to remove 
the selected property from the group.

➤ The groups in which the order of the properties is 
significant have Up and Down buttons to enable 
moving the selected property within the list.

Object Identification 
- Mandatory Group

Properties that QuickTest always learns as part of the 
description for test objects of this class.

Note: You cannot include the same property in both 
Object Identification lists.

Indicated by: ForDescription attribute set to true
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Object Identification 
- Assistive Group

Additional properties that QuickTest can learn for a test 
object of the selected class to create a unique test object 
description.

When QuickTest learns an object, and assistive properties 
are necessary to create a unique object description, 
QuickTest adds the assistive properties to the description 
one at a time until it has enough information to create a 
unique description, according to the order you set in this 
group.

Indicated by: ForAssistive attribute set to true, 
AssistivePropertyValue attribute set to the position of the 
property within the group

Smart Identification - 
Base Group

Properties that QuickTest learns as base filter properties 
for this test object class. The Smart Identification 
mechanism uses these properties to create a list of 
possible candidate objects.

Note: You cannot include the same property in both 
Smart Identification lists.

Indicated by: ForBaseSmartID attribute set to true

Smart Identification - 
Optional Group

Properties that QuickTest learns as optional filter 
properties for this test object class. The Smart 
Identification mechanism uses these properties in the 
specified order to narrow down the object candidate list 
to one object.

When QuickTest uses Smart Identification, it creates a list 
of possible candidate objects according the base filter 
properties, and then checks the values of the optional 
filter properties one by one according to the order you 
set, until it narrows down the candidate list to one 
object.

Indicated by: ForOptionalSmartID attribute set to true, 
OptionalSmartIDPropertyValue attribute set to the 
position of the property within the group

UI Elements Description



Chapter 4 • Supporting a Custom Control

96

Checkpoints and 
Output Values Group

Properties available in the Checkpoint Properties and 
Output Value Properties dialog boxes in QuickTest. 

If the check box for a property if selected, it is selected by 
default in the Checkpoint Properties dialog box when 
creating a checkpoint.

Indicated by: ForVerification and, if selected, 
ForDefaultVerification attribute set to true

Object Spy Group Indicated by: ForSpy attribute set to true

UI Elements Description
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Advanced Options

Click the Advanced Options panel to expand it. 

This area enables you to set advanced options for implementing property 
support. If you do not define these options, QuickTest uses default values.

User interface elements are described below:

UI Elements Description

Implementation file 
name

The file that contains the implementation function 
(optional).

You cannot modify this value directly. 

Use the Import File  button to browse to and select 
the relevant file. If you select a file that is not located in 
the project’s JavaScript folder, a local copy is created in 
that folder. The file must be located in the project’s 
JavaScript folder to be properly deployed.

Use the Clear  button to clear the edit box. 

The corresponding XML attribute in the toolkit 
configuration XML file is cleared, but the JavaScript file is 
not removed from the project.

Default: The Default implementation file defined in the 
general tab

Stored in: Property element in the toolkit configuration 
XML file

Implementation 
function name

The name of the function that you implement to retrieve 
the values of the identification properties from the 
control.

Default: get_property_value

Stored in: Property element in the toolkit configuration 
XML file
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Debug Test Object Operation Dialog Box

This dialog box enables you to run your test object operations from within 
Extensibility Accelerator, so that you can test and debug your JavaScript 
implementation functions using the Microsoft Visual Studio Shell 
debugging tools.

 

To access Do one of the following: 

➤ Select Project > Debug Test Object Operation

➤ In the Class View, right-click the operation that you 
want to run and select Debug.
Tip: If the operations are not displayed in the Class 
View, first select the test object class.

Important 
information

Make sure that you select the relevant control in the 
application before you run the operation.

Relevant tasks "Debug Your Test Object Operation Support" on page 61



Chapter 4 • Supporting a Custom Control

99

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Elements Description

Test object class The test object class of the operation that you want to 
run.

Operation The test object operation that you want to run. 

<operation 
arguments>

The arguments for the operation. Includes the following 
for each argument:

Name. The name of the argument and whether it is 
optional. (Read only)

Type. The type of value the operation expects for this 
argument. (Read only)

Value. The value to use for the argument when running 
the operation. You must enter values for all mandatory 
arguments.

Select Control Highlights all of the controls that match the test object 
class’ mapping rules in all open Web applications, and 
enables you to select the control on which you want to 
run the operation.

Available when: A Test object class is selected in the 
dialog box.

Run Operation Runs the operation on the selected control, calling the 
JavaScript implementation that you designed.

If you prepared your JavaScript function for debugging, 
as described in "Debug Your Test Object Operation 
Support" on page 61, the run session pauses at the 
debugger; line in the JavaScript file.

From this point, you can debug your JavaScript functions 
as you would in a regular Microsoft Visual Studio 
JavaScript debugging session. 

Available when: A control is selected in the application.

Cancel Close this dialog box without running the operation.
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5
Custom Toolkit Support Deployment

This chapter includes:

Concepts

➤ Deployment Objectives on page 102

➤ Deployment Destinations on page 104

➤ Deployment File Structure on page 104

Tasks

➤ Deploy a Toolkit Support Set on page 105
Concepts
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Deployment Objectives

You can deploy your toolkit support set at various stages of development to 
test how it works on QuickTest. 

Example

When you complete the development of the toolkit support set, you can 
deploy it for regular use, or package it for distribution. For details, see 
"Deployment Destinations" on page 104.

If you deploy after ... You can verify that...

You define a test object class and 
its operations, but do not 
implement the JavaScript 
function for the operation.

You can use this test object class when editing 
steps in QuickTest, and the operations are 
displayed correctly in the Keyword View and 
in IntelliSense.

You define the mapping rules for 
a test object class, but do not 
define any operations.

QuickTest can learn objects of this type.

You implement the JavaScript 
function for an operation.

QuickTest can run steps that perform the 
operation.

You implement the JavaScript 
function that retrieves the 
identification property values 
from the control.

You can see the identification property values 
in the Object Spy.
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Setting the Development Mode Option 

When you deploy the toolkit support set during the design stages, keep the 
Development mode option in the Toolkit Support Properties Designer 
(described on page 37) selected. This ensures that if you modified attributes 
of IdentificationProperty elements in the test object configuration XML file, 
QuickTest uses all of the changes you made.

Be sure to clear this option before you deploy the toolkit support set for 
regular use. Otherwise, every time QuickTest opens, it will refresh the 
property lists based on the definitions in the test object configuration XML 
file. If QuickTest users change the property lists using the Object 
Identification dialog box, their changes will be lost when they reopen 
QuickTest.

For more details, see the section on modifying deployed support in the 
HP QuickTest Professional Web Add-in Extensibility Developer Guide. 

Validating the Toolkit Support Set

Before deploying the toolkit support set, Extensibility Accelerator saves all of 
your changes and validates the information. If mandatory data is missing, or 
if conflicts or discrepancies are found between information in the different 
files, the Error List window displays messages that explain the problems 
encountered.  

When you deploy the toolkit support set during the design stages, many of 
the issues reported in the Error List can be ignored.

Before you deploy the toolkit support set for regular use, make sure to 
address these issues.

WebExtensibility.chm::/DeployModify.htm
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Deployment Destinations

You can deploy a toolkit support set locally, making it immediately available 
for use with QuickTest or the QuickTest Add-in for Quality Center, if those 
are installed on the same computer as Extensibility Accelerator.

Alternatively, you can automatically package the toolkit support set in a .zip 
file, which you can then distribute and unzip for use on other QuickTest 
computers. In the .zip file, the files are stored in the same structure as a 
deployed toolkit support set. Therefore, in order to use this toolkit support 
set on a QuickTest computer, unzip it in <QuickTest installation 
folder>\dat\Extensibility\Web.

For task details, see "Deploy a Toolkit Support Set" on page 105.

Deployment File Structure

The toolkit support set files are deployed in the following structure: 

If the toolkit support set was previously deployed in a different structure, 
files that are not overwritten remain in their original locations but are no 
longer used. For example, if you imported a toolkit support set developed 
for QuickTest 9.5 or 10.00, where the JavaScript files were not stored in a 
JavaScript subfolder, and then re-deployed this toolkit support set. You 
might want to delete the unused files to avoid future confusion.

Tasks

Parent folder or zip file
|
|---<ToolkitName>TestObjects.xml file
|---Toolkits folder:

|
|---<ToolkitName> folder

|
|---<ToolkitName>.xml file
|---JavaScript folder containing JavaScript files
|---Res folder containing icon files (optional)
|---Help folder containing .chm files (optional)
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Deploy a Toolkit Support Set

This task describes how to deploy a toolkit support set. You can deploy it 
directly to QuickTest or the QuickTest Add-in for Quality Center if they are 
installed on the local computer. Alternatively, you can package the toolkit 
support set for distribution to other computers. 

You can deploy a toolkit support set:

➤ During the design stages, to test its functionality.

➤ When the design is complete, to begin using the toolkit support.

To deploy the toolkit support set:

 1 Open an extensibility project that contains at least one test object class.

 2 If the toolkit support set design is complete, and you are distributing it for 
regular use:

➤ Clear the Development mode option in the Toolkit Support Properties 
Designer (described on page 37).

➤ Save all your changes and make sure that you addressed all issues listed 
in the Error List Window.  

For details, see "Deployment Objectives" on page 102.

 3 Depending on your deployment destination, do one of the following:

➤ To deploy to QuickTest (if it is installed on this computer), select 
Project > Deploy > Deploy to QuickTest Professional.

➤ To deploy to the QuickTest Add-in For Quality Center (if it is installed 
on this computer), select Project > Deploy > Deploy to QuickTest 
Add-in For Quality Center.

➤ To package the toolkit support set for distribution, select Project > 
Deploy > Deploy to Zip File. In the Save Zip File As dialog box that 
opens, specify the file path for the .zip file that you want to create.
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Note: If you have unsaved changes in your project, you will be 
prompted to save them before the Deploy command is carried out. The 
Save Zip File As dialog box opens only after you complete the saving 
process.

The toolkit support set files are deployed in the structure described in 
"Deployment File Structure" on page 104. 

If you deploy to QuickTest or the QuickTest Add-in for Quality Center, 
Extensibility Accelerator locates the QuickTest or add-in installation folder 
and deploys the files to the <QuickTest or add-in installation 
folder>\dat\Extensibility\Web folder.

If you deploy to a .zip file, Extensibility Accelerator creates the same file 
structure within the zip file. To use this toolkit support set with QuickTest or 
the QuickTest Add-in for Quality Center installed, unzip it in the <QuickTest 
or add-in installation folder>\dat\Extensibility\Web folder.
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Map to Controls tab (Test Object Class 
designer) 74
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Operations tab (Test Object Class designer) 
81
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Project Explorer 34
projects

importing 29
structure 34

Properties tab (Test Object Class designer) 90
properties. See identification properties

S

saving changes 26
selection dialog box 79
Start Pages 13
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Test Object Class designer
General tab 65
Map to Controls tab 74
Operations tab 81
Properties tab 90

test object classes
designing operations 57
designing properties 59
mapping to Web elements 49

test object methods. See test object 
operations
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debugging 61
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