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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As 
a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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Welcome to This Guide

Welcome to HP Service Test, HP's tool for creating tests, with a focus on 
testing SOA and headless technologies.

This chapter includes:

➤ How This Guide Is Organized on page 9

➤ Who Should Read This Guide on page 10

➤ Service Test Updates on page 10

➤ Service Test Documentation on page 11

How This Guide Is Organized

This guide contains the following chapters:

Chapter 1 Working with Service Test

This chapter describes the Service Test interface, its layouts, and dockable 
window panes.

Chapter 2 Creating and Saving Tests

This chapter describes how to create a new solution and project.

Chapter 3 Defining Services

This chapter describes how to import services and maintain them.
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Chapter 4 Data Handling

This chapter describes how to add data to your test and how to assign it to 
your test’s parameters.

Chapter 5 Running Tests

This chapter describes how to run tests from the user interface or command 
line.

Chapter 6 Run Results Viewer

This chapter describes how to view the results in the Run Results Viewer and 
filter or export the information according to your needs.

Chapter 7 ALM/QC Integration

This chapter describes how to integrate with HP ALM/QC (Application 
Lifecycle Management/Quality Center) to manage your tests and implement 
version control.

Who Should Read This Guide

This guide is for the following users of Service Test:

➤ Application developers or configurators

➤ System or instance administrators

➤ Functional and load testers

Readers of this guide should be moderately knowledgeable about SOA 
systems and Web services.

Service Test Updates

You can check online for updates to all HP products installed on your 
computer at any time by choosing Start > Programs > HP Service Test 11.00 
> HP Update. You can then choose which updates to download and 
(optionally) install. 
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Service Test Documentation

Service Test includes the following online documentation:

Readme. Choose HP Service Test > Readme from the Start menu.

HP Service Test Online Help. Available from the Service Test user interface by 
clicking in the window and pressing F1 or clicking the Help button.

User Friendly Documentation. Online books can be viewed and printed 
using Adobe Reader, which can be downloaded from the Adobe Web site 
(www.adobe.com).

➤ HP Service Test User Guide. Choose HP Service Test 11.00 > 
Documentation > User Guide from the Start menu. 

➤ HP Service Test Installation Guide. Choose HP Service Test 11.00 > 
Documentation > Installation Guide from the Start menu.

➤ HP Service Test Tutorial. Choose HP Service Test 11.00 > 
Documentation >Service Test Tutorial from the Start menu.

http://www.adobe.com
http://www.adobe.com
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1
Creating and Saving Tests

This chapter includes:

Concepts

➤ Test Overview on page 14

Tasks

➤ How to Create a New Test on page 15

➤ How to Define Test Properties or User/System Variables on page 16

Reference

➤ Test User Interface on page 19
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Concepts

Test Overview

To test your applications, you use Service Test to create tests. 

You can base the new test on the standard Service Test template, or, if you 
have LoadRunner installed, on a Load Testing template. 

You can create tests on either the file system, or within HP ALM/QC 
(Application Lifecycle Management/Quality Center).
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Tasks

How to Create a New Test

The following steps describe how to create a new test. Each test provides an 
empty canvas to which you can add activities.

➤ "Set the path type - optional" on page 15

➤ "Open the create a new test dialog box" on page 15

➤ "Define test properties" on page 16

➤ "Define user variables" on page 17

 1 Set the path type - optional

By default the path used for the test is relative. If you plan to transfer the 
test to other machines, you can use an absolute path. Select Edit > Settings 
and clear the Use a Relative Path option. 

 2 Connect to ALM/QC- optional

To create tests in an ALM/QC repository, first connect to the ALM/QC server. 
For details, see "How to Connect to ALM/QC" on page 206.

 3 Open the create a new test dialog box

Click or File > New > Test. For user interface details, see the "Create New Test 
Dialog Box" on page 19.

 4 Select a template

In the Create a New Test dialog box, select the Service Test template. For 
load testing, select the Service Test Enabled for Load Testing template. The 
latter template is only available when LoadRunner is installed on the 
machine.
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 5 Specify a name

Accept the default name or specify your own string in the Name box.

 6 Select a location

Accept the default location, or click the Browse button adjacent to the 
Location box to open the Open Folder dialog box.

For a location on the file system, browse to the folder. and click Open.

For ALM/QC tests, click the ALM/QC Test Plan button in the left pane, and 
navigate to the folder. Use the New Folder .button to create a new branch. 
Click Open.

 7 Generate the test

In the Create a New Test dialog box, click Create.

How to Define Test Properties or User/System Variables

The following steps describe how to define test properties, user variables, 
and operating system variables. These settings are optional.

➤ "Define test properties" on page 16

➤ "Define user variables" on page 17

➤ "Define user variables profiles" on page 18

➤ "Set user variable values" on page 17

➤ "Set operating system variables" on page 18

Define test properties

This step applies if you want to define custom properties that can be used by 
all steps in the test, with the ability to assign data from a query.

 1 Click in a blank area of the canvas. In the Property Sheet, open the Test 
Input Parameters view. 

 2 Click the Add Property button  to define a new input or output property. 
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 3 In the Add Input/Output Property dialog box, specify a property name 
and type.

 4 Click in the Default Value column. Specify a value or click the Link to 
Source button  to specify a data source. For details, see "Select Link Source 
Dialog Box" on page 174.

Define user variables 

Service Test lets you create user variables and set their values. You can define 
multiple profiles for the variable values. You select a profile to be active 
before the test run. For details, see the next step.

 1 Click in a blank area of the canvas. In the Property Sheet, open the Test 
Variables view. 

 2 Click the Add User Variable button  to define a new user variable. 

Set user variable values 

Set values for the variables in one of the following ways:

➤ In the Property Sheet’s Test Variables view, click in the Profile column and 
manually enter values.

➤ Open the Toolbox (left pane) and drag the Set Test Variable activity from 
the Miscellaneous category into a loop, such as Test Flow. In the Property 
Sheet, define the variable key and value. To obtain values, click the Link 
to a Data Source button in the row. In the Select Link Source dialog box, 
select the Test Variables option. Select a name and value for the Variable 
key and Variable value.

➤ Open the Property Sheet’s Events view for the step or define a Custom 
Code activity. Edit the Event Handler code and assign a value using the 
TestProfile object. The following example sets the value of Region user 
variable to NE.

For details, see Appendix A, "Coding Service Test Events."

activity.Context.TestProfile.SetVariableValue("Region", "NE"); 
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Repeat this step for each variable for which you want to set values. 

Define user variables profiles 

This step only applies if you created user variables as described in the 
previous step.

 1 Define one or more user variables as described above. 

 2 Click the Add New Profile button.

 3 In the New Test Profile dialog box, specify a name and indicate the profile 
(if any) from which to copy the properties. If you do not copy from an 
existing profile, Service Test copies the user variables from the active 
profile without its values.

 4 To rename or delete a profile, click the Manage Profiles button. Click 
Remove or Rename.

 5 Click the Compare button  to display the profiles side-by-side. 

 6 Only the active profile is accessed during the test run. To make a profile 
active, select it from the Active Profile dropdown list.

For user interface information, see the "Test Variables View" on page 77.

Set operating system variables

 1 Open the Toolbox (left pane) and drag the Set OS Environment Variable 
activity from the System category into the loop, such as Test Flow. 

 2 In the Property Sheet’s Input/Checkpoints view, define the variable key 
and value or click the Link to Source button  to specify a data source.

Tip: To view a list of the test variables, click in a blank area of the canvas. In 
the Property Sheet, open the Test Variables view. The System variables are 
listed in the lower pane. 
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Reference

Test User Interface

This section includes:

 ➤ Create New Test Dialog Box on page 19

Create New Test Dialog Box

This dialog box enables you to specify the location and name of the new 
test.

User interface elements are described below:

To access File > New > Test (Ctrl + Shift +N)

Relevant tasks "Open the create a new test dialog box" on page 15

UI Elements (A-Z) Description

Browse. Selects a location for the new test. To select a 
location on an ALM/QC server, first connect to the 
server. For details, see "How to Connect to ALM/QC" 
on page 206.

Creates a new test in the selected location.

Categories pane A list of the test categories.

Location The complete path of the test. Use the Browse button to 
choose a location.
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Name A name for the test. May contain only letters, numbers, 
underscores, spaces, and dots (".").

Templates pane A collection of templates. Service Test and Service Test 
Enabled for Load Testing.

Default value: Service Test

Note: The Service Test Enabled for Load Testing template 
is only visible when HP LoadRunner is installed.

UI Elements (A-Z) Description
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2
Working with Service Test

This chapter includes:

Concepts

➤ Service Test Overview on page 22

➤ UFT (Unified Functional Testing) on page 36

➤ JMS Transport Overview on page 36

Tasks

➤ How to Populate a Test on page 41

➤ How to Implement UFT testing on page 47

➤ How to Create a Call to a Java Class on page 49

References

➤ The Service Test User Interface on page 53

➤ Security Scenarios User Interface on page 84
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Concepts

Service Test Overview 

Welcome to HP Service Test, HP'’s tool for the construction and execution of 
functional tests for headless systems.

You create a test by dragging and dropping activities from the Service Test 
toolbox into a canvas. The toolbox provides a collection of activities for 
functional testing in areas such as REST, Web Services, JMS, and HTTP. You 
can add more activities to the toolbox by importing WSDLs or providing 
other contract definitions. 

This section includes:

➤ "Introducing Service Test" on page 23

➤ "Performing Integrated Testing" on page 23

➤ "The Canvas" on page 24

➤ "The Toolbox" on page 29

➤ "Data Sources" on page 29

➤ "Using Service Test for Testing Web Services" on page 31

➤ "Using Service Test for Testing REST Services" on page 31

➤ "Java Testing" on page 32

➤ "The Property Sheet" on page 33
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Introducing Service Test 
Service Test uses a visual designer as a canvas for creating steps in a test. You 
create tests by dragging activities from a toolbox palette into the canvas and 
defining their parameters.

For integrated testing, Service Test supports a variety of activities such as 
string manipulation, file verifications, and flow control. The toolbox also 
provides access to Web and REST Service operations and methods. 

Performing Integrated Testing
In testing your systems, you perform known activities and observe the 
response. By checking the response, you determine whether your system is 
performing as expected.

For example, in a basic Replace String activity, you provide the old text, new 
text, and an expected value. You compare the response with the expected 
value to confirm that your activity functioned properly.
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The steps to create a basic integrated test are:

➤ Drag an activity into the canvas

➤ Assign input data

➤ Set checkpoints to verify the response

The Canvas
The canvas in Service Test provides a visual representation of the test flow. 
You populate the canvas by dragging in activities from the Toolbox palette. 

You can drag Web Services, REST services, or any Toolbox activity, into the 
canvas. For a service to appear in the Toolbox, you must first import it (Web 
services) or define it (REST services) in your project. For details, see "How to 
Import a WSDL-Based Web Service" on page 116.
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Tab Title

The canvas tab title is <Test name>.st. An asterisk denotes changes that were 
not yet saved.

Manipulating Steps

The canvas allows you to manipulate the steps in the following ways:

➤ Reorder. Drag a step from one location to another.

➤ Copy and Paste. Select a step and press Ctrl+C to copy it to the clipboard. 
Press Ctrl+V to paste it into another location within the Test Flow or to 
another loop.

➤ Delete. Select a step and press the keyboard’s Delete button.

Flow Control

The canvas allows you to control the flow of the steps in the following ways:

➤ Loop. The main Test Flow area provides a default loop for test steps. You 
can add steps to the Test Flow or add additional loops. Using the 
Properties Sheet, you can specify the type of loop, number of iterations, 
and conditions for the Test Flow or loop. For details, see "Input/
Checkpoints View" on page 70.

➤ Conditional steps. Adds a two-branched conditional node to the test.
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For conditional steps, you drag the Condition activity from the Toolbox into 
the canvas, and then drag an activity into each of the conditional branches.

➤ Break. Moves control to the step after the loop.

➤ Continue. Moves control back to the first step in the Test Flow or Loop 
and increments it to the next iteration.

Alerts

Steps that require intervention in order to run, such as HTTP, Custom Code, 
and SOAP Request, post an alert in their top right corner. Clicking an alert 
button displays the action that you are required to do.

You can also view this information in the Errors tab by selecting View > 
Errors.

Connecting Data

The canvas displays the link between output parameters and input

parameters from a previous step. An arrow indicates a relationship between 
the parameters.
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For more information, see "Data Handling User Interface" on page 167.

Sending Messages to the Output and Results Viewer

The Report Message activity lets you send custom messages to the Output 
log and/or the Results viewer. You drag the activity to the canvas and set its 
properties in the Property sheet.

As with any step, you can link its input to the output of a prior step and 
show the results in the Output window.
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In the following example, the Output window shows the message string.

When you use this activity, Service Test adds a Message row to the Results 
report, with the contents of the message.
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For more information, see the "Run Results Viewer" on page 211.

The Toolbox
The Toolbox palette contains all of the activities and flow control objects 
that you need in order to create a test.

After you import a Web service, it appears in the Toolbox, under the Web 
Services node. When you expand the Web Services node, the Toolbox 
displays the service’s name, port, and operations.

For additional details about each of the nodes, see the"Toolbox Palette" on 
page 59.

Extensibility

For greater control over test steps, you can define custom code activities that 
seamlessly integrate with Service Test. You can also customize the behavior 
of existing activities using event handlers. For more information, see 
"Coding Service Test Events" on page 261.

For information about adding new activities, speak with you HP 
representative.

Data Sources
Using the Data window, you can define data for your test’s properties. You 
can link to a variety of data sources, such as Excel or XML files. You can also 
define data locally for the test steps. 

When you load data from Excel, you can indicate whether to make a local 
copy of the data, or a referenced query which refers to the data at its original 
source.
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A data grid displays the Excel and locally defined data. If you created a 
referenced query, you will be unable to edit the values in the data grid.

After you load data, you can assign it to properties in your test.

For information on using data in your test, see "How to Assign Data to Test 
Steps" on page 161.
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Using Service Test for Testing Web Services
You can use Service Test to test standard Web Services. For Web services, you 
import the service’s WSDL file.

After importing the WSDL file, the Toolbox window lists the operations in 
the Toolbox. You then drag the operations directly into canvas and provide 
input values.

For task details, see "How to Import a WSDL-Based Web Service" on 
page 116.

Using Service Test for Testing REST Services
You can use Service Test to test non-SOAP Web Services, such as REST.

For REST services, you manually define the metadata and model your 
activities based on the design of your service’s requests.
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After setting the REST resource definitions, you can create REST method calls 
based on the metadata. To validate the results, you set checkpoints for the 
REST method’s response.

Service Test allows you to create templates for individual REST methods. The 
templates include all of the request and header information, as well as 
custom parameters. Using this template, you can drag the method into the 
canvas without having to configure its details repeatedly.

For task details, see "How to Create a Template-Based REST Service" on 
page 125.

Java Testing
Service Test allows you to call Java classes with its Call Java Class activity. 

In order to use this step, you must implement the Service Test Java interface. 
The aim of this interface is to define a contract or bridge between the Java 
artifacts owner and Service Test. The interface contains three methods:

➤ getInputProperties. Returns a mapping of the input property names and 
their Java class.

➤ getOutputProperties. Returns a mapping of the output property names 
and their Java class.

➤ Execute. A method that receives the mapping of the input properties 
names and their actual values i.e. their object instance. In this method, 
you process input properties and delegate them to your own Java artifacts. 
Afterwards you process the output properties and send their mappings 
and their actual values as the method’s output.
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The following table lists the relevant paths:

To configure a Java step, you select a root path, a jar file containing the class, 
and the actual Java class. You can provide additional classpaths and jar files 
for the Java call. For details about selecting the Java class and packaging, see 
the "Call Java Class Settings Dialog Box" on page 95.

Service Test supports the following Java classes: Byte, Short, Int, Long, Float, 
Double, Boolean, Date, and String. The Char class is not supported.

For task details, see "How to Create a Call to a Java Class" on page 49.

The Property Sheet
The Property Sheet provides several views that allow you to set properties for 
each of the test steps. 

General View

The General view shows the Step ID and Name properties of the test 
step. Several activities have additional General properties. For 

example, for Web Service operations, this view also shows the Endpoint 
Address, SoapAction, ContentType and IsOneWay setting. For details, see 
the "General View" on page 68.

File Path

Interface code ➤ Path:
%ST_DIR%\addins\ServiceTest\JavaCall\Java 
Interface\src\hp\st\ext\java\ServiceTestCall.java

➤ Default installation:
C:\Program Files\HP\Service Test 
11\addins\ServiceTest\JavaCall\Java 
Interface\src\hp\st\ext\java\ServiceTestCall.java 

Sample code ➤ Path:
%ST_DIR%\addins\ServiceTest\JavaCall\Java 
Interface\src\hp\st\ext\java\sample 

➤ Default installation:
C:\Program Files\HP\Service Test 
11\addins\ServiceTest\JavaCall\Java 
Interface\src\hp\st\ext\java\sample 
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Input/Checkpoints View

The Input/Checkpoints view displays a grid of properties and their 
values. This view shows properties that apply to the selected activity or 

step:

The display grid shows important information about each of the elements 
such as whether they will be encoded as base64 or whether they can be set 
to a NIL value. A green triangle indicates an optional element. The element 
is included when the toggable triangle is filled and excluded when it is 
cleared. For a list of the icons in the grid, see the "Input/Checkpoints View" 
on page 70.

You can automatically select data for the properties from data sources, 
system variables, and so forth. For details, see "Select Link Source Dialog 
Box" on page 174.

Events View

The Events view lets you select or set a handler function for each of the 
step’s events, or to open an editor to write code describing what to do 

when the event occurs.

For information on creating an event handler, see "Specify an event handler 
- optional" on page 45.

Selected step Title Displayed in view

Activities Input/Checkpoint Input and checkpoint properties 
and their values.

Canvas, Start 
step, End step

Test Input 
Parameters

Input and Output properties for 
the test.

Loop (Test Flow 
or additional 
loops)

Input The type of loop and the 
relevant properties such as the 
number of iterations. For details, 
see "Loop Settings" on page 72.
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Test Variables View

The Test Variables view, is available for the Start and End steps and 
when standing on an empty part of the canvas. It displays the user and 

system-defined test variables. You can save a set of user variables in a profile. 
You can create multiple profiles and compare them. For details, see "Define 
user variables" on page 17.

REST HTTP Input View

The REST HTTP Input view, available when selecting a REST service 
method in the toolbox, stores the Endpoint Address, HTTP Method, 

HTTP Version, and the Request Headers. For details, see the "REST HTTP 
Input View" on page 78.

HTTP View

The HTTP view, available for the HTTP activity and REST service 
methods, displays the HTTP request, response and version. You can 

also set the headers and import the body of the request. For details, see 
"HTTP View" on page 78.

SOAP Fault View

The SOAP Fault view is available for Web Services only. It allows you to 
specify whether to expect a SOAP fault and to set the SOAP fault 

properties. For details, see the "SOAP Fault View" on page 76. 

Attachments View

The Attachments view is available for Web Services. It allows you to 
view the input and output attachments and their properties. For 

details, see the "Attachments View" on page 81. 

Security Settings View

The Security Settings view, available for Web services, allows you to 
add tokens, message signatures, and encryption to the service calls. 

You can also select security scenarios and customize them. For details, see 
"Security Settings View" on page 82.
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Data Queries View

The Data query view is available when you click in the empty area of a 
Loop box. It allows you to add queries that appear in the Data window, 

and set its data navigation policies. For details, see "Navigating within the 
Data" on page 153. 

Data Query Properties View

The Data Query Properties view, only available for a REST service 
methods, displays the HTTP request, response and version. You can 

also set the headers and import the body of the request. For details, see 
"Data Query Properties View" on page 83.

UFT (Unified Functional Testing) 

The UFT (Unified Functional Testing) activities allow you to create tests with 
steps from Service Test, QuickTest Professional, or LoadRunner’s Virtual User 
Generator. 

QuickTest Professional is HP’s tool for functional testing of client and Web 
applications. HP LoadRunner allows you to perform Load Testing on your 
applications and environment.

You create the tests or scripts in the original application and call them 
within the Service Test flow. You can also call another Service Test test from 
within the Test Flow.

For user interface details, see the "Toolbox Palette" on page 59

For task details, see "How to Implement UFT testing" on page 47.

JMS Transport Overview

"The Property Sheet" on page 33 is a J2EE standard for sending messages—
either text or Java objects—between Java clients. Service Test supports the 
sending of text messages between Java clients.

There are two scenarios for communication: 
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Peer-to-Peer. Also known as Point-to-Point. JMS implements point-to-point 
messaging by defining a message queue as the target for a message. Multiple 
senders send messages to a message queue, and the receiver gets the message 
from the queue.

Publish-Subscribe. Each message is sent from one publisher to many 
subscribers through a designated topic. The subscribers only receive 
messages sent after they have subscribed.

Service Test supports both types of communication by allowing you to send 
and receive JMS messages to and from a queue or topic. The following is a 
list of the built-in JMS activities.

To interpret Topic and Queue names, Service Test calls a lookup method on 
a JNDI context, defined in the Property Sheet’s Test Settings. For details, see 
the "Test Settings View" on page 66.

For task details, see "Set up a JMS message - optional" on page 45.

Publish Message to Topic

Publishes a message to multiple subscribers using a JMS topic.

Property Description

Topic name The JNDI name of the queue from which to receive 
the message.

Message The message to publish

JMS send properties JMS properties with the key/value form. You can use the 
key to modify JMS header or message properties.
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Receive Message from Queue

Receives a message from a JMS queue.

Receive Message from Topic 

Receives published messages to a specific JMS topic for a subscription. Call 
this step after a Subscribe to Topic step.

Send Message to Queue

Sends a message to a JMS queue.

Property Description

Receive queue name The JNDI name of the queue from which to receive the 
message. If the value is empty, Service Test uses a 
temporary queue.

JMS receive message 
selector

An SQL expression to filter the received message. For 
more information on the syntax for defining selectors, 
see the Message Properties section in http://
java.sun.com/j2ee/sdk_1.3/techdocs/api/javax/jms/
Message.html. 

For example a key JMSCorrelationID, with a value of 
4566636, only receives messages whose correlation ID is 
4566636 (right-click to add array elements).

Property Description

Topic name The JNDI name of the topic from which to receive the 
message.

Subscription name The name of the subscription. Use the same subscriber 
name value from the previously-called Subscribe to Topic 
step.

Property Description

Send queue name The JNDI name of the queue from which to receive the 
message.

http://java.sun.com/j2ee/sdk_1.3/techdocs/api/javax/jms/Message.html
http://java.sun.com/j2ee/sdk_1.3/techdocs/api/javax/jms/Message.html
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Send and Receive Message From Queue

Sends a message to a specified queue and receives a message from a specified 
queue.

Message The message to send.

JMS send properties JMS properties with the key/value form. You can use the 
key to modify JMS header or message properties.

Property Description

Send queue name The JNDI name of the queue to which to send the 
message.

Receive queue name The JNDI name of the queue from which to receive the 
message. If the value is empty, Service Test uses a 
temporary queue.

Message The message to send.

JMS send properties JMS properties with the key/value form. You can use the 
key to modify JMS header or message properties.

JMS receive message 
selector

An SQL expression to filter the received message. For 
more information on the syntax for defining selectors, 
see the Message Properties section in http://
java.sun.com/j2ee/sdk_1.3/techdocs/api/javax/jms/
Message.html.

For example a key JMSCorrelationID, with a value of 
4566636, only receives messages whose correlation ID is 
4566636 (right-click to add array elements).

Tip: To automatically generate a selector, use the 
Automatically generate selector option in the Property 
Sheet’s Test Settings tab. This selector uses a correlation 
ID that corresponds to the request’s message ID.

Property Description

http://java.sun.com/j2ee/sdk_1.3/techdocs/api/javax/jms/Message.html
http://java.sun.com/j2ee/sdk_1.3/techdocs/api/javax/jms/Message.html
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Subscribe to Topic

Creates a subscription for a JMS topic. Use this step before any Receive 
Message from Topic steps for the subscription

Property Description

Topic name The JNDI name of the queue from which to receive the 
message.

Subscription name The name of the subscription. To retrieve messages on 
the subscription created by this step, insert a Receive 
Message from Topic step using the same Subscription 
Name value.

JMS receive message 
selector

An SQL expression to filter the received message. For 
more information on the syntax for defining selectors, 
see the Message Properties section in http://
java.sun.com/j2ee/sdk_1.3/techdocs/api/javax/jms/
Message.html.

http://java.sun.com/j2ee/sdk_1.3/techdocs/api/javax/jms/Message.html
http://java.sun.com/j2ee/sdk_1.3/techdocs/api/javax/jms/Message.html
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Tasks

How to Populate a Test 

This task describes how to set up the workflow and add steps to your tests. 
For details on creating the test and defining user or test variables, see 
"Creating and Saving Tests" on page 13.

This task includes the following steps:

➤ "Prepare the service references - optional" on page 41

➤ "Create the test flow" on page 42

➤ "Add activities to the test" on page 42

➤ "Define data for the test" on page 42

➤ "Add additional properties - optional" on page 42

➤ "Create a Custom Code activity - optional" on page 43

➤ "Add attachments to the test - optional" on page 44

➤ "Set up a JMS message - optional" on page 45

➤ "Configure SOAP Fault information - optional" on page 45

➤ "Specify an event handler - optional" on page 45

 1 Prerequisite - open a test

Create a new test. For details, see "How to Create a New Test" on page 15.

 2 Prepare the service references - optional

For Web Service based tests, import your WSDL at this point. For details, 
see "How to Import a WSDL-Based Web Service" on page 116.

For REST services, build the metadata for the service. For details, see "How 
to Create a Template-Based REST Service" on page 125.

Skip this step when using the built-in activities, such as string 
manipulation.
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 3 Create the test flow

Expand the nodes of the Toolbox palette and drag Flow Control activities 
into the canvas: 

➤ Loop. Drag the Loop activity into the canvas to add a loop other 
than the standard Test Flow. Specify a loop condition in the input 
properties.

➤ Condition. Drag a Condition activity into the Test Flow or Loop 
frame. Specify a condition in the input properties. 

➤ Sleep. Drag a Sleep activity into the Test Flow or Loop frame. 
Indicate a time delay in milliseconds.

 4 Add activities to the test

Expand the nodes of the Toolbox palette and drag activities into the Text 
Flow box within the canvas. If you added a Condition step, drag activities 
into the condition branches.

For a list of the activities, see the "Toolbox Palette" on page 59.

 5 Define data for the test

For details, see "How to Assign Data to Test Steps" on page 161 or "How to 
Data Drive a Test Step" on page 165.

 6 Add additional properties - optional

Use the Additional Properties activity to add additional input or output 
parameters to a built-in activity or imported service.

 a Drag the Additional Properties activity from the Miscellaneous 
category, into the Test Flow.

 b Open the Input/Checkpoints view in the Property Sheet. 

 c Add new input and output properties based on your needs.
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 d Drag the activity from the toolbox for which you want to utilize these 
new properties, into the Additional Properties frame within the Test 
Flow.

 7 Create a Custom Code activity - optional

Select the Custom Code activity from the Miscellaneous category and 
drag it into a loop.

 a Open the Input/Checkpoints view in the Property Sheet. 

 b Add new input and output properties based on your needs.

 c Open the Events view in the Property Sheet. 

 d Double-click the Handler column of the ExecuteEvent row. Service Test 
opens a new tab SharedUserCode.cs. 

 e Locate the TODO section and enter your custom code. Follow the 
sample code in the comments and use autocompletion to write your 
code. 

 f Click File > Save All to save all buffers of the test.

For details and examples, see Appendix A, "Coding Service Test Events."
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 8 Add attachments to the test - optional

For Web Service activities that support input attachments, add an input 
attachment: 

 a Select the Web Service in the canvas and open the Attachments view 
in the Property Sheet. 

 b In the upper pane, select an attachment Type: DIME or MIME.

 c Click on Attachments and select Add Array Element from the shortcut 
menu.

 d Select an Origin for the attachment using the Browse button. 

 e Select an Origin Type, Content Type. Specify a Content ID or keep the 
default value, Auto. 

To validate an output attachment:

 a Select the Web Service in the canvas and open the Attachments view 
in the Property Sheet. 

 b Click on Attachments in the bottom pane, in the Output Attachments 
node. Select Add Array Element from the shortcut menu.

 c Select the check box adjacent to each item that you want to validate. 
Specify values for the elements being validated: Content Type and/or 
Content ID. 

 d To validate content, click the Calculate the file checksum button icon 
in the Content row. Service Test calculates the file’s checksum using 
the MD5 Hash function. 

For user interface details, see "Attachments View" on page 81. You can 
also check for received attachments in the test’s folder, stored as files with 
a bin extension.
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 9 Set up a JMS message - optional

 a Click in the canvas and open the Test Settings view in the Property 
Sheet. Set the Java test settings for the VM and JMS. For details, see the 
"Test Settings View" on page 66.

 b Expand the JMS node in the toolbox and drag a JMS activity into the 
canvas. 

 c Set the step’s properties. Click on the step in the canvas, and open the 
Input/Checkpoints view in the Property Sheet. Enter a Queue, 

Subscription, Topic name, and any other relevant property values. 

 d For Send activities, specify a message.

 e For Receive activities, select the output properties you want to validate 
in the Checkpoints pane and specify their values.

For more details, see "JMS Transport Overview" on page 36.

 10 Configure SOAP Fault information - optional

To apply negative testing to a Web service:

 a Open the SOAP Fault view.

 b Select Fault is expected.

 c Provide SOAP Fault checkpoint values for the negative testing:

➤ To work In the XML layout: Expand the SOAP nodes and define Any 
elements for the SOAP Header and Body. If relevant, provide values 
for faultcode, faultstring, or faultactor.

➤ To work with Xpath expressions: Click the Xpath tab and use the 
Add button to add new Xpath entries. Copy the XPATH entry into 
the cell.

For details, see the "SOAP Fault View" on page 76.

 11 Specify an event handler - optional 

For non-custom code activities, you can define default event handlers for 
checkpoints, before step executions, and after step executions.
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The checkpoint event handlers help you verify the output values in your 
test. You can use a Report, Assert, or Log function to gather information 
about your service. 

To add a checkpoint event handler for an activity:

 a Select an activity title in the canvas and open the Events view in the 
Property Sheet.

 b In the CodeCheckPoint row, select Create a default handler.

 c Edit the code in the SharedUserCode.cs tab. Locate the TODO section 
and add your custom code. Follow the sample code in the comments 
and use auto-complete to create an expression.

 d To access the properties of an activity, cast it beforehand. For example:

 e Click File > Save All to save all buffers of the test.

For details and examples, see Appendix A, "Coding Service Test Events.".

Tip: To instruct Service Test to ignore all event handlers, select a handler 
and press DELETE to clear the field in the grid.

ConcatenateStringsActivity cat = args.Activity as ConcatenateStringsActivity;
args.Checkpoint.Assert.Equals(cat.Prefix+cat.Suffix, cat.Result);
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 12 Run the test

Run the test and view the report. For more information, see "How to Run 
a Test" on page 187.

How to Implement UFT testing 

This task describes how to incorporate tests from other HP applications to 
provide Unified Functional Testing solution (UFT). THese applications 
include QuickTest Professional, Virtual User Generator, and Service Test. For 
details, see "UFT (Unified Functional Testing)" on page 36.

This task includes the following steps:

➤ "Prerequisites" on page 47

➤ "Add a QuickTest test activity - optional" on page 48

➤ "Add a LoadRunner script activity - optional" on page 49

➤ "Add a Service Test test - optional" on page 49

 1 Prerequisites

Make sure you have installed the application whose test/script you want 
to call:

➤ QuickTest test step: Make sure you have QuickTest Professional 11.00. 
Create the test in QuickTest Professional and run it at least once.

➤ Virtual User Generator step: Make sure you have HP LoadRunner 
11.00. Generate a test with the Virtual User Generator, or use a test 
that you enabled for load testing in Service Test.
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 2 Add a QuickTest test activity - optional

 a In Service Test, expand the Unified Functional Testing node in the 
Toolbox palette. Drag the Call QuickTest Professional Test activity into 
the canvas. 

Tip: Do not insert a call to a QuickTest test that contains a call to a Service 
Test test, as this can cause unexpected behavior.

 b Open the Property Sheet’s Input/Checkpoints view, and click the Select 
QTP Test button. Select a QuickTest Professional version 11.00 (or 
higher) test.

 c If the QTP test changed at its source, you can update it in Service Test. 
In the Input/Checkpoints view, click Update properties. 

 d Service Test imports the properties defined in the QuickTest test. You 
can edit the properties manually, data drive them, or load values from 
a replay.

 e Add other relevant steps to your test.

 f Save and run the test.

Note: The first time you invoke QuickTest Professional in a test step, you 
may need to wait several seconds for Service Test to invoke QTP and load 
the test.
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 3 Add a LoadRunner script activity - optional

 a In Service Test, expand the Unified Functional Testing node in the 
Toolbox palette. Drag the Call Virtual User Generator Script activity 
into the canvas. 

 b Open the Property Sheet’s General view, and click the Browse button 
in the Script Path row. Select a VuGen (Virtual User Generator) .usr 
file.

 c Add other relevant steps to your test.

 d Save and run the test.

 4 Add a Service Test test - optional

 a Expand the Unified Functional Testing node in the Toolbox palette. 
Drag the Call Service Test test activity into the canvas. 

 b Open the Property Sheet’s General view., and click the Select ST Test 
button. Select a test version 11.00 (or higher).

 c To update a test that has already been loaded, click Update ST Test. 

 d To specify a custom directory for the results, click the Browse button in 
the Results Directory row in the General view. Select a directory for the 
results.

 e Add other relevant steps to your test.

 f Save and run the test.

How to Create a Call to a Java Class 

The Call Java Class activity lets you to add Java steps to your test script. This 
feature allows you to incorporate existing Java code into your test.

This task describes how to create the Java call and includes the following 
steps:

➤ "Prerequisite - open a test" on page 50

➤ "Set the global Java settings - optional" on page 50

➤ "Implement the Service Test Java interface" on page 50
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➤ "Package your custom step - optional" on page 51

➤ "Add a Call Java Class activity" on page 51

➤ "Open the Java Class Setting dialog box" on page 51

➤ "Set the Java Call properties" on page 51

➤ "Provide Input parameters" on page 51

➤ "Run the test." on page 52

 1 Prerequisite - open a test

Create a new test. For details, see "How to Create a New Test" on page 15.

 2 Set the global Java settings - optional

To set global VM (Virtual Machine) settings, click in the canvas outside of 
the Test Flow, and open the Test Settings  view in the Property Sheet. For 
details, see the "Test Settings View" on page 66.

 3 Implement the Service Test Java interface

Run javac.exe in JDK 1.6 or earlier, to implement the Service Test 
interface. The interface, ServiceTestCall.java, is located in the 
<ST_INSTALL_HOME>\addins\ServiceTest\JavaCall\Java 
Interface\src\hp\st\ext\java folder. 

This interface provides the essential information to Service Test: input 
properties, output properties, and a point of entry.

For example, the following code implements the "Hello World" sample 
provided with Service Test:

javac "C:\Program Files\HP\Service Test 11\addins\ServiceTest\JavaCall\Java 
Interface\src\hp\st\ext\java\*.java" "C:\Program Files\HP\Service Test 
11\addins\ServiceTest\JavaCall\Java Interface\src\hp\st\ext\java\sample\*.java"



Chapter 2 • Working with Service Test

51

 4 Package your custom step - optional

Package your java classes into a jar file. This is optional, since you can also 
provide a package root for the class.

 5 Add a Call Java Class activity

In Service Test, expand the Java node in the Toolbox palette, and drag the 
Call Java Class activity into the canvas. 

 6 Open the Java Class Setting dialog box

Click on the Java step in the canvas, and open the Input/Checkpoints 
view in the Property Sheet. Click the Select Java File button to open the 
Call Java Class Settings dialog box. 

For general guidelines, see "Java Testing" on page 32.

 7 Set the Java Call properties

In the Call Java Class Settings dialog box: 

 a Provide a classpath. If you packaged your Java step, click the Jar button 
and point to the jar file. Alternatively, click the Package root button to 
select a package root folder.

 b Click the Browse button in the Selected Java Class box, to locate the 
class within the jar file or the folder. Make sure it is a class that 
implements the ServiceTestCall interface.

 c To provide additional classpaths, click the Jar or Folder buttons in the 
Additional Classpaths section to browse for a jar file or classpath folder. 
Click Add to move the contents into the list. 

 d Click OK to save the Java Call settings. 

For user interface details, see the "Call Java Class Settings Dialog Box" 
on page 95. 

 8 Provide Input parameters

In the Property Sheet’s Parameter view, provide values for the step’s input 
parameters.
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 9 Run the test.

Run the test and view the results in the Run Results Viewer.
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References

The Service Test User Interface

The Service Test interface lets you design a test by dragging activities into a 
canvas.

This section includes:

 ➤ Service Test Main Window on page 53

 ➤ Tests Pane on page 57

 ➤ Toolbox Palette on page 59

 ➤ Property Sheet on page 63

 ➤ Output Tab on page 93

 ➤ Errors Tab on page 94

 ➤ Call Java Class Settings Dialog Box on page 95

Service Test Main Window 

This screen is the main window box of the Service Test.

To access Select Start > HP Service Test 11.00 > HP Service Test 
11.00

Relevant tasks "How to Populate a Test" on page 41



Chapter 2 • Working with Service Test

54

User interface elements are described below (unlabeled elements are 
indicated by angle brackets):

UI Elements (A-Z) Description

Create New Test. Opens the Create New Test dialog box.

Open Test. Prompts you to open an existing test.

Add New Test. Opens the Add New Test dialog box.

Save. Saves the file in the active tab.

Tip: Select File > Save Test As… to save the test to a new 
location.

Save All. Saves all open files.

ALM/QC Connection. Opens the HP ALM/QC 
Connection dialog box for defining server information 
and logging into an ALM/QC project. 

Enable Load Testing. Enables the test for Load Testing.

Note:

➤ This button adds a menu to the Run button, to run the 
test in Load Testing mode.

➤ The button is disabled if you created the test with the 
Load Test template.

➤ Run Project. Saves, compiles and runs the current 
project.

➤ Run Test (Load Test). Saves, compiles and runs the 
current test in Load Test mode with the mdrv driver.

Note: The Run Test option is only available for Load Test 
type tests (created with the Load Test template or 
converted from the standard template to a load test).

➤ Break Test. Pauses the test run.

➤ Continue Test. Resumes the test run from the point of 
the Break.
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Stop. Stops the current test run.

Zoom Controls:

➤ Default Zoom. Restores the default enlargement of the 
objects in the canvas.

➤ Zoom in. Enlarges the objects in the test canvas.

➤ Zoom out. Reduces the objects in the test canvas.

The following step commands are only active when the 
test is in Break mode.

➤ Step Over. Executes the current statement. If the 
statement calls another procedure, Service Test will 
not step into that procedure. It will run the procedure, 
and advance to the next statement in the current 
procedure.

➤ Step Into. Executes the current statement. If the 
statement calls another procedure, Service Test steps 
into that procedure.

➤ Step Out. If you used Step Into and the control moved 
to a called procedure, Step Out runs the current 
procedure, and returns to the procedure from which it 
was called.

Opens one of the Import dialog boxes:

➤ Import Service from URL/UDDI. Opens the Import 
Service from URL/UDDI dialog box. For user interface 
details, see the "Import Service from URL/UDDI Dialog 
Box" on page 134. 

➤ Import Service from FIle/ALM Application 
Component. Opens the Select Service dialog box for 
importing a WSDL from the file system or HP ALM/
QC with HP Service Test Management. For user 
interface details, see the "Select Service Dialog Box" on 
page 133. 

UI Elements (A-Z) Description
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<.Editor / Designer 
pane>

A series of tabs, to view and edit the file selected in the 
left pane: For example:

➤ visual display of the test (default).

➤ C Sharp files (.cs)

➤ XSD files (.xsd)

➤ Solution file (.sln)

Data Window tab Displays the data from an Excel or XML file, or local 
tables. You can use this data in your tests.

➤ Data Explorer. An expandable/collapsible tree 
hierarchy of the table data.

➤ New. Creates a new data node in the Data Explorer 
through:

➤ Excel File. Opens the Add New Excel File Data 
Query dialog box for creating a new set of data. For 
details, see the "Add New Excel File Data Query 
Dialog Box" on page 168.

➤ Local Table. Opens the Add New Local Table Data 
Query wizard. For details, see the "Add New Local 
Table Data Query Dialog Box" on page 169.

➤ XML. Opens the Add New XML Data Query dialog 
box. For details, see the "Add New XML Data Query 
Dialog Box" on page 170.

➤ Delete. Removes the selected data query.

Errors tab Displays errors, warning, and messages about the test 
run.

The default location is the bottom pane.

Output tab Displays the Output log for the compilation and test run. 
For details, see "Output Tab" on page 93.

The default location is the bottom pane.

Tests pane Displays the test components in a tree hierarchy. For 
details, see the "Tests Pane" on page 57.

The default location is the left pane.

UI Elements (A-Z) Description
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Tests Pane

The Tests pane enables you to view all the test components in a tree 
hierarchy. 

The following elements are included (unlabeled GUI elements are shown in 
angle brackets):

Property sheet A series of screens showing the general properties, 
schemas, snapshots, and event information for the 
activity selected in the canvas. For details, see "Property 
Sheet" on page 63. 

Note: Only active when viewing the canvas.

Toolbox palette A tree view of all of the available activities. This includes 
built-in activities and operations of imported services. 
For details, see the "Toolbox Palette" on page 59.

The default location is the left pane.

To Access View > Tests (Ctrl+Alt+L)

Relevant Tasks "How to Create a New Test" on page 15

See Also "Test User Interface" on page 19

UI Elements Description

Show All. Shows/hides all files associated with current 
test.

Refresh. Refreshes the Tests tree.

Open. Opens a tab with the contents of the selected file.

Note: Only available for the st, canvas file.

UI Elements (A-Z) Description
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<Test> Tree Tree hierarchy of the test components. Expanding the 
parent node displays all the references and dependent 
files.

Tip. To view all files, click the Show All button.

<Test> Tree

- Solution context 
menu

➤ Build Solution. Begins a new build (F8).

➤ Rebuild Solution. Rebuilds the current solution 
(Alt+F8).

➤ Clean Solution. Performs a clean build.

➤ Add. Allows you to add a New Test, Existing Test, New 
Solution Folder, or another Item to the solution tree.

➤ Paste. Pastes a solution from the clipboard.

➤ Rename. Renames the current solution node.

<Test> Tree - Project 
context menu

➤ Build commands: Build, Rebuild, Clean

➤ References: Add Reference

➤ Open/Run: Open With…, Run Project

➤ Edit: Cut, Paste, Remove, Rename

<Test> Tree - 
References context 
menu

➤ Add Reference. Opens the Add Reference dialog box.

<Test> Tree - File 
context menu

➤ Refresh 

➤ Remove

<Test> Tree - Test file 
(*.st) context menu

➤ Open commands: Open, Open With…, Open 
Containing Folder in Explorer

➤ Add commands: New Item, Existing Item, New Folder, 
Existing Folder, New Dependent Item, Existing 
Dependent item

➤ Edit commands: Cut, Copy, Paste, Delete, Rename

UI Elements Description
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Toolbox Palette

The Toolbox palette enables you to view all of the available activities. This 
includes imported services and built-in activities such as that you can use in 
your visual design, such as Replace String or File Exists.

Toolbar Controls

The following toolbar controls elements are included in the Toolbox Palette:

To Access Use one of the following:

➤ Click the Toolbox tab in the left pane (Plain layout)

➤ View > Toolbox

Important 
Information

➤ Drag components from this tab into the canvas.

➤ When you drag an activity into the canvas, it becomes 
a step in the test.

➤ Only available when viewing the Toolbox tab.

Relevant Tasks "Create the test flow" on page 42

Tree Elements Description

Expand All. Expands all nodes in the Activity list.

Collapse All. Collapses all node in the Activity list.

Add Resource. Adds a resource under the selected node.

Note: Located adjacent to the Filter box, for the REST 
Services node only.

Add Method. Adds a method under the selected node.

Note: Located adjacent to the Filter box, for the REST 
Services node only.

Delete. Delete a service, resource, or method.

Note: Located adjacent to the Filter box, for the REST 
Services node only.
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Activity Groups

The following Activity groups are included in the Toolbox palette (in 
alphabetical order):

Rename. Rename a service, resource, or method.

Note: Located adjacent to the Filter box, for the REST 
Services node only.

<Filter box> Filters the toolbox display by the entered text.

Group name Description

File System Provides access to the following file related activities:

➤ File Exists. Returns true if the file exists.

➤ Folder Exists. Returns true if the folder exists.

➤ File Copy. Copies a file to a new destination.

➤ File Move. Moves a file to a new destination.

➤ File Create. Creates a new file.

➤ File Delete. Deletes a file.

➤ File Rename. Renames a file.

➤ Write to File. Writes to an existing or new file.

➤ Read from File. Retrieves text from a file.

Flow Control Provides access to the following control flow activities:

➤ Condition. Allows you use a branching mechanism 
based on the value of a property.

➤ Loop. A loop frame whose properties can be set 
independent of the Test Flow.

➤ Break. Halts the test execution.

➤ Continue. Resumes the test execution after a break.

➤ Sleep. Pauses the test execution for a specific 
amount of time.

For details, see "Flow Control" on page 25.

Java Calls a Java class. For details see the "Call Java Class 
Settings Dialog Box" on page 95.

Tree Elements Description
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JMS Activities that allow you to handle JMS messages:

➤ Publish Message to Topic

➤ Receive Message from Queue

➤ Receive Message from Topic

➤ Send Message to Queue

➤ Send and Receive Message from Queue

➤ Subscribe to Topic

For details, see "JMS Settings" on page 66.

Load Testing Activities that allow you prepare the test for Load Testing, 
such as Start Transaction and End Transaction.

Miscellaneous Provides access to the following miscellaneous activities:

➤ Custom Code. Allows you to program a step to execute 
your own activity.

➤ Additional Properties. Defines additional properties 
for built-in or imported services.

➤ Set Test Variable. Defines global variables for your test.

➤ Run Program. Invokes an application the Service Test 
machine.

➤ End Program. Closes an open application.

➤ Report Message. Sends a custom message to the Run 
Results.

Network Activities that allow you to handle the transport method, 
such as HTTP. 

Rest Services Lets you define resources and methods for a REST Service. 

For details, see "How to Create a Simple Test for a REST 
Service" on page 122.

Group name Description
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String Manipulation Provides access to the following string manipulation 
activities:

➤ Concatenate Strings. Joins two strings.

➤ Replace String. Replaces part of a string with an 
alternate string.

➤ Substring. Extracts the characters between two 
specified locations of a string.

➤ Trim String. Removes whitespace characters from 
the beginning or end of a string.

System Provides access to the operating system variables:

➤ Set OS Environment Variable

➤ Get OS Environment Variable

Unified Functional 
Testing 

➤ Call Service Test test. Invokes a Service Test test when 
the current Test Flow or loop reaches this step.

➤ Call QuickTest Professional test. Invokes a QTP 
(QuickTest Professional) test when the current Test 
Flow or loop reaches this step. Do not insert a call to a 
QuickTest test that contains a call to a Service Test test, 
as this can cause unexpected behavior.

➤ Call VuGen script. Runs a VuGen (LoadRunner’s 
Virtual User Generator) script.

Note: The first time you invoke QTP in a test step, you 
may need to wait several seconds for Service Test to 
invoke QTP and load the test.

For details, see "How to Implement UFT testing" on 
page 47.

Web Services ➤ SOAP Request. Sends a manual SOAP request to the 
server, usually in XML format. You can import a 
schema and load XML for this activity. For details, see 
"Input/Checkpoints View" on page 70.

➤ <Imported Web service methods>. For imported Web 
services, a tree hierarchy showing:

➤ level 1 - services

➤ level 2 - ports

➤ level 3 - operations

Group name Description
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Property Sheet

Displays a series of tabs showing the general properties, schemas, and event 
information for the activity selected in the canvas.

The following elements are included (unlabeled GUI elements are shown in 
angle brackets):

To Access View > Property Sheet

Important 
Information

➤ Only active when the canvas is visible.

➤ The toolbar displays different buttons based on the 
type of activity or view. 

➤ The buttons to the left of the horizontal divider, are 
View buttons, such as General or Events views.

➤ The buttons to the right of the horizontal divider, are 
Action buttons, such as Data-Drive and Load XML. 
These differ based on the view. For details, see the 
specific view.

Relevant Tasks ➤ "How to Populate a Test" on page 41

➤ "How to Set Security for a Web Service" on page 118

UI Elements Description

Test Settings view. Java related settings that apply to all 
test steps. This is only visible when clicking in the 
canvas, outside of the Test Flow. For details, see "Test 
Settings View" on page 66.

Service Test test view. The path and properties of the 
Service Test test to be called from this step. This is only 
visible when selecting a Call Service Test test activity.

General view. Shows the general properties of the 
selected element. By default it shows the Step ID as it 
appears in the Toolbox, and the Name as it is shown in 
the canvas.

For details, see "General View" on page 68.
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Input/Checkpoints view. The input properties and the 
checkpoint values for those properties. The top section 
shows the input properties; the bottom shows the 
checkpoints.

Tip: A triangular icon indicates an optional element. 
Toggle the triangle to include or exclude an element. A 
filled-in triangle indicates an included element. 

For REST and Custom Code: Use the  Add button to 
create new parameters.

For details, see "Input/Checkpoints View" on page 70. For 
REST and HTTP types, see "REST HTTP Input View" on 
page 78.

SOAP Fault view. The SOAP fault settings for the Web 
Service steps.

HTTP view. The body of the input request and the 
checkpoints (HTTP activities and REST services only).

For details, see the "HTTP View" on page 78.

REST HTTP Input view. The HTTP input elements for. 
REST services.

For details, see the "REST HTTP Input View" on page 78.

Events view. Lets you select a handler function for a step’s 
events, or to open an editor to write code describing what 
to do when the event occurs.

Tip: The Create a default handler option lets you create a 
default event handler. For details, see the "Events View" 
on page 80.

Attachments view. A list of attachments associated with 
the Web Service step. For details, see "Attachments View" 
on page 81.

Note: This view is only available for Web Service steps.

UI Elements Description
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Security Settings view. Allows the setting of Security 
Scenarios and security tokens for the Web Service. For 
details, see "Security Settings View" on page 82.

Note: This view is only available for Web Service steps.

Test Variables view. Displays the User and Test variables, 
and allows you to create Test Variable profiles. For details, 
see "Test Variables View" on page 77.

Note: This view is only available when selecting the Start 
or End steps, or by clicking in the canvas outside of the 
Test Flow.

Data Queries view. Allows you to select data queries for 
the loop, and set their policies. For details, see the "Data 
Queries View" on page 82.

Note: This view is available when selecting the Test Flow 
frame or a loop’s frame in the canvas.

Data Query Properties view. Allows you to define and 
edit data relations between tables. For details, see the 
"Define/Edit New Data Relation Dialog Box" on page 181.

Note: This view is only available when selecting a query 
in the Data window.

<data grid> Information about the step selected in the canvas, 
depending on the view: 

➤ General view. Activity name and comments.

➤ Input/Checkpoints view. Properties, checkpoints, and 
their values,

➤ Events view. A list of the events and their handlers.

➤ Data Query view. A list of queries for the selected step.

Comments An editable note describing the purpose of the step. 
Service Test also places the comment in the test report. 

UI Elements Description



Chapter 2 • Working with Service Test

66

Test Settings View
Test settings apply to all the activities in the test. User interface elements are 
described below:

Load Settings

JVM (Java Virtual Machine) Settings

JMS Settings

UI Elements Description

Load enabled 
(read-only)

Indicates whether the test is enabled for load testing. To 
enable load testing, select Test > Enable Test for Load.

Note: Once a test is enabled for load testing, you cannot 
disable it.

UI Elements Description

Classpath The vendor implementation of JMS classes together with 
any other required supporting classes, as determined by 
the JMS implementation vendor.

Additional VM 
Parameters

Extra parameters to send to the JVM such as 
Xbootclasspath, and any parameters specified by the JVM 
documentation.

UI Elements Description

JNDI initial context 
factory

The fully qualified class name of the factory class that 
will create an initial context. Provides a list of context 
factories and allows manual entries.

JNDI provider URL The URL of the service provider. For example:
Websphere - iiop://myserver:myport

JMS connection 
factory

The JNDI name of the JMS connection factory. This 
setting is unique per test.

JMS security principal Identity of the principal (for example the user) for the 
authentication scheme.
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JMS security 
credentials

The principal’s credentials for the authentication 
scheme.

Number of JMS 
connections per 
process

The number of JMS connections each execution process 
creates. The default is 1, and the maximum is 50. The 
fewer connections you have, the better your 
performance.

Received message 
timeout options

The timeout for received messages. The default is No 
wait.

➤ Indefinite wait. Wait as long as required for the 
message before continuing.

➤ No wait. Do not wait for the Receive message, and 
return control to the script immediately. If there 
was no message in the queue, the operation fails. 

➤ User defined timeout. Wait a specified number of 
seconds for the message. If it does not arrive, the 
operation fails. (default)

User defined timeout The amount of seconds to wait for the message before 
timing out. The default is 20 seconds.

Automatically 
generate selector

Generates a selector for the response message with the 
correlation ID of the request (No by default). Each JMS 
message sent to the server has a specific ID. Enable this 
option if you want Service Test to automatically create a 
selector that includes the message ID.

Note: This option only affects the Send and Receive 
Message from Queue activity.

UI Elements Description
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General View

User interface elements are described below (unlabeled elements are shown 
in angle brackets). The properties differ based on the activity type.

UI Elements (A-Z) Description

Properties - default ➤ Step ID. A unique ID for the step.

➤ Name. Step name as it should appear in the canvas.

Properties - HTTP ➤ Proxy. The settings for the proxy server hosting the 
service contract: Server (URL and port when required), 
Username, and Password.

➤ Authentication. The user credentials settings for 
obtaining a service contract: Username and Password.

➤ Connection Type: Keep-Alive (default) or Close.

➤ Timeout. The HTTP timeout in milliseconds.

➤ ClientCertificate. Details about the client certificate:

➤ File System: The full path of the certificate file.

➤ Windows Store: The certificate properties 
StoreLocation, StoreName, X509Type, and 
X509FindValue.

➤ Password. The certificate’s password.

➤ Maximum Automatic Retries. The number of times to 
attempt accessing a page, by default 3.

➤ Allow Redirections. Allow the step to redirect to 
another URL. Default is true.

➤ Reuse Cookies. Enables the reusing of cookies for the 
current step. Default is false.

Properties - Service 
Test Test/ QTP Test / 
VuGen Script

➤ Script Path. The path of the Service Test or QTP test, or 
VuGen (LoadRunner’s Virtual User Generator) script to 
run.
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Properties - Web 
Services

Service Test derives these properties from the WSDL file:

➤ Endpoint Address. The endpoint location of the 
service as derived from the WSDL.

➤ SoapAction. An expression indicating the SOAP 
action, for example, HP.SOAQ.SampleApp/
IHPFlights_Service/DeleteFlightOrder.

➤ ContentType. For example text/xml; charset=utf-8.

➤ IsOneWay. A variable indicating whether the service is 
a one way service: true or false.

Comment An editable note describing the purpose of the step. 
Service Test also places the comment in the test report. 

UI Elements (A-Z) Description
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Input/Checkpoints View

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Elements (A-Z) Description

<properties list> A list of all the properties. The fields differ per step type:

➤ For the Start step: Test Input Parameter 

➤ For the End step: Test Output Parameter 

➤ For activities and Web Services: Input properties

➤ For SOAP Requests (under Web Services category): 

➤ Standard Schema. A schema for the SOAP request.

➤  Imports a schema XSD file.

➤ . Loads XML with values for the schema.

➤ . Deletes the current schema.

➤ For HTTP activities: 

➤ URL. The endpoint URL of the service.

➤ HTTP method. GET, POST, PUT, DELETE, TRACE, 
OPTIONS, HEAD, and CONNECT.

➤ HTTP version. 1.0 or 1.1

➤ Request Headers. Keys and their values, and arrays.

➤ Checkpoints. HTTP version, Status code, Status 
description, and Response body.

➤ For JMS activities, see "JMS Transport Overview" on 
page 36.

<loop settings> The loop settings for the iteration such as the number of 
iterations, conditions, and so forth.

Note: To set these properties, click on the frame of the 
Test Flow or Loop.

For details, see the "Loop Settings" on page 72.
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<checkpoint list> A list of the step’s output parameters, displaying the 
following columns:

➤ Checkpoints. A list of the output parameters.

➤ Validate. When checked, validates the current output 
parameters when running the step. When unchecked, 
ignores the parameters.

➤ Value. The expected value for the output parameter. 
Provides a dropdown list for comparison operators, 
number scrolling, and boolean values. You can 
manually enter the expected value into the cell.

<context menu> Provides shortcuts for including properties and setting 
their values:

➤ Set Auto-value. Inserts a sample value for the 
argument, based on its data type.

➤ Include All. Includes all properties.

➤ Exclude All. Excludes all properties.

➤ Copy XPath. Copies the XPath expression of the value 
to the clipboard.

➤ Link to a data source. Opens the Select Link Source 
dialog box.

➤ Clear cell contents. Clears the contents of the cell.

Tip: Right-click in Values column to see the menu.

Checkpoint 
properties

Additional checkpoint properties:

➤ Trim whitespace (from start and end of string). 
Removes whitespace before and after the text.

➤ Ignore case. When looking for a match, ignores the 
case.

➤ Stop test if checkpoint fails. Exits the test run if the 
checkpoint fails. You set this individually for each 
checkpoint.

Note: You must click on a row in the Checkpoint section 
to see these properties. The first two properties are only 
available for string data types. 

UI Elements (A-Z) Description
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Loop Settings
The following iteration settings are available for the Test Flow or other 
custom loops:

Send request to 
service.

Sends the step’s request to the service when running the 
test. This is the normal behavior for Web Services and 
most types of actions. It is activated by default.

To send messages using JMS transport, clear this check 
box. Link a subsequent JMS step to the output of this 
step, to obtain the value of a JMS key.

Value column The property value as a constant value or a query. 

An icon adjacent to the value provides information about 
the property, such as read-only, data type, optional, and 
allows you to choose values when appropriate. 

For a list of the most common icons, see the "Value 
Column Icons" on page 73.

Tip: Click inside a row to display the relevant icons. 

Note: To view the buttons and icons, click within a row 
of the Value column.

UI Elements (A-Z) Description

For Loop Performs the Test Flow or custom loop the number of 
times that you specify in the Number of Iterations box. 

Do While Loop - 

Use condition

Repeats the loop as long as the specified condition is met:

➤ Variable. The variable to evaluate. Use the Select Link 
Source button  to enter a query expression.

➤ Operator. A comparison operator, relevant to the 
variable such as =, !=, Contains, Starts and Regex.

➤ Value. The value with which to compare the result.

UI Elements (A-Z) Description
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Value Column Icons
The following icons represent information, dropdown lists, or actions 
within the Parameter view’s Value column:

Do While Loop - 

Use event

Performs iterations until the event returns True. This 
mode is useful for complex conditions that can be 
defined in an event handler. When you select this 
option, the Input Properties grid opens.

➤ Click . to define properties.

➤ Click . to open the Events view. Click Create a 
default handler in the Handler column. 

➤ Modify or add code to the event handler method that 
defines your condition.

For Each Loop Performs an iteration for each element in the associated 
array or collection of objects. Data is selected using the 
Select Link Source button .

Note: When you delete data from a data table, Service 
Test continues to run an iteration for that row, with 
empty values. To remove an entire row of a data, click the 
row and select Delete from the shortcut menu (only with 
Excel installations).

UI 
Elements

Description

 Include argument in the request. Toggle to clear the triangle and 
exclude the argument.

  Include an array element. Toggle to clear the box and exclude the 
array element.

 Set to NIL. Toggle to clear the icon and remove the NIL value 
assignment.

 Read-only node. Values that cannot be changed such as properties 
linked to a data source other than a constant value, or nodes with 
read-only attribute in the activity signature, first HTTP header, and 
so forth.

UI Elements (A-Z) Description
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Action Buttons - Input/Checkpoints View

The following buttons represent actions within the Input/Checkpoints view:

 Warning. A warning related to the data query. For example, The 
data types of the link source and link destination do not match.

 ➤ For Input properties:
A dropdown list of possible values. For example, for boolean 
values it provides a list of values for boolean type data: true, 
false, 0, or 1. For date types, it opens a calendar. This dropdown 
arrow is located adjacent to the Link to a data source button 

. 

➤ For Checkpoints:
A dropdown list of the relevant comparison operators such as: 
=,!=, >, >=, <, <=, Starts, Ends, Contains, or Regex. The greater 
than operator, >, when used with strings, indicates that it 
appears later in the alphabet.

 Scroll. A scroll control for integer data types.

 Browse. Allows you to locate a file or folder for a File System type 
activity.

 Link to a data source. Opens the Select Link Source Dialog Box 
allowing you to select values for the property from a query. For 
details see "Select Link Source Dialog Box" on page 174.

UI Elements Description

Data Drive Entire Step. Data-drives all values for the step. 
It adds query terms to the value columns of all input 
properties.

For details, see "How to Data Drive a Test Step" on 
page 165.

Load from Replay. Loads XML data in order to populate a 
service’s schema with values.

For details, see "How to Run a Test" on page 187.

UI 
Elements

Description
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Select Java File. Opens the Call Java Class Settings Dialog 
Box for setting additional classpaths for the call.

For details, see the "Call Java Class Settings Dialog Box" 
on page 95.

Add New Input/Output Property. Opens the Add New 
Input/Output Property dialog box, allowing you to 
define a new property and its data type.

Note: This only applies to the Custom Code/Property 
steps, REST steps, and the Start/End steps, or when 
selecting the entire canvas.

For details, see "Coding Service Test Events" on page 261.

Remove Property. Deletes the selected property from the 
list.

Note: This only applies to the Custom Code/Property 
steps, REST steps, and the Start/End steps, or when 
selecting the entire canvas.

Select QTP/ST Test For Call QTP Test and Call Service Test steps: Invokes the 
Open Test dialog box for selecting the test to call from 
this step. 

Update QTP/ST Test For Call QTP Test and Call Service Test steps: Updates the 
QTP or Service Test test from its original location. 

UI Elements Description
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SOAP Fault View

User interface elements are described below: This view is only available for 
Web Service or SOAP activities.

For more information about SOAP faults and how they can be used for 
Negative testing, see "Negative Testing" on page 114.

For task details, see "Configure SOAP Fault information - optional" on 
page 45.

UI Elements Description

Fault is expected Indicates that a SOAP fault is expected during the test 
run. This setting confirms that the application did not 
perform a task that it was not designed to perform.

XML tab The SOAP envelope, containing the Header and Body of 
the SOAP message. In this section you enter the expected 
response.

You can define Any type elements or values for the 
following properties: 

➤ faultcode. A status code indicating that the SOAP 
request was invalid.

➤ faultstring. A response string indicating that the SOAP 
request was invalid.

➤ faultactor. An indication of the source of the fault.

XPath tab A list of XPATH expressions used to evaluate the SOAP 
response.

➤ . Adds a line for an XPATH expression.

➤ . Removes the selected entry.
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Test Variables View

User interface elements are described below: This view is only available 
when selecting the canvas, Start step, or End step.

Action Buttons - Test Variables View

The following buttons represent the actions available from the Test 
Variables view (unlabeled elements are shown in angle brackets):

UI Elements Description

User variables A list of the user variables for all profiles. When enabling 
the Compare Profiles option, the grid displays the 
variable values for each profile in separate columns.

System variables A read-only list of common system variables and their 
values: ScenarioID, SystemTempDir, GroupName, 
TestDir, TestName, LocalHostName, OS, OSVersion, 
ProductDir, ProductName, ProductVer, and UserName.

UI Elements Description

Add New User Variable. Adds a new user variable to the 
all profiles.

Remove User Variable. Deletes the selected user variable 
from all profiles. 

Add New Profile. Adds a new User Variable profile to the 
list.

Edit Active Profile. Enables you to remove or rename a 
profile.

Compare Profiles. Displays the profiles side-by-side for 
comparison.

<Profile list> A list showing the existing User Variable profiles.
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REST HTTP Input View

For REST Services, you can set the method’s HTTP settings and use them as a 
template for that method. User interface elements are described below:

HTTP View

For REST Services and HTTP activities. User interface elements are described 
below (unlabeled elements are shown in angle brackets):

UI Elements (A-Z) Description

Input The REST Input properties:

➤ Endpoint Address. The endpoint URL for the REST 
service.

➤ HTTP Method. GET, POST, PUT, DELETE, TRACE, 
OPTIONS, HEAD, and CONNECT.

➤ HTTP Version. 1.0 or 1.1

➤ Request Headers. Keys and their values, and arrays.

Checkpoints The REST output properties for validation:

➤ HTTP Version. 1.0 or 1.1

➤ Status Code. An integer indicating the status code.

➤ Status Description. A textual description of the 
status. 

➤ Response Body. The body returned by the server.

Tip: To validate a property, make sure to select its check 
box.

UI Elements (A-Z) Description

Clear. Clears the contents of the:

➤ Request Body (upper pane)

➤ Checkpoint keys (lower pane) 

For Text body types, imports a file containing the body of 
the request.

For XML body types, imports a schema file.
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Loads an XML file with Body request values, that 
correspond to the loaded schema. (Body: XML only)

Browse. Allows you to load a non-XML file containing 
the request body (Body: File only)

<checkpoint list> A list of the checkpoints keys and their values in the 
bottom pane.

<request body> The body of the request loaded through a file, pasted 
from a clipboard (Edit > Paste), or manually entered 
(POST form)

Body (top) The data type of the request body. Text, XML, File, or Post 
Form.

Default: Text

Body (bottom) The data type of the response body. Text or XML.

Default: Text

UI Elements (A-Z) Description
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Events View

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

For details about writing event handlers, see "Specify an event handler - 
optional" on page 45.

UI Elements Description

<Events list> - default A list of events for the activity:

➤ CodeCheckPointEvent. Triggered when the activity is 
executed.

➤ AfterExecuteStepEvent. Triggered after the activity was 
executed.

➤ BeforeExecuteStepEvent. Triggered before the activity 
is executed.

Tip: For details about an event, select it and choose 
Create a default handler. Refer to comments in the 
template.

<Events list> - 
Web Services

➤ AfterGenerateRequest

➤ AfterProcessRequestSecurity

➤ AfterProcessRequestAttachments

➤ OnSendRequest

➤ OnReceiveResponse

➤ BeforeProcessResponseAttachments

➤ BeforeProcessResponseSecurity

➤ BeforeSaveResponse

➤ BeforeApplyProtocolSettings

For details about Web Services, see "Defining Services" on 
page 97.

Handler The handler to call when the event is detected. Choose 
Create a default handler if no handler is available. This 
opens the SharedUserCode.cs tab for editing the handler 
template.
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Attachments View

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

For task details, see "Add attachments to the test - optional" on page 44.

UI Elements Description

<Input Attachment> Input attachments for the current Web Service step:

➤ Type. Attachment type: NONE, DIME, or MIME.

➤ Attachments. A list of the input attachments and their 
properties:

➤ Origin. The file to send as an attachment.

➤ Origin Type. The attachment type. File is default.

➤ Content Type. The attachment’s content type: 
application/zip, image/gif, image/ief, image/jpeg, 
image/png, image/tiff, text/plain, text/richtext, 
text/html, or text/xml.

➤ Content ID. A unique ID for the attachment or Auto 
for an ID generated by Service Test.

Note: To add input attachments, click Attachments and 
choose Add Array Element from the shortcut menu.

<Output 
Attachment>

The server response saved as an attachment.

➤ Attachments. A list of the output attachments and 
their properties to validate:

➤ Content. The file content’s checksum value. The 
checksum is computed by applying the MD5 hash 
function to the file. 

➤ Content Type. The attachment’s content type. 

➤ Content ID. The unique ID of the attachment. 

Note: To add output attachments, click Attachments and 
choose Add Array Element from the shortcut menu.

Tip: To validate an output attachment, select the check 
boxes adjacent to the elements you want to validate. 
Received attachments are saved in the test’s folder, with 
bin extensions.
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Security Settings View

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

For task details, see "How to Set Security for a Web Service" on page 118.

Data Queries View

User interface elements are described below:

UI Elements Description

Opens the Advanced Settings dialog box. For details see 
"Advanced Settings Dialog Box" on page 137.

Note: Not available for Web Service type scenarios.

Saves the security scenario settings to an stss file, for use 
by other tests.

Loads security scenario settings from a previously saved 
scenario file.

Service Details A list of the available scenarios: Web Service, WCF 
Service (Custom Binding), WCF Service (Federation), or 
WCF Service (Http Binding).

For information on choosing a scenario, see "Setting 
Security Overview" on page 98.

For user interface details about each of the scenarios, see 
the "Security Scenarios User Interface" on page 84.

UI Elements Description

Opens the Attach Query to Loop dialog box for selecting 
queries from the Data Window tab.

Opens the Data Navigation dialog box for setting the 
data policy—the way to use the data from the table. For 
user interface details, see "Data Navigation Dialog Box" 
on page 178.
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For details about setting policies, see "How to Set the Navigation Properties" 
on page 164.

Data Query Properties View

User interface elements are described below:

For details about defining data relations, see "Create a new child relation - 
optional" on page 161.

Deletes the selected data query from the list—not from 
the Data Window.

Data Navigation 
Policies

A list of the data queries sorted by: 

➤ Query Name. The name of the query from the Data 
Window.

➤ Policy. A summary of the data navigation policy, for 
example: Start at first row, froward one row, wrap 
around.

UI Elements Description

Opens the Define New Data Relation dialog box. For user 
interface details, see "Define/Edit New Data Relation 
Dialog Box" on page 181

Opens the Edit Data Relation dialog box. For user 
interface details, see "Define/Edit New Data Relation 
Dialog Box" on page 181.

Deletes the selected data relation from the list.

Relations A list of the data queries sorted by: 

➤ Child Query. The sheet or table to use for the query.

➤ Primary Key. A column in the parent query to use as a 
primary key for the child relation.

➤ Foreign Key. The column in the child query to use as a 
foreign key for the child relation.

UI Elements Description



Chapter 2 • Working with Service Test

84

Security Scenarios User Interface

Using the Property Sheet’s Security Settings view, you can configure a 
security scenario for your test. 

For examples, see "How to Set up Common Web Services Security Scenarios" 
on page 129.

This section includes: 

➤ "Web Service Scenario Details" on page 84

➤ "WCF Service (Custom Binding) Scenario Details" on page 88

➤ "WCF Service (Federation) Scenario Details" on page 90

➤ "WCF Service (HTTP Binding) Scenario Details" on page 91

Web Service Scenario Details 

The Web Service scenario provides the HTTP, WS-Security, and 
WS-Addressing tabs.

HTTP tab

The HTTP tab lets you provide the user credentials for sending a message 
over HTTP. The user interface elements are described below.

UI Elements Description

User name, Password The credentials for HTTP authentication such as basic 
authentication, digest, or NTLM. For example, User 
name: myDomain\myUser Password: myPassword

Client certificate The client credentials required for client certificate 
authentication when using two-way SSL scenarios. 

The Browse button opens the "Select Certificate Dialog 
Box" on page 138.

Proxy URL The URL and port of the proxy server through which the 
message must pass. For example, http://myProxy:8888/.
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WS-Security tab

The WS-Security tab provides an interface to add message level security 
using tokens, message signatures, and encryption. The user interface 
elements are described below. (unlabeled elements are shown in angle 
brackets).

Proxy user name, 
Proxy password

The credentials for the proxy server through which the 
message must pass.

Keep alive Keeps the connection persistent.

Connection timeout The time threshold in which to connect through the 
proxy server or with authentication. 

UI Elements Description

Add a token. User Name, X509, Kerberos, Kerberos2, or 
SAML.

Add a message signature. Adds a signature to the 
message. This requires a token.

Add encryption. Adds encryption to the message. This 
requires a token.

Delete. Removes the security element from the list.

Up/Down. Positioning tools that allow you to set the 
priority of the security elements. 

Important: Make sure the security elements are 
positioned in order of their priority.

<security element 
list>

A list of the tokens, message signatures, and encryptions.

UI Elements Description
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<Token details pane> 
- Username tokens

Token details for Username tokens. 

➤ Logical name. An meaningful name for the token (you 
can use the default value).

➤ Include nonce. Include a nonce in the token.

➤ User name, Password

➤ Password type: (Text, Hash, None)

➤ Timestamp format: Created is the default value

<Token details pane> 
- X509 Certificate 
tokens

Token details for X509 Certificate tokens:

➤ Logical name. An meaningful name for the token.

➤ Server certificate. The path of the server certificate file. 
The Browse button opens the Select Certificate Dialog 
Box.

➤ Reference type: How the token should be referenced: 
BinarySecurity Token or Reference. When the 
certificate is used for encryption, for example, a service 
certificate, use Reference. When using it for a 
signature (for example, a certificate with your private 
key) choose BinarySecurity Token.

<Token details pane> 
- Kerberos tokens

Token details for Kerberos tokens:

➤ Logical Name. An meaningful name for the token.

➤ Host. The host name of the server to which you want 
to authenticate. In most cases, it is the host portion of 
the service URL.

➤ Domain. The Windows domain of the server to which 
you want to authenticate.

<Token details pane> 
-SAML tokens

Token details for SAML tokens:

➤ Load from file. Allows you to browse for a SAML 
certificate.

➤ Client certificate. The path of the client certificate file. 
The Browse button opens the Select Certificate Dialog 
Box.

➤ Certificate reference type. How the certificate should 
be referenced— by X509 Data or RSA.

UI Elements Description
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<Signature details 
pane>

The details of the digital signature used to secure the 
token.

➤ Use token. The token to use for signing, usually an 
X.509 type. Select from the dropdown list of all added 
tokens. 

➤ Target token. The token you want to sign. Select from 
the dropdown list of all added tokens (optional). With 
most services, this field should be left empty.

➤ Target path. An XPath which specifies which parts in 
the message to sign. If left blank, the elements selected 
in the Signature options field are signed. 

➤ Canonicalization algorithm. A URL for the algorithm 
to use for canonicalization. A dropdown provides 
common algorithms. If you are unsure which value to 
use, keep the default.

➤ Transform algorithm. A URL for the Transform 
algorithm to apply to the message signature. A 
dropdown provides common algorithms. If you are 
unsure which value to use, keep the default.

➤ Inclusive namespaces list. A list of prefixes to be 
treated as inclusive (optional).

➤ Signature options. Which SOAP elements should be 
signed: Body, Timestamp, and WS-Addressing. 

Tip: You can also specify an XPATH in the message which 
you want to be signed. e.g. //*[local-name(.)='Body']

UI Elements Description
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WS-Addressing tab

The WS-Addressing tab indicates whether WS-Addressing is used by the 
scenario, and if so, its version number.

WCF Service (Custom Binding) Scenario Details 
Use this scenario to test WCF services which require security or transport 
configurations. User interface elements are described below (unlabeled 
elements are shown in angle brackets). For details see "WCF Service (Custom 
Binding) Scenarios" on page 103.

<Encryption details 
pane>

The details of the encryption token.

➤ Use token. The token to use for encryption, usually an 
X.509 type. A dropdown box provides a list of all 
available tokens. 

➤ Target token. The name of the encrypted token. A 
dropdown box provides a list of all added tokens. With 
most services, this field should be left empty.

➤ Target path. An XPath which indicates the parts of the 
message to encrypt. If left blank, only the SOAP body 
is encrypted. 

➤ Type. Whether to encrypt the whole destination 
Element or only its Content.

➤ Key algorithm. The algorithm to use for the 
encryption of the session key: RSA15 or RSAOAEP.

➤ Session algorithm. The algorithm to use for the 
encryption of the SOAP message. A dropdown list 
provides common values.

UI Elements Description

Opens the Advanced Settings dialog box. For details see 
"Advanced Settings Dialog Box" on page 137.

Transport Transport type. HTTP, HTTPS, TCP, NamedPipe, or 
AutoSecuredHTTP.

UI Elements Description
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For details about additional security settings, see the "Advanced Settings 
Dialog Box" on page 137.

Encoding Message encoding. Text, MTOM, or WCF Binary

Security Authentication mode. For a list of modes, see "WCF 
Service (Custom Binding) Scenarios" on page 103.

Note: If you choose a the SecureConversation mode, 
select a Bootstrap Policy.

Net Security The type of stream security: None, Windows stream or 
SSL stream.

Reliable Messaging Enables Reliable Messaging in Ordered Or Non-ordered 
format.

Identities The identity information for the bindings and certificate:

➤ Username and Password

➤ Server /Client Certificates

➤ Expected DNS, SPN, and UPN

Client Windows 
Identity

The identity information for the client windows:

➤ Current User logged onto the machine

➤ Custom User with the following credentials:

➤ Username

➤ Password

➤ Domain

UI Elements Description
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WCF Service (Federation) Scenario Details 
In the WCF Service (Federation) scenario, the client authenticates against 
the STS (Security Token Service) to obtain a token. The client uses the token 
to authenticate against the application server.

User interface elements are described below (unlabeled elements are shown 
in angle brackets). For details see "WCF Service (Federation) Scenarios" on 
page 105.

For details about additional security settings, see the "Advanced Settings 
Dialog Box" on page 137.

UI Elements Description

Opens the Advanced Settings dialog box. For details see 
"Advanced Settings Dialog Box" on page 137.

Server Transport Transport. The transport type: HTTP or HTTPS.

Encoding. The server’s encoding policy: Text or MTOM.

Security Authentication mode. The authentication mode for the 
scenario. For a list of modes, see "WCF Service 
(Federation) Scenarios" on page 105.

Note: If you choose a the SecureConversation mode, 
select a Bootstrap Policy.

Identities The identity information for the bindings and certificate:

➤ Server Certificate. The Browse button opens the Select 
Certificate Dialog Box.

➤ Expected DNS. The expected identity of the server in 
terms of its DNS. This can be localhost, an IP address, 
or server name.

STS (Security Token 
Service)

Information about the security token:

➤ Issuer address. The address of the issuer of the STS. 
This can be localhost, an IP address, or a server name.

➤ Referenced binding. The scenario which references 
the binding that contacts the STS (Security Token 
Service).
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WCF Service (HTTP Binding) Scenario Details 
In the WCF Service (Http Binding) scenario, you can choose from several 
types of authentication: None, Windows, Certificate, or Username (message 
protection). For details see "WCF Services (Http Binding) Scenarios" on 
page 106.

User interface elements are described below (unlabeled elements are shown 
in angle brackets) by the client authentication types:

Client Authentication Type — None

UI Elements Description

Opens the Advanced Settings dialog box. For details see 
"Advanced Settings Dialog Box" on page 137.

Client authentication 
type

Authentication type: None, Windows, Certificate, or 
Username.

UI Elements Description

Negotiate server 
credentials

Negotiates the Web Service’s certificate with the server.

You can also provide the server’s DNS information.

Specify service 
certificate

The location of the service’s certificate. If you select this 
option, the Negotiate service credentials option is not 
relevant.

For more information, see the "Select Certificate Dialog 
Box" on page 138.

Expected server DNS The expected identity of the server in terms of its DNS. 
This can be localhost, an IP address, or a server name. It 
can also be the common name by which the certificate 
was issued.
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Client Authentication Type — Windows

Client Authentication Type — Certificate

UI Elements Description

Expected server 
identity

The expected server identity method SPN or UPN.

Client Windows 
identity

The identity information for the client windows:

➤ Current User logged into the machine

➤ Custom User with the following credentials:

➤ Username

➤ Password

➤ Domain

UI Elements Description

Client certificate The location of the client certificate. The Browse button 
opens the Select Certificate Dialog Box.

Negotiate server 
credentials

Negotiates the Web Service’s certificate with the server.

You can also provide the server’s DNS information.

Specify service 
certificate

The location of the service’s certificate. If you select this 
option, the Negotiate service credentials option is not 
relevant. 

For more information, see the "Select Certificate Dialog 
Box" on page 138.

Expected server DNS The expected identity of the server in terms of its DNS. 
This can be localhost, an IP address, or a server name. It 
can also be the common name by which the certificate 
was issued.
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Client Authentication Type — Username (message protection)

Output Tab

Enables you to view the output messages that were generated while 
compiling and running the test.

UI Elements Description

Username, Password The authentication credentials of the client.

Negotiate server 
credentials

Negotiates the Web Service’s certificate with the server.

You can also provide the server’s DNS information.

Specify service 
certificate

The location of the service’s certificate. If you select this 
option, the Negotiate service credentials option is not 
relevant. 

For more information, see the "Select Certificate Dialog 
Box" on page 138.

Expected server DNS The expected identity of the server in terms of its DNS. 
This can be localhost, an IP address, or a server name. It 
can also be the common name by which the certificate 
was issued.

To Access  View > Output (Ctrl+Alt+O)

Important 
Information

Click on a row to navigate to the code that generated the 
output message.

Relevant Tasks "How to Run a Test" on page 187
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The following elements are included (unlabeled GUI elements are shown in 
angle brackets):

Errors Tab

Enables you to view a list of the errors generated during the test run, and 
their level of severity: message, warning, or error.

GUI Element (A-Z) Description

Clear All. Clears all the information in the message 
window.

Toggle Word Wrap. Wraps the text of each message onto 
the next line

<Show Output from> Dropdown list for selecting the output to display: Build, 
Design, Debug, or Run.

Default: Run

<message window> Displays all build and debug information issued to the 
log during the test run.

To Access Click Errors tab in bottom pane or select View > Errors or 
Ctrl+Alt+K

Important 
Information

➤ Click on a row to jump to the line in the code that 
generated the error.

➤ Click any column header, for example Line or File, to 
sort by that criteria.

Relevant Tasks "How to Run a Test" on page 187

See Also "Alerts" on page 26
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The following elements are included:

Call Java Class Settings Dialog Box

This dialog box enables you to configure the settings for a call to a Java class.

UI Elements (A-Z) Description

Displays the errors detected during the test run.

Displays the warnings detected during the test run.

Displays the informational messages detected during the 
test run.

! (Exclamation Point) Message Type:

➤ Error

➤ Warning 

➤ Informative message

Description Description of the error, warning or message and advice 
on how to fix the problem.

File The file that generated the error, warning, or message.

Line The line number in which the error was detected. 

Path The complete path of the file that generated the error.

To access ➤ Add a Call Java Class step to the canvas.

➤ In the Property Sheet, open the Java Call Input Output 
Input/Checkpoints view .

➤ Click the Select Java File button.

Relevant tasks "How to Create a Call to a Java Class" on page 49



Chapter 2 • Working with Service Test

96

User interface elements are described below:

UI Elements Description

Select location The location of the Java class.

➤  - Opens the Select Jar File dialog box. 

➤  - Opens the Browse for Folder dialog 
box to select a root folder. 

Select Java class The Java class to associate with the Call Java Class step. 
When you click Browse, Service Test shows the classes in 
the specified jar file. 

System classpath The paths you defined in the Test Settings for system 
classpaths.

To modify this setting, click in the canvas (outside the 
Test Flow or Loop) and open the Property Sheet’s General 
view. Modify the Test Setting’s JVM > Classpath node.

Additional classpaths 
box

Additional classpaths to associate with the Call Java Class 
step.

➤  - Opens the Select Jar File dialog box. 

➤  - Opens the Browse for Folder dialog box to 
select a folder containing the .class file. 

<additional classpath 
list>

A list of jar files or folders containing the additional 
classes.

➤  - Adds the contents of the Additional 
Classpath box to the additional classpath list. 

➤  - Removes the selected entry from the list. 
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3
Defining Services 

This chapter includes:

Concepts

➤ Preparing Service References on page 98

➤ Setting Security Overview on page 98

➤ Security Scenarios Overview on page 99

➤ WCF Scenario Settings on page 103

➤ Advanced Security Settings on page 109

➤ Negative Testing on page 114

Tasks

➤ How to Import a WSDL-Based Web Service on page 116

➤ How to Set Security for a Web Service on page 118

➤ How to Create a Simple Test for a REST Service on page 122

➤ How to Create a Template-Based REST Service on page 125

➤ How to Set up Common Web Services Security Scenarios on page 129

Reference

➤ Import Service User Interface on page 133

➤ Security User Interface on page 136

Tips and Guidelines on page 139
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Concepts

Preparing Service References

Service Test lets you import or define services for the purpose of creating 
high-level tests. 

For Web Services, you typically begin creating a test by importing a WSDL 
file. This file provides a structure for the test, since it describes the service in 
terms of its elements, argument values and properties. For information on 
importing a WSDL, see "How to Import a WSDL-Based Web Service" on 
page 116.

If your service document is unique and cannot be imported in the normal 
way, you can use the SOAP Request activity to send a manual SOAP request 
to the server. action - when ST doesn't support the service/wsdl type.

For REST services, you define the metadata manually by modelling the 
service and defining your own methods. For task details, see "How to Create 
a Template-Based REST Service" on page 125.

Setting Security Overview

When building Web Service applications, there is a challenge in building 
scalable applications that are secure. You can secure Web Services by having 
the message sent over a secure transport, such as Secure Sockets Layer (SSL), 
or by applying security at the message level, also known as WS-Security. 

For testing a secured service, answering the following questions will help 
you define your security scenario.

➤ Is there transport security, such as SSL? What is the HTTPS URL?

➤ Is basic authentication required?

➤ Is mutual authentication required?

➤ What type of security is required in the SOAP header?



Chapter 3 • Defining Services

99

For task details, see "How to Set Security for a Web Service" on page 118.

Security Scenarios Overview

Service Test provides several built-in scenarios for configuring security in 
Web Service calls.

A security scenario represents a typical environment of a Web Service 
security and contains information such as security, encoding, proxy, 
certificates, and so forth. 

A default Web Service scenario can be used for most Web services. It allows 
you to configure both transport and message-level security. Service Test 
support for message-level security lets you manually configure the security 
elements such as tokens, message signatures, and encryption. For details, see 
"Web Service Security Scenario" on page 100.

WCF scenarios allows you to configure security for HTTP or custom 
bindings and work with advanced specifications, such as 
WS-SecureConversation.

Note: When testing Web Services that require message-level security, the 
Web Service security scenario only supports SOAP version 1.1. For SOAP 1.2 
use a WCF type scenario.

The built-in security scenarios are

➤ Web Service Security Scenario

➤ WCF Service (Custom Binding) Scenarios

➤ WCF Service (Federation) Scenarios

➤ WCF Services (Http Binding) Scenarios

Use the default Web Service scenario for:

➤ Simple Web Services where no advanced standards are required.
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➤ Web services using HTTP transport level security or message level security 
(WS-Security). 

Use a WCF scenario to:

Test WCF Services that utilize advanced security and WS-Specifications. 
Such services can be written in various platforms such as WCF (Windows 
Communication Foundation), Metro (WSIT), and Axis2. Service Test also 
supports proprietary standards and transports.

Web Service Security Scenario 
The default Web Service scenario is based on the WS-Security specification. 
This scenario lets you place security credentials in the actual SOAP message. 

When a SOAP message sender sends a request, the security credentials, 
known as tokens, are placed in the SOAP message. When the Web server 
receives the SOAP request, it does not need to send additional requests to 
verify the integrity of the sender. The server verifies that the credentials are 
authentic before letting the Web Service execute the application. By not 
having to go back to the source of the credentials, the application’s 
scalability improves significantly.

To further secure Web Services, it is common to use digital signatures or 
encryption for the SOAP messages. Digitally signing a SOAP message verifies 
that the message has not been altered during transmission. Encrypting a 
SOAP message helps secure a Web Service by making it difficult for anyone 
other than the intended recipient to read the contents of the message.

The default Web Service security scenario contains the following tabs: HTTP, 
WS-Security, and WS-Addressing. The HTTP tab lets you configure the 
transport security, the WS-Security tab handles the message-level security, 
and the WS-Addressing tab sets the addressing version.

For user interface details, see "Security Settings View" on page 35.

Transport Level Security

The transport level security includes the authentication and proxy server 
information. You can also specify Keep Alive preferences and connection 
timeout. For user interface details, see "Security Settings View" on page 35.
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Message Level Security

The WS-Security tab lets you set the message level security through tokens, 
signatures and encryption. 

To support WS-Security, Service Test allows you to create security tokens for 
your script. You can create multiple tokens and set their properties. After 
creating a token, you use it to sign or encrypt a SOAP message.

The Web Services security mechanism associates security tokens with 
messages. This mechanism supports several security token formats to 
accommodate a variety of authentication requirements. For example, a 
client might need to provide a proof of identity or a security certificate.

The available tokens are Username Token, X.509 Certificate Token, Kerberos 
Token, Kerberos2 Token, and SAML. 

➤ User Name Token. The User Name and Password token contains user 
identification information for the purpose of authentication: User Name 
and Password. You can also specify Password Options, indicating how to 
send the password to the server for authentication: Text, None, or Hash. 

➤ X.509 Certificate Token. This security token is a token based on an X.509 
certificate. To obtain a certificate, you can either purchase it from a 
certificate authority, such as VeriSign, Inc. or set up your own certificate 
service to issue a certificate. Most Windows servers support the public key 
infrastructure (PKI) which enable you to create certificates. You can then 
have it signed by a certificate authority or use an unsigned certificate.

➤ Kerberos Token/Kerberos2 Ticket. (for Windows 2003 or XP SP1 and 
later) The Kerberos protocol is used to mutually authenticate users and 
services on an open and unsecured network. Using shared secret keys, it 
encrypts and signs user credentials. A third party, known as a KDC 
(Kerberos Key Distribution Center), authenticates the credentials. After 
authentication, the user may request a service ticket to access one or more 
services on the network. The ticket includes the encrypted, authenticated 
identity of the user. The tickets are obtained using the current user’s 
credentials.
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The primary difference between the Kerberos and Kerberos2 tokens is that 
Kerberos2 uses the Security Support Provider Interface (SSPI), so it does 
not require elevated privileges to impersonate the client's identity. In 
addition, the Kerberos2 security token can be used to secure SOAP 
messages sent to a Web Service running in a Web farm.

➤ SAML Token. SAML is an XML standard for exchanging security-related 
information, called assertions, between business partners over the 
Internet. The assertions can include attribute statements, authentication, 
decision statements, and authorization decision statements.

SAML uses brokered authentication with a security token issued by STS 
(Security Token Service). The STS is trusted by the client and the Web 
Service to provide interoperable security tokens. SAML tokens are 
important for Web Service security because they provide cross-platform 
interoperability and a means of exchanging information between clients 
and services that do not reside within a single security domain.

Message Signatures and Encrypted Data

When you add a security token to a SOAP message, it is added to the SOAP 
message in the form of an XML element in the WS-Security SOAP header. 

The message, however, is exposed and therefore requires additional security. 
This is especially true when the credentials, including the password, are sent 
in plain text as it is with role-based security.

The two methods used to secure the data are message signatures and 
message encryption. 

➤ Message Signatures. Message Signatures are used by the recipients to 
verify that messages were not altered since their signing. The signature is 
in the form of XML within the SOAP message. The recipient checks the 
signature to make sure it is valid.

➤ Message Encryption. Although the XML message signature offers a 
mechanism for verifying that the message has not been altered since it 
was signed, it does not encrypt the SOAP message—the message is still 
plain text in XML format. To secure the message in order that it should 
not be exposed, you encrypt it, making it difficult for an intruder to view 
and obtain a user’s password.
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For task details, see "How to Set Security for a Web Service" on page 118.

WCF Scenario Settings 

This section describes the values required for the WCF security scenarios: It 
includes:

➤ "WCF Service (Custom Binding) Scenarios" on page 103

➤ "WCF Service (Federation) Scenarios" on page 105

➤ "WCF Services (Http Binding) Scenarios" on page 106

WCF Service (Custom Binding) Scenarios
The WCF Service (Custom Binding) scenario enables the highest degree of 
customization. Since it is based upon WCF customBinding, it allows you to 
test most WCF services, along with services on other platforms such as Java 
that use WS - <spec_name> specifications.

Use the WCF Service (Custom Binding) scenario to configure a scenario that 
does not comply with any of the predefined security scenarios. You can use 
Service Test’s default settings or customize the following elements:

➤ Transport. HTTP, HTTPS, TCP, or NamedPipe

➤ Encoding. Text, MTOM, or WCF Binary
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Specify the following security information:

➤ Authentication mode. None, AnonymousForCertificate, 
AnonymousForSslNegotiated, CertificateOverTransport, Kerberos, 
KerberosOverTransport, MutualCertificate, MutualSslNegotiated, 
SecureConversation, SspiNegotiated, UserNameForCertificate, 
UserNameForSslNegotiated, UserNameOverTransport, or 
SspiNegotiatedOverTransport.

➤ Bootstrap policy. For the SecureConversation authentication mode, you 
can specify a bootstrap policy: AnonymousForCertificate, 
AnonymousForSslNegotiated, CertificateOverTransport, Kerberos, 
KerberosOverTransport, MutualCertificate, MutualSslNegotiated, 
SspiNegotiated, UserNameForCertificate, UserNameForSslNegotiated, 
UserNameOverTransport, or SspiNegotiatedOverTransport.

➤ Net security. For TCP and Named Pipe transports, you can set the network 
security. Select None, Windows stream security, or SSL stream security. 
For services with HTTP transport, leave the default value, None. To enable 
SSL for HTTP, choose the HTTPS transport.

Reliable Messaging

If your Web Service uses Reliable messaging, enable the option, and select 
Ordered or Not Ordered.

Identities

Your security settings may require you to provide identity details for either 
the client and server, or both of them. 

An example of identity details for the client, are user name/password or an 
X.509 certificate.

For identity information, provide one or more authentication details as 
required by the service:
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Username, Password, Server certificate, Client certificate, or a custom 
Windows identity. For details about choosing a certificate, see "Select 
Certificate Dialog Box" on page 138.

Some scenarios require you to declare the expected identity of the server in 
terms of its DNS, SPN, or UPN identity.

➤ DNS. Provide the name of a server or use localhost.

➤ SPN. Provide the SPN identity in the domain\machine format.

➤ UPN. Provide the UPN identity in the user@domain format.

After setting the basic values, you can set advanced attributes as described in 
"Advanced Security Settings" on page 109.

Note: For WSE3 security configurations, use the WCF Service (Custom 
Binding) Scenario. For details, see "How do I test a WCF service?" on 
page 139.

WCF Service (Federation) Scenarios 
In the WCF Service (Federation) scenario, the client authenticates against 
the STS (Security Token Service) to obtain a token. The client uses the token 
to authenticate against the application server.

Therefore, two bindings are needed, one against the STS and another against 
the application server. 

Click the Browse button in the Referenced binding field to define an STS 
binding. Then, fill in the following Security Details for the application 
server’s security scenario:

Server

➤ Transport. HTTP or HTTPS

➤ Encoding. Text or MTOM
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Security

➤ Authentication mode. IssuedToken, IssuedTokenForCertificate, 
IssuedTokenForSslNegotiated, IssuedTokenOverTransport, or 
SecureConversation.

➤ Bootstrap policy. IssuedToken, IssuedTokenForCertificate, 
IssuedTokenForSslNegotiated, or IssuedTokenOverTransport.

Identity

➤ Server certificate. Browse for a server certificate. For more information, 
see the "Select Certificate Dialog Box" on page 138.

➤ Expected DNS. The expected identity of the server in terms of its DNS. 
This can be localhost, an IP address, or a server name.

STS (Security Token Service)

➤ Issuer address. The address of the issuer of the STS. This can be localhost, 
an IP address, or a server name.

➤ Referenced binding. The scenario which references the binding that 
contacts the STS (Security Token Service).

For task details, see "Set up a WCF Federation scenario - optional" on 
page 120.

WCF Services (Http Binding) Scenarios 

Note: The WCF Service (Http Binding) scenario only supports the testing of 
WCF services which utilize wsHttpBinding and incorporate some level of 
security. To test WCF services that use wsHttpBinding but have no security, 
use the WCF Service (Custom Binding) scenario.
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In the WCF Service (Http Binding) scenario, you can choose from several 
types of authentication: None, Windows, Certificate, or Username (message 
protection).

For all of the authentication types, you can apply advanced settings as 
described in "Advanced Security Settings" on page 109.

No Authentication (Anonymous)

In this scenario, the client uses the server's certificate to encrypt a message; 
there is no client authentication.

You specify only one of the following settings:

➤ Negotiate service credentials. Negotiate the Web Service’s certificate with 
the server.

➤ Specify service certificate. Browse for a service certificate. For more 
information, see "Select Certificate Dialog Box" on page 138. If you select 
this option, the Negotiate service credentials option is not available.

You can also provide the server’s DNS information.

➤ Expected server DNS. The expected identity of the server in terms of its 
DNS. This can be localhost, an IP address, or a server name. It can also be 
the common name by which the certificate was issued.

Windows Authentication

This WCF scenario uses Windows Authentication. If you are testing a WCF 
service that has not been customized and uses the default configuration, use 
this type of scenario.

You declare the expected identity of the server in terms of its SPN or UPN 
identities.

You declare the expected identity of the client in terms of the current user 
credentials or those of a custom user. If you choose the identity of a custom 
user, you provide, a Username, Password, and Domain.
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Certificate Authentication

In this WCF WSHttpBinding scenario, the client uses the server’s X.509 
certificate to encrypt the message and its own certificate for a signature.

Specify only one of the following settings:

➤ Negotiate service credentials. Negotiate the Web Service’s certificate with 
the server.

➤ Specify service certificate. Browse for a service certificate. For details, see 
"Select Certificate Dialog Box" on page 138. If you select this option, the 
Negotiate service credentials option is not available.

Provide the DNS information:

➤ Expected server DNS. The expected identity of the server in terms of its 
DNS. This can be localhost, an IP address, or a server name. It can also be 
the common name by which the certificate was issued.

Username Authentication (Message Protection)

In this WCF WSHttpBinding scenario, the client uses the server’s X.509 
certificate to encrypt the message, and sends a user name and password to 
authenticate itself.

Specify the following settings:

➤ Username. Password. The client’s user name and password credentials.

Specify only one of the following settings:

➤ Negotiate service credentials. Negotiate the Web Service’s certificate with 
the server.

➤ Specify service certificate. Browse for a service certificate. For details, see 
"Select Certificate Dialog Box" on page 138. If you select this option, the 
Negotiate service credentials option is not available.

You can also provide the server’s DNS information.

➤ Expected server DNS. The expected identity of the server in terms of its 
DNS. This can be localhost, an IP address, or a server name. It can also be 
the common name by which the certificate was issued.
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Advanced Security Settings 

This section describes the Advanced scenario settings to customize a WCF 
Service (Custom Binding) scenario in the areas of Encoding, Advanced 
Standards, Security, or HTTP and Proxy.

Not all settings are relevant for all scenarios, so some of them might be 
disabled or hidden depending on the scenario.

This section includes:

➤ "Encoding" on page 109

➤ "Advanced Standards" on page 109

➤ "Security" on page 110

➤ "HTTP and Proxy" on page 113

Encoding
The Encoding tab lets you indicate the type of encoding to use for the 
messages: Text, MTOM, or WCF Binary. The default is Text encoding.

For each of these encoding methods, you can choose a version of 
WS-Addressing:

➤ None

➤ WSA 1.0 

➤ WSA 04/08

Advanced Standards
This tab lets you configure advanced WS- standards, such as Reliable 
Messaging and the Via address option.

If your service implements the WS-ReliableMessaging specification, you can 
enable the Reliable Messaging option and set the following options:

➤ Reliable messaging ordered. indicates whether the reliable session should 
be ordered
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➤ Reliable messaging version. WSReliableMessagingFebruary2005 or 
WSReliableMessaging11

Via Address

In certain instances, you may need to send a message to an intermediate 
service that submits it to the actual server. This may also apply when you 
send the message to a debugging proxy. This corresponds to the WCF 
clientVia behavior. 

In such cases it may be useful to separate the physical address to which the 
message is actually sent, from the logical address for which the message is 
intended. The logical address may be the physical address of the final server 
or any name. It appears in the SOAP message as follows:

<wsa:Action>http://myLogicalAddress<wsa:Action>

The logical address is retrieved from the user interface. By default, it is the 
address specified in the WSDL. You can override this address from the 
Manage Services dialog box. 

Security
The Advanced security settings correspond to the WS-Security 
specifications.

For security scenarios that are based upon WCF WSHttpBinding, you can 
indicate the following settings:

➤ Enable secure session. Establish a security context using the 
WS-SecureConversation standard.

➤ Negotiate service credentials. Allow WCF proprietary negotiations to 
negotiate the service’s security.
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For Custom Binding WCF type scenarios, you can set the default algorithm 
suite and protection level:

You can customize the security settings in greater detail. The following table 
describes the options and their values:

Attribute Meaning Possible Values

Default algorithm suite The algorithm to use for 
symmetric/
asymmetric encryption.

These are the values 
from the 
SecurityAlgorithmSuite 
configuration in WCF: 

➤ Basic128
➤ Basic128Rsa15
➤ Basic128Sha256
➤ Basic128Sha256Rsa15
➤ Basic192
➤ Basic192Rsa15
➤ Basic192Sha256
➤ Basic192Sha256Rsa15
➤ Basic256
➤ Basic256Rsa15
➤ Basic256Sha256
➤ Basic256Sha256Rsa15
➤ TripleDes
➤ TripleDesRsa15
➤ TripleDesSha256
➤ TripleDesSha256Rsa15

Protection level Should the SOAP Body 
be encrypted/signed

None, Sign, and Encrypt And 
Sign (default)

Attribute Meaning Possible Values

Message protection order The order for signing 
and encrypting

➤ Sign Before Encrypt
➤ Sign Before Encrypt-And 

Encrypt Signature
➤ Encrypt Before Sign

Message security version The WS-Security 
security version

A list of the current 
versions

Security header layout The layout for the 
message header

➤ Strict
➤ Lax
➤ LaxTimeStampFirst
➤ LaxTimeStampLast

Key entropy mode The entropy mode for 
the security key.

➤ Client Entropy
➤ Security Entropy
➤ Combined Entropy
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You can enable or disable the following options:

➤ Require derived keys. Indicates whether or not to require derived keys.

➤ Require security context cancellation. Disabling this option implies 
that stateful security tokens will be used in the 
WS-SecureConversation session (if enabled).

➤ Include timestamp. Includes a timestamp in the header.

➤ Allow serialized signing token on reply. Enables the reply to send a 
serialized signing token.

➤ Require signature confirmation. Instructs the server to send a signature 
confirmation in the response.

For X.509 certificates, you can specify values for the following items:

Attribute Meaning Possible Values

X509 Inclusion Mode When to include the 
X509 certificate

➤ Always to Recipient
➤ Never
➤ Once
➤ Always To Initiator

X509 Reference Style How to reference the 
certificate

➤ Internal
➤ External

X509 require derived keys Should X509 certificates 
require derived keys

➤ Enable - Yes
➤ Disable - No

X509 key identifier clause 
type

The type of clause used 
to identify the X509 
key. 

➤ Any
➤ Thumbprint
➤ Issuer Serial
➤ Subject Key Identifier
➤ Raw Data Key Identifier
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HTTP and Proxy
This tab lets you set the HTTP and Proxy information for your test.

HTTP (S) Transport 

The following table describes the HTTP(S) Transport options:

Option Meaning Possible Values

Transfer mode The transfer 
method for 
requests/responses 

Buffered, Streamed, 
Streamed Request, 
Streamed Response

Max response size (KB) The maximum size 
of the response 
before being 
concatenated

Default 65 KB

Allow cookies Enable cookies Enabled / Disabled

Keep-Alive Enabled Enable keep-alive 
connections

Enabled / Disabled

Authentication scheme HTTP 
authentication 
method

None, Digest, 
Negotiate, NTLM, 
Integrated Windows 
Authentication, Basic, 
Anonymous

Realm The realm of the 
authentication 
scheme

Any URL

Require client certificate For SSL transport, 
require a certificate

Enabled / Disabled
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Proxy Information

If the Web service’s transport uses a proxy server, you can specify its details 
in the Security tab. The following table describes the proxy options:

Negative Testing

When performing a functional test for your Web Service, you should 
approach the testing in a variety of ways. The most common type of testing 
is called Positive Testing—checking that the service does what it was 
designed to do.

In addition, you should perform Negative Testing, to confirm that the 
application did not perform a task that it was not designed to perform. In 
those cases, you need to verify that the application issued an appropriate 
error—a SOAP Fault.

To illustrate this, consider a form accepting input data—you apply positive 
testing to check that your Web Service has properly accepted the name and 
other input data. You apply negative testing to make sure that the 
application detects an invalid character, for example a letter character in a 
telephone number.

Option Meaning Possible Values

Use default web proxy Use machine’s 
default proxy 
settings

Enabled / Disabled

Bypass proxy on local Ignore proxy when 
the service is on 
the local machine

Enabled / Disabled

Proxy address the proxy server Any URL

Proxy authentication 
scheme

HTTP 
authentication 
method on Proxy

Digest, Negotiate, 
NTLM, Basic, 
Anonymous
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When your service send requests to the server, the server responds in one of 
the following ways:

➤ SOAP Result. A SOAP response to the request 

➤ SOAP Fault. A response indicating that the SOAP request was invalid. 
Negative Testing applies only to SOAP faults.

➤ HTTP Error. An HTTP error, such as Page Not Found, unrelated to Web 
Services.

Service Test can check for a standard SOAP result or a SOAP fault response. 
For example, if your Web Service attempts to access a Web page that cannot 
be found, it will issue a 404 HTTP error. Using negative testing you indicate 
that you expect a SOAP fault. In this case, the test run will fail if the service 
accesses a valid Web page.

Service Test’s Property Sheet lets you provide values for the SOAP fault 
header and body. You can enter faultcode, faultstring, and faultactor values 
as well as custom properties using Any type parameters. Using the 
Checkpoint mechanism, you can validate these values and view the results 
in the Run Results Viewer.

For details on setting up the SOAP fault values, see "SOAP Fault View" on 
page 76.
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Tasks

How to Import a WSDL-Based Web Service

This task describes how to import a Web Service into your project.

This task includes the following steps:

➤ "Prerequisites" on page 116

➤ "Open the Import/ Select Service dialog box" on page 116

➤ "Select a source" on page 117

➤ "Set connection settings for URL/UDDI imports - optional" on page 118

➤ "Complete the Import" on page 118

 1 Prerequisites

If you intend to import a WSDL through Service Test Management, the 
ALM/QC extension for application components, open a connection to 
the ALM/QC sever. For details, see the "HP ALM/QC Connection Dialog 
Box" on page 208.

 2 Open the Import/ Select Service dialog box

➤ To import a WSDL from the file system or ALM/QC, click  > 
Import Service from File/ALM Application Component. For details, see the 
"Select Service Dialog Box" on page 133.

Note: Before importing from Service Test Management, first connect to 
the ALM/QC server with Service Test Management (File > ALM/QC 
Connection).
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➤ To import a WSDL from a Web site or UDDI repository, click 
 > Import Service from URL/UDDI. 

➤ For a URL, select Import from: URL

➤ For a UDDI, select Import from: UDDI

For details, see the "Import Service from URL/UDDI Dialog Box" on 
page 134.

 3 Select a source 

➤ For File System or ALM Application Components (Quality Center) 
imports, click the appropriate button in the left pane. Navigate to the 
WSDL in the file system or the ALM/QC repository.

➤ For a URL import, click the Browse button adjacent to the Address field. 
This opens a browser window. Navigate to the WSDL and close the 
browser. Service Test automatically places the URL in the Address field.

➤ For a UDDI, click the Browse button adjacent to the Address field. This 
opens the Select Service from UDDI dialog box. Specify a UDDI address 
and select the service to import. For details, see the "Select Service from 
UDDI Dialog Box" on page 135.



Chapter 3 • Defining Services

118

 4 Set connection settings for URL/UDDI imports - optional

For URL or UDDI imports, if your WSDL must be accessed through a 
secure server or proxy machine, click Connection Settings to expand the 
dialog box. Enter the authentication information or the proxy server 
details.

 5 Complete the Import

Click OK. If Service Test succeeds in importing the WSDL, it displays it in 
the Toolbox palette under the Web Services branch.

How to Set Security for a Web Service

This task describes how to configure security settings for Web Services.

This task includes the following steps:

➤ "Prerequisites" on page 119

➤ "Open the Security Setting view" on page 119

➤ "Set up a Web Services scenario - optional" on page 119

➤ "Set up a WCF Custom Binding scenario - optional" on page 120

➤ "Set up a WCF Federation scenario - optional" on page 120

➤ "Set up a WCF Http binding scenario - optional" on page 121

➤ "Configure advanced settings - optional" on page 122
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 1 Prerequisites

Import a Web Service and drag an operation into the canvas.

 2 Open the Security Setting view

Click  in the Property Sheet to open the Security Setting view.

 3 Set up a Web Services scenario - optional

 a In the Service Details dropdown list, select Web Services (default).

 b If relevant, open the HTTP tab and set the User Name, Password, Proxy 
URL (if not using the default proxy), Proxy User Name, and Proxy 
Password. These settings affect the transport level security. You can 
also set the Keep alive option and the Connection timeout, in seconds. 

 c Click the WS-Security tab (optional). 

➤ To add a token, click  and select a token from the list, Provide the 
token details in the lower pane. The fields differ, based on the token 
type. For details, see "Message Level Security" on page 101.

Note: When adding a SAML token, if you have the complete SAML 
token string, you can paste it directly into the AssertionIDReference 
field. If you do not have the complete token string and you want to 
configure the token manually, make sure that the first row in the 
schema contains the Assertion property—not the 
AssertionIDReference. You can change this using the grid’s 
dropdown menu. 

➤ To add a message signature, (you must first add at least one token), 
click  and select which token to sign in the Use token box, 
usually an X.509 token. Provide the other required information: 
Target token, Target path, Canonicalization algorithm, Transform 
algorithm, Inclusive namespaces list, and Signature options.
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➤ To add a message encryption, (you must first add at least one token), 
click  and select which token to sign in the Use token box. 
Provide the other required information: Target token, Target path, 
Type, Key algorithm, and Session algorithm.

➤ It is essential that you apply the security elements in the correct 
order. Use the Up  and Down  arrows to set the priorities of 
the security elements. The basic order is tokens, followed by 
message signatures, and then encryption. In addition, your service 
may also require a specific order for the tokens. 

 d Click the WS-Addressing tab (optional). Select the relevant version or 
None if WS-Addressing is not used. 

For details about the security elements. see the "Web Service Security 
Scenario" on page 100. For user interface details see "Web Service Scenario 
Details" on page 84.

 4 Set up a WCF Custom Binding scenario - optional

To use WCF bindings:

 a In the Service Details dropdown list, select WCF Service (Custom 
Binding).

 b In the Transport box, select a transport type: HTTP (default), HTTPS, 
TCP, or NamedPipe. Select an Encoding type: Text, MTOM, or WCF 
Binary.

 c Configure the Security, Net Security, Reliable Messaging, and 
Identities information. For guidelines about setting these options, see 
"WCF Service (Custom Binding) Scenarios" on page 103.

For user interface details see "WCF Service (Custom Binding) Scenario 
Details" on page 88.

 5 Set up a WCF Federation scenario - optional

For details about this scenario type, see "WCF Service (Federation) 
Scenarios" on page 105.

 a In the Service Details dropdown list, select WCF Service (Federation).

 b In the Transport box, select a transport type: HTTP (default) or HTTPS.
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 c Select an Encoding type: Text or MTOM.

 d Select an Authentication mode. For the Secure Conversation mode, 
choose a Bootstrap policy. 

 e Set the server Identities—Click the Browse button to locate a certificate 
and optionally, specify the expected DNS.

 f Provide the STS information. Click the Browse button in the Issuer 
Address box to open a browser. Navigate to address location.

 g To apply referenced binding, click the Browse button in the 
Referenced binding field. In the Referenced Scenario dialog box, 
configure the referenced scenario.

For user interface details see "Security Settings View" on page 82.

 6 Set up a WCF Http binding scenario - optional

 a In the Service Details dropdown list, select WCF Service (Http 
Binding).

 b Select a Client authentication type:, None, Windows, Certificate, or 
Username. 

 c For each authentication type, provide the required information. For 
details, see "WCF Services (Http Binding) Scenarios" on page 106.

For user interface details see "WCF Service (HTTP Binding) Scenario 
Details" on page 91.
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 7 Configure advanced settings - optional

For WCF type scenarios, click the Advanced button to set Encoding, 
Advanced Standards (such as Reliable Messaging), Security (such as 
Message Protection and token settings), and HTTP/Proxy preferences. For 
details, see "Advanced Settings Dialog Box" on page 137.

 8 Save the scenario - optional

Your security scenario is automatically saved with the test. If, however, 
you also want to use the settings for another test, without having to 
redefine the scenario, you can save it.

In the Properties Sheet’s Security view, click the Save button. Specify a 
location for the stss scenario file. To use the file in another test, click 
Import.

How to Create a Simple Test for a REST Service

This task describes how to model a REST service and create a simple test. 
Optionally, you can create a template for each method, allowing you to 
reuse it within your test without having to provide the configuration 
settings each time. For details, see "How to Create a Template-Based REST 
Service" on page 125.

This task includes the following steps:

➤ "Add a new REST service" on page 123

➤ "Add a resource" on page 123

➤ "Add a method" on page 123

➤ "Create a test step" on page 123

➤ "Locate the endpoint URL" on page 123

➤ "Enter the input values" on page 123

➤ "Locate the request body" on page 124

➤ "Run the test and view the report" on page 124
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 1 Prerequisite 

Study the structure of the REST Service body and determine which 
resources and methods you need to define.

 2 Add a new REST service

In the Toolbox palette select the REST Services node. Choose Add Service 
from the shortcut menu. Provide a meaningful name for the service.

 3 Add a resource

Select the service node and choose Add Resource from the shortcut menu. 
Provide a meaningful name for the resource. Repeat as required.

 4 Add a method

Select the service or resource node, and choose Add Method from the 
shortcut menu. Provide a meaningful name for the method. Drag the 
method onto the canvas.

 5 Create a test step

Drag the method you created above, into the Test Flow of the canvas. 
Expand the REST service step and click on the HTTP Activity box.

 6 Locate the endpoint URL 

Locate your REST service design document and copy the URL to the 
clipboard. 

 7 Enter the input values

 a Open the Parameter view in the Property Sheet.

 b Paste the clipboard contents, the endpoint URL, into the Endpoint 
Address row. 

 c Select the HTTP Method: GET, PUT, POST and so forth.
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 d Expand the Request Header node. Based on the operation details on the 
Help page, set the header name and value as follows: Type in the key and 
its value. For example, in the Key row you could type Content-Type and in 
the Value row, text/xml.

 8 Locate the request body 

 a Return to the design document for the REST service and copy the 
Request body onto the clipboard.

 b In the Property Sheet, open the HTTP Activity view and select a 
Request Body type from the dropdown list. 

➤ To paste in plain text, select the Text type. For a request body of 
XML in the form of plain text, select Text/xml. The latter removes 
all extra spaces. Copy the Request body from the design document 
to the clipboard. Click within the Body section and press Ctrl-V to 
paste in the contents of the request. Modify the element values 
within the body as required.

➤ For the XML type, click Import Schema to load an XSD file. Edit the 
values for the schema in either the Grid or Text views

➤ For a FIle type, browse for the file with the Request body.

➤ For a Post Form, enter the keys and their values.

 9 Run the test and view the report

Click the Run  button or F5 to compile and run the test. After the test run, 
the Run Results Viewer opens. 

In the left pane of the viewer window, select Expand All from the shortcut 
menu. Select the HTTPActivity node. In the Captured Data pane, verify 
that the Response Body values are correct.
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How to Create a Template-Based REST Service

This task describes how to set up a REST service template. You define the 
request details and parameters of the service directly from the toolbox, 
before dragging into a the Test Flow. Once you create the template, you can 
incorporate the REST activity in your test with minimal configurations.

This task includes the following steps:

➤ "Add a new REST service" on page 126

➤ "Add a resource" on page 126

➤ "Add a method" on page 126

➤ "Locate the endpoint URL" on page 126

➤ "Enter the REST input parameters - optional" on page 126

➤ "Define custom input parameters - optional" on page 127

➤ "Enter the Request body directly - optional" on page 127

➤ "Link the body request to a REST Input parameter - optional" on page 127
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 1 Prerequisite 

Study the structure of the REST Service body and determine which 
resources and methods you need to define.

 2 Add a new REST service

In the Toolbox palette select the REST Services node. Choose Add Service 
from the shortcut menu. Provide a meaningful name for the service.

 3 Add a resource

Select the service node and choose Add Resource from the shortcut menu. 
Provide a meaningful name for the resource. Repeat as required.

 4 Add a method

Select the service or resource node, and choose Add Method from the 
shortcut menu. Provide a meaningful name for the method.

 5 Locate the endpoint URL 

In your REST Service design document, determine the endpoint URL and 
copy it onto the clipboard. 

 6 Enter the REST input parameters - optional

 a In the Toolbox, click on the method you created above. Open the REST 
Input Parameter view in the Property sheet.

 b Paste the clipboard contents, the endpoint URL, into the Endpoint 
Address row. 

 c Select the HTTP Method: GET, PUT, POST, and so forth.

 d Expand the Request Header node. Based on the operation details on 
the Help page, set the header name and value as follows: Type in the 
key and its value. For example, in the Key row you could type 
Content-Type and in the Value row, text/xml.
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 7 Define custom input parameters - optional

For methods that require input, such as PUT or POST, add the required 
input parameters. For methods that provide an output such as GET, add 
the required output parameters. 

 a In the Toolbox palette, select the method you created above. Open the 
Parameter view in the Property Sheet.

 b Expand the Plus  button and select Add Input/Output Property.

 c Add custom parameters as required—provide a name and data type for 
the parameter.

 d Manually provide values for the parameters or click the Link to Source 
button to map to existing data. For more information, see the "Select 
Link Source Dialog Box" on page 174.

 8 Enter the Request body directly - optional

You can enter the Request body directly or data drive the values to use a 
query expression. To data drive the values, see the next step.

 a Return to the design document for the REST service and copy the 
Request body onto the clipboard.

 b In the Property Sheet, open the HTTP Activity view and click within 
the Body section. Press Ctrl-V to paste in the contents of the request. 
Make sure that there no extra spaces before or after the body text.

 c Modify the element values within the XML body as required.

 9 Link the body request to a REST Input parameter - optional

 a Return to the design document for the REST service and copy the 
Request body onto the clipboard.

 b In the Property Sheet, open the HTTP Activity view and click within 
the Body section. 

 c Click the Link to Data button  to the right of the pane, to open the 
Select Link Source dialog box. 
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 d In the Select Link Source dialog box, check the Select Multiple Sources 
option. Paste the clipboard contents, the Request body, into the 
Expression box.

 e In the XML, highlight the value of the element you want to link. In 
the upper pane, double-click on the custom parameter you defined in 
step 7.

 f Repeat the same for all other elements that you want to data drive. 
Note the expression added in the Expression box in the bottom pane.

 g Click OK. Service Test places the data in the HTTP body section.

You have now created a template for your REST method, complete with 
input parameters and the HTTP information. You can now drag the 
activity into the Test Flow and run it with minimal intervention.

For an example of creating a REST Service with data driving and data 
tables, see the HP Service Test Tutorial provided with the product.

<Class>{Step..MyClass}</Class>
<CustomerName>{Step..MyCustomerName}</CustomerName>
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How to Set up Common Web Services Security Scenarios 

This section illustrates several common security scenarios. The examples 
apply when using the default Web Service security scenario. For WCF- based 
services, the WCF Service (Custom Binding) scenario is recommended. For 
additional examples, see "Tips and Guidelines" on page 139.

Authenticating with a Username Token
To send a message level username/password token (a UserName token):

 1 Open the Security Settings view  in the Property Sheet, select the Web 
Services scenario, and click the WS-Security tab.

 2 Click the Add Token button and add a Username token. 

 3 Customize the token details, such as username and password.

Signing with an X.509 Certificate
To send a message using a X.509 certificate for a digital signature.

 1 Open the Security Settings view  in the Property Sheet, select the Web 
Services scenario, and click the WS-Security tab.

 2 Click the Add Token button and add an X509 Certificate token. 

 3 Fill the token details to reference your private certificate. Make sure to 
enter a value in the Logical Name field. 

 4 Select a Reference type. Since this token is used for a signature, the most 
common type is BinarySecurityToken.

 5 Click the Add Message Signature button. In the dropdown list, select the 
token you created in the previous steps.

Note: The certificate needs to be installed in the Windows certificate store. 
In the example above, you need to set the actual store name, store location, 
and subject name of your certificate. 
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Signing a Specific Element with an X.509 Certificate
It is possible to sign only a specific element in a message. The following 
example signs a specific element using an XPATH expression:

To send a message using a X.509 certificate for a digital signature.

 1 Open the Security Settings view  in the Property Sheet, select the Web 
Services scenario, and click the WS-Security tab.

 2 Click the Add Token button and add an X509 Certificate token. 

 3 Fill the token details to reference your private certificate. Make sure to 
enter a value in the Logical Name field. 

 4 Select a Reference type. Since this token is used for a signature, the most 
common type is BinarySecurityToken.

 5 Click the Add Message Signature button. In the dropdown list, select the 
token you created in the previous step.

 6 In the Target Path field enter an XPATH expression, for example:, 
// *[local-name(.)='Body']

Encrypting with a Certificate
To encrypt a message using the service’s X.509 certificate:

 1 Open the Security Settings view  in the Property Sheet, select the Web 
Services scenario, and click the WS-Security tab.

 2 Click the Add Token button and add an X509 Certificate token. 

 3 Fill the token details to reference the server’s public certificate. Make sure 
to enter a value in the Logical Name field. 

 4 Since this token is used for encryption, use Reference as the Reference 
type.

 5 Click the Add Message Encryption button. In the dropdown list, select 
the token you created in the previous steps.

 6 To encrypt a specific message, specify an XPATH expression in the Target 
Path field.
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Authenticating with a Username Token and Encrypting 
with an X.509 Certificate
The following section describes how to send a Username token to the 
service and encrypt it with the server's X.509 certificate:

 1 Open the Security Settings view  in the Property Sheet, select the Web 
Services scenario, and click the WS-Security tab.

 2 Click the Add Token button and add a Username token. Customize the 
token details, such as username and password.

 3 Click the Add Token button and add an X509 Certificate token. 

 4 Fill the token details to reference the server’s public certificate. Make sure 
to enter a value in the Logical Name field. Since this token is used for 
encryption, use Reference as the Reference type.

 5 Click the Add Message Encryption button. In the dropdown list, select 
the token you created in Step 3.

 6 To encrypt a specific message, specify an XPATH expression in the Target 
Path field.

Encrypting and Signing a Message
This example shows how to sign a message using a private key and then 
encrypt it using the service's public key.

 1 Open the Security Settings view  in the Property Sheet, select the Web 
Services scenario, and click the WS-Security tab.

 2 Click the Add Token button and add an X509 Certificate token. 

 3 Fill the token details to reference your private certificate. Make sure to 
enter a value in the Logical Name field. Select a Reference type. Since this 
token is used for a signature, use the BinarySecurityToken type.

 4 Click the Add Token button, and add another X509 Certificate token. Fill 
the token details to reference the server’s public certificate. Make sure to 
enter a value in the Logical Name field. Since this token is used for 
encryption, use Reference as the Reference type.

 5 Click the Add Message Signature button. In the dropdown list, select the 
X509 token you created in Step 2.
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 6 Click the Add Message Encryption button. In the dropdown list, select 
the token you created in Step 4.

Referencing an X.509 Certificate Using a Hash
In certain cases, you may be unable to reference a certificate with a subject 
name. This section shows how to reference the certificate using its unique 
hash.

 1 Open the Security Settings view  in the Property Sheet, select the Web 
Services scenario, and click the WS-Security tab.

 2 Click the Add Token button and add an X509 Certificate token. 

 3 Fill in the token details. In the Search Type box, select HashIdentifier. 
Enter the certificate thumbprint (hash) in the Search Value field.

 4 Add message encryption or a message signature as described in the 
previous sections.
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Reference

Import Service User Interface 

This section describes the user interface for importing a Web Service 
through a file system, URL, or Service Test Management.

Select Service Dialog Box

Enables you to import WSDLs from a file system or Service Test 
Management, the ALM/QC extension for working with application 
components.

The following elements are included (unlabeled GUI elements are shown in 
angle brackets):

To access  
 > Import Service from File/ALM 

Application Component

Relevant tasks "Open the Import/ Select Service dialog box" on page 116

UI Elements (A-Z) Description

File System Show WSDLS in the file system.

ALM Application 
Components

Show the WSDLs in the ALM/QC repository.

Note: Only visible if there is an open connection to 
ALM/QC with a Service Test Management extension.
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Import Service from URL/UDDI Dialog Box

Enables you to import WSDLs through a URL or UDDI.

The following elements are included (unlabeled GUI elements are shown in 
angle brackets):

File name The contract name:

➤ File System. The file name of the WSDL.

➤ ALM Application Components. The name of the 
application component or service.

Files of type The document type:

➤ File System. The contract file extension, such as wsdl 
or All files.

➤ ALM Application Components. The type of application 
component—Web Service or JMS.

To access  > Import Service from URL/UDDI.

Relevant tasks "Open the Import/ Select Service dialog box" on page 116

See also "Select Service from UDDI Dialog Box" on page 135

UI Elements (A-Z) Description

Expands the dialog box to show the Authentication and 
Proxy settings.

Browse.

➤ For URL imports: Opens a browser to allow you to 
navigate to a URL.

➤ For UDDI Imports: Opens the Select Service from UDDI 
Dialog Box.

Address The URL or UDDI path of the WSDL.

UI Elements (A-Z) Description



Chapter 3 • Defining Services

135

Select Service from UDDI Dialog Box

Enables you to select and import services from a UDDI (Universal 
Description, Discovery, and Integration) server.

Use authentication 
settings

The authentication settings by which to access the 
WSDL: Username and Password.

Use proxy settings The authentication settings for the proxy server hosting 
the WSDL: Server, Port, Username, and Password.

To access  > Import Service from URL/UDDI. 
Select Import from: UDDI and click the   button.

Relevant tasks "How to Import a WSDL-Based Web Service" on page 116

See also "Import Service from URL/UDDI Dialog Box" on page 134

UI Elements (A-Z) Description
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The following elements are included:

 Security User Interface

This section includes (in alphabetical order):

 ➤ Select Service Dialog Box on page 133

 ➤ Import Service from URL/UDDI Dialog Box on page 134

 ➤ Select Service from UDDI Dialog Box on page 135

 ➤ Advanced Settings Dialog Box on page 137

 ➤ Select Certificate Dialog Box on page 138

UI Elements (A-Z) Description

Retrieves the list of services that match the string in the 
Service name field. I no string is specified, it retrieves all 
available services.

UDDI Address The name or IP address of the UDDI server inquiry API.

For Example: http://lab1.devlab.ad:8090/uddi/inquiry.

Version The UDDI version—2 or 3.

Service Name A string in the service name by which to filter the list.

<list of services> A list of the services that match the filter criteria. The 
grid shows the following information:

➤ Service Name

➤ Description

➤ Service Contract

➤ Service ID



Chapter 3 • Defining Services

137

Advanced Settings Dialog Box

This dialog box allows you to customize the security settings for your test. 

User interface elements are described below:

To access ➤ Select a Web Services step in the canvas

➤ Open the Security Setting view in the Property Sheet. 
.

➤ Select the Custom Binding scenario.

➤ Click . 

Important 
information

For details, see "Advanced Security Settings" on 
page 109.

Relevant tasks "How to Set Security for a Web Service" on page 118

UI Elements Description

Encoding tab Allows you to select the encoding type (Text, MTOM, or 
WCF Binary) and the WS-Addressing version. 

For details, see "Encoding" on page 109. 

Advanced Standards 
tab

Allows you to configure the Reliable messaging and 
Specify via address settings. 

For details, see "Advanced Standards" on page 109. 

Security tab Allows you to enable secure sessions, negotiate service 
credentials, and set the protection level.

From this tab you configure the token and derived key 
settings.

For details, see "Security" on page 110. 

HTTP & Proxy tab Allows you to configure HTTP details such as the transfer 
mode, response size, authentication scheme and realm, 
and proxy information. 

For details, see "HTTP and Proxy" on page 113. 
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Select Certificate Dialog Box 

This dialog box enables you to search and locate a certificate from a file or 
Windows store.

Select Certificate from File

When you choose Import from: File, the dialog box shows the user interface 
elements are described below:

Select Certificate from Windows Store

When you choose Import from: Windows Store, the dialog box shows the 
user interface elements are described below:

To access ➤ Select a Web Service step in the canvas.

➤ Open the Security Setting view in the Property Sheet. 
.

➤ Select a WCF type scenario in the Service Details box. 

➤ Click the Browse button adjacent to the Server 
Certificate or Client Certificate fields.

Relevant tasks "Set up a WCF Custom Binding scenario - optional" on 
page 120.

UI Elements Description

Browse. Allows you to locate the certificate file with a 
.cer or .pfx extension.

File The complete path of the certificate file.

Password (optional) The password required to access the certificate.

UI Elements Description

Begins the search for the certificate based on the Search 
text.

Store location The store location, for example Current User.

Store name The store name, for example, AuthRoot.
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Tips and Guidelines

This section provides a "how to" guide for testing WCF services and defining 
security scenarios.

WCF Guidelines 
This section describes how to use Service Test for testing WCF.

How do I test a WCF service?

Open the Security View in the Property Sheet and select a WCF scenario in 
the Scenario Details dropdown list.

If the Federation or WSHttpBinding scenarios are not appropriate, choose 
the WCF Service (Custom Binding) scenario, as it can all other bindings.

How do I test a WCF service that uses WSHttpBinding?

WSHttpBinding is one of the most popular bindings in WCF. In order to use 
this binding, select the WCF Service (Http Binding) scenario from the 
Scenario Details list.

In the Client Authentication box, select the client credential type that you 
use in your binding—Windows, Certificate, or Username. This value 
corresponds to the MessageClientCredentialType property of the WCF’s 
WSHttpBinding.

Windows authentication is the most common value for a WCF services. If 
you are using the WCF default settings for your service, use this option. 
Other options are username, certificate, or none.

Search text The text to match in the certificate name. If left blank, 
the Find action retrieves all available certificates.

<certificate list> A list of the certificates in the Windows store sorted by 
Subject, Issuer, Private, Store Location, and Store Name. 

Password (optional) The password required to access the certificate.

UI Elements Description
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For some scenarios you should indicate whether to use the WCF proprietary 
negotiation mechanism to get the service credentials.

Use the Advanced scenario properties to control the usage of a secure 
session.

For details, see "Set up a WCF Http binding scenario - optional" on page 121.

How do I test a WCF service that uses CustomBinding?

Open the Security View in the Property Sheet and select the WCF Service 
(Custom Binding) scenario.

You can then customize many binding elements, such as your transport 
method, encoding, security, and reliable messaging.

For details, see "Set up a WCF Custom Binding scenario - optional" on 
page 120.

How do I test a WCF service that uses netTcp or namedPipe 
transport?

Open the Security View in the Property Sheet and select the WCF Service 
(Custom Binding) scenario.

Configure the transport to TCP or NamedPipe.

For details, see "Set up a WCF Custom Binding scenario - optional" on 
page 120.

How do I test a Federation scenario that uses an STS (Security 
Token Service)?

For this scenario, you must define the communication properties for both 
the STS and the service. Use the built-in Federation scenario.

Open the Security View in the Property Sheet and select the WCF Service 
(Federation) scenario.

For this scenario, you must to define the communication properties for both 
the STS and the application server. 

For details, see "Set up a WCF Federation scenario - optional" on page 120.
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How do I test a scenario that uses a WSE3 security 
configuration with a server certificate?

The following procedure describes how to set up a security scenario for 
WSE3.

 1 Create a new test, import the WSDL for the W3ES service, and drag the 
operation into the canvas.

 2 Open the Security View in the Property Sheet and select the WCF Service 
(Custom Binding) scenario.

 3 Set the Transport to HTTP, and the Encoding to Text.

 4 Provide a username and password in the Identities section.

 5 Click the Browse button adjacent to the Server Certificate field and 
specify the Store Location, Store Name and Search text (optional). Click 
Find, select the certificate, and click Select.

 6 Provide the Expected DNS.

 7 Click the Advanced button and configure the following settings:

 a Encoding tab— Encoding: Text, WS-Addressing: WSA 04/08 (for 
example). 

 b Security tab—

➤ Enable secure session: Enabled

➤ Negotiate service credentials: Enabled 

➤ Protection level: Encrypt and Sign

➤ Message protection order: Sign Before Encrypt 

➤ Message security version: 
WSSecurity11WSTrustFebruary2005WSSecureConversationFebruary
2005 (first entry)

➤ Require Derived keys: Enabled

For all other fields, use the default settings.

For details, see "Set up a WCF Custom Binding scenario - optional" on 
page 120.
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How do I test a scenario that uses mutual certificate 
authentication?

The following procedure describes how to set up a security scenario for 
mutual certificates and how to comply with a WSE3 security configuration.

 1 Create a new test, import the WSDL for the service, and drag the 
operation into the canvas.

 2 Open the Security View in the Property Sheet and select the WCF Service 
(Custom Binding) scenario.

 3 Set the Transport to HTTP, and the Encoding to Text.

 4 Set the authentication mode to MutualCertificate.

 5 In the Identities section, select server and client certificates. For details, 
see "Select Certificate Dialog Box" on page 138.

 6 Provide the Expected DNS.

 7 Click the Advanced button and configure the following settings:

 a Encoding tab— Encoding: Text, WS-Addressing: WSA 04/08 (for a 
WSE3 security configuration). 

 b Security tab—Require Derived keys: Disabled

For all other fields, use the default settings.

For details, see "Set up a WCF Custom Binding scenario - optional" on 
page 120.

How do I test a WCF service that uses the netTCP transport and 
authenticates using a client certificate on the transport level?

 1 Create a new test, import the WSDL for the WCF service, and drag the 
operation into the canvas.

 2 Open the Security View in the Property Sheet and select the WCF Service 
(Custom Binding) scenario.

 3 Set the Transport to TCP.

 4 Set the Net Security to SSL stream security.

 5 Open the Property Sheet’s Event view.
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 6 Select the BeforeApplyProtocolSettings event. Click in the Handler 
column and select Create a default handler from the dropdown list.

 7 Add the following definitions to the implementation section of the 
SharedUserCode.cs file.

 8 Save the test and run it.

How do I configure a WCF binding with TCP transport to 
require an X509 client certificate?

The following procedure describes how to configure a WCF custom scenario 
to require an X509 client certificate in nettcp.

 1 Create a new test, import the WSDL for the service, and drag the 
operation into the canvas.

 2 Open the Security View in the Property Sheet and select the WCF Service 
(Custom Binding) scenario.

 3 Set the Transport to TCP.

 4 Set the Net Security to SSL stream security.

 5 Open the Property Sheet’s Event view.

 6 Select the BeforeApplyProtocolSettings event. Click in the Handler 
column and select Create a default handler from the dropdown list.

 7 Add the following definitions to the implementation section of the 
SharedUserCode.cs file.

For all other fields, use the default settings.

var wcf = (HP.ST.Ext.WebServicesTechnologyRT.Models.WcfChannelBinding)args[1];
var ssl = 
(HP.ST.Ext.WebServicesTechnologyRT.Models.WcfSslStreamSecurityChannel)wcf.Prot
ocols.Channels[1];           
ssl.RequireClientCertificate = true;

var wcf = (HP.ST.Ext.WebServicesTechnologyRT.Models.WcfChannelBinding)args[1];
var ssl = 
(HP.ST.Ext.WebServicesTechnologyRT.Models.WcfSslStreamSecurityChannel)wcf.Prot
ocols.Channels[1]; 
ssl.RequireClientCertificate = true;
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 8 Save the test and run it.

General Security Testing 
This section provides a summary of using Service Test for general security 
testing.

How do I test a Web Service that uses SSL?

Testing a secure site does not require any special configuration. If your 
service URL begins with https, SSL is automatically used. 

If in addition to SSL you are using message-level security (for example a 
username) then you must configure the security for the message separately. 

You can use the basic Web Services security scenario and specify the 
message-level security such as tokens and signatures. 

You can also use the WCF Service (Custom Binding) scenario, or the WCF 
Service (Http Binding) scenario with the transport credentials. 

How do I test a Web Service that require Windows 
authentication at the HTTP level?

Open the Security View in the Property Sheet and select the Web Services 
scenario.

In the HTTP tab, specify the credentials.

For details, see "Set up a Web Services scenario - optional" on page 119.

How to I test a Web Service that uses WS-Security?

Use the basic Web Services security scenario and open the WS-Security tab. 
Add the message-level security such as tokens, signatures, and encryption. 

How do I configure the low-level details of my WS-Security 
tokens?

In most cases, you can configure the low-level details as described in 
"Advanced Settings Dialog Box" on page 137. 
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Tips for Advanced Standards Testing 
This section provides guidelines for using Service Test in advanced standards 
testing.

How do I test a Web Service that uses MTOM?

Open the Security View in the Property Sheet and select the WCF Service 
(Custom Binding) scenario.

Configure the Encoding to MTOM.

If your service requires advanced settings, click the Advanced button. For 
details, see the "Advanced Settings Dialog Box" on page 137.

For more information about the scenario, see "Set up a WCF Custom 
Binding scenario - optional" on page 120.

How do I change the WS-Addressing version of a service?

Open the Security View in the Property Sheet and select the Web Services 
scenario.

Click the WS Addressing tab and select a version.

For details, see "Set up a Web Services scenario - optional" on page 119.

If your service uses WCF, use the appropriate scenario and configure the 
addressing version from the Advanced window’s Encoding tab. For details, 
see the "Advanced Settings Dialog Box" on page 137. 
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4
Data Handling 

This chapter includes:

Concepts

➤ Data Handling Overview on page 148

➤ Defining Data on page 148

➤ Data Handling on page 153

Tasks

➤ How to Create Data Queries on page 158

➤ How to Assign Data to Test Steps on page 161

➤ How to Set the Navigation Properties on page 164

➤ How to Data Drive a Test Step on page 165

Reference

➤ Data Handling User Interface on page 167
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Concepts

Data Handling Overview 

Before running a test, you may assign input and checkpoint data and specify 
how the data should be used.

Service Test’s Data Window lets you view and maintain data for your test 
steps. You can import data from Excel files, create local data tables, or define 
XML queries as sources for your data. For details, see "How to Assign Data to 
Test Steps" on page 161.

You can data-drive the properties of a step. Data-driving is the mechanism 
by which Service Test automatically creates query expressions for the 
properties, that refer to data in a new, editable table. For details, see the 
"Data Driving Dialog Box" on page 167.

Defining Data 

Service Test allows you to assign data to your steps in several ways. You can 
set the data manually, link to existing data, or data drive the values and add 
data to tables creating a structure for the data for future use.

This section also includes: 

➤ "Populating Data Manually" on page 149

➤ "Linking to a Data Query" on page 150

➤ "Data Driving" on page 151

Note: For machines with Excel, the data tables follow standard Excel 
behavior—when you delete data from a table, the row remains without data. 
To remove a data row, select Delete from the row’s shortcut menu. 
Otherwise, Service Test will run an iteration for that row, with empty values. 
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Populating Data Manually 
The Input/Checkpoints View grid allows you to view and edit the values of 
each input property. You can manually insert values into the grid for both 
simple properties and arrays.

You can also edit the values in the XML text mode. The editor also allows 
you to discard changes and return to the original using the Revert button.

You can also populate the checkpoint values manually. In addition, after 
running the test at least once, you can load the replay values directly into 
the checkpoint using the Load from Replay button.
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Linking to a Data Query
The recommended way to define data for a step is by linking it to a data 
query. The Select Link Source dialog box allows you to link to data in several 
ways:

➤ Specify a constant value

➤ Reference the output of a previous step

➤ Use the data from a query in the Data window

➤ Use an test variable

You can also use a combination of these types: for example, a constant 
value, a data query column, and an test variable combined to make a single 
expression.
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To use data query columns, you import an existing data file, such as an Excel 
spreadsheet or XML file. Alternatively, you can use a wizard to create a 
custom local table. For details, see the relevant section:

➤ "Add an Excel data query" on page 158 

➤ "Add a local data table" on page 159

➤ "Add an XML data query" on page 159.

When preparing scripts for load testing, the Select Link Source dialog box 
also lets you select the way in which to retrieve the data and what to do 
when the data has run out. For details, see "Data Retrieval Options for Load 
Test Enabled Tests" on page 176.

For task details, see "How to Assign Data to Test Steps" on page 161.

Data Driving
Data-driving is the mechanism by which Service Test automatically creates 
query expressions for properties. When you data drive a step, Service Test 
adds query expressions to the step’s value fields.

These queries refer to data in a new editable Excel table or XML structure, 
depending on the type of query you specified during the data driving.
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You can customize data-driving in the following ways:

➤ Specify the type of data query to create—Excel or XML 

➤ Indicate which properties to data drive— Input, Checkpoints, or both.

➤ Set the loop type. This overrides the regular Loop Settings.

For Excel queries, you can manually add to and edit the table data in the 
Data Window.
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For XML queries, you can manually edit the XML root.

For task details, see "How to Data Drive a Test Step" on page 165.

For user interface details, see "Data Driving Dialog Box" on page 167.

Data Handling 

Service test lets you indicate how to use the data query, how many times to 
loop through the data. 

You can also define relations between data tables and queries.

This section also includes: 

➤ "Navigating within the Data" on page 153

➤ "Child Relations" on page 155

➤ "Data Keywords" on page 156

Navigating within the Data 
Using the Data Navigation dialog box, you control the way you use the 
values in the data tables. 

The Data Navigation settings work together with the loop settings described 
in "Loop Settings" on page 72.
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If the loop is configured as a ForEach type, and you designate a specific 
query as the loop’s collection, then the Data Navigation settings affect the 
number of iterations of the loop.

For queries that are not designated as the loop collection, but whose values 
are fetched by steps within the loop, the Data Navigation policy affects the 
data differently. It indicates the order in which the values are fetched from 
the data query, and assigned to steps within the loop.

You can indicate the following:

➤ Start at. At which row of data to begin. You can indicate a row number or 
a condition that must be met by the start row. 

➤ Move Direction. The direction and the number of rows by which to 
advance and the condition that must be met. You can also move to a 
specific row or allow Service Test to use a random one.

➤ End at. At which row of data to end, and the condition that must be met 
by the start row. You can indicate a row number or a condition that must 
be met by the end row.

➤ Last Row Behavior. 
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➤ For Forward direction advancement, what to do when reaching the 
last row of data—continue using the last row for the rest of the 
iterations, or wrap around and begin again with the first row.

➤ For Backward direction advancement, what to do when reaching the 
first row of data—continue using the first row for the rest of the 
iterations, or wrap around and begin again with the last row.

For user interface details, see the "Data Navigation Dialog Box" on page 178.

Child Relations
You can define data relations for all of your data tables. You can then use 
this relation as data for a test step.

To create a relation, you select a parent query and specify the following:

➤ Child Query. The query containing the column whose data you want to 
use in the relation.

➤ Primary key. The column in the parent query used as a primary key.

➤ Foreign key. The column in the child query used as a foreign key.

For task details, see "Create a new child relation - optional" on page 161.
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Data Keywords
You can use keywords to customize the test run and validation. To use a 
keyword, type it into the Value column or table row. Enclose the keyword 
with the # character. The keyword names are not case-sensitive.

Service Test provides keywords for both Input properties and checkpoints. 

Input Keywords

For input properties, you can enter a keyword into one or more data 
provider sources, such as a data table or XML code. 

Keyword Description

#SKIP# Omits this element from the XML of the request. 

#NIL# Adds a nil=true attribute to the property’s XML in the 
request. For example, <name John Doe nil="true"></
name>).

If the XML element is not nillable, Service Test reports 
this to the log.
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Checkpoint Keywords

You can use keywords for checkpoints, by entering the keyword into the 
data table or XML associated with the checkpoint. Service Test provides the 
following keywords for checkpoints.

Keyword Description

#SKIP# The checkpoint with the #SKIP# value will not be 
validated.

#NIL# During the test run, Service Test checks that the element 
has a nil="true" attribute in its response.

#NOT_FOUND# Indicates that the element should not be found in the 
XML of the response. This setting ignores the 
comparison operator—it only checks for the absence of a 
value.

#EXISTS# Indicates that the element should be found in the XML 
of the response. This setting ignores the comparison 
operator—it only checks for the presence of a value.
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Tasks

How to Create Data Queries

This task describes how to define data queries before selecting a test step. 
After creating a test step, you link it to an existing data query.

This task includes the following steps:

➤ "Add an Excel data query" on page 158

➤ "Add a local data table" on page 159

➤ "Add an XML data query" on page 159

➤ "Create a new child relation - optional" on page 161

Add an Excel data query

 1 Make sure the Data Window is visible. If not, select View > Data Window.

 2 In the Data Window pane, select New > Excel File.

 3 In the Add New Excel File Data Query dialog box, browse for the file and 
indicate if the first row is a header row.

 4 Specify a query name or accept the default one. 

 5 Select an import mode: Referenced or Embedded. The Data Explorer 
shows the table in the right pane.

 6 Click OK.

 7 In the Data Explorer, select the query’s node and move within the table 
using the keyboard arrows. Click the grid cells to manually set values.

For user interface details, see the "Add New Excel File Data Query Dialog 
Box" on page 168.
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Add a local data table

 1 Show the Data Window. Select View > Data Window.

 2 In the Data Window pane, select New > Local Table.

 3 Click Add to create a column for the data query.

 4 In the Add Columns dialog box, specify a column name and description. 
Select a data type from the dropdown list. Click OK.

 5 Repeat steps c and d for each column you want to create.

 6 Use the arrows to reorder the columns as required.

 7 Click Next to specify a query name. Click Finish.

 8 In the Data Explorer, select the table’s node and move within the table 
using the keyboard arrows. Click the grid cells to manually set values.

Add an XML data query

 1 Show the Data Window. Select View > Data Window.

 2 In the Data Window pane, select New > XML. The Add New XML Data 
Query dialog box opens. For user interface details, see the "Add New XML 
Data Query Dialog Box" on page 170.

 3 Provide a Query name.
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 4 Select a source or schema option:

➤ Create new query using schema file. Browse for the Schema File Path.

➤ Create new query based on XML file. Browse for the XML File Path 
representing the structure of the data. You can add data at a later time.

➤ Use existing query. Browse for the Location of Query. Queries are 
stored as subfolders of the script’s DataQueries folder. Make sure to use 
the query name as it appears in the folder, without the suffix. For 
example, for the file Query1_DataSource.xml file, enter Query1 in the 
Query name field.

Tip: Choose Test > Open Script Directory to view the files.

 5 Click OK.

 6 Expand the query’s node in the Data Window.

 7 Edit the XML data in the grid. Add rows as described in the "XML Query 
Grid - Toolbar" on page 171.

 8 To load XML values, click the Load data from an XML file button.
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Create a new child relation - optional

This step lets you add child relations using primary and foreign keys. This 
applies to Excel type queries.

 1 Add at least two Excel files or one file with two worksheets, containing 
the foreign and primary keys.

 2 In the Data Window, select the parent table in the Data Explorer tree. 

 3 Click in the Property Sheet to open the Data Query Properties view.

 4 Click the Add button. The Define New Data Relation dialog box opens.

 5 Specify the details of the new relation. For user interface details, see 
"Define/Edit New Data Relation Dialog Box" on page 181.

 6 To edit a data relation, double-click the entry or click Edit.

 7 To delete a data relation, select the entry and click Remove.

How to Assign Data to Test Steps

This task describes how to link the test step properties to data queries 
through the following steps:

➤ "Open the Select Link Source dialog box" on page 161

➤ "Select a linking option" on page 162

➤ "Assign array data - no leaf nodes" on page 163

 1 Open the Select Link Source dialog box

 a Display the step’s properties. Select View > Property Sheet and open 
the Input/Checkpoints view.

 b Click the Link Source button in the right corner of the row.
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 2 Select a linking option

 a In the Select Link Source dialog box, select a data query option:

➤ Constant value. Enter the value manually. 

➤ Previous step. Select the step in the left pane and its property in the 
right pane.

➤ Test variable. Select a user or system variable. For information on 
defining user variables and profiles, see "Define user variables" on 
page 17.

➤ Data query column. For properties with simple data structures or 
with both leaf nodes and arrays—in the left pane, select a query. In 
the right pane, double-click on the relevant node. For properties 
that only have arrays, see step 3 on page 163. 

 b To use a combination of several data sources for one parameter, click 
More to expand the Select Link Source dialog box. Select the data 
sources one-by-one and click Add. If necessary, edit the expression 
manually.

 c Click OK to complete the linking of the data. Service Test copies the 
values or expressions into the Value column of the grid.

Note: 

➤ Linking data queries to properties only applies to steps within a loop. 

➤ When linking data queries to an array with multiple elements. you 
only link the data to the first array element. Service Test will apply the 
data to the next elements according to the availability of the data. For 
example, if the Excel table contains three rows of data for the current 
parent query row, it will populate three array elements.

➤ Linking a leaf node to a complex XML node is only supported for 
string type data.

For user interface details, see the "Select Link Source Dialog Box" on 
page 174. To
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 3 Assign array data - no leaf nodes

Follow these steps if the property only contains an array, and there are 
there are no leaf nodes outside the array.

 a Create a data relation (if required) as described in "Create a new child 
relation - optional" on page 161.

 b Click within the frame of Test Flow, or the relevant loop, and open the 
Data Queries  view in the Property Sheet.

 c Click the Add button. The Attach Query to Loop dialog box opens.

 d Select the parent query from the list. Click OK.

 e To edit the data navigation properties, click Edit. Set the preferences 
and click OK.

 f Select the step in the canvas. In the Property Sheet’s Input/Parameter’s 
view, click within the row of the array element you want to assign. 

 g Click the Link Source button in the right corner of the row. Select the 
Data query column option and select the desired node.
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How to Set the Navigation Properties

This task describes how to set the navigation preferences for data stored in 
tables. You can set different navigation properties for each data query. For 
details, see "Navigating within the Data" on page 153. 

 1 Open the Data Queries view

In the canvas, click within the loop frame, but not within a test step. In 
the Property Sheet, click the Data Queries view button (only visible for 
steps within a loop).

 2 Select a query

Click Add to select a query. The Attach Query to Loop dialog box opens. 
Double-click a query.

 3 Open the Data Navigation dialog box

in the Data Queries view, select the query with your data. Click Edit to 
open the Data Navigation dialog box. 

 4 Set the navigation properties

 a In the Data Navigation dialog box, specify the Start and End rows. 

 b Indicate the direction in which to move when retrieving data from the 
table: Forward or Backward, and the number of rows by which to 
advance for each iteration. 

 c Specify the action to do when reaching the last row- Wrap around or 
Keep using that row.

 d Click OK.

For user interface details, see the "Data Navigation Dialog Box" on page 178.
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How to Data Drive a Test Step 

This task describes how to data drive a test step. Data driving is Service Test’s 
mechanism for automatically creating a query expressions for step 
properties. 

For further details, see "Data Driving" on page 151.

This task includes the following steps:

➤ "Prerequisites" on page 165

➤ "Open the Input Properties view" on page 165

➤ "Include the data" on page 165

➤ "Data drive the test step" on page 165

➤ "Enter values" on page 166

 1 Prerequisites

Create a step in the canvas. For details, see "Create the test flow" on 
page 42.

 2 Open the Input Properties view

Display the step’s properties grid. Select View > Property Sheet and open 
the Input/Checkpoints view.

 3 Include the data 

To include optional properties in the data driving, toggle the triangle icon 
adjacent to the property. A filled-in triangle indicates an included 
property.

 4 Data drive the test step

 a Click the  Data Drive button. The Data Driving dialog box opens.

 b Choose a Data provider: Excel or XML.

 c Select the properties upon which you want to apply data driving: input 
properties, checkpoints, or both. 
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 d Indicate whether you want to Configure 'Test Flow' as a For Each loop 
using the new query. This option repeats the test steps according to 
the number of data rows in the Excel or XML data query. If you disable 
this option, you can manually set the number of iterations through 
the loop properties. This setting overrides the general loop properties. 
For details, see "Loop Settings" on page 72.

 e Click OK.

 f Service Test prompts you to confirm the action. Click OK. 

Service Test populates the value column with queries. The queries are 
preceded by informational icons, indicating read-only status or 
unmatching data types.

Note: If your checkpoints are within an array, you must create an array 
element before data driving. Expand the Body node, select the array and 
choose Add Array Element from the shortcut menu.

For user interface details, see the "Data Driving Dialog Box" on page 167.

 5 Enter values

In the Data Window (View > Data Window), edit the columns of the 
newly created data table(s) or XML source.
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Reference

Data Handling User Interface 

This section includes (in alphabetical order):

 ➤ Data Driving Dialog Box on page 167

 ➤ Add New Excel File Data Query Dialog Box on page 168

 ➤ Add New Local Table Data Query Dialog Box on page 169

 ➤ Add New XML Data Query Dialog Box on page 170

 ➤ Attach Query to Loop Dialog Box on page 173

 ➤ Select Link Source Dialog Box on page 174

 ➤ Data Navigation Dialog Box on page 178

 ➤ Define/Edit New Data Relation Dialog Box on page 181

Data Driving Dialog Box

Enables you to populate the input property and checkpoint values for a step, 
with data query statements.

To Access

Relevant Tasks "How to Data Drive a Test Step" on page 165

See Also "Add New Excel File Data Query Dialog Box" on page 168
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The following elements are included (unlabeled GUI elements are shown in 
angle brackets):

Add New Excel File Data Query Dialog Box

Enables you to add new Excel queries to the Data Explorer within the Data 
tab.

The following elements are included (unlabeled GUI elements are shown in 
angle brackets):

UI Elements Description

Data Provider The source type of the data: Excel or XML.

Data Driven Sections The section upon which to apply the data driving:

➤ Input. All input properties listed in the grid.

➤ Checkpoints. All checkpoints listed in the grid. For 
array type Output properties, you must create at least 
one array element in order to enable data driving.

➤ Inputs and Checkpoints. All entities in the grid.

Configure 'Test Flow/
Loop' in a ForEach 
loop using the new 
query

Runs the steps in the Test Flow or Loop using a For Each 
type loop, with the values from the newly created query. 
It performs one iteration for each row in the query.

Note: This option overrides the configuration that you 
may have set for the Test Flow/Loop settings. For details, 
see "Loop Settings" on page 72.

To Access View > Data Window and select New > Excel File.

Relevant Tasks "Add an Excel data query" on page 158

UI Elements Description

Browse. Enables you to locate the Excel file containing 
the query data.

Excel file path The complete path of the Excel file containing the data.
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Add New Local Table Data Query Dialog Box

Enables you to create local tables in the Data window for use with your test.

The following elements are included (unlabeled GUI elements are shown in 
angle brackets):

Excel file contains 
header row

Indicates whether the data in the Excel table contains a 
header row. Header rows are ignored when running the 
test. 

Query name The name of query as it will appear in the Data Window’s 
Excel file node. 

Default: The name of the file.

Mode The mode of storage for the query:

➤ Referenced Query. Links to the Excel file at its original 
location. If the data changes at its source, it will affect 
your test. In addition, if you modify the data in Service 
Test, it will affect the data at tis source.

➤ Embedded Query. Copies the Excel file locally. If the 
data changes at its source, it will not affect your test.

To Access View > Data Window and select New > Local Table.

Relevant Tasks "Add a local data table" on page 159

See Also ➤ "Add New Excel File Data Query Dialog Box" on 
page 168

➤ "Add New XML Data Query Dialog Box" on page 170

UI Elements Description

Opens the Add Columns dialog box for providing a new 
column’s properties.

Opens the Edit Columns dialog box for modifying the 
properties of the selected column.

UI Elements Description
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Add/Edit Columns Dialog Box
The Add/Edit Columns dialog box lets you define the properties for a new column or 
edit the properties of an existing one.

User interface elements are described below:

Add New XML Data Query Dialog Box

Enables you to add new XML queries to the Data Explorer within the Data 
tab.

Deletes the selected data table column. 

Raises/Lowers the selection in the column list.

Columns A list of the columns in the local data table.

UI Elements (A-Z) Description

Column Name An arbitrary name for the column.

Data Type The type of data in the column:

➤ String

➤ Integer

➤ Double

➤ Date

Description A description of the data in the column.

To Access View > Data Window and select New > XML.

UI Elements Description
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The following elements are included:

XML Query Grid - Toolbar

Relevant Tasks "Add an XML data query" on page 159

See Also ➤ "Add New Excel File Data Query Dialog Box" on 
page 168

➤ "Add New Local Table Data Query Dialog Box" on 
page 169

UI Elements Description

Query name The display name of the query.

Create new query 
using Schema file 

Loads the specified schema into the Data Explorer 
window as a basis for the new query.

Create new query 
based on XML file

Creates a new schema based on the XML file specified in 
the XML file path box.

Use existing query Uses an existing query specified in the Location of query 
box. Since this query is referenced, changes made to the 
query will be reflected in all tests using the query.

UI Elements (from 
left to right)

Description

Go back. Go back to previous view.

Go to start. Go to the first row.

Go to previous row. Go to the previous row (one row up).

Row The current row number out of the total rows, such as
1/3 and so forth. 

Description A title for the row currently displayed.

Go to next. Go to the next row (one row down).
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Go to last. Go to the last row.

Load XML. Loads data from an XML file into the current 
row.

Move up. Moves the current row up one position.

Move down. Moves current row down one position.

Adds a new empty row at one of the following locations. 

➤ Add after current

➤ Add at start 

➤ Add at end

Duplicates the current row at one of the following 
locations. 

➤ Duplicate after current

➤ Duplicate at start 

➤ Duplicate at end

Deletes the current row.

UI Elements (from 
left to right)

Description
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Attach Query to Loop Dialog Box 

This dialog box enables you to add a data query to the current loop.

User interface elements are described below:

To access Follow these steps:

➤ In the canvas, click in a loop, but not within a step.

➤ In the Property Sheet, select the Data Query view. .

➤ Click Add. 

Important You must first define data in the Data Window in order 
to generate a list of queries. 

When you link any step in the loop to the data, it 
automatically adds a query to the loop.

For details, see "How to Assign Data to Test Steps" on 
page 161.

Relevant tasks "How to Set the Navigation Properties" on page 164

See also "Data Navigation Dialog Box" on page 178

Element Description

Select a data query A list of the available data queries.
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Select Link Source Dialog Box

This dialog box enables you to select a data source for the step’s properties. 

User interface elements are described below (unlabeled elements are shown 
in angle brackets):

To access Click  in the Value column of the property for which 
you want to select a data query.

Important 
information

➤ To see the icon, click in the property row and move 
the cursor to the right of the cell.

➤ A step property not contained within a loop, cannot 
be linked to a data query. For example, the For Loop's 
Number of Iterations property, cannot be linked to a 
data query, since it is not contained within the Test 
Flow loop.

Relevant tasks "How to Assign Data to Test Steps" on page 161

See also ➤ "How to Create Data Queries" on page 158

➤ "How to Set the Navigation Properties" on page 164

UI Elements (A-Z) Description

Expands the dialog box to allow you to use multiple data 
sources for an expression, and edit the query expression 
manually.

<data source> The source for the property value: 

➤ Constant value. A constant value to use for all 
iterations.

➤ Previous step. A property value from a previous step.

➤ Data query column. A value from a data query—Excel, 
XML, or local table.

➤ Test Variables. A value of an test variable—either user 
or system.

<preceding step list> A list of the steps preceding the current one. Select the 
step whose output value you want to use as input.

Note: Visible only when choosing Previous step. 



Chapter 4 • Data Handling

175

<step properties 
grid>

A schema view of the selected step’s properties.

Note: Visible only when choosing Previous step.

<data queries and 
their columns>

A list of the Excel, XML, or local table queries in the left 
pane, and their columns or schema (for XML) in the 
right pane.

Note: Visible only when choosing the Data query column 
option. 

<user variable grid> A list of the user-defined test variables and their values in 
the current profile.

Note: Visible only when choosing the Test Variables 
option. 

<system variable 
grid>

A list of the system environment variables and their 
values: ControllerHostName, IsLoadTest, ScenarioID, 
SystemTempDir, GroupName, TestDir, TestName, 
LocalHostName, OS, OSVersion, ProductDir, 
ProductName, ProductVer, and UserName.

Note: Visible only when choosing the Test Variables 
option. 

Enter a value The constant value to use for this property in all 
iterations.

Note: Visible only when choosing Constant value. 

Show data columns 
of matching data 
types only

Hides all columns (or schema rows for XML) whose data 
types do not match the input property whose value you 
want to set.

Note: Visible only when choosing the Data query column 
option. 

UI Elements (A-Z) Description
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Data Retrieval Options for Load Test Enabled Tests

For Load Test Enabled tests, the Select Link Source dialog box provides 
additional controls for the Input properties, when choosing the Data query 
column option.

User interface elements are described below:

Show properties of 
matching data types 
only

Hides all properties whose data types do not match the 
one whose value you want to set.

Note: Visible only when choosing the Previous step. 

Attach the query to 
the loop

A dropdown list of the loops in the test containing the 
activity. The query is only associated with the selected 
loop.

Note: Visible only when choosing the Data query column 
option. 

UI Elements Description

Attach the query to 
the loop

The loop with which to associate the query (for future 
implementations).

UI Elements (A-Z) Description
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Use a unique value 
for each Virtual User 
when load testing

Assigns a unique value to each Virtual User, from the data 
table, with the following properties:

➤ Query parameter. The query parameter to use as a 
source of values for the selected input property. 

➤ Update value on. The frequency by which LoadRunner 
will update the values: Each Iteration, Each 
Occurrence (of the query parameter), or Once.

➤ When out of values.The action to do when reaching 
the end of the data table: 

➤ Abort Vuser. End the test run for the Virtual User.

➤ Continue Cyclic. Return to the top of the data table 
and use the data in a cyclic manner.

➤ Continue with Last. Use the last value retrieved 
from the data table for all subsequent occurrences.

Allocate Virtual User 
values in the 
Controller

Allocates a specific amount of values from the data table 
for the Virtual User:

➤ Automatically allocate block size. Automatically 
allocates a block size from the data based on the 
number of iterations and Virtual Users (only for 
Update value on Each Iteration).

➤ Allocate <amount> values for each Virtual User. 
Allocates a specific number of values for each Virtual 
User.

Note: Allocation is only possible when choosing Update 
value on Each Occurrence or Each Iteration. For details, 
see the HP LoadRunner Controller User Guide.

UI Elements Description
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Data Navigation Dialog Box 

This dialog box enables you to set the data navigation properties for your 
test loop. You can set the direction in which to use the data, from where to 
begin, and the condition for selecting data.

To access Follow these steps:

1  In the canvas, click inside the loop frame—not on a 
test step.

2  In the Property Sheet, select the Data Query view .

3  Click Add. The Attach Query to Loop dialog box 
opens.

4  Select a query to attach and click OK. The query is 
added to the grid.

5  Click Edit. 

Relevant tasks "How to Set the Navigation Properties" on page 164

See Also "Navigating within the Data" on page 153
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User interface elements are described below:

GUI Element Description

Start at The row within the query from which to begin.

➤ Start at. The row of data from which to begin: First 
row, Last row, Specific row, Random row, or First row 
matching.

➤ Row. The row number from which to begin (only 
available when selecting Specific row).

➤ Condition. The condition the data row must meet in 
order to start the looping (only available when 
selecting the First row matching option):

➤ Column. One of the query’s columns.

➤ Comparison operator. =, !=,>, >=, <, <=, Starts, Ends, 
Contains, or Regex (depending on row’s data type).

➤ Value. The value to be matched in order to use this 
row of data.

Move The direction and amount of rows by which to advance 
within the data.

➤ Move by. The number of rows to advance. 

➤ Direction. The direction in which to move: Forward or 
Backward. 
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End at When to stop the looping through the data: First row, 
Last row, Specific row, or First row matching

➤ Row. The row number in which to end (only available 
when selecting Specific row).

➤ Condition. The condition the data row must meet in 
order to end the looping (only available when 
selecting the First row matching option):

➤ Column. One of the query’s columns.

➤ Comparison operator. =, !=,>, >=, <, <=, Starts, Ends, 
Contains, or Regex (depending on row’s data type).

➤ Value. The value to be matched in order to use this 
row of data.

Note: This setting stops the looping only when the loop 
type is set to 'For Each' (see "Loop Settings" on page 72) 
and the current query whose navigation settings you are 
editing, is the same query that is linked to the loop. 

Upon reaching the 
last row - Action:

(Forward direction)

The action to take when reaching the last row of data.

➤ Keep using that row. Keep using the last row of data 
for all subsequent loops.

➤ Wrap around. Start again from the first row of data.

Upon reaching the 
first row - Action:

(Backward direction)

The action to take when reaching the first row of data.

➤ Keep using that row. Keep using the first row of data 
for all subsequent loops.

➤ Wrap around. Start again from the last row of data.

GUI Element Description



Chapter 4 • Data Handling

181

Define/Edit New Data Relation Dialog Box 

This dialog box enables you to define a new data relation for a query.

User interface elements are described below:

To access Follow these steps:
1  Add a data query through the Data Window and select 

its node in the left pane.

2  Click in the Property Sheet pane. The Data Query 
Properties  view opens.

3  Click Add or Edit.

Relevant tasks "Create a new child relation - optional" on page 161

GUI Element Description

Child query The sheet or table to use for the query.

Primary key A column in the parent query to use as a primary key for 
the child relation.

Foreign key The column in the child query to use as a foreign key for 
the child relation.
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5
Running Tests 

This chapter includes:

Concepts

➤ Running Tests Overview on page 184

Tasks

➤ How to Run a Test on page 187

➤ How to Prepare and Run a Load Test on page 190

Reference

➤ Command Line Syntax on page 194

➤ Run Test User Interface on page 195

➤ Debug Tabs User Interface on page 197
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Concepts

Running Tests Overview

You can run tests directly from the Service Test interface or from the 
command line. The test run allows you to determine if the activities are 
functional and if they are performing as expected.

Before running the test, you can select a location in which to store the 
results, and set input parameter values specifically for this test run. For 
details, see "How to Run a Test" on page 187.

For details about the command line, see "Command Line Syntax" on 
page 194.

The Run Results Viewer provides a detailed report about each step and its 
checkpoints. For details, see Chapter 7, "Run Results Viewer."

When you run custom code from the user interface, you can also use 
breakpoints and other tools to debug your code.

Service Test allows you set the run configuration—Debug or Release. The 
Release mode is more efficient, and is recommended for Load Testing.

When a test step fails, Service Test continues to run the other test steps. The 
exception to this is if you enabled the Stop test if checkpoint fails option 
and the checkpoint failed. For details, see "Input/Checkpoints View" on 
page 70.
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Checkpoint Validation
In functional testing, it is necessary to check the response from the server to 
confirm that your service performed the actions correctly. The response can 
contain several properties, each containing several data items. The 
Checkpoints section is a central point for defining the required response 
values for your test.

Before replaying a test, you set expected values for the test properties. You 
can enter the values manually, link them to a data source, or load values 
that were captured during replay. This is useful when you have many 
argument values—instead of manually entering values, you automatically 
load them. 

Service Test automatically displays all of the step’s properties with a check 
box. To include a checkpoint in the test, you select its check box. If you load 
replay values, you can select only those properties that you want to check.

The Xpath tab lets you validate results against XPATH expressions.

Service Test’s Checkpoint setting lets you indicate whether or not to stop the 
test if the checkpoint fails. For details, see the "Input/Checkpoints View" on 
page 70.

After the test run, you can view the log or the run results and determine if 
the results were as expected. The Run Results Viewer displays the checkpoint 
status in its own sub-node. For details, see "HTTP Checkpoint Response" on 
page 218.
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Load Testing 
You can add load testing capabilities to your test, that will allow you to 
measure performance under load. 

When you have a full LoadRunner installation on the Service Test machine, 
Service Test provides a custom template, Service Test Enabled for Load Test. 

For tests created with the standard Service Test template, Service Test 
provides a conversion utility which converts the script into a LoadRunner 
compatible script, with a .usr extension.

Note: Tests created in Service Test and converted into LoadRunner scripts, 
cannot be edited in LoadRunner’s Virtual User Generator (VuGen). To edit a 
test, modify it in Service Test.

To measure performance within LoadRunner, you can insert Start and End 
Transaction markers. During execution, LoadRunner measures the execution 
time of all the actions between the transaction markers.

When working with data tables, you can use the standard data retrieval 
methods that are available in LoadRunner. For details, see "Data Retrieval 
Options for Load Test Enabled Tests" on page 176.

For task details, see "How to Prepare and Run a Load Test" on page 190.
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Tasks

How to Run a Test 

This task describes how to run a test through the user interface and view its 
results. 

For information on running a test through the command line, see 
"Command Line Syntax" on page 194.

This task includes the following steps:

➤ "Configure checkpoints" on page 187

➤ "Select a location for the run results - optional" on page 188

➤ "Save the test in ALM/QC - optional" on page 188

➤ "Select a location for the run results - optional" on page 188

➤ "Set values for the test variables- optional" on page 189

➤ "Run the test" on page 189

➤ "Debug the test - optional" on page 189

➤ "Results" on page 189

 1 Configure checkpoints

Checkpoint slet you validate the results. For details, see "Checkpoint 
Validation" on page 185.

 a Open the Input/Checkpoints view, and provide an expected value for 
each row in one of the following ways:

➤ Manually 

➤ Link to Source dialog box.

➤ Load from replay button.

 b Select a comparison operator, such as =, >, or Regex. These may differ 
depending on the data type. 
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 c Select the check boxes in the rows of the properties that you want to 
validate. Clear the check boxes for the properties you are not 
validating.

 d To validate against an XPATH expression, click the Xpath tab in the 
Checkpoints section and paste the expression into the Xpath 
Checkpoints column.

 e If required, select the Stop test if checkpoint fails option.

Tip: You can customize and override the checkpoint settings using an 
event handler. For details, see "How to Write Checkpoint Events" on 
page 268.

For user interface details, see the "Input/Checkpoints View" on page 70.

 2 Select a build configuration - optional

Choose a build configuration. Select Build > Set Configuration to select a 
configuration: Debug or Release. During development, it is preferable to 
use the Debug option to allow you access to detailed output information. 
To conserve resources, such as in Load Testing, use the Release option.

 3 Save the test in ALM/QC - optional

To save results in ALM/QC, you need to first save the actual test in ALM/
QC. Select File > HP ALM/QC Connection.

 4 Select a location for the run results - optional

 a Click the Run button on the toolbar and select the Results Location 
tab. 

To show and hide this dialog box, choose Edit > Settings > Show Run 
Dialog Box.



Chapter 5 • Running Tests

189

 b For test saved on the File System, select a location in which to store the 
run results—New run results folder or Temporary run results folder. 
Choose the latter if you do not expect to use and analyze the results. 
For details, see "Results Location" on page 196.

 c For tests saved test in ALM/QC, specify a Run name. If relevant, select a 
Test set and instance.

 5 Set values for the test variables- optional

Select the test properties or user/system variables. For details, see "How to 
Define Test Properties or User/System Variables" on page 16.

 6 Run the test

Click the OK button in the Run dialog box.

 7 Debug the test - optional 

Use the Break mode and other debug tools to solve any runtime issues.

For user interface details, see the "Service Test Main Window" on page 53 
or the "Debug Menu" on page 197.

 8 Results

View the results in the Run Results Viewer. The viewer opens 
automatically after a test run.

➤ A green check mark indicates success.

➤ A red X mark indicates a failure in one of the steps. Expand the nodes 
of the report to view details about each step and checkpoint.

To view the report at a later stage, choose Test > View Test Results.
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How to Prepare and Run a Load Test 

This task describes how to prepare a test for load testing in LoadRunner. For 
an explanation about load testing, see "Load Testing" on page 186.

This task includes the following steps:

➤ "Prerequisite" on page 190

➤ "Create a load test" on page 190

➤ "Add test steps" on page 191

➤ "Prepare for load testing - optional" on page 191

➤ "Assign data to the test - optional" on page 192

➤ "Set the data retrieval properties - optional" on page 192

➤ "Set the run configuration to Release" on page 193

➤ "Run the test in Load Test mode" on page 193

➤ "Results" on page 193

 1 Prerequisite

Make sure that the HP LoadRunner Controller is installed on the same 
machine as Service Test. The Load Testing template will be unavailable 
without a full LoadRunner installation. 

 2 Create a load test

Create a new test with the Service Test Enabled for Load Test template. 

If you have a test created with the standard Service Test template, select 
Test > Enable Test for Load Testing or click the Enable Test for Load 
Testing buttonI.
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 3 Add test steps

Drag activities from the toolbox into the canvas to add steps to the test.

 4 Prepare for load testing - optional

To measure the performance of certain steps, define a transaction

 a Drag the Start Transaction activity from the Toolbox’s Load Testing 
category, into the canvas. Place it before the first step you want to 
measure. 

 b Drag the End Transaction activity at the end of the series of steps you 
want to measure.

 c Click the Start Transaction step in the canvas, and open the Input/
Checkpoints view in the Property Sheet. Enter a Transaction name. 
This name will appear in the reports.

 d Click the End Transaction step in the canvas, and open the Input/
Checkpoints view in the Property Sheet. Enter the same Transaction 
name as above.

 e In the End Transaction’s Input properties, select a Status for reporting: 
PASS, FAIL, AUTO. or STOP.

Note: The End Transaction status is only the LoadRunner transaction's 
status-not the status of step in Service Test. For example, if you assign a 
Failed status to the transaction, Service Test can still issue a Passed status for 
the test step.
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 5 Assign data to the test - optional

Import or create data tables for the input properties. For details, see "How 
to Assign Data to Test Steps" on page 161.

 6 Set the data retrieval properties - optional

If you have data in the Data Window pane, set the data retrieval 
properties. Click the Link to a Data Source buttonI. For details, see the 
"Data Retrieval Options for Load Test Enabled Tests" on page 176.
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 7 Set the run configuration to Release

Select Build > Set Configuration and select Release. The Release mode 
conserves resources, thus enhancing the load testing capabilities.

 8 Run the test in Load Test mode

Expand the Run button and choose Run test (Load Testing mode).

 9 Results

Check the Output tab to verify that the test was successful.

Note: When you run a test in Load Testing mode, the Run Results Report 
does not open. To view a Run Results report, choose Run Project to run the 
test in functional mode.
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Command Line Syntax

The Service Test executable, ServiceTestExecuter.exe, is located in the 
product’s bin directory.

You can run ServiceTestExecuter.exe from the command line using the 
following parameters:

For example:

UI Elements (A-Z) Description

-test The full path of the test name (required)

-inParams The full path of an XML file containing the input 
parameter values (optional).

-outParams The full path of an XML file containing the output 
parameter values (optional).

-profile The name of an Test profile (optional). For details, see 
"How to Define Test Properties or User/System Variables" 
on page 16.

-report The folder in which to store the report.

C:\Program Files\HP\Service Test\bin> ServiceTestExecuter.exe -test 
"c:\MyTests\Test1\Test1" -inParams "c:\MyData\inParams.xml" -outParams 
"c:\MyData\outParams.xml"
-profile Profile1
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where the input parameter file, InParams.xml has, for example, this 
structure:

Tip: To retrieve a list of all of available parameters, run 
ServiceTestExecuter.exe without any parameters.

Run Test User Interface 

This section includes (in alphabetical order):

 ➤ Run Dialog Box on page 195

 ➤ Debug Menu on page 197

 ➤ Debug Output Window on page 199

Run Dialog Box

Enables you to view the properties of the application.

<Arguments>
<a>1</a>
<b>2</b>

</Arguments>

To Access or Debug > Run

Relevant Tasks "How to Run a Test" on page 187
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The following tabs are included:

Results Location
This dialog box lets you specify a location for the Run Results. The fields 
differ for a test saved on the file system and one saved in an ALM/QC 
project.

GUI Element (A-Z) Description

New run results in HP 
ALM/QC Project

Stores the run results in the current ALM/QC project. You 
cannot change the destination Project name (Available 
when there is a connection to an ALM/QC server).

The following fields are editable:

➤ Run name. A custom name for the test run.

➤ Test set. The name of the test set in ALM/QC.

➤ Instance. The instance number of the run.

New run results 
folder

Stores the run results in a specific folder (Available when 
there is no connection to an ALM/QC server).

Click the Browse button to select a location. The default 
path is C:\Documents and 
Settings\%USERPROFILE%\My 
Documents\ServiceTestProjects\<Test Name 
Folder\<TestName>.

Temporary run 
results folder

Stores the run results in a temporary folder, overwriting 
any existing results. This folder uses the TEMP variable 
defined for the current user, %USERPROFILE%\Local 
Settings\Temp\STTempResults.

Don’t show this 
dialog again

Bypasses the Run dialog box in future test runs, using 
your last selection.

Tip: To show this dialog box again, select Edit > Settings 
> Show Run Dialog Box.
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Input Parameters
This tab lets you view and specify values for Input parameters that you 
defined earlier.

For details about defining user variables, see "Action Buttons - Test Variables 
View" on page 77.

Debug Tabs User Interface 

This section includes (in alphabetical order):

 ➤ Run Dialog Box on page 195

 ➤ Debug Menu on page 197

 ➤ Debug Output Window on page 199

Debug Menu

Enables you to view the properties of the application.

GUI Element (A-Z) Description

Schema The name of the parameter.

Value An editable column containing the parameter values.

To Access Debug menu

Relevant Tasks "Debug the test - optional" on page 189
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The following tabs are included:

GUI Element (A-Z) Description

Run. Runs and compile the test.

Stop Process. Stops the test execution. 

Break. Pauses the test run and enters Break mode in order 
to allow you to edit the code.

Continue Debugging. Resumes the test run from the 
point of the break.

Step Over. Executes the current statement and enters 
Break mode in order to allow you to edit the code. If the 
statement calls another procedure, Service Test will not 
step into that procedure. It will run the procedure, and 
advance to the next statement in the current procedure. 

Step Into. Executes the current statement and enters 
Break mode in order to allow you to edit the code. If the 
statement calls another procedure, Service Test will step 
into that procedure.

Step Out. If you used Step Into and the control moved to 
a called procedure, Step Out automatically runs the 
current procedure, and returns to the procedure from 
which it was called.

Step Into. Executes the current statement and enters 
Break mode in order to allow you to edit the code. If the 
statement calls another procedure, Service Test will step 
into that procedure.
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Debug Output Window

Enables you to view the run’s debug information.

The following tabs are included:

Step Out. If you used Step Into and the control moved to 
a called procedure, Step Out automatically runs the 
current procedure, and returns to the procedure from 
which it was called.

Toggle Breakpoint Inserts or removes a breakpoint at the location of the 
cursor.

Note: This applies when working in a code window, such 
as an event, but not in the canvas.

Tip: The shortcut key for toggling a breakpoint is F7.

To Access View > Debug > …

Relevant Tasks "Debug the test - optional" on page 189

GUI Element (A-Z) Description

Breakpoints tab A list of the breakpoints in the test, for each open buffer. 
This tab provides the following controls:

➤ . Go to Previous Bookmark. Jumps to previous 
bookmark in the list.

➤ . Go to Next. Jumps to next bookmark in the list.

➤ . Enable/Disable. Enable or disable all bookmarks.

➤ . Delete. Delete the selected bookmark.

➤ . Delete All. Delete all bookmarks in all buffers.

Tip: To create a bookmark, click on a line within a buffer 
and press F7.

Callstacks tab A list of the calls in the stack sorted by Name or 
Language.

GUI Element (A-Z) Description
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Console tab A console allowing you to manually enter debug 
commands

Loaded modules tab A list of the currently loaded modules by Name, Address, 
Path, Order, and Symbols.

Local variables tab A list of the local variables by Name, Value, and Type.

Threads tab A list of the currently loaded modules by ID, Name, 
Location, Priority, and Frozen.

Watch tab A list of watched expressions. The shortcut menu 
provides the following controls:

➤ Add watch. Allows you to add an expression to be 
watched.

➤ Remove Watch. Removes the selected watched item.

➤ Remove all. Removes all items from the watch list.

GUI Element (A-Z) Description
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6
ALM/QC Integration

This chapter includes:

Concepts

➤ Managing Tests Through HP ALM/QC Overview on page 202

➤ ALM/QC Tests and Version Control on page 203

Tasks

➤ How to Work with Tests in ALM/QC on page 204

➤ How to Save Tests to ALM/QC Projects on page 206

➤ How to View a List of Previous Test Versions on page 207

Reference

➤ ALM/QC User Interface on page 208
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Concepts

Managing Tests Through HP ALM/QC Overview

Service Test integrates with supported versions of HP ALM/QC (Application 
Management Lifecycle/Quality Center). ALM/QC integration allows you 
maintain projects with a different kinds of tests (such as Service Test and 
QuickTest tests, business process tests, manual tests, tests created using other 
HP products, and so forth) that cover all aspects of your application's 
functionality. Each test in your project is designed to fulfill a specified 
testing requirement of your application. To meet the goals of a project, you 
organize the tests in your project into unique groups. 

HP ALM/QC provides an intuitive and efficient method for scheduling and 
running tests, collecting results, analyzing the results, and managing test 
versions. They also features a system for tracking defects, enabling you to 
monitor defects closely from initial detection until resolution. 

Service Test integrates with Service Test Management, the ALM/QC tool for 
storing and managing application components, such as Web services. 
Service Test Management is an extension of ALM/QC and it provides an 
efficient method for storing and retrieving application components. 

In order for Service Test to work with ALM, you must connect to the Web 
server on which ALM/QC is installed. You can connect to either a local or 
remote server.

For more information on working with ALM/QC, see the HP Application 
Lifecycle Management User Guide.
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ALM/QC Tests and Version Control

If your test is saved in an ALM/QC project that uses version control, the 
process of opening and saving a test is different.

Tests with version control are either in a state of checked-in or checked-out. 
When you are working with a test in a checked-out state, any changes you 
make will not be saved on the ALM/QC server until you check in the test. If 
you save the test from within Service Test, a temporary file is saved onto 
your machine that protects the test in case your computer crashes.

If you are working with a test in a checked-in state, the test is read-only and 
you cannot save your changes until you check out the test.

If a particular test is being saved to ALM/QC for the first time, and the 
project uses version control, the test automatically starts in a checked-out 
state.
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Tasks

How to Work with Tests in ALM/QC

The following steps describe the workflow of how to work with tests saved 
in an ALM/QC project.

➤ "Connect to ALM/QC" on page 204

➤ "Open the test" on page 205

➤ "(Version control only) Check in/out the test" on page 205

➤ "(Version control only) Cancel a check out" on page 205

➤ "Save the test" on page 205

Connect to ALM/QC

Open a connection to the ALM/QC server. Log into the project that contains 
the test. For task details, see "How to Connect to ALM/QC" on page 206.
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Open the test

Select File > New menu to create a new test, or choose Open > Test to open a 
test already saved in ALM/QC. Select the To find the test, select the HP ALM/
QC Test Lab module, and drill down in the folder tree until you locate it.

(Version control only) Check in/out the test

If the ALM/QC project has version control, tests are defined as being either 
checked-in or checked-out. For more details, see "ALM/QC Tests and Version 
Control" on page 203. To check in and check out scripts, select File > ALM/
QC Version Control > Check In/Out.

(Version control only) Cancel a check out

If you checked out a test and do not want to save the changes, you can 
return the status of the test to checked-in without saving by selecting File > 
ALM/QC Version Control > Undo Check Out.

Save the test

Select File > Save Test As. Click the HP ALM/QC Test Plan button and 
navigate to the desired location. If you connected to a project that uses 
version control but is not checked out, the test is only saved as a temporary 
file on your local machine.
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How to Connect to ALM/QC
To store and retrieve scripts from ALM/QC, you need to connect to a project.

 1 Select File > HP ALM/QC Connection. 

 2 Enter a URL, user name and password and click Connect. Use the 
complete URL. For example, http://servername.dev.lab:8080/qcbin. 

Note: An http/https prefix and port number are mandatory.

 3 Select a domain and project for your test and click Login.

 4 To logout from the project, but remain connected to ALM/QC, click 
Logout. This is useful if you want to switch to a different project.

 5 To disconnect from ALM/QC, click Disconnect.

For user interface details, see "HP ALM/QC Connection Dialog Box" on 
page 208. 

How to Save Tests to ALM/QC Projects

The following steps describe how to save a Service Test project to the ALM/
QC repository.

➤ "Connect to ALM/QC" on page 207

➤ "Open a test" on page 206

➤ "Save the test to ALM/QC" on page 207

Open a test

Create or open a test. Choose File > Open > Test or click the Create New Test 
link on Service Test’s Start Page tab.
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Connect to ALM/QC

Open a connection to the ALM/QC server and project that you want to store 
the test. For task details, see "How to Connect to ALM/QC" on page 206.

Save the test

Choose File > Save to save the test to a temporary folder.

Save the test to ALM/QC

Choose File > Save As and select the HP ALM/QC Test Plan button. Navigate 
to the desired location or use the New Folder button  to create a new 
directory for the test. Specify a File Name and click Save.

How to View a List of Previous Test Versions

If your test is saved in an ALM/QC project that uses version control, you can 
view a list of the versions of the test. The following steps describe how to do 
this.

➤ "Connect to ALM/QC" on page 207

➤ "Open a test" on page 207

➤ "View a list of the versions" on page 207

Connect to ALM/QC

Open a connection to the ALM/QC server and project that you want to store 
the test. Make sure the ALM/QC project supports versioning. 

For task details, see "How to Connect to ALM/QC" on page 206.

Open a test

Create or open a test. Choose File > Open > Test.

View a list of the versions

Select File > HP ALM/QC Version Control > Version History and view the list.



Chapter 6 • ALM/QC Integration

208

Reference

ALM/QC User Interface 

This section includes:

 ➤ HP ALM/QC Connection Dialog Box on page 208

HP ALM/QC Connection Dialog Box

This dialog box enables you to connect to a ALM/QC project from within 
Service Test.

To access File > HP ALM/QC Connection …

Relevant tasks ➤ "Managing Tests Through HP ALM/QC Overview" on 
page 202

➤ "How to Work with Tests in ALM/QC" on page 204
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User interface elements are described below:

UI Elements (A-Z) Description

Step 1: Connect to 
Server

➤ Server URL. The URL of the server that contains ALM/
QC.

➤ User Name. Your ALM/QC user name.

➤ Password. Your ALM/QC password.

➤ . Connects to the ALM/QC server with 
your user information.

➤ . Disconnects from the ALM/QC server.

Step 2: Login to 
Project

➤ Domain. The domain that contains the ALM/QC 
project. Only those domains containing projects to 
which you have permission to connect to are 
displayed. 

➤ Project. Enter the ALM/QC project name or select a 
project from the list. Only those projects that you 
have permission to connect to are displayed.

➤ . Logs in to the selected project.

➤ . Logs out from the current project.

Reconnect on startup ➤ Connects to ALM/QC the next time your open Service 
Test.
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7
Run Results Viewer

This chapter includes:

Concepts

➤ Run Results Viewer Overview on page 212

➤ Run Results File Location on page 214

➤ Captured Data on page 215

➤ Custom Fields on page 218

Tasks

➤ How to Open Run Results on page 220

➤ How to Navigate the Run Results Tree on page 221

➤ How to Manually Submit Defects to Quality Center on page 222

➤ How to Export Run Results on page 224

Reference

➤ Run Results Viewer User Interface on page 226

➤ Run Results Viewer Commands on page 229

➤ Run Results Viewer Panes on page 232

➤ Run Results Viewer Dialog Boxes on page 245
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Concepts

 ➤ Run Results Viewer Overview on page 212

 ➤ Run Results File Location on page 214

 ➤ Captured Data on page 215

 ➤ Custom Fields on page 218

Run Results Viewer Overview 

After running a test, the Run Results Viewer opens automatically at the end 
of a test run. You can also open it manually at any time.

The Run Results Viewer contains a description of the steps performed during 
the run session. 

➤ For a test that does not contain Data Table input parameters, the Run 
Results Viewer shows a single test iteration. 

➤ For tests, that contain Data Table input parameters, the Run Results 
Viewer displays details for each iteration of the test run. The results are 
grouped by the actions in the test.

For an overview of the various panes, see "Run Results Viewer User Interface" 
on page 226.
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QuickTest Professional Integration
Service Test lets you perform (UFT) Unified Functional Testing with Quick 
Test Professional tests. If you run a Service Test test that contains a call to a 
QuickTest Professional test, or vice versa, you can view the results for all 
steps performed in the main test and in the called test.

Run Results XML File
The results of each Service Test run session are saved in a single .xml file 
(called results.xml). This .xml file stores information on each of the run 
result nodes in the display. The information in these nodes is used to 
dynamically create .htm files that are shown in the top-right pane in the 
Run Results Viewer. 

Each node in the run results tree is an element in the results.xml file. In 
addition, there are different elements that represent different types of 
information displayed in the run results. You can take run result 
information from the .xml file and use XSL to display the information you 
require in a customized format (either when printing from within the 
Service Test Run Results Viewer, when displaying run results in your own 
customized results viewer, or when exporting the run results to an HTML 
file).

XSL provides you with the tools to describe exactly which run result 
information to display and exactly where and how to display, print or 
export it. You can also modify the .css file referenced by the .xsl file, to 
change the appearance of the report (for example, fonts, colors, and so 
forth). 

For example, in the results.xml file, one element tag contains the name of a 
step, and another element tag contains information on the time at which 
the run session is performed. Using XSL, you could tell your customized run 
results viewer that the step name should be displayed in a specific place on 
the page and in a bold green font, and that the time information should not 
be displayed at all.
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You may find it easier to modify the existing .xsl and .css files provided with 
Service Test, instead of creating your own customized files from scratch. The 
files are located in C:\Program Files\HP\UFT Result Viewer\dat, and are 
named as follows:

➤ PShort.xsl. Specifies the content of the run results report printed, or 
exported to an HTML file, when you select the Short option in the Print 
or Export to HTML File dialog boxes.

➤ PDetails.xsl. Specifies the content of the run results report printed, or 
exported to an HTML file, when you select the Detailed option in the 
Print or Export to HTML File dialog boxes.

➤ PResults.css. Specifies the appearance of the run results print preview. 
This file is referenced by all three .xsl files.

For more information on printing run results using a customized .xsl file, see 
"Print Dialog Box" on page 252.

For more information on exporting the run results to a file using a 
customized .xsl file, see "Export Run Results Dialog Box" on page 246.

Run Results File Location

When you run a test, Service Test opens the Run dialog box. You can select a 
path for the results or use the default location—the test’s folder. 
Alternatively, you can specify a temporary folder, that gets overwritten by 
each subsequent test run. This is ideal if you are developing a test and have 
no need for the results.

If your test is stored in ALM/QC (Application Management Lifecycle/
Quality Center), the Run dialog box prompts you to store the results in your 
ALM/QC project. You cannot modify the project, but you can specify a run 
name, a test folder, and an instance.

For details, see "How to Run a Test" on page 187.
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Captured Data

The captured data tab in the bottom pane shows the data generated during a 
test run. The contents of the tab differs depending on the level you select in 
the Results tree in the left pane.

These user interface elements are described below:

UI Elements Description

Flow Diagram A snapshot of the test’s canvas.

Start, End General information about the Start and End activities.

Test Flow / Loop Information about the loop such as loop name, loop 
type, display name and so forth.

Iteration Information about the iteration to which the activities 
belong.
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Request and Response

The Activity level captured data contains a table showing the request and 
response messages.

The following example shows the Request and Response data for the 
GetFlights operation from the sample Web Service.

Activity Captured data from the activity:

➤ For Service type activities, this level shows the Request 
and Response data for the operation or method. 

➤ For the Report Message activity, this level displays the 
custom message defined in the activity’s properties. 
For details, see "Sending Messages to the Output and 
Results Viewer" on page 27.

Checkpoint Data about the checkpoints such as the Expected and 
Actual values, the method of evaluation (Equals, Does 
Not Equal, and so forth) and status.

UI Elements Description
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Messages

For the Report Message activity, the Activity level displays a custom 
message defined in the activity’s properties.

For details, see "Sending Messages to the Output and Results Viewer" on 
page 27.

Data Driven and Parameterized Properties

If you parameterized or applied data driving to an activity’s properties, the 
viewer lists the actual values used during the test run, per iteration.

For built-in activities, the Step Properties table shows the values used during 
the test run.
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For service requests, you can observe the actual values in the Request/
Response table.

HTTP Checkpoint Response

To view the actual result for HTTP activity checkpoints, select the 
checkpoint’s parent node in the Captured Data tab, and scroll to the 
Response body. Locate the actual result string in the Response body table. 
The child node of the checkpoint does not provide this information.

Custom Fields

You can use the Report function to show custom information in the Results 
report. You can specify strings or existing arguments and display them in 
the report.

You add the Report function to the step’s events. For details, see the section 
on Custom Code and Events.

The following example prints AUG-12-2010_CYCLE_1 in the Value column 
for TestID, in the Concatenate String step.

args.Activity.Report("TestID","AUG-12-2010_CYCLE_1");
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The report displays the keyword and its value at the Activity level of the 
results. For details, see the "Captured Data" on page 215.
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Tasks

 ➤ How to Open Run Results on page 220

 ➤ How to Navigate the Run Results Tree on page 221

 ➤ How to Manually Submit Defects to Quality Center on page 222

 ➤ How to Export Run Results on page 224

How to Open Run Results

After a test run, Service Test automatically opens the Run Results Window 
with the results of the current run. This task describes how to open specific 
run results in the Run Results Viewer.

This task includes the following steps:

➤ "Open the Run Results Viewer" on page 220

➤ "Connect to your Quality Center project - optional" on page 220

➤ "View saved results" on page 220

Open the Run Results Viewer

➤ If the Run Results Viewer is not open, select Test > View Test Results in 
the Service Test window.

Connect to your Quality Center project - optional

If your run results are saved in Quality Center, connect to your 
Quality Center project before opening the results file. For details, see 
"Quality Center Connection - Server Connection Dialog Box" on page 255.

View saved results 

Click the Open button or select File > Open. The Open Run Results dialog 
box opens. Browse to the relevant results folder or file. For details, see "Open 
Run Results Dialog Box" on page 251.
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How to Navigate the Run Results Tree

This task describes how to collapse or expand a branch in the run results tree 
to select the level of detail that the tree displays. 

When you open the Run Results Viewer for the first time, the tree expands 
one level at a time. If the child branches under a parent branch were 
previously expanded, that state is maintained when you expand or collapse 
the parent branch.

To expand a specific branch, do any of the following: 

➤ Select the branch and click the expand (+) sign to the left of the branch 
icon.

➤ Press the plus key (+) on your keyboard number pad. 

The tree displays the details for the branch, and the expand sign changes to 
collapse.

To expand a branch and all branches below it: 

➤ Select the branch and press the asterisk (*) key on your keyboard number 
pad.

To expand all of the branches in the run results tree, do any of the 
following: 

➤ Right-click a branch and select Expand All. 

➤ Select the top level of the tree and press the asterisk (*) key on your 
keyboard number pad.

To collapse a specific node, do any of the following: 

➤ Select it and click the collapse (–) sign to the left of the node icon.

➤ Press the minus key (–) on your keyboard number pad. 

The node’s child nodes disappear from the tree, and the collapse sign 
changes to expand (+).

To collapse all of the nodes in the tree: 

Right-click a node and select Collapse All.
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To move between previously selected nodes within the run results tree:

Click the Go to Previous Node or Go to Next Node buttons.

To find specific steps within the Run Results:

Use the Search box (shown in the example below).

You can search for text and/or types of nodes. For details, see "Run Results 
Tree Pane and Search Box" on page 232.

To filter the tree to display only nodes that match certain criteria:

Use the Filter dialog box (View > Filters). For details, see "Filter Dialog Box" 
on page 249.

How to Manually Submit Defects to Quality Center

This task describes how to manually add defects to a Quality Center project.

This task includes the following steps:

➤ "Prerequisites" on page 223

➤ "Connect to a Quality Center project" on page 223

➤ "Open the New Defect dialog box" on page 224

➤ "Modify the defect information if needed and submit it" on page 224

➤ "Results" on page 224
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 1 Prerequisites

Ensure that the Quality Center client is installed on your computer. (Enter 
the Quality Center Server URL in a browser and ensure that the Login 
screen is displayed.)

 2 Connect to a Quality Center project

Select Tools > Quality Center Connection or click the Quality Center 
Connection button and connect to a Quality Center project. 
"Quality Center Connection - Server Connection Dialog Box" on 
page 255.

Note: If you do not connect to a Quality Center project before proceeding 
to the next step, Service Test prompts you to connect before continuing.
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 3 Open the New Defect dialog box

Select Tools > Add Defect or click the Add Defect button to open the New 
Defect dialog box in the specified Quality Center project. The New Defect 
dialog box opens.

 4 Modify the defect information if needed and submit it

Basic information is included in the description, but you can modify the 
defect if needed.

 5 Results

The defect is added to the Quality Center project’s defect database.

How to Export Run Results

This task describes how to export run results to a file. For details on what is 
included when you export run results, see "Export Run Results Dialog Box" 
on page 246.

This task includes the following steps:

➤ "Open the results in the Run Results Viewer" on page 225

➤ "Specify the export settings" on page 225

➤ "Save the file" on page 225

➤ "Results" on page 225
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 1 Open the results in the Run Results Viewer

For details, see "Open Run Results Dialog Box" on page 251.

 2 Specify the export settings

Select File > Export To File. The Export Run Results dialog box opens. For 
details on the various settings, see "Export Run Results Dialog Box" on 
page 246.

 3 Save the file 

Click Export. The Save As dialog box opens. Specify the file name and 
path, and select the required file type. 

 4 Results

When you click Save, the file is exported in the specified format to the 
designated location. 

Report type Save as type

Step details ➤ HTML (*.htm, *.html) (default)

➤ PDF (*.pdf)

➤ DOC (*.doc)

Data Table Excel (.xls)

Log Tracking XML (.xml)

Screen Recorder FlashBack (*.fbr)

System Monitor ➤ Text (*.csv, *.txt) (default)

➤ Excel (.xls)

➤ XML (.xml)

➤ HTML (*.htm, *.html)
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Reference

 ➤ Run Results Viewer User Interface on page 226

 ➤ Run Results Viewer Commands on page 229

 ➤ Run Results Viewer Panes on page 232

 ➤ Captured Data Pane on page 240

 ➤ Run Results Viewer Dialog Boxes on page 245

Run Results Viewer User Interface

This window enables you to view the results of a test run. 
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The following example shows an Executive Summary: 

 

To access ➤ Opens automatically after a test run. To enable or 
disable, select Edit > Settings > Show Results After Run

➤ Choose Test > View Test Results

Relevant tasks "How to Run a Test" on page 187
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By default, the left pane contains the Run Results tree. The right side of the 
window contains additional panes. These user interface elements are 
described below (unlabeled elements are shown in angle brackets):

Note: Certain panes are only available in QuickTest Professional.

UI Elements Description

<Run Results Viewer 
menu bar and 
toolbar>

See "Run Results Viewer Commands" on page 229.

Executive Summary 
pane

➤ A high-level results overview report (pass/fail status)

➤ Quality Center information for your test (if the test 
was run from Quality Center 

Run Results Tree 
pane

➤ A graphical representation of the results in an 
expandable tree

➤ Displays the test or component steps, specifying 
exactly where application failures occurred

Result Details pane Detailed explanations of each step and checkpoint pass 
or failure, at each stage of the test or component

Captured Data pane A still image of the state of your application at a 
particular step. For details, see "Captured Data Pane" on 
page 240.

<status bar> Displays the status of the currently selected command. 
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Run Results Viewer Commands

The Run Results Viewer menu bar and toolbar contain commands to help 
you view run session results. 

Button Command
Shortcut 
Key

Description

File > Open CTRL+O Opens the Open Run Results dialog box, 
enabling you to open saved run results from 
the file system or from Quality Center. 

For details, see "How to Open Run Results" 
on page 220. 

File > Print CTRL+P Opens the Print dialog box, enabling you to 
print the results of the run session. 

For details, see "Print Dialog Box" on 
page 252. 

-- File > Print 
Preview

CTRL+F2 Opens the Print Preview dialog box, 
enabling you to preview the results of the 
run session prior to printing. 

For details, see "Print Preview Dialog Box 
(Run Results Viewer)" on page 254. 

-- File > 
Export To 
File

-- Opens the Export Run Results dialog box, 
enabling you to save various parts of the 
results as external files.

For details, see "Export Run Results Dialog 
Box" on page 246.

-- File > 
Recent 
Files

-- Lists the recently viewed files.

-- File > Exit -- Closes the Run Results Viewer session.

-- View > Run 
Results 
Viewer 
Toolbar

-- Shows or hides the Run Results Viewer 
toolbar.
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-- View > 
Status Bar

-- Shows or hides the status bar, which 
indicates:

➤ a hint about the currently selected 
command

➤ the status of the Run Results Viewer

➤ the Quality Center server name and 
project to which the Run Results Viewer 
is connected

-- View > 
Result 
Details

-- Shows or hides the Results Details pane. For 
details, see "Result Details Pane" on 
page 236.

-- View > 
Captured 
Data 

-- Shows or hides the Captured Data pane. For 
details, see "Captured Data Pane" on 
page 240.

-- View > 
Restore 
Layout

-- Restores the default layout of the Run 
Results Viewer.

View > 
Filters

CTRL+T Opens the Filters dialog box, enabling you 
to filter the information displayed. For 
details, see the "Filter Dialog Box" on 
page 249.

-- View > 
Expand All

-- Expands all of the branches in the run 
results tree.

Also available as a context-menu option.

-- View > 
Collapse All

-- Collapses all of the branches in the run 
results tree.

Also available from the shortcut menu.

Button Command
Shortcut 
Key

Description
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Tools > Add 
Defect

-- Enables you to add a defect to your 
Quality Center project. If you are not 
currently connected to Quality Center, 
opens the Quality Center Connection - 
Server Connection dialog box. For more 
information, see "How to Manually Submit 
Defects to Quality Center" on page 222. 

Tools > 
Quality 
Center 
Connection

-- Opens the Quality Center Connection - 
Server Connection dialog box, enabling you 
to connect to a Quality Center project. For 
more information, see the "Quality Center 
Connection - Server Connection Dialog 
Box" on page 255.

Go to 
Previous 
Node

BACKSPACE Moves the cursor to the previously selected 
node in the run results tree. For more 
information, see "How to Navigate the Run 
Results Tree" on page 221.

Go to Next 
Node

ALT+RIGHT 
ARROW

Moves the cursor to the node you selected 
in the run results tree prior to clicking the 
Go to Previous Node button. For more 
information, see "How to Navigate the Run 
Results Tree" on page 221.

Help > Help 
Topics

-- Opens the online help for the Run Results 
Viewer.

-- Help > 
About Run 
Results 
Viewer

-- Displays version information about the Run 
Results Viewer.

Button Command
Shortcut 
Key

Description
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Run Results Viewer Panes

This section includes:

➤ "Run Results Tree Pane and Search Box" on page 232

➤ "Result Details Pane" on page 236

Run Results Tree Pane and Search Box
This pane displays the run results tree—a hierarchical representation of the 
test run results.
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The following image shows an example of an expanded Search box. Six 
instances of the searched for text, Welcome, were found.

 

User interface elements are described below:

To access This pane is displayed by default on the left side of the 
Run Results Viewer. It cannot be hidden.

Important 
information

You can collapse or expand a node in the run results tree 
to change the level of detail that the tree displays. 

You can also use the Search and Filter commands to 
control what is displayed in the run results tree. For 
details, see "Run Results Tree Pane and Search Box" on 
page 232 and "Filter Dialog Box" on page 249. 

UI Elements Description

A step that succeeded. 

Note: If a test does not contain checkpoints, no icon is 
displayed. 

A step that failed. Note that this causes all parent steps 
(up to the root action, test, or component) to fail as 
well.

A warning, meaning that the step did not succeed, but 
it did not cause the action, test or component to fail.
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Search box user interface elements are described below:

A step that failed unexpectedly.

The run session was stopped before it ended.

UI Elements Description

Text box in which you can optionally enter text for 
which to search. 

If the specified text is found in one or more tree nodes, 
the text area indicates this, as shown below:

In this example, 1 of 6 indicates that there are six nodes 
displaying the text, Welcome, and the first matching 
node is highlighted in the tree.

Search. Finds the next instance that matches the 
criteria you specified in the Search box. Click this 
button to jump to each node that matches your search 
criteria.

Cancel. Clears the Search for text box.

Expand or Collapse. Shows or hides the lower part of 
the Search box.

UI Elements Description
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Status The status to search for. (Optional)

Possible values:

➤ Passed. Searches for steps that passed and match 
your other selection criteria.

➤ Failed. Searches for steps that failed and match your 
other selection criteria.

➤ Done. Searches for steps with the status Done (steps 
that were performed successfully but did not receive 
a pass, fail, or warning status) that match your other 
selection criteria.

➤ Warning. Searches for steps with the status Warning 
(steps that did not pass, but did not cause the test to 
fail) that match your other selection criteria.

Note: If the tree does not contain any steps that match 
a particular status, that option is grayed out in the 
Search box.

Node type The type of node to search for (together with your 
other search criteria). (Optional)

Possible values for Service Test:

➤ Step. Searches for steps that match your other 
selection criteria.

Direction The direction to search in the tree. Possible values:

➤ Up

➤ Down

UI Elements Description
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Result Details Pane 
This pane displays the details for an individual iteration, an action, or a step 
that is currently selected in the run results tree.

Example of Executive Summary:

The Executive Summary is displayed when the topmost node in the run 
results tree is selected.
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Example of Result Details:

Result details are displayed when any node (other than the topmost node) is 
selected in the run results tree.

 

To access Do the following:

1  Select a node in the run results tree: 

➤ To open the Executive Summary page, select the 
topmost node in the tree.

➤ To open the Result Details for a step, select the 
relevant node in the tree.

2  Select the Result Details tab. (This assumes that the 
default layout is displayed.) 

Tip: If the Result Details pane is hidden, select View > 
Result Details to show it.

Important 
information

By default, when the Run Results Viewer opens after a 
run session, an Executive Summary is displayed in the 
Result Details pane. 

For any other node, the details in the Result Details pane 
are specific for the step selected in the run results tree. 
For details, see "Captured Data" on page 215.
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

Executive Summary Page

Result Details for Step

UI Elements Description

Executive Summary Includes:

➤ the test or component name and result details

➤ time-related information for the run

➤ the product from which the test or component was 
run

➤ Quality Center server and project, if Service Test was 
connected to a Quality Center project during the run 

Note: If a test or component that is stored in Quality 
Center is run from QuickTest, but you choose to store 
the results in a temporary location, the Test set and 
Test instance fields are not displayed in the results.

Statistics Graphical, status-related statistics for the current run and 
the previous run (if any). If the test or component was 
run previously, you can click Open to open a previous 
run results.

UI Elements Description

<step name> The name of the step.
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<step status> The status of the step. Possible values:

➤ Done. Relevant for iterations, actions, and steps that 
ran successfully, but do not contain checkpoints.

➤ Failed. Relevant for iterations, actions, and steps that 
contain checkpoints.

➤ Passed. Relevant for iterations, actions, and steps that 
contain checkpoints.

➤ Warning. Relevant for steps that were not successful, 
but did not cause the test or component to stop 
running.

Note: A test, component, iteration, or action 
containing a step marked Warning may still be labeled 
Passed or Done.

<step details> Details about the step, such as the object on which the 
step was performed, the timestamp, the step results, and 
so on. The information in this area changes according to 
the type of step. 

For more details, see "Captured Data" on page 215.

UI Elements Description
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Captured Data Pane 
The captured data tab in the bottom pane shows the data generated during a 
test run. The contents of the tab differs depending on the level you select in 
the step pane tree in the left pane. 

The following image shows the Captured Data pane showing the Web 
Service Call properties. 

 

To access Select View > Captured Data or click the Captured Data 
tab.

Important 
information

Programmatically adding information to the results: 
You can programmatically add items to the report. For 
details, see "Custom Fields" on page 218. 

Relevant tasks "How to Navigate the Run Results Tree" on page 221
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The contents of the Captured Data in Service Test pane differs depending on 
the level you select in the run results tree.

➤ Start, End. General information about the Start and End activities. 

➤ Parent step. Information about the loop to which the test steps belong, 
such as Test Flow.

➤ Iteration. Information about the iteration to which the activities belongs 
such as the status of the iteration and its display name.

➤ Activity. Captured data from the activity, or operation in the case of Web 
Services. For Service type activities, this level shows the Request and 
Response data.

➤ Checkpoints. Data about the checkpoints such as the Expected and Actual 
values, the method of evaluation (Equals, Does Not Equal, and so forth) 
and status.

Samples of Captured Data

Request and Response

The following example shows the Request and Response data for the 
GetFlights operation from the sample Web Service, on the Step level. 
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Data Driven and Parameterized Properties

If you parameterized or applied data driving to an activity’s properties, the 
viewer lists the actual values used during the test run, per iteration.

For built-in activities, the Step Properties table shows the values used during 
the test run. 

For service requests, you can observe the actual values in the Request/
Response table.
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Web Service Activity

The following tables shows the results of a Web Service operation from the 
Sample application, GetFlights: 

Concatenate String Activity

The following tables shows the results of a the String Manipulation Activity, 
Concatenate String.

In the results tree: In the Result Details pane:

Step Type The type of step as it is defined in the source code. This 
field is not editable by the user. For example 
HP.ST.Ext.WebServicesTechnologyRT.StServiceCallActivity.

Step Name The step name as it appears in the test’s source code, 
visible when you create an event handler for a step. For 
example StServiceCallActivity1. This field is read-only.

Service Name The service name as defined in the WSDL. 

Port Name The name of the operation’s port.

Operation Name The name of the operation.

Endpoint Address The endpoint for the service to which the requests are 
sent.

SOAP Action The full path of the SOAP action, such as 
HP.SOAQ.SampleApp/IHPFlights_Service/CreateFlightOrder.

Content Type The content type of the request message, for example, text/
xml, charset=utf

Message Exchange 
Pattern

The pattern of the messages, for example Request 
{followed by) Response.

HTTP Status Code The HTTP Status code returned by the server.

In the results tree: In the Result Details pane:

 Type The internal type name of the step.

HP.ST.Ext.BasicActivities.ConcatenateStringsActivity
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Checkpoint Captured Data

The Checkpoint level captured data is only presented if you enable 
Checkpoints for the test run. A grid provides the following information for 
each checkpoint:

Name The step name as it appears in the test’s source code, 
ConcatenateStringsActivity. This is visible when you 
create an event handler for a step. 

Message A message indicating the status and purpose of the 
step. For example, "Successfully concatenated 
strings."

Prefix The built-in property, Prefix. 

Suffix The built-in property, Suffix. 

Result The resulting text after the step was executed.

Name The name of the step as it appears in the canvas, 
ConcatenateStringsActivity, or a custom name.

Comment The comment entered in the step’s General tab.

 Status The run status, such as Done, Failed, and so forth.

In the results tree: In the Result Details pane:

Name The checkpoint index. For example, 
Checkpoint(), Checkpoint1, and so forth.

Result Passed or Failed, indicated graphically with 
a check or X mark.

Property The path of the checkpoint in the SOAP 
envelope. For example, 
Envelope[1]\Body[1]\CreateFlightOrderResp
onse[1]\CreateFlightOrderResult[1]\OrderNu
mber[1]. 

Actual Result The actual output value received in the 
response.

In the results tree: In the Result Details pane:
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Run Results Viewer Dialog Boxes

This section includes (in alphabetical order):

 ➤ Export Run Results Dialog Box on page 246

 ➤ Filter Dialog Box on page 249

 ➤ Open Run Results Dialog Box on page 251

 ➤ Print Dialog Box on page 252

 ➤ Print Preview Dialog Box (Run Results Viewer) on page 254

 ➤ Quality Center Connection - Server Connection Dialog Box on page 255

Evaluation Style The type of comparison operator, such as 
EqualTo, and so forth.

Expected Values The response you expected to receive, from 
the Checkpoint grid’s Expected Value field.

Details Checkpoint details, when relevant. For 
example, if you add an Assert function to 
the step’s event handler, the text will 
appear in this field. For details, see the 
"How to Write Checkpoint Events" on 
page 268.

In the results tree: In the Result Details pane:
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Export Run Results Dialog Box

This dialog box enables you to export run results to a file so that you can 
view them even if the Run Results Viewer is unavailable. For example, you 
can send the file containing the run results in an e-mail to a third-party who 
does not have the Run Results Viewer installed. 
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User interface elements are described below:

To access Select File > Export to File.

Important 
information

➤ The export time varies according to the size of the 
results file and the file type you select. When selecting 
the file type, consider the length of time it will take to 
generate different document types, especially for a 
report with many images. HTML files generate the 
fastest, followed by PDF and DOC. When exporting a 
report with 100 or more images to a DOC file, a dialog 
box is displayed reminding you that it may take a long 
time to generate the file. The dialog box gives you the 
option to continue exporting with images, continue 
exporting without images, or to export to PDF.

➤ Screen capture images are not exported for steps on 
Web-based applications. When you export run results 
containing steps on a Web application, any screen 
capture images for those steps are not exported to the 
file. This is because for Web-based applications, the 
Run Results Viewer displays the HTML corresponding 
to the relevant Web page (with downloaded images) 
rather than a captured image and thus no image is 
saved with the report.

Relevant tasks "How to Export Run Results" on page 224

UI Elements Description

Report type The type of report you want to export, for example, Step 
Details.



Chapter 7 • Run Results Viewer

248

Export range Relevant only for Step Details report type.

➤ All nodes. Exports the results for the entire test or 
component.

➤ Selected node. Exports run result information for the 
selected branch in the run results tree. 

Export format Relevant only for Step Details report type.

➤ Short. Exports a summary line (when available) for 
each item in the run results tree. This option is only 
available if you selected All nodes in Export range.

➤ Detailed. Exports all available information for each 
item in the run results tree, or for the selected branch, 
according to your Export range selection. (In the Run 
Results Viewer, these images are displayed in the 
Captured Data pane.) 

➤ User-defined XSL. Enables you to browse to and select 
a customized .xsl file. You can create a customized .xsl 
file that specifies the information to be included in the 
exported report, and the way it should appear. For 
more information, see the "Run Results XML File" on 
page 213.

UI Elements Description
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Filter Dialog Box 

This dialog box enables you to filter the results tree to display only those 
nodes that match the conditions that you specify.

 

To access Select View > Filters
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User interface elements are described below (unlabeled elements are shown 
in angle brackets):

UI Elements Description

<Filter box> The text by which you want to filter. 

Status ➤ Passed. Displays the run results for the steps that 
passed.

➤ Failed. Displays the run results for the steps that failed.

➤ Done. Displays the run results for the steps with the 
status Done (steps that were performed successfully 
but did not receive a pass, fail, or warning status).

➤ Warning. Displays the run results for the steps with 
the status Warning (steps that did not pass, but did not 
cause the test to fail).

Node type list Displays all results that match your selection criteria 
based on: (Optional)

➤ Iteration. Displays the run results in the run results 
tree for the iterations specified in the Iterations area.

➤ Action. Displays the run results for all actions in the 
run results tree that match your other selection 
criteria.

➤ Component. Displays the run results for all 
components in the run results tree that match your 
selection criteria.

➤ Step. Displays the run results for all steps in the run 
results tree that match your other selection criteria.

➤ Reporter. Displays the run results for all Reporter steps 
in the run results tree that match your other selection 
criteria. (QuickTest Professional only) 

➤ Checkpoint/Output Value. Displays the run results for 
all checkpoint and output value steps in the run 
results tree that match your other selection criteria.

Iterations ➤ All. Displays run results from all iterations.

➤ From iteration X to Y. Displays the run results from 
the specified range of test iterations.
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Open Run Results Dialog Box

This dialog box enables you to select the results to display in the Run Results 
Viewer.

 

User interface elements are described below.

To access Select File > Open or click the Open button .

Important 
information

➤ To view results stored in Quality Center, you must first 
connect to your Quality Center project. For details, see 
"Quality Center Connection - Server Connection 
Dialog Box" on page 255.

➤ By default, results files for tests are stored in the 
Reports folder under the user’s My Documents folder.

Relevant tasks "How to Open Run Results" on page 220

UI Elements Description

Test name The name of the test for which you want to view results. 
The test can be located in the file system or in a 
Quality Center project. If you select the Test name 
option, you must also specify the Results folder name.

The Browse button allows you to navigate to the location 
of the test.

Results folder The results for a particular run. 

Results XML file An XML file in which the results are stored. The file must 
be located in the file system.
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Print Dialog Box

This dialog box enables you to print run results from the Run Results Viewer. 
You can select the type of report you want to print, and you can also create 
and print a customized report.

 

To access Use one of the following:

➤ Select File > Print

➤ Click the Print button 
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User interface elements are described below:

UI Elements Description

Print range ➤ All nodes. Prints the run results for the entire test or 
component.

➤ Selected nodes. Prints the run results information for 
the selected branch in the run results tree.

Print format ➤ Short. Prints a summary line (when available) for each 
item in the run results tree. This option is only 
available if you selected All in Print range.

➤ Detailed. Prints all available information for each item 
in the run results tree, or for the selected branch, 
according to your selection in Print range. The printed 
report includes still images associated with the steps in 
your run results. If a bitmap checkpoint step displays 
expected, actual, and difference bitmaps, these are also 
included.

➤ User-defined XSL. Enables you to browse to and select 
a customized .xsl file. You can create a customized .xsl 
file that specifies the information to be included in the 
printed report, and the way it should appear. 
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Print Preview Dialog Box (Run Results Viewer)

This dialog box enables you to preview run results on screen before you 
print them. You can select the type and quantity of information you want to 
view, and you can also display the information in a customized format.

 

User interface elements are described below:

To access Select File > Print Preview

UI Elements Description

Displays the run results on screen as they will appear 
when printed.

Tip: If some of the information is cut off in the preview, 
for example, if checkpoint names are too long to fit in 
the display, click the Page Setup button  in the Print 
Preview window and change the page orientation from 
Portrait to Landscape.
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Quality Center Connection - Server Connection Dialog 
Box

This dialog box enables you to connect or disconnect to or from a 
Quality Center project.

 

Print range ➤ All nodes. Previews the run results for the entire test.

➤ Selected nodes. Previews run results information for 
the selected branch in the run results tree.

Print format ➤ Short. Previews a summary line (when available) for 
each item in the run results tree. This option is only 
available if you selected All in Print range.

➤ Detailed. Previews all available information for each 
item in the run results tree, or for the selected branch, 
according to your selection in Print range. The 
preview includes still images associated with the steps 
in your run results. If a bitmap checkpoint step 
displays expected, actual, and difference bitmaps, 
these are also included.

➤ User-defined XSL. Enables you to browse to and select 
a customized .xsl file. You can create a customized .xsl 
file that specifies the information to be included in the 
preview, and the way it should appear. For more 
information, see "Run Results XML File" on page 213.

UI Elements Description
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After you connect to the server, the dialog box expands to include the 
remaining connection fields.

 

To access Select Tools > Quality Center Connection

Important 
information

Connect. The connection process has two stages. First, you 
connect to a local or remote Quality Center server. This server 
handles the connections between Service Test and the Quality 
Center project. 

Next, you log in and choose the project you want the Run 
Results to access. 

Relevant tasks "How to Open Run Results" on page 220

See also "Run Results Viewer Overview" on page 212
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User interface elements are described below:

UI Elements (A-Z) Description

Authenticate /
Change User

Authenticates your user information against the 
Quality Center server.

Note: After your user information has been authenticated, 
the edit boxes in the Authenticate user information area are 
displayed in read-only format. The Authenticate button 
changes to a Change User button.

Tip: You can log in to the same Quality Center server using 
a different user name by clicking Change User, and then 
entering a new user name and password and clicking 
Authenticate again.

Authenticate on 
Startup

Automatically authenticates your user information against 
the Quality Center server every time you open the Run 
Results Viewer.

Close Closes the Quality Center Connection dialog box.

Connect / 
Disconnect

Connects or disconnects the Run Results Viewer to or from 
the selected Quality Center server. (After you successfully 
connect to a Quality Center server, the button changes to 
Disconnect.)

Domain The domain that contains the Quality Center project.

Note: Only those domains to which you have permission 
to connect are displayed.

Login / Logout ➤ Login. Logs into the selected domain and project using 
the current user information. (After you successfully log 
into a project, the button changes to Logout.)

➤ Logout. Logs out of the selected domain and project.

Login to project on 
startup

Automatically logs into the selected project every time the 
Run Results Viewer opens.

Password Your Quality Center password.

Project The Quality Center project with which you want to work. 

Note: Only those projects for which you are a defined user 
are displayed.
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Guidelines for Windows Vista, Windows 7, and Server 2008 
Users

The security settings in the following operating systems may prevent you 
from connecting to a Quality Center project:

➤ Windows Vista

➤ Windows 7

➤ Windows Server 2008

This can occur when the UAC (User Account Control) option is set to ON, 
and you have never connected to a Quality Center project. 

To connect to Quality Center for the first time, you must disable the UAC 
option. After you successfully connect to Quality Center, you can turn the 
UAC option on again. Thereafter, you should be able to connect to 
Quality Center, as needed.

To enable Service Test to connect to a Quality Center project:

 1 Log in as an administrator.

 2 From the Control Panel, select User Accounts > Change Security Settings. 

 3 Clear the Use User Account Control (UAC) to help protect your computer 
check box and click OK.

 4 Connect to Quality Center as described below.

 5 Select the Use User Account Control (UAC) to help protect your computer 
check box and click OK to turn the UAC option on again.

Reconnect to 
Server on startup

Automatically reconnects to the Quality Center server 
every time you open the Run Results Viewer.

Server URL The URL address of the Web server where Quality Center is 
installed.

You can choose a Quality Center server accessible via a 
Local Area Network (LAN) or a Wide Area Network (WAN).

User name Your Quality Center user name.

UI Elements (A-Z) Description
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A
Coding Service Test Events 

This chapter includes:

Concepts

➤ Writing Code for Events Overview on page 262

Tasks

➤ How to Open a Window for Writing Custom Code on page 264

➤ How to Access Input and Output Properties on page 265

➤ How to Use the Logging Function on page 266

➤ How to Use the Report Function on page 267

➤ How to Write Checkpoint Events on page 268

➤ How to retrieve and set test variables on page 270

➤ How to encrypt and decrypt passwords on page 270

➤ How to use the OnReceiveResponse Web Service Event on page 272

Reference

➤ Context methods on page 274

➤ Logging Options on page 275

➤ Assert Options on page 276
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Concepts

Writing Code for Events Overview

Service Test lets you write customized code for your test in two ways: 

➤ Event Handlers for all activities

➤ Custom Code activity

For each activity, you can define event handlers for common events, such 
as: CodeCheckPointEvent, BeforeExecuteStepEvent, and 
AfterExecuteStepEvent. Certain activity types such as Web Services and 
HTTP have additional built-in events. For a list of the events, see the "Events 
View" on page 80.

The Custom Code activity allows you to define the behavior of your own 
activity and its properties. You define this behavior through an event 
handler that is triggered before, during, or after the execution of the activity. 

Service Test’s code editor allows you to use autocompletion to prepare the 
event handler. For task details, see "How to Open a Window for Writing 
Custom Code" on page 264.

Tip: To instruct Service Test to ignore an event handler, select the handler 
and press DELETE to remove the name of the handler from the grid.

Casting
The Event Handler code in the SharedUserCode.cs file uses the following 
objects:

➤ sender. The object that raises the activity’s event.

➤  args. The event arguments passed to the activity.
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To access an activity's context, such as any input and output arguments, cast 
the args.Activity object to the appropriate activity type. The built-in 
template provides commented code which illustrates the casting of the 
activity to allow you to use its context.
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Tasks

How to Open a Window for Writing Custom Code

For non-custom code activities, you can define default event handlers for 
checkpoints, before step execution, and after step execution.

The checkpoint event handlers help you verify the output values in your 
test. You can use a Report, Assert, or Log function to gather information 
about your service. 

 1 Open the Events view

Select an activity title in the canvas and open the Events view in the 
Property Sheet.

 2 Select an event

Select the event for which you want to provide code. Double-click in the 
Handler column. 

 3 Edit the code

Click the SharedUserCode.cs tab. Locate the TODO section and add your 
custom code. Follow the sample code in the comments and use 
autocompletion to write your own code.

 4 Enable access to the activity’s properties

If you need to access an activity’s input or output parameters, remove the 
comment tags from the activity object. For example:

// Uncomment the code below to access the activity’s properties.
//var activity = ((HP.ST.Ext.HTTPActivity.HTTPActivity)(args.Activity));
// TODO: Add your code here...
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 5 Save the changes.

Click File > Save All to save all buffers of the test.

How to Access Input and Output Properties

You can set the values of input and output properties through event 
handlers. 

 1 Access the activity’s properties

Access the activity’s properties by removing the comments in the code. 
For example:

 2 Select a property

Use autocompletion to locate and select a property from the dropdown 
list. The dropdown shows all the activity-specific properties. For example, 
for the ConcatenateString activity, the dropdown shows Prefix and Suffix.

 // Uncomment the code below to access the activity’s properties.
var activity = ((HP.ST.Ext.BasicActivities.ConcatenateStringsActivity)(args.Activity));
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 3 Access the activity’s parent

To access the activity’s parent, select the Parent method from the 
dropdown list. A parent refers to the step, condition, or loop that encloses 
the activity. For example, for a step in a conditional branch, the parent is 
the name of the condition step.

How to Use the Logging Function 

The UserLogger function generates messages during replay. You can view 
these messages in the Output tab or in the log file.

 1 Select the UserLogger object

Use autocompletion from the activity’s Context object, and select the 
UserLogger function.

 2 Choose a log type

Use autocomplete to choose a log type. For a list of the log types, see 
"Logging Options" on page 275.

 3 Complete the function

Complete the function as indicated by the tooltip. Provide the necessary 
arguments.

The following example logs unformatted Debug information to the log 
from a variable you defined earlier called debug_information.

string ParentName = activity.Parent.Name;

 args.activity.Context.UserLogger

 activity.Context.UserLogger.Debug(debug_information);
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 4 View the Output Log 

View the output information in the Output tab or in the log file.

To view the output tab:

 a Run the test at least once (F5).

 b Select View > Output. View the Output tab in the bottom section of 
the Service Test window.

To view the output log file:

 a Run the test at least once (F5).

 b Select Test > Open Script Directory and open the Log directory.

 c Open the vtd_user.log file.

How to Use the Report Function 

Use the Report function to show the results of a test’s execution in the Run 
Results Viewer. The report opens automatically after you run the test. You 
can also view it at any time by selecting Test > View Test Results. 

 1 Select the Report object

Use the args.activity object, and select the Report object using 
autocomplete.

 2 Complete the function

Provide a keyword and value, based on the function’s prototype: 
Report(string keyword, string value);

The following example sends the employee’s last name to the report using 
a variable that was defined earlier called LastName. 

 args.activity.Report

args.Activity.Report("Employee Name",LastName);
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 3 View the run results

Run the test and view the Run Results. The report displays the keyword 
and its value in the iteration’s branch.

How to Write Checkpoint Events

You write checkpoint event handlers using the checkpoint object. The Assert 
library functions run a comparison between actual and expected values, and 
show the results in the step’s Checkpoint node. You can also use the 
checkpoint object to control checkpoints in the user interface and customize 
your reports.

 1 Create a checkpoint handler

Double-click the Handler column of the CodeCheckPointEvent row in the 
activity’s Events view.

 2 Access the activity’s properties

Access the activity’s properties by removing the comments in the code. 
For example:

 3 Select the checkpoint object

Use the args object, and select the Checkpoint object using autocomplete.

 4 Validate a checkpoint - optional

To validate a value during run-time, follow these steps:

 a Use the args.checkpoint object, and select the Assert object using 
autocomplete. 

 b Use autocomplete to select a comparison operator such as Equals, and 
so forth. For details, see "Assert Options" on page 276.

 // Uncomment the code below to access the activity’s properties.
var activity = ((HP.ST.Ext.BasicActivities.ConcatenateStringsActivity)(args.Activity));

 args.Checkpoint
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 c Complete the function as indicated by its tooltip. Provide the 
necessary arguments. 

The first example checks if the actual value (first argument) equals the 
expected value (second argument) for the ConcatenateString activity. 

The second example checks if the text value (alphabetical order for a 
string) of the prefix is less than the suffix. To ensure that the checkpoint 
succeeds, enter a prefix value that is greater than the suffix, for example a 
prefix of aa and a suffix of bb.

 5 Ignore selected checkpoints - optional

You can instruct Service Test to ignore the checkpoints selected in the 
Service Test UI (Input/Checkpoints view). This is useful if you need to 
ignore the checkpoints temporarily.

 a Use the args.checkpoint object, and select the RunUICheckpoints 
object using autocomplete. 

 b Set the value to false. You can enable the checkpoints for this step at 
any time by removing this line or by setting it to true.

 6 Customize the checkpoints reporting - optional

You can instruct Service Test to send a specific message to the 
Checkpoints node in the report. The standard Report function sends a 
message to the step’s node, but the Checkpoint’s Report function allows 
you to send messages to the Checkpoint sub-node. 

 a Use the args.checkpoint object, and select the Report object using 
autocomplete. 

 b Complete the function syntax, based on the function’s tooltip, 
providing the actual and expected result and a logical operator.

args.Checkpoint.Assert.Equals(activity.Prefix+activity.Suffix, activity.Result);.

args.Checkpoint.Assert.Less("Concatenate test", activity.Prefix, activity.Suffix,
"Prefix is less than suffix");

args.Checkpoint.RunUICheckpoints = false;
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 7 View the results

Run the test and view the Run Results Viewer. Drill down to the 
checkpoints and check your results.

How to retrieve and set test variables 

The Context object’s TestProfile method allows you to set or get the value of 
a user test variable from the active Test Profile.

 1 Select the TestProfile object

Use the args.activity.Context object, and select TestProfile from the 
autocomplete menu. 

 2 Get or Set a Variable

From the autocomplete menu, select GetVariableValue or 
SetVariableValue methods.

The following example retrieves the value of the TestName test variable.

How to encrypt and decrypt passwords

Password fields expect an encrypted string—if you provide an unencrypted 
string, the authentication will fail. 

The EncryptionMngr method lets you encrypt and decrypt strings within 
your events. 

string testName = activity.Context.TestProfile.GetVariableValue("TestName"); 
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 1 Encrypt the password

Use the args.activity.Context.EncryptionMngr method, select Encrypt 
from the autocompletion dropdown. The following example encrypts a 
password.

 2 Decrypt the password - optional

Use the Decrypt method from the autocompletion dropdown. 

The following example decrypts a password and validates against the 
original string.

// Original password
string plainText = "myPassword";
args.Activity.Context.EncryptionMngr.Encrypt("plainText");

…

args.Activity.Context.EncryptionMngr.Decrypt("encryptedText"); 
…

// Check that the decrypted string is the same as the original password
Debug.Assert(plaintext.Equals(decryptedText));
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How to use the OnReceiveResponse Web Service Event

Service Test provides several custom event handlers for Web Services. The 
following example shows how to send the inner SOAP envelope as a string 
to the execution report, when a response is received. 

Note: To manipulate the Output Envelope (activity.OutputEnvelope 
property), use the AfterExecuteStepEvent—the activity.OutputEnvelope 
property is not available for the OnReceiveResponse event.

For a complete list of the Web Service events, open the Property Sheet’s 
Events view for a Web Service’s step.

 1 Create an event handler

Select a Web Service step and double-click the Handler column of the 
OnReceiveResponse row in the activity’s Events view. A code editor 
containing the new event handler will open.

 2 Access the activity’s properties

Access the activity’s properties by removing the comments in the code. 

 3 Define an XmlDocument 

Use autocompletion to select the XmlDocument method. Define a name 
for the envelope and assign it the value of activity.OutputEnvelope.

 // Uncomment the code below to access the activity's properties.
var activity = 
((HP.ST.Ext.WebServicesActivities.StServiceCallActivity)(args.Activity));

XmlDocument xdoc = activity.OutputEnvelope
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 4 Send the report to the XmlDocument

Add a call to args.Activity.Report, pass in a short description, and the 
inner text of the XML document that represents the envelope.

 args.Activity.Report("Envelope Inner Text",xdoc.InnerText);



Chapter A • Coding Service Test Events

274

Reference

Context methods

This section describes some of the common Context methods. 

For a complete list of the functions, use the autocompletion feature:

UI Elements Description

Denotes a function.

Denotes a string.

Denotes an event.

EncryptionMngr Allows you to encrypt and decrypt password strings.

TestInputParameters Allows you to retrieve the test’s input parameters.

TestIteration Provides information about the test iteration.

TestOutputParameters Allows you to retrieve the test’s output parameters.

TestProfile Allows you to set and retrieve user variables. For 
details on how to define user variables, see "How to 
Define Test Properties or User/System Variables" on 
page 16.
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Logging Options

The Service Test API provides the following logging options, available from 
the Context.UserLogger object: 

The Format option allows you to provide values based on the list of items. 
The following example logs formatted informational messages, using the 
FirstName variable’s value for the first item, and the LastName variable for 
the second item, and so forth.

For task details, see "How to Use the Logging Function" on page 266.

UI Elements Description

Debug, DebugFormat Logs debug information collected during the test run.

Error, ErrorFormat Logs errors that occurred during the test run.

Fatal, FatalFormat Logs fatal errors that occurred during the test run.

Info, InfoFormat Logs informational data from the test run.

Warn, WarnFormat Logs warnings that were issued during the test run.

activity.Context.UserLogger.InfoFormat("Hello: {0}{1}", FirstName, LastName);
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Assert Options

The Assert object provides the following comparison operators:

For task details, see "How to Write Checkpoint Events" on page 268.

UI Elements 

Equals 

Greater

GreaterOrEqual

Less

LessOrEqual

NotEquals
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version control 203

API 261
Assert function 268
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adding 44
view in Property Sheet 81
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WSDL import 134
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binary encoding 109
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UserLogger 266
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Data Navigation dialog box 164
Data Queries view 82
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documentation, online 11
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Java testing 32
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security settings, advanced 137
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