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1 Getting Started with HP Deployment
Management

Introduction to HP Deployment Management

HP Deployment Management is an HP Project and Portfolio Management
Center (PPM Center) product that automates the migration and deployment of
software code, configurations, and content. HP Deployment Management
groups these objects into packages and routes the packages along business
processes modeled in HP’s configurable workflow. The workflow
automatically moves each package through required steps, which typically
include system build, testing, quality assurance, staging, and final deployment.

HP Deployment Management automatically deploys the application
components (such as XML content, HTML files, Java™ programs, and
Oracle® application configurations) that each package requires. For example,
HP Deployment Management connects to the development environment,
copies Java files from the version control repository, and transfers the files to
the quality assurance environment. It then uses the Java compiler to compile
and pack all of the files into a single Java program. The customer can use a
built-in scheduler to schedule deployments. HP Deployment Management
maintains an audit trail for all activities, including package information,
application components altered, approvals obtained, and deployments
performed.



Overview of an HP Deployment Management Process
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HP Deployment Management is an enterprise application designed to deploy
and audit software changes to mission-critical applications. It does this by
gathering all information required for a successful deployment (for example,
information on environments and objects to be migrated) into a single logical
unit called a package.

The package is the fundamental work unit in HP Deployment Management. A
package consists of the objects that are processed through a business
workflow. This results in a successful, easy-to-track software change.

Figure 1-1. HP Deployment Management overview
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A package consists of a group of objects, each of which belongs to an object
type. Each object type is associated with a set of parameters that defines the
information the package requires, and any additional information it can accept.

For a more complete overview of packages, see Chapter 2, Understanding
Packages, on page 23.
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For example, the File Migration object is a standard object type that copies
files (objects) from one environment to another.

Figure 1-2. A package

/Puckage N
Package Line Package Line
Object Type Object Type
Object Name Object Name
Object Location Object Location
Special Commands Special Commands
AN J

Although each package line can be acted upon separately, the group of package
lines and objects represent a logical unit that is moved and tracked as a unit.
The way a package is processed depends on the specific workflow applied to it.
Figure 1-3 shows a sample package in the Package window of the Package
Workbench.

Figure 1-3. Sample package in the Package window
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A workflow represents the business process associated with the package.
Workflows consist of a logical series of steps that define the path that the
objects in a package follow. Some of those workflow steps might represent
decision-making processes; for example, code reviews and management
approvals. Usually, at least one workflow step represents, or actually performs,
the migration of the objects from one environment to another environment.

In Figure 1-4, the workflow step Migrate to Test represents the migration of
package objects from one environment to another. The workflow steps Design
Review and Evaluate represent business package-related decisions.

Figure 1-4. Package workflow
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HP Deployment Management Terms and Concepts

Standard Interface, PPM Workbench, and HP Deployment Management

HP Deployment Management provides two different interfaces for working
with packages. In the standard interface, HP Deployment Management
provides the package detail page. In the PPM Workbench, HP Deployment
Management provides the Package Workbench. Although these two interfaces
have common functionality, a package detail page does not have all of the
functionality of the Package Workbench.

The key difference between the Package Workbench and the detail page for a
package is that you can use the Package Workbench to add package lines and
submit a package. You cannot add package lines and submit a package from a
detail page.

The Package Workbench is designed to allow engineers or developers to create
and submit packages. Creating and submitting packages requires specialized
knowledge. In some cases, it requires passwords to production servers. Some
of this information is not available to the resources making decisions about a
package. Additionally, not everyone who makes decisions about a package
requires access to the PPM Workbench.

) For instructions on how to create and submit packages to deploy software and
application changes, see Chapter 3, Creating Packages, on page 47.

From a package detail page, and with the required permissions, you can
process a package through its workflow. You can add notes and references to
the package and make decisions about package status. However, you cannot
change or delete a package from the detail page.

For information about the licenses and access grants required to work with packages

in HP Deployment Management, see the Security Model Guide and Reference. For
) information on how to move packages through their associated workflows, see

Chapter 4, Processing Packages, on page 87. For instructions on how to work with

(copy, cancel, merge, and so on) packages, see Chapter 5, Managing Packages,

on page 121.

Getting Started with HP Deployment Management 13
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Packages and Obiject Types

Packages are the fundamental work units of HP Deployment Management. A
package consists of the objects that are processed through a business
workflow.

While each package line can be acted upon separately, the group of package
lines and objects represent a logical unit that should be moved and tracked
together. The processing of a package and package lines can vary greatly
depending upon the workflow specified for that package. Figure 1-5 shows a
sample package in the Package window.

Figure 1-5. Sample package in the Package window
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Each object belongs to an object type. An object type can also have associated
commands that determine its behavior as it moves from one environment to
another. Commands are used to define what a migration means for each type of
object. For example, a File Object Type might only require that a file be
copied, while a Database Script Object Type might require the copying of a file
and executing it against the destination database.

Object types are user-configurable. HP Deployment Management and its
extensions also provide libraries of predefined object types, falling under one
of the following categories:
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e Standard Objects. Standard objects are predefined object types that are
shipped with HP Deployment Management or one of the HP Deployment
Management Extensions. These object types encapsulate the basic
functionality that manages crucial actions; for example, migrating and
executing file system-level objects and operating system commands, or
applying patches to an Oracle applications instance. A standard object type
is the File Migration object, which copies a file from one environment to
another. A more complex standard object type is the SQL Script, which not
only copies the file but also executes the script against the destination
database.

e Custom Objects. Customers must often customize standard object types,
or produce entirely new object types, in order to handle the requirements of
their software environments and deployment management processes. A
custom objects category is provided to help distinguish these customized
object types from those that come with HP Deployment Management or its
extensions. Such object types, designed by the customer or by consultants,
are often used for integration with third-party tools or in-house products.

e PPM Center Migrator Objects. PPM Center migrator objects are object
types that contain functionality to export and import configuration
information. You can use these for several purposes, including:

o To transfer configuration information between distinct PPM Center
instances

o To extract information from a PPM Center database schema into an
XML file

o To load information from an XML file into a database schema

This means that you can migrate configuration information using standard
deployment management test practices, processing a package through a
workflow.

Getting Started with HP Deployment Management 15



Workflows and Workflow Steps

A workflow consists of a logical series of steps that define the path to be
followed by objects in a package. Workflow configuration and routing can be
customized, and the workflow engine can handle virtually any business
practice. This allows a department to generate workflows to automate existing
processes, rather than forcing users to adopt a new set of processes to perform
their work.

Workflow steps can range in usage from functional approvals to actual
migrations. For example, migration steps automatically move specified objects
from source environments to destination environments.

Workflow steps are events that are linked together to form a complete
workflow. HP Deployment Management uses the following four types of
workflow steps:

e Decision workflow steps. In decision workflow steps, you or group of
users must indicate a result or outcome; for example, work is approved or a
review is completed.

e Execution workflow steps. In execution workflow steps, the system
performs an action, and then updates the step with its result. The action can
be as simple as calculating the value for a token, or as complex as copying
files, running programs, or updating Web pages.

e Condition workflow steps. Condition workflow steps are logic steps used
for complex workflow processing; for example, allowing a workflow to
proceed only after all prerequisite steps are completed.

e Subworkflow workflow steps. Subworkflow workflow steps are entire
workflows that have been enabled for use as subworkflows. Subworkflows
are useful time savers in modeling business processes that include
predefined procedures.

Chapter 1



Figure 1-6 shows a sample package workflow.

Figure 1-6. Package workflow
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Releases

In HP Deployment Management, you can configure releases to group packages
and related requests that must be deployed together. For example, the software
company XYZ Corporation has a product update release scheduled for five
months from now. To ensure successful product delivery, they decide to use
HP Deployment Management to create a release that lets them track all
changes to their original code.

As developers complete their packages, the packages are included in the
release and processed together. Because every required change is grouped in
the release, the company can quickly and easily assess the product status and
progress toward delivery.

For detailed information about releases, and how to create and configure them,
see the HP Deployment Management Configuration Guide.

Getting Started with HP Deployment Management 17



HP Deployment Management Environments

An HP Deployment Management environment is composed of a unique
combination of server, client, database, and file system data that represent one
logical group.

Figure 1-7. HP Deployment Management environment
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The environment server represents the main host machine for the environment.
This machine may be of any platform type; for example, UNIX® or
Windows®. Typically, the server is a UNIX machine that also hosts the
database for this environment.

0

The environment client represents a remote client machine that also serves to
identify the specified environment. The client is typically defined if users are
doing multiplatform development in a client/server environment, with some
development done on UNIX, and some on Windows Server. The client can be
a file server that stores client code accessed by users. Many programs, such as
transactional forms, have both client and server components; for example, the
user interface code and the database objects, respectively. Figure 1-8

on page 19 shows an example of information displayed in the Environment
window.
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Figure 1-8. Sample environment
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Integrating HP Deployment Management

Integration with Version Control

HP Deployment Management provides complete integration with all standard
version control systems, including RCS, SCCS, PVCS, ClearCase, CCC/
Harvest, and Visual SourceSafe. The HP Deployment Management outbound
API provides all check-in, check-out, and promotion functions during
deployment.

File system objects can be deployed to new installations and updated in version
control simultaneously. This synchronizes your version control repository,
physical installations, and HP Deployment Management workflows.

Getting Started with HP Deployment Management 19



Integration with HP Demand Management

HP Deployment Management manages the physical deployment of changes to
your application environment, but equally important, it also gathers and
analyzes issues (requests) related to system stability. To facilitate this request
gathering, HP Deployment Management is integrated with HP Demand
Management.

Like HP Deployment Management, HP Demand Management is a
workflow-based system that features complete audit trail tracking of requests
from submission to closure. The tight integration between HP Demand
Management and HP Deployment Management allows packages to be
automatically generated from requests.

The requests are then automatically updated upon package completion. This
closed-loop integration ensures a coherent and consistent view of issue status
and removes the need for redundant data across multiple applications.

Integration with Third-Party Applications through HP Deployment Management Extensions

HP Deployment Management Extensions are application-specific modules that
automate the deployment and post-deployment steps of objects, files, and
patches. Extensions are fully integrated with HP Deployment Management to
provide a total solution for managing various enterprise applications. The
following extensions are available:

e HP Deployment Management Extension for Oracle E-Business Suite
e HP Deployment Management Extension for Oracle Technology

e HP Deployment Management Extension for SAP Solutions

Chapter 1



Related Documents

You can find related information in the following documents:

HP Deployment Management Configuration Guide
Commands, Tokens, and Validations Guide and Reference
Reports Guide and Reference

Security Model Guide and Reference

HP-Supplied Entities Guide

Getting Started with HP Deployment Management
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2 Understanding Packages

About Packages

HP Deployment Management automates the migration and deployment of
software code, configurations, and content. These objects are grouped into
packages and are routed along business processes (workflows) using the PPM
Workbench and the standard interface. Workflows automate the movement of
each package through their required steps.

For example, you want to copy an operating system patch from the
development environment, Dev, to the test environment, Test. After the
operating system patch is thoroughly tested, you can copy the patch to
production environment, Prod.

23
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Figure 2-1. Package processing in HP Deployment Management
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A package is the fundamental work unit of HP Deployment Management. Each
package follows a workflow (business process). As with any business process,
decisions are made and actions taken that affect the package. Each decision or
action becomes a workflow step.

If a decision on a package is required, you must manually update a workflow
step to reflect that decision. However, you can configure some actions (for
example, migrating a file from one environment to another) to occur
automatically. The basic components required to configure a workflow step to
automatically migrate a file from one environment to another environment are
as follows:

e A package, which defines the file name, location, and type, and the
workflow to apply.

e A workflow, which determines the conditions that trigger file migration
(workflow step), and the source and destination environments for the file
migration.

Chapter 2



When you create a package, you assign it a single workflow that defines the
steps the package must take. Figure 2-2 shows a sample workflow, with the
following steps:

e Approve Package

e Dev to Test (migration)
e Test Package

e Test to Prod (migration)
e Exit

Figure 2-2. Package workflow and workflow steps
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You must perform the Approve Package and Test Package workflow steps
manually during the course of the workflow. You configure the Dev to Test
and Test to Prod workflow steps to execute automatically.

To assign a workflow to a package, you do not need to know how to configure a
) workflow step, or even a workflow. However, you do need to know how to access the
information in a workflow, workflow step, and environment.

In Figure 2-3 on page 26, the package displayed in the Package Workbench is
associated with a workflow in the Workflow Workbench. The migration
workflow steps are configured with source and destination environments. You
access and configure environments using the Environment Workbench.

The package in Figure 2-3 on page 26 is configured with a single package line,
and then configured with an object type. A package line can contain only one
object type. The object type contains the information required to migrate a file
(an object), including the file name, location, and type (ASCII or binary).
Depending on the object type definition, additional information may be
required.

Understanding Packages 25



Figure 2-3. How a package comes together

. Workflow Workbench N

4 Workflow h /Environmenf Workbench\'

(" Workflow Step Definition N Environment
(Source)

Environment Name
(Source)

Server
Client
Database

Environment Name

(Destination) [ m—
(Destination)
. Server
\\ Client
A Database
. Package Workbench A
4 Pacllage
( Workflow Name )
é Package Line N Object Type Workbench A
Object Type Obiject Type Definition
Filename
File Location Command Sequence
File Type (Special Commands)
S/
Special Jommand ™
Worlggench
Special Command
Definition
ksc ...
fip.....
telnet .....
. /

Object types are defined in the Object Type Workbench. In the Object Type
Workbench, you can open and access the command sequence used to migrate
the object across environments. These command sequences include special
commands defined in the Special Command Workbench.
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To create a package, you must know the following:
e Workflow. Defined in the Workflow Workbench.

e Environments. Specified in the workflow step and defined in the
Environment Workbench.

e Object type. Defined in the Object Type Workbench.

For information about the licenses and access grants required to work with
packages in HP Deployment Management, see the Security Model Guide and
Reference.

Packages in the Standard Inferface

You can use the package detail page in the standard interface to view
information for a package, add notes and references to the package, and
process the package through its workflow. When you add a new package as a
reference to a request, you do not access the Package window in the PPM
Workbench. Instead, you access a New Package page in the standard interface.

Creating a new package using the New Package page does not create a
complete package that you can submit. Instead, the New Package page opens
and saves a package in the standard interface. Before you can submit the
package, you must use the Package window in the PPM Workbench to add
package lines to it. Figure 2-4 on page 28 shows the detail page for a package
that was created from the standard interface as a reference to a request, and
contains no lines yet.
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Figure 2-4. Package detail page
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Package Detail Page, Header Section

On the detail page for a package, the Header section displays general

information such as who created the package, the date it was created, and its

associated workflow. Figure 2-5 shows a typical Header section.

Figure 2-5. Package detail page, Header section

Header
*Package Ho.: 30007 Package Group: Customization E| Created By: Admin User
Description: Patch v3 migration test Created On September 28, 2008
Workflow: DEY = TEST = PROD Status: In Progress
Assigned User: Caralyn Sayer B Priority: Marmal Parent:
Assigned Group: ITG Deploymert Managem (2] Package Type: Customization % Priority Seq: 20
Percent Complete: i

Package Detail Page, Status Section

The Status section on a Package detail page displays the current package
status. After a package is first created in the standard interface, the Status
section does not exist. After the package is submitted, the Status section
displays the package lines and all of the steps in the associated workflow.
Figure 2-6 shows the Status section on a package detail page.

Figure 2-6. Package detail page, Status section

Status
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Package Detail Page, Notes Section

The Notes section on a package detail page contains fields that you can use to
provide package information that you want to store. The Notes section is
included in the package creation process and continues with package until it is
closed.

Figure 2-7 shows a typical Notes section. All Notes sections include the Add
Notes subsection. The Existing Notes section is created after the first note is
created for the request.

Figure 2-7. Package detail page, Notes section

Notes

Add Notes

Hotes to be added on save:

Existing Notes

iin User (ad

Admi min| Escalate 1o P1 after April 5, 2007,
March 6, 2007 08:52:07 AMPST

Package Detail Page, References Section

A package’s detail page References section contains additional information
about the package. For example, you might add a URL to a package or delete
an outdated document from a package. The References section is included in
the package creation process and continues with the package until the package
is closed. References can be added or deleted from the package.

Use the Reference Additions section to add a reference to the package. Saved
references are organized by reference type; for example, all saved reference
packages are saved in the Packages section. For some references, a functional
dependency between the package the referenced entity can be created. For
more information about references and their functional dependencies, see
Reference Relationships on page 41.
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Figure 2-8 shows the References section on the Package detail page.

Figure 2-8. Package detail page, References section

References

Reference Additions

Hew Reference: | Attachment A Add

References to be added on Save:

Open Remove

Packages in the PPM Workbench

You can use the Package Workbench to view existing packages. From a
Package window, you can add notes and references to the package, and process
the package through its workflow. From the Package window, you can create
and submit a package, process it through its workflow, cancel it, or delete it.

Figure 2-9 shows the detail page for a package.

Figure 2-9. Package window

() Package: 30007

rPackage Infortnation

Fackage Mo M:l Package Group: ICustDmizatinn Created By |Admin User |
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Ready
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Package Window, Package Information Section

The Package Information section of the Package window displays general
information about the package; for example, who created the package, the date,
and the associated workflow. The Package Information section is included in
the package creation process and stays with the package. Typically, when
creating a package, you must complete some fields in this section. Figure 2-10
shows a typical general information section. The information in a package’s
detail page Header section is found in the Package window’s general
information section.

Figure 2-10. Package window, Package Information section
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Package Window, Package Lines Tab

The Package Lines tab lists the package lines associated with a package.
Package lines define the object migrating from one environment to another
environment. Each package line defines one object (file). Typically, objects
(files) are defined by their object type (for example, File Client > Client or File
Migration), filename, location, and file type. You cannot define multiple
objects on a single package line. Figure 2-11 shows the Package Line tab with
package lines displayed.

Figure 2-11. Package window, Package Lines tab
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Package Window, Status Tab

The Status tab in the Package window displays the current package status.
When a package is first created, the Status tab displays the package lines. After
the package is saved or submitted, the Status tab displays the package lines and
all of the workflow steps in the associated workflow.

Use the Status tab to view:

e All the possible actions that can be performed on the package
e All the actions performed to date

e Pending actions that must be performed to resolve the package

After a package is submitted, you can use the Status tab to process it through
the workflow. Each package line includes all of the steps in the workflow. If a
workflow step is eligible for action, the Initial Approval field for that step
displays the value Eligible (Figure 2-12).

Figure 2-12. Package window, Status tab
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After a package is submitted, you can expand a package line to display any of
the subworkflow steps defined in the workflow. To view the subworkflow
steps, above the subworkflow step, click Expand.

To expand all subworkflows on the Status tab, click Expand All. To hide
expanded subworkflow steps, above the subworkflow step, click Collapse. To
hide all subworkflow steps, click Collapse All. Clicking Expand expands the
package line horizontally to display all of the steps within the subworkflow.

The header text for subworkflow steps is displayed in a different color than the
header for workflow steps. The step numbering includes additional decimal
places to indicate the level of the workflow. For example, if step 3 of a
top-level workflow is a subworkflow, its steps are numbered as 3.1, 3.2, 3.3,
and so on. Similarly, if the second step in that subworkflow is also a
subworkflow step, its steps are numbered as 3.2.1, 3.2.2, 3.2.3, and so on.

From the Status tab, you can access several log files, a graphical view of the
workflow, transaction histories, and detail files related to the package. Use
these files, views, and histories to help you as you process your package.

Accessing the Line Execution Log

You can select a package line and get the details of the execution of that
particular line by viewing the line execution log. The line viewed is a subset of
the overall execution batch log.

If the package line has been configured to migrate to multiple environments
using an environment group, the execution log returns an execution summary
and link for each destination environment. To view the detailed execution log
for an environment, click the associated link.
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Accessing the Package Execution History

The Package Execution History displays the execution history of each package
line. It displays the workflow step name, execution date, and outcome
(Succeeded or Failed) of each execution step.

If the package line has been configured to migrate to multiple environments
using an environment group, the execution log returns an execution summary
and link for each destination environment. Click the link to get the detailed
execution logs for each environment.

Graphical View

To view the workflow, select the Graphical View window (Figure 2-13
on page 37). Use the legend at the top of the window to determine which
workflow steps have been visited and which steps are active. This image
displays all of the workflow steps and subworkflows used in the workflow
definition.

To obtain a graphical view of a particular subworkflow, select the
subworkflow name from the Show Subworkflow Step list at the bottom of the
window. This opens a new window that displays the graphical view of that
subworkflow.
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Figure 2-13. Graphical View window for a package
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Viewing Line Permissions

Workflow permissions are established during the initial workflow
configuration. The Line Permissions view lists all users in security groups that
have been enabled for the related workflow step. If you have questions
regarding the permissions set for a particular workflow step, see your
application administrator.
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Viewing Line Transaction History

You can view the transaction history of each package line. This provides
detailed information on how the package line has proceeded through an HP
Deployment Management workflow. Information; for example, as the date of
the transaction event, the user linked to the workflow step, the workflow step
name and number, status, and results are displayed.

To display information on the subworkflow steps that have been traversed
more than once by a single package line, select Full transaction history.

Selecting Current transaction status displays only information on the most
recent transaction up through that step.

Viewing the Decision Detail

The Decision Detail displays the decision history of each workflow step. It
displays the date, resource, and decision of the decision workflow step.

Viewing the Workflow Step Information URL

Workflow steps can be configured to include a URL that provides information
regarding the workflow step. If you administrator has linked an informational
URL to a workflow step, you can view the URL in the Workflow Step
Information URL window.
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Package Window, Notes Tab

The Notes tab in the Package window (Figure 2-14) contains fields where
notes on and information about the package can be entered and stored. The
Notes section is included in the package creation process and continues with
the package until it is closed. Typically, when creating a package, you do not
need to add a note to the package.

Figure 2-14. Package window, Notes tab
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Package Window, References Tab

A package window’s References tab (Figure 2-15) displays additional
information about the package. For example, you might add a URL to a
package or delete an outdated document from a package. The References tab is
included in the package creation process and continues with the package until
the package is closed. You can add references to or delete them from the
package.

Use the Reference Addition section to add a reference to the package. Saved
references are organized by reference type; for example, all saved reference
packages are saved in the Packages section. For some references, a functional
dependency between the package and the referenced entity can be created. For
more information about references and their functional dependencies, see
Reference Relationships.

Figure 2-15. Package window, References tab
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Reference Relationships

For some references, you can create a functional dependency between the
package and the referenced entity. For example, you can specify that a request
is a predecessor to the package. This means the package cannot continue until
the request is closed.

e Predecessor Relationships. Predecessor relationships dictate that action is
not allowed on one entity until the referenced entity closes. For example, a
package cannot complete any workflow action until the referenced task is
closed (Completed, Bypassed, or Cancelled). The package status is
Pending Task. After the task closes, the package can be acted upon after
more. This does not stop other request fields from being edited.

e Successor Relationships. Successor relationships dictate that action is not
allowed on the referenced entity until the entity closes. For example, a
referenced task cannot change status until the original package is closed.
The task status is Pending Request. When the package closes, the task can
again be changed. This does not prevent other task fields from being
edited.

Table 2-1 on page 42 lists the references, their definitions, and possible
dependency relationships.
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Table 2-1. References and relationships (page 1 of 4)

Reference Possible Relationship
Reference Description Relationships | Description
Qt::(r:\?nae il(l)et:]rg?u?rleon(ial Standard (Informational) The
Attachment ackage. The attached file attachment attachment is related
ips cop% d. to the server interaction to this package.
(Informational) The
Duplicate referenced package
package is a duplicate of the
package.
Run before this (Informational) In a
. release, the selected
package in a
release package must be run
before this package.
Run after this (Informational) In a
ackage in a release, the selected
Packages Reference an existing Eelease package must be run
(Existing) package. after this package.
(Blocking) Action is
not allowed on the
Predecessor package until the
referenced package
closes.
(Blocking) Action is
not allowed on the
Successor referenced package

until the package
closes.
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Table 2-1. References and relationships (page 2 of 4)

Reference

Reference
Description

Possible
Relationships

Relationship
Description

Packages
(New)

New packages can also be
created from a package.

If configured as part of the
workflow, you can spawn a
package from a workflow
step. When this happens, a
reference to that package
is automatically generated,
establishing a two-way link
between the packages.

Run before this
package in a
release

(Informational) In a

release, the selected
package must be run
before this package.

Run after this
package in a
release

(Informational) In a
release, the selected
package must be run
after this package.

Predecessor

(Blocking) Action is
not allowed on the
package until the
referenced package
closes.

Successor

(Blocking) Action is
not allowed on the
referenced package
until the package
closes.

Programs

Reference a program in HP
Program Management.

Related to This
program

(Informational)
Selected program is
related to this
package.

Projects

Reference a project in HP
Project Management.

Related to This
package

(Informational)
Selected project is
related to this
package.

Releases

Reference a release in HP
Deployment Management.

Contains this
package

(Informational) The
package is contained
in the selected
release.
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Table 2-1. References and relationships (page 3 of 4)

Reference

Reference
Description

Possible
Relationships

Relationship
Description

Request
(Existing)

Reference an existing
request.

Parent of this
package

(Informational) The
referenced request is
the parent of the
package.

Related to this
package

(Informational)
Referenced request
is related to this
package.

Predecessor

(Blocking) Action not
allowed on this
package until the
referenced request
closes.

Successor

(Blocking) Action not
allowed on the
referenced request
until this package
closes.
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Table 2-1. References and relationships (page 4 of 4)

Reference

Reference
Description

Possible
Relationships

Relationship
Description

Requests
(New)

New packages can be
created from existing
packages.

Also, if configured as part
of the workflow, you can
spawn a package from a
package. When this
happens, a reference to
that package is
automatically generated,
establishing a two-way link
between the packages.

Parent of this
package

(Informational) The
referenced request is
the parent of the
package.

Related to this
package

(Informational)
Referenced request
is related to this
package.

Predecessor

(Blocking) Action not
allowed on this
package until the
referenced request
closes.

Successor

(Blocking) Action not
allowed on the
referenced request
until this package
closes.

Tasks

Reference a task in HP
Project Management.

Related to this
package

(Informational) The
referenced task is
related to this
package.

URL

Reference a Web address.
Documents at the URL
must be in MIME format.

Standard URL
interaction

(Informational) The
URL is related to this
package.
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Predecessor Relationships

Predecessor relationships dictate that action cannot be performed on one entity
until the referenced entity closes. For example, a package cannot complete any
workflow action until the referenced task is closed (Completed, Bypassed, or
Cancelled). The package status is Pending Task. After the referenced task
closes, the package can be acted on again. This does not prevent the editing of
other request fields.

Successor Relationships

Successor relationships dictate that action is not allowed on a referenced entity
until the entity closes. For example, a referenced task cannot change its status
until the original package is closed. The task status is Pending Request. After
the package closes, the task can be acted on. This does not stop other task
fields from being edited.
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3 Creating Packages

Overview of Creating Packages

This chapter provides instructions on how to create and submit packages to
deploy software and application changes. Although you typically use the PPM
Workbench to create packages, you can also create them by copying an
existing package, or create them as referenced entities.

After you create a package, you must submit it to start the workflow (business
process). For information on how to submit a package, see Submitting
Packages on page 86.

Before You Create Packages

Before you create a package, make sure you understand the following:
e Workflow. Defined in the Workflow Workbench.

e Environments. Specified in the workflow step and defined in the
Environment Workbench.

e Object type. Defined in the Object Type Workbench.
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Selecting Workflows

Each package is processed through a predefined workflow. You must select a
workflow to apply to each package you create. It is important that you route
your packages through workflows that accurately model the appropriate
business process.

To view the graphical layout of an HP Deployment Management workflow:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Configuration > Workflows.
The Workflow Workbench window opens.
4. To display all of the workflows, in the Workflow Workbench, click List.

) To restrict your search, you would specify one or more of the query parameters.

The Results tab lists all workflow records.
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Creating Packages

5. Select a workflow for which the Workflow Scope column displays
Packages, and then click Open.

The Workflow <Workflow Name> window opens to the Layout tab, which
displays a graphical representation of the workflow steps.

workflow : DEY = TEST > PROD

Package Workflows l Request Types I Cwnership 1 I

Workflow Layout Step Sequence I Deployment Management Settings

S Renark Reauret
|

—— dppraved — -

Faed

Ready foe Higratior — g %

£ Design Review 2. Evatae 3. Migrate 2 Test

L

Succeaded

| Ll

l B
4

—— - %  Sucreded—— !7|

o g Tes 5. Migrate 12 Srad 6. Clase [Sumcess) - L00%

Faied Tast Faied

Scale: ‘100% 'H Exportimage |

| Verify ‘ |§| | Cancel |
\Ready

Check to ensure that the workflow follows the correct business process for
your package. If it does not, open a different workflow.

6. Double-click a migration workflow step. For example, Migrate to Test or
Migrate to Prod.

The Workflow Step window for that step opens to the Properties tab.

49



50

7. Verify that the source and destination environments listed on the tab are
correct.

Properties' Security| Seareoation of Duties | Motifications | Timeout| User Data | Results |

Step Mumber: | 3

Step Narme: | Migrate to Test

Action Surmmary: |

Description: |

Source Type: | Execution
Source Narme: | Gopy(1) (R DLY Execution (Manual)

Enahled:

Dispiay: |Alrays ~|

Wwiorkflowy Parameter: |NONE V|
@ Source Environmert: I
O Source Environmert Grougp: I
@ Dest Environtnent: I
O Dest Environtment Graup: I

Avy Lead Time: | |

Project Status: I

Current % Complste: | |

Patrert Assighed To Uset: I EE

Parent Assighed To Groug: I
‘Wiorkflowe Step nformstion | |

Authentication Reguired |Nune 8 |

I Ok ] [ Cancel ]

|Ready

8. To view additional information in the Workflow Step window, click the
following tabs:

e Security. Use to define the security groups allowed to act on the
selected step. All enabled security groups are displayed in either the
Available Security Groups ficld or the Linked Security Groups field.
Each user who belongs to a linked security group can perform the
actions defined for that particular workflow step.

e Segregation of Duties. Use to specify workflow steps to be segregated
from the selected step in the workflow. This segregation prevents a
given user from acting on both steps in the workflow. For example, you
might use it to prevent the person who requests a change from then
deploying that change to the production system without approval from
a third party.

Chapter 3



9.

You can also use this tab to specify that the package creator cannot act
on the selected workflow step.

e Notifications. Use to attach email notifications to the workflow step.
Email messages can be sent whenever a particular event (for example,
the step completes with a specific result) occurs at the step.

e Timeout. This tab displays timeout intervals set for this workflow step.
e User Data. This tab displays any custom fields for each workflow step.

e Results. This tab lists all of the possible valid results for the step.

Close the Workflow Step window.

Veritying Environments

Creating Packages

Some workflow steps include specify source and destination environments. If
you are not sure the specified environments are correct, you can open them in
the Environment Workbench.

To access an environment:

1.
2.

Log on to PPM Center.

From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.

From the shortcut bar, select Environments > Environments.

The Environment Workbench opens.

To display all of the environments, click List.
To restrict the search, specify one or more query parameters.

The Results tab lists the environment records.

Select one or more of the listed environments, and then click Open.
The Environment <Environment Name> window opens.

Check the settings for the server, client, and database.

Close the Environment window.
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Veritying Object Types

When creating a package, the available object types are displayed in an
auto-complete list. To view the available object types before you start to create
a package, you can open an object type in the Object Type Workbench.

Table 3-1 lists the HP-supplied object types.

The HP Deployment Management Extensions provide additional object types.

Table 3-1. Object types (page 1 of 2)

Object Type

Description

File Client>Client

File copy from client to client.

File Migration

File copy from environment to environment.

PPM Data Source Migrator

Migrates a PPM Center data source migrator.

PPM Module Migrator

Migrates a PPM Center module from one PPM Center
environment to another PPM Center environment.

PPM Object Type Migrator

Migrates a PPM Center object type from one PPM
Center environment to another PPM Center
environment.

PPM Overview Page
Section Migrator

Migrates a PPM Center overview page section from
one PPM Center environment to another PPM Center
environment.

PPM Portlet Definition
Migrator

Migrates a PPM Center portlet definition from one
PPM Center environment to another PPM Center
environment.

PPM Project Template
Migrator

Migrates a PPM Center project template from one
PPM Center environment to another PPM Center
environment.

PPM Report Type Migrator

Migrates a PPM Center report type from one PPM
Center environment to another PPM Center
environment.

PPM Request Header Type
Migrator

Migrates a PPM Center request header type from one
PPM Center environment to another PPM Center
environment.
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Table 3-1. Object types (page 2 of 2)

Obiject Type

Description

PPM Request Type
Migrator

Migrates a PPM Center request type from one PPM
Center environment to another PPM Center
environment.

PPM Special Command
Migrator

Migrates a PPM Center special command from one
PPM Center environment to another PPM Center
environment.

PPM User Data Context
Migrator

Migrates a PPM Center user data context from one
PPM Center environment to another PPM Center
environment.

PPM Validation Migrator

Migrates a PPM Center validation from one PPM
Center environment to another PPM Center
environment.

PPM Workflow Migrator

Migrates a PPM Center workflow from one PPM
Center environment to another PPM Center
environment.

0S/390 JCL Migration

Migrates an OS/390 JCL from a source environment
to the destination environment.

PVCS File Migration

Migrates an object from the PVCS archive to the
destination environment.

RCS File Migration

This object manages the check out and distribution of
code in RCS.

RCS Server File

Old file will be checked in on the destination
environment. New file will be checked in and checked
out Read-Only on the destination environment.

SourceSafe File Migration

Manages the check out and promotion of files from the
SourceSafe version control archive.

Creating Packages
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Opening an

Object Type

To open an object type:

1

2.

. Log on to PPM Center.

The PPM Workbench opens.

From the shortcut bar, select Deployment Mgmt > Object Types.
The Object Type Workbench window opens to the Query tab.

. To display all object types, click List.

To restrict the search, specify one or more query parameters.

The Object Type <Object Type Name> window opens.
Click the Commands tab.
Check the commands that the object type calls.

Close the Object Type <Object Type Name> window.

Select one or more of the listed object types, and then click Open.

From the menu bar, select Open > Administration > Open Workbench.
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Creating Packages

Although you typically use the PPM Workbench to create packages, you can
also create one by copying an existing package, or by creating a new package
as a referenced entity. This section provides information about how to use all
three methods.

Creating Packages Using the PPM Workbench

Creating Packages

Packages are used to deploy software and application changes. This section
covers how to define the contents of a package, including adding package lines
and specifying the appropriate deployment workflow. For each instance of a
software migration submission, a new package needs to be created.

To create a package from the PPM Workbench:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

55



4. Click New Package.

The Package window opens.

(p Package: 30007

rPackage Information
Packagerio: BN | Package Group: [Customization El Created By: | Admin Lser |
Deseription: |Patch v3 migration test | Crested On: [September 28, 2006
Workflow: [DEV = TEST = FROD Package Status: |In Progress |
Azsigned User: ICarnIyn Sayer &0 Priority: |Mormal v Parent: | |
Assigned Group: Iagemem Administrator Package Type: |Customization b Priotity Secy |50 |
Package Lines I Status I |51 Motes | ]| Reierencesl User Data I
Seqg Chject Type App Code 1 2 ]
1 RCS Server File (Mone) File Mame: TestFile RCE Dir: R
2 File Client-=Client (HWone) Client File Mame: Mercury Help. bt Suh Path FiI||
3 PWCE File Migration (Money File Location: Client Sub Path Fil
£ ¥
+e
Feady

5. In the Package Information section, complete the fields.

For information on how to complete the fields in section, see Entering
General Information for Packages on page 63.

6. On the Package Lines tab, add the package lines to the package.

Package lines capture information specifically related to each object that
you are migrating from one environment to another environment. For
information on how to add package lines, see Adding Lines to Packages
on page 64.

7. On the Notes tab, add any notes to the package.

For information on how to add notes, see Adding Notes to Packages
on page 68.
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8. On the References tab, you can add references to the package.

For information on how to add references, see Adding References to
Packages from the Package Workbench on page 69.

9. To save the package and close the Package window, click OK. To save the
package and leave the Package window open, click Save.

Creating Packages by Copying Existing Packages

You can create a package by copying an existing package (either new or
saved). You can specify which sections of the existing package you want to
include in the new package.

To create a package from an existing package:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Deployment Mgmt > Packages.
The Package Workbench opens.
4. On the Query tab, click List.

The Package Workbench Results tab lists all existing packages.
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5. On the Results tab, select a package, and then click Copy.

The Copy Package window opens to the Options tab. 7Table 3-2 lists the
options available on the tab.

0 o
Package Mo Dezcription Wiorkfiow Package Groug Package Status
30029 |Uparade for release 7.00 |DEV = TEST = PROD |Upgrade [Mew
30019 Patch w3 migration test DEV = TEST = PROD Mew

Fesulh Query (B

Copied Peckage Information:

Copy Header Fram: |30007 ~ | Mew Package NG'M

Description: Copy of 30007
‘Winrkflow: |DEY = TEST » PROD

) [

Options | Datails |

Copy Package Lines? ) yes O Mo Copy Header's Notes? () ygg @ No
Cony Closed Lines? ) yes O Na CopyHeader's User Data? (3) yes O Mo
Copy Cancelled Lines? ¢ vgg &) Mo Submit New Package? ) ygg ) No

|Luadmg complete.

6. Select the sections to include in the new package, and then click the Details
tab.

Copied Package Infortation:

Copy Header Fram: 30007 v | mew Package ro: |ERED |

Description: | Copy of 30007 J
Warkflow: |DEY = TEST = PROD

Options Deta\lsl

Package Lines to Copy

Plg Mo | Seg Includecl? Ohiject Type Chjzct Marme Ohject Revision Status App Code

30007 -1 zE RCES Server File |TesiFile Qpen (HWone)

30007 - 2 res File Client=Cli.. [Mercury Help ta Cancelled [(None)

30007 -3 Yes PYCS File Migr... |KeyConcepts. pdf Open (Mone)

[[] show Parameters?

Loading complete.
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The Details tab lists all of the package lines that were copied from the
original package. By default, all of these lines are included in the new
package.

7. To exclude a listed package line from the new package:
a. In the Package Lines to Copy table, select the line.
b. At the bottom of the tab, click Exclude.

The Package window opens and displays the information you selected
from the copied package.

8. To view the parameters that describe a listed package line:
a. In the Package Lines to Copy table, select the line.
b. At the bottom of the tab, select the Show Parameters checkbox.

Additional columns in the Package Lines to Copy table display the
package line parameters.

c. To view all of the parameters, use the horizontal scroll bar.

9. Click OK.
Table 3-2. Copy package options (page 1 of 2)

Option Description

Copy Package Lines Copies all of the package lines (with a status
other than Closed or Cancel) in the existing
package into the new package. The default is
Yes.

Copy Closed Lines Copies all of the closed package lines in the

existing package into the new package. The
default is Yes.

Copy Cancelled Lines Copies all of the cancelled package lines in the
existing package into the new package. The
default is No.
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Table 3-2. Copy package options (page 2 of 2)

Option

Description

Copy Header’s Notes

Copies all of the notes attached to the existing
package to the new package. Defaults to No.

Copy Header’s User
Data

If applicable, copy the user data from the
existing package to the new package.

Submit New Package

After the package is copied, submit the
package. The default is No. If you select No,
your package is not submitted. To submit the
package, you must open the copied package
and click Submit.

Creating Packages as References from Packages

You can create a new package as part of referencing a new package to an entity
such as a request or another package.

To create a new package as a reference to an existing package:

1.
2.

Log on to PPM Center.

From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens to the Query tab.

Use the available fields to provide your search criteria, and then click List.

The Results tab lists the packages that match your search criteria.

Double-click the row for the package you want to open.

The Package window opens.

Click the References tab.
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7. From the New Reference list at the bottom on the tab, select Package (New),
and then click Add.

The New Reference - Package (New) window opens.

(D New Reference - Package (New) 3]

Select the Relationship that the selected Package has to Package 30007

() Relatedto s Package - (nformational) - Selecte Packags s related to Package 30007

O Run after thiz Package in a Release - (Informational) - Selected Package should be run after Package 30007 wwhen both are
O Run before this Package in a Release - (hformational) - Selected Package should be run before Package 30007 when both <
O Predecessor - (Blocking) - Action not alloweed on Package 30007 until selected Package closes

O Suceessor - (Blocked) - Action not allwed on selzcted Package until Package 30007 closes

< *

[Reacty

8. Under Select the Relationship that the selected Package has to Package #
<Package Number>, select the option that describes the relationship that the
new package is to have to the existing package, and then click Create.

A new Package window opens.

For descriptions of the possible relationships between referenced entities,
see Table 2-1 on page 42.

9. Provide all required information, and any optional information you want to
associate with the new package, and then click OK or Save.

10. In the Package window that displays the original package, click OK.
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Creating Packages as References from Requests

You can create a package as a reference from a request. When creating a
package from a request, you do not open the PPM Workbench, even if you
have the correct permissions. Instead, you work in the standard interface using
the Create New Package and New Package pages. When you create a package
as a reference from a request, you cannot add package lines, which means you
cannot complete and submit the package. Adding package lines to a package
and submitting a package requires using the Package Workbench.

To create a package as a reference from a request:

1.
2.

Log on to PPM Center.

From the menu bar, select Open > Demand Management > Search
Requests.

Locate, and then open a request.

You can open an existing request or create a new request from the menu
bar. For information about how to open an existing request or create a
request, see the HP Demand Management User’s Guide.

The detail page for the request opens.
In the request’s detail page, scroll to the References section.
From the New Reference list, select Package (New), and then click Add.

The Create New Package page opens.

Create New Package

‘Relationship:

O Chile! of this Request - (Infarmational) - The selected Package is the child of Request 30221

@ Related to this Reguest - (Informational) - The selected Package is relsted to Request 30221
O Predecesgsar - (Blocking) - Action not allowed on Reguest 30221 urtil selected Package closes
O Successor - (Blocked) - &ction not allowed on selected Package until Regquest 30221 closes

Create Cancel
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. Select the relationship, and then click Create.

The New Package page opens.
Select the workflow from the list.

Type any optional information that you want to keep as part of the record
in the Notes tab, and then click Save.

On the detail page for the request, click Save.

Entering General Information for Packages

Creating Packages

To complete the general information section for packages:

1

2.

Log on to PPM Center.

From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.

From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

. From the Query tab, click New Package.

The Package window opens. You use the Package window to define the
package contents. The package number is assigned automatically.

Complete the required fields.
Select the workflow from the auto-complete list.
In the Package window, click OK or Save.

The package line is added to the package.
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Adding Lines to Packages

Package lines define the object migrating from one environment to another
environment. Each package line defines just one object (often a file).
Typically, objects are defined by their object type (for example, File Client >
Client or File Migration), name, location, and, in the case of files, file type.

To add a line to package:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Deployment Mgmt > Packages.
The Package Workbench opens.
4. Open or create a new package.
The Package window opens.
5. Click New Line.

The Add Line window opens.
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Creating Packages

6. In the Object Type field, select the object type for the object (file) you plan
to migrate using the auto-complete icon.

Selecting an object type dynamically updates the fields in the Add Line

window.

(D Package: 30007

rPackage Informstior

Package Mo:© (30007 Package Group: | Customization Created By: |Admin User
o 28, 2006

us: |In Progress

Sequence

e B | Object Type starts with: [|[CFne ]

Description:
ertlent 11| opjact Type Information
Assigned User: i
ssighed User: LIEERIT (D Validate
Assighed Group:
E I

aramelarsl
Package Lines | stat
Seq Object Typel > Showing 1 - 23 of 23
1 |RCS Senv
2 \an Client Extension Mame  Object Category
3 [PvCS File 8 -~
File Migratian Standard Objects File Copy from Environmen
ITG Data Source Migratar Standard Objects ITG Data Source Migrator
TG Module Migrator Standard Ohjects ITG Module Migrator
ITG Object Type Migrator Standard Objects ITG Object Type Migrator
ITG Overview Page Section. Standard Objects ITG Overview Page Section..
ITG Porilet Definition Migrat. Standard Objects ITG Porilet Definition Migrat.
ITG Report Type Migrator Standard Objects ITG Report Type Migratar
< ITG Reguest Header Type ... Standard Ohjects ITG Request Header Type ...
ITG Reguest Type Migrator Standard Objects ITG Reguest Type Migrator
ITG Special Command Mig. Standard Objects ITG Special Command Mig..
ITG User Data Contex Migr... Standard Ohjects ITG User Data Contex Migr...
ITG Validation Migratar Standard Objects ITG Validation Migrator
W ITG Workflow Migrator Standard Objects ITG Workflow Migratar =
ITG Warkplan Template Mi Standard Objects ITG Waorkplan Template Mi
051390 JCL Migration Standard Objects 051350 JCL Migration
FPPM Project Type Migrator Standard Ohjects copy of "(REFERENCE] PP,
PPM Woarkplan Template M Standard Objects copy of "(REFERENCE) PP v

- Eturned 23 choices.
Enter an ohject
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7. Inthe Add Line window, complete the associated fields, and then click OK.

In some cases, you can add multiple package lines from a single Add Line
window. You can do this when you have multiple objects (files) to migrate
that are in the same location.

To add multiple lines from a single Add Line window, the following must
be true:

e Package lines all follow the same workflow and use the same object
type.

e The object type parameters include at least one auto-complete list field
with an enabled Multi button.

By selecting multiple files, you add multiple package lines to the package.
Remember, you cannot define multiple objects on a single package line.

Chject Type Information
IRl R ¢ S File Migration
Sequence: |5 Application Code: |Mone v
Fararneters
File Location:  |Server v
Sup Path;
File Marne: @
“ersion Label: | [PKG NUMEER]
File Type:  |ASCI hd
[Cox ][ ac ][ cancer |
|'RCS File Migration' parameters loaded.

The contents of the Add Line window are included in the Packages
window as a package line. The Add Line window closes. In the Add Line
window, clicking Add includes the package line in the Package window
and the Add Line window remains open.
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() Package: 30007

rPackage Information

Package Mo.: ID Package Group: |Custamization Created By: |Admin User |

Description: |Patch w3 migration test ‘ Created On: ISeptembEr 28, 2006
Worktloy: |DEV = TEST » PROD Package Status: |In Progress |

assined User: [Caralyn Sayer &1 Pririty: |Mormal v parert: | |
Aasigned Group: |agemem Administrator Package Type: |Customization hd Priarity Seq; (50 |

Percert Complete: l:l
Pachage Lines I Status I |=] Motes | ]| Re1erences| User Data I
Seq Chject Type App Code 1 2 3 Jl
1 RCS Server File (Mone) File Name: TestFile RCS Dir: R
2 File Client-=Client (Hone) Client File Wame: Mercury Help bt Sub Path FiI||
3 PYCE File Migration (Mone) File Location: Client Sub Path Fil

1

Feady

8. In the Package window, click OK or Save.

The package line is added to the package. To start the package on its
associated workflow, click Submit. Submitting the package to the
workflow generates entries under the Status tab for each of the workflow
steps defined for the workflow. As each step in the workflow is ready to be
processed, the step shows an Eligible status. You can view the progress of
each package line by clicking the Status tab. For information about how to
submit a package, see Submitting Packages on page 86.
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Adding Notes to Packages

In the Package window, the Notes tab (Figure 3-1) displays additional package
information. Notes are attached to the package, and not to individual package
lines. If you have a note that is specific to a package line, you must include the

package line reference as part of the note text.

Figure 3-1. Package window, Notes section

¢p Package: 30019

rPackage Information

Package Mo |3001 9 Package Group:

Description: |Patch v3 migration test

wiorkfiow: [DEV = TEST » PROD

Assigned Lzer: |Caru|yn Sayer & Priatity:
Assigned Group: Iagemem Administrator Package Type:

Package Lmesl Status 151 Mates I IE] Reierencesl Wser Data I

Mormal

Customization

b
~

Created By: |Ad

min Usger |

Created Or: [October 19, 2006

Package Status: |NE!W |

Parent: |

Priarity Sec |50

Existing Motes

4 Mew Motes
4

Admin User @dmin)
March 6 2007 09:52:07 Al PST
Escalate to P1 after April 5, 2007

Subrmit

Feady

You can add notes to existing packages, packages you are creating, and to
submitted packages that have not been closed. You cannot add a note to a

closed package.

To add a note, open a package and click the Notes tab. In the New Notes field,
type the text of the note, and then click Save. The note is added to the Existing

Notes field.
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Adding References to Packages from the Package Workbench

You can use the References section of the package detail page to add
references of several types to a package. For example, you might want to add a
document or URL to a package. You can add the following types of references
to a package:

e Attachments

e Packages (new and existing)
e Projects

e Releases

e Requests (new and existing)
e Tasks

e URLs

For some references (such as requests and other packages), you can create a
functional dependency to the original package. For example, you can specify
that a request is a predecessor to the package. This means the package cannot
continue until the request is closed. For a list of the references and their
possible dependency relationships, see Reference Relationships on page 41.

This section provides details on how to use the Package Workbench to add the
different entity types as package references. For information on how to add
package references from the standard interface, see Adding References to
Packages from the Standard Interface on page 94.
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Adding Attachments as Package References

This section provides the steps you use to add an attachment as a package
reference.

To add an attachment as a package reference:
1.
2.

Log on to PPM Center.

From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

Open a package.

In the Package window, click the References tab.

(p Package: 30007

rPackage Information
Package Mo.: Im:l Package Group: ICustDmiZatiDn Created By: |Admin User |
Description: |Patch w3 migration test Created Or: IBeptembEr 28, 2006
Whiorkfiow: |DEV = TEST = FROD Package Status: |In Progress |
assined User: [Caralyn Sayer &1 Pririty: |Mormal v parert: | |
Assigned Group: Iagemem Administrator Package Type: |Customization hd Priotity Secy |50 |
Package Lmesl Status I |Z| Netes 15 References IUser Data I
Type Matne Dretails Status % Cotnplete Desi
Project  [ERP Service Pack- Sept 2008 ERP Service Pack- Sept 2006 Business Readiness Sign-Of 46%
Project  |Whirlwind 2 Whirlwind 2 In Flanning 0%
Package (30032 DEY = TEST = PROD M 0% Pate
£ >
ftem=in Bold are actively controling this Packaoe
Mew Reference |Attachment V| [ Achd ]
Feady
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6. From the New Reference list, select Attachment., and then click Add.

The Add Document window opens.

(D Add Document =
File:

| Browse

Author. |Admin User

Description:

7. Attach the file, complete the fields, and then click Add.
The References tab lists the attachment.

8. Click OK or Save.
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Adding Existing Packages as Package References

To add an existing package as a reference to a package:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Deployment Mgmt > Packages.
The Package Workbench opens.
4. Open a package.
5. In the Package window, click the References tab.
6. From the New Reference list, select Package (Existing), and then click Add.

The New Reference - Package (Existing) window opens.

(D New Reference - Package (Existing) E®
Package Mo | El

Select the Relstionship that the selected Package has to Package 30007:

@ Related to this Package - (hformstional) - Selected Package is related to Packsge 30007

O Runh after thiz Package in a Release - (Informational) - Selected Package should be run after Package 30007 when both are
O Run before this Package in a Release - (Informational) - Selected Package should be run before Package 30007 when hoth 2
O Predecessor - (Blocking) - &ction not alloveed on Package 30007 until selected Package closes

O Successor - (Blocked) - Action not allowed on selected Package until Package 30007 cloges

< >
|Ready

7. Under Select the Relationship that the selected Package has to Package
<Package Number>, select the option that describes the relationship that the
packages have to the open package.
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8.

9.

Select the existing packages from the Package No. auto-complete list.
The Package No field displays the number of the package you selected.

Under Select the Relationship that the selected Package has to Package
<Package Number>, select the option that describes the relationship that the
packages have to the open package, and then click OK.

The References tab lists the selected packages.

10. Click OK or Save.

Adding New Packages as Package References

You can reference a new package to a package.

To create a package to add as a package reference:

1.
2.

Creating Packages

Log on to PPM Center.

From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.

From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

Open the package to which you want to add a reference.

In the Package window, click the References tab.

From the New Reference list, sclect Package (New), and then click Add.

The New Reference - Package (New) window opens.
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10.

(D New Reference - Package (New)

Select the Relstionship that the selected Package has to Package 30007

(%) Related ta this Package - (informational) - Selected Package is related to Package 30007

O Run after thiz Package in & Release - (Informational) - Selected Package should be run after Package 30007 whenh both are
O Run betfare thiz Package in & Release - (Informational) - Selected Package should be run before Package 30007 when both 2
O Predecesszor - (Blocking) - Action not allovwed on Package 30007 until selected Package closes

O Successor - (Blocked) - Action not allowed on selected Package until Package 30007 cloges

< >

|Read;r

Under Select the Relationship that the selected Package has to Package
<Package Number>, select the option that describes the relationship that the
new package is to have to the package you opened, and then click Create.

A new Package window opens.

In the Workflow field, type the name of a workflow to apply to the new
package.

Type any other information you want to record in the Notes tab, modify
any values that you want to change, and then click Save or OK.

The References tab lists the new package reference.

Click Save to save the package.
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Attaching Programs as Package References

You can reference existing programs to a package.
To reference an existing program:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Deployment Mgmt > Packages.
The Package Workbench opens.
4. Open the package to which you want to add a reference.
5. In the Package window, click the References tab.
6. From the New Reference list, select Program, and then click Add.

The New Reference - Program window opens.

(D New Reference - Program 3]
Program Namell
Select the Relstionship that the selected Program has to Packaye S0007:
@ Related to this Packacs - (Informational) - Selected Prograrm is related to Packags 30007
[Reacy

7. In the Program Name field, select the program from the auto-complete list.

The Program Name field displays the program you selected.
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8. Under Select the Relationship that the selected Program has to Package

9.

<Package Number>, select the option that describes how the program is
related to the package, and then click OK.

The References tab displays the program name.

Click Save to save the package.

Attaching Projects as Package References

To attach a project as a package reference:

1.
2.

Log on to PPM Center.
From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

. Open the package to which you want to add a reference.

In the Package window, click the References tab.
From the New Reference list, select Project, and then click Add.

The New Reference - Project window opens.

Chapter 3



Creating Packages

Project Mame: I E=

Select the Relationship that the selected Project has to Package 30007

@ Related to this Package - (Ihformstional) - Selected Project is relsted to Package 30007

|Read;r

7. In the Project Name field, select a project name from the auto-complete list.

8. Under Select the Relationship that the selected Project has to Package
<Package Number>, select the option that describes how the project is
related to the package, and then click OK.

The References tab lists the selected project.

9. Click Save to save the package.
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Adding Releases as References

You can reference existing releases to requests.

To reference a release:

[N

. Log on to PPM Center.

2. From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

3. From the shortcut bar, select Deployment Mgmt > Packages.
The Package Workbench opens.

4. Open the package to which you want to add a reference.

5. In the Package window, click the References tab.

6. From the New Reference list, select Release, and then click Add.

In the Status section, the New Reference - Release window opens.

(D New Reference - Release 3]
Releaze Namal E
Select the Relstionship that the selected Release has to Package 30007
@ Cortaing this Packass - (Infarmational) - Package 30007 is contained in the selected Release
[Reacy

7. To specify a release name in the Release Name field, use the auto-complete

list.
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8. Under Select the Relationship that the selected Release has to Package
<Package Number>, select the option that describes how the release is
related to the package, and then click OK.

The References tab lists the release.

9. Click Save to save the package.
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Adding Existing Requests as Package References

You can reference existing requests to requests.

To reference an existing request:

1.
2.

Log on to PPM Center.
From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

Open the package to which you want to add a reference.

In the Package window, click the References tab.

From the New Reference list, select Request (Existing), and then click Add.
The New Reference - Request (Existing) window opens.

(D New Reference - Request (Existing) (3]

Request Mo || E
Select the Relstionship that the selected Reguest has to Package S0007:

O Parent of this Packags - (Informational) - Selected Reguest is the parent of Package 30007
@ Related to this Packace - (hformstional) - Selected Reguest is related to Package 30007
) Predecessar - (Blocking] - Action not allowed on Package 30007 urtil selected Request closes

O Successor - (Blocked) - Action not allowed on selected Request until Package 30007 closes

[Reacy
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7. To specify the request name in the Request No field, use the auto-complete
list.

8. Under Select the Relationship that the selected Request has to Package
<Package Number>, select the option that describes how the request is
related to the package, and then click OK.

The References tab lists the existing request.

9. Click Save to save the package.
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Adding New Requests as Package References

You can create new requests and add them as package references.

To reference a new request:

1.
2.

Log on to PPM Center.

From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

Open the package to which you want to add a reference.

In the Package window, click the References tab.

From the New Reference list, sclect Request (New), and then click Add.
The New Reference - Request (New) window opens.

Request Type: || E

Select the Relationship that the selected Reguest has to Package 30007
O Parent of this Package - (Informational) - Selected Request is the parent of Package 30007

@ Related to this Packade - (hformstional) - Selected Reguest is related to Package 30007
O Predeces=ar - (Blocking) - Action not allowwed on Package 30007 until selected Request closes

O Successor - (Blocked) - Action not allowed on selected Reguest until Package 30007 closes

Ready
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10.

1.

12.

. To specify the type of request you want to create in the Request Type field,

use the auto-complete list.

Under Select the Relationship that the Request has to Package <Package
Number>, select the option that describes how the new request is related to
the package, and then click Create.

The Create New Request page opens in a new browser window.
Complete all required fields (marked with a red asterisk).

In the optional fields and in the Notes tab, type any additional information
about the request you want to make available to users.

Click Submit.
In the Package window, the References tab lists the new request.

Click Save to save the package.

Adding Tasks as Package References

You can add existing tasks as references to packages.

To reference an existing task:

1.
2.

Creating Packages

Log on to PPM Center.

From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.

From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

Open the package to which you want to add a reference.

From the New Reference list, select Task, and then click Add.

The New Reference - Task window opens.
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(D New Reference - Task ®

Task MNarme: I El

Select the Relationship that the selected Task has to Package 30007

@ Related to this Package - (Ihformational) - Selected Task is related to Package 30007

|Read;r

6. To specify a task in the Task Name field, use the auto-complete list.

7. Under Select the Relationship that the selected task has to Package
<Package Number>, select the option that describes how the task is related
to the package, and then click OK.

In the Package window, the References tab lists the task.

8. Click Save to save the package.
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Adding URLs as Package References

You can reference a URL to a package.

To reference a URL:

1.
2.

10.

Creating Packages

Log on to PPM Center.
From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

Open the package to which you want to add a reference.

In the Package window, click the References tab.

From the New Reference list, select URL, and then click Add.
The New Reference URL window opens.

(D New Reference - URL

E]

URL: |

=

Description:

[ Ok ] [ Cancel

|Ready

In the URL field, type the URL address.
To test the URL you specified, to the right of the URL field, click U.

In the Description field, you can type a description or an explanation of
how the URL is related to the package, and then click OK.

In the Package window, the References tab displays the URLs.

Click Save to save the package.
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Submitting Packages
After you complete a package, you can submit it. A complete package must
have the following:
e A package number
e An associated workflow
e At least one package line

In the Package window, if a package is complete and eligible for submission,
the Submit button is enabled in the bottom left corner.

To submit a completed package, click Submit.
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4 Processing Packages

Overview of Processing Packages

In HP Deployment Management, after a package has been submitted, you can
process and manage it. Processing packages refers to working with the package
as the package progresses through its workflow.

You can locate packages that require attention using one of the following
methods:

e Use the Package Workbench. Use the Query tab in the Package
Workbench to specify search criteria to find a package. After the package
is found, highlight the package and click Open. The selected package opens
in the Package window.

e Use Portlets in the Standard Interface. The quickest way to locate
relevant packages is through the standard interface. When included on a
PPM Dashboard page, the My Packages portlet displays all the packages
you have created or that are assigned to you. Click a package number to
open the package in the standard interface.

e Use Searches in the Standard Interface. Using search in the standard
interface is another way to find a package. In the standard interface, on the
menu bar, select Search > Packages. The Package Search page opens. In
the Package Search page, complete the search criteria, and then click
Search. The Package Search Results page opens. In the Package Search
Results page, click a package number to open the package in the standard
interface.
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e Use Notifications. As a package proceeds through its workflow, email
notifications can be sent to alert you of pending actions. The notification
might include a link to the package. Click the link to open the referenced
package in the PPM Workbench. If you are not currently logged on to PPM
Center, the Logon page opens.

e Generate a Report on Open Packages (Standard Interface). HP
Deployment Management includes a predefined set of reports that generate
HTML text and can be accessed by a Web browser. Among these reports is
the Packages Pending Report, which reports on open packages with
pending activity.

For information about generating and viewing HP Deployment
Management reports, see the Reports Guide and Reference.

For detailed information on how to process packages in the standard interface,
see Using the Standard Interface to Process Packages.

Using the Standard Interface to Process Packages

You can use the package detail page in the standard interface to process a
package through its entire workflow. You can add notes and references to the
package, and make decisions about package status. For information on how to
process packages from the PPM Workbench, see Processing Packages Using
the PPM Workbench on page 108.
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Opening Packages from the Standard Interface

This section provides information on how to open packages from the standard
interface using the Search Packages page, using portlets, or using the package
links in email notifications.

Opening Packages from the Search Packages Page
To open a package using the Search Packages page:
1. Log on to PPM Center.

2. From the menu bar, select Open > Deployment Management > Search
Packages.

The Search Packages page opens.
3. Provide your search criteria, and then click Search.

The Package Search Results page lists the packages that match the criteria
you specified.

4. In the Pkg # column, click the package number for the package you want to
open.

The detail page for that package opens.

Processing Packages 89



Opening Packages from the My Packages Portlet

If the My Packages portlet is not displayed on one of your PPM Dashboard
pages, you can add it. For information on how to add portlets to PPM
Dashboard pages, see the Creating Portlets and Modules guide.

To use the My Packages portlet to open a package that you have created or a
package that is assigned to you:

1. Log on to PPM Center.

2. From the menu bar, select Dashboard, and then select the name of a PPM
Dashboard page that displays the My Packages portlet.

The My Packages portlet lists all of the packages that you have created.

3. On the My Packages portlet, in the Pkg # column, select the number for the
package you want to open.

The detail page for that package opens.

Opening Packages Using Notification Links

In some cases, as a package moves through the steps in its workflow, email
notifications are sent to alert you of pending actions for a package. If the
notification includes a link to the package, click the link to open the referenced
package in the PPM Workbench. (If you are not logged on to PPM Center, the
Logon page opens.)

Approving Packages in the Standard Interface

To approve a package using the standard interface:

1. Log on to PPM Center.
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2. Open the package that you want to approve.

For information on how to open the details page, see Opening Packages
from the Standard Interface on page 89.

Package 30007

Header

‘Package Ho.: 30007 Package Group: Customization iE| CcreatedBy: Admin User
Description: Patch w3 migration test Created On September 28, 2006
Workflow: DEY = TEST = PROD Status: In Progress
Assigned User: Carolyn Sayer & Priority: Mormal Parent:
Assigned Group: ITG Deployment Managemd 32| Package Type: Customization v Priority Seq: 50
Percent Complete: 0

Status

View Lines: () Pending Lines Only View Steps: (2 Steps Waiting my Action

O alLines O Alsteps
View All Lines Viiew Eligible Steps for DEV > TEST > PROD
Seq  Object lame Object Type ] ol ] ]

This package does not have any Lines to show.

Notes

Hotes to be added on save:

References
Projects
Hame Project Status Y Relationship Relationship Details
Manager Resource Complete
ERP Service Joseph Banks Business Readiness 46% i Informationat Project 30031 is related to
] Related to this Package -
Pack Sig. Package 30007
w Vw2 David Jones In Flanning 0% [Relstedto this Fackags | Informational: Project 30222 is related to
Package 30007
Reference Ad ons
New Reference: | Attachment v Add Highlighted ltems are actively controlling this Package

References to be added on Save:

Save Reset

The Status section displays the package lines for the workflow.
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3. In the Status section, next to View Lines, do one of the following:

e To display only the package lines that are eligible for action, click
Pending Lines Only, and then click Refresh.

e To display all of the package lines for the workflow, click All Lines,
and then click Refresh.

4. In the Status section, next to View Steps, do one of the following:

e To display only workflow steps that await action, click Steps Waiting
my Action, and then click Refresh.

e To display all workflow steps, click All Steps, and then click Refresh.

Status
View Lines: (O pencing Lines Oy View Steps: (O Steps Waiting my Action
All Lines All Steps
® ®

View All Lines View All Steps for DEV > TEST > PROD

Seq  Object Hame Object Type 1: Design Review 2: Evaluate 3: Migrate to Test 4 0A Test
O 1 TestFile RCS Server Filg Eligible:
0 3 KeyConcepts pdf PYWCS File Migration Eligible
O 4 File Cliert-=Clignt Eligible:
Check All Lo |

Under the workflow name are the numbered steps that must be completed
and approved to move the workflow to completion. To navigate forward or
backward through the workflow steps, use the directional arrows.

5. In the View Eligible Steps for <Workflow Name> section, select the option
button that corresponds to the numbered workflow step that you want to
approve (or not), and then select the Eligible checkbox for the specific line
you want to approve (or not).

To select all of the steps, click Check All.
To clear all eligible checkboxes for the workflow step, click Clear All.
6. If one or more package lines are selected for action, click Workflow Action.

The Package Workflow Action page opens.
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7. In the Action Required section, select the outcome of the step.

Because the outcome is configurable, it can be different for each workflow
step, depending on the configuration at your site. In the above example, the
possible actions are:

e If the workflow step is ready for approval, select Approved.
e If the workflow step is not ready for approval, select Not Approved.
8. Click OK.

The package details page opens. Because you approved (or disapproved)
the selected workflow steps, the workflow has moved on to the next step.
This process continues until the package moves through all of its steps to
resolution.

Adding Notes to Packages in the Standard Interface

Processing Packages

The Notes section contains fields in which you can provide supplementary
package information. To add a note, in the Add Notes subsection, type the
information. To save the note, save the package.

View existing notes in the Existing Notes section. Existing notes are listed in
chronological order with the most recent note listed first. You can filter
existing notes, using Show Only User Notes, Note Author, and Changed Fields.

You cannot delete an existing note.

Figure 4-1. Notes section

Notes

Add Notes

Hotes to be added on save:

Existing Notes

iin User (ad

Admi min| Escalate 1o P1 after April 5, 2007,
March 6, 2007 08:52:07 AMPST

23
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Adding References to Packages from the Standard Interface

In some cases, it might be useful to reference a Web-accessible file, a
document, or file from a local machine to the package. You can add such
references to a package from the standard interface.

You can add the following entities as package references:
e Attachments

e Packages (new or existing)

e Projects

e Releases

e Requests (new or existing)

e Tasks

e URLs

For some reference types (such as requests and other packages), you can create
a functional dependency to the reference. For example, you can specify that a
request is a predecessor to the package. This means that the package cannot
continue along its workflow until the referenced request closes. For more
information about valid package references and the relationships they can have
to packages, see Reference Relationships on page 41.

This section provides information on how to add various types of references to
a package from the standard interface. For information on how to add package
references from the PPM Workbench, see Adding References to Packages from
the Package Workbench on page 69.
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Adding Attachments as References

To add an attachment as a package reference:

1.
2.

Processing Packages

Log on to PPM Center.

Open or create a package.

For information on how to open a package, see Opening Packages from the
Standard Interface on page 89.

Scroll to the References section.

. From the New Reference list, select Attachment, and then click Add.

The Add Document window opens.

(D Add|Document ®
File:

‘ Browse

Author: | Admin User

Description:

. Next to the File ficld, click Browse, and then locate and select the document

file you want to attach as a reference.

In the Author field, you can replace the default value with the name of the
attachment author.

In the Description field, type a description of the attachment.
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8. Click Add.

On the Package page, the References to be added on Save field lists the
referenced attachment.

9. Click Save.

The attachment is added as a request reference.

Adding Existing Packages as Package References
You can reference existing packages to a package.
To specify an existing package as a package reference:
1. Log on to PPM Center.
2. Open or create a package.

For information on how to open a package, see Opening Packages from the
Standard Interface on page 89.

3. Scroll to the References section.
4. From the New Reference list, select Package (Existing), and then click Add.

The Add References: Package window opens.
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Add Reference: Package

‘Select which relationship the selected Packages will have to Package =30008:

(@) Related to this Package - (Informational) - Selected Package s related to Package 30008

© Run after this Package in a Release - (Informational) - Selected Package should be run after Package 30008 when both are in @ Release
) Run beforethis Package in a Release - (nformational) - Selected Package should be run before Package 30003 when both are in a Release
© Predecessor - (Blocking) - Action not allowed on Package 30005 until sslected Package closes

) Successor - (Blacked) - Action not allowed on selected Package until Package 30008 closes

Package Search Results Showving 1 -7 of 7
Pkg 7 Workflow Status Priority Assigned To Pkg Lines Description
O 30032 DEY = TEST = PROD ey Maormal cayer Patch «3 migration test
D 30029 DEY = TEST » PROD My Morrmal hhaywaod Upgrade for relsase 7 0b
O 30019 DEY = TEST = PROD ey Maormal cayer Patch «3 migration test
O 30016 DEY = TEST » PROD My Morrmal cEayer
O 30013 DEY = TEST = PROD ey Marmeal cyayer
O 30008 DEY = TEST » PROD Mewy Mormal cayer 1
O 30007 DEV = TEST = PROD In Progress Marmal cIAYEr 4 Patch w3 migration test
Check All|  Clear All Showing 1 -7 of 7
Add Modify Searchy Cancel

5. Provide your search criteria, and then click Search.

The Package Search Results section lists the packages that match your
search criteria.

6. Select the checkbox for the package that you want to add as a reference,
and then click Add.

On the Package page, the References to be added on Save field lists the
referenced package.

7. Click Save.
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Adding New Packages as Package References

You can reference a new package to a package.

To add a new package as a package reference:

1.
2.

Log on to PPM Center.
Open a package.

For information on how to open a package, see Opening Packages from the
Standard Interface on page 89.

Scroll to the References section.
From the New Reference list, select Package (New), and then click Add.
The Create New Package window opens.

Under Relationship, select the option that describes the relationship that the
new package has to the open package.

Under Select which Relationship the new Package will have to Package #,
select the option that describes the relationship that the new package has to
the open package.

For information about the different types of reference relationships, see
Reference Relationships on page 41.
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7. Click Create.

10.

The New Package window opens.

Create New Package

'Relationship:

() Related to this Package - (nformational) - Selected Package is related to Package 30008

O Run after this Package in a Release - (Informational) - Selected Package should be run after Package 30008 when both are in & Release
© Run kefare this Package in a Release - (Informational) - Selected Package should be run before Package 30008 when both are in a Release
O Predecessor - (Blocking) - Action not allowed on Package 30008 until szlected Package closes

O Successor - (Blocked) - Action not allawed on selected Package until Package 30008 closes

Create Cancel

In the Workflow field, type the name of a workflow to apply to the new
package.

Type any optional information you want to save, and modify any values

that you want to change, and then click Save.

On the Package page, the References to be added on Save field lists the
new referenced package.

Click Save.
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Attaching Programs as Package References
You can reference existing programs to a package.
To specify a program as a package reference:
1. Log on to PPM Center.
2. Open or create a package.

For information on how to open a package, see Opening Packages from the
Standard Interface on page 89.

3. Scroll to the References section.
4. From the New Reference list, select Program, and then click Add.

The Reference Program window opens.

Reference Program

‘Program: | ‘ i

‘Relationship:

@ Related to this Package - (Informational) - Selected Program is related to Package 30008

5. To specify the name of the program to reference in the Program field,
select the name from the auto-complete list, and then click Add.

On the Package page, the References to be added on Save field lists the
program you selected.

6. Click Save.
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Attaching Projects as Package References
To specify a project as a package reference:
1. Log on to PPM Center.
2. Open or create a package.

For information on how to open a package, see Opening Packages from the
Standard Interface on page 89.

3. Scroll to the References section.
4. From the New Reference list, select Project, and then click Add.

The Add Reference: Project window opens.

Add Reference: Project

Search for Projects to View

Project Hame conlains: Project Manager: &
Project Type: | Detailed Search

Planned Start Date From: To: =

Planned Finish Date From: B Tor =

Include Finished Projects: (O vez & o
Hearn: [ H

F Associated Programs: (=)
oo Region: =
[ none

SortBy: | Projact Name ¥ @ asscending ‘Results Displayed Per Page: |50

) Descending

Search

5. Provide your search criteria in one or more of the available fields, and then
click Search.

The Add Reference: Project window lists the projects that match the search
criteria you specified.

6. In the Select Project to View section, select the checkbox for the project that
you want to add as a package reference.

Processing Packages 107



7. Click Add.

8.

On the Package page, the References to be added on Save field lists the
referenced project.

Click Save.

Adding Releases as Package References

You can add existing releases as package references.

To reference an existing release to a package:

1.
2.

102

Log on to PPM Center.
Open or create a package.

For information on how to open a package, see Opening Packages from the
Standard Interface on page 89.

Scroll to the References section.
From the New Reference list, select Release, and then click Add.

The Reference Release window opens.

Reference Release

‘Release: [ |
*Refationship:

) Contains this Package - (nformational) - Package 30008 is contained in the selected Release

To specify the name of the release to reference in the Release field, select it
from the auto-complete list, and then click Add.

On the Package page, the References to be added on Save field lists the
referenced release.

Click Save.
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Adding Existing Requests as Package References
You can reference existing requests to packages.
To reference an existing request:
1. Log on to PPM Center.
2. Open or create a package.

For information on how to open a package, see Opening Packages from the
Standard Interface on page 89.

3. Scroll to the References section.
4. From the New Reference list, select Request (Existing), and then click Add.
The Add Reference: Request window opens.

5. Specify search criteria for the request, and then click Search.

A Add Reference: Request [HP] - Microsoft Internet Explorer
File Edit ‘View Favorites Tools  Help

Add Reference: Request

‘Select which relationship the selected Requests will have to Package £30007:

© Parert of this Package - (Informational) - Selected Request is the parent of Package 30007

(%) Related to this Packags - (nformational) - Selected Request is related to Package 30007

) Predecessor - (Blocking) - ction nat allowed on Package 30007 until selected Request closes
(2 Successor - (Blocked) - Action not allowed on selected Request until Package 30007 closes

Request Search Results Shivwing 1 - 30t 3
Req=¥% | Request Type Description Status | Assigned To | Priority | Created By
O 30248 DEM - Application Bug Laptop DEMO installation is broken Mew Leslie Frankiin - High Admin User
O 30246 DEM - Applicstion Add 5 module that can be used to manage Mewe Leslie Frankin - High Admin Uzer
Enhancement employes buy-out options
[] 3024 Frogramissus Deploy to sipha test stes Open  LeslisFrankin  Criticsl  Admin Liser
Check Alll  Clear Al Showing 1 - 3of 3
Add Meodify Search| Cancel
h
&] % Local intranet
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6. Under Select which Relationship the selected Requests will have to

Package #, select the option that describes the relationship that the new
request has to the open package.

For information about the different types of reference relationships, see
Reference Relationships on page 41.

Select the checkbox for the request that you want to add as a package
reference, and then click Add.

On the Package page, the References to be added on Save field lists the
referenced request.

8. Click Save.

Adding New Requests as Package References

To reference a new request:

1.
2.

Log on to PPM Center.
Open or create a package.

For information on how to open a package, see Opening Packages from the
Standard Interface on page 89.

Scroll to the References section.

. From the New Reference list, sclect Request (New), and then click Add.

The Create New Request window opens.

Create New Request

‘Request Type: e

'Relationship:

© Parerit of this Package - tinformational) - Sslected Request is the parent of Package 30008
® Related to this Package - (Informational) - Selected Request is related to Package 30008
(O Predecessor - (Blocking) - Action nat allowed on Package 30008 unti selected Request closes

' Successor - (Blocked) - Action not sllowed on selected Request urtil Package 30008 closes

Create Cancel
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5. From the Request Type list, select the type of request you want to create as
a reference to the open package.

6. Under Relationship, select the option that describes the relationship that the
new request has to the open package.

For a list of reference types, their definitions, and possible dependency
relationships, see Reference Relationships on page 41.

7. Click Create.
The Create New <Request Type> window opens.

8. Provide data in all of the required fields (marked with a red asterisk), and
any optional data about the new request that you want to record.

9. Click Submit.

On the Package page, the References to be added on Save field lists the
new request.

10. Click Save.
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Adding Tasks as Package References

You can reference existing tasks to packages.

To reference an existing task:

1.
2.

Log on to PPM Center.

Open or create a package.

For information on how to open a package, see Opening Packages from the

Standard Interface on page 89.

Scroll to the References section.

From the New Reference list, select Task, and then click Add.

The Add Reference: Task window opens.

Provide your search criteria in any of the available fields, and then click

Search.

The Add Reference: Task window lists the tasks that match the search

criteria you specified.

Add Reference: Task

Search for Tasks to View

Task Name starts with:

Include finished Tasks? (O ves ®ha
Scheduled Start Date From: =
Scheduled Finish Date From: <

Show only tasks with exceptions?  (Jives &ng

Show only milestones? Oives @

Search in projects that meet the following criteria

Project Hame: |

SortBy: | TaskName ¥ & sscending
(@] Descending

L]

‘Results Displayed Per Page: |50

6. In the Select Task to View section, select the checkbox for the task you
want to add as a reference to the open package, and then click Add.
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7.

On the Package page, the References to be added on Save field lists the
task you selected.

Click Save.

Adding URLs as Package References

You can reference an existing URL to a package.

To add a URL as a package reference:

1.
2.

Processing Packages

Log on to PPM Center.
Open or create a package.

For information on how to open a package, see Opening Packages from the
Standard Interface on page 89.

. Scroll to the References section.

From the New Reference list, select URL, and then click Add.

The Reference URL window opens.

Reference URL

‘URL:

Deseription:

0K Cancel

In the URL field, type the URL address.

To test the URL you specified in your default browser window, to the right
of the URL field, click U.

In the Description field, type a description or an explanation of how the
URL is related to the package.
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8. Click OK.

On the Package page, the References to be added on Save field lists the
URL you specified.

9. Click Save.

Processing Packages Using the PPM Workbench

You can process submitted packages from the PPM Workbench using the
Package window. You can use the Package window to process a submitted
package through its workflow. You can add notes and references to the
package, make decisions on package status, and execute actions for the
package. You can also change or delete a package from the Package window.

Opening Packages from the PPM Workbench

To open a package from the PPM Workbench:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Deployment Mgmt > Packages.
The Packages Workbench opens.
4. To display all the existing packages, click List.

To restrict the search, provide information in one or more of the search
fields.

5. Select a listed package, and then click Open.
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Checking Package Status

Each package line must follow the business process defined by its assigned
workflow. You can view all the workflow and subworkflow steps for each line
on the Status tab in the Package window.

To view the status of a submitted package:
1. Open a submitted package.

For information on how to open a package, see Opening Packages from the
PPM Workbench on page 108.

The Package window opens.
2. Click the Status tab.
3. Review the status of the package.

You can now review the status of each package line. The result of each
workflow step is recorded in the package line row, so that you can quickly
get an idea of which lines have closed with success or closed with a failure.

Although all the workflow steps are listed, a package line does not
necessarily go through every step before it is resolved. For example, you
might have a rework step that is only used if rework is required. For more
information about the package, select one of the logs, views, or reports
related to the package. For more information about the Status tab, see
Package Window, Status Tab on page 34.
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Acting on Eligible Steps

After a package is submitted, each package line has one or more workflow
steps set to Eligible, as shown in Figure 4-2 on page 110. This indicates that the
execution or decision steps must be performed first in the resolution process
for the package. If you have permission to act on the eligible step, the text in
the Status column is displayed in bold text.

If the eligible step is:
e FExecution workflow step, you must perform an action.
e Decision workflow step, you must specify a decision.

After you perform the action or make the decision, HP Deployment
Management displays the outcome.

Figure 4-2. Status tab eligible steps

(% Package: 30007

rPackage Inforrmstion

Package Mo 30007 Package Group: |Customization Created By:
Deserigtion: | Patch w3 migration test i Crested On: [September 28, 2006
Werkilow. [DEV > TEST » PROD Package Status:
Assigned Group: [agernent Administratar Package Type: Priority Secp
Package Lines | Status]] (= Notes | 15 Refarences | User Deta |
2 Object Object T ! 2 3 4
=6 Ject Nathe: Ject Type Desitn Review Evaluate: Migrats to Test QA Test
1 TestFile RCS Server File Eligihle
2 Mercury Help bd File Client=Client Cancelled
3 kevConcepts pdf  |PVCS File Migration Eligihle
4 File Client-=Client Eligible
< >
[ Refresn | [ selectan | *e = [ view > ||Line Exec Log (Latest) v
Fready
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Processing a Workflow Step

Processing Packages

To process a workflow step:

1. Open a submitted package.

For information on how to open a package, see Opening Packages from the
PPM Workbench on page 108.

The Package window opens.

. Click the Status tab.

. Select one or more package lines.

You can select a single step for a single package line, or multiple steps for
multiple lines. To select all the steps on all the open package lines that are
eligible for action, click Select All.

You cannot act on multiple workflow steps at one time. If you select cells
for multiple workflow steps, the Action button remains disabled. If you
have the security privileges to perform the given workflow step, the button
is enabled.

After you select a workflow step for which you have the security
permission to act on the workflow step, the label on the button at the
bottom-right of the Status tab changes from Action to the workflow step
name.

. To perform an action or decision on a selected step, click Action.

A decision window or the execution window opens.

Each step is configured with a selection of valid results.

. If a decision window is open, from the Result list, select a decision result.

If an execution window is open, in the list, select Execute Now, Schedule
Execution, or Bypass Execution.
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6. In the Notes field, you can type any comments you want to save.

For information about the decision window, see Acting on Decision
Workflow Steps on page 113. For information about the execution window,
see Acting on Execution Workflow Steps on page 115.

7. Click OK.

Whether the step is a decision or an execution, the result of the step is
processed by the workflow engine and can lead to a number of changes. Based
on the workflow definition (which can contain multiple workflow steps and
subworkflows) the given workflow step result can cause additional workflow
steps to become eligible, indicating the next actions to be performed in the
package resolution process.

When subsequent steps become eligible, those steps are completed
sequentially, making eligible the next workflow steps in line. This process
continues until the package reaches its final state and is resolved, usually at a
close step.
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Acting on Decision Workflow Steps

Decision workflow steps are steps for which you (or a group) must indicate the

outcome. For example, Approve Migration is an example of a decision

workflow step. You can either act on the decision step yourself or delegate the

decision.

To act on a decision workflow step:

1. In the Package window, select the Status tab.

@ Package: 30007 BEEE

Package Informatior

Package No.: |EIIY
Description: |Patch w3 migration test
wiorkflow: [DEW > TEST = FROD

Assignied User: |Caralyn Sayer [ Priority: | Marmal 3
Assigned Group: igerment Administrator 5] Package Type: | Gustormization b

Percent Complete: |0

Package Group: [ Custarnization

Created By: | Admin User

Created On: [September 28, 2006

Package Status: | In Progress

Parent:

Priority Seq: |50

Package Lines Status | (=) Hotes | 151 References | |
) ) 1 z 3 4
S5 @R D Object Type Design Revisw Evaluate Migrate o Test O Tast
1 |TestFile RCS Server File Eligible
2 Mercury Help .t File Client=Client Cancelled
3 KeyConcepts.pdl  [PYCS File Migration Eligihle
4 File Client-=Client Eligible
< >
[ Refresh ] [ Select Al ] = [ Yigw - Line Exec Log (Latesl) ¥

Ready

2. Select an eligible decision workflow step.

For information on how to access the Status tab and select an eligible
decision workflow step, see Acting on Eligible Steps on page 110.

The Action button label changes, depending on the step selected. For

example, if you click Eligible for QA Test, the Action button label changes

to QA Test.

) If you cannot see the Action button on the Status tab, that means that a security
group has not been assigned to the workflow step.
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3. Click the action button. For the example given in step 2, click QA Test.
The QA Test Package Decision window opens.

4. In the list, select the applicable action needed (Decide Now or Delegate
Decision).

e If you select Decide Now, you must make a decision about the decision
workflow step; for example, Approve. To make a decision regarding
the decision workflow step:

a. From the Result list, select the result.

b. In the Notes field, type helpful information about the decision you
made, and then click OK.

The decision window closes. The decision results are added to the
Status tab.

e If you select Delegate Decision, you must then assign the decision to
someone. To delegate a decision:

a. To select a resource, use the Delegate To auto-complete list.

b. In the Notes field, type helpful information about the decision that
needs to be made, and then click OK.

The decision window closes, and the results are listed on the Status tab.
5. Click OK.

The decision is entered into the system. If the workflow step was configured so
that more than one person must decide on the result, the package line may not
move to the next step until all required decisions are made. If a decision
workflow step requires that more than one person decide on the result, you can
view the current decision results for the workflow step using the Decision
Detail view.
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Acting on Execution Workflow Steps

Execution workflow steps are workflow steps where the HP Deployment
Management system performs an action, and then updates the step with its
result. These actions can be as simple as calculating the value for a token or as
complex as copying files, running programs, or updating Web pages.

To act on an execution workflow step:

1. In the Package window, on the Status tab, select the eligible decision

workflow step.

For information on how to access the Status tab and select an eligible
decision workflow step, see Acting on Eligible Steps on page 110.

The Action button is enabled. Notice that the button label changes with the
step selected. For the following example, the action button label changed to

SAP_ Export.

Package: 30127

15 =1 B3

~Package Information

Package Mo | 30127 Package Group

E}

Drescription: ‘

wiorklaw: [Alpha ith Email

Azsighed User: EH
Percent Complete: |1

Package Lines  Status 1 IZ] Notes I =] Reierences] ]

Priority: |Low 2
Azsigned Group: Package Type: |Customization <

Created By W
Created On;
Packsge Status: [In Progress

Parent: ’7
Priority Seg ’507

Sey Ohject Mamme Ohject Type

ckage |

2

Code Reviewn:

1 B [File Client-=Client |

5 |
| SAP_FXPORT

Kl | =]
Refresh | Select Al | ﬂ j ey - Line Exec Log {Latest) = S&P_EXPORT
K ‘ ‘ Cancel |
Feady

2. On the Status tab, click the action button, which for this example is SAP_

Export.

The SAP_Export execution window opens.
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3. In the list, select Execute Now, Schedule Execution, or Bypass Execution.

e Ifyou select Execute Now and click OK, you execute the workflow step.

The Execution window closes. The result of the workflow step is
displayed on the package line at the workflow step. This process could
be a software migration, execution of a PL/SQL function, the closing of
the package line, or other activity. The execution engine executes the
step and sets the result accordingly.

If you select Schedule Execution, the Execution Date and Execution
Time fields are visible. Select a date and time, and then click OK. The
Execution window closes. The execution schedule is displayed on the
package line at the workflow step. This process could be a software
migration, execution of a PL/SQL function, the closing of the package
line, or other activity. The execution engine executes the step and sets
the results accordingly.

If you select Bypass Execution, the Execution Result field is visible.
Select the results, and then click OK. The execution window closes and
the selected result is displayed on the package line at the workflow
step.

4. Click OK.
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Adding Notes

In the Package window, the Notes tab (Figure 4-3) displays additional package
information.

Figure 4-3. Notes tab in the Package window

¢p Package: 30019

rPackage Information

Package Mo |3001 9 Package Group: I Created By: |Admin User |

Description: |Patch v3 migration test ‘ Created On IOctober 14, 2006
wrkflow: [DEY » TEST = PROD Package Status: |New |
Azsigned Lzer: ICaruIynSaye—rEH Priority: |Marmal L Parent: | |
Assigned Group: Package Type: |Customization v|  Priority Seq; |50 |
Percert Complete: I:l
Package Lmesl Statys S Notes I 1 Reierencesl Uzer Data I
Existing Motes : Meww Notes

Admin User @dmin)
March 6 2007 09:52:07 Al PST
Escalate to P1 after April 5, 2007

Subrmit Save

Feady

To add a note, type the text in the New Notes field, and then click Save. The
note is added to the Existing Notes field.
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Adding, Updating, and Deleting References

You can add and update package references from the References tab of the
Package window in the PPM Workbench. The following sections provide
information about how to add, update, and delete references.

Adding References

The Package window References section contains additional package
information. For example, you might add a document or URL as a reference to
a package. You can add the following entities as package references:

Attachments

Packages (New and Existing)
Projects

Releases

Requests (New and Existing)
Tasks

URLs

For some references (such as requests and other packages), a functional
dependency to the original package can be created. For example, you can
specify that a request is a predecessor to the package. This means the package
will not continue until the request is closed. For a list of the references and
their possible dependency relationships, see Reference Relationships

on page 41.

For information on how to add a reference, see Adding References to Packages
from the Package Workbench on page 69 or Adding References to Packages
from the Standard Interface on page 94.
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Updating Reference Relationships

To update an existing reference relationship from the PPM Workbench:

1. Open a package.

For information on how to open a package, see Opening Packages from the

PPM Workbench on page 108.

2. Click the References tab.

3. Click the Relationship field for the referenced entity, and then select an

item from the displayed list.

(p Package: 30007

rPackage Information

Package Mo 30007 Package Group: [Customization = Created By, |Admin User I

Description: |Fateh w3 migration test

| Created On: [September 28, 2006

wiorkfiow: [DEV > TEST > PROD

Percent Complete: |0

Package Lines | Status | 12 Motes (51 References |Llser Dt |

Assigned User: [Carolyn Sayer & Priority Parent | |
Assigned Group: [tanagement Administrator B Package Type. Priority Seq; |50 ]

Package Status: |In Progress |

<

Type Mame Details Status % Complete  Description Relationship
Related to this Package v
Project  [Whirlwind 2 Mithirlwind 2 Ih Planning 0%
Froject |ERP Senvice Pack- .. [ERP Service Pack- Se...[Business Readiness Sign-0F _ |46% | Run after this Fackage in a A
Run before this Package in 3
Predecessor
Successor

¥

ters in Bold are actively cortroling this Package

Ilew: Reference Attachment VH Add H Remove
Fready

4. Click OK or Save.

The change to the package is saved.
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Deleting References
To delete a reference from the PPM Workbench:
1. Open a package.

For information on how to open a package, see Opening Packages from the
PPM Workbench on page 108.

2. Click the References tab.
3. Select the reference, and then click Remove.
The reference is deleted.
4. Click Save to confirm that you want to delete the reference(s).

5. Click Cancel to back out of the reference and cancel removing (or deleting)
any references.

Adding a Package Line fo an In-Progress Package

You may want to add a package line to a package that is already submitted.
You can add package lines to a package that has a status of In Progress. For
information on how to do this, see Adding Lines to Packages on page 64.

A new package line is not submitted until you save the package. After you save
the package, the new package line is submitted to the first step in the
workflow, and the user can process it separately until it catches up with the
other lines in the package. At submission, the new package line is not
automatically assigned the same status as the other lines.
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5 Managing Packages

Managing Packages in HP Deployment Management

After a package is submitted in HP Deployment Management, it can be
processed and managed. Package management involves copying, merging,
grouping, editing, and deleting packages, modifying package groups, and
cancelling package lines. The following sections address all of these tasks,
except for copying packages. The procedure for copying packages is provided
in Creating Packages by Copying Existing Packages on page 57.

Merging Packages

You can generate a new package by merging two or more existing packages.
This is useful if you want to generate a single package consisting of certain
package lines contained in separate packages.

To merge two packages:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.
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4. On the Query tab, click List.

The Results tab lists all of the existing packages.

5. Select the packages to merge.

To select nonadjacent rows, use the ctrl key. To select adjacent rows, use

the shift key.

(p Package Workbhench

2 | Package Mo Description Workflowy Package Group Package Status

g 20032 Patch w3 migration test DEW = TEST = PROD RETH

C [30029 Upgrade for release 7.0b DEY = TEST = PROD [Upgrade N ew

£ 30019 Fatch wda migration test DEW = TEST = PROD [RETH

E 30002 DEY = TEST = PROD [Customization R

o 30007 Patch w3 migration test DEY = TEST = PROD |Customization In Progress
4 ¥
|1 Package Records Deleted.

6. On the Results tab, click Merge.

The Merge Package window opens to the Options tab.

Merged Package Information:

Copy Header From: |30029 | Mew Package No [m

Description: Copy of 30029,30019

oo

Warkflow: |DEY = TEST = PROD

Options | Details |

Copy Package Lines? (3) yes O Mo
CopyClosed Lines? (3) yes O No

Copy Cancelled Lings? =) ygg &) No

Copy Header's Notes? (5 veg
Copy Header's User Data? 3 veg

Submit New Package?

) Mo
O Mo

\Luaumg complete.

7. In the New Package Number field, you can either leave the generated
package number, or type a different unique package number.
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10.

1.

. In the Workflow field, you can leave the default workflow name, or select a

different one in the auto-complete list.
On the Options tab, select Yes or No for the listed options.
Click OK.

The Package Workbench prompts you to indicate whether you want to edit
the new (merged) package.

To edit the package, click Yes. To save and close the package, click No.

Creating New Package Groups

It is often useful to link a new package to a package group for tracking and
reporting purposes. After you link packages to package groups, you can use the
package group to search for packages or in building custom portlets. You
create new package groups from the Package Workbench.

To create a package group:

1.
2.

Managing Packages

Log on to PPM Center.
From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.

From the Package menu, select New Package Group.

€D HP Project and Porifolio Management Workbench: Admin User ([admin) on kintana (rmiz/ammvitgl002:48001/KintanaSenver) :
File Edit Tools Mavigate Window BEEHEEEN Product Infarmation

SLUCIBLIEUS (o Package Workh)
Ceployment Mamt)
Time Mgmt

Package Mo
30032

Workflow Package Group Package Status
DEV = TEST = PROD Mew

Dashboard 30028 - I DEV > TEST > PROD [Upgrade New
30018 Patch vda migration test DEY = TEST = PROD MNew
@ 30008 DEY = TEST = PROD |Custamization Mew

Results Query

Canfiguration
Sys Admin

30007 Patch w3 migration test DEV = TEST = PROD |Customization In Progress

123



The Validation: KNTA - Package and Request Groups window opens and
displays the existing groups for packages and requests.

.(iD Validation : PPM - Package and Request Groups 3

t Groups

Hame: | FRiHs and R

Diescription |grnupmgs for packages and reguests

Enabled

Use inWorkflow? []

Component Type |Drop Crowwn List

validated By: || st

l Used By H Ownership l

Walidation Values:
Seq  Code Mearing Description Enabled  Default
TCUSTOMIZATL.. [Customization  |Customization |V &l
2|SETUR Setup Setup v I
3[UPGRADE Upgrade Upgrade i &l
+e

[ QK ] Cancel

I|Ready (Read-Only, Seed Data)

5. Click New.

The Add Validation Value window opens to the Value Information tab.

Walue Information I User Data I

Coce: ”

Meaning: |

Deszc: |

Enable?

Default: |:|

ok ] aed [ cencel |

\Read\f

6. In the Code field, type the token name for the new Package Group list item.

7. In the Meaning field, type the name to display for this item in the Package

Group list.
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8. In the Desc field, type a short description of the package group.
9. To disable the new list value, clear the Enable? checkbox.

10. To make this value the default selection in the Package Group list, select
the Default checkbox.

11. Click OK.

Editing Package Groups

You can edit existing package groups from within the PPM Workbench. You
can only change the KNTA Package and Request Groups Validation list if you
have the required access grants and security privileges. For information about
the licenses and access grants required to work with packages in HP
Deployment Management, see the Security Model Guide and Reference.

Before you add or edit any package groups, consult your application
administrator. Package groups are typically generated to adhere to specific
business application standards.

To edit a package group:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Deployment Mgmt > Packages.
The Package Workbench opens.
4. Select Package > New Package Group.

The Validation: KNTA - Package and Request Groups window opens and
lists existing package groups.
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5. Select the package group you want to change, and then click Edit.
The Edit Validation Value window opens.

€D Edit Validation Value

“alue Infarmation I User Data I

Meaning: |Setup |

Desc: |Setup |
Enable? Default: |:|

[Lox || Aeey [ cance

‘Fx’eady

6. Edit the field values, as necessary, and then click OK.

The new validations are added to the Validation: KNTA - Package and
Request Groups window.

7. Click OK.
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Deleting Packages

You can delete packages from the Packages Workbench.
To delete a package:
1. Log on to PPM Center.
2. From the menu bar, select Open > Administration > Open Workbench.
The PPM Workbench opens.
3. From the shortcut bar, select Deployment Mgmt > Packages.
The Package Workbench opens.
4. To see a list of all the packages, on the Query tab, click List.
The Results tab displays the packages list.

5. Select the packages you want to delete, and then click Delete.

) To select nonadjacent rows, press and hold the ctrl key. To select adjacent
rows, press and hold the shift key.

The Packages Workbench prompts you to confirm that you want to delete
the package.

6. Click Yes.
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Cancelling Package Lines

In some instances, you might want to cancel package lines because, for
example, the files are out of date or are no longer required. You use the
Package Workbench to cancel package line.

To cancel a package line:

1.
2.

128

Log on to PPM Center.
From the menu bar, select Open > Administration > Open Workbench.

The PPM Workbench opens.

. From the shortcut bar, select Deployment Mgmt > Packages.

The Package Workbench opens.
To see a list of all of the packages, on the Query tab, click List.
The Results tab displays the list.

Select a package that contains lines you want to cancel, and then click
Open.

The Package window opens.

On the Package Line tab, select the package line to cancel.

From the menu bar, select Package > Cancel Package Line.

(D HP Project and Porifolio Managem
File Edit Tools Mavigate Window B3

rkbench: Admin User (admin) on kintana (rmi://ammvitgl002:48001/KintanaSever)
duct Information

Demand Mgmt ]

Deployment Mgmtlf—— —————
> [PackageMo  MewPackage Group Package Group ackage Status
Timewgrt [l § 30032 t DEV > TEST » PROD New
EER==== e = |
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Workbench, 36
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package line execution log in the
Workbench, 35
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Workbench, 37
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Workbench, 38

package workflow step information URL in
the Workbench, 38

adding

attachments to packages, 95
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existing packages to packages in
Workbench, 72

existing requests to packages, 103
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Workbench, 80

notes to packages in the standard interface,

notes to packages in Workbench, 68, 117

package line to in-progress package in
Workbench, 120

package lines in Workbench, 64

packages to packages, 98

packages to packages in the Workbench, 73

programs to packages, 100

programs to packages in Workbench, 75

projects to packages, 101
projects to packages in Workbench, 76
references to packages, 94
references to packages in Workbench, 69,
118
releases to packages, 102
releases to packages in the Workbench, 78
requests to packages, 104
requests to packages in the Workbench, 82
tasks to packages, 106
tasks to packages in the Workbench, 83
URLSs to packages, 107
URLSs to packages in the Workbench, 85
approving
packages, 90
attachments
adding to packages from the standard
interface, 95

C

cancelling
package lines in the Workbench, 128

condition workflow steps, 16

configuring
package groups in Workbench, 125
package lines in Workbench, 64
packages general information in
Workbench, 63
copying
creating packages in the Workbench, 57
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creating
package groups in Workbench, 123
packages, 47
packages as references in the Workbench,
60, 62
packages in the Workbench, 55
packages using copy in the Workbench, 57

custom object types definition, 15

D

decision workflow steps, 16

deleting
package references in Workbench, 120
packages in Workbench, 127

Demand Management
integrating with Deployment Management,
20

Deployment Management, 20
integrating, 19
integrating with version control, 19
integration with third-party applications,

20
packages, 10
process, 10

using the standard interface, 13
using the Workbench, 13

Deployment management
environment components, 18

E

Environment Workbench, 51

environments
defined for packages, 48
for deployment management, 18
verifying in the Environment Workbench,
51

execution workflow steps, 16

integrating
Deployment Management, 19
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integrating with Demand Management, 20

M

managing
packages in the Workbench, 121

merging packages in Workbench, 121
migrators, defined, 15

My Packages portlet
opening packages from, 90

N

notes
adding to packages from the standard
interface, 93
adding to packages in Workbench, 68, 117

notifications
links to packages, 90

(o)

object types
custom objects definition, 15
defining in Workbench, 52
definition, 14
migrator definition, 15
standard objects definition, 15
where defined, 26

opening
packages, 89
packages from My Packages portlet, 90
packages from the Search Packages page,
89
packages in the Workbench, 108

P

Package Information section
Package window, 32

Package window
Package Information section, 32

Package Workbench, 55
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, 23

accessing decision detail in Workbench, 38

accessing graphical view in Workbench, 36

accessing line execution log in the
Workbench, 35

accessing line permissions in the
Workbench, 37

accessing line transaction history in
Workbench, 38

accessing package execution history in the
Workbench, 36

accessing workflow step information URL
in the Workbench, 38

adding attachments from the standard
interface, 95

adding existing packages in Workbench, 72

adding existing requests, 103

adding existing requests in Workbench, 80

adding line to in-progress package in
Workbench, 120

adding notes from the standard interface,
93

adding notes in Workbench, 68, 117

adding package lines in Workbench, 64

adding packages, 98

adding packages in the Workbench, 73

adding programs, 100

adding programs in Workbench, 75

adding projects, 101

adding projects in Workbench, 76

adding references, 94

adding references in Workbench, 69

adding references to Workbench, 118

adding releases, 102

adding releases in the Workbench, 78

adding requests, 104

adding requests in the Workbench, 82

adding tasks, 106

adding tasks in the Workbench, 83

adding to packages, 96

adding URLs, 107

adding URLs in the Workbench, 85

approving, 90

cancelling package lines in the Workbench,
128

checking status in the Workbench, 109

configuring general information in
Workbench, 63

creating, 47

creating by copying in the Workbench, 57

creating by referencing in the Workbench,
60, 62

creating in the Workbench, 55

creating package groups in Workbench,
123

defined, 10, 14

deleting in Workbench, 127

deleting references in Workbench, 120

editing package groups in Workbench, 125

in the standard interface, 27

in the Workbench, 31

managing in the Workbench, 121

merging in Workbench, 121

opening, 89

opening from email notification links, 90

opening in the Workbench, 108

package detail page header section, 29

package detail page Notes section, 30

package detail page Reference section, 30

package detail page Status section, 29

processing, 88

processing in the Workbench, 108

processing packages through decisions in
the Workbench, 113

processing packages through executions in
the Workbench, 115

processing steps in the Workbench, 110

processing through workflow steps in
Workbench, 110

reference relationships, 41

submitting, 86

submitting in the Workbench, 86

updating references in the Workbench, 118

Workbench package window Notes tab, 39

Workbench package window Package
Lines tab, 33

Workbench package window References
tab, 40
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Workbench Package window Status tab, 34
workflows defining environments, 48

predecessor reference relationships, 41, 46

processing

packages, 88

packages in the Workbench, 108, 110

packages through decisions in the
Workbench, 113

packages through executions in the
Workbench, 115

packages through workflow steps in
Workbench, 110

programs
adding to packages, 100
adding to packages in Workbench, 75

projects
adding to packages, 101
adding to packages in Workbench, 76

R

references

added to packages in Workbench, 118

adding attachments to packages from the
standard interface, 95

adding existing packages to packages, 96

adding existing packages to packages in
Workbench, 72

adding existing references to packages, 103

adding existing requests to packages in
Workbench, 80
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