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Support

Please visit the HP OpenView Web site at:

http://openview.hp.com/ 

There you will find contact information and details about the products, services, and support that HP 
OpenView offers.

You can go directly to the HP OpenView Web site at:
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• Training information

• Support program information
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Chapter 1
Overview

This overview covers the following topics:

• OVPI and Cisco Gateway Statistics

• Folders and Reports

• Integration with NNM

• Editing Reports

• Sources for Additional Information

OVPI and Cisco Gateway Statistics

The Cisco IP Telephony Statistics Report Pack contains interactive reports designed to 
highlight Cisco CallManager resources that are underutilized or imbalanced. Use the reports 
in this package to display performance information for the following metrics: 

• CAS channel usage

• PRI channel usage

• FXO port usage

• FXS port usage

• Total call volume handled by an instance of a CallManager

• Time spent in different states by channels of a given gateway

The figure below shows a Cisco CallManager, a Cisco GSU, the Cisco GSU Datapipe, and an 
OVPI server running the Cisco IP Telephony Statistics Report Pack. 

The Cisco GSU (Gateway Statistics Utility) is a drop-in module for CiscoWorks IP Telephony 
Environment Monitor. The Cisco GSU collects performance statistics for Media Gateway 
Control Protocol (MGCP) gateways controlled by Cisco CallManager. The Cisco GSU Datapipe 
includes a preprocessor that reformats output from the Cisco GSU. After reformatting data, 
7



Folders and Reports
the datapipe imports the results into OVPI. The Cisco IP Telephony Statistics Report Pack 
adds report templates, adds new objects to OVPI’s object model, and configures OVPI to 
summarize and aggregate the data imported by the Cisco GSU Datapipe.

New Objects for the Object Model

An object is any item that has performance data or property information associated with it. 
Devices, customers, and locations are objects categories that belong to OVPI’s default object 
model. When you select an object in the object model, you refresh the right side of the Object/
Property Management window. Under General Tasks, you will see a list of forms, under Object 
Specific Tasks, you will see a list of forms, and under Object Specific Reports, you will see a list 
of reports.

The object tree changes each time you install a new report pack. The Cisco IP Telephony 
Statistics package adds the following object categories to the object model:

• Cluster

• CallManager

• Gateway

• IP_Phone

Version History

Folders and Reports

If you are using the Management Console, you will access the reports in Cisco IP Telephony 
Statistics by navigating the object model. If you are accessing reports on the web, you will see 
four report folders: 

• CallManager Cluster

Version RNS Version and Date Features/Enhancements

1.0 RNS 3.0 - May 2003 32 reports
Cisco GSU Datapipe

2.0 RNS 4.0 - October 2003 OVPI Object Manager support
Change Forms:
• Configure a New CallManager Cluster
• Assign CallManagers to Clusters
• Configure Gateway Thresholds
• Configure CallManager Thresholds
• Configure Channel/Port Thresholds

2.0 RNS 5.0 - April 2004 OVPI 5.0 support

3.0 RNS 6.0 - August 2004 Oracle support
Upgrade package (to_3.0)
8



Chapter 1
• CallManager

• Gateway

• Location

CallManager Cluster Folder

The reports in the CallManager Cluster folder present data aggregated for CallManagers that 
belong to a particular cluster. These reports allow you to drill down from a given CallManager 
Cluster to usage patterns and trends. In addition, these reports allow you to correlate the 
usage patterns for the CallManagers in the cluster. This folder contains the following reports: 

• Cluster Busy Hour Utilization Correlation

• Cluster CAS Channel Activity Summary

• Cluster Call Activity Summary

• Cluster Call Activity Top Ten

• Cluster FXO Port Activity Summary

• Cluster FXS Port Activity Summary

• Cluster Forecast

• Cluster PRI Channel Activity Summary

• Cluster Peak Utilization Correlation

• Cluster Port Utilization Top Ten

CallManager Folder

The reports in the CallManager folder present data aggregated at the CallManager level. 
These reports allow you to drill down from a given CallManager cluster to usage patterns and 
trends. This folder contains the following reports:

• CallManager CAS Channel Activity Summary

• CallManager Call Activity Summary

• CallManager Call Activity Top Ten

• CallManager FXO Port Activity Summary

• CallManager FXS Port Activity Summary

• CallManager Forecast

• CallManager PRI Channel Activity Summary

• CallManager Port Utilization Top Ten

Gateway Folder

The reports in the Gateway folder provide gateway summarization and reporting features, 
allowing you to drill down from a given gateway to usage patterns and trends at the following 
levels: gateway, DS1, and DS0. This folder contains the following reports:
9



Folders and Reports
• CAS Channel Activity Summary

• DS0 Usage Summary

• DS1 Usage Summary

• FXO Port Activity Summary

• FXS Port Activity Summary

• Gateway Forecast

• PRI Channel Activity Summary

Location Folder

The reports in the Location folder summarize the above data based on the geographic location 
or a user-defined group. This folder contains the following reports:

• Channel Usage Summary By Location

• DS1 Usage Summary Correlation By Location

• Gateway Forecast By Location

• Gateway Summary By Location

• Location Forecast

• Location Summary

• Location/Gateway Top Ten

The Generic Reports

The preceding lists of reports contain multiple instances of four generic report types:

• Top Ten

• Summary

• Forecast

• Correlation

Top Ten reports identify the heavily utilized CallManager Clusters, CallManagers, gateways 
or locations based on yesterday’s resource utilization levels.

Summary reports provide historical data for groups of devices organized by CallManager 
Cluster, CallManagers, gateways, DS1 and other user-defined groups. Use these reports to 
determine if recent excess traffic is a short-lived anomaly or a longer-term trend that may 
require corrective action. 

Forecast reports show estimates of future port utilization. These reports highlight items that 
are trending toward over-utilization and under-utilization. Use these reports to find out which 
CallManager Clusters, CallManagers, gateways, and locations may be over- or under-utilized 
in the near future. 

Correlation reports display the usage metrics for various devices (or group of devices) on a 
single graph. Use these reports to determine if traffic is distributed evenly among the 
members of the group.
10



Chapter 1
Integration with NNM

If your NNM server and your OVPI server are integrated, you can blend the trending analysis 
produced by Cisco IP Telephony Statistics will the diagnostic and fault management 
capabilities of NNM. The NNM operator can reach any report in Cisco IP Telephony Statistics 
by opening the Report Launchpad window. 

You can integrate these two systems more closely by installing the thresholds sub-package 
that comes with Cisco IP Telephony Statistics. If you install the thresholds sub-package, 
OVPI will send threshold traps to your NNM server, and your NNM server will display these 
traps as alarms in the NNM alarm browser. 

The thresholds sub-package contains default thresholds. For a description of the defaults in 
the sub-package and the change forms related to thresholds, see Resource Thresholds and 
Associated Change Forms on page 34. 

Editing Reports

You can easily change the contents of a report by editing parameters and selecting a different 
view option for individual tables and graphs. For details about view options for tables and 
graphs, see Chapter 10, Editing Tables and Graphs.

Editing a parameter applies a constraint to the report, eliminating the data you are not 
interested in seeing. If you edit the Gateway parameter, data for all gateways except the 
gateway you typed in the Gateway field drops from the report. If you edit Gateway Location, 
data for all locations except the location you typed in the Gateway Location field drops from 
the report. You may apply multiple constraints at once. Cisco IP Telephony Statistics 3.0 
supports the following parameters:

• CallManager Cluster Name

• CallManager Name

• Gateway Name

• Gateway Location

If you are using the Web Access Server to view reports remotely, edit parameters by clicking 
the edit parameters icon at the bottom right-hand corner of the report. When the Edit 
Parameters window opens, enter the constraint in the field and click Submit. 

If you are using Report Viewer, select Edit > Parameter Values from the menu bar. When the 
Modify Parameter Values window opens, click the Current Value field. Type a new value and 
click OK.

Sources for Additional Information

This user guide contains samples of some of the reports in the package. The demo package 
that comes with Cisco IP Telephony Statistics contains samples of every report in the 
package. If you have access to the demo package, and you want to know what fully-populated 
reports look like, install the demo package. Like real reports, demo reports are interactive. 
Unlike real reports, demo reports are static.
11



Sources for Additional Information
The Cisco IP Telephony Statistics Report Pack and the IP Telephony Call Detail Report Pack 
are designed to share property data for the objects they have in common. Sharing property 
data eliminates duplication and simplifies administration. However, installing both packages 
is not required, since they operate independently.

For information regarding the latest enhancements and any known issues, refer to the 
following document:

Cisco IP Telephony Statistics Report Pack 3.0 Release Statement

You may also be interested in the following documents: 

• Common Property Tables 3.5 User Guide

• IP Telephony Call Detail Report Pack 2.0 User Guide

• IP Telephony Call Detail Report Pack 2.0 Release Statement

Manuals for the core product, OVPI, and manuals for the reporting solutions that run on 
the core product can be downloaded from the following site:

http://www.hp.com/managementsoftware

Select Technical Support > Product Manuals to open the Product Manual Search page. Manuals for 
OVPI are listed under Performance Insight. Manuals for OVPI report packs and value-add 
components for NNM are listed under Reporting and Network Solutions. 

Every title listed under Reporting and Network Solutions indicates the month and year of 
publication. If a user guide is revised and reposted, the date of publication will change even if 
the software version number does not change. Since updated user guides are posted to this 
site on a regular basis, you should check this site for updates before using an older PDF that 
may not be the latest PDF available.
12



Chapter 2
The Upgrade Install

This chapter covers the following topics: 

• Guidelines for a Smooth Upgrade

• Upgrading Version 2.0 to Version 3.0

• Package Removal

Guidelines for a Smooth Upgrade

When you insert the RNS 6.0 CD, launch the package extraction interface, and select OVPI 
report packs for installation, the install script extracts every OVPI package from the CD and 
copies the results to the Packages directory on your system. Once the extraction process 
finishes, the install script prompts you to launch Performance Insight and start Package 
Manager. Upgrading to Cisco IP Telephony 3.0 is an easy and straightforward task:

• Install the 2.0-to-3.0 upgrade package

• Remove Cisco GSU Datapipe 2.0

• Install Cisco GSU Datapipe 3.0

Before running Package Manager, review the following guidelines. 

Prerequisites

Make sure the following software is already installed before upgrading to version 3.0:

• OVPI 5.0

• Any service pack available for OVPI 5.0

• Common Property Tables 3.0 or higher

Common Property Tables

If you are running version 2.2 of Common Property Tables, you must upgrade your current 
version to version 3.0 or higher. When you install the upgrade package (either 2.2-to-3.0 or 
3.0-to-3.5), do not install anything else at the same time. Install the upgrade package for 
Common Property Tables and only the upgrade package for Common Property Tables.
13



Upgrading Version 2.0 to Version 3.0
Distributed Environments

If your system is distributed, every server must be running OVPI 5.0 and all the service packs 
currently available for OVPI 5.0. Following is an overview of the installation procedure for a 
distributed environment:

1 Disable trendcopy on the central server.

2 At the central server:

• Install the upgrade package for Common Property Tables; deploy reports

• Install the 3.0 upgrade package for Cisco IP Telephony Statistics 3.0; deploy reports

3 At each satellite server:

• Install the upgrade package for Common Property Tables

• Install the 3.0 upgrade package for Cisco IP Telephony Statistics.

• Remove Cisco GSU Datapipe 2.0

• Install Cisco GSU Datapipe 3.0

4 Re-enable trendcopy on the central server.

When you installed Cisco IP Telephony Statistics 2.0 in a distributed environment, you had to 
set up connections with satellite server databases, configure trendcopy pull commands, and 
switch off aggregations on the satellite servers. If you recently upgraded from OVPI 4.6 to 
OVPI 5.0, the following configuration changes, which you made the first time when you 
installed version 2.0, will have to be redone:

• Set up connections with satellite server databases (using the Add Database Wizard)

• Configure trendcopy pull commands again. 

For details, see Chapter 5, Distributed Systems.

Upgrading Version 2.0 to Version 3.0

Perform the following tasks to upgrade from version 2.0 to version 3.0:

• Task 1: Stop OVPI Timer and extract packages from the RNS 6.0 CD

• Task 2: Install the upgrade package for Common Property Tables

• Task 3: Install the upgrade package for Cisco IP Telephony Statistics

• Task 4: Remove Cisco GSU Datapipe 2.0

• Task 5: Install Cisco GSU Datapipe 3.0

• Task 6: Restart OVPI Timer

Task 1: Stop OVPI Timer and extract packages from the RNS CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, type one of the following:
14



Chapter 2
HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the RNS 6.0 CD. On Windows, a Main Menu displays automatically; on UNIX, 
mount the CD, navigate to the top-level directory for the CD drive, and type the setup 
command. 

4 Select OVPI report packs by typing 1 in the choice field and pressing Enter. The install 
script displays a percentage complete bar. When extraction finishes, the install script 
starts Package Manager. The Package Manager welcome window opens.

If you navigate to the Packages directory on your system, you will see the following folders 
under the IP Telephony folder:

• Cisco_IP_Telephony_Statistics.ap

• Cisco_IP_Telephony_Statistics_Demo.ap

• Cisco_IP_Telephony_Statistics_Location.ap

• Cisco_IP_Telephony_Statistic_Thresholds.ap

• UPGRADE_Cisco_IP_Telephony_to_3.ap

• UPGRADE_Cisco_IP_Telephony_Statistics_Location_to_3.ap

You are about to install the two upgrade packages. Under Cisco GSU Datapipe, you will see 
the following folder:

• CiscoGSU_Datapipe.ap

Task 2: Upgrade to Common Property Tables 3.0 or higher

If you are running an earlier version of Common Property Tables, upgrade to Common 
Property Tables 3.0 or higher. If you are not running any version of Common Property Tables, 
skip this task. If you are upgrading, observe these rules:

• Do not install any other package with the upgrade package; install the Common Property 
Tables upgrade package and only the Common Property Tables upgrade package. 

• When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you disable the default, the forms that come with Common Property Tables will not be 
deployed.

• When the install finishes, click Done to return to the Management Console.

If you need help with the upgrade, refer to the Common Property Tables 3.5 User Guide. 

Task 1: Upgrade Cisco IP Telephony Statistics

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or select a different directory if 
necessary. 

4 Click Next. The Report Deployment window opens; accept the default for Deploy Reports 
and enter your username and password for the OVPI Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following packages:
15



Package Removal
• UPGRADE_Cisco_IP_Telephony_Statistics_to_3

• UPGRADE_Cisco_IP_Telephony_Statistics_Location_to_3

7 Click Next. The Type Discovery window opens. Disable the default and click Next. The 
Selection Summary window opens. 

8 Click Install. The Installation Progress window opens; when installation is complete, a 
package installation complete message appears.

9 Click Done to return to the Management Console. 

Task 2: Remove the Cisco GSU Datapipe 2.0

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Uninstall.

4 Click Next. The Report Undeployment window opens.

5 Click Next. The Package Selection window opens.

6 Click the check box next to the following package:

• CiscoGSU_Datapipe 2.0

7 Click Next. The Selection Summary window opens.

8 Click Uninstall. The Progress window opens. When the uninstall process is complete, a 
package removal complete message appears.

9 Click Done.

Task 3: Install the Cisco GSU Datapipe 3.0

1 Start Package Manager. The Welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. 

4 Click Next. The Report Deployment window opens. Disable the default for Deploy Reports 
and click Next. The Package Selection window opens. 

5 Click the check box next to the following package:

• CiscoGSU_Datapipe 3.0

6 Click Next. The Type Discovery window opens. Disable the default and click Next. The 
Selection Summary window opens. 

7 Click Install. The Installation Progress window opens. When the installation finishes, a 
package installation complete message appears.

8 Click Done. 

Package Removal 

If you remove a report pack, the associated tables and all the data in those tables will be 
deleted. If you want to preserve the data in those tables, archive the data before removing the 
report pack.
16



Chapter 2
Follow these steps to uninstall Cisco IP Telephony Statistics:

1 Log on to the system. On UNIX systems, log on as root.

2 Stop OVPI Timer and wait for processes to stop running.

Windows: Do the following:

a From the Control Panel, select Administrative Tools  Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.

UNIX: As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer stop

— Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. 

a Launch Performance Insight and select Management Console.

b Select Tools  Package Manager

The Package Manager welcome window opens.

4 Click Next. The Packages Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens. Accept the default for Undeploy 
Reports; accept the defaults for application server name and port. Enter your username 
and password for the OVPI Application Server. 

7 Click Next. The Package Selection window opens.

8 Click the check box next to the following packages:

• Cisco IP Telephony Statistics 

• Cisco IP Telephony Statistics_Location

• Cisco IP Telephony Statistics_Thresholds (if installed)

• Cisco IP Telephony Statistics _Demo (if installed)

9 Click Next. The Selection Summary window opens. 

10 Click Uninstall. The Progress window opens. When the uninstall process is complete, a 
package removal complete message appears.

11 Click Done.

12 Restart OVPI Timer.

Windows: Do the following:

a From the Control Panel, select Administrative Tools  Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

UNIX: As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer start
17



Package Removal
— Sun: sh /etc/init.d/ovpi_timer start

Removing Cisco IP Telephony Statistics automatically removes the Cisco 
GSU Datapipe even if you do not select the datapipe for removal.
18



Chapter 3
The New Install

This chapter covers the following topics: 

• Guidelines for a smooth installation

• Prerequisites related to OVPI and Cisco

• Installing IP Telephony Statistics 3.0

• Options for viewing reports

• Package removal

Guidelines for a Smooth Install

The reporting solutions that run on OVPI consist of two installable packages, a report pack 
and a datapipe. Some reporting solutions have multiple datapipes. When you install a 
datapipe, you configure OVPI to collect a specific type of performance data at a specific polling 
interval. When you install a report pack, you configure OVPI to summarize and aggregate 
performance data in a specific way. 

When you insert the RNS 6.0 CD, launch the package extraction interface, and select OVPI 
report packs for installation, the install script extracts every OVPI report pack from the CD 
and copies the results to the Packages directory on your system. When the extraction process 
finishes, the install script prompts you to launch Performance Insight and start Package 
Manager. Review the following guidelines before running Package Manager.

Prerequisites

Cisco IP Telephony Statistics 3.0 has the following prerequisites:

• OVPI 5.0

• Any service packs available for OVPI 5.0

• A functioning CallManager environment

• CiscoWorks

• Cisco GSU 1.0 or Cisco GSU 2.0
19



Guidelines for a Smooth Install
Upgrading Common Property Tables

If you are running an earlier version of Common Property Tables, you must upgrade your 
version to version 3.0 or later. If you are not running any version of Common Property Tables, 
you have nothing to do since Package Manager will install the latest version of Common 
Property Tables for you.

Do not install the upgrade for Common Property Tables and other packages at the same time. 
Install the upgrade package for Common Property Tables and only the upgrade package for 
Common Property Tables. For more information about installing and using this package, refer 
to the Common Property Tables 3.5 User Guide.

Distributed Environments

If you intend to run Cisco IP Telephony Statistics in a distributed environment, the 
installation procedure is more complicated. Here is an outline of the steps involved when 
installing Cisco IP Telephony Statistics in a distributed environment:

1 Verify that every server is running OVPI 5.0 and all available service packs for OVPI 5.0

2 Disable trendcopy on the central server.

3 If you are running an earlier version of Common Property Tables, upgrade to 3.0 or 
higher.

4 Install Cisco IP Telephony Statistics 3.0 on the central server; deploy reports

5 For each satellite server:

• Upgrade to Common Property Tables 3.0 or higher

• Install Cisco IP Telephony Statistics 3.0

• Install the Cisco GSU Datapipe 3.0

6 Re-enable trendcopy on the central server.

After the installation is complete, you must set up connections with satellite server databases, 
configure trendcopy pull commands, and switch off aggregations above the hourly level on the 
satellite servers. For details, see Chapter 5, Distributed Systems.

Prerequisites Related to Cisco

A functioning CallManager environment consists of CallManager systems, MGCP gateways, 
and phones. 

Installing CiscoWorks and Cisco GSU

CiscoWorks is available on Cisco CD One, Fifth Edition for Windows. Please refer to 
documentation published by Cisco for more information about installing, configuring, and 
troubleshooting CiscoWorks. 

Cisco GSU can be downloaded from the following URL: 

http://www.cisco.com/cgi-bin/tablebuild.pl/cw-gtwystat-util 

You need a Cisco CCO login to download Cisco GSU. If you do not have a login, contact your 
local Cisco representative. 
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Download both the Cisco GSU readme and the executable installation file.

Read the readme and run the GSU installation file. The CiscoWorks menu window opens.

Configuring Cisco GSU

To configure Cisco GSU, do the following:

1 Create a data collection file.

2 Import the data collection file.

3 Schedule data collection.

Creating a Data Collection File

Create a data collection file that includes a list of the gateways you want to monitor. Use the 
following syntax rules:

Field Description

Device Name Required. The device name or IP address for the CCM 
system.

Device Capabilities Required. The only valid value is “CCM”.
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An example entry is:

CCMSys1,CCM,MCS,3.1, 

For more information, refer to the online help.

Importing the Data Collection File

To import the data collection file:

1 From the CiscoWorks menu, select Gateway Statistics.

2 From the Gateway Statistics menu, select Device Management.

3 From the Device Management menu, select Device Import. When you are prompted, enter 
the path and name of the data collection file you created. 

4 Close the Device Import window. 

Scheduling Data Collection

Schedule data collection by defining study parameters:

1 From the CiscoWorks menu, select Gateway Statistics.

Device Family Optional. Describes the CCM platform.

Software Version Required. The version number of the CCM software. 
Valid values are “3.1” and “3.2”.

HTTP Server Optional. The DNS name or IP address of the HTTP 
server in the CCM cluster. If this field is not specified, the 
address or the name of the CCM system is used.

Field Description
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2 From the Gateway Statistics menu, select Study Management. The Define Study 
Parameters window opens. 

3 Schedule data collection by accepting or modifying the defaults for polling interval and 
schedule.

4 Click OK.

Installing Cisco IP Telephony Statistics 3.0

This section covers the following tasks:

• Task 1: Stop OVPI Timer and extract packages from the RNS 6.0 CD

• Task 2: Upgrade to Common Property Tables 3.0 or higher

• Task 3: Remove Thresholds Module 4.0

• Task 4: Install these packages:

— Cisco IP Telephony Statistics 3.0

— Cisco IP Telephony Statistics Location

— Cisco IP Telephony Statistics Thresholds (optional)

— Cisco GSU Datapipe
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• Task 5: Restart OVPI Timer

Task 1: Stop OVPI Timer and extract packages from the RNS CD

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the RNS 6.0 CD. On Windows, a Main Menu displays automatically; on UNIX, 
mount the CD, navigate to the top-level directory for the CD drive, and type the setup 
command. 

4 Select OVPI report packs by typing 1 in the choice field and pressing Enter. The install 
script displays a percentage complete bar. When extraction finishes, the install script 
starts Package Manager. The Package Manager welcome window opens.

If you navigate to the Packages directory on your system, you will see the following folders 
under the IP Telephony folder:

• Cisco_IP_Telephony_Statistics.ap

• Cisco_IP_Telephony_Statistics_Demo.ap

• Cisco_IP_Telephony_Statistics_Location.ap

• Cisco_IP_Telephony_Statistic_Thresholds.ap

• UPGRADE_Cisco_IP_Telephony_to_3.ap

• UPGRADE_Cisco_IP_Telephony_Location_to_3.ap

Ignore the upgrade packages. Installing the demo package is optional. You may install the 
demo package by itself, or you may install the demo package along with everything else.

Under Cisco GSU Datapipe, you will see the following folder:

• CiscoGSU_Datapipe.ap

Task 2: Upgrade to Common Property Tables 3.0 or higher

If you are running an earlier version of Common Property Tables, upgrade to Common 
Property Tables 3.0 or higher. Observe these rules:

• Do not install any other package with the upgrade package; install the Common Property 
Tables upgrade package and only the Common Property Tables upgrade package. 

• When prompted to accept or disable the option to Deploy Reports, accept the default. If 
you disable the default, the forms that come with Common Property Tables will not be 
deployed. 

• When the install finishes, click Done to return to the Management Console.

If you need help with the upgrade, refer to the Common Property Tables 3.5 User Guide. 
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Task 3: Remove any previous version of the Thresholds Module

There is no upgrade path for the Thresholds Module. The latest version is version 5.0. If you 
are running an earlier version of the Thresholds Module (most likely version 3.0 or possibly 
version 4.0) uninstall this package by starting Package Manager and following the on-screen 
directions for package removal. When the uninstall is complete, click Done to return to the 
Management Console.

Package Manager will install the newest version of the Thresholds Module for you, 
automatically, if and when you select for installation the thresholds sub-package that comes 
with Cisco IP Telephony Statistics. In Task 4, you are directed to install the thresholds 
sub-package. If you install the thresholds sub-package, Package Manager will select and 
install Thresholds Module 5.0 for you.

Task 4: Install Cisco IP Telephony 3.0 and the Cisco GSU Datapipe

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or use the browse feature to select 
a different directory if necessary. 

4 Click Next. The Report Deployment window opens. Accept the default for Deploy Reports; 
accept the default for application server name and port. Type your username and 
password for the OVPI Application Server. 

5 Click Next. The Package Selection window opens. 

6 Click the check box next to the following package:

• Cisco IP Telephony Statistics 3.0 

• Cisco IP Telephony Statistics Location 

• Cisco IP Telephony Statistics Thresholds

• Cisco IP Telephony Statistics Demo [optional]

• Cisco GSU Datapipe 3.0

7 Click Next. The Type Discovery window opens. To run Type Discovery immediately after 
package installation, accept the default.

8 Click Next. The Selection Summary window opens.

9 Click Install. The Installation Progress window opens and the install process begins. When 
the install finishes, a package install complete message appears. 

10 Click Done to return to the Management Console. 

11 Restart OVPI Timer.

Windows: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

12 Click Next. The Type Discovery window opens. 
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13 Type Discovery is not required for Cisco IP Telephony Statistics and CiscoGSU_Datapipe. 
If no other packages are to be installed at the same time, clear the Discover check box and 
click Next. The Selection Summary window opens. 

14 Click Install. The Installation Progress window opens; when installation is complete, the 
following message appears: Report Package: Completed.

15 Click Done. 

Task 5: Restart OVPI Timer.

Windows: Do the following:

a From the Control Panel, select Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

UNIX: As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer start

— Sun: sh /etc/init.d/ovpi_timer start

Viewing Reports

Before reports can be viewed using a web browser, they must be deployed. If you enabled the 
Deploy Reports option during the preceding installation procedure, the reports in this 
package are deployed and available for remote viewing. 

The method of report viewing available depends on how OVPI was installed. If the client 
component is installed on the user’s system, the user has access to Report Viewer, Report 
Builder, and the Management Console. If the client component is not installed on the user’s 
system, the only way the user can view reports is to view them remotely on the web.

For more information about the client components, refer to the Performance Insight 
Installation Guide. For more information about deploying, viewing, and undeploying reports, 
refer to the Performance Insight Guide to Building and Viewing Reports.

Package Removal 

If you remove a report pack, the associated tables and all the data in those tables are deleted. 
If you want to preserve the data in those tables, archive the data before removing the report 
pack. Follow these steps to uninstall Cisco IP Telephony Statistics:

1 Log on to the system. On UNIX systems, log on as root.

2 Stop OVPI Timer and wait for processes to stop running.

Windows: Do the following:

a From the Control Panel, select Administrative Tools  Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.
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UNIX: As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer stop

— Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens.

4 Click Next. The Package Location window opens.

5 Click Uninstall.

6 Click Next. The Report Undeployment window opens. Accept the default for Undeploy 
Reports; also accept the defaults for application server name and port. Type your 
username and password for the OVPI Application Server. 

7 Click Next. The Package Selection window opens.

8 Click the check box next to the following packages:

• Cisco IP Telephony Statistics 

• Cisco IP Telephony Statistics_Location

• CiscoGSU_Datapipe

• Cisco IP Telephony Statistics_Thresholds (if installed)

• Cisco IP Telephony Statistics _Demo (if installed)

9 Click Next. The Selection Summary window opens. 

10 Click Uninstall. The Progress window opens. When the uninstall process is complete, a 
removal complete message appears.

11 Click Done.

12 Restart OVPI Timer.

Windows: Do the following:

a From the Control Panel, select Administrative Tools  Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

UNIX: As root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer start

— Sun: sh /etc/init.d/ovpi_timer start

Removing Cisco IP Telephony Statistics automatically removes the Cisco 
GSU Datapipe even if you did not select the datapipe for removal.
27



Package Removal
28



Chapter 4
Package Configuration

This chapter covers the following topics: 

• Specifying the Source Data Directory

• CallManager Clusters

• Resource Thresholds and Associated Change Forms 

Specifying the Source Data Directory

Before the Cisco GSU Datapipe can begin to collect data, it needs to know where the source 
data files are located. According to the default, the raw data files from Cisco Gateway 
Statistics Utility should be located on the server that is running the Cisco GSU Datapipe. If 
the raw data files are located on a remote server, the Cisco GSU Datapipe can be configured to 
use FTP to retrieve those files.

The default directory for the location of the raw data files is:

${DPIPE_HOME}/data/ImportData/CiscoGSU_Datapipe

The Cisco GSU Datapipe includes a preprocessor. The purpose of the preprocessor is to filter 
the raw data and put the raw data into a format that can be manipulated by the Cisco GSU 
Datapipe. The preprocessor (a perl script, CiscoGSU_PP.pl) produces the following output:

• CManager.dat

• Gateway.dat

• Channel.dat

The preprocessor stores these files in the source data directory. The Cisco GSU Datapipe 
reads the output from the preprocessor and imports the data into the OVPI database using 
the CiscoGSU_Collection.pro file and the following specialized configuration TEEL files:

• CiscoGSU_Cmanager.teel

• CiscoGSU_gateway.teel

• CiscoGSU_channel.teel

Before package installation, the TEEL files are located in: 

{DPIPE_HOME}/packages/CiscoGSU_Datapipe/CiscoGSU_Datapipe.ap

After installation, the TEEL files are located in: 
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{DPIPE_HOME}/packages/CiscoGSU_Datapipe/CiscoGSU_Datapipe.ap

{DPIPE_HOME}/lib

Changing the Source Directory Path

If raw GSU data files are located on a remote system, you must modify a line in a file. Follow 
these steps:

1 Open the {DPIPE_HOME}/scripts/CiscoGSU_Collection.pro file

2 Locate this line: 

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoGSU_PP.pl 

3 Add this to the end of the line:

-f 1 -m <Remote_Host_Name> -u <Username> -p <Password> -r <Remote_directory>

If the data source directory is not the same as the default directory described in the preceding 
section, make the following changes: 

1 Navigate to the appropriate directory (see the discussion above regarding which 
directories are involved).

2 Open the CiscoGSU_Collection.pro file.

3 Locate the following line:

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/bin/CiscoGSU_PP.pl

4 Add this to the end of the line: 

-l <new directory path>

5 Open the following files:

— CiscoGSU_Cmanager.teel

— CiscoGSU_gateway.teel

— CiscoGSU_channel.teel

6 Locate the line beginning with Sourcefile = 

7 Change the path, replacing the existing path with the complete path name to the new 
directory; begin the new path name just after the equals sign (=). The source directory 
specified would normally be the directory created to receive the output from the Cisco 
Gateway Statistics Utility. 

If you make changes to TEEL files after installation, make the same changes 
in both directories.

Leave the filename as specified in the original SourceFile.
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Changing Source Disposition

TEEL files are also used to specify what to do with a data file once the data has been 
imported. The default behavior for the Cisco GSU Datapipe is to delete the preprocessed files. 
Because raw data files are archived, there is no need to archive data output by the 
preprocessor. 

CallManager Clusters

Although the Cisco IP Telephony Statistics package operates without importing custom 
property information, none of the cluster nor location-oriented reports provide meaningful 
data (for example, all CallManagers would be combined into one group called “Location 
Unassigned”).

The Cisco IP Telephony Statistics Report Pack allows the user to place the devices 
(CallManagers and gateways) into logical groups:

• Groups of CallManagers (based on cluster or other criteria)

• Groups of gateways (based on geographic location or user-defined criteria)

The grouping of these objects is enabled by creating a cluster name and assigning 
CallManagers or gateways to the cluster. For example, if the CallManagers s1ccm1 and 
s1ccm2 are assigned to a cluster named cluster1 and similarly if the CallManagers s2ccm1 
and s2ccm2 are assigned a cluster named cluster2, the report pack aggregates the data 
belonging to these four CallManagers into two groups (cluster1 and cluster2).

To get cluster information into reports, configure a CallManager cluster. You see clusters in 
reports immediately after OVPI processes your updated import file. 

Configuring a CallManager Cluster

To configure a CallManager cluster, do the following:

1 Create a cluster name:

a Launch the Management Console.

b Click Objects. The Object/Property Management window opens.
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c Select File > New > Create a new CallManager Cluster. The Configure A New CallManager 
Cluster form opens.

d Enter a name for the cluster and a brief description.

e Click Apply to save changes, OK to save changes and close the form, or Cancel to close 
the form without saving changes.

2 Assign CallManagers or gateways to the cluster:

a From the Object/Property Management window, select View > Change View > Location. 

b Select a location.

c Highlight the Location Unassigned folder.
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d Double-click Assign CallManagers to Clusters under Object Specific Tasks. The form 
opens.

e Highlight a CallManager name in the CallManager List and select the cluster name 
to which it is assigned.

f Click Apply to save changes, OK to save changes and close the form, or Cancel to close 
the form without saving changes.
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Resource Thresholds and Associated Change Forms

Cisco_IP_Telephony_Statistics_Thresholds imposes nine default thresholds for resource 
utilization monitoring. When performance reaches one of these default thresholds, the 
thresholds sub-package sends a trap to the Network Node Manager (NNM). The following 
table describes the condition behind each threshold and the severity of the alarm. 

Modifying Gateway and CallManager Thresholds

Threshold values can be modified, using forms, for a gateway or CallManager. To modify a 
threshold value, do the following:

1 Launch the Management Console.

Threshold Default Condition Severity

PRIOverUtilization 95% 95% of PRI channels or more were 
occupied for each monitored device 
(CallManager or Gateway) during the 
previous day.

Warning

PRIUnderUtilization 5% 5% of PRI channels or less were 
occupied for each monitored device 
(CallManager or Gateway) during the 
previous day.

Warning

CASOverUtilization 95% 95% of CAS channels or more were 
occupied for each monitored device 
(CallManager or Gateway) during the 
previous day.

Warning

CASUnderUtilization 5% 5% of CAS channels or less were 
occupied for each monitored device 
(CallManager or Gateway) during the 
previous day.

Warning

FXOOverUtilization 95% 95% of FXO ports or more were occupied 
for each monitored device (CallManager 
or Gateway) during the previous day.

Warning

FXOUnderUtilization 5% 5% of FXO ports or less were occupied 
for each monitored device (CallManager 
or Gateway) during the previous day.

Warning

FXSOverUtilization 95% 95% of FXS ports or more were occupied 
for each monitored device (CallManager 
or Gateway) during the previous day.

Warning

FXSUnderUtilization 5% 5% of FXS ports or less were occupied 
for each monitored device (CallManager 
or Gateway) during the previous day.

Warning

DeadChan N/A A channel was in OutofService status all 
the time during the previous day.

Warning
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2 Click Objects. The Object/Property Management window opens.

3 Select View > Change View > Cluster. 

4 Select a gateway or cluster.

5 Under Object Specific Tasks, double-click Configure Gateway Thresholds or Configure 
CallManager Thresholds. The form opens. Both forms are similar and the Configure 
Gateway Thresholds form is shown below.

6 Modify the threshold.

7 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.

Modifying Channel/Port Thresholds

The channel/port threshold value (DeadChan) can be modified:

1 Start Report Builder. 

On a Windows system, select Programs > HP OpenView > Performance Insight > Builder. 
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On a UNIX system, cd to $OVPI_HOME/bin and type ./builder.

2 From Report Builder, select File > Open.

3 Open the following file:

%OVPI_HOME%\forms\deploy\admin\Cisco_IPT_Admin_Forms\
Cisco_IPT_Statistics_Forms\ChannelPortThreshConfig.frep

The Configure Channel/Port Thresholds form opens.

4 Modify the threshold.

5 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the 
form without saving changes.
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Distributed Systems

If you intend to run Cisco IP Telephony Statistics as a distributed system across multiple 
servers, and you followed the installation guidelines in the installation chapter, your central 
server is running the report pack and each of your satellite servers is running the report pack 
and the Cisco GSU Datapipe. You are now ready to perform these tasks:

• Configure the central server

• Configure each satellite server

• Verify that all system clocks are synchronized

Configuring the Central Serve

Perform these tasks to configure the central server:

• Set up connections with satellite server databases

• Configure trendcopy pull commands 

Task 1: Set up connections with satellite server databases.

1 Start the Management Console.

2 Click the Systems icon on the lower left. The System/Network Administration pane opens.

3 Right-click the Databases folder. When prompted, select Add OVPI Database. The Add 
Database Wizard opens. 

4 Click Next.

5 Type the hostname and port number for the database you want to add; click Next.

6 Review the Summary. Repeat Steps 4 and 5 for each additional database.

7 Click Finish when you are done. 

Task 2: Configure trendcopy pull commands from the central server to each satellite server.

1 Open the following file:

$DPIPE_HOME/scripts/Cisco_IP_Telephony_Statistics_Daily.pro

2 Modify block0 as follows:

a Remove “#” before each line in block0, including the begin and end lines.
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b Replace SATELLITE_SERVER_1_DATABASE with the satellite server name.

c Replace THIS_MACHINE_DATABASE with the central server name.

3 If there is more than one satellite server, create a copy of block0 for each satellite server 
and repeat step 2 for each block.

4 Save and close:

$DPIPE_HOME/scripts/Cisco_IP_Telephony_Statistics_Daily.pro

Configuring a Satellite Server

Switch off daily aggregations. Follow these steps:

1 Locate the $DPIPE_HOME/lib/trendtimer.sched file.

2 Comment out the lines referencing Cisco_IP_Telephony_Statistics_Daily.pro.

System Clocks

Make sure that the system clock on each satellite server is synchronized with the system clock 
on the central server.

If the satellite server is performing local reporting, or if the 
Cisco_IP_Telephony_Statistics_Location module is installed, do not switch off 
daily aggregations.
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Top Ten Reports

The Cisco IP Telephony Statistics Report Pack contains five Top Ten reports: two cluster 
reports, two CallManager reports, and one location report. The cluster reports aggregate 
statistics for groups of devices belonging to each cluster. The location report aggregates 
statistics for groups of devices at various locations. 

All five versions of the Top Ten reports display average utilization for yesterday and forecasts 
for future performance based on busy hour utilization over the baseline. Since these reports 
are driven by hourly utilization levels that were recorded yesterday, you can expect the 
contents of these reports to change from day to day.

Use this report to gain a good grasp of which CallManagers, CallManager Clusters, or 
locations are ranking worst in terms of resource utilization.

The Cluster Call Activity Top Ten does the following:

• Sorts CallManager Clusters by highest average active calls for yesterday 

• Sorts CallManager Clusters by rate of increase in active calls

The Cluster Port Utilization Top Ten does the following:

• Sorts CallManager Clusters by highest port utilization rate for yesterday 

• Sorts CallManager Clusters by highest rate of increase in port utilization

The CallManager Call Activity Top Ten does the following:

• Sorts CallManagers by highest average active calls for yesterday 

• Sorts CallManagers by rate of increase in active calls

The CallManager Port Utilization Top Ten does the following:

• Sorts CallManagers by highest port utilization rate for yesterday 

• Sorts CallManagers by highest rate of increase in port utilization

The Location/Gateway Top Ten does the following:

• Sorts locations by highest port utilization for yesterday 

• Sorts locations by rate of increase in port utilization

• Sorts gateways by highest port utilization for yesterday

• Sorts gateways by highest rate of increase in port utilization
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The rate of increase is calculated by taking the 30-day forecast and dividing that value by the 
baseline average. The baseline average is derived from averaging all the busy hours reported 
over the baseline period. 

An example Top Ten report, the CallManager Call Activity Top Ten report, is shown.

The Most Active Calls table ranks CallManagers by highest average call volume. Use this 
table to find CallManagers handling the highest number of calls.

The Active Calls Increase table ranks CallManagers based on the F90 forecast value. Use 
this table to find out which CallManagers will be experiencing the highest call volume three 
months from now.
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Summary Reports

Summary reports add depth to Top Ten Reports. They focus on a particular element type—by 
aggregating data according to the element type—and plot a variety of metrics over time. (See 
Chapter 1, Overview for a definition of each metric.) Use summary reports to find out whether 
performance appearing in a Top Ten report reflects a temporary condition or an on-going 
trend. See below for samples of these reports:

• Cluster PRI Channel Activity Summary

• DS1 Usage Summary

All summary reports provide access to hourly, daily, and monthly data. Use the hourly graph 
to identify anomalies and time of day usage patterns. The daily and monthly graphs show 
trends derived from historic activity. 
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The CallManager Cluster Selection table sorts clusters by busy hour call activity, from 
highest to lowest. This table reports events for yesterday. Selecting a cluster updates the PRI 
Channel Activity graph to reflect the activity for the selected cluster. 

In the PRI Channel Activity graph, if the average or busy hour levels for PRI channel 
activity in the hourly graph (see the full report) seem unusual, compare the hourly graph to 
the daily graph. The daily graph gives you a feel for what has been normal for the last few 
weeks. If the hourly graph diverges significantly from the daily graph, yesterday’s levels were 
not typical. The daily tab includes busy hour. If conditions are normal, busy hour and average 
utilization will not converge.
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The CallManager Cluster Selection table sorts clusters by busy hour calls, from highest to 
lowest. Use this table to see which clusters require further investigation and which type or 
types of metrics need more attention. This table reports events for yesterday. Select a cluster 
to view call activity by CallManager in the CallManager Selection table. 

The CallManager Selection table sorts CallManagers by call activity for the selected cluster 
(selected in the CallManager Cluster Selection table), from highest to lowest. This table 
reports events for yesterday. 

The Gateway Selection Table and DS1 Selection Table present data aggregated at 
various levels in the hierarchy. They are similar to the CallManager Cluster and CallManager 
selection tables. In this example, the DS1 selection table is the lowest level in the hierarchy. 
Selecting a DS1 updates the Channel States graph with metrics for that DS1.

The Channel States graph displays the percentage of time spent in various states by the 
channels that belong to the selected DS1. Data is displayed at hourly, daily and monthly 
levels depending upon which tab is selected. If the hourly graph diverges significantly from 
the daily graph, yesterday’s levels were not typical.
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Forecast Reports

The following forecast reports alert you to port over-utilization and port under-utilization:

• CallManager Cluster Forecast

• CallManager Forecast

• Gateway Forecast by CallManager

• Location Forecast

• Gateway Forecast by Location

In the forecast reports, the standard tab compares the baseline to F30, F60, and F90 values. 
The Day of Week tab aggregates data by day, allowing you to see whether overall growth is 
generally the same throughout the week or whether there is a significant difference on a 
particular day. In addition, this view factors “downdays” out of the forecast equation, allowing 
you to see what values are like when they have not been skewed by abnormal levels of 
utilization on certain days.

The graphs vary from report to report. See the following table for details. 

CallManager 
Cluster CallManager

Gateway 
Forecast by 
CallManager Location

Gateway 
Forecast by 
Location

Call Activity X X

PRI Channel 
Activity X X X X X

CAS Channel 
Activity X X X X X

FXO Port 
Activity X X X X X

FXS Port 
Activity X X X X X

Call Activity X X
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Use the Call Activity Forecast bar chart on the standard tab to find out where utilization is 
headed. This particular graph indicates that utilization is expected to remain the same for the 
next 90 days.
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Selecting the Day of Week tab displays a table with baseline busy hour average utilization 
percentages and future estimates on a per day-of-week basis. This particular graph indicates 
that PRI Channel Activity is headed up on certain days of the week (Sundays) and down on 
other days of the week (Wednesdays). 

Selecting the History tab displays the busy hour metrics on which the forecast values are 
calculated.
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Correlation Reports

Correlation Reports compare performance metrics for different resources within the same 
group (for example, CallManagers within a cluster or DS1 within a gateway). These reports 
help identify imbalanced utilization of resources within a group.

The following correlation reports alert you to imbalanced utilization of resources:

• Cluster Busy Hour Utilization Correlation

• Cluster Peak Utilization Correlation

• DS1 Usage Correlation by Location
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Selecting a cluster in the CallManager Cluster Selection table updates all the graphs with 
statistics for the CallManagers that belong to the cluster. In the FXO Port Activity graph, 
the FXO port utilization displays for the two CallManagers in the “West Coast Cluster1” 
cluster.
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Chapter 10
Editing Tables and Graphs

Any table or graph can be viewed in several ways. While the default view is usually adequate, 
you can easily change to a different view. 

If you are using the Report Viewer application, right-click the object to display a list of view 
options. If you are looking at a report using the Web Access Server, follow these steps to 
change the default view of a table or graph:

1 Click Preferences on the links bar.

2 Expand Reports in the navigation frame.

3 Click Viewing.

4 Select the Allow element editing box.

5 Click Apply.

6 Click  (the edit icon) next to the table or graph. 

View Options for a Table

Right-clicking a table, or selecting the edit table icon if you are using the Web Access Server, 
opens a list of table view options.

Select Set Time Period to alter the relative time period (relative to now) or set an absolute time 
period. The Set Time Period window opens.
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View Options for a Table
You may shorten the period of time covered by the table from, for example, 42 days to 30 days 
or to 7 days. If you are interested in a specific period of time that starts in the past and stops 
before yesterday, click Use Absolute Time and select a Start Time and an End Time.

Select Change Constraint Values to loosen or tighten a constraint, thereby raising or lowering 
the number of elements that conform to the constraint. The Change Constraint Values 
window opens. To loosen a constraint, set the value lower; to tighten a constraint, set the 
value higher.

The Select Nodes/Interfaces allows you to change the scope of the table by limiting the table to 
specific nodes, specific interfaces, or a specific group of nodes or interfaces. The Select Node 
Selection Type window opens.
Change Max Rows increases or decreases the number of rows in a table. The default is 50. If 
you expand the default, the table may take more time to open. If you are trending a large 
network, using the default ensures that the table opens as quickly as possible. 
View in new Frame opens the table in a Table Viewer window, shown below. If necessary, make 
the data in the table more legible by resizing the window. 
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Chapter 10
View Options for a Graph

Right-clicking a graph, or clicking the edit graph icon if you are using the Web Access Server, 
opens the following list of view options. 

The following table provides details about each option.

Option Function

Set Time Period Same as the table option shown above.

Change Constraint Values Same as the table option shown above.

Select Nodes/Interfaces Same as the table option shown above.

Displayed Data For every point on a graph display data in a 
spreadsheet.

Grid Add these to the graph:
X axis grid lines
Y axis grid lines
X and Y axis grid lines

Legend Delete or reposition the legend. 

Style See the illustrations below.

Change Max Rows... Same as the table option shown above.

Display Data Table See below.
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View Options for a Graph
Style Options

Select Style to display a list of seven view options for graphs.

Style > Area

The plot or bar chart changes to an area graph. While relative values and total values are 
easy to view in this format, absolute values for smaller data types may be hard to see. Click 
anywhere within a band of color to display the exact value for that location 

Export Element as CSV... Same as the table option shown above.

View in New Frame Opens graph in a Graph Viewer window.

Print Graph Same as the table option shown above.

Option Function
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Chapter 10
To shorten the time span of a graph, press SHIFT+ALT and use the left mouse button to 
highlight the time span you want to focus on. Release the mouse button to display the selected 
time span.

Style > Stacking Area

The area or plot graph changes to a stacking area graph. This view is suitable for displaying a 
small number of variables.

Style > Bar

The graph changes to a bar chart. This view is suitable for displaying relatively equal values 
for a small number of variables. There are three variables in the graph below.
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View Options for a Graph
Style > Stacking Bar

The plot or area graph changes to a stacking bar chart. If you increase the width of the frame, 
the time scale becomes hourly. If you increase the height of the frame, the call volume shows 
in units of ten.

Style > Plot

Bands of color in an area graph change to lines. If you adjust the frame width, you can make 
the data points align with hour; if you adjust the frame height, you can turn call volume into 
whole numbers.
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Chapter 10
Style > Pie

An area graph becomes a pie chart. Bands in an area graph convert to slices of a pie and the 
pie constitutes a 24-hour period. This view is helpful when a small number of data values are 
represented and you are looking at data for one day.

If you are looking at data for more than one day, you will see multiple pie graphs, one for each 
day. 

Display Data Table

This option changes a graph into a spreadsheet. 
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View Options for a Graph
View in New Frame

The graph opens in a Graph Viewer window. Improve legibility by resizing the window. 
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glossary
active ports rate

A measure of the percentage of total active channels/ports divided by the total channels/ports.

baseline average

The average of all samples during the baseline period. The baseline period is a rolling period 
comprising the previous 91 days

busy hour

Busy hour is the maximum hourly average for the day. This value is the basis for calculating future 
performance. Unlike the average for the day, this value does not smooth out daily peaks and 
valleys. In addition, unlike the daily maximum, or peak, and the daily minimum, this value 
represents a relatively persistent phenomenon, not a momentary condition. Since busy hour is an 
average, actual utilization could have been well above the average for a portion of that particular 
hour, as well as well below the average for a portion of that particular hour. 

Cisco IP Telephony Statistics calculates a busy hour for the following metrics:

• Number of calls

• Active PRI channels

• Active CAS channels

• Active FXO ports

• Active FXS ports 

CallManager

A Cisco AVVID IP Telephony service whose primary function is the control and routing of calls 
from voice-enabled IP device.

CAS

Channel Associated Signaling. A scheme for transmission of call signaling information that relies on 
interleaving the call signaling within the media information that the interface transmits.

channel name

The concatenation of DS1Name and Channel Index.
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Glossary
daily

Performance over the preceding 30 days for the following metrics:

• PRI channel activity

• CAS channel activity

• FXO port activity

• FXS port activity 

The most recent day in this view is yesterday.

day of week

A forecast, derived from baseline data, that correlates growth rate to each day of the week. 

F30, F60, F90

The level where utilization is expected to be 30, 60, and 90 days from now. Calculated by applying 
linear regression to busy-hour levels over the baseline period.

FXO

Foreign Exchange Office. A VoIP gateway providing analog access to central office’s line 
termination.

FXS

Foreign Exchange Station. A VoIP gateway providing analog to a Plain Old Telephone Service 
(POTS) station.

gateway

A device that provides real-time, two-way communications between the packet-based network and 
other stations on a switched network.

growth rate

Also known as rate of increase. F30 utilization divided by average busy-hour utilization.

hourly

A view of yesterday’s performance for the following metrics:

• PRI channel activity

• CAS channel activity

• FXO port activity

• FXS port activity 

location

The place where gateways are located. Value imported by the Common Property Tables 
provisioning process. If not provisioned, field reads unassigned.

PRI 

Primary Rate Interface. An ISDN interface containing 24 or 32 channels for the communication of 
media and signaling information.
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