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Overview
HP-UX patches are delivered exclusively by HP as depots. Depots contain multiple patch products and 
each patch product contains multiple patch file sets. The depots can be uploaded into HP Server 
Automation (SA). With SA you can:

• Create HP-UX Software policies from HP-UX patches or patch bundles.
• Identify, install, and remove HP-UX patches from the server.
• Install software and patches by remediating software policies.
• Download information associated with each patch, including:
• Platform settings including support for multi-platform patches

— Patch dependencies
— Reboot settings

• Perform compliance scans. 

Patch Management for HP-UX Prerequisites

To use the HP-UX Patching features, you must apply the SA 7.84 patch and perform the following 
tasks, which are explained in this document:

• Download the HP-UX Software Catalog file, swa_catalog.xml, from the ITRC website (ftp://
ftp.itrc.hp.com/export/patches) and upload the catalog file using the import_hpux_metadata 
script.

• Upload the new patches and re-upload the existing HP-UX patches, depots, and bundles to the 
SA repository using the import_hpux_depot script.

• Update the HP-UX agent on all existing managed servers. The agent version should be greater 
than or equal to opsware-agent-37.0.0.2.130.

HP-UX Patching Features

With HP-UX patching you can:

• Define HP-UX Software policies, which provides a model-based approach to managing your 
HP-UX servers. HP Server Automation enables you to create a model of your IT environment using 
HP-UX Software policies. HP-UX Software policies specify patches and scripts that can be installed 
on the managed servers.

• Install HP-UX patches bundles/patches on managed servers.
• Establish a patch installation process.

With HP-UX patching, you can separate and independently schedule the various stages of patch 
management: analysis, download, and installation. You can be notified of job status via email 
upon completion of each stage and associate a ticket ID with each job.

• Verify compliance status of servers to software policies

The Compliance View enables you to determine if servers are configured according to the 
Software policy and to remediate non-compliant servers.

• Search for software resources and servers.

In the SA Client, the Library provides a way to search for HP-UX packages, patches, and software 
policies using powerful and flexible search criteria such as availability, architecture, operating 
system, reboot options, and version, among others. You can also search for HP-UX software 
policies by name, folder name, availability, and operating system.
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• View patch dependencies and patch applicability analysis while previewing patch installation.

Importing HP-UX Depots

The HP-UX Depot importer script makes it easy to import HP-UX patches, bundles, and depots to the 
HP Server Automation Library. For each source depot, the tool creates a <depot name> Depot policy 
in the SA Library containing the depot's products.

The import_hpux_depot script needs the .depot extension to script input. The Standard HP-UX Bundles 
that are downloaded from http://itrc.hp.com have a .depot extension by default.

HP-UX patches downloaded from http://itrc.hp.com do not come with the .depot extension by 
default. These patches must be manually downloaded to an HP-UX server, unshared to create a .depot 
file, and uploaded to the SA Library using the import_hpux_depot script.

Location 

/opt/opsware/mm_wordbot/util/import_hpux_depots

Usage 

import_hpux_depots [options]

All *.depot files in the current working directory are imported to the Library.

import_hpux_depots [options] <source-directory>

All *.depot files in the specified directory are imported to the Library.

import_hpux_depots [options] <*.depot>

The explicitly specified depots are imported to the Library.

import_hpux_depots -h 

Show additional options.

-h, --help

Show help message and exit.

-f, --force

Force depot products to be imported even if already in the Library.

-o OS, --os=OS

HP-UX release of depot products 10.20, 11.00, 11.11, 11.23, and 11.31. 
Some patches are common to both 11.23 and 11.31 os versions. Use -o=11.23 or -o=11.31 to 
upload these patches to the SA Library.

-p POLICY_FOLDER, --policy_folder=POLICY_FOLDER

Path to Library folder in which to create policies

-n, --silent

Display errors only.

-u USERNAME, --username=USERNAME

Upload packages as specified user (default: opsware).

-v, --verbose

Display verbose output.

--manual

Show manual page and exit.

--version
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Show version and exit.

-b, --bundle-policies create a policy for each depot bundle

For each bundle that appears in a source depot, the tool creates a <bundle name> Bundle policy in 
the Library containing the bundle's products using the --bundle-policies option.

-s SPLIT, --split=SPLIT How to split each depot (default: product): 'product', 
'instance', 'none'

Products already in the Library are not re-imported unless --force is specified.

By default, depots containing multiple products are split by product so that each product is kept in the 
Library as its own self-contained depot. The split behavior is controlled by the --split option:

• none — Source depots are not split but are imported as is.
• product — Source depots are split by product. If a depot contains multiple instances of the same 

product (by name), the instances are kept together. This is the default.
• instance — Source depots are split by product instance. If a depot contains multiple instances of 

the same product (by name), each instance is split into its own depot.

Importing patches and depots using the SA OCC Client instead of scripts will not create software 
policies, and patch dependency will not work.

Importing the HP-UX Software Catalog File

The HP-UX Software Catalog file is the HP-UX Patch Database in XML format. The catalog file is 
named swa_catalog.xml and can be downloaded from ftp://ftp.itrc.hp.com/export/patches.

The HP-UX Metadata script is used to import the HP-UX Software Catalog file to the HP Server 
Automation Library. This script can list dependent patches for any patch that exists in the software 
catalog file and indicate the dependent patches that are missing in the package repository.

Location 

/opt/opsware/mm_wordbot/util/import_hpux_metadata

Usage 

Options:

-h, --help

Shows the help message.

-c HPUX_SW_CATALOG_FILE, --catalog_file=HPUX_SW_CATALOG_FILE

Specifies the source location of the HP-UX software catalog file. The catalog file 
swa_catalog.xml can be downloaded from ftp://ftp.itrc.hp.com/export/patches.

-a HPUX_ANALYZE_PATCHES, --analyze_patches=HPUX_ANALYZE_PATCHES

Specifies the HP-UX patches that will be analyzed to indicate dependent patches missing in the 
package repository. Multiple HP-UX patches can be specified by separating them using a 
comma. You can specify to analyze all the HP-UX patches in the package repository by using 
the keyword "all."

-n, --no_supersedence

Flag is used with -a option indicating whether to use the superseded dependence tree or the 
basic dependence tree to report missing patches. The superseded dependence tree is the 
default behavior for HP-UX patching. It performs the most recent dependency check. The basic 
dependency tree performs the least recent dependence check.

-d DISPLAY_DEPENDENCIES,--display_dependencies=DISPLAY_DEPENDENCIES
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Specifies HP-UX patches for which the dependencies should be displayed. The keyword "all" 
displays the dependencies for all patches in software catalog file.

Supported Operating Systems for HP-UX Patching

The following operating system versions are supported for HP-UX patching by SA.  

HP-UX Software Policy Management Tasks

In SA, HP-UX Software policies enable you to install HP-UX software and patches on servers and 
groups of servers. When you create a software policy you can attach it to servers or groups of 
servers. When you remediate a server or group of servers, the patches specified in the attached 
policy are automatically installed. The remediation process compares what is actually installed on a 
server to the patches that should be installed on the server according to the policy. SA then 
determines what operations are required to make the server conform to the policy. The following 
sections describe how to manage HP-UX Software policies.

Creating an HP-UX Software Policy
You can create a software policy in the SA client using either of the following views:

• Type View in the Library
• Folder View in the Library

You must have a set of permissions to create and manage an HP-UX Software policy. To obtain these 
permissions, contact your SA administrator. For more information, see the SA Administration Guide.

To use Type View in the Library, follow these steps:

1 From the Navigation pane, select Library > By Type > Software Policies > HP-UX. The list of 
software policies appears in the Content pane. By default, the software policies are organized by 
operating system families.

2 Select a specific operating system.

3 From the Actions menu, select New. The HP-UX Software Policy window opens.

4 In the Name field, enter the name of the HP-UX Software policy.

5 In the Description field, enter text that describes the purpose or contents of the policy.

6 Click Browse to specify the location for the HP-UX Software policy in the folder hierarchy. The Select 
Folder window opens. Select a folder in the Library to specify the location of the HP-UX Software 
policy and then click Select.

7 From the Availability drop-down list, select the SA server life cycle values for the HP-UX Software 
policy.

8 From the OS drop-down list, select the operating system family or specific operating systems in that 
family.

9 To save the changes, select Save from the File menu.

To use Folder View in the Library, follow these steps:

1 From the Navigation pane, select Library > By Folder. The folder hierarchy in the library appears in 
the Content pane.

OS Version Architecture 

HP-UX 11.23 PA-RISC, Itanium

HP-UX 11.31 PA-RISC, Itanium
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2 Select the folder that should contain the HP-UX Software policy.

3 From the Actions menu, select New HP-UX Software Policy. The HP-UX Software Policy window 
opens.

4 In the Name field, enter the name of the HP-UX Software policy.

5 In the Description field, enter text that describes the purpose or contents of the policy.

6 Click Browse to change the location for the HP-UX Software policy in the folder hierarchy. The 
Select Folder window opens. 

7 Select a folder in the Library to specify the location of the HP-UX Software policy and then click 
Select.

8 From the Availability drop-down list, select the SA server life cycle values for the HP-UX Software 
policy.

9 From the OS drop-down list, select the operating system family or specific operating systems in that 
family.

10 To save the changes, select Save from the File menu.

Opening an HP-UX Software Policy
You can open a software policy in the SA client using any of the following:

• Search
• Devices
• Type View in the Library
• Folder View in the Library

To use Search, follow these steps:

1 From the Navigation pane, select Search.

2 Select HP-UX Software Policy from the drop-down list and then enter the name of the policy in the 
text field.

3 Select the -> icon. The search results appear in the Content pane.

4 From the Content pane, select the HP-UX Software policy and then select Open from the Actions 
menu. The HP-UX Software Policy window opens.

To use Devices, follow these steps:

1 From the Navigation pane, select Devices > Servers > All Managed Servers. The server list appears 
in the Content pane.

Or 

From the Navigation pane, select Devices > Device Groups. The device groups list appears in the 
Content pane.

2 From the Content pane, select a server. From the Actions menu, select Open. The Server Explorer 
window opens.

3 From the Views pane, select Management Policies > Software Policies. The software policies 
attached to the server appear in the Content pane.

4 From the Content pane, select the software policy and then select Open from the Actions menu. The 
HP-UX Software Policy window opens.

To use Type View in the Library, follow these steps:

1 From the Navigation pane, select Library > By Type > Software Policies > HP-UX. The HP-UX 
Software policies appear in the Content pane.
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2 From the Content pane, select the HP-UX Software policy and then select Open from the Actions 
menu. The HP-UX Software Policy window opens.

To use Folder View in the Library, follow these steps:

1 From the Navigation pane, select Library > By Folder. The folder hierarchy in the Library appears in 
the Content pane.

2 From the Content pane, select the HP-UX Software policy in a folder and then select Open from the 
Actions menu. The HP-UX Software Policy window opens.

Editing HP-UX Software Policy Properties
After you create an HP-UX Software policy, you can view and modify its properties. You can view 
properties such as the SA user that created the HP-UX Software policy, the date when it was created, 
and the SA ID of the HP-UX Software policy. You can also modify the name, description, availability, 
location of the HP-UX Software policy in the Library, and the operating systems of the HP-UX Software 
policy.

You must have a set of permissions to manage HP-UX Software policies. To obtain these permissions, 
contact your SA administrator. For more information, see the SA Administration Guide.

To define the properties of an HP-UX Software policy, follow these steps:

1 From the Navigation pane, select Library > By Type > Software Policies > HP-UX.

2 From the Content pane, select the HP-UX Software policy and open it. The HP-UX Software Policy 
window opens. 

3 From the Views pane, select Properties. You can edit the name, description, location, life cycle, and 
operating systems for the HP-UX Software policy in the Content pane.

4 In the Name field, edit the name for the HP-UX Software policy.

5 In the Description field, edit the text that describes the purpose or contents of the policy.

6 Click Browse to change the location for the HP-UX Software policy in the folder hierarchy. The 
Select Folder window opens. 

7 Select a folder in the Library to specify the location of the HP-UX Software policy and then click 
Select.

8 From the Availability drop-down list, select the SA server life cycle values for the HP-UX Software 
policy.

9 From the OS drop-down list, select the operating system family or specific operating systems in that 
family.
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10 To save the changes, select Save from the File menu.

Adding the HP-UX Patch to a Software Policy
After you create an HP-UX Software policy, you can add the HP-UX Patch, HP-UX software, and server 
scripts to it. Adding these does not install them on a managed server. You must attach the policy to a 
managed server and then remediate the server. 

You must have a set of permissions to add HP-UX patches, HP-UX software, and server scripts to an 
HP-UX Software policy. To obtain these permissions, contact your SA administrator. For more 
information, see the SA Administration Guide.

To add software resources to a software policy, follow these steps:

1 From the Navigation pane, select Library > By Type > Software Policies > HP-UX.

2 From the Content pane, select the HP-UX Software policy and open it. The HP-UX Software Policy 
window opens.

3 From the Views pane, select Policy Items.

4 Either select the + icon or, from the Actions menu, select Add. The Select Library Item window opens.

5 Select the Browse Types tab to display items that can be added to the HP-UX Software policy.

6 Select one or more items you want to add to the policy and click Select. The items are added to the 
policy.

Or 

Select the Browse Folders tab to display the folder hierarchy in the Library and the list of items 
contained in the folders. Select one or more items you want to add to the policy and click Select. 
The items are added to the policy.

7 To change the order in which the software is installed, use the up and down arrows. 

8 To remove a software from the policy, select the software and click the - (red) icon.

9 To save the changes to the policy, select Save from the File menu.

The following graphic shows an HP-UX Software policy that contains three patches in the SA Client. 

Removing Software from an HP-UX Software Policy
Removing HP-UX software from an HP-UX Software policy does not uninstall it from a managed server. 
It only removes the software from the policy. To uninstall the HP-UX software from a managed server, 
you must directly uninstall the HP-UX software from the managed server.

You must have a set of permissions to remove HP-UX software from an HP-UX Software policy. To 
obtain these permissions, contact your SA administrator. For more information, see the SA 
Administration Guide.

To remove HP-UX software from an HP-UX Software policy, follow these steps:

1 From the Navigation pane, select Library > By Type > Software Policies > HP-UX and select a 
version of HP-UX.
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2 From the Content pane, select the HP-UX Software policy and open it. The HP-UX Software Policy 
window opens.

3 From the Views pane, select Policy Items.

4 Select the items that you want to remove from the list of policy items displayed in the Content pane.

5 Either click the - (red) icon or, from the Actions menu, select Remove.

6 To save your changes, select Save from the File menu.

Viewing the History of an HP-UX Software Policy
To view the events associated with an HP-UX Software policy, follow these steps:

1 From the Navigation pane, select Library > By Type > Software Policies > HP-UX and select a 
version of HP-UX.

2 From the Content pane, select the HP-UX Software policy and open it. The HP-UX Software Policy 
window opens.

3 From the Views pane, select History. The events associated with the HP-UX Software policy will 
display in the Content pane. You can view the action performed on the policy, the user who 
performed the action, and the time when the action was performed.

4 From the Show drop-down list, select the time period you want to see the events from.

Viewing Servers Attached to an HP-UX Software Policy
In the SA Client, you can view the list of all servers and device groups that have a selected HP-UX 
Software policy attached to them.

To view the servers that have a selected HP-UX Software policy attached to them, follow these steps:

1 From the Navigation pane, select Library > By Type > Software Policies > HP-UX and select a 
version of HP-UX.

2 From the Content pane, select the HP-UX Software policy and open it. The HP-UX Software Policy 
window opens.

3 From the Views pane, select Servers. The list of servers that have the selected HP-UX Software policy 
attached to them appears in the Content pane.

Locating HP-UX Software Policies in Folders
To locate an HP-UX Software policy in the folder hierarchy, follow these steps:

1 From the Navigation pane, select Library > By Type > Software Policies > HP-UX and select a 
version of HP-UX.

2 From the Content pane, select the HP-UX Software policy.

3 From the Actions menu, select Locate in Folders. The folder hierarchy for the HP-UX Software policy 
appears in the Content pane.
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Importance of Custom Attribute

HP-UX Patching enables you to set a custom attribute by name (hpuxpatch_dont_supersede) to any 
managed server, as shown in the following graphic. 

SA mandates the inclusion of the latest patches in the software policy with the custom attribute not set, 
which is the default behavior. With the custom attribute set, SA accepts the non-latest patches in the 
policy. To toggle the behavior, you can set the custom attribute or delete the custom attribute. Custom 
attribute cannot be set on the software policy.

Patch Installation

The patch installation process consists of two phases:

• Download Phase: This is when the patch is downloaded from SA to the managed server. This 
phase is commonly referred to as the staging phase.

• Installation Phase: This is when the patch is installed on the managed server. This phase is 
commonly referred to as the deployment phase.

You can specify whether you want the installation to occur immediately after the patch is downloaded 
(staged) or you can schedule it to occur at a later date and time. Patch Management also supports 
the need for best-effort installations of multiple patches by allowing you to specify that the patch 
installation process will continue even when an error occurs with one of the patches.

Patch Management displays the name of the command that installs the patch. The SA Agent runs this 
command on the managed server. You can override the default command-line arguments you want to 
perform the installation.

To optimally manage HP-UX patch installations, Patch Management enables you to manage server 
reboot options and pre- and post-installation scripts, simulate (preview) a patch installation, and set 
up email notifications to alert you about the status of the installation process. The Install Patch 
window, as shown in following graphic, guides you through the setup.  
10



Installation Flags
You can specify installation flags that are applied whenever an HP-UX patch is installed. However, SA 
also uses default installation flags and requires that patches be installed with these flags. You must 
therefore be certain that you do not specify any installation flags that override or contradict the 
default flags passed in by SA.

Installing an HP-UX Patch
Before a patch can be installed on a managed server, it must be imported into SA, and its status must 
be Available. Administrators who have the required permissions can install patches that are marked 
Limited.

You must have a set of permissions to manage patches. To obtain these permissions, contact your SA 
Administrator. For more information, see the SA Administration Guide.

You can perform the installation by explicitly selecting patches and servers.

To install a patch on a managed server, follow these steps: 

1 From the Navigation pane, select Library and then select Patches.

2 Expand the Patches and select a specific HP-UX operating system.

3 From the Content pane, select a patch.

4 From the View drop-down list, select Servers (or Server Groups).

5 From the Show drop-down list, select Servers without Patch Installed (or Server Groups without 
Patch Installed).

6 From the Preview pane, select one or more servers.

7 From the Actions menu, select Install Patch. The first step of the Install Patch window, Servers and 
Server Groups, opens.

8 After you complete a step, click Next to advance to the next step. Before you click Start Job, you 
can return to a completed step to make changes by clicking on it in the list of steps.

9 When you are ready to launch the installation job, click Start Job.

After you launch the job, you cannot change its parameters, even if the job is scheduled to run at a 
later time.

If the Install Patch window remains open until the job completes, Patch Management updates the 
Patch Compliance column in the All Managed Servers window with the revised compliance count (in 
parenthesis) for affected servers. Press F5 or select Refresh from the View menu to update information 
in the Patch Preview pane.

Setting HP-UX Install Options
You can specify the following types of patch installation options:

• Perform the patch installation immediately after the patch is downloaded or at a later date and 
time.

• Do not interrupt the patch installation process even when an error occurs with one of the patches.
• Use different command-line options to perform the installation.

To set these options, follow these steps:

1 From the Install Patch window, click Next to advance to the Install Options step.

2 Select one of the following Staged Install Options:

— Continuous: Enables you to run all phases as an uninterrupted operation.
— Staged: Enables you to schedule the download and installation to run separately.
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3 Select the Error Options check box if you want the patch installation process to continue even when 
an error occurs with one of the patches. By default, this check box is not selected.

4 In the Install Command text box, enter command-line arguments for the command that is displayed.

5 Click Next to go to the next step or click Cancel to close the Install Patch window.

Setting Reboot Options for an HP-UX Patch Installation
To minimize the downtime that server reboots can cause, you can control when servers will and will 
not be rebooted. You can adopt the vendor's reboot assignments, reboot a server each time a patch 
is installed on it, completely suppress all server reboots, or postpone reboots until all patches are 
installed.

When you are selecting reboot options in the Install Patch window, HP recommends that you use the 
HP-UX reboot recommendations, which is the “Reboot servers as specified by patch properties” 
option. If you cannot use the HP-UX reboot setting, select the single reboot option, which is the “Do 
not reboot servers until all patches are installed” option.

The following options determine whether the servers are rebooted after the patch is installed. These 
options apply only to the job launched by the Install Patch window. They do not change the Reboot 
Required option, which is on the Install Parameters tab of the patch properties window. Except for the 
first option, the following options override the Reboot Required option.

• Reboot servers as specified by patch properties

By default, the decision to reboot depends on the Reboot Required option of the patch properties. 
The server is rebooted only once at the end. This is done to satisfy the patch dependency. In 
effect, the option works as the third option which is to not reboot servers until all patches are 
installed

• Reboot servers after each patch install

Even if the Reboot Required option of the patch properties is not set, reboot the server. If multiple 
patches are installed, the server will be rebooted only once after all patches are installed.

• Do not reboot servers until all patches are installed

If the Reboot Required option is set for some selected patches but not for others, the server is 
rebooted one time after all patches are installed. If the Reboot Required option is not set for any 
of the selected patches, the server is not rebooted.

• Suppress all server reboots

Even if the Reboot Required option of the patch properties is set, do not reboot the server. 
(Because of vendor settings, some patches ignore the suppress option and force a reboot.)

To set reboot options, follow these steps:

1 From the Install Patch window, click Next to advance to the Pre & Post Actions step.

2 Select one of the Rebooting Options.

3 Click Next to go to the next step or click Cancel to close the Install Patch window.

Specifying Install Scripts for an HP-UX Patch Installation
For each patch, you can specify a command or script to run before installation or after installation. A 
pre-install script, for example, could check a certain condition on the managed server. If the condition 
is not met or if the pre-install script fails, the patch is not installed. A pre-install script could also be 
used to shut down a service or application before it is patched. A post-install script could be used to 
perform a certain cleanup process on the managed server. You can also specify the following types of 
scripts to run on the managed server before or after an installation or download phase:
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• Pre-Download: A script that runs before patches are downloaded from SA to the managed server. 
This is available only if you select Staged in the Install Options step.

• Post-Download: A script that runs after patches are downloaded from SA to the managed server 
and before the patch is installed. This is available only if you select Staged in the Install Options 
step.

• Pre-Install: A script that runs before patches are installed on the managed server.
• Post-Install: A script that runs after patches are installed on the managed server.

To specify a pre-install script, follow these steps:

1 From the Install Patch window, click Next to advance to the Pre & Post Actions step.

2 Select the Pre-Install tab. You may specify different scripts and options on each of the tabs.

3 Select Enable Script. This option enables the remainder of the fields on the tab. If Enable Script is 
not selected, the script will not run.

4 Select either Saved Script or Ad-Hoc Script.

5 A Saved Script was previously stored in SA with the SAS Web Client. To specify the script, click 
Select.

6 If the script requires command-line flags, enter the flags in the Command text box.

7 Specify the information in the User section. If you choose a system other than Local, enter the User 
Name, Password, and Domain. The script will be run by this user on the managed server.

8 To stop the installation if the script returns an error, select the Error check box.

9 Click Next to go to the next step or click Cancel to close the Install Patch window.

Scheduling an HP-UX Patch Installation
Because the two phases of patching can be decoupled, you can schedule when you want patches 
installed (deployed) to occur independently of when patches are downloaded (staged).

To schedule a patch installation, follow these steps:

1 From the Install Patch window, click Next to advance to the Scheduling step.

By default, the Scheduling step displays only the scheduling options for the install phase. If you 
selected Staged in the Install Options step, the scheduling options for the download phase are 
also displayed.

2  Select one of the following Install Phase options:

— Run Task Immediately: This enables the system to perform a preview analysis in the Summary 
Review step. The scheduling option for the download phase is Run Immediately Following 
Download.

— Run Task At: This enables you to specify a later date and time that you want the installation or 
download performed.

3  Click Next to go to the next step or click Cancel to close the Install Patch window. A scheduled 
patch installation can be cancelled (prior to its execution), even if the patch download has already 
completed.

Setting Up Email Notifications for an HP-UX Patch Installation
You can set up email notifications to alert users when the download and installation operations 
complete successfully or with errors.

To set up email notifications, follow these steps:

1 From the Install Patch window, click Next to advance to the Notifications step.
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2 To set the notification status on the success of a Job, select the icon. To set the notification status on 
the failure of a Job, select the icon. By default, the Notification step displays only the notification 
status for the installation phase.

3 Enter a Ticket ID to be associated with a Job in the Ticket ID field.

4 Click Next to go to the next step or click Cancel to close the Install Patch window.

If you previously selected Staged in the Install Options step, the Notifications pane displays 
notification options for both the download and installation phases.

Previewing an HP-UX Patch Installation
The installation preview process provides an up-to-date report about the patch state of servers. The 
installation preview is an optional step that lets you see what patches, either single patch or patches 
part of standard HP-UX bundle, will be installed on managed servers and what type of server reboots 
are required. This preview process verifies whether the servers you selected for the patch installation 
already have that patch installed. In some cases, a server could already have the patch installed if a 
system administrator manually installed it, which means that Patch Management does not know about 
it.

The preview process also reports on dependency information, such as patches that require certain 
HP-UX products, and patches that obsolete other patches or are obsoleted by other patches. If a 
dependency is not met, Patch Management displays an error message indicating this condition.

To preview a patch installation, follow these steps:

1 From the Install Patch window, click Next to advance to the Summary Review step.

2 Verify the information displayed for the Servers, Server Groups, and Patches at the top of the 
window.

3 (Optional) Click Preview to see the separate actions that will be performed when the patch is 
installed. To view the details of a previewed action, select a row in the table.

4 Click Start Job to launch the installation job or click Cancel to close the Install Patch window without 
launching the installation.

If you selected Run Task Immediately in the Scheduling step, the job begins now. If you selected Run 
Task At, the job will be launched at the specified time and date.
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The following graphic shows the patch preview information. 

Viewing the Job Progress of an HP-UX Patch Installation
You can review progress information about a patch installation (job), such as whether actions 
completed or failed.

To display job progress information, follow these steps:

1 From the Install Patch window, click Next to advance to the Job Progress step. This starts the 
installation job.

The Progress bar and text indicate how many of the actions listed in the table were completed. 
For each server, the following actions can be performed:

— Analyze: SA examines the patches needed for the installation, checks the managed servers for 
the most recent patches installed, and determines other actions it must perform.

— Download: The patch is downloaded from SA to the managed server.
— Install: After being downloaded, the patch is installed.
— Final Reboot: If this action is specified in the Pre & Post Actions step, the server is rebooted.
— Pre/Post Install/Download Script: If this action is specified in the Pre & Post Actions step, a 

script is run before or after the uninstallation.
— Install & Reboot: When a patch will be installed is also when the server will be rebooted.
— Verify: Installed patches will be included in the software registration.

2 To view additional details about a specific action, select the row in the table to display the start and 
completion times of the job. From the Navigation pane, select Jobs and Sessions to review detailed 
information about the job.

3 Click Stop Job to prevent the job from running or click Close to close the Install Patch window.
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Uninstalling HP-UX Patches and Bundles

Uninstallation of HP-UX Patch & Bundles is not supported in SA 7.84 Release. To uninstall the HP-UX 
patch and bundles from a managed server, you must directly uninstall the HP-UX patch and bundles 
from the managed server.

HP-UX Patch Compliance

A HP-UX Patch compliance scan compares the HP-UX patches that are installed on a managed server 
with the HP-UX patch policies that are attached to the server. If the actual server configuration does 
not match the HP-UX patch policies attached to the server, the server is out of compliance with the 
HP-UX patch policies. In addition, if a patch in the patch policy has been superseded by a newer 
patch and the newer patch is installed on a server, that server will be marked as compliant.

In the SA Client, when you perform a patch compliance scan, the scan indicates the server's overall 
compliance with all the HP-UX patch policies attached to the server. Even if only one HP-UX patch 
policy attached to the server is not compliant, the server is considered non-compliant. You can then 
view the non-compliant server and remediate the server against the applicable patch policy.

The SA Client displays the following compliance information for a patch policy: 
States of Patch Compliance for a Managed Server

Compliance Status of the 
Managed Server Icon Description

Compliant All the patch policies attached to a server are compliant — all the 
patches specified in all the patch policies are installed on the server.

Non-compliant At least one of the patch policies attached to the server is not 
compliant.

Scan Started The patch compliance information is currently being gathered.

Scan Failed The patch compliance scan was unable to run.

Scan Needed The patch compliance information needs to be gathered or the 
compliance information may be inaccurate.

Not Applicable — The patch compliance information does not apply.
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The following example show the patch compliance status for the Standard HP-UX bundle: 

In the example, SA is reporting that the compliance status for the Standard HP-UX QPK bundle is “2 
of 258 rules out of compliance.” The total number of patches within QPK bundle is 259. SA 
determined that one patch in this bundle is not applicable to this managed server. Therefore, it 
reports compliance status only for 258 patches instead of 259 patches.

SA also determined that two patches have superseded patches, and these superseded patches are 
installed on the server but not uploaded in the repository. Therefore, they are reported as out of 
compliance. 
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