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1 Introduction

HP DDM InventoryTM collects a lot of different data from your network devices. This guide
will help you understand how to read the data collected by DDM Inventory’s discovery
features.

For information on data collected by DDM Inventory scanners, refer to the Scan Data
Analysis Guide.

This guide provides information on the following topics:
¢ Finding Network Devices on page 11

e Using the Network Map on page 23

e Using the Service Analyzer on page 49

e Using the Health Panel on page 53

e Using the Alarms Viewer on page 57

e Using the Events Browser on page 61

e Using the Device Manager on page 69

e Using the Port Manager on page 99

e Using the Attribute Manager on page 117
e Using the MIB Browser on page 121

e Using the Scan Data Viewer on page 133
e Using the Reports on page 143
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2 Finding Network Devices

The Find command lets you locate and examine any device on the network. There are many
ways to search for a particular device, based on its DNS name, IP address, MAC address, and
SO on.

There is also an Aggregate Find feature that will let you search for devices across all of your
aggregated DDM Inventory servers. The Aggregate Find is almost identical to the regular
Find, but the Aggregate Find has fewer search options. The Easy Find option is now available
within Aggregate Find.

The following sections explain the Find command in detail:
e How to Find Your Devices on page 11

¢ Finding Devices on page 12

e EKasy Find on page 14

e Basic Match on page 15

e Asset Match on page 16

e [P Address on page 19

e MAC Address on page 20

e DNS Query on page 21

e Advanced Find on page 21

How to Find Your Devices

There are six Find modes.
Table1  Types of Find

Name Why use it?

Easy Find This option is a “catch-all” that should be good for most searches.
Read more details about it in Easy Find on page 14.

Basic Match A Basic match allows you to perform a search based on various device
attributes.

Asset Match An Asset match allows you to perform a search based on asset data
collected.
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Tablel Types of Find

Name Why use it?

IP Address Find a device with a specific IP address.

MAC Address Find a device with a specific MAC address.

DNS Query Do a DNS Query on a specific domain name.
Note: Not available with Aggregator Find.

Finding Devices

To use the Find tool:

1 Open the Find tool:
Table 2 Opening Find

From Click
Navigation Tree Find
Health Panel, Network Map, Alarms | Tools > Find

Viewer, Events Browser, MIB
Browser, or Service Analyzer

2 By default, you can use the Easy Find feature (go to step 6). If you want to do a more
advanced find, continue with the next step in this procedure.

3 In the first pull-down list, select the Find mode you want to use to perform the search (for

example, “Basic Match”).

4 In the second pull-down list, select the device data you want to search on (for example,

“NetBIOS Name”).

In the third pull-down list, select a match mode (for example, “containing”). (For
explanation of these match modes, see Advanced Find on page 21).

Enter a match value.

) When using Easy Find, enter the first letters of a title or the first numbers of an
address to find multiple devices in the DDM Inventory database.

Press Enter or click Go.
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Select the
Find mode

DDM Inventory searches for the device. The results of the search appear in table format, and
you can select the device you want to open. You can double-click (or right-click) to open a
Device Manager or Port Manager.

2 Find - Brindusa's Test Server

Select the
device data

Select a
match mode

File Edit |View Device Pori Tools Help

| I
Basic Match | w | Device Title ¥ | containing | o | =
Easy Find — leo Count:0 |@ | & | B
Basic Match : - il | | |
Asset Match [§ evice . | P Address Matched Yalue
IP Address o & = TR 5 l
PR e E* Find - Brindusa's Test Server
DHS Guery File Edit View Device FPori |Tools Help

Basic Match | b

r
Device Title

* | containing

Match value: Device Title

Device Tag

VM Hame

i aggregate Find - Server

Domain Hame
HetBIOS Ham
HetBIOS Worl
Famihy

Model

oup

[»

(4]

Address

0 Find - Brindusa's Test Server

File Edit Wiew Device Port Tools Help

t
| * | containing | b

containing .
T

ending with
equal to
matching ?*
matching regex

Basic Match | - | Device Title

Count: 0 I

hatched Yalue

Match value: | | E

| Device | 1A

The Aggregate Find window has a G} (globe) icon to the left of the File menu on the main
menu bar. When you click this icon, you can open the Find window for one of the remote
servers associated with this Aggregator:

% File Edit View Device

Easy Find

D

Aggregate Yiew

ind - cwc_testserver

&= Server* BE= File Edit Wiew [Dewvice
& cwe_testserver [::{_‘ Easy Find - ind - cwc_testserver
Match value: & | File Edit Wiew Deuice
| Devic E:r Aggregate View I
L E—
&= Server*
cwe_testserver E s

The Find window for an individual server has a &s (server) icon instead of a globe icon. When
you click the server icon, you can either return to the Aggregate Find window or open the Find
window for any other remote server associated with this Aggregator.

Finding Network Devices
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Easy Find

When you enter text into the Find box, DDM Inventory searches the network in the following
order. If there is no result at one stage, DDM Inventory will try the next. For example, once an
IP address has been found, DDM Inventory does not search domain names and device titles.

Table 3 Internal Search Order for the Easy Find

Find Method

Explanation

“localhost” or “nmc”

These are two shortcuts for finding the DDM Inventory server.

MAC address

DDM Inventory will try to search based on the known MAC address.
Note: To find a specific device, you can either enter its complete MAC
address in 12:AB:34:CD:56:EF, 12AB34CD56EF, or 12AB34 CD56EF
format, or you can use wildcard characters. Refer to MAC Address
on page 20 for detailed instructions.

IPv4 or IPv6
address

DDM Inventory will try to search based on the known IP address
(IPv4 or IPv6).

Note: To find a specific device, you can either enter its complete IPv4
or IPv6 address, or you can use wildcard characters. Refer to IP
Address on page 19 for detailed instructions.

Device Title

DDM Inventory will then search the network based on your device
title preferences from Administration > System Configuration > Display
preferences > Device title preference. Only the selected titles are
searched.

Asset Tag Even if Asset Tag is not listed in your Device title preference, DDM
Inventory will search for it next.
NetBIOS Name Even if NetBIOS name is not listed in your Device title preference,

DDM Inventory will search for it next.

Domain Name

DDM Inventory searches based on the DNS suffix as configured in
your server DNS (done in Control Panel).

Easy Find now finds ports as well as devices. If you specify an IP or MAC address, and that
address is associated with a port, you will see a value in the Port column of your Easy Find

results.

‘n- The Find tool treats incomplete IP and MAC addresses differently than addresses that
contain wildcard characters.

For example, if you enter “192.168.2”, you will not find all devices in the range 192.168.2.0—
192.168.2.255. You will find only devices with “192.168.2” in the device title. If the device with
IP address 198.168.2.55 gets its title from its domain name instead of its IP address, that
device will not be found.

If, on the other hand, you specify “192.168.2.*”, you will find all devices in the range
192.168.2.0-192.168.2.255 that DDM Inventory has thus far discovered in your network.

) When you use Easy Find, it may take several seconds to get a response—especially on a large

network.
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Basic Match

Table 4 Basic Match
Name Why use it? Examples
Device Title Find a device when you know the name, | 172.22.5.5
but not necessarily the type of device. | apydevice.example.com
Device Tag Find a device with a specific device tag. | VMware or Microsoft
A device tag is a short descriptive string
assigned to this type of device.
You can also enter a partial device tag
to find several devices with similar
numbers.
VM Name Find a VMware virtual machine by its | VM_WinXP

VM name.

Domain Name

Find a device with a specific domain

anydevice.example.com

name. hp.com
NetBIOS Name Find a device with a specific NetBIOS | NTAWORKQA
hame. mymachine
NetBIOS Find a device within a specific NetBIOS | QA_SAN_DIEGO
Workgroup workgroup. ACTIVE
Family Find a device within a specific family. Cisco 2600 Series Modular
Access Routers
WaveSwitch 1000 Series
Workgroup Switch
Model Find a device of a specific model. IBM xSeries 330 (867411X)
Cisco Intelligent Gigabit
Ethernet Switch Module
(IGESM)
Operating System | Find a device with a specific operating | Linux
system. HP-UX 11.0
Network Function |Find a device which serves a specific router

network function.

SNMP Description | Find a device with a specific description | Linux Virtual Gateway
in the SNMP MIB. 3Com SuperStack I1
SNMP Contact Find a device with a specific contact in | Kevin
the SNMP MIB. IT Manager
SNMP Name Find a device with a specific name in Demo Server

the SNMP MIB.

manager.example.com

Finding Network Devices
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Table 4 Basic Match
Name Why use it? Examples
SNMP Location Find a device with a specific location in | server room
the SNMP MIB. QA LAB
SNMP Serial Find a device with a specific serial 12345ABCDE
Number number in the SNMP MIB.
Mobile Phone Find a mobile device with a specific 888-555-1212
Number phone number. This option is only 613
available when mobile discovery is
active.?
Mobile User Name | Find a mobile device with a specific Smith
user name. This option is only available Wong, James
when mobile discovery is active and
mobile user names are collected.?
See Special Note About Mobile User
Names on page 16.

a. See Enabling and Disabling Mobile Discovery and Protecting Private Information for Mobile
Devices in the Reference Guide for more information.

Special Note About Mobile User Names

In the DDM Inventory database, mobile user names are stored in two parts: the first name
and the last name. To find mobile devices based on a Mobile User Name, you can specify
either the first name, the last name, or both. Use a comma (,) to separate the names when you
type them in the Match value box, as shown here:

Search by Match value format Example
Last name <last name> Wong

or or

<last name>, Wong ,
First name , <first name> , James

Both first and last name

<last name>, <first name>

Wong, James

Spaces between the names are ignored. The results of the Find operation are displayed in
<last name>, <first name> format.

Asset Match

An Asset match allows you to perform a search based on asset data collected. It includes
details about users, departments, physical assets, equipment, and any other information that

is useful to record.
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There are three methods of collecting asset data: scanner, bulk import, or Web Asset
Questionnaire (WAQ). One or multiple methods can be used for a device but the order of
priority is as follows:

e Web Asset Questionnaire
¢ Bulk import
e Scanner

When you perform a Find query, the search query will look at all three levels in the priority
order.

For example, a device may be picked based on the AssetTag collected by the scanner if the
value matches and there is no AssetTag collected through either the WAQ or bulk import.

The resultant value is always the one collected by the method with the highest priority.

Table 5 Asset Match

Name Why use it? Examples
Description Find a device from the Description line | Development Machine
that contains a brief description of the
asset.
Asset Tag Find a device with a specific asset tag. | EXAMPLE123456

The Asset Tag field contains a unique 123456
identifier for the machine.

You can also enter a partial asset tag to
find several devices with similar

numbers.

Employee ID Find devices from a specific Employee | FINANCE3746
ID as used in the organization.

Last Name Find devices with a specific last name of | SMITH
user

Full Name Find devices with a specific full name of | JOHN SMITH
user

Job Title Find devices with a specific job title of | IT Manager
user

Cost Center Find devices with a specific cost center

description or code

Business Unit Find devices with a specific name of
business unit

Division Find devices with a specific division
description or code

Department Find devices with a specific department | IT32
description or code

Section Find devices with a specific section
description or code

Finding Network Devices 17



Table 5 Asset Match

Name Why use it? Examples

Office Location Find devices with a specific location of | UKRichmond
office.

Building Find devices from the building RICHMOND
containing the machine

Floor Find devices with a specific floor on first
which the machine is located

Room Find devices with a specific description, | Room5
name or number of the room containing
the machine

Bar Code Find a device with a specific bar code.

Telephone Find devices with a specific internal 3256

Extension telephone extension

Telephone Number | Find devices with a specific full direct | 020 8956 5569
telephone number of user

Cellphone Number | Find devices with a specific cell/mobile | 07285692658
phone number of user

Printer Description | Find devices with a specific description | FinancePrinter
of a local printer attached to the
machine, if any

Printer Asset Tag | Find devices with a specific from the FinancePrinter1234
Asset tag of a local printer attached to
the machine, if any

Machine Make Find devices with a specific Make or HP
Manufacturer of the machine. This data
is automatically collected on machines
supporting SMBIOS

Machine Model Find devices from the Model of the
machine. This data is automatically
collected on machines supporting
SMBIOS

Device Type Find devices from the Device type of the | Server, Notebook, Tower
machine.

User field 29 User field 29 is the default label for a

user defined field.

When the field is configured in the User
Interface, the field is given a
meaningful name.

The user defined fields will show in the
Asset Match list only if a custom label
is being used for a field.
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IP Address

The Find function enables you to search for devices using IPv4, IPv6, or IPv6 with the IPv4

suffix format:

i Find - Brindusa’s

Test Server

File Edit WView [Device FPori Tools Help

IP Address - | ud b :
MatchIP: = |, [¥% Count: 0
o
| uB (v SUFFix) [ P address Matched Yalue |
Table 6 IP Address
Name Why use it? Examples
IP Address Find a device with a specific IP | 172.22.5.5
address. 1792.% * 955
1080:0:0:0:8:800:200C:417A

1080::8:800:200C:417A
1080::8:800:200C:129.144.52.38

Depending on the IP format you choose, you specify the IP address as follows:
e IPv4-123.123.123.123

e JPv6—1234:ABCD:1234:ABCD:1234:ABCD:1234:ABCD
e IPv6:v4 suffix — 1234:ABCD:1234:ABCD:1234:ABCD:123.123.123.123

Finding Network Devices
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To find multiple devices, you can substitute an asterisk (*) for an octet in an IPv4 address or a
group of four hexadecimal digits in an IPv6 address. You can also copy/paste IP addresses in

these fields. The following are valid search strings:

IP Addre=ss w  vi b4
Match IP: 123 |, /123 . * |. *
IP Address | vb b4

MatchIP: =+ 1 * @ = &+ % 2234 1ghod s 2 1 %

IP Address w | ub (vl suffin) | *
Ma‘tch":l:*:*:*:*:*:*:*_*_*_*

All IPv6 notation formats specified by the RFC2373 standard are supported. The last
example above is a format, where the last eight hexadecimal digits in the IPv6 address are
represented as an IPv4 address.

If you specify an IP address, and that address is associated with a port, you will see this port
listed in your Find (or Easy Find) results.

MAC Address

Table 7 MAC Address

Name Why use it? Examples
MAC Address Find a device with a specific 12:AB:34:CD:56:EF
MAC address. 12:%:34:%:56:EF

Note: You can use asterisks (¥) to
find multiple devices.

You must specify the MAC address in the following format: 12:AB:34:CD:56:EF
You can substitute a * for a segment of a MAC address. The following, for example, are valid
search strings:

MAC Address |

Matt:hMAC:12:*:*:*:*:*

MAC Address |

Match MAC: | 12 - & @ * : CD : 36 : EF m

MAC Address | *

Match MAC:  * |: A 1 * : CD : * |2 EF m
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You cannot omit leading zeros in a MAC address segment. For example, you cannot enter “5”
instead of “05” for a segment.

) If you specify a MAC address, and that address is associated with a port, you will see this port
listed in your Find (or Easy Find) results.

DNS Query

Table 8 DNS Query

Name

Why use it? Examples

DNS Query

Do a DNS Query on a specific www.hp.com
domain name.

Note: Not available with
Aggregator Find.

Advanced Find

For the advanced find option, there are different match modes that will help your search.

These modes are described in the following table.

’ Searches are not case-sensitive.

Table 9 Advanced Find

Match Modes

Notes

containing

beginning with

ending with

equal to

matching 7*

Wildcard characters:

e “?” can represent any single character. For
example, “gr?y” finds “gray” and “grey.”

e “¥”can find multiple characters. For
example, “E*t” finds “Ethernet.”

matching regex

Matching a regular expression.

Note: For some examples of regular expressions,
see the Analysis Workbench chapter in the Scan
Data Analysis Guide.

Finding Network Devices
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3 Using the Network Map

You can only use the Network Map if you have an DDM Inventory topology license.

The Network Map gives you a graphical view of your network, using icons and lines that
represent the devices in your network and their connectivity.

There are many ways to change how you view the map. You can change the layout, and many
look-and-feel features. You can even save different layouts (configuration files) in case you
want to look at the network in different ways.

This chapter will start off by explaining what you first see on the map (icons, lines), and then
get into details about how to change the map.

) The map is generated automatically based on the data gathered through the discovery
process. If the source data is reliable, the map will accurately represent your network. There
may be cases where information is not available for certain devices or connections. In these
cases, DDM Inventory will make its best “guess” about connectivity.

In this chapter, you will find information on the following topics:
e  How Does the Map Work? on page 24

e  What are the Icons on the Map? on page 25

¢ (Customizing the Network Map View on page 29

¢ (Changing the Map Background Image on page 33

e Managing Your Background Image Library on page 34

e Packaging Your Network on page 34

¢ Organizing Map Configuration Files on page 42

e Saving a Map Window as a Graphic File on page 47
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How Does the Map Work?

*\ Main Map - HaiTian

File Edit View Device Port Package Configure Tools Help

100 i 7] ael

* Deuinanddsmelﬂes| | ‘ | | |

Catalyst 4232-L3
15.172.180.1

[T

device—| \\\
icon \
11 devices ——— 210 ;Ltagv;nas
kg &
PaCkage\ WaveSwitch @16
con
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To determine what the Map will display, select an alarm category on the Health Panel or
Alarms Viewer, or click the alarm list on the map status bar. For more information, see Status
Bar on page 24.

The colored ring around an icon indicates the device’s status for the category you select. For
example, if you select Device Adds/Deletes, any devices that were recently added will have
green rings.

) To show rings, the objects must be within the priority range as selected on the map status bar,
Health Panel, or Alarms Viewer. (Information about setting device priorities is in the
Configuration and Customization Guide.)

) Devices and ports that do not have applicable attribute or report data will not have a ring (for
example, connector devices).

Status Bar

The Status Bar appears at the top of every map window. It displays information about the
window contents, and allows you to change the window display.
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The following graphic shows the Status Bar. The table below the graphic explains the features
available on the Status Bar.

) Some parts of the Status Bar duplicate information available on the Health Panel.

* | * @ Device Adds/Deletes | vl 386 | vl example_map | v|

=———{_F——— | 100 | Devices: 623 w =

7 8 9 10 11

1 2 3 5 6
Table 1 Toolbar Legend
Number Name
1 package alarm state
2 object alarm state (displayed when you
mouse over an object on the map)
3 alarm type pull-down list
4 priority range pull-down list
5 map configuration file
6 map scale slider
7 map scale percentage in this window
8 number of devices in this package
9 Find a device
10 go up one level
11 connectivity (green = OK, red = no

connection to server)

What are the Icons on the Map?

The following sections describe the different icons you will encounter on the Network Map:

e Devices and Packages on page 26

¢ Connector Devices on page 26

e Priority on page 27

e Package Icons Group other Icons Together on page 27

e Icon Appearance on page 28

Using the Network Map
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Devices and Packages

>»

DDM Inventory tries to develop a realistic view of your network, and that view is represented
with icons (representing a device or a group of devices) and lines that connect the devices.

The icons on the map fall into categories:

Table 2 Icon Categories

Icon Type |Example |Description

Device Icons Device icons represent the physical equipment in
your network.

i XP Pro
win.example.com

Package A package is a collection of objects (objects means
Icons either devices or packages).

2 devices
for 172.23.4.4

DDM Inventory selects device icons based on the data collected from that device. For example,
if DDM Inventory sees that a device is a Microsoft Windows 2000 workstation, that device will
appear on the map with a “Win2000 Workstation” icon.

DDM Inventory will usually select the correct device icon. If for some reason, the wrong icon
has been selected, you can change it. See Customizing the Network Map View on page 29.

Connector Devices

When DDM Inventory is unable to determine the exact physical, port-level connectivity
between devices, it displays the connection with a connector device icon representing the
logical subnet.

DDM Inventory creates two types of connector devices: clouds and diamonds.

Table 3 Connector Devices

Icon Type |Example | Description

Cloud Clouds represent one or more devices or MAC
: systems that provide connectivity in the network.
'::'-:""'-"'":
Diamond Diamonds do not represent actual network

devices; they indicate connectivity. Sometimes,
\IF'/ DDM Inventory knows that there is connectivity
without being able to specify the devices.

For more information on the real and connector devices, see the Reference Guide.

You can see a complete list of all the icons used in DDM Inventory in Help > Classifications >
Device Types/Package Types.
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Priority

In DDM Inventory, devices can have priorities 1-6. Devices with priority 1 are the least
important. The higher the number, the higher the priority and greater the importance.

By default, priorities 5 and 6 are reserved for the user. By default, priority 6 is reserved for
those devices that should trigger event notification—see the Event Filters chapter in the
Configuration and Customization Guide.

Package Icons Group other Icons Together

DDM Inventory helps you organize and simplify your Network Map with packages. A package
is a collection of objects (objects means either devices or packages) that is represented by an
icon. You can double-click a package icon to open the package in its own window. There are
two types of packages:

Table 4 Packages

Package Type |Description Example
Automatic These packages are
Package automatically created by DDM
Inventory. For more
information on packaging, see 2 devices
Packaging Your Network on
page 34.
Multi-object These packages are created by
Package the user, and can contain any g
devices you wish to place in E.ri
them. For more information on 5040 devices

Wirtual Network

packaging, see Packaging Your
Network on page 34.

Any map window can contain packages. You can modify the contents of a package (selecting
objects or groups of objects) exactly as you can in the Main Map.

As with other icons, you will sometimes see package icons with colored rings around them
(when you select an alarm type). The color of the ring around the package depends on the
color of rings around objects inside the package. The ring around the package icon will match
the most severe alarm of the devices in the package.

For example, if there are Critical (red), Minor (gold) and Info (green) rings inside a package,
the package will have a Critical (red) ring.

For more information on packaging, see Packaging Your Network on page 34.
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lcon Appearance

The following table shows a device icon in the possible states as it will appear on the Network

Map.

Table 5 Icon Appearance

Appearance

What it means

i XP Pro
win.example.com

Normal Icon

This is how a device icon will appear when:
e no alarms are selected

e an alarm has been selected but that type of
alarm does not apply to this device

e an alarm has been selected but this device is
not in the priority range

i XP Pro
win.example.com

Colored Ring
A thin gray ring will appear around a device when:

e this device is in the priority range

e this device is not alarmed

A colored ring will appear around a device when:
e an alarm is selected that exists on this device

e this device is in the priority range

Faded Icon

If an object appears faded, that means DDM
Inventory has not seen that device for more than 24
hours. DDM Inventory will eventually deactivate
such a device from the Network Map and,
eventually, DDM Inventory will purge the device
and all its associated data.

Win 2P Pro
win.example.com

Locked Icons

If you have manually packaged your map
configuration, you will see many icons with a blue
line beneath them, if you have selected the
“Underline locked objects” option in Edit > User
Preferences. The blue line indicates that the device
has been manually packaged by a user, meaning it
has been put inside a package (Package command),
promoted from a package (Promote), or has had its
package removed (Unpackage).

DDM Inventory does create some automatic
packages. They are created during discovery and
whenever you use the Pack or the Unpack All
commands.

For more information on packaging, see Packaging
Your Network on page 34.
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Table 5 Icon Appearance

Appearance

What it means

in XP Pro
win.example.com

Selected Icon

If you select an icon on the Network Map, it will
appear dark.

iil««h

Win ¥P Pro
win.example.com

Found Icon

This icon was located on the Network Map using
the Locate feature.

Note: For packages, the large yellow circle
indicated that you have just left this package, as
you are navigating through the Network Map. Also
note that the package tag is a different color after
you have been inside the package.

.4

i XP Pro
win.example.com

Deactivated or Hidden Icon

This device has been manually deactivated or
hidden by an Admin account. It will disappear from
the Network Map at the end of the next network
poll cycle.

Customizing the Network Map View

There are several ways you can change the look and feel of your Network Map. Your
account-type determines the preferences and properties you are allowed to change.

All accounts can change preferences such as line style, background color, background image,

and scale.

Administrator or IT Manager users have the option of changing Device Properties such as
device icon, device title, and so on (from the Network Map, click Device > Device Properties).

These properties will affect all accounts.

Changing Map User Preferences on page 29 explains several ways that you can use to change
the look of your Network Map.

Changing Map User Preferences

Topics in this section include:

e Map Preferences on page 30

e Placing an Object at the Top of the Map Window on page 31

e Layout on page 32

e Promoting Objects on page 32

e Reverting Your Map Changes on page 32

Using the Network Map
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Map Preferences

You can change the look of your Network Map in several ways. To open this dialog from the
Network Map, click Edit > User Preferences.

= User Preferences - Server
[ Hetwork Map | Health Panel |

9(=1E

Line Style Background
) Step @ White
) Straight ) Gray

() ZigZag ) Black
@ Arc

Scale | 100

Options

Show pop-up info

[_] underline locked objects
Confirm packaging commands
Truncate object titles

[] open Health Panel too

Table 6 Map Preferences

Preference Description

Line Style This option lets you choose which style of line to draw
to connect objects in a Network Map window. You can
change this setting from the default (straight)
whenever you wish.

Background This option lets you choose the background color for

your map windows.

Show pop-up info

This option lets you choose whether an information
box associated with an object or a line appears when
you position the mouse pointer over an icon.

Underline locked
objects

This option lets you choose if locked objects should be
underlined in all map windows. Objects that are
“locked” from a packaging status are shown with a
blue line under the icon.

Typically, objects acquire locked status when they are
packaged by a user. When an object is locked, DDM
Inventory does not package or unpackage it
automatically.

Confirm packaging
commands

This option lets you choose if you will require
confirmation when using packaging commands such
as Layout, Make Top of the Network, Unpackage, Pack,
Unpack, and Unpack All.

You receive a confirmation question that gives you
time to reconsider what you are doing. You can turn
confirmation messages off, if you wish.

30
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Table 6 Map Preferences

Preference Description
Truncate object This option lets you choose if you want to truncate
titles object titles on your map. Sometimes, the object titles

are very long, and DDM Inventory will automatically
truncate them to save space on the map. If you would
rather have the full object name appear on the map,
you can change it.

Scale This option lets you choose the scale for all map
windows.

Also, the scale slider appears on every map window.
You can click this and change the scale to from as
small as 1% up to 200%. You can also type in a
number into the text box, and hit Enter on your
keyboard to initiate the change.

You can also use the Zoom In and Zoom Out commands
to change the scale of one map window at a time.

Open Health Panel | This option lets you choose if the Health Panel will
with Network Map | automatically be opened when you click open the
Network Map.

Note: This setting does not affect the Aggregate
Health Panel.

Placing an Obiject at the Top of the Map Window

When you are organizing a map window, you can assign one object to appear at the top of the
window. This object should be of special significance in relation to the other objects in the
window.

DDM Inventory may not have been running long enough to show the right device at the top of
the map, or you may know a top-of-network router or a core device would make more sense.

) This preference will affect the current map configuration file.

To place an object at the top of the map window:
1 Select an icon.
2  Click Configure > Top of Network.
A confirmation message appears.
3 Click Top of Network.

The window is redrawn with the selected icon at the top.

To reset the top object for the window to the default chosen by DDM Inventory:

1 Select the icon at the top of the map window.

The Top of Network command should have a check mark with it, indicating that you have
previously chosen this object to be at the top of the window.

2  Click Configure > Top of Network.
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A confirmation message appears.
3 Click Top of Network.
The window is redrawn with the default icon at the top, as chosen by DDM Inventory.

Layout

The Layout command reorganizes the layout of the active map window, then redraws the
window. Use it to tidy a map with confusing layout and crisscrossing connections.

To clean up a map window:

¢ (Click Configure > Layout.

This command will destroy any custom layout, but will not affect any of the packaging.

Promoting Obijects

The Promote command moves the selected objects to the window one level above the current
window (in terms of hierarchy, not screen space).

To promote an object:

¢ Click Configure > Promote.

This command locks all selected objects (unless they are promoted into the Main Map).

When the last object is promoted out of the package, the package is destroyed.

Reverting Your Map Changes

If you are making changes to your map layout, and decide not to save your changes, you can
Revert your map. This way, the autosave function will not save your changes.

This feature works for changes to your map layout and packaging. Changes to the device
properties (device tag, title, icon, or priority) or port properties cannot be reverted.
To revert your map fo the version you last saved:

1 Click File > Revert.
A warning dialog appears.

2 Click OK.
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Changing the Map Background Image

You can add images to your Network Map background (main map and packages).

There is a library of images you can select, all of which are available to all users. An
Administrator or IT Manager account can add more pictures to the library (see Managing
Your Background Image Library on page 34).

Map Background Image [ %]

rChoose Image rManage Library |

" Ho background image

@ Use library image:

| globalCorporation.png V|

) Test local image file {will not be saved):

| | | Browse

Apply || 0K || Cancel

To test an image file from your computer:
1 Click Configure > Background Image.
The Map Background Image dialog appears.
2 Select Test Local Image File and browse to find the file you want.
3 Click Apply.

’ This background will not be saved as part of your map configuration. Only files in
the image library can be saved.

To select an image file from the library:
1 Click Configure > Background Image.
The Map Background Image dialog appears.
2 Select an image from the image library pull-down list.
3 Click Apply.

The image will appear as the background of your map window. By default, the image will
cover the entire map window. You can alter the size of the image by clicking and dragging the
image from its bottom-right corner.

Click here

and drag to
% resize the

image.
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Managing Your Background Image Library

ot
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An Administrator or IT Manager account can add and delete images from the DDM Inventory

image library. These images are available to every user, regardless of account type. .

If you add images that are larger than 250KB, you may notice the Network Map scrolling
slowly

You will notice that the background images are dimmed slightly, so the image colors will not
interfere with the map icons and lines. If you add your own images to the library, DDM
Inventory will automatically dim the images, so you need not alter your graphic files before
adding them to the library.

( Choose Image I[ Manage Library
Image Marme . | Diate |
africaEurasiaGlobalMap png 2004-03-03 20:42
americazGlobalhap phg 2004-03-03 20:44
europedutine prg 2004-02-24 18:32
europeReal png 2004-02-24 18:32
globalCorporation phg 2004-03-02 12:56
gradientGlobalMap phg 2004-03-03 20:20
itolevice prg 2004-03-02 12:58
japanGlobalMap . phg 2004-03-03 20:37

To add an image, specify an image file and press "Add"™

| | Browse

To add an image to the library:

1

Click Configure > Background Image.

The Map Background Image dialog appears.
Select the Manage Library panel.

Click Browse and search for your image file.

Click Add.

To delete an image from the library:

1

Click Configure > Background Image.

The Map Background Image dialog appears.
Select the Manage Library panel.

Select the file you want to delete.

Click Delete.

Packaging Your Network

You can group objects into packages so that the map is more organized and easier to

understand.
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Regardless of your account type, you can package the network any way you want. You can also
save different layouts and packages into map configuration files.

Topics in this section include:

e How Packaging Works on page 35

e How You Can Request the Creation of Packages on page 36

e How You Can Create Your Own Packages on page 37

e How You Can Unpack Your Packages on page 38

e How to Create Locked Objects on page 38

e How to Change the Automatic Packaging Preferences on page 39

How Packaging Works

By packaging devices, you can reduce the size of the Network Map. You can package your
network differently in each map configuration file.

You can create packages to represent hierarchies, such as campuses, buildings, floors in
buildings and so on. There are many package icons available to help you create the desired
look and feel of the Network Map.

There are two types of packages: the type DDM Inventory creates automatically and the type
you can create yourself.

One application of multi-object packaging is mapping the network at a physical location, such
as a city. For example, in the figure below, the main map contains a package for Building 1.
Drilling down one level, the Building 1 map contains packages for the first floor and the
server room. Drilling down further, you reach the devices for the “server room” within the end
node package.
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How You Can Request the Creation of Packages

DDM Inventory can create packages for you. This is a quick way to reduce the size of the
Network Map. DDM Inventory will create a package for each port of the device at the top of
the network. Each package will contain the devices connected to that port.

To have DDM Inventory create your multi-object packages:

1 Select a map window.
2  Click Configure > Pack.
You are asked to confirm the action.
3 Click Pack.
The Pack command does not lock your objects on the Network Map.

The Pack command does not delete any existing packages. However, the Pack command will
remove any other layout changes you have made.

If you wish, you can open each package and click Pack again to continue packaging your
network.
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Multi-object packages can be created by the user. DDM Inventory can create them with the
Pack command, but if the packages are to be meaningful to you, it is best to create them
yourself.

Exception: While customizing your network, you may decide to use the Unpack All command.
This command will destroy all the packages you have created. However, DDM Inventory will
recreate all of the automatic packages.

How You Can Create Your Own Packages

Ty

If you wish, you can create your own packages as well. Packages you create are called
multi-object packages. How you package the Network Map will depend on how your network
is connected, and on how you want to view the map. You are not changing the actual
connectivity of any devices only how you view them on the map.

Remember, you can create many different map configuration files, each with different
packaging.

You can add new devices to a package at any time by dragging the icons on the map, or
between map windows. However, your layout may change when you drop new devices into a
package:

e Ifthe package has been laid out by the user: when adding new devices, DDM Inventory
places them without moving any of the other icons.

e Ifthe package is in “auto-layout” mode: when adding new devices, DDM Inventory places
them and moves the other icons around as well.

Here are three quick procedures that will show you how to create your own packages.

To create a new package with objects in it:

1 Click an object icon, or select a group of objects.

2  Click Configure > Create Package.

To create a new package with objects in it:

) This method is handy for tidying up devices connected to a Logical View icon.

1 Right click an object that has dependent objects.
2 Select Create Package.

The object will absorb any dependent object that:

* isnot packaged

¢ isnot locked

e does not have another connection

To change the icon and title of your package:

1 With the package icon selected, click Package > Package Properties.
2 Select a custom package icon from the pull-down list.

3 Enter a custom title for the package.

4 Click Apply or OK.
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How You Can Unpack Your Packages
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To move the contents of the active package up one level:
¢ From the package window, click Configure > Promote All.
This command causes the following:

e Only the current package window is destroyed. Packages within the current package are
not destroyed.

e Unlocks all objects.

e Automatic packages that were within the window are repackaged.

In the Main Map window, this command is replaced by Unpack All.

To unpack the entire Network Map, and destroy all packaging:

e From the Main Map window, click Configure > Unpack All.
This command causes the following:

e All packages are destroyed.

e Unlocks all objects.

e Automatic packages are repackaged.

In a package window, this command is replaced by Promote All.

To empty one package:

e From any map window, with a package selected, click Configure > Unpackage.

This command causes the following:

e Causes the selected package to be unpackaged, which also deletes the package

e Locks all objects within the package (unless they are unpackaged into the main map).

Available to single packages only.

How to Create Locked Objects

If you have manually packaged your map, you will see many icons with a blue line beneath
them, if you have selected the “Underline locked objects option in Edit > User Preferences. The
blue line indicates that the device has been manually packaged, meaning it has been put
inside a package (Package command), promoted from a package (Promote), or has had its
package removed (Unpackage).

Win XP Pro
win.example.com
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When you manually package or unpackage an icon, you lock it into position. For example, if
you take a workstation icon from a package and place the icon on the Network Map, that
workstation icon will be locked there.

DDM Inventory creates some automatic packages. Whenever you use the Pack or the Unpack
All commands, DDM Inventory will recreate all automatic packages. To keep a device from
being automatically packaged, you can lock the device by using the Lock command.

To use the Lock command:
e Click Configure > Lock.

’ To see which objects have been locked, turn on View locked objects. An icon you have moved
yourself—into a place DDM Inventory would not naturally have chosen—will have a blue line
beneath it to indicate that it is locked.

How to Change the Automatic Packaging Preferences

Automatic packaging is based on connectivity. There are a few basic scenarios:
e device with one connection to a single connectivity device (such as a router or switch)
e device with multiple connections to a single connectivity device

e devices connected to a cloud or phone, which has a single connection to a connectivity
device (in this case, the cloud or phone is also packaged with the devices)

DDM Inventory automatically creates packages, based on the major connectivity devices in
your network.

These packages appear on your map with the label “X devices for Y” where X is the number of
devices (this number is constantly updated as devices are added to or removed from the
package) and Y is the name of the connectivity device.

Connectivity devices will have other devices associated with them (for example,
workstations). DDM Inventory automatically packages the devices associated with that
connectivity device.

) DDM Inventory usually treats a telephone as an end-node, but it may see it as a connectivity
device.

By default, whenever DDM Inventory detects two or more end nodes of any classes, it creates
a package to contain those objects. If it detects 3 or more objects of the same class (for
example, workstations) it will create class-specific packages. The default is 3, but you can
change this threshold if you wish.

Also by default, whenever DDM Inventory detects 10 or more network devices, it will
automatically package those devices.

The defaults work well with most networks. You can change them to package the network in a
particular way.

’ If you have an Administrator account, you can change whether or not each class of device is
packaged.

There are seven automatic package types available:
e Workstations

e Servers
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Printers
POS/ATM
Controllers
Unknown
Network Devices

End Nodes

The End Nodes package is a generic package type. If there are devices that do not fit the
thresholds of another package type, those devices may fit into a generic End Node package.
There are also three device icons native to this package type.

Automatic packaging settings do not affect your ability to create custom packages.

To create automatic packages of a particular type:

1 Click Administration > System Configuration > Automatic packaging.
LD B i
EEgEreeenas " B 7
ElEa ke Ny A= )
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L e L E ] .
Primary Selection: POSIATH g ofonsl [
;;\mary Selaction: Controllers &L ozl [
Pf;maw Selection: Unknown %2 [ond [
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Emawiiject\on: End Nodes "Lg On = |2—
AT TR LS
HEEELE =R
EEEEEEERRE
B8R nBIHDER
@A=RN?
Submit | Restore Defauts |
2 For the package types you want to create, turn the package type On.
3 Select a threshold for each type of package.
4 To prevent a class of devices from being packaged, turn it Off.
5 Click Submit.
6 To restore the default settings, click Restore Default.

Examples on page 41 provides specific packaging guidelines depending on your use case.
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Examples

If you don't usually monitor end nodes, you should package all types of end node into a single
type of package:

1 Set these controls Off:
— Workstations
— Servers
— Printers
— POS/ATM
— Controllers
— Unknown
2 Set this control On:
— End Nodes
3 Set the End Nodes threshold to 2.

If your network contains many servers for which you are responsible, you should package
servers separately, but allow all other end nodes to be placed in a single type of package:

1 Set these controls Off:
— Workstations
— Printers
— POS/ATM
— Controllers
— Unknown
2  Set these controls On:
— Servers
— End Nodes
3 Set the Servers threshold to 1.
4 Set the End Nodes threshold to 2.

If you are responsible for the three most common types of end nodes (workstations, servers,
and printers), you should package each type separately for easy locating and identifying.

1 Set these controls Off:
— POS/ATM
— Controllers
— Unknown
2 Set these controls On, and set each threshold to 1:
— Workstations
— Servers
— Printers

— End Nodes
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Organizing Map Configuration Files

What

DDM Inventory lets you save different map configuration files. Each of these map
configurations contains your layout and packaging. You can save as many configurations as
you want, so you can quickly change your view of the Network Map.

These configuration files are saved (by default) at this location:
C:\Documents and Settings\All Users\Application
Data\Hewlett—-Packard\DDMI\Topology\config

If you backup your system data, these configuration files will be included. For more
information on creating a backup, see the Installation and Initial Setup Guide.

For example, you may want to concentrate on one particular building or campus. So you create
a map configuration that shows that campus, and all your important devices there. In another
map configuration, you may want to see an overview of the entire network.

Topics in this chapter include:

e What is a Map Configuration? on page 42

¢ Prime Configuration on page 43

e Saving Your Changes on page 43

e Starting a Map Configuration on page 43

e Saving a Map Configuration File on page 43

e Saving the Prime Map Configuration on page 44

e Opening a Saved Map Configuration File on page 45
e Managing Map Configuration Files on page 45

is a Map Configuration?

DDM Inventory automatically opens a map configuration file at the start of each map session.
The first time a new account starts a map session, this is always a copy of the Prime
configuration. All other times, the map configuration file that DDM Inventory opens depends
on the type of account you are using.

Table 7 Default Map Configurations

Account type Subsequent default file
Demo Copy of Prime

IT Employee last opened or designated
IT Manager last opened or designated
Administrator last opened or designated

When you end a map session, DDM Inventory takes note of what map configuration file is in
use. The next time you start a map session, DDM Inventory opens that file. There are two
exceptions:

¢  You can designate a different configuration file to be opened next time.
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e Demo accounts always start a map session with a configuration called “Copy of Prime”.
This is so that each user of a Demo account can start fresh, unaffected by previous users.

Demo accounts can open a saved configuration if they want to pick up where they left off.

Prime Configuration

The Prime configuration is a special configuration not associated with a particular account.
As the owner of an Administrator account or an I'T Manager account, you control the Prime
map configuration. The Prime configuration can serve as a basis or starting point; people can
copy it and make their own configurations.

’ If you have just installed and set up DDM Inventory, you will notice that the Prime
configuration does not exist. First, an Administrator account or IT Manager account must
save a Prime configuration with the Save As Prime command (in a Network Map window, click
File > Save As Prime).

Any user can open a copy of the Prime configuration in the Network Map by clicking File >
Open Copy of Prime.

Saving Your Changes

Each account may save one or more named map configuration files. Each file contains
information on the account’s Network Map, and priorities, layout, packaging, package icons
and titles.

An account owner can use the different map configuration files for different purposes. For
example, one configuration file could show the network geographically, and another
configuration file could show the network by subnets.

An account may open a different configuration at any time. Once saved, this configuration
becomes the “current” configuration and will be used for the next map session.

) Your current configuration is normally the one active when you exit the Network Map, but
you can alter this with the Manage Map Configurations option.

Each account has the configuration files saved in a separate space. Therefore, each account
may have a configuration named “test” without interfering with other accounts.

Starting a Map Configuration

) A new configuration will be labeled “Untitled” until you save it, at which time you are able to
name the file.

To start a new map configuration:

e (Click File > New.

Saving a Map Configuration File

Creating a specific configuration name enables you to see your configuration the next time
you log in to the Network Map.
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A configuration name must be 1-30 bytes long (the number of characters depends on
language encoding). You can use the following characters:

e A through Z (upper case)
¢ a through z (lower case)
e 0 though 9 (numbers)

e underscore ()

e hyphen (-)

To save a map configuration:

1 Click File > Save As.
2 Enter the new configuration name.
3 Click OK.

Also see Autosave.

Autosave

DDM Inventory provides an autosave capability for recovery purposes by saving the “current”
configuration to a recovery file. DDM Inventory will make an autosave file (within a time
period ranging from 10 seconds to two minutes, depending on the changes made by the
account). If a session ends abnormally, the recovery file will be used the next time you open a
map.

When you next open a map, you will see the message “Restored configuration from autosave”
to remind you that a recovery has occurred. In the event that DDM Inventory uses the
recovery file, the user still has the opportunity to discard the unsaved changes and re-open
the configuration that represents the state of the last explicit save.

’ Autosave will not overwrite your named configuration. When you respond “no” to the
question “Do you want to save the changes?”, you are discarding the active changes and the
autosave file. The autosave file is also discarded when you save a configuration.

Saving the Prime Map Configuration

The Prime map configuration is the default configuration for all accounts. Any account can
open the Prime map configuration, but only Administrator and IT Manager accounts can
change it. IT Employee and Demo accounts must save their changes under a different file
name.

To save the Prime map configuration:
1 Click File > Save As Prime.

A confirmation box appears, asking if you really want to save this configuration as the
Prime configuration.

2 Click Save As Prime.
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Opening a Saved Map Configuration File

You can only open your own configuration files with this procedure. If you wish to use the
configuration file of another account, you must first copy that file into your account.

) When you open a configuration file, all open package windows close. The Device Manager
windows, Port Manager windows, Line Manager windows, Network Map, and Health Panel
stay open.

To open a saved map configuration:

1
2
3

Click File > Open.
Select the file name of the configuration you wish to use.

Click OK.

Managing Map Configuration Files

This section applies to all accounts, except for the demo account. The demo account cannot
perform any administration functions. The other three types of accounts can perform the
following tasks:

copy map configuration files
delete map configuration files
rename map configuration files

choose which map configuration file will be the one that opens first (Make current)

) Close your map before performing any of these procedures.

To reach the Administration menu, click the Administration button.

To copy a map configuration file:

1

o O A WN

Click Administration > My map configurations > Manage map configurations.
Select a configuration file from the first pull-down list.

Select Copy.

Click Next.

Enter a name for the new configuration file.

Click Finish.

To delete a map configuration file:

1

u A w0 N

Click Administration > My map configurations > Manage map configurations.
Select a configuration file from the first pull-down list.

Select Delete.

Click Next.

Click No to delete the file.

Using the Network Map
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To rename a configuration file:

1 Click Administration > My map configurations > Manage map configurations.
Select a configuration file from the first pull-down list.

Select Rename.

Click Next.

Enter a name for the new configuration file.

Click Finish.

o 0 A WN

To choose which map configuration that will open first:

The command, Make Current, makes a map file the first one you see when you open the
Network Map.

1 Click Administration > My map configurations > Manage map configurations.
Select a configuration file from the first pull-down list.

Select Make Current.

Click Next.

u A w0 N

Click Yes to make this your default map configuration.

Also see Sharing Map Configuration Files with other Accounts.

Sharing Map Configuration Files with other Accounts

You can make it possible for other accounts to make copies of your files, but you cannot
actually send a file. The procedure is simple and quick. First, you make sure that your
account has its permissions set correctly. Next, the user with whom you want to share the file
requests it.

To permit others to share your map configuration files:
1 Click Administration > My account administration > Modify properties.
2  Click Account Properties.

3  Select “Yes” from the “Allow others to copy map configurations?” radio button. (If “Yes” has
already been selected, your task is complete.)

4 Click Modify Properties.

You have just permitted all users to copy all your map configuration files.

What the other user must do:

’ The other user must not have a map session open.

1 Click Administration > My map configurations > Copy map configurations.

Select an account name (of the person whose file they want to copy) and click Next.
Select a configuration file and click Next.

Enter a name for the configuration file.

Click Finish.

u A w0 N

The other user now has a copy of one of your map configuration files.
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Saving a Map Window as a Graphic File

You can save any map window (the main map, or any package) as an image file (either jpg or
png).

To save your map as an image file:
1 Click File > Save Map Image.
The File Chooser dialog appears.

2 Enter the name and location of the image file you want to save.
Select a file type.
4 Click Save.

.1, save Map Image - File Chooser

Look In: |ﬁ My Documents - | @ @ @ @E

3 Adobe

|j My eBooks

|j My Pictures

T My Received Files
|j Security

D networkmap.jpg

File Hame: || |
Files of Type: | Image file {*jpeq, *jpg, *.png} hd |
Save Cancel
Using the Network Map
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4  Using the Service Analyzer

The DDM Inventory Service Analyzer allows you to analyze the network path between two
devices. To get started with the Service Analyzer, you must identify the devices at the ends of
the path you want to analyze.

Topics in this section include:
e  (Choosing Your Path on page 49

e Service Analyzer Window on page 50

Choosing Your Path

The toolbar contains two search boxes: From and To. Each box searches for a device based on
its name, title, or address. This Find window works exactly the same way as the global Find
feature. For more information, see Finding Network Devices on page 11.

To use the Service Analyzer:
1 From the DDM Inventory navigation tree, click Service Analyzer.

) You can also open the Service Analyzer from the Device Manager. That device will
be the first device in the Service Analyzer query.

Fron: | Ho device i " &J Tao: | Ho device S~ | ..

| All alarms w7 | Paths: I\ w7 | Devices: 0 ;}‘/ %

L]

N
Find for Service Analyzer Clle the “Find”

T H icons, and the Find

Match value: | | Count: 0

| Device o [ P address [ dlalog appears.

~Enter the devices
you want to locate.

Cancel

2 Click the first Find icon.

3 In the Match value box, enter the IP address or the first few characters of the device
identifier for the first device that you want to find, and press Enter.

4 Select a device from the Find dialog and click OK.
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5 Repeat step 2 to step 4 for the second Find icon.

) It is important to fill in the device on the left first. Changing the device on the left
side will automatically clear the device on the right side.

Service Analyzer Window

Topics in this section include:
e User Interface on page 50
e Path Diagram on page 51
e Full-Path Graphs Tab on page 51

User Interface

After you provide valid endpoints for the path to be analyzed, the Service Analyzer displays a

diagram of the path in the upper pane and a graphical representation of performance
information for that path in the lower pane.

In the following example, the lower pane shows the rate of collisions observed over a 48-hour
period. To see the number of broadcasts or errors that took place during this same 48 hours,
you would click the Broadcasts button or the Errors button.

5 Service Analyzer - My Server

File Edit View Tools Help
From: ‘ ? rtri10.acme.us.com hd H&‘ To: | ‘{T'- Srurd21.acme.us.com hd || *|
- | All alarms '| Paths: ‘A(NJ%) - ‘ Devices: 7 | @ ﬂ
10 u
L+ L = [N}
F‘ F‘ _/q. - o
Cisco 2651 Cisco 3725 Catalyst 2912 XL unmanaged hub 3 HP 3200 Hub P th
rr010.acme. Lus.com  pr32S.acmeus.com  switch047 . acme. Lus.com certhub.adme.us.com a
< Diagram
9000/700 Series default cloud 7
srurd21.acme us.com
-
Collisions H Broadcasts ” Errors

0.12

.10 Performance
alia Information

0.060
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=
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-
pai
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=
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] ~ ] @ @ ] [ -
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[Tlarms | Full Pathy Graphs [ Siribite Graphe
Routing Server

Tab Selector
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Path Diagram

You will notice that the path diagram has a similar look to the Network Map. The path
diagram presents only devices and lines. Packages are not shown. In the Paths drop-down list,
multiple views are available to display the data for different paths between the two devices.

’ If there is only a single path, it will be the only choice. The percentage indicates how
frequently a path was taken. If the sum of the percentages is less than 100, this indicates that
a path was not available at some point during the preceding 48 hours.

Full-Path Graphs Tab

The Full-Path Graphs tab shows a summary of the entire path for the following alarm
categories:

Table 1  Graphs

Alarm Category Notes

Collisions Collisions per seconds; for ports
Broadcasts Broadcasts in frames/sec.; for ports, bi-directional
Errors Errors in frames/sec.; for ports

You can click any of the buttons to view the related alarm category. All graphs display traffic
levels for the last 48 hours across the entire path.
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5 Using the Health Panel

There are many ways to look at your device data with DDM Inventory. The Health Panel
allows you to see your devices, and to determine the devices that currently have problems.

Typically, a user would start with the Health Panel, which lists all the alarms currently on
your network. To see a list of devices with these alarms, double-click on an alarm category in
the Health Panel, and the Alarm Viewer opens. The Alarms Viewer is described in Using the
Alarms Viewer.

Topics in this chapter include:
e Viewing Network Overview with Health Panel on page 53
e Using the Aggregate Health Panel on page 55

Viewing Network Overview with Health Panel

The Health Panel enables you to set up, highlight, and examine conditions, alarms, and
statistics that DDM Inventory has gathered about your devices. To change which Alarms are
displayed, see Customizing the Alarms List on page 54.

: Health - Server E“E”z]

File Edit Yiew Tools Help

% [4f Device AddsMeletes v | 3.6 |v | (7 M

BlErtmn . m(e| s + |
i Port AddziDeletes a4
= Part Changes
E Device AddsiDeletes BB
¥ E Device Changes 23
A | [ Exceptions &0 | 53
% @ Mot Recertly Seen 12
Devices Ports Availabilty Frames'/s Errors's
242 182
- 1:13 P

) The Health Panel is automatically updated with current device information.
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There are icons on the Health Panel to distinguish device and port alarms. The Health Panel
is divided into sections as indicated by these icons:

Table 1 Alarm Indicators

Category Indicator
Port Attribute Alarm

—
Device Attribute Alarm

1

Port Report Alarm E-

Device Report Alarm @

The Health Panel will show you how many devices have alarms. You can drill down with the
Alarms Viewer to see exactly which devices have the alarms. For more information, see Using
the Alarms Viewer.

Table 2 Health Panel footer

Statistic Explanation

Devices The number of discovered devices in the network.
Ports The number of discovered ports in your network
Availability This number represents the number of real devices

with priority 3 (or higher) that are operational as a
percentage of the total number of real devices with
priority 3 (or higher).

Frames This number represents the instantaneous number of
frames per second seen on the entire network.

Errors This number represents the instantaneous number of
errors per second seen on the entire network. This
includes the number of errors on both the “in” and the
“out” ports of the network devices.

Customizing the Alarms List

The following sections describe how to customize the appearance of the Health Panel.
e My User Alarms on page 54
e Hide Inactive Alarms on page 55

My User Alarms

You can change the appearance of the Health Panel so you see only the alarms in which you
are interested.
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To customize the alarms shown on the Health Panel:
1 From the Health Panel, click Edit > User Preferences > Health Panel tab.
Here, you can create a list of the alarms you want to see on the Health Panel.
2  After you have created your list, click Apply.
3 Click OK.
Next, you must select these changes in the View menu.

4 Click View > My User Alarms Only.

Hide Inactive Alarms
You can hide the categories that currently have no alarms associated with them.

To hide the inactive alarm categories:

e (Click View > Hide Inactive Alarms.

Using the Aggregate Health Panel

The Aggregate Health Panel looks similar to the regular Health Panel; it has all the same
buttons and statistics. However, the Aggregate Health Panel combines all the statistics from
all the aggregated DDM Inventory servers in your network.

You can click on the report buttons to see complete lists of all alarms in the entire network. If
you were looking at a regular Health Panel for one server, you would only see alarms for a
portion of your network.

’ You can tell what Health Panel you are looking at by the report banner. If it is the Aggregate
Health Panel, the banner says “Aggregate Health” rather than “Health Panel”. A “globe”
symbol also shows that you are looking at an Aggregator.

The statistics listed in the Aggregate Health Panel are the same as those listed in the regular
Health Panel.

To open the Aggregate server Health page, click the Servers button.

Servers button

Clicking the servers button at the bottom of the Health Panel takes you to the Aggregate server
Health page. This page shows you a summary of the health status of all your remote DDM
Inventory servers.

By clicking on any of the server hyperlinks on this page, you can see the server Health page for
that DDM Inventory server.

’ The local DDM Inventory server is always at the top of the list with an asterisk (*).
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6 Using the Alarms Viewer

There are many ways to look at your device data with DDM Inventory. The section, Using the
Health Panel, tells you how this is done with the Health Panel. This section explains how to
use the Alarms Viewer with the Health Panel.

Typically, a user would start with the Health Panel, which lists all the alarms currently on
your network. To see a list of devices with these alarms, double-click on an alarm category in
the Health Panel, and the Alarm Viewer opens.

The Alarms Viewer shows all the devices on the network with current alarms. From the
Alarms Viewer, you can open up the Device Manager, Port Manager, or Attribute Manager.

Topics in this chapter include:

e Using the Alarms Viewer on page 58

e Using the Aggregate Alarms Viewer on page 59
e Saving Data to a Text File on page 59
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Using the Alarms Viewer

The Alarms Viewer is an extension of the Health Panel and shows you exactly on which
devices and ports the alarms have occurred. By double-clicking on a line in the Health Panel,
you will open the Alarms Viewer. The Alarms Viewer works with the Health Panel to show

you which devices on your network have Critical, Major, Minor, or Info alarms.

= Alarms Viewer - Server

File Edit Yiew [Device Port

Attribute  Tools Help

% [il Device Changes. 'l 3-6 |'| Alarms: 231 | I | I | Bl
Priw i Device Rf'%ort ; Yalue Update Time -

] & FRIC % | @Y Device Changes: Default T... | Win 2000 Server (P Cnly Device) | 2006-05-20 09, |—

3 & FRIC * E Device Changes: Default Ti... | FRIC (15173.152.82) 2006-05-2809..

3 | e | GIGAEYTE #* | ¥ Device Changes: Defautt Ti... | GIGABYTE (15.178.181.118) 2006-05-2009..

5| e | HASEK * E Device Changes: Default Ic... | Dizcovery Server (Unknoan) 2006-05-2909...

3 | e | HASEK * E Device Changes: Defaut P |3 (1) 2006-05-29 09, .

3 | i | HASEK #* | By Device Changes: Defautt T... | ED 2.0.3 (IP Orly Device) 2006-05-2909... | =

5 | e | HASER * Device Changes: Default Ti... | HASEK (15178181 .102) 2006-05-2309...

3 S| ISR ADY L * Device Changes: Default 1. | Win2000 Server (Unknosan) 2006-05-29 09,

3 5| 1SN ALY L * ¥ Device Changes: Default P | 3(1) 2008-05-29 09, ..

3 a | |S-VW2KADVQA * E Device Changes: Default T... | Win 2000 Server (IP Only Device) | 2008-03-2909..

3| T | 1EWaHADYGL * Device Changes: Default Ti... | IS~W2HADYWEA (172.23.7.12) 2006-05-2009..

3| e | MIG * H Device Changes: Default lc... | Discovery Server [Unknown] 2006-05-29 09,

3| MG * E Device Changes: Defaut P, |3 (1) 2006-05-29 09,

3 | | MIG * Device Changes: Default T... | ED 2.1 (P Only Device) 2006-05-29 09,

G| e | WG * { Device Changes: Default Ti... | MIG (15178181 124) 2006-05-28 03,

3 %1 MNT4TERMOT * E Device Changes: Default e | WinNT Server (Unknoven) 2006-05-29 09, .

3 MT4TERKMOT % | f¥ Device Changes: Defaut P... |3 01) 2008-05-29 09, .,

] MT4TERMO1 * E Device Changes: Default T... [NT 4.0 Server (IF Cnly Device) 2006-05-2909...

3 MT4TERMO1 * Device Changes: Default Ti... | MTATERMO1 (172.237.149) 2006-05-2809..

3 MT4TERMOZ * ¥ Device Changes: Default ... | WIRMNT Server (Unknown) 2008-05-29 09, .,

3 % MT4TERMOZ * E Device Changes: Defautt P, | 301 2006-05-2509..

3 % MNT4TERMOZ * Device Changes: Default T... | MNT 4.0 Server (P Only Device) 2006-05-29 09,

3 MT4TERMOZ * Device Changes: Default Ti... | NT4TERMOZ (172.23.7.157) 2008-05-29 09, ..

3 E MT4TERMOS * E Device Changes: Default lc... [ WinNT Server (Unknovwn) 2006-05-2909.. =

BT ATEC Y PN . S wn a

The status bar in the Alarms Viewer is similar to that on the Health Panel. You can change
the displayed alarm type or priority with the pull-down lists on either window. Your selection
will appear in the Health Panel and the Alarms Viewer.

The Alarms Viewer will show a maximum of 1000 alarms.
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Using the Aggregate Alarms Viewer

The Aggregate Alarms Viewer is almost identical to the regular Alarms Viewer. The major
difference is that the Server column shows which server is the source of the alarm data.

. hgpregate Alarms Viewer - Server

File Edit View Device Port Altribute Tools Help

@ | [ Device AddsDeletes | - | 36 \ -|

B

Alarms: 94 ‘ | | | % =

-

Priw Device Server Report Update Time
F] 10551 200 15 176 181_20 Device Deletes
1722383 15_178_181_20 @ Device Adds
1722363 15_17E_151_20 B Device Deletes

default cloud 1
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Device Adcds
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@ Device Deletes
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B Device Deletes
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15 178 181_20

Device Deletes

mike reboot.loran.com
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@ Device Adds

mike reboot loran.com
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B Device Deletes

unmaraged hub 13

15 178 181_20

Device Deletes

po o *
] ] *
F] B *
F] = *
4 Cal *
4 e *
4 o) *
] = *
F] EA *
4 - *
4 ié unmanaged hukb 26 15_176_181_20 * @ Device Deletes
4 -_ unmanaced hukb 27 15_1768_181_20 * B Device Deletes
[ B 154781771 HaiTian * Dievice Adds
4 -5 15478477.21 HaiTian * @ Device Adds
4 g 15173177 23 HaiTian * B Device Ades
[ =] 15178.181 1 HaiTian * Dievice Adds
4 i 1517818111 HiTian * 18| Device Deletes
q F 15.178.183.235 HaiTian * [ Device Adds
4 W 15178.183.236 HaiTian * Device Adds
4 W 15178183238 HaiTian * Device Adds
4 e 17223683 HaiTian * [ Device Adds
4 L] bulk ottawwa loran cotn HaiTian * B Device Deletes
4 - chefault cloud 21 Sergei * Device Adds
4 i default cloud 21 Sergei * @ Device Deletes
4 -_ unmmanaced hub 14 Sergel * B Device Adds
4 - unmaraged hub 15 Sergei * Device Adds
4 = unmanaged hukb 15 Sergei * @ Device Deletes
4 ié unmanaced hukb 20 Sergel * B Device Deletes
-

4

Saving Data to a Text File

You can now use the Save Table Data feature to save selected info into a tab separated value
(. tsv) file in the following DDM Inventory features:

Health Panel
MIB Browser

Find

Alarms Viewer

Service Analyzer

Events Browser

You can save the entire contents of a window, or you can Ctrl-click to select the data you want
to save.

To save data fo a text file:

1

Select the table items you want to save. To select the entire table, click Edit > Select Table.

2 Click File > Save Table Data.

A Save Table Data dialog appears.

Using the Alarms Viewer
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To save data to the clipboard:

1 Select the table items you want to save. To select the entire table, click Edit > Select Table.
2 Click Edit > Copy.

Your selected items have been copied to the clipboard. For example, you can paste it into a
file or an e-mail.

Select a file name and location for the text files.

4 Click Save.
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7 Using the Events Browser

DDM Inventory logs network and access events. The Events Browser can display up to 1,000
events at a time.

An event occurs when:
e A device or port is physically added, deleted, or moved.

e A device or port property is changed by a user (through the Device or Port Properties
dialog) or by the system itself.

An access event occurs when:
e Users access (or attempt to access) or logout of the DDM Inventory server.

¢ An admin or IT manager user writes to a device MIB, updates a device model, changes a
device’s visibility, or changes device properties.

) Only admin accounts can view access events.

For example, DDM Inventory can log an event if it discovers a device has been added to the
network. It may also log an event when a line breaks or if there are too many delays on a line.
The Events Browser shows you a list of events that occurred on lines and devices in your
network during a specified period.

The Health Panel and Network Map give you information about the current state of your
network. The Events Browser gives you historical information. The Health Panel and
Network Map can tell you what’s wrong now. The Events Browser shows you problems that
only patterns over time can reveal.

"- The Events Browser shows events for the past 45 days or up to a maximum of 500,000 events
(whichever is less).

Topics in this section include:
e Kvents Browser on page 61

e Using the Aggregate Events Browser on page 67

Events Browser

Topics in this section include:

¢ Opening the Events Browser on page 62
e Network Events on page 62

e Access Events on page 63

e Toolbar on page 67
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Opening the Events Browser

To open the Events Browser:

¢ On the navigation tree, click the Events Browser link.

OR

¢  From the Health Panel or Alarms Viewer, click Tools > Events Browser.
OR

e  From a Device Manager or Port Manager, click the Events button.

Network Events

All users can see the network events on the Events Browser. The next figure shows an
example of what you will see if you selected All Events from the events pull-down list. If you
select one type of event from the list, the display will change, and you will see only that event
and columns relating to that event-type.

. Events Browser - Server

62

File Edit Wiew Device Port Attribute Tools Help
All events | - | 36 | = | All devices | = |

Q now | - | 3 | Limit: | 20 Events: 20 ! I I I @I:

Evert Time - Pri Device Part Atribute Walue
2008-05-2812:00 |3 | f5 | example_45_server * @ Device Changes: User Title example_45_server [=default=)
2006-05-29 1200 | 3 :;, server?_example * E Device Changes: User Title server?_example (=default=)
2006-05-2911:59 | 3 :;, server_ED * E Device Changes: User Title server_ED [=default=]
2006-05-29 11:37 | 3 :;, example_45_server * E Device Changes: Default Title matleycrue (MOTLEY CRLE)
2006-05-29 11:37 | 3 :;, example_45_server * E Device Changes: Default Tag Wi 2003 Server (Yiware]
2006-05-29 11:37 | 3 :;, example_45_server * E Device Changes: Default Priority | 3 (1)
2006-05-29 11:37 | 3 :;, example_45_server * E Device Changes: Default lcon Win2003 Server (Workstation)
2006-05-29 11:37 | 3 :;, example_45_server |00 | & Q Port Adds: Port 0.0
2006-05-2911:34 | 3 :;, server?_example * @ Device Changes: Default Title skidrowe (15.178.180.235)
2006-05-2911:34 | 3 :;, server?_example * E Device Changes: Default Tag Wi 2003 Server (Yiware]
2006-05-2911:34 | 3 :;, server?_example * E Device Changes: Default Priority | 3 (1)
2006-05-2911:34 | 3 :;, server?_example * E Device Changes: Default lcon Win2003 Server (Workstation)
2006-05-2911:34 | 3 :;, server?_example 00 | * Q Part Adds: Port 0.0
2006-05-2911:31 | 3 :;, server_ED * @ Device Changes: Default Title ironmmaiden (15.178.180.233)
2006-05-29 11:31 | 3 :;, server_ED * E Device Changes: Default Tag Wi 2003 Server (YiMware]
2006-05-29 11:31 | 3 :;, server_ED * E Device Changes: Default Priority | 3 (1)
2006-05-29 11:31 | 3 :;, server_ED * E Device Changes: Default lcon Win2003 Server (Workstation)
2006-05-2911:31 |3 :;, server_ED 00 | * Q Part Adds: Port 0.0
2006-05-29 11:23 | 3 :;, V2K 3ent-02 * @ Device Changes: Default Title W2k 3ent-02 (W2KIENT-02)
2006-05-29 11:23 | 3 :;, V2K 3ent-02 * E Device Changes: Default Tag Wi 2003 Server (IP Cnly Device)

Events Browser columns

Each row in the Events Browser window contains the following information:
Table 1

Data

Explanation

Event Time

The time the event was generated.

Device
Priority

Device type

Small device icon

Device

Device title?
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Table 1 Events Browser columns

Data Explanation

Port Port number (will not appear if a device
alarm is selected)

Alarm type | Alarm type icon

Attribute Name of the alarm
ValueP Numerical value, if any, associated with this
alarm.

a. Ifnodevice title can be determined, the Events Browser title
column is blank. This depends on the Device Title
Preferences as set in Administration > System
Configuration > Display preferences.

b. There will not be a Value column for Line and Device Breaks.

“Broadcast In” and “Broadcast out” alarms are not logged, due to the potentially very high
number of events. “Source of Broadcast” alarms are logged.

Access Events

Only admin accounts can view access events on the Events Browser. You can select any of the
these event types to view:

e Server Access

e SNMP Write by MIB OID
e SNMP Write by Attribute
e Port Adds/Deletes

e Port Changes

¢ Device Adds/Deletes

e Device Changes

e Update Model

You will notice that the Port and Device events are listed in the Network Events panel as well
as the admin-only Access Events panel. The same events are listed in both panels, but under
Access Events, you can see more details about where these changes originated: the source IP
address and account name.

Similar to the network events list, the columns will change depending on the type of event you
choose to display.

Server Access events show the following data:

Table 2 Server Access Events

Data Explanation

Event time the time of the access event
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Table 2

Server Access Events

Data

Explanation

Account name

the user accessing DDM Inventory

From IP

the IP address from which the user accessed DDM Inventory

Access status

whether or not the user was able to access DDM Inventory:

Connect — the user has connected to DDM Inventory, and disconnected
without attempting to login.

Login OK — the user has successfully logged in to DDM Inventory.

Login fail — the user has attempted to login, and did not have the
correct password.

Logout — the user has logged out of DDM Inventory.?

Login disabled — the user has tried to login with a failed password too
many times (limit has been set in Administration > System Configuration
> Appliance passwords)

Login no permission — this account has been denied permission to
access DDM Inventory.

a. Logout for HTTP and HTTP proxy has a timeout of 5 minutes from your last HTTP request.

SNMP Write events show the following data:

Table 3

SNMP Write Events

Data

Explanation

Event time

the time of the access event

Account name

the user accessing DDM Inventory

From IP the IP address from which the user accessed the device

To IP the device that had its MIB changed

MIB OID the MIB OID changed by the user (for “Write by MIB OID” only)

Attribute either Administrative Status or Bridge Aging Interval, these being the
only attributes a user can change through the MIB (for “Write by
Attribute” only)

Write the community string used to access the MIB

Community

String

Value the new “changed” value of the OID

Access Status

whether or not the user was able to write to the MIB:

Write OK

Fail (any of the following messages may appear): invalid response, too
big, no such name, bad value, read only, gen err, no access, wrong type,
wrong length, wrong encoding, wrong value, no creation, inconsistent
value, resource unavailable, commit failed, undo failed, authorization
error, not writable.
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Device and Port Add/Delete events show the following data:
Table 4 Add/Delete Events

Data

Explanation

Event Time

the time of the access event

Account name

the user accessing DDM Inventory

From IP the IP address from which the user accessed the device
Priority the priority of the device

Icon the current icon representing this device

Device the current device title

Port The port number (only appears for Port event)
Attribute Add or Delete

Device and Port Change events show the following data:
Table 5 Change Events

Data

Explanation

Event Time

the time of the access event

Account name

the user accessing DDM Inventory

From IP the IP address from which the user accessed the device
Priority the priority of the device

Icon the current icon representing this device

Device the current device title

Port The port number (only appears for Port event)
Attribute The type of change (device title, etc.)

Value The changed value

Update Model events show the following data:
Table 6 Update Model Events

Data

Explanation

Event Time

the time of the access event

Account Name

the user accessing DDM Inventory

From IP

the IP address from which the user accessed the device

Priority

the priority of the device

Using the Events Browser
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Table 6 Update Model Events

Data Explanation

Icon the current icon representing this device

Device the current device title

Access The command issued by the user (Update Model, Enrich XML, etc.)
Command

To view access events on the Events Browser:

e (Click View > Show Access Events.

Events Browser - Server

File Edit Wiew Device Port Attribute Tools Help
&3 Serve ] -
Q |now |v| % | Limit: | 20 Events: 20 ! @
Evert Time « Account Mame Fram [P Access Paint Access Status
2006-05-29 12:30 aclmin 16117 .57 .30 HTTP Login Ok,
2006-05-29 12:05 aclmin 16117 .57 .30 HTTP Logout
2006-05-29 11:33 aclmin 161175715 HTTP Logout
2006-05-29 11:09 aclmin 161175715 HTTP Login Ok
2006-05-29 11:06 aclmin 161175715 HTTP Logout
2006-05-29 11:01 aclmin 1611757 .25 HTTP Logout
2006-05-29 10:57 aclmin 16117 .57 .30 HTTP Login Ok
2006-05-29 10:55 aclmin 1611757 .25 HTTP Login Ok
2006-05-29 10:55 aclmin 161175715 HTTP Login Ok
2006-05-29 10:31 aclmin 1611757 .25 HTTP Logout
2006-05-29 10:23 aclmin 161175715 HTTP Logout
2006-05-29 10:21 aclmin 16117 .57 .30 HTTP Logout
2006-05-29 10:14 aclmin 16117 .57 .30 HTTP Login Ok
2006-05-29 10:07 aclmin 161175715 HTTP Login Ok
2006-05-29 10:09 aclmin 161175715 HTTP Logout
2006-05-29 09:55 aclmin 161175715 HTTP Login Ok
2006-05-29 09:53 aclmin 161175715 HTTP Logout
2006-05-29 09:53 aclmin 1611757 .25 HTTP Login Ok
2006-05-29 09:47 aclmin 1611757 .25 HTTP Logout
2006-05-29 09:44 aclmin 161175715 HTTP Login Ok
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Toolbar

The following diagram of the Events Browser toolbar shows all the methods of changing the
event list. You can use the different buttons and text boxes to view the events in which you are
most interested.

1\ 2 3 4

All events !vl)é‘vl Alldeuézs ‘vlé‘

-53‘ |nnw : |"| % ‘ Limit: @ Events: 20 , EEE@ :
\ \ ST

5 6 8 9 10 11 12 13 14

Table 7 Toolbar Legend

Number Feature

1 Event Category Pull-down list
2 Priority

3 Recent device list

4 Find a device

5 Older

6 Events Time Frame

7 Newer

8 Maximum number of events to find
9 Show Additional Info

10 Open Device Manager

11 Open Port Manager

12 Locate on Network Map

13 Refresh

14 Connectivity Indicator

Using the Aggregate Events Browser

The Aggregate Events Browser is almost identical to the regular Events Browser. The major
difference is that the “Server” column shows which server is the source of the event data.

By default, the Aggregator updates events hourly. Due to the time lag, events may not be
completely up to date.

If aggregation is turned on, but no Aggregators have been set up, the aggregate Events
Browser will look very much like the regular Events Browser, except for the time delay.
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8 Using the Device Manager

The Device Manager provides you with detailed information about a device, in several panels.

Through its series of panels, you can see the current alarms on the device, as well as historical
statistics. You can also interact with the device directly through the Device Manager, by
pinging the device, opening a telnet session, or by forcing DDM Inventory to update the device

model.

To open the Device Manager:

From

Open by...

Health Panel, Alarms Viewer,
Events Browser, Network Map,
Service Analyzer, Scan Data Viewer

Click Tools > Find (Ctrl - F). Enter a device address
or title, then click Find.

Alarms Viewer, Events Browser,
Virtual Servers window

Double-click on a table row, or right-click on the
device icon, title, or IP address.

Find

Enter a device address, title, or any other criterion
available in the Find tool then click Find.

Reports, Status, Manager panels

Click a hyperlinked device title

Network Map, Service Analyzer

Double-click a device icon. Right-click a device icon,
and select Open Device. Click a device icon, and click
Object > Open Device.
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List of Device Manager Panels

This is a complete list of panels available in the Device Manager. If you are reading this
document online, click the hyperlinks in this table to read more information on these panels.
Some panels are only available with certain license combinations.

Icon

Name

Description

Configuration

This panel identifies a device and presents an overview of the
device’s identity and status.

For more information, see Configuration on page 72.

Reports

This panel displays current values for report and summary
historical data. Displays alarm signals even when the device
priority is less than the minimum priority for a configuration
(unlike in map windows).

For more information, see Reports on page 79.

il

Diagnosis

This panel displays information about the current state of the
device that can be helpful in diagnosing problems.

For more information, see Diagnosis on page 80.

il

Ports

This panel lists ports for this device and summarizes the
information available for them. By default, it displays 24 ports
at a time. You can change this value directly in the panel or in
Administration > Account administration > Account properties).

For more information, see Ports on page 91.

Events

This button opens the Events Browser with this device in
context.

For more information, see Using the Events Browser on
page 61.

Locate

This button highlights in a map window the location of the
device.

If a map session was not open already, one will open now.
Within the map window, the device you are locating has a
yellow circle around it.

If the window containing the device was already open, that
window becomes the front-most window, and the window scrolls
so that the highlighted icon can be seen.

Service Analyzer

This button opens the Service Analyzer query with the current
device already selected as Device 1, to allow the user to view the
state of the path between this device and any other device on
the Network Map. This functionality exists only if you have the
Topology and Alarms licenses.
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Icon

Name

Description

Manage

This button launches an element manager of your choice.

The URL or application must defined in Administration > System
Configuration > Element management. If not, this button is
dimmed.

Note: for Aggregator—Definitions for Element management are
supplied from the Aggregator server, not the remote server.

Browse MIB

This button opens the MIB Browser to allow the user to view
the device’s SNMP MIB.

The MIB Browser also allows an expert user with an
Administrator or IT Manager account to manipulate the device
on a more detailed level.

View Scan Data

This button opens one of the DDM Inventory Viewers to show
device information collected by DDM Inventory scanners.

For more information, see View Scan Data on page 92.

Web

This button attempts to open a web browser window for the
device.

For more information, see Web on page 92.

Note: The device must have an IP address. If not, this button is
dimmed.

Telnet

This button attempts to open a Telnet session. Many network
devices provide Telnet as a means to set up and configure the
device.

Note: The device must have an IP address. If not, this button is
dimmed.

Note: The device must support Telnet sessions. (DDM Inventory
does not check before attempting a connection.)

Update Model
(Administrator or
IT Manager)

This panel provides several actions you can take to update the
device information in the DDM Inventory database. At the top
of the panel, there is a drop-down list that you can use to select
the action that you want to perform.

For more information, see Update Model (Administrator or IT
Manager) on page 93.

Device Visibility
(Administrator or
IT Manager)

This panel gives you options to activate, deactivate, hide, or
purge devices.

For information on how to activate, deactivate, hide, or purge
devices, refer to the Configuration and Customization Guide.

&

Properties

This button allows you to change the icon, title, and priority of a
device in your network.

For instructions on how to use this feature, refer to the
Configuration and Customization Guide.

&

Asset
Questionnaire

This button opens up an Asset Questionnaire for this device.
For more information on how to create and use this feature,
refer to the Installation and Initial Configuration Guide.

Using the Device Manager
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Icon |Name

Description

Refresh

This button refreshes the contents of the panel.

When used with IP Ping and SNMP Ping panels, uses the last
entered value instead of prompting you for a value.

Note: Does not re-read the data in the panel from the network.
Re-reads the data only from the DDM Inventory database.

Note: Does not affect Properties or Locate panels, or any of the
interactive session windows (Browse MIB, Web, Telnet).

Print This button prints the contents of the panel.
Close This button closes the window and exits the Device Manager.
Help This button opens a window that display context-sensitive help
@ about the Device Manager.
Configuration

>»

This panel identifies a device and presents an overview of the device’s identity and status.

This panel is blank if the device is not in the DDM Inventory database.

At the top of this panel, the device icon appears. Next to the icon, you can see if the device is
SNMP-managed, unmanaged, or a virtual device. If an asterisk appears next to this
description, it means that the IP address of the device has been cleaned from the DDM
Inventory database because it was a duplicate of a more recently discovered device. To
understand how devices with dynamically assigned IP addresses are managed, see the
“Adding, Removing, and Replacing Devices” chapter in the Configuration and Customization
Guide. When the device description appears with an asterisk, it is a link to the exception that
is generated by this condition.

The remainder of this panel is divided into the following principal sections:

Identity table (real devices only)

Virtual Devices (host devices only)

Virtual Devices Management Software (VMware VirtualCenter servers only)

Asset Data table
SNMP Configuration

VMware Credentials (VMware hosts only)

Mobile Discovery Credentials (mobile device servers only)

Device structure (Serial number and description, disk, CPU, memory)

Address table (real devices only)

Virtual LANs
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Identity Table

As shown in Table 1 on page 73, the information in the Identity table can come from these

sources: the DDM Inventory Rulebase, the SNMP MIB of the object, and the data included in

a scan file.

The Rulebase determines the device’s operating system, application, device family, and model.

Some of the information collected from the SNMP MIB has been set by the device

manufacturer; other information can be customized.

More elements of identity appear for the DDM Inventory server than for any other device.

All these elements are optional.

Table 1 Identity Table
Administrator
Data Example Creator or IT Manager
Package?® Main Map DDM Inventory/ —
account

UNSPSC Computer Servers Rulebase —
Family Cisco 2600 Series Rulebase —

Modular Access Routers
Family current Cisco Systems Inc Rulebase —
manufacturer
ModelP Cisco 2621XM Modular | Rulebase —

Access router
Model current Cisco Systems Inc Rulebase —
manufacturer
Model historical Cisco Systems Inc Rulebase —
manufacturer®
Operating system Cisco IOS Version 12.2 | Rulebase —

(8)T5
Operating system Cisco Systems Inc Rulebase —
current manufacturer
Operating system Cisco Systems Inc Rulebase —
historical manufacturer
Network Function — Rulebase —
Network Function — Rulebase —
current manufacturer
Network Function — Rulebase —
historical manufacturer
Operating system Linux DDM Inventory —
Service pack — DDM Inventory —
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Table 1 Identity Table
Administrator
Data Example Creator or IT Manager
NetBIOS name DUPONT device owner —
(network)d
NetBIOS workgroup MARKETING device owner —
Rulebase extra info — DDM Inventory —
Rulebase
Device-specific title — scripts —
System OID .1.3.6.1.4.1.295.5.1.1.2 manufacturer —
System OID PlainTree Systems Inc | Rulebase —
manufacturer
System descriptionP Ethernet Switch manufacturer —
System contact test@example.com device owner set® link
System nameP ws1216-2 device owner set® link
System location Server Room device owner set® link
Managing VirtualCenter | vmwar_host1/ DDM Inventory —
15.178.180.105
Asset tag 78LL996 Scanner —
BIOS asset tag — Scanner —
BIOS product name eserver xSeries 330 Scanner —
-[867441X]-
BIOS product IBM Scanner —
manufacturer
BIOS serial number 78L1.996 Scanner —
BIOS chassis — Scanner —
CPU Pentium III 1133 MHz | Scanner —

(Genuine Intel)

Computer name (scan)f | DUPONT device owner —
Memory (MB) 1024 Scanner —
Windows/NIS domain MARKETING Scanner —
VM type VMware DDM Inventory —
VM name VM-Vista64-Business DDM Inventory —
VM operating system Microsoft Windows DDM Inventory —
Vista (64-bit)
VM status powered on DDM Inventory —
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Table 1 Identity Table
Administrator
Data Example Creator or IT Manager
VM host myvmhost.mybiz.com / | DDM Inventory —
208.77.188.166
VM UUID 50 3b c7 ba c9 fe DDM Inventory —
45 95-c2 15 3f de
23 f£5 da 52
VM Path [storagel] DDM Inventory —
VM-NoOS-3a/
VM-No00OS-3a.vmx
Mobile phone number (613) 123-4567 Mobile device —
server
Mobile carrier company | Cingular Mobile device —
server
Mobile carrier network CDMA Mobile device —
server
Mobile status Assigned Mobile device —
server
Mobile user last nameg | Doe Mobile device —
server
Mobile user first name? | Jane Mobile device -
server
Mobile user e-mail jane_doe@hotmail.com | Mobile device —
address® server
Mobile device server myserver.mycarrier.com | DDM Inventory —

/208.77.188.166

a. This is optional if you have not opened a map configuration since this object was discovered. The
Network Map feature is available only if you have the Topology license.

b. Appears with an asterisk next to it if the information about this device was gathered indirectly
through Cisco Discovery Protocol (CDP) cache information from other network devices. When the
data name appears with an asterisk, it is a link to the exception that is generated by this

condition.

c. Appears only when different from the current manufacturer.
d. NetBIOS data is blank unless the device has an IP address or if the network card is

disabled.

A shortcut to the MIB Browser.
On Windows workstations, frequently the same as the system name.
g. NetBIOS data is blank unless the device has an IP address or if the network card is

disabled.

h. Only appears when this information is collected. Refer to “Protecting Private Information for
Mobile Devices” in the Reference Guide.
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About the Package Data

The package row displays the position of a device within the packaging of the Network Map.
Click on a hyperlink to open a corresponding map window.

If you have a map open, this row reflects the packaging of your current configuration. If you
open the Device Manager and then make packaging changes that affect the device, click the
Refresh button to have this row updated.

If you do not have a map open, this row reflects the packaging of the configuration you were
using in your previous map session.

If you have never had a map open, this row does not appear.

If the device has been added to the network since the last time you saved your configuration,
this row does not appear.

Virtual Devices

The Virtual Devices table appears only when the device is a VM host. The table has two parts:
information about the host itself, and information about the virtual devices that are
associated with this host.

For the host, the following items are displayed:

e Server: Type of virtualization software running on the virtual device

e Version: Version of the virtualization software running on the virtual device
e Platform: Operating system running on the virtual device

e Model: Model of the virtual device server machine

e UUID: Universal Unique IDentifier of the virtual device server

For each virtual device associated with this host, the following items are displayed:
e Device: Logical machine name and IP address of the virtual device

e VM Name: Name assigned to the virtual device

e VM OS: Operating system running on the virtual device

e VM Status: Current status of the virtual device

e Update Time: Time that DDM Inventory last collected information about this virtual
device

Virtual Devices Management Software

The Virtual Devices Management Software table appears only when the device is a
VirtualCenter server. The table has two parts: information about the VirtualCenter server
itself, and information about the VMware host that are managed by the VirtualCenter server.

For VirtualCenter, the following items are displayed:

e Server: Type of the virtualization software running on the VirtualCenter server

e Version: Version of the virtualization software running on the VirtualCenter server
e Platform: Operating system running on the VirtualCenter server

e Model: Model of the VirtualCenter server

For each VMware host managed by the VirtualCenter server, the following items are
displayed:
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e Device: Logical machine name and/or IP address of the VMware host

e Server: Type of the virtualization software running on the VMware host

e Version: Version of the virtualization software running on the VMware host

¢ Platform: Operating system running on the virtual device

e Model: Model of the VMware host machine

e Update Time: Time that DDM Inventory last collected information about VMware host

Asset Data

This table displays the data entered in the Asset Questionnaire or collected from the scanner.

SNMP Configuration

These are the community strings (for devices with SNMPv1/v2) and users (for devices with
SNMPv3). The entire list is displayed in the Diagnostics panel. It will be blank if there are no
strings or users configured in DDM Inventory.

An Admin or IT Manager user will also see a read and a write community string (for devices
with SNMPv1/v2) or user (for devices with SNMPv3) for a device. These values are taken from
the list of community strings and users; however:

e Strings and users from the list appear here only if they are valid.

¢ Only a single valid string/user appears here even if the list has multiple valid strings/
users for this device.

e The read string/user that appears here is the string/user that DDM Inventory is currently
using to poll the device.

Deployment Credentials

This table shows you the deployment credentials (Admin and IT Manager only) that were
most recently used to successfully communicate with this device. It shows you the values of
the following settings:

e Label

e Login

e Type (Windows or SSH)
¢ Domain

e Share

e Path

VMware Credentials

This table displays the preferred VMware credentials, including the user name and a
password hint, for VMware hosts in this device group. This table is present only for VMware
host devices. The information in the table is populated after the VMware discovery process is
completed for this host. This information is only visible to Admin and IT Manager type
accounts.
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For additional information about how DDM Inventory works with VMware and other
virtualization methods, refer to Chapter 4, “Virtualization in DDM Inventory” in the
Reference Guide.

Mobile Discovery Credentials

This table is present only for mobile device servers. The table displays the preferred log-on
credentials, including the user name and a password hint, for this mobile device server. The
information in the table is populated after the mobile discovery process is completed for this
server. This information is only visible to Admin and IT Manager type accounts.

Mobile discovery credentials are specified in the Mobile configuration profile associated with
the device group that contains this mobile device server. The profile can contain multiple sets
of log-on credentials.

For more information about mobile device discovery, refer to “Mobile Devices in DDM
Inventory” in the Reference Guide.

Device Structure
This table provides information on the serial number of the chassis and modules in a device.
You will see the following information about each module:

e Type (backplane, container, misc, other, powerSupply, stack, chassis, fan, module, port,
sensor, CD, disk, cpu, ram, vram, tray, toner, unknown)

e Ifthe following information is present in the MIB, it is also displayed: hardware,
firmware, software, serial number, mount point, capacity, description

Address
This table provides information about the IP addresses and/or MAC addresses of a device’s
ports. The information comes from the Network Explorer or from scan file data.

This table has hyperlinks for all the ports with addresses. If a port does not have an address,

it does not appear in the list. To open a Port Manager, click a port hyperlink. Each table row
contains either:

e A MAC address, an OUI abbreviation (if known), and a manufacturer (if known)
e An IP address, a netmask (if known), and a domain name (if known)
A special port of “Device” is used:

¢ For the IP or MAC address that DDM Inventory identifies as the primary IP or MAC
address for the device

e  When DDM Inventory does not know which port an IP or MAC address is associated with

Data Notes

Port index port number and description

MAC/IP address —

OUI/Netmask netmask in octet notation

Manufacturer/Domain name usually hyperlinked to an external
web site
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The address table is particularly useful:
e  When the device is

® arouter

¢ a device with multiple IP addresses and domain name aliases (such as a web server)

When you want to know a device’s domain name (and domain name is not included in the
list of Device Title Preferences)

VLANs

VLANSs are software-defined broadcast domains, created by your System Administrator at the
switch. If your device has any VLANSs configured, you will see them in the Device Manager.

VLAN example:
Virtual LANs:

VLAN ID
1 default

100 ComputerRoom
200 VLANOZ00

1002 fddi-default

1003 token-ring-defalilt
1004 fddinet-default
1005 trnet-default

Reports

This panel displays current values for report and summary historical data. Displays alarm
signals even when the device priority is less than the minimum priority for a configuration
(unlike in map windows).

This ‘report’ data is historical information. You can use the data on this panel in conjunction
with the State panel to look for problem trends in your device. For example, you can see an
alarm in the State panel for the device CPU, you can check the ‘reports panel’ to see if there
was a problem yesterday, or over the past week or month.

This panel is not available if the object is not in the DDM Inventory database.

State

Displays ‘report’ data like adds, deletes, and changes. Also displays notifications if any of
these are in an alarm state (info, minor, major, critical).
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If there are any exceptions for the device, they are noted in this table. For a list of exceptions
in your network devices, see the Health Panel and Alarms Viewer. For a complete listing of
DDM Inventory exceptions, see Help > Classifications > Exceptions.

Data

Notes

Report name

Exceptions, Device Adds, Device Deletes, Device Moves?,
Device Changes, Not Recently Seen

State

OK, Info, Minor, Major, Critical

Value

o effect

e action

For exceptions:

e description

a) Device moves are only reported if the Topology license is installed.

>»

Diagnosis

Exceptions cannot always be reported for a device.

This panel displays information about the current state of the device that can be helpful in
diagnosing problems.

You can access the following diagnostic tools from this panel:

Icon |Name Description
Agent This button displays information logged during the agent
= Deployment Log | deployment process.
For more information, see page 87.
Scanner This button displays information logged during the scanner
= Deployment Log | deployment process.
For more information, see page 88.
Virtual Log This button display