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CHAPTER
1 A
bout Exporting Data
This book is for people who want to create custom reports of Network 
Discovery data.

Note that Network Discovery also has reports you can access from within its 
own interface (see the Reports menu by clicking the Reports button on the 
Toolbar). 

Topics in this chapter include:

What you need to know before you start on page 6

About the Network Discovery database on page 6
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What you need to know before you start

There are some skills you should have before attempting to follow the 
procedures in this book.

For Microsoft Word
To export data into a Microsoft Word document, you should already:

be comfortable with the environment in which you are working 
(Windows 95/98/2000/NT4.0)

have a high level of expertise with Microsoft Word 97 or 2000

For data access applications
To create custom reports with your own data access application, you should 
already be comfortable with:

the environment in which you will be working (Windows 
95/98/2000/NT/XP or UNIX)

Microsoft Access 2000

the Open Database Connectivity Standard (ODBC)

the reporting application you want to use

About the Network Discovery database

The schema of the database is optimized for reporting performance and 
human understandability rather than for real-time access and statistic 
storage. In particular, the tables and columns are clearly named and the 
schema is fully normalized.

The database includes inventories of: 

devices

ports

attributes

connections

events
6 Chapter 1—About Exporting Data 
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Open database access
The Reports database is open. That means the schema is published in 
standard description languages and you can access and export the data in a 
number of ways by means of standard protocols.

The schema of the reports database is described using English, SQL and XML 
DTDs. All descriptions are available from the appliance. 

The data can be accessed directly on the appliance (queries only, no updates) 
through the ODBC protocol. MySQL provides an ODBC driver for 
Windows. The ODBC driver is available on the appliance, in the Download 
directory. 

Using this driver, Windows-based applications can remotely access the 
Reports database. 

Creating your own reports
There are three ways to use Network Discovery data. 

1) Network Discovery has its own reports accessible through the Network 
Discovery interface.

2) You can export Network Discovery data into Comma Separated Values 
(CSV) or into XML format for use with Microsoft Word documents or 
spreadsheets (see “Exporting data into Microsoft Word documents on page 9”).

3) A third option is to export Network Discovery data into a data access 
application that operates on the Open Database Connectivity (ODBC) 
standard. You can use a third-party data access application to customize the 
presentation of Network Discovery data, if your application operates on the 
ODBC standard. ODBC applications into which you can export Network 
Discovery data comprise (but are not limited to): 

Microsoft Access

Crystal

Cognos Impromptu

PowerPlay OLAP tool
About the Network Discovery database  7



Network Discovery
Note: The data imported into the data access application is read-only. You 
cannot manipulate Network Discovery or your network from within the 
application.
8 Chapter 1—About Exporting Data 



CHAPTER
2 E

d

xporting data into Microsoft Word 
ocuments
You can create custom Microsoft Word report documents with any text you 
want and include any graphs and pie charts that appear in Network 
Discovery. Because the graphs are actually linked to the Network Discovery 
appliance, they update automatically.

Topics in this chapter include:

What you need before you start on page 10

Two Word files are included with Network Discovery on page 11

Download the Word files on page 11

The example file is a report you can customize on page 13

Start a report from scratch with the template file on page 15

Update the graphs in your report on page 17
Exporting data into Microsoft Word documents  9
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What you need before you start

You must have either Word 97, Word 2000, or Word 2003 on one of the 
following operating systems:

Windows 95

Windows 98

Windows 2000

Windows NT 4.0

Note: You must have Internet Explorer (IE) on the computer you’re 
working with. Even if you do not use IE with Network Discovery, you 
must have it loaded onto your management workstation for the Word 
file to work properly.

You must enable macros in Word.

To enable macros

1 For example, in Word 2000, click Tools > Macro > Security.

2 In the Security Level tab, select one of the following security levels to enable 
macro execution: Medium or Low.

Figure 2-1: Word Security Level tab
10 Chapter 2—Exporting data into Microsoft Word documents 



Data Export Guide
Two Word files are included with Network Discovery

Microsoft Word can import diagrams from URLs. Since most of the 
components of Network Discovery are web-based, they have URLs that 
Microsoft Word can reference. See your Microsoft Word documentation for 
a full explanation of how to create and manipulate a document with URL 
references.

To make it easier to prepare your Word report, Network Discovery comes 
with two documents for Microsoft Word that you can download. 

The two files are:

SumRepExample.doc, a sample Microsoft Word file

SumRepTemplate.dot, a Microsoft Word template file

The first document is an example report framework for the intermediate 
Microsoft Word user. To use it, you use the Microsoft Cut and Paste 
commands to rearrange the built-in graphs. The second document, the 
template, is for an advanced Microsoft Word user who is comfortable with 
Word field codes and macro substitution.

Each document contains links to graphs on your Peregrine appliance. Once 
you customize the report with the name of your Peregrine appliance, you can 
easily update the graphs—to present at weekly meetings for example.

Note: To use the SumRepExample.doc report framework, you must 
download both files. You need the template file to be able to update 
the example file.

Download the Word files

Important: When you download the two Word files, you must save them 
both to your Microsoft Word template directory. 

To download the example file

1 From the Network Discovery Home page, click Download.

2 Right-click SumRepExample.doc > Save Target As. 
Two Word files are included with Network Discovery  11



Network Discovery
Save the file to your Microsoft Word template directory (in Word 2000, the 
path is C:\Program Files\Microsoft Office\Templates\1033). 

Figure 2-2: The Network Discovery Download page

Remember you also need the template file to use the example file.

To download the template file

You can use the template file either on its own or with the example file.

1 In Network Discovery, click Home >Download.

2 Right-click SumRepTemplate.dot > Save Target As. Save the template file in 
your local Word template directory. If you don’t know where this directory 
is on your PC, see your Microsoft documentation.

Important: Before you save the file, change the file name suffix
from .doc to .dot

Figure 2-3: Change .doc to .dot when you save the template

Change suffix
12 Chapter 2—Exporting data into Microsoft Word documents 
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In this example (Figure 2-4 on page 13, below), the path for saving the file is 
C:\Program Files\Microsoft Office\Templates\1033. This is using Microsoft 
Word 2000 on Windows NT 4.0. 

Figure 2-4: Word 2000 on Windows NT 4.0 path for saving template file

In Word XP, the directory is C:\Documents and Settings\Application 
Data\Microsoft\Templates. 

Your template directory may be in a different location, so refer to your 
Microsoft documentation.

3 Click Save.

The example file is a report you can customize

The example file includes all the graphical reports available on your 
Peregrine appliance. You can use the example report to create your own 
reports by deleting what you do not need, and by adding your own 
descriptive text.

To work with the Example file

1 In Microsoft Word, click File > Open.

2 Select the file SumRepExample.doc.
The example file is a report you can customize  13
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A dialog asks if you want to enable macros.

Figure 2-5: Enable macros dialog

3 Click Enable Macros.

A dialog box appears, called “Summary Report Include for Printed Reports.” 
The dialog allows you to connect to your Peregrine appliance to import the 
Network Discovery graphs.

Figure 2-6: “Summary Report Include for Printed Reports” dialog

4 Enter the IPv4 address or domain name for your Peregrine appliance.

5 Click OK.
14 Chapter 2—Exporting data into Microsoft Word documents 
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A dialog asks if you want to continue searching at the beginning.

6 Click Yes.

You are prompted for your user name and password for the appliance.

7 Enter your name and password.

Four more dialogs appear, asking if you want to search the document.

8 Click Yes to all of the dialogs.

The Word document is now full of graphs from your appliance. Use Word’s 
Cut and Paste commands to make the example file your own report.

Start a report from scratch with the template file

The template file allows you to create a report from scratch rather than 
cutting and pasting within a prepared document as you can do with the 
example file. It is for expert Microsoft Word users. You should be 
comfortable with Word field codes and macro substitution.

To start a new Word report file

1 Open Word.

2 Click File > Open.

3 Select the file sumreptemplate.dot. 

4 Click Open.
Start a report from scratch with the template file  15



Network Discovery
A dialog box, called “Summary Report Include for Printed Reports”, appears.

Figure 2-7: “Summary Report Include for Printed Reports” dialog

5 Enter the URI or domain name for your Peregrine appliance.

6 Click Save.

You can now create your document from scratch.

You can use shortcuts to include graphs automatically
Instead of typing the exact URI for the graph stored on your appliance, you 
type a shortcut that translates automatically into the exact URI that 
INCLUDEPICTURE requires. The shortcut takes this form:

?graph(group,attr,stat,period,legend)?

Spaces are permitted between each element, but not within elements.

Once you have typed the shortcut into the template, you run a pre-recorded 
macro to translate the shortcut into a field code that loads a fresh graph right 
from the Network Discovery appliance.
16 Chapter 2—Exporting data into Microsoft Word documents 
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Note: The available shortcuts and what graphs they map to are in the original 
example file.

Figure 2-8: From the Word example report: 

To translate a shortcut;

Select the shortcut.

Do one of the following:

Click Tools > Macro > Macros.

Press Alt + F8.

Update the graphs in your report

To update the graphs

1 In your Word report, click Tools > Macro > Macros.

(The shortcut is Alt + F8.)

2 Select SumRepUpdate.

3 Click Run.

A dialog asks you to confirm the name of the server you want the data to 
update from (the domain name of the Peregrine appliance).

4 Click Yes.

You are prompted for your user name and password for the appliance.

5 Enter your name and password.

Four more dialogs appear, asking if you want to continue searching at the 
beginning.

6 Click Yes to all of the dialogs.

The graphs in your report have updated.

7 Select the “SumRepUpdate” macro, then click Run.

T h is  c h a p te r p ro v id e s  s ta tis tic s  o n  n e tw o rk  p e rfo rm a n c e  o v e r 
v a rio u s  tim e  p e rio d s .  G ra p h s  a re  in c lu d e d  u s in g  th e  
IN C L U D E P IC T U R E  fie ld  c o d e .  Y o u  in se rt a  fie ld  c o d e  b y  
s e le c tin g  th e  In se rt-F ie ld …  m e n u  ite m .  U n d e r th e  L in k s  a n d  
R e fe re n ce s  c a te g o ry , p ic k  IN C L U D E P IC T U R E .  A fte r th e  
IN C L U D E P IC T U R E  k e y w o rd , in s e rt th e  U R L  fo r th e  g ra p h  
y o u  w is h  to  in c lu d e  (m a k e  s u re  th e  U R L  is  e n c lo s e d  b e tw e e n
d o u b le  q u o te s ).  T h e  re q u ire d  U R L s  a re  n o te d  w ith  e v e ry  
g ra p h  illu s tra te d  h e re . 
Update the graphs in your report  17
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When you open a document created with the template, the graphs update 
automatically.

To update one graph at a time

1 Select the graph in your Word file.

2 Press F9 on your keyboard.

The graph should update automatically. 

Note: When the graph updates, it may shrink. You will need to manually fix 
the graphic. 
18 Chapter 2—Exporting data into Microsoft Word documents 



CHAPTER
3 E

A

xporting Data into Data Access 
pplications
This chapter contains a tutorial that walks you through a simple example of 
how to connect to the Network Discovery database from Microsoft Access 
2000 by means of ODBC; how to link in the tables and perform two basic 
queries.

Topics in this chapter include:

Step 1: Set up Network Discovery to export data on page 20

Step 2: Putting data into CSV format first works better on page 20

Step 3: Select MYSQL as the data source (create an ODBC alias) on page 21

Step 4: Create a new database in Microsoft Access 2000 on page 24

Step 5: Link in the Network Discovery tables on page 25

Step 6: Create a basic license query on page 28

Step 7: Create a basic assets and recognition query on page 32
Exporting Data into Data Access Applications  19
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Step 1: Set up Network Discovery to export data

To set up Network Discovery to export data

1 In Network Discovery, click Administration > System Preferences > 
Appliance Services.

2 Next to MySQL access enabled, click Yes.

Note: Remote access to the MySQL database must also be granted to at least 
one account. 

3 Click Administration > Account administration > Account Capabilities.

4 Select the account that should have MySQL access. 

5 Click Modify Capabilities.

6 Select Yes for MySQL ODBC. 

7 Click Modify Capabilities.

Step 2: Putting data into CSV format first works better

Putting Network Discovery data into “comma-separated values” (CSV) 
format first, allows you to export it into a Microsoft Word document or into 
a spreadsheet more successfully.

To export Reports data into CSV format

1 In Network Discovery click on the [Export] link in a Report list.

A dialog box asks if you want to export the data to a file, or open the file from 
the Peregrine appliance.

2 Select Export.

3 Click OK.

If you select Open the file from its current location, the data is displayed 
in a spreadsheet using the default program designated by your system to 
display CSV files, such as Microsoft Excel.

If you select Save this file to disk, follow the prompts to save the CSV file 
for opening later.
20 Chapter 3—Exporting Data into Data Access Applications 
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Step 3: Select MYSQL as the data source (create an 
ODBC alias)

Before you can use the Network Discovery data with Microsoft Access 2000 
you need to create an ODBC alias for the database.

To set up MySQL as the data source

1 From the Windows Control Panel, select Data Sources (ODBC).

Note: In Windows 2000, select Setting|Control Panel|Administrative 
Tools|Data Sources (ODBC)

The ODBC Data Source Administrator appears.

2 In the User DSN tab, click Add. 
Step 3: Select MYSQL as the data source (create an ODBC alias)  21



Network Discovery
The Create New Data Source dialog appears.

3 In the list box select MySQL.

4 If your computer does not already have a MySQL driver, you can do one of 
two things:

Go to http://www.mysql.com. Follow the directions on the web site to 
download the ODBC driver.

Download the MYSQL driver from the appliance. From the Home page, 
click Download. On the Download page click the 
MyODBC-Windows-3.51.06.tar.gz link.

5 Click Finish. 
22 Chapter 3—Exporting Data into Data Access Applications 
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The TDX MySQL Driver default configuration dialog appears.

6 Enter the following information:

The Windows DSN name (Data Source Name). In the following example 
we have called it Network Discovery Tutorial.

The name or IP address of the Peregrine appliance.
(Ask your network administrator if you are not sure of the IP address or 
name of your appliance).

In the MYSQL database name field, enter the name of the database. Enter 
Aggregate.

7 For the name of the user, enter one of the following:

“demo” for anyone

“admin” for anyone who has the administrator password or

the account name of anyone who has been set up with a user account

8 Enter the password for the above user.

9 For the number of the port, always enter 8108.

10 Once you have entered these fields, click OK.
Step 3: Select MYSQL as the data source (create an ODBC alias)  23



Network Discovery
Now you are returned to the UserDSN tab in the ODBC Data Source 
Administrator dialog box. 

11 Click OK to exit.

You are now ready to connect to the Network Discovery database with 
applications such as MS Access 2000 by means of ODBC.

Step 4: Create a new database in Microsoft Access 2000

To create a new database

1 Start Microsoft Access 2000.

2 Create a new blank database. Give it a name and save it. 

The following screen is displayed. In this example, the database has been 
named Automated InventoryTutorial.mdb and saved in the following 
directory

C:\Program Files\Peregrine\Network Discovery\
The following dialog is displayed.
24 Chapter 3—Exporting Data into Data Access Applications 
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Step 5: Link in the Network Discovery tables

To link in the Network Discovery tables

1 In the Objects menu, select Tables and click New. 

The following dialog appears.

2 Select Link Table and click OK. 

The following screen appears.

3 In the Files of type pull-down list select ODBC Databases. 

The following dialog appears.
Step 5: Link in the Network Discovery tables  25
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Note: The Automated InventoryTutorial.mdb file is not supplied with 
Network Discovery, but is the file that you created in step 2 on page 24.

4 Click the Machine Data Source tab.

5 Select your entry (in this case Automated Inventory Tutorial) and click OK.

The Logon to InterBase dialog appears.
26 Chapter 3—Exporting Data into Data Access Applications 
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Note: Note, that this is the Tutorial data source name that you created in 
step 6 on page 23.

The following Link Tables dialog is displayed.

6 Click Select All.

All the entries are now highlighted.

7 Click OK.

You are returned to the Tables Tab which shows the newly linked Network 
Discovery tables.
Step 5: Link in the Network Discovery tables  27
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Step 6: Create a basic license query

To create a basic license query

1 From the Objects list, select Queries. 

2 Double click Create query in Design view.

The Show Table dialog appears.

3 In the Tables tab page, select:

SWSubComponent

Version
28 Chapter 3—Exporting Data into Data Access Applications 
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Application

Company

4 With the table selected, click Add, then Close. 

The table displayed is similar to this:

5 Click File > Save As and save the query

In this example, we have called it Licenses.
Step 6: Create a basic license query  29
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6 Enter the query field parameters as shown below:

7 Run the Query. From the Query pull down menu, select the Run option. 
30 Chapter 3—Exporting Data into Data Access Applications 
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A query is generated, showing license data from the inventory scans in the 
Inventory Database.
Step 6: Create a basic license query  31
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Step 7: Create a basic assets and recognition query

To create a basic assets and recognition query

1 From the Objects list, select Queries. 

2 Double click Create query in Design view.

The Show Table dialog appears.

3 In the Tables tab page, from the list, select:

hwAssetData
32 Chapter 3—Exporting Data into Data Access Applications 
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Device

hwCPUData

hwSystemData

4 With the table selected, click Close. 

The table appears.

5 Save the query. In this example we have called it Assets and Recognition.

6 Enter the query field parameters as shown below: 

7 Run the Query. From the Query pull-down menu, select Run. 
Step 7: Create a basic assets and recognition query  33



Network Discovery
A query is generated, showing asset and recognition data from the inventory 
scans in the Inventory Database.
34 Chapter 3—Exporting Data into Data Access Applications 



CHAPTER
4 H

o

ow the Network Discovery schema is 
rganized
This chapter explains how the data has been named and how and why the 
data refreshes at different rates. It also gives a brief description of each type 
of data available.

Topics in this chapter include:

Naming conventions on page 36

An entry can come from another table—foreign keys on page 37

Data refreshes at different rates on page 38

The data sorted by refresh rate category on page 38

The Classification sub-schema on page 38

The Network Inventory sub-schema on page 40

The Reports sub-schema on page 41

The Control sub-schema on page 41

The Events sub-schema on page 43
How the Network Discovery schema is organized  35
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Naming conventions

The following conventions have been used to name tables and fields in the 
Aggregate schema to ease reading and understanding.

Table Names 
Table names start with a capital letter followed by lower case 
letters—“Device”, “Port”, or “Connection”—unless the name itself is an 
abbreviation. If the table name is an abbreviation, capital letters are kept for 
the acronym part of the name—“IPv4”, “MAC”, and so on.

Table names always use the singular form— “Connection” not 
“Connections”. 

If the name of a table is formed by putting more than one word together, the 
words making up the name start with capitals to differentiate them— 
“DeviceCategory” or “PortCategory”.

Field Names 
As with table names, field names start with a capital letter followed by 
lowercase letters—“Index” or “Description”—unless the name itself is an 
abbreviation. If the name is an abbreviation, the acronym part of the name 
keeps its capital letters— “CIR” or “URI”. 

If the name of a field is formed by putting more than one word together, the 
words forming the name start with capitals to differentiate 
them—“SpeedIn”, “SpeedOut”, or “IsFullDuplex”.

Field names are always prefixed by the name of the table to which they 
belong, followed by an underscore character, followed by the name of the 
field—“Device_Label”, “Port_Speed”, “MAC_Address”. 

Usually, primary keys of tables are simply sequential numbers (positive 
integers). In these cases, the name of the primary key field is “ID”, so the 
complete field (key) name becomes “<table name>_ID – Device_ID” (or 
“Port_ID” or “Connection_ID” and so on).
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If a primary key field enters a table as a foreign key, it keeps its original name, 
thus indicating its origin. When two or more primary keys from the same 
table are imported into one table, a suffix follows each foreign key name to 
indicate the different purpose of the fields—“Company_IDHardware” and 
“Company_IDSoftware” or “DeviceCategory_ID” and 
DeviceCategory_IDPreferred”.

Abbreviations
Use of abbreviations has been limited to a few widely spread conventions, 
such as using Dt to abbreviate Date. Also, as explained above, industry wide 
acronyms were kept where it was felt that they would easily be understood:

BIOS (Basic Input/Output System) 

CIR (Committed Information Rate)

DNS (Domain Name System)

FDDI (Fiber Distributed Data Interface) 

IP (Internet Protocol) 

MAC (Media Access Control) 

NMID (Network Management Identifier—the ID (key) of the Device or 
Port in the Appliance) 

PVCS (Permanent Virtual Connection) 

URI (Universal Resource Identifier) 

An entry can come from another table—foreign keys

The Network Discovery database is normalized. That means that 
information occurs only in one place so that it doesn’t have to be updated 
more than once. For instance, if a company changes its name, the new name 
does not have to be updated in every table that uses the company name. 
Company_Name is only “real” in the Company table. Any other table that 
refers to Company_Name is using the Company table primary key, 
“Company_ID”.
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Data refreshes at different rates

It is important to understand that Network Discovery collects and refreshes 
different kinds of data at different rates. Different layers of the underlying 
software are responsible for refreshing different areas of the data at suitable 
intervals. The data falls into groups (or sub-schemas), depending on the 
refresh rate:

Classification

Network Inventory

Events

Reports

Control

Note: A schema or a sub-schema is a group of database objects such as tables 
that are logically connected.

The data sorted by refresh rate category

The sub-schemas only indicate how and how frequently the data is refreshed. 
They do not affect how you access and retrieve data. 

However, the following list arranges the tables by their sub-schemas, so that 
you can have a quick overview of the data available and understand which 
tables have their content refreshed more frequently than others. 

The Classification sub-schema
The Classification sub-schema contains generic information common to any 
network. For example, it contains the list of hardware or software 
manufacturers (Company), the various categorization of devices or ports 
(DeviceCategory & PortCategory) and so on. This information is quite 
stable. It only changes when you upgrade Network Discovery with a new 
Rulebase software component.

The Classification sub-schema contains the following tables:

Application: This table lists all the various applications that can be found 
on an end-user workstation or that can be run on network devices, such 
as Word, Excel, and Visio.
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ApplicationCategory: This table lists all the categories used to regroup 
applications, such as Word Processors, Spread Sheets, and Accounting 
Packages.

Attribute Group: The AttributeGroup lists all the generic attributes 
categories supported by the system.

Company: This table lists information on companies that manufacture 
computer equipment and/or produce software. Other tables (for example, 
Device, Application) reference this table to indicate which company 
manufactures certain kinds of hardware (Device) or which company 
produces certain software (Application).

DeviceCategory: This table lists various categories of devices, such as 
printers, workstations, switches, routers, and web servers. It also stores 
some attributes of these categories.

Device Icon: In a fashion similar to the DeviceCategory table, the 
DeviceIcon table lists grouping of Devices, along with some of the 
properties of these groupings. 

Family: This table lists product families, such as hubs, routers, 
workstations, switches, and so on. The Device table is related to this table 
so that a specific device can be related to information about the product 
family to which it belongs.

Language: This table lists all the various languages that exist. It tells what 
language an application supports.

MediaCategory: This table lists the media category of the line, such as 
Ethernet, CSMA / CD, Token Ring.

Model: This table lists various models of devices, such as Cisco’s Catalyst 
X series, HP’s LaserJet X series, Compaq’s (DEC) AlphaServer X series.

NetworkFunction: Sometimes you need workstations or server platforms 
set up with commercial operating systems for the specific purpose of 
deploying a software application or a set of applications. In such cases 
NetworkFunction identifies the software application that is identified by 
the SNMP MIB II (RFC 1213, RFC 2011, RFC 2012, RFC 2013) data fields 
within the device.

OperatingSystem: This table lists all the various operating systems that 
exist for networked devices—such as Windows, Unix, or Mac OS.

Operating System Group: This table groups all variants (releases) of a 
particular generic operating system—such as Windows 95, Windows 97, 
Windows 2000, or Windows NT.
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PortCategory: This table lists categories (and subcategories) of ports, such 
as Token Ring, Serial, Ethernet, FDDI. Records in the Port table are related 
to records in this table so that each port is associated with a specific port 
category.

Property Group: The PropertyGroup table lists all the properties that can 
be changed by a change Event.

ReleaseLabel: This table lists major releases of applications—Word 97, 
Word 2000, Word XP are Release Labels of the Word application.

Report Details: The ReportDetail table contains generic information 
about the various reports produced by the system and stored either in the 
ReportState or EventSummary tables.

Version: This table lists all the various versions that exist for a specific 
release. For example, the release, Word 97, could have the following 
versions—Word 97, Word 97sr1, Word 97sr2, Word 97 sr2a/v, Word 97.

Note: An application can have Versions, without necessarily having 
ReleaseLabels.

The Network Inventory sub-schema
The Network Inventory sub-schema is usually refreshed on a daily basis. The 
Network Inventory sub-schema contains the following tables:

Connection: This table lists all the connections between devices or ports 
within a network. In other words, it represents the connectivity between 
nodes in a network. 

Device: This table lists all the hardware equipment found in a network, 
including end-user workstations and interconnecting devices. 

DeviceExtension: This table lists additional information about devices. It 
is used for support purposes and should be ignored.

IPv4: This table lists IPv4 addresses linked to a particular device or port. 
Both may have several addresses.

MAC: This table lists MAC or IEEE802 style addresses linked to a 
particular device or port. Both may have several addresses.

Port: This table lists information about all the ports discovered on each of 
the network devices.

Serial Number: The SerialNumber table stores serial numbers associated 
with Device's components.
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SubComponent: The SubComponent table contains information 
gathered on resource managed devices, such as CPU speed, disk 
utilization, etc.

VLAN: The VLAN table documents the virtual LANs found in the 
network. 

VLAN Object: The VLANObject table implements the many to many 
relationship between the VLAN and the Device or Port tables: it lists the 
participating Devices or Ports in each particular VLANs.

The Reports sub-schema
The Reports sub-schema contains reports generated on an ongoing basis, 
and is summarized and refreshed either hourly or daily to minimize the 
amount of disk space needed to hold them.

The data retention period is one year or 500 M Bytes of data—whichever 
limit is reached first. 

The Reports sub-schema contains the following tables:

Report State: The ReportState table contains the line items of the most 
recent reports generated by the system on a regular basis.

Event Summary: The EventSummary table regroups events in categories 
and summaries them over time periods so one can have a quick idea of 
what happened in the network over time.

Report State Summary: The Report State Summary table is a summary of 
all alarmed rows found in the Report State table (state > 1) grouped by 
Report, Object Type (device or port), Priority, and State. This table is 
primarily used to speed up the display of the Aggregate Health Panel. 

HourlySummary: This table contains summaries of certain statistics for 
certain pre-defined groups of devices summarized on an hourly basis. To 
spare disk space, HourlySummary records will be deleted after a certain 
period of time (currently set as 1 year).

The Control sub-schema
The Control sub-schema is relevant when you have an Aggregator. It 
contains tables that control how the database is refreshed by multiple 
appliances.
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The Control sub-schema contains the following tables:

Appliance: This table lists all the appliances contributing to the Reports 
Database. It describes all remote appliances that are aggregated by this 
system. If the system is not licensed as an aggregator, then this table 
contains one row: Appliance_ID = 0. Note that an appliance acting as an 
aggregator has entries for all remote appliances in the Appliance table and 
an entry for itself (Appliance_ID = 0).

Attribute Refresh Schedule: The AttributeRefreshSchedule table stores 
the scheduling information entered by the user to refresh the Attribute 
table. Using this table, the user can determine the frequency at which the 
various Attribute table rows are refreshed based on the AttributeGroup 
they belong to.

DataSet: This table lists all the data components that can be imported into 
the Reports database along with their characteristics. The information 
found here closely matches the sub schemas listed in this section.

DataSetGranularity: This table lists all the possible granularities 
(resolutions) (certain) data sets can have.

DB Version: This table contains the actual version of the Network 
Inventory sub-schema (and associated sub-schemas) and the Workstation 
Inventory sub-schema. 

LastTime: This table contains the last time a load operation was 
performed for a given appliance and data set.

NMID: This table lists all the internal Network Manager IDs that 
contribute to populate the Reports database, along with their matching 
Appliance_IDs and the corresponding Object_IDs to which they are 
mapped. It also contains information stating when the last update was 
performed on a specific object as well as the status this object has in the 
source appliance.

Object: This table lists all the Object_IDs and which table (Connection, 
Device, IPv4, MAC, Port, Serial Number, SubComponent, VLAN) they 
belong to. The Object table serves as a foreign key exported to these tables 
(Device, Ports, and so on.). This means that the primary keys of these 
tables can not overlap. For example, if the value 1 is assigned to the 
Device_ID (key) of the Device table, then that value can not appear as the 
value of any primary key found in any of the other tables (such as Port_ID, 
Connection_ID).

RefreshRate: Stores the various possible values for the data set refresh rate 
configuration parameter.
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Schedule: This table contains information related to scheduled jobs (jobs 
under the control of the sch_scheduler jobs scheduler).

ScheduleLog: This table contains information and statistics about the 
status of jobs that have run or are currently running.

UpdateHistory: This table gives the time a Network Inventory 
Sub-Schema update run was performed as well as how many objects were 
updated by that run. Note that update runs are performed on a per 
appliance basis.

The Events sub-schema
The Events sub-schema stores the various events that occurred on the 
network over the last 45 days. The retention period could be shorter if the 
number of events exceeds 200,000 (for each appliance). 

The Events sub-schema contains the following tables:

Event: The Event table lists all the events that have occurred on specific 
device attributes over time. As times goes by, old events are purged from 
this table to keep its size manageable.

Attribute: The Attribute table lists all the attributes a given device or port 
can have. Note that the list of attributes (of a device or port) may not be 
exhaustive depending on the settings found in the 
AttributeRefreshSchedule table. 

Attribute State: The AttributeState table lists all the attributes of a device 
or port that are alarmed. It can also contain values of attributes that are 
not alarmed (such as the number of pages printed) based on criteria set up 
by the user (and stored in the AttributeRefreshSchedule table).

Connection Event: The ConnectionEvent table stores information 
associated with “connection” Events: i.e., Events that are created following 
a change in the connectivity between two Devices (or Ports).

Attribute Group State: The AttributeGroupStateSummary table is a 
summary of all alarmed rows found in the AttributeState table (State > 1) 
grouped by AttributeGroup, ObjectType (i.e., Device or Port), Priority, & 
State. This table is primarily used to speed up the display of the Aggregate 
Health Panel.
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