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Legal Notices

Warranty

Hewlett-Packard makes no warranty of any kind with regard to this document, including, but not limited to, 
the implied warranties of merchantability and fitness for a particular purpose. Hewlett-Packard shall not be 
held liable for errors contained herein or direct, indirect, special, incidental or consequential damages in 
connection with the furnishing, performance, or use of this material. 

A copy of the specific warranty terms applicable to your Hewlett-Packard product can be obtained from your 
local Sales and Service Office.

Restricted Rights Legend

Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph 
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause in DFARS 252.227-7013.

Hewlett-Packard Company
United States of America

Rights for non-DOD U.S. Government Departments and Agencies are as set forth in FAR 52.227-19(c)(1,2).

Copyright Notices

© Copyright 2000–2004 Hewlett-Packard Development Company, L.P.

No part of this document may be copied, reproduced, or translated into another language without the prior 
written consent of Hewlett-Packard Company. The information contained in this material is subject to change 
without notice.

Trademark Notices

OpenView is a U.S. registered trademark of Hewlett-Packard Company. JavaTM is a U.S. trademark of Sun 
Microsystems, Inc. Windows® is a U.S. registered trademark of Microsoft® Corp. UNIX® is a registered 
trademark of The Open Group. 
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Support

Please visit the HP OpenView Web site at:

http://openview.hp.com/ 

There you will find contact information and details about the products, services, and support that HP 
OpenView offers.

You can go directly to the HP OpenView Web site at:

http://support.openview.hp.com/ 

The support Web site includes:

• Downloadable documentation

• Troubleshooting information

• Patches and updates

• Problem reporting

• Training information

• Support program information
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Overview

The Threshold and Event Generation Module, shortened to the Thresholds Module from here 
on out, monitors data for threshold violations. When it detects that a threshold has been 
breached or that a previous breach has returned to normal, it invokes an action. The default 
action is to send an SNMP trap.

The Thresholds Module is highly configurable. You can define threshold policies describing 
one or more events, and you can enable one or more actions per event. A MIB definition file, 
included with the Thresholds Module, allows network management systems to interpret the 
threshold breach and threshold clear traps.

Many of the reporting solutions that install on OVPI include a thresholds sub-package. The 
thresholds sub-package contains a thresholds policy customized for the solution. If you want 
to implement thresholding, install the thresholds sub-package and the Thresholds Module. 
You can also create your own thresholds policy. To do that, use existing files as templates (the 
Thresholds Module includes template files) or create these files from scratch. 

Version History

Version 4.0 of the Thresholds Module was released October 2003 as part of Reporting and 
Network Solutions (RNS) 4.0. Version 5.0 of the Thresholds Module was released April 2004 
as part of RNS 5.0. Version 5.0 of the Thresholds Module includes the following 
enhancements:

• Supports Oracle as well as Sybase database software

• Calls a perl script that provides a JavaTM interface to the OVPI database

Tasks and Traps

The Thresholds Module performs the following tasks: 

• Reads policy configuration files

• Creates queries against data in OVPI database tables 

• Responds to any exception condition by taking specified actions

• Records the object, the time, and the data values that triggered the exception
7



Threshold Examples Package
Each event is identified by values for Category and Severity. After all threshold exceptions 
have been identified, the Category and Severity of each exception are used to determine 
which, if any, of the following actions should occur:

• Send an SNMP trap

• Send SMTP e-mail

• Call a user-defined program

A single event can trigger one or more actions. For example, a single event could trigger a 
trap, an e-mail, and a program call. The timing of an action depends on the type of action. For 
example, while traps are sent one at a time, e-mails are batched together and sent later, after 
every exception has been processed.

Threshold Examples Package

Installing the optional Threshold Examples package does two things:

• Creates new database tables populated with test data

• Installs configuration files that monitor the new database tables

Since the data in the tables is recycled, the data is always up-to-date. The threshold policies 
will cause several OVPI threshold SNMP traps to be sent to the local host on a regular basis. 
This example is intended to illustrate the operation of the Thresholds Module. Installing it is 
entirely optional.

Sources for Additional Information

For the latest information regarding limitations and known problems affecting the Thresholds 
Module, see:

Threshold and Event Generation Module 5.0 Release Statement 

For information about the threshold sub-packages that come with most report packs, refer to 
the following user guides:

• Interface Reporting Report Pack User Guide 

• MPLS VPN Report Pack User Guide 

• Cisco Ping Report Pack User Guide 

• Service Assurance Report Pack User Guide 

• Device Resources Report Pack User Guide 

• System Resources Report Pack User Guide 

The following documents may also be of interest to you:

• Creating and Using Registration Files with HP OpenView NNM

• Managing Your Network with HP OpenView Network Node Manager

• HP OpenView Performance Insight Administration Guide
8



Chapter 1
Manuals for the core product, OVPI, and manuals for the reporting solutions that run on 
OVPI are posted to the following website:

http://support.openview.hp.com/support

Select Technical Support > Product Manuals to open the Product Manual Search page. Manuals 
for OVPI are listed under Performance Insight. Manuals for report packs, datapipes, and 
preprocessors are listed under Reporting and Network Solutions. 

Each user guide listed under Reporting and Network Solutions indicates the month and year of 
publication. If a user guide is revised and reposted, the date of publication will change even if 
the software version number does not change. Always check for updates on the web before 
using an older PDF that may no longer be current.
9
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Package Installation

This chapter covers the following topics:

• Upgrading or Removing an Earlier Version?

• Software Prerequisites

• Installing Thresholds Module 5.0

• Testing the Thresholds Script

• Uninstalling Thresholds Module 5.0

Upgrading or Removing an Earlier Version?

When you insert the RNS 5.0 CD and select OVPI components for installation, the install 
script will extract every OVPI package from the CD and copy the results to the Packages 
directory on your system. When the extraction process finishes, the install script will prompt 
you to launch Performance Insight and start Package Manager. 

If you are currently running version 4.0, you can use the Package Manager install wizard to 
upgrade to version 5.0 by installing the 4.0-to-5.0 upgrade package. If you are currently 
running any version earlier than 4.0, you cannot upgrade to the latest release. Instead, 
remove the version you are running now, then install version 5.0.

Software Prerequisites

Make sure the following platform software is already installed before installing the 
Thresholds Module:

• OVPI 5.0

• Any available Service Pack for OVPI 5.0

Aside from OVPI 5.0, the Thresholds Module has no prerequisites. Rather, the Thresholds 
Module is itself a prerequisite for the various threshold sub-packages that come with most 
report packs. When you select one of these sub-packages for installation, Package Manager 
will install the Thresholds Module for you, automatically. However, you also have the option of 
using the instructions in this chapter to install the Thresholds Module before you install any 
threshold sub-package.
11



Installing Thresholds Module 5.0
Installing Thresholds Module 5.0

Perform the following tasks to install Thresholds Module 5.0:

Task 1: Stop OVPI Timer and extract OVPI packages from the RNS 5.0 CD

Task 2: Use Package Manager to install Thresholds Module 5.0

Task 3: Restart OVPI Timer

Task 1: Extract OVPI packages from the RNS 5.0 CD

If you have not already extracted packages from the RNS 5.0 CD, complete these steps:

1 Log in to the system. On UNIX® systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.

On UNIX, as root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer stop

— Sun: sh /etc/init.d/ovpi_timer stop

3 Insert the RNS CD. 

Windows: The package extraction interface opens automatically. 

UNIX: 

a Mount the CD (if the CD does not mount automatically).

b Navigate to the top level directory on the CD.

c Run ./setup

4 Type 1 in the choice field and press Enter. The install script displays a percentage 
complete bar. When the copy is complete, the install script starts Package Manager. The 
Package Manager Welcome window opens.

Task 2: Install Thresholds Module 5.0

1 Click Next. The Package Location window opens.

2 Click the Install button; approve the default installation directory or select a different 
directory if necessary. 

3 Click Next. The Report Deployment window opens. Accept the option to Deploy Reports.

4 Type your username and password for the OVPI Application Server. 

There are no reports with the Thresholds Module. However, there 
are forms and the forms will not deploy unless you accept the 
Deploy Reports option.
12



Chapter 2
5 Click Next. The Package Selection window opens. 

6 Click the check boxes next to the following items: 

• Thresholds

• ThresholdExample (optional)

• ThresholdsRP (optional)

7 Click Next. The Type Discovery window opens; disable the Type Discovery option.

8 Click Next. The Selection Summary window opens. 

9 Click Install. The Installation Progress window opens. When installation is complete, a 
package installation complete message appears.

10 Click Done to return to the Management Console. 

Task 3: Restart OVPI Timer.

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

On UNIX, as root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer start

— Sun: sh /etc/init.d/ovpi_timer start

Testing the Thresholds Script

To verify that the Thresholds Modules and all the prerequisites have been installed correctly, 
run one of the following commands.

UNIX:

$DPIPE_HOME/bin/perl $DPIPE_HOME/scripts/thresholds.pl -h

Windows:

%DPIPE_HOME%\bin\perl %DPIPE_HOME%\scripts\thresholds.pl -h 

The system returns a usage-is statement similar to the following: 

D:/OVPI/scripts/thresholds.pl -f <rulesfile> [-d]

where:

<rulesfiles> is an XML threshold rules definition file

-d enables the debug mode

The default action file is {DPIPE_HOME}/lib/threshAct.xml

If you do not see this statement, see “Troubleshooting” on page 41.
13



Uninstalling Thresholds Module 5.0
Uninstalling Thresholds Module 5.0

Before removing the Thresholds Module, be aware that any sup-packages that depend on the 
Thresholds Module (for example, MPLS_VPN_Thresholds) will be automatically selected and 
uninstalled. 

Follow these steps to remove Thresholds Module 5.0: 

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Stop.

On UNIX, as root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer stop

— Sun: sh /etc/init.d/ovpi_timer stop

3 Start Package Manager. The Package Manager welcome window opens. 

4 Click Next. The Package Location window opens.

5 Select the Uninstall button and click Next. The Report Undeployment window opens.

6 Keep the defaults and click Next. The Package Selection window opens.

7 Click the check box next to the Thresholds package.

8 Click Next. The Selection Summary window opens.

9 Click Uninstall. The Progress window opens. When removal is complete, a package removal 
complete message appears.

10 Click Done to return to the Management Console.

11 Restart OVPI Timer.

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services

b Select OVPI Timer from the list of services.

c From the Action menu, select Start.

On UNIX, as root, do one of the following:

— HP-UX: sh /sbin/ovpi_timer start

— Sun: sh /etc/init.d/ovpi_timer start

Any packages that depend on the Thresholds Module (for example, 
MPLS_VPN_Thresholds) will be selected and uninstalled.
14



3

Defining and Maintaining Actions

This chapter covers the following topics:

• Thresholds Sub-package

• Using Forms to Maintain Action Definitions

• Supported Actions

• Disabling an Action

Thresholds Sub-package

Most OVPI report packs are distributed with a thresholds sub-package. The thresholds sub-
package contains a customized threshold policy that defines the conditions that cause 
exceptions to be reported. If you want to modify threshold values, do not modify the thresholds 
sub-package. Instead, modify threshold values by using the threshold policy that comes with 
the thresholds sub-package.

If you want to set new threshold limits for some or all of the objects you are monitoring, use 
one of the forms or the provisioning interface that comes with the report pack. The forms, 
which are described in this chapter, are easier and faster than the provisioning interface. If 
you use the provisioning interface, you must export existing property data from OVPI, edit 
this file by inserting new threshold values, and then re-import the file into OVPI.

Using Forms to Maintain Action Definitions

Action definitions are stored in the OVPI database. You can use OVPI forms to create and 
maintain action definitions. Access forms from the OVPI Management Console in the Objects 
section. Forms contain detailed instructions for their use.

All actions have Category and Severity values associated with them. These may be wildcards 
(*), which match any Category or any Severity. These values are used to associate actions with 
threshold breaches, which must have a Category and Severity associated with them.
15



Using Forms to Maintain Action Definitions
Category Value

The Category value is the name of the event category that will cause this action to occur. To 
match all categories, use a wildcard by entering an asterisk (*). Category is an arbitrary 
string value and can be set to any non-null value (subject to database limitations).

Severity Value

The Severity value reflects the severity of an event that will cause this action to occur. To 
match all severities, use a wildcard by entering an asterisk (*). Severity is an arbitrary string 
value and can be set to any non-null value (subject to database limitations). Using values that 
match the severity levels used by other systems is recommended. For example, if you are 
sending traps to a network management system that assigns traps to severities CRITICAL, 
HIGH, MEDIUM, and LOW, use these values.

Default Actions

Default actions are those that will occur regardless of the Category or Severity of the 
threshold breach that has occurred; that is, they will occur for all exceptions. Default actions 
have wildcards (*) for both the Category and Severity fields. 

A default action is inserted into the database during package installation. The default action 
is to send an SNMP trap to port 162 on the local system using a community string set to 
“public”. If you want to send traps to a different destination, use a nonstandard SNMP port, or 
use a different community string, you must edit the SNMP action definitions. Do this by 
accessing the Update SNMP Trap Action Definition form (see “Updating SNMP Trap Actions” 
on page 19) and using it to change the values for server, port, or community.

You may choose to have additional default actions. For example, you can create a user script 
default action definition by typing the wildcard symbol (*) in the Category and Severity fields 
on the Create User Script Action Definition form (see “Creating User Script Actions” on 
page 25). Then you will have two default actions: an SNMP trap action and user script action.

Creating and Modifying Action Definitions

You can define multiple actions. For example, you may send traps to more than one system, or 
you may send both e-mail and traps for the same exception. The following are the types of 
actions you can define:

• SNMP Trap

• SMTP Mail

• User Script

After you create an action definition, you can modify it using the corresponding Update Action 
Definition form.

Disabling Actions

You can disable actions, but they will remain in the database in case you want to enable them 
in the future. For instructions, see “Disabling an Action” on page 29.
16



Chapter 3
Supported Actions

Three actions are supported, and each requires a set of parameters.

1. SNMP-TRAP

Parameters

• Server
• Port 
• Community

An SNMP trap is sent to the specified server and port using the specified community string. 

The ovpiThresholdBreach trap is sent when a threshold condition is initially breached. The 
ovpiThresholdClear trap is sent when the condition returns to normal. Details about the 
exception are stored in the trap variables. The package includes a MIB that defines 
ovpiThresholdBreach and ovpiThresholdClear traps. For details, see “OVPI Exception MIB” 
on page 43.

Creating SNMP Trap Actions

To create an SNMP trap action, use the Create SNMP Trap Action Definition form. Follow 
these steps to launch the form:

1 In the Management Console, click the Objects icon. 

2 Select File > New.

3 Select Create SNMP Trap Action and click Create.

4 Follow the instructions on the form.

5 When you finish, click OK.
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Updating SNMP Trap Actions

To modify an existing SNMP trap action, use the Update SNMP Trap Action Definition form. 
Follow these steps to launch the form:

1 In the Management Console, click the Objects icon. 

2 Select an object so that the General Tasks pane is updated.

3 In the list of General Tasks, double-click Update SNMP Trap Action. The Update SNMP 
Trap Action Definition form opens.

4 Click the desired action definition from the list of actions near the center of the form. The 
boxes in the bottom section of the form display the action definition parameters.

5 Modify the desired parameters.

6 When you finish making changes, click OK.
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2. SMTP-MAIL

Parameters

• Server
• Port 
• To
• From
• Subject

An email is sent using the specified SMTP server details. No authentication is used, because 
the assumption is that the SMTP server will be set up to allow unauthenticated mail from 
OVPI. The email contains a copy of the exception variables in a CSV-like format. Multiple 
exceptions will be bundled in a single e-mail for each address.

Creating SMTP Mail Actions

To create an SMTP mail action, use the Create SMTP Mail Action Definition form. Follow 
these steps to launch the form:

1 In the Management Console, click the Objects icon. 

2 Select File > New.

3 Select Create SMTP Mail Action and click Create.

4 Follow the instructions on the form.

5 When you finish, click OK.
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Updating SMTP Mail Actions

To modify an existing SMTP mail action, use the Update SMTP Mail Action Definition form. 
Follow these steps to launch the form:

1 In the Management Console, click the Objects icon. 

2 Select an object so that the General Tasks pane is updated.

3 In the list of General Tasks, double-click Update SMTP Mail Action. The Update SMTP Mail 
Action Definition form opens.

4 Click the desired action definition from the list of actions near the center of the form. The 
boxes in the bottom section of the form display the action definition parameters.

5 Modify the desired parameters.

6 When you finish making changes, click OK.
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3. USER-SCRIPT

Parameters

A CSV file is created for each exception type (combination of Category and Severity). The 
specified program is then called once for each file created and the filename is passed as a 
parameter.

The user script program is called using the command line supplied. If the program is not on 
the user’s path, an appropriate path name should be included. In addition, the user must have 
suitable permissions to run the program. The program is responsible for managing the files 
created; the thresholding package does not archive or delete them.

The program is launched independent of the thresholding package and may outlive the 
instance that invokes it. Be careful when calling processes that require user intervention. If a 
backlog of processes develops, OVPI may slow down or even crash. For this reason, it is good 
practice to call processes that run to completion automatically.

Creating User Script Actions

To create a user script action, use the Create User Script Action Definition form. Follow these 
steps to launch the form:

1 In the Management Console, click the Objects icon. 

2 Select File > New.

3 Select Create User Script Action Definition and click Create.

4 Follow the instructions on the form.

5 When you finish, click OK.
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Updating User Script Actions

To modify an existing user script action, use the Update User Script Action Definition form. 
Follow these steps to launch the form:

1 In the Management Console, click the Objects icon. 

2 Select an object so that the General Tasks pane is updated.

3 In the list of General Tasks, double-click Update User Script Action Definition. The Update 
User Script Action Definition form opens.

4 Click the desired action definition from the list of actions near the center of the form. The 
boxes in the bottom section of the form display the action definition parameters.

5 Modify the desired parameters.

6 When you finish making changes, click OK.
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Disabling an Action

You can disable actions, but they will remain in the database in case you want to enable them 
in the future. Do the following to disable an action:

1 In the Management Console, click the Objects icon.

2 Select an object so that the General Tasks pane is updated.

3 In the list of General Tasks, double-click the desired Update Action Definition form. The 
form opens.

4 Click the desired action definition from the list of actions near the center of the form. The 
boxes in the bottom section of the form display the action definition parameters.

5 Change Category and/or Severity to a value that will not occur (for example, 
“NOT_IN_USE” or “RESERVED”) to ensure that the action will not take place.

6 Click OK.
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Advanced Configuration

To configure the more advanced features of the Thresholds Module, it helps to be familiar 
with the components of the threshold sub-package. A threshold sub-package contains:

• A procedure file that calls the Threshold Module with appropriate configuration files

• trendtimer.sched file entries that control timing of threshold checking

• A threshold policy definition

Threshold Procedure File

A threshold procedure file is an OVPI procedure (.pro file) and typically consists of a single 
call to the Thresholds Module within a single block. A single procedure file could also be used 
to check multiple thresholds across multiple tables by simply inserting multiple calls to the 
Thresholds Module, either in the same block or another block. For more information about 
OVPI procedure files, refer to the HP OpenView Performance Insight Reference Guide.

A call to the Thresholds Module within a procedure file looks like this:

begin: checkThreshold

{DPIPE_HOME}/bin/perl {DPIPE_HOME}/scripts/thresholds.pl -f policy.xml

end: checkThreshold

policy.xml should be replaced with a full path to the desired configuration file.

Scheduling Threshold Checking

To check thresholds on a regular basis, you should set up an entry in the trendtimer.sched 
file to call an appropriate procedure file. You should check thresholds at a frequency that is 
less than or equal to the frequency at which data is inserted into the table you are checking. 
For example, if data is collected and inserted into the table every 15 minutes, you should not 
check thresholds more often than every 15 minutes. For more information about OVPI 
trendtimer.sched entries, refer to the HP OpenView Performance Insight Reference Guide.

Here is an example of a trendtimer.sched entry that calls a thresholds procedure every 15 
minutes:

15 - - {DPIPE_HOME}/bin/trend_proc -f {DPIPE_HOME}/scripts/thresh.pro
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Threshold Policy Definition File

Any call to the Thresholds Module must include a valid policy definition file. Policy definition 
files are written in XML, specifying the data to be checked and the threshold values for that 
data. The file also assigns a Category value and a Severity value to any threshold breaches 
(events). The structure and content of policy definition files are described in “Defining 
Threshold Policies” on page 33.
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Defining Threshold Policies

This chapter covers the following topics:

• Threshold Policy Definition Files

• Threshold Policy Definition File Names

• Threshold Policy Definition File Structure

• Examples of Threshold Policy Definitions

Threshold Policy Definition Files

A threshold definition file establishes a threshold policy. It provides the rules necessary to 
construct queries against a single database table or view and an associated property table. A 
view may span multiple data and property tables.

Threshold configuration files are written in XML. To modify them you can use an XML editor 
or any text editor. 

The threshold policy definition file contains a number of clauses. Some are mandatory and 
some are optional, but the structure is fixed.

When modifying XML files, make sure that you use special characters correctly. For 
example, in XML the less-than (<) and greater-than (>) signs indicate the start and end 
of tags. If you want symbols for less-than and greater-than, use &lt and &gt. If you want 
to add a comment, use this format: 

<!-- This is a comment --> 

Most web browsers know when an XML file is correctly constructed. Load the edited file 
into your browser to verify it is well constructed.
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Threshold Policy Definition File Names

A threshold definition file name cannot exceed 27 characters in length (ignoring the final 
period and any extension following the period). The name of the threshold definition file is 
used to build an OVPI data table that stores data required by the Thresholds Module. 
Exceeding this character limit may cause errors when the data table is built and when the 
data table is used.

Threshold Policy Definition File Structure

The threshold policy definition file consists of a single all-encompassing OVPI clause. The 
OVPI clause contains a single “ThresholdPolicy” clause.

A “ThresholdPolicy” clause consists of several clauses; a “MaxAge” clause, a “DataTable” 
clause, a “Constraint” clause and a “Thresholds” clause. It may optionally include “Variables” 
and “UserDefs” clauses.

A “Constraint” clause contains a single “SQL” clause.

An “SQL” clause contains an optional “Name” clause, a “PropertyTable” clause, and an 
optional SQL constraint “Clause” clause.

A “Variables” clause contains a number of “Variable” clauses.

A “Variable” clause contains a “Data” clause.

A “UserDefs” clause contains up to five numbered “UserDefX” clauses.

A “Thresholds” clause consists of a number of “Threshold” clauses.

A “Threshold” clause contains a “Rule” clause, identified by a “Name” and a “Severity”. It may 
also optionally be identified as being an “SLA” and may optionally contain a “Display” clause.

A “Rule” clause contains a “Data” clause.

A “Display” clause contains a “Data” clause.

This is shown below:

<OVPI>

  <ThresholdPolicy Category="CATEGORY-NAME">

    <MaxAge>

      <DeltaTime Value="MAXIMUM-AGE" Units="HOURS"/>

    </MaxAge>

    <DataTable>tableName</DataTable>

    <Constraint Type="SQL">

      <SQL>

        <Name>CONSTRAINT-NAME</Name>

        <!-- The Name clause is optional -->

        <PropertyTable>PROPERTY-TABLE</PropertyTable>

        <Clause>SQL-CONSTRAINT</Clause>
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        <!-- The SQL constraint Clause clause is optional -->

      </SQL>

    </Constraint>

    <Variables>

      <Variable Name=”VARIABLE-NAME”>

        <Data>VARIABLE-SQL</Data>

      </Variable>

    </Variables>

    <UserDefs>

      <UserDef1>USERDEF-SQL</UserDef1>

       <!-- Include up to five USERDEF tags -->

    </UserDefs>

    <Thresholds>

      <Threshold Name="THRESHOLD-NAME" Severity="SEVERITY" SLA=”SLA-FLAG”>

        <Rule>

          <Data>THRESHOLD-SQL</Data>

        </Rule>

        <Display>

          <Data>DISPLAY-SQL</Data>

        </Display>

      </Threshold>

       <!-- Include as many additional Threshold tags as desired -->

    </Thresholds>

  </ThresholdPolicy>

</OVPI>

Required values, appearing in italics above, are defined below.

CATEGORY_NAME

The name of the category to which any events defined in this threshold policy belong. 
Category name is an arbitrary string value and can be set to anything (subject to limitations 
imposed by XML). If you are integrating OVPI with NNM and wish to launch OVPI reports 
from NNM, you must set this value to a category that is registered with NNM.

MAXIMUM-AGE

The maximum age of data that will trigger an event. Must be entered in HOURS. Using 
exceptionally high values the first time a threshold-policy is run may cause event storms if 
there is a great deal of data in the table and threshold levels are frequently exceeded.
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DATA-TABLE

The data table to be checked. The table must be a valid OVPI data table or view.

CONSTRAINT-NAME

The name of the constraint applied to data to be checked. Constraint-name is an arbitrary 
string value and can be set to anything (subject to limitations imposed by XML). The 
constraint name does not get passed on from the thresholds module; thus, it is not externally 
visible. The name can be used to provide a description of what the constraint does, for 
example “DOMESTIC-US-CIRCUITS-ONLY” or “FRAME-RELAY-PORTS”.

PROPERTY-TABLE

The property table which is being checked. This must be related to the DATA-TABLE and 
exist in OVPI’s dictionary tables.

SQL-CONSTRAINT

An SQL clause that constrains the query. The query built by the threshold module is ANDed 
with this clause. Columns from property and/or data tables may be used. Prefix columns from 
the property table with “p.”; prefix columns in the data table with “d.”. For example, if the 
property table being checked contained a column for if_type, it would be possible to check 
thresholds for a particular if_type by using a constraint clause similar to the following:

<Clause>d.if_type = 17</Clause>

SQL is checked only when it is passed to the database server. Invalid SQL clauses will result 
in errors being returned from the database, which in turn will be logged by the Thresholds 
Module.

VARIABLE-NAME

The name by which the variable will be known. Variable names must be unique within the 
definition file.

VARIABLE-SQL

An SQL clause that will be evaluated to provide a value for the variable. Columns from 
property and/or data tables may be used. Prefix columns from the property table with “p.”; 
prefix columns in the data table with “d.”.

USERDEF-SQL

An SQL clause that will be evaluated and passed directly to output. Columns from property 
and/or data tables may be used. Prefix columns from the property table with “p.”; prefix 
columns in the data table with “d.”.
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SLA-FLAG

If this tag is present, the threshold is considered an SLA threshold and the value is ignored.

DISPLAY-SQL

An SQL clause that will be evaluated and passed to output. Columns from property and/or 
data tables may be used as well as variables (defined above). Prefix columns from the 
property table with “p.”; prefix columns in the data table with “d.”, prefix variables with “v”.

THRESHOLD NAME

The name of this threshold. Name is an arbitrary string value and can be set to anything 
(subject to limitations imposed by XML). 

SEVERITY

The severity of the event defined in the particular threshold-policy. Severity is an arbitrary 
string value and can be set to anything (subject to limitations imposed by XML). Using values 
that match with the severity levels used by other systems is recommended. For example, if 
you are sending traps to a network management system that assigns traps to severities 
CRITICAL, HIGH, MEDIUM, or LOW, use these values.

THRESHOLD-SQL

SQL clauses that constitute the main body of the threshold query. Columns from property 
and/or data tables may be used. Prefix columns from the property table with “p.”; prefix 
columns in the data table with “d.”. For example, if the property table being checked 
contained a column for CIR, and the data table contained a column for bytes_transmitted, it 
would be possible to determine if the bytes_transmitted exceeded the CIR by using the 
following SQL clause:

<Data>d.bytes_transmitted &gt; p.cir</Data>

Examples of Threshold Policy Definitions

A number of examples of policy definition files are included with the thresholds module. You 
can find them in the following directories:

UNIX

  $DPIPE_HOME/packages/Thresholds/ThresholdExamples.ap/xml

Windows

  %DPIPE_HOME%\pacakges\Thresholds\ThresholdExamples.ap/xml
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Understanding Policy Definitions 

This section contains a sample policy definition and explanation.

Sample Definition

<OVPI>
  <ThresholdPolicy Category="THRESHOLD-EXAMPLE">

    <MaxAge>
      <DeltaTime Value="1" Units="HOURS"/>
    </MaxAge>

    <DataTable>R_threshEg</DataTable>

    <Constraint Type="SQL">
      <SQL>
        <PropertyTable>K_threshEg</PropertyTable>
      </SQL>
    </Constraint>

    <Variables>
      <Variable Name="utilisation">
        <Data>((d.ifinoctets * 8 * 1000) / (60 * (1+ d.delta_time)))</Data>
      </Variable>
    </Variables>

    <UserDefs>
      <UserDef1>d.received_usec</UserDef1>
    </UserDefs>

    <Thresholds>
      <Threshold Name="EXAMPLE1" Severity="HIGH" SLA="True">

        <Rule>
          <Data>(d.ifinoctets * 8 * 1000) / (60 * (1+ d.delta_time))) 
                                               &gt; p.util_threshold)</Data>
        </Rule>

        <Display>
          <Data>Utilisation = v.utilisation, limit = p.util_threshold</Data>
        </Display>

      </Threshold>

    </Thresholds>
  </ThresholdPolicy>
</OVPI>

Explanation

The statements above define a threshold in the category THRESHOLD-EXAMPLE. The 
category is an arbitrary name that can be used (with Severity) to identify groups of 
thresholds. This mechanism is used to associate threshold breaches (or clears) with actions.

The maximum age of data that will cause an exception is set to one hour. Data samples are 
checked only once at most. If a sample is either older than the last sample checked (for a 
particular object) or the sample is older than the maximum age specified in this clause, it will 
be ignored.
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Data from the table “R_threshEg” will be checked. The table has a related property table: 
“K_threshEg”.

A variable called “utilisation” is defined. Any variables defined can be used in “display” 
clauses (described below).

A user defined field is created. This is passed directly to output.

A single threshold rule, EXAMPLE1, is defined. The severity associated with this threshold is 
HIGH and, because the SLA tag is defined, any actions generated by this rule will have the 
SLA flag set to True. 

The rule checks whether the calculated value for circuit utilisation is greater than the limit 
stored in the property table. Different objects can have different limits.

A display clause is defined and contains the variable defined above, some text, and the limit 
value from the property table. If the threshold is breached, the resulting string will look 
similar to this: “Utilisation = 93, limit = 90”.
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Troubleshooting

This chapter explains how to:

• Troubleshoot error and warning messages

• Troubleshoot problems caused by the thresholds.pl file not running

In OVPI 5.0, the thresholds functionality logs to the website.log file. The perl script 
thresholds.pl will continue to log to the trend.log file, but you can usually obtain 
more detailed data from the website.log file.

Error and Warning Messages

The following table, sorted alphabetically by message, provides recommended responses to 
specific error messages.  

MESSAGE TYPE SUGGESTED ACTION

Cannot find system information
Error code: 10

FATAL Use the system manager component in 
the Management Console to identify a 
database system as the default collector 
database. Usually this is the local host.

Failed to lock rules file (another 
instance may be running)
Error code: 11

FATAL The requested policy is still in use. Wait 
and try again.

Invalid property table
Error code: 12

FATAL Make sure the key table specified in the 
policy file matches the key table defined 
in the database.

Some threshold actions 
reported errors. See log file for 
more details.
Error code: 99

Reason: The threshold action 
(SNMP, User-Script, or Mail) 
reported an error during 
processing

FATAL You can find additional information in 
the website.log file. Verify that the 
thresholds policy file and threshold 
actions are correctly formatted and that 
the required statistics appear in the key 
and data tables.
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Running the thresholds.pl File

On UNIX systems, check that execute permission has been granted to the files in the Scripts 
directory, located beneath the $DPIPE_HOME directory. Run the following command: 

ls -l $DPIPE_HOME/scripts/thresholds.pl 

If execute permission has been granted, a message similar to this message appears:

-rwxr-x--x 1 trendadm adm 25591 Aug 24 19:42 thresholds.pl 

Execute permission for the current user is shown by the fourth letter in the permission string 
(“-rwxr-x--x” in the example above) and must be set to “x”.

Unknown error has occurred at 
<LOCATION>
Error code: 99

This error code is usually 
followed by a reason message 
and line number that HP 
Technical Support can use to 
help you resolve the problem. 

FATAL You can find additional information in 
the website.log file. Verify that the 
thresholds policy file and threshold 
actions are correctly formatted and that 
the required statistics appear in the key 
and data tables.

MESSAGE TYPE SUGGESTED ACTION
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OVPI Exceptions

This chapter covers the following topics:

• OVPI Exception MIB

• OVPI Exception Mail

• OVPI Exception User Scripts

• OVPI Exception Content 

OVPI Exception MIB

The OVPI exception MIB defines the trap sent by the Thresholds Module. The MIB is 
included with the package. You do not have to install the MIB to send threshold traps.

OVPI-EXCEPTION DEFINITIONS ::= BEGIN

-- Version @(#) hpov-pi.mib /main/3 mcameron Tue Sep 16 06:11:20 2003 @(#)

IMPORTS

    MODULE-IDENTITY, OBJECT-IDENTITY, OBJECT-TYPE,

    NOTIFICATION-TYPE, enterprises

        FROM SNMPv2-SMI

    DisplayString,

        FROM SNMPv2-TC

    MODULE-COMPLIANCE, OBJECT-GROUP, NOTIFICATION-GROUP

        FROM SNMPv2-CONF;

hp                      OBJECT IDENTIFIER ::= { enterprises 11 }

nm                      OBJECT IDENTIFIER ::= { hp 2 }
43



OVPI Exception MIB
openView                OBJECT IDENTIFIER ::= { nm 17 }

hpOVPerformanceInsight  OBJECT IDENTIFIER ::= { openView 14 }

ovpiEvents              OBJECT IDENTIFIER ::= { hpOVPerformanceInsight 0 }

ovpiVariables           OBJECT IDENTIFIER ::= { ovpiEvents 4 }

ovpiThreshold MODULE-IDENTITY

       LAST-UPDATED "200309150000Z" 

       ORGANIZATION "HP OpenView PerformanceInsight" 

       CONTACT-INFO 

             "Name: Michael Cameron 

              Addr: 10700 Parkridge Blvd.

              Reston, VA 20191 -- Tel: +44 (0)1563 822370 

              Fax: +44 (0)1563 822611 

              Email: Michael.Cameron@hp.com" 

       DESCRIPTION 

             "HP OpenView PerformanceInsight (OVPI) can be configured 

              to send traps when defined threshholds are exceeded. 

              These traps appear under this branch." 

       ::= { hpOVPerformanceInsight 1 }

ovpiThresholdBreach    NOTIFICATION-TYPE

       OBJECTS { 

                  ovpiThresholdID, 

                  ovpiThresholdTargetName, 

                  ovpiThresholdTableKey, 

                  ovpiThresholdTaPeriod, 

                  ovpiThresholdCondition,

                  ovpiThresholdExpression,

                  ovpiThresholdCategory,

                  ovpiThresholdSeverity,

                  ovpiThresholdUserDef1,

                  ovpiThresholdUserDef2,
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                  ovpiThresholdUserDef3,

                  ovpiThresholdUserDef4,

                  ovpiThresholdUserDef5,

                  ovpiThresholdDisplayString,

                  ovpiThresholdSLA

               }

       STATUS  current

       DESCRIPTION

         "Indicates a threshold exception has occured.  TRAP variables provide further details."

       ::= { ovpiEvents 2 }

ovpiThresholdClear    NOTIFICATION-TYPE

       OBJECTS { 

                  ovpiThresholdID, 

                  ovpiThresholdTargetName, 

                  ovpiThresholdTableKey, 

                  ovpiThresholdTaPeriod, 

                  ovpiThresholdCondition,

                  ovpiThresholdExpression,

                  ovpiThresholdCategory,

                  ovpiThresholdSeverity,

                  ovpiThresholdUserDef1,

                  ovpiThresholdUserDef2,

                  ovpiThresholdUserDef3,

                  ovpiThresholdUserDef4,

                  ovpiThresholdUserDef5,

                  ovpiThresholdDisplayString,

                  ovpiThresholdSLA

               }

       STATUS  current

       DESCRIPTION

         "Indicates a threshold exception has cleared.  TRAP variables provide further details."

       ::= { ovpiEvents 3 }
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ovpiThresholdID OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "ID of the definition which caused the exception"

      ::= { ovpiVariables 1 }

ovpiThresholdTargetName OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "target name of the object for which the exception occured"

      ::= { ovpiVariables 2 }

ovpiThresholdTableKey OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "table key of the object for which the exception occured"

       ::= { ovpiVariables 3 }

   

ovpiThresholdTaPeriod OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "ta_period of the data for which the exception occured"

       ::= { ovpiVariables 4 }
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ovpiThresholdCondition OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "The exception condition"

       ::= { ovpiVariables 5 }

ovpiThresholdExpression OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "The values which caused the exception"

       ::= { ovpiVariables 6 }

       

ovpiThresholdCategory OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "Category"

       ::= { ovpiVariables 7 }

   

ovpiThresholdSeverity OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "Severity"

       ::= { ovpiVariables 8 }
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ovpiThresholdUserDef1 OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "UserDef1"

       ::= { ovpiVariables 9 }

ovpiThresholdUserDef2 OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "UserDef2"

       ::= { ovpiVariables 10 }

ovpiThresholdUserDef3 OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "UserDef3"

       ::= { ovpiVariables 11 }

ovpiThresholdUserDef4 OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "UserDef4"

       ::= { ovpiVariables 12 }
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ovpiThresholdUserDef5 OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "UserDef5"

       ::= { ovpiVariables 13 }

ovpiThresholdDisplayString OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "DisplayString"

       ::= { ovpiVariables 14 }

ovpiThresholdSLA OBJECT-TYPE

       SYNTAX         OCTET STRING

       MAX-ACCESS  read-only

       STATUS      current

       DESCRIPTION

           "SLA"

       ::= { ovpiVariables 15 }

       

END

OVPI Exception Mail

Mail messages consist of a single row header containing field names followed by one row per 
exception. Fields are comma delimited. Content is described in the table below.
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OVPI Exception User Scripts

Exception files passed to user scripts consist of one row per exception. Fields are comma 
delimited.  Content is described in the table below.

OVPI Exception Content

OVPI exceptions contain the following information:

Column Name Contents

Status 0 for clear, 1 for breach

Threshold ID The name of the rule that has been breached.

TargetName The target name of the object that caused the breach.

TableKey The table key of the object that caused the breach.

TaPeriod The time period the data that caused the threshold 
relates to.

Condition The threshold condition (from the rule).

Expression The threshold condition with values substituted into 
it.

Category The category the threshold belongs to.

Severity The severity assigned to the threshold.

UserDef1 User-defined field.

UserDef2 User-defined field.

UserDef3 User-defined field.

UserDef4 User-defined field.

UserDef5 User-defined field.

DisplayString A string designed for presentation to users, which can 
include details of the threshold and the values that 
caused the exception.

SLA If set to 1, this exception indicates that an SLA breach 
has occurred.
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