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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed 
as constituting an additional warranty. HP shall not be liable for technical or editorial errors 
or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or 
copying. Consistent with FAR 12.211 and 12.212, Commercial Computer Software, 
Computer Software Documentation, and Technical Data for Commercial Items are licensed 
to the U.S. Government under vendor's standard commercial license.

Third-Party Web Sites

HP provides links to external third-party Web sites to help you find supplemental 
information.  Site content and availability may change without notice.  HP makes no 
representations or warranties whatsoever as to site content or availability.

Copyright Notices

© Copyright 2000 - 2010 Hewlett-Packard Development Company, L.P.

Trademark Notices

Java™ is a US trademark of Sun Microsystems, Inc.

Microsoft® and Windows® Microsoft and Windows are U.S. registered trademarks of 
Microsoft Corporation.

Oracle®  is a registered US trademark of Oracle Corporation, Redwood City, California.

UNIX®  is a registered trademark of The Open Group. 
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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. 
As a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. 
Many also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
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Welcome to This Guide

Welcome to the HP Service Test Management Installation Guide. Service Test 
Management is an extension for HP Quality Center that allows you to 
manage application components such as Web Services, REST services, and 
others, within the Quality Center repository. This guide describes how to 
install and set up HP Service Test Management.

 ➤  How This Guide Is Organized on page 5

 ➤  Who Should Read This Guide on page 7

 ➤  HP Service Test Management Online Documentation on page 7

 ➤  Additional Online Resources on page 7

How This Guide Is Organized

This guide contains the following sections:

Section 1 Requirements for Service Test Management

Provides the requirements and prerequisites for installing HP Service Test 
Management.

Section 2 The Installation Process

Provides you with the information that helps you prepare for the 
installation process.
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Section 3 Installing Service Test Management

Describes how to install HP Service Test Management on a Windows 
machine.

Section 4 Loading the Service Test Management License

Describes the process for requesting and activating a license code for your 
copy of Service Test Management.

Section 5 Enabling the Service Test Management Extension

Describes how to enable the Service Test Management extension in Quality 
Center.

Section 6 Installing the Service Test Add-in for Quality Center

Describes how to install the Service Test add-in for Service Test Management 
which adds several SOA utilities.

Section 7 Uninstalling Service Test Management

Describes how to uninstall HP Service Test Management.

Section 8 Upgrading Service Test Management

Describes how to upgrade HP Service Test Management and Quality Center 
projects to version 10.50.

Section 9 Manual Client Installations

Describes how to manually install Quality Center and Service Test 
Management clients for environments where automatic downloading and 
registering are prohibited.
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Who Should Read This Guide

This guide is intended for users who need to install and set up HP Service 
Test Management.

Readers of this guide should have some knowledge of system 
administration.

HP Service Test Management Online Documentation

Service Test includes the following online documentation:

Readme provides last-minute news and information about Service Test 
Management. You access the Readme from Installation folder.

Books Online/Printer-Friendly Documentation includes PDF versions of the 
documents. Click the Help button and choose Books Online.

Online Help is available from specific Service Test Management windows by 
clicking in the window and pressing F1 or clicking the Help button.

Additional Online Resources

Troubleshooting & Knowledge Base accesses the Troubleshooting page on 
the HP Software Support Web site where you can search the Self-solve 
knowledge base. Choose Help > Troubleshooting & Knowledge Base. The 
URL for this Web site is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software Support accesses the HP Software Support Web site. This site 
enables you to browse the Self-solve knowledge base. You can also post to 
and search user discussion forums, submit support requests, download 
patches and updated documentation, and more. Choose Help > HP Software 
Support. The URL for this Web site is www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an HP Passport user 
and sign in. Many also require a support contract.

http://h20230.www2.hp.com/troubleshooting.jsp
http://www.hp.com/go/hpsoftwaresupport
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To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

HP Software Web site accesses the HP Software Web site. This site provides 
you with the most up-to-date information on HP Software products. This 
includes new software releases, seminars and trade shows, customer support, 
and more. Choose Help > HP Software Web site. The URL for this Web site 
is www.hp.com/go/software.

http://h20230.www2.hp.com/new_access_levels.jsp
http://h20229.www2.hp.com/passport-registration.html
http://www.hp.com/go/software
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Setting Up Service Test Management

This chapter describes the installation requirements and setup procedures 
for using Service Test Management in Quality Center.

This chapter includes:

 ➤  Requirements for Service Test Management on page 10

 ➤  The Installation Process on page 10

 ➤  Installing Service Test Management on page 12

 ➤  Loading the Service Test Management License on page 20

 ➤  Enabling the Service Test Management Extension on page 21

 ➤  Installing the Service Test Add-in for Quality Center on page 22

 ➤  Uninstalling Service Test Management on page 24

 ➤  Upgrading Service Test Management on page 32

 ➤  Manual Client Installations on page 35
9
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Requirements for Service Test Management

To use Service Test Management 10.50, you must have the following 
installed:

➤ Quality Center 10.00 with Patch 9 on your server machine. Patch 12 or 
higher is recommended.

➤ Recommended: Service Test version 9.53, or version 9.10 with Feature Pack 
9.17, or the Service Test 9.53 Add-in for Quality Center (on your client 
machine).

The minimum system requirements to run Service Test Management are the 
same as for Quality Center, as described in the HP Quality Center Installation 
Guide.

The Installation Process

This section describes the Service Test Management installation process.

To install Service Test Management:

 1 Ensure that Quality Center 10.00 with Patch 9 or higher is installed on your 
server machine.

For more information on installing Quality Center, refer to the 
HP Quality Center Installation Guide.

 2 Install Service Test Management 10.50 on your server machine.

Run the setup for Service Test Management, as described in “Installing 
Service Test Management” on page 12.

 3 Load the Service Test Management license.

For more information, see “Loading the Service Test Management License” 
on page 20.

 4 Enable the Service Test Management extension in Quality Center Site 
Administration for every project that requires Service Test Management.

For more information, see “Enabling the Service Test Management 
Extension” on page 21.
10
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 5 Install Service Test or the Service Test Add-in for Quality Center.

To use all the features in Service Test Management, you must install HP 
Service Test 9.53 or version 9.10 with the 9.17 Feature Pack. Alternatively, 
you can install the Service Test Add-in for Quality Center (add-in version 
9.53) on each client machine from which you want to use the extension. 
Earlier versions of Service Test or the Service Test Add-in for Quality Center 
are not compatible with Service Test Management 10.50.

For more information on installing Service Test, refer to the HP Service Test 
Installation Guide. For more information on installing the Service Test Add-
in, see “Installing the Service Test Add-in for Quality Center” on page 22.
11



Chapter 3 • Setting Up Service Test Management
Installing Service Test Management

The setup program provides a wizard that guides you through the 
installation.

To install Service Test Management:

 1 Insert the Service Test Management installation DVD into the DVD drive 
and run the appropriate file.

 2 If you have installed a previous version of Service Test Management, a 
warning message opens. Click Yes to overwrite the existing files.

 3 The Welcome dialog box opens. Click Next.

 4 The License Agreement dialog box opens.

Read the license agreement. To accept the terms of the license agreement, 
select I accept the terms of the license agreement.

Click Next.

Platform To install:

Windows Run the setup.exe file.

Solaris or Linux
(console mode)

➤ To install on a Solaris platform, type:
./setupSolaris.bin -console 

➤ To install on a Linux platform, type:
./setupLinux.bin -console

Solaris, Linux, or AIX
(UI mode)

Make sure that the DISPLAY environment variable is 
properly configured on the Quality Center host machine, 
and that the machine from which you are installing is 
running an X-server (for example, Exceed). 

➤ To install on a Solaris platform, type:
./setupSolaris.bin

➤ To install on a Linux platform, type:
./setupLinux.bin

➤ To install on an AIX, type:
./setupAix.bin
12
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 5 The Directory Name dialog box opens.

Accept the proposed folder for the Service Test Management installation or 
browse for an alternate folder.

Click Next.

 6 The HP Quality Center Repository Path dialog box opens.

Browse for the location of the Quality Center repository. The installation 
screen displays the default path.

Click Next.
13
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 7 The Installation Summary dialog box opens.

To review or change any settings, click Back.

To accept the settings and start the installation, click Next. The installation 
process starts.
14
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 8 When the installation process completes, the Update the Server dialog box 
opens.

When you update the Quality Center server, the Service Test Management 
files are copied into the opened archive directories (for example 
20qcbin.war and 30stm.war) in the 
<Quality Center Installation>\application directory, and the Quality Center 
Archive and Deployment Tool is launched. This tool enables you to update 
the running Quality Center Web server.

Select an update option:

➤ Update now. To update the Quality Center archive files and launch the 
deployment tool now (for JBoss only).

➤ Update later. To manually update the Quality Center server at a later 
time. You must update the Quality Center server before you can use 
HP Service Test Management.

Click Next. 
15
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 9 If you selected Update now, proceed to step 10.

If you selected Update later, click Next and then click Finish to close the 
installation setup dialog box. When you are ready to update the application 
server, run the deploy.bat script (or deploy.sh for Solaris or Linux) from the 
<Service Test Management installation> directory. When running the batch 
file, specify the Quality Center installation directory and the location of the 
Quality Center repository, using the format:

deploy <Quality Center installation directory> <Quality Center repository 
directory>

For example:

deploy "C:\Program Files\HP\Quality Center" "C:\Program Files\Mercury\Quality 
Center\repository"

 10 After clicking Update now or manually launching the batch file, the 
Quality Center Archive and Deployment Tool opens.

For Service Test Management to work with Quality Center, you need to 
create a new archive and redeploy the qcbin.war and stm.war files on the 
application server. This enables changes to the archive files to take effect.
16
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Click Next to create the new archive files.

 11 If your application server is JBoss, proceed to step 12.

If your application server is other than JBoss, the installation screen informs 
you that you must redeploy HP Quality Center manually on the application 
server after the setup, before changes can take effect. The screen also shows 
the location of the archive files. 

The updated archive files are stored in different formats, although the 
content is the same. The files are stored in the 30stm.war and 20qcbin.war 
folders (These names may differ per platform. Refer to the Readme file 
limitations for details). 

Note: For more information on manually deploying Quality Center on an 
application server, refer to the HP Quality Center Installation Guide.

Click Next and proceed to step 14.

 12 If your application server is JBoss, the HP Quality Center Redeployment 
dialog box opens. 
17
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If your application server is other than JBoss, proceed to step 14. To deploy 
the artifacts on non-JBoss servers, rename the files and remove the number 
prefix.
 

Choose one of the following options:

➤ Yes. To deploy the archive files automatically.

➤ No. To manually deploy the archive files later.

Click Next.
18



Chapter 3 • Setting Up Service Test Management
 13 If the Quality Center service is running, the Archive and Deployment Tool 
automatically attempts to stop the service. If the tool is unable to stop the 
service, the Service Not Stopped dialog box opens.

Choose one of the following options:

➤ Retry. To try again to stop the JBoss service.

➤ Skip JBoss deployment. To cancel the deployment and manually deploy 
JBoss later.

Click Next.

 14 When the deployment is complete, the Completion dialog box opens. Click 
Finish to close the Quality Center Archive and Deployment Tool.

Note: If you manually deployed the archive files on your application server, 
you must restart Quality Center after deployment. 

 15 Click Finish to close the HP Service Test Management Setup dialog box.
19
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Loading the Service Test Management License

After installing Service Test Management on your Quality Center server, you 
must load your Service Test Management license in Site Administration to 
enable the Application Components module in Quality Center.

To load the Service Test Management license:

 1 In Site Administration, click the Licenses tab.

 2 Click the Modify button. The License Edit dialog box opens.
20
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 3 Click the Load License button and select the Service Test Management 
license file. Alternatively, copy the license file and click Paste License.

 4 Click OK. The SOA license is displayed in the list of HP Quality Center 
licenses.

Enabling the Service Test Management Extension

After loading the Service Test Management license, you must enable the 
Service Test Management extension for a project before you can use it with 
the project. 

Important: You cannot disable an extension for a project after you enable it.

To enable the Service Test Management extension for a project:

 1 In Site Administration, click the Site Projects tab.

 2 In the Projects list, select a project. In the right pane, click the Project 
Extensions tab. This tab is available only if you have a license for at least one 
extension and the extension is installed on the Quality Center server. The 
Extensions list is displayed, listing extensions installed on the 
Quality Center server.
 

 3 Select Application Components in the Extension Name column. Select the 
check box in the Enabled column.

 4 To refresh the Extensions list, click the Refresh button.

 5 Verify that the Version Enabled for Project is 10.5.
21
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Installing the Service Test Add-in for Quality Center

The Service Test Add-in for Quality Center provides extended functionality 
to Service Test Management, enabling you to do the following in the 
Application Components module:

➤ Import service WSDL files from a file system, URL, UDDI or Systinet server.

➤ Import service WSDL files that reside in secure locations or that are accessed 
through proxy servers.

➤ Generate requirements and tests using the Requirement and Test Generation 
wizard.

➤ Perform manual and automatic test runs, or spot testing.

Note: The functionality provided by the Service Test add-in is included in 
Service Test. If you have already installed Service Test on your 
Quality Center client machine, or you intend to install it before using 
Service Test Management, you do not need to install this add-in. For more 
information on installing Service Test, refer to the HP Service Test User’s 
Guide.

If you do not install the add-in, you can still use the Application 
Components module in Viewer mode. This mode is suitable for business 
services users, such as QA managers and SOA architects who want to view 
data on the quality process, create component coverage, link application 
components to requirements and tests, and produce reports or graphs.

You can install the Service Test Add-in for Quality Center from the following 
locations:

➤ Service Test Management installation DVD. To install the add-in, run the 
ServiceTestPlugin.exe file. 

➤ Quality Center Add-ins page. For more information, see “Installing the Add-
in from the Quality Center Add-ins Page” on page 23.
22
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Installing the Add-in from the Quality Center Add-ins 
Page
You can install the Service Test Add-in from the Quality Center Add-ins 
page.

Note: To install this add-in, you must log in with administrator privileges.

To install the add-in from the Quality Center Add-ins page:

 1 Open your Web browser and type your Quality Center URL: 

http://<Quality Center server name>[<:port number>]/qcbin. 

The HP Quality Center Options window opens.

 2 Click the Add-ins page link. The Quality Center Add-ins page opens.

 3 Click the More HP Quality Center Add-ins link. The More HP Quality Center 
Add-ins page opens.

 4 In the Quality Center Administrator Add-ins section, under HP Tool Add-ins, 
click the HP Service Test Add-in for Quality Center link. The HP Service Test 
Add-in for Quality Center page opens.

 5 Click the Download HP Service Test Add-in for Quality Center link to 
download the add-in. 

 6 Follow the on-screen installation instructions.
23
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Uninstalling Service Test Management

This section describes how to uninstall Service Test Management from your 
Windows, Solaris, or Linux server machine. When you uninstall Service Test 
Management, the Service Test Management files are deleted from 
Quality Center.

To uninstall Service Test Management from Windows:

 1 Make sure that the application server is running.

 2 To open the HP Service Test Management Uninstall dialog box, you can:

➤ Choose Control Panel > Add/Remove Programs, select HP Service Test 
Management, and click the Change/Remove button. Follow the 
instructions on your screen.

➤ Locate the Service Test Management home directory. By default, the files 
are stored in [drive]:\Program Files\HP\STM. In the _uninst subdirectory, 
double-click uninstall.exe.

The HP Service Test Management Uninstall dialog box opens.
24



Chapter 3 • Setting Up Service Test Management
 3 Click Next. The Update the Server dialog box opens.

Select an update option:

➤ Yes. To update the archive files and launch the deployment tool now.

➤ No. To uninstall later.

Click Next.
25
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 4 The Quality Center Archive and Deployment Tool opens.

To uninstall Service Test Management, you need to create a new archive and 
redeploy the Quality Center and Site Administration war files on the 
application server. This enables changes to the.war files to take effect.

Click Next to create the new archive files.

 5 If your application server is JBoss, proceed to step 6.

If your application server is other than JBoss, the installation screen informs 
you that you must redeploy Quality Center manually on the application 
server after the setup process completes. The location of the archive files is 
shown in the dialog box. 

The updated archive files are stored in different formats, although the 
content is the same. The files are stored in the 30stm.war and 20qcbin.war 
folders (these names may vary according to the platform).
26
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To update the archives and undeploy them manually, run the undeploy.bat 
script (or undeploy.sh for Solaris or Linux) from the <Service Test 
Management installation> directory. When running the batch file, specify 
the Quality Center installation directory and the location of the 
Quality Center repository, using the format:

undeploy <Quality Center installation directory> <Quality Center repository 
directory>

For example:

undeploy "C:\Program Files\HP\Quality Center" "C:\Program 
Files\Mercury\Quality Center\repository"

Note: For more information on manually deploying Quality Center on an 
application server, refer to the HP Quality Center Installation Guide.

Click Next and proceed to step 8.
27
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 6 If your application server is other than JBoss, proceed to step 8.

If your application server is JBoss, the HP Quality Center Redeployment 
dialog box opens.

Choose one of the following options:

➤ Yes. To deploy the archive files automatically.

➤ No. To manually deploy the archive files later. 

Click Next to continue.
28
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 7 If the Quality Center service is running, the Archive and Deployment Tool 
automatically attempts to stop the service. If the tool is unable to stop the 
service, the Service Not Stopped dialog box opens.

Choose one of the following options:

➤ Retry. To try again to stop the JBoss service.

➤ Skip JBoss deployment. To cancel the deployment and manually deploy 
JBoss later.

Click Next.
29
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 8 When the deployment is complete, the Completion dialog box opens. Click 
Finish to close the Quality Center Archive and Deployment Tool Setup. The 
HP Service Test Management Uninstall dialog box is displayed.

 9 Click Next. The Update completed dialog box opens.
30
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 10 Click Next to continue. 

It is recommended that you click Yes to delete the remaining uninstall files 
in the Service Test Management directory.

Click Next.

 11 Click Finish to close the HP Service Test Management Uninstall dialog box.

To uninstall Service Test Management from Linux or Solaris:

 1 Make sure that the application server is running.

 2 Type the following command at the system prompt:

/[directory]/[Service_Test_Management_directory]/_uninst/uninstall.bin

The Service Test Management Uninstall wizard opens.

 3 Click Next. Follow the on-screen instructions.

 4 Run the Quality Center Archive and Deployment Tool to create a new 
archive and redeploy the Quality Center and Site Administration .war files 
on the application server.

 5 When Service Test Management prompts you to delete all add-in files, select 
Yes.
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Upgrading Service Test Management

The following sections section describes how to upgrade Service Test 
Management and existing projects to version 10.50.

Cascaded Upgrades
When performing a cascaded upgrade from Service Test Management 9.2 to 
9.4x, and then to version 10.x, you must manually remove the certificates. 
First, perform an upgrade from 9.2 to 9.41 and then manually remove the 
sv_ssl_certificate and sv_use_ntlm certificates. Proceed with the upgrade 
from 9.41 to 10.01 as described below.

Upgrading Service Test Management 9.4x to Version 10.x
This section describes how to upgrade the version of the Service Test 
Management Extension to Quality Center. 

To perform an upgrade:

 1 Uninstall Service Test Management 9.4x as described in “Uninstalling 
Service Test Management” on page 24.

 2 Uninstall Quality Center version 9.2 and install version 10.00 and patch 9 
or higher (Patch 12 is recommended).

 3 Install Service Test Management version 10.50 as described in “Installing 
Service Test Management” on page 12.

 4 Launch Site Administrator from the Quality Center homepage. Provide 
credentials and log in.

 5 In the left pane’s Projects list, select a project to upgrade. 

 6 From the right-click menu, choose Maintain Project > Upgrade Project. 
Follow the on-screen upgrade instructions to complete the upgrade.

 7 Select the Project Extensions tab. Verify that values in the Version Installed 
on Site and Version Enabled for the Project table cells are 10.5.
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Moving a Project to a Another Machine
This section describes how to move a project from one machine to another 
and perform an upgrade on the project. This is useful if you already have a 
machine with Quality Center 10.00. 

To move and upgrade a project:

 1 Check that you have Quality Center 10.00 with Patch 9 or higher, and 
Service Test Management 10.50 on the new machine. Verify that the 
database software version is supported by Quality Center 10.00, for example 
MSSQLServer 2005. For more information about supported databases, see 
the Quality Center Administrator Guide.

 2 On the machine with the earlier version, launch Site Administration from 
the Quality Center homepage. Provide credentials and log in.

 3 In the left pane’s Project list, select a project and choose Remove Project. 
This will not delete the project repository or database—it only removes the 
reference to the project from the site.

 4 Copy the source project from the machine with earlier version, to the target 
machine with version 10.00, into the Quality Center repository folder. 

Note: If the local path of the repository on the 10.00 machine differs from 
that of the machine with the earlier version, you need to edit the dbid.xml 
file in the repository on the 10.00 machine. Open the file and update the 
PHYSICAL_DIRECTORY element to the correct path.

 5 On the 10.00 machine, launch Site Administration from the Quality Center 
homepage. Provide credentials and log in.

 6 Select the DB Servers tab and verify that there is a database with the same 
name as the original machine with the earlier version.

 7 Locate the dbid.xml file in the project repository. Verify that the database 
details are correct.

 8 Click a target domain on the 10.00 machine and select Restore Project from 
the right-click menu. This references the copied project with the same 
project database. 
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 9 From the right-click menu, choose Maintain Project > Upgrade Project. 
Follow the on-screen upgrade instructions to complete the upgrade.

 10 Select the Project Extensions tab. Verify that values in the Version Installed 
on Site and Version Enabled for the Project table cells are 10.5.
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Manual Client Installations

In most deployments of Quality Center and Service Test Management, your 
browser downloads client files the first time you access the Quality Center 
server machine. There is no need to install a client on your machine.

In environments where automatic downloads and registrations are 
prohibited, you can manually install the client files on all of the required 
machines.

The client installation files are stored on the Quality Center server machine 
in the C:\Program Files\HP\Quality 
Center\application\20qcbin.war\PlugIns\ClientSideInstallation folder.

Ask your administrator to copy or create a batch file that copies the 
installation files to the desired machines. Run the installation files before 
you access Quality Center.

To install the client files: 

 1 Copy the installation files onto the client machine.

 2 Run the Quality Center client installation file, QCClient.msi. By default, the 
setup installs the client files to the C:\Program Files\HP\Quality Center 
Client Side folder. 

 3 Install the Service Test Management client installation file, STMClient.msi, 
to the same folder as the Quality Center client, by default C:\Program 
Files\HP\Quality Center Client Side. If you installed the Quality Center 
client to a different location, make sure to use the same folder for the Service 
Test Management client.
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