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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2003 - 2009 Hewlett-Packard Development Company, L.P. 

Trademark Notices

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.

UNIX® is a registered trademark of The Open Group. 
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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign in. To register for an HP Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
3



Support

Visit the HP Software Support Online web site at:

www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and support that HP 
Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and efficient way to 
access interactive technical support tools needed to manage your business. As a valued support customer, you 
can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp  
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1 Introducing the Smart Plug-in for Microsoft 
Exchange for UNIX
Smart Plug-in (SPI) is plug-in or add-in software for HP Operations Manager (HPOM). It 
functions as a modular component of HPOM and further improves its monitoring capabilities 
in managing your IT resources. SPIs help you to simplify the tasks of your environment by: 

• Monitoring availability and health

• Detecting performance lapse

• Detecting, preventing, and solving problems

• Documenting problem solutions

• Generating reports

Figure 1 HPOM Client-Server Architecture
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About Smart Plug-in for Microsoft Exchange

The Smart Plug-in for Microsoft Exchange Server (Microsoft Exchange SPI) helps you to 
manage the Microsoft Exchange Server 2007 in your environment. The Microsoft Exchange 
SPI keeps you informed about the conditions related to the Microsoft Exchange 2007 and 
updates you with the following: 

• Availability of Microsoft Exchange Server and its roles.

• Monitoring events that occur on Microsoft Exchange Servers.

• Monitoring functions of different Microsoft Exchange Servers.

• Monitoring and reporting important metrics like Mail Flow Latency, Transport Agent 
Queue Lengths, Information Store DB Cache Size, and SPAM Statistics among others

• Providing ExBPA Integration

The Microsoft Exchange SPI enables you to oversee your distributed Microsoft Exchange 
environment from a central, easy-to-use console. You can apply the performance and problem 
management processes that you use for networks and systems to monitor Microsoft Exchange 
Server 2007. The Microsoft Exchange SPI:

• Increases Microsoft Exchange availability and performance.

• Reduces support costs associated with the Microsoft Exchange services.

• Improves capacity management and planning for Microsoft Exchange.

Components of Microsoft Exchange SPI

The components of the Microsoft Exchange SPI are policies, tools, reports, and graphs. Each of 
these components contributes to enhance the monitoring capability of the Microsoft Exchange 
SPI.

Policies 

Policies are pre-defined thresholds to keep a constant vigilance over the Microsoft Exchange 
Server 2007 environment and improve monitoring schedules in the form of service map alerts 
and messages. Service map alerts are shown in service map while messages are available in 
message browser. The Microsoft Exchange SPI provides a range of polices. For more 
information on policies, see Chapter 4, Using Policies.

Tools

Tools are the utilities to gather more Microsoft Exchange Server 2007 related information. 
The Microsoft Exchange SPI tools enable you to perform certain tasks on managed nodes to 
simplify monitoring the Microsoft Exchange Server 2007. You can also use tools to configure 
the Microsoft Exchange SPI. For more information on tools, see Chapter 5, Using Tools.
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Reports

Reports represent a summarized data generated by policies. Data collected by policies are 
used to generate reports. For more information on reports see Chapter 6, Integrating 
Microsoft Exchange SPI with HP Reporting and Graphing Solutions.

Graphs

Graphs are the pictorial representation of various metrics of the Microsoft Exchange Server 
2007. Graphs contain the data that are collected by policies. For more information on graphs, 
see Chapter 6, Integrating Microsoft Exchange SPI with HP Reporting and Graphing 
Solutions.

See HP Operations Microsoft Exchange SPI Reference Guide for a complete list of policies, 
tools, reports, and graphs.

Functions of Microsoft Exchange SPI

After you configure the Microsoft Exchange SPI, you can view critical information about your 
Microsoft Exchange Server 2007 environment through the HPOM console in the form of:

• Service map

• Message alerts

• Reports and graphs

• Topology viewer tool

Service Map

The map view of HPOM presents a graphical and structural view of the Microsoft Exchange 
Server 2007 in your environment. The Microsoft Exchange SPI discovers the Microsoft 
Exchange Server 2007 nodes and Microsoft Exchange Server 2007 services and displays them 
in the map view. The map view displays the real-time status of your Microsoft Exchange 
Server 2007 environment. The map view indicates severity levels problems in the Microsoft 
Exchange organization through colors (red, yellow, blue, and green).

Service map shows the newly added Microsoft Exchange nodes and the discovered Microsoft 
Exchange Server 2007 services. To view the services, log into the operational GUI (for 
operator):

1 Click Services. The service map appears. (See Figure 2).

Microsoft Exchange SPI reports come in a separate package, EXSPI-Reporter.msi which is 
found in the HP Operations Manager for UNIX Application DVD-ROM. Use HP Reporter to 
generate and view Microsoft Exchange SPI reports.
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Figure 2 Services in the Operator’s GUI

2 Expand the hierarchy to view the specific servers of the Microsoft Exchange 2007. Further 
expansion of each server displays its components. See Figure 3.
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Figure 3 Service Map

Message Browser

The Microsoft Exchange SPI monitors events and services on the managed nodes (servers on 
which the Microsoft Exchange Server 2007 is installed and the HP Operations agent is 
deployed) and generates messages, which are displayed on the message browser of HPOM 
console. Figure 4 displays the Message Alerts in the message browser.
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Figure 4 Message Alerts

Reports and Graphs

You can integrate the Microsoft Exchange SPI with HP Reporter and HP Performance 
Manager (HP PM) to generate reports and graphs based on collected metric data. HP 
Reporter captures and formats data collected at nodes and generates web-based reports. HP 
PM generates graphs from near real-time data gathered from the managed nodes. You can 
access these graphs from the HPOM console if you install HP PM on HPOM management 
server.

HP Operations Topology Viewer Tool

The Microsoft Exchange SPI enables you to view a Microsoft Exchange organization 
graphically with the help of three-dimensional maps of routing groups and server connections. 
From the topology view you can quickly view routing groups, Exchange servers, and the roles 
they play within your Microsoft Exchange organization. Figure 4 displays the Topology view. 
For more information on the HP Operations Topology Viewer tool, see HP Operations 
Topology Viewer on page 93.
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EXSPI Configuration Utility Tool

The EXSPI Configuration Utility tool enables you to edit the collection configuration data for 
Microsoft Exchange SPI. You can also create new collections and metrics and can modify 
them, if required. For more information on the EXSPI Configuration Utility tool, see 
Additional Configuration Procedure on page 54. 

Monitoring Microsoft Exchange Server 2007 in SAN Environment

The Microsoft Exchange SPI can monitor the Microsoft Exchange Server 2007 configured to 
use SAN. 

SAN ensures storage consolidation, movement towards centralized management of messaging 
systems, and realtime mirroring of data. The Microsoft Exchange SPI monitors the Microsoft 
Exchange database (Information Store) configured on external SAN storage. 

To start the HP Topology Viewer and EXSPI Configuration Utility tools, you must install 
them on a Windows node (For HP Operations Topology Viewer, install on a 32-bits Windows 
system). These tools are not listed in the Tool Bank.
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2 Installing and Upgrading Microsoft Exchange 
SPI
Perform the tasks mentioned in the following sections to install the Microsoft Exchange 
Server SPI on UNIX. 

The following flowchart shows an overview of installing and configuring the Microsoft 
Exchange SPI. See Table 1 for the references of the legends.

If you are upgrading the Microsoft Exchange SPI from the previous version to 13.00, perform 
the steps in Upgrading Microsoft Exchange SPI on a Standalone HPOM for UNIX 9.0x, and 
then install the Microsoft Exchange SPI.
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Figure 5 Flowchart on Installation and Configuration Steps

Table 1 References of the Legends in Flowchart

Legend References

A Pre-requisites to Install Microsoft Exchange 
SPI on page 21

B Mounting the SPI DVD on page 22

C Installing Microsoft Exchange SPI on page 23

D Verifying the Installation of Microsoft 
Exchange SPI on page 24

E Manage Exchange Server Nodes on page 29
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The following flowchart shows an overview of upgrading the Microsoft Exchange SPI. See 
Table 2 for references of the legends.

F Assign Microsoft Exchange Nodes to Node 
Group on page 29

G Assign Instrumentation Categories to 
Exchange Nodes on page 31

H Deploy Configuration on page 33

I Assign Tool Group to Operator on page 34

J Assign Exchange Node Group and Message 
Groups to the Operator on page 36

K Run Tools - Create DataSources, Register 
DataCollection, and Start PowerShell 
Collector on page 38

L Customize Policies on page 45

M Assign Microsoft Exchange SPI Policies to 
Exchange Nodes on page 43

N Deploy Microsoft Exchange SPI Policies to 
Exchange Nodes on page 47

O View Service Map through Operator GUI on 
page 53

P Troubleshooting Discovery on page 107

Q Assign Microsoft Exchange SPI Services to 
Operator on page 53

R Using the EXSPI Configuration Utility Tool 
on page 56

Legend References
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Figure 6 An Overview of Upgrade Steps

Table 2 References of Legends of Flowchart 

Legend References

A Rename the Microsoft Exchange SPI policy 
group SPI for MS Exchange and tool group 
EXSPI ADMIN as SPI for Exchange_OLD. on 
page 26

B Installing Microsoft Exchange SPI on page 23

C Verifying the Installation of Microsoft 
Exchange SPI on page 24

D Configuring Microsoft Exchange SPI on 
page 29
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Installation Packages

The Microsoft Exchange SPI installation packages include SPI, reporting, graphing, and 
console packages.

SPI Package

The SPI package is the core.depot (HP-UX) and.sparc (Solaris) package, which contains all the 
functionality of the SPI. It must be installed on a HPOM server. You can find the Microsoft 
Exchange SPI in the following location:

For HP-UX: <SPI DVD>\HPUX\HP_Operations_Smart_Plug-ins_HPUX.depot

For Solaris: <SPI DVD>\SOLARIS\HP_Operations_Smart_Plug-ins_SOLARIS.sparc

Reporting Package

The Reporter package contains the reports provided by the SPI. The HP Reporter gathers the 
data from the nodes managed by the SPI through the HPOM, stores the data in its local 
database, and creates .html reports based on the default SPI report policies. You can find the 
reporting package in the following location: 

<SPI DVD>\SPIs\Exchange SPI Reporter Package\EXSPI-Reporter.msi

Graphing Package

The Graphing package contains the graphs provided by the SPI. Graphs are drawn from 
metrics that are collected in the datasources created by the SPI. You can find the graphing 
package in the following location:

<SPI DVD>\SPIs\EX SPI OVPM ConfigurationPackage\HPOvSpiExGc.msi

Installation Environments

You can install the Microsoft Exchange SPI in the following environments:

• Standard installation of SPI components on an HPOM 9.0x Server.

• Standalone HP Reporter and HP Performance Manager.

Pre-requisites to Install Microsoft Exchange SPI

Fulfill the hardware and software requirements before installing the SPI. Also, ensure that 
you install the HP Operations Manager (HPOM) management server before installing the 
Microsoft Exchange SPI. It is not necessary to stop HPOM sessions before beginning the 
Microsoft Exchange SPI installation.
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Hardware Requirements

Ensure that there is atleast 200 MB Free Hard-Disk space. See the HP Operations Manager 
for UNIX Installation Guide for information on hardware requirements.

Software Requirements

Ensure the following software requirements are fulfilled:

On the management server:

• HP Operations Manager for UNIX: 9.0x

• HP Reporter 3.80 for EXSPI-Reporter

• HP Performance Manager 8.20 for EXSPI-Graphs

• HP Operations SPI Data Collector (DSI2DDF): 2.40

• HP SPI Self-Healing Services. (SPI-SHS-OVO, automatically installed while installing 
the SPI using SPIDVD): 3.00

• Software Upgrade Tool Kit 2.0 

You can install these products from the HPOM Smart Plug-ins DVD.

• A 32-bit Windows system for OVTV and a Windows system with .Net Framework 3.x and 
above for EXSPI Configuration Utility tool.

• Service Navigator to view the Microsoft Exchange Server 2007 Service Map.

On the managed node, HP Performance Agent: 5.00 (required if you want to use HP 
Performance Agent for data logging):

Mounting the SPI DVD

The HP Operations Smart Plug-ins DVD contains the Microsoft Exchange SPI. 

Mounting the DVD on HP-UX

To mount the SPI DVD on HP-UX:

1 Log on as user root.

2 Set the user root’s umask by entering:

umask 027

3 Create a directory to mount the DVD:

mkdir /<mount_point>

For example: mkdir /dvdrom

4 Insert the DVD into the disk drive and mount it as user root by entering:

mount /dev/<dvdrom_drive_name> /<mount_point>

For example, for a local DVD, you might enter:
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mount /dev/dsk/c0t2d0 /dvdrom

You can also run SAM and mount the DVD to a specific path in the Disks and File Systems 
window.

Mounting the DVD on Solaris

Insert the DVD into the DVD drive. The DVD is automatically mounted (and unmounted) on 
Sun Solaris systems.

Installing Microsoft Exchange SPI

You can install the Microsoft Exchange SPI on a standalone HPOM for UNIX 9.0x server or on 
a HPOM for UNIX 9.0x cluster servers or both.

Installing Microsoft Exchange SPI on a Standalone HPOM for UNIX 9.0x Server 

To install the Microsoft Exchange SPI on the HPOM management server from the command 
line interface, perform the following steps:

1 Insert the SPI DVD into the DVD-ROM drive of the management server.

2 Run the following commands:

a For an HP-UX 11.x management server:

swinstall -s /cdrom/HPUX/HP_Operations_Smart_Plug-ins_HPUX.depot 
EXSPI

b For a Solaris management server:

pkgadd -s /cdrom/SOLARIS/
HP_Operations_Smart_Plug-ins_SOLARIS.sparc ADSPI

The installer installs Microsoft Exchange SPI on the management server.

Installing Microsoft Exchange SPI on a HPOM for UNIX 9.0x Cluster Servers

Before installing the Microsoft Exchange SPI in a cluster environment, ensure that HPOM for 
Unix 9.0x is installed on each system of the cluster. 

To install the Microsoft Exchange SPI on cluster servers, perform the following tasks:

Task 1: At the first cluster-aware management server, select and install Smart Plug-ins.

Complete the steps described in Installing Microsoft Exchange SPI on a Standalone HPOM 
for UNIX 9.0x Server on page 23 before proceeding to the next management server.

The HPOM console does not function properly until you install the Microsoft Exchange SPI 
on all the nodes in the HPOM cluster.

Before starting, ensure that sufficient disk space is available on each management server for 
the Microsoft Exchange SPI. Cancelling the installation process before the completion leads 
to partial installations and require manual removal of the partially installed components.
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Task 2: At the next cluster-aware management server, install pre-selected Smart Plug-ins.

Repeat the steps described in Installing Microsoft Exchange SPI on a Standalone HPOM for 
UNIX 9.0x Server on page 23 on each management server in the cluster and continue to every 
management server until you have finished.

Verifying the Installation of Microsoft Exchange SPI

To verify the Microsoft Exchange SPI has been installed properly, perform one of the following 
steps:

1 Check the Policy Bank which contains SPI for Exchange policy group. For this, click Policy 
Bank → SPI for Exchange. The SPI for Exchange policy group is displayed. See Figure 3.

Figure 7 Verifying SPI for Exchange

2 From the command prompt of HPOM 9.0x server, browse to <OVO_DATADIR>/share/
databases/OpC/mgd_node/instrumentation location. You can see the 
Instrumentation groups Exchange2k7__Core, Exchange2k7_Discovery and 
Exchange2k7_Collector. All EXSPI instrumentation files are in these directories.

The HPOM console will not function properly until you complete all the installations on all 
the nodes in the cluster.

To get the value of <OVO_DATADIR>, run the command opcagt -type -verbose on HPOM 
on UNIX 9.0x Server.
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Migrating Microsoft Exchange SPI 12.0 from HPOM for UNIX 8.0 
to HPOM for UNIX 9.0x

The instrumentation files and other SPI specific data are migrated while migrating or 
upgrading HPOM for UNIX 8.x server (where Microsoft Exchange SPI 12.00 is installed) to 
HPOM for UNIX 9.0x. Some SPI specific data, however, must be migrated manually. 

You can migrate HPOM from one system to another.

Migrating HPOM from one System to another

Install HPOM for UNIX 9.0x on a new system. To perform the migration from one system to 
another, follow these steps:

1 After completing migrating HPOM for UNIX 8.x to HPOM for UNIX 9.0x, create the 
following directories on the target HPOM for UNIX 9.0x server for Microsoft Exchange 
SPI:

• /opt/OV/EXSPI

• /opt/OV/www/htdocs/ito_op/images

2 Copy the files present in /opt/OV/EXSPI and files with signature exspi* from /opt/OV/
www/htdocs/ito_op/images on HPOM for UNIX 8.x system into the respective folders 
that you have created in HPOM for UNIX 9.0x server.

Limitations and Workarounds

These are the following limitations and workarounds for Microsoft Exchange SPI 12.00 
support on HPOM for UNIX 9.0x:

• Microsoft Exchange SPI 12.00 is not supported on HPOM for UNIX 9.0x, when HPOM for 
UNIX 8.x on Solaris is migrated to HPOM for UNIX 9.0x on HP-UX IA.

• SPI discovery does not work since Service Discovery Framework (SDF) is not supported 
on HPOM for UNIX 9.0x.

• After you complete the migration, to invoke the GUIs related to SPI, you must install 
X-Windows client software on the machine from which you will launch the HPOM for 
UNIX 9.0x server operator GUI.

• If you are planning to install any patches that are available, you should install the latest 
patch available for Microsoft Exchange SPI 12.00 on the HPOM for UNIX 8.x server 
before starting the migration. Installing patches for Microsoft Exchange SPI 12.00 on 
HPOM for UNIX 9.0x is not supported after migration.

• Installing patches that would be released in the future for Microsoft Exchange SPI 12.00 
is not supported on HPOM for UNIX 9.0x after migration. However, patch can be installed 
on the HPOM for UNIX 8.x server and migrated to HPOM for UNIX 9.0x environment.

• Graphs cannot be launched through an “automatic action” or “Operator initiated action” 
of alerts on a HPOM for UNIX 9.0x machine after the migration.
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Upgrading Microsoft Exchange SPI on a Standalone HPOM for 
UNIX 9.0x

You can upgrade the Microsoft Exchange SPI on a standalone HPOM for UNIX 9.0x server or 
on a HPOM for UNIX 9.0x cluster servers or both.

Upgrading Microsoft Exchange SPI on a Standalone HPOM for UNIX 9.0x Server

To upgrade the Microsoft Exchange SPI on a standalone HPOM for UNIX 9.0x Server:

1 Rename the Microsoft Exchange SPI policy group SPI for MS Exchange and tool group 
EXSPI ADMIN as SPI for Exchange_OLD. 

2 Install the Microsoft Exchange SPI 13.00. See Installing Microsoft Exchange SPI.

3 Run the tools - Stop Collection Manager and Stop PowerShell Collector Server from the 
tool group SPI for Exchange_OLD on all the managed Microsoft Exchange servers. This 
stops collection manager and collector server on the nodes.

4 Deploy the instrumentation group Exchange2k7_Core to all the managed Microsoft 
Exchange server nodes. To deploy the instrumentation category see Assign 
Instrumentation Categories to Exchange Nodes on page 31 and Deploy Configuration on 
page 33.

5 Launch the tool Delete Older EXSPI artifacts from the tool group SPI for Exchange on all the 
managed Microsoft Exchange server nodes to remove the previous version of the Microsoft 
Exchange SPI policies and instrumentation categories deployed on the nodes.

6 Gather data from all the managed node and perform the following steps on HP Reporter 
Server:

a Ensure to install the .NET Framework 2.x (or higher) on the HP Reporter server. 
Insert the HP Operations Smart Plug-ins DVD on the HP Reporter server.

b Run the discovery command to discover all the managed nodes on the HP Reporter 
server. Check the %OvDataDir%\trace.discover file to ensure that all the 
Microsoft Exchange managed nodes are discovered.

c Open a command prompt and browse to the following path: 

<SPIDVD>/Windows/OV_REPORTER/EXCHANGE_SPI/

d Ensure that all the Microsoft Exchange managed nodes are discovered by the HP 
Reporter, and then run the following command:

EXSPI_run_gatherCODA.exe <reporter_system_dsn> <reporter_db_username> 
<reporter_db_password>

In this instance, <reporter_system_dsn> is the system DSN for the HP Reporter 
database; <reporter_db_username> and <reporter_db_password> are the user name 
and password to access the HP Reporter database.

Delete service discovery policy EXSPI_Discover_2K7 from the management server before 
upgrading from Microsoft Exchange SPI 12.00 to EXSPI 13.00

Ensure to perform the following steps before upgrading the Microsoft Exchange SPI 
reporter package to 13.00 on the HP Reporter Server.
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e Check the %OvDataDir%\trace.gather file for any errors. Ensure that the data is 
collected for all the metric lists from all the managed Microsoft Exchange nodes.

7 Launch the tool Delete older EXSPI classes from the tool group SPI for Exchange on all the 
managed Microsoft Exchange server nodes to delete the previous version of the Microsoft 
Exchange SPI data store on the managed nodes.

8 Proceed to configure the Microsoft Exchange SPI. See Configuring Microsoft Exchange 
SPI.

Upgrading Microsoft Exchange SPI on HPOM for UNIX 9.0x Cluster Servers

To upgrade the Microsoft Exchange SPI on cluster servers, perform the following tasks:

Task 1: At the first cluster-aware management server, select and install Smart Plug-ins.

Complete the steps in Upgrading Microsoft Exchange SPI on a Standalone HPOM for UNIX 
9.0x Server on page 26 before proceeding to the next management server.

Task 2: At the next cluster-aware management server, install pre-selected Smart Plug-ins.

Repeat step 1, step 2, and step 8 of Upgrading Microsoft Exchange SPI on a Standalone 
HPOM for UNIX 9.0x Server on page 26 on each management server in the cluster. Complete 
the upgrade on every management server until you have finished.

Support Statement for Co-Existence of different versions of Microsoft Exchange 
SPI on HP Operations Manager on UNIX 9.0x

Be aware of the following limitations when you plan to install the Microsoft Exchange SPI 
13.00 (from SPI DVD 2009) on a HPOM 9.0x, which has the Microsoft Exchange SPI 12.00 
installed from SPI DVD 2008. 

• You must complete the migration process from HPOM 8.xx to HPOM 9.0x before 
upgrading the Microsoft Exchange SPI to version 13.00. After the Microsoft Exchange SPI 
13.00 is installed, migrating from HPOM 8.xx is not supported.

• Having the Microsoft Exchange SPI version 12.00(migrated from HPOM 8.xx) and 
Microsoft Exchange SPI version 13.00 (newly installed from SPI DVD 2009) on HPOM 
9.0x is an intermediate mode and you must move all the managed nodes to the Microsoft 
Exchange SPI version 13.00 as soon as possible.

• If you have multiple SPIs deployed on a managed node, the node can be monitored either 
by SPI DVD 2008 SPIs or SPI DVD 2009 SPIs. Monitoring a node by combination of SPIs 
from SPI DVD 2008 and SPI DVD 2009 is not supported.

• If you have the Microsoft Exchange SPI 13.00 installed on HPOM 9.0x systems, which 
also has the Microsoft Exchange SPI 12.00, the following points are valid:

After ensuring that all the managed nodes are being monitored by Microsoft Exchange SPI 
13.00, launch the tool Cleanup older EXSPI artifacts from server from the tool group SPI for 
Exchange on the management server node to delete the previous version of the Microsoft 
Exchange SPI instrumentation files from the management server.

Before starting, ensure that sufficient disk space is available on each management server for 
the Microsoft Exchange SPI. Cancelling the installation process before the completion leads 
to partial installations and require manual removal of the partially installed components.
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— The newly added managed nodes should be configured using the Microsoft Exchange 
SPI 13.00.

— No configuration is possible on the existing or old managed nodes monitored by the 
Microsoft Exchange SPI 12.00.

This is because the Microsoft Exchange SPI 12.00 configuration tools are overwritten by 
the Microsoft Exchange SPI 13.00 tools and these tools (previous version) are 
incompatible.

• Patches for the Microsoft Exchange SPI version 12.00 must be installed before you start 
the HPOM migration process. After the Microsoft Exchange SPI version 13.00 is installed, 
no patches or hot-fixes pertaining to the Microsoft Exchange SPI version 12.00 could be 
installed on the HPOM server.

• To invoke the GUIs related to the Microsoft Exchange SPI 13.00, you must install 
X-windows client software on the machine from which you will launch the HPOM for 
UNIX 9.0x server Operator GUI.

• After migration from HPOM 8.xx to HPOM 9.0x, when you run license reporting tool from 
HPOM 9.0x, the following errors would be reported. This is an expected behavior. You can 
ignore this error.

Verifying the Upgrade

To verify the upgrade of the Microsoft Exchange SPI, see Verifying the Installation of 
Microsoft Exchange SPI.
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3 Configuring Microsoft Exchange SPI
The SPI monitors the Microsoft Exchange Server by discovering the existing components of 
the Microsoft Exchange Server 2007 in your environment and maintaining the thresholds set 
up by the policies. After you install the Microsoft Exchange SPI, you must configure it to 
monitor the Microsoft Exchange Server 2007 nodes in your organization. 

Basic Configuration Procedure

Configure the Microsoft Exchange SPI by performing the tasks in the Administration UI.

Manage Exchange Server Nodes

To manage the Exchange Server (EXSPI) nodes, see section Organizing Managed Nodes in 
chapter 3 (Configuring and Maintaining) HPOM in the HP Operations Manager for UNIX 
Concepts Guide.

Assign Microsoft Exchange Nodes to Node Group

Assign the Exchange nodes to the Exchange Server 2007 node group. To assign nodes:

1 Click Browse → All Node Groups and select the Exchange_Server_2007 node group check 
box. 

2 Select Assign Nodes... from the drop-down list, and click Submit . A Selector window 
appears.
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3 Select the Microsoft Exchange nodes to be added in the Exchange_Server_ 2007 node 
group and click OK.

.

A message displays successful assignment of the nodes to the Exchange_Server_2007 
node group.
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Assign Instrumentation Categories to Exchange Nodes

Assign the following instrumentation categories to the Microsoft Exchange nodes:

• Exchange2k7_Core

• Exchange2k7_Discovery

• Exchange2k7_Collector

• SPI Data Collector

To assign instrumentation to the Microsoft Exchange nodes:

1 Click Browse → All Node Groups and click Exchange_Server_ 2007 node group. The 
Exchange nodes are listed.

2 Select the Exchange nodes check boxes to assign the instrumentation categories.

3 Click Assign Categories... from the drop down list and click Submit . The Selector 

window opens.

4 Select Exchange2k7_Core, Exchange2k7_Discovery, Exchange 2k7_Collector, and SPI Data 
Collector, and then click OK.
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The selected categories are assigned to the Microsoft Exchange nodes. 
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Deploy Configuration

Deploy configuration to one or more Exchange nodes. To deploy configuration: 

1 Click Browse → All Node Groups and click Exchange_Server_2007 node group. The Exchange 
nodes are listed.

2 Select the check box of the Exchange nodes to deploy configuration.

3 Select Deploy Configuration... from the drop down list and click Submit .

4 A box opens which indicates the categories of configuration. Select only Distribute 
Instrumentation check box, and click OK. 

 

The instrumentation is successfully deployed on the Exchange nodes.

Configuration deployment fails, if the PowerShell prompt, with the Microsoft Exchange SPI 
pssnapin loaded, is kept open on managed node.

Ensure to stop the EXSPI Collector Server, (if it is already running on the managed node) 
before you deploy the instrumentation category Exchange2k7_Collector. Use the Stop 
PowerShell Collector tool to stop the collector server. Restart the EXSPI Collector Server 
after you deploy the instrumentation category. To start the collector server, use the Start 
PowerShell Collector tool. See Starting PowerShell Collector Tool for more details.
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Assign Tool Group to Operator

Assign the Microsoft Exchange SPI tool group to the operator opc_adm (or any desired 
operator). For this:

1 Click Tool Bank. The tool group SPI for Exchange is displayed.

2 Select the SPI for Exchange check box.

3 Select Assign to User/Profile... and click Submit . The Selector window opens.

4 Type opc_adm (or any desired operator) in the Name box and click OK. The operator 
which you selected is displayed.

5 Select the opc_adm operator (or any desired operator) and click OK. 
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The Exchange 2007 tool group is assigned to the operator opc_adm. 
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Assign Exchange Node Group and Message Groups to the Operator

Assign Exchange_Server_2007 node group and EXSPI_2007 and EXSPI_2007_Errors 
message groups to one or more operators for HP Operations for UNIX. This enables the 
operator to view messages, alerts, or both which are generated from the EXSPI nodes.

To assign the node group and message groups:

1 Click Browse → All Users. All the users as operators are listed. 

2 Select one or more operators for EXSPI, for example, opc_adm check box and click Edit 

Responsibilities... from the Edit option .

3 All the available nodes groups and message groups are displayed in the Edit Matrix View 
window.
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4 Click Edit View and select Exchange_Server_2007 node group and EXSPI_2007 and 
EXSPI_2007_Errors message groups by shifting them from the available node groups and 
available message groups to visible node groups and visible message groups by clicking 

the icon .

5 The Exchange_Server_2007 node group and the EXSPI_2007 and EXSPI_2007_Errors message 
groups are added to the list.
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6 Select the Exchange_Server_2007 node group and the EXSPI_2007 and EXSPI_2007_Errors 
message groups check boxes to which now enables the opc_adm operator to use the 
message browser and to view the alert. Click Save.

Run Tools - Create DataSources, Register DataCollection, and Start PowerShell 
Collector

Run the following Exchange SPI tools in each Microsoft Exchange node in the given order:

• Create Data Sources: The Create Data Sources tool creates databases either into the HP 
Operations agent's data store (embedded performance component-also known as CODA), 
or into the HP Performance Agent.

If you do not have the HP Performance Agent (HP PA) installed in your environment, the 
tool creates databases into the data store (CODA). The data store can store the data 
collected by individual collectors.

For more details on data logging, see Data Logging Scenarios.

If the managed node has both HP PA and CODA installed, then to create the data source 
in CODA, create an empty nocoda.opt file, and then customize the Create DataSources 
tool cmdline by adding -CODA option before you start the tool.

• Register DalaCollector: The Register DataCollector tool registers necessary COM 
components on the nodes. Run this tool before you start monitoring the nodes.

• Start PowerShell Collector

The Start PowerShell Collector tool starts the EXSPI Collector on the Exchange node. Start 
this tool as a user who has the following privileges of an:

— Exchange View-Only Administrator

— Exchange Server Administrator of all mailbox servers

— Local Administrator of all mailbox servers and

— READ+WRITE access to Microsoft Exchange System Object (MESO) of all mailbox 
servers

To grant READ+WRITE access to MESO to the user:

a Open Active Directory Users & Computers snap-in on the DC of the domain to which 
the Microsoft Exchange Server is a member of.

b Ensure that View → Advanced Features is selected.

c Browse to Microsoft Exchange Systems Objects container, right-click, and select 
Properties.

d Click Security tab, and then click Advanced.

e Select Add button, type the name of user account to be delegated, and then click OK.

f In the Apply to Drop down list, select msExchSystemMailbox objects.

g Select the READ PROPERTY & WRITE PROPERTY check box.

h Click the consequent OK buttons to close all the property sheets.

This tool checks for any existing EXSPI datasource. If no datasource exists, it displays an 
error message. This error message, however, can be ignored as the Create Data Sources 
tool continues to create a new EXSPI datasource.
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i Wait for or force the AD replication.

Starting PowerShell Collector Tool

To start the Start PowerShell Collector tool, log into the operator’s GUI:

a From the Administration UI, click Integrations → HPOM for Unix Operational UI. The 
login window appears.

b Type the user name and password to log in.

c Right-click the node where the tool needs to be started and click Start Customized.... 

Run the Edit XPL Configuration File tool on the managed node before starting the Start 
PowerShell Collector tool. This tool enables the PowerShell Collector tool to run as non-agent 
user.
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d Expand SPI for Exchange → Exchange 2007, and select Start PowerShell Collector tool.

e Click Next.
40 Chapter 3



f Enter the user credentials with the required privileges.

g Click Finish. The Start PowerShell Collector tool starts.

To start the Create Data Sources and Register DataCollector tools, log into the operator’s 
interface:

1 From the Administration UI, click Integrations → HPOM for Unix Operational UI. The login 
window appears.

2 Type the user name and password to log in.

3 Right-click the node where the tool need to be started.

The Start PowerShell Collector tool does not return any output. The message Tool Started. 
Please wait. continues to be displayed. To check if the PowerShell Collector has started, 
close the tool output and check the Task Manager on the managed node.
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4 Select Start → SPI for Exchange → Exchange 2007 → Create Data Sources (Register 
DataCollector). 

5 A message “Tool Started. Please wait.” indicates the start of the selected tool.
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Specify the Credentials for EXSPI-8X Check Collector Server Policy

Specify the same credentials of the user who starts the Start PowerShell Collector tool for the policy 
EXSPI-8X Check Collector Server. To know the details of the privileges which the user must have, see 
Start PowerShell Collector.

Assign Microsoft Exchange SPI Policies to Exchange Nodes

Assign Microsoft Exchange SPI policies to the Exchange nodes. For this:

1 If the Microsoft Exchange server nodes run on a cluster environment, perform the steps as 
described in Edit Discovery Policy.

2 Click Browse → All Node Groups and click Exchange_Server_ 2007 node group. The 
Exchange nodes are listed.

3 Select the check box of the Exchange nodes to assign policies.

4 Click Assign Policies / Policy Group... from the drop down list and click Submit . The 

Selector window opens.

5 Select Policy Groups in Locate box and type the name of the policy group corresponding to 
the role being hosted on the Exchange server node in the Name box and click Filter. For 
more details, see Table 3.

6 Select SPI for Exchange/Exchange 2007/Manual Deploy Groups/<policy group> and click OK. 
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All the Microsoft Exchange SPI policies of the policy group are assigned to the Exchange 
nodes which host the appropriate role.

 

See the following table to deploy the specific policy group for the specific Exchange server.

Assign only those policy groups on the managed nodes which host the roles that the policy 
group is related to. For example if the managed node hosts the Edge Server, deploy only the 
Edge Server policy group, and so on.
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Table 3 Server Role and the Policy Group to be deployed

Deploy the following policy groups for all the managed nodes irrespective of the specific server 
role:

• Discovery

Policy Bank → SPI for Exchange → Exchange 2007 → Manual Deploy Groups → Discovery

• Availability

Policy Bank → SPI for Exchange → Exchange 2007 → Manual Deploy Groups → Availability

• Collector Definition

Policy Bank → SPI for Exchange → Exchange 2007 → Manual Deploy Groups → 
Collector Definition

• ExBPA Integration

Policy Bank → SPI for Exchange → Exchange 2007 → Manual Deploy Groups → 
ExBPA Integration

Customize Policies

You can customize one or more policies, if required, to suit the Microsoft Exchange Server 
2007 environment. 

To customize a policy:

1 Click Policy Bank → SPI for Exchange → Exchange 2007 → Manual Deploy Groups.

2 Click the policy groups where the policy resides. For example, Edge Server.

3 Select the policy check box which requires modifications. For example, select EXSPI-8X 
DcTransport Queues check box.

Server Role Policy Group

Mailbox Server Policy Bank → SPI for Exchange → Exchange 2007 → 
Manual Deploy Groups → Mailbox Server

Hub Transport 
Server

Policy Bank → SPI for Exchange → Exchange 2007 → 
Manual Deploy Groups → Hub Transport Server

Edge Transport 
Server

Policy Bank → SPI for Exchange → Exchange 2007 → 
Manual Deploy Groups → Edge Server

Client Access Server Policy Bank → SPI for Exchange → Exchange 2007 → 
Manual Deploy Groups → Client Access Server

Unified Messaging 
Server

Policy Bank → SPI for Exchange → Exchange 2007 → 
Manual Deploy Groups → Unified Messaging Server

Edit the EXSPI-8X Check Collector Server policy to run with the same privileges as required 
to run the Start PowerShell Collector tool. For more details, see the privileges (for the Start 
PowerShell tool) mentioned in Run Tools - Create DataSources, Register DataCollection, and 
Start PowerShell Collector.

Use Software Upgrade Tool Kit 2.0 (SUTK) to retain the customization of the policies. See HP 
Operations Smart Plug-in Upgrade Toolkit UNIX User Guide for more details.
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4 Select Edit... from the drop-down list.

4 The Edit Measurement_Threshold Policy "EXSPI-8X Dc Transport Queues" 
window opens to enable you to edit the policy in terms of customizing its properties, 
settings parameters, or message threshold or all.

5 Click the Properties or Parameters or Message Defaults or Thresholds or Options or all tabs to 
modify the policy attributes and click Save. 

The tabs enables you to perform the following actions:

a Parameter tab - selecting the default view or the design view. 

b Message Default tab - using or not using the Instruction Text or the Instruction Text 
interface. 
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c Threshold tab - selecting the monitoring type between VBScript or perl.

d Options tab - setting the logging and processing options. 

Deploy Microsoft Exchange SPI Policies to Exchange Nodes

Deploy the Microsoft Exchange SPI policies to the Exchange nodes. For this:

1 Click Browse → All Node Groups and click Exchange_Server_2007 node group. The Exchange 
nodes are listed.

2 Select the check box of the Exchange nodes to deploy policies.

3 Select Deploy Configuration... from the drop down list and click Submit . 

4 A box opens which indicates the categories of configuration. Select only Distribute Policies 
check box, and click OK. 

Configuration deployment fails, if the PowerShell prompt, with the Microsoft Exchange SPI 
pssnapin loaded, is kept open on managed node.
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All the other Exchange SPI policies are deployed on the Exchange nodes. 

Data Logging Scenarios

If you use Performance Agent as the datastore, data source creation and data logging happens 
in Performance Agent, by default. There is no configuration required.

To create data sources and to log data into CODA, while Performance Agent is installed, 
perform the following steps:

1 Create a folder dsi2ddf in the path %OvAgentDir%\Conf, if it does not exist.

2 Create an empty file nocoda.opt.

3 Enter the names of the other data sources except EX2007_DATA, which are to be created 
and for which the data logging has to happen in Performance Agent into the file 
nocoda.opt. 

The data source EX2007_DATA is created and data logging happens in CODA. 

For more details on the data store metrics and policy logging details see HP Operations Smart 
Plug-in for Microsoft Exchange Server Reference Guide. 

Discovery Configuration Scenarios

The Microsoft Exchange SPI discovers the services of the Microsoft Exchange 2007 Server and 
helps you to manage the Microsoft Exchange environment. Perform the tasks in the following 
sections to discover the Microsoft Exchange services.
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Edit Discovery Policy

Edit the Exchange SPI Discovery policy. For this:

1 Click Policy Bank → SPI for Exchange → Exchange 2007 → Manual Deploy Groups → 
Discovery.

2 Select the Exchange 2007 Discovery policy and click Edit... . 

Perform the following steps only for the clustered Exchange server nodes.
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3 Enter the credentials of the Exchange Organization Administrator.

Assign Discovery Policy to Managed Nodes

Assign the Discovery policy to all the Exchange managed nodes. For this:

1 Click Browse → All Node Groups and click Exchange 2007 Servers node group. The Exchange 
nodes are listed.

2 Select the check box of the Exchange nodes to assign policies.

3 Click Assign Policies / Policy Group... from the drop down list and click Submit . The 

Selector window opens.

4 Select Policies in Locate box and type Exchange 2007 Discovery in the Name box and 
click Filter. The Exchange Discovery policy is displayed.

5 Click Exchange 2007 Discovery, and then click OK.
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The Discovery policy is assigned to the Exchange nodes.
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Deploy Discovery Policy to Managed Nodes 

Deploy the Microsoft Exchange SPI Discovery policy to the Exchange nodes. For this:

1 Click Browse → All Node Groups and click Exchange 2007 Servers node group. The Exchange 
nodes are listed.

2 Select the check box of the Exchange nodes to deploy the Discovery policy.

3 Select Deploy Configuration... from the drop down list and click Submit . A box opens 

which indicates the categories of configuration. Select only Distribute Policies check box, 
and then click OK.

The Discovery policy is successfully deployed on the Exchange nodes.
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Assign Microsoft Exchange SPI Services to Operator

Assign the EXSPI discovered services to the operator opc_adm (or any desired operator) by 
running the command opcservice -assign <<operator_name>> MicExch2k7 after 
EXSPI discovery is run. The service navigator now shows the Microsoft Exchange Server 2007 
service map.

View Service Map through Operator GUI

You can view the Microsoft Exchange SPI service map through the operator GUI. To view 
services click Services.

The service map shows the newly discovered services of the Microsoft Exchange Server 2007. 
Expand the hierarchy to view the specific services of the Microsoft Exchange Server 2007. See 
Figure 8. 
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Figure 8 Service Map

Additional Configuration Procedure

You can enhance the monitoring capabilities of the Microsoft Exchange SPI on the Microsoft 
Exchange Server 2007 nodes by customizing the data collection configuration. The Microsoft 
Exchange SPI data collectors follow a pre-defined data collection configuration to monitor the 
managed nodes. You can create and modify those new data collection configuration.

Functions of EXSPI Data Collectors

The pre-defined data collection configuration is described in an XML file named as 
spimetadata.xml. Deploy the EXSPI-8X Spimetadata Versioning policy to use the 
spimedata.xml file. The EXSPI data collectors follow the data collection configuration as 
defined in the spimetadata.xml file. This file consists of a component, that is, collection, 
which determines the data which is to be collected by an EXSPI data collector. The data 
collection configuration describes the complete workflow of collecting, storing, and alerting.

A data collection configuration consists of the following components or building blocks: 

• MetricSet — A metric is a measurement that defines a specific operational or performance 
characteristic of a system or an application. A MetricSet is a group of related metrics.

• OpCMsg Calls  — An OpCMsg Call generates an alert message when a metric value does 
not match a pre-set value or range of values.

The EXSPI Data collector can collect only the data from Cmdlets available on the managed 
node.
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• OpCMon Calls —  An OpCMon Call sends the collected data to a measurement threshold 
policy. The measurement threshold policy checks the data against some upper or lower 
threshold as defined within the policy and sends alarm to the message browser.

• Data Store — A Data Store defines the way in which the collected data can be stored into 
the data store (CODA or PA).

Each data collection configuration is associated with a scheduled task policy. Each collection is 
associated with a unique integer value called the collection ID. A request must be sent to the 
EXSPI Data Collector with the ID as one of the parameters to start the collection process. 
This is performed by the schedule task policy for each collection which executes a command 
HP.OV.SPI.ExScheduler -CID <ID>.

When you deploy a scheduled task policy on a managed node, the EXSPI data collector 
retrieves the following details from the data collection configuration:

• The cmdlets to be executed and the metrics to be collected from the Resultset. 

• The name of the data store where the collected data is to be logged.

• The name of the monitor policy to which a particular metric has to be passed. This policy 
performs the threshold on this metric value.

• The set of rules in the spimetadata.xml file to be applied on the metrics and if required 
generate opcmsg.

EXSPI Configuration Utility Tool

The Microsoft Exchange SPI provides a tool named EXSPI Configuration Utility to modify the 
default data collection configuration specified in the spimetadata.xml file on the Microsoft 
Exchange Server 2007 nodes be adding new data collection through its graphical user 
interface. You can add the components of the data collection configuration—MetricSet, 
OpCMsg Calls, OpCMon Calls, and data store—and modify the newly created collection 
configuration to monitor the managed nodes. 

Launching EXSPI Configuration Utility Tool

To launch the EXSPI Configuration Utility tool:

1 Copy the file <OVO_INSTALLDIR>/install/EXSPI/EXSPI-Console.zip to a windows 
system which has a .NET Framework 3.x or above.

2 Extract the EXSPI-Console.zip.

3 Copy the contents of the EXSPI-8X SPImetadata Versioning policy from HPOM on UNIX    
9 Server into an XML file and place the XML file in a folder.

4 Open the folder and double-click HP.OV.SPI.Composer.exe to start using EXSPI 
Configuration Utility tool.

5 Edit the XML file using EXSPI Configuration GUI as described in the Modifying a 
Collection.

6 After you complete editing the XML file, copy the contents of modified XML file to the 
EXSPi-8X SPIMetaData Versioning policy on the HPOM on UNIX 9 Server.

7 Save the policy and redeploy it on the managed nodes.

To get the value of <OVO_INSTALLDIR>, run the command opcagt -type -verbose 
on the HPOM for UNIX 9 Server.
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Using the EXSPI Configuration Utility Tool

To start the EXSPI Configuration Utility tool:

1 In the console tree, expand Tools → SPI for Exchange, and double-click Exchange 2007. 

2 In the details pane, double-click EXSPI Configuration Utility. The Select Server dialog box 
opens. 

3 Select the OM for Windows Server option, and click Load.

4 The EXSPI Configuration Utility tool starts displaying the collection topology.
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Viewing the EXSPI Configuration Utility Tool

The EXSPI Configuration Utility provides you with a graphical user interface to perform 
necessary tasks to create new data collection configuration. The graphical user interface 
consists of the following elements: 

• Menu bar 

• Toolbar 

• Left pane and right pane

EXSPI Configuration Utility Menubar

You can use the menu options in the menu bar to perform tasks like adding and removing an 
element of collection definition. You can also view a preview of every element (in the form of 
XML markups) by using the Preview menu option. 

Table 4 EXSPI Configuration Utility Menubar

Menu Options Description

File Save Saves any changes that you 
make.

Save as Enables you to save the 
updated spimetadata.xml 
file on a different location 
and with a different name.

Reload/ Cancel All 
Changes 

Reloads the utility, cancels 
all unsaved changes. 

Exit Exits the PowerShell 
collection configuration 
utility. 

Edit Delete Selected 
Collection

Deletes the selected 
collection configuration or 
component from this menu. 
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EXSPI Configuration Utility Toolbar

You can use the toolbar to add references to the collection elements—MetricSets, DataStores, 
OpCMsg Calls, and OpCMon Calls. 

Table 5 EXSPI Configuration Utility Toolbar

Insert Add New 
MetricSet 

Adds a new MetricSet to the 
list of available MetricSets. 

Add New Metric Adds a new Metric to the list 
of available metrics in a 
particular MetricSet. This 
option is enabled only when 
you select a MetricSet.

Add New 
Collection

Adds a new collection to the 
list of available collections. 

Add New 
DataStore 

Adds a new DataStore to the 
list of available DataStores. 

Add New 
OpCMon Call 

Adds a new OpCMon Call to 
the list of available OpCMon 
Calls. 

Add New OpCMsg 
Call 

Adds a new OpCMsg Call to 
the list of available OpCMsg 
Calls.

Menu Options Description

Icon Tool Name

Add MetricSet

Add DataStore

Add OpCMsg Call 

Add OpCMon Call
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EXSPI Collection Configuration Utility Panes

The left pane lists all available metrics, MetricSets, collections, DataStores, OpCMsg Calls, 
and OpCMon Calls in a tree like structure. You can navigate to specific collection elements 
with the help of the left pane. The right pane provides you an interface to view and modify 
properties and settings for every collection element.

. 

Saving Collection Configuration

There are two options for saving the updated collection configuration:

• File → Save

• File → Save As

File and Save Option

When you open the file from the following location:

• From OM for Windows option: The configuration is read from the EXSPI-8x SPIMetadata 
Versioning policy. When you save the updated configuration, the data is written back to 
the policy. This updates the version of the policy. 

To make this configuration available on the node, redeploy the policy.

If you modify the EXSPI Configuration Utility tool, ensure to deploy the EXSPI-8X 
SPIMetaData Versioning policy on the managed nodes where the changed data collection 
mechanism takes effect. Even if you revert to the previous version of the EXSPI-8X 
SPIMetaData Versioning policy, the GUI shows the latest version.
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• From the local disk: No versions are maintained if you save the file from local disk as the 
latest file overwrites the previous file.

File and Save As Option

When you click Save → Save As, the file is saved irrespective of its location in the local disk. 
The Save As option, however, enables you to save only the local copy. 

Adding Collection Data

The EXSPI Configuration utility tool enables you to add the following components:

• MetricSet

• OpCMsg Call

• OpCMon Call

• DataStore

• Collection

Adding a MetricSet

A MetricSet is a group of related metrics. The Microsoft Exchange SPI collects these metrics 
to monitor the health, availability, and performance of Microsoft Exchange Server 2007. 

Each MetricSet can execute a Powershell command. The Powershell command can either be a 
single Cmdlet or a pipeline of Cmdlets. You can use either or all of the following Cmdlets:

• Default Powershell Cmdlets

• Microsoft Exchange Cmdlets

• EXSPI Internal Cmdlets

• User created cmdlets (See Using Additional Cmdlets)

To add a new MetricSet: 

1 In the left pane, right-click MetricSet from Collection Components, and then click Add New 
MetricSet or click Insert → Add New MetricSet from the menu bar. A new MetricSet (with the 
name New MetricSet) appears in the list of MetricSets. 

2 In the right pane, specify the MetricSet Name. For example GetMailBox. Select the 
PowerShell command from the drop down. 

The list consists of the default Cmdlets available with the Microsoft Exchange 
Management PowerShell.

Since every time you save the file, a new version gets created, avoid saving the file very often 
to limit the numerous versions of the file.

Do

Do not modify any default MetricSet or data store or both. You can however modify the newly 
added MetricSet, the DataStore, OpcMSg Call, and OpcMon Call.

You can use the drop-down option for PowerShell commands only for a single command. For 
more than one PowerShell command (pipelined commands), you must manually type the 
required commands.
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3 Click Apply Changes.

4 Click File → Save. The added MetricSet (GetMailBox) gets listed with the other 
MetricSets in the left pane. 
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For the MetricSet GetMailBoxDetails (which is required to collect Mailbox Details), the 
cmdlet can be Get-Mailbox or if we want to add filter and not want to log System Mailbox 
Details, it can be "Get-Mailbox | where {$_.DisplayName -notlike "SystemMailbox*" }".

After you add a new MetricSet, the EXSPI Configuration Utility adds a new metric template 
to the MetricSet. You can create new metrics and add these to the newly created MetricSet.

Adding a Metric

After you add a MetricSet, you must now add or select metrics from the resultset of the 
powershell command specified in the MetricSet. If the command is a single Cmdlet, select the 
metrics from the drop-down list. If the command is pipelined command (more than one 
cmdlet) type these commands. Then type each metric name from the resultset of the last 
Cmdlet in the pipeline.

To add a new metric: 

1 In the left pane, expand MetricSets from Collection Components.

2 Right-click the MetricSet (for example GetMailbox), and then click Add New Metric or click 
Insert → Add New Metric from the menu bar. 

3 A new metric (with the name New Metric) appears in the list of metrics under the selected 
MetricSet enabling you to fill the following options (as shown in the table) on the right 
pane. 

Option Description

Metric Name Select a metric name from the 
drop-down list of the available 
metrics or type the required metric 
name if it is not listed in the 
drop-down list. For example, 
NextHopDomain.

Metric 
Description

Type the description of the metric, 
RulesQuota (Example). 

Metric Data 
Type 

After you choose the metric, suitable 
data type appears by default. Do not 
change the default setting 
(RulesQuota). However, if you have 
typed the metric, then you must type 
the required metric data type also.
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Category Only incase of metrics which 
represents bytes/kilobytes you must 
mention a Category. For Example for 
the metricset GetMailbox the metric 
"RulesQuota" returns value in Kilo 
Bytes (KB). So the category to be 
selected is KiloByte.

Scale To convert the metric value to a unit 
of your choice, specify the 
multiplying factor. For example, if 
the metric value is in the form of KB 
and you want to collect the metric in 
the form of bytes, specify 16 
(example) in this field. This option is 
useful for the metrics which are 
representing the value in Bytes or 
KB and so on.

Suffix Specify the element of the metric 
value that you want to eliminate. For 
example, if the metric value is 
appended with the unit B (as in 
1200B), you can eliminate B by 
typing B in the Suffix text box. 
This option is useful for those 
metrics which identifies memory size 
in bytes. Many of the Microsoft 
Exchange cmdlet metrics which 
return BYTES/KILOBTYES are 
suffixed with B/KB. As in the 
example of "RulesQuota" it is KB. To 
use the metrics for calculations we 
must remove the suffix. By 
mentioning the suffix here the 
collector removes the suffix from the 
metric before using it. 
Specify one suffix for each metric.

Option Description
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4 Click Apply Changes to save the metric. The added metric RulesQuota is listed in the 
MetricSet GetMailbox. 

5 Continue adding the other metrics, if required.
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Adding an OpCMsg Call

If some metric values cross a certain threshold value, you can receive alert messages in the 
HPOM message browser. The EXSPI Data Collector Configuration enables you to specify the 
conditions on the metrics of a given metricset to generate alerts through the opcmsg call. 

An OpCMsg Call is an element of a collection definition, which holds the following 
information: 

• Threshold value (or range of values) for a metric.

• Alert message if the metric does not match the required value or crosses the range of 
values.

• Severity level (major, minor, normal, warning, and so on) of the event when the metric 
does not match the limiting value.

To add a new OpCMsg Call:

1 In the left pane, right-click OpCMsg Calls from Collection Components, and then click Add 
New OpCMsg Call or click Insert → Add New OpCMsg Call from the menu bar. A new OpCMsg 
Call appears in the list in the left pane.

2 Fill the following options (as shown in the table) appearing in the right pane. 

You can apply the rules over the metrics for an alert only for a single MetricSet.

Option Description

OpCMsg Call 
Set Name 

Type an appropriate name. 
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Application Type an appropriate name of the 
application that will be affected. You 
can view this text in the HPOM 
message browser by opening the 
Message Properties dialog box. You 
can leave this field blank. 

Object Type an appropriate name of the 
object of the application that will be 
affected. You can view this text in the 
HPOM message browser by opening 
the Message Properties dialog box. 
You can leave this field blank.

Severity Select the severity level of the event. 

Message Text Type the message that you want to 
generate. 

MetricSet Ref Select an available MetricSet from 
the list. 

Metric Ref Select an available metric from the 
list. 

Select 
Arithmetic 
Operator 

Select an available arithmetic 
operation from the list. 

Select Logical 
Operator to 
combine with 
Previous 
Rule 

This field is enabled only when you 
choose more than one limiting value 
or condition for the chosen metrics. 
Select AND or OR to combine the 
rules that you create based on the 
available arithmetic operators.

Value to 
compare 

Select the limiting (threshold) value 
of the selected metric. 

Option Description
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3 Click Add to add the rules.

4 Click Apply Changes to save the OpCMsg Call. The added OpCMsg Call GetQueue is listed 
with the other OpCMsg Calls. 
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Adding an OpCMon Call

An OpCMon Call sets a limiting value for metric data through a measurement threshold 
policy. The Microsoft Exchange SPI retrieves the details like message text and severity from 
the measurement threshold policy. 

To add a new OpCMon Call:

1 In the left pane, right-click OpCMon Calls from Collection Components, and the click Add 
New OpCMon Call or click Insert → Add New OpCMon Call from the menu bar.A new OpCMon 
Call appears in the list in the left pane.

2 Fill the following options (as shown in the table) appearing in the right pane. 

You can use OpCMon Calls only for numeric metric values.

Option Description

Name Type an appropriate name for the 
OpCMon Call. 

MetricSet Ref Select an available MetricSet. 

Metric Ref Select the metric name for which you 
want to set the OpCMon Call. 

Measurement 
Threshold Policy 
Name

Type the name of a measurement 
threshold policy to which you want to 
associate this OpCMon Call.
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3 Click Apply Changes to save the OpCMon Call. The added OpCMon Call 
TransportQueueCount is listed with the other OpCMon Calls.

Adding a DataStore

Data Stores define the way in which you can store metric data. After the Microsoft Exchange 
SPI collects metric data by using collectors, you can store the collected data either in the HP 
Operations agent's data store (CODA) or in the HP Performance Agent (PA, if you have it 
installed it in the HPOM environment). 

To add a new DataStore:

1 In the left pane, right-click DataStores from Collection Components, and the click Add New 
DataStore or click Insert → Add New DataStore from the menu bar. A new DataStore appears 
in the list in the left pane.

2 Fill the following options (as shown in the table) appearing in the right pane.

Option Description

Name Type an appropriate name for the 
DataStore. 

Capacity Type the number of rows for the 
DataStore. 

Data Source Type EX2007_DATA. 
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3 From the Select MetricSet reference drop-down list, select the appropriate MetricSet.

4 From the Select Metric reference drop-down list, select the one or more appropriate 
metrics.

5 In the Select Data column reference box, type a name for the data column in which the 
DataStore will store the selected metrics. Do not leave this field blank if you want to add 
more than one metric. 

6 Click Add. You can add only one MetricSet whereas more than one metrics can be added 
but all the metrics should belong to the same MetricSet.

7 Click Apply Changes to save the DataStore. The added DataStore QueueInfo is listed with 
the other DataStores.

 

Data Table Type EX2007_<table name>, where 
<table name> is an appropriate 
name for the table.

Index By Set the index on daily, weekly, or 
monthly schedules. 

Roll By Type the interval at which the data 
should be flushed out of the data 
store. You can specify DAY, WEEK, 
or MONTH. You cannot store data 
for more than a month. 

Option Description
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After you create a new Data Store, you must add it to an existing collection configuration. See 
Adding a Collection Configuration to add a collection configuration. After adding the newly 
created Data Store to an existing collection configuration, perform the following steps:

1 Go to the newly created DataStore.

2 In the right pane, click Generate SPEC. The Spec File Generator dialog box opens.

3 In the Spec File Generator dialog box, type an appropriate label name in the Table Label 
text box, and then click Create. The details of the SPEC file appear in the Preview of the 
SPEC File section.

4 Click Save. A pop-up box opens to confirm the successful creation of the spec file.

5 Close the Spec File Generator dialog box.

Adding a Collection Configuration

A collection defines the complete mechanism of metric data collection. A collector can collect 
metric data, log it to a data store, or send a message to the HPOM message browser if a 
threshold is violated. A collection configuration consists of all the elements that collectively 
describe the complete lifecycle of the collection mechanism for a MetricSet. 

To add a new collection configuration:

1 In the left pane, right-click Collection Configurations, and then click Add New Collection or 
click Insert → Add New Collection. A window appears to add MetricSet to the new collection.

2 Select the MetricSet from the Component Name box from the drop-down menu list.

If you create a new DataStore and generate a spec file by using the PowerShell collection 
configuration utility, ensure that the spec file is made available at the instrumentation 
directory of the managed node. This can be done by saving the spec file in Instrumentation 
Category folder of the Microsoft Exchange SPI. Save the spec file in 
%ovsharedir%\Instrumentation\Categories\Exchange2k7_Core on the HPOM 
Server. Then deploy the Exchange2k7_Core category on the node. After this launch the 
Create Data Source tool on that node to add the datastore. Launch the Create Data Source 
tool on the nodes before you deploy the EXSPI-8X SPIMetaData Versioning policy.
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t. For example,  The MetricSet is added to the collection.

3 To add an OpCMsg Call to this collection, click Add OpCMsg in the right pane. A window 
appears to add the OpCMsg Call to the new collection.

4 Select an OpCMsg Call from the Component Name box from the drop-down list, and then 
click Add. The OpCMsg Call is added to the collection.
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5 To add an OpCMon Call to this collection, click Add OpCMon in the right pane. A window 
appears to add the OpCMon Call to the new collection.

6 Select an OpCMon Call from the Component Name box from the drop-down list, and then 
click Add. The OpCMon Call is added to the collection.
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7 To add a DataStore, click Add DataStore in the right pane. A window appears to add the 
DataStore to the new collection.

8 Select the appropriate DataStore from the Component Name box from the drop-down list, 
and then click Add. The DataStore is added to the collection.
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9 In the right pane, type an appropriate name in the Collection Configuration Name text 
box.

10 Click File → Save. The new collection configuration  is listed with the default 

configurations .

11 Note the command displayed in the Schedule Task Policy Command text box.

12 After you add a new collection configuration, you must perform the following tasks:

a  Create a new scheduled task policy.

b In the newly created scheduled task policy, specify the command that you have noted 
down. 

You must deploy the newly created scheduled task policy (along with the EXSPI-8X 
SPIMetaData Versioning policy) on the nodes where you want the changed data collection 
mechanism to take effect.
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Modifying a Collection

The EXSPI Configuration utility tool enables you to modify the newly added configuration 
collections:

• MetricSet

• OpCMsg Call

• OpCMon Call

• DataStore

• Collection configuration

Modifying a MetricSet

To modify the MetricSet, perform the following:

1 Click the MetricSet (for example, GetQueue) which requires changes. The MetricSet 
details are displayed in the right pane.

2 Change one or more of the following options (as shown in the table) appearing in the right 
pane.

3 Click Apply Changes to save the change.

Do not delete any default MetricSet that is present in the EXSPI Configuration Utility. To 
delete a MetricSet that you have added to the EXSPI Configuration Utility, right-click the 
MetricSet in the left pane, and then click Delete Selected MetricSet. 

Modifying a Metric

To modify an existing metric: 

1 In the left pane, click the metric that you want to modify. 

2 Change one or more of the following options (as shown in the table) appearing in the right 
pane. 

Do

Do not modify any default MetricSet or data store or both. 

Option Description

MetricSet 
Name 

Change to an appropriate name. 

Powershell 
Command

Select a command from the list of 
available commands. 

If you change the PowerShell command, all the previously added metrics will be removed.

Do not modify the metric order in the existing default MetricSets. You can modify the order of 
metrics only in the MetricSets that you have added to the EXSPI Configuration Utility.

Option Description

Metric Name Select a metric name from the list of 
available metrics. 
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3 Click Apply Changes.

Do not delete any default metric that is present in the EXSPI Configuration Utility. To delete a 
metric that you have added to the EXSPI Configuration Utility, right-click the metric in the 
left pane, and then click Remove this....

4 Click Apply Changes.

5 Click File → Save.

Modifying OpCMsg Call

To modify an existing OpCMsg Call:

1 In the left pane, expand Collection Components, and then click the OpCMsg Call that you 
want to modify. 

2 Change one or more of the following options (shown in the table) appearing in the right 
pane. 

Metric 
Description

Type a description of the metric. 

Metric Data 
Type 

After you choose the metric, suitable 
data type appears by default. Do not 
change the default setting. 

Category Select this option to specify the unit 
of measure of the metric. 

Scale To convert the metric value to a unit 
of your choice, specify the 
multiplying factor. For example, if 
the metric value is in the form of KB 
and you want to collect the metric in 
the form of bytes, specify 1024 in this 
field.

Suffix Specify the element of the metric 
value that you want to eliminate. For 
example, if the metric value is 
appended with the unit B (as in 
1200B), you can eliminate B by 
typing B in the Suffix text box. 

Option Description

Option Description

OpCMsg Call 
Set Name 

Type an appropriate name. 

Application If necessary, modify the name of the 
application that will be affected. You 
can view this text in the HPOM 
message browser when you open the 
Message Properties dialog box. You 
can leave this field blank. 
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3 Click Apply Changes.

To delete an existing OpCMsg Call, right-click the OpCMsg Call in the left pane, and then 
click Remove from Collection.

Editing Existing Rules

You can edit the existing rules of OpCMsgCall. To edit the rules, perform the following:

1 Click Edit. 

2 In the section Update Rule, change one or more of the following options:

— Metric Ref

— Arithmetic Operator

To delete any existing rule, select the rule in the Available Rules box, and then click Delete.

Object If necessary, modify the name of the 
object of the application that will be 
affected. You can view this text in the 
HPOM message browser when you 
open the Message Properties dialog 
box. You can leave this field blank.

Severity Select the severity level of the event. 

Message Text Type the message that you want to 
generate. 

MetricSet Ref Select an available MetricSet from 
the list. 

Metric Ref Select an available metric from the 
list. 

Select 
Arithmetic 
Operator 

Select an available arithmetic 
operation from the list. 

Select Logical 
Operator to 
combine with 
Previous 
Rule 

This field is enabled only when you 
choose more than one limiting value 
or condition for the chosen metrics. 
Select AND or OR to combine the 
rules that you create based on the 
available arithmetic operators.

Value to 
compare 

Select the limiting (threshold) value 
of the selected metric. 

Option Description
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Modifying OpCMon Call

To modify an existing OpCMon Call:

1 In the left pane, click the OpCMon Call that you want to modify.

2 Change one or more of the following options (as shown in the table) appearing in the right 
pane. 

3 In the Measurement Threshold Policy name text box, type the name of a measurement 
threshold policy to which you want to associate this OpCMon Call.

4 Click Apply Changes.

5 To delete an existing OpCMon Call, right-click the OpCMon Call in the left pane, and then 
click Remove from Collection.

Modifying a Data Store

To modify an existing DataStore:

1 In the left pane, click the DataStore that you want to modify.

2 Change one or more of the following options (as shown in the table) appearing in the right 
pane.

3 From the Select MetricSet Reference drop-down list, select a MetricSet.

4 From the Select Metric Reference drop-down list, select a metric.

Option Description

Name Type an appropriate name for the 
OpCMon Call. 

Metric Ref Select the metric name for which you 
want to set the OpCMon Call. 

Option Description

Name Type an appropriate name for the 
DataStore. 

Capacity Type the number of rows for the 
DataStore. 

Data Source Type EX2007_DATA. 

Data Table Type EX2007_<table name>, where 
<table name> is an appropriate 
name for the table.

Index By Type DAY. 

Roll By Type the interval at which the data 
should be flushed out of the data 
store. You can specify DAY, WEEK, 
or MONTH. You cannot store data 
for more than a month. 
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5 In the Select Data Column Reference box, type a name for the data column in which the 
DataStore will store the metric selected. 

Do not leave this field blank if you want to add more than one metric.

6 Click Add. You cannot add more than one MetricSet. You can however add more metrics in 
that MetricSet. 

7 To add a new MetricSet and a new metric to this DataStore, in the Add Reference section, 
select new MetricSet and metric, and then click Add. 

8 To delete existing MetricSets and metrics from this DataStore, select an entry from the 
Available Metric References list, and then click Delete.

9 Click Apply Changes.

Regenerating the Spec File 

After you modify an existing DataStore, you must re-generate the spec file. To re-generate the 
spec file for the modified DataStore, perform the following steps:

1 Go to the modified DataStore.

2 In the right pane, click Generate SPEC. The Spec File Generator dialog box opens.

3 In the Spec File Generator dialog box, type an appropriate label name in the Table Label 
text box, and then click Create. The details of the SPEC file appear in the Preview of the 
SPEC File section.

4 Click Save. A pop-up box opens to confirm the successful creation of the spec file.

5 Close the Spec File Generator dialog box..

Do not delete any default Data Store that is present in the EXSPI Configuration Utility. To 
delete a DataStore that you have added to the EXSPI Configuration Utility, right-click the 
DataStore in the left pane, and then click Remove from Collection. If the DataStore is 
associated with an existing collection configuration, the utility removes the DataStore from 
the collection. 

Modifying Collection Configuration

To modify an existing collection configuration: 

1 In the left pane, click the collection configuration that you want to modify.

2 In the right pane, right-click the collection configuration block or any other component 
block to edit.

3 After making changes, click File → Save.

If you create a new DataStore and generate a spec file by using the PowerShell collection 
configuration utility, ensure that the spec file is made available at the instrumentation 
directory of the managed node. This can be done by saving the spec file in Instrumentation 
Category folder of the Microsoft Exchange SPI. Save the spec file in 
%ovsharedir%\Instrumentation\Categories\Exchange2k7_Core on the HPOM 
Server. Then deploy the Exchange2k7_Core category on the node. After this launch the 
Create Data Source tool on that node to add the datastore. Launch the Create Data Source 
tool on the nodes before you deploy the EXSPI-8X SPIMetaData Versioning policy.

Do not modify the existing default collection configurations. You can modify a collection 
configuration that you have added. 
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Do not delete any default collection configuration that is present in the EXSPI Configuration 
Utility. To delete a collection configuration that you have added to the EXSPI Configuration 
Utility, right-click the collection in the left pane, and then click Remove Collection. 

Using Additional Cmdlets

You can create customized cmdlets and use those cmdlets to monitor metric data on a 
managed node. You can create customized cmdlets to return additional metrics, and configure 
the Microsoft Exchange SPI to monitor these additional metrics. Perform the following tasks 
to achieve this:

Task 1: Identify the Microsoft Exchange Server 2007 Node

Identify the Microsoft Exchange Server 2007 node on which you want to add customized 
cmdlets to observe additional metric data.

Task 2: Create Cmdlets

Create customized cmdlets on the identified nodes.

Task 3: Install Snap-ins

Install customized snap-ins for the newly created cmdlets on the nodes on which you have 
created new cmdlets.

Task 4: Update the Exspi-exshell.psc1 File

To update the Exspi-exshell.psc1 file with the new snap-in information, perform these 
steps:

1 Open the Exspi-exshell.psc1 file by using a text editor from the location 
%OvAgentDir%/bin/instrumentation.

2 Add the following within the PSSnapin tag:

<PSSnapIn Name="new_snap-in_name" />

where new_snap-in_name is the name of newly added snap-in.

3 Save the file.

Task 5: Create New Collection Definitions for New Cmdlets

Use the EXSPI Collection Configuration utility and create new collections with the newly 
added cmdlets. While creating the new collection configuration, note the command displayed 
in the Schedule Task Policy Command text box.

Task 6: Create a New Scheduled Task Policy

After creating a new collection configuration, perform these steps:

1 Create a new scheduled task policy.

2 In the newly created scheduled task policy, specify the command as mentioned in Task 5.

Perform this change on the managed node where the snapin is installed. If the snapin is 
installed on all managed nodes then the Exspi-exshell.psc1 can be updated at the 
management server itself.
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Task 7: Deploy the EXSPI-8X SPIMetaData Versioning Policy on Nodes

Deploy the EXSPI-8X SPIMetaData Versioning policy on the nodes where you have created 
the new cmdlets.

Task 8: Deploy the Scheduled Task Policy

Deploy the created scheduled task policy on the nodes where you have created the new 
cmdlets.

Configuring Microsoft Exchange SPI for Exchange Server Cluster 
Environment

You can use Microsoft Exchange Server 2007 in a cluster environment where the fail-over 
capability of Exchange Servers ensures uninterrupted Exchange availability. In the event of a 
cluster node failure, the Microsoft Exchange SPI automatically switches monitoring activity 
from the failed node to the active node.

The Microsoft Exchange SPI recognizes Exchange instances in an Exchange cluster by using 
XML configuration files (apminfo.xml and msexchange.apm.xml). In the event of failure, 
these XML files enable the HP Operations agent to automatically perform the following 
functions:

• Disable instance monitoring on the inactive node

• Enable instance monitoring on the currently active node

To configure the Microsoft Exchange SPI for a cluster environment, perform the following 
tasks in the order given. 

Task 1: Add the Exchange Cluster Nodes to HPOM Console

Identify the cluster nodes of your Exchange environment, and then add those nodes to HPOM 
console.

If policy auto deployment is disabled, you must launch the necessary polices on newly added 
cluster nodes.

Edit the Discovery policy to run it with the special user privileges. Deploy the policy groups 
depending on the Server role hosted by the managed node. See Edit Discovery Policy on 
page 49 (Table 3) for the specific policy group.

The discovery policy discovers the Microsoft Exchange cluster and updates the map with 
cluster topology. 

Task 2: Generate Cluster Application Configuration File

You must generate the apminfo.xml file to describe the cluster instances (Exchange virtual 
servers). For this, start the Cluster Configuration tool:

1 Expand Tools → SPI for Exchange → Exchange 2007.
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2 In the details pane, double-click Exchange Cluster Configuration. The Select where to 
launch this tool dialog box opens.
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3 Click Launch.... The tool Status window appears and displays the output under the Tool 
Output section.

4 Remove any content above <?xml version=”1.0”?>.

5 Select the text content under the Tool Output section, and then copy it to a text editor.

6 Save the text as apminfo.xml in the %OvAgentDir%\conf\conf\ location on cluster 
nodes.

7 Stop and start the agents on the nodes by using the following commands:

opcagt -kill
opcagt -start

Example apminfo.xml File

In the following example, aspivm6 is the names of the Exchange resource groups 
corresponding to the aspivm6 instance (virtual server):

<?xml version="1.0" ?>
<APMClusterConfiguration>

  <Application>

    <Name>msexchange</Name>

Before copying the apminfo.xml file, you must manually create the  
%OvAgentDir%\conf\conf\ folder if it does not exist.
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    <Instance>

      <Name>ASPIVM6</Name>

      <Package>aspivm6</Package>

    </Instance>

  </Application>

</APMClusterConfiguration>

Figure 9 Example of Exchange Resource Group

Task 3: Copy the Cluster-Aware Policy XML File

Perform the following steps:

1 Deploy the SPI for Exchange instrumentation on the node.

2 Create the \conf\ folder under %OvAgentDir%\bin\instrumentation\.

3 Copy the msexchange.apm.xml file from the %OvAgentDir%\bin\instrumentation\ 
folder to  %OvAgentDir%\bin\instrumentation\conf\.

4 Restart the agent.

5 Repeat step 1through step 4 for all the Exchange nodes.

Additional Configuration for Policy Name Change

The Microsoft Exchange SPI disables all polices from a cluster node if the node fails, and then 
enables all polices on the active cluster node. While switching its operation from disabled node 
to active node, the Microsoft Exchange SPI retrieves policy information from the 
msexchange.apm.xml file. If you change any policy name (or add a new policy) and deploy 

Make sure to deploy the policy EXSPI-8X Exchange Cluster Discovery SysLog on Windows 
Server 2003 cluster nodes and the policy EXSPI-8X Exchange Cluster Discovery AppLog 2K8 
on Windows Server 2008 cluster nodes, to handle failovers.
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the changed policy on a managed cluster node, you must reflect the change in the 
msexchange.apm.xml file as well. To update the msexchange.apm.xml file with changed 
policy information, follow these steps:

1 On the management server, open the msexchange.apm.xml file from the 
%OvShareDir%\Instrumentation\Categories\SPI for 
Exchange\Windows\6.0\X64 location by using a text editor.

2 Edit the changed policy names in this file. Add new policy names (within the Template 
markup), if required.

3 For the managed nodes, follow these steps:

a Redeploy the SPI for Exchange instrumentation on the node.

b Create the \conf\ folder under %OvAgentDir%\bin\instrumentation\.

c Copy the msexchange.apm.xml file from the 
%OvAgentDir%\bin\instrumentation\ folder to  
%OvAgentDir%\bin\instrumentation\conf\.

d Restart the agent.

e Repeat step a through step d for all nodes.

While redeploying the instrumentation on Microsoft Exchange Server 2007 nodes, see Assign 
Instrumentation Categories to Exchange Nodes and Deploy Configuration.

Map View for Exchange Cluster Services

The Microsoft Exchange SPI represents Exchange clusters in the map view. Map view creates 
one node for each virtual server in the cluster. Because the cluster is properly modeled in the 
service map, Microsoft Exchange SPI instrumentation and Quick Start polices are 
auto-deployed to all managed Exchange cluster nodes.

Messages for the Exchange virtual server show up under the Exchange virtual server name in 
the maps.

For the Exchange Virtual server an EXSPI service discovery hosted-on hierarchy is created 
within a Clusters container. This allows messages to be sent to the hosted-on hierarchy. 

This same hierarchy is also created as virtual nodes under the Exchange Virtual Server. A 
dependency is created from each Virtual Exchange Server virtual node to its corresponding 
Cluster hosted-on node. Messages and status will then propagate to the correct Virtual 
Exchange Server virtual node.
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Figure 10 Service Map in Clustered Environment 

When a fail-over happens, dependencies to the failed node will be removed and replaced with 
new dependencies to the newly active node.

When a failover happens, messages that occurred before the failover will not be propagated to 
the virtual node.
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4 Using Policies
Policies monitor the Microsoft Exchange 2007 Server environment and run according to rules 
and schedule specifications. Scheduled Tasks policies contain the rules for interpreting 
Microsoft Exchange Server 2007 states or conditions. The SPI for Microsoft Exchange 
Reference Guide provides the description of all Microsoft Exchange SPI policies.

Policy Group and Policy Type

The policies of the Microsoft Exchange SPI in the HPOM console are available in two ways—
policy group and policy type.

Policy Group

A policy group organizes policies according to the deployment method and area to be targeted 
for discovery or monitoring. Deployment in Microsoft Exchange SPI is manual. To view the 
manually deployed policies in the Microsoft Exchange SPI, click Policy Bank → SPI for 
Exchange → Exchange 2007 → Manual Deploy Groups.

The policies are displayed in each sub-groups of the Microsoft Exchange SPI. 

To customize policies, see Customize Policies on page 45.
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The Microsoft Exchange SPI has the following policy groups depending on the Exchange 
server roles:

• Availability

• Client Access Server

• Collector Definition

• Discovery

• Edge Server

• ExBPA Integration

• Hub Transport Server

• Mailbox Server

• Unified Messaging Server

Policy Type

Agent policies grouped by type organize policies according to type. The Microsoft Exchange 
SPI has the following policy types:

• Service Auto-Discovery

• Scheduled Task

• Measurement Threshold

• Windows Event Log

• Windows Management Interface

• ConfigFile

• Open Message Interface

• LogFile Entry

To know the policies in each policy group and their policy type in detail, see HP Operations 
Smart Plug-in for Microsoft Exchange Reference Guide. 
90 Chapter 4



5 Using Tools
The Microsoft Exchange SPI uses different tools to monitor the Microsoft Exchange Server 
2007 environment. For more information on the functioning of the tools, see the HP 
Operations Smart Plug-in for Microsoft Exchange Server Reference Guide. 
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Starting Microsoft Exchange SPI Tools

You must start the tool from the operator GUI. To start a tool:

1 Right-click the node where the tool need to be started.

2 Select Start → SPI for Exchange → Create Data Sources (example). 

3 A message “Tool Started. Please wait.” indicates the start of the selected tool.
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HP Operations Topology Viewer

The HP Operations Topology Viewer provides a quick means to seeing an Exchange 
environment, providing a hierarchical view in a tree (left pane), and a topological view in a 
map (right pane). The left pane shows the organization/admin groups/Microsoft Exchange 
servers/connectors/routing groups components, while the map in the right pane graphically 
represents servers/routing groups/connectors links and connections. 

After you launch the HP Operations Topology Viewer and enter domain controller access 
information, the tool gathers data from the domain controller and Microsoft Exchange 
servers. From this information a map is created, displaying servers, connectors, and routing 
groups. 

In the Topology Viewer window right pane, the map initially shows Routing group connectors, 
external mail connectors. You can display the server labels and modify the display by selecting 
View → Properties. The Properties page allows you many options for how to display the map: 
you can show or hide connectors between routing groups, server labels and roles, DC Roles. 

Using the HP Operations Topology Viewer

After you complete steps mentioned to connect to a Microsoft Active Directory domain 
controller, the Topology Viewer tool can gather information. This information is organized into 
a tree, showing Microsoft Exchange Server components on the left and a map graphically 
representing the Microsoft Exchange Server organization on the right.

You can modify the default display by using the View menu and selecting Properties.... The 
Properties page has three tabbed pages that show additional information and allow you to 
change the display (Visibility and Colors and Lines).

To start the Topology Viewer: 

1 Copy the file on a 32-bit Windows system which is located in: 

<INSTALLDIR>/install/EXSPI/ovtv.zip 

2 Extract the OVTV.zip. 

3 Double-click on OVTV-Console.msi. 

4 Browse to C:\Program Files\HP\HP BTO 
Software\install\ADSPI-Console\InstallScripts and double-click 
postinstall-console.vbs. This registers the required DLLs.

5 Browse to C:\Program Files\HP OpenView\bin\OVTV and double-click ovtv.exe to 
start using OVTV. 

The Topology Viewer provides a view that reflects the Active Directory site/server replication 
information/Exchange organization information at the time you connect to a server. The view 
remains static until you refresh it. To update the view, select from the menu 
File → Refresh Data. The map is then updated.

If the logged-in user account has proper access to the DC to which you are attempting to 
connect, no alternate credentials are necessary. 
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HP Operations Topology Viewer Toolbar

The following table lists the HP Operations Topology Viewer toolbar functions and the icons. 
HP Operations Topology Viewer Toolbar

Icon Function

Starts a new file, which appears as 
an empty grid; you can then click the 
Add Forest button to populate the 
empty view. The "New" button allows 
you to transition to a new view (for 
example, an Add a Forest), 
without adding to or changing the 
current view if the current view has 
been saved.

Allows you to open a file of a 
previously saved view.

Saves the current view to a file.

Exports the current view and saves it 
to a graphic format of your choice, 
such as .png or .bmp. (The default 
format is .png.

Allows you to add a forest by opening 
the Add Forest dialog, where you 
enter server connection information.

Refreshes the data by checking 
information on the current 
connection.

Zooms out the map view to the 
maximum degree.

Zooms out the map view 
incrementally.

Resets the map view to the default.

Zooms in the map view 
incrementally.

Zooms in the map view to the 
maximum degree.
94 Chapter 5



HP Operations Topology Viewer Menus

The following table lists the HP Operations Topology Viewer menu commands.

Shows the next available top-level 
view in the forest.

Displays the navigator, which shows 
a thumbnail of the entire map, 
surrounding the area of focus with a 
blue square. You can change the map 
focus by repositioning the blue 
square in the Navigator.

Displays the Topology Viewer online 
Help.

Icon Function
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Table 6 HP Operations Topology Viewer Menus

Menu Command Function

File New... Opens a new file (empty 
grid); allows you to 
transition from the 
current view to a new 
view.

Open... Opens a selected, saved 
file that shows the 
layout as it was saved.

Save Saves the layout as the 
default layout.

Save as... Saves the layout to a file 
so that you can load it 
when desired.

Export View... Saves the currently 
displayed map in a 
graphical format of your 
choice.

Add Forest... Opens the Add Forest 
dialog, where successful 
connection to a 
server generates the 
replicated information 
within that forest and 
displays the 
information in the HP 
Operations Topology 
Viewer tree and map.

Refresh Data Reconnects to the server 
and updates the view 
with changes, if any, 
since the last 
connection.
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View Zoom Allows you to zoom-in 
closer for greatest 
magnification or 
zoom-out farther for 
overall view. Minimum 
is at greatest degree 
zoomed out. Maximum 
is at greatest degree 
zoomed in.

Next View Shows the next view 
available in the right 
pane. 

Navigator Shows a thumbnail of 
the entire map 
(including any area 
outside the current 
display) with a blue box 
indicating the current 
visible display.

Legend Displays the legend, 
which explains the 
meaning of the symbols 
used in the map located 
next to each server.

Clear Find When enabled, means 
that a server or site in 
the tree or the map has 
been right-clicked and 
Find in View or Find in 
Tree selected, 
resulting in selecting 
the corresponding item; 
clicking Clear Find 
returns the display to its 
default status with no 
elements selected.

Menu Command Function
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View Toolbar Toggles on/off the 
display of the Topology 
Viewer toolbar buttons.

Status Bar Toggles on/off the 
display of the Topology 
Viewer status bar 
(located at the bottom of 
the Topology Viewer 
window).

Properties... Opens the Site Topology 
Properties dialog, which 
allows you to hide/show 
elements in the map and 
to modify the map 
appearance.

Window Title Page Displays the HP 
Operations Topology 
Viewer title page. 

Site Topology Displays the Active 
Directory topology of the 
current forest.

Exchange Topology Displays the Exchange 
messaging view (with 
routing groups) of the 
current forest.

Help HP Operations Topology 
Viewer Help

Displays online Help for 
HP Operations Topology 
Viewer.

About HP Operations 
Topology Viewer...

Displays the HP 
Operations Topology 
Viewer version number.

Menu Command Function
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HP Operations Topology Viewer Map

Map connection lines labels: You can choose which connection lines to display and whether to 
display server, routing group, and external mail connector labels by right-clicking the map, 
selecting View → Properties.... In the Exchange Topology View Properties page, select the 
Colors and Lines tabbed page. The connections are represented in default colors as follows: 

• Routing Group (Represented in green): This acts as a connector that connects one routing 
group to the other logically. The Routing Group shows a logical routing of mail within the 
organization 

• External Mail Connectors (Represented in blue): This represents the different send 
connectors which are configured in an organization having a Microsoft Exchange setup. 
An external connector shows the logical connection between a source server and a 
destination server. These connectors describe the way the nodes are running in a 
Microsoft Exchange 2007 environment and how the nodes which have the Edge Transport 
server or the Hub Transport server installed communicate: 

— With each other 

— With the Internet 

— With servers that are running Exchange 2000 or Exchange 2003 

— With other messaging systems 

The Send connectors send outbound messages. To enable communication, set one or more 
source servers on a Send connector. The source servers act as transport servers which are 
responsible to handle message delivery along with that connector. When a Microsoft 
Exchange Server 2007 receives messages for a remote destination, they are sent to the 
source server of a Send connector. This Send connector is configured to send the e-mail to 
the destination domain. Send connectors are not applied to a single source.

• Routing Groups (Represented in green): This represents the logical grouping of different 
components which play a role a routing a message to the recipients. These components 
control the flow of the messages between various servers like Hub Transport servers, 
Edge Transport servers, servers which are running on Microsoft Exchange 2000 or 2003, 
and other SMTP servers. You can control the flow of the messages between these servers 
by configuring the settings of these components.

The Topology Viewer provides a view that reflects the Active Directory site/server replication 
information/Exchange organization information at the time you connect to a server. The view 
remains static until you refresh it. To update the view, select from the menu 
File → Refresh Data. The map is then updated.
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6 Integrating Microsoft Exchange SPI with HP 
Reporting and Graphing Solutions
Reports and graphs provide you with a complete view of the performance of the components of 
the Microsoft Exchange Server 2007.

Using Reports and Graphs

Report- and graph-generating templates are installed after you install the Microsoft 
Exchange SPI. They cover updates on the availability or the activity or both in Microsoft 
Exchange Server 2007 such as SMTP, MTA, processes for activity and status, and IS Public or 
Private Mailbox. 

Integrating Microsoft Exchange SPI with HP Reporter

You must install EXSPI Reporter package on HP Reporter Server to use the Microsoft 
Exchange SPI reports. For this, run the EXSPI-Reporter.msi setup. This setup installs the 
Microsoft Exchange SPI Report Package within the Reporter server. After you complete the 
installation, configure the Reporter to generate reports. See Figure 11.

Time Interval for Exchange SPI Reports or Graphs

The Microsoft Exchange SPI reports and graphs are not available until data has been 
gathered to the management server from the managed nodes. This occurs each night, so at 
least one day of activity is needed for the reports to populate. Where a report or graph type 
requires data from a Sat/Sun collection, those reports or graphs or both require a weekend to 
pass.
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Figure 11 EXSPI Reporter 

Installing and/or Upgrading Report Package

To install and/or upgrade the Microsoft Exchange SPI Report Package on a stand-alone 
Reporter server:

1 Insert the HP Operations Smart Plug-ins DVD.

2 Browse to the folder <SPIDVD>/WINDOWS/OV_REPORTER/EXCHANGE_SPI.

3 Double-click the file EXSPI-Reporter.msi. Follow the instructions as they appear. 

4 Click Finish to complete the installation.

Configuring Report Package

To configure the Microsoft Exchange SPI Report Package:

1 Open the Reporter main window and check the status pane to note the changes to the 
Reporter configuration, which include uploading the Microsoft Exchange SPI reports.

The Microsoft Exchange SPI Reports are automatically assigned to the ALL group in the 
Reporter main window. (See for HPOM Report list.) 

2 Add group and single system reports by assigning reports as desired. 

Complete the steps mentioned in step 6 on page 26 in Upgrading Microsoft Exchange SPI on 
a Standalone HPOM for UNIX 9.0x Server on page 26 before installing the Report package.
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Reports are available for viewing the following day.

Instructions are available in the HP Reporter Help for assigning Microsoft Exchange SPI 
reports to the targeted nodes. To access Help, select Reports or Discovered Systems in the left 
panel of the HP Reporter main window and right-click it. Select Report Help or Discovered 
Systems Help from the sub-menu that appears. See the topic “To assign a report definition to a 
Discovered Systems Group.” Reporter also includes two online documents: the Concepts Guide 
and the Installation/Special Configurations Guide for further information.

Generating Reports

After you install the Microsoft Exchange SPI, the HPOM generates reports using the 
SPI-collected data for Microsoft Exchange Server 2007. HPOM runs the reports regularly on a 
nightly schedule. You can see the updated reports every day because the HPOM, by default, 
re-generates reports every night with the day’s data.

The report data of Microsoft Exchange SPI is collected based on metrics used for each report. 
The HP Reporter identifies the data through metric variables. This data is stored in the MS 
SQL Reporter database. 

You can access the reports of Microsoft Exchange SPI from the Reports area of the HPOM 
console. You can find complete description of all the reports in Microsoft Exchange SPI Online 
Help. Figure 12 shows reports being generated.

Identify the Microsoft Exchange SPI reports of group and single systems by 
their full name; for example, abc.xyz.com is acceptable while abc is not.

If you want to customize your reports you must install HP Reporter. The documentation on 
HP Reporter on modifying the reports is available in Concepts Guide, Installation Guide and 
Special Configuration Guide, Online Help, and Release Notes.
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Figure 12 Generating Reports 

Integrating Microsoft Exchange SPI with HP Performance 
Manager

The Microsoft Exchange SPI comes with a set of preconfigured graph templates. Ensure that 
these graph templates are installed on an HP Performance Manager system, and that the 
data store (CODA or HP Performance Agent) runs on the managed node.

To integrate the Microsoft Exchange SPI with HP Performance Manager, follow these steps:

1 Install and configure the Microsoft Exchange SPI.

2 Install the graph package.

On a Windows system that has HP Performance Manager, follow these steps:

a Insert the Smart Plug-ins DVD-ROM (that contains the graph packages) into the 
DVD-ROM drive, and in Windows Explorer, double-click 
\WINDOWS\OV_PM\EXCHANGE_SPI\HPOvSpiExGc.msi.

For information see the HP Performance Manager documentation. 
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Generating Graphs

You can generate the Microsoft Exchange SPI graphs on OVPM on a stand-alone Windows 
Server. 

Figure 13 Generating Graphs

 

Few messages that arrive at the message browser have operator-initiated actions to launch 
graphs. Ensure to configure HP Operations Manager for UNIX 9 server to use a HP 
Performance Manager server to view the graphs.

Execute the following command on HP Operations Manager for UNIX 9 server to use the HP 
Performance Manager server to view the graphs:

/opt/OV/contrib/OpC/OVPM/install_OVPM.sh <new OVPM server>:8081
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7 Troubleshooting
This chapter includes troubleshooting some areas of the Microsoft Exchange SPI and provides 
solutions thereof. The methods described may or may not require support assistance.

Troubleshooting Discovery

The following sections describe the possible cause and suggested action for the failed 
discovery of the Microsoft Exchange Server services.

Insufficient Privileges 

In some cases the Microsoft Exchange SPI fails to discover the Microsoft Exchange Server 
services. The possible cause and suggested action is as follows:

• Possible cause: The account with which the Discovery policy (Policy Management → Policy 
Groups  → SPI for Exchange → en (ja) → Exchange 2007 → Manual Deploy Groups  → 
Discovery) is run by the HP Operations Agent does not have the privileges to connect to 
the Microsoft Exchange Server and retrieve data. 

• Suggested action: Ensure that an administrator credentials are provided in the Discovery 
policy and then redeploy the policy.

Failed Binary on the Managed Node 

In some cases the HP Operations Agent fails to update the discovered services to the HPOM 
management server. The possible cause and suggested action is as follows:

• Possible cause: The output of the Microsoft Exchange SPI discovery policy is not a properly 
formatted xml file. 

• Suggested action: Run the Microsoft Exchange SPI discovery binary on the managed node. 
To do this:

a Login to the managed node as an administrator.

b From the command prompt, open the instrumentation directory.

c Run the Exchange_discovery.exe > out.xml command.

d Check the out.xml is in the required xml format by opening it in the web browser.
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Discovery Binary times-out on Managed Node

Sometimes, the Microsoft Exchange SPI discovery binary takes a lot of time to complete. In 
such cases, the discovery agent (agtrep) forcefully terminates the Microsoft Exchange SPI 
discovery binary before it completes. This causes the Microsoft Exchange SPI discovery 
failure.

You can identify the Microsoft Exchange SPI discovery binary termination by agtrep through 
the following statements in the System.txt of the managed node:

• 0: ERR: Thu Nov 12 10:52:01 2009: agtrep (4732/5412): (agtrep-151) Timeout 
occurred when executing action "C:\Windows\system32\cmd.exe /C ""C:/
ProgramData/HP/HP BTO Software/bin/instrumentation/
Exchange_Discovery.exe""" - will be terminated.

• 0: ERR: Thu Nov 12 10:52:01 2009: agtrep (4732/5412): (agtrep-133) No 
output received from discovery policy action

The possible cause and suggested action for discovery failure are as follows:

• Probable cause: The Microsoft Exchange SPI discovery binary does not complete within 
the ACTION_TIMEOUT period of agtrep.

• Suggested Action: Increase the ACTION_TIMEOUT of agtrep to give sufficient time for 
the Microsoft Exchange SPI discovery binary to complete.

To increase ACTION_TIMEOUT of agtrep:

a Open the command prompt on managed node.

b Run the command ovconfchg -edit to edit the agent configuration file. The default 
value is ACTION_TIMEOUT=3

c Increase the value of the ACTION_TIMEOUT. For Example, ACTION_TIMEOUT=10

d Save and close the file.

e Re-run the Microsoft Exchange SPI discovery.

Troubleshooting through Tracing 

With the help of the EXSPI Trace tool, you can obtain troubleshooting information from 
managed nodes. The Microsoft Exchange SPI stores the troubleshooting information as trace 
files in the %OvDataDir%\bin\exspi\log location on a managed node.

This tool enables you to set two trace levels:

• <T1Value> specifies trace level for Scheduler and Collector Server. The value is either 0 or 
1.

• <T2Value> specifies trace level for power shell script file. The value ranges from 0 to 2, 
where 2 is the maximum possible value.

To launch the EXSPI Trace tool on a managed node, perform the following steps: 

1 In the console tree, expand Tools → SPI for Exchange, and then double-click Exchange 2007.

Each trace statement proceeds with a unique ID to distinguish between the different 
instances of the same collection which run simultaneously.
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2 In the details pane, double-click EXSPI Trace. The Select where to launch this tool dialog 
box opens.

3 Select a node, and then click Launch. The Edit Parameters dialog box opens. The Edit 
Parameters box contains values as -T1 0 -T2 0. You can replace the value with 0. For -T1 
replace with 0 or 1 while with -T2 replace the value with 0, 1, or 2. This sets the trace 
value. 

4 Click Launch. 

Troubleshooting Reports and Graphs 

The following sections describe the possible cause and suggested action for the failed 
generation of data in Microsoft Exchange SPI reports and graphs.

Reports and Graphs are not generated

In some cases, the reports and graphs are not generated. The possible cause and suggested 
action are as follows: 

• Possible cause: The appropriate policies are not deployed to the respective Microsoft 
Exchange SPI reports and graphs. The policy, therefore, fails to collect the data which the 
HP Reporter generates as report. Failure to deploy the appropriate policy also disables the 
HP PM to generate graphs.
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• Suggested action: See Appendix B Report, Report Table, Data Store, and Policy Mapping 
Details in HP Operations Smart Plug-in for Microsoft Exchange Server Reference Guide to 
know the appropriate policy for each Microsoft Exchange SPI report. See also Graphs, 
Data Store, and Policy Mapping Details in HP Operations Smart Plug-in for Microsoft 
Exchange Server Reference Guide to know the appropriate policy for each Microsoft 
Exchange SPI. Deploy the policy accordingly.

For more details on troubleshooting Microsoft Exchange SPI reports and specific reports, see 
Troubleshooting Microsoft Exchange SPI Reports in HP Operations Smart Plug-in for 
Microsoft Exchange Server 2007 Reference Guide.

Data Logging Policies cannot log Data 

In some cases the data logging policies cannot log data. The possible cause and the suggested 
action are as follows:

• Possible cause: The data source is not created in the datastores—CODA or OVPA or both.

• Suggested action: Check if the datasource EX2007_DATA is created. To do this:

a Login to the managed node as an administrator.

b From the command prompt run the ovcodautil -obj > out.txt command.

c Check the out.txt file to ensure that the datasource EX2007_DATA is created.

Browser Crashes while Viewing the HTML Report

While viewing the reports in HTML format, the browser crashes. The possible cause and the 
suggested action are as follows:

• Possible cause: The browser cannot handle huge amount of data.

• Suggested action: View the reports in PDF format.

Reports Fail with Oracle Database

Some of the reports fail due to invalid Reporter ODBC driver. 

• Possible cause: The versions of Oracle client to access Oracle database do not match.

• Suggested action: Use Oracle client 9.2.0 to access Oracle 9.2.0 database and 10gR2 client 
to access 10gR2 database.

Modifying Policy Names 

If you change the default name of the following Microsoft Exchange SPI policies, ensure to 
change the SPIMetaDataxml also:

• EXSPI-8X_ReplicationCopyQueueLength

• EXSPI-8X_ReplicationReplayQueueLength

• EXSPI-8X-HubMonitorBlockedMails

• EXSPI-8X-EdgeMonitorBlockedMails
110 Chapter 7



8 Removing Microsoft Exchange SPI
To uninstall the Microsoft Exchange SPI you must first remove all the existing policies and 
Instrumentation from all the managed nodes. Then you can uninstall the Microsoft Exchange 
SPI from the management server.

Removing Microsoft Exchange SPI from HPOM Management 
Server

To uninstall the Microsoft Exchange SPI on the HPOM management server from the 
command line interface, execute the following commands:

1 For an HP-UX 11.11 management server:

swremove EXSPI

2 For a Solaris management server:

pkgremove EXSPI

The installer removes Microsoft Exchange SPI on the management server.

Removing Other Components of Microsoft Exchange SPI

Remove other component, that is, message group, user profile, report and graph package.

Removing Microsoft Exchange SPI Message Group

To remove the EXSPI message groups - EXSPI_2007 and EXSPI_2007_Errors:

1 Click Browse →All Message Groups. All the existing message groups are displayed.

2 Select the EXSPI_2007 and EXSPI_2007_Errors message groups check box. 

3 From the drop down list, select Delete and click  to delete the ADSPI message group.

Undeploy all Microsoft Exchange SPI policies from all managed nodes before uninstalling.
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Removing All User Profiles

To remove the user profile:

1 Click Browse →All Message Groups. All the existing message groups are displayed.

2 Select the appropriate user profile check box. 

3 From the drop down list, select Delete and click  to delete the user profile.

Removing Report Package

The Reporter Package can be uninstalled either through Control Panel or through msi file.

To uninstall the Report Package through Control Panel:

1 Click Start → Control Panel.

2 Click Add or Remove Programs from the Pick a Category list.

3 Click Remove and Yes to confirm the uninstallation.

Removing Graph Package

The Graph Package can be uninstalled either through Control Panel or through msi file.

To uninstall the Graph Package through Control Panel:

1 Click Start → Control Panel.

2 Click Add or Remove Programs from the Pick a Category list.

3 Click Remove and Yes to confirm the uninstallation.

Removing Reporting and Graphing Package using .msi File

You can also remove the reporting and graphing package by using .msi file.

Removing Reporting Package using .msi file

To remove the reporting package using .msi file, perform the following steps:

1 Browse to:

<SPI DVD>\SPIs\Exchange SPI Reporter Package\EXSPI-Reporter.msi

2 Right-click EXSPI-Reporter.msi, and then click Uninstall.

3 Confirm the removal of the reporting package by clicking Yes.

Removing Graphing Package using .msi File

To remove the graphing package using the .msi file, perform the following steps:

1 Browse to:
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<SPI DVD>\SPIs\EX SPI OVPM ConfigurationPackage\HPOvSpiExGc.msi

2 Right-click HPOvSpiExGc.msi, and then click Uninstall. 

3 Confirm the removal of the graphing package by clicking Yes.
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A List of Microsoft Exchange SPI Instrumentation 
Files
Appendix A provides instrumentation category details of the Microsoft Exchange SPI in the 
following tables.

Exchange2k7_Collector

Table 7 Instrumentation Category Details - Exchange2k7_Collector

Exchange 2k7_Core 

Table 8 Instrumentation Category Details - Exchange 2k7_Core

Category Description 

HP.OV.SPI.ExCollectorServ
er.exe

Daemon which runs on the node and starts 
the powershell script (exspi2007.ps1) for each 
collection. 

HP.OV.SPI.ExCollectorServ
er.exe.config

Configuration file for 
HP.OV.SPI.ExCollectorServer.exe

HP.OV.SPI.EXCustomCmdl
ets.dll

Defines the Microsoft Exchange SPI custom 
cmdlets

exspi2007.ps1 PowerShell script which formulates and 
executes the Microsoft Exchange cmdlets and 
logs data or sends alerts, or does both. 

Category Description

HP.OV.SPI.ExspiTraceUtil.e
xe

Sets the trace levels for the scheduler and the 
collector server.

HP.OV.SPI.ExScheduler.exe Requests the collector server to launch a 
collection with the required parameters.

HP.OV.SPI.ExScheduler.exe.
config

Configuration file for 
HP.OV.SPI.ExScheduler.exe

HP.OV.SPI.Terminator.exe Stops the collector server

HP.OV.SPI.ExBPASchedule
r.exe

Calls the ExBPA (Exchange Best Practices 
Analyzer) command line utility

CheckServiceState.exe Returns the state of a particular service

exspidatasource.exe Creates the datasource for Microsoft 
Exchange SPI and sets certain registry 
entries which are                                                 
utilized by the collector server.
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EX2007_AVAILABILITY.sp
ec

Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
Ex2007_AVAILABILITY

ex2007_attachfilter.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_attachfilter

ex2007_connfilter.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_connfilter

ex2007_contfilter.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_contfilter

ex2007_hubtransdsn.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_hubtransdsn

ex2007_recpfilter.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_recpfilter

ex2007_senderid.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_senderid

ex2007_sendfilter.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_sendfilter

ex2007_prtagt.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_prtagt

ex2007_fdsoab.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_fdsoab

ex2007_fdsum.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_fdsum

ex2007_isperf.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_isperf

ex2007_mbsummary.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_mbsummary

ex2007_pfsummary.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_pfsummary

Category Description
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ex2007_mbdetail.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_mbdetail

ex2007_pfdetail.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_pfdetail

ex2007_isclient.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_isclient

ex2007_umipgway.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umipgway

ex2007_pfperf.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_pfperf

ex2007_pop3perf.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_pop3perf

ex2007_mbperf.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_mbperf

ex2007_umhunt.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umhunt

ex2007_ummbox.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_ummbox

ex2007_imap4perf.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_imap4perf

ex2007_replsumm.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_replsumm

ex2007_umpin.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umpin

ex2007_smtprecv.spec Specifies the column names and data types 
for the EXSPI dataclass ex2007_smtprecv

ex2007_umsrv.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umsrv

Category Description
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ex2007_qinfo.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_qinfo

ex2007_smtpsend.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_smtpsend

ex2007_agcfg.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_agcfg

ex2007_umplcy.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umplcy

EX2007_DEST.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
EX2007_DEST

EX2007_RECP.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
EX2007_RECP

EX2007_SENDER.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
EX2007_SENDER

EX2007_SOURCE.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
EX2007_SOURCE

ex2007_transq.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_transq

ex2007_umautoattendent.sp
ec

Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umautoattendent

ex2007_umavailability.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umavailability

ex2007_umcallanswer.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umcallanswer

ex2007_umfax.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umfax

ex2007_umgeneral.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umgeneral

Category Description
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ex2007_umsubaccess.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_umsubaccess

ex2007_blockedmails.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_blockedmails

ex2007_blockedrcpts.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_blockedrcpts

ex2007_spamstats.spec Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
ex2007_spamstats

ex2007_MailFlowLatency.sp
ec

Specifies the column names and data types 
for the Microsoft Exchange SPI dataclass 
EX2007_MFLAT

CmdletCommands.xml Lists the datatypes of the properties of all the 
Microsoft Exchange cmdlets used in the 
Microsoft Exchange SPI.

spimetadata.xml Defines the various default and user-defined 
Microsoft Exchange SPI collections.

spi_msexch.xml Defines the various modes under which SHS 
collector can run.

spi_msexch_chkexch.vbs Checks the operating system and Microsoft 
Exchange server information for use by SHS 
collector.

spi_msexch.cmd Calls shs_collector.pl which launches the SHS 
collector.

spi_msexch_runSHSCollect
or.cmd

Used by the self-healing client to run the 
SHS collector.

spi_msexch_shs_install.xml Contains the Microsoft Exchange SPI 
installation folder details.

spi_msexch_shs_input.xml Contains the input parameters for 
spi_msexch.cmd

register.bat Registers HP.OV.SPI.EXCustomCmdllets.dll

Exspi_exshell.psc1 Defines the Microsoft Exchange SPI custom 
PS snap-in.

exbpa_wrapper.vbs Wrapper script which calls ExBPACmd.exe

Category Description
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Exchange2k7_Discovery

Table 9 Instrumentation Category Details - 
Exchange2k7_Discovery

exspi_e2k7_clust_config.js Generates the apminfo.xml file which 
describes the cluster instances

ovosysdetect_exspi.pl Checks whether the Microsoft Exchange SPI 
is installed 

license.vbs Checks the license validity of the Microsoft 
Exchange SPI

Category Description

Category Description 

interop.opcautolib.dll  dll used in the Microsoft Exchange SPI 
discovery

Exchange_Discovery.exe.con
fig

 Configuration file for 
Exchange_Discovery.exe

discoverresult.dll Used by Exchange_Discovery.exe to create 
the Microsoft Exchange SPI service discovery 
tree.

Exchange_Discovery.exe Discovers the Microsoft Exchange topology 
and services.

msexchange.apm.xml Contains the list of the Microsoft Exchange 
SPI policies that are to be disabled on a 
passive cluster node

ex2k7_rundiscovery.js Runs the Microsoft Exchange SPI discovery 
policy (Exchange 2007 Discovery) on a cluster 
node after a cluster failover happens.
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