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1 Overview

This chapter covers the following topics:

Performance Insight and NNM Events
Recent Enhancements

Folders and Reports

Options for Customizing Reports

Sources for Additional Information

Performance Insight and NNM Events

Performance Insight collects data from many sources, performs in-depth trend analysis,
maintains performance baselines, and provides users with convenient, web-based reporting.
Following is a partial list of product features:

Distributed architecture

Easy to scale (supports data collection from thousands of agents)
CODA/PA agent support

Multi-company security model

Data warehousing

Near Real Time reporting

Forecasting

Multiple aggregations (by day, week, month; by location, by customer)
Thresholding and alerting

Bottlenecks easy to spot; capacity trends easy to assess

Accurate and timely documentation for management

Network Node Manager 7.5x defines an event using the following attributes:

Category
Severity
Device
Device Type
Vendor

Customer



The NNM Event and Availability Report Pack uses a built-in datapipe to collect event and
downtime data from NNM. The report pack processes collected data (summarizations and
aggregations) and displays the results in report templates. Use the reports to:

e See whether availability for a particular device is improving or worsening

e See whether availability for a particular customer is improving or worsening
¢ Look at the distribution of alarms across alarm categories

e See the trend line for each alarm category

e Look at the distribution of severity levels

e See the trend line for each severity level

¢ Find out which devices are responsible for the majority of alarms in each alarm category

Recent Enhancements

The enhancements in version 1.40 are listed in the following table.

New in Version 1.40

Upgrade packages e NNM_Event_Upgrade_10_to_14 (RNS11-->RNS14.10 only)
e NNM_Event_Upgrade_12_to_14 (RNS13 --> RNS14.10 only)

Folders and Reports

When you install NNM Event and Availability, PI creates the NNM_Report directory. This
directory has two child directories:

e Availability

e Event

The Availability directory contains six reports:
e Detailed Availability

¢ Availability Forecast by Customer

e Availability Forecast by Vendor

e Availability SLA

e Detailed Availability on Station Level

e Detailed Availability on Node Level

The Event directory contains multiple subdirectories:
* General

e (Category

e Severity

e (Consolidated
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General (7)

The General directory contains:

Event Summary by Customer
Event Summary by Device Type
Event Summary by NNM Station
Event Summary by Vendor
Event Summary by Customer
Executive Summary by Vendor

Forecast by Category

Category (4)

The Category directory contains:

NNM Event Summary by Category and Device
NNM Event Summary by Category and Device Type
NNM Event Summary by Category and Severity
NNM Event Summary by Category and Vendor

Severity (4)

The Severity directory contains:

NNM Events by Severity and Category

NNM Event Summary by Severity and Device
NNM Event Summary by Severity and Device Type
NNM Event Summary by Severity and Vendor

Consolidated (5)

The Consolidated directory contains:

Overview

NNM Events by Category
NNM Events by Severity
Executive Summary by Category
Executive Summary by Severity

Hot Spot Report

i



Options for Customizing Reports

You can customize reports by importing customer names, by applying group filters, by editing
parameters (applying constraints), and by editing tables and graphs. While group filters
appeal to service providers, or any organization that wants to share reports with customers,
editing a table, graph, or parameter is something any user can do.

Group Filters
If you want to share reports with your customers, you have to configure PI to produce
customer-specific reports. Here is an overview of the steps involved:
e Use Common Property Tables to import customer names and device locations
e Create a group account for all the users affiliated with each customer
e Create a group filter for each group account

For more information about group filters, refer to the HP PI Administration Guide.

Editing Parameters

Editing a parameter applies a constraint to the reports. The constraint eliminates data you
are not interested in seeing. The NNM Event and Availability Report Pack supports the
following parameters:

e (Category

e Category ID

e Customer

e (Customer ID

e Device

e Device Type

e NNM Station

e Severity

e Severity ID

e Vendor

If you are using Report Viewer, follow these steps to edit a parameter:

1 Select Edit > Parameter Values from the menu bar.

2 When the Modify Parameter Values window appears, click the Current Value field.
3 Enter a new value.

4 Click OK.

If you are using the Web Access Server, follow these steps:

1 Click the Edit icon at the bottom right-hand corner of the report.

2 When the Edit Parameters window opens, type the constraint in the appropriate field.
3 Click Submit.
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Sources for Additional Information

Overview

The demo package for the NNM Event and Availability Report Pack contains a sample of every
report in the package. If you have access to the demo package and you want to see what fully
populated reports look like, install the demo package. For information regarding the latest
enhancements to this package, and any known issues affecting this package, refer to the NNM
Event and Availability Report Pack 1.40 Release Notes. You may also be interested in the
following documents:

e Common Property Tables User Guide

®  Reporting and Data Analysis with Network Node Manager

e  Managing Your Network with HP Software Network Node Manager

e NNM/Performance Insight Integration Guide

e PI Report Packs, CD-ROM Release Notes, September 2009

You can download the documents listed above from this site:
http:/h20230.www2.hp.com/selfsolve/manuals

The user guides for PI are listed under Performance Insight. The user guides for report packs
and datapipes are listed under Performance Insight Report Packs. Each user guide indicates a
date and if the manual is revised and reposted, the date will change. We post revised manuals
on a regular basis, so be sure to download the web edition if the web edition is more current
that your PDF.
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2 Upgrade Install

This chapter covers the following topics:
e  Guidelines for a Smooth Upgrade

e Upgrading to Version 1.40

e Package Removal

If you are installing the NNM Event and Availability Report Pack for the first time, this
chapter does not apply to you. See Chapter 3, The New Install.

Guidelines for a Smooth Upgrade

When you insert the report pack CD in the CD-ROM drive and launch the package extraction
program, the install script extracts every package from the CD and copies the results to the
Packages directory on your system. When the extract finishes, the install script prompts you
to launch Performance Insight and start Package Manager. Before running Package Manager,
review the following guidelines:

e  Prerequisites for the NNM Event and Availability Report Pack
e Upgrading Common Property Tables
e Upgrading NNM Event and Availability in a Distributed Environment

Prerequisites for the NNM Event and Availability Report Pack

Make sure the following software is installed before upgrading:
¢ Performance Insight 5.41

e All service packs available for PI 5.41

e Common Property Tables 3.91

Upgrading Common Property Tables

If you are running an older version of Common Property Tables, you must upgrade that
package to version 3.91 by installing the upgrade package
CommonPropertyTables_Upgrade_to_391. If you are not running any version of Common
Property Tables, Package Manager will install the latest version of Common Property Tables
for you, automatically.

Do not install an upgrade for Common Property Tables and other packages at the same time.
Install the upgrade package for Common Property Tables and only the upgrade package for
Common Property Tables. For more information about installing and using Common Property
Tables, refer to the Common Property Tables User Guide.
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Upgrading NNM Event and Availability in a Distributed Environment

Following is an overview of the upgrade procedure in a distributed environment:

1
2

Disable trendcopy on the central server.

For the central server:

e Upgrade to Common Property Tables 3.91; deploy reports

e Upgrade to NNM Event and Availability 1.40; deploy reports
For each satellite server:

e Upgrade to Common Property Tables 3.91

e Upgrade to NNM Event and Availability 1.40

Re-enable trendcopy on the central server.

Reconfigure central and satellite servers. For details, see Chapter 4, Setting Up a
Distributed System.

Upgrading to Version 1.40

Task 1:

Perform the following tasks to upgrade to version 1.40:

Stop OVPI Timer and extract packages from the report pack CD

1
2

Log in to the system. On UNIX systems, log in as root.
Stop OVPI Timer and wait for processes to terminate.
On Windows, do the following:
a Select Control Panel > Administrative Tools > Services.
b  Select OVPI Timer from the list of services.
¢ From the Action menu, select Stop.
On UNIX, as root, do one of the following:
HP-UX: sh /sbin/init.d/ovpi_timer stop
Sun: sh /etc/init.d/ovpi_timer stop

Insert the report pack CD in the CD-ROM drive. On Windows, a Main Menu opens
automatically; on UNIX, mount the CD if the CD does not mount automatically, navigate
to the top level directory on the CD, and run the . /setup command.

Type 1 in the choice field and press Enter. The install script displays a percentage complete
bar. When the copy is complete, the install script starts Package Manager. The Package
Manager welcome window opens.

If you navigate to the Packages directory on your system, you will see the following folders
under the NNM_Event folder:

NNM_Event.ap
NNM_Event_Demo.ap
NNM_Event_Upgrade_10_to_14.ap (While upgrading from RNS11 to RNS14.10)
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NNM_Event_Upgrade_12_to_14.ap (While upgrading from RNS13 to RNS14.10)

Task 2:  Upgrade to Common Property Tables 3.91

Follow these rules:

Do not install any other package with the CPT upgrade package
CommonPropertyTables_Upgrade_to_391. Install the CPT upgrade package and only the
CPT upgrade package.

When prompted to accept or disable the option to Deploy Reports, accept the default. If
you do not deploy reports, you will not deploy the change forms that come with Common
Property Tables.

When the install finishes, click Done to return to the Management Console.

If you need more help with this task, refer to the Common Property Tables User Guide.

Task 3:  Install the Upgrade Packages

1

From the Management Console, select Tools > Package Manager. The Package Manager
welcome window opens.

Click Next. The Package Location window opens.
Click Install.

Click Next. The Report Deployment window opens. Accept the defaults for Deploy Reports,
Application Server, and Port. Type your user name and password for the PI Application
Server.

Click Next. The Package Selection window opens.

Click the check box next to the following packages based on the current version of NNM
Event and Availability report pack you are running:

NNM _Event_Upgrade_10_to_14 (While upgrading from RNS11 to RNS14.10)
NNM _Event_Upgrade_12_to_14 (While upgrading from RNS13 to RNS14.10)
NNM_Event_Demo 1.4 (optional)

Click Next. The Type Discovery window opens. Disable the default.

Click Next. The Selection Summary window opens

Click Install. The Installation Progress window opens and the install begins. When the
install finishes, a package install complete message appears.

10 Click Done.

) Do not be surprised if the UPGRADE package you just installed disappears from
view. Package Manager will display what you just installed as NNM Event and
Availability Report Pack 1.40. This is not an error.

Task 4:  Restart OVPI Timer

Upgrade Install

On Windows, do the following:

a Select Control Panel > Administrative Tools > Services.
b  Select OVPI Timer from the list of services.

¢ From the Action menu, select Start.

On UNIX, as root, do one of the following:
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HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Package Removall

Follow these steps to uninstall NNM Event and Availability:

1
2

N o0 0 AW

10

1
12
13

14
15

Log in to the system. On UNIX systems, log in as trendadm.
Stop OVPI Timer and wait for processes to terminate.
Windows: Select Control Panel > Administrative Tools > Services
UNIX: As root, do one of the following:
HP-UX: sh /sbin/init.d/ovpi_timer stop
Sun: sh /etc/init.d/ovpi_timer stop
Start Package Manager. The Package Manager welcome window opens.
Click Next. The Package Location window opens.
Click the Uninstall radio button.
Click Next. The Report Undeployment window opens.

If NNM Event and Availability reports were deployed from this server, accept the defaults
for Undeploy Reports, Application Server Name, and Port. Otherwise, clear the check box
and skip to step 9.

Type your username and password for the PI Application Server.
Click Next. The Package Selection window opens.
Click the check box next to the following packages:
NNM _Event 1.4
NNM _Event_Demo 1.4
Click OK.
Click Next. The Selection Summary window opens.

Click Uninstall. The Progress window opens and the removal process begins. When the
uninstall process is complete, a package removal complete message appears.

Click Done to return to the Management Console.

Restart OVPI Timer.

Windows: do the following:
a Select Control Panel > Administrative Tools > Services.
b Select OVPI Timer from the list of services.
¢ From the Action menu, select Start.

UNIX: as root, do one of the following:
HP-UX: sh /sbin/init.d/ovpi_timer start
Sun: sh /etc/init.d/ovpi_timer start
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3 The New Install

This chapter covers the following topics:

e Prerequisites

¢ Installing NNM Event and Availability
e Accessing Deployed Reports

e Package Removal

Prerequisites

You cannot use the NNM Event and Availability Report Pack unless your NNM server and
your PI server are integrated. If your servers are not yet integrated, you need to do this now.
Refer to the NNM/ PI Integration Guide for more information about enabling integration on
the NNM server and running the Integration Wizard on the PI server.

The following software that must be running on your PI server before installing the NNM
Event and Availability Report Pack:

e Performance Insight 5.41
e Any and all Service Packs available for PI 5.41
e Common Property Tables 3.91

Installing NNM Event and Availability

Perform the following tasks to install the report pack:

e Task 1: Stop OVPI Timer and extract report packs from the report pack CD
e Task 2: If necessary, upgrade Common Property Tables

e Task 3: Install the NNM Event and Availability Report Pack

Task 1:  Stop OVPI Timer and extract packages from the report pack CD

1 Login to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.
Windows: Select Control Panel > Administrative Tools > Services
UNIX: As root, do one of the following:

HP-UX: sh /sbin/init.d/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop
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3 Insert the report pack CD in the CD-ROM drive. Do one of the following:

e  On Windows, run the setup.bat command if auto run is disabled. If outrun is
enabled, a Main Menu appears.

e  On UNIX, mount the CD manually if the CD does not mount automatically, then run
the setup command.

4  Type 1 to select PI report packs in the choice field and press Enter. The install script
displays a percentage complete bar. When extraction is complete, the install script starts
Package Manager. The Package Manager Welcome window opens.

’ If you navigate to the Packages directory on your system, you will see the following
directories under the parent directory for the report pack:

e NNM_Event.ap
e NNM_Event_Demo.ap (optional)

Installing the demo package is optional. You may install the demo package by
itself, or you may install the demo package along with the report pack.

Task 2:  Upgrade Common Property Tables

If you are running an older version of Common Property Tables, upgrade to Common Property
Tables 3.91 by installing the upgrade package CommonPropertyTables_Upgrade_to_391. If
you are not running any version of Common Property Tables, skip this task.

Installing the Common Property Tables upgrade package is no different from installing other
upgrade packages; however, do not install this upgrade package and other packages at the
same time. Install the Common Property Tables upgrade package and only the Common
Property Tables upgrade package. When the installation is complete, click Done to return to
the Management Console.

Task 3:  Installing NNM Event and Availability Report Pack

1 Start Package Manager. The Package Manager welcome window opens.

2 Click Next. The Package Location window opens.

3 Click Install. Approve the default installation directory or use the browse feature to select
a different directory, if necessary.

4 Click Next. The Report Deployment window opens. Accept the default settings for Deploy
Reports; also accept the defaults for application server name and port in the same window.

5 Enter your username and password for the PI Application Server.
Click Next. The Package Selection window opens.
7 Select the check box next to the following packages:
Common Property Tables 3.91 (if not already installed)
NNM Event 1.4
NNM Event Demo 1.4
8 Click Next. The Type Discovery window opens.

9 To run Type Discovery immediately after package installation, unselect Type Discovery
and click Next. The Selection Summary window opens.

10 Click Install. The Installation Progress window opens and the install process begins. When
the install process is complete, an installation complete message appears.

1 Click Done.
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12 Restart OVPI Timer.
Windows: do the following:
a Select Control Panel > Administrative Tools > Services.
b Select OVPI Timer from the list of services.
¢ From the Action menu, select Start.
UNIX: as root, do one of the following:
HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Accessing Deployed Reports

When you installed the report pack, you enabled the Deploy Reports option. As a result, the
reports in this package (as well as any forms that come with it) were deployed to the PI
Application Server. Once reports reside on the PI Application Server, you have two ways to
view them:

e PI client applications
e Web browser

If the client applications are installed on your system, you have access to Report Viewer,
Report Builder, and the Management Console. If you don’t have the clients, use a web browser
to reach the Web Access Server.

For more information about the clients, refer to the PI Installation Guide. For details about
the Management Console, including how to use the Object/Property Management view to
launch reports specific to a selected object, refer to the PI Administration Guide.

Package Removall

The New Install

Follow these steps to uninstall NNM Event and Availability:
1 Login to the system. On UNIX systems, log in as trendadm.
2 Stop OVPI Timer and wait for processes to terminate.
Windows: Select Control Panel > Administrative Tools > Services
UNIX: As root, do one of the following:
HP-UX: sh /sbin/init.d/ovpi_timer stop
Sun: sh /etc/init.d/ovpi_timer stop
Start Package Manager. The Package Manager welcome window opens.
Click Next. The Package Location window opens.

Click the Uninstall radio button.

o 0 A W

Click Next. The Report Undeployment window opens.
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10

n
12
13

14
15

If NNM Event and Availability reports were deployed from this server, accept the defaults
for Undeploy Reports, Application Server Name, and Port. Otherwise, clear the check box

and skip to step 9.
Type your username and password for the PI Application Server.
Click Next. The Package Selection window opens.
Click the check box next to the following packages:
NNM Event 1.4
NNM _Event_Demo 1.4
Click OK.
Click Next. The Selection Summary window opens.

Click Uninstall. The Progress window opens and the removal process begins. When the
uninstall process is complete, a package removal complete message appears.

Click Done to return to the Management Console.
Restart OVPI Timer.
Windows: do the following:
a Select Control Panel > Administrative Tools > Services.
b Select OVPI Timer from the list of services.
¢ From the Action menu, select Start.
UNIX: as root, do one of the following:
HP-UX: sh /sbin/init.d/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
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4 Setting Up a Distributed System

These are the steps to follow when setting up a distributed system:

¢ Decide whether or not you want local reporting

e Install the right set of packages (NNM Report Pack packages) on each server

e Verify that the system clocks in your environment are synchronized

e Register your satellite servers

e Ifyou are not copying rate data to the central server, enable LIR on the central server
e Ifyou enable LIR, add LIR mapping with the time type set to rate

e Verify that you have all the copy policies you need

e Configure the central server (manual edits to trendtimer.sched and .pro files)

¢ Configure each satellite server (manual edits to trendtimer.sched and .pro files)

If you want to set up a distributed system, you can implement local reporting or you can
implement centralized reporting. If you want local reporting, you need to deploy reports when
you install the report pack on each satellite server, and you need to allow summarizations to
run on each satellite server. If you do not want local reporting, then you do not need to deploy
reports when you install a report pack on a satellite server and you can disable the scripts
that run summarizations on each satellite server.

Before Location Independent Reporting (LIR) was available, our recommendation to anyone
setting up a distributed system was to deploy reports on satellite servers, keep rate data on
satellite servers, copy hourly data to the central server, and disable summarizations above the
hourly level on satellite servers. The advantage to this approach was that it kept a large
volume of rate data off the network and it decreased the processing load on the central server.
The disadvantage is that the central server could not display a Near Real Time (NRT) report.
The only NRT report was a local NRT report, on a satellite server. LIR overcomes this
disadvantage. If you enable LIR, you can open an NRT report on the central server and
drill-down on table selections. The selections you make cause the central server to query a
satellite server for locally aggregated data. Of course, if you would rather copy rate data to the
central server, you can. If you do that, then enabling LIR is not necessary.

NNM Event and several other report packs in the current version have a new copy policy
import file. When you install NNM Event, PI uses this file to generate copy policies. As a
result, you do not need to use the Management Console to create copy policies yourself.
Instead, your only task is to verify that the copy policies you need already exist.

Because you are likely to have multiple satellite servers, we designed the hourly process files
to be satellite-server friendly. This means that most of the time, most of the defaults are
correct. But some defaults will be incorrect, or less than optimal, and so to improve
performance you should change them. These manual edits, as well as the other steps listed
above, are spelled out in detail below.
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Configuring the Central Server

To configure the central server, perform the following tasks:

e Task 1: Register the satellite server by setting the database role

e Task 2: If you are not copying rate data to the central server, enable LIR
e Task 3: If you enable LIR, add LIR mappings

e Task 4: Verify the automatically generated copy policies

e Task 5: Modify the hourly NNM Event.pro file

e Task 6: Modify the hourly NNM Avail.pro file

Task 1:  Register the satellite server by setting the database role

1 Start the Management Console (log on with Administrator privileges).
Click the Systems icon in the navigation pane.

Navigate to the PI Databases folder and select the database system.
Click Database Properties.

From the Database Role list, select the Satellite Server role.

o 0 A W N

Enter any information necessary to configure the Satellite Server role.

’ To add a new database reference, you can use the Add Database Reference Wizard in the
System and Network Administration application.

Task 2:  Enable LIR

1 Start the Management Console (log on with Administrator privileges).
2 Click the Systems icon in the navigation pane.

3 Navigate to the PI Databases folder and select the central server.

4 Click LIR Configuration.

5 Select the LIR enabled check box.

Task 3:  Add LIR mappings

1 Start the Management Console (log on with Administrator privileges).

Click the Systems icon in the navigation pane.

Navigate to the PI Databases folder and select the central server.

Click LIR Configuration.

Click Add Mapping.

From the Select Satellite Server list, select a satellite server to which to add a mapping.
Select the Category data table option.

Select NNM_Event from the drop down list.

O 00 N 00 0 AW N

Select the rate data type.
10 Click Add to List.
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N If you want to add additional LIR mappings, click Add to list and repeat step 6 through
step 10.

12 Click OK.
13 Click Apply.

A copy policy is automatically generated for the hourly data and for each LIR mapping that
you add. The data type selected when adding an LIR mapping (in step 9 above) determines
the type of data copied (defined in the generated copy policy). The type of data copied (defined
in the generated copy policy) is one summarization level greater than the data type selected in
the LIR mapping. For example, if you select an hourly data type, you will generate a daily
data copy policy.

Task 4:  Verity the automatically generated copy policies

Verify that a copy policy has been generated for the following tables and that the copy type is
set correctly (to Property and Data):

1 Start the Management Console (log on with Administrator privileges).
2  Click the Copy Policy icon in the navigation pane to start the Copy Policy Manager.

3 Find the following tables and verify the copy type is set to Property and Data for each
table:

e SH NNM_Event
e SH NNM_Avail
e RVNNM_Avail

A copy policy is required for RVVNNM_Avail only if the cust_id, make, and node_type
variables are unique on each satellite server; if these variables are not unique and a copy
policy exists for this table, delete the copy policy.

If a copy policy has not been generated for a table, do the following:

1 Click the New Copy Policy icon or select File > New Copy Policy from the Copy Policy
Manager. The Copy Policy Wizard displays.

2 Click Next. The Satellite Server and Copy Policy Selection Page displays.

w

Select a satellite server from the pull down list. This is the satellite server from which
data is copied to the central server.

Select Single Table and select the table from the pull down list.
Click Next. The Copy Type Selection Page displays.

Select Property and Data.

Click Next. The Summary page displays.

0 N O O A

Verify the information in the summary window. If the information is not correct, you can
modify it by clicking Back.

9 Click Finish.

10 Repeat step 4 - step 9 for all missing tables.

If the copy type is not set to Property and Data, do the following:
1 Double-click the copy policy.

2  Select the Property and Data copy type.

3 Click OK.
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Task 5:  Modify the hourly_ NNM_Event.pro file

1

Navigate to:

{DPIPE HOME}/scripts/

where {DPIPE HOME} is the directory in which PI is installed.
2 Open the file.

3 Comment out blockO if this server is a non-collecting central server

Task 6:  Modify the hourly_ NNM_Avail.pro file

1

Navigate to:

{DPIPE HOME}/scripts/

where {DPIPE HOME} is the directory in which PI is installed.

Open the file.

Comment out the following line in block1:

{DPIPE HOME}/bin/trend sum -f {DPIPE HOME}/scripts/hourly NNM Avail.sum

If you did NOT configure a copy policy for the RVNNM_Avail table (refer to task 5),
comment out the following line in block1:

{DPIPE HOME}/bin/trend sum -f {DPIPE HOME}/scripts/
hourly NNM Avail allnnm.sum

Configuring a Satellite Server

Follow these steps to configure each satellite server.

1

Modify the {DPIPE HOME}/scripts/hourly NNM Event.pro file (wWhere
{DPIPE HOME} is the directory in which PI is installed).

Make the following changes:

e  Comment out blockl init.

e  Uncomment block2, including the begin and end lines.

Modify the {DPIPE HOME}/scripts/hourly NNM Avail.pro file.
Make the following changes:

e Ifyou configured a copy policy for the RVNNM_Avail table on the central server (refer
to task 5), comment out the following two lines in block1:

{DPIPE HOME}/bin/trend sum -f {DPIPE HOME}/scripts/hourly NNM Avail allnnm.sum

{DPIPE HOME}/bin/ovpi run sgl -sglscript
{DPIPE HOME}/scripts/{DBVENDOR}/update SH NNM Avail.sql -logfile
{DPIPE HOME}/tmp/update SH NNM Avail.out

¢  Uncomment the following three lines in block2:
begin: block2 wait
{DPIPE HOME}/bin/trendcopy -t SH NNM Avail
end: block2
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e Ifyou configured a copy policy for the RVNNM_Avail table on the central server (refer
to task 5), uncomment the following line in block2:

{DPIPE HOME}/bin/trendcopy -t RVNNM Avail

3 Make sure that each satellite server is collecting data from a disjoint set of NNM stations.

System Clocks

Make sure that the system clock on each satellite server is synchronized with the system clock
on the central server.
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5 Collecting Data from NNM 7.5x

This chapter covers the following topics:

¢ Adding and Modifying Properties

e Changing the HTTP Port Number of HP Interconnect on NNM
e Synchronizing Node or Category Information

¢ Changing the NNM Events Data Tool

e Checking and Debugging Collection Failures

A list of NNM stations is required to collect event and availability data. There are two ways to
produce this list: bulk import and PI forms.

Adding and Moditying Properties

Property information comes from the following sources:

e Forms bundled with the NNM Event and Availability Report Pack
e Common Property Tables batch-mode property import

e Common Property Tables (Device, Customer, Vendor)

e Category List Table

e NNM List Table

e NNM List Tables “add new” and “update” forms

e Category List Table “add new” and “update” forms

e Automatic feed from the network

If you have customers associated with specific devices or specific interfaces, or if you have
vendors associated with specific devices, use Common Property Tables to import this
information.

Bulk Import

To import a list of NNM stations using bulk import, perform these tasks:
e Task 1: Create the NNM station list file

e Task 2: Import the NNM station list file

e Task 3: PI data collection

29



Task 1:  Creating the NNM station list file

Create a property parameter file NNM_List.dat in the directory $DPIPE_HOME/data/
PropertyData/NNM_Event/ when bulk import of NNM stations is to be done or a set of
NNM stations for collection is required. To import one NNM station, use forms as described in
Using Forms on page 30.

The format of the data is as follows:
<nnm_station_l><tab><ovi_port_number>
<nnm_station_n-1><tab><ovi_port_number>
<nnm_station_n><tab><ovi_port_number>
Example:

nnml.hp.com 8092

nnm2.hp.com 8092

nnmn.hp.com 8092

The default HP Interconnect port number is 8092.

A Change this port number only if you have changed the port number for the
CommandResponder pluglet of HP Interconnect.

Task 2:  Import the NNM station list
To import the NNM station list, run the NNM List Importer tool:
$DPIPE_HOME/bin/trend_proc -f S$DPIPE_HOME/scripts/NNM_Event_import_nnm.pro

The NNM List Importer tool imports NNM_List.dat to the PI database. The imported list is
now ready for data collection.

) Errors are logged to: $SDPIPE HOME/log/trend.log

Task 3: Data collection

Once the NNM stations list is provisioned, the system is ready for collection. During the first
collection, the data collection tool will automatically:

1 Get the nodes from NNM with Device Type, Vendor, and Category information.

2 Get data for the last two days from the NNM station or as available in NNM, whichever is
faster.

3  Put the category list into PI.

) By default, data collection takes place hourly. The periodicity (polling interval) of
data aggregated by NNM is 15 minutes.

Using Forms

This section describes the following forms:
e Add or Update NNM List

¢ Remove NNM Station

¢ Add or Update Category Information
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¢ Remove Alarm Category
e Update Availability Threshold
Use these forms to create, update, or remove property data.

To launch a form, click the Objects icon in the panel on the left side of the Management
Console window. The Object/Property Management view opens. Object Manager shows a list
of objects. The type of object presented depends on which Object Manager View is open. The
default view is the Device view, showing a list of devices. To change the view, select View >
Change View and use the pop-up window to select a different view. Once the type of object you
are interested in updating is in view, select the particular object you want to update.

When you select the object, Object Specific Tasks will appear in the window on the right.
Double-click and open the form. Click Apply to save changes, OK to save changes and close the
form, or Cancel to close the form without saving changes.

Add or Update NNM List
Use the Add or Update NNM List form to add a new NNM station or modify the following
details for an existing NNM station:
e PI port number
e Polling interval
e Polling granularity
e HTTP time-out
Follow these steps to update an NNM station:
1 Launch the Management Console.

2 Click the Objects icon. The Add or Update NNM List form appears under General Tasks.
Navigate to the NNM station you want to update, then double-click the Add or Update
NNM list form.

Highlight the row that contains the data you want to change.

4 Ifrequired, change the Polling Granularity and then change the following entry in the
SDPIPE_HOME/trendtimer.sched:

01:00 - - {DPIPE_HOME}/bin/trend_proc -f {DPIPE_HOME}/scripts/NNM_Event.pro
For example, if Polling Interval is 180 mins, then change the entry as shown below:
03:00- - {DPIPE_HOME}/bin/trend_proc -f {DPIPE_HOME}/scripts/NNM_Event.pro

Polling Granularity is the result of duration units divided by Polling Interval. For a given
Polling Interval, events data collected can be aggregated over smaller units of duration
(called Polling Granularity). For example, if Polling Interval is 60 mins, then Polling
Granularity can have values such as 30, 60, and 180 mins.

5 Make your changes. Click Apply to save changes, OK to save changes and close the form, or
Cancel to close the form without saving changes.

Follow these steps to add a new NNM station:
1 Select any row.

2 Enter the name of the NNM station in the NNM Station field. Change other values as
required.

3 Click Apply to save changes, OK to save changes and close the form, or Cancel to close the
form without saving changes.
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>»

NNM Event Report
Add or Update NINM List

[

invent

Station far OWPI to collect data.

Alist of MMM Station is required to collect the event and availability data. The table below lists the
MMM Station configured for OWPI data collection. This form can he used to update or create new MR

. Station . HTTP

HMM Station Version oVl Port Poll Granularity Timeout
default 7480 2092 EO 15 [={au}

lena.chnhpocom T8 2000 =] 15 [=ulu]

NNM Station Ide{ault

Station Version |?.5.c|

OV Port Number |8,092

Poll Interval {in mins) |aa

Poll Granularity (in mins) |15

HTTP timeout {in secs) |aun

As soon as NNM 8.0 is supported, the Station Version field will display 8.0. For now, version

7.5x is the only value this field displays.
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Remove NNM Station

Follow these steps to remove a single NNM station:

1
2

Launch the Management Console.

Open the Object/Property Management view. Select View > Change View and use the
pop-up window to select NNM view. The NNM stations are listed here.

Select the NNM station you want to remove.

Double-click the Remove NNM Station form under Object Specific Tasks. The form opens,
showing NNM stations configured for PI data collection.

Highlight the row that contains the NNM station that you want to remove.

) Once you remove an NNM station, that NNM station will stop collecting data.
Existing data is still available.

Click Apply to remove the NNM station, OK to save changes and close the form, or Cancel
to close the form without saving changes.

NNM Event Report (ﬁ/n

Remove NNM Station

invent

Alist of NNM Station is required to collect the event and availability data.
The table below lists the NMNM Station configured for OVPI data collection.
This fortm can be used to remove the selected NNM Station from
callection by OVPI.

NNM Station OVl Port HTTP Timeout
suntest21 .cnd hp.com 2,092 600
NNM Station I-_=.u ntest21.cnd.hp.com

OV1 Port Number |:5: 082

HTTP timeout in |10
Secs)

Ok Apply Cancel
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Add or Update Category Information

Follow these steps to update a new alarm category for an NNM station:

1
2

Launch the Management Console.

Click Objects. The Add or Update Category Information is listed under General Tasks.
Double-click the form.

Navigate to the NNM station and double-click the form. The form opens, showing category
information.

Highlight the row that contains the data you want to change.
Make the changes.

Click Apply to save changes, OK to save changes and close the form, or Cancel to close the
form without saving changes.

Follow these steps to add a new NNM station:

1
2
3

Select any row.
Enter the new Category Id and Category Name.

Click Apply to save changes, OK to save changes and close the form, or Cancel to close the
form without saving changes.

NNM Event Report (6/3
Add or Update Category Information

invent

Every NMM Station has a set of Category list for its alarms. The tahles below lists
the MMM Stations and their Category list. This form can be used to update or add
new alarm category for a choosen NRNM Station.

NNM Station Category Id Category Name
All NNM Stations | 3 Threshold Alarms Al
bisqit2.cnd hp.com 4 Status Alarms
default J 5 Configuration Alarms
ovpihpts.india hp .com (-] Application Alert Alarms J
suntest21.cnd hp.com LI 7 Problem Diagnosis Alarms v
NNM Station In:-'-.-'pihptEi india hp.com

Category Id |23

Category Name ITest Alarms

Ok Apply Cancel
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Remove Alarm Category

Follow these steps to remove a category for an NNM station:

1 Launch the Management Console.

2 Open the Object/Property Management view. Select View > Change View and use the

pop-up window to select NNM view. The NNM stations are listed here.

Select the NNM station that you want to remove.

4  Double-click the Remove Alarm Category form under Object Specific Tasks. The form opens,

showing NNM stations, Category Id, and Category Name.

5 Highlight the row you want to remove.

6 Click Apply to remove a category for an NNM station, OK to save changes and close the
form, or Cancel to close the form without saving changes.

NNM Event Report (ﬁa

Remove Alarm Category

invent

Every NNM Station has a set of Category list for its alarms. The tahles below lists
the MMM Stations and their Category list. This form can be used to remove a
category for an NMNM Station.

NNM Station Category
surtest21 .chd hp.com Id
2 Error Alarms
3 Threshold Alarms
4 Status Alarms

Category Name

|
lll*_LI'_

NNM Station suntest21.cnd.hp.com
Category Id |
Category Name IThr-':shc-Id Alarms

Collecting Data from NNM 7 5x
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Update Availability Threshold

The Availability Threshold (percentage of availability) values are based on NNM station,
Customer, Vendor and Device type. Threshold is the line between normal and abnormal
performance. When this line is crossed, an exception is recorded. Thresholds are set to default
values that are easily changed to reflect individual needs.

Follow these steps to change the threshold value:
1 Launch the Management Console (piadmin).

2  Click Objects. Under General Tasks you will see the Update Availability Threshold form.
Double-click the form. The forms opens, showing a list of NNM stations and an
availability threshold for each station.

Highlight the row that contains the Availability Threshold you want to change.

4 Make the changes. Click Apply to save changes, OK to save changes and close the form, or
Cancel to close the form without saving changes.

NNM Event Report (ﬁﬂ’
Update Availability Threshold ——r
The availability threshold is the availability percentage level. Any value below this value would be
treated as an SLA violation. The availahility threshold value can be based on NNM Station, Customer,
Yendor and Device Type. This form can be used the modify the availability threshold value.
Availability Threshold
Device RAvailability
NNM Station Customer Vendor Threshold
Type
et e i e am —— )
owpihpte india hp.com Customer Unassigned Un=set |FRouter S55.00 :]
owpihptEindia hp.com Customer Unassigned Unset Hode 55.00
ovpihpteindia hp.com Customer Unassigned Unset PC 95.00
ovpihpte indiz hp.com Customer Unzzsigned Unizet Wior kstation 95.00
ovpihptE india hp.com Customer Unassigned cisco IFRouter S5.00
suntest21.ond hp.com Customer Unassigned Unset IP Router 85.00 v
MNNM Station |:u|-|tc:t21 .znd hp.com
Customer Id I 2
VYendor Unset
Device Type ||r Router
Availability Threshold s
Ok Apply Cancel
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Changing the HTTP Port Number of HP Interconnect on NNM

If the port number 8092 is already in use, do the following to change the port number:

1 On NNM, change the <serverPort>8092</serverPort> parameter in the file specified
below to identify the new HTTP port number.

UNIX
SOV_INSTALL_DIR/conf/OVPI_INTEGRATION/ResponderProxyPluglet.config
Windows

SOV_INSTALL_DIR/newconfig/OVPI_INTEGRATION/
ResponderProxyPluglet.config

2 Re-start the CommandResponder pluglet of HP Interconnect. To start or stop HP
Interconnect, do as follows:

UNIX

SOV_BIN/ICO_ctl.ovpl -s : to stop OVI
SOV_BIN/ICO_ctl.ovpl -g : to start OVI
Windows

$OV_BINS\ICO_ctl.ovpl -s : to stop OVI
$OV_BINS\ICO_ctl.ovpl -g : to start OVI

Synchronizing Node or Category Information

Use the get_nnm_aggevt tool to synchronize the node information or category information
from all NNM stations.

e To update the NNM Event and Availability Report Pack with current node information
from NNM, use the following script to get the node information:

SDPIPE_HOME/bin/perl SDPIPE_HOME/scripts/get_nnm aggevt.pl -i

e Ifyou install new SPIs, the alarm category will change. To update the NNM Event and
Availability Report Pack, use the following script to get node information:

SDPIPE_HOME/bin/perl $DPIPE_HOME/scripts/get_nnm_aggevt.pl -c

Changing the NNM Events Data Tool

NNM uses the following tools to provide event data:
e ovdumpevents: This tool is the default data collection tool on PI.
e ovdwquery: This tool is based on RDBMS.

For more information about these tools, refer to Managing Your Network with HP Network
Node Manager.

Follow these steps to change the tool to ovdwquery:

1 Access the $DPIPE_HOME/1ib directory
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Create a configuration file named NNM_Event_Report.conf with the following entry:
AGG_TOOL, ovdwquery

The new tool will be used in the next poll cycle.

Follow these steps to change the tool to ovdumpevents:

1
2

Access the $DPIPE_HOME/1ib directory
Do one of the following:
e Remove the conf file NNM_Event_Report.conf

e Modify the AcG_TooL entry in the above configuration file as
AGG_TOOL, ovdumpevents

Checking and Debugging Collection Failures

To check and debug collection failures, perform the following steps:

1

Enable debugging instrumentation for NNM Event and Aggregation datapipe on the PI
server by setting the environment variable DEBUG = 1. On PI, the collection details for
all NNM stations will now be logged into the following file:

$DPIPE_HOME/log/trend.log.

Check for entries with get_nnm_aggevt.pl, the module that collects event data from
NNM stations.

Enable debugging instrumentation for NNM Event and Aggregation datapipe on the
NNM server by setting the environment variable DEBUG = 1. Then re-start the
ICO_RNS service on the NNM server. On NNM, collection details and failures, if any, will
now be logged into the following file:

SOV_TMP/OVPI/NNM_EVT_RP_*log

The following three scenarios discuss possible resolution steps if the NNM Event and
Aggregation datapipe fails to collect event and downtime data from the NNM server:

Scenario 1

If the datapipe logs the following error message, then the NNM version you are currently
using may not be supported:

Unsupported version for NNM [$nnm, $version], failed

To resolve this issue,

1
2

Open PI Management Console and then open the Object Manager.

The Add or Update NNM List form appears under General Tasks. Click on the form Add or
Update NNM List.

Navigate to the NNM station you want to update and check if you have configured the
supported NNM version for your NNM datapipe.

If not, then you need to edit this form and modify the NNM Server station version. For
more information, see Add or Update NNM List on page 31.
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Scenario 2

If the datapipe logs the following error message, then probably the HP Interconnect (OVI
Service) is down on the NNM Server or is not responding to the datapipe's request:

“Can't connect” to NNM Server

To resolve this issue, log on to the NNM Server and see if the OVI Service is running. If not,
then re-start it on the NNM Server. For more information about how to start and stop the OVI
Service, see the process to re-start HP Interconnect in page 37.

Scenario 3

If the NNM datapipe returns “<HTML>. *Error. *<HTML>” or “<HTML>. *Fail.*<HTML>" then
the NNM server is probably facing some difficulties in sending an HTTP response.

To resolve this issue, re-start the OVI Service on the NNM server or run the following
command on the NNM server:

OV_BIN/ovpi_agg_evtdump.ovpl
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6 Sample Reports

This chapter provides samples of the following reports:

1 Detailed Availability - Station Level

2 Details Availability - Node Level

3 Availability Forecast by Customer

4 Availability SLA Report

5 Executive Summary by Vendor

6 Event Summary by NNM Station

7 Forecast by Severity

8 Hot Spots Top 20

9 NNM Events by Category and Device
10 NNM Events by Severity and Device
1  Executive Summary by Severity

Calculating Availability

The events coming from NNM station are collected and stored in Performance Insight for
further calculation and reporting. You can configure the polling interval and the polling
granularity.

Note that only those managed nodes that had an NNM node critical event are considered by
Performance Insight for calculations. The calculation of node availability starts once the node
becomes critical. This node appears on the Availability reports even after the node comes up.
If a node did not have a node critical event, it will not appear on the Availability reports. The
nodes that are not shown on the reports are interpreted by Performance Insight as 100
percent available over the specified time interval.

Availability Metrics

Following are the description and calculation of the metrics displayed on the PI reports:

¢ Mean Time between Failures (MTBF) - This term denotes the mean time in seconds
for which the device was up and running before it went down again.

¢ Mean Time to Repair (MTTR) - This term denotes the mean time to repair or bring up
the device. This metric is also termed as downtime.

e Availability % - This term denotes the percentage of time the device was available or up
and running during the specified time period. The Availability % metric is calculated as
follows:
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Availability % = ((Total Time - Downtime) / Total Time) * 100

e Downtime - This term denotes the time in seconds when the device was down. Downtime
is the same as MTTR.

e Total Outage - This term denotes the number of times a device went down in the
specified time duration.

Example

The sample row in the following partial snapshot of a report shows the following metrics for
the selected NNM station:
e Total number of outages = 1
e MTTR or Downtime metric value = 1524 seconds.
e Let us assume the polling interval is one hour or 86400 seconds, therefore,
Total Time = 86400 seconds.
Therefore, the Availability % is calculated as:
e Availability % = ((Total Time - Downtime) / Total Time) * 100
= ((86400-1524)/86400) * 100
= 98.24 percent.

Availability metrics for the above selected NNM Station, Vendor, Customer and Device Type
-
Month: to Date 1( Monthly ‘( Yearly ‘
Sun, Feb 1, 2008 - Thu, Feb 12, 2003 O
Date MTEF (in sec) MTTR (in sec) Availability % Downtime (in sec) Total Qutage {xﬁ‘.
11, Feb 85,500.00 0.00 100.00 0 0
10, Feb 85.400.00 0.00 100.00 0 0 i
3, Feb 85.400.00 0.00 100.00 0 0 5
B, Feb 85.400.00 0.00 100.00 0 0
7. Feb 85.400.00 0.00 100.00 0 0
8, Feb 85.391.00 109.00 99,87 10 1
5. Feb 85.400.00 0.00 100.00 0 0
4, Feb 85.400.00 0.00 100.00 0 0
3, Feb 85.400.00 0.00 100.00 0 0
Sample L 2, Fh B4,876.00 1,524.00 83824 1,524 1 =
R ows o i ‘
SRl R
@Elacktn Top Drax

Sample 1: Detailed Availability Report on Station Level

Daily, monthly, and yearly availability information for a selected customer, and a selected type
of device, on a per-vendor basis. This report does not show availability across multiple NNM
stations. This report aggregates data at the NNM station level.

First select the NNM station, then select a vendor, a customer, and a device type. The table
below the selection fields provides statistics for:

e Availability
e MTTR
e Total downtime

e MTBF
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e QOutage count

Use this report to see if availability for a particular device type managed by a particular NNM
station is improving or worsening.

Sample 2: Detailed Availability Report on Node Level

Daily, monthly, and yearly availability information for a selected customer, and a selected type
of device, on a per-vendor basis. This report does not show availability across multiple NNM
stations. This report aggregates data at the NNM station level.

First select the NNM station, then select a vendor, a customer, and a device type. The table
below the selection fields provides statistics for:

e Availability

e MTTR

e Total downtime
e MTBF

e Qutage count

Use this report to see if availability for a particular device type managed by a particular NNM
station is improving or worsening.

Sample 3: Availability Forecast by Customer

If multiple NNM stations are in use, this report aggregates data from all of them, and rolls up
data to the customer level. Once you select a customer, you can either select All or a particular
device type. The bar graph provides baseline, F30, F60, and F90 values for:

e MTBF

e MTTR

e Availability
e Downtime

Use this report to see whether the customer you selected is expected to see improved
availability metrics or degraded availability metrics.

Sample 4: Availability SLA

Sample Reports

The availability SLA report aggregates data for multiple NNM stations. It answers four
questions:

e On average, is a particular vendor operating above or below the threshold for availability?
e Is a particular device type from one vendor operating above or below the threshold?

¢ On average, are the devices owned by a customer operating above or below the threshold?
e Is a device type owned by a particular customer operating above or below the threshold?

This report looks at downtime details as well as availability details. You can compare actual
availability to the SLA value (the threshold for availability), and you can compare actual
downtime to the SLA value (the threshold for downtime).
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Sample 5: Executive Summary by Vendor

This report aggregates alarm category and alarm severity data at the vendor level, on a
station by station basis. Use this report to determine:

¢ The distribution of alarms across alarm categories
¢  Whether the number of alarms per category is increasing or decreasing
e The distribution of severity levels

e  Whether the number of alarms per severity level is increasing or decreasing

Sample 6: Event Summary by NNM Station

This report aggregates the total number of events on a station by station basis. Use this
report to find out what the total is for each NNM station and whether the total is increasing
or decreasing.

Sample 7: Forecast by Severity

This report produces an alarm severity forecast. It aggregates severity data across all devices
on a station by station basis, calculates a baseline value for each severity level, then lets you
compare the baseline value to F30, F60, and F90. Use this report to find out which severity
level was most prevalent over the baseline period and how each severity level is expected to
behave in the future.

Sample 8: Hot Spots Top 20

This report aggregates events for each device on a station by station basis. Use this report to
find out which devices are responsible for the most events. Select a station, then select a
severity level. The graph below produces a list of devices, ranked by number of events, highest
to lowest, allowing you to see event statistics for the twenty devices responsible for the
majority of events.

Sample 9: NNM Events by Category and Device

This report aggregates event category statistics on a station by station basis. Use this report
to drill down from an event category to a list of the devices responsible for the alarms in that
category. The devices are ranked by the number of events in that alarm category, highest to
lowest. Use this report to find out which devices are responsible for majority of events in each
alarm category.

Sample 10: NNM Events by Severity and Device

This report aggregates severity level statistics on a station by station basis. Use this report to
drill down from a severity level to a list of the devices responsible for the alarms in that level.
The devices are ranked by number of events in that severity level, highest to lowest. Use this
report to find out which devices are responsible for most of the events in each severity level.

Sample 11: Executive Summary by Severity
This report compiles data about the number of events per severity level. The results are

available on a vendor-by-vendor basis and on a customer-by-customer basis. After selecting
the NNM station, select a vendor and a severity level. The graph to the right shows the trend

Chapter 6



Sample Reports

line for the number of events for this particular device and this particular severity level. You

can also select a customer and a severity level. The graph to the right shows the trend line for
the number of events for this particular customer and this particular severity level. Use this

report to find out whether the event count for a severity level is increasing or decreasing.
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Network Node Manager ﬁﬂ
Detailed Availability Report On Station Level inven:t

The Detailed Awvailability Report, reports on availability, mttr, mtbf, total downtime and the outages, by the MM Station, Wendar,
Customer and Device type. Select the nnm station, customer, wvendar and the device type from the top tables to wiew the daily, monthly

and yearly availability metrics.

NNM Station Yendor Customer Device Type

Al HF Custorer Unassigned Rionter

lena.chn.hp.com

Availahility metrics for the ahove selected HNM Station, Yendor, Customer and Device Type

tarth to Date I Mnnthlyl ‘r'earlyl
Sat, Sep 1, 2007 - Wed, Sep 26, 2007

Date MTBF(insec) MTTR{insec) Availahility% Downtime {in sec) Total Outage
25, Sep 65 .50 182.00 72.01 4,00 2z
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Network Node Manager (ﬁa
Detailed Availability Report On Node Level inven:t

The Detailad Awvailability Report On Mode Lewvel, reports on availability, mttr, mibf, total downtime and the outages, by the NN Station,
“endor, Customer and Device type. Select the nnm station, customer, vendor and the device type from the top tables, and then select a

node to view the daily, monthly and ywearly availability metrics on this node.

NMM Station Yendor Customer Device Type
All Station w MHane w Mlane w MHone w
NNM Nodes
Node Hame Availability Threshold
zahpt1 1 .india hp.com 95.00
95.00

zahpt Q.indiza hp.com

Availahility metrics for the above selected NHM Station, Vendor, Customer and Device Type
Karth to Date I Mnnthlyl ‘r'earI].rI
Sat, Sep 1, 2007 - Wed, Sep 26, 2007

Date MTBF{insec) MTTRiinsec) Awvailahility® Downtime {insec) Total Owutage
25, Sep GO0 244.00 7252 2 G2 11

Sample Reports
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Network Node Manager (éﬂ]

Availability: Forecast By Customer invent

The Availability Farecast with Baseline Repor, reparts onmean time bebveen failure (mtbf), mean tire to repair{mtt’ and cowntime.
Selact the Costomer and Device tyae to view corresponding forecastwith baseline details tor mtbf, mtr, availability and donntime.

customer Device T]FPE
ABC Al
Al Custorers Bridge
Halley Raouter
Hirmalan=
Dzzy

Baseline Vs F30, F60 and FO0 of metrics for the selected Customer and Device Type

WTBF | MTF | Availability | Dovrtime |

400
3207
2401 Clwavy MTEF
2 M Fz0 MTEF
= M reo MTEF
1507 CFao mTeF
80
a
Sun 12:00 AM

48
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Network Node Manager
Availability: SLA Report

[

invent

The Availability: SLA& Report, reports on availability with threshold. It also repors the total downtime. Select the customer and device type

{or vendor and device type) to view summarny of avail ability with threshold breach and downtime.

Vendor Device Type
AbA All
All BEridge
DEF Computer
HP Router
LUNKENOWN

Availability and Downtime details for the selected VYendor and Device Ttype
Daily: Availability | Monthly: avaiabitty | Daily: Downtime | Morthiy: Dowrtime |

Sun, Mar 7 12:00 AM - Sat, Mar 13 12:00 AM

100
e80T
EOT
407
207
o . + } } . 4
Sun 1200 AM Mon 12:00 A Tue 12:00 Ak Wed 1200 AM Thu 12:00 AM Fri 12:00 AM Sat 12:00 A
— Awailability — Availability Threshold
Customer Device Type
Customer Unassigned Al
Al Customers Bridge
ABC Router
Ozzy
Halley
HaleBob
Availability and Downtime details for the selected Customer and Device Ttype
Daily: Availability | Morthly: Availability | Daily: Downtime | Morthiy: Dowrtime |
Sun, Mar7 12:00 Al - Sat, Mar 13 12:00 A
100
20
[=2n]
40
201
] } . 4 } } i
Sun 12:00 AM Mon 12:00 AM Tue 12:00 AM Wed 12:00 AM Thu 12:00 Ak Fri 12:00 AM Sat 1200 AM

— Awailability — Awvailability Threshold

Sample Reports
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Network Node Manager

Executive Summary by Vendor

QO

invent

The Executive Summary by Vendor, reports on the events count based on category and severity for a selected NKM Station and

Yendor. Select the nnm station and vendor from the top takles to view the carresponding morthly events count summary . The tabbed
region allows further classification for ether Category or Severity.

NNM Station

ovpirtE.india hp.com
owvpihptE india.hp.com

Category
All Categories
Application Alert Alarms 20,000,000
Corfiguration Alarms
Error Alarms 16,000,000
Status Alarms A
Threshold Alarms v '
2,000,000
4,000,000 4-—

Severity
All Severities

Critical 20,000,000

Major

Minor 16,000,000

HNar mal PR

Warning 0000
2,000,000
4,000,000

Vendor

All
Cisco
HF

Sun

Monthly Summary By Category
Thu, Jan 1 12:00 AM - Sun, Feb 1 12:00 AM

0 + + + +
Fri 12:00 AM Fri 12:00 AM  Fri 12:00 &M Fri 12:00 AM  Fri 12:00 AM

— Total Event: ovpintl.india.hp.com

Monthly Summary By Severity
Thu, Jan 1 12:00 AM - Sun, Feb 1 12:00 AM

o ' + + .
Fri 12:00 AM  Fri 12:00 AM  Fri 12:00 AM Fri 12:00 AM Fri 12:00 AM

Total Event: ovpintl.india hp.com

50
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Network Node Manager 6’;
Event Summary By NNM Station

invemnt

Thie MM Evernt Report by MMM Station, gives avent count bazed on NNM Stations, Salect the NMM Station from the table below (o view
itz event count summany .

NNM Station

Al
owvpihptE.india.hpcom
owpinte indiz hp.com

Event Count for Selected NNM Station

Dzdly I Weekly | Bonthl y |

Sur, Mar 14 1200 AM - Mon, Mar 22 309 PM
30,0007

240007

10004
12 0001

€,00071

i} + t - + ' - |
Sun 1200 AM Mon 12:00 AM Tue 12:00 AM ‘Wed 1200 &M Thuo 12:00 AM  Fri 12:00 AM  Sat 1200 AM  Sun 12:00 AM
— Ewent Court: ovpihptEindiahp.com

Sample Reports
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Network Node Manager
Forecast By Severity

hp

imwvent

The M Event Forcast by Severity Report, forecasts total evenis for 30, 60 and 30 days. Select the NNM Station and the Severity
from the top tables to view the correspodning expected total events from the graph belowy, along with the baseline data. The baseline

evert court is welghted average.

NNM Station Severity

owpihpts india hp com Sewverity ID
ovpintE india hp com A

& WK =

30, 60 and 90 Days Events Count Forecast for the selected HNM Station and Sewverity

BL V= F3I0/F60FI0

Baseline vs 30 Day Forecast
By Sewerity
100,000

Sun 12:00 AM

Severity
Al Severities
Mor el
‘Warning
Minor
Major
Critical

B weighted Avg

] Day Forecast
Oeo Day Forecast
Meo Day Forecast

52
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Network Node Manager
Hot Spots Report: Top 20

0

inwvent

scapuloo.grencble hp.oom

The top 20 Hot Spots Report reports on the top 20 devices generating the most severe svents, aggregated daily and weskly

NNM Station Severity
All sev_id Sev_name
ovpihpts.india hpocom -1.00 All Severities
orvpirtG india b com 1.00 Mol
2.00 Warning
3.00 Minor
4.00 hajor
S.00 Critical
Top 20 Devices generating most events for the selected NHM Station and Severity
Daily | weeky |
Top 20 Devices Generating Most Events
Wed, Mar 17 12:00 AM - Thu, Mar 128 12:25 PM
Device Event Count
All Hodes 14400
144.00

Sample Reports
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Network Node Manager
NNM Events by Category and Device

[

invent

The MM Events by Category and Device, report provides event count grouped by category and device, Selact the Mub Station from
the top table to view the list of categories. Select category from the top table to view the st of event court by device, aggregsted

aver morthly, weekly and dailly.

NNM Station Category
Al Category ID Category
ovpihpts india hp com -1 Al Categories
ovpintE india hpocam 1 LOS0MLY
2 Error Alarms
i Status &larms

Event Count by Device for the selected NNM Station and Categony

Daily | waekly | Mantiy |

Event Count By Device
Sumn, Mar 24 12200 AM - Sun, Mar 21 12:00 AM
Device
Al Modes
hobry grenobée hp com

acapulco grenoble hp.com

Ewvent Court
11,280
g 765

4,512
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Network Node Manager (ﬁa
NNM Events by Severity and Device e e

The MM Events by Severity and Device, report provides event count grouped by severity and device. Select the MMM Station from the
table belovy 1o view the list of severity far the nodes belonging to MMM Station. Select severity from the top table to view the list of

event court by device aggragated over manthly, weskly and daily.

NNM Station Severity
Al Severity ID Severity
ovpibptE india hp.com -1 Al Severities
avpints india hp.com 1 Hor ral
2 Warning
3 Mimor
4 Major
5 Critical
Event Count by Device for the Selected NNM Station and Severity
Daity | weskty | Morthiy |
Ewent Count By Device
Sun, Mar 21 12:00 AM - Sun, Mar 21 12:00 AM
Device Event Count
All Hodes 4512
acapulco.grencble hp.com 2,256
boby.grenckle hp.com 2,256

Sample Reports
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Network Node Manager
Executive Summary By Severity

O

invent

Thia Executive Summany Report, repoits the monthly event count based onf Vendor and Customer. | aleo forecasts the tolal events
for 30, B0 and 90 day s using the veeighted average of tolal events, aggegated by Severidy. Choose the N Stafion from the top table

to viewy the defais as required,

NNM Statien

owpihpls.india hp.com
ovpintE.india hpcom

Monthly Summary By Vendor for Selected NNM Station

Vendor Severity

A

p Id Severity
-1 Critical
P Major
3 I i
2 Warning
1 Mo rval

3 | Al Severities

Severity |

han, Sep 1 12:00 AM - Mon, Mar 22 3:15 P

200,000

180,000

120,000 e —
80000 ———

A0 0

Mon 12:00 AM Mo 12:00 AM
— Evard Courd; ovpihplsindahpcom

Monthly Summary By Customer for Selected NNM Station

Customer Severity |
Halley
Hi ezl zym id Sevarity
Al Customers ? s
2 Warring
1 Mo sl

- Al Severities

Severity |

han, Sep 1 12:00 AM - Mon, Mar 22 3:15 P

70,000

86,000 e

42,000 e

28,000

14,000
1]

e

har 1200 AM lar 1200 AM
= Ewvart Court; ovpihplE indshpoom
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A Editing Tables and Graphs

Any table or graph can be viewed in several ways. Although the default view is usually
adequate, you can easily change to a different view. If you are using Report Viewer, right-click
the object to open a list of view options. If you are using the Web Access Server, follow these
steps to change the default view of a table or graph:

1 Click Preferences on the links bar.

Expand Reports in the navigation frame.
Click Viewing.

Select the Allow element editing box.

Click Apply.

Click the Edit icon next to the table or graph.

o O AN

View Options for Tables

Right-clicking a table, or selecting the Edit Table icon if you are using the Web Access Server,
opens a list of table view options.
Sek Tirme Petiad, .

Change Constraint Yalues...
Select Modes|Interfaces. ..

Change Max Rows, .,
Wieww in new Frame

Print Table. ..

Export Element as CSY...
Delete Table

Select Set Time Period to alter the relative time period (relative to now) or set an absolute time
period. The Set Time Period window opens.

You may shorten the period of time covered by the table from, for example, 42 days to 30 days
or to 7 days. If you are interested in a specific period of time that starts in the past and stops
before yesterday, click Use Absolute Time and select a Start Time and an End Time.

Select Change Constraint Values to loosen or tighten a constraint, thereby raising or lowering
the number of elements that conform to the constraint. The Change Constraint Values
window opens. To loosen a constraint, set the value lower; to tighten a constraint, set the
value higher.

The Select Nodes/Interfaces allows you to change the scope of the table by limiting the table to
specific nodes, specific interfaces, or a specific group of nodes or interfaces. The Select Node
Selection Type window opens.
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Direction
Input
Input
Input
Input
Input
Input
Input
Input
Input
Input
Input
Input
Input

Change Max Rows increases or decreases the number of rows in a table. The default is 50. If
you expand the default, the table may take more time to open. If you are trending a large
network, using the default ensures that the table opens as quickly as possible.

View in new Frame opens the table in a Table Viewer window, shown below. If necessary, make
the data in the table more legible by resizing the window.

ies Table ¥iewer

Polled IP QoS Statistics Data - Input

Cver Previous 6 Hours

IpPrecedence Switched Bytes
u] 105,688

o o o o0

GO0

02,234

O L o e L. | B (O T % B
]

Lo B R |

View Options for Graphs

Switched Plis

GYa

o th OO O O O

G622

L I Y o

=10l

Time Period
Tue Ot 29 0700 A
Tue Ot 29 0700 Ahd
Tue Oct 20 07:00 Ahd
Tue Ot 29 0700 A
Tue Oct29 0700 Ahd
Tue Oct 20 07:00 Ahd
Tue Oct 29 0700 A
Tue Oct 29 0700 Ah
Tue Ot 29 0645 Ahd
Tue Oct 29 0645 Al
Tue Ot 29 05495 A
Tue Ot 20 06495 Ahd
Tue Oct 29 0645 Al

Right-clicking a graph, or clicking the Edit Graph icon if you are using the Web Access Server,
opens the following list of view options.

40000 1

22720 7

29540 1

163 60 1

2180 1

0

Sap 17 Sep 21 Sap 25 Sep 28

add Cverlay. .
Remave Overlay

Set Time Period. .,

hange Constraint Yalues. ..

Select Modes)Interfaces, ..

Displayed Data

Grid
Legend
Skyle

. . .

—hange Max Rows. ..

Display Daka Table

Export Element as CSW. ..
Display: Gverlay Data Table
Excport Graph @verlay Data as C54

View in new Frame

Print Graph. ..

Delete Graph

Appendix A



The following table provides details about each option.

Option Function

Set Time Period Same as the table option shown above.

Change Constraint Values Same as the table option shown above.

Select Nodes/Interfaces Same as the table option shown above.

Displayed Data For every point on a graph, display data in a
spreadsheet.

Grid Add these to the graph:

X axis grid lines
Y axis grid lines

X and Y axis grid lines
Legend Delete or reposition the legend.
Style See the illustrations below.
Change Max Rows... Same as the table option shown above.
Display Data Table See below.
Export Element as CSV... Same as the table option shown above.
View in New Frame Opens graph in a Graph Viewer window.
Print Graph Same as the table option shown above.

Style Options

Select Style to display a list of seven view options for graphs.

add|Owerlas. .

Remowve Chvetlay P

Set Time Period. ..

Change Constraint Yalues. ..

Select Modes)Interfaces. ..

Displayed Data r % !

Grid ]

Legend b A

Skyle Area

Change Max Rows. .. Stacking Area

Display Data Table Bar

Expott Element as C5Y... Stacking Bar

Display Crverlay Data Table Pie

Export Graph @verlay Data as C5.,. * Plat

Yiew in new Frame Scatter Flot

Print Graph. .. iHle |

e e Hi-Lo-Open-Close L
- Shlutcl nat Candle

Edliting Tables and Graphs
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Style > Area

The plot or bar chart changes to an area graph. While relative values and total values are
easy to view in this format, absolute values for smaller data types may be hard to see. Click
anywhere within a band of color to display the exact value for that location

Disconnect Cause Hourly Totals for Yesterday
For Selected Gateway Group

143240 ¢

11880 ¢+

9560 ¢

olure

T1.70 ¢

Sat Feb 24 06:00 AWM EST
Mormal Dizconnect (107 j= 74.00

s

o ' =
0400 000 0200

10:00 12:00 14:00 1800 4800 2000 2200

To shorten the time span of a graph, press SHIFT+ALT and use the left mouse button to
highlight the time span you want to focus on. Release the mouse button to display the selected

time span.

Style > Stacking Area

The area or plot graph changes to a stacking area graph. This view is suitable for displaying a
small number of variables.

% 200.00

1E80.00
120.00
20.00

40.00

hon 01 Tue 02 Wed 03

M g Utilization (H)
I 0 2 Utilization (Ha
M Util Threshold
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Style > Bar

The graph changes to a bar chart. This view is suitable for displaying relatively equal values
for a small number of variables. There are three variables in the graph below.

11,924 .00 +

953920 1

7,154.40 1

4 TE9 60

Forecast Minutes

228480 1

I

Thwa 04 Fri 02 Sat 03 Sun 04

Style > Stacking Bar

O=ys Of The Week

hon 05

Tue 05

Wead 07

The plot or area graph changes to a stacking bar chart. If you increase the width of the frame,
the time scale becomes hourly. If you increase the height of the frame, the call volume shows

in units of ten.

200.00
160.00
120.00

20.00

40.00

u]
bon 04 Tue 02

M 2o Utilization cH)
I i 2 Utilization (H)
M Uil Threshiald

Edliting Tables and Graphs
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Style > Plot

Bands of color in an area graph change to lines. If you adjust the frame width, you can make
the data points align with hour; if you adjust the frame height, you can turn call volume into
whole numbers.

Ta.50 1

E2.80 1 ﬂ
B
47.10 1 o M W

3140 1

15.70 1

u] + +
hon a1 Tue 02 Wied 03

— Auwrg Utilization (H)
— Max WMilization (H)
— Wil Threshald

Style > Pie

An area graph becomes a pie chart. Bands in an area graph convert to slices of a pie and the
pie constitutes a 24-hour period. This view is helpful when a small number of data values are
represented and you are looking at data for one day.

Mimurtes Of Use Distributions for Yesterday
For Selected Customer

M Under 1 minute

O patween 1 and § minutes

O Between & and 20 mingtes

O petween 30 minutes and 2 hours
M petween 2 hours and 12 hours
M Cwer 12 hours

If you are looking at data for more than one day, you will see multiple pie graphs, one for each
day.
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Display Data Table

This option changes a graph into a spreadsheet.

=1k
w Bxis I Average I

Tue Feb 19 .., 0,509

Tue Feb 19 .., 0621

Tue Feb 19 .., 1,026

Tue Feb 19 .., 0,362

Tue Feb 19 .., 1,171

Tue Feb 19 .., 1,051

Tue Feb 19 .., 0,254

Tue Feb 19 .., 0.826

Tue Feb 19 .., 1,433 [,\\5

Tue Feb 19 .., 0,967

Tue Feb 19 .., 1,471

Tue Feb 19 .., 1,305

Tue Feb 19 .., 1,123

Tue Feb 19 .., 0.93

Tue Feb 19 .., 1,497

Tue Feb 19 .., 0,806

Tue Feb 19 .., 0.725

View in New Frame

The graph opens in a Graph Viewer window. Improve legibility by resizing the window.

=0l x|

Hetwork Response Time
Cisco_04
Tue Feb 19 12:00 AM - Tue Feb 18 14:00 PM

Seconds

Tue 05:00 A Tue 11:00 PM
— Ffwerage

Edliting Tables and Graphs
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Index

A

Add or Update Category Information (form), 34
Add or Update NNM List (form), 31

alarm category, 11

Availability folder, 10

availability threshold, 36

B
bulk import, 29

C
change max rows option, 59
change view, 31

Common Property Tables, 17, 20
upgrading, 15

Consolidated (folder), 12
Copy Policy Manager, 25

D

demo package, 20
Display Data Table, 59
displayed data option, 59

E
editing parameters, 12
Event folder, 10

extracting packages, 19

G

General folder, 11
grid options, 59
group accounts, 12

group filters, 12

H
HTTP port numbers, 37

L
legend options, 59
LIR Configuration, 24

(o)

OVPI Timer
starting, 17
stopping, 16

P

polling granularity, 31
polling interval, 31

R
Remove Alarm Category (form), 35
Remove NNM Stations (form), 33

S
Severity folder, 11
style options for graphs, 59

U

Update Availability Threshold (form), 36
upgrading Common Property Tables, 15
Use Absolute Time, 57

\'}

view in new frame, 58
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We appreciate your feedback!

If an email client is configured on this system, by default an email window opens when you
click on the bookmark “Comments”.

In case you do not have the email client configured, copy the information below to a web mail
client, and send this email to docfeedback@hp.com

Product name:
Document title:
Version number:
Feedback:
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