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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

You can visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software Support Online provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As 
a valued support customer, you can benefit by using the HP Software Support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 

To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 
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1 HP Storage Essentials SRM Overview
HP Storage Essentials SRM (HP SE SRM) is a family of open standards-built 
Storage Area Network Management and Storage Resource Management 
solutions that enable you to visualize, monitor, report on, provision, and 
manage your heterogeneous storage environment with simplicity and speed.

It features a base management console and an expanding portfolio of value 
added plug-ins. When HP Storage Essentials is integrated with HP System 
Insight Manager (HP SIM), HP Storage Essentials SRM is accessed through 
HP SIM menu items that are labeled HP Storage Essentials SRM.

 Key Features and Benefits of HP Storage Essentials SRM

• Visualization

Discovers automatically and maps the storage network (DAS, SAN, NAS) 
and backup topology by displaying the objects, path, and zones between 
the application and the LUN on which the corresponding data resides.

• Zoning and provisioning

Enables end-to-end zoning and provisioning tasks at the host, switch, and 
disk subsystem layers. Provides a common interface for a multi-vendor 
storage environment.

• Utilization management

Monitors availability and utilization at hosts, switches, and arrays. 
Provides graphical trending and forecasting. Soft Quota management 
enables proactive monitoring of consumption levels. File system 
management provides file-level scanning, analysis, reporting, and 
policy-based management capabilities.
 9



• Performance management 

Monitors performance from application objects down to storage 
subsystems. Monitors applications, hosts, HBAs, switches, and disk 
subsystems. Enables quick detection of bottlenecks that cause 
performance problems.

• Chargeback 

Supports customizable chargeback values, depreciation formulas, 
asset-based and storage-based chargeback models, and business unit 
groupings. Reports enable administrators to associate costs with the 
quality and quantity of storage used by different business units.

• NAS management 

Analyzes the impact of configuration changes and file sharing activities.

• Backup management 

Offers a single view of backup activities. Identifies unprotected 
applications, servers, and files. Enables root cause analysis of backup 
failure. Increases utilization of backup resources.

• Standards-based architecture 

Designs solution on the Storage Management Initiative Specification 
(SMI-S), the storage industry standard for heterogeneous storage network 
management based on the Common Information Model (CIM) and 
Web-Based Enterprise Management (WBEM). Enables support for 
multi-vendor storage infrastructures and ensures that investments are 
protected.

CIM is a common data model of an implementation-neutral schema for 
describing overall management information in a network/enterprise 
environment. CIM consists of a specification and a schema. The 
specification defines the details for integration with other management 
models such as Simple Network Management Protocols (SNMPs), 
Management Information Base (MIBs), and the Distributed Management 
Task Force’s (DMTFs) Maker Interchange Formats (MIFs). The schema 
provides the actual model descriptions.

• Customizable reports 

Generates an extensive set of out-of-the-box reports that satisfy 
requirements related to capacity management, planning, performance 
management, asset management, and chargeback. Reports can be 
10 Chapter 1



customized and scheduled for automatic email distribution. Supports a 
wide variety of reporting formats, including HTML, XML, Microsoft Excel, 
and PDF.

• End-to-end visibility of business applications 

Provides an interface to monitor business applications, including their 
associated infrastructure and interdependencies.

• Web-based global management console 

Manages heterogeneous storage environments through a web-based user 
interface.

• Reporting 

Offers flexible, in-depth report generation in both predefined and 
user-defined formats. It can also export data to other management 
applications.

• Standards-based architecture 

Protects user flexibility and investments with a standards-based interface 
for managing heterogeneous storage environments.

• Storage server, network, and subsystem provisioning 

Reduces manual processes and risk of downtime caused by free-space 
outages with multi-level storage provisioning.

• Integrated storage management 

Lowers cost of acquiring and managing a heterogeneous storage 
environment by using multiple disparate point solutions.

You can find more information on features of HP Storage Essentials SRM and 
other HP management products at the following HP web sites:

http://www.managementsoftware.hp.com/ 

http://www.hp.com/go/storageessentials 
HP Storage Essentials SRM Overview 11



HP Storage Essentials SRM SPI Overview

The HP Operations Smart Plug-in for HP SE SRM (the HP Storage Essentials 
SRM SPI) integrates HP SE SRM with HP Operations Manager (HPOM). The 
HPOM management scope for the HP Storage Essentials SRM SPI includes 
storage infrastructure managed by HP SE SRM installed in an environment 
that consists of the HPOM.

The HP Storage Essentials SRM SPI is used to monitor the HP SE SRM 
services and infrastructure. The HP Storage Essentials SRM SPI, forwards 
events from HP SE SRM Central Management Server (CMS) to HPOM.

The HP Storage Essentials SRM SPI, allows the storage network to be 
monitored and managed from the HPOM management server console.

The HP Storage Essentials SRM SPI enables HPOM administrators to 
troubleshoot problems in the storage network before they become serious 
enough to affect tools and, ultimately, the end-users. Storage events are stored 
in the HPOM database. The HPOM intelligent agents are configured on the 
HP SE SRM CMS.

The HPOM intelligent agents are configured on the HP Storage Essentials 
SRM CMS, and managed servers that are managed nodes in the HPOM 
management domain. The CMS runs the HP Storage Essentials SRM 
AppStorManager service and initiates all management operations within the 
management domain.
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Features and Functionality of the HP Storage Essentials 
SRM SPI

The HP Storage Essentials SRM SPI offers the following:

• Service Discovery 

Discovers the HP SE SRM CMS and HP SE SRM-managed hosts CIM 
Extension services.

• Service and process monitoring 

Monitors the availability of the HP SE SRM CMS and HP SE SRM CIM 
Extension. Any service alerts can be communicated to the HPOM service 
map and the HPOM active message browser. This enables administrators 
to perform root-cause analysis of the inherent HP SE SRM services.

• Policy groups 

Contains policies for monitoring the HP SE CMS process 
(AppStorManager) and the HP SE CIM Extension process, policies for 
forwarding events from HP SE SRM CMS to HPOM and policies for 
clearing events on HP SE SRM CMS when the corresponding events are 
cleared on the HPOM.

• Tool groups 

Contains tools to start, stop, and view the status of the HP SE CMS 
process (AppStorManager) and the HP SE CIM Extension process. It also 
has a tool to import the SE SRM Infrastructure elements to the HPOM 
Node Bank.
HP Storage Essentials SRM Overview 13
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2 Installing the HP Storage Essentials SRM 
SPI
This chapter provides information on installing the HP Storage Essentials 
SRM SPI.

Installation Requirements

Standard Installation of SPI Components on an HPOM 8.10 Server

By using the HP Operations Smart Plug-ins DVD you can select to install only 
HP Storage Essentials SRM SPI package and not the reporter and graphing 
packages. However, if the full version of Reporter or Performance Manager is 
installed on the same system, the corresponding packages can be installed or 
uninstalled on the HPOM server.

Standard Installation on Remote Consoles

All the Remote Console packages on the SPI DVD including the HP Storage 
Essentials SRM SPI are installed at once on to remote consoles. No option is 
provided to select a particular remote console package.

Standalone HP Reporter and HP Performance Manager

For such a machine only the corresponding package of any SPI is enabled and 
available for selection from the HP Operations Smart Plug-Ins DVD. For 
example, if a system has only HP Reporter installed then the reporter package 
of any SPI could be installed on it. The same applies to the graphing package 
and HP Performance Manager.
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Installation Prerequisites

For the HP Storage Essentials SRM SPI to run properly, your system must 
meet the requirements described in this section.

Hardware Requirements

The following documents explain all the hardware requirements: 

• For the HPOM 8.10: 

HP Operations Manager for Windows Installation Guide

• For the HPOM 8.10 HTTPS managed nodes:

HP Operations Manager HTTPS Agent Concepts and Configuration 
Guide

Disk Space Requirements

Table 1 Disk space requirements  

System Operating System Installation
Runtime 
Files Total

HPOM 
management 
server 8.10

Windows 2008 EE (32-bit)
Windows 2003 R2 (32-bit)

4 MB 1 MB 5 MB
16 Chapter 2



Software Requirements

• HPOM for Windows 8.10 is updated with the latest server and agent 
patches

• HP Storage Essentials SRM 6.0 (SP4), 6.1.0, 6.1.1

HPOM managed 
node

HP-UX 11.11
HP-UX 11.23 IA
HP-UX 11.23 PA
HP-UX 11.31 PA
HP-UX 11.31 IA

1 MB 1 MB 2 MB

Solaris 8, 9,10

RedHat Linux Advanced Server 
4.0 (32-bit and 64-bit)
RedHat Linux Advanced Server 
5.0 (32-bit)
SuSE Linux Enterprise Server 9 
(32-bit and 64-bit)
SuSE Linux Enterprise Server 
10 (32-bit)

AIX 5.1, 5.2, and 5.3

Tru64 5.1B

Microsoft Windows 2003 (32-bit 
and 64-bit)
Microsoft Windows 2003 R2 
(32-bit and 64-bit)
Microsoft Windows 2008 (32-bit)

1 MB 1 MB 2 MB

No additional memory (RAM) is required either on the HPOM or on the 
managed nodes for the HP Storage Essentials SRM SPI.

System Operating System Installation
Runtime 
Files Total
Installing the HP Storage Essentials SRM SPI 17



• HP Operations Smart Plug-In Self-Healing Integration Component, 
Version 2.30

HPOM Management Server Versions

Table 2 Versions of HPOM management server 

HP SE SRM CMS Versions

Table 3 Versions of HP Storage Essentials CMS 
. 

HPOM Management 
Server Operating System

HPOM Agent 
Types

HPOM 8.10 • Microsoft Windows 2003 
(32-bit)

• Microsoft Windows 2003 R2 
(32-bit)

• Microsoft Windows 2008 
EE (32-bit)

HTTPS

DCE

HP SE SRM Operating System

HP Storage Essentials 6.0, SP4
HP Storage Essentials 6.1.0
HP Storage Essentials 6.1.1

• Windows 2003
• Windows 2003 R2 (32-bit)
• RedHat Linux EL 4.0(32-bit)
• SuSE Linux ES 9 (32-bit) and 

SLES 10
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CIM Extension and HPOM Agent Versions

Table 4 Versions of CIM Extension and HPOM Agent
  

Agent Operating System

CIM Extension
HPOM Agent

Windows 2003 (32-bit and 64-bit)
Windows 2003 R2 (32-bit and 64-bit)
Windows 2008 (32-bit)
HP-UX 11.11
HP-UX 11.23 PA
HP-UX 11.23 IA
HP-UX 11.31 PA
HP-UX 11.31 IA
Solaris 9
Solaris 10
RedHat Linux EL 4.0 (32-bit)
RedHat Linux EL 4.0 (64-bit)
SuSE Linux ES 9 (32-bit)
SuSE Linux ES 9 (64-bit)
AIX 5L 5.1
AIX 5L 5.2
AIX 5L 5.3
Tru64 5.1 B
Installing the HP Storage Essentials SRM SPI 19



Installing the HP Storage Essentials SRM SPI

Before you install and configure the HP Storage Essentials SRM SPI software, 
make sure you delete the previously installed Storage Essentials SRM SPI 
version. This is a mandatory step before you proceed with the installation.

Also make sure that you install HPOM and patch it to the latest required 
level. After completing the installation of HPOM, use the HP Operations 
Smart Plug-ins DVD to install the HP Storage Essentials SRM SPI software.

Follow these steps:

1 Insert the Smart Plug-ins, DVD into the DVD drive of the management 
server or console system. 

2 Click Next to continue.

3 Click Next to proceed.
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4 In the next dialog, select HP Storage Essentials SRM to install.

5 When complete with selecting products, click Next.
Installing the HP Storage Essentials SRM SPI 21



6 HP Operations Manager 8.10 deploys policies automatically only when 
desired. Select to disable or enable the Auto Deployment feature.

7 Indicate your acceptance of licensing agreement terms by selecting the I 
accept the terms in the license agreement button.

8 Click Next.
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9 Selecting Back allows you to edit previous selections, otherwise, click 
Install to begin installation.

10 You will see various status dialogs as the install program proceeds. 
Depending on the speed of your system and the components selected for 
installation, this process could take several minutes or more.

11 Click Finish to conclude the installation.

Selecting the Cancel button after the installation has started does 
not halt the entire installation process, but only that of the product 
currently being installed (shown in the Status area); installation of 
the next selected product then begins.
Installing the HP Storage Essentials SRM SPI 23



Verifying Installation

Open the HPOM console and check that the following elements are present. 

Table 5 List of elements to be present in the HPOM console

If they are not present in the HPOM console, uninstall the HP Storage 
Essentials SRM SPI (see Uninstalling HP Storage Essentials SRM SPI from 
HPOM on page 76) and reinstall it (see Installing the HP Storage Essentials 
SRM SPI on page 20).

HPOM Console Element

Node Groups HP SE SRM CMS-Win
HP SE SRM CMS-Unix
HP SE SRM CIM Extn-Win
HP SE SRM CIM Extn-Unix

Tool Groups HP Storage Essentials SRM 
• AppStorManager-Win
• AppStorManager-Unix
• CIM Extension-Win
• CIM Extension-Unix
• HPSESRMSPI Utils

Policy Groups HP Storage Essentials SRM
• HP SESRM Event Acknowledging
• AppStorManager-Win
• AppStorManager-Unix
• CIM Extension-Win
• CIM Extension-Unix
• Service Discovery

User Roles HP SE SRM SPI Admin
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Installed File Locations

The installation process copies the necessary files on the HPOM.

Table 6 Location of the installed files on the HPOM
  

The following lists the directories that are used on deployment of the policies 
to the HPOM managed node(s). 

Table 7 List of Directories 
   

The HP Storage Essentials SRM SPI instrumentation scripts are copied into 
these paths when the HP SE SRM instrumentation is deployed to the 
managed nodes.

File Type Location on the HPOM

Binaries and Scripts <OvInstallDir>install\HPSESRMSPI
<HP 
OMShareInstallDir>SPI-Share\HPSESRMSPI

Instrumentation <OvInstallDir>Data\shared\Instrumentation
\Supported Operating Systems\HP Storage 
Essentials SRM

Documentation <OvInstallDir>install\HPSESRMSPI\doc

MofFiles <OvInstallDir>install\HPSESRMSPI\NLS\1033
\MofFiles

Operating System File Location

HP-UX, Solaris, Linux, Tru64  /var/opt/OV/bin/instrumentation

Microsoft Windows <OvAgentDir>\bin\instrumentation

AIX /var/lpp/OV/OpC/instrumentation
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3 Configuring the HP Storage Essentials 
SRM SPI
Configuring the HP Storage Essentials SRM SPI requires the following tasks.

Task 1: Install the HPOM Agent on Nodes

The HPOM agent must be installed on all the nodes that needs to be managed 
by the HPOM. Before starting, make sure that the system on which you want 
to install the HPOM agent meets the installation requirements provided in 
Chapter 2, Installing the HP Storage Essentials SRM SPI. 

You can install the HPOM agent on a managed node by various methods. For 
more information on the various installation methods, see the HP Operations 
Manager for Windows Installation Guide and also the documents listed in 
Chapter 2, Installing the HP Storage Essentials SRM SPI.

Task 2: Assign Nodes to the HP SE SRM Node Group

Assigning the AppStorManager Node to the Node Group

This tool assigns the node to the chosen HP SE SRM CMS node group and 
deploys the HP SE SRM policy groups AppStorManager-Unix or 
AppStorManager-Win (depending on your node’s operating system) and 
Service Discovery policies. The service discovery policy deployment causes the 
HP SE SRM discovery process to run. If an HP SE SRM service is not 
discovered, the corresponding monitor policy is disabled.
 27



To assign the nodes on which the HP SE SRM AppStorManager service is 
running to the node group, follow these steps:

1 Log on to the HPOM management server, and start the HPOM Console.

2 Select Tools > HP Storage Essentials SRM > AppStorManager-Unix or 
AppStorManager-Win and right-click Assign AppStorManager node to node 
group.

3 Select All Tasks > Launch Tool. The Edit Parameters window opens.
  

4 From the Select the nodes/services to replace $OPC parameters 
with, select the node on which the SE SRM AppStorManager service is 
running.
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5 Click Launch…. The Tool Status window opens.
  

This assigns the node on which the SE SRM AppStorManager process is 
running to the HP SE SRM CMS-Unix or HP SE SRM CMS-Win node 
group.  

When the managed node is assigned to the HP SE CMS-Win Node 
group using “Assign Node to Node Group” Tool, the following 
warning message is displayed on the HPOM.

Discovery command  "C:\WINDOWS\system32\cmd.exe /C "perl 
"C:/Documents and Settings/All Users/Application Data/HP/HP 
BTO Software/bin/instrumentation/
HPSESPI_CreateHostServices.pl""" returned with non-zero return 
value.

This occurs because HP SESRM authentication is not provided. 
The authentication is provided when you run the Get HP SE 
SRM Credentials tool from the HP SE SRM SPI Utils tools 
group.
Configuring the HP Storage Essentials SRM SPI 29



The HP SE SRM instrumentation and relevant policies gets auto-deployed 
along with the Service Discovery policy to the node.  

6 Assign the CIM Extension Node to the Node Group.

To assign the node on which the SE SRM CIM Extension process is running to 
the node group, follow these steps:

1 Log on to the HPOM management server and start the HPOM Console.

2 Select Tools > HP Storage Essentials SRM > CIM Extension-Unix or CIM 
Extension-Win and right-click Assign CIM Extension node to node group.

3 Select All Tasks > Launch Tool. The Edit Parameters window opens.

When the new nodes are added in the HP SE SRM CMS-Unix or 
HP SE SRM CMS-Win node group, the Service Discovery policy 
is deployed to each new node.

The automatic policy deployment requires the HPOM agent to be 
present on the managed nodes. If the HPOM agent is not present 
on the Windows nodes, the management server deploys the agent 
automatically if the node is not an external node. For UNIX 
nodes, the agent must be installed manually. You can install the 
HPOM agent by various methods. For more information, see HP 
Operations Manager for Windows Installation Guide.
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4 From the Select the nodes/services to replace $OPC parameters 
with, select the node on which the SE SRM CIM Extension process is 
running.

5 Click Launch…. The Tool Status window opens.
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This assigns the node on which the SE SRM CIM Extension process is 
running to the HP SE SRM CIM Extn-Unix or HP SE SRM CIM Extn-Win 
node group.  

Assigning the HP SE SRM CIM Extension node to the node group also starts 
auto-deployment of the HP SE SRM CIM Extension Service Monitoring policy 
to the node.

When the new nodes are added in the HP SE SRM CIM Extn-Unix or HP SE 
SRM CIM Extn-Win node group, the Service Discovery policy is deployed to 
each new node.
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Task 3: Obtain HP SE SRM Credentials

To start the functionality provided with the HP Storage Essentials SRM SPI, 
you must first enter the HP SE SRM credentials for each HP SE SRM CMS.  

To obtain HP Storage Essentials SRM SPI credentials, follow these steps:

1 Log on to the HPOM management server and start the HPOM Console.

2 Select Tools > HP Storage Essentials SRM > HP SE SRM SPI Utils and 
right-click Get HP SE SRM Credentials.

HP SE SRM credentials are stored in an encrypted format on the HPOM 
managed nodes.
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3 Select All Tasks > Launch Tool. The Edit Parameters window opens.  

4 From the Select the nodes/services to replace $OPC parameter 
with option, select the node on which HP SE SRM CMS is running.

5 Click Launch. The following message is displayed:

Enter the HP Storage Essentials SRM username:

6 At the prompt, enter the HP SE SRM user name for HP SE CMS on this 
node and press Enter. The following message is displayed at the prompt:

Enter the HP SE SRM password:

7 Enter the corresponding HP Storage Essentials SRM password and press 
Enter.

Validating the entered credentials for omidl09...
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The entered credentials have been successfully 
authenticated !!
Press the Enter key to exit

The tool attempts to verify the user name and password. At the prompt, 
press Enter to exit.

If the credentials entered are not authenticated by HP SE SRM, the 
following message is displayed:

Failed to validate the HP SE CMS credentials. Possible 
causes could be:
1. HP SE SRM CMS is not installed
2. HP SE SRM CMS service is not running
3. HP SE SRM CMS credentials incorrect
Press any key to continue . . .

8 Press Enter. The command prompt window closes.  

  

  

After successful execution, the hpsecms.conf file is created on the 
HP SE SRM CMS node. This file is a prerequisite for significant 
features like importing HP SE SRM infrastructure, 
forwarding HP SE SRM events to HPOM and drawing HP SE 
SRM service map. If the service discovery policy is present on the 
node, soon after the execution of the Get Credentials tool, the 
service map would be drawn.

Service Discovery does not function correctly if the user name and 
password are incorrect. If you do not know the user name and 
password, contact your system administrator.
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Task 4: Import HP SE SRM Infrastructure

To get events from the HP SE SRM devices, you must import the 
infrastructure for each of the HP SE SRM CMS. To import the HP SE SRM 
Infrastructure, follow the below mentioned steps.

1 Log on to the HPOM Management Server and start the HPOM Console.

2 Select Tools > HP Storage Essentials SRM > HP SE SRM SPI Utils and right 
click Import HP SE SRM Infrastructure

3 Select All Tasks > Launch Tool. The Edit Parameters window opens.

4 From the Select the nodes/services to replace $OPC parameters 
with option, select the node on which the HP SE SRM CMS is running.

This tool can be executed only on HTTPS agent nodes.
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5 Click Launch. This will add all the Hosts, Switches and Storage Systems to 
the Node Bank.
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6 Click Enter. The command prompt window closes automatically.

Now the HP SE SRM Infrastructure (Fabrics and corresponding Hosts, 
Switches and Storage Systems) is added to the HPOM Node Bank under 
the Node Group HP SE SRM INFRA with the following sub groups.
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• HP SE SRM INFRA

— FABRICNAME-SECMS
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– HP SE SRM HOSTS

– HP SE SRM SWITCHES

– HP SE SRM STORAGESYSTEMS

Task 5: Configure the HPOM Agent for a Non-root User

For information on configuring the HPOM agent to run as a non-root user, see 
the HP Operations HTTPS Agent Concepts and Configuration Guide.

To configure non-root user on Linux nodes, follow these steps:

1 Log on to the managed node as a root user and open a terminal window.

2 Access the instrumentation directory of the node:

The HP SE SRM INFRA node groups and the nodes that they contain should 
be deleted manually after the HP SE SRM CMS node is unmanaged from 
HPOM.

To delete the HP SE SRM SPI Infrastructure node groups and the nodes that 
they contain, execute the following steps:

1 Open the Node Configuration Editor.
2 On the right pane, right click on HP SE SRM INFRA node group and click 

on Delete.
3 A Confirm Delete window opens, click on Yes.

The device(s) without any fabric association is not added to the Node Bank.

If a host already exists in HP SE SRM INFRA and becomes a HPOM 
managed node, then all the new events are mapped to the HPOM managed 
node only. You have to delete the node manually using HPOM node editor 
from HP SE SRM INFRA. This will help you to identify the node that get 
events.
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cd /var/opt/OV/bin/instrumentation

3 Enter the following command at the command prompt:

./HPSESPI_perl HPSESPI_root.pl.

This command generates the HPSESPI.su file.

The following message is displayed on successful execution of the 
command:

The script has completed successfully.

The HP Storage Essentials SRM SPI does not support a non-root HPOM agent 
on AIX and Tru64 CIM Extension nodes.

Providing Access to HP Storage Essentials SRM SPI Applications

To provide access to HP Storage Essentials SRM SPI applications, follow these 
steps:

1 Log on to the managed node as a root user, and open a terminal window.

2 Open the following file: 

/etc/HPSESPI.su

3 Edit the file by uncommenting lines or by adding the following:

root:$CIMExtnPath/APPQcime/tools/start
root:$CIMExtnPath/APPQcime/tools/stop
root:$CIMExtnPath/APPQcime/tools/status
root:/etc/init.d/appstormanager start
root:/etc/init.d/appstormanager stop 

On HP-UX and Linux, the $CIMExtnPath is /opt 

On Solaris, enter the following command to get the value for $CIMExtnPath:

/usr/bin/pkginfo -r APPQcime
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Task 6: Configuring the HP SE SRM SPI to forward HP 
SE SRM events to HPOM

To forward HP SE SRM Events, complete the following steps:

1 Specifying a Filter for Events Forwarded from Storage Essentials SRM to 
HPOM.

2 Enable event forwarding from HP SE SRM CMS to HPOM.

Specifying a Filter for Events forwarded from Storage Essentials to 
HPOM

Users can filter events forwarded from Storage Essentials SRM to HPOM.

Filtering events sent to HPOM has the following advantages:

• Improved usability - Although all event notification is theoretically 
useful, some events may have little information value. For example, Log In/
Log out events for Storage Essentials SRM may be of little interest to an 
administrator who is concerned primarily with important and critical SAN 
events. The administrator can filter out these “informational” events.

• Increased system performance - Storage Essentials can generate a large 
number of events that appear in HPOM. Certain events can be filtered out in 
order to limit the communication traffic.

Events can be filtered based on the following:

• Event severity - Use the <event-filter-severity> tag to filter out events by 
severity.

• Element type - Use the <event-filter-element-type> tag to filter out events 
by element type.

• Element name - Use the <event-filter-element-name> tag to filter out 
events by element name.

It is possible to specify multiple filter criteria, in which case the resulting 
filter is a disjunction (the logical or) of the filter conditions. For example, the 
following filter excludes events from hosts or events from all element types 
with INFORMATIONAL severity from being forwarded from Storage 
Essentials to HPOM.
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Essentials to HPOM:

<HP-config>

<event-filter-severity>INFORMATIONAL</event-filter-severity>

<event-filter-element-type>HOST</event-filter-element-type>

</HP-config>

To filter events forwarded to HPOM:

1 Go to the %OvDataDir%\bin\instrumentation directory on the HP SE 
SRM CMS

2 Create a file named hp-event-config.xml in the 
%OvDataDir%\bin\instrumentation directory.

3 Open the hp-event-config.xml file in Notepad.

4 Add the following to the file:

<HP-config>

</HP-config>

Your filter tags will go between the <HP-config> tags, as shown in the 
following example:

<HP-config>

<event-filter-severity>INFORMATIONAL</event-filter-severity>

<event-filter-element-type>HOST</event-filter-element-type>

</HP-config>

5 To filter events by severity, use the <event-filter-severity> tag. For 
example, to prevent informational events from being forwarded to HP SE 
SRM, enter the following between the

<HP-config> tags:

<event-filter-severity>INFORMATIONAL</event-filter-severity>

You can also filter out the following event severities:

• UNKNOWN

• CRITICAL

• MAJOR

• MINOR
Configuring the HP Storage Essentials SRM SPI 43



• INFORMATIONAL

• WARNING

6 To filter events by element type, use the 
<event-filter-element-type> tag. For example, to prevent events 
from hosts from being forwarded to HPOM, enter the following:

between the <HP-config> tags:

<event-filter-element-type>HOST</event-filter-element-type>

You can filter out the following element types:

• HOST

• SWITCH

• STORAGE_SYSTEM

• TAPE_LIBRARY

7 To filter events by name, use the <event-filter-element-name> tag. For 
example, to prevent events from an element named ElementA from being 
forwarded to HPOM, enter the following between the <HP-config> tags:

<event-filter-element-name>ElementA</event-filter-ele-

ment-name>
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Enable event forwarding from HP SE SRM CMS to HPOM

To start the event forwarding from HP SE SRM to HPOM running on 
Windows or UNIX, complete the following steps:

1 Launch Start forwarding HP SE SRM events to HPOM tool available in the 
Tools > HP Storage Essentials SRM > AppStormanager - Win or 
AppStorManager - Unix tool group, depending on the operating system of 
HP SE SRM CMS node. The Select where to launch this tool appears.
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2 From Select Nodes/Services pane, select the HP SE SRM CMS node in 
HP SE SRM CMS-Win or HP SE SRM-Unix node group.
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3 Click Launch.... . The tool status window appears.

This would initiate event forwarding from HP SE SRM to HPOM based on 
any filters set.
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 Task 7: Configuring Event Acknowledgement from HP 
SE SRM CMS to HPOM

HP SE SRM SPI is configured to automatically acknowledge an event on the 
HPOM if the corresponding event is cleared in the HP SE SRM Event browser. 
This is enabled by the policy named 
HPSESRMSPI-HPSESRM_Events-Win or 
HPSESRMSPI-HPSESRM_Events-Unix which is auto deployed to the 
nodes when the nodes are added in the HP SE SRM CMS-Unix or HP SE 
SRM CMS-Win node group.

Task 8: Configuring Event Clearing from HPOM to HP 
SE SRM CMS 

HP SE SRM SPI can be configured to automatically clear an event on the HP 
SE SRM CMS if the corresponding event is acknowledged in the HPOM 
message browser. For this functionality, the policies in the policy group HP 
Storage Essentials SRM > HP SE SRM Event Acknowledging are 
deployed to the HPOM management server while installing HP SE SRM SPI 
The policies are:

• HPSESRMSPI-HPSESRM_ClearEvents

• HPSESRMSPI-HPSESRM_Auto_Acknowledge

• HPSESRMSPI-HPSESRM_DupEvent_Acknowledge

To verify whether the polices are deployed on the HPOM console, follow these 
steps:

1 Right-click the HPOM managed node.

2 Select View > Policy Inventory and look for the presence of the above listed 
policies. 

If the policies are not deployed to HPOM, follow these steps:

3 Select Policy Groups > HP Storage Essentials SRM and right-click HP SE SRM 
Event Acknowledging.
48 Chapter 3



4 Select All Tasks > Deploy on. The Deploy policies on window opens.

5 Select the HPOM server node.

6 Clear deploy policy only if version is newer option.

7 Click OK.

For event clearing from HPOM to SESRM CMS, the event on the HPOM 
message browser should be acknowledged one at a time. The dependent 
events are also acknowledged. Acknowledging multiple events is not 
supported.
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Task 9: Reconfigure HP SE SRM CMS Credentials for HP 
SE SRM SPI

Follow these steps:

1  Stop forwarding HP SE SRM Events to HPOM.

2 Enter the new HP SE SRM CMS credentials.

For more information, see Task 3: Obtain HP SE SRM Credentials on 
page 33.

3 Start forwarding HP SE SRM Events to HPOM, see Task 6: Configuring 
the HP SE SRM SPI to forward HP SE SRM events to HPOM on page 42.

The credentials are used by HP SE SRM SPI for clearing the events on HP SE 
SRM CMS when acknowledged on HPOM.

The following functionalities require HP SE SRM credentials:

• Viewing the Service discovery map

• Importing the HP SE SRM Infrastructure

• Forwarding the events from HP SE SRM CMS to HPOM

• Acknowledging the events on HPOM when they are cleared on the HP SE 
SRM CMS

• Clearing the events on HP SE SRM CMS when acknowledged on HPOM.
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4 Using the HP Storage Essentials SRM 
SPI
Using the HP SE SRM SPI Policies

All policies provided with HP SE SRM SPI are grouped under the HP 
Storage Essentials SRM policy group. HP SE SRM SPI provides a set of 
pre-configured policies for HP SE SRM nodes. These policies enable you to 
monitor the status of the services running on these nodes.

The HP SE SRM SPI installation creates the following high-level policy 
groups:

• AppStorManager-Unix

• AppStorManager-Win

• CIM Extension-Unix

• CIM Extension-Win

• HP SE SRM Event Acknowledging

• Service Discovery
  

For more information on the pre-configured policies provided by HP SE SRM 
SPI, see HP Storage Essentials SRM SPI Policy Groups.
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Using the HP Storage Essentials SRM SPI Node Group

Installing the HP Storage Essentials SRM SPI creates the following node 
groups (shown in the figure that follows):

• HP SE SRM CMS-Unix

• HP SE SRM CMS-Win

• HP SE SRM CIM Extn-Unix

• HP SE SRM CIM Extn-Win
  

You can find more information about adding nodes in Task 2: Assign Nodes to 
the HP SE SRM Node Group on page 27.

Node folders and tool folders are associated as follows:
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Table 8 Association between nodes folder and tools folder 

Nodes Folder Tools Folder

HP SE SRM CMS-Unix AppStorManager-Unix

HP SE SRM CMS-Win AppStorManager-Win

HP SE SRM CIM Extn-Unix CIM Extension-Unix

HP SE SRM CIM Extn-Win CIM Extension-Win
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Using HP Storage Essentials SRM SPI Tools

The HP Storage Essentials SRM SPI adds the top-level tools group in the 
HPOM Application bank window. The HP SE SRM tools group contains the 
following tools (shown in the figure that follows):

• AppStorManager-Unix

• AppStorManager-Win

• CIM Extension-Unix

• CIM Extension-Win

• HP SE SRM SPI Utils
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The HP Storage Essentials SRM SPI tool folders contain a number of tools 
that enable the HPOM administrator to manage HP SE SRM. 

The AppStorManager-Unix or AppStorManager-Win tools group contains 
tools that can be run on HP SE SRM CMS nodes (UNIX or Windows).

Using the AppStorManager Tools Group

The AppStorManager-Unix or AppStorManager-Win tools group includes 
tools for HP SE SRM AppStorManager that are run on HP SE SRM CMS 
server nodes.

The AppStorManager tools group includes the following tools that monitor the 
HP SE SRM AppStorManager process on selected UNIX or Windows nodes.
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Table 9 Name of tools which monitor the HP SE SRM AppStorManager process
  

Tools Group Tool Name Description

AppStorManager-Unix AppStorManager-Unix Start Starts the HP SE SRM 
AppStorManager service on 
selected Unix nodes.

AppStorManager-Unix 
Status

Status of HP SE SRM 
AppStorManager service on 
selected Unix nodes.

AppStorManager-Unix Stop Stops the HP SE SRM 
AppStorManager service on 
selected Unix nodes.

Assign AppStorManager 
Unix node to node group

Assigns Storage Essentials SRM 
AppStorManager Unix node to 
\"HP SE SRM CMS-Unix\" node 
group.

De-assign AppStorManager 
Unix node from node group

De-assign AppStorManager Unix 
node from node group.

Start forwarding HP SE 
SRM events to HPOM

Forwards the HP SE SRM events 
from Windows managed node to 
HPOM

Status forwarding HP SE 
SRM events to HPOM

Gives status of forwarding the HP 
SE SRM events from Windows 
managed node to HPOM

Stop forwarding HP SE SRM 
Events to HPOM

Stops forwarding the HP SE SRM 
events from Windows managed 
node to HPOM
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AppStorManager-Win AppStorManager-Win Start Starts the HP SE SRM 
AppStorManager service on 
selected Windows nodes.

AppStorManager-Win Status Status of the HP SE SRM 
AppStorManager service on 
selected Windows nodes.

AppStorManager-Win Stop Stops the HP SE SRM 
AppStorManager service on 
selected Windows nodes.

Assign AppStorManager 
Windows node to node group

Assigns the Storage Essentials 
SRM AppStorManager Windows 
node to \"HP SE SRM 
CMS-Win\" node group.

De-assign AppStorManager 
Windows node from node 
group

De-assigns Storage Essentials 
SRM AppStorManager Windows 
node from \"HP SE SRM 
CMS-Win\" node group.

Start forwarding HP SE 
SRM events to HPOM

Forwards the HP SE SRM events 
from Windows managed node to 
HPOM

Status forwarding HP SE 
SRM events to HPOM

Gives status of forwarding the HP 
SE SRM events from Windows 
managed node to HPOM

Stop forwarding HP SE SRM 
Events to HPOM

Stops forwarding the HP SE SRM 
events from Windows managed 
node to HPOM

Tools Group Tool Name Description
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Using CIM Extension Tools Group

The CIM Extension-Unix or CIM Extension-Win tools group includes the 
following tools for HP SE SRM CIM Extension that are run on the HP SE 
SRM CIM Extension nodes (UNIX or Windows). The CIM Extension tools 
group includes the tools that monitor HP SE SRM CIM Extension services on 
the selected UNIX or Windows nodes.

Table 10 Name of the tools which monitor HP SE SRM CIM Extension services
  

Tools Group Tool Name Description

CIM 
Extension-Unix

CIM Extension-Unix 
Start

Starts HP SE SRM CIM 
Extension on selected UNIX 
nodes

CIM Extension-Unix 
Status

Status of the HP SE SRM CIM 
Extension on selected UNIX 
nodes.

CIM Extension-Unix 
Stop

Stops HP SE SRM CIM 
Extension on selected UNIX 
nodes.

Assign CIM Extension 
Unix node to node 
group

Assigns Storage Essentials 
SRM CIM Extension Unix node 
to \"HP SE SRM CIM 
Extn-Unix\" node group.

De-assign CIM 
Extension Unix node 
from node group

De-assigns Storage Essentials 
SRM CIM Extension Unix node 
from \"HP SE SRM CIM 
Extn-Unix\" node group.
58 Chapter 4



Using the HP SE SRM SPI Utils Tools Group

The HP SE SRM SPI Utils tools group includes the following tools for 
performing administrative tasks for the HP Storage Essentials SRM SPI. 

Table 11 Name of the tools used for performing administrative tasks for the HP 
Storage Essentials SRM SPI

  

CIM 
Extension-Win

CIM Extension-Win 
Start

Starts the HP SE SRM CIM 
Extension on selected Windows 
nodes.

CIM Extension-Win 
Status

Gets the status of HP SE SRM 
CIM Extension on selected 
Windows nodes.

CIM Extension-Win 
Stop

Stops the HP SE SRM CIM 
Extension on selected Windows 
nodes

Assign CIM Extension 
Windows node to node 
group

Assigns Storage Essentials 
SRM CIM Extension Windows 
node to \"HP SE SRM CIM 
Extn-Win\" node group.

De-assign CIM 
Extension Windows 
node from node group

De-assigns Storage Essentials 
SRM CIM Extension Windows 
node from \"HP SE SRM CIM 
Extn-Win\" node group.

Tools Group Tool Name Description

Tools Name Description

Clean HP SE SRM SPI–
Unix

Deletes HP SE SRM SPI files on selected Unix managed nodes

Clean HP SE SRM SPI–
Win

Deletes HP SE SRM SPI files on selected Windows managed 
nodes

Get HP SE SRM 
Credentials

Get username and password of HP Storage Essentials SRM for 
HPSESRMSPI.
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Service Discovery–Unix Performs HP SE SRM Service Discovery on the UNIX managed 
nodes.

Service Discovery–Win Performs HP SE SRM Service Discovery on the Windows 
managed nodes.

Tracing Off–Unix Sets HP SE SRM SPI tracing to OFF state on UNIX managed 
nodes.

Tracing Off–Win Sets HP SE SRM SPI tracing to OFF state on Windows 
managed nodes.

Tracing On–Unix Sets HP Storage Essentials SRM SPI tracing to ON state on the 
UNIX managed nodes.

Tracing On–Win Sets HP Storage Essentials SRM SPI tracing to ON state on the 
Windows managed nodes.

Version Verify Verifies the version of HP Storage Essentials SRM SPI files.

Import HP SE SRM 
Infrastructure

Queries the HP SE SRM Infrastructure details and adds Hosts, 
Switches and Storage Systems to the Node Bank.
Note: Get HP SE SRM Credentials tool must be executed before 
running this tool

Clean HP SE SRM 
SPI-UNIX

Deletes HP SE SRM SPI files on selected UNIX managed nodes

Clean HP SE SRM 
SPI-Win

Deletes HP SE SRM SPI files on selected Windows managed 
nodes

Tools Name Description
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Using HP Storage Essentials SRM SPI messages

Events generated by the HP Storage Essentials SRM SPI are grouped under 
the HP Storage Essentials SRM SPI’s 
HPSESRMSPI-StorageEssentialsSRM message group. The messages 
generated by the HP Storage Essentials SRM SPI policies appear in the 
message browser window and contain information that is vital for 
understanding the problems being reported.

  

The figure below shows messages for the HP Storage Essentials SRM SPI. 

The message content describes the scope of the problem. The columns provide 
the following information:

• Severity – Specifies the severity of the message. The severities reported are 
normal, warning, minor, major, and critical. By default, normal severity 
messages are redirected to the acknowledged message browser.

Events with a severity of Normal are redirected to the HPOM acknowledged 
message browser in the HPSESRMSPI-HPSESRM_Events policy. 
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• Object – Name of the HP SE SRM CMS node that forwarded the message 
to HPOM. 

• Application –HP Storage Essentials SRM

• Node – The system name of the event source

• Text – A single line description of the event.

• Message Group – HPSESRMSPI-StorageEssentialsSRM.

$OPTION (variable) – The event listener uses the -option switch in the opcmsg 
call to pass additional HP SE SRM event fields to HPOM.    

$OPTION(EventID) contains the HP SE SRM event ID. 

$OPTION(probableCause) contains the HP SE SRM event probable cause 
string. $OPTION(EventType) contains the HP SE SRM event type.

$OPTION(EventSubType) contains the HP SE SRM event sub type.

$OPTION(DeviceID) contains the HP SE SRM device ID. 

$OPTION(ElementID) contains the HP SE SRM element ID.    

These fields could be used in the HPSESRMSPI-HPSESRM_Events 
policies for customization.
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Launching the HP SE SRM CMS Web Portal from the 
Message Browser

Each message forwarded to the HPOM message browser from HP SE SRM 
contains an Operator Action to launch into the HP SE SRM web interface. It 
launches the event details page of the corresponding message on HPOM. This 
allows the HPOM operator to determine the cause of the problem and perform 
corrective tasks for the events which belong to 
HPSESRMSPI-StorageEssentialsSRM message group.

To launch the HPSESRM web interface, follow these steps:

1 Select an event, right-click the event, and select Commands > Start > 
Operator Initiated. The HPSESRM logon page opens.

2 Sign in to HPSESRM with proper credentials.

3 This will open the event details page of the corresponding message.
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Using the HP Storage Essentials SRM SPI Service Map

The HP Storage Essentials SRM SPI provides the administrator with the 
additional perspective of service views. It discovers the services automatically 
and uses the discovered data to generate service maps that can be viewed by 
the administrator from the HPOM console.

The HP SE SRM managed hosts are discovered by querying the SE SRM CMS 
for its managed hosts. Therefore, some of the nodes represented in this tree 
may not be HPOM managed nodes. Status is shown only for CIM Extension 
nodes that have an HPOM Agent installed and the HP Storage Essentials 
SRM SPI configured.

You can decide whether these nodes must be configured as HPOM managed 
nodes or not. You can also decide whether the HP Storage Essentials SRM SPI 
policies must be installed or not. If the nodes in this tree are HPOM managed 
nodes with the HP Storage Essentials SRM SPI policies deployed, the service 
view node status changes based on the status of the CIM Extension on the 
node is displayed.

The following service map shows the status of the HP SE AppStorManager 
process. 
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The service status implications of the service map are the following: 

Table 12 Service status implications of the service map  

  

Item Description

1 SE SRM CMS node

2 Nodes with CIM Extensions installed or running

By default, status propagation rules for the objects in the HP SE SRM service 
tree are defined such that if the HP SE SRM CIM Extension service objects is 
critical (item 2 in the previous figure), the higher service objects status are 
decreased by two levels to minor. 

If the HP SE SRM AppStorManager service objects is critical (item 1 in the 
previous figure), the higher service objects status are decreased by a level to 
major. 

The parent service does not change the status of a child object and, by default, 
calculation rules for the HP SE SRM service trees are set to Most Critical. 
Therefore, if a parent service has more than one child service, the parent 
service assumes the status equal to the highest severity of its child services.
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The following service map shows that the CIM Extension service on the node 
highlighted in red is not running.  

The service discovered by the HP Storage Essentials SRM SPI enables 
root-cause analysis of problems in crucial elements on the CIM Extension 
node in an HP SE SRM network managed storage network.

Viewing Services

The service views are created after HP SE SRM CMS node is added to the HP 
SE SRM CMS-Unix or HP SE SRM CMS-Win node group, Get HP SE 
SRM Credentials tool is executed and service discovery is started. For 
information on adding SE SRM CMS to the HP SE SRM CMS-Unix or HP 
SE SRM CMS-Win node group, see Task 2: Assign Nodes to the HP SE SRM 
Node Group on page 27.

Running the appropriate Service Discovery tool on the SE CMS node 
generates services in the HP SE SRM service map. Make sure that you 
perform the steps described in Task 3: Obtain HP SE SRM Credentials on 
page 33 before performing the following steps for viewing the discovered HP 
SE SRM service.
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To view the discovered HP SE SRM service, follow these steps:

1 Log on to the HPOM management server, and start the HPOM console.

2 Select Services > System Infrastructure on the left pane of the HPOM 
console.

By default, the HP Storage Essentials SRM SPI service discovery policy is 
configured to run service discovery every day at 2:00 am. You can change the 
service discovery period by modifying the Service discovery policy. The 
changed discovery period comes into effect only after the policies are 
redeployed on the HP SE SRM CMS node.
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Importing SE Infrastructure into HPOM NodeBank

In the present scenario, all events are generated from the SE managed 
Devices mapped to the SE SRM CMS. To correctly map all the events to the 
devices we have to add the nodes to HPOM Nodebank. SE managed nodes are 
queried and added to the HPOM Node Bank as message nodes.

When the events reach the HPOM from SE SRM CMS Server, the events are 
mapped to SE Managed Nodes instead of SE CMS Server.

Information about the SE Infrastructure is collected from the SE Discovery 
Database. The following device types in SE are collected and added to HPOM 
Node bank.

• Hosts

• Switches

• Storage Systems

In HPOM for Windows, these messages are added as external nodes in the 
HPOM Node Bank.

In HPOM for Unix, these messages are added as “Message Allowed Node” in 
the HPOM Node bank.

A new node group called HP SE SRM INFRA is added to add the all the 
created nodes. These nodes are added to sub-groups which we must create. 
These sub-groups are: 

• HP SE SRM INFRA HOSTS, 

• HP SE SRM INFRA SWITCHES 

• HP SE SRM INFRA STORAGE SYSTEMS 
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Using HP Storage Essentials SRM SPI User Roles

The installation of the HP Storage Essentials SRM SPI adds a new user role, 
HP Storage Essentials SRM SPI Admin, to HPOM as shown in the following 
figure.
  

The HPOM administrator uses user roles to simplify the process of assigning 
responsibilities to HPOM users. The users associated with the role HP 
Storage Essentials SRM SPI Admin can access all the HP Storage Essentials 
SRM SPI tools, policies, and HPSESRMSPI-StorageEssentialsSRM 
message groups assigned to them, and can manage and control the HP SE 
SRM CMS and HP SE SRM CIM Extension nodes.

The HP Storage Essentials SRM SPI Admin user role assigns the following 
authorizations:

• Access all messages with message group attribute 
HPSESRMSPI-StorageEssentials_SRM from HP SE SRM CMS or HP SE 
SRM CIM Extension node.
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• Execute any tool in the HP Storage Essentials SRM Tools groups.

• Update the HPOM service map, displaying the HP SE SRM services 
successfully discovered.
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5 Uninstalling the HP Storage Essentials 
SRM SPI
Deleting HP Storage Essentials SRM SPI Instrumentation 
from Nodes

To remove HP Storage Essentials SRM SPI instrumentation from the 
managed nodes, follow these steps:

1 Open the HP SE SRM SPI Utils tools group in the HP Storage Essentials SRM 
SPI tools group.

2 Run the Clean HP SE SRM SPI-Unix tool on the selected Unix managed 
nodes.

3 Run the Clean HP SE SRM SPI- Win tool on the selected Windows managed 
nodes.

4 Right click each node on which the clean tool has been executed in above 
step and select All Tasks → Synchronize Inventory → Policies. All the policies 
present in the node gets synchronized with HPOM GUI.

Removing Nodes from the Node Group

Removing a node from the node group involves the following tasks.

Task 1: Remove the AppStorManager Node from the Node Group

To remove the node on which the HP SE SRM AppStorManager service is 
running from the HP SE SRM CMS-Unix or HP SE SRM CMS-Win node 
group, follow these steps:

1 Log on to the HPOM management server, and start the HPOM Console.
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2 Select Tools > HP Storage Essentials SRM > AppStorManager-Unix and 
right-click De-assign AppStorManager node from node group.

3 Select All Tasks > Launch Tool. The Edit Parameters window opens.
  

4 Select the node in the HP SE SRM CMS-Win node group in the Select 
the nodes/services to replace $OPC parameter with window pane.

5 Click Launch…. The Tool Status window opens.
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6 Repeat the previous steps to remove nodes from the HP SE SRM 
CMS-Win node groups using Tools > HP Storage Essentials SRM > 
AppStorManager-Win > De-assign AppStorManager Win node from node group.

Task 2: Remove the CIM Extension Windows Node from the Node 
Group

To remove the node on which the HP SE SRM CIM Extension service is 
running, from the HP SE SRM CIM Extn-Unix or HP SE SRM CIM Extn-Win 
node group, follow these steps:

1 Select Tools > HP Storage Essentials SRM > CIM Extension-Unix, and 
right-click De-assign CIM Extension Windows node from node group.

2 Select All Tasks > Launch Tool. The Edit Parameters window opens.
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3 Select the node in the HP SE SRM CIM Extn-Unix node group in the 
Select the nodes/services to replace $OPC parameters with window 
pane.

4 Click Launch…. The Tool Status window opens.
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5 Repeat the previous steps to remove nodes from the HP SE SRM CIM 
Extension-Win node groups using the Tools > HP StorageEssentials SRM > 
CIM Extension-Win > De-assign CIM Extension-Win node from node group.

The nodes in the SE INFRA Node Group are not HPOM managed nodes and 
hence do not have to be removed from their node groups. Uninstalling the SE 
SRM SPI will automatically remove the SE INFRA Nodes and their node 
groups.
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Uninstalling HP Storage Essentials SRM SPI from HPOM

To uninstall the HP Storage Essentials SRM SPI components from HPOM, 
follow these steps:

1 Insert the HP Operations Smart Plug-ins DVD.

2 Select Remove products to proceed to the product selection dialog box.

Make sure that HPOM managed nodes are not present under the HP Storage 
Essentials SRM SPI node groups. They must be moved out of their respective 
groups before uninstalling the HP Storage Essentials SRM SPI. For 
information on removing the HPOM managed nodes, see Removing Nodes 
from the Node Group on page 71.
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3 In the Product Selection Uninstall window, select SPI for HP SE SRM and 
click Next. The Product Selection Uninstall window opens.

4 Select Remove.

5 Click Finish to complete the uninstallation procedure and exit the wizard.

This removes all the configuration files and executables of the HP Storage 
Essentials SRM SPI from the HPOM server. The HP Storage Essentials SRM 
SPI node groups, policies, and tools are also removed from the HPOM.
Uninstalling the HP Storage Essentials SRM SPI 77



Uninstalling HP Storage Essentials SRM SPI 
Components from HPOM

Most of the components of the HP Storage Essentials SRM SPI in HPOM are 
automatically removed during the uninstallation of the product. However, the 
HP Storage Essentials SRM SPI Admin user role must be removed manually.

Removing HP Storage Essentials SRM SPI User Roles

To remove the HP Storage Essentials SRM SPI user roles, follow these steps:

1 Select Actions > Configure > User Roles. You can also click User Roles 
Configuration Editor, which is located on the menu bar of the main HPOM. 
The User Roles window opens.

   

2 Select HP Storage Essentials SRM SPI Admin, and click Delete.
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6 Troubleshooting
Start by checking the following to verify that the HP Storage Essentials SRM 
SPI environment is installed and configured correctly:

• Make sure that the HP Storage Essentials SRM SPI is installed properly. 
For more information, see Installing the HP Storage Essentials SRM SPI 
on page 20.

• Make sure that the HP Storage Essentials SRM SPI is configured 
properly. For more information, see Chapter 3, Configuring the HP 
Storage Essentials SRM SPI.

If the HP Storage Essentials SRM SPI is correctly installed and configured, 
the messages appearing in the HPOM message browser will be intercepted by 
the HP Storage Essentials SRM SPI policies and will appear in the HPOM 
message browser in the form you expect.

If the problem persists, refer to the following list of common problems and 
their solutions.

Error Messages and Solutions

No HP SE SRM service monitoring events arrive on the HPOM 
Message Browser console

Solution:

• Make sure that the connection between HPOM and the HP SE SRM CMS 
and the CIM Extension nodes is up and running.

• Verify that the HPOM agent is correctly installed and configured on the 
management server, and the HPOM agent processes (especially the 
control agent and message agents) are running.
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• Make sure that HP SE SRM CMS and CIM Extension nodes are added to 
the appropriate node groups (see Task 2: Assign Nodes to the HP SE SRM 
Node Group on page 27).

HP SE SRM services are not visible in the HPOM console

Solution: 

• Make sure that the connection between the HPOM and the HP SE SRM 
CMS nodes is up and running.

• Verify that the HPOM agent is correctly installed and configured on the 
management server, and the HPOM agent processes (especially the 
control agent) are running.

• If the HP SE SRM CMS credentials are invalid, there might be error 
messages in the service discovery log at 
<OvAgentDir>\log\javaagent.log on the HP SE SRM CMS node 
indicating authentication failures.

• Make sure that the Service Discovery policies present in Policy 
Management > Policy Groups > HP Storage Essentials SRM > Service 
Discovery are deployed on the HP SE SRM CMS nodes. To check whether 
the policies are correctly deployed, right-click the node, select View > Policy 
Inventory, and ensure that the Service Discovery policies are present. You 
can also check the service discovery log at 
<OvAgentDir>\log\javaagent.log on the HP SE SRM CMS node for 
error messages.

SHS-related tools fail on non-root HTTPS node; says cannot open 
SPI_SE.xml

When the HPOM agent is migrated from root user to non-root user, the 
Version Verify tools fail with the following error.

Cannot open collector output file /tmp/SPI_SE/SPI_SE.xml for 
writing.

Solution: 
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If the HPOM agent is migrated from root user to non-root user, delete or 
rename the HP Storage Essentials SRM SPI files/directories from /tmp on the 
nodes that were created by root user.

Enable logging for event forwarding

To enable logging inorder to trace the processing do the following:

1 Stop forwarding HP SE SRM events to HPOM.

2 Open the file 
<OvAgentDir>\bin\instrumentation\HPSESPI_LogConf.prp for editing 
and modify the value of Threshold to 10.

3 Start forwarding HP SE SRM events to HPOM.

The file <OvAgentDir>\log\HPSESPI\HPSESRMSPI_Debug.log is created to 
assist with debugging.

<OvAgentDir>\log\HPSESPI\HPSESRMSPI_Events.log has all the events 
forwarded from HP SE SRM to HPOM logged in it.
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A HP Storage Essentials SRM SPI Policy 
Groups
The high-level HP Storage Essentials SRM policy groups are available in HP 
Storage Essentials SRM SPI policy groups.

The policies provided with the HP Storage Essentials SRM SPI are grouped 
under the HP SE SRM policy group as shown in the following figure.
  

Messages generated by the HP Storage Essentials SRM SPI policies are 
assigned an HPOM severity level as defined in the policy groups. By default, 
all messages generated by an HP Storage Essentials SRM SPI policy belong to 
the HPSESRMSPI-StorageEssentials_SRM message group.
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Policies in the AppStorManager and CIM Extension policy groups for the 
indicated operating systems monitor the status of the AppStorManager 
service running on HP SE SRM CMS nodes, and the HP SE SRM CIM 
Extension service running on the HP SE SRM managed nodes. These policies 
generate messages to indicate any status change in the monitored services.

Policies in the Service Discovery policy group discover the SE SRM services 
when deployed on HP SE SRM CMS nodes.

Table 13 List of policies in the HP Storage Essentials SRM SPI policy groups
       

Policy Group Policy Name Description Policy Type

AppStorManager-Unix HPSESRMSPI-AppStor
Manager-Unix

Monitor HP Storage 
Essentials SRM 
AppStorManager 
service on Unix.

Measurement 
Threshold

AppStorManager-Win HPSESRMSPI-AppStor
Manager-Win

Monitor HP Storage 
Essentials SRM 
AppStorManager 
service on Windows

Measurement 
Threshold

CIM Extension-Unix HPSESRMSPI-CIM 
Extension-Unix

Monitors HP SE SRM 
CIM Extension 
service on Unix

Measurement 
Threshold

CIM Extension-Win HPSESRMSPI-CIM 
Extension-Win

Monitors HP SE SRM 
CIM Extension 
service on Windows

Measurement 
Threshold

Service Discovery HPSESRMSPI-Storage
Essentials_SRM_Servic
es

Discovers services of 
the hosts managed by 
the SE SRM 
AppStorManager

Service 
Auto-discovery

The CIM extension can be either an extension to the Windows WMI service or 
a separate executable called AppStorWin32Agent service. The 
HPSESRMSPI-CIM_Extension-Win monitor policy monitors only the 
AppStorWin32Agent service. HPSESRMSPI-CIM_Extension-Win is 
disabled if this service is not present or only the extension to the WMI service 
is present on a Windows managed node.
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