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Using the Workbench
 Chapter

Introduction

Mercury IT Governance Center provides two areas where the user can interact 
with the product: the standard interface and the Mercury IT Governance 
Workbench. The standard interface uses HTML and Javascript to provide users 
with access to the key areas of functionality. The Workbench is a Java applet 
designed to help application administrators, product configuration experts, and 
Power Users perform advanced configuring and processing tasks, such as 
creating entities (like Request Types, Object Types, and Workflows). The 
Workbench can also query detailed information on specific entities, such as a 
particular Package. 

Use the Workbench to:

• Create and configure entities, such as Request Types, Object Types, and 
Workflows.

• Define Environments for distribution and deployment processes.

• Configure field validations and logic.

• Create Project plans in Mercury Project Management.

• Set user access and security through licensing and entity configuration.

• Create custom Reports and synchronize them with the Reporting Meta 
Layer.

• Manage instances using the Migrator Object Types.

About This Document
This guide describes how to navigate and use the Mercury IT Governance 
Workbench. Each chapter covers a specific topic on navigation or usage:
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Using the Workbench
Intended Audience
The intended audience for this document includes:

• Users of the Workbench 

• Managers who create and manage Requests, Projects, Packages and Tasks 

• Managers who create and manage Calendars

• Business configuration experts who model their processes 

• System and application administrators responsible for Environments 
configuration 

Document Conventions
Table 1-1 lists the types of conventions used in this document.

Key Concepts Provides the general concepts of the Workbench. This 
includes screen groups and screens, workbenches and 
detail windows.

Using the 
Workbench

Describes navigating to specific detail windows in the 
Workbench and explains regional and other settings 
configured in the Workbench. 

Field Formats Lists the field formats of the Workbench. This includes 
information on all of the fields, lists, and buttons found 
in the Workbench.

Table 1-1. Document conventions 

Convention Description Example

Button, menu, tabs Names of interface components that can be 
clicked (such as buttons, menus, and tabs) 
are shown in bold.

Apply button
2 Introduction
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Additional Resources
Mercury Interactive provides the following additional resources to successfully 
use Mercury IT Governance Center:

• Related Documentation

• Customer Support

• Education Services

Related Documentation
The Library includes additional documents related to the topics discussed in 
this guide. Access the Library through the Mercury ITG Center online help.

Fields, Windows, Pages Names of windows, fields, and pages are 
shown as displayed.

New Request window

Code Code input and output are shown as 
displayed.

CauchoConfigFile 
C:/ITG_Home/conf/
resin.conf

Link Linked URLs, filenames, and cross references 
are shown as blue italicized text.

www.mercury.com

Variable Variables are shown as italicized text. ITG_Home/bin directory

Note Used to identify note boxes that contain 
additional information.

Caution Used to identify caution boxes that contain 
important information. Follow the instructions 
in all caution boxes, failure to do so may result 
in loss of data.

Example Used to identify example boxes that contain 
examples of related procedure.

Table 1-1. Document conventions  [continued]

Convention Description Example
Introduction 3



Using the Workbench
Customer Support
Customer support and downloads for the Mercury ITG Center and additional 
product information can be accessed from the Mercury Interactive Support 
Web site at http://support.mercuryinteractive.com. 

Education Services
Mercury Interactive provides a complete training curriculum to help you 
achieve optimal results using the Mercury IT Governance Center. For more 
information, visit the Education Services Web site at http://www.merc-
training.com/main/ITG.

Using the Dashboard This document provides details for defining 
and configuring the Mercury IT Governance 
Dashboard and custom Portlets. 

Security Model Guide and 
Reference

This document presents an overview of the 
data security model and provides instructions 
for controlling access to different entities.
4 Introduction
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 Chapter

Key Concepts

This chapter defines common concepts and terms used in the Mercury IT 
Governance Workbench. Understanding these concepts and terms is necessary 
when using the Workbench.

This chapter covers the following topics:

• Screen Groups and Screens

• Entity Workbench

• Detail Windows

• Workbench Menu Navigation

Screen Groups and Screens 
Screen groups are the major functional components of the Workbench. A 
screen group can be product specific or support common functionality. 
Mercury IT Governance Center administration and configuration functions are 
performed in the Workbench. 

This section covers the following topics: 

• Screen Group Overview

• Demand Management Screen Group

• Project Management Screen Group

• Change Management Screen Group

• Time Management Screen Group

• Dashboard Screen Group
Key Concepts 5
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• Environments Screen Group

• Configuration Screen Group

• System Administration Screen Group

Screen Group Overview
Screen groups are a collection of functional windows grouped together under a 
common product or functional area. Screen groups are listed as tabs at the top 
of the Shortcut bar. Each screen group contains a sets of screens. Each screen 
contains an entity Workbench and detail windows to perform end-user and 
configuration functions. Screens are represented as icons below the screen 
group tabs. Clicking on a screen group tab opens a different set of screens. 
Figure 2-1 illustrates the Reports screen, in the Change Management screen 
group.

Figure 2-1 Change Management - Reports Workbench and window 

Screen group access depends on:

• The appropriate licenses.

• The appropriate Security Group setting. 

Change Mgmt

Reports 

Reports 
Workbench 

Reports 
Detail Window 

Screen Group 

Icon 

Shortcut
Bar 

Reports 
Screen 

Workbench Menu
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Demand Management Screen Group
The Demand Management screen group contains screens related to configuring 
your Mercury Demand Management system. Table 2-1 lists the screens in the 
Demand Management screen group.

Project Management Screen Group
The Project Management screen group contains screens related to configuring 
your Mercury Project Management system. Table 2-2 lists the screens in the 
Project Management screen group.

Table 2-1. Demand Management Screens 

Screens Definition

Reports The Reports Workbench runs standard and custom 
Mercury Demand Management reports. These include 
reports regarding system set-up, specific configurations, 
Request Details and Contact Details. 

Contacts The Contacts Workbench is used to quickly generate new 
Contacts as well as edit existing contact information. 
Standard information is collected in the Contact window, 
such as Last Name and Phone Number. 

Request Types The Request Types Workbench is used to define Request 
Types. A Request Type is a type of template defining the 
nature of a Request in Demand Management. A few of the 
available system Request Types are Bug, Enhancement 
Request, and Patch Request. When a Request is 
generated, the fields appearing are based on the Request 
Type. The base install of Demand Management includes 
the default Request Types, which can be customized. 
Custom Request Types can also be created. 

Request Header 
Types

Similar to the Request Types Workbench, the Request 
Header Types Workbench enables Request Types to be 
changed by changing the Request Header. Request 
Header Types are used to customize which header fields 
appear, as well as the layout of these fields. 
Key Concepts 7
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Change Management Screen Group
The Change Management screen group contains screens related to configuring 
your Mercury Change Management system. Table 2-3 lists the screens in the 
Change Management screen group.

Table 2-2. Project Management Screens 

Screens Definition

Projects A Project is the fundamental entity of Project Management. 
The Project Workbench contains all of the information 
normally required to create and manage a Project. 

Reports The Reports Workbench runs standard and custom Project 
Management reports. These reports include system set-up, 
specific configurations and end user reports, such as 
Project Details. 

Project Templates Project Templates are a reusable collections of Project 
parameters and processes which can be applied to any 
Project. Project Templates allow Project Managers to 
rapidly create customized project plans. 

Calendars The Calendar Workbench is where Project Managers 
record company and individual working and non-working 
days. This information is used by the scheduling engine to 
aid in determining project start and finish dates. 

Table 2-3. Change Management Screens 

Screens Definition

Packages The Packages Workbench is used to create Packages. A 
Package is the fundamental entity of Change 
Management. Packages contain all of the information 
needed to be processed including the Package Type, 
priority and status. A Package also contains a list of all 
objects to be tracked and migrated as the Package moves 
through the Workflow. Processing Packages and Package 
Lines vary greatly depending upon the Workflow specified 
for the Package. 

Reports The Reports Workbench runs standard and custom 
Change Management reports. These include reports 
regarding system set-up, specific configurations and end 
user reports. 
8 Key Concepts
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Time Management Screen Group
The Time Management screen group contains screens related to configuring 
your Mercury Time Management system. Table 2-4 lists the screens in the 
Time Management screen group.

Releases Using the Release Workbench, Change Management 
users can manage and control software changes by 
grouping them in scheduled releases. Releases codify best 
practices and easily manage complex Package 
dependencies. 

Environment Refresh The Environment Refresh Workbench is used to update 
the audit history and in-process Packages. During the 
course of day-to-day application management activity, 
specific software changes are migrated to various 
instances using Change Management. Change 
Management maintains an audit trail of all this activity, 
providing clear visibility to all the changes for each 
environment. 

Object Types The Object Types Workbench is used to define the 
different types of entities to be controlled and migrated. 
Object Types are user-configurable. Every Object Type 
has a unique set of fields determining the information it 
requires, as well as any additional information it might 
accept. Each Object Type can also have associated 
Commands which determine its behavior as it moves 
between Environments or Environment Groups. 

Table 2-3. Change Management Screens  [continued]

Screens Definition

Table 2-4. Time Management Screens 

Screens Definition

Reports The Reports Workbench runs standard and custom 
Change Management reports. These include reports 
regarding system set-up, specific configurations and end 
user reports. 

Time Management 
Settings

The Time Management Settings Workbench views or 
updates Time Management settings for a specific 
Resource. 
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Dashboard Screen Group
The Dashboard screen group contains all of the functions required for creating 
custom Portlets. Table 2-5 lists the screen of the Dashboard screen group. 

Environments Screen Group
The Environments screen group contains screens related to configuring your 
Environment. Table 2-6 lists the screens in the Environments screen group. 

Override Rules The Override Rules Workbench is used to supersede 
default cost rates and instead base the cost rates on 
specific Time Sheet line information such as Work Item 
Type and Work item. Override Rules can also be used to 
override Approver information and Charge Codes. 

Activities The Activity Workbench is used to view, add or update a 
specific Activity. The Activity window defines basic 
information for the Activity as well as the areas where the 
Activity can be used. 

Charge Codes The Charge Codes Workbench is used to add, view, or 
update a Charge Code. Charge Codes create links 
between Work Items and charge accounts, allowing time 
information to be extracted by a billing systems. 

Table 2-4. Time Management Screens  [continued]

Screens Definition

Table 2-5. Dashboard Screen 

Screen Definition

Portlet The Portlet Workbench is used to create new Portlets. 
Application administrators create custom Portlets by 
identifying the information to be displayed in the Portlet, 
designing a database query retrieving the information and 
creating a Portlet configuration to perform these steps. 
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Configuration Screen Group
The Configuration screen group contains screens related to configuring 
Mercury IT Governance Center. Table 2-7 lists the screens in the Configuration 
screen group. 

Table 2-6. Environments Screens 

Screens Definition

Environments The Environments Workbench is used to create and 
maintain Environments. An Environment is comprised of a 
unique combination of server, client, database, and file 
system information representing one logical group. 
Environments are typically used in distribution and 
deployment systems. The Environment server is the main 
host machine for the Environment. The Environment client 
is the remote client machine for the specified Environment. 

Environment Groups The Environment Groups Workbench is used to create and 
maintain Environment Groups. Environment Groups define 
a set of Environments which can be referenced as the 
Sources or Destinations for object migrations. Environment 
Groups are designed to facilitate the migration of objects to 
multiple Environments. A Source Environment Group and 
Destination Environment Group can be specified when 
configuring a Workflow Execution step.

Table 2-7. Configuration Screens 

Screens Definition

Workflows The Workflow Workbench is used to create and maintain 
Workflows potentially used by all products. A Workflow 
consists of a logical series of steps defining a business 
process. Business process routing is configurable with 
Mercury IT Governance Center, handling virtually any 
situation. This allows an organization to generate 
Workflows to automate existing processes, rather than 
forcing users to adopt a new set of processes to perform 
their work.
Key Concepts 11
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Validations The Validations Workbench is used to create and maintain 
Validations in the system. Validations determine the 
acceptable values available in user-defined custom fields, 
such as those found in Request Types, Workflow Steps 
and Object Types. Validations enforce data integrity by 
ensuring the proper information is entered in a field before 
it is saved to a database. More complex Validations can be 
used to verify such information as whether or not a user 
assigned to a Task is a valid user. These Validations can 
be based on values returned from a database query or the 
execution of a system command.

User Data The User Data Workbench creates fields used to capture 
specific business processes. Every entity, such as 
Workflows, Packages and Environments, comes with a set 
of standard fields. Every entity also has the flexibility to 
hold additional information specific to business processes. 

Special Commands The Special Commands Workbench is used to create and 
maintain Special Commands. Special Commands are 
commands with variable parameters used in the command 
steps of Object Types, Report Types, and Request Types. 
Special Commands perform a variety of functions, such as 
copying files between Environments and establishing 
connections to Environments for remote command 
execution. There are two types of Special Commands: 
predefined Special Commands and user defined Special 
Commands. 

Notification 
Templates

The Notification Templates Workbench is used to create 
and maintain Notification Templates. Notifications are sent 
out by products to let users know the status of an entity, 
such as a Package, Request, or Project. Notification 
Templates can be defined for standard messages which 
might be required on multiple Workflow steps. 

Report Types The Report Types Workbench is used to create and 
maintain Report Types. Report Types define the standard 
or custom reports defined within Mercury IT Governance 
Center. These reports are configurable and can be run by 
both administrators and end users. Reports are run from 
the Reports window and produce textual reports viewable 
through a Web browser. 

Table 2-7. Configuration Screens  [continued]

Screens Definition
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System Administration Screen Group
The System Administration screen group contains screens related to 
administering your system. Table 2-8 lists the screens in the System 
Administration screen group. 

Entity Workbench
Every configuration entity has a Workbench to help query detailed information 
on a specific entity. These entities are selected by entering search criteria in the 
Query tab of the Workbench, which returns the matching entities in the Results 
tab. Figure 2-2 shows a sample Workbench. 

Table 2-8. System Administration Screens 

Screens Definition

Users The Users Workbench is used to create and maintain all 
users in the system. Mercury IT Governance Center 
provides a secure access mechanism and a complete audit 
trail of activity. Each user definition contains essential 
information about the user, including the user’s email 
address, start and end dates, the user’s authorized 
applications, and the user’s Security Group.

License The License Workbench is used to assign licenses to 
multiple users or modify the license assignments to 
already-licensed users.

Security Groups The Security Groups Workbench is used to create and 
maintain Security Groups. Security Groups provide a 
means of grouping users together into screens and 
functional access levels. 

Server Tools The Server Tools Workbench views the technical status of 
the application server. This workbench offers a series of 
queries against the server to give information such as 
connected users and number of database sessions. This 
Workbench is primarily used by the application 
administrator to view application activity or trouble-shoot 
connection problems.
Key Concepts 13
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Figure 2-2 Package Workbench 

Detail Windows 
Every configuration entity has detail windows to view, define, create, edit or 
delete the entity. Detail windows are reached through an entity’s Workbench. 
Figure 2-3 illustrates the Request Type detail window. 

Figure 2-3 Request Type window

Workbench Menu Navigation
The Navigate menu can be used instead of the Shortcut bar to access entity 
Workbenches. All available screen groups and Workbenches are accessible 
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through the Navigate menu. The Navigate menu’s structure mimics the 
Shortcut bar and is accessible at all times. 

Figure 2-4 Navigate Menu 

Shortcut
Bar

Navigate Menu 

Workbench Menu 
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 Chapter

Using the Workbench

This chapter details information and procedures for using the Mercury IT 
Governance Workbench including the different ways of navigating between 
detail windows in the Workbench. Additionally, this chapter details how to 
search for entities, using the advanced search features, and how to change the 
way the Workbench looks and operates. 

This chapter covers the following topics:

• Logging On and Off the Workbench

• Navigating Between Detail Windows

• Searching for Entities

• Using Advanced Query Searches

• Using Saved Queries

• Configuring User Profiles

• Configuring Regional Settings

• Configuring Server Settings

• Using the Navigation Menu

• Changing Your Password

• Accessing Entity-Dependent Menus
Using the Workbench 17
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Logging On and Off the Workbench
The Workbench is accessed through the standard Mercury IT Governance 
interface. This section details the steps required to logon to the Workbench and 
to log off the Workbench.

To Logon to the Workbench:

1. Logon to the Dashboard.

2. From the Menu bar, select Administration > Open Workbench.

The Workbench opens. 

To Log off the Workbench:

1. On the Workbench menu, select File > Exit.

The Workbench closes. 

Navigating Between Detail Windows
Workbenches and detail windows are accessed by selecting a screen group and 
screen, as displayed in Figure 3-1. Examples of entities with Workbenches 
include:
18 Using the Workbench
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• Request Types

• Request Header Types

• Projects

• Portlets

• Object Types

• Environments

• User Data

• Validations

Figure 3-1 Screen Group, Screen, Workbench, and Detail Window 

Detail windows are accessed through the entity workbench, which consists of a 
Query tab and a Results tab. Figure 3-2 illustrates how to navigate to a detail 
window.

Change Mgmt

Reports 

Reports 
Workbench 

Reports 
Detail Window 

Screen Group 

Icon 

Shortcut
Bar 

Reports 
Screen 

Workbench Menu
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Figure 3-2 Navigating to a detail window 

If multiple detail windows have been opened, they can be accessed using the 
buttons at the bottom of the Workbench, as shown in Figure 3-3. 

Request Type Workbench
Query Tab

Request Type Workbench
Results Tab

Request Type 

1. Enter search
criteria and click
List to see matching
results.

2. Select the desired
entity and click
Open to view details.

3. Detail window
opens.

Detail Window (Bug)
20 Using the Workbench



Using the Workbench
Figure 3-3 Navigating between multiple open detail windows 

Searching for Entities
An entity’s Workbench provides an interface for users to search for a specific 
entity, such as a Package or Request Type. These entities are selected by 
entering search criteria in the Query tab of the workbench, which returns the 
matching records in the Results tab. 

To search for an entity, enter criteria in any combination of the fields in the 
Query tab. Clicking List searches for all records matching the criteria and 
reports the results in the Results tab. See the following topics for more detailed 
information:

• “Query Tab” on page 22

• “Results Tab” on page 22

Click to access workbench 
or detail windows
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Query Tab
The Query tab of a given Workbench includes all of the fields used to search 
for an entity. For example, the Request Type Workbench Query tab includes 
fields included in a Request Type. 

Figure 3-4 Request Query Tab

Each Workbench has one field used to query the primary name for the entity. 
When searching for the name of an entity, the value entered in the field is case 
insensitive and can be a partial value. For example, entering “test” in the 
Request Type Name field returns Request Types with names like ‘TEST 
Project’ and ‘Testing Case Project.’

The Query tab also accepts a wildcard character (“%”) when searching on the 
entity’s name. This matches against any characters. For example, to query all 
Request Types with “ample” in their name, search by “%ample”. This query 
returns Request Types with names like ‘Request Type Example’ and ‘Sample 
Request Type’.

Some Workbenches also have a Max Rows field. This field limits the number of 
rows returned by a query. Regardless of the total results in the system matching 
the query parameters, no more than 200 rows will be returned. Decrease the 
number of maximum rows to yield faster queries.

Results Tab
The Results tab is automatically displayed when a query is submitted. The 
Results tab displays all of the entities matching the query criteria, along with 
key data fields for each entity. The results can be sorted on any of the fields by 
clicking the column header. In the Results tab, select any of the returned 
entities (or a range of entities) for viewing, copying or modifying.

From the Results tab, you can access the detailed information on the desired 
entity (for example, Request Header Type). Select the result and click Open to 
22 Using the Workbench
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proceed to that entity’s detail window. Click on a record to select it, or use 
Ctrl-click (press Ctrl while clicking the mouse) to select multiple distinct 
records. Use Shift-click (press Shift key while clicking the mouse) to select a 
range of records.

The Results tab also provides buttons for executing other common tasks. From 
the Results tab, users can also create New records, Copy or Delete existing 
items, or re-run the query by clicking Refresh. A sample Results tab is shown 
in Figure 3-5.

Figure 3-5 Results Tab

Using Advanced Query Searches
The entity Workbench provides an interface for users to search for a specific 
entity, such as a Package or Request Header Type. These entities are selected 
by entering search criteria in the Query tab of the workbench, which returns the 
matching records in the Results tab of the Workbench. 

To perform an advanced query, click the Advanced tab on the Workbench’s 
Query tab. Here you can set up custom lists of inclusions and exclusions in the 
database search. New conditions can be set up and conditions of an existing 
advanced query can be edited, enabled, disabled, and deleted. A search is first 
performed on the information in the Query. Whatever results are processed 
from the simple query are passed through the advanced query. 

To use only the advanced query, make sure to leave the simple query tab 
blank.
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To create new criteria for an advanced query:

1. On the Query tab of a Workbench, click the Advanced tab.

The Advanced tab opens. 

2. Click New. 

The Advanced Query window opens. 

3. In the Field field, choose a field from the auto-complete field. 

4. In the Condition field, select the condition from the drop down list. 

See Table 3-1 for the list of conditions. 

5. In the Value field, enter a value for the field. 

6. Click Add.

The additional logic is added to the list of parameters. The list of results 
considers each parameter on the list, and only items matching all of the 
logic are displayed. If zero matches are returned, be less restrictive by 
disabling or removing some of the criteria.
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Descriptions of the Boolean operators available in the Condition drop down list 
are shown in Table 3-1.

Table 3-1. Boolean Operators 

Condition Description

Like Like looks for close matches of the value to the contents of the 
selected field.

Not like Not like looks for contents in the selected field which are not close 
matches to the value field.

Like Like looks for close matches of the value to the contents of the 
selected field.

Not like Not like looks for contents in the selected field which are not close 
matches to the value field.

Equal to Equal to looks for an exact match of the value to the contents of 
the selected field.

Not equal to Not equal to will return all results which are not an exact match of 
the value to the contents of the selected field.

Is null Is null will return all instances in which the selected field is blank.

Is not null Is not null will return all instances in which the selected field is not 
blank.

Greater than Greater than looks for a numerical value in excess of the value 
entered in the Value field.

Less than Less than looks for a numerical value below the value entered in 
the Value field.

Greater than 
equal to 

Greater than equal to looks for a numerical value in excess or the 
same as the value entered in the Value field.
Using the Workbench 25



Using the Workbench
Using Saved Queries
Saved queries provide a quick method for performing standard, reoccurring 
searches. 

This section covers the following topics:

• “Saving a Query” on page 26

• “Using a Saved Query” on page 27

• “Deleting a Saved Query” on page 28

Saving a Query
To save a search query:

1. On the Query tab of a Workbench, enter the search parameters for a query.

2. Click Save Query. 

The Save Query window opens.

3. In the Query Name field, enter a unique query name.

Less than 
equal to 

Less than equal to looks for a numerical value below or the same 
as the value entered in the Value field.

Table 3-1. Boolean Operators  [continued]

Condition Description

Each day a query is run for all Packages assigned in the last day. These query 
parameters can be saved to avoid entering the same parameters every day.
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4. Click Save. 

The query is saved. Once the query is saved, the saved query can be 
selected from the Query tab’s Query field drop down list. 

Using a Saved Query
To use a saved search query:

1. From the Query field list, select a saved query name.

The fields of the Query tab are populated. 

2. Click List. 

The search is run with the saved parameters of the selected query.

Only the user who saved the query can access and use that saved query.
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Deleting a Saved Query
To delete a saved search query:

1. From the Query drop down list, select a saved query name.

The fields of the Query tab are populated. 

2. From the Workbench menu, select File > Delete <query name>.

A Question Dialog opens.

3. In the Question Dialog, click Yes.

The saved query is deleted. 

Configuring User Profiles
The User Profiles window determines the way certain Workbench features 
function for a particular user. These user profiles are set on a per-user basis. 
Changes to a user’s profile does not affect other user’s Workbench settings. 
Open the User Profiles window by selecting Edit > User Profiles from the 
Workbench menu. 

This section covers the following topics:

• “Setting User Profiles” on page 29

• “Setting the Display of Workflows” on page 30
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• “Setting the Display of Cancelled Package Lines” on page 32

Setting User Profiles 
The General tab of the User Profiles window controls common settings for the 
Workbench. This section lists the fields of the General tab and provides an 
example of configuring a setting on the General tab. To access the General tab, 
from the Workbench menu select Edit > User Profiles. Figure 3-6 shows the 
General tab of the User Profiles window. Table 3-2 defines the fields of the 
General tab of the User Profiles window. 

Figure 3-6 User Profiles Window - General Tab

Table 3-2. User Profile Window - General Tab 

Fields Description

Startup in this 
Screen

Determines which screen group is first seen when logging 
into the application.

Shortcut Bar? Determines whether or not the shortcut bar is shown. If the 
shortcut bar is not shown, navigate between windows using 
the Navigate menu.

Position If the shortcut bar is shown, determines which side of the 
Workbench it appears on.

Save Window Size 
on Exit?

Saves the size of the entire Workbench when exiting the 
application. The window retains its size when logging back 
into the application.

Reuse Inner 
Windows?

Determines whether or not multiple windows can be open at 
once. If this field is unchecked, only one detail window for 
each entity from its workbench can be selected.

Show Change 
Warning Messages?

Determines whether or not warning messages are sent 
when attempting to change the entities (such as Project 
Templates).
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The following is an example of setting a field on the General tab. The 
following process details the steps required to hide the Shortcut bar. 

To hide the Workbench Shortcut bar:

1. On the Workbench menu, select Edit > User Profiles.

The User Profiles window opens. 

2. De-select the Shortcut Bar checkbox.

3. Click OK.

The change is accepted and the Shortcut bar is no longer visible on the 
Workbench. 

Setting the Display of Workflows 
The Workflow Status tab of the User Profiles window controls settings for the 
display of Workflows based on the status of their steps. Table 3-3 lists the 
fields of the Workflow Status tab and details how to show all of a Workflow’s 
steps. To access the Workflow Status tab, from the menu select Edit > User 
Profiles. 

Default Browser Determines which browser is used to view attachments and 
URLs.

Table 3-2. User Profile Window - General Tab  [continued]

Fields Description
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Figure 3-7 User Profiles Window - Workflow Status Tab

The following process details how to show all of the steps in a Workflow. 

To show all of a Workflow’s steps:

1. On the Workbench menu, select Edit > User Profiles.

The User Profiles window opens. 

Table 3-3. Workflow Status Options 

Field Option

Workflow Steps Sets the display of Workflow steps. The following 
lists the options of the Workflow Steps field: 

• Show all Workflow Steps
Show all the steps in the Workflow. No options 
are available.

• Specify steps to show 
Choose whether to show traversed steps, and 
also whether to hide immediate and condition 
steps not in progress.
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2. Click the Workflow Status tab. 

The Workflow Status tab opens.

3. In the Workflow Steps field, select Show all workflow steps.

4. Click OK. 

The Show all workflow steps option is set. 

Setting the Display of Cancelled Package Lines
The Package tab of the User Profiles window controls settings for the display of 
cancelled Package Lines. This section details how to hide cancelled Package 
lines using the Package tab. To access the Package tab, from the Workbench 
menu select Edit > User Profiles. Figure 3-8 shows the Users Profile window 
Package tab. 

Figure 3-8 User Profiles Window - Package Tab

To hide cancelled Package lines:

1. On the Workbench menu, select Edit > User Profiles.

The User Profiles window opens. 
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2. Click the Package tab. 

The Package tab opens.

3. Select the Hide Cancelled Package Lines checkbox. 

4. Click OK. 

The Hide Cancelled Package Lines option is set. 

Configuring Regional Settings
Users can modify the display of dates, times, and numbers using the Regional 
Settings window. Each user’s computer operating system has a locale setting 
specifying the user’s language and country. Mercury IT Governance Center 
reads this setting and displays dates, times, and numbers according to the 
region’s customary format. For example, in Germany dates are displayed in 
day-month-year format with periods as separators (18.4.2001). In the United 
States, dates are displayed in month-day-year format with backslashes as 
separators (4/18/01). 
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To modify the display of regional settings:

1. On the Workbench menu, select Edit > Regional Settings.

2. De-select the Use Default Setting check box.

3. Click the Date tab.

The Date tab is used to set the display of dates to short, medium and long 
format. The following lists examples of date formats:

• Short - m/d/yy

• Medium - dd-Mon-yy

• Long - Month d, yyyy

Users can also specify the characters used to separate days, months, and 
years. Formats and delimiters are updateable through drop down lists.

4. Click the Time tab.

The Time tab is used to set the display of times in either the 12 or 24-hour 
format. Users can also specify AM and PM symbols and the character used 
to separate hours, minutes, and seconds. Format, symbols, and delimiters 
are updateable through drop down lists.

5. Click the Number tab.

All dates, times, and numbers are set to display using the default settings for 
the user’s locale. 
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The Number tab is used to configure which characters are used to denote 
decimals (either a period or a comma). Users can also define the grouping 
of digits, the symbol used to group them, and the sign used to mark 
percentages. Decimal markers, digit groupings and symbols, and 
percentage signs are updateable through drop down lists.

6. Click OK 

The new settings for the date, time, and number are saved. These settings 
are saved in each user’s personal profile, and are not editable by any other 
user.

7. Log off of the Workbench.

Users must log off of the Workbench and then logon again for the new 
regional settings to take effect.

Configuring Server Settings
The Server Settings window is used to configure how much information is 
logged by the server while running the application. This log information is 
used to analyze performance issues and gather information while the 
application is in use. Figure 3-9 shows the Sever Settings window. Table 3-4 
shows the fields of the Server Settings window. 

Figure 3-9 Server Settings Window

Unless specifically told to do so by the application administrator, do not 
change the Server Settings. 
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Using the Navigation Menu
The Navigate menu on the Workbench menu can be used instead of the 
Shortcut bar. All available screen groups and the Workbenches are accessible 
through the Navigate menu. The Navigate menu’s structure mimics the 
Shortcut bar and is accessible at all times. 

Table 3-4. Server Settings Field Definitions 

Field Definition

Debug Level (User) Sets the debug level for the client. The following lists the 
options of the Debug Level (User) field:

• No debugging information
System debug level is set to NONE. Only critical 
events are written to the log file. 

• Normal debugging information
System debug level is set to LOW. System 
performance is degraded. 

• Maximum debugging information
System Debug level is set to HIGH. System 
performance is degraded. 

Log User Name Sets whether to include the username in the Log file.

Log TimeStamp Sets whether to enable a timestamp in the Log file. 

Enable DB Trace Mode Sets whether to enable the database trace mode. 

Debug Level (Server) Sets the debug level for the client. The following lists the 
options of the Debug Level (Server) field:

• No debugging information
Server debug level is set to NONE. Only critical 
events are written to the log file. 

• Normal debugging information
Server debug level is set to LOW. System 
performance is degraded. 

• Maximum debugging information
Server Debug level is set to HIGH. System 
performance is degraded. 

Enable JDBC Logging Sets whether to enable JDBC. 
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Figure 3-10 Navigate Menu 

Changing Your Password
The Tools menu on the Workbench menu can be used to set a user’s password. 
This functionality is identical to setting a user’s password from the 
Dashboard’s menu bar Settings > Edit my Profile page. 

To set the standard interface password from the Workbench:

1. On the Workbench menu, select Tools > Change Password.

The Change Password window opens.

To hide the Shortcut bar, use the General tab of the User Profiles window. For 
more detailed information, see “Setting User Profiles” on page 29. 
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Figure 3-11 Tools Menu 

2. In the Confirm Old Password field, enter the old password.

3. In the Enter New Password field, enter the new password.

4. In the Confirm New Password field, re-enter the new password.

5. Click OK.

The new user password is accepted. 

Accessing Entity-Dependent Menus
Certain entities have extra configuration or processing options which are 
accessed through their own menus. These extra menus appear on the 
Workbench menu when the entity is selected. For example, when selecting a 
Request Type, the Request Type menu is added to the Workbench menu (see 
Figure 3-12 on page 39).
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Figure 3-12 Entity-Dependent Menu - Request Type 
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 Appendix

Field Formats

The Mercury IT Governance Workbench features a number of standard 
interface components. This appendix summarizes these components. 

This appendix covers the following topics:

• Attachment Field

• Auto-Complete Lists

• Arrows

• Check Boxes

• Dates

• Drop Down List

• Lists

• Radio Buttons

• Text Areas

For detailed information on altering the look and feel of these fields, consult 
the Validations appendix in Configuring a Request Resolution System or 
Configuring a Deployment System (Change Management). 

The field labels for required fields are always marked with red text.
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Attachment Field
Attachment fields occur as part of Request details or header fields. Attachment 
fields also occur as User Data fields. Attached documents are viewable by 
clicking on the hyper-linked name. When no file is attached, the Attachment 
field consists of the text field and a Browse button. 

Figure A-1  Attachments field without attachment 

Once an attachment is added and saved, such as by saving a Request, the name 
of the attachment and a Remove button are added to the Attachment field. 
Clicking the Remove button removes the attachment. 

Clicking the Browse button allows a different file to be selected, which 
replaces the currently attached file. 

Figure A-2  Attachment field with attachment 

Auto-Complete Lists
Auto-complete lists are used for fields validated against a list of pre-defined 
values. When entering a partial value into an auto-complete field, press the tab 
key and an auto-complete list opens. The auto-complete list shows all of the 
pre-defined values matching the partial value. Clicking on the icon located in 
the field also opens the auto-complete list. 

Figure A-3  Auto-Complete List field 

If no value is typed into the auto-complete field and you tab out of the field, 
the auto-complete dialog will not open, even if the field is required. If a 
mouse is used to navigate out of the field, the field will not be validated. If 
the field is left without using the tab key, the field will be validated at the 
next save. 
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Figure A-4  Auto-Complete Single Selection window 

Long auto-complete lists return all matching entities in a paging mode. Users 
navigate through multiple pages of entities using page numbers or arrow 
buttons. The number of returned pages and the current position in the list is 
displayed. 

Filter fields at the top of a Validation window can be used to shorten the list. 
Enter some or all of an entity’s name and click Filter. To clear the filter fields, 
click Clear. 

Some auto-complete lists can be configured to hold multiple values. When the 
auto-complete’s Validate page opens, an available page listing all available 
entries is opened and an adjacent selected page is also opened.
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Figure A-5  Auto-Complete Multiple Selection window 

To select more than one item from the auto-complete list:

1. Enter the values directly into the auto-complete field using a semi-colon to 
separate the entries. 

or

1. Click the auto-complete icon.

The auto-complete’s Validate page opens. 

2. Select an entity to include from the available page.

3. Click the Right arrow button  to move the entity to the selected page.

Repeat the process to add additional entities. To remove an entity from the 
selected page, select the entity and click the Left arrow button . Move 
multiple entities by using Shift + click for adjacent entities or Ctrl + click 
for non-adjacent entities.

4. Move an item up or down in the selected page by selecting the entity and 
clicking the Up or Down arrows  .

5. Click OK to accept the multiple selections. 
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The Validate page closes and the selected entities fill in the auto-complete 
field.

Arrows
Arrows are used to move an item from an unlinked (inactive) state to a linked 
(active) state. The following displays arrows used to move items to a linked 
state.

Figure A-6  Arrows 

Check Boxes
Check boxes are used for fields where there are only two choices, such as On 
and Off. To indicate On, click on the box beside the label and a check appears 
in the box. To indicate Off, the check box next to the label should be empty.

Figure A-7  Check Box field
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Dates
The date field is used to enter dates and time in any valid format. Mercury IT 
Governance Center automatically converts these dates into a standard format 
for the field. An example of a standard format is “March 15, 2001.”

Example valid date formats for “March 15, 2001” are:

• 3/15/2001

• 15-Mar-2001

• March 15, 2001 3:15 PM
(For a date with an associated time of 3:15)

• Valid date formats depend on the user’s locale. 

Figure A-8  Date field 

Clicking the date field calendar icon opens a date selection page which 
populates the date field by selecting a date from a calendar. The date selection 
page shows dates, time, or both, depending on the source of the field. Display 
of dates, times, and numbers can be altered. 

Figure A-9  Calendar

Date fields must be entered using a valid date (time) format. If an invalid 
date format is entered, a message appears showing sample valid date entries. 
If the field also accepts time entries and an invalid format is entered, a 
message appears showing sample valid date and time entries.
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Drop Down List
Drop down lists feature a pull-down list of valid values. Fields are selected by 
clicking on the field and using the mouse to make a choice. Also, fields can be 
selected by tabbing into the field and using the up and down arrow keys, or 
tabbing into the field and entering the first letter of the targeted choice.

Figure A-10  Drop Down List field

Lists
Lists are used to display multiple records with multiple items. Click on a 
column heading to sort the list by the column heading. Resize columns by 
centering the cursor on the lines between adjoining headings. When the cursor 
changes to a double headed arrow, click and drag the bar to the required 
position. To switch the columns, hold down the mouse button on a column 
header and drag it to the desired location. Any changes made to the list are 
temporary and the list reverts to the default format at the next logon. 

Figure A-11  List field

Radio Buttons
Radio buttons are used for fields where there are two or more choices. 
Selecting one option disables the other associated options. For example, 
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clicking Yes in a Yes/No radio button pair disables the No option. To select a 
choice, click the button to the left of the appropriate choice.

Figure A-12  Radio Button field

Text Areas
Text areas are generic entry fields. Text areas are displayed on multiple lines 
using a scroll bar, if necessary. Text areas can be configured with Field Help 
Icons (  ), providing specific information concerning the text area. Text areas 
can be pre-configured to only accept certain types of data, such as pure text or 
numbers. Non-conforming values cannot be entered into a text area. For 
example, entering the letter ‘A’ into a numeric text area is not accepted. In 
addition, text areas can be configured to accept only certain types of formats, 
such as Social Security numbers or telephone numbers. 

Figure A-13  Text Area field

Text Fields
Text fields are generic entry fields. Text fields are displayed on a single line. 
Text fields can be configured with Field Help Icons (  ), providing specific 
information concerning the text fields. Text fields can be pre-configured to 
only accept certain types of data, such as pure text or numbers. Non-
conforming values cannot be entered into a text fields. For example, entering 
the letter ‘A’ into a numeric field is not accepted. In addition, text fields can be 
configured to accept only certain types of formats, such as Social Security 
numbers or telephone numbers. 
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Figure A-14  Text field
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