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Support

Please visit the HP OpenView website at:

http://openview.hp.com/ 
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Chapter 1
Overview

Common Property Tables is a package that allows multiple reporting solutions associated 
with OVPI to share the same property data. Sharing property data eliminates duplication, 
allows the database to operate more efficiently, and simplifies the administration of report 
packs.

The following tables are created by installing the Common Property Tables package:

• K_Customer for customers

• K_Location for locations

• K_Node for nodes

These tables (especially K_Node) are populated by the reporting solution packages. These 
tables can be augmented and modified by the utilities and forms that come with Common 
Property Tables.

Version History

Version 2.1 of Common Property Tables was released January 2003. Version 2.1 installed on 
OVPI 4.5. The most noteworthy change in version 2.1 was the addition of a HOSTS file 
property import. This change simplified the mapping of node name to IP address in K_Node.

Version 2.2 of Common Property Tables was released May 2003. Version 2.2 installed on OVPI 
4.6 and took advantage of object management features and forms support introduced in OVPI 
4.6. Version 2.2 included forms two sets of forms, one for adding customers, locations, and 
nodes, and one for modifying existing customers, locations, and nodes.

Version 3.0 was released in April 2004. It installs on OVPI 5.0 and supports Oracle database 
software as well as Sybase database software. When you install version 3.0, the following 
directories are created:

• $DPIPE_HOME\data\ImportData 

• $DPIPE_HOME\data\PropertyData

All report packs that rely on Common Property Tables use the PropertyData directory. They  
import flat files from the PropertyData directory, and they export flat files to the 
PropertyData directory.

Version 3.0 also includes a new process that runs nightly:

CommonPropertyTables_delete_nodes.pro
7



Sources for Additional Information
The process performs the following tasks:

• Rebuilds stored procedures, one per property table

• Deletes nodes from individual property tables 

• Deletes nodes from ksi_managed_node

While there are two versions of the stored procedures, one for Sybase and one for Oracle, the 
process itself is database independent. The deletion of nodes from individual property tables 
takes place in response to the user marking nodes for deletion in Polling Policy Manager. 
Deleted nodes are listed in the Common Properties log file.

Sources for Additional Information

Notes about enhancements and any known problems affecting Common Property Tables 3.0 
can be found in the following document: 

• Common Property Tables 3.0 Release Statement

The following documents are sources of information about the core product, OVPI: 

• Performance Insight 5.0 Administration Guide 

• Performance Insight 5.0 Installation Guide 

• Performance Insight 5.0 Guide to Building and Viewing Reports

Manuals for OVPI, and manuals for the reporting solutions that run on OVPI, are 
available for downloading from the following site:

http://support.openview.hp.com/support

Select Technical Support > Product Manuals to open the Product Manual Search page. Manuals for 
OVPI are listed under Performance Insight. Manuals for report packs, datapipes, preprocessors, 
and NNM SPIs are listed under Reporting and Network Solutions. 

Every title under Reporting and Network Solutions 5.0 indicates the date of publication. Since 
updated user guides are posted to this site on a regular basis, check for updates on the web 
before using an older PDF that may no longer be current.
8



Chapter 2
Package Installation

This chapter covers the following topics:

• Guidelines for a smooth installation

• Restrictions that apply to installing the upgrade package

• Extracting packages and installing Common Property Tables 

• Package removal

Guidelines for a Smooth Installation

The RNS 4.0 CD included NNM components as well as OVPI packages. The RSN 5.0 CD is 
similar and it includes a similar install script. Once you select OVPI packages for extraction, 
the install script extracts every OVPI package from the CD and copies the results to the 
Packages directory on your system. 

If you have already extracted packages from the RNS 5.0 CD, every OVPI package on the CD 
is on your system and available for installation. You may install Common Property Tables 3.0 
by starting Package Manager and following the familiar on-screen directions. Before doing 
that, review the following guidelines. 

Upgrading to Version 3.0

If you are running Common Property Tables 2.2, you may upgrade to Common Property 
Tables 3.0 by installing the 2.2-to-3.0 upgrade package. Keep these rules in mind:

• Do not install other packages, for example, a report pack, when you are upgrading to 
Common Property Tables 3.0. Install the upgrade package for Common Property Tables 
and only the upgrade package for Common Property Tables.

• While you are installing the upgrade package, you will have the opportunity to keep or 
disable the Deploy Reports option. Since the forms in Common Property Tables 3.0 will 
not deploy unless you accept the default, be sure to accept the default.

• If your system is distributed, install the upgrade package on every OVPI server that is 
running a report pack that requires Common Property Tables.
9



Extracting Packages and Installing CPT
Software Prerequisites

Common Property Tables 3.0 requires OVPI 5.0 or higher. Do not attempt to install Common 
Property Tables 3.0 on an earlier version of OVPI. 

Directory Structure

When OVPI was installed, the installation program created the following:

• A directory for OVPI; the directory name is OVPI

• A directory for packages under the OVPI

• An environment variable that points to the OVPI directory.

The environment variable is {DPIPE_HOME}. On a UNIX system, the directory for OVPI 
defaults to /OVPI. On Windows NT, the directory for OVPI defaults to C:\OVPI. Several 
directories in the tree, shown below, are mentioned later in this guide.

The Packages directory is where Package Manager looks for packages awaiting installation. 
This directory contains one sub-folder for each package copied from the RNS 5.0 CD. When 
you run Package Manager, any package inside the Packages directory will show up as an 
installable item in the Package Selection window.

Extracting Packages and Installing CPT

Insert the RNS 5.0 CD and follow the directions for extracting OVPI report packs. On 
Windows, the directions appear in a menu that opens automatically; on UNIX, mount the CD, 
navigate to the top level directory for the CD drive, and run the setup command. 
10



Chapter 2
Once the files have been extracted and copied to your system, the install script will start 
Package Manager for you. If Package Manager is running now, begin this procedure at Step 5; 
otherwise, begin at Step 1.

1 Log in to the system. On UNIX systems, log in as root.

2 Stop OVPI Timer and wait for processes to terminate.

Windows NT: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer stop

Sun: sh /etc/init.d/ovpi_timer stop

3 Select HP OpenView > Performance Insight > Management Console.

4 Select Tools > Package Manager. The Package Manager welcome window opens. 

5 Click Next. The Package Location window opens.

6 Click the Install radio button.

7 Approve the default installation directory or select a different directory if necessary. 

8 Click Next. The Report Deployment window opens. Accept the default to deploy reports. 

9 Enter your username and password. 

10 Click Next. The Package Selection window opens. 

11 If this is a new install, click the check box next to CommonPropertyTables; if you are 
upgrading, click the check box next to UPGRADE22_30_CommonPropertyTables. 

12 Click Okay.

13 Click Next. The Type Discovery window opens. To run Type Discovery immediately after 
package installation, accept the default.

14 Click Next. The Selection Summary window opens.

15 Click Install. The Package Installation window opens and the install begins. When the 
install finishes, a package installation complete message appears.

16 Click Done to return to the Management Console

17 Restart OVPI Timer.

Windows NT: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start

Removing CPT from OVPI

If you just installed Common Property Tables for the first time, you may remove it. However, 
you must also remove any package that uses Common Property Tables as a prerequisite. You 
do not need to remove packages that do not use Common Property Tables.
11



Removing CPT from OVPI
If you just installed the upgrade package, you cannot return to your previous version of 
Common Property Tables by removing the upgrade package. Instead, you must remove the 
upgrade package you just installed and then re-install the version you were running.

Follow these steps to remove Common Property Tables 3.0. 

1 Log in to the system. On UNIX systems, log in as root.

2 Select HP OpenView > Performance Insight > Management Console.

3 Select Tools > Package Manager. The Package Manager welcome window opens. 

4 Click Next. The Package Location window opens.

5 Click the Uninstall radio button.

6 Click Next to uninstall the package from the default directory, or select Browse to locate 
and select a directory containing the component(s) to uninstall. 

7 Click Next. The Package Selection window opens. Click the check box next to Common 
Property Tables. 

8 Click Next. The Selection Summary window opens.

9 Click Uninstall. The Progress window opens and the removal begins. When the removal 
finishes, a package removal complete message appears. 

10 Click Done to return to the Management Console.

11 Restart OVPI Timer.

Windows NT: Select Settings > Control Panel > Administrative Tools > Services

UNIX: As root, type one of the following:

HP-UX: sh /sbin/ovpi_timer start

Sun: sh /etc/init.d/ovpi_timer start
12



Chapter 3
User Input Forms

The node, customer, and location objects maintained by the Common Property Tables package 
can be modified in two ways: 

• By using the input forms discussed in this chapter

• By using the import and export utilities discussed in the next chapter

The input forms allow you to create new objects for customers, locations, and nodes and 
modify existing objects. Using the forms is appropriate when you are adding or updating a 
small number of objects, while the batch-oriented utilities will be more efficient when lots of 
entries are involved.

The “Create New” Forms

The Create-New forms allow you add new objects to the database. Follow these steps to 
launch a create-new form.

1 Click the Objects icon in the panel on the left side of the Management Console window. 
The Object/Property Management view opens. 

2 Click the New icon in the tool bar, or select File > New... from the menu. The Create 
Managed Object window opens.

3 Select an option and click the Create button at the bottom of the window.
13



The “Create New” Forms
Create New Customer

To add a new customer, type a customer name and a description. If you are only entering one 
customer, click OK. The customer will be added and the window will close. If you have more 
customers to add, click Apply. The customer will be added, the form will be cleared, and the 
form will remain open for the next customer. 

Keep the following rules in mind when using the Create New Customer form:

• You must supply a name to create a new customer object.

• The customer name must be unique; you cannot have two customer objects with the same 
name.

• If a description is not specified, it will be set to the customer name.

Create New Location

To add a new location, enter a location name and a description. If you are only entering one 
location, click OK. The location will be added and the window will close. If you have more 
locations to add, click Apply. The location will be added, the form will be cleared, and the form 
will remain open for the next location. 

Keep the following rules in mind when using the Create New Location form:

• You must supply a name to create a new location object.

• The location name must be unique; having two location objects with the same name is not 
permitted.
14



Chapter 3
• If a description is not specified, it will be set to the location name.

Create New Node

To add a new node, enter a node name and any other information you may have. To assign a 
node to a customer or a location, click the customer or location drop box and select the desired 
entry. If you are only entering one node, click OK. The node will be added and the window will 
close. If you have more nodes to add, click Apply. The node will be added, the form will clear, 
and the form will remain open for the next node. 

Keep the following rules in mind when using the Create New Node form:

• You must supply a name for the node to create a new node object. The name can be its 
DNS name or its IP address.

• The name you supply must be unique; you cannot create a new node with the same name 
as an existing node.

• A node can only be assigned to pre-existing customers and locations. If you want to assign 
a node to customer that does not exist, you must first add the customer or location using 
the New Customer or New Location form.

• If a description is not specified, it will be set to the node name.

Creating a new node via this form will not automatically result in data 
collection. To initiate SNMP collections, the same node must be defined in 
Polling Policy Manager and added to a polling group. See the OVPI 
Administration Guide for more information on Polling Policy Manager.
15



The “Update” Forms
The “Update” Forms

The update forms modify properties for customer, location, and node objects that already exist 
in the database. To launch an update form, click the Objects icon in the panel on the left side of 
the Management Console window. The Object/Property Management view opens. Object 
Manager will present you with a list of objects. The type of object presented depends on which 
Object Manager View is open. The default view is the Device view, showing a list of devices, 
16



Chapter 3
that is, nodes. The Customer view shows a list of customers, and the Location view shows a 
list of locations. To change the view, select View > Change View and use the pop-up window to 
select a different view.

Once the type of object you are interested in updating is displayed, select the particular object 
you would like to update. When you have selected the object, Update <Object Type> Information 
will appear under Object Specific Tasks. Double-click the update task to open the appropriate 
update form.

Update Customer

To update customer information, type the changes in the fields provided. The ID is a reference 
number and cannot be changed. When changing the customer name, do not change it to 
another existing customer name. Having two customer objects with the same name is not 
allowed. To save your changes, click Apply. When you have finished making changes, click OK. 
Your changes will be saved and the window will close.

 Update Location

To update location information, type the changes in the fields provided. The ID is a reference 
number and cannot be changed. When changing the location name, do not change it to 
another existing location name. Having two location objects with the same name is not 
allowed. To save your changes, click Apply. When you have finished making changes, click OK. 
Your changes will be saved and the window will close. 
17



The “Update” Forms
Update Node

To update node information, type the changes in the fields provided. The node name cannot be 
changed. To assign a node to a different customer or location, click the customer or location 
drop box and select the desired entry. To save your changes, click Apply. When you have 
finished making changes, click OK. Your changes will be saved and the window will close. 
18
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Chapter 4
Import and Export Utilities

The user input forms described in the previous chapter are fine when dealing with a small 
number of customer, location, or node objects. However, for a large numbers of objects, you 
may find it more efficient to enter data using a batch process. The Common Property Tables 
package includes import and export utilities for this purpose. 

The import utility imports the four property data files described in Chapter 5. It runs 
automatically, once a day, and the default run time is midnight. The default run time can be 
changed to any hour of the day. You can also run the import utility manually, ahead of 
schedule. Run the export utility as needed.

The Import Utility

The import utility performs three tasks:

• Reads property data files containing records for the elements to be updated

• Stores the data in temporary tables in the database

• Uses imported data to update Common Property Tables (K_Node, K_Customer, and 
K_Location)

If the data in the property data file is for an element (node, customer, or location) that already 
exists in the property table, the data in the property table is overwritten by the imported 
data. If an element does not exist, a new row is inserted in the appropriate property table.

The default directory for property import and export files is:

{DPIPE_HOME}/OVPI/data/PropertyData

You never need to have all four property files in this directory. This directory can be empty, or 
it can contain just one or two files. When you want to update just one property table, edit just 
one file and store just one file.

To run the import utility manually, before the utility is scheduled to run, do the following:

1 Open a command prompt at the system level.

2 Navigate to the {DPIPE_HOME}/scripts directory.

3 Type the following command: 

trend_proc -f CommonPropertyTables_importdata.pro 
21



The Export Utility
The Export Utility

The export utility exports the contents of property tables as tab-delimited flat files and stores 
these files in the default property export directory, or in different directoy if you specify a 
different directory. The export utility is based on a process known as trend_export. This 
process determines which columns to export from the database and generates tab-delimited 
files in the proper directory, appending each file name with a timestamp, as follows:

• CommonPropertyTables_Customer.dat.<timestamp>

• CommonPropertyTables_Location.dat.<timestamp>

• CommonPropertyTables_Node.dat.<timestamp>

To run the export utility:

1 Open a command prompt at the system level.

2 Navigate to the {DPIPE_HOME}/scripts directory.

3 Type the following command:

trend_proc -f CommonPropertyTables_exportdata.pro 

Changing Default Directories

Common Property Tables creates a default directory reserved for property import and 
property export files. The import utility looks for files in this directory, and the export utility 
stores files in this directory. You are not required to establish a different directory. However, if 
changing the default directory is necessary, these are the task you would need to perform:

• Task 1: Create a new directory for import and export files

• Task 2: Provide the import utility with the path to the new directory

• Task 3: Provide the export utility with the path to the new directory

You can use the same directory for import and export files, or you can set up separate 
directories for import and export files.

Changing the Default Import Directory

The default directory for data property files, the location where the import utility will look for 
your edited files, is specified by the SourceDirectory path. This path appears in the following 
TEEL files:

• CommonPropTablesCustomer.teel

• CommonPropTablesHosts.teel

• CommonPropTablesLocation.teel

• CommonPropTablesNode.teel

If you are changing the default directory before you install the Common Property Tables 
Package, you can locate the TEEL files in the CommonPropertyTables.ap directory. If you 
want to change the default directory after running Package Manager, you must change the 
path information in two directories:
22



Chapter 4
• CommonPropertyTables.ap

• {DPIPE_HOME}/lib

To change the SourceDirectory, do the following:

1 Create the new source directory.

2 Navigate to the appropriate directory and open the directory. (See the discussion in the 
preceding section about which directories are involved.) You will see the following files:

• CommonPropTablesCustomer.teel

• CommonPropTablesHosts.teel

• CommonPropTablesLocation.teel

• CommonPropTablesNode.teel

3 Double-click the CommonPropTablesCustomer.teel file.

4 Locate the line beginning with: SourceDirectory = 

5 Change the path, replacing the existing path with the complete path name to the new 
directory; begin the new path name just after the equals sign ( = ). 

6 Make the same change in these files:

• CommonPropTablesHosts.teel

• CommonPropTablesLocation.teel

• CommonPropTablesNode.teel.

Changing the Default Export Directory

To change the default export directory, modify the export data process file. If you are making 
this change before you install the package, you will only have to make this modification once, 
in the CommonPropertyTables.ap directory. If you are making this change after you run 
Package Manager, make this modification in two places: 

• CommonPropertyTables.ap

• {DPIPE_HOME}/scripts

Follow these steps to change the default export directory: 

1 In the CommonPropertyTables.ap directory, edit the 
CommonPropertyTables_exportdata.pro file. See sample file below.

2 Locate the three trend_export statements and, beginning at the bracket after the -o, 
replace the existing path with the complete path to the new directory.

3 Only if necessary—only if you have already installed this package—navigate to the 
{DPIPE_HOME}/scripts directory and make the same changes you made to 
CommonPropertyTables_exportdata.pro.

Leave the file filters as specified in the original SourceDirectory.
23



Changing the Default Run Time
Changing the Default Run Time

The default run time for the automatic import process is 12:00 midnight. Follow these steps to 
change the default:

1 In the {DPIPE_HOME}/lib directory, edit the trendtimer.sched.

2 Scroll down the file and locate the line that defines the interval and offset for the 
trend_proc that executes the CommonPropertyTables_importdata.pro command.

3 Modify the offset indicator. The offset indicator is the number after the plus (+) sign. For 
example, if you change 24:00 to 18:00, the import utility will run at 18 hours after 
midnight, or 6:00 p.m.
24



Chapter 5
The Property Import Files

The import utility reads the following tab-delimited flat files:

• Customer data file

• Location data file

• Hosts data file

• Node data file

If the data that needs to be in these files already exists in a provisioning system, you can 
probably generate each flat file automatically by writing a script and exporting the data 
directly from the provisioning system database. If you cannot generate the file automatically, 
you will have to create it yourself. You may create it using a spreadsheet program such as 
Excel, or a text editor such as Notepad.

You can also generate customer, location, and node property import files by running the 
property export utility that comes with the Common Property Tables package. However, this 
approach to updating property information works only if the property tables have already 
been populated by a datapipe. If you run the export utility and notice that the export file is 
empty, the property tables are empty.

File Generation Guidelines

Whether you are exporting the data from a database or creating your own property import 
files, produce a separate file for customer, location, hosts, and node information and follow 
these guidelines:

• The sequence of columns, shown in the format tables below, is important. Adhere to this 
sequence and do not use values reserved for use by OVPI. 

• Do not embed tabs in quoted text strings. 

• If you are using a spreadsheet program, save each file as a tab-delimited file. If you are 
using a different method, be sure to enter a tab between columns.

• Give each input file the proper file name and save all the files to the directory where the 
import utility expects to find them.
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The required file names are listed in the following table.

If you are using the default SourceDirectory path, save your property data files to:

{DPIPE_HOME}/data/PropertyData

If you changed the SourceDirectory path, copy the files to the new directory.

Format of the Import Files

This section describes the format of the customer, location, hosts, and node data files. Make 
sure the sequence of columns in your files is correct—the same exact sequence shown here—
and make sure you do not use values that are reserved by OVPI. If you were able to export 
data from a provisioning system database and specify the proper column sequence, most of 
your work is already done and your only task is to verify that reserved values are used 
correctly.

Customer Data File

The customer data file contains three columns separated by tabs. Each row represents one 
customer. See below for a description of each column.

Restrictions

Follow these rules when you prepare the customer data file:

• Do not include column headers in your file. The first entry in your file should be an actual 
customer ID, not “cust_id.” 

• Reserved values for column 1 (cust_id) are: -2, -1, 0. 

• If the cust_id string was exported from the K_Customer property table, do not change it. 

Property File File Name

Customer CommonPropertyTables_Customer.dat

Location CommonPropertyTables_Location.dat

Host CommonPropertyTables_Hosts.dat

Node CommonPropertyTables_Node.dat

Column No. Description

1 Unique integer value for each customer. This value is 
known as “cust_id.”

2 The name associated with the customer ID. 

3 A description of the customer.
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• If you are adding a new customer to K_Customer, the value in column 1 (cust_id) must be 
different from all existing cust_id values.

• If you use an existing cust_id value (a value that matches the cust_id value of an existing 
customer), you will overwrite that cust_id’s data.

• Since conflict with cust_ids that were automatically assigned by a report pack or datapipe 
is possible, try to use high numbers in column 1. For example, you could begin with 10,000 
and go up from there.

Location Data File

The location data file contains three columns separated by tabs. Each row represents one 
location. See below for a description of each column.

Restrictions

Follow these rules when you prepare the location data file:

• Do not include column headers in your file. The first entry in your file should be an 
integer value for a location ID, not “location_id.”

• Reserved values for column 1 (location_id) are: -2, -1, and 0.

• If the location_id string was exported from the K_Location property table, do not change 
it. 

• If you are adding a new location to K_Location, the value in column 1 (location_id) must 
be unique; that is, it must be different from all existing location_id values. 

• Since conflict with location_ids that were automatically assigned by a report pack or 
datapipe is possible, try to use high numbers in column 1. For example, you could begin 
with 10,000 and go up from there.

Column No. Description

1 Unique integer value for each location. This value is 
known as “location_id.”

2 The name associated with the location ID. 

3 A description of the location.
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Hosts Data File

The hosts data file contains a one-to-one mapping of IP address to host name. This can be the 
system HOSTS file or a file with the same format as a system HOSTS file. The file contains 
two columns separated by a tab. Each row represents one device. See below for a description of 
each column.

Restrictions

Follow these rules when you prepare the hosts data file:

• Do not include column headers in your file. The first entry in your file should be an 
integer value for a location ID, not “IP address”.

• Each IP address and host name should only be listed once. Only the first occurrence of an 
IP address or host name will be imported; subsequent occurrences will be ignored.

• If an IP address had previously been mapped to a host name, importing it mapped to a 
different host name will make the previous mapping invalid. Only the latest mapping will 
be considered valid.

Node Data File

The node data file contains 15 columns separated by tabs. Each row represents one node. See 
below for a description of each column. 

Column No. Description

1 IP address

2 Host name

Column No. Description

1 A unique text string that matches the node name or the 
node IP address. 
Note: The node name, if the name is resolvable, or the 
node IP address.

2 The node reference number specified by the user.
Note: This number is known as “node_id.”

3 Note: This column is not used; preserved to maintain 
compatibility with earlier versions.

4 The node IP address.

5 The node type. Initially, this should be set to host. Other 
node types will be added in the future.

6 A description of the node composed by the user.

7 The manufacturer of the node.
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The customer name and location name columns are not necessary and are supported as a 
convenience for the user when specifying cust_ids and location _ids that are not defined in the 
K_Customer and K_Location common property tables.

If a new customer_id or location_id is specified for a given node, that cust_id/location_id will 
be inserted into the K-Customer or K-Location table along with the specified customer name 
or location name. If the customer name or location name is not specified, the name will be set 
to Undefined Customer or Undefined Location, as appropriate.

Restrictions

Follow these rules when you prepare the node data file:

• Do not include column headers in your file.

• If node name was exported from the K_Node Common Property Table, do not change it. 

• If you want to add a new node to the node property table, the text string in column 1 must 
be unique and it should be set to the node name (if available) or the node IP address. 

• If the text string in column 1 is not unique—that is, if the text string matches an existing 
value for node name—the other columns of your data file will overwrite the corresponding 
row in the common property table.

8 Node model type.

9 Node serial number.

10 Node operating system.

11 A name defined by the customer for the department 
where the node resides.

12 The ID number for the customer who owns the node; in 
other words, cust_id. This value establishes a link 
between the node and a customer in the K_Customer 
property table. 
Note: Default cust_id = -2

13 The ID number for the location of the node; in other 
words, location_id. This value establishes a link between 
the node and a location in the K_Location property table.
Note: Default location_id = -2

14 Customer name associated with cust_id.

15 Location name associated with location_id.

Column No. Description
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Import Files and Property Tables

The import file on the left updates the table on the right.

When you want to modify existing information in a property table, values must match exactly. 
If you are modifying a row in the K_Customer table, the cust_id values in the property file and 
the property table must match. Similarly, if you are modifying a row in the K_Location table, 
location_id values must match, and if you are modifying values in the K_Node table, node 
name values must match.

If the property import file introduces an existing value—that is, an existing cust_id, 
location_id, or node name value—the other values in the row from the property data file will 
overwrite the corresponding row in the common property table. If the property data file 
introduces a new value, a new row and keyid value will be inserted in the property table. 

Property File Common Property Table

CommonPropertyTables_Customer.dat K_Customer

CommonPropertyTables_Location.dat K_Location

CommonPropertyTables_Node.dat K_Node

CommonPropertyTables_Hosts.dat K_Node
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The Property Tables

The Common Property Tables package creates the following property tables:

• K_Customer

• K_Location

• K_Node

Each table is described below. 

K_Customer

The K_Customer property table contains customer-specific information. This table maintains 
customer ID, name, and description only. However, it can be expanded to support additional 
customer information (for example, address) if needed. 

COLUMN DESCRIPTION

dsi_key_id Unique value automatically assigned

dsi_target_name Always set to “0” for customer information

dsi_table_key Set equal to cust_id

dsi_descr Customer definable

cust_id Unique reference number for each customer.

cust_name Customer name associated with cust_id
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K_Location

The K_Location property table contains location specific information. This table maintains 
location id, name, and description only. However, it can be expanded to support additional 
location information if needed.

K_Node

The K_Node property table contains node-specific information. A node is any network device 
(computer, router, switch) capable of being polled for performance data.

COLUMN DESCRIPTION

dsi_key_id Unique value automatically assigned

dsi_target_name Always set to “0” for customer information

dsi_table_key Set equal to location_id. If the location information is not pre-
provisioned, dsi_table_key will equal dsi_key_id.

dsi_descr Customer definable

location_id Unique reference number for each location. If the location 
information is not pre-provisioned, location_id will equal 
dsi_key_id.

location_name Location name associated with location_id

COLUMN DESCRIPTION

dsi_key_id Unique value automatically assigned

dsi_target_name Always set to “0”

dsi_table_key Set equal to node_name.

dsi_descr Customer definable

node_id Customer assigned reference number for each node.

node_name Name of node; the DNS name or the IP address.

node_type Type of node; only valid type = Host

IP_address Node IP address

make Node manufacturer

model Node model type

serial_num Customer defined name for node department

operating_sys Node operating system

department Customer-defined name for node department

sysObjectID MIB II system object ID - not currently used
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cust_fk Foreign key pointing to table K_Customer. Default value 
points to default K_Customer row.

location_fk Foreign key pointing to table K_Location. Default value 
points to default K_Location row.

IP_state Flag indicating if the IP address node name mapping is the 
most recent mapping for the IP address.

COLUMN DESCRIPTION
33



K_Node
34



Index
Symbols
$DPIPE_HOMEdataImportData, 7
$DPIPE_HOMEdataPropertyData, 7

C
CommonPropertyTables_delete_nodes.pro, 7
Customer Data File, 26

D
default directories, 22
defaults

export directory, 22, 23
import process run time, 24

deleting nodes from ksi_managed_node, 8
deleting nodes from property tables, 7
directories

scripts, 21, 22

E
ee_collect, 24
environment variable, 10
export data command, 22
export file timestamps, 22
export utility, 13, 14, 15, 17, 18, 22

I
import utility, 21

K
K_Customer, 31
K_Host, 31
K_Location, 32

L
Location Data File, 27

N
Node Data File, 28

P
property data tables

RcomPropTab_Customer, 26
RcomPropTab_Host, 26
RcomPropTab_Location, 26

property export utility, 25

Q
quotation marks, 25

T
TEEL files

CommonPropTablesCustomer.teel, 22
CommonPropTablesHost.teel, 22
CommonPropTablesLocation.teel, 22

trend_export, 22
trendtimer.sched, 24

U
UNIX directory, 10

V
version history

Common Property Tables 2.1, 7
Common Property Tables 2.2, 7
Common Property Tables 3.0, 7
35



Index
36


	Common Property Tables User Guide
	Overview
	Version History
	Sources for Additional Information

	Package Installation
	Guidelines for a Smooth Installation
	Upgrading to Version 3.0
	Software Prerequisites
	Directory Structure

	Extracting Packages and Installing CPT
	Removing CPT from OVPI

	User Input Forms
	The “Create New” Forms
	Create New Customer
	Create New Location
	Create New Node

	The “Update” Forms
	Update Customer
	Update Location
	Update Node


	Import and Export Utilities
	The Import Utility
	The Export Utility
	Changing Default Directories
	Changing the Default Export Directory

	Changing the Default Run Time

	The Property Import Files
	File Generation Guidelines
	Format of the Import Files
	Customer Data File
	Location Data File
	Hosts Data File
	Node Data File

	Import Files and Property Tables

	The Property Tables
	K_Customer
	K_Location
	K_Node

	Index

