Summary
Error
The Server Automation java gui eports the following error when running a communications test against a managed server...
“SWR – Server identification error” problem.
Cause
The actual IP address of the physical managed server and the IP address stored on SA device record does not match up.
Support has noticed, on most of the cases, that it is caused because the /etc/localtime link to /usr/share/zoneinfo/UTC is broken.
In some cases the /etc/localtime could be overwritten by a recent OS patch, for instance.
Expected result for (correctly linked) /etc/localtime file:
# ls -la /etc/localtime
lrwxrwxrwx. 1 root root 25 May 2 2018 /etc/localtime -> ../usr/share/zoneinfo/UTC
Fix
Restoring the time zone to UTC and restarting the Satellite fixes the issue.
Steps to fix:
-
Restore the link:
# ln -s /etc/localtime /usr/share/zoneinfo/UTC -
Reboot the SA Satellite. Full restart required since the change is made on OS Level to ensure all system processes are using the correct information.
Note: As described above, this is the fix for the most of the cases, if this doesn´t resolve your problem, a Support case should be filed for deeper troubleshooting assistance.