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About this Guide
Welcome to the HP SOA Systinet Plug-In for Eclipse Guide. This guide explains how to use Systinet Plug-
In for Eclipse with SOA Systinet.

This guide contains the following chapters and appendices:

• Chapter 1, Systinet Plug-In for Eclipse

• Chapter 2, Getting Started

• Chapter 3, Exploring the Repository

• Chapter 4, Modifying Resources

• Chapter 5, Validating Resources

• Chapter 6, Generating Service Clients

• Chapter 7, Generating Service Skeletons

• Appendix A, Dialog Boxes

• Appendix B, Preferences

• Appendix C, Configuring Systinet Plug-In for Eclipse

• Appendix D, Eclipse Plug-in Requirements
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Document Conventions
This document uses the following typographical conventions:

Script name or other executable command plus mandatory arguments.run.bat make

Command-line option.[--help]

Choice of arguments.either | or

Command-line argument that should be replaced with an actual value.replace_value

Choice between two command-line arguments where one or the other is
mandatory.

{arg1 | arg2}

User input.java -jar hpsystinet.jar

File names, directory names, paths, and package names.C:\System.ini

Program source code.a.append(b);

Inline Java class name.server.Version

Inline Java method name.getVersion()

Combination of keystrokes.Shift+N

Label, word, or phrase in a GUI window, often clickable.Service View

Button in a user interface.OK

Menu option.New→Service
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Documentation Updates
This guide's title page contains the following identifying information:

• Software version number, which indicates the software version

• Document release date, which changes each time the document is updated

• Software release date, which indicates the release date of this version of the software

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign-in. To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html

Or click the New users - please register link on the HP Passport logon page.

You will also receive updated or new editions if you subscribe to the appropriate product support service.
For details, contact your HP sales representative.
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Support
You can visit the HP Software Support Web site at:

http://www.hp.com/go/hpsoftwaresupport

HP Software Support Online provides customer self-solve capabilities. It provides a fast and efficient way
to access interactive technical support tools needed to manage your business. As a valued support customer,
you can benefit by using the HP Software Support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a
support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html
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1 Systinet Plug-In for Eclipse

SOA Systinet enables your organization to manage the growth and development of your service infrastructure.
HP SOA Systinet Plug-In for Eclipse bridges the gap between your development environment and SOA
Systinet.

This chapter introduces Systinet Plug-In for Eclipse in the following sections:

• Overview on page 9

• Usecases on page 10

Overview
HP SOA Systinet Plug-In for Eclipse is a set of features enabling you to integrate SOA Systinet with your
IDE.

Systinet Plug-In for Eclipse contains the following features:

• Search

Search the SOA Systinet repository to find the service definitions you require.

For details, see Chapter 3, Exploring the Repository.

• Modify

Download resources from SOA Systinet, modify them in your IDE, and then upload them back to SOA
Systinet.

For details, see Chapter 4, Modifying Resources.

• Validate

Validate resources in your IDE against policies in the SOA Systinet repository.
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For details, see Chapter 5, Validating Resources.

• Generate

Generate service clients and skeletons from repository resources.

For details, see Chapter 6, Generating Service Clients and Chapter 7, Generating Service Skeletons.

Usecases
Systinet Plug-In for Eclipse is designed to assist in the development of services for the following users:

• Service Architects

• Download resources.

Import service definition files from SOA Systinet.

For details, see Downloading SOA Systinet Resources on page 21.

• Edit resources.

Edit service definitions using the standard functionality of your IDE.

• Validate resources before publication.

Using policies imported from SOA Systinet, validate your service definitions to ensure they meet your
policy requirements.

For details, see Chapter 5, Validating Resources.

• Upload resources.

Export your service definition files to SOA Systinet.

For details, see Uploading SOA Systinet Resources on page 22.

• Service Consumers

• Locate the services you want to consume.
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Repository Search enables you to identify services you want to consume. You can limit the search to
services that are consumable, or to a particular lifecycle stage (for example, Production).

For details, see Searching the Repository on page 17.

• Generate service clients for services you want to consume.

Using the service definitions located in the search, generate a service client from the service definition
to assist the development of your consuming service.

For details, see Chapter 6, Generating Service Clients.

• Service Providers

• Locate the service definitions you want to develop.

Repository Search enables you to identify services you want to develop. You can limit the search to
services at particular lifecycle stages (for example, Initial or Development).

For details, see Searching the Repository on page 17.

• Validate your local resources against policies from the SOA Systinet repository.

Using policies imported from SOA Systinet, validate your resources to ensure they meet your policy
requirements.

For details, see Chapter 5, Validating Resources.

• Generate service skeletons for services you want to develop.

Using the service definitions located in the search, generate a service skeleton from the service definition
to assist the development of your service.

For details, see Chapter 7, Generating Service Skeletons.
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2 Getting Started

Systinet Plug-In for Eclipse works in conjunction with your existing development platform.

This chapter contains the following sections:

• Installing Systinet Plug-In for Eclipse on page 13

• Setting Up 2-way SSL on page 16

Installing Systinet Plug-In for Eclipse
HP SOA Systinet Plug-In for Eclipse is a plug-in for Eclipse distributed as the following archive file:

hp-soa-systinet-eclipse-plugin-3.20.zip

Table 1. System Requirements

IDEJava JDKOperating System

Eclipse 3.2.xSun JDK 5.0Windows XP

Eclipse 3.3.x

Eclipse 3.4.x

Eclipse 3.3.xSun JDK 5.0Windows Vista

Eclipse 3.4.x

Eclipse 3.2.xSun JDK 5.0RHEL 5.2

Eclipse 3.3.x

Eclipse 3.4.x
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For supported platforms and known issues, see readme.txt alongside the archive.

The following versions of Eclipse can be used with Systinet Plug-In for Eclipse without any other plug-in
dependencies:

• Europa for Java EE Developers (eclipse-jee-europa-winter-win32.zip)

• Ganymede for Java EE Developers (eclipse-jee-ganymede-SR2-win32.zip)

If you use another version of Eclipse, you may require a number of plug-ins. For details, see Appendix D,
Eclipse Plug-in Requirements.

To install Systinet Plug-In for Eclipse to Eclipse:

1 In your current Eclipse SDK (3.2 or later), use the software updates feature to install Systinet Plug-In
for Eclipse.

Select Help→Software Updates→Find and Install....

The Install/Update dialog opens.

2 In the Install/Update dialog, select Search for new features to install, and click Next.

The Install – Update Sites to Visit dialog opens.

3 In the Update Sites to Visit dialog, click New Archived Site.

The Select Local Archive Site dialog opens.

4 Locate and select hp-soa-systinet-plugin-eclipse-3.20.zip, and then click Open.

The Edit Local Site dialog opens.

5 In the Edit Local Site dialog, if required, rename the local archive name, and click OK.

6 In the Install – Update Sites to Visit dialog, select the new local archive, and then click Finish.

The Updates – Search Results dialog opens.
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7 Select the archive, or expand the archive and select individual components, and click Next.

Systinet Plug-In for Eclipse consists of the following components:

• Search and Validate

The search and validation features of Systinet Plug-In for Eclipse.

• WTP Integration

The integration points with the WTP plug-in.

The Install – Feature License dialog opens.

8 In the Feature License dialog, select I accept the terms in the license agreements, and click Next.

The Install – Installation dialog opens.

9 In the Installation dialog, if required, change the installation location, and then click Finish.

To start Systinet Plug-In for Eclipse:

• Execute ECLIPSE_HOME/eclipse.exe.

The first time you start Systinet Plug-In for Eclipse, you are prompted for the connection URL and credentials
for the SOA Systinet server.

Do one of the following:

• Set a connection URL and credentials and optionally select to save them, and then click OK.

The SOA Systinet server must be running.

• Click Skip to set them later. For details, see Setting the Server on page 63.
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Systinet Plug-In for Eclipse uses the Eclipse API to store passwords. Saved passwords are
stored in a file that is difficult but not impossible for an intruder to read.

Setting Up 2-way SSL
You can set up 2-way SSL communication between Systinet Plug-In for Eclipse and SOA Systinet using
the client certificate for your SSL environment.

To enable 2-way SSL:

1 Close Systinet Plug-In for Eclipse

2 Open ECLIPSE_HOME/eclipse.ini with a text editor.

3 Add the following properties using your certificate values:

• -Djavax.net.ssl.keyStore=<user_keystore>

• -Djavax.net.ssl.keyStorePassword=<keystore_pass>

• -Djavax.net.ssl.keyStoreType=<keystore_format>

• -Djavax.net.ssl.trustStore=<user_truststore>

• -Djavax.net.ssl.trustStorePassword=<truststore_pass>

• -Djavax.net.ssl.trustStoreType=<truststore_format>

4 Restart Eclipse using ECLIPSE_HOME/eclipsec.exe.
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3 Exploring the Repository

Systinet Plug-In for Eclipse enables you to search and examine data in the SOA Systinet repository.

These features are described in the following sections:

• Searching the Repository on page 17

Locate specific artifacts using lifecycle, consumption, and property criteria.

• Search Results on page 18

View artifacts matching your search criteria and their related artifacts.

• Artifact Detail View on page 19

Examine individual artifacts in detail.

Searching the Repository
HP SOA Systinet Plug-In for Eclipse includes a Repository Search feature, enabling you to explore the
content of SOA Systinet.

To search the repository:

1 Do one of the following:

• From the menu, select Search→Repository.

• Use the keyboard shortcut, Ctrl+R.

The Search dialog opens displaying the Repository Search tab.

2 In the Scope section, select an artifact type to search, and if required, a specific lifecycle stage.
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The Properties section refreshes showing specific details depending on the artifact type.

Generating service clients and skeletons uses WSDL definitions to create code stubs. To
find the WSDL you need, search for SOAP Services or Operations, as these artifacts
contain lifecycle and contract information. The functionality for generating code stubs
is available on search results for SOAP Services and Operations and utilises the WSDLs
associated with them.

3 Enter your search parameters. The parameters vary depending on the artifact type.

For parameter details, see Repository Search on page 50.

4 To display the parent artifacts search result artifacts depend on, select Show Parent Artifacts

5 Click Search to execute the search.

Systinet Plug-In for Eclipse displays the results of the search in the Repository Search Result tab. For
details, see Search Results on page 18.

Search Results
Systinet Plug-In for Eclipse displays the results of a repository search in the Repository Search Results tab.

To search the repository, see Searching the Repository on page 17.

The results show a tree of artifacts for each artifact matching the search criteria, as shown in Figure 1,
“Repository Search Results View”:
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Figure 1. Repository Search Results View

The tree for each matching artifact contains any related child artifacts. If you select Show Parent Artifacts
in your search, the tree also includes related parent artifacts.

Double-click an artifact name in the Repository Search Results tab to view its details in an artifact details
tab. The tab name is the name of the artifact. For details, see Artifact Detail View on page 19.

For SOAP Services and Operation artifacts, the search results provide code generation functionality. Right-
click the resource and select Generate Service Client or Generate Service Skeleton. For details, see
Chapter 6, Generating Service Clients or Chapter 7, Generating Service Skeletons.

To download any associated service resources, right-click a result entry, and select Save As. For details,
see Downloading SOA Systinet Resources on page 21.

The hierarchy of artifact types and the properties displayed for each artifact type are defined
in the configuration you can customize.

For details, see Appendix C, Configuring Systinet Plug-In for Eclipse.

Artifact Detail View
Systinet Plug-In for Eclipse enables you to view the details for a particular artifact in its own detail view.
The content of this view is similar to the Artifact Detail View in the Tools tab in SOA Systinet.

In Eclipse, this kind of view is normally called an Editor. However, Systinet Plug-In for
Eclipse does not provide editing features in these Artifact Views.
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The artifact details vary depending on the artifact type and your customization and configuration.

For details about customizing the detail views, see Appendix C, Configuring Systinet Plug-In for Eclipse.

The Artifact Detail view contains the following segments depending on the artifact type:

• General

Displays a description, the owner of the artifact, and a URL to the XML representation of the artifact.

• Details

Displays a set of properties for the artifact. These properties vary depending on the artifact type.

• Data

Displays a link to the attached data in the repository for artifacts with attached data content. Click the
link to view the content of the attached data.

• Relationships

Displays the set of related artifacts, indicating the type of relationship, the related artifact, and the direction
of the relationship.

Double-click an artifact name to open its detail view.
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4 Modifying Resources

Systinet Plug-In for Eclipse enables you to download resources from SOA Systinet, modify them, and then
upload them back to SOA Systinet.

These features are described in the following sections:

• Downloading SOA Systinet Resources on page 21

Download service definitions from SOA Systinet.

• Uploading SOA Systinet Resources on page 22

Upload service definitions to SOA Systinet.

• Synchronizing Resources on page 24

Synchronize local resources with their SOA Systinet versions.

• Deleting SOA Systinet Resources on page 24

Delete resources from the SOA Systinet repository.

Downloading SOA Systinet Resources
Systinet Plug-In for Eclipse enables you to download the service definitions associated with artifacts from
SOA Systinet.

Systinet Plug-In for Eclipse supports download for the following file types:

• WSDL

• BPEL

• XSD
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• DTD

• SCA

To download service definitions from SOA Systinet:

1 Perform a repository search to locate the service you want to download the definitions for.

For details, see Searching the Repository on page 17.

2 In the Repository Search Results view, right-click a search result, and select Save As.

The Download Document from SOA Systinet dialog opens.

3 In the Download Document from SOA Systinet dialog:

Select Resolve Dependencies to resolve any dependencies in the service definition files and download
all referenced files as well.

Select Open Resource after Downloading to open an editor view of the downloaded resource after
download.

Select a location in your project to store the downloaded resources, and then click Finish.

Systinet Plug-In for Eclipse downloads the relevant service definition files and copies them to the
selected location. The structure of the SOA Systinet publishing location space is preserved.

For details about the Publishing Location space, see "Publishing Locations Workspace" in the HP SOA
Systinet Developer Guide.

Uploading SOA Systinet Resources
Systinet Plug-In for Eclipse enables you to upload service definition documents directly to SOA Systinet.

Systinet Plug-In for Eclipse supports upload for the following file types:

• WSDL

• BPEL
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• XSD

• DTD

• SCA

Unlike other supported types, Systinet Plug-In does not automatically resolve SCA style
references by name between various SCA files, typically defined by elements such as
<include>. You must select all interconnected SCA files explicitly for upload.

To upload service definitions to SOA Systinet:

1 In the Project Explorer, right-click the resource or folder of resources you want to upload, and select
HP SOA Systinet → Upload.

The Upload Documents dialog opens.

2 Select resources to upload, and then click Next.

3 Select the publishing location folder, or input a new one.

Select from the following Advanced Options:

DefinitionParameter

Select a WSDL processing level from the following options:Decomposition

• Services

Process any WSDLs, create all defined content and create business services
to associate with any newly created implementations.

• Implementations

Process any WSDLs and create all defined content. Business services are
not created.

• None
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Publish any WSDLs as artifacts with attached data content. The WSDL
files are not processed.

DefinitionParameter

If a WSDL is republished the artifacts it references may change and
previously created artifacts may no longer be required. Select artifact types
to remove the relationships with these obsolete referenced artifacts.

Remove
Unsynchronized

Click Next.

SOA Systinet processes the content for upload and returns an Upload Overview to Systinet Plug-In
for Eclipse.

4 Review the overview and click Finish to complete the upload and create the relevant artifacts, or
Cancel to abort the upload.

Synchronizing Resources
After downloading resources from SOA Systinet, you may want to synchronize them with SOA Systinet.

To synchronize a local resource with SOA Systinet:

1 In the Project Explorer, right-click the resource you want to synchronize and select HP SOA
Systinet→Synchronize with Server.

The Synchronization view opens showing any files that differ.

2 Optionally, right-click an item that differs from the server version, and select Update to import the
latest version from SOA Systinet.

You can configure Systinet Plug-In to perform automatic synchronization. For details, see Setting
Synchronization on page 66.

Deleting SOA Systinet Resources
Systinet Plug-In for Eclipse enables you to delete resources stored in the SOA Systinet repository.
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To delete SOA Systinet resources:

1 In the Project Explorer, right-click the resource you want to delete, and select HP SOA Systinet→Delete
from Server.

The SOA Systinet UI opens requesting authentication.

2 Enter your credentials.

The detail view of the artifact you want to delete opens.

3 Use SOA Systinet functionality to delete the artifact. For details, see the HP SOA Systinet User Guide.
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5 Validating Resources

Systinet Plug-In for Eclipse enables you to validate local resources against policies.

This chapter contains the following sections:

• Setting Up Validation on page 27

Explains the process of importing and updating policies from the Policy Manager.

• Ad Hoc Validation on page 31

Explains how to run unscheduled validation and produce reports.

• Automatic Validation on page 37

Explains how to set up automatic validation.

Setting Up Validation
Systinet Plug-In for Eclipse contains a default set of policies. You can add or delete policies, and update
your local policies against versions from an SOA Systinet server. Systinet Plug-In for Eclipse also includes
the default HP SOA Systinet Policy Manager extension, which contains default Policy Manager validation
handlers.

Validation is introduced in the following sections:

• Setting Up Policies on page 28

• Importing Policies on page 30

• Removing Policies on page 30

• Updating Policies on page 30
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• Customizing Validation Handlers on page 31

Setting Up Policies

You can add, delete, or update policies in the Systinet Plug-In for Eclipse Policies page.

To set up policies:

1 From the menu, select Window→Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, expand HP SOA Systinet→Policy Validation→Policies.

The Policies page opens, as shown in Figure 2, “Policies Page”.
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Figure 2. Policies Page

In the Policies page, do any of the following:

• Import an archive or folder.

For details, see Importing Policies on page 30.

• Remove a policy

For details, see Removing Policies on page 30.

• Update local policies.

For details, see Updating Policies on page 30.
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Importing Policies

You can import policies from an archive or folder from a designated HP SOA Systinet server.

To import an archive or folder from an HP SOA Systinet server:

1 In the Policies page, do one of the following:

• Click Import Archive to open the Select an Archive to Import dialog box, and then go to Step 2.

• Click Import Folder to open the Select a Folder to Import dialog box, and then go to Step 3.

2 Enter the required parameters and browse for the archive you need, and then click Open.

The selected archive is imported to the Policies page.

3 Browse for the folder you need, and then click OK.

The selected folder is imported to the Policies page.

The Import Archive and Import Folder buttons load policies, assertions, and remote server
information from the client distribution, created during the installation process in the folder
SOA_HOME.

The import of the client distribution will fail if the provided folder or archive does not follow
the structure of the SOA Systinet 3.20 client distribution, which must include the bin, conf,
data, extensions, and lib folders.

Removing Policies

To remove a policy:

• Highlight the policy in the Policies page, and then click Delete.

Updating Policies

You can use Systinet Plug-In for Eclipse to update local policies against policies on an SOA Systinet server.
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To update policies:

1 Make sure the SOA Systinet server is running.

2 Click Update.

The local version of the policy is updated to reflect the version on the HP SOA Systinet server.

Customizing Validation Handlers

Systinet Plug-In for Eclipse includes a set of validation handlers, contained in the standard Policy Manager
extension. Custom validation handlers can be included in the Systinet Plug-In for Eclipse by adding the
appropriate extensions.

To add extensions to Systinet Plug-In for Eclipse:

1 From the menu, select Window→Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, expand HP SOA Systinet→Policy Validation→PM
Extensions.

3 Click Add.

The Select an Extension dialog box opens.

4 Browse for the .jar file you require, and then click Open.

The extension is now visible in the PM Extensions page.

You must restart Systinet Plug-In for Eclipse for your changes to take effect.

Ad Hoc Validation
Ad hoc validation is the unscheduled validation of documents against policies.
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Ad hoc validation is described the following sections:

• Running Ad Hoc Validation on page 32

• Viewing Ad Hoc Validation Results on page 33

• Revalidating a Document on page 35

• Exporting Reports on page 36

• Setting Report Style on page 36

Running Ad Hoc Validation

To run ad hoc validation on a single resource:

1 Right-click a document in Project Explorer to open its context menu, and then scroll over Check Policy
Compliance.

A list of available policies is displayed.

2 Select the policy you want to validate the document against.

The validation runs and the result is shown in the Validation Result tab.

For details, see Viewing Ad Hoc Validation Results on page 33.

To run ad hoc validation using multiple resources or policies:

1 Right-click a document in Project Explorer to open its context menu, and then scroll over Check Policy
Compliance.

A list of available policies is displayed.

2 Select More Validation Options.

The Edit Configuration and Launch dialog box opens, as shown in Edit Configuration and Launch on
page 46.

3 To add documents, do one of the following:
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Click Add File to browse and select documents from your Eclipse project.•

• Click Add External File to browse and select documents from your file system.

• Click Add External Folder to browse and select all documents in a folder in your file system.

• Click Add URL to enter the endpoint URL of a remote document.

4 In the Technical Policies field, click Add to select from a list of available policies to use in the validation.

5 Click Run.

The validation runs and the result is shown in the Validation Result tab.

For details, see Viewing Ad Hoc Validation Results on page 33.

Viewing Ad Hoc Validation Results

When validation completes, the Validation Result view displays the results. For each result, you can view
a detailed HTML report. You can also view a summary report for all validation results.

The default report style is similar to that of Policy Manager validation reports. For information about setting
report styles, see Setting Report Style on page 36.

To view a validation report:

• Right-click a validation result in the Validation Result tab to open its context menu, and then select 
View Detail.

An HTML report opens, as shown in Figure 3, “Validation Report”.
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Figure 3. Validation Report

If you have more than one validation result, you can view a summary report of all the validation results.

To view a summary report, click the Summary Report button on the Validation Result tab.

The Summary Report view opens, as shown in Figure 4, “Summary Report”.
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Figure 4. Summary Report

To view the detailed report of a document in the summary, click the report hyper link in the Details column.

You can set a resource in the results view to be automatically validated. Right-click the resource to open
its context menu, and select Set as Automatic Validation. The resource is re-validated against the set of
automatic policies for the project and added to the custom list of project resources to be validated. For
details, see Setting Up Automatic Validation on page 37.

Revalidating a Document

If recent changes have been made to a document, you can revalidate that document.

To revalidate a document:

• Select a result in the Validation Result tab, and click Revalidate.

The document is revalidated against the selected policies.
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Exporting Reports

You can export the report to your file system.

To export a validation report:

• Select a result in the Validation Result tab, and then click Export Reports.

• Browse for the location to which you want to save the report, and click OK.

Both detail and summary reports are saved.

Setting Report Style

Included with Systinet Plug-In for Eclipse is the Policy Manager detail report stylesheet. If you want to
change the stylesheeet, you can select from a pure text style or XML format.

To change the style of ad hoc validation reports:

1 From the menu, select Window→Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, expand HP SOA Systinet→Policy Validation.

The Policy Validation page opens. For details, see Policy Validation on page 48.

3 In the Validation Result Format pane, select one of the following options:

• Text Format, then go to Step 5.

• XML Format, then go to Step 4.

4 In the Stylesheet pane, select one of the following options:

• Associate with default stylesheet.

• Custom stylesheet, then browse for the stylesheet you need.
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5 Click OK to produce the report in the selected format.

Automatic Validation
Systinet Plug-In for Eclipse enables the automatic validation of documents while you work on them.

After you set up automatic validation, you can see annotations to your document that change in real time.

Automatic validation is described in the following sections:

• Setting Up Automatic Validation on page 37

• Disabling Spell Checker on page 40

• Assertion Details on page 40

Setting Up Automatic Validation

To enable automatic validation, you must set it up for a project.

To enable automatic validation:

1 Do one of the following:

• Right-click the project in Project Explorer to open its context menu, and select Configure Automatic
Validation→Set Project to be Automatically Validated.

• Right-click the project in Project Explorer to open its context menu, and select Properties.

In the tree menu, select Automatic Validation.

The Properties for [Project Name] dialog box opens showing thw Automatic Validation options. For
details, see Properties for [Project Name] on page 49.

2 Select Set Project to be Automatically Validated if it is not already set.

3 In the List of Policies pane, click Add and select the policies you need. Click OK.

4 In the List of Resources pane, select one of the following:
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Default (Entire Project), then go to Step 6.•

• Custom, then go to Step 5.

5 Select any of the following:

• Add

To add a folder from your project.

• Exclude

To exclude individual files from the selected folder.

• Remove

To remove the folder from the list.

6 In the Filtered By pane, do any of the following:

• Click Add to add a file extension.

• Click Remove to remove a file extension from the list.

7 Click OK to confirm automatic validation settings.

The validation runs and the results are displayed in the Automatic Validation Results view, as shown in
Figure 5, “Automatic Validation Results”.
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Figure 5. Automatic Validation Results

After automatic validation has been set up, you have the option to include or exclude documents for validation.

To include or exclude documents:

1 Right-click the document in Project Explorer to open its context menu.
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2 Select Configure Automatic Validation, and do one of the following:

• Select Exclude from Validation Path to remove the document from the validation process.

• Select Include in Validation Path to add the document to the validation process.

You can also add resources to the custom list from the Validation Results view. For
details, see Viewing Ad Hoc Validation Results on page 33.

Disabling Spell Checker

In Eclipse 3.2 (or higher), the spell checker annotates documents that are open in the main view. The spell
checker annotations can obscure Systinet Plug-In for Eclipse automatic validation annotations. You should
disable the Eclipse spell checker.

To disable the Eclipse spell checker:

1 From the menu, select Window→Preferences.

The Preferences dialog box opens.

2 In the tree menu, expand General→Editors→Text Editors→Spelling.

3 Deselect Enable spell checking and click OK.

Assertion Details

You can view additional details about assertions that were violated. Systinet Plug-In for Eclipse can create
a special tooltip describing the assertion, with HTML links to assertion description web pages.

To view an assertion description:

• Right-click one of the errors listed in the Problems view to open its context menu, and then click View
Assertion Description.

A tooltip opens with the assertion description and a link to available online resources about the assertion.
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6 Generating Service Clients

Systinet Plug-In integrates with existing Eclipse Web Tools Platform (WTP) functionality, enabling you
to create a client stub from resources in the repository.

To generate a service client stub:

1 Perform a repository search to locate the resource you want to use for client generation.

For details, see Searching the Repository on page 17.

For consumer use cases search for Consumable services at the Production lifecycle stage.

2 In the Repository Search Results view, right-click the Operation or SOAP Service to use for client
generation, and select Generate Service Client.

If the Environment preference is set to Always Ask, you are prompted to select from the available endpoint
options, otherwise any endpoint uses the default setting. For details, see Setting the Environment on
page 64.

Generating a client uses the WSDL associated with SOAP Service or Operation.

The Web Service Client dialog opens.
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3 Use the Web Service Client dialog to select your project and environment settings.

For details, see the WTP documentation at the following location:

http://help.eclipse.org/help33/topic/org.eclipse.jst.ws.axis.ui.doc.user/tasks/tsampappa.html

The WTP plug-in looks for a Dynamic Web Project and warns you if there is no such
project available. It is possible to ignore the warning and select a plain Java project
instead.

Click Client Project and select the project you require.

The WTP plug-in uses the provided WSDL to generate source code stubs for the service client.

Use the Package Explorer to access the generated code.
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7 Generating Service Skeletons

Systinet Plug-In for Eclipse integrates with existing Eclipse Web Tools Platform (WTP) functionality,
enabling you to create a skeleton stub from resources in the repository.

To generate a service skeleton stub:

1 Perform a repository search to locate the resource you want to use for skeleton generation.

For details, see Searching the Repository on page 17.

For provider use cases search for services at early lifecycle stages, such as Initial or
Development.

2 In the Repository Search Results view, right-click the SOAP Service or Operation to use for client
generation, and select Generate Service Skeleton.

Generating a skeleton against a SOAP Service or Operation uses the WSDL associated
with it.

The Web Service dialog opens.
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3 Use the Web Service dialog to select your project and environment settings.

For details, see the WTP documentation at the following location:

http://help.eclipse.org/help33/topic/org.eclipse.jst.ws.axis.ui.doc.user/tasks/tsklwsdla.html

The WTP plug-in requires a Dynamic Web Project for skeleton generation.
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The WTP plug-in uses the provided WSDL to generate source code stubs for the service skeleton.

Use the Package Explorer to access the generated code.
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A Dialog Boxes

Each Systinet Plug-In for Eclipse input dialog is described in the following sections:

• Edit Configuration and Launch on page 46 Run ad hoc validation on several documents and policies at
the same time.

• Policy Validation on page 48 Set preferences for your report style.

• Properties for [Project Name] on page 49 Set up automatic validation for your project.

Edit Configuration and Launch
Run ad hoc validation on several documents and policies at the same time:
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DefinitionParameter

The name you want to use for the validation check.Name

The list of resources you want to use for validation.Sources

Browse and select documents from your Eclipse project.Add Resource

Browse and select documents from your file system.Add External File

Browse and select all documents in a folder in your file system.Add External Folder

Enter an endpoint URL of a remote document.Add URL

Remove previously selected documents.Remove

The list of technical policies associated with the resources.Technical Policies

Select from a list of available policies to use in the validation.Add
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DefinitionParameter

Remove previously selected policies.Remove

Filter available documents or policies by file type.Filtered By

Add a specific file type.Add

Remove a previously selected file type.Remove

Apply the current configuration.Apply

Restore the previous configuration.Revert

Start validation.Run

Close the dialog box without launching validation.Close

Policy Validation
Set preferences for your report style:
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DefinitionParameter

Choose whether you want the validation results to be in Text or XML format.Validation Result
Format

Choose whether to use the default or a custom stylesheet.Stylesheet

Browse for and select a custom stylesheet.Browse

Specify the maximum number of returned results.Validation Result
Limit

Filter available stylesheets by file type.Filtered By

Add a specific file type.Add

Remove a previously selected file type.Remove

Save your preferences.OK

Exit without saving your preferences.Cancel

Properties for [Project Name]
Set up automatic validation for your project.
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DefinitionParameter

Available policies for use in validation.List of Policies

Browse for and select the policies you need.Add

Remove previously selected policies.Remove

Choose whether you want to use resources in the entire project (default) or create a
custom selection.

List of Resources

Add custom resources.Add

Exclude specific files from the selected resource.Exclude

Remove previously selected resources.Remove

List of associated file types.Filtered By

Add a specific file type to the filter.Add

Remove a previously selected file type from the filter.Remove

Save your settings.OK

Exit without saving your settings.Cancel

Repository Search
The property parameters available in the Repository Search dialog vary depending on the artifact. The
artifacts available and their properties also vary according to your customization and configuration.

For details about customizing Systinet Plug-In for Eclipse, see Appendix C, Configuring Systinet Plug-In
for Eclipse.

This section describes the default parameters for the default artifact types in the following sections:

• Repository Search: Application on page 51

• Repository Search: Business Service on page 52

• Repository Search: SOAP Service on page 52

• Repository Search: Operation on page 53
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• Repository Search: WSDL on page 55

• Repository Search: BPEL on page 56

• Repository Search: SCA on page 58

• Repository Search: Business Process on page 60

• Repository Search: XML Schema on page 61

Repository Search: Application

This section describes the default property search parameters for applications.

DescriptionProperties

Name of the application.Name

Description of the application.Description

Select to restrict the search to consumable applications.Consumable Only

Alias for the application.Alias
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DescriptionProperties

Version number.Version

Repository Search: Business Service

This section describes the default property search parameters for business services.

DescriptionProperties

Name of the business service.Name

Description of the business service.Description

Select to restrict the search to consumable business services.Consumable Only

Version number.Version

Any keywords assigned to the business service.Keyword

Repository Search: SOAP Service

This section describes the default property search parameters for SOAP services.
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DescriptionProperties

Name of the SOAP service.Name

Description of the SOAP Service.Description

Select to restrict the search to consumable SOAP services.Consumable Only

Version number.Version

Service namespace defined in the associated WSDL.WSDL Service
Namespace

Repository Search: Operation

This section describes the default property search parameters for Operations.
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DescriptionProperties

Name of the operation.Name

Description of the operation.Description

XSD fault types defined for the operation.Fault Types

Select to restrict the search to consumable operations.Consumable Only

Operation name defined by the associated WSDL.Operation Name

XSD output types defined for the operation.Output Types

Set of related operations defined by the associated WSDL.Port Type

Namespace defined by the associated WSDL.Target Namespace

XSD input types defined for the operation.Input Types
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Repository Search: WSDL

This section describes the default property search parameters for WSDLs.

DescriptionProperties

Name of the WSDL.Name

Description of the WSDL.Description

Server folder where the WSDL is stored in the repository.Location

Select to restrict the search to consumable WSDLs.Consumable
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DescriptionProperties

Version number.Version

Repository Search: BPEL

This section describes the default property search parameters for BPELs.
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DescriptionProperties

Name of the BPEL.Name

Description of the BPEL.Description

Query language used in the selection of nodes for assignment.Query Language
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DescriptionProperties

Namespace defined in the BPEL.Target Namespace

Language defining expressions in the BPEL.Expression
Language

Server folder where the BPEL is stored in the repository.Location

Search term identifying the BPEL.Keyword

Select an impact level from the drop-down list.Failure Impact

Select to restrict the search to consumable WSDLs.Consumable

Version number.Version

Repository Search: SCA

This section describes the default property search parameters for SCAs.
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DescriptionProperties

Name of the SCA.Name

Description of the SCA.Description

Server folder where the SCA is stored in the repository.Location

The type of the attached SCA file.SCA Type

Version number.Version

Namespace defined in the SCA.Target Namespace
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Repository Search: Business Process

This section describes the default property search parameters for business processes.

DescriptionProperties

Name of the business process.Name

Description of the business process.Description

Select an impact level from the drop-down list.Failure Impact

Version number.Version

Select to restrict the search to consumable business processes.Consumable
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Repository Search: XML Schema

This section describes the default property search parameters for XML schemas.

DescriptionProperties

Name of the XML Schema.Name

Description of the XML Schema.Description

Server folder where the schema is stored in the repository.Location

Select to restrict the search to consumable XMLs.Consumable
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DescriptionProperties

Version number.Version

Namespace defined in the XML Schema.Target Namespace
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B Preferences

Systinet Plug-In for Eclipse contains a set of preferences determining its interaction with SOA Systinet.
These settings are prompted for when required, but they can also be changed from the Tools→Options
menu.

These settings are described in the following sections:

• Setting the Server on page 63

Specify the installation of SOA Systinet to integrate with.

• Setting the Environment on page 64

Specify the environment categorization to use when obtaining endpoints.

• Setting Synchronization on page 66

Specify whether to automatically synchronize local resources with the equivalent resources in SOA
Systinet.

Setting the Server
The develop services in conjunction with SOA Systinet you must set the credentials for the server you are
working with.

To set the SOA Systinet server:

1 From the menu, select Window→Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, select HP SOA Systinet.
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The HP SOA Systinet page opens, as shown in Figure 6, “HP SOA Systinet Page”.

Figure 6. HP SOA Systinet Page

3 Set the connection details for the SOA Systinet server. Optionally, save these credentials or use Validate
to test the connection.

4 Click OK.

Setting the Environment
SOA Systinet uses an Environment taxonomy to categorize endpoints enabling multiple endpoints for a
single service without requiring modification of the WSDL definition.

This means that the WSDL itself does not define the environment specific endpoints that you may require
for service development.

Systinet Plug-In contains an environment setting that allows you to define a default environment you are
developing your services for in order to obtain the relevant endpoints associated with the service.
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To set the default environment:

1 From the menu, select Window→Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, select HP SOA Systinet→Environment.

The Environments page opens, as shown in Figure 7, “Environments Page”.

Figure 7. Environments Page

3 Set the default environment from the following options:

DescriptionEnvironment Option

Use the WSDL without any environment specific endpoints.As originally uploaded
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DescriptionEnvironment Option

Use the endpoints for the service categorized as the selected
environment. For example, Development or Testing.

Environment Categories

Prompt for environment selection whenever it is required.Always Ask

4 Click OK.

Setting Synchronization
Systinet Plug-In enables you to download resources from SOA Systinet. In addition, you can specify
automatic synchronization between SOA Systinet resources and their local equivalents in your IDE project.

To set up automatic synchronization:

1 From the menu, select Window→Preferences.

The Preferences dialog box opens.

2 In the tree view of the Preferences dialog box, select HP SOA Systinet→Auto Synchronization.

The Auto Synchronization page opens, as shown in Figure 8, “Auto Synchronization Page”.

66



Figure 8. Auto Synchronization Page

3 To enable automatic synchronization, select Auto Synchronization, and select from the following
synchronization options:

DescriptionAuto Synchronization
Option

Update local versions with newer versions from SOA Systinet
whenever the SOA Systinet server starts.

Each Time Platform is Started

Update local versions with newer versions from SOA Systinet every
hour.

Hourly

Update local versions with newer versions from SOA Systinet
whenever a project is opened.

Each Time Project is Opened

4 Click OK.
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C Configuring Systinet Plug-In for Eclipse

Systinet Plug-In for Eclipse uses a configuration file at the following location in the SOA Systinet repository:

http://host:port/soa/platform/restSecure/location/hpsoa/client/search-configuration.xml

This file is a server specific configuration that all instances of Systinet Plug-In for Eclipse access to determine
the format and content of repository search for that server.

When you first use Systinet Plug-In for Eclipse in your organization you must upload this configuration to
the SOA Systinet server after you make any changes to reflect your requirements.

Systinet Plug-In for Eclipse contains a default configuration defined in the following file:

ECLIPSE_HOME/plugins/com.hp.systinet.tools.search.core_3.2.0.vBUILDTIME/config/search-configuration.xml

To change the Systinet Plug-In for Eclipse configuration and upload it to SOA Systinet:

1 Create a working copy of search-configuration.xml.

2 Open search-configuration.xml with a text editor.

3 Edit search-configuration.xml to reflect your requirements.

For details, see the following sections:

• Configuring Search and Detail Parameters on page 69

• Configuring Search Results on page 70

• Configuring Artifact Hierarchies on page 71

• Configuring Localization on page 72
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4 In SOA Systinet use the Upload Content feature to store the configuration in the repository.

In the Upload Content page, specify the following location:

/hpsoa/client

For details, see "Uploading Service Infrastructure from Definition Documents" in the HP SOA Systinet
User Guide.

Configuring Search and Detail Parameters
The artifact types in Repository Search and the property parameters displayed in Repository Search and the
Artifact Detail View are defined in the <details_view> section of the configuration file.

For example, the application artifact is defined as follows:

<details_view>
  <artifact_type localName="hpsoaApplicationArtifact">
    <invisible_properties>
      <property localName="lastRevision"/>
      <property localName="revision"/>
      <property localName="identifierBag"/>
      <property localName="artifactType"/>
      <property localName="categoryBag"/>              
      <property localName="stakeholderEmail"/>
      <property localName="criticality"/>
    </invisible_properties>
  </artifact_type>
  ...
</details_view>

To configure the Repository Search:

1 Open search-configuration.xml with a text editor.

2 Do any of the following:

• Add an artifact type to search by adding an <artifact_type> segment using the localName of the
artifact type.

• Remove properties from the search parameters and detail view by adding a <property> in the
<invisible_properties> segment of an artifact, using the localName of the property.
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You can locate the localNames in your configuration at the following location:

http://host:port/soa/systinet/platform/restBasic/repository/sdm/sdmConfig.xml

3 Save search-configuration.xml.

Configuring Search Results
The property parameters displayed for artifacts in the Repository Search Results view are defined in the
<search_result> section of the configuration file.

For example, the application artifact is defined as follows:

<search_result>
  <artifact_type localName="hpsoaApplicationArtifact">
    <visible_properties>
      <property localName="name"/>
      <property localName="version"/>
      <property localName="productionStage"/>
      <property localName="description"/>
    </visible_properties>
  </artifact_type>
  ...
</search_result>

To configure the Repository Search:

1 Open search-configuration.xml with a text editor.

2 Do any of the following:

• Add an artifact type to search results by adding an <artifact_type> segment using the localName of
the artifact type.

• Add properties to the results for an artifact type by adding a <property> in the <visible_properties>
segment of an artifact, using the localName of the property.
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You can locate the localNames in your configuration at the following location:

http://host:port/soa/systinet/platform/restBasic/repository/sdm/sdmConfig.xml

3 Save search-configuration.xml.

Configuring Artifact Hierarchies
Service artifacts in SOA Systinet form natural hierarchies. Repository Search locates the artifacts matching
your search criteria, and if requested, any related artifacts specified in the hierarchical structure defined in
the configuration.

For example, the default hierarchy is defined as follows:

<hierarchical>
  <artifact localName="hpsoaApplicationArtifact">
    <artifact localName="businessServiceArtifact" upRef="hpsoaProvidingApplication"
      downRef="hpsoaProvidesBusinessService">
      <artifact localName="webServiceArtifact" upRef="inBusinessService" downRef="service">
        <artifact localName="wsdlArtifact" upRef="definitionOf" downRef="definition"/>
      </artifact>
    </artifact>
  </artifact>
</hierarchical>

You can add and modify hierarchies to match those relevant to your requirements.

To configure the Repository Search hierarchies:

1 Open search-configuration.xml with a text editor.

2 Do any of the following:

• Add a hierarchy by adding the top level <artifact> within the <hierarchical> segment, defined by its
local name.

• Add artifacts to hierarchies by adding <artifact> within a nested structure of an artifact hierarchy.
Define the artifact with a local name and directional relationship properties.
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You can locate the localNames and property names in your configuration at the following
location:

http://host:port/soa/systinet/platform/restBasic/repository/sdm/sdmConfig.xml

3 Save search-configuration.xml.

If you define multiple hierarchies, the first hierarchy defined takes precedence in the event of
a conflict.

Configuring Localization
Localized text can be configured in repository search for artifact names in the <artifact_mapping> section of
the configuration file.

For example, the application artifact is defined as follows in English, Spanish, and Vietnamese:

<artifact_mapping>  
  <artifact_type localName="hpsoaApplicationArtifact">
    <custom_name value="Application"/>
    <custom_name locale="es" value="Aplicacion"/>                
    <custom_name locale="vi" value="&#7912;ng D&#7909;ng"/>                
  </artifact_type>
  ...
</artifact_mapping>

To configure the localized text in Repository Search:

1 Open search-configuration.xml with a text editor.

2 Add a new mapping rule for localization to Repository Search by adding an <artifact_type> segment
using the localName of the artifact type.

Specify the text to be localized with a <custom_name> specifying the text to be localized when the artifact
type is rendered.
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Add location specific text for an artifact type by adding a <custom_name> to the artifact specifying the
locale and the text to use in that location.

You can locate the localNames in your configuration at the following location:

http://host:port/soa/systinet/platform/restBasic/repository/sdm/sdmConfig.xml

3 Save search-configuration.xml.
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D Eclipse Plug-in Requirements

If you use a non-packaged version of Eclipse you may require a number of plug-ins.

The following sections list the plug-ins required by Systinet Plug-In for Eclipse for each supported version
of Eclipse:

• Eclipse 3.2.x Plug-in Requirements on page 74

• Eclipse 3.3.x Plug-in Requirements on page 75

• Eclipse 3.4.x Plug-in Requirements on page 75

Eclipse 3.2.x Plug-in Requirements
For Eclipse 3.2.x, Systinet Plug-In for Eclipse has dependencies on the following plug-ins:

• DTP SDK 0.9 (dtp-sdk_0.9.1.zip)

http://www.eclipse.org/datatools/downloads.php

• EMF SDO Runtime 2.2.0 (emf-sdo-runtime-2.2.0.zip)

http://www.eclipse.org/modeling/emf/downloads/

• GEF Runtime 3.2 (GEF-runtime-3.2.zip)

http://archive.eclipse.org/tools/gef/downloads/drops/R-3.2-200606270816/

• WTP-R-1.5.0 (wtp-R-1.5.0-200606281455.zip)

http://www.eclipse.org/webtools/releases/1.5/

• XSD Runtime 2.2.0 (xsd-runtime-2.2.0.zip)
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• JEM-SDK-1.2 (JEM-SDK-1.2.zip)

http://download.eclipse.org/tools/ve/downloads/drops/R-1.2-200606280938/

Install these plug-ins before installing Systinet Plug-In for Eclipse.

Eclipse 3.3.x Plug-in Requirements
For Eclipse 3.3.x, Systinet Plug-In for Eclipse has dependencies on the following plug-ins:

• DTP SDK 1.5 (dtp-sdk_1.5.zip)

http://www.eclipse.org/datatools/downloads.php

• EMF SDO Runtime 2.3.0 (emf-sdo-runtime-2.3.0.zip)

http://www.eclipse.org/modeling/emf/downloads/

• GEF Runtime 3.3 (GEF-runtime-3.3.zip)

http://archive.eclipse.org/tools/gef/downloads/drops/R-3.3-200706281000/index.php

• WTP 2.0 (wtp-R-2.0-200706260303.zip)

http://www.eclipse.org/webtools/releases/2.0/

• XSD Runtime 2.3 (xsd-runtime-2.3.1.zip)

http://www.eclipse.org/modeling/mdt/downloads/?project=xsd

Install these plug-ins before installing Systinet Plug-In for Eclipse.

Eclipse 3.4.x Plug-in Requirements
For Eclipse 3.4.x, Systinet Plug-In for Eclipse has dependencies on the following plug-ins:

• DTP SDK 1.6 (dtp-sdk_1.6.0.zip)
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• EMF SDO Runtime 2.4.0 (emf-runtime-2.4.0.zip, sdo-runtime-2.4.0.zip)

http://www.eclipse.org/modeling/emf/downloads/

• GEF Runtime 3.4 (GEF-runtime-3.4.0.zip)

http://archive.eclipse.org/tools/gef/downloads/drops/

• WTP 3.0 (wtp-R-3.0-20080616152118a.zip)

http://www.eclipse.org/webtools/

• XSD Runtime 2.4.0 (xsd-runtime-2.4.0.zip)

http://www.eclipse.org/modeling/mdt/downloads/?project=xsd

Install these plug-ins before installing Systinet Plug-In for Eclipse.
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