
DevInspect for Java QuickStart Guide

DevInspect simplifies security for developers by finding applica-
tion security defects and advising how to eliminate them. This 
enables you to build secure Web applications and Web services 
quickly and easily, without impacting schedules or requiring 
extensive knowledge of Web application security. 

DevInspect is the only developer security product that finds secu-
rity vulnerabilities through hybrid analysis techniques that com-
bine dynamic, static and configuration analysis for unmatched 
accuracy and precision.

You can scan all or part of your dynamic Web project, multiple 
Web projects, or remote Web sites.

 System Requirements
• Windows XP SP2

• 1 GB of RAM

• 1.2 GB of free disk space required (2 GB preferred)

• 1 GHz processor or better

• Microsoft .NET Framework 2.0

• Microsoft SQL Server 2005 Express Edition SP1 (note that 
Express Edition must be installed even if other SQL Server 
2005 versions are present)

• For plug-in versions: Eclipse 3.2 or above, Rational Software 
Development Platform 6 or 7.

• The NTFS file system is strongly recommended, especially 
when using Rational Application Developer 6 or 7.

Getting Started
DevInspect can be installed in the following configurations:

• Eclipse plug-in - Installs DevInspect features into an existing 
installation of Eclipse 3.2 or higher. You must allocate at least 
one gigabyte of RAM for the maximum heap size used by 
Eclipse applications. To do so, simply add the following 
parameter to the eclipse.ini file: -Xmx1024m.

• IBM Rational Software Development Platform plug-in - Installs 
DevInspect features into an existing installation of IBM Rational 
Software Development Platform 6 and 7 products, including 
Rational Application Developer, Web Developer and Software 
Architect.

Install Using HP Application Security Center Update Site
DevInspect can be installed from within your existing Eclipse 
installation through the HP Update Site if you are choosing the 
Eclipse or IBM Rational Software Development Platform plug-in 
options. 

Note: To install DevInspect on the Eclipse 3.4 platform, see 
Install/Update Eclipse 3.4 (next column).

1. Click Help > Software Updates > Find and Install.

2. On the Install/Update dialog, select Search for new features 
to install and click Next.

3. Click New Remote Site.

4. On the New Update Site dialog, in the Name box, enter HP 
Update Site.

5. In the URL box, enter one of the following, depending on 
your target Eclipse platform:

Eclipse 3.2: 
http://updates.hpsmartupdate.com/eclipse/eclipse-3.2/
site.xml 

Eclipse 3.3: 
http://updates.hpsmartupdate.com/eclipse/eclipse-3.3/
site.xml 

RSDP6:
http://updates.hpsmartupdate.com/eclipse/RSDP6/site.xml 

RSDP7:
http://updates.hpsmartupdate.com/eclipse/RSDP7/site.xml

6. Click OK and make sure only HP Update Site is checked 
in the Sites to include in search list. 

7. Click Finish.

8. On the Search Results panel, select DevInspect for Java (<tar-
get>) <version>, where <target> is your platform and <ver-
sion> is the latest version number. 

9. Click Next and follow the on-screen instructions to complete 
the installation.

Note: When you install from the update site, the Eclipse Update 
Manager automatically downloads and installs .NET Framework 
2.0 and SQL Server 2005 Express Edition, if needed.

Install/Update Eclipse 3.4
Eclipse 3.4 ships with a new default Update Manager (called p2) 
as well as  the older update engine. The DevInspect Java 5.1 
release for Eclipse 3.4 can be installed only by using the older 
Update Manager,as noted in the following instructions. 

1. Open the Update Manager (Help -> Software Updates).

2. Select the Available Software tab.

3. Click Add Site.

4. Enter http://updates.hpsmartupdate.com/eclipse/eclipse-
3.4/.

5. Click OK.
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6. Expand the "HP Software" entry and check DevInspect fo 
Java (Eclipse SDK  3.4.

7. Click Install.

8. When a dialog box appears, asking to open the previous 
(older) Update Manage, click Launch.

The older (pre Eclipse 3.4) update manager appears. 

9. Select Search for new features to install and click Next.

10. When the Install dialog appears, click New Remote Site. 

11. Enter a name.

12. Enter the following URL:  http://updates.hpsmartup-
date.com/eclipse/eclipse-3.4/. 

13. Click OK.

14. Make sure the new entry is checked and click Finish.

15. Expand the entries and select DevInspect for Java (Eclipse 
SDK 3.4) 5.1.7667.1. 

16. Click Select Required.

17. Click Next.

18. Accept the terms of the license agreement and click Next. 

19. Click Finish.

20. Click Install All.

21. When the updater prompts to restart, click Yes.

Install/Update PCs Not Connected to the Internet
This procedure describes how you can use a PC with Internet 
access to download required files and make them available to 
other PCs that do not have an Internet connection. 

At the PC with Internet Access:

1. Install Java.

To verify that Java is installed, open a command prompt (or 
terminal) and issue the following command:
  java -version
If you don't see an official java version message displayed, 
install Java.

2. Install Eclipse

Download and install the Eclipse IDE.

3. Create a directory to hold the files you will download.

4. Download the required files to the directory.

Eclipse provides a command line option to mirror update 
sites to a local file system. Use this mechanism to download 
the official DevInspect plug-in site to a local file system.

a. Navigate to the eclipse directory that contains startup.jar.

b. Open a command prompt (or terminal) and execute the 
following from the command line:

java -cp startup.jar org.eclipse.core.launcher.Main -application 
org.eclipse.update.core.standaloneUpdate -command mirror -
from http://updates.hpsmartupdate.com/eclipse/eclipse-3.2/
site.xml -to c:/devinspect/3.2/update-site -ignoreMissingPlugins 
true

where

c:/devinspect/3.2/update-site is the directory you created in 
Step 3.

The URL will determine which plug-in version you will down-
load. If you do not intend to install DevInspect into Eclipse 
3.2, replace “eclipse-3.2” with an appropriate Eclipse ver-
sion.

Note: If you are trying to download a local update site for 
Eclipse 3.3., this procedure will not work. Special steps are 
needed to build a local update site for Eclipse 3.3.

5. Burn the local update site to CD or DVD. The update site is 
usually quite large, so you will need a large USB drive or 
DVD.

At the PC without Internet Access:

1. Insert the CD or DVD.

2. Open Eclipse.

3. Click Help > Software Updates > Find and Install.

4. On the Install/Update dialog, select Search for new features 
to install and click Next.

5. On the Install dialog, click New local site.

6. On the Browse For Folder dialog, select the local update site 
that you created on CD or DVD and click OK.

Running DevInspect
The first time you run DevInspect, you will need to activate the 
product with the license provided to you by HP, using the follow-
ing procedure:

1. Activate DevInspect.

a.  Start Eclipse.

b. On the Welcome page, select Go to Workbench.

c. Click Window > Preferences.

d. Expand the Web Application Security group.

e. Click Licensing.

f. Enter the activation key provided to you and enter all per-
sonal information.
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g. Confirm the license service URL as 
https://licenseservice.spidynamics.com/

h. Click Apply to activate the product.

2. Connect to AMP (Optional)

Follow the steps below if your license requires or permits you 
to access the HP Assessment Management Platform (AMP):

a. In the list of Web Application Security preferences, click 
AMP Connectivity.

b. Enter the URL or IP address of the AMP server.

c. Enter a user name and password.

d. Click Test Connection.

e. In the list of Web Application Security preferences, click 
Policy.

f. Select a policy from the list downloaded from AMP.

3. Configure the Server

DevInspect's hybrid analysis requires a local development 
server to be controlled from within the Eclipse development 
environment. Any Java application server is supported and is 
simply configured as a server runtime in Eclipse. The follow-
ing example demonstrates how to configure DevInspect to 
use a local Tomcat server:

a. On the Preferences window, expand the Server group and 
select Installed Runtimes.

b. Click Add.

c. On the New Server Runtime window, choose Apache Tom-
cat v5.5 and click Next.

d. Select an installation directory (C:\Program Files\Apache 
Software Foundation\Tomcat 5.5) and click Finish.

e. Click OK to close Preferences.

f. Click Window > Open Perspective> J2EE.

4. Import your Project

If you have your application source code in the Eclipse work-
space, DevInspect can perform hybrid analysis, combining 
the depth of source code analysis with the accuracy of black 
box testing. To perform black box testing only, skip this step. 
If you are not currently using Eclipse, you can import the 
code manually from the file system, WAR or EAR files. To 
import an existing Eclipse project, follow these steps.

a. Click File > Import 

b. Expand the General group and select Existing Projects 
into Workspace.

c. Select the root directory or archive file of your existing 
Eclipse project. The project will then be available in the 
Project Explorer.

d. In the Servers window at the bottom of the Workbench, 
right-click the Tomcat server entry and select Add and 
Remove Projects.

e. Select your project and click Add.

f. Click Finish.

g. Right-click the Tomcat server entry again and select Pub-
lish.

h. Right-click the Tomcat server entry again and select Start 
to start the server.

You are now ready for testing.
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Test for Vulnerabilities
To test your local project with hybrid analysis:

1. Click the DevInspect icon  on the toolbar (or click the 
DevInspect menu and select Test for Vulnerabilities).

2. Select Choose targets to test, select your application from the 
list, and click OK.

3. As your security analysis runs, you will see vulnerabilities 
populated to the Vulnerabilities window. Analysis progress is 
displayed in the Console window.

4. Right-click a vulnerability in the Vulnerabilities window and 
select Explain Vulnerability for detailed vulnerability informa-
tion.

To test a remote server or conduct a black box only test:

1. Add the target host as an Allowed Host in DevInspect prefer-
ences. All hosts not explicitly enabled in the Allowed Host 
configuration will be ignored so that DevInspect does not 
attack external sites. Your DevInspect license must also allow 
access to the IP address that you are targeting. 

2. Click the DevInspect icon   on the toolbar (or click the 
DevInspect menu and select Test for Vulnerabilities).

3. Select Test a specific target URL and enter the URL.

Update the Application
DevInspect allows you to check for updates on demand via a 
Web service that keeps DevInspect current with HP vulnerability 
research. To update vulnerability tests:

1. Click DevInspect > Tools > SmartUpdate. 

2. To accept the updates, click Update.

DevInspect for Java uses the Eclipse Update Manager to distrib-
ute updates to the product features. To check for DevInspect fea-
ture updates, or if you receive notification from HP that a new 
release is available, follow these steps:

• Click Help > Software Updates > Manage Configuration.

• In the Product Configuration dialog, select DevInspect for 
Java.

• In the right-hand pane, select Scan for Updates.

• If updates are found, follow the on-screen instructions to 
upgrade to the latest version of DevInspect.

Other Areas to Explore
After configuring the environment and running an initial security 
analysis, you can explore these other areas of DevInspect:

• Generate vulnerability reports from the security analysis 
results: Select DevInspect > Generate Report.

• Configure advanced security analysis settings: Select Window 
> Preferences > Web Application Security.
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