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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed 
as constituting an additional warranty. HP shall not be liable for technical or editorial errors 
or omissions contained herein.

The information contained herein is subject to change without notice.
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information.  Site content and availability may change without notice.  HP makes no 
representations or warranties whatsoever as to site content or availability.

Copyright Notices
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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

You can visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software Support Online provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. 
As a valued support customer, you can benefit by using the HP Software Support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. 
Many also require a support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 

To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 



5

Table of Contents

Welcome to This Guide .......................................................................17
How This Guide is Organized..............................................................17
Documentation Library.......................................................................19
Additional Online Resources...............................................................21
Documentation Updates .....................................................................22

PART I:  QUALITY CENTER BASICS

Chapter 1: Introduction ......................................................................25
The Application Life Cycle Management............................................27
Specifying Releases ..............................................................................28
Specifying Requirements .....................................................................29
Planning Tests .....................................................................................31
Running Tests ......................................................................................33
Tracking Defects ..................................................................................34
Working with Project Databases .........................................................35
User Privileges......................................................................................35
Importing from Microsoft Word and Microsoft Excel........................36

Chapter 2: Getting Started .................................................................37
Starting Quality Center .......................................................................38
Resetting Your Password .....................................................................42
The Quality Center Window...............................................................43
Quality Center Common Toolbar.......................................................45
Changing User Properties and Password.............................................47
Clearing History ..................................................................................49
Viewing Administrator Messages ........................................................50



Table of Contents

6

Chapter 3: Working with Quality Center Data ...................................51
About Working with Quality Center Data..........................................52
Arranging Columns.............................................................................52
Selecting Users.....................................................................................55
Filtering Records..................................................................................56
Advanced/Cross Filtering Records.......................................................61
Sorting Records....................................................................................65
Grouping Grid Records .......................................................................67
Updating Multiple Records .................................................................70
Copying Settings .................................................................................71
Refreshing and Clearing Settings ........................................................71
Searching Records................................................................................72
Exporting Data to a File.......................................................................74

Chapter 4: Alerting on Changes .........................................................75
About Alerting Changes ......................................................................75
Understanding Alerts ..........................................................................76
Viewing Alerts .....................................................................................80
Clearing Alerts .....................................................................................81
Flagging for Follow Up ........................................................................82

Chapter 5: Adding Attachments .........................................................85
About Adding Attachments ................................................................86
Attaching a File....................................................................................87
Attaching a URL ..................................................................................87
Attaching a Snapshot ..........................................................................88
Attaching System Information............................................................89
Attaching Items from the Clipboard...................................................90
Managing Attachments .......................................................................90

Chapter 6: Working with Favorite Views............................................93
About Working with Favorite Views...................................................93
Adding Favorite Views.........................................................................94
Loading Favorite Views .......................................................................95
Updating Favorite Views .....................................................................95
Organizing Favorite Views ..................................................................96



Table of Contents

7

Chapter 7: Working with Version Control..........................................99
About Working with Version Control ................................................99
Version Control Overview.................................................................100
Checking Out Entities .......................................................................104
Checking In Entities ..........................................................................106
Undoing Check Outs.........................................................................107
Viewing Checked Out Entities ..........................................................108
Viewing Version History ...................................................................109
Filtering Version Control Fields ........................................................112

PART II:  RELEASE MANAGEMENT

Chapter 8: The Release Management Workflow..............................115
Defining Releases and Cycles ............................................................116
Assigning Requirements ....................................................................117
Assigning and Running Test Sets ......................................................118
Assigning Defects...............................................................................119
Analyzing Releases and Cycles ..........................................................119

Chapter 9: The Releases Module at a Glance ...................................121
The Releases Module .........................................................................122
The Releases Menu Bar ......................................................................123
The Releases Toolbar .........................................................................123
The Release and Cycle Fields.............................................................124

Chapter 10: Developing the Releases Tree.......................................127
About Developing the Releases Tree .................................................128
Creating a Releases Tree ....................................................................133
Adding Releases to Release Folders....................................................134
Adding Cycles to Releases .................................................................134
Viewing Assigned Requirements and Test Set Folders ......................136
Viewing Coverage Progress of Releases and Cycles...........................137
Viewing Defects of Releases and Cycles ............................................141
Modifying the Releases Tree..............................................................143

PART III :  REQUIREMENTS SPECIFICATION

Chapter 11: The Requirements Specification Workflow ..................149
Defining the Requirements Scope.....................................................150
Creating the Requirements Outline ..................................................151
Detailing Requirements.....................................................................152
Assigning Requirements to Releases..................................................153
Analyzing Requirements Specification..............................................153
Establishing Baselines........................................................................154



Table of Contents

8

Chapter 12: The Requirements Module at a Glance ........................155
The Requirements Module ................................................................155
The Requirements Menu Bar.............................................................167
The Requirements Toolbar ................................................................169
The Requirement Fields.....................................................................171

Chapter 13: Developing the Requirements Tree..............................177
About Developing the Requirements Tree........................................178
Creating a Requirements Tree ...........................................................179
Assigning Requirements to Releases or Cycles..................................182
Adding Rich Text to Requirements ...................................................183
Updating Requirements ....................................................................184
Finding Requirements .......................................................................187
Replacing Field Values.......................................................................189
Viewing the Requirements Tree ........................................................191
Viewing Requirement History...........................................................193
Mailing Requirements .......................................................................194
Modifying Requirements...................................................................196
Creating Tests from Requirements....................................................200

Chapter 14: Tracing Requirements ...................................................207
About Tracing Requirements.............................................................208
Defining Traceability Relationships ..................................................211
Viewing Traceability Relationships...................................................213
Viewing Traceability Impact .............................................................215
Removing Traceability Relationship Links .......................................217

Chapter 15: Calculating Requirement Risks......................................219
About Calculating Requirement Risks ..............................................220
The Risk-Based Quality Management Process...................................221
Assessing Requirements.....................................................................223
Defining the Testing Policy Settings .................................................229
Finalizing the Testing Policy .............................................................231
Analyzing the Testing Strategy..........................................................234
Risk-Based Quality Management Example........................................239



Table of Contents

9

PART IV: TEST PLANNING

Chapter 16: The Test Plan Workflow ................................................245
Defining Testing Strategy ..................................................................246
Defining Test Subjects .......................................................................246
Designing Tests..................................................................................247
Creating Requirements Coverage......................................................248
Designing Test Steps..........................................................................248
Automating Tests...............................................................................249
Analyzing Your Test Plan ..................................................................250
Establishing a Baseline ......................................................................250

Chapter 17: The Test Plan Module at a Glance ................................251
The Test Plan Tree .............................................................................252
The Test Plan Menu Bar ....................................................................254
The Test Plan Toolbar........................................................................255
The Test Grid .....................................................................................257

Chapter 18: Developing the Test Plan Tree......................................263
About the Test Plan Tree ...................................................................264
Creating a Test Plan Tree...................................................................265
Adding Tests to a Test Plan Tree .......................................................266
Viewing the Test Plan Tree................................................................271
Viewing Instances of Tests ................................................................273
Viewing Test History .........................................................................274
Mailing Tests......................................................................................275
Finding Tests in the Tree or Test Grid...............................................277
Replacing Field Values in the Test Grid ............................................280
Updating Multiple Records in the Test Grid.....................................281
Copying Tests ....................................................................................281
Copying URLs of Tests.......................................................................283
Sorting a Test Plan Tree .....................................................................283
Modifying a Test Plan Tree................................................................285

Chapter 19: Requirement and Test Coverage ..................................287
About Requirement and Test Coverage ............................................287
Linking Requirements to a Test ........................................................290
Linking Tests to a Requirement ........................................................294
Analyzing Coverage...........................................................................298

Chapter 20: Building Tests ................................................................303
About Building Tests .........................................................................303
Defining Design Steps .......................................................................305
Calling Manual Tests .........................................................................307
Managing Design Steps .....................................................................309



Table of Contents

10

Chapter 21: Working with Parameters in Manual Tests ..................317
About Working with Parameters in Manual Tests ............................317
Defining Test Parameters ..................................................................319
Updating Test Parameters .................................................................320
Inserting Test Parameters in a Design Step .......................................321
Assigning Actual Values ....................................................................322
Managing Test Parameters ................................................................324

Chapter 22: Creating Automated Tests ............................................327
About Creating Automated Tests ......................................................327
Generating Automated Test Scripts...................................................328

Chapter 23: Working with System Tests ..........................................331
About Working with System Tests ....................................................331
Adding System Tests to a Test Plan Tree ...........................................332
Defining a System Test ......................................................................334
Running a System Test ......................................................................335
Viewing System Test Results .............................................................336

Chapter 24: Managing Test Resources .............................................339
About Managing Test Resources .......................................................340
The Test Resources Module ...............................................................341
Creating a Test Resource Tree ...........................................................342
Updating Details of Resources and Folders .......................................344
Working with Resources....................................................................346
Viewing Test Resource Dependencies ...............................................348
Managing the Test Resource Tree......................................................348
Viewing Resource History .................................................................356

Chapter 25: Viewing Dependencies..................................................357
About Viewing Dependencies ...........................................................357
Viewing Dependencies ......................................................................358

PART V: TEST EXECUTION

Chapter 26: The Test Lab Workflow .................................................363
Creating Test Sets ..............................................................................364
Scheduling Test Runs ........................................................................364
Running Tests Manually ...................................................................364
Running Tests Automatically ............................................................365
Analyzing Test Results.......................................................................365



Table of Contents

11

Chapter 27: The Test Lab Module at a Glance .................................367
The Test Lab Module .........................................................................368
The Test Lab Menu Bar......................................................................370
The Test Lab Toolbars........................................................................371
The Execution Grid ...........................................................................373
The Execution Flow...........................................................................378

Chapter 28: Creating Test Sets .........................................................381
About Creating Test Sets ...................................................................382
Creating a Test Sets Tree....................................................................384
Assigning Test Set Folders to Cycles..................................................385
Adding Test Sets ................................................................................386
Adding Tests to a Test Set..................................................................388
Setting Test Set Notifications ............................................................390
Setting Test Set On Failure Rules.......................................................392
Managing Test Sets ............................................................................396

Chapter 29: Scheduling Test Runs ....................................................409
About Scheduling Test Runs..............................................................409
Scheduling a Test Run .......................................................................411
Modifying a Test Run Schedule.........................................................414
Arranging Tests Sequentially.............................................................417
Finding Tests......................................................................................418
Viewing the Execution Flow Diagram...............................................418

Chapter 30: Running Tests Manually................................................421
About Running Tests Manually.........................................................421
Running a Test Manually ..................................................................422
Editing the Test Steps ........................................................................428
Resuming a Manual Test Run............................................................429

Chapter 31: Running Tests Automatically ........................................431
About Running Tests Automatically .................................................431
Running a Test Automatically...........................................................432
Viewing the Execution Log ...............................................................436
Setting Up Hosts for Remote Test Execution ...................................437
Ordering Tests in the Execution Grid ...............................................439
Finding and Replacing Values in the Execution Grid.......................441



Table of Contents

12

Chapter 32: Viewing Test Results .....................................................443
About Viewing Test Results ...............................................................444
Viewing Test Results..........................................................................445
Viewing Details of a Test Run ...........................................................447
Comparing Results of All Runs .........................................................449
Viewing Configuration of a Test Run ...............................................452
Viewing Linked Defects.....................................................................457
Viewing Test Run History..................................................................458

PART VI: DEFECT TRACKING

Chapter 33: The Defect Tracking Workflow .....................................463
Adding Defects ..................................................................................464
Reviewing New Defects .....................................................................465
Repairing Open Defects.....................................................................466
Testing a New Application Build.......................................................466
Analyzing Defect Data.......................................................................466

Chapter 34: The Defects Module at a Glance...................................467
The Defects Module...........................................................................468
The Defects Menu Bar .......................................................................471
The Defects Toolbar...........................................................................472
The Defects Grid................................................................................474

Chapter 35: Adding and Tracking Defects .......................................477
About Adding and Tracking Defects .................................................478
Adding New Defects ..........................................................................479
Matching Defects...............................................................................481
Updating Defects ...............................................................................485
Finding and Replacing Values...........................................................487
Updating Multiple Records ...............................................................489
Viewing Defect History .....................................................................489
Mailing Defects..................................................................................490
Copying Defects ................................................................................493
Copying URLs of Defects...................................................................494
Printing Defects .................................................................................494
Deleting Defects ................................................................................495

Chapter 36: Linking Defects..............................................................497
About Linking Defects.......................................................................497
Viewing Defect Links.........................................................................500
Adding Defect Links ..........................................................................501
Removing Defect Links .....................................................................502



Table of Contents

13

PART VII:  LIBRARY MANAGEMENT

Chapter 37: The Libraries Module at a Glance .................................505
The Libraries Module.........................................................................506
The Libraries Menu Bar .....................................................................507
The Libraries Toolbar.........................................................................507
The Library and Baseline Fields.........................................................508

Chapter 38: Libraries and Baselines..................................................511
About Libraries and Baselines ...........................................................512
Creating a Libraries Tree....................................................................513
Creating Libraries ..............................................................................513
Creating Baselines .............................................................................515
The Compare Baselines Tool .............................................................518
Configuring the Comparison Settings ..............................................522
Viewing Baseline History...................................................................524
Pinning a Test Set to a Baseline.........................................................525
Modifying the Libraries Tree .............................................................526
Comparing Entities ...........................................................................528

Chapter 39: Importing Libraries .......................................................533
About Importing Libraries.................................................................534
Importing a Library ...........................................................................536
Viewing Associated Libraries .............................................................540
The Compare Libraries Tool..............................................................544
Synchronizing Libraries.....................................................................547
Mailing Libraries................................................................................550

PART VIII :  QUALITY CENTER ANALYSIS

Chapter 40: The Dashboard Module ................................................557
About the Dashboard Module...........................................................557
The Dashboard Module at a Glance..................................................558
Developing the Analysis and Dashboard Trees.................................559
Creating Analysis Items.....................................................................560
Generating Dashboard Pages.............................................................561
Managing Analysis Items and Dashboard Pages...............................565



Table of Contents

14

Chapter 41: Generating Graphs........................................................569
About Generating Graphs .................................................................569
Creating Graphs with the Graph Wizard..........................................570
Creating Quick Graphs......................................................................575
Creating Graphs in the Dashboard Module......................................576
Configuring Graphs ..........................................................................578
Creating Cross-Project Graphs ..........................................................581
Viewing Graphs.................................................................................583
Quality Center Graph Types .............................................................591

Chapter 42: Generating Standard Reports ......................................607
About Generating Standard Reports .................................................607
Creating Quick Standard Reports......................................................608
Creating Standard Reports in the Dashboard Module......................612
Configuring Standard Reports...........................................................615
Adding Sub-Reports ...........................................................................617
Viewing Standard Reports .................................................................620

Chapter 43: Generating Excel Reports .............................................623
About Generating Excel Reports .......................................................624
Creating Excel Reports ......................................................................625
Creating SQL Queries ........................................................................626
Adding Parameters to SQL Queries ...................................................630
Creating Post-Processing Scripts........................................................634
Running Excel Reports ......................................................................635

Chapter 44: Generating Live Analysis Graphs ..................................637
About Generating Live Analysis Graphs ...........................................637
Creating Live Analysis Graphs ..........................................................638
Deleting Live Analysis Graphs ..........................................................644
Setting the Graph Appearance ..........................................................645

Chapter 45: Generating Project Documents ....................................647
About Using the Document Generator.............................................648
Launching the Document Generator................................................650
Setting Formatting Instructions ........................................................651
Specifying Project Data .....................................................................657
Generating a Project Document........................................................681



Table of Contents

15

PART IX: APPENDIXES

Appendix A: Working with VAPI-XP .................................................685
About Working with VAPI-XP...........................................................686
Creating VAPI-XP Test Scripts ...........................................................686
Editing VAPI-XP Test Scripts .............................................................696
Using the VAPI-XP API......................................................................701
Running VAPI-XP Tests in Debug Mode...........................................706
Running VAPI-XP Tests in Test Mode...............................................707
Debugging VAPI-XP Test Scripts .......................................................709

Appendix B: Quality Center Keyboard Shortcuts .............................713
Switching Between Quality Center Modules ....................................714
General Keyboard Shortcuts..............................................................714
Attachments Shortcuts ......................................................................716
Send Email Dialog Box Shortcuts......................................................716
Management Module Shortcuts ........................................................717
Requirements Module Shortcuts .......................................................717
Test Plan Module Shortcuts...............................................................718
Test Resources Module Shortcuts ......................................................719
Test Lab Module Shortcuts ................................................................719
Defects Module Shortcuts..................................................................720
Dashboard Module Shortcuts............................................................721

Appendix C: Quality Center Editions ................................................725
About Quality Center Editions..........................................................725
Quality Center Functionality by Edition ..........................................726

Glossary .............................................................................................731

Index..................................................................................................743



Table of Contents

16



17

Welcome to This Guide

Welcome to HP Quality Center, the HP Web-based solution for application 
life cycle management. Quality Center helps you organize and manage all 
phases of the application life cycle management, including defining 
releases, specifying requirements, planning tests, executing tests, and 
tracking defects.

How This Guide is Organized 

The Quality Center User Guide describes how to use Quality Center to 
manage all phases of the application life cycle. 

It contains the following parts:

 Part I Quality Center Basics

Provides an overview of the Quality Center features and methodology.

 Part II Release Management

Describes how to define releases and cycles for managing the application life 
cycle.

 Part III Requirements Specification

Describes how to define requirements by building a requirements tree.

 Part IV Test Planning

Describes how to plan the testing process, from building a test plan tree to 
creating tests.
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 Part V Test Execution

Describes how to create test sets, execute manual and automated tests, and 
review test results.

 Part VI Defect Tracking

Describes how to report application defects to a Quality Center project and 
keep track of the repair process until the defects are resolved.

 Part VII Library Management

Describes how to define libraries to track changes in your project, reuse 
entities in a project, or share entities across multiple projects.

 Part VIII Quality Center Analysis

Describes how you can analyze the application life cycle management 
process, by creating graphs, standard reports, Excel reports, dashboard 
pages, and project documentation.

 Part IX Appendixes

Describes how to work with the VAPI-XP testing tool, and provides a list of 
Quality Center keyboard shortcuts. Also describes the different 
Quality Center editions available — Starter, Enterprise and Premier.

Glossary

Provides a list of terms used throughout Quality Center.
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Documentation Library

The Documentation Library is an online help system that describes how to 
use Quality Center. You can access the Documentation Library in the 
following ways:

➤ Click Documentation Library in the Quality Center Help menu to open the 
Documentation Library home page. The home page provides quick links to 
the main help topics.

➤ Click Help on this page in the Quality Center Help menu to open the 
Documentation Library to the topic that describes the current page.

Documentation Library Guides

The Documentation Library consists of the following guides and references, 
available online, in PDF format, or both. PDFs can be read and printed using 
Adobe Reader, which can be downloaded from the Adobe Web site 
(http://www.adobe.com).

Getting Started explains how to use the Documentation Library and how it 
is organized. (Available online.)

What’s New? describes the newest features in the latest version of 
Quality Center. (Available online and in PDF format.)

You can also access What’s New? from the Quality Center Help menu. In 
addition, you can select Help > Product Feature Movies to view short movies 
that demonstrate the main product features. 

Readme provides last-minute news and information about Quality Center. 

Quality Center Guides

HP Quality Center User Guide explains how to use Quality Center to 
organize and execute all phases of the application life cycle management 
process. It describes how to specify releases, define requirements, plan tests, 
run tests, and track defects. (Available online and in PDF format.)

HP Quality Center Administrator Guide explains how to create and maintain 
projects using Site Administration, and how to customize projects using 
Project Customization. (Available online and in PDF format.)

http://www.adobe.com
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HP Quality Center Tutorial is a self-paced guide teaching you how to use 
Quality Center to manage the application life cycle management process. 
(Available in PDF format.)

HP Quality Center Installation Guide explains how to install Quality Center 
on a server machine in a cluster environment or as a standalone application. 
(Available in PDF format.)

HP Quality Center Upgrade Preparation Guide explains how to detect and 
repair problems before beginning a project upgrade. (Available in PDF 
format.)

HP Quality Center Database Best Practices Guide provides best practices for 
deploying Quality Center on database servers. (Available in PDF format.)

Business Process Testing Guides

HP Business Process Testing User Guide explains how to use Business 
Process Testing to create business process tests. (Available online and in PDF 
format.)

HP Business Process Testing Tutorial provides a self-paced guide that teaches 
you the basics of Business Process Testing in Quality Center. (Available in 
PDF format.)

API References

HP Quality Center Database Reference provides a complete online reference 
for the project database tables and fields. (Available online.)

HP Quality Center Open Test Architecture API Reference provides a 
complete online reference for the Quality Center COM-based API. You can 
use the Quality Center open test architecture to integrate your own 
configuration management, defect tracking, and home-grown testing tools 
with a Quality Center project. (Available online.)

HP Quality Center Site Administration API Reference provides a complete 
online reference for the Site Administration COM-based API. You can use 
the Site Administration API to enable your application to organize, manage, 
and maintain Quality Center users, projects, domains, connections, and site 
configuration parameters. (Available online.)
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HP Quality Center Entity Dependencies API Reference provides an online 
reference for managing relations between Quality Center entities. The 
reference covers a subset of the Quality Center COM-based API and a subset 
of the data tables used when managing relations. You can use this reference 
to integrate testing tools with Quality Center. (Available online.)

HP Quality Center Custom Test Type Guide provides a complete online 
guide for creating your own testing tool and integrating it into the Quality 
Center environment. (Available online.)

Additional Online Resources

The following additional online resources are available from the 
Quality Center Help menu:

Troubleshooting & Knowledge Base accesses the Troubleshooting page on 
the HP Software Support Web site where you can search the Self-solve 
knowledge base. Choose Help > Troubleshooting & Knowledge Base. The 
URL for this Web site is http://h20230.www2.hp.com/troubleshooting.jsp.

HP Software Support accesses the HP Software Support Web site. This site 
enables you to browse the Self-solve knowledge base. You can also post to 
and search user discussion forums, submit support requests, download 
patches and updated documentation, and more. Choose Help > HP Software 
Support. The URL for this Web site is www.hp.com/go/hpsoftwaresupport.

Most of the support areas require that you register as an HP Passport user 
and sign in. Many also require a support contract.

To find more information about access levels, go to:  
http://h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport user ID, go to:  
http://h20229.www2.hp.com/passport-registration.html 

http://h20230.www2.hp.com/troubleshooting.jsp
http://www.hp.com/go/hpsoftwaresupport
http://h20230.www2.hp.com/new_access_levels.jsp
http://h20229.www2.hp.com/passport-registration.html
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HP Software Web site accesses the HP Software Web site. This site provides 
you with the most up-to-date information on HP Software products. This 
includes new software releases, seminars and trade shows, customer support, 
and more. Choose Help > HP Software Web site. The URL for this Web site 
is www.hp.com/go/software.

Add-ins Page opens the HP Quality Center Add-ins Page, which offers 
integration and synchronization solutions with HP and third-party tools. 
For more information, refer to the HP Quality Center Installation Guide.

Documentation Updates

HP Software is continually updating its product documentation with new 
information.

To check for recent updates, or to verify that you are using the most recent 
edition of a document, go to the HP Software Product Manuals Web site 
(http://h20230.www2.hp.com/selfsolve/manuals).

http://h20230.www2.hp.com/selfsolve/manuals
http://www.hp.com/go/software
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1
Introduction

Welcome to HP Quality Center, the HP Web-based solution for application 
life cycle management. You access Quality Center over the Internet or a 
corporate intranet, via a Web browser.

Application life cycle management is a complex process. It entails inter-
related steps such as defining releases, developing requirements, designing 
and validating tests, and monitoring and reporting defects. Administrating 
all aspects of the application management process can be time-consuming 
and difficult.

Quality Center simplifies and organizes application management by 
providing you systematic control over the process. It helps you create a 
framework and foundation for your application management workflow.

Quality Center features a system for organizing and tracking application 
releases, enabling you to align your business priorities and quality 
expectations with your project requirements, tests, and defects.

Quality Center helps you define and maintain a project database of 
requirements and tests. Requirements help ensure that all aspects of your 
application's functionality are covered. Tests can then be automatically 
generated from these requirements to ensure the correct aspects of the 
application are being tested. To meet the various goals of a project, you can 
organize the tests in your project into unique groups. Quality Center 
provides an intuitive and efficient method for scheduling and executing test 
sets, collecting test results, and analyzing the data.
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Quality Center also features a sophisticated system for tracking application 
defects, enabling you to monitor defects closely from initial detection until 
resolution. By linking Quality Center to your email system, defect tracking 
information can be shared by all application development, business 
analysts, quality assurance, customer support, and information systems 
personnel.

Quality Center provides tools for analyzing requirements, test design and 
execution, and defect tracking. You can generate interactive graphs that 
demonstrate a wide variety of business performance perspectives, or define 
reports with any cross-section of data. You can also monitor multiple 
business metrics, by arranging multiple graphs alongside each other in a 
single view.

Quality Center offers integration with HP testing tools (WinRunner, 
QuickTest Professional, LoadRunner, and Visual API-XP) as well as third-
party and custom testing tools, and requirement and configuration 
management tools. Quality Center communicates seamlessly with the 
testing tool of your choice, providing you with a complete solution to fully 
automated application testing.

Quality Center guides you through all phases of the application life cycle 
management. By integrating the tasks involved in application management, 
it helps ensure that your customers receive the highest quality applications.

Quality Center Editions: The availability of each feature depends on your 
Quality Center edition — Starter, Enterprise or Premier. For more 
information, see Appendix C, “Quality Center Editions”.
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The Application Life Cycle Management

The application life cycle management process with Quality Center involves 
the following phases: 

Specify Releases. Develop a release-cycle management plan.

Specify Requirements. Analyze your application and determine your 
requirements.

Plan Tests. Create a test plan, based on your requirements.

Execute Tests. Create test sets and perform test runs.

Track Defects. Report defects detected in your application and track repair 
progress.

Throughout each phase, you can analyze data by generating detailed reports 
and graphs.

Specify
Requirements

Plan
Tests

Execute
Tests

Track
Defects
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Specifying Releases 

Develop a release-cycle management plan. 

Define Releases and Cycles. Build a releases tree to define your releases and 
cycles. A release represents a group of changes in one or more applications 
that will be available for distribution at the same time. A cycle represents a 
development and QA cycle based on the project timeline.

Assign Requirements. Define requirements in the Requirements module and 
assign them to releases and cycles in the releases tree. 

Assign and Run Test Sets. Create test set folders in the Test Lab module and 
assign them to cycles in the releases tree. A test set is a group of tests in a 
Quality Center project designed to achieve specific test goals. After assigning 
test set folders to a cycle, run the test sets under these test set folders. 
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Assign Defects. Submit new defects detected in your application to a 
Quality Center project. Assign defects to the relevant releases and cycles in 
the releases tree.

Analyze Releases and Cycles. Generate reports and graphs to assist in 
analyzing the progress of the release. Review your releases tree to ensure that 
it meets your release goals.

Specifying Requirements 

Analyze your application and determine your requirements. 

Define Scope. Examine application documentation to determine your 
scope, objectives, and strategies.

Create Requirements. Build a requirements tree to define your overall 
requirements.
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Detail Requirements. For each requirement in the requirements tree, create 
a list of detailed requirements. Describe each requirement, assign it a 
priority level, and add attachments if necessary.

Assign to Releases. Assign each requirement to releases and cycles in the 
releases tree in the Releases module. The releases tree shows your product 
releases within a hierarchical tree structure. 

Analyze Requirements. Generate reports and graphs to assist in analyzing 
your requirements. Review your requirements to ensure they meet your 
application management scope.

Establish Baseline. A baseline provides you with a snapshot of your 
requirements at a specific point in time. Create a baseline to sign off or 
compare significant milestones in your application life cycle.
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Planning Tests 

Create a test plan, based on your requirements. 

Define Testing Strategy. Examine your application, system environment, 
and testing resources to determine your testing goals.

Define Test Subjects. Divide your application into functions to be tested. 
Build a test plan tree to hierarchically split your application into testing 
units, or subjects.

Design Tests. Determine the types of tests you need for each subject. Add a 
basic definition of each test to the test plan tree.

Create Requirements Coverage. Link each test with one or more 
requirements.
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Design Test Steps. Develop manual tests by adding steps to the tests in your 
test plan tree. Test steps describe the test operations and the expected 
outcome of each test. Determine which tests to automate.

Automate Tests. For tests that you decide to automate, create test scripts 
with HP testing tools, or with custom or third-party testing tools.

Analyze Test Plan. Generate reports and graphs to assist in analyzing test 
planning data. Review your tests to determine their suitability to your 
testing goals.

Establish Baseline. A baseline provides you with a snapshot of your test plan 
at a specific point in time. Create a baseline to sign off or compare 
significant milestones in your application life cycle.
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Running Tests 

Create test sets and perform test runs. 

Create Test Sets. Define groups of tests to meet the various testing goals in 
your project. These might include, for example, testing a new application 
version or a specific function in an application. Determine which tests to 
include in each test set. Assign test set folders to cycles defined in the 
releases tree in the Releases module. 

Schedule Runs. Schedule test execution and assign tasks to application 
testers. 

Run Tests. Run the tests in your test set either automatically or manually.

Analyze Test Results. View the results of your test runs in order to determine 
whether a defect has been detected in your application. Generate reports 
and graphs to help analyze these results.
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Tracking Defects 

Submit defects detected in your application and track how repairs are 
progressing. 

Add Defects. Report new defects detected in your application. Quality 
assurance testers, developers, project managers, and end users can add 
defects during any phase in the application management process.

Review New Defects. Review new defects and determine which ones should 
be fixed.

Repair Open Defects. Correct the defects that you decided to fix.

Test New Build. Test a new build of your application. Continue this process 
until defects are repaired.

Analyze Defect Data. Generate reports and graphs to assist in analyzing the 
progress of defect repairs, and to help determine when to release the 
application.
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Working with Project Databases 

When you create a Quality Center project, you need to store and manage 
the data that was generated and collected by Quality Center. Each project is 
supported by a database that stores project information.

For more information on supported database servers, refer to the 
HP Quality Center Installation Guide.

For more information on creating and managing Quality Center projects, 
refer to the HP Quality Center Administrator Guide.

User Privileges 

Quality Center enables you to manage user access to a project. By creating a 
list of authorized users and assigning each user a password and user group, 
you control the kinds of additions and modifications that each user makes 
to the project. The user group determines the privileges that the user has 
within a project. Quality Center includes a privileges and permissions 
mechanism that enables you to create rules for specific fields in a project.

For detailed information on the user groups available in Quality Center, and 
on assigning passwords and privileges, refer to the HP Quality Center 
Administrator Guide.
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Importing from Microsoft Word and Microsoft Excel

You can import data from Word or Excel to a Quality Center project.

Importing from Word

You can import requirement or test plan data from a Word document to a 
Quality Center project. To import from Word, you must install the 
HP Quality Center Microsoft Word Add-in and the HP Quality Center 
Connectivity Add-in on your client machine. To install an add-in, choose 
Help > Add-ins Page to open the HP Quality Center Add-ins page, and click 
the appropriate add-in link.

For more information, refer to the HP Quality Center Microsoft Word Add-in 
Guide available on the Microsoft Word Add-in page.

Importing from Excel

You can import requirement, test plan, or defect data from an Excel 
worksheet to a Quality Center project. To import from Excel, you must 
install the HP Quality Center Microsoft Excel Add-in and the 
HP Quality Center Connectivity Add-in on your client machine. To install 
an add-in, choose Help > Add-ins Page to open the HP Quality Center Add-
ins page, and click the appropriate add-in link.

For more information, refer to the HP Quality Center Microsoft Excel Add-in 
Guide available on the Microsoft Excel Add-in page.
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2
Getting Started

This chapter explains how to start Quality Center and introduces the 
Quality Center window.

This chapter includes:

 ➤  Starting Quality Center on page 38

 ➤  Resetting Your Password on page 42

 ➤  The Quality Center Window on page 43

 ➤  Quality Center Common Toolbar on page 45

 ➤  Changing User Properties and Password on page 47

 ➤  Clearing History on page 49

 ➤  Viewing Administrator Messages on page 50
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Starting Quality Center

You launch Quality Center on your machine from your Web browser.

To start Quality Center:

 1 Open your Web browser and type your Quality Center URL
http://<Quality Center server name>[<:port number>]/qcbin. Contact your 
system administrator if you do not have the correct path.

The HP Quality Center Options window opens.

 2 Click the Quality Center link.

The first time you run Quality Center, files are downloaded to your 
machine, and if it is not already installed, the Microsoft .NET Framework 2.0 
Setup program runs. Subsequently, Quality Center carries out a version 
check. If there is a newer version on the server, updated files are downloaded 
to your machine.
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Note: 

➤ To download files to your machine, you must log in with administrator 
privileges. For more information on the minimum permissions required 
to install client components, refer to the HP Quality Center Installation 
Guide.

➤ If file downloads are prohibited through your browser, you can install 
these files from the HP Quality Center Client Side Setup Add-in on the 
HP Quality Center Add-in page. For more information on add-ins, refer 
to the HP Quality Center Installation Guide. 

➤ Quality Center prompts you to install Microsoft .NET Framework 2.0 if it 
is not already installed on your machine. To perform the installation, 
follow the instructions in the Software Update Installation Wizard (if 
Windows Installer 3.1 is not installed) and the Microsoft .NET 
Framework 2.0 Setup.
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After the Quality Center version has been checked and files have been 
updated if necessary, the HP Quality Center Login window opens.

 3 In the Login Name box, type your user name.

 4 In the Password box, type the password assigned to you by your site 
administrator. If you cannot remember your password, click the Forgot 
Password link. For more information, see “Resetting Your Password” on 
page 42.

To change your assigned password, see “Changing User Properties and 
Password” on page 47.

 5 Select the Automatically log in to my last domain and project on this 
machine check box if you want Quality Center to automatically log in to the 
last project in which you were working.

 6 Click the Authenticate button. Quality Center verifies your user name and 
password and determines which domains and projects you can access. If you 
specified automatic login, Quality Center opens.
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If authentication fails, check that your user name and password are correct 
and try again.

 7 In the Domain list, select a domain. By default, the last domain in which 
you were working is displayed.

 8 In the Project list, select a project. By default, the last project in which you 
were working is displayed.

If the demonstration project was installed on the Quality Center server, you 
can select the QualityCenter_Demo project (make sure that you select 
DEFAULT in the Domain list). The project includes sample data to help 
introduce you to Quality Center. For more information, refer to the 
HP Quality Center Tutorial.

 9 Click the Login button. Quality Center opens and displays the module in 
which you last worked during your previous session.

The first time you run Quality Center, the Welcome page opens. From the 
Welcome page, you can directly access the Quality Center documentation. If 
you do not want to display the Welcome page each time you log in to 
Quality Center, select Don’t show this again. To open the Welcome page at 
any time, choose Help > Welcome Page.

 10 To exit and return to the HP Quality Center Login window, click the Logout 
button located in the upper-right corner of the window. 

Alternatively, choose Tools > Change Project to log in to a different project.
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Resetting Your Password

When logging in to Quality Center, if you cannot remember your password, 
you can reset it and create a new one.

Note: Resetting your password is unavailable in either of the following 
situations:

➤ It is deactivated by the PASSWORD_RESET_DISABLE Site Configuration 
parameter. 

➤ LDAP authentication is enabled. 

For more information, refer to the HP Quality Center Administrator Guide.

To reset your password:

 1 In the Quality Center Login window, click the Forgot Password link. The 
Forgot Password dialog box opens.

 2 In the Login Name box, type your user name. By default, the name entered 
in the Quality Center Login window is displayed.

 3 Click OK. Quality Center sends a message to the email address assigned to 
your Quality Center user name.

The link contained in the message is valid for a set period of time. For more 
information, refer to the HP Quality Center Administrator Guide.

 4 Locate the Quality Center email and click the Reset your password link. The 
Password Reset window opens.

 5 In the Login Name box, type your user name.

 6 In the New Password box, type a new password.

 7 In the Retype Password box, retype the password.

 8 Click OK. The Quality Center Login window opens. Log in using your new 
password.
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The Quality Center Window

When you connect to a project, the Quality Center main window opens and 
displays the module in which you were last working. On the upper-right 
side of the window, the domain, project, and your user name are displayed.

Note: Available Quality Center functionality may depend on how your site 
or project administrator has configured your Quality Center project.

The Quality Center window contains the following key elements:

➤ Quality Center sidebar. Provides access to the Quality Center modules. For 
more information, see “Quality Center Modules” on page 44.

Common toolbar
Module menu bar

Module toolbar

Quality Center
sidebar
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➤ Quality Center common toolbar. Provides navigation buttons, access to 
common tools, documentation and additional resources. This toolbar is 
located on the upper-left part of the window. For more information, see 
“Quality Center Common Toolbar” on page 45.

➤ Module menu bar. Displays the names of menus from which you select 
commands in the current Quality Center module.

➤ Module toolbar. Contains buttons for frequently-used commands in the 
current Quality Center module.

➤ Logout button. The Logout button, located in the upper-right corner of the 
window, logs you out of your current project and returns you to the 
HP Quality Center Login window.

Quality Center Modules
Quality Center has the following modules, which are accessible from the 
sidebar:

Quality Center Editions: The availability of each module and feature 
depends on the Quality Center edition you have — Starter, Enterprise or 
Premier. For more information, see Appendix C, “Quality Center Editions”.

➤ Management. This module includes the following sub-modules:

➤ Releases. Enables you to define releases and cycles for the application 
management process.

➤ Libraries. Enables you to define libraries to track changes in your project, 
reuse entities in a project, or share entities across multiple projects.

➤ Requirements. Enables you to manage requirements in a hierarchical tree-
structure. Requirements can be linked to other requirements, tests, or 
defects. 

➤ Test Plan. Enables you to develop and manage tests in a hierarchical tree-
structure. Tests can be linked to requirements and defects.

➤ Test Resources. Enables you to manage test resources in a hierarchical tree-
structure. Test resources can be associated with tests.
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➤ Test Lab. Enables you to manage and run tests. After running tests, you can 
analyze the results.

➤ Defects. Enables you to add defects, determine repair priorities, repair open 
defects, and analyze the data.

➤ Dashboard. Enables you to create graphs, reports, and Excel reports. You can 
also create dashboard pages, which enable you to view multiple graphs side-
by-side.

Depending on your Quality Center license, you may also have access to the 
Business Components module. This module enables subject matter experts 
to drive the quality optimization process using Business Process Testing, the 
HP test automation solution. For more information, refer to the HP Business 
Process Testing User Guide.

Tip: You can navigate between the modules using shortcut keys. For a list of 
shortcut keys, see Appendix B, “Quality Center Keyboard Shortcuts.”

To customize the module names, refer to the HP Quality Center Installation 
Guide.

Quality Center Common Toolbar

The Quality Center common toolbar, located on the upper-left side of the 
Quality Center window, is accessible from all modules and contains the 
following buttons:

Navigation Buttons

Back. Navigates back to your previous location in Quality Center.

Forward. Navigates forward to your next location in Quality Center.

Tools Button

The Tools button contains the following menu items:
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Change Project. Enables you to log out of your current project and select 
one of the previously opened projects on that machine (if appropriate), or 
select a different project from the Login window.

Customize. Opens the Project Customization window, enabling you to 
customize your project. For more information, refer to the HP Quality Center 
Administrator Guide.

New Defect. Opens the New Defect dialog box, enabling you to add a new 
defect. For more information, see Chapter 35, “Adding and Tracking 
Defects.”

Spelling and Grammar: 

➤ Check Spelling. Checks the spelling for the selected word or text box. If 
there are no errors, a confirmation message opens. If errors are found, the 
Spelling dialog box opens and displays the word together with 
replacement suggestions.

➤ Spelling Options. Opens the Spelling Options dialog box, enabling you 
to configure the way Quality Center checks spelling. 

➤ Thesaurus. Opens the Thesaurus dialog box and displays a synonym, 
antonym, or related word for the selected word. You can replace the 
selected word or look up new words.

Clear History. Opens the Clear History dialog box, enabling you to delete 
history data from your project. Clearing history requires the appropriate 
user permissions. For more information, see “Clearing History” on page 49.

Document Generator. Opens the Document Generator. For more 
information, see Chapter 45, “Generating Project Documents.”

To customize the Tools menu, refer to the HP Quality Center Installation 
Guide.

Help Button

The Help button enables you to open the Quality Center Documentation 
Library and other additional online resources. It also enables you to display 
version information for each Quality Center client component. For more 
information, see “Documentation Library” on page 19 and “Additional 
Online Resources” on page 21.



Chapter 2 • Getting Started

47

To customize the Help menu, refer to the HP Quality Center Installation 
Guide.

Changing User Properties and Password

You can change your user properties, including full name, email address, 
phone number, and description. Email information is important because it 
enables you to receive email notifications and alerts directly to your 
mailbox. You can also change your password for accessing Quality Center 
projects.

The site administrator can change and override a user’s properties or 
password. For more information, refer to the HP Quality Center Administrator 
Guide.

To change user properties and password:

 1 On the upper-left side of the window, click the Tools button and choose 
Customize. The Project Customization window opens. 
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 2 Click the User Properties link. The User Properties window opens.

 3 Edit the user properties.

 4 Click Save to save your changes.

 5 Click the Change Password button. The Change Password dialog box opens.

 6 In the Old Password box, type your old password.

 7 In the New Password box, type the new password.

 8 In the Retype New Password box, retype the new password.
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 9 Click OK to save your changes. The Change Password dialog box closes.

 10 On the upper-right side of the window, click the Return button to exit the 
Project Customization window and return to your project.

Clearing History 

When you customize your project, you can instruct Quality Center to 
preserve a log of values for the system and user fields in your project. For 
more information on enabling history for a field, refer to the 
HP Quality Center Administrator Guide.

When the history data is no longer needed, you can choose to delete this 
data from your Quality Center project. For example, if you have successfully 
run the test sets you created, you may want to clear the test history from 
your project.

You can choose to clear all history data, or you can select a specific entity or 
field whose history you want to clear. In addition, you can choose to delete 
history data up to and including a specific date. Quality Center clears the 
data displayed in the History tab of the corresponding modules.

Note: You must have the appropriate user permissions to clear history. 

To clear history:

 1 On the upper-left side of the window, click the Tools button and choose 
Clear History. The Clear History dialog box opens.

 2 In the Entity box, select the entity whose history you want to delete. To 
delete history data from all entities, select All.

 3 In the Field box, select the field whose history you want to delete. To delete 
history data from all fields, select All.

 4 In the Until Date box, select a date. All data up to and including the selected 
date is deleted.

 5 Click OK.
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Viewing Administrator Messages

The site administrator can send messages to users connected to 
Quality Center projects informing them about important maintenance or 
other issues. For example, the site administrator may send a message 
warning that a project you are connected to will be disconnected, or that a 
Quality Center server will be restarted.

For more information on sending messages from Site Administration, refer 
to the HP Quality Center Administrator Guide.

To view administrator messages:

 1 When the site administrator sends you a message, a pop-up window 
automatically opens on your machine displaying the message text.

 2 If there is more than one message, use the Previous Message and Next 
Message buttons to view other messages.

 3 To close the message box, click the Close button.
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3
Working with Quality Center Data

You can view and modify the data in your project using Quality Center grids 
and trees.

This chapter includes:

 ➤  About Working with Quality Center Data on page 52

 ➤  Arranging Columns on page 52

 ➤  Selecting Users on page 55

 ➤  Filtering Records on page 56

 ➤  Advanced/Cross Filtering Records on page 61

 ➤  Sorting Records on page 65

 ➤  Grouping Grid Records on page 67

 ➤  Updating Multiple Records on page 70

 ➤  Copying Settings on page 71

 ➤  Refreshing and Clearing Settings on page 71

 ➤  Searching Records on page 72

 ➤  Exporting Data to a File on page 74
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About Working with Quality Center Data

Quality Center organizes and displays data in grids or trees. You can 
manipulate the data in various ways including rearranging columns, 
filtering, sorting and grouping. You can also copy settings, search for specific 
text, and export data to a file.

As Quality Center grids and trees vary in the type of content they display, 
the activities described in this chapter do not always apply to all grids and 
trees.

Tip: You can save your grid and tree settings, such as sorting and filters, as a 
favorite view. For more information, see Chapter 6, “Working with Favorite 
Views.”

Arranging Columns 

You can customize data by specifying the order in which columns appear, 
and by changing column size. Quality Center displays your customized 
column settings the next time you open the project.

Quality Center Starter Edition: Not all fields and functionality are available 
if you are working with the Starter Edition. 

Setting Column Order

You determine which columns are displayed in Quality Center and the order 
in which they appear using the Select Columns dialog box. For example, 
you can set Subject as the first column in the Test Grid.
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To determine column appearance and order:

 1 Click the Select Columns button. The Select Columns dialog box opens.

Available Columns lists columns that are not currently displayed. 
Visible Columns lists columns that are currently displayed.

 2 If you are opening the Select Columns dialog box from the Requirements 
module, this dialog box also displays the Requirement Type box and the 
Hide Risk-Based Quality Management Columns check box. 

Select a requirement type from the Requirement Type list. The columns 
available for the requirement type are displayed.

Select the Hide Risk-Based Quality Management Columns check box to hide 
the requirement fields related to risk-based quality management from the 
Available Columns list. Clear the check box to make the fields visible.
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 3 Select column names and click the arrow buttons (> and <) to move them 
between Available Columns and Visible Columns. Click the double arrow 
buttons (>> and <<) to move all the columns from one list to the other. Note 
that you can also drag the column names between lists or double-click a 
column name to move a column between lists.

Note: Columns displayed with the  icon cannot be removed from the 
Visible Columns list.

 4 In Visible Columns, set the order in which columns appear by using the Up 
and Down arrows. You can also drag the column names up or down.

 5 To set non-scrolling columns, specify the number of non-scrolling columns 
you want to set in Fixed Columns. Starting from the leftmost column, the 
number of columns you specify will be set as non-scrolling. Non-scrolling 
columns remain stationary when you scroll horizontally. These columns are 
shaded.

 6 Click OK to close the dialog box and apply the new column order.

Resizing Columns

You can resize columns using the mouse. Click on the right edge of a 
column heading and drag to adjust the width. You can only resize columns 
that are not fixed (non-scrolling).



Chapter 3 • Working with Quality Center Data

55

Selecting Users

When you select a column in a Quality Center grid or tree with a user name 
value, Quality Center displays a users list with the name and full name of 
each user. You can sort the users list, search for users, group users by user 
groups, and select users from the list or from a group tree. 

To select users:

 1 Select a user field and click the drop-down arrow. The Users List dialog box 
opens.

To sort the Users List in ascending or descending order by user name or full 
name, click the Name or Full Name column heading. Click the column 
heading again to reverse the sort order. 

 2 To search users, you can:

➤ Search incrementally by typing the first character in the user name. You 
can type additional characters to narrow down the search. 
Quality Center begins searching as soon as you type the first character of 
the search string, and highlights the record with the first occurrence of 
all the characters in the search string.

➤ Search users by user name or full name. Type the name of a user (or part 
of the name) in the Find box. Click the Find button. Quality Center 
highlights the record with the first occurrence of the search string. Press 
F3 to find subsequent occurrences of the search string.
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 3 To display users by user group, select View by Group. The users are grouped 
by user group.

To expand a branch in the tree, click the Expand  sign to the left of the 
user group name. To collapse a branch in the tree, click the Collapse  sign 
to the left of the user group name.

 4 Select a user and click OK. The Users List dialog box closes and the user 
value is displayed in the data field.

Filtering Records 

You can filter Quality Center data to display only those records that meet 
the criteria that you define. You can assign a single item (such as “Failed”) or 
a logical expression (such as “Passed Or Failed”) to a filter. Only records 
meeting all the criteria of the filter appear in the grid or tree. 

In addition, you can define multiple filters. For example, you can define the 
Status filter as “Failed” and the Tester filter as “David Or Mark”. Only failed 
test runs performed by David or Mark are displayed.

When filtering a tree, the results are displayed in Quality Center as follows:

➤ If you are filtering in the requirements tree, parents of filter entities that do 
not correspond to the filter are displayed with the  icon.

➤ If you are filtering in the test plan or test set tree, folders in the tree that do 
not correspond to the filter are not displayed.
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Version Control: For information on filtering data based on version control 
fields, see “Filtering Version Control Fields” on page 112.

Quality Center Starter Edition: Not all fields and functionality are available 
if you are working with the Starter Edition. 

Tip: You can save filter and sort information as a favorite view and then load 
it as needed. To save as a favorite view, choose Favorites > Add to Favorites. 
For more information, see Chapter 6, “Working with Favorite Views”.

To define a filter:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens and 
displays the Filter Condition tab.
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 2 To define a filter by a requirement type, in the Requirement Type box, click 
the browse button. The Select Filter Condition dialog box opens. Select a 
requirement type. Click OK to close the Select Filter Condition dialog box. 
The Filter Condition tab displays the relevant field names.

 3 If you are working in the Requirements module, you can select the Hide 
Risk-Based Quality Management Columns check box to hide the 
requirement fields related to risk-based quality management. Only fields for 
which no filter condition is set are hidden. Clear the check box to make the 
fields visible.

 4 To go to a field in the Filter Condition tab, click a box in the Field Name 
column and type the first character of the field name. Quality Center 
highlights the first occurrence.

 5 To set a filter condition for a field, click the corresponding Filter Condition 
box. Click the browse button. The Select Filter Condition dialog box opens.



Chapter 3 • Working with Quality Center Data

59

Notes: 

➤ If you select a field with a user name value, the Select Filter Condition 
dialog box displays a user list that enables you to sort users, search for 
users, group users by user groups, and select users from the list or from a 
group tree. For more information, see “Selecting Users” on page 55.

➤ In the Requirements module, if you select the Req Parent field, the Select 
Filter Condition dialog box displays the requirements tree, sorted by 
requirement name. If you select a requirement from the requirements 
tree, its full path is displayed in the Condition box. Only requirements 
which are descendents of this requirement are displayed when you apply 
the filter.

 6 Define the filter condition. If applicable, select items from the list. You can 
add operators to create a logical expression. 
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Notes: 

➤ Some items that appear in hierarchical lists contain sublists. These items 
are preceded by a folder icon. To choose an item from a sublist, double-
click the folder and click the item.

➤ When defining a condition for a user, you can specify the current user 
(select [CurrentUser]), or an entire user group (for example, [Developer]).

➤ If you enter an item with more than one word, it must be enclosed in 
quotes. For example, to search for the test Login Boundary, in the 
Condition box, type the following: "login boundary"

➤ If you want to enter only part of the item, use an asterisk (*). For 
example, to search for all tests with the word Login, in the Condition 
box, type the following: *login*. To search for all tests that begin with the 
words Insert New in the Condition box, type the following: "insert new*"

➤ To specify an empty field, type the following: ""

➤ To specify a non-empty field, type the following: not ""

 7 Click OK to close the Select Filter Condition dialog box.

 8 To add cross filters, click the Show Advanced Filter arrow. For more 
information, see “Advanced/Cross Filtering Records” on page 61.

 9 To copy the settings, click the Copy Filter Settings button. For more 
information, see “Copying Settings” on page 71.

 10 To clear the settings, click the Clear Filter button.

 11 Click OK to close the Filter dialog box.

Any filters are applied and the filter description is displayed. For a grid, 
Quality Center also displays the condition in the grid filter box, which 
appears under each column name.
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To display the grid filter box, choose View > Grid Filters. If the filter box is 
empty, no filter is currently applied to the column. Type directly into the 
box, or click the box to display the Browse button, which opens the Select 
Filter Condition dialog box. 

Advanced/Cross Filtering Records

When defining a filter, you can also include a cross filter. This is an 
advanced, second filter on an associated item such as requirements, tests, 
test sets, or defects. For example, in the test plan tree, you can define the 
cross filter for associated test sets as “Open”. This ensures that only tests that 
belong to an open test set are displayed. Alternatively, you can define the 
associated test set filter to find tests that are not in any test set.
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The following table summarizes the cross filters available in each 
Quality Center module:

Module Cross Filter

Requirements ➤ Tests. Filters the requirements by covered tests.

➤ Defects. Filters the requirements by defects that have been 
directly or indirectly-linked to the requirements.

➤ Requirements: Trace from. Filters the requirements by 
traced from requirements.

➤ Requirements: Trace to. Filters the requirements by traced 
to requirements.

➤ Show requirements with alerts. Filters the requirements by 
alerts that have been triggered.

Test Plan ➤ Requirements. Filters the tests by covered requirements.

➤ Test Sets. Filters the tests by test sets that contain the tests.

➤ Defects. Filters the tests by defects that have been directly or 
indirectly-linked to the tests.

➤ Show tests with alerts. Filters the tests by alerts that have 
been triggered.

Test Lab - Test 
Sets list

➤ Tests. Filters the test sets by contained tests.

➤ Defects. Filters the test sets by defects that have been 
directly or indirectly-linked to the tests.

Test Lab - 
Execution Grid

➤ Requirements. Filters the test instances by tests that cover 
selected requirements.

➤ Defects. Filters the tests by defects that have been directly or 
indirectly-linked to the tests.

➤ Show test instances with alerts. Filters the test instances by 
alerts that have been triggered.

Defects ➤ Requirements. Filters the defects by linked requirements.

➤ Test Sets. Filters the defects by linked test sets.

➤ Tests. Filters the defects by linked tests.

➤ Show defects with alerts. Filters the defects by alerts that 
have been triggered.

Dashboard - 
Analysis View

You can define cross filters for requirements, tests, test 
instances, and defects. 
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Notes:

➤ Although the cross filter functionality is the same across all 
Quality Center modules, the interface of the Filter dialog box in the 
Dashboard module is slightly different than the other modules. 

➤ Quality Center Starter Edition: Not all fields and functionality are 
available if you are working with the Starter Edition. 

To define a cross filter:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens and 
displays the Filter tab. 

For more information on defining a filter, see “Filtering Records” on 
page 56.

 2 Click the Show Advanced Filter arrow to display the cross filter options.
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 3 Under Cross filter by, select a filter check box. For example, select Test Sets. 
The Cross Filter dialog box opens.

In the Test Plan module, the following options are available:

➤ Filter tests not in any test set. Filters tests that are not part of any test set. 
For example, this can help you identify tests that have not been run. This 
option is only available in the Cross Filter: Test Sets dialog box. 

➤ Filter tests with no requirement coverage. Filters tests that do not cover 
any requirements. For example, this can help you identify redundant 
tests or tests with missing requirement coverage links. This option is only 
available in the Cross Filter: Requirements dialog box.

 4 Define the cross filter, using the same rules you would to define a filter. For 
more information, see “Filtering Records” on page 56.

 5 To copy the settings, click the Copy Filter Settings button. For more 
information, see “Copying Settings” on page 71.

 6 To clear the settings, click the Clear Filter button.
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 7 Click OK to save your changes and close the Cross Filter dialog box. In the 
Filter dialog box, under Cross filter by, the cross filters you defined are 
displayed.

 8 Click OK to save your changes and close the Filter dialog box.

Sorting Records

By default, records appear in Quality Center according to the order in which 
they were added. When you set sorting priorities, records are displayed 
according to the ASCII sort order. The ASCII sort order considers records 
beginning with a space or character before considering those beginning 
with numbers. It then considers uppercase letters and, finally, lowercase 
letters.

For example, if the Designer column in the Test Grid is assigned the highest 
sort priority, records are sorted in the ASCII sort order according to the 
names appearing in the Designer column. If Test Name is assigned the next 
highest priority, test records assigned the same name in the Designer 
column are then sorted in the ASCII sort order according to their test name.

Notes:

➤ You can save filter and sort information as a favorite view and then load 
it as needed. To save as a favorite view, choose Favorites > Add to 
Favorites. For more information, see Chapter 6, “Working with Favorite 
Views”.

➤ Quality Center Starter Edition: Not all fields and functionality are 
available if you are working with the Starter Edition. 
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To sort records:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens.

 2 Click the View Order tab.

Available Fields contains the names of all the fields you can display. 
Sorted Fields contains the names of the fields currently assigned a sorting 
priority.

 3 If you are working in the Requirements module, select a requirement type 
from the Requirement Type list. The View Order tab displays the relevant 
field names.

 4 If you are working in the Requirements module, you can select the Hide 
Risk-Based Quality Management Columns check box to hide the 
requirement fields related to risk-based quality management from the 
Available Fields list. Clear the check box to make the fields visible.
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 5 Select field names and click the arrow buttons (> and <) to move a name 
between Available Fields and Sorted Fields. Click the double arrow buttons 
(>> and <<) to move all the names from one list to the other. You can also 
drag the field names between lists or double-click a column name to move a 
column between lists.

 6 In Sorted Fields, select a field and use the Sort Ascending and Sort 
Descending buttons to sort the field in an ascending or descending order.

 7 In Sorted Fields, select a field and use the Move Field Up and Move Field 
Down buttons to set the sort priority. You can also drag the field names up 
or down.

 8 To copy the settings, click the Copy Filter Settings button. For more 
information, see “Copying Settings” on page 71.

 9 To clear the settings, click the Clear Filter button.

 10 Click OK to apply the sort order.

Grouping Grid Records

When working with Quality Center grids, you can separate data into groups 
according to specified criteria. You can determine the information by which 
Quality Center groups records, and set the hierarchical order in which they 
are displayed (up to three levels). This enables you to navigate through large 
sets of data more easily.

For example, in the Defects Grid if you select the Assigned To column as the 
highest group by priority, records are grouped according to the names 
appearing in the Assigned To column. If you select Status and Severity as 
the next highest priorities respectively, test defects assigned the same name 
in the Assigned To column are next grouped according to their status, and 
then their severity.
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Notes:

➤ You cannot select a group header and perform Quality Center actions on 
an entire group. To perform actions on multiple records, use CTRL or 
SHIFT to select records.

➤ If you group records by a field containing multiple values, the 
information in each value is grouped as its entire value. This value is the 
category for grouping. For example, a value with English and French will 
be grouped once as English;French, and not as part of separate English 
and French categories. For more information on allowing multiple 
values, refer to the HP Quality Center Administrator Guide.

➤ The group by list displays only system and user-defined fields associated 
with a User List or Lookup List type field. For more information on field 
types, refer to the HP Quality Center Administrator Guide.

➤ Quality Center Starter Edition: Not all fields and functionality are 
available if you are working with the Starter Edition. 
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To group grid records:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens.

 2 Click the Group tab.

 3 If you are working in the Requirements module, select a requirement type 
from the Requirement Type list. The Group tab displays the relevant field 
names.

If you are working in the Requirements module, you can select the Hide 
Risk-Based Quality Management Columns check box to hide the 
requirement fields related to risk-based quality management. Clear the 
check box to make the fields visible.

 4 Click the Group items by arrow. Choose the field by which you want to 
group records.

 5 To group records by additional fields, click the Then by arrow and choose 
the field by which you want to group records. If you group records by more 
than one field, select fields in the hierarchical order that you want them to 
be displayed. You cannot select a field that has already been selected.
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 6 To remove a group level, change the level to (none). If you change a parent 
group level to (none), its child group levels automatically change to (none).

 7 To copy the settings, click the Copy Filter Settings button. For more 
information, see “Copying Settings” on page 71.

 8 To clear the settings, click the Clear Filter button.

 9 Click OK to close the Filter dialog box.

The grid records are grouped by the group by settings.

Updating Multiple Records

You can update a field value for multiple records in a grid or a tree. This 
option is available in the following Quality Center modules: Requirements, 
Test Plan (grid only), and Defects.

To update multiple records:

 1 Select the records using the CTRL or SHIFT key.

 2 Choose Edit > Update Selected. The Update Selected dialog box opens.

 3 In the Update in Field box, select a field.

 4 In the Value box, type a replacement value.

 5 Click Update. An information box opens, showing the number of values 
that were updated, and the number of instances where the values were not 
updated. Click OK.

 6 Click Close to close the Update Selected dialog box.
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Copying Settings

You can copy and paste the filter, sort, and group by settings to and from the 
Clipboard. You can copy the settings and paste them to another project. You 
can also share the settings with another user by pasting them to an email or 
a text file. 

To copy settings:

 1 Click the appropriate Set Filter/Sort button. The Filter dialog box opens.

 2 Click the Copy Filter Settings button. The settings are copied to the 
Clipboard.

 3 To paste to another project, log in to the project to which you want to paste 
the settings, display the appropriate module, and open the Filter dialog box. 
Click the Paste Filter Settings button. Click OK.

To paste to an email or a text file, click the paste button. 

Refreshing and Clearing Settings 

You can refresh and clear the filter, sort, and group by settings applied to 
Quality Center data.

➤ To refresh the data in a grid or tree, click the Refresh All button.

➤ To clear all the filters and sorting priorities in a grid or tree, click the Set 
Filter/Sort arrow and choose Clear Filter/Sort.
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Searching Records

You can use text search to search for records in predefined fields of the 
Requirements, Test Plan, and Defects modules. The searchable text fields are 
predefined by the project administrator in Project Customization. For more 
information on defining searchable fields, refer to the HP Quality Center 
Administrator Guide.

When you enter a keyword, Quality Center searches the predefined fields for 
the keyword or variations of the keyword. For example, if you type log, the 
search will find fields containing log, logs, logging, and logged. The search 
will not find login or logical because these are not variations of the word. For 
more information on search details, see “Search Considerations” on page 73.

If you have defined filter conditions for a module, you can restrict the 
search to the filtered records, or you can search all records in the module 
(this saves you having to clear the current filter and redefine it again). If you 
have a folder selected in the module, the search is still performed on all the 
records in the module, subject to the filtering option that you selected. 

Quality Center displays the search results in a list, sorted in order of 
relevance. You can view search results, and display record details. You can 
customize the data by determining which columns are displayed and the 
order in which they appear. 

Notes:

➤ Version Control: Quality Center searches only checked in versions.

➤ Text search is only available if it has been enabled for the project. 
Contact your Quality Center site administrator if the search option is 
unavailable.

➤ Quality Center Starter Edition: Text search is not available. 
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Search Considerations

When you use text search, you should consider the following:

➤ The search ignores the following: articles (a, an, the); coordinate 
conjunctions (and, but, for, nor, or); boolean operators (and, or, not, if, 
or, then).

➤ If you enter more than one search word, the results will include all 
records that contain at least one of the search words.

➤ The letter case does not affect the results.

➤ The search ranks the results and displays them in order of relevance.

To search records:

 1 Click the Text Search button or choose Edit > Text Search. The text search 
pane opens in the lower part of the window. 

 2 In the Search for box, type the words you want to find. If you are working in 
the Test Plan module: In the In box, select Tests or Design Steps.

 3 To search all records in the module, clear the Restrict to current filter check 
box. 

 4 Click Search. Quality Center performs the text search on the predefined 
fields and displays the search results in order of relevance.

 5 To change the column appearance and order, click the Select Columns 
button. The Select Columns dialog box opens. For more information, see 
“Arranging Columns” on page 52.
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 6 To view the list of predefined search fields set in Project Customization, click 
the Searchable Fields Information button. The list of predefined search fields 
is displayed. Click OK to close the searchable fields list.

 7 To display record details, select a record and click the record ID or Name 
link. Alternatively, select the record and click the Go to Entity button.

Note: In Quality Center tree views, the record details only display if the 
record matches the current filter. To display details for records that do not 
match this filter, change or clear the filter.

Exporting Data to a File 

You can export the data in a grid as a text file, Microsoft Excel worksheet, 
Microsoft Word document, or HTML document.

To export data to a file:

 1 You can export all grid data or selected records:

➤ To export all grid data, right-click the grid and choose Export > All. The 
Export All Grid Data dialog box opens.

➤ To export selected records in the grid, select the records using the Ctrl or 
Shift key. Right-click the grid and choose Export > Selected. The Export 
Selected Grid Data dialog box opens.

 2 In the Save in box, choose a location for the file.

 3 In the File name box, type a name for the file.

 4 In the Save as type box, select a file type. 

 5 Click Save.
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4
Alerting on Changes

You can instruct Quality Center to create alerts automatically and send 
email to notify those responsible when changes occur in your project that 
may impact the application management process. You can also add your 
own follow up alerts.

This chapter includes:

 ➤  About Alerting Changes on page 75

 ➤  Understanding Alerts on page 76

 ➤  Viewing Alerts on page 80

 ➤  Clearing Alerts on page 81

 ➤  Flagging for Follow Up on page 82

About Alerting Changes

You can keep track of changes to your requirements, tests, and defects as you 
perform project testing. There are two alerting functions available in 
Quality Center:

➤ Automatic notification alerts. Your Quality Center project administrator can 
activate alert rules. The rules are based on associations you make in 
Quality Center between requirements, tests, and defects. When an entity in 
your project changes, Quality Center alerts  any associated entities that 
may be impacted by the change. The alerts can be seen by all users. 
Quality Center also notifies the person responsible for the entity at the time 
of the change of any associated entities that may be impacted by the 
change. For more information, see “Understanding Alerts” on page 76 and 
“Viewing Alerts” on page 80.
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➤ Follow up alerts. You can add a follow up flag  to a specific requirement, 
test, test instance, or defect to remind yourself to follow up on an issue. 
When the follow up date arrives, Quality Center sends you email. For more 
information, see “Flagging for Follow Up” on page 82.

Understanding Alerts

When a requirement, test, or defect changes, Quality Center alerts the 
associated entities and can notify those responsible for any associated 
entities. The alert rules in Quality Center are based on the following 
associations you can create:

➤ You can associate a test in the test plan tree with a requirement. This is 
accomplished by creating requirements coverage in the Test Plan module, 
or by creating tests coverage in the Requirements module. For more 
information, see Chapter 19, “Requirement and Test Coverage.”

➤ You can associate a test instance with a defect. This is performed by creating 
Linked Defects in the Test Plan module, or by adding a defect during a 
manual test run. For more information, see Chapter 36, “Linking Defects.”

➤ You can create traceability links between requirements in the Requirements 
module. For more information, see Chapter 14, “Tracing Requirements.”

After you establish associations in your project, you can track changes using 
these associations. When an entity in your project changes, Quality Center 
alerts any associated entities that may be impacted by the change. The alerts 
can be seen by all users. Quality Center also notifies the person responsible 
for the entity at the time of the change of any associated entities that may 
be impacted by the change.

Version Control: Quality Center alerts associated entities only when a new 
version is checked in. The alert indicates that the version status has changed 
to Checked In. You can then compare the new version with the previous 
version. For more information on comparing versions, see “Viewing Version 
History” on page 109.
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Your Quality Center project administrator can activate four alert rules:

For more information on activating alert rules in Project Customization, 
refer to the HP Quality Center Administrator Guide.

Rule Description Entities Flagged User Notified by Email

1 When a requirement is 
modified, alert the 
associated tests.

Note: A change to the 
requirement can be any 
modification, excluding 
changes to the Direct 
Cover Status field and 
the risk-based quality 
management fields.

Tests covering the 
requirement.

Test designer. 

2 When a defect status 
changes to “Fixed”, 
alert the associated test 
instances.

Test instances 
associated with the 
defect.

Responsible tester for 
the test instance.

3 When a test runs 
successfully (status 
changes to “Passed”), 
alert the linked defects.

Defects linked to 
the test run.

User assigned the 
defect.

4 When a requirement is 
modified or deleted, 
alert traced to 
requirements and child 
requirements.

The requirement’s 
child requirements 
and traced to 
requirements. 

Author of the 
requirement.
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Alert Example
Suppose you are using the QualityCenter_Demo project based on the 
Mercury Tours application. In Project Customization, your project 
administrator activates the first rule: When a requirement is modified, alert 
the associated tests. The project administrator also specifies that 
notifications be sent by email.

In the Requirements module, your QA manager defines the requirement 
Page Download Time (under Application Performance). 

In the Test Plan module, the QA manager then defines a new test 
Connect_Site_Stress for this requirement (under Mercury Tours Site > 
Welcome Page). In the Details tab, the project administrator assigns the new 
test to designer Cecil.
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In the Req Coverage tab, the QA Manager links the Connect_Site_Stress test 
to the Page Download Time requirement. 

A QA tester, Mike, reviews the requirement Page Download Time and 
decides that 10 seconds to download the page is too long. He changes the 
requirement description to 7 seconds. As a result, Cecil now needs to adjust 
his test Connect_Site_Stress so that it meets the changed requirements.

With the rule activated, Mike’s change to the requirement causes 
Quality Center to flag the associated test. This alert can be seen by Cecil, the 
designer responsible for the test, and all other project users. 
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When clicking the Alerts flag, the Alerts dialog box opens and displays the 
details of the change. For more information, see “Viewing Alerts” on 
page 80. 

In addition, Cecil (being the test’s designer) receives an automatic 
Quality Center notification email message that describes the change Mike 
made to the Page Download Time requirement and recommends that Cecil 
check the associated test, Connect_Site_Stress. Cecil clicks a link to open 
Quality Center and display the specified requirement or test.

Viewing Alerts

You can view a list of alerts for a selected entity. The entity can be one of the 
following:

➤ a requirement in a Requirements module view

➤ a test in the test plan tree or Test Grid

➤ a test instance in the Execution Grid

➤ a defect in the Defects Grid or Defect Details dialog box

Note: You can also view a list of all alerts for a selected module by selecting 
the Show <entity> with alerts option in the Filter dialog box. For more 
information, see “Advanced/Cross Filtering Records” on page 61.

For more information on how Quality Center creates alerts, see 
“Understanding Alerts” on page 76.

To view alerts:

 1 Select an entity with an alert as follows:

➤ In the main module, click the Alerts flag  in the Alerts column of the 
tree or grid. If this column is not visible, choose View > Indicator 
Columns. Alternatively, choose Edit > Alerts.

➤ In the Defect Details dialog boxes, click the Alerts button.
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A red flag indicates that the alert is new. A gray flag indicates that the alert 
has already been read.

The Alerts dialog box opens.

Quality Center displays the selected entity and lists the alerts. You can click 
a link in the dialog box to highlight the item in Quality Center.

 2 You can click the Delete Alert button to delete a specific alert, or click Clear 
All to delete all alerts for the entity. Click Yes to confirm. Note that you can 
only clear alerts that are assigned to you, or that are not assigned to any 
user. The user to which an alert is assigned is the user that is sent email 
notification when the alert is triggered. For a list of alerts, and the users that 
are sent email notification, see “Understanding Alerts” on page 76.

 3 Close the Alerts dialog box.

Clearing Alerts

You can clear an individual alert or all alerts for a selected entity from the 
Alerts dialog box. For more information on the Alerts dialog box, see 
“Viewing Alerts” on page 80.

In addition, you can clear all the alerts associated with all the entities in a 
Quality Center module. If you choose this option, only alerts associated 
with entities that match the current filter are cleared. In addition, you can 
only clear alerts that are assigned to you, or that are not assigned to any 
user. The user to which an alert is assigned is the user that is sent email 
notification when the alert is triggered. This user is listed in the Alerts dialog 
box for the alert. For a list of alerts, and the users that are sent email 
notification, see “Understanding Alerts” on page 76.
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To clear all the alerts for a module:

 1 If you are working in the Requirement, Test Plan, or Defects module, choose 
Edit > Clear Alerts. If you are working in the Test Lab module, choose Tests > 
Clear Alerts.

 2 Click Yes to confirm. The alerts are cleared.

Flagging for Follow Up

Quality Center enables you to add your own alerts, in addition to automatic 
traceability notifications. You can use follow up flags to remind yourself to 
follow up on something. For example, you can set a follow up flag on a 
defect to remind yourself to check the status in a week. 

You can set follow up flags for:

➤ a requirement in a Requirements module view

➤ a test in the test plan tree or Test Grid

➤ a test instance in the Execution Grid

➤ a defect in the Defects Grid or Defect Details dialog box

When you add a flag, Quality Center adds a gray flag icon  to the record. 
You can open the follow up alert at any time to view the details. When the 
follow up date arrives, Quality Center sends you email and changes the flag 
icon to red.

Quality Center also displays an information bar for a follow up alert. This 
appears in the right pane of the test plan tree for a test follow up, in the Test 
Instance Properties dialog box for a test instance follow up, and in the 
Defect Details dialog box for a defect follow up.

Note: A follow up flag is specific to your user login name. Anyone else 
viewing the record does not see your follow up alert.

You can create new follow up alerts, or view and modify existing alerts.
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Creating Follow Up Alerts
You can create a follow up alert for a requirement, test, test instance, or 
defect. 

To create a follow up alert:

 1 Select the record you want to flag for follow up. Click the Flag for Follow Up 
button, or right-click the record and choose Flag for Follow Up. The Flag For 
Follow Up dialog box opens. 

 2 In Follow up by, select the date you want Quality Center to send the follow 
up email.

 3 In Description, type the reminder you want to display.

 4 Click OK. Quality Center saves the follow up alert and adds the flag icon  
to the record.

Modifying Follow Up Alerts
You can open a follow up alert you created for a record. You can view and 
modify the details, or delete the follow up. 

To modify a follow up alert:

 1 Click the flag icon  in the Follow Up Flag column for the flagged record in 
the tree or grid. If this column is not visible, choose View > Indicator 
Columns. The Flag For Follow Up dialog box opens. 

 2 To modify the alert, change the Follow up by date or Description. Click OK 
to close the dialog box.

 3 To remove the follow up flag, click the Clear Flag button. Click Yes to 
confirm and close the dialog box.
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5
Adding Attachments

You can add an attachment to a Quality Center record.

This chapter includes:

 ➤  About Adding Attachments on page 86

 ➤  Attaching a File on page 87

 ➤  Attaching a URL on page 87

 ➤  Attaching a Snapshot on page 88

 ➤  Attaching System Information on page 89

 ➤  Attaching Items from the Clipboard on page 90

 ➤  Managing Attachments on page 90



Chapter 5 • Adding Attachments

86

About Adding Attachments

Throughout the application management process, you can add attachments 
to help illustrate your work. You can attach a file, URL, snapshot of your 
application, items from the Clipboard, or system information. When you 
add an attachment to a record, Quality Center adds the  icon to the record. 

You manage attachments using the Attachments tab or dialog box. 
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Attaching a File 

You can attach a file to a Quality Center record.

To attach a file:

 1 In the Attachments dialog box, click the File button. The Open dialog box 
opens.

 2 Choose a file name and click Open. Alternatively, double-click a file name.

The file name appears in the Attachments list, together with the size and 
date modified. An icon for the application associated with the file appears 
next to the file name.

 3 In the Description box, add any comments related to the attached file.

Attaching a URL 

You can attach a Uniform Resource Locator (URL) to a Quality Center 
record. This can be any valid URL scheme such as HTTP, FTP, Gopher, News, 
Mailto, or File.

To attach a URL:

 1 In the Attachments dialog box, click the URL button. The Attach Uniform 
Resource Locator (URL) dialog box opens.

 2 In the URL box, type a valid URL and click OK.

The URL appears in the Attachments list. An icon for your default Web 
browser appears next to the URL.

 3 In the Description box, add any comments related to the attached URL.
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Attaching a Snapshot 

You can attach images of your application to a Quality Center record.

To attach a snapshot:

 1 In the Attachments dialog box, click the Snapshot button. The Snapshot 
dialog box opens.

 2 Drag the camera icon onto an object that you want to capture. The captured 
image is displayed in the Snapshot dialog box.

 3 You can change the magnification level of the captured image. 

➤ Click Zoom Out or Zoom In to reach the desired magnification level. 

➤ Click Normal to return to the standard level.

 4 Click Attach. 

Quality Center assigns the image a unique file name with a .jpg extension. 
The file name appears in the Attachments list, with an image icon next to it. 
The size of the file and the date on which it was modified are also displayed.

 5 In the Description box, add any comments related to the attached snapshot.
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Attaching System Information

You can attach information about your machine to a Quality Center record.

To attach system information:

 1 In the Attachments dialog box, click the System Info button. The System 
Information dialog box opens.

 2 To attach information from a single tab, click a tab and click the Current 
Topic button. 
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 3 To attach information from all tabs, click All Topics.

The information is assigned a unique file name with a .tsi extension. The file 
name appears in the Attachments list, with an icon next to it. The size of the 
file and the date on which it was modified are also displayed.

 4 In the Description box, add any comments related to the attached text file.

Attaching Items from the Clipboard 

You can attach text and images that you copied to the Clipboard to a 
Quality Center record.

To attach an item from the Clipboard:

 1 Copy a text string or an image to the Clipboard.

 2 In the Attachments dialog box, click the Clipboard button.

A text string is assigned a unique file name with a .txt extension. An image 
is assigned a unique file name with a .jpg extension. The attached file 
appears in the Attachments list, with an icon next to it. The size of the file 
and the date on which it was modified are also displayed.

Managing Attachments

You can view, modify, save, and delete an attachment in the Attachments 
dialog box or tab.

Viewing Attachments
You can view an attachment in the Attachments list.

To view an attachment:

 1 In the Attachments list, select an attachment. The corresponding 
description is displayed in the Description box.

 2 Double-click the attachment, or click the Download and Open button. The 
attachment opens in the application associated with it. For example, a URL 
opens in your default Web browser.
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Modifying Attachments
You can modify an attachment in the Attachments list. When you open an 
attachment in the associated application, Quality Center downloads the 
attachment to a local directory on your client machine. After making 
changes, you must save the attachment twice. First, save it locally in the 
application in which you opened it. Then, in Quality Center, click the 
Upload Selected button to save the local copy of the attachment to your 
Quality Center project.

To modify an attachment:

 1 Double-click an attachment in the Attachments list. A local copy of the 
attachment opens in the application associated with it. 

 2 Modify the attachment.

 3 Save the attachment in the application. This saves the local copy of your 
attachment.

 4 Close the attachment.

 5 In Quality Center, click the Upload Selected button in the Attachments 
dialog box. This saves the local copy to the Quality Center project.

Saving Attachments
You can save an attachment to the local directory of your client machine.

To save an attachment:

 1 In the Attachments list, select an attachment and click the Save As button. 
The Save Attachment dialog box opens.

 2 In the Save in box, choose a location for the file.

 3 In the File name box, type a name for the file.

 4 Click Save. The attachment is downloaded and saved to a local directory on 
your client machine.
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Deleting Attachments
You can delete an attachment from the Attachments list.

To delete an attachment:

 1 In the Attachments list, select the attachment to delete. To select more than 
one attachment, use the CTRL key.

 2 Click the Delete Selected button and click Yes to confirm.
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6
Working with Favorite Views

A favorite view is a view of a Quality Center window with the settings you 
apply to it. You can save your favorite views and reload them in the future.

This chapter includes:

 ➤  About Working with Favorite Views on page 93

 ➤  Adding Favorite Views on page 94

 ➤  Loading Favorite Views on page 95

 ➤  Updating Favorite Views on page 95

 ➤  Organizing Favorite Views on page 96

About Working with Favorite Views

You determine the way a Quality Center window looks by selecting certain 
settings for it. For example, these settings may include applying a filter to 
grid columns, or sorting fields in a grid. You can save a favorite view for 
future use and then load it as necessary.

You save favorite views in either a public folder or a private folder. Views in a 
public folder are accessible to all users. Views in a private folder are 
accessible only to the user who created them. 

Some favorite view commands are accessible only to certain user groups. For 
more information on user group privileges, refer to the HP Quality Center 
Administrator Guide.
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Note: Working with favorite views is different from the description in this 
chapter for Document Generator. 

In the Document Generator, click the Add to Favorites button to add a new 
view and the Favorites button to organize your views.

Adding Favorite Views 

You can add a view to your private folder or to the public folder.

To add a favorite view:

 1 Choose Favorites > Add to Favorites. The Add Favorite dialog box opens.

 2 In the Name box, type a name for the view.

 3 In Location: 

➤ Select Private to add the view to your private folder. Favorite views in this 
folder can only be accessed by you. 

➤ Select Public to add the view to the common folder. Favorite views in this 
folder can be accessed by all users of the project.



Chapter 6 • Working with Favorite Views

95

The favorite views that already exist in the folder you selected are displayed 
under Existing Favorites.

 4 Click OK. The new view is added to your private folder or to the public 
folder.

Loading Favorite Views

You can load an existing favorite view in a Quality Center window.

To load a favorite view:

➤ To load a recently used favorite view, open the Favorites menu and choose a 
view.

Note: By default, Quality Center displays the four most recently used views 
on the Favorites menu. You can define the number of views displayed on 
the menu by setting the FAVORITES_DEPTH parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator Guide.

➤ To load a favorite view, choose Favorites > Private or Favorites > Public and 
choose a view.

Alternatively, on the module toolbar, select a view from the Favorite bar. By 
default, the Favorite bar is not displayed. To display it, choose View > 
Favorite Bar. The Favorite bar is available from Quality Center grid views 
only.

Updating Favorite Views

You can update the settings of an existing favorite view.

To update a favorite view:

 1 Load a favorite view from the Favorites menu. For more information, see 
“Loading Favorite Views” on page 95.
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 2 Make changes to the view.

 3 Choose Favorites > Add to Favorites. The Add Favorite dialog box opens.

 4 Under Existing Favorites, select the view name and click OK.

 5 Click Yes to overwrite the previous settings.

Organizing Favorite Views

You can organize the list of favorite views in the private and public folders 
by changing the properties of a view and by deleting views.

To organize favorite views:

 1 Choose Favorites > Organize Favorites. The Organize Favorites dialog box 
opens.

 2 To change properties, select a view from the list and click Properties. The 
Properties dialog box opens.
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 3 In the Name box, type a new name for the view. 

 4 Under Location:

➤ Select Private to add the view name to your private folder. It can only be 
accessed by you.

➤ Select Public to add the view name to a common folder. It can be 
accessed by all users.

 5 Click OK to save the properties. Click Yes to confirm.

 6 To delete a favorite view, select it from the list and click Delete. Click OK to 
confirm.

 7 Click Close to close the Organize Favorites dialog box.
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7
Working with Version Control

Version control enables you to keep track of changes made to entities in 
your project, including requirements, tests, test resources, and business 
components.

This chapter includes:

 ➤  About Working with Version Control on page 99

 ➤  Version Control Overview on page 100

 ➤  Checking Out Entities on page 104

 ➤  Checking In Entities on page 106

 ➤  Undoing Check Outs on page 107

 ➤  Viewing Checked Out Entities on page 108

 ➤  Viewing Version History on page 109

 ➤  Filtering Version Control Fields on page 112

About Working with Version Control

In a version control enabled project, you can create and manage 
Quality Center entities while maintaining previous versions of those 
entities. This includes requirements, tests, test resources, and business 
components. For more information on working with business components 
in a version control enabled project, refer to the HP Business Process Testing 
User Guide.
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You check out an entity to make changes. Then you check in the entity to 
store the changes, and make the new version of the entity available to other 
users. You can view and compare previous versions of an entity, or check out 
a previous version.

For information on enabling version control for a project, refer to the 
HP Quality Center Administrator Guide.

Version Control Overview

To make changes to an entity in a version control enabled project, you must 
first check out the entity. When you check out an entity, Quality Center 
locks the entity, preventing other users from overwriting any changes you 
make. The checked out version of the entity is not visible to other users. For 
more information, see “Checking Out Entities” on page 104.

When you finish making changes, you check in the entity. The new version 
of the entity is then available to the other users. For more information, see 
“Checking In Entities” on page 106.

The default version number for a new entity is 1. Prior to Quality Center 
10.00, version numbers consisted of three segments separated by periods, 
such as 1.7.4. From Quality Center 10.00, version numbers consist of a 
single segment, such as 12. When an entity is checked in, the version 
number is increased by one.

When an entity is checked out, you can undo the checkout to cancel your 
changes. For more information, see “Undoing Check Outs” on page 107.

You can view all previous versions of an entity, or check out an earlier 
version. You can also compare two versions of an entity to view the changes 
between versions. For more information on viewing previous versions of an 
entity, see “Viewing Version History” on page 109.
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Note: To maintain usability and data integrity, Quality Center stores 
previous versions of an entity without most data related to relationships 
between entities. The following data is not stored for previous versions: 
requirements and tests coverage, requirements traceability, and defect 
linkage. In addition, risk data is also not stored for previous versions of an 
entity.

You can view the list of all entities that you have checked out in your 
project. For more information, see “Viewing Checked Out Entities” on 
page 108.

You can create and manage entities in a version control enabled project in 
both tree and grid views. In the tree view, an entity checked out by the 
current user is displayed with an open green lock icon . An entity checked 
out by another user is displayed with a red lock icon . Grid views contain 
additional version control fields, such as Version Status, indicating whether 
the entity is checked in or checked out.



Chapter 7 • Working with Version Control

102

The following table provides additional information about working with 
version control in the Quality Center modules.

You can define filters based on version control fields. For more information, 
see “Filtering Version Control Fields” on page 112.

Module Creating a New Entity Version Control Fields

Requirements When you create a new 
requirement, Quality 
Center automatically 
checks out the 
requirement.

The Requirements 
module contains 
additional version 
control fields. For more 
information, see “The 
Requirement Fields” on 
page 171.

Test Plan When you create a new 
test, you have the option 
to immediately check 
out the test. For more 
information, see 
“Adding Tests to a Test 
Plan Tree” on page 266.

The Test Plan module 
contains additional 
version control fields. 
For more information, 
see “Test Grid Columns” 
on page 260.

Test Resources When you create a new 
test resource, Quality 
Center automatically 
checks out the resource.

The Test Resources 
module contains 
additional version 
control fields. For more 
information, see 
“Updating Details of 
Resources and Folders” 
on page 344.

Test Lab N/A In the Test Instance 
Properties dialog box, 
the Run VC Version field 
indicates the version 
number of the test. The 
following fields are not 
in use in this version of 
Quality Center:  Run VC 
Status and  Run VC User.
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The Requirements, Test Plan, and Test Resources module toolbars display the 
following additional buttons for checking in and checking out entities:

➤ Check Out. Opens the Check Out dialog box, enabling you to check out 
the selected entity.

➤ Check In. Opens the Check In dialog box, enabling you to check in the 
selected entity.

Non-versioned Fields

Changes to the following fields are not stored under version control:

➤ Requirement fields: Reviewed, Direct Cover Status, Target Release, Target 
Cycle, and all RBQM fields.

➤ Test fields: Execution Status.

Consider the following when working with non-versioned fields in a version 
control enabled project:

➤ When you undo a checkout, any changes you made to non-versioned fields 
while the entity was checked out are not cancelled and the new values 
remain.

➤ When you check out a previous version, the value of a non-versioned field is 
the value in the currently checked in version.

➤ When you view and compare previous versions of an entity, non-versioned 
fields are displayed with the value Non-versioned Field.

Version Control Examples

The following examples demonstrate how you can use version control.

➤ Monitor changes and compare versions.

The product manager finds that product development is being implemented 
differently than he had expected. He reviews the requirements for the 
product and discovers that some have changed. He compares the current 
requirements with the versions of the requirements that were agreed upon 
at the start of the release.
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➤ Restore an earlier version.

A QA tester receives a new build of the banking application currently being 
developed. She starts to update the relevant tests to meet the needs of the 
new release. Then the development team sends out notification of a 
significant problem with the build. Development rolls back to the previous 
build. The tester decides to check out and revert back to the versions of tests 
that were used for the previous build and continue testing from there.

➤ Lock entities for editing.

A business analyst wants to update certain functionality for an application. 
To do this, he needs to update a set of requirements. He requires several days 
to update the requirements, and doesn’t want anyone else to make any 
changes to the requirements while he is editing them. He checks out the 
relevant requirements, and starts to edit.

Checking Out Entities

You check out an entity in a version control enabled project to make 
changes to the entity. When you check out an entity, Quality Center locks 
the entity, preventing other users from overwriting any changes you make. 
The checked out version of the entity is not visible to other users.

You can check out an entity in the following ways:

➤ Checking Out Entities Automatically

➤ Checking Out Entities Manually
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Checking Out Entities Automatically
When you start to make changes to an entity in a version control enabled 
project, Quality Center initiates an automatic check out of the entity.

To check out an entity automatically:

 1 Select an entity and start to edit. The Check Out dialog box opens.

 2 In the Change Comments box, type a brief description of the reason for the 
checkout.

 3 Select Don’t show this again to instruct Quality Center to automatically 
check out entities that you start editing, without requesting confirmation.

To instruct Quality Center to display the confirmation message before 
automatically checking out entities, from the menu bar, select Versions > 
Warn Before Check Out.

 4 Click OK. In the tree view, the entity is displayed with a lock icon  
indicating that it is checked out.

Checking Out Entities Manually
You can check out one or more entities in a version control enabled project 
to make changes to the entities.

To check out an entity manually:

 1 Select the entity that you want to check out. To check out more than one 
entity, press the CTRL key and select the entities.
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 2 Click the Check Out button, or select Versions > Check Out. Alternatively, 
right-click the entity and select Versions > Check Out. The Check Out dialog 
box opens.

 3 In the Change Comments box, type a brief description of the reason for the 
checkout.

 4 Click OK. In the tree view, the entity is displayed with a lock icon  
indicating that it is checked out.

Checking In Entities

After you make changes to an entity, you check in the entity. Each time you 
check in an entity, a new version is created. For example, suppose the 
current version of a requirement is version number 3. You check the 
requirement out and make some changes. When you check the requirement 
in, Quality Center defines it as version number 4. When the entity is 
checked in, it is unlocked and available to other users.

You can also view a list of all entities you have checked out in the current 
module. For more information, see “Viewing Checked Out Entities” on 
page 108.

To check in an entity:

 1 Select the entity that you want to check in. To check in more than one 
entity, press the CTRL key and select the entities.
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 2 Click the Check In button, or select Versions > Check In. Alternatively, 
right-click the entity and select Versions > Check In. The Check In dialog 
box opens.

 3 In the Change Comments box, type a brief description of the changes that 
were made to this version.

 4 Select Keep checked out to store your changes with the new version number 
while keeping the entity checked out.

 5 Click OK.

Undoing Check Outs

When an entity is checked out, you can undo the checkout to cancel your 
changes. To undo checkouts for entities checked out by other users, you 
must have the appropriate user permissions. For more information, refer to 
the HP Quality Center Administrator Guide.

When you undo a checkout, any changes you made to non-versioned fields 
while the entity was checked out are not cancelled and the new values 
remain. For more information, see “Non-versioned Fields” on page 103.

You can view a list of all entities you have checked out in the current 
module. For more information, see “Viewing Checked Out Entities” on 
page 108.
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To undo a checkout:

 1 Select an entity, or press the CTRL key and select multiple entities for which 
you want to undo the checkout.

 2 Select Versions > Undo Check Out, or right-click the entity and select 
Versions > Undo Check Out.

 3 Click Yes to confirm.

Viewing Checked Out Entities

You can view a list of all entities in the current module that you have 
checked out, and check in or undo the check out for selected entities.

To view checked out entities:

 1 Select Versions > Pending Check In, or click the Check In button on the right 
side of the module toolbar. The Pending Check In dialog box opens, 
displaying a list of all entities checked out by the current user in the current 
module.

You can rearrange columns by dragging the column headers.
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 2 To check in an entity, select an entity from the list, or press the CTRL key and 
select multiple entities. Click Check In. For more information, see “Checking 
In Entities” on page 106.

 3 To undo a checkout, select an entity from the list, or press the CTRL key and 
select multiple entities. Click Undo Check Out. For more information, see 
“Undoing Check Outs” on page 107.

Viewing Version History

You can view the history for a selected entity, including all previous 
versions, the name of the user who created each version, and the date each 
version was created. You can also compare two versions, or check out a 
previous version.

You can also view the baseline in which a version is stored. For more 
information, see “Viewing Baseline History” on page 524.
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To view version history:

 1 Select an entity and click the History tab. The version history for the entity 
is displayed.

 2 In the Versions and Baselines tab, in the View by box, select Versions. The 
version history for the entity is displayed in a grid.

 3 Under Comment for selected version, view the comments typed by the user 
when checking in the version.

Column Description

Version The version number. If the entity is currently checked 
out, the Version column for the checked out version 
displays Checked out.

Date The date the version was created.

Modified By The user who created the version.

Baseline The baseline in which the version appears.
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 4 To view details of a previous version, select the version and click View. A 
Details dialog box opens, displaying read-only details for the version. For 
example, you can view details for a previous version of a test.

Click a button on the sidebar to view additional details for the version, such 
as the Design Steps, Test Script and Attachments. The buttons available 
depend on the data stored under version control for the particular entity 
type.

Changes to some fields are not stored under version control. For more 
information, see “Non-versioned Fields” on page 103.

Click Close to close the Details dialog box.

 5 To compare two versions, press the CTRL key and select each version. Click 
Compare. For more information on comparing entity versions, see 
“Comparing Entities” on page 528.



Chapter 7 • Working with Version Control

112

 6 To check out a previous version, select the version and click Check Out. For 
more information on the check out process, see “Checking Out Entities” on 
page 104.

Note: To maintain usability and data integrity, Quality Center stores 
previous versions of an entity without most data related to relationships 
between entities. The following data is not stored for previous versions: 
requirements and tests coverage, requirements traceability, and defect 
linkage. In addition, risk data is also not stored for previous versions of an 
entity.

The Confirm dialog box opens. Click Yes to confirm.

Filtering Version Control Fields

You can filter Quality Center data based on version control fields in the 
Requirements, Test Plan, Test Resources, and Test Lab modules. For more 
information on defining filters, see “Filtering Records” on page 56.

Defining a filter to display only checked out entities varies depending on 
the Quality Center module in which you are working. The following table 
describes how to set the filter conditions:

For more information on version control fields, see the “Version Control 
Overview” on page 100.

Filter Description
Filter Conditions for the 
Test Plan Module

Filter Conditions for All 
Other Modules

Display all entities 
that you have 
checked out

Version Status=Checked 
Out and Version 
Owner=<your user name>

Version Checked Out 
By=<your user name>

Display all entities 
checked out by 
another user

Version Status=Checked 
Out and Version 
Owner=<other user’s user 
name>

Version Checked Out 
By=<other user’s user 
name>
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8
The Release Management Workflow

You begin the application management process by defining a releases tree in 
the Releases module. 

Quality Center Editions: The Releases module is available for Quality Center 
Enterprise Edition and Quality Center Premier Edition.
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This chapter describes how you use Quality Center to manage the release life 
cycle. The release management workflow consists of the following stages.

Defining Releases and Cycles

The foundation of the Releases module is the releases tree. This tree enables 
the modeling of upcoming releases within a hierarchical tree structure. 

You start by defining a release folder along with its releases. A release 
represents a group of changes in one or more applications that will be 
available for distribution at the same time. After defining the release, you 
define cycles. A cycle is a set of development and quality assurance efforts 
performed to achieve a common goal based on the release timeline.

Define Releases and 
Cycles

Assign
Requirements

Assign and Run 
Test Sets

Assign Defects

Analyze
Releases and Cycles
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For example, suppose you are defining upcoming releases for the sample 
Mercury Tours application. The Mercury Tours Application folder contains 
Release 10.5. This release includes four cycles. You might define the releases 
and cycles in the releases tree as follows:

For more information on defining releases, see Chapter 10, “Creating a 
Releases Tree.”

Assigning Requirements

After defining the releases tree, you define and review the requirements in 
the Requirements module and assign them to releases and cycles. 
Requirements describe in detail your application needs. 

For example, in the requirements tree, under the Mercury Tours Application 
folder, you might assign Booking System and Application Security to the 
Cycle 1 - New Features cycle in the Release 10.5 release.

Requirements are used as a basis for the test plan in the Test Plan module. 
The tests you create during the test plan phase should cover these 
requirements. 
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For more information on requirements, see Chapter 13, “Developing the 
Requirements Tree.”

For more information on test plans, see Chapter 18, “Developing the Test 
Plan Tree.” For more information on coverage, see Chapter 19, 
“Requirement and Test Coverage.”

Assigning and Running Test Sets

After assigning requirements to releases and cycles, you assign each test set 
folder in the Test Lab module to a cycle. A test set is a group of test instances 
in a Quality Center project designed to achieve specific test goals.

For example in the test set tree, you might define the following test set 
folders for Release 10.5.

Each test set folder is assigned to a cycle. For example, the Cycle 1 test set 
folder is assigned to the Cycle 1 - New Features cycle. 

After assigning test set folders to a cycle, you run the test sets under these 
test set folders. 

For more information on test sets, see Chapter 28, “Creating Test Sets.” For 
more information on running tests, see Chapter 30, “Running Tests 
Manually” and Chapter 31, “Running Tests Automatically.”



Chapter 8 • The Release Management Workflow

119

Assigning Defects

If an application flaw is detected while running a test set, you can submit a 
defect. Quality Center automatically creates a link between the test run, 
associated release and cycle, and the new defect. 

Suppose a defect is detected while running a test instance from a test set in 
the Cycle 1 test set folder. When the defect is initially submitted to the 
project, the Detected in Release field is assigned to the Release 10.5 release, 
and the Detected in Cycle field is assigned to the Cycle 1 - New Features 
cycle. 

While reviewing and deciding which new defects need to be fixed, they can 
be assigned to the appropriate target release and cycle. 

Continuing with this example, suppose this defect is planned to be fixed in 
the next cycle. The Target Release field would be assigned to Release 10.5, 
and the Target Cycle field would be assigned to Cycle 2 - New Features + 
Regression. 

A defect can be submitted to a Quality Center project from any module at 
any stage of the application management process.

For more information on submitting defects, see Chapter 35, “Adding and 
Tracking Defects.”

Analyzing Releases and Cycles

Following test runs, you can review the test progress to determine how well 
it meets the release goals. You can also determine how many defects were 
resolved, and how many still remain open. The results can be analyzed at a 
release or at a cycle level. 

You can track the progress of the application management process in real 
time by analyzing the releases tree and ensuring that it matches the release 
goals. For more information on analyzing results at a release or at a cycle 
level, see Chapter 10, “Creating a Releases Tree.”
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9
The Releases Module at a Glance

This chapter introduces the key elements in the Releases module.

Quality Center Editions: The Releases module is available for Quality Center 
Enterprise Edition and Quality Center Premier Edition.

This chapter includes:

 ➤  The Releases Module on page 122

 ➤  The Releases Menu Bar on page 123

 ➤  The Releases Toolbar on page 123

 ➤  The Release and Cycle Fields on page 124
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The Releases Module

You define releases and cycles in Quality Center using the Releases module. 
To display this module, click the Management button on the sidebar and 
then click the Releases tab.

The Releases module contains the following key elements:

➤ Releases menu bar. Displays drop-down menus of Releases module 
commands. 

➤ Releases toolbar. Contains buttons of Releases module commands. 

➤ Details tab. Describes the release folder, release, or cycle currently selected in 
the releases tree. It also indicates range of release and cycle dates. The 
Statistics pane displays the requirements and test set folders associated with 
the release or cycle.

➤ Attachments tab. Lists attachments that provide additional information on 
the currently selected release folder, release, or cycle. For more information, 
see Chapter 5, “Adding Attachments”.
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➤ Progress tab. Shows a high-level overview of the progress of your release or 
cycle. For more information, see “Viewing Coverage Progress of Releases and 
Cycles” on page 137.

➤ Quality tab. Shows the number of defects opened over the course of your 
release or cycle. It also shows the number of outstanding defects. For more 
information, see “Viewing Defects of Releases and Cycles” on page 141.

The Releases Menu Bar 

The Releases menu bar contains the following menus.

➤ The Releases menu contains commands that enable you to add release 
folders, releases, and cycles. 

➤ The Edit menu contains commands that enable you to cut, paste, delete, 
and rename release folders, releases, and cycles. It also contains a command 
to create a duplicate of a cycle.

➤ The View menu contains commands that enable you to expand and collapse 
the releases tree. It also contains a command to refresh the releases tree.

The Releases Toolbar 

The Releases toolbar contains the following buttons:

New Release Folder. Adds a new release folder to the releases tree. 

New Release. Adds a new release to the releases tree. 

New Cycle. Adds a new cycle to the releases tree.

Cut. Cuts a release folder or a release from the releases tree to move it to a 
different location in the tree.

Paste. Pastes a cut release folder or a release to the specified location in the 
tree.

Duplicate Cycle. Creates a duplicate of a cycle within the same release.
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Delete. Deletes the selected item. Deleting a release folder also deletes its 
releases and cycles. Deleting a release also deletes its cycles.

Refresh All. Refreshes the releases tree and tabs so that it displays the most 
up-to-date data.

The Release and Cycle Fields 

The Details tab of the Releases module can display the following fields:

Field Description

Name The release folder, release, or cycle name.

Start Date The date on which the release or cycle starts. Click the down 
arrow to display a calendar and select a start date.

End Date The date on which the release or cycle ends. Click the down 
arrow to display a calendar and select an end date.

Release ID A unique numeric ID for the release, assigned automatically by 
Quality Center. The Release ID is read-only. 

Cycle ID A unique numeric ID for the cycle, assigned automatically by 
Quality Center. The Cycle ID is read-only. 

Statistics Statistics on the requirements and test set folders assigned to 
your releases and cycles.

Description The release folder, release, or cycle description.
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Notes: 

➤ The dates for the cycles must be contained within the dates for the 
releases.

➤ You can add user-defined fields and change the label of any of the fields 
in the Releases module. For more information, refer to the 
HP Quality Center Administrator Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Releases module. For more information, refer to 
the HP Quality Center Administrator Guide.



Chapter 9 • The Releases Module at a Glance

126



127

10 
Developing the Releases Tree

The issuing of application releases is often challenging. It requires aligning 
your business priorities and quality expectations with your project 
requirements, tests, and defects. Most applications require testing on 
multiple hardware platforms, multiple configurations (computers, operating 
systems, and browsers), and multiple application versions. Managing all 
aspects of an application release can be time-consuming and difficult. In the 
Releases module, you can organize and track your upcoming releases by 
defining a releases tree.

Quality Center Editions: The Releases module is available for Quality Center 
Enterprise Edition and Quality Center Premier Edition.

This chapter includes:

 ➤  About Developing the Releases Tree on page 128

 ➤  Creating a Releases Tree on page 133

 ➤  Adding Releases to Release Folders on page 134

 ➤  Adding Cycles to Releases on page 134

 ➤  Viewing Assigned Requirements and Test Set Folders on page 136

 ➤  Viewing Coverage Progress of Releases and Cycles on page 137

 ➤  Viewing Defects of Releases and Cycles on page 141

 ➤  Modifying the Releases Tree on page 143



Chapter 10 • Developing the Releases Tree

128

About Developing the Releases Tree 

In the Releases module, you can organize and track your upcoming releases 
by defining a hierarchical releases tree containing releases and cycles. A 
release represents a group of changes in one or more applications that will 
be available for distribution at the same time. Each release can contain a 
number of cycles. A cycle represents a development and QA cycle based on 
the project timeline. Both releases and cycles have defined start and end 
dates.

After defining the releases tree, you define requirements in the 
Requirements module and assign them to releases and cycles (see 
Chapter 13, “Developing the Requirements Tree”). Requirements describe in 
detail what needs to be tested in your application.

To cover your requirements (making sure that all of the features developed 
in a particular cycle are fully tested), you create tests in the Test Plan module 
(see Chapter 18, “Developing the Test Plan Tree” and Chapter 19, 
“Requirement and Test Coverage”).

Then in the Test Lab module, you create a test set folder to store your test 
sets. Next, you assign the test set folder to a cycle. You then add test sets to 
your test set folder. Finally, you complete the test coverage planning by 
adding tests to each test set (see Chapter 28, “Creating Test Sets”).

You then run your test sets (see Chapter 30, “Running Tests Manually,” and 
Chapter 31, “Running Tests Automatically”). If application flaws are 
detected, you can submit defects, which you assign to a particular release 
and cycle in the releases tree (see Chapter 35, “Adding and Tracking 
Defects”). This enables all relevant developers and testers to determine what 
needs to be fixed and the target date for each fix. 

After running the specified test sets, you can review the release progress in 
the Releases module to determine how well it meets your release goals. You 
can also determine how many defects were detected and how many defects 
are outstanding. You can analyze results at the level of a release or a cycle.
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Release Management Example

Suppose you are developing a flight reservation application. In four months, 
you plan on releasing version 10.5. Your release includes four cycles. The 
first cycle is for testing new features. The second cycle is for regression 
testing. The third cycle is for sanity testing. The fourth cycle verifies the full 
functionality of the application. Your releases tree may be defined as 
follows:

In the Requirements module, you decide which requirements need to be 
covered in each cycle and assign them to the relevant cycles accordingly. In 
the Test Plan module, you then create tests and associate them with the 
assigned requirements to create coverage. 

In the Test Lab module, you create test set folders and assign them to 
specific cycles. For this example, you might define the Cycle 1, Cycle 2, 
Cycle 3, and Cycle 4 test set subfolders:

When you assign a test set folder to a cycle, the test set folder icon  is 
replaced by the assigned test set folder icon .
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For each assigned test set folder, you then create test sets and add tests to 
them, for example:

After running the test sets from the assigned test set folders, you can review 
the progress in the Progress tab of the Releases module to determine how 
well it meets your release goals. This provides you with a high-level 
overview of the progress of your release. 



Chapter 10 • Developing the Releases Tree

131

The following shows the progress in the Release 10.5 example:

The top pane shows the total and remaining days in the release, total test 
instances for the release, actual and remaining test instances to run, and 
more. 

The bottom pane displays the Coverage Progress graph. The curves 
displayed in this graph are accumulative, that is, each curve is calculated by 
accumulating all the release information from the beginning of the release. 

The Assigned requirements curve indicates the distribution of the assigned 
requirements within the release's cycles. In this example, the curve indicates 
a 100% value in the Cycle 4 - Full cycle. 

The Planned coverage curve below the Assigned requirements curve 
indicates the percentage of requirements that are covered throughout the 
release. In this example only 60% of the requirements are covered in the 
Cycle 4 - Full cycle.
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The Executed coverage curve below the Planned coverage curve indicates 
the percentage of tests that were run as the release progressed. In this 
example, the curve indicates that at Cycle 4 - Full only 40% of the assigned 
tests were run.

The Passed coverage curve is below the Executed coverage curve. It 
indicates the test runs in which the most recent status is passed. In this 
example, the curve indicates a 20% value in the Cycle 4 - Full cycle.

For each cycle, you can view the number of defects submitted and their 
severity in the Quality tab. Suppose that while running the Cycle 1 test set 
under the Release 10.5 test set folder, four application flaws are detected. In 
the Releases tree, you would select Cycle 1 - New Features cycle and click 
the Quality tab to view the number of defects opened over the course of the 
cycle. The defects are categorized by severity level, ranging from 1-Low to 
5-Urgent.
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In the Defect Opening Rate graph, you can see that out of the four defects 
detected while testing the first cycle, two defects are assigned a severity 
value of 3-High, one defect is assigned 5-Urgent, and one defect is assigned 
2-Medium.

In the Outstanding Defects graph, you can see that two out of the four 
defects are still outstanding. One defect is assigned 2-Medium the other 
defect is assigned 3-High.

Creating a Releases Tree

You define a hierarchical framework for your releases by creating a releases 
tree. For each release folder in the tree, you define releases and add cycles to 
them. You start a releases tree by adding a folder under the Releases root 
folder.

To create a releases tree:

 1 In the releases tree, select the Releases folder.

 2 Click the New Release Folder button or choose Releases > New Release 
Folder. The New Release Folder dialog box opens.

 3 Type the Release Folder Name and click OK. The new folder is added under 
Releases in the releases tree.

 4 In the Details tab, type a description for the release folder.

 5 Click the Attachments tab to add an attachment to the folder if necessary. 
An attachment can be a file, URL, snapshot of your application, an item 
from the Clipboard, or system information. For more information, see 
Chapter 5, “Adding Attachments.”

 6 To create additional folders, select a folder and repeat steps 2 to 5.
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Adding Releases to Release Folders

After creating the releases tree, you add releases to your release folders. For 
each defined release, you add cycles.

To add a release to a release folder:

 1 Select a release folder in the releases tree.

 2 Click the New Release button or choose Releases > New Release. The New 
Release dialog box opens. 

 3 Type the Release Name and click OK. The new release appears under the 
selected release folder.

 4 Enter the following release details in the Details tab:

 5 Click the Attachments tab to add an attachment to the release if necessary. 
An attachment can be a file, URL, snapshot of your application, an item 
from the Clipboard, or system information. For more information, see 
Chapter 5, “Adding Attachments.”

 6 To create additional releases, select a release folder and repeat steps 2 to 5.

Adding Cycles to Releases

After adding releases to your release folders, you add cycles to each release.

To add a cycle to a release:

 1 Select a release in the releases tree.

 2 Click the New Cycle button or choose Releases > New Cycle. The New Cycle 
dialog box opens. 

Field Description

Start Date The date on which the release starts. Click the down arrow to 
display a calendar and select a start date.

End Date The date on which the release ends. Click the down arrow to 
display a calendar and select an end date.

Description Type a description of the release.
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 3 Type the Cycle Name and click OK. The new cycle appears under the 
selected release.

 4 Enter the following cycle details in the Details tab:

The dates for the cycles must be contained within the dates of the releases.

 5 Click the Attachments tab to add an attachment to the cycle if necessary. An 
attachment can be a file, URL, snapshot of your application, an item from 
the Clipboard, or system information. For more information, see Chapter 5, 
“Adding Attachments.”

 6 To create additional cycles, select a release and repeat steps 2 to 5.

Field Description

Start Date The date on which the cycle starts. Click the down arrow to 
display a calendar and select a start date.

End Date The date on which the cycle ends. Click the down arrow to 
display a calendar and select an end date.

Description Type a description of the cycle.
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Viewing Assigned Requirements and Test Set Folders

You can view statistics on the requirements and test set folders assigned to 
your releases and cycles.

To view assigned requirements for a release or a cycle:

 1 In the releases tree, select a release or a cycle.

 2 Click the Details tab. The details for the release or cycle are displayed.

 3 If you select a release, under the Statistics area, you can view the following 
statistics:

Option Description

Requirements assigned to 
release

Displays the number of requirements associated 
with the selected release. To view the requirements 
assigned to the release in the Requirements 
module, click the link displaying the number of 
requirements. Alternatively, in the releases tree, 
right-click the release and choose Show 
Requirements.
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If you select a cycle, under the Statistics area, you can view the following 
statistics:

Viewing Coverage Progress of Releases and Cycles

The Progress tab displays statistics and graphs to provide visual indications 
of the current progress of your release or cycle. This tab shows information 
such as elapsed and remaining days, completed and remaining test 
instances to run, and actual and required execution rate. 

To view coverage progress of a release or a cycle:

 1 Select a release or a cycle in the releases tree.

Option Description

Requirements assigned to 
cycle

Displays the number of requirements associated 
with the selected cycle. To view the requirements 
assigned to the cycle in the Requirements module, 
click the link displaying the number of 
requirements. Alternatively, in the releases tree, 
right-click the cycle and choose Show 
Requirements.

Test set folders assigned to 
cycle

Displays the number of test set folders associated 
with the selected cycle. To view the test set folders 
assigned to the cycle in the Test Lab module, click 
the link displaying the number of test set folders. 
Alternatively, in the releases tree, right-click the 
cycle and choose Show Test Set Folders.
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 2 Click the Progress tab.

For each release, you can view the following information in the top pane of 
the Progress tab:

Option Description

Total days in release The total number of days in a selected release (end 
date - start date). 

Remaining days in 
release

The total number of days remaining in a selected 
release.

Total test instances for 
release

The total number of test instances included in the 
test set folders assigned to a selected release.

Remaining test 
instances to run

The total number of test instances included in the 
assigned test set folders of a selected release that 
have not yet run.

Required execution rate 
(test instances/day)

The average number of test instance runs required 
per day for the remaining days in a selected release.

Actual execution rate 
(test instances/day)

The average number of test instance runs per day 
in the selected release up to the current date.
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For each cycle, you can view the following information in the top pane of 
the Progress tab:

Days (progress bar) The percentage of days elapsed in a selected release.

Test Instance Runs 
(progress bar)

The percentage of test instance runs completed in a 
selected release.

Option Description

Total days in cycle The total number of days in a selected cycle (end 
date - start date). 

Remaining days in cycle The total number of days remaining in a selected 
cycle.

Total test instances for 
cycle

The total number of test instances included in the 
test set folders assigned to a selected cycle.

Remaining test 
instances to run

The total number of test instances included in the 
assigned test set folders of a selected cycle that have 
not yet run.

Required execution rate 
(test instances/day)

The average number of test instance runs required 
per day for the remaining days in a selected cycle.

Actual execution rate 
(test instances/day)

The average number of test instance runs per day 
in the selected cycle up to the current date.

Days (progress bar) The percentage of days elapsed in a selected cycle.

Test Instance Runs 
(progress bar)

The percentage of test instance runs completed in a 
selected cycle.

Option Description
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 3 To customize the Coverage Progress graph for a selected release, select or 
clear the check boxes for the following options:

 4 To customize the Coverage Progress graph for a selected cycle, select or clear 
the check boxes for the following options:

 5 To refresh the data in the Progress tab, click the Refresh All button. 

Option Description

Assigned requirements The accumulated percentage of requirements 
assigned to all cycles within a release. 

Planned coverage The accumulated percentage of tests planned for all 
cycles within a release. 

Executed coverage The accumulated percentage of tests that ran in all 
cycles within a release. 

Passed coverage The accumulated percentage of tests that ran 
successfully in all cycles within a release. 

Option Description

Planned coverage The percentage of tests planned to be run each day 
within a cycle.

Executed coverage The percentage of tests that ran each day within a 
cycle.

Passed coverage The percentage of tests that ran successfully each 
day within a cycle.
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Viewing Defects of Releases and Cycles

The Quality tab helps you draw conclusions quickly and see the number of 
defects submitted over the course of a release or cycle. The defects are 
categorized by severity in terms of how they impact system operation. The 
severity level ranges from Low-1 to Urgent-5. You can view the graphs at 
any stage of the application management process to check the progress of 
your release.

For each release, you can view the following graphs in the Quality tab:

Graph Description

Defect Opening 
Rate

Displays the number of defects opened over the course of a 
release. The graph displays defects whose Detected in Release 
value matches the selected release. The defects are grouped 
according to their level of Severity. The x-axis displays the 
number of defects according to their severity on the last day 
of each cycle. 

Outstanding 
Defects

Displays the number of outstanding defects for the selected 
release. The graph displays defects whose Target Release 
value matches the selected release or is empty. The defects are 
grouped according to their level of Severity. The x-axis 
displays the number of outstanding defects according to their 
severity on the last day of each cycle. By default, New, Open, 
and Reopened defects are considered outstanding. 
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For each cycle, you can view the following graphs in the Quality tab:

To view the defects for a release or a cycle:

 1 Select a release or a cycle in the releases tree.

 2 Click the Quality tab.

The tab displays the Defect Opening Rate and Outstanding Defects graphs 
for the selected release or cycle.

Graph Description

Defect Opening 
Rate

Displays the number of defects opened over the course of a 
cycle. The graph displays defects whose Detected in Cycle 
value matches the selected cycle. The defects are grouped 
according to their level of Severity. The x-axis displays the 
number of existing defects for each date.

Outstanding 
Defects

Displays the number of outstanding defects for a cycle. The 
graph displays defects whose Detected in Cycle value matches 
the selected cycle. The defects are grouped according to their 
level of Severity. The x-axis displays the number of existing 
defects that are outstanding on each date. By default, New, 
Open, and Reopened defects are considered outstanding.
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 3 In the Defect Opening Rate graph, you can select or clear the check boxes of 
the defect severity levels displayed in this graph.

 4 In the Outstanding Defects graph, you can:

➤ Select or clear the check boxes of the defect severity levels displayed in 
this graph.

➤ Determine which defects are displayed in the graph by filtering them by 
their status. Click Configure Outstanding Defects. In the Configure 
Outstanding Defects dialog box, select a defect status and click the arrow 
buttons (> and <) to move it between Available Defect Status and Visible 
Defect Status. To move all of the types from one list to the other, click 
the double arrow buttons (>> and <<). Click OK. 

 5 To refresh the data in the Quality tab, click the Refresh All button. 

Modifying the Releases Tree

This section on modifying the releases tree includes the following topics:

➤ Renaming Release Folders, Releases, and Cycles

➤ Moving Release Folders and Releases

➤ Duplicating Cycles

➤ Deleting Release Folders, Releases, and Cycles

Renaming Release Folders, Releases, and Cycles
You can rename a release folder, release, or cycle.

To rename a release folder, release, or cycle:

 1 Select an item from the releases tree.

 2 Choose Edit > Rename. Alternatively, right-click the release folder, release, or 
cycle and choose Rename.

 3 Edit the item name and press ENTER. 
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Moving Release Folders and Releases
You can move a release folder or a release to a different location in the 
releases tree. Moving a release folder also moves its releases and cycles. 
Moving a release also moves its cycles. The Releases root folder cannot be 
moved. 

Tip: You can also move a release folder or a release to a new location in the 
releases tree by dragging it.

To move a release folder or a release:

 1 Select a release folder or a release from the releases tree. To move more than 
one item, press the CTRL key and select the items you want to move.

 2 Click the Cut button. Alternatively, choose Edit > Cut.

 3 Select a folder in the releases tree.

 4 Click the Paste button. Alternatively, choose Edit > Paste.

Duplicating Cycles
You can create a duplicate of a cycle within the same release. 

To duplicate a cycle:

 1 Select a cycle from the releases tree. 

To duplicate more than one cycle, press the CTRL key and select the cycles 
you want to duplicate. You can select only multiple cycles that belong to the 
same release.

 2 Click the Duplicate Cycle button. Alternatively, choose Edit > Duplicate 
Cycle. A duplicate copy is added to the release.
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Deleting Release Folders, Releases, and Cycles
You can delete a release folder, release, or cycle. When you delete a folder, 
the releases and cycles under the folder are also deleted. When you delete a 
release, the cycles under it are also deleted.

Note: Deleting a release folder, release, or cycle, also unassigns the 
associated requirements, test set folders, and defects.

To delete a release folder, release, or cycle:

 1 Select an item from the releases tree. To delete more than one item, press the 
CTRL key and select the items you want to delete.

 2 Click the Delete button. Alternatively, choose Edit > Delete. A confirmation 
message displays.

 3 Click Yes to confirm. The items are deleted.
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Part III

Requirements Specification
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11
The Requirements Specification 
Workflow

Requirements describe in detail what needs to be solved or achieved to meet 
the objectives of your application under development.

This chapter describes how you use the Requirements module to specify 
requirements. The requirements specification workflow consists of the 
following: 

Define
Scope

Create
Requirements

Detail
Requirements

Assign to
Releases

Analyze
Requirements

Establish
Baseline
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Quality Center Starter Edition: Not all fields and functionality in the 
Requirements module are available if you are working with the Starter 
Edition. 

Defining the Requirements Scope

You begin the application life cycle management process by gathering all 
available documentation on the application under development, such as 
marketing and business requirements documents, system requirement 
specifications, and design documents. 

Use these documents to obtain a thorough understanding of the application 
under development and determine your scope, goals, objectives, and 
strategies.

For example, some questions you may want to ask are:

➤ What is the main purpose and direction of the application?

➤ What are the critical constraints of the application?

➤ What are the major features of the application?

➤ What is the relative importance of each element in the application 
functionality?

➤ What are the critical or high-risk functions of the application?

➤ What are your business or testing priorities? 

➤ Do your customers/end-users agree with your priorities?

➤ What are your overall quality goals?
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Creating the Requirements Outline

You use the requirements scope to determine the overall requirements for 
the application under development. You then define different groups of 
requirements based either on requirement type or functional area. 
Requirement groups are recorded in the Requirements module by creating a 
requirements tree. The requirements tree is a graphical representation of 
your requirements specification, displaying the hierarchical relationship 
between different requirements.

For example, consider a flight reservation application that lets you manage 
flight scheduling, passenger bookings, and ticket sales. You may define your 
major requirements as: Online Travel Booking Services, Online Travel 
Information Source, Profile Management, Reservation Management, 
Booking System, Application Security, Application Usability, Application 
Client System, and Application Performance. 

For more information, see Chapter 13, “Developing the Requirements Tree.”
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Detailing Requirements

For each requirement group, you create a list of detailed requirements in the 
requirements tree. For example, the Profile Management requirement can 
be broken down into the following requirements: 

Each requirement in the tree is described in detail and can include any 
relevant attachments. You then assign the requirement a priority level 
which can be taken into consideration when creating the test plan. 

After defining your requirements, you can add traceability between the 
requirements. When analyzing the impact of a change proposed in a specific 
requirement, traceability shows the other requirements that the change 
might affect. For more information, see Chapter 14, “Tracing 
Requirements.”
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Assigning Requirements to Releases

You can assign the requirements to releases and cycles of the releases tree in 
the Releases module. The releases tree specifies past, current, and upcoming 
product releases within a hierarchical tree structure. A release represents a 
group of changes in one or more applications that will be available for 
distribution at the same time. A cycle is a set of development and quality 
assurance efforts performed to achieve a common goal based on the release 
timeline. For more information on assigning requirements, see “Assigning 
Requirements to Releases or Cycles” on page 182.

The assigned requirements are then used as a basis for the test plan in the 
Test Plan module. The tests you create during the test plan phase are used to 
link to these requirements to create coverage. For more information on 
requirements and tests coverage, see Chapter 19, “Requirement and Test 
Coverage.” 

Analyzing Requirements Specification

Review your requirements to ensure that they meet the scope defined 
earlier. After a requirement is approved, you change a requirement from a 
Not Reviewed status to Reviewed.

You can use risk-based quality management to help you decide how to 
allocate the resources you have available. For more information, see 
Chapter 15, “Calculating Requirement Risks.”

To help review the requirements, you can generate reports and graphs. For 
more information, see Chapter 40, “The Dashboard Module.”
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Establishing Baselines

After the requirements have been reviewed and approved, you can create a 
baseline for your requirements. A baseline can be used as an agreement that 
all stakeholders are responsible for signing off. This baseline then serves as a 
point of reference against which changes can be compared. The 
requirements baseline can be reviewed throughout the project to ensure its 
ongoing validity.

For more information on baselines, see Chapter 38, “Libraries and 
Baselines.”
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12
The Requirements Module at a Glance

This chapter introduces the key elements in the Requirements module.

This chapter includes:

 ➤  The Requirements Module on page 155

 ➤  The Requirements Menu Bar on page 167

 ➤  The Requirements Toolbar on page 169

 ➤  The Requirement Fields on page 171

The Requirements Module

You specify requirements in Quality Center using the Requirements module, 
which is opened by clicking the Requirements button on the sidebar. 

You can display requirements in the following views:

➤ Requirements Tree

➤ Requirement Details

➤ Requirements Grid

➤ Coverage Analysis
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Note: You can also import requirements to your Quality Center project from 
Microsoft Word, Excel, or other third-party requirement management tools. 
To import requirements, you must first install the appropriate 
HP Quality Center add-in. For more information, refer to the 
HP Quality Center Installation Guide. 

Quality Center Starter Edition: Not all fields and functionality in the 
Requirements module are available if you are working with the Starter 
Edition. 

Requirements Tree
The Requirements Tree view enables you to display requirements in a tree. 

The Requirements Tree view contains the following key elements:

➤ Requirements menu bar. Displays drop-down menus of Requirements 
module commands. For more information, see “The Requirements Menu 
Bar” on page 167.
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➤ Requirements toolbar. Contains buttons for commands commonly used 
when creating and modifying requirements. For more information, see “The 
Requirements Toolbar” on page 169.

➤ Indicator columns. Indicates that the specified requirement has 
attachments, linked defects, alerts, and follow up flags. Choose View > 
Indicator Columns to display these columns.

➤ Requirements tree. Displays requirements in a tree.

➤ Information Panel. Displays the following tabs: Description, Comments, 
Attachments, History, and RichContent. Choose View > Information Panel 
or click the Show arrow  to display these tabs.
 

Column Description

Attachments Click the  icon to view attachments for the 
requirement. For more information, see Chapter 5, 
“Adding Attachments.”

Linked Defects Click the  icon to view linked defects for the 
requirement. For more information, see Chapter 36, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the requirement. 
For more information, see “Viewing Alerts” on 
page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
requirement. For more information, see “Flagging 
for Follow Up” on page 82.

Tab Description

Description Displays a description of the currently selected 
requirement. 

Comments Displays comments about the currently selected 
requirement. 

Attachments Lists attachments that provide additional 
information about the currently selected 
requirement. For more information, see Chapter 5, 
“Adding Attachments”.
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Tip: To find a specific requirement by ReqID in the Requirements Tree view, 
choose Requirements > Go to Requirement, and type the requirement ID. 
To display the requirement ID, select the ReqID column using the Select 
Columns dialog box. You can only go to requirements that are in the 
current filter.

History Displays a list of changes made to the currently 
selected requirement. For more information, see 
“Viewing Requirement History” on page 193. Also 
displays a history of baselines in which the 
requirement appears. For more information, see 
“Viewing Baseline History” on page 524.

RichContent Enables you to add, view, and edit Microsoft Word 
rich text directly from Quality Center. For more 
information, see “Adding Rich Text to 
Requirements” on page 183.

Tab Description
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Requirement Details
The Requirement Details view enables you to create links between 
requirements and other entities. It also enables you to calculate and analyze 
requirement risks.

The Requirement Details view contains the following key elements:

➤ Requirements menu bar. Displays drop-down menus of Requirements 
module commands. For more information, see “The Requirements Menu 
Bar” on page 167.

➤ Requirements toolbar. Contains buttons for commands commonly used 
when creating and modifying requirements. For more information, see “The 
Requirements Toolbar” on page 169.
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➤ Indicator columns. Indicates that the specified requirement has 
attachments, linked defects, alerts, and follow up flags. Choose View > 
Indicator Columns to display these columns.
 

➤ Requirements tree. Displays requirements in a tree.

➤ Details tab. Displays details about the currently selected requirement. It also 
includes the following tabs:

For more information on the fields displayed in the Details tab, see “The 
Requirement Fields” on page 171.

➤ Requirements Traceability tab. Lists the requirements linked to the currently 
selected requirement. For more information, see Chapter 14, “Tracing 
Requirements.”

Column Description

Attachments Click the  icon to view attachments for the 
requirement. For more information, see Chapter 5, 
“Adding Attachments.”

Linked Defects Click the  icon to view linked defects for the 
requirement. For more information, see Chapter 36, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the requirement. 
For more information, see “Viewing Alerts” on 
page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
requirement. For more information, see “Flagging 
for Follow Up” on page 82.

Tab Description

Description Displays a description of the currently selected 
requirement. 

Comments Displays comments about the currently selected 
requirement. 
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➤ Test Coverage tab. Lists the tests associated with the currently selected 
requirement. For more information, see Chapter 19, “Requirement and Test 
Coverage.”

➤ Linked Defects tab. Lists the defects linked to the currently selected 
requirement. For more information, see Chapter 36, “Linking Defects.”

➤ Risk tab. Calculates and analyzes requirement risks. For more information, 
see Chapter 15, “Calculating Requirement Risks.”

➤ Attachments tab. Lists the attachments that provide additional information 
about the currently selected requirement. For more information, see 
Chapter 5, “Adding Attachments.”

➤ RichContent. Enables you to add, view, and edit Microsoft Word rich text 
directly from Quality Center. For more information, see “Adding Rich Text 
to Requirements” on page 183.

➤ History tab. Displays a list of changes made to the currently selected 
requirement. For more information, see “Viewing Requirement History” on 
page 193. Also displays a history of baselines in which the requirement 
appears. For more information, see “Viewing Baseline History” on page 524.

Tip: To find a specific requirement by ReqID in the Requirement Details 
view, choose Requirements > Go to Requirement, and type the requirement 
ID. To display the requirement ID, select the ReqID column using the Select 
Columns dialog box. You can only go to requirements that are in the 
current filter.
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Requirements Grid
The Requirements Grid view enables you to display requirements in a flat 
non-hierarchical view. Each line in the grid displays a separate requirement. 

The Requirements Grid view contains the following key elements:

➤ Requirements menu bar. Displays drop-down menus of Requirements 
module commands. For more information, see “The Requirements Menu 
Bar” on page 167.

➤ Requirements toolbar. Contains buttons for commands commonly used 
when creating and modifying requirements. For more information, see “The 
Requirements Toolbar” on page 169.
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➤ Indicator columns. Indicates that the specified requirement has 
attachments, linked defects, alerts, and follow up flags. Choose View > 
Indicator Columns to display these columns.

➤ Information Panel. Displays the following tabs: Description, Comments, 
Attachments, History, and RichContent. Choose View > Information Panel 
or click the Show arrow  to display these tabs.
 

Column Description

Attachments Click the  icon to view attachments for the 
requirement. For more information, see Chapter 5, 
“Adding Attachments.”

Linked Defects Click the  icon to view linked defects for the 
requirement. For more information, see Chapter 36, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the requirement. 
For more information, see “Viewing Alerts” on 
page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
requirement. For more information, see “Flagging 
for Follow Up” on page 82.

Tab Description

Description Displays a description for the currently selected 
requirement. 

Comments Displays comments about the currently selected 
requirement. 

Attachments Lists attachments that provide additional 
information about the currently selected 
requirement. For more information, see Chapter 5, 
“Adding Attachments”.
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Tip: To find a specific requirement by ReqID in the Requirements Grid view, 
choose Requirements > Go to Requirement, and type the requirement ID. 
To display the requirement ID, select the ReqID column using the Select 
Columns dialog box.

History Displays a list of changes made to the currently 
selected requirement. For more information, see 
“Viewing Requirement History” on page 193. Also 
displays a history of baselines in which the 
requirement appears. For more information, see 
“Viewing Baseline History” on page 524.

RichContent Enables you to add, view, and edit Microsoft Word 
rich text directly from Quality Center. For more 
information, see “Adding Rich Text to 
Requirements” on page 183.

Tab Description
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Coverage Analysis
The Coverage Analysis view enables you to analyze the breakdown of child 
requirements according to test coverage status. 

The Coverage Analysis view contains the following key elements:

➤ Requirements menu bar. Displays drop-down menus of Requirements 
module commands. For more information, see “The Requirements Menu 
Bar” on page 167.

➤ Requirements toolbar. Contains buttons for commands commonly used 
when creating and modifying requirements. For more information, see “The 
Requirements Toolbar” on page 169.
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➤ Indicator columns. Indicates that the specified requirement has 
attachments, linked defects, alerts, and follow up flags. Choose View > 
Indicator Columns to display these columns.

➤ Requirements tree. Displays requirements in a tree.

➤ Information Panel. Displays the following tabs: Description, Comments, 
Attachments, History, and RichContent. Choose View > Information Panel 
or click the Show arrow  to display these tabs.
 

Column Description

Attachments Click the  icon to view attachments for the 
requirement. For more information, see Chapter 5, 
“Adding Attachments.”

Linked Defects Click the  icon to view linked defects for the 
requirement. For more information, see Chapter 36, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the requirement. 
For more information, see “Viewing Alerts” on 
page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
requirement. For more information, see “Flagging 
for Follow Up” on page 82.

Tab Description

Description Displays a description for the currently selected 
requirement. 

Comments Displays comments about the currently selected 
requirement. 

Attachments Lists attachments that provide additional 
information about the currently selected 
requirement. For more information, see Chapter 5, 
“Adding Attachments”.
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Tip: To find a specific requirement by ReqID in the Requirement Details 
view, choose Requirements > Go to Requirement, and type the requirement 
ID. To display the requirement ID, select the ReqID column using the Select 
Columns dialog box. You can only go to requirements that are in the 
current filter.

The Requirements Menu Bar 

The Requirements menu bar has the following menus. The menus and 
commands available in the menu bar may change depending on the 
requirements view.

➤ The Requirements menu contains commands that enable you to add and 
locate requirements in the tree, generate a test from a requirement, display 
requirement details, and mail a requirement.

➤ The Edit menu contains commands that enable you to cut, copy, paste, 
rename, or delete a requirement, update selected requirements, or to find, 
replace, or search requirements. You can also view and clear alerts for 
requirements and flag requirements for follow-ups. For more information 
on alerts and follow-ups, see Chapter 4, “Alerting on Changes.”

History Displays a list of changes made to the currently 
selected requirement. For more information, see 
“Viewing Requirement History” on page 193. Also 
displays a history of baselines in which the 
requirement appears. For more information, see 
“Viewing Baseline History” on page 524.

RichContent Enables you to add, view, and edit Microsoft Word 
rich text directly from Quality Center. For more 
information, see “Adding Rich Text to 
Requirements” on page 183.

Tab Description
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➤ The View menu contains commands that enable you to set the display of 
the requirements tree or grid, filter and sort the requirements, set the 
displayed columns, and select a requirement view.

➤ The Versions menu is available in a version control enabled project. It 
contains commands that enable you to check in and check out 
requirements, undo a checkout, or view all the requirements you have 
checked out. For more information, see Chapter 7, “Working with Version 
Control.”

➤ The Favorites menu contains commands that enable you to add, organize, 
and load favorite views. For more information, see “Working with Favorite 
Views” on page 93.

➤ The Analysis menu contains commands that enable you to generate 
requirements reports and graphs. For more information on requirements 
reports, see Chapter 42, “Generating Standard Reports.” For more 
information on requirements graphs, see Chapter 41, “Generating Graphs.”

Tip: You can access the Requirements menu bar from the Requirements 
module by pressing the shortcut key F9. Additionally, you can perform 
many other Quality Center operations using shortcut keys. For a list of 
shortcut keys, see Appendix B, “Quality Center Keyboard Shortcuts.”
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The Requirements Toolbar 

The Requirements toolbar has the following buttons. The buttons available 
in the toolbar may change depending on the requirements view.

New Folder. Adds a new folder to the requirements tree. 

New Requirement. Adds a new requirement to the requirements tree. 

Delete. Deletes the selected requirement or folder. Deleting a requirement 
also deletes its child requirements, tests coverage, defects linkage, and 
attachments.

Refresh All. Refreshes the requirements tree or grid so that it displays the 
most up-to-date requirements.

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
the requirements in the requirements tree or grid. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied to the 
requirements tree or grid.

Select Columns. Opens the Select Columns dialog box, enabling you to 
determine which fields to display in the requirements tree or grid and their 
order. For more information, see “Arranging Columns” on page 52.

Requirement Details. Opens the Requirement Details dialog box, enabling 
you to display the details of the selected requirement. For more information, 
see “Updating Requirements” on page 184.

Attachments. Opens the Requirement Details dialog box in the Attachments 
view, enabling you to add an attachment to the selected requirement. For 
more information, see Chapter 5, “Adding Attachments.”

Go To Requirement in Requirements Tree. From the Requirement Grid view, 
goes to the Requirements Tree view and highlights the selected requirement.

Zoom In. Changes the level of detail in the requirements tree. For more 
information, see “Zooming the Tree” on page 191.
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Send by Email. Opens the Send Email dialog box, enabling you to send 
requirement email to recipients selected from a list or to the author of the 
requirement. For more information, see “Mailing Requirements” on 
page 194.

Text Search. Opens the text search pane in the lower part of the window, 
enabling you to enter keywords and search predefined fields. For more 
information, see “Searching Records” on page 72.

Favorite. Click the Favorite arrow to display a list of favorite views. Favorite 
views enable you to reload a Quality Center window with the settings you 
apply to it. (Available only in the Requirements Grid view. To display the 
Favorite bar, choose View > Favorite Bar.) For more information on favorite 
views, see Chapter 6, “Working with Favorite Views.”

Version Control. The Requirements toolbar displays the following additional 
buttons for version control:

➤ Check Out. Opens the Check Out dialog box, enabling you to check out 
the selected requirement.

➤ Check In. Opens the Check In dialog box, enabling you to check in the 
selected requirement.

For more information on version control, see Chapter 7, “Working with 
Version Control.”
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The Requirement Fields 

The Requirements module displays the following fields:

Field Description

Author The user name of the person who created the requirement. By 
default, this is the login user name. 

Comments Comments about the requirement.

Creation Date The date on which the requirement was created. By default, 
the creation date is set to the current database server date. 
Click the down arrow to display a calendar and select a 
different creation date.

Creation Time The time at which the requirement was created. By default, the 
creation time is set to the current database server time.

Description A description of the requirement.

Direct Cover 
Status

The current status of the requirement. By default, the status is 
Not Covered.

A requirement status can be one of the following:

➤ Not Covered. The requirement has not been linked to a test.

➤ Failed. One or more tests covered by the requirement have 
an execution status of “Failed”.

➤ Not Completed. One or more tests covered by the 
requirement have an execution status of “Not Completed”. 
Alternatively, tests covered by the requirement have 
execution statuses of “Passed” and “No Run”.

➤ Passed. All the tests covered by the requirement have an 
execution status of “Passed”. 

➤ No Run. All the tests covered by the requirement have an 
execution status of “No Run”.

➤ N/A. The current status of the requirement is not applicable.

➤ -----. The requirement does not have a direct cover status as 
it belongs to a requirement type that does not support 
coverage.

Modified The date the requirement was last changed.

Name The requirement name.
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Old Type 
(obsolete)

(formerly Type)

The type of requirement (obsolete). In previous versions of 
Quality Center, the type could be any value configured in the 
project, with typical values Change, Functional, Guideline, 
Quality, Standard, and System.

This field can only be in use for requirements of undefined 
type.

Priority The priority of the requirement, ranging from low priority 
(level 1) to urgent priority (level 5).

Product The component of the application on which the requirement 
is based.

RBQM Business 
Impact

The calculated Business Criticality for the requirement. 
Possible values are A (High), B (Medium), and C (Low). This 
field is use only for assessment requirements.

RBQM Custom 
Business Impact

The user-defined custom Business Criticality for the 
requirement. Possible values are A (High), B (Medium), and C 
(Low). This field is only in use for assessment requirements.

RBQM Custom 
Failure 
Probability

The user-defined custom Failure Probability for the 
requirement. Possible values are 1 (High), 2 (Medium), and 
3 (Low). This field is only in use for assessment requirements.

RBQM Custom 
Functional 
Complexity

The user-defined custom Functional Complexity for the 
requirement. Possible values are 1 (High), 2 (Medium), and 
3 (Low). This field is only in use for assessment requirements.

RBQM Custom 
Risk

The user-defined custom Risk for the requirement. Possible 
values are A (High), B (Medium), and C (Low). This field is only 
in use for assessment requirements.

RBQM Custom 
Testing Hours

The user-defined effort required to test the requirement, 
measured in units defined in Project Customization. This field 
is only in use for assessment requirements.

RBQM Custom 
Testing Level

The user defined level at which to test the requirement. 
Possible values are 1-Full, 2-Partial, 3-Sanity, and 4-None. This 
field is only in use for assessment requirements.

Field Description
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RBQM Date of 
Last Analysis

The date a risk-based quality management analysis was last 
performed on the requirement. This field is only in use for 
analysis requirements.

RBQM Effective 
Business Impact

The effective Business Criticality for the requirement. Possible 
values are A (High), B (Medium), and C (Low). This field is only 
in use for assessment requirements.

RBQM Effective 
Failure 
Probability

The effective Failure Probability for the requirement. Possible 
values are 1 (High), 2 (Medium), and 3 (Low). This field is only 
in use for assessment requirements.

RBQM Effective 
Functional 
Complexity

The effective Functional Complexity for the requirement. 
Possible values are 1 (High), 2 (Medium), and 3 (Low). This 
field is only in use for assessment requirements.

RBQM Effective 
Risk

The effective Risk for the requirement. Possible values are A 
(High), B (Medium), and C (Low). This field is only in use for 
assessment requirements.

RBQM 
Estimated RnD 
Effort

The user-defined estimate of the effort required to develop the 
requirement. This field is only in use for assessment 
requirements.

RBQM Exclude 
from Analysis

Indicates whether to exclude the requirement from risk 
analysis. A requirement may be excluded from risk analysis if it 
belongs to a type for which risk assessments are not available, 
or if you specifically exclude it from analysis.

RBQM Failure 
Probability

The calculated Failure Probability for the requirement. Possible 
values are 1 (High), 2 (Medium), and 3 (Low). This field is only 
in use for assessment requirements.

RBQM 
Functional 
Complexity

The calculated Functional Complexity for the requirement. 
Possible values are 1 (High), 2 (Medium), and 3 (Low). This 
field is only in use for assessment requirements.

RBQM Risk The calculated Risk for the requirement. Possible values are A 
(High), B (Medium), and C (Low). This field is only in use for 
assessment requirements.

RBQM Testing 
Hours

The calculated effort required to test the requirement, 
measured in units defined in Project Customization. This field 
is only in use for assessment requirements.

Field Description
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RBQM Testing 
Level

The calculated level at which to test the requirement. Possible 
values are 1-Full, 2-Partial, 3-Sanity, and 4-None. This field is 
only in use for assessment requirements.

RBQM Use 
Custom 
Business Impact

Indicates whether to use the user-defined Business Criticality, 
instead of the Business Criticality calculated by Quality Center. 
This field is only in use for assessment requirements.

RBQM Use 
Custom Failure 
Probability

Indicates whether to use the user-defined Failure Probability, 
instead of the Failure Probability calculated by Quality Center. 
This field is only in use for assessment requirements.

RBQM Use 
Custom 
Functional 
Complexity

Indicates whether to use the user-defined Functional 
Complexity, instead of the Functional Complexity calculated 
by Quality Center. This field is only in use for assessment 
requirements.

RBQM Use 
Custom Results

Indicates whether to use the user-defined testing effort and 
testing level, instead of the values calculated by 
Quality Center. This field is only in use for assessment 
requirements.

RBQM Use 
Custom Risk

Indicates whether to use the user-defined Risk, instead of the 
Risk calculated by Quality Center. This field is only in use for 
assessment requirements.

Req ID A unique alphanumeric ID for the requirement that is assigned 
automatically. The Req ID field cannot be modified.

Req Parent The name of the parent requirement.

Field Description
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Requirement 
Type

Indicates the type of requirement. Default values are: 

➤  Business. A business process requirement. By default, 
you cannot add coverage to this requirement.

➤  Folder. A folder for organizing requirements. By default, 
you cannot add coverage to this requirement.

➤  Functional. A system behavioral requirement.

➤  Group. A collection of related requirements.

➤  Testing. A system performance requirement.

➤  Undefined. An undefined requirement.

You can customize the default types and create your own 
requirement types. For more information on customizing 
requirement types, refer to the HP Quality Center Administrator 
Guide.

Reviewed Indicates whether the requirement has been reviewed and 
approved by the person responsible.

Target Cycle Indicates the cycle in which the requirement was assigned. 
Click the down arrow to select a different cycle.

Target Release Indicates the release in which the requirement was assigned. 
Click the down arrow to select a different release.

Field Description
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Version Control: The Requirements module displays the following 
additional fields:

Notes: 

➤ You can add user-defined fields and change the label of any of the fields 
in the Requirements module. You can also customize project lists. For 
more information, refer to the HP Quality Center Administrator Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Requirements module. For more information, 
refer to the HP Quality Center Administrator Guide.

➤ When you select a requirement column with a user name value 
(including user-defined fields), Quality Center displays a list with the 
name and full name of each user. You can search for users, sort users, 
group users by user group, and select users from the users list or a group 
tree. For more information, see “Selecting Users” on page 55.

➤ Quality Center Starter Edition: Not all fields are available if you are 
working with the Starter Edition. 

Field Description

Version Check 
Out Date

The date the version was checked out.

Version Check 
Out Time

The time the version was checked out.

Version 
Checked Out By

The name of the user who checked out the version.

Version 
Number

The version number.

Version Status The status of the version (Checked Out or Checked In).
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13 
Developing the Requirements Tree

The requirements tree organizes and displays your requirements 
hierarchically.

This chapter includes:

 ➤  About Developing the Requirements Tree on page 178

 ➤  Creating a Requirements Tree on page 179

 ➤  Assigning Requirements to Releases or Cycles on page 182

 ➤  Adding Rich Text to Requirements on page 183

 ➤  Updating Requirements on page 184

 ➤  Finding Requirements on page 187

 ➤  Replacing Field Values on page 189

 ➤  Viewing the Requirements Tree on page 191

 ➤  Viewing Requirement History on page 193

 ➤  Mailing Requirements on page 194

 ➤  Modifying Requirements on page 196

 ➤  Creating Tests from Requirements on page 200
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About Developing the Requirements Tree 

The Requirements module enables you to define and manage your 
requirements. You record requirements in Quality Center by creating a 
requirements tree. This is a graphical representation of your requirements 
specification, displaying your requirements hierarchically. 

After defining your requirements, you can establish traceability between two 
or more requirements. Requirements traceability defines a relationship 
between the requirements. When analyzing the impact of a change 
proposed in a specific requirement, the traceability links indicate the other 
requirements that the change might affect. When a requirement changes, 
Quality Center alerts the directly influenced traced requirements. For more 
information on establishing traceability between requirements, see 
Chapter 14, “Tracing Requirements.”

During the requirements specification phase, you assign your requirements 
to a release or a cycle in the releases tree. Requirements can be assigned to 
one or more releases or cycles. For more information, see “Assigning 
Requirements to Releases or Cycles” on page 182.

Assigned requirements can be associated with tests and defects. In this way, 
you can keep track at all stages of the software development life cycle. If a 
requirement changes, you can immediately identify which tests and defects 
are affected, and who is responsible. For more information on associating 
requirements with tests, see Chapter 19, “Requirement and Test Coverage.” 
For more information on associating requirements with defects, see 
Chapter 36, “Linking Defects.”

Note: This chapter assumes you are using the Requirements module’s 
Requirements Tree to create a requirements tree. For information on the 
Requirements Grid view, see “Requirements Grid” on page 162. For 
information on the Requirement Details view and Coverage Analysis view, 
see Chapter 19, “Requirement and Test Coverage.”
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Creating a Requirements Tree

You start a requirements tree by adding requirements to the Requirements 
root folder. You can organize your requirement topics into folders. The root 
folder cannot be renamed or deleted.

Quality Center Starter Edition: Requirement Types are not available. 

Note: In addition to creating requirements directly in Quality Center, you 
can also import requirement data from Microsoft Word or Microsoft Excel to 
your Quality Center project. To import from Word, you must install the 
HP Quality Center Microsoft Word Add-in and the HP Quality Center 
Connectivity Add-in. To import from Excel, you must install the 
HP Quality Center Microsoft Excel Add-in and the HP Quality Center 
Connectivity Add-in. You can install the add-ins from the HP Quality Center 
Add-ins page. For more information, refer to the HP Quality Center 
Installation Guide.

To create a requirements tree:

 1 In the Requirements module, choose View > Requirements Tree to display 
the Requirements Tree view.

 2 To add a requirement at the main level, select the Requirements root folder. 
To create a child requirement, select a requirement.

 3 To add a folder, click the New Folder button or choose Requirements > New 
Folder. In the Create New Requirement Folder dialog box, type the Folder 
Name and click OK. Note that a folder name cannot include the following 
characters: \ ^ *
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 4 To add a requirement, click the New Requirement button. Alternatively, 
choose Requirements > New Requirement. The Create New Requirement 
dialog box opens.

 5 In the Requirement Type list, select a requirement type. For more 
information on requirement types, see “The Requirement Fields” on 
page 171.

 6 In the Requirement Name box, type a name for the new requirement. A 
requirement name cannot include the following characters: \ ^ *

 7 Click OK. The New Requirement dialog box opens.
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 8 Add details for the requirement. Note that a required field is displayed in 
red. For more information on the available fields in the Requirements 
module, see “The Requirement Fields” on page 171.

 9 To clear the data in the New Requirement dialog box, click the Clear button.

 10 You can add an attachment to your requirement:

➤ Click the Attach File button to attach a text file.

➤ Click the Attach URL button to attach a URL.

➤ Click the Attach Snapshot button to capture and attach an image.

➤ Click the Attach Sysinfo button to attach information about your 
machine.

➤ Click the Attach Clipboard button to attach text or an image from the 
Clipboard.

For more information about adding attachments, see Chapter 5, “Adding 
Attachments.”

 11 You can check the spelling in the New Requirement dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. 

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way Quality Center checks spelling. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. 

 12 Click Submit to add the new requirement to the tree. 

 13 Click Close to close the New Requirement dialog box.

Version Control: The new requirement is automatically checked out. For 
more information, see “Checking Out Entities” on page 104.

 14 To add test coverage for the requirement, choose View > Requirement 
Details. You can also choose View > Coverage Analysis to display the 
breakdown of child requirements according to test coverage status. For more 
information, see Chapter 19, “Requirement and Test Coverage.”
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 15 To add requirement traceability links for the requirement, choose View > 
Requirement Details and click the Requirements Traceability tab. For more 
information, see Chapter 14, “Tracing Requirements.”

 16 To add defect links for the requirement, choose View > Requirement Details 
and click the Linked Defects tab. For more information, see Chapter 36, 
“Linking Defects.”

Assigning Requirements to Releases or Cycles

After you have defined your requirements in the requirements tree, you 
assign the requirements to a release or a cycle in the Releases module. You 
can assign requirements to one or more releases or cycles in the releases tree. 
For more information, see Chapter 10, “Developing the Releases Tree.”

During the test planning stage, you associate the tests in the Test Plan 
module to your assigned requirements to create coverage. By defining 
coverage, you can keep track of the relationship between the tests in your 
test plan and your requirements. For more information on coverage, see 
Chapter 19, “Requirement and Test Coverage.”

During the test running stage, you add the tests that cover the assigned 
requirements to test sets in the Test Lab module, and then you assign the 
test set folders to cycles. For more information, see “Assigning Test Set 
Folders to Cycles” on page 385.

Quality Center Starter Edition: Assigning requirements to releases or cycles 
is unavailable.

Note: Assigning a parent requirement to a cycle also assigns its child 
requirements to the same cycle. 

To assign a requirement to a release or a cycle:

 1 In the requirements tree, select the requirement that you want to assign to a 
release or a cycle. To select more than one requirement, use the Ctrl key.
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 2 To assign to a release, choose Requirements > Assign To Release. 
Alternatively, right-click and choose Assign To Release. The Assign To 
Release dialog box opens. Expand the tree and select a release. Click OK to 
close the dialog box.

To assign to a cycle, choose Requirements > Assign To Cycle. Alternatively, 
right-click and choose Assign To Cycle. The Assign To Cycle dialog box 
opens. Expand the tree and select a cycle. Click OK to close the dialog box.

 3 If the selected requirement contains child requirements, a confirmation box 
opens. Click Yes to assign the requirement and its child requirements. Click 
No to assign the requirement without its child requirements.

Adding Rich Text to Requirements

You can add, view, and edit Microsoft Word rich text from within 
Quality Center, without the need to edit the text in Word. Changes you 
make to the rich text for a requirement are saved automatically when you 
move to a different requirement or a different module.

Note: To verify supported versions of Microsoft Word, refer to the 
HP Quality Center Installation Guide.

To add rich text to a requirement:

 1 Select a requirement and click the RichContent tab. A Microsoft Word editor 
is displayed.

 2 Edit the rich text as you would in Word. For more information on using 
Word to edit rich text, refer to the Microsoft Word documentation.

 3 To edit rich text in a separate window, click the Maximize Content button.

 4 To replace the existing rich text with content from a saved Word file, in the 
RichContent tab, choose File > Import.

 5 To replace the existing rich text with a blank page, in the RichContent tab, 
choose File > New.

 6 To save the rich text as a Word document, choose File > Save.
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Updating Requirements

You can update your requirements directly in the requirements tree or grid, 
or in the Requirement Details dialog box. Using the Requirement Details 
dialog box, you can update the details, attachments, tests coverage, 
requirement traceability links, risk-based quality management settings, and 
defect links for any requirement. You can also view a list of changes made to 
any requirement.

Quality Center Starter Edition: Not all fields and functionality are available 
in Requirement Details if you are working with the Starter Edition. 
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To update a requirement:

 1 Double-click the requirement you want to update. Alternatively, select the 
requirement and click the Requirement Details button. The Requirement 
Details dialog box opens.

 2 You can click the First button to display the first requirement in the tree or 
grid, or the Previous button to display the preceding requirement.

 3 You can click the Next button to display the next requirement in the tree or 
grid, or the Last button to display the final requirement in the tree or grid.

 4 Click the Send by Email button to send an email with the requirement 
details. For more information on mailing requirements, see “Mailing 
Requirements” on page 194.
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 5 In the Details view, you can add or modify information for the selected 
requirement. For more information on available fields in the Details view, 
see “The Requirement Fields” on page 171.

 6 Click Requirements Traceability on the sidebar to add requirement 
traceability links for the requirement. For more information on traceability, 
see Chapter 14, “Tracing Requirements.”

 7 Click Test Coverage on the sidebar to add test coverage for the requirement. 
For more information on test coverage, see Chapter 19, “Requirement and 
Test Coverage.”

 8 Click Linked Defects on the sidebar to add defect links for the requirement. 
A clickable icon  is placed next to the requirement in the Requirements 
Grid. For more information on linked defects, see “Linking Defects” on 
page 497.

 9 Click Risk on the sidebar to use risk-based quality management to help you 
determine a strategy for testing the requirement. For more information on 
risk-based testing, see Chapter 15, “Calculating Requirement Risks.”

 10 Click Attachments on the sidebar to add an attachment to the requirement. 
An attachment can be a file, URL, snapshot of your application, system 
information, or an item from the Clipboard. A clickable attachment icon  
is placed next to the requirement in the Requirements Grid. For more 
information on attachments, see Chapter 5, “Adding Attachments.”

 11 Click History on the sidebar to view the history of changes made to the 
requirement. For more information, see “Viewing Requirement History” on 
page 193.

 12 Click OK to save your changes and close the Requirement Details dialog box.
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Finding Requirements

You can search for a particular requirement by using the Find command.

Tip: If available, Text Search is a more powerful tool that enables you to 
search for keywords and variations of keywords. For information on using 
text search, see “Searching Records” on page 72.

Finding Requirements in the Requirements Tree
You can search for a requirement in the requirements tree. If you have 
applied filters to the tree, the search is restricted to the requirements 
currently displayed.

To find a requirement in the requirements tree:

 1 Choose Edit > Find. The Find Requirement dialog box opens.

 2 In the Find in Field box, select the search criterion. 

 3 In the Value to Find box, type or select the value of the field you chose. The 
search is not case sensitive.

 4 Click Find. The Requirements module searches for the requirement with the 
specified value. If the search is successful, the Search Results dialog box 
opens and displays a list of possible matches. Select a result from the list and 
click the Go To button to highlight the requirement in the requirements 
tree. If the search is unsuccessful, an information box opens.
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Finding Requirements in the Requirements Grid
You can search for requirements in the requirements grid, based on the 
value of a particular field. If you have applied filters to the grid, the search is 
restricted to the requirements currently displayed.

To find a requirement in the requirements grid:

 1 Choose Edit > Find. The Find dialog box opens.

 2 In the Find in Field box, select a field in the grid.

 3 In the Value to Find box, type or select the value of the field, for which you 
want to search.

 4 Select Exact Match if you want to find requirements with field values that 
exactly match the Value to Find string.

 5 Select Case Sensitive if you want the search to distinguish between 
uppercase and lowercase characters.

 6 Select Use Wildcard if you want to use asterisk (*) characters in your search 
string in order to type only part of the item.

 7 Click Find Next. If the search is successful, the matching requirement is 
highlighted in the grid. If the search is unsuccessful, an information box 
opens.

 8 Click Find Next again to find the next requirement that matches the criteria.
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Replacing Field Values

You can replace field values in the requirements tree or in the requirements 
grid using the Replace command.

Replace Field Values in the Requirements Tree
You can replace field values for a selected requirement and all of its child 
requirements, or for all requirements in the requirements tree.

To replace a field value in the requirements tree:

 1 To replace a field value for the selected requirement and of its child 
requirements, select a requirement in the tree and choose Edit > Replace > 
Replace Selected. 

To replace all values, choose Edit > Replace > Replace All. 

The Replace dialog box opens.

 2 In the Find in Field box, select the field in which you want to replace values.

 3 In the Value to Find box, type or select the value for which you want to 
search. 

 4 In the Replace with box, type or select a replacement value.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box. 
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 7 To receive a prompt before each value is replaced, select the Prompt on 
replace check box. 

 8 Click Replace. If you selected Prompt on replace in step 7, the Confirm 
dialog box opens.

➤ Select Yes to replace the current occurrence of the value.

➤ Select Replace All to replace the value, either in the selected requirement 
and its child requirements, or in all the requirements, according to your 
selection in step 1.

An Information dialog box opens, showing the number of values that were 
replaced, and the number of instances where the values were not replaced. 
Click OK.

Replace Field Values in the Requirements Grid
You can replace field values in the requirements grid using the Replace 
command.

To replace a field value in the requirements grid:

 1 Choose Edit > Replace. The Find/Replace dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value. 

 3 In the Value to Find box, type or select the value to find. 

 4 In the Replace with box, type or select a replacement field value.
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 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.

 7 To start the search from the top of the grid, select the From Beginning check 
box.

 8 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 9 To replace the found item and find the next occurrence, click Replace.

 10 To replace all occurrences of the value in the grid, click Replace All.

Viewing the Requirements Tree

You can change the way the Requirements module displays the 
requirements tree. This includes zooming in and out of the tree, refreshing 
the tree, filtering the tree, and expanding and collapsing the branches of the 
tree.

Zooming the Tree
You can zoom in and zoom out of the requirement topics in the 
requirements tree. This enables you to change the level of detail that the 
tree displays.

To zoom in:

 1 Select a requirement topic in the requirements tree.

 2 Click the Zoom In button on the toolbar. Alternatively, right-click the 
requirement and choose Zoom In.

The requirements tree only displays the selected requirement topic and 
includes a heading with the hierarchical path of the requirement topic.
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To zoom out:

To reverse a zoom in action, you can either zoom out one level or zoom out 
to the highest hierarchical level.

➤ Click the Zoom In arrow and choose Zoom Out One Level to undo the 
previous zoom in command.

➤ Click the Zoom In arrow and choose Zoom Out To Root to zoom out to the 
highest hierarchical level and display the entire requirements tree. 

Refreshing the Tree
You can refresh the data in the tree so that it displays the most up-to-date 
requirements. To refresh the tree, click the Refresh All button.

Filtering Requirements
You can filter and sort requirements in the Requirement module. Click the 
Set Filter/Sort arrow and choose from the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
the requirements in the Requirement module. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied to the 
requirements tree or grid.

For more information, see Chapter 3, “Working with Quality Center Data.”

Expanding and Collapsing the Tree
You can expand and collapse the branches in the requirements tree. This 
enables you to change the level of detail that the tree displays.

To expand and collapse the tree:

➤ To expand a branch in the tree, click the Expand  sign to the left of the 
branch name. To expand all the levels in a branch, right-click the branch 
name and choose Expand All. 

➤ To collapse a branch in the tree, click the Collapse  sign to the left of the 
branch name. To collapse all the levels in a branch, right-click the branch 
name and choose Collapse.
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Viewing Requirement History 

You can view a list of changes made to any requirement in the requirements 
tree.

You can also view previous versions of requirements stored in a particular 
baseline. For more information, see “Viewing Baseline History” on page 524.

To view requirement history:

 1 In the requirements tree, select a requirement. Click the History tab. The 
history of changes made to the requirement is displayed in a grid.

Version Control: By default, the Versions and Baselines tab is displayed. 
Click the Audit Log tab to view requirement history.

For each change to the requirement, the grid displays the date and time of 
the change and the name of the user who made the change. 

 2 Expand a change to view a list of fields modified during the change. For 
each field, the grid displays the old value and the new value. To expand all 
changes, click the Expand All button.

 3 You can specify which changes are displayed in the grid. In the Field list, 
select a field name to view only changes made to that field. Select <All> to 
view changes made to all fields.

For information on preserving the history of changes made to a field, refer 
to the HP Quality Center Administrator Guide.



Chapter 13 • Developing the Requirements Tree

194

Mailing Requirements 

You can send email about a requirement to other users in your 
Quality Center project. This enables you to routinely inform them about the 
status of your requirements. A link is included in the email message that 
enables the recipient to go directly to the requirement.

Note: By default, Quality Center sends email in HTML format. To send email 
as plain text instead, edit the MAIL_FORMAT parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator Guide.

To mail a requirement: 

 1 Select one or more requirements and click the Send by Email button. The 
Send Email dialog box opens.
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Tip: You can automatically send the email to a specific user type. This can be 
any requirement column with a user name value, including user-defined 
fields. Click the Send by Email arrow and choose an option. For example, 
choose Send by Email to Author to send the email to the user who wrote the 
requirement.

 2 Type a valid email address or user name. Alternatively, click the To button or 
CC button to select users. The Select Recipients dialog box opens. 

You can sort the users list, search for users, group users by user groups, and 
select users from the list or from a group tree. For more information, see 
“Selecting Users” on page 55.

Select the users or user groups to which you want to send the email, and 
click OK. 



Chapter 13 • Developing the Requirements Tree

196

 3 In the Subject box, type a subject for the email.

 4 Choose whether you want to include the Attachments, History, Tests 
Coverage and/or Traced Requirements of the requirement. If you include 
the requirement’s Attachments, any rich text for the requirement is 
included as a separate attachment.

 5 In the Additional comments box, add any comments you may have.

 6 To check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word 
together with replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way spelling is checked. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.

 7 Click Custom to customize the email. In the Select Fields dialog box, you 
can specify fields to include in the email. 

 8 Click Send to send the email.

Modifying Requirements

This section on modifying requirements includes the following topics:

➤ Renaming Requirements

➤ Copying Requirements

➤ Copying URLs of Requirements

➤ Updating Multiple Requirements

➤ Moving Requirements

➤ Deleting Requirements
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Renaming Requirements
You can rename a requirement in the Requirements module. A name cannot 
include the following characters: \ ^ *

Note: You cannot rename the root folder.

To rename a requirement:

➤ To rename a requirement in the tree, select a requirement and choose Edit > 
Rename. Alternatively, right-click the requirement and choose Rename. Edit 
the requirement name and press ENTER.

➤ To rename a requirement in the grid, click the requirement’s name and type 
a new name.

Copying Requirements
You can copy a requirement within the same project or between projects. 
When you copy a requirement topic, any children of the requirement topic 
are also copied.

Notes:

➤ Test coverage, defect linkage, and risk-based quality management data for 
the requirement are not copied.

➤ To copy a requirement with traceability, you must also copy its associated 
traced requirements.

➤ The root folder cannot be copied within the same project.
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To copy a requirement:

 1 Select a requirement from the requirements tree or grid. To copy more than 
one requirement, press the CTRL key and select the requirements you want 
to copy.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy. 

 3 If you are copying a requirement from the grid to the requirements tree, 
choose View > Requirements Tree. The Requirements Tree view is displayed.

 4 Select a requirement in the requirements tree.

 5 Choose Edit > Paste. Alternatively, right-click and choose Paste.

Note that if you paste a requirement that has the same name as an existing 
requirement, the suffix _Copy is added automatically to the end of the 
requirement’s name. 

Copying URLs of Requirements
You can copy a requirement and paste its URL as a link. The requirement 
itself is not copied. Instead, you can paste the address into another location, 
such as an email or a document. Clicking the link opens up Quality Center 
and takes you to the requirement. If you are not already logged in, 
Quality Center first prompts for login details. 

To copy a URL of a requirement:

 1 Select a requirement from the requirements tree or grid. 

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.

Updating Multiple Requirements
You can update a field value for multiple records in the requirements tree or 
grid. To update, select the records in the grid or select the requirements in 
the requirements tree. Choose Edit > Update Selected. The Update Selected 
dialog box opens. For more information, see “Updating Multiple Records” 
on page 70.
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Moving Requirements
You can move a requirement to a different location in the requirements tree. 
Moving a requirement topic also moves its child requirements, tests 
coverage, requirement traceability links, and defects linkage. The root folder 
cannot be moved.

Tip: You can also move a requirement to a new location in the requirements 
tree by dragging it.

To move a requirement:

 1 Select a requirement from the requirements tree. To move more than one 
requirement, press the CTRL key and select the requirements you want to 
move.

 2 Choose Edit > Cut or right-click the requirements and choose Cut.

 3 Select a requirement in the requirements tree.

 4 Choose Edit > Paste. Alternatively, right-click and choose Paste. 

Deleting Requirements
You can delete a requirement from the Requirements module. Deleting a 
requirement also deletes its child requirements, tests coverage, requirement 
traceability links, and defects linkage. Note that you cannot delete the root 
folder.

Version Control: Deleting a requirement deletes all previous versions of the 
requirement.

To delete a requirement:

 1 Select a requirement. To delete more than one requirement, press the CTRL 
key and select the requirements you want to delete.

 2 Click the Delete button or right-click and choose Delete.

 3 Click Yes to confirm.
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Creating Tests from Requirements

After you have created the requirements tree, you use the requirements as a 
basis for defining the tests in your test plan tree and running tests in a test 
set. Note that you must have the necessary permissions in order to create 
tests.

There are two methods you can use to create tests from requirements:

➤ Convert Requirements to Tests. Convert requirements to tests in a specified 
subject in the test plan tree. You can convert selected requirements or all 
requirements in the requirements tree. This method, using the Convert to 
Tests wizard, assists you when designing your test plan tree. See “Converting 
Requirements to Tests” on page 200.

➤ Generate a Test from Requirements. Convert requirements to a test in a 
specified subject in the test plan tree and a specified test set in the Test Lab 
module. This method, using the Generate Test dialog box, enables you to 
quickly run a test when analyzing your requirements. See “Generating a Test 
from Requirements” on page 205.

Converting Requirements to Tests
Use the Convert to Tests wizard to convert requirements to tests in a 
specified subject in the test plan tree. Coverage is automatically created 
between the requirements and their corresponding tests.

To convert requirements to tests:

 1 To convert a specific requirement, select the requirement in the 
requirements tree. To convert all requirements, select the root requirement 
folder in the requirements tree.
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 2 Choose Requirements > Convert to Tests.

The Step 1 dialog box opens.

 3 Choose an automatic conversion method:

➤ Select Convert lowest child requirements to design steps to convert all 
lowest level child requirements to design steps, the next level up to tests, 
and all levels above to subjects.

➤ Select Convert lowest child requirements to tests to convert all lowest 
level child requirements to tests and all levels above to subjects.

➤ Select Convert all requirements to subjects to convert all selected 
requirements to subjects.



Chapter 13 • Developing the Requirements Tree

202

 4 Click Next to begin converting the requirements. To cancel the conversion 
process and return to the Step 1 dialog box, click the Stop button in the 
progress bar. When the conversion process is complete, the results are 
displayed in the Step 2 dialog box.

Note: If you are converting a single requirement, the wizard skips this dialog 
box.

 5 To view the wizard legend, click the Legend link.
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 6 For each converted item, you can do the following:

➤ Select the item and click the Convert to Subject button or right-click the 
item and choose Subject, to change the item to a subject in the test plan 
tree. Children can then be either subjects or tests. Note that subject 
names must be unique.

➤ Select the item and click the Convert to Test button or right-click the 
item and choose Test, to change the item to a test in the test plan tree. 
Children are then converted to steps. Note that test names must be 
unique.

➤ Select the item and click the Convert to Step button or right-click the 
item and choose Step, to change the item to a step in the test plan tree. 
Children are then converted to step descriptions.

➤ Select the item and click the Convert to Description button or right-click 
the item and choose Description, to change the item to a step description 
in the test plan tree. Children are then converted to indented description 
text.

➤ Select the item and click the Exclude from Conversion button or 
right-click the item and choose Exclude to exclude the item from the test 
plan tree.

 7 Clear the Auto Complete Children check box if you do not want the wizard 
to assist you when you make changes. If this option is selected and you 
change the level of a parent, for example, from a subject to a test, the wizard 
changes the level of all the children from tests to test steps.
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 8 Click Next. The Step 3 dialog box opens.

 9 Under Destination Subject Path, click the Select Subject button to select a 
subject from your test plan tree in the Select Destination Subject dialog box. 
Alternatively, type a new subject name. By default, the subject folder and 
tests are placed in the Subject folder of the Test Plan module. 

 10 Click Finish. 

 11 To stop the conversion process and return to the Step 3 dialog box, click the 
Stop button in the progress bar. 

Note: If you stop the conversion process, any requirements already 
converted are not deleted from the test plan tree. You must delete them 
manually.

 12 Click OK to close the Convert to Tests wizard or view the error messages that 
have been generated.
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Generating a Test from Requirements
Use the Generate Test dialog box to convert requirements to a test in a 
specified subject in the test plan tree and a specified test set in the Test Lab 
module. Coverage is automatically created between the requirements and 
their corresponding tests. Note that by default you cannot generate a test for 
the following requirement types, which do not enable coverage: Business, 
Folder, and Group.

To generate a test from requirements:

 1 Select a requirement and choose Requirements > Generate Test. 
Alternatively, right-click a requirement in the requirements tree and choose 
Generate Test. The Generate Test dialog box opens.

 2 In the Subject box, select a subject from your test plan tree or type a new 
subject name. By default, the test is placed in the Temporary Tests folder in 
the Test Plan module.

 3 In the Test Name box, type a name for the new test. By default, the new test 
is assigned the same name as the requirement.

 4 In the Test Status box, select a status for the test. 

 5 If you do not want to create design steps, clear the Create Design Steps 
check box. If this option is selected, a step is added to the test for each child 
requirement.

 6 Select Add Test to Test Set to add the test to a test set in the Test Lab 
module. In the Test Set list, select a test set or type a new test set name.

 7 Click OK.
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14 
Tracing Requirements

Requirements traceability defines a relationship between requirements. As 
requirements or their linked requirements change, you can trace and 
monitor the impact of these changes.

Quality Center Editions: Requirements traceability is available for 
Quality Center Enterprise Edition and Quality Center Premier Edition.

This chapter includes:

 ➤  About Tracing Requirements on page 208

 ➤  Defining Traceability Relationships on page 211

 ➤  Viewing Traceability Relationships on page 213

 ➤  Viewing Traceability Impact on page 215

 ➤  Removing Traceability Relationship Links on page 217
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About Tracing Requirements

Requirements traceability defines a relationship between two or more 
requirements. When analyzing the impact of a change proposed in a specific 
requirement, the traceability links indicate the other requirements that the 
change might affect.

After defining your requirements in the requirements tree (see Chapter 13, 
“Developing the Requirements Tree”), you can establish traceability 
between the requirements. Using the Requirements Traceability tab in the 
Requirement Details view, you can add traceability links to and from a 
selected requirement. Trace from links indicate requirements that affect a 
selected requirement. Trace to links indicate requirements that are affected 
by a selected requirement.

When a requirement changes, Quality Center alerts the affected 
requirements. The alerts can be seen by all users. Quality Center also sends 
email notifications to the authors of the affected requirements. For more 
information on alerts, see Chapter 4, “Alerting on Changes.”
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Requirements Traceability Example
To implement this relationship between the requirements, suppose 
Requirement_1B and Requirement_2B affect Requirement_1A. You select 
Requirement_1A in the requirements tree. In the Relationships tab, you add 
Requirement_1B and Requirement_2B to the Trace From grid. 

If you select Requirement_1B in the requirements tree, the Trace To grid 
indicates that Requirement_1B is traced to Requirement_1A. 
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If you select Requirement_2B in the requirements tree, the Trace To grid 
indicates that Requirement_2B is traced to Requirement_1A. 

When a requirement changes, Quality Center flags the traced to 
requirements and sends email to notify the authors to evaluate the impact 
on their requirements. For example, if you change Requirement_1B or 
Requirement_2B, Quality Center alerts Requirement_1A and alerts its author. 
The alerts are visible to all users.
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Defining Traceability Relationships

You can define traceability relationships between requirements in the 
Relationships tab. This tab contains the Trace From and Trace To grids. The 
Trace From grid displays requirements that affect a selected requirement. 
The Trace To grid displays the requirements that are affected by the selected 
requirement.

You define a relationship by selecting a requirement from the requirements 
tree or by typing a requirement ID. 

To define a relationship using the requirements tree:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 Click the Show/Hide arrow to display the Trace From or Trace To grid. 

 3 In the Relationships tab, click the Add Requirement Traceability button to 
open the requirements tree in the right pane.

 4 To search for a specific requirement in the tree, type the name (or part of the 
name) of the requirement in the Find box and click the Find button. If the 
search is successful, the requirement is highlighted in the tree.
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 5 To filter or sort requirements in the tree, click the Set Filter/Sort button. For 
more information on filtering and sorting records, see Chapter 3, “Working 
with Quality Center Data”. 

 6 To refresh the tree, click the Refresh All button. 

 7 Select a requirement to add to the grid:

➤ Click the Add to Traceability arrow and choose Add to Traceability (Trace 
To) to add the requirement to the Trace To grid.

➤ Click the Add to Traceability arrow and choose Add to Traceability (Trace 
From) to add the requirement to the Trace From grid.

The requirement is added to the grid.

Tip: You can also add a requirement traceability link by dragging a 
requirement from the requirements tree to the appropriate grid.

 8 Click the Close button to hide the requirements tree in the right pane.

To define a relationship by typing a requirement ID:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 Click the Show/Hide arrow to display the Trace From or Trace To grid. 

 3 Click the Add Requirement Traceability button and choose one of the 
following options:

➤ By ID (Trace From). Add a traceability link to the Trace From grid by 
typing a requirement ID.

➤ By ID (Trace To). Add a traceability link to the Trace To grid by typing a 
requirement ID.

The Trace Existing Requirement dialog box opens.

 4 Type the requirement ID for the requirement you want to add and click 
Trace. The requirement is added to the specified grid.
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Viewing Traceability Relationships

You can display traceability relationships that exist between requirements in 
the Relationships tab. This tab contains the Trace From and Trace To grids. 
The Trace From grid displays requirements that affect a selected 
requirement. The Trace To grid displays the requirements that are affected 
by the selected requirement. 

In addition to the columns described in “The Requirement Fields” on 
page 171, the Relationships tab can also display the following columns:

Column Description

Created By The user name of the person who created the requirement 
link. By default, this is the login user name. 

Creation Date The date on which the requirement link was created. By 
default, the creation date is set to the current database 
server date.

Modified The date and time on which the requirement link was 
modified. By default, the date and time are set to the 
current database server date and time.
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To view traceability relationships:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 To refresh the grids, click the Refresh All button. 

 3 To set column appearance and order, click the Select Columns arrow and 
choose Select Column (Trace From) or Select Column (Trace To). The Select 
Columns dialog box opens. For more information, see “Arranging 
Columns” on page 52.

 4 To display a traced requirement in the requirements tree, select a 
requirement and click the Go To Requirement button.

 5 To view details of a traced requirement, select a traced requirement and click 
the Requirement Details button. The Requirement Details dialog box opens. 
For more information, see “Updating Requirements” on page 184.

Requirement Trace 
ID

A unique alphanumeric ID for the requirement link that is 
assigned automatically.

Trace Comment Displays comments about the requirement link.

Column Description
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Viewing Traceability Impact

After establishing traceability relationships, you can analyze the impact of 
requirement changes by reviewing the relationships. The Impact Analysis 
tab helps you understand the many associations and dependencies that 
exist between the requirements by displaying them in a hierarchical tree 
structure. Unlike the Relationships tab, the Impact Analysis tab shows the 
affected requirements along with their parent and child requirements. 

The Trace From tree displays requirements that affect a selected 
requirement. For example, the following Trace From tree indicates that 
Req_A is traced from Requirement_1B. Requirements is the parent 
requirement of Req_A. Req_B is the parent requirement of Requirement_1B. 
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The Trace To tree displays requirements that are affected by a selected 
requirement. For example, the following Trace To tree indicates that 
Requirement_1B is traced to Req_A. Requirement_1A through 
Requirement_4A are child requirements of Req_A, which are affected by 
Req_A. 

The Impact Analysis tab contains the following icons:

Icon Description

A child requirement affected by a change to a selected requirement.

A parent requirement that affects a selected requirement.

A traced-to requirement.

A traced-from requirement.

A recursive relationship between the requirements.
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To view traceability impact:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 Click the Impact Analysis tab.

 3 To refresh the tree, click the Refresh All button. 

 4 To display a traced requirement in the requirements tree, select a 
requirement and click the Go To Requirement button.

 5 To view details of a traced requirement, select a traced requirement and click 
the Requirement Details button. The Requirement Details dialog box opens. 
For more information, see “Updating Requirements” on page 184.

Removing Traceability Relationship Links

You can remove a traceability relationship link from the Relationships tab.

To remove a traceability relationship link:

 1 In the Requirement Details view, select a requirement from the 
requirements tree and click the Requirements Traceability tab. By default, 
the Relationships tab is displayed.

 2 Click the Show/Hide arrow to display the Trace From or Trace To grid. 

 3 In the appropriate grid, select a traceability relationship link. To select more 
than one link, press the CTRL key and select the links you want to remove.

 4 Click the Remove from Traceability button, or right-click and choose 
Remove from Traceability.

 5 Click Yes to confirm.
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15 
Calculating Requirement Risks

Risk-based quality management can assist you in determining testing 
strategy for your requirements.

Quality Center Editions: Risk-based quality management is available for 
Quality Center Enterprise Edition and Quality Center Premier Edition.

This chapter includes:

 ➤  About Calculating Requirement Risks on page 220

 ➤  The Risk-Based Quality Management Process on page 221

 ➤  Assessing Requirements on page 223

 ➤  Defining the Testing Policy Settings on page 229

 ➤  Finalizing the Testing Policy on page 231

 ➤  Analyzing the Testing Strategy on page 234

 ➤  Risk-Based Quality Management Example on page 239
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About Calculating Requirement Risks

When planning how to test your requirements, you generally do not have 
unlimited resources available, and are not able to fully test every 
requirement. You must make compromises and only partially test 
requirements that have low criticality to the business, or those that have 
only a minor risk associated with their implementation. The risk-based 
quality management feature enables you to calculate at which level to test 
each requirement, based on the nature of the requirement and the resources 
you have available. You can then plan your testing process based on these 
recommendations.

Each requirement type can be enabled for risk-based quality management. 
Each requirement type with risk-based quality management enabled can 
support either risk analysis which is referred to as an analysis requirement, 
or an individual risk assessment which is referred to as an assessment 
requirement.

➤ An analysis requirement is a requirement belonging to a type that represents 
higher levels in the requirements tree hierarchy, such as the Folder type. You 
perform risk analysis on an analysis requirement based on the assessment 
requirements under it in the requirements tree. 

The risk results of multiple assessment requirements are aggregated to give 
an overall risk analysis which can then be used to determine testing effort 
and test strategy.

➤ An assessment requirement is a requirement belonging to a type that 
represents requirements that are children of analysis requirements and at a 
lower level in the requirements tree hierarchy. Assessment requirements 
under a particular analysis requirement form the basis for risk analysis on 
that analysis requirement.

You work with risk-based quality management in the Requirement Details 
view of the Requirements module. You can also work with risk-based quality 
management in the Risk view of the Requirement Details dialog box.

You can customize default settings for risk-based quality management. For 
more information, see the HP Quality Center Administrator Guide.
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The Risk-Based Quality Management Process

Performing a risk-based quality management analysis for an analysis 
requirement involves the following steps: 

Assessing Requirements

For each assessment requirement under the analysis requirement, you 
determine the Risk and Functional Complexity Categories:

➤ The Risk Category is composed of two factors: Business Criticality and 
Failure Probability. Business Criticality measures how crucial a requirement 
is for the business. Failure Probability indicates how likely a test based on 
the requirement is to fail. 

➤ The Functional Complexity Category indicates the complexity of the 
requirement’s implementation.

For more information, see “Assessing Requirements” on page 223.

Define Testing 
Scope

Create
Requirements

Create
Requirements

Detail 
Requirements

Detail 
Requirements

Analyze 
Requirements

Analyze 
Requirements

Assess
Requirements

Define Testing Policy
Settings

Finalize
Testing Policy

Analyze
Testing Strategy
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Defining Testing Policy Settings

After you determine the Risk and Functional Complexity Categories of the 
assessment requirements under an analysis requirement, you define the 
initial settings for testing the analysis requirement and the assessment 
requirements under it. These settings include how much time to assign to a 
requirement of a specific Functional Complexity were you to test it fully and 
how long it would take you to perform partial or basic testing on a 
requirement. You also decide which level of testing you want to perform on 
requirements for each Risk and Functional Complexity. For more 
information, see “Defining the Testing Policy Settings” on page 229.

Finalizing the Testing Policy

After you determine the testing policy settings, Quality Center calculates the 
total estimated testing time for the analysis requirement and the assessment 
requirements under it. You decide how much time you have to assign to test 
these requirements, and can then make adjustments to the testing policy to 
ensure that you have enough time to perform all the testing, and that no 
resources are wasted. For more information, see “Finalizing the Testing 
Policy” on page 231.

Analyzing the Testing Strategy

After you finalize how many resources to allocate to each requirement, you 
can view a report to analyze the conclusions you reached. For more 
information, see “Analyzing the Testing Strategy” on page 234.

For an example of using risk-based quality management to help you decide 
on a testing strategy for a requirement, see “Risk-Based Quality Management 
Example” on page 239.
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Assessing Requirements

For each assessment requirement under the analysis requirement, you can 
assign or calculate the Risk and Functional Complexity. The Risk Category is 
composed of its Business Criticality and Failure Probability. The Functional 
Complexity Category indicates the complexity of the requirement’s 
implementation. 

You determine the Business Criticality, Failure Probability, and Functional 
Complexity of a requirement by assigning them values directly or by 
assigning values to a set of criteria. If you do not determine these factors for 
a requirement, Quality Center does not include the requirement in the risk 
analysis.

You can customize these criteria, their possible values, and how these values 
determine the Business Criticality, Failure Probability, and Functional 
Complexity. You can also customize how the Business Criticality and Failure 
Probability are used to calculate the Risk. For more information, see the 
HP Quality Center Administrator Guide.

To assess a requirement:

 1 In the Requirement Details view of the Requirements module, select an 
assessment requirement and click the Risk tab. 

 2 Click the Risk Assessment tab.

 3 Determine the Risk Category of the selected requirement. For more 
information, see “Determining the Risk Category” on page 224.

 4 Determine the Functional Complexity Category of the selected requirement. 
For more information, see “Determining the Functional Complexity 
Category” on page 227.

 5 At the bottom of the Risk tab, in the Estimated development time box, you 
can type the estimated time needed to develop the requirement. 
Quality Center can then calculate the total estimated development time for 
an analysis requirement and its children as the sum of the estimated 
development times of the children. Assigning the estimated development 
time is optional, and does not affect the risk analysis.

 6 To ignore an assessment requirement when performing risk analysis, select 
Exclude from Analysis, located at the top of the Risk tab.
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Determining the Risk Category
You can assign or calculate the Risk Category of an assessment requirement. 
The Risk Category is composed of its Business Criticality and Failure 
Probability. 

The Business Criticality of a requirement is a measure of how important the 
requirement is to your business. It has three possible values: A - Critical, 
B - Important, and C - Nice to Have. For example, a requirement affecting a 
minor feature that is likely to be used rarely might be assigned a Nice to Have 
Business Criticality, whereas a requirement that is essential to your 
application’s functionality would probably be assigned a Critical Business 
Criticality.

The Failure Probability of a requirement is a measure of how likely a test on 
the requirement is to fail. It has three possible values: 1 - High, 2 - Medium, 
and 3 - Low. For example, a requirement whose implementation involves 
making significant changes across most areas of your application would 
probability be assigned a High Failure Probability. In contrast, a requirement 
that involves changing an icon in your application would probably not 
have many associated risks, and so is likely to be assigned a Low Failure 
Probability.
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To determine the Risk Category for a requirement:

 1 To determine the Business Criticality value for the requirement, perform the 
following steps:

 a In the Risk Assessment tab, click the Business Criticality tab. The Business 
Criticality tab displays a list of criteria used to determine Business 
Criticality.

 b Assign a value to each criterion. To assign a value to a criterion, in the 
Criterion column, click a criterion name and select a value from the 
Value column. You can view a description of a criterion in the 
Description of Criterion box.

After you have assigned a value to each criterion, the Calculated Business 
Criticality is updated according to the values you assigned to the criteria.
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 c To ignore the Business Criticality value calculated on the basis of the 
values for the criteria, and use instead a custom value when performing 
risk analysis, select Use custom Business Criticality. In the Use custom 
Business Criticality box, select the value which you want to use when 
performing risk analysis.

 2 To determine the Failure Probability value for the requirement, perform the 
following steps:

 a Click the Failure Probability tab.

 b Assign a value to each criterion. To assign a value to a criterion, in the 
Criterion column, click a criterion name and select a value from the 
Value column. You can view a description of a criterion in the 
Description of Criterion box.

After you have assigned a value to each criterion, the Calculated Failure 
Probability is updated according to the values you assigned to the 
criteria.
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 c To ignore the Failure Probability value calculated on the basis of the 
values for the criteria, and use instead a custom value when performing 
risk analysis, select Use custom Failure Probability. In the Use custom 
Failure Probability box, select the value which you want to use when 
performing risk analysis.

 3 To ignore the Calculated Risk value calculated on the basis of the values of 
the Business Criticality and Failure Probability, and use instead a custom 
value when performing risk analysis, select Use custom Risk. In the Use 
custom Risk box, select the value which you want to use when performing 
risk analysis.

Determining the Functional Complexity Category
You can assign or calculate the Functional Complexity Category of an 
assessment requirement. The Functional Complexity of a requirement 
indicates the complexity of the requirement’s implementation. It has three 
possible values: 1 - High, 2 - Medium, and 3 - Low. For example, a 
requirement whose implementation involves making significant changes to 
your application to enable it to communicate with other systems probably 
has a high complexity and would be assigned a High Functional Complexity. 
In contrast, a requirement that involves no significant changes to enable 
your application to communicate with other systems would probably not 
have many associated risks, and so is likely to be assigned a Low Functional 
Complexity.
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To determine the Functional Complexity Category for a requirement:

 1 In the Risk tab, click the Functional Complexity tab. The Functional 
Complexity tab displays a list of criteria used to determine Functional 
Complexity.

 2 Assign a value to each criterion. To assign a value to a criterion, in the 
Criterion column, click a criterion name and select a value from the Value 
column. You can view a description of a criterion in the Description of 
Criterion box.

After you have assigned a value to each criterion, the Calculated Functional 
Complexity is updated according to the values you assigned to the criteria.

 3 To ignore the Functional Complexity value calculated on the basis of the 
values for the criteria, and use instead a custom value when performing risk 
analysis, select Use custom Functional Complexity. In the Use custom 
Functional Complexity box, select the value which you want to use when 
performing risk analysis.
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Defining the Testing Policy Settings

After you have defined the Risk and Functional Complexity for each 
requirement, you determine how much time each requirement needs to be 
tested. The time needed to test a requirement depends on the Functional 
Complexity of the requirement. A requirement with a high Functional 
Complexity generally requires more testing time as it is more likely that the 
requirement’s implementation contains defects. For each Functional 
Complexity, you define the Testing Time needed to fully test a requirement 
with that Functional Complexity. 

Quality Center defines four Testing Levels: Full, Partial, Basic, and None. For 
partial and basic testing, you define how much Testing Time is required for a 
requirement as a percentage of full testing. For example, if 20 hours are 
required to perform full testing on a requirement and partial testing is 
defined as 75% of full testing, Quality Center calculates that 15 hours are 
required to perform partial testing on the requirement. A requirement 
whose Testing Level is set to None is not tested at all, and the Testing Effort 
is zero.

After you define the Testing Time required for each Testing Level and 
Functional Complexity, you can estimate at what Testing Level to test 
requirements. For each Risk and Functional Complexity Category, you 
assign a Testing Level. 

You can customize the testing policy used by default. For more information, 
see the HP Quality Center Administrator Guide.
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To define the testing policy settings for a requirement:

 1 In the Requirement Details view of the Requirements module, select an 
analysis requirement and click the Risk tab. Click the Show button to 
display the Change Analysis Constants section.

 2 Under Testing Time (full) per Functional Complexity, for each Functional 
Complexity value, type the estimated Testing Time required to fully test a 
requirement.

 3 Under Testing level, in the Partial and Basic boxes, type the default Testing 
Time required for partial testing and basic testing of a requirement. You 
express this as a percentage of the effort required for full testing.
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 4 In the Testing Policy grid, define the level at which to test a requirement of 
each Risk and Functional Complexity Category.

To define these levels, click the arrow next to the cell in the grid. Select a 
Testing Level from the available Testing Levels. The available Testing Levels 
are Full, Partial, Basic, and None. Next to each Testing Level, you can see the 
estimated time needed to test a requirement at that level, based on the 
Testing Efforts and Testing Levels you defined.

 5 To display the default constants used, click the Show Defaults button. The 
Risk-Based Quality Management Constants Defaults dialog box opens.

In the Risk-Based Quality Management Constants Defaults dialog box, you 
can click the Restore Defaults button to assign these default values to the 
constants used for the current requirement.

Click Close to close the Risk-Based Quality Management Constants Defaults 
dialog box.

Finalizing the Testing Policy

Based on the testing policy you defined, Quality Center can calculate the 
total estimated testing time for the analysis requirement and the assessment 
requirements under it. You estimate how much time you have available to 
test these requirements and make adjustments to the testing policy to make 
sure that the testing time required does not exceed the testing resources 
available.

For example, suppose you have 100 hours available to test a requirement. 
Quality Center estimates that you need 120 hours to test the requirement 
using the current Testing Levels. You decide to lower the Testing Level for 
requirements with Low Risk and Medium Functional Complexity from Partial 
to Basic. After you adjust the Testing Level and recalculate the testing time, 
Quality Center estimates that you need only 98 hours to perform the 
testing, which is within the time you have available. You can now plan the 
testing of your requirement based on Quality Center’s recommendations.
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To finalize the testing policy:

 1 Make sure that you have determined the Risk and Functional Complexity 
Categories of all assessment requirements that are located under the analysis 
requirement for which you want to finalize the testing policy, and that you 
want to include in the risk analysis. For more information, see “Assessing 
Requirements” on page 223.

 2 You can filter the requirements tree to include only the assessment 
requirements you want to include in the risk analysis. For more information 
on filtering, see “Filtering Records” on page 56.

 3 If you do not want to use the default Testing Effort and Testing Level values, 
make sure that you have defined custom values. For more information, see 
“Defining the Testing Policy Settings” on page 229.

 4 In the Requirement Details view of the Requirements module, select an 
analysis requirement and click the Risk tab.
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 5 In the Total allocated testing time box, type the time available to test the 
analysis requirement and the assessment requirements under it.

 6 Click the Perform Risk Analysis button. Quality Center calculates the Testing 
Level and Testing Time for each assessment requirement under the analysis 
requirement that matches the current filter. This calculation is based on the 
assessment requirements’ Risk Category, and the Testing Level and Testing 
Time values you defined for the analysis requirement. The results of this 
calculation are displayed in the following ways:

➤ Total required testing time. Displays the total calculated time required to 
test all the assessment requirements under the analysis requirement 
matching the current filter and included in the risk analysis.

➤ Total required development time. Displays the total time required to 
develop all the assessment requirements under the analysis requirement, 
based on the required development time you optionally estimated for 
each assessment requirement.

➤ No. of Requirements per Risk Category graph. Displays the number of 
sub-requirements of the analysis requirement of each Risk Category.

➤ Total Testing Time per Risk Category graph. Displays the total calculated 
testing time required to test all the requirements of each Risk Category.

 7 To display which requirements are included and which were not included in 
the analysis, click a segment in the Requirements per Risk graph, or the 
missing assessment or not assessable links. The Drill Down Results dialog 
box opens and displays a grid with a list of requirements in the category. 
You can determine the order and appearance of the columns and view 
details for an individual requirement. You can also export the contents of 
the grid as a text file, Microsoft Excel spreadsheet, Microsoft Word 
document, or HTML document. For more information, see “Exporting Data 
to a File” on page 74.
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Tip: The missing assessment link displays the requirements for which you 
did not determine a category or exclude explicitly from the analysis. Verify 
that there are no requirements that should be assigned a category. If you do 
not want to include a requirement in the analysis, then exclude it from the 
analysis explicitly.

 8 Compare the total calculated testing time with the resources you have 
available. If the resources you have available are not sufficient to test the 
requirement according to the current settings, you can reduce the Testing 
Level for a Risk Category, or reduce the Testing Time assigned to each 
Testing Level, and perform the calculation again. For more information on 
changing the Testing Levels and Testing Times, see “Defining the Testing 
Policy Settings” on page 229.

 9 When you are satisfied with the testing policy, click the Save and Apply to 
Children button to apply it to all assessment requirements under the 
analysis requirement that match the current filter.

 10 You can now analyze how the testing policy you created for the analysis 
requirement affects the assessment requirements under it, and produce a 
report detailing your testing strategy. For more information, see “Analyzing 
the Testing Strategy” on page 234.

Analyzing the Testing Strategy

After you have finalized your testing policy for an analysis requirement, you 
can analyze the testing strategy for the analysis requirement and for the 
assessment requirements under it. The analysis results are only valid for the 
requirements at the time the analysis was last performed. If you 
subsequently modify the Risk or Functional Complexity Categories of the 
requirements, or the testing policy, you should re-perform the analysis.

This section describes:

➤ Analyzing the Testing Strategy for Analysis Requirements

➤ Analyzing the Testing Strategy for Assessment Requirements
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Analyzing the Testing Strategy for Analysis Requirements
After you have finalized your testing policy for an analysis requirement, you 
can generate a report detailing your testing strategy. The report is saved as a 
Microsoft Word document in a specific file directory. It can also be saved as 
an attachment to the analysis requirement.

Note: To generate the report, Microsoft Word and Excel must be installed on 
your machine.

To analyze the testing strategy for an analysis requirement:

 1 In the Requirement Details view of the Requirements module, select an 
analysis requirement and click the Risk tab.

 2 Make sure that you save the analysis and apply it to all assessment 
requirements under the analysis requirement. Click the Save and Apply to 
Children button. Click OK.

 3 Click the Generate Report button. The Generate Report dialog box opens.

 4 In the Default Location box, type the location and name of the Word file to 
which you want the data to be exported. You can click the browse button to 
select a location from the Save As dialog box.

 5 To also add the report as an attachment to the analysis requirement, select 
Add report as attachment.
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 6 To include a list of the requirements, select Include list of requirements in 
the report.

 7 Click Generate. A report is generated and saved in the location you 
specified.

The report may contain the following headings, depending on the options 
you selected in the Generate Report dialog box:

Heading Description

Date last saved The date on which the risk analysis was last 
performed.

Filter The filter used to determine which requirements 
were included in the risk analysis.

Processed The number of requirements included in the risk 
analysis. Also provides a breakdown of which 
requirements had assessment, which were missing 
assessment, and which were not assessable.

Total required testing time The total time required to test the requirements 
included in the risk analysis, according to the 
testing policy you determined.

Total allocated testing 
time

The total time allocated to test the requirements 
included in the risk analysis.

Total required 
development time

The total time required to develop the features 
defined by the requirements.

No. of Requirements per 
Risk Category

A graph displaying a breakdown of the number of 
requirements by their Risk Category.

Total Testing Time per Risk 
Category

A graph displaying the total time needed to test all 
the requirements of each Risk Category.

Implemented testing 
policy

The time necessary to test requirements belonging 
to each Risk Category, according to the testing 
policy used in the risk analysis.

Analyzed requirements A list of the requirements included in the risk 
analysis which had assessments, together with their 
Risk Category, Testing Level, and Testing Time.
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Analyzing the Testing Strategy for Assessment 
Requirements
After you have finalized your testing policy for an analysis requirement, you 
can analyze its effect on the assessment requirements under the analysis 
requirement.

To analyze the testing strategy for an assessment requirement:

 1 In the Requirement Details view of the Requirements module, select an 
assessment requirement and click the Risk tab. Click the Analysis Results tab.

Requirements with 
missing assessments

A list of the requirements included in the risk 
analysis which did not have assessments.

Not assessable 
requirements 

A list of the requirements that cannot be assessed. 
These may be requirements explicitly excluded 
from the analysis, or requirements belonging to a 
type that does not support risk-based quality 
management.

Heading Description
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The Analysis Results tab displays the conclusions of the last analysis you 
performed on an analysis requirement that is a parent of the assessment 
requirement:

➤ Based on analysis requirement. Displays the analysis requirement on 
which the last analysis that included the current requirement was 
performed. You can click the analysis requirement’s name to go to the 
analysis requirement in the requirements tree.

➤ Last analysis on date. The date on which the last analysis that included 
the current requirement was performed.

➤ Overall Risk Assessment. Calculates the risk based on the Business 
Criticality and Failure Probability for the requirement.

➤ Calculated Testing Level. The level at which to test the requirement, as 
calculated in the last analysis that included the current requirement.

➤ Calculated Testing Time. The time allocated to test the requirement, as 
calculated in the last analysis that included the current requirement.

 2 To override the calculated values in the next calculation, and instead use 
custom values, select the Use these for the next calculation check box. In 
the Testing Level box, select the Testing Level to use for the next calculation. 
In the Testing Time box, type the Testing Effort to use for the next 
calculation. When you next perform an analysis that includes the current 
requirement, these values will be used instead of the calculated values.
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Risk-Based Quality Management Example

Suppose you are using a project based on an application for reserving flights 
and vacations. You want to plan the testing of the analysis requirement 
Online Travel Information Source, located under Mercury Tours Application.

You begin by assigning values to the Business Criticality criteria for the child 
assessment requirement Itineraries Information. As information on travel 
itineraries is for display purposes and does not involve calculation or 
validation, you assign the value Display to the criterion Type of Process. As 
incorrect information on travel itineraries could result in legal action, you 
assign the value Legal to the criterion Impact of failure. 

You also assign the value Very often to the criterion Frequency of use, and 
the value Many/High to the criterion Number/Significance of affected users. 
Quality Center now calculates the Business Criticality of the requirement as A.
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Similarly, you determine the Failure Probability by assigning values to its 
criteria. Quality Center calculates the Failure Probability as 2. Next, you 
determine the Functional Complexity by assigning values to its criteria. 
Quality Center calculates the Functional Complexity as 1. The overall Risk 
Category is A and the overall Functional Complexity is 1. 

You then proceed to determine the Risk and Functional Complexity for each 
of the assessment requirements Maps, Travel Guides, and Tips & FAQ.

You are now ready to perform a risk analysis on the requirement Online 
Travel Information Source. You decide to use Quality Center’s default testing 
policy and perform a risk analysis based on this policy. Quality Center 
calculates that you need 60 hours to test the requirement. However, you 
only have 50 hours available, which is 83% of the required resources, so 
need to modify the testing policy.
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You change the Testing Level for requirements with Risk Category A3 from 
Full to Basic. Quality Center re-calculates the time needed to test the 
requirement as 52 hours, which is still greater than the time available. You 
therefore modify the definition of basic testing by defining it as 20% of full 
testing instead of 34%. The time needed to test the requirement is now 
estimated at 50 hours, which is the amount of time you have available, so 
you decide to accept this modified testing policy.

You now have sufficient resources to test the requirement, so you create a 
risk analysis report to summarize the testing strategy recommended by 
Quality Center, and give it to your organization to use as a basis for their 
test plan.
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Part IV

Test Planning





245

16
The Test Plan Workflow

Developing a clear and concise test plan is fundamental to successful 
application testing. A good test plan enables you to assess the quality of 
your application at any point in the application management process.

This chapter describes how you develop a test plan using the Test Plan 
module. Developing a test plan consists of the following: 

Define
Testing Strategy

Define
Test Subjects

Design
Tests

Create Requirements 
Coverage

Design
Test Steps

Automate
Tests

Analyze
Test Plan

Establish Baseline
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Defining Testing Strategy

Outline a strategy for achieving your requirements, as defined in the 
Requirements module. Ask yourself two basic questions: 

How should you test your application?

➤ Which testing techniques will you use (stress tests, security tests, 
performance and load tests, etc.)? 

➤ How will you handle defects (severity classification, authorization to open 
and close defects, etc.)?

What resources do you require?

➤ What resources do you require to test (personnel, hardware, etc.)?

➤ When will the various tasks be completed?

For example, consider a flight reservation application that lets you manage 
flight scheduling, passenger bookings, and ticket sales. Testing will require 
designing both manual and automated tests. You could assign testing 
personnel with programming experience the task of designing automated 
tests, while non-programmers could design manual tests.

Defining Test Subjects

Consider the hierarchical relationship of the functions in your application. 
Divide the functions into subjects and build a test plan tree representing 
your application’s functionality. 

The test plan tree is a graphical representation of your test plan. It is a 
hierarchical list of tests organized according to topic, which describes the set 
of tests you will implement in order to meet your quality requirements. For 
example, the flight reservation application could require that you include 
Flight Finder, Book Flight, Flight Confirmation, and Flight Cost as test 
subjects.

For a complete description and illustration of how to create a test plan tree, 
see Chapter 18, “Developing the Test Plan Tree”.
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Designing Tests

Plan tests for each subject in your test plan tree. Decide which types of tests 
to create for each subject, such as sanity level tests or regression tests. (For an 
explanation of these test types, see Chapter 28, “Creating Test Sets”.) Then 
create the tests and assign them to a branch of the test plan tree. For 
example, in the flight reservation application, you could include the 
following tests under the subject Flight Finder: Airline Preference, Departing 
and Arriving Locations, Departing Date, Find Flight, Flight Time Preference, 
and Number of Passengers.

You can link a test to specific defects. This is useful, for example, when a 
new test is created specifically for a known defect. By creating a link, you 
can determine if the test should be run based on the status of the defect. 

For information on planning tests, see Chapter 18, “Developing the Test 
Plan Tree”.

You can include parameters in your manual tests. This enables you to run 
the same test repeatedly and assign the parameters different values. For 
more information, see “Working with Parameters in Manual Tests” on 
page 317.

You can also associate your tests with a set of resources that you upload to 
your Quality Center repository. You can then view these dependencies and 
determine the resources that are in use. This is useful, for example, when 
you copy tests between projects. The tests along with the related resources 
are copied to the new project. For more information on resources, see 
Chapter 24, “Managing Test Resources”, and Chapter 25, “Viewing 
Dependencies”.
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Creating Requirements Coverage

Link each test in the test plan tree with a requirement or requirements in 
the requirements tree. By defining requirements coverage for a test, you can 
keep track of the relationship between the tests in your test plan and your 
original requirements. For example, in the flight reservation application, the 
tests in the subject Registration cover the requirement topic Customer 
Personal Information.

For information on requirements coverage, see Chapter 19, “Requirement 
and Test Coverage”.

Designing Test Steps

Design the tests in your test plan tree. Create test steps describing the 
operations to perform and the expected results. After you define the test 
steps, decide whether to perform the test manually or to automate it.

For manual tests you define steps, execute them on your application, and 
record the results of each step. Use manual tests in cases where the test 
requires a response by the tester. Manual tests include usability tests, one-
time tests, tests that need to be run immediately, tests requiring knowledge 
of the application, and tests without predictable results. 

For example, in the flight reservation application, tests that check if a dialog 
box is user-friendly require user response. Therefore, you should make these 
tests manual.

You can include a step that calls another manual test. This is useful if you 
have common steps that you want to perform as part of other tests.

For information on designing test steps, see Chapter 20, “Building Tests.”
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Automating Tests

Automating a test allows unattended execution of the test at high speed. It 
also makes the test reusable and repeatable. For example, you automate 
functional, benchmark, unit, stress and load tests, as well as tests requiring 
detailed information about applications. 

After designing test steps, you can decide which tests to automate. Factors 
influencing test automation include frequency of execution, volume of data 
input, length of execution time, and complexity. 

For automated tests, you can first design test steps and automate them by 
generating a test script. The test script can be for WinRunner, QuickTest 
Professional, LoadRunner, QAInspect, or Visual API-XP.

For example, in the flight reservation application, you can automate a test 
that checks whether the login mechanism works. After adding test steps, 
you create a test script. Then, using QuickTest Professional, you complete 
the automated test script.

For more information on creating automated tests, see Chapter 22, 
“Creating Automated Tests.”

You can also create automated system tests that provide system information 
for a machine, capture a desktop image, or restart a machine. For more 
information, see Chapter 23, “Working with System Tests”.
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Analyzing Your Test Plan

Review your test plan to determine how well it meets the goals that you 
defined at the beginning of the application management process. Then, 
analyze your test plan by generating reports and graphs. For more 
information, see Chapter 40, “The Dashboard Module.”

For example, you can create a report that displays design step data for each 
test in a test plan tree. You can then use this report to help you determine 
your test design priorities.

To best ensure the success of the application management process, analyze 
your test plan throughout the process. Review the plan, and determine 
whether or not it matches your testing goals. Make adjustments to your test 
plan accordingly.

Establishing a Baseline

After your test plan has been reviewed and approved, you can create a 
baseline. A baseline provides you with a snapshot of your test plan at a 
specific point in time. You can use a baseline to mark any significant 
milestone in the application life cycle. The baseline then serves as a point of 
reference against which changes can be compared.

For more information on baselines, see Chapter 38, “Libraries and 
Baselines.”
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17
The Test Plan Module at a Glance

This chapter introduces the key elements in the Test Plan module.

This chapter includes:

 ➤  The Test Plan Tree on page 252

 ➤  The Test Plan Menu Bar on page 254

 ➤  The Test Plan Toolbar on page 255

 ➤  The Test Grid on page 257
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The Test Plan Tree

You design tests in Quality Center in the Test Plan module, which you open 
by clicking the Test Plan button on the sidebar. To view the test plan tree, 
choose View > Test Plan Tree. 

The test plan tree contains the following key elements:

➤ Test Plan menu bar. Displays drop-down menus of Test Plan module 
commands. For more information, see “The Test Plan Menu Bar” on 
page 254.

➤ Test Plan toolbar. Contains buttons of commands commonly used when 
creating and modifying the test plan tree. For more information, see “The 
Test Plan Toolbar” on page 255.

➤ Test Plan Tree. A graphical representation of your test plan. For more 
information, see Chapter 18, “Developing the Test Plan Tree.” For a list of 
test icons, see “Viewing the Test Plan Tree” on page 271.

➤ Details tab. A description of the test currently selected on the test plan tree. 
For more information, see Chapter 18, “Developing the Test Plan Tree.”
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➤ Design Steps tab. A list of test steps explaining how to execute the test 
currently selected on the test plan tree. The tab includes an icon  if the 
selected test has design steps. For more information, see Chapter 20, 
“Building Tests.”

➤ Test Script tab. The test script for the test currently selected on the test plan 
tree. The tab includes an icon  if the selected test has a test script. For 
more information, see Chapter 22, “Creating Automated Tests.” For more 
information on using the Test Script tab in Business Process Testing, refer to 
the HP Business Process Testing User Guide.

➤ Test Parameters tab. A list of parameters associated with the test currently 
selected on the test plan tree. Parameters can be incorporated in the test’s 
design steps. The tab includes an icon  if the selected test has any 
parameters. For more information, see Chapter 21, “Working with 
Parameters in Manual Tests.”

➤ Attachments tab. A list of attachments that provide additional information 
for the test currently selected on the test plan tree. The tab includes an 
icon  if the selected test has any attachments. For more information, see 
Chapter 5, “Adding Attachments.”

➤ Req Coverage tab. A list of the requirements that are met by the test 
currently selected on the test plan tree. The tab includes an icon  if the 
selected test has requirements coverage. For more information, see 
Chapter 19, “Requirement and Test Coverage.”

➤ Linked Defects tab. A list of the defects that are linked to the test currently 
selected in the test plan tree. For more information, see Chapter 36, 
“Linking Defects.”

➤ Dependencies tab. A list of dependencies that are associated with the test 
currently selected in the test plan tree. For more information, see 
Chapter 25, “Viewing Dependencies.”

➤ Live Analysis tab. A graphical representation of test data related to the 
selected subject folder in the test plan tree. For more information, see 
Chapter 44, “Generating Live Analysis Graphs.”

➤ History. A list of changes made to the currently selected test. For more 
information, see “Viewing Test History” on page 274. Also displays a history 
of baselines in which the test appears. For more information, see “Viewing 
Baseline History” on page 524.
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Tip: To find a specific test by Test ID in the test plan tree, choose Tests > 
Go to Test, and type the test ID. To display the test ID, select the Test ID 
column using the Select Columns dialog box. You can only go to tests that 
are in the current filter.

The Test Plan Menu Bar 

The Test Plan menu bar has the following menus:

➤ The Tests menu contains commands that enable you to manage the folders 
and tests in the tree, go to tests in test sets, and to mail tests. For more 
information, see Chapter 18, “Developing the Test Plan Tree.” 

➤ The Edit menu contains commands that enable you to cut, copy, paste, 
rename, delete, find, or search tests. You can also update selected tests, view 
and clear alerts for tests, and flag tests for follow-ups. For more information 
on alerts and follow-ups, see Chapter 4, “Alerting on Changes.”

➤ The Versions menu is available in a version control enabled project. It 
contains commands that enable you to check in and check out tests, undo a 
checkout, or view all the tests you have checked out. For more information, 
see Chapter 7, “Working with Version Control.”

➤ The View menu contains commands that enable you to set the display of 
tests in the test plan tree or grid, filter and sort the tests, and set the 
displayed columns.

➤ The Favorites menu contains commands that enable you to add and 
organize favorite views. Available only in Test Grid. For more information 
on favorite views, see Chapter 6, “Working with Favorite Views.”

➤ The Analysis menu contains commands that enable you to generate 
planning reports and graphs. For more information on planning reports, see 
Chapter 42, “Generating Standard Reports.” For more information on 
planning graphs, see Chapter 41, “Generating Graphs,” and Chapter 44, 
“Generating Live Analysis Graphs.”
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Tip: You can access the Test Plan menu bar from the Test Plan module by 
pressing the shortcut key F9. Additionally, you can perform many other 
Quality Center operations using shortcut keys. For a list of shortcut keys, see 
Appendix B, “Quality Center Keyboard Shortcuts.”

The Test Plan Toolbar 

The Test Plan toolbar has the following buttons:

New Folder. Adds a new subject folder to the test plan tree. For more 
information, see “Creating a Test Plan Tree” on page 265.

New Test. Adds a new test to the test plan tree. For more information, see 
“Adding Tests to a Test Plan Tree” on page 266.

Delete. Deletes the selected folder or test from the tree. For more 
information, see “Deleting a Folder or Test” on page 285.

Refresh All. Refreshes the test plan tree so that it displays the most up-to-
date tests.

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
the tests in the test plan tree. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied to the 
test plan tree.

For more information on filtering and sorting tests, see Chapter 3, “Working 
with Quality Center Data.”

Sort Folders. Opens the Sort Folders in Test Plan Tree dialog box, enabling 
you to custom sort the folders in the test plan tree. By default, folders are 
sorted by name. For more information, see “Sorting a Test Plan Tree” on 
page 283.
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Flag for Follow Up. Opens the Flag For Follow Up dialog box, enabling you 
to add or modify a follow up flag for a test. For more information, see 
“Flagging for Follow Up” on page 82.

Send by E-mail. Opens the Send by E-mail dialog box, enabling you to send 
email containing the selected tests to recipients selected from a list, or to 
any other email addresses. For more information, see “Mailing Tests” on 
page 275.

Text Search. Opens the text search pane in the lower part of the window, 
enabling you to enter keywords and search predefined fields. For more 
information, see “Searching Records” on page 72.

Version Control. The Test Plan toolbar displays the following additional 
buttons for version control:

➤ Check Out. Opens the Check Out dialog box, enabling you to check out 
the selected test.

➤ Check In. Opens the Check In dialog box, enabling you to check in the 
selected test.

For more information on version control, see Chapter 7, “Working with 
Version Control.”
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The Test Grid 

The Test Grid displays all the tests in a Quality Center project. Each row 
displays a separate test record. Each column represents a separate data item.

To view the Test Grid, choose View > Test Grid. 

You can view and modify test information in the Test Grid. For example, 
you can copy several automated tests and paste them in another project, or 
you can delete several tests at once. In addition, you can save the grid 
information in several formats, including a text file, Word document, HTML 
document, XML document, and Excel spreadsheet.
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The Test Grid contains the following key elements:

➤ Test Grid toolbar. Contains buttons of commands commonly used when 
creating and modifying the Test Grid. For more information, see “The Test 
Grid Toolbar” on page 259.

➤ Indicator columns. Indicates that the specified test has attachments, linked 
defects, alerts, and follow up flags. Choose View > Indicator Columns to 
display these columns.

➤ Grid filter. Displays the filter that is currently applied to a column. For more 
information, see “Filtering Records” on page 56.

➤ Description tab. Displays a description of the selected test in the Test Grid.

➤ Attachments tab. Displays the attachments for the selected test. For more 
information, see Chapter 5, “Adding Attachments.”

➤ History tab. A list of changes made to the currently selected test. For more 
information, see “Viewing Test History” on page 274. Also displays a history 
of baselines in which the test appears. For more information, see “Viewing 
Baseline History” on page 524.

Column Description

Attachments Click the  icon to view attachments for the test. 
For more information, see Chapter 5, “Adding 
Attachments.”

Linked Entities Click the  icon to view linked entities for the test. 
For more information, see Chapter 36, “Linking 
Defects.”

Alerts Click the  icon to view alerts for the test. For more 
information, see “Viewing Alerts” on page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
test. For more information, see “Flagging for Follow 
Up” on page 82.
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Tip: To find a specific test by Test ID in the Test Grid, choose Test > 
Go to Test, and type the test ID. To display the test ID, select the Test ID 
column using the Select Columns dialog box.

The Test Grid Toolbar
The Test Grid toolbar has the following buttons:

Delete Selected Tests. Deletes the selected tests from the Test Grid.

Refresh All. Refreshes the Test Grid so that it displays the most up-to-date 
tests. 

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter, sort, 
and group the tests in the Test Grid.

➤ Clear Filter/Sort. Clears any filters, sorting, or grouping that you have 
applied to the Test Grid.

For more information on filtering and sorting tests, see Chapter 3, “Working 
with Quality Center Data.”

Select Columns. Opens the Select Columns dialog box, enabling you to 
determine which columns to display in the grid and their order. For more 
information, see “Arranging Columns” on page 52.

Go to Test in Test Plan Tree. Closes the Test Grid and displays the selected 
test in the test plan tree.

Attachments. Opens the Attachments dialog box, enabling you to add an 
attachment to the selected test. For more information, see Chapter 5, 
“Adding Attachments.”

Flag for Follow Up. Opens the Flag For Follow Up dialog box, enabling you 
to add or modify a follow up flag for a test. For more information, see 
“Flagging for Follow Up” on page 82.
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Send by E-mail. Opens the Send by E-mail dialog box, enabling you to send 
email containing the selected test to recipients selected from a list, or to any 
other email addresses. For more information, see “Mailing Tests” on 
page 275.

Text Search. Opens the text search pane in the lower part of the window, 
enabling you to enter keywords and search predefined fields. For more 
information, see “Searching Records” on page 72.

Version Control. The Test Grid toolbar displays the following additional 
buttons.

➤ Check Out. Opens the Check Out dialog box, enabling you to check out 
the selected test.

➤ Check In. Opens the Check In dialog box, enabling you to check in the 
selected test.

For more information on version control, see Chapter 7, “Working with 
Version Control.”

Test Grid Columns
The Test Grid displays the following test planning data columns:

Column Description

Comments Displays comments about the test.

Creation Date The date on which the test was created. By default, the 
creation date is set to the current server date. Click the 
down arrow to display a calendar and select a different 
creation date.

Description Describes the test.

Designer The user name of the person who designed the test.

Estimated DevTime The time estimated to design and develop the test.

Execution Status The execution status of the last run of an instance of 
the test. Execution status can be one of the following: 
Failed, N/A, No Run, Not Completed, Passed.

Modified The date and time of the last change to the test.
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Path The path of this test relative to the Tests directory in 
the project repository.

Status The planning status of the test. The default status is 
Design.

Subject The subject folder in the test plan tree in which the 
test resides.

Template Indicates whether the manual test or QuickTest 
Professional test is a test template. The value in this 
column is Y if the test is a test template; N or empty 
otherwise. For more information on manual template 
tests, see “Viewing Instances of Tests” on page 273. For 
more information on QuickTest Professional template 
tests, see “Adding Tests to a Test Plan Tree” on 
page 266.

Test ID A unique numeric ID for the test, assigned 
automatically by Quality Center. The field is read-
only. 

Test Name The name of the test.

Type The type of test. For example, manual or WinRunner. 
The field is read-only.

Column Description
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Version Control: The Test Grid displays the following additional fields:

Notes: 

➤ You can add user-defined fields and change the label of any of the fields 
in the Test Grid. You can also customize project lists. For more 
information, refer to the HP Quality Center Administrator Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Test Grid. For more information, refer to the 
HP Quality Center Administrator Guide.

➤ When you select a Test Grid column with a user name value, 
Quality Center displays a list with the name and full name of each user. 
You can search for users, sort users, group users by user group, and select 
users from the users list or a group tree. For more information, see 
“Selecting Users” on page 55.

Field Description

Version Owner
The name of the user who performed the last action 
(check in or check out).

Version Date
The date of the last action (check in or check out) 
performed for the version.

Version Number The version number.

Version Status The status of the version (Checked Out or Checked In).

Version Time
The time of the last action (check in or check out) 
performed for the version.
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18
Developing the Test Plan Tree

The test plan tree organizes and displays your tests hierarchically, according 
to test subjects.

This chapter includes:

 ➤  About the Test Plan Tree on page 264

 ➤  Creating a Test Plan Tree on page 265

 ➤  Adding Tests to a Test Plan Tree on page 266

 ➤  Viewing the Test Plan Tree on page 271

 ➤  Viewing Instances of Tests on page 273

 ➤  Viewing Test History on page 274

 ➤  Mailing Tests on page 275

 ➤  Finding Tests in the Tree or Test Grid on page 277

 ➤  Replacing Field Values in the Test Grid on page 280

 ➤  Updating Multiple Records in the Test Grid on page 281

 ➤  Copying Tests on page 281

 ➤  Copying URLs of Tests on page 283

 ➤  Sorting a Test Plan Tree on page 283

 ➤  Modifying a Test Plan Tree on page 285
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About the Test Plan Tree

The typical application is too large to test as a whole. The Test Plan module 
enables you to divide your application according to functionality. You 
divide your application into units, or subjects, by creating a test plan tree. 
This is a graphical representation of your test plan, displaying your tests 
according to the hierarchical relationship of their functions. 

After you define subjects in the tree, you decide which tests to create for 
each subject and add them to the tree. At this stage, you define basic 
information about the test, such as its name, status, and the designer. You 
can also attach a file, URL, application snapshot or system information to 
illustrate a test. Afterwards, you define the test steps. Test steps contain 
detailed instructions on how to execute a test and evaluate the results.

During the application management process, you may need to modify your 
test plan. You can update the test plan tree at any time.

There are a number of methods for organizing your test plan by subject. For 
example, you could define subjects according to:

➤ Application functionality—such as editing, file operations, and reporting

➤ Type of testing—such as functional, user interface, performance, and load

Suppose you are testing a flight reservation application that lets you manage 
flight scheduling, passenger bookings, and ticket sales. (For the complete 
example, refer to the QualityCenter_Demo project.) You might define the 
following subjects for the test plan tree:
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Notice how, for example, the Itinerary subject contains additional subject 
folders. These folders further categorize the tests in the test plan tree by 
creating additional levels of subjects.

After you build the basic structure of your plan, you create tests and assign 
them to each subject. For example, in the test plan tree shown above, you 
might assign tests to the Reservation Details subject folder as follows:

Note: Developing and editing a test plan tree requires appropriate user 
permissions. For more information, refer to the HP Quality Center 
Administrator Guide.

Creating a Test Plan Tree

You define a hierarchical framework for your test plan by creating a test plan 
tree that may contain folders and subfolders. 

Note: In addition to creating a test plan tree directly in Quality Center, you 
can also import test plan data from Microsoft Word or Microsoft Excel to 
your Quality Center project. To import from Word, you must install the 
HP Quality Center Microsoft Word Add-in and the HP Quality Center 
Connectivity Add-in. To import from Excel, you must install the 
HP Quality Center Microsoft Excel Add-in and the HP Quality Center 
Connectivity Add-in. You can install the add-ins from the HP Quality Center 
Add-ins page. For more information, refer to the HP Quality Center 
Installation Guide.
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To create a test plan tree:

 1 In the test plan tree, select a subject folder and click the New Folder button, 
or choose Tests > New Folder. The New Folder dialog box opens.

 2 In the Folder Name box, type a name for the subject and click OK. Note that 
a folder name cannot include the following characters: \ ^ *

The new subject folder appears under Subject in the test plan tree.

 3 In the Description tab, type a description of the subject. 

 4 Click the Attachments tab to add an attachment to the new folder if 
necessary. An attachment can be a file, URL, snapshot of your application, 
an item from the Clipboard, or system information. For more information, 
see Chapter 5, “Adding Attachments.”

 5 To create additional subjects at the main level, repeat steps 1 to 4.

 6 To create a subfolder, select a subject folder and repeat steps 1 to 4. 

Adding Tests to a Test Plan Tree 

After you have created a test plan tree containing the main test subjects, you 
are ready to create tests. Each test should have a distinct objective, such as 
verifying a specific function or system requirement. The tests you define 
should be based on the goals you set at the beginning of the application 
management process.

For example, in the flight reservation application, you could define a test 
called Password Verification that checks that only users that provide the 
correct password can sign on. You could place this test under the subject 
Sign-On/Sign-Off.
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Tip: You can automatically create tests based directly on your requirements 
in the Requirements module. For more information, see “Creating Tests 
from Requirements” on page 200.

To add a new test:

 1 Choose a subject folder in the test plan tree.

 2 Click the New Test button, or choose Tests > New Test. The Create New Test 
dialog box opens.

Note: If you have installed the QuickTest Professional Add-in on your 
machine, the Create New Test dialog box includes the Template box.

 3 Select a test type from the Test Type list. You can select the following test 
types:

Test Type Description

MANUAL A Quality Center manual test.

WR-AUTOMATED A test that is executed by WinRunner, HP’s functional 
testing tool for Microsoft Windows applications.

LR-SCENARIO A scenario that is executed by LoadRunner, HP’s load 
testing tool.
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 4 In the Test Name box, type a name for the test. A test name cannot include 
the following characters: \ / : " ? < > | * % ' 

 5 If you selected QUICKTEST_TEST from the Test Type list, the Template box is 
available. You create your new test based on another QuickTest test, defined 
as a template test. The template test is copied to your new test, without the 
test results. 

QUICKTEST_TEST A test that is executed by QuickTest Professional, HP’s 
functional enterprise testing tool. 

This test type is only available if you have installed the 
appropriate add-in from the HP Quality Center Add-ins 
page. For more information on installing add-ins, refer to 
the HP Quality Center Installation Guide.

VAPI-XP-TEST A test that is created using Visual API-XP, the 
Quality Center open test architecture API testing tool. For 
more information, see Appendix A, “Working with 
VAPI-XP.”

SYSTEM-TEST A test that instructs Quality Center to provide system 
information, capture a desktop image, or restart a 
machine. For more information, see Chapter 23, 
“Working with System Tests.”

QAINSPECT-TEST A test that is executed by QAInspect, the HP security 
testing tool.

BUSINESS-PROCESS A business process test. For more information, refer to the 
HP Business Process Testing User Guide.

FLOW A test comprising a collection of business components in 
a fixed sequence that performs a specific task. For more 
information, refer to the HP Business Process Testing User 
Guide.

Test Type Description
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Note: To set the QuickTest add-ins that Quality Center associates with a new 
QuickTest test, choose a template test that lists the appropriate add-ins. 
Alternatively, use the default template test provided on your Quality Center 
client. This test loads the Web and ActiveX add-ins by default. For more 
information, refer to the QuickTest documentation and the relevant 
QuickTest add-in documentation.

To select a template test, click the browse button. The Select Tests dialog box 
opens. By default, only QuickTest template tests are displayed. 

Select the template test and click the Add Test button. The Select Tests 
dialog box closes and the template test is displayed in the Template box.

Note: To set a QuickTest Professional test as a template test, right-click the 
test in the test plan tree, and choose Mark as Template Test.

 6 Version Control:

➤ Select Check out immediately to keep the test checked out after it is 
created. This enables you to continue to define the test after it is created, 
such as by defining design steps or adding parameters. By default, this 
option is selected.

➤ In the Comments box, type a brief description of the reason for the 
checkout. The Comments box is enabled only if the Check out 
immediately check box is selected.

 7 Click OK to close the Create New Test dialog box.

If required test fields were defined in the Project Customization window, the 
Required Test Fields dialog box opens. Select values for the required fields, 
and click OK.

The new test appears in the test plan tree under the subject folder you 
selected. In the Details tab, the name is added to the Test Name box.
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 8 Enter the following test details in the Details tab:

Note: You can change the label of any of the test detail fields. You can also 
add user-defined fields to the test details. For more information, refer to the 
HP Quality Center Administrator Guide.

 9 In the Details tab, click the Description tab and type a description for the 
test.

 10 In the Details tab, click the Comments tab to add a comment to the test. In 
the Comments tab, click the Add Comment button. A new section is added 
to the Comments tab, displaying your user name and the database’s current 
date.

 11 Click the Test Parameters tab to add parameters to the new test, if necessary. 
In the Test Parameters tab, click the New Parameter button. For more 
information, see Chapter 21, “Working with Parameters in Manual Tests.”

 12 Click the Attachments tab to add an attachment to the new test, if 
necessary. An attachment can be a file, URL, snapshot of your application, 
an item from the Clipboard, or system information. For more information, 
see Chapter 5, “Adding Attachments.”

 13 Click the Req Coverage tab to define requirements coverage. For more 
information, see Chapter 19, “Requirement and Test Coverage.”

Option Description

Designer The person who designed the test. By default, the name of the 
user who is currently logged in to Quality Center is displayed. 
Click the down arrow to select a different user name.

Creation Date The date on which the test was created. By default, the creation 
date is set to the current database server date. Click the down 
arrow to display a calendar and select a different creation date.

Status The current status of the test. The default status is Design. Click 
the down arrow to select a different status from the list.
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 14 Click the Linked Defects tab to link defects to the test. For more 
information, see Chapter 36, “Linking Defects.”

 15 Click the Design Steps tab to define steps for the test. For more information, 
see Chapter 20, “Building Tests.”

Viewing the Test Plan Tree

Use the test plan tree to review the overall structure of your test plan and to 
view the tests assigned to each subject.

A test plan tree can include the following test icons:

Manual test

Manual test that includes test steps

Manual Template test

Manual Template test that includes test steps

Business process test

Flow of business components

WinRunner test
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Version Control: The test plan tree can include the following additional 
icons.

To view tests in the test plan tree:

By default, the test plan tree displays only the highest level subjects in the 
subject hierarchy.

➤ To expand a branch in the tree, click the Expand  sign to the left of the 
branch name. To expand all the branches in the tree, right-click the Subject 
folder and choose Expand All. 

➤ To collapse a branch in the tree, click the Collapse  sign to the left of the 
branch name. To collapse all the branches in the tree, right-click the Subject 
folder and choose Collapse.

➤ To view tests associated with a particular subject, double-click a subject 
folder . 

➤ To refresh all tests in the test plan tree, click the Refresh All button.

WinRunner batch test

For more information on creating and working with WinRunner batch 
tests, refer to the HP WinRunner User Guide.

LoadRunner scenario

QuickTest Professional test

QuickTest Professional Template test

QuickTest Professional test that includes test steps

QuickTest Professional Template test that includes test steps

Visual API-XP test 

System test

Vuser Script test

QAInspect test

The test is checked out by the current user.

The test is checked out by a different user.
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➤ Click the Set Filter/Sort button to filter and sort the tests in the test plan 
tree. For more information, see Chapter 3, “Working with Quality Center 
Data.” Any currently applied filters or sorting orders are displayed under the 
test plan tree toolbar.

➤ To view all the tests in a Quality Center project at once, choose View > Test 
Grid. 

Viewing Instances of Tests

You can view instances of tests you create in test sets in the Test Lab module. 
You can view which test sets contain an instance of a test, and go to such a 
test instance in the Test Lab module.

To view an instance of a test:

 1 In the test plan tree, select a test and choose Tests > Go to Test in Test Set. 
Alternatively, right-click a test and choose Go to Test in Test Set. If there is 
only one instance of the selected test, the Test Lab module opens with the 
instance highlighted. If there is more than one instance, the Select Test Set 
dialog box opens.

 2 In the Test Set box, select the test set containing the test instance you want 
to go to, from the list of all test instances containing the test.

 3 In the Test Instance box, select the instance of the test from the test 
instances in the selected test set.

 4 Click OK. The Test Lab module opens with the selected test instance 
highlighted.
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Viewing Test History

You can view a list of changes made to any test in the test plan tree. 

You can also view previous versions of the test stored in a particular 
baseline. For more information, see “Viewing Baseline History” on page 524.

To view test history:

 1 In the test plan tree, select a test. Click the History tab. The history of 
changes made to the test is displayed in a grid.

Version Control: By default, the Versions and Baselines tab is displayed. 
Click the Audit Log tab to view test history.

For each change to the test, the grid displays the date and time of the 
change and the name of the user who made the change.

 2 Expand a change to view a list of fields modified during the change. For 
each field, the grid displays the old value and the new value. To expand all 
changes, click the Expand All button.

 3 You can specify which changes are displayed in the grid. In the Field list, 
select a field name to view only changes made to that field. Select <All> to 
view changes made to all fields.

For information on preserving the history of changes made to a field, refer 
to the HP Quality Center Administrator Guide.
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Mailing Tests 

You can send email about a test to other users in your project. This enables 
you to routinely inform development and quality assurance personnel 
about the status of your tests. A Go To Test link is included in the email, 
enabling the recipient to go directly to the test.

Note: By default, Quality Center sends email in HTML format. To send email 
as plain text instead, edit the MAIL_FORMAT parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator Guide.

To mail a test: 

 1 Select one or more tests in the test plan tree or in the Test Grid, and click the 
Send by Email button. The Send Email dialog box opens.
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Tip: You can automatically send the email to a specific user type. This can be 
any test column with a user name value, including user-defined fields. Click 
the Send by Email arrow and choose an option. For example, choose Send 
Mail to Designer to send the email to the user who designed the test.

 2 Type a valid email address or user name. Alternatively, click the To button or 
CC button to select users. The Select Recipients dialog box opens. 

You can sort the users list, search for users, group users by user groups, and 
select users from the list or from a group tree. For more information, see 
“Selecting Users” on page 55. 

Select the users or user groups to whom you want to send the email, and 
click OK.
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 3 In the Subject box, type a subject for the email. By default, if you select only 
one test, the domain, project, test ID, and name of the test are displayed in 
the Subject box.

 4 If you select more than one test, the tests are listed in the Item box. You can 
clear any tests you do not want to include in the email.

 5 Choose whether you want to include the Attachments, History, and/or 
Design Steps of the test.

 6 In the Additional comments box, add any comments you may have.

 7 To check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word 
together with replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way spelling is checked. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.

 8 Click Custom to customize the email. In the Select Fields dialog box, you 
can specify fields to include in the email.

 9 Click Send to send the email.

Finding Tests in the Tree or Test Grid

You can search for a particular test in the test plan tree or in the Test Grid 
using the Find command.

Tip: If Text Search is available, you can use it to search for tests in the test 
plan tree or Test Grid. Text search provides a more powerful search by 
allowing you to search for keywords and variations of keywords. For 
information on using the text search, see “Searching Records” on page 72.
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Finding Tests in the Test Plan Tree
You can search for a folder or test in the test plan tree. If you have applied 
filters to the test plan tree, the search is restricted to the tests currently 
displayed.

To find a folder or test in the test plan tree:

 1 Select a subject folder in the test plan tree, and choose Edit > Find.

The Find Folder/Test dialog box opens and displays the folder name in the 
Find in box. If you are searching the entire tree, the folder name is Subject.

 2 In the Value To Find box, type the name (or part of the name) of the folder 
or test. Note that the search is not case sensitive.

 3 Check Include Tests to search for both folders and tests.

 4 Click Find.

The Test Plan module attempts to locate the folder or test. If the search is 
successful, the Search Results dialog box opens and displays a list of possible 
matches. Select a result from the list and click the Go To button to highlight 
the folder or test in the test plan tree. 

If the search is unsuccessful, an information box opens.
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Finding Tests in the Test Grid
You can search for tests in the Test Grid, based on the value of a particular 
field. If you have applied filters to the Test Grid, the search is restricted to 
the tests currently displayed.

To find tests in the Test Grid:

 1 Choose View > Test Grid.

 2 Choose Edit > Find. The Find dialog box opens.

 3 In the Find in Field box, select a field in the grid.

 4 In the Value to Find box, type or select the value of the field, for which you 
want to search.

 5 Select Exact Match if you want to find tests with field values that exactly 
match the Value to Find string.

 6 Select Case Sensitive if you want the search to distinguish between 
uppercase and lowercase characters.

 7 Select Use Wildcards if you want to use asterisk (*) characters in your search 
string in order to type only part of the item.

 8 Click Find Next. If the search is successful, the matching test is highlighted 
in the grid. If the search is unsuccessful, an information box opens.

 9 Click Find Next again to find the next test that matches the criteria.
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Replacing Field Values in the Test Grid

You can replace field values in the Test Grid using the Replace command.

To replace a field value in the Test Grid:

 1 Choose Edit > Replace. The Find/Replace dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value. 

 3 In the Value to Find box, type or select the value to find. 

 4 In the Replace with box, type or select a replacement field value.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.

 7 To start the search from the top of the grid, select the From Beginning check 
box.

 8 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 9 To replace the found item and find the next occurrence, click Replace.

 10 To replace all occurrences of the value in the grid, click Replace All.



Chapter 18 • Developing the Test Plan Tree

281

Updating Multiple Records in the Test Grid

You can update a field value for multiple records in the Test Grid. To update, 
select the records in the grid and choose Edit > Update Selected. The Update 
Selected dialog box opens. For more information, see “Updating Multiple 
Records” on page 70.

Copying Tests

You can copy tests within the same project or between projects.

Copying Tests in a Project
You can copy tests and subject folders within the same project. 

To copy a test in a project:

 1 Select the test or the subject folder that you want to copy in the test plan 
tree. To copy more than one test or subject folder, use the CTRL key.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Select the folder to which you want to copy the tests or subject folders.

 4 Choose Edit > Paste. Alternatively, right-click and choose Paste.

Copying Tests Across Projects
You can copy tests from one project to another. If the tests contain calls to 
other tests, or if the tests are dependent on test resources, you can instruct 
Quality Center to copy them using one of the following methods:

➤ Copy tests and link them to existing called tests and related test resources in 
the target project. If a called test or a test resource does not exist in the target 
project, Quality Center copies it to the target project.

➤ Copy tests along with called tests and related test resources into the target 
project. 

➤ Copy tests without copying called tests and related test resources into the 
target project.
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Note: To copy tests across projects, both projects must use the same 
Quality Center version and patch level.

For more information on related entities, see “Viewing Dependencies” on 
page 357.

To copy a test across projects:

 1 Select the test or the subject folder that you want to copy in the test plan 
tree. To copy more than one test or subject folder, use the CTRL key.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Open another instance of Quality Center and log in to the project to which 
you want to paste the tests.

 4 Select the folder to which you want to copy the tests or subject folders.

 5 Choose Edit > Paste. Alternatively, right-click and choose Paste. The Paste 
Tests/Subject Folders to Target Project dialog box opens. 

 6 Select one of the following options:

➤ Copy tests/subject folders and link to existing related entities. 
Quality Center copies the tests or subject folders and pastes them into the 
target project. The copied tests or subject folders are linked to existing test 
resources and called tests with the same name and path. If a related test 
resource or a test does not exist in the target project, Quality Center copies it 
to the target project.

➤ Copy tests/subject folders and related entities. Quality Center copies the 
tests or subject folders along with the related test resources and called tests, 
and pastes them into the target project. If a related test resource or a called 
test already exists in the target project, the copied related test resource or 
called test is renamed to resolve the duplicate name.
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➤ Copy tests/subject folders without copying related entities. Quality Center 
copies the tests or subject folders without copying the related test resources 
or called tests, and pastes them into the target project. The copied items are 
not linked to any related entities.

 7 Click OK. 

Copying URLs of Tests

You can copy a test and paste its URL as a link. The test itself is not copied. 
Instead, you can paste the address into another location, such as an email or 
a document. Clicking on the link opens up Quality Center and takes you to 
the test. If you are not already logged in, Quality Center first prompts for 
login details. 

To copy a URL of a test:

 1 Select a test from the test plan tree or grid. 

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.

Sorting a Test Plan Tree 

By default, subjects are displayed in a test plan tree in alphabetical order. 
You can sort the folders in the test plan tree and create a custom sort 
according to your needs.

Note: You must have project administrator permissions to create a custom 
sort. For more information on assigning user group permissions, refer to the 
HP Quality Center Administrator Guide.
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To sort a test plan tree:

 1 Click the Sort Folders button on the toolbar. The Sort Folders in Test Plan 
Tree dialog box opens.

By default, Folder Name is selected.

 2 To create a custom sort, select Custom Sort.

 3 Click a subject folder on the left side of the dialog box. The subfolders 
appear on the right side.

 4 Choose a subfolder on the right side of the dialog box and click the Up or 
Down arrow buttons to set the sorting priority for your test plan tree. You 
can also drag the subfolder up or down.

 5 Click Close to apply the sort order to your test plan tree.
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Modifying a Test Plan Tree

You can rename or delete subject folders and tests in the test plan tree.

Renaming a Folder or Test
You can rename a folder or a test.

To rename a folder or test:

 1 Select an item from the test plan tree.

 2 Click the item. Alternatively, right-click the item and choose Rename.

 3 Edit the item name and press ENTER or click another location.

Deleting a Folder or Test
You can delete a folder or test from the test plan tree. When you delete a 
folder, you can choose to delete the folder only, or the folder, its subfolders, 
and tests.

Consider the following before deleting a folder or test:

➤ If you choose to delete the folder only, all of the tests are moved to the 
Unattached folder in the test plan tree. 

➤ If you choose to delete a folder and tests, all subfolders and tests under the 
selected folder are deleted permanently. 

➤ If you delete a test, the test and test script are deleted permanently.

➤ If dependencies are defined for a test, deleting the test may impact these 
dependencies. For more information on related entities, see “Viewing 
Dependencies” on page 357.

➤ Version control: Deleting a test deletes all previous versions of the test.

To delete a folder:

 1 Select a folder from the test plan tree. To delete more than one folder, press 
the CTRL key and select the folders you want to delete.

 2 Click the Delete button Alternatively, right-click the folder and choose 
Delete. The Confirm Delete Folder dialog box opens.
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 3 To delete folders and move all related tests to the Unattached folder, select 
Delete folders only. Click Yes. 

 4 To delete folders, tests, and test scripts, select Delete folders and tests. Click 
Yes. 

If dependencies are defined for some of the tests in the folders, an additional 
dialog box opens. To delete the tests and possibly impact the dependencies, 
click Yes. 

To cancel, click No. To view the dependencies before you delete, click the 
Dependencies tab. For more information, see “Viewing Dependencies” on 
page 357.

To delete a test:

 1 Select a test from the test plan tree. To delete more than one test, press the 
CTRL key and select the tests you want to delete.

 2 Click the Delete button, or choose Edit > Delete. Alternatively, 
right-click the test and choose Delete.

 3 If other entities are not dependent on the test, a confirm box opens. Click 
Yes.

 4 If dependencies are defined for the test, the Delete Test dialog box opens. To 
view the related entities, click Details. Click Yes to confirm you want to 
delete the test and the related entities.
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19
Requirement and Test Coverage

It is essential that the tests in your test plan meet your original 
requirements. To keep track of the relationship between your requirements 
and tests, you add links between them.

This chapter includes:

 ➤  About Requirement and Test Coverage on page 287

 ➤  Linking Requirements to a Test on page 290

 ➤  Linking Tests to a Requirement on page 294

 ➤  Analyzing Coverage on page 298

About Requirement and Test Coverage

You begin by defining your requirements in the requirements tree and then 
assigning them to a release or a cycle in the releases tree (see Chapter 13, 
“Developing the Requirements Tree”). In the planning stage, you build a test 
plan tree based on these assigned requirements (see Chapter 18, 
“Developing the Test Plan Tree”). To keep track of the relationship between 
your assigned requirements and tests, you add links between them.

In the Test Plan module, you create requirements coverage by selecting 
requirements to link to a test. Alternatively, in the Requirements module, 
you create test coverage by selecting tests to link to a requirement. A test 
can cover more than one requirement, and a requirement can be covered by 
more than one test.
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Note: You can also create coverage between test instances and requirements. 
To enable this feature use the ALLOW_REQ_COVERAGE_BY_TEST_INSTANCE 
parameter in Site Administration. For more information on this parameter, 
see the HP Quality Center Administrator Guide.

You can link requirements and tests to defects. This can help you ensure 
compliance with your testing needs throughout the application 
management process (see Chapter 36, “Linking Defects”). If a requirement 
changes, you can immediately identify which tests and defects are affected, 
and who is responsible.

Requirements Coverage Example
Suppose you are using the QualityCenter_Demo project based on the 
Mercury Tours application. Click the Test Plan button on the sidebar. In the 
test plan tree, under Profiling, expand the Registration folder and select the 
Phone (Contact Information) test. 
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The Phone (Contact Information) test verifies the customer phone number 
in the Registration page. If you click the Req Coverage tab, you can see that 
this test covers the following requirement topics: Customer Personal 
Information, and Correct Error Messages.

Test Coverage Example
Continuing with the requirements coverage example, you can also view 
coverage in the QualityCenter_Demo project from the other direction. Click 
the Requirements button on the sidebar. In the requirements tree, under 
Requirements, expand the requirement topics Mercury Tours Application, 
Profile Management, and Registration, and then select the requirement 
Customer Personal Information. 

The Customer Personal Information requirement ensures that the flight 
reservation system includes personal information about the customer. In the 
Test Coverage tab, you can see that this requirement is covered by the 
following tests: Email (Contact Information), First & Last Name (Contact 
Information), Mailing Information, Phone (Contact Information), and 
Registration.
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Linking Requirements to a Test

During test planning, when you select a test in the test plan tree, the test’s 
requirements coverage is displayed in the Req Coverage tab. 

The coverage grid lists the requirements that are covered by the selected test. 
You can view, add, and remove requirements from the coverage grid. 

The columns in the Req Coverage tab display data for the covered 
requirements. In addition to the columns described in “The Requirement 
Fields” on page 171, the coverage grid can also display the following 
columns:

Column Description

Coverage Type The type of coverage. The value in this column can be 
“Test” or “Test Instance”.

Entity Name The entity name.

Entity Status The current execution status of the entity.
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Viewing the Requirements Coverage Grid
You can set column appearance and order in the coverage grid. You can view 
requirements in the coverage grid with their full path. In addition, you can 
instruct Quality Center to go to a requirement in the requirements tree.

To view the Requirements Coverage Grid:

 1 In the test plan tree, select a test.

 2 Click the Req Coverage tab.

 3 To refresh the coverage grid so that it displays the most up-to-date 
requirements, click the Refresh All button.

 4 To set column appearance and order in the coverage grid, click the Select 
Columns button. For more information, see “Arranging Columns” on 
page 52.

 5 To display the location of the requirements in the requirements tree, right-
click the coverage grid and choose Show Full Path.

 6 To go to a requirement in the requirements tree, click the requirement in the 
coverage grid. Alternatively, right-click the requirement and choose Go To 
Requirement in Requirements Tree.

Adding Requirements Coverage
To add requirements coverage to a test, you select one or more requirements 
from the requirements tree. Note that by default you cannot add coverage 
for the following requirement types: Business, Folder, and Group.

Note: Requirements coverage is created automatically when you convert a 
requirement to a test. Therefore, even if you have not yet added 
requirements coverage, it may already exist. For more information, see 
“Creating Tests from Requirements” on page 200.

To add requirements coverage:

 1 In the test plan tree, select a test.

 2 Click the Req Coverage tab.
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 3 Click the Select Req button to display the requirements tree in the right 
pane. 

 4 To search for a specific requirement in the tree, type the name (or part of the 
name) of the requirement in the Find box and click the Find button. If the 
search is successful, the requirement is highlighted in the tree.

 5 To search for a specific requirement by ReqID, click the Go To Requirement 
button. The Go To Requirement dialog box opens. Type a requirement ID 
and click OK. If the search is successful, the requirement is highlighted in 
the tree.

 6 To filter and sort requirements in the tree, click the Set Filter/Sort button. 
For more information, see Chapter 3, “Working with Quality Center Data”.

 7 To refresh the requirements tree or coverage grid, click the appropriate 
Refresh All button. 
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 8 Select a requirement or requirement topic to add to the coverage: 

➤ Click the Add to Coverage (Without Children) button to add the 
requirement without the requirement’s child requirements. Alternatively, 
double-click the requirement.

➤ Click the Add to Coverage arrow and choose Add to Coverage (Include 
Children) to add the requirement, including its child requirements. Only 
child requirements that match the current filter and that belong to a type 
that supports test coverage are added to the coverage.

The requirement is added to the coverage grid.

Tip: You can also define requirements coverage by dragging a requirement in 
the requirements tree to the coverage grid. The requirement is added to the 
coverage grid without its child requirements.

 9 Click the Close button to hide the requirements tree.

Removing Requirements Coverage
You can remove requirements from a test’s requirements coverage.

To remove requirements coverage:

 1 In the test plan tree, select a test.

 2 Click the Req Coverage tab.

 3 Select a requirement from the coverage grid to delete.

 4 Click the Remove Selected button, and click Yes to confirm.
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Linking Tests to a Requirement

You can link tests to requirements using the Requirements module.

When you select a requirement in the requirements tree, the requirement’s 
test coverage is displayed in the Test Coverage tab. The coverage grid lists 
the tests that cover the selected requirement. You can view, add, and remove 
tests from the coverage grid. 

The columns in the Test Coverage grid display data for the tests that cover 
the requirement. In addition to the columns described in “Test Grid 
Columns” on page 260, the coverage grid can also display the following 
columns:

Column Description

Coverage Type The type of coverage. The value in this column can be 
“Test” or “Test Instance”.

Entity Name The entity name.

Entity Status The current execution status of the entity.
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Viewing the Test Coverage Grid
You can filter the coverage grid, and show or hide full coverage. You can also 
instruct Quality Center to go to a test in the test plan tree.

To view the Test Coverage Grid:

 1 In the Requirement Details view, select a requirement.

 2 Click the Test Coverage tab.

 3 To filter the coverage grid by status type, select a status from the Status Filter 
list. For example, you can select to view only tests that have passed. Select 
All to clear the filter.

 4 To refresh the data in the coverage grid, click the Refresh All button.

 5 To filter, sort, or group records in the coverage grid, click the Set Filter/Sort 
button. To clear any filters, sorting, or group by settings, click the Set 
Filter/Sort arrow and choose Clear Filter/Sort.

 6 To set column appearance and order in the grid, click the Select Columns 
button. For more information on the Select Columns dialog box, see 
“Arranging Columns” on page 52.

 7 To show the test coverage of all the children of the requirement, check the 
Full Coverage check box. By default, full coverage is not displayed.

 8 To go to the test in the test plan tree, click the test in the coverage grid. 
Alternatively, right-click the test in the coverage grid and choose Go to Test 
in Test Plan Tree.

 9 To go to the test in the Test Lab module, right-click the test in the coverage 
grid and choose Go to Test in Test Set.

 10 On the lower-right side of the window, click Show to display the Coverage 
Chart. This pie chart graphically displays the run status of the tests in the 
coverage grid.
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Adding Test Coverage
To add test coverage to a requirement, you select tests from the test plan 
tree. Note that by default you cannot add coverage for the following 
requirement types: Business, Folder, and Group.

Note: Test coverage is created automatically when you generate a test from a 
requirement. Therefore, even if you have not yet added test coverage, it may 
already exist. For more information, see “Creating Tests from Requirements” 
on page 200.

To add test coverage to a requirement:

 1 In the requirements tree, select a requirement. The Test Coverage tab 
displays the coverage grid for the selected requirement.

 2 In the Test Coverage tab, click the Select Tests button to display the test 
plan tree in the right pane.
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 3 To search for a specific test in the tree, type the name (or part of the name) 
of the test in the Find box and click the Find button. If the search is 
successful, the test is highlighted in the tree.

 4 To search for a specific test by Test ID, click the Go To Test button. The Go 
To Test dialog box opens. Type a test ID and click OK. If the search is 
successful, the test is highlighted in the tree.

 5 To filter or sort tests in the tree, click the Set Filter/Sort button. For more 
information on filtering and sorting records, see Chapter 3, “Working with 
Quality Center Data”. 

 6 To refresh the tree, click the Refresh All button. 

 7 To add a test to the requirement's test coverage, in the Test Plan Tree tab, 
select a test or a test folder and click the Add To Coverage button. The test is 
added to the coverage grid. If you select a folder, only tests that match your 
current filter are added to the test coverage.

Tip: You can also define test coverage by dragging a test or a test folder from 
the Test Plan Tree tab to the coverage grid.

 8 Click the Close button to hide the test plan tree in the right pane.

Removing Test Coverage
You can remove tests from a requirement’s test coverage.

To remove test coverage:

 1 In the Requirements Details view, select a requirement. The Test Coverage 
tab displays the coverage grid for the selected requirement.

 2 Select a test from the coverage grid to delete.

 3 Click the Remove From Coverage button and click Yes to confirm.
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Analyzing Coverage

In the Requirements module, you can use the Coverage Analysis view to 
examine the status of your requirements. This enables you to understand 
the breakdown of child requirements according to test coverage. You can set 
the coverage analysis by cycle, enabling you to view in the analysis only the 
coverage of runs that are assigned to specific cycles.

For example, in the QualityCenter_Demo project, select the requirement 
Application Client System, located under the requirement Mercury Tours 
Application. This requirement has twelve children, including itself. In the 
Coverage Analysis, you can see that two of the children have a status of 
Failed (one or more of the tests covered by the requirement failed). When 
you analyze this, you can see that three (27%) of the tests associated with 
this requirement failed.

Note: By default, coverage is available only for the following requirement 
types: Functional, Testing, and Undefined.

To analyze coverage:

 1 Choose View > Coverage Analysis. 



Chapter 19 • Requirement and Test Coverage

299

The Coverage Analysis view displays the following columns:

 2 Quality Center Enterprise and Premier Editions: To include in the analysis 
only tests that have runs that are assigned to specific cycles, in the Coverage 
calculation by cycle box, click the browse button. The releases tree opens. 
Expand the tree and select the cycles for which you want to analyze 
coverage. Click OK to close the releases tree.

 3 Click the Coverage Analysis column for the requirement you want to 
analyze. Alternatively, right-click the requirement, and choose Coverage 
Analysis. The Coverage Analysis dialog box opens.

Column Description

Name The requirements tree, listing requirements grouped 
hierarchically.

Direct Cover Status The current status of the requirement, determined 
according to the status of the tests associated with the 
requirement. For example, if the direct cover status is 
“Not Completed”, then one or more tests covered by the 
requirement have not been completed. For a complete 
definition, see “Direct Cover Status” on page 171. 

Coverage Analysis This column graphically displays the direct cover status of 
the requirement and its children. Requirements which do 
not match the current filter, or requirements with direct 
cover status “N/A” are not counted in the analysis.

If you set the coverage by cycle, Quality Center does not 
use the Direct Cover Status field in its calculations. 
Instead, it uses calculated direct cover status values based 
on the tests that have instances belonging to test set 
folders that are assigned to cycles included in the filter. In 
this case, requirements that do not have test coverage for 
any of the cycles in the filter are not counted in the 
analysis.
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For example, click the Coverage Analysis column for the requirement 
Application Client System. The graph shows that this requirement has two 
requirements that have Failed and ten child requirements that are Not 
Covered.

 4 Click a section in the graph to display a list of child requirements with the 
selected status. In this example, click the Failed area of the graph to show 
the requirements with a status of Failed. The names of the two requirements 
with Failed status are displayed.

You can select a requirement and click Go To to highlight the requirement 
in the requirements tree.
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 5 Click the Show Tests Coverage link to extend the Coverage Analysis dialog 
box and display the Tests Coverage Chart.

This pie chart graphically displays the full test coverage for the requirement, 
grouped according to test status. In this example, the Application Client 
System requirement and its child requirements are associated with one 
Failed test, one Not Completed test, two No Run tests, and seven Passed 
tests. If a parent requirement has several children all of which cover the 
same test, that test is included only once in the parent requirement’s Tests 
Coverage Chart.
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 6 Click a section in the chart to view the list of tests with the selected status 
that cover the requirement and its children. The Tests Coverage dialog box 
opens with the Status Filter set to the status of the area you selected in the 
chart.

If a parent requirement has several children all of which cover the same test, 
that test is included once for each child requirement in the parent 
requirement’s Tests Coverage Chart.

You can change the Status Filter or modify test coverage for the 
requirement. For more information, see “Linking Tests to a Requirement” on 
page 294.

 7 To display the Tests Coverage Chart, click the Show button.

 8 Click Close to close the Test Coverage dialog box.

 9 Click Close to close the Coverage Analysis dialog box.

 10 To save the Coverage Analysis view to a Word document, choose 
Requirements > Export > Word Document. A Word document is created, 
displaying a bar graph for each parent requirement in the requirements tree.
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20
Building Tests

After you create a test plan tree, you are ready to develop the tests by 
defining design steps.

This chapter includes:

 ➤  About Building Tests on page 303

 ➤  Defining Design Steps on page 305

 ➤  Calling Manual Tests on page 307

 ➤  Managing Design Steps on page 309

About Building Tests

You build tests in the Test Plan module by defining design steps: detailed, 
step-by-step instructions on how to execute a test. A step includes the 
actions to perform on your application, the input to enter, and the expected 
output. You define steps for a test after you add the test to the test plan tree 
and define basic test information.

You can create design steps for both manual and automated tests. For a 
manual test, you complete test planning and design once you finish 
creating the steps. Using your plan, you can begin execution immediately. 
Automated tests require that you create automated test scripts using HP 
testing tools, or custom, or third-party testing tools. 
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If you decide to automate a test, a test script is created based on the design 
steps you defined. After evaluating your test design, you decide whether to 
automate a test. For further information, see Chapter 22, “Creating 
Automated Tests.”

You can create a design step that calls another manual test. This is useful if 
you have common steps that you often want to perform as parts of other 
tests. For more information on calling a manual test, see “Calling Manual 
Tests” on page 307.

You design steps for a test using the Design Steps tab in the test plan tree.
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Defining Design Steps 

You add design steps to a test using the Design Step Editor.

Note: You can include a design step that calls another manual test. For more 
information, see “Calling Manual Tests” on page 307.

To define a design step:

 1 Select a test in the test plan tree and click the Design Steps tab. 

 2 Click the New Step button or right-click in the Design Steps tab and choose 
New Step. The Design Step Editor opens and displays a default step name in 
the Step Name box. 

The default step name is the sequential number of the design step (Step 1 if 
you are adding steps to a test for the first time). You can change the name by 
typing a different name in the box.



Chapter 20 • Building Tests

306

 3 Type a Description and Expected Result for the design step.

 4 To insert a parameter, click the Insert Parameter button. For more 
information, see “Inserting Test Parameters in a Design Step” on page 321.

 5 To manually save the current step, click the Save Steps button.

 6 To add additional steps, click the New Step button. The next sequential 
number appears in the Step Name box.

 7 Click OK to close the Design Step Editor and add the steps.

The design steps appear in the Design Steps tab. In the test plan tree, a 
footprint  appears next to the test icon, indicating that steps were 
defined for the test.

 8 You can associate an attachment with a design step. An attachment can be a 
file, URL, snapshot, an item from the Clipboard, or system information. To 
add an attachment to a design step, select a step and click the Attachments 
button. For more information, see Chapter 5, “Adding Attachments.”

Notes: 

➤ You can copy steps from an existing test. For more information, see 
“Managing Design Steps” on page 309.

➤ If you add an attachment to a design step, a copy of the attachment is 
made every time the test is run. For more information on running tests, 
see “Running a Test Manually” on page 422.
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Calling Manual Tests

In a test, you can include a design step that calls a manual test. When you 
run the calling test, it includes the steps and parameters from the called test. 
This is useful if you have common steps you often want to perform as part 
of other tests.

For example, suppose you want to include a login step in a number of 
different tests. You can create a test Login_Template that logs in a user when 
you start your application. You can call this test at the beginning of each 
test.

To easily identify tests that you will call from other tests, you can mark the 
called tests as template tests. 

Template tests often include test parameters. These are useful if you want to 
run the template test with different data according to the type of test that is 
calling it. For more information on using parameters in manual tests, see 
Chapter 21, “Working with Parameters in Manual Tests.”

This section on calling manual tests includes the following topics:

➤ Marking a Manual Test as a Template Test

➤ Calling a Manual Test

Marking a Manual Test as a Template Test
You can mark a manual test in the test plan tree as a template test. You do 
not need to mark a test as a template test to be able to call it. Marking a test 
as a template test makes selecting the template test easier when you call it 
from another test.

To mark a manual test as a template test:

In the test plan tree, right-click a manual test, and choose Mark as Template 
Test. The manual test icon changes from gray to white to indicate that it is 
now a template test.
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Calling a Manual Test
In a test, you can include a step that calls another manual test. When you 
run the calling test, its design steps include the steps from the called test.

To call a manual test:

 1 Select a test in the test plan tree and click the Design Steps tab.

 2 Select the step after which you want to include a call to another test and 
click the Call to Test button. The Select a Test dialog box opens.

 3 By default, only template tests are displayed. If you want to choose a test 
that is not a template test, clear the Show only Template Tests check box.

 4 To filter and sort the tests in the Select a Test dialog box, click the Set 
Filter/Sort button. The Filter dialog box opens. For more information on 
filtering and sorting, see Chapter 3, “Working with Quality Center Data.”

 5 To search for a specific test, type the name (or part of the name) of the test 
in the Find box and click the Find button. If the search is successful, the test 
is highlighted in the tree.

 6 To refresh all tests in the tree, click the Refresh All button. 

 7 Select the manual test that you want to call.
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 8 Click OK. If the called test contains parameters, the Parameters of Test dialog 
box opens and displays the parameters of the test you are calling. Assign 
actual values for the parameters. These values will be used for all test 
instances created from this test. For more information, see “Assigning Actual 
Values” on page 322.

 9 Click OK. The call is inserted as a link in your design step, and the values 
assigned to the parameters in the called test are displayed.

 10 To edit the values you assigned to the parameters in the called test, right-
click the test call and choose Called Test Parameters. In the Called Test 
Parameters dialog box, type the new values for the parameters, and click OK.

Managing Design Steps

This section on managing design steps includes the following topics:

➤ Editing Design Steps

➤ Reordering Design Steps

➤ Renumbering Design Steps

➤ Resizing Design Steps

➤ Arranging Design Step Columns

➤ Deleting Design Steps

➤ Copying Design Steps in a Project

➤ Copying Design Steps Across Projects

➤ Finding and Replacing Step Text

Editing Design Steps
You can edit existing design steps or add new ones.

To modify design steps:

 1 Choose a test in the test plan tree and click the Design Steps tab.
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 2 Double-click a step, or select a step and click the Edit Step button. The 
Design Step Editor opens. 

You can proceed through the steps in a test using the browse buttons:

➤ Click the First Step button to display the first step in the test, or the 
Previous Step button to display the preceding step.

➤ Click the Next Step button to display the subsequent step in the test, or 
the Last Step button to display the final step in the test.

Tip: You can navigate between steps in the Design Step Editor using shortcut 
keys. Use ALT+HOME to access the first step, ALT+LEFT to access the previous 
step, ALT+RIGHT to access the next step, and ALT+END to access the last step.

 3 Edit step descriptions and expected results by typing in the Description and 
Expected Result areas.

 4 Click the New Step button to add a step after the currently selected step.

 5 Click OK to close the Design Step Editor and save your changes.



Chapter 20 • Building Tests

311

Reordering Design Steps
You can change the order of the steps in a test.

To reorder design steps:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Position the mouse pointer on the gray sidebar to the left of the step you 
want to move. The mouse pointer changes to .

 3 Click and drag the step to the desired position.

Renumbering Design Steps
You can renumber your steps after you add, delete, or reorder steps in a test. 

To renumber design steps:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Click the Renumber Steps button.

Resizing Design Steps
You can adjust the row size of the steps in a test. This enables you to view all 
the text in the Description or Expected Result columns if the text is long. 

To resize design steps:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Position the mouse pointer in the gray sidebar on the lower edge of the step 
you want to resize. 

 3 Click the Adjust Rows Height button. 

Alternatively, position the mouse pointer in the gray sidebar on the lower 
edge of the step you want to resize. The mouse pointer changes to . Click 
and drag the step to adjust the row size.
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Arranging Design Step Columns
You can determine which columns appear and the order in which they 
appear in the Design Steps tab.

To arrange design step columns:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Click the Select Columns button. The Select Columns dialog box opens. For 
more information, see “Arranging Columns” on page 52.

Deleting Design Steps
You can remove steps from a test.

To delete a design step:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Choose the step that you want to delete. To delete more than one step, 
position the mouse pointer on the gray sidebar to the left of the step that 
you want to delete. The mouse pointer changes to . Click to select the 
step. Then use the CTRL or SHIFT key to select additional steps.

 3 Click the Delete Selected button. Alternatively, right-click and choose 
Delete Selected.

 4 Click Yes to confirm.

Copying Design Steps in a Project
You can copy design steps from another test in the same project. Parameters 
used in the design step test are copied to the target test.

To copy a design step in a project:

 1 Select the test in the test plan tree from which you want to copy steps and 
click the Design Steps tab.

 2 Select the step that you want to copy. To copy more than one step, position 
the mouse pointer on the gray sidebar to the left of the step that you want 
to copy. The mouse pointer changes to . Click to select the step. Then use 
the CTRL or SHIFT key to select additional steps.

 3 Click the Copy Steps button, or right-click and choose Copy.
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 4 Select the test to which you want to copy the steps, and click the Design 
Steps tab.

 5 Click the Paste Steps button or right-click and choose Paste.

Copying Design Steps Across Projects
You can copy design steps in a test from one project to another. If the design 
steps contain calls to other tests, you can instruct Quality Center to copy 
them using one of the following methods:

➤ Copy design steps and link them to existing tests in the target project. If a 
called test does not exist in the target project, Quality Center copies it to the 
target project.

➤ Copy design steps and called tests into the target project.

➤ Copy design steps without copying called tests into the target project.

Parameters used in the design step test are copied to the target test.

Note: To copy design steps across projects, both projects must use the same 
Quality Center version and patch level.

To copy a design step across projects:

 1 Select the test in the test plan tree from which you want to copy steps and 
click the Design Steps tab.

 2 Select the step that you want to copy. To copy more than one step, position 
the mouse pointer on the gray sidebar to the left of the step that you want 
to copy. The mouse pointer changes to . Click to select the step. Then use 
the CTRL or SHIFT key to select additional steps.

 3 Click the Copy Steps button, or right-click and choose Copy.

 4 Open another instance of Quality Center and log in to the project to which 
you want to paste the steps.

 5 Select the test to which you want to copy the steps, and click the Design 
Steps tab.
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 6 Click the Paste Steps button or right-click and choose Paste. The Paste 
Design Steps to Target Project dialog box opens. 

 7 Select one of the following options:

➤ Copy design steps and link to existing related entities. Quality Center 
copies the design steps and pastes them into the target project. The 
copied design steps are linked to existing tests with the same name. If a 
called test does not exist in the target project, Quality Center copies it to 
the target project.

➤ Copy design steps and related entities. Quality Center copies the design 
steps and called tests and pastes them into the target project. If a called 
test name already exists in the target project, the copied called test is 
renamed to resolve the duplicate test name.

➤ Copy design steps without copying related entities. Quality Center 
copies the design steps without copying the called tests, and pastes them 
into the target project. The copied design steps are not linked to any 
called tests.

Click OK. 

Finding and Replacing Step Text
You can search for specific text in the design steps in the Design Steps tab. 
For a single step, you can also find and replace specific text in the Design 
Steps Editor.

To find text in the Design Steps tab:

 1 Choose a test in the test plan tree and click the Design Steps tab.
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 2 Click the Find Text button. The Find dialog box opens.

 3 In the Find in Field box, select the criterion to search for.

 4 In the Value to Find box, select the value of the field you chose.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.

 7 To use asterisk (*) characters in your search string to type only part of the 
item, select the Use Wildcard check box.

 8 Click Find Next. If the search is successful, the step is highlighted. If the 
search is unsuccessful, an information box opens.

 9 Click Close to close the dialog box.

To find and replace text in the Design Steps Editor:

 1 Choose a test in the test plan tree and click the Design Steps tab.

 2 Click the New Step button to add a new step, or click the Edit Step button 
to modify an existing step. The Design Step Editor opens.
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 3 Click the Find/Replace Text button. The Replace dialog box opens.

 4 In the Find what box, type the text for which you want to search.

 5 To replace the specified text, type the text you want to use as replacement 
text in the Replace with box.

 6 To search for whole words, select the Match whole word only box.

 7 To search for an exact value, select the Match case check box.

 8 Click Find Next. If the search is unsuccessful, an information box opens.

 9 Click Replace to replace the first occurrence of the text, or Replace All to 
replace all occurrences of the text.



317

21
Working with Parameters in Manual 
Tests

You can add parameters to your manual tests and use them in design steps.

This chapter includes:

 ➤  About Working with Parameters in Manual Tests on page 317

 ➤  Defining Test Parameters on page 319

 ➤  Updating Test Parameters on page 320

 ➤  Inserting Test Parameters in a Design Step on page 321

 ➤  Assigning Actual Values on page 322

 ➤  Managing Test Parameters on page 324

About Working with Parameters in Manual Tests

To increase the flexibility of manual tests, you can add parameters to design 
steps. This enables you to run the same test repeatedly with different data 
each time.

A test parameter is a variable that can be assigned a value outside the test 
from which it is defined.

Manual tests with parameters can be called from other tests. This is useful if 
you have common steps you often want to perform as part of other tests. For 
example, you can create a template test Login_Template that logs a user in 
when you start the application. You need to call this test at the beginning of 
each test. In some cases, you will want to log in as a regular user while in 
others, you will need to log in as the project administrator.
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For this purpose, you can create two parameters, <<<user name>>> and 
<<<password>>>, and change the values according to the type of test that is 
calling Login_Template. If the most common login is a regular user, you can 
set the default values for the parameters to a regular user name and 
password. For more information on calling manual tests, see “Calling 
Manual Tests” on page 307.

To work with parameters in manual tests:

 1 Define parameters in a manual test. For more information, see “Defining 
Test Parameters” on page 319.

 2 Add parameters to a design step. For more information, see “Inserting Test 
Parameters in a Design Step” on page 321.

 3 At different stages of designing your test, assign parameter values that are 
used during test runs. For more information, see “Assigning Actual Values” 
on page 322.
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Defining Test Parameters

Before you can use parameters in design steps, you need to define them in 
the test.

To define a test parameter:

 1 Select a test in the test plan tree and click the Test Parameters tab.

 2 Click the New Parameter button. The New Parameter dialog box opens.

 3 Type a name for the new parameter. A parameter name may not include the 
following characters: ~ ? ’ < > %

 4 Click the Default Value tab and type a default value for the parameter. The 
default value helps users to assign an actual value before they run the test.

 5 Click the Description tab and type a description of the parameter.

 6 Click OK.
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Updating Test Parameters

You can add or change details of an existing test parameter.

To update a test parameter:

 1 In the Test Parameters grid, double-click the parameter you want to edit. 
Alternatively, select the parameter and click the Parameter Details button. 
The Parameter Details dialog box opens.

 2 Update or type values in the following fields:

➤ Parameter Name. A parameter name may not include the following 
characters: ~ ? ’ < > %

If you rename the parameter, Quality Center creates a new parameter 
with the new name, in addition to the original parameter.

➤ Default Value.

➤ Description.

 3 Click OK to save the changes.
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Inserting Test Parameters in a Design Step

You can add a parameter to the description or expected results of a manual 
design step. You can use existing parameters, or define new parameters.

To insert a test parameter in a design step:

 1 In the Design Steps tab, double-click a design step. Place the cursor in the 
Description box or Expected Result box.

 2 Click the Insert Parameter button. The Insert Parameter dialog box opens.

 3 To insert an existing parameter, select the parameter and click OK.

The parameter is added to the step at the current cursor location, using the 
syntax <<<parameter name>>>.

Note: If you apply formatting to a parameter name in a design step, you 
must apply the same formatting to the entire parameter name, including 
the <<< and >>> characters. For example, if you want to italicize the 
parameter <<<password>>>, you must italicize the entire string 
<<<password>>> and not just the word password.
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 4 To insert a new parameter, click the New Parameter button. For more 
information, see “Defining Test Parameters” on page 319. The new 
parameter is added to the step. 

Alternatively, in the description of the design step, type a new parameter 
name, using the syntax <<<parameter name>>>. After the design step is 
saved, the new parameter is added to the Test Parameters tab.

Assigning Actual Values

Before you run a test, Quality Center prompts you to assign actual values to 
the parameters included in the test. The actual value is the data that is used 
during the test run. You can take the parameter default values and use them 
as actual values.

Quality Center prompts you to assign actual values at three stages of 
designing your test. According to your testing policy, you can assign actual 
values at any of these stages:

➤ When you call a test with parameters. If you assign actual values to 
parameters when you call a test, the values are automatically applied to each 
test instance that you create from the calling test.

➤ When you create a test instance. If you assign actual values to parameters 
when you create a test instance, the values are automatically applied to each 
run of the test instance. You can also assign actual values to test instances 
within the test instance configuration. For more information, see “Setting 
Parameter Values for Manual Test Instances” on page 452.

➤ When you run a test. If you assign actual values to parameters for a test run, 
the values apply to that test run only. If you do not assign actual values at 
this stage, the test will run with null values.

At each of these stages, you can only assign values to parameters that have 
not already been assigned values.



Chapter 21 • Working with Parameters in Manual Tests

323

To assign actual values:

 1 When you call a manual test with parameters, create a test instance with 
parameters, or run a test with parameters, Quality Center prompts you to 
assign actual values to the parameters. The Parameters of Test dialog box 
opens.

Quality Center displays only parameters for which you have not already 
assigned actual values.

 2 Select a parameter that you want to assign an actual value. To select multiple 
parameters, use the CTRL or SHIFT key.

 3 In the Actual Value column, type the value that will be used for the 
parameter during the test run. After you start typing, a text box opens. Click 
OK to save the value.

 4 To use a parameter’s default value as its actual value, click the Take Default 
Values button. The current Actual Value is replaced by the Default Value.

 5 Click OK.
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Managing Test Parameters

You view and manage the parameters of a test in the Test Parameters tab.

To manage test parameters:

 1 In the Test Plan tree, select a test and click the Test Parameters tab.

A tick mark in the Used column indicates that the parameter is included in a 
design step.

 2 To add a new test parameter, click the New Parameter button. For more 
information, see “Defining Test Parameters” on page 319.

 3 To delete a test parameter, select a parameter and click the Delete button. If 
you delete a parameter that is included in a design step, the parameter in the 
design step is replaced by regular text, using the syntax: <parameter name>.

 4 To refresh the test parameters grid, click the Refresh All button.



Chapter 21 • Working with Parameters in Manual Tests

325

 5 To filter the test parameters that appear in the grid, use one of the following 
options in the Set Filter/Sort button:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
the parameters in the test parameters grid. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied to the 
test parameters grid.

For more information on filtering and sorting, see Chapter 3, “Working with 
Quality Center Data.”

 6 To select the columns that appear in the test parameters grid, and to set their 
order, click the Select Columns button. For more information, see 
“Arranging Columns” on page 52.

 7 To edit the details of a test parameter, select a parameter and click the 
Parameter Details button. For more information, see “Updating Test 
Parameters” on page 320.
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22
Creating Automated Tests

After you have designed test steps, you can use them as a framework for 
creating an automated test script.

This chapter includes:

 ➤  About Creating Automated Tests on page 327

 ➤  Generating Automated Test Scripts on page 328

About Creating Automated Tests 

Test planning involves deciding which tests to automate. If you choose to 
automate a test, you can generate a test script and run the test using 
WinRunner, QuickTest Professional, LoadRunner, or Visual API-XP.

Consider the following issues when deciding whether to automate a test.

Frequency of Execution

Tests that will run with each new version of your application are good 
candidates for automation. These include sanity tests that check basic 
functionality across an entire application. Each time there is a new version 
of the application, you run these tests to check the stability of the new 
version, before proceeding to more in-depth testing.

Tests that use multiple data values for the same operation (data-driven tests) 
are also good candidates for automation. Running the same test manually—
each time with a different set of input data—can be tedious and ineffective. 
By creating an automated data-driven test, you can run a single test with 
multiple sets of data.
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Stress/Load Testing

It is also recommended that you automate tests that are run many times 
(stress tests) and tests that check a multi-user client/server system (load 
tests). For example, suppose a test must be repeated a thousand times. 
Running the test manually would be extremely impractical. In this case, you 
can create a test that runs a thousand iterations.

When Not To Automate Tests

Generally, the more user involvement a test requires, the less appropriate it 
is to automate. The following describes test cases that should not be 
automated:

➤ Usability tests—tests providing usage models that check how easy the 
application is to use.

➤ Tests that you only have to run once.

➤ Tests that you need to run immediately.

➤ Tests based on user intuition and knowledge of the application.

➤ Tests with no predictable results.

Generating Automated Test Scripts

After you have created steps for a manual test, you can generate a test script 
skeleton in which you can write scripts to run the test as an automated test.

Any text that appeared in the steps of the manual test is listed as comments 
in the generated test script. If the manual test has parameters, they are also 
listed as comment text.

To generate an automated test script:

 1 In the test plan tree, choose the manual test that you want to automate.

 2 Click the Design Steps tab and click the Generate Script button. 
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 3 Choose an automated test type to convert to:

Note: The QUICKTEST_TEST test type is only available if you have installed 
the appropriate add-in from the HP Quality Center Add-ins page. For more 
information on installing add-ins, refer to the HP Quality Center Installation 
Guide.

The Test Plan module uses the steps of the selected test to create an 
automated test script. In the test plan tree, note that the manual test icon  
next to the test you just automated is now replaced with the automated test 
icon.

 4 Click the Test Script tab to view the test script. 

 5 If the test is a WinRunner test, you can attach a different test script to the 
test by clicking the Copy From button. The Select Test dialog box opens, 
enabling you to select a WinRunner test from the file system. 

Test 
Icon

Test Type Description

WR-AUTOMATED A test that is executed by WinRunner, the HP 
functional testing tool for Microsoft Windows 
applications.

VAPI-XP-TEST A test that is created by Visual API-XP, the 
Quality Center open test architecture API testing 
tool. For more information on VAPI-XP tests, see 
Appendix A, “Working with VAPI-XP.”

LR-SCENARIO A scenario that is executed by LoadRunner, the HP 
load testing tool.

QUICKTEST_TEST A test that is executed by QuickTest Professional, 
the HP functional enterprise testing tool.

QAINSPECT_TEST A test that is executed by QAInspect, the HP 
security testing tool.
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 6 For WinRunner, LoadRunner, and QuickTest Professional tests, to display 
your test script in the testing tool for which it is created, click the Launch 
button. You can now modify your test as necessary.
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Working with System Tests

Using system tests, you can instruct Quality Center to provide system 
information for a machine, capture a desktop image, or restart a machine.

This chapter includes:

 ➤  About Working with System Tests on page 331

 ➤  Adding System Tests to a Test Plan Tree on page 332

 ➤  Defining a System Test on page 334

 ➤  Running a System Test on page 335

 ➤  Viewing System Test Results on page 336

About Working with System Tests

You can run a system test to retrieve a machine’s system information, view a 
captured desktop image of a test run on a machine, or restart a machine. For 
example, you can run a system cleanup test that will restart the machine on 
which an automated test failed. You can also create a system test to retrieve 
information about a machine’s resource usage before or after a test run.



Chapter 23 • Working with System Tests

332

You create a system test by adding a system test to the test plan tree, 
defining the test, and adding the test to a test set.

Note: To run a system test, you must install the System Test Remote Agent 
Add-in and the HP Quality Center Connectivity Add-in on the machine 
where the test is to be run. For more information on HP Quality Center 
add-ins, refer to the HP Quality Center Installation Guide.

When running a system test, the following steps can be created:

➤ SysInfo. Collection of system information

➤ Snapshot. Capture of desktop image

➤ Reboot Start and Reboot Finish. Machine restart

You can view details for each of these steps after your system test has 
finished running. You can also view the system information that has been 
retrieved—such as CPU, memory, and processes running on the machine—
and an image of the machine executing the system test.

Adding System Tests to a Test Plan Tree

You begin creating a system test by adding it to your test plan tree.

To add a system test to a test plan tree:

 1 Choose a subject folder in the test plan tree.

 2 Click the New Test button, or choose Tests > New Test. The Create New Test 
dialog box opens.
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 3 In the Test Type box, select SYSTEM-TEST. 

Note: If you have installed the QuickTest Professional Add-in on your 
machine, the Create New Test dialog box includes the Template box.

 4 In the Test Name box, type a name for the test.

 5 Click OK.

Note: If required test fields were defined in Project Customization, the 
Required Test Fields dialog box opens. Select values for the required fields 
and click OK.

The new system test with a system test icon  appears in the test plan tree 
under the subject folder you selected. 

 6 You can add details and attachments to the test, and define requirements 
coverage. For more information, see Chapter 18, “Developing the Test Plan 
Tree.”
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Defining a System Test

Once you have added your system test to the test plan tree, you can define a 
test script for the test. 

To define a system test:

 1 Select the system test you created from the test plan tree, and click the Test 
Script tab.

 2 Select Collect system information to collect information such as CPU, 
memory, and processes running on the machine when the system test is 
run. 

 3 Select Capture desktop image to add an attachment displaying a snapshot 
of the machine’s desktop, when the system test is run. 
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 4 Select Restart the computer to instruct Quality Center to restart the 
machine when the system test is run. 

Notes: 

➤ To use the Restart the computer option, you must enable auto login on 
your machine. Choose Start > Programs > HP Quality Center SystemTest 
Agent > SystemTest Agent (configuration). The Auto Restart Settings 
dialog box opens. By default, User Name and Domain are read-only. Type 
your password and click OK. 

➤ To select a different user name, reopen the Auto Restart Settings dialog 
box. User Name and Domain are no longer read-only. Modify the values 
and click OK.

 5 Click the Save button to save your system test settings.

After you define your system test in the Test Plan module, you can choose to 
add the test to a test set in the Test Lab module. For information on creating 
test sets, see Chapter 28, “Creating Test Sets”.

Running a System Test

Once you have defined your system test and added it to a test set in the Test 
Lab module, you can run it. System tests can be run on your own machine, 
or on multiple remote host machines connected to your network. 

For more information on running tests, see Chapter 31, “Running Tests 
Automatically”.
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Viewing System Test Results

You can view the results of your system test in the Test Lab module.

To view system test results:

 1 In the Execution Grid, double-click your system test, or select the test and 
click the Test Instance Properties button. In the Execution Flow tab, right-
click the system test and choose Test Instance Properties. 

The Test Instance Properties dialog box opens and displays the All Runs 
view.

You can view the status, execution date, and execution time for the 
following steps that are created during a system test run: 

➤ SysInfo. Details for collection of the system information.

➤ Snapshot. Details for capture of the desktop image.

➤ Reboot Start and Reboot Finish. Details for the machine restart.
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 2 Click the Collected System Info link to view the collected system 
information, for example, CPU, memory, and processes running on the 
machine.

 3 Click the Captured Desktop Image link to view the desktop image of the 
machine executing the system test.
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Managing Test Resources

You can manage a set of resources to be used by your tests in the Test 
Resources module. You can organize your resources by defining a test 
resource tree.

This chapter includes:

 ➤  About Managing Test Resources on page 340

 ➤  The Test Resources Module on page 341

 ➤  Creating a Test Resource Tree on page 342

 ➤  Updating Details of Resources and Folders on page 344

 ➤  Working with Resources on page 346

 ➤  Viewing Test Resource Dependencies on page 348

 ➤  Managing the Test Resource Tree on page 348

 ➤  Viewing Resource History on page 356
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About Managing Test Resources

The Test Resources module enables you to manage resources used by your 
tests. You can organize your resources by defining a hierarchical test 
resource tree containing resource folders and resources. For each resource in 
the tree, you select and upload a set of resource files to the Quality Center 
repository. These files can be used by one or more tests.

For example, suppose you work with an external testing tool that stores its 
tests in Quality Center. Each test uses a shared configuration file that is 
common to a number of tests. You therefore want a single point of 
maintenance for the configuration file, rather than saving separate copies of 
the file for each test.

Your testing tool may define the configuration file as a resource and define 
each test that uses the file as dependent on that resource. As only one copy 
of the resource exists in Quality Center, replacing the configuration file 
would replace it for all tests that depend on it. 

You can define dependencies between resources and tests using QuickTest 
Professional. For more information, refer to the HP QuickTest Professional 
User Guide.

You can also define dependencies between resources and tests by writing 
your own application or script. For more information, refer to HP Quality 
Center Entity Dependencies API Reference.

After you define dependencies, if you attempt to delete the resource, Quality 
Center warns you that this may affect tests that depend on it. When 
copying one of the tests that depend on the resource between projects, 
Quality Center enables you to choose to copy the resource as well as the test.
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The Test Resources Module

You define resource folders and resources in Quality Center using the Test 
Resources module, which is opened by clicking the Test Resources button 
on the sidebar.

The Test Resources module contains the following key elements:

➤ Test Resource tree. A graphical representation of your test resources. 

➤ Details tab. Displays details of the currently selected resource folder or 
resource. For more information, see “Updating Details of Resources and 
Folders” on page 344.

➤ Resource Viewer tab. Enables you to upload and download test resource files 
from the Quality Center repository. For more information, see “Working 
with Resources” on page 346.

➤ Dependencies tab. Displays dependency relationships that exist between 
entities such as test resources and tests. For more information, see “Viewing 
Test Resource Dependencies” on page 348.

➤ History tab. Displays a history of baselines in which the resource appears. 
For more information, see “Viewing Resource History” on page 356.
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Creating a Test Resource Tree

You define a hierarchical framework for your resources by creating a test 
resource tree. For each resource folder in the tree, you define resources.

Note: When a Quality Center project with Business Process Testing is 
connected to QuickTest Professional, a BPT Resources folder is created 
automatically in the tree. The BPT Resources folder contains all the 
QuickTest resources available for business components in the project.

Adding Folders to the Test Resource Tree
You start a test resource tree by adding a folder under the Resources root 
folder. 

To add a resource folder to the test resource tree:

 1 In the test resource tree, select the Resources folder.

 2 Click the New Resource Folder button or choose Resources > New Resource 
Folder. The New Resource Folder dialog box opens.

 3 Type the Resource Folder Name and click OK. The new folder is added under 
Resources in the test resource tree.

 4 In the Details tab, type a description for the resource folder. For more 
information on the Details tab, see “Updating Details of Resources and 
Folders” on page 344.

 5 To add an additional folder, select a folder from the tree and repeat Steps 2 
to 4.

Adding Resources to Resource Folders
You can add resources to resource folders.

Version Control: The new resource is automatically checked out. For more 
information, see “Checking Out Entities” on page 104.
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To add a resource to a resource folder:

 1 Select a resource folder in the test resource tree.

 2 Click the New Resource button or choose Resources > New Resource. The 
New Resource dialog box opens.

 3 In the Name field, type the resource name.

 4 In the Type box, select a resource type.

 5 In the Created By box, select the user name of the person who created the 
resource. By default, the name of the user who is currently logged in to 
Quality Center is displayed.

 6 In the Description box, type a description for the resource.

 7 To add a comment, click the Comments tab. Click the Add Comment 
button. A new section is added to the Comments box, displaying your user 
name and the database’s current date.

 8 Click Submit. An empty resource is added to the selected resource folder. 
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Resource details are displayed in the Details tab. For more information on 
the Details tab, see “Updating Details of Resources and Folders” on 
page 344.

You can add content to the resource using the Resource Viewer tab. For more 
information on the Resource Viewer tab, “Working with Resources” on 
page 346. 

For more information on working with QuickTest resources, see the section 
on working with Quality Center in the HP QuickTest Professional User Guide.

Updating Details of Resources and Folders

You can view and update details of the resources and folders of your test 
resource tree in the Details tab.

To update details of a resource or folder:

 1 Select a resource or folder in the test resource tree.

 2 Click the Details tab.
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➤ If you select a folder, the following fields are displayed in the Details tab:

➤ If you select a resource, the following fields are displayed in the Details 
tab:

You can add user-defined fields and change the label of any of the fields in 
the Test Resources module. For more information, refer to the 
HP Quality Center Administrator Guide.

Field Description

Name The name of the resource folder. 

Folder ID A unique numeric ID for the folder that is assigned by 
Quality Center. This field cannot be modified.

Description The description of the resource folder. 

Field Description

Name The name of the resource. 

Type Indicates the type of resource. Click the down arrow to 
select a different type from the list.

Created By The user who created the file. Click the down arrow to 
select a different user name. 

Creation Date The date on which the file was created. Click the down 
arrow to display a calendar and select a creation date. 
By default, the creation date is set to the current 
database server date.

Resource ID A unique numeric ID for the file that is assigned by 
Quality Center. This field cannot be modified.

Description The description of the resource. 

Comments Displays comments about the resource. To add a new 
comment, click the Add Comment button. A new 
section is added to the Comments box, displaying 
your user name and the database’s current date.

Version Number The version number of the resource. If version control 
is enabled for your project, this field is displayed.
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You can use the Script Editor to restrict and dynamically change the fields 
and values in the Test Resources module. For more information, refer to the 
HP Quality Center Administrator Guide.

Working with Resources

Using the Resource Viewer tab, you can upload files for each resource or 
folder in the test resource tree to the Quality Center repository. You can also 
download files to a local directory. 

After you upload your files, you define dependencies between resources and 
tests from your testing tool, for example, QuickTest Professional. For more 
information, refer to the HP QuickTest Professional User Guide.

You can also define dependencies between resources and tests by writing 
your own application. For more information, refer to HP Quality Center 
Entity Dependencies API Reference.

Note: To view the resource content, you must install the relevant add-in or 
extension. For more information on the QuickTest Professional add-in, refer 
to the HP QuickTest Professional User Guide.

This section includes:

➤ Uploading Test Resource Files

➤ Downloading Test Resource Files

Uploading Test Resource Files
You can upload files for each resource in the test resource tree to the 
Quality Center repository.

To upload a test resource file:

 1 Select a resource in the test resource tree.
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 2 Click the Resource Viewer tab.

 3 To upload a file, click the Upload File button. The Upload File dialog box 
opens. Select a file and click Open. The file is uploaded to the Quality Center 
repository.

 4 To upload a folder, click the Upload File arrow and choose Upload Folder. 
The Browse for Folder dialog box opens. Select a folder and click OK. The 
folder is uploaded to the Quality Center repository.

 5 To replace an uploaded file, repeat Step 3.

 6 To replace an uploaded folder, repeat Step 4.

Downloading Test Resource Files
To view and edit your test resources, you can download them to your 
machine.

To download a test resource file:

 1 Select a resource in the test resource tree.

 2 Click the Resource Viewer tab.
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 3 Click the Download button. The Browse for Folder dialog box opens.

 4 Select a folder and click OK. The resource is downloaded to the specified 
folder.

Viewing Test Resource Dependencies

After you define associations between the test resources and your tests, you 
can view dependency relationships that exist between them in the 
Dependencies tab. For more information, see “Viewing Dependencies” on 
page 357.

Managing the Test Resource Tree

This section on managing the test resource tree includes the following 
topics:

➤ Copying Test Resources in a Project

➤ Copying Test Resources Across Projects

➤ Copying URLs of Test Resources

➤ Finding Test Resources

➤ Filtering Test Resources

➤ Mailing Test Resources

➤ Moving Test Resources

➤ Renaming Test Resources

➤ Deleting Test Resources

Copying Test Resources in a Project
You can copy resources within the same project. 

To copy a test resource in a project:

 1 Select the resource or folder that you want to copy in the test resource tree. 
To copy more than one item, use the CTRL key.
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 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Select the folder to which you want to copy the resource or folder.

 4 Choose Edit > Paste. Alternatively, right-click and choose Paste.

Copying Test Resources Across Projects
You can copy resources from one project to another. If the test resources are 
dependent on other test resources, or if the test resources contain calls to 
other tests, you can instruct Quality Center to copy them using one of the 
following methods:

➤ Copy test resources and link them to existing related test resources and 
called tests in the target project. If a related test resource or called test does 
not exist in the target project, Quality Center copies it to the target project.

➤ Copy test resources along with related test resources and called tests into the 
target project. 

➤ Copy test resources without copying related test resources and called tests 
into the target project.

Note: To copy test resources across projects, both projects must use the same 
Quality Center version and patch level.

For more information on related entities, see “Viewing Dependencies” on 
page 357.

To copy a test resource across projects:

 1 Select the resource or folder that you want to copy in the test resource tree. 
To copy more than one item, use the CTRL key.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Open another instance of Quality Center and log in to the project to which 
you want to paste the resource or folders.

 4 Select the folder to which you want to copy the resources or folders.
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 5 Choose Edit > Paste. Alternatively, right-click and choose Paste. The Paste 
Resources to Target Project dialog box opens. 

 6 Select one of the following options:

➤ Copy resources and link to existing related entities. Quality Center 
copies the test resources or folders and pastes them into the target 
project. The copied test resources or folders are linked to existing test 
resources and called tests with the same name. If a related test resource or 
a test does not exist in the target project, Quality Center copies it to the 
target project.

➤ Copy resources and related entities. Quality Center copies the test 
resources or folders along with the related test resources and called tests, 
and pastes them into the target project. If a related test resource or a 
called test already exists in the target project, the copied related test 
resource or called test is renamed to resolve the duplicate name.

➤ Copy resources without copying related entities. Quality Center copies 
the test resources or folders without copying the related test resources or 
called tests, and pastes them into the target project. The copied items are 
not linked to any related entities.

Click OK. 

Copying URLs of Test Resources
You can copy a resource from the test resource tree and paste its URL as a 
link. The resource itself is not copied. Instead, you can paste the address into 
another location, such as an email or a document. Clicking on the link 
opens up Quality Center and takes you to the resource file or folder. If you 
are not already logged in, Quality Center first prompts for login details. 

To copy a URL of a test resource:

 1 In the test resource tree, select a resource or a folder. 

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.
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Finding Test Resources 
You can search for resources in the test resource tree. If you have applied 
filters to the tree, the search is restricted to the resources currently displayed.

To find a test resource:

 1 Choose Edit > Find. The Find dialog box opens.

 2 In the Find in Field box, select the criterion to search for. 

 3 In the Value to Find box, type or select the value of the field you chose. The 
search is not case sensitive.

 4 Click Find. The Test Resources module searches for the resource with the 
specified value. If the search is successful, the Search Results dialog box 
opens and displays a list of possible matches. Select a result from the list and 
click the Go To button to highlight the resource in the test resources tree. If 
the search is unsuccessful, an information box opens.

Filtering Test Resources
Click the Set Filter/Sort button to filter and sort the resources in the test 
resource tree. For more information, see Chapter 3, “Working with 
Quality Center Data.” Any currently applied filters or sorting orders are 
displayed under the test resource tree toolbar.
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Mailing Test Resources 
You can send email about a resource to other users. This enables you to 
routinely inform development and quality assurance personnel about the 
status of your resources. A link is included in the email, enabling the 
recipient to go directly to the resource.

By default, Quality Center sends email in HTML format. To send email as 
plain text instead, edit the MAIL_FORMAT parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator Guide.

To mail a test resource: 

 1 Select one or more resources in the test resource tree and click the Send by 
E-mail button. The Send E-mail dialog box opens.
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 2 Type a valid email address or user name. Alternatively, click the To button or 
CC button to select users. The Select Recipients dialog box opens. 

You can sort the users list, search for users, group users by user groups, and 
select users from the list or from a group tree. For more information, see 
“Selecting Users” on page 55. 

Select the users or user groups to whom you want to send the email, and 
click OK.

 3 In the Subject box, type a subject for the email. By default, the domain, 
project, resource ID, and name of the resource are displayed in the Subject 
box.

 4 In the Additional comments box, add any comments you may have.

 5 To check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word as 
well as replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way spelling is checked. 
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➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.

➤ Click the Custom button to specify fields to include in the email. In the 
Select Fields dialog box, select field names and click the arrow buttons (> 
and <) to move them between Available Fields and Visible Fields. Click 
the double arrow buttons (>> and <<) to move all the fields from one list 
to the other. Click OK to close the Select Fields dialog box.

 6 Click Send to send the email.

Moving Test Resources
You can move a resource to a different location in the test resource tree. The 
root folder cannot be moved.

Tip: You can also move a resource to a different location in the test resource 
tree by dragging it.

To move a test resource:

 1 Select the resource or folder that you want to move in the test resource tree. 
To move more than one item, use the Ctrl key.

 2 Choose Edit > Cut or right-click the resource and choose Cut.

 3 Select the folder to which you want to move the resource or folder.

 4 Choose Edit > Paste. Alternatively, right-click and choose Paste. 

Renaming Test Resources
You can rename a resource or a folder in the test resource tree.

To rename a test resource:

 1 In the test resource tree, select a resource or a folder. 

 2 Click the item. Alternatively, right-click the item and choose Rename.

 3 Edit the item name and press ENTER.



Chapter 24 • Managing Test Resources

355

Deleting Test Resources
You can delete resources and folders from the test resource tree. If other 
entities depend on the resource, deleting the resource may impact these 
related entities. For more information on related entities, see “Viewing 
Dependencies” on page 357.

Version Control: Deleting a resource deletes all previous versions of the 
resource.

To delete a test resource:

 1 In the test resource tree, select a resource. 

 2 Click the Delete button or choose Edit > Delete. 

 3 If the resource is not being shared with other entities, a confirm box opens. 
Click Yes.

 4 If other entities depend on the resource, the Delete Resource dialog box 
opens. To view the related entities, click Details. Click Yes to confirm you 
want to delete the resource.

To delete a folder:

 1 In the test resource tree, select a folder. 

 2 Click the Delete button or choose Edit > Delete. A confirm box opens.

 3 If the folder is not being shared with other entities, click Yes.

 4 If other entities are dependent on some of the resources in the folder, choose 
one of the following: 

➤ Click Yes to delete the folder and possibly impact other related entities.

➤ Click No to view the related entities before you delete the folder. You can 
view related entities in the Dependencies tab. For more information, see 
“Viewing Dependencies” on page 357.
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Viewing Resource History

You can view a history of baselines in which the test resource appears. You 
can also compare two baseline versions. For more information, see “Viewing 
Baseline History” on page 524.

Version Control: You can view all previous versions of a test resource. For 
more information, see “Viewing Version History” on page 109.
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Viewing Dependencies

Dependencies define relationships between entities such as tests, 
components, and test resources. You can view the entities used by a selected 
entity, and the entities that a selected entity is using. 

This chapter includes:

 ➤  About Viewing Dependencies on page 357

 ➤  Viewing Dependencies on page 358

About Viewing Dependencies

You can view dependencies that exist between entities such as tests, 
components, and test resources. When analyzing the impact of a change 
proposed to a specific entity, the dependencies indicate the other entities 
that the change might affect. 

Dependency relationships are displayed in the Dependencies tab. This tab is 
available from the Test Plan and Test Resources modules. Depending on 
your Quality Center license, you may also view the Dependencies tab from 
the Business Components module. For more information, refer to the HP 
Business Process Testing User Guide.

You can define dependencies between entities using other HP testing tools, 
for example, QuickTest Professional. For more information, refer to the HP 
QuickTest Professional User Guide. 

You can also define dependencies between entities by writing your own 
application. For more information, refer to HP Quality Center Entity 
Dependencies API Reference.
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Viewing Dependencies

You can view dependencies in the Dependencies tab. This tab contains the 
Used By and Using grids. The Used By grid displays entities that depend on a 
selected entity. The Using grid displays the entities that a selected entity 
depends on. 

Version Control: When checking out an old version of an entity, the 
Dependencies tab does not display any dependencies to entities that no 
longer exist.
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The Used By grid contains the following columns:

The Using grid contains the following columns:

Column Description

Owner ID A unique numeric ID for the associated entity. The ID is 
assigned automatically by Quality Center. 

Owner Type The type of the associated entity that uses the selected 
entity. It includes the following types:

➤ Resource. A resource listed in the test resource tree.

➤ Test. A test listed in the test plan tree.

➤ Component. Depending on your Quality Center 
license, you may also view the component listed in the 
business component tree. For more information, refer 
to the HP Business Process Testing User Guide.

➤ <user-defined entity>. A user-defined entity.

Owner Name The name of the associated entity that uses the selected 
entity.

Owner Description The description of the associated entity that uses the 
selected entity.

Column Description

Related ID A unique numeric ID for the associated entity. The ID is 
assigned automatically by Quality Center. 

Related Type The type of the associated entity that the selected entity 
uses. It includes the following types:

➤ Resource. A resource listed in the test resource tree.

➤ Test. A test listed in the test plan tree.

➤ Component. Depending on your Quality Center 
license, you may also view the component listed in the 
business component tree. For more information, refer 
to the HP Business Process Testing User Guide.

➤ <user-defined entity>. A user-defined entity.
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To view dependencies:

 1 To display the Dependencies tab:

➤ From the Test Plan module, select a test from the test plan tree. Click the 
Dependencies tab.

➤ From the Test Resources module, select a resource from the test resource 
tree. Click the Dependencies tab.

Depending on your Quality Center license, you may also view the 
Dependencies tab from the Business Components module.

 2 Click the Show/Hide arrow to display the Used By or Using grid. 

 3 To refresh the grids, click the Refresh button. 

 4 To view additional details for an entity, select an entity from the Used By or 
Using grid and click the Go To button. You can view the following entities:

➤ Resource. Goes to the test resource tree and displays the test resource.

➤ Test. Goes to the test plan tree and displays the test.

➤ <user-defined entity>. Goes to the test plan tree and displays the test that 
is associated with this user-defined entity.

➤ Component. Depending on your Quality Center license, you may also 
view the component in the Business Components module. 

Related Name The name of the associated entity that the selected entity 
uses.

Related Description The description of the associated entity that the selected 
entity uses.

Column Description
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26
The Test Lab Workflow

As your application changes, you run the manual and automated tests in 
your project in order to locate defects and assess quality.

Quality Center Starter Edition: Fields and functionality related to release 
management and baselining are not available in the Test Lab module if you 
are working with the Starter Edition. 

This chapter describes how you run tests using the Quality Center Test Lab 
module. Executing tests consists of the following: 

Define Testing 
Scope

Create
Requirements

Create
Requirements

Detail 
Requirements

Detail 
Requirements

Analyze 
Requirements

Analyze 
Requirements

Create
Test Sets

Schedule
Runs

Run Tests
Manually

Analyze Test Results

Run Tests
Automatically
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Creating Test Sets

Start by creating test sets and choosing which tests to include in each set. A 
test set is a group of tests in a Quality Center project designed to achieve 
specific testing goals. In the sample Mercury Tours application, for example, 
you could create a set of sanity tests that checks the basic functionality of 
the application. You could include tests that check the login mechanism, 
and tests that check the flight booking mechanism.

After you have created test sets, you assign test set folders to cycles defined 
in the releases tree in the Releases module. A cycle represents a development 
and QA cycle based on the project timeline.

For more information, see Chapter 28, “Creating Test Sets.”

Scheduling Test Runs

Quality Center enables you to control the execution of tests in a test set. You 
can set conditions, and schedule the date and time for executing your tests. 
You can also set the sequence in which to execute the tests. For example, 
you can determine that you want to run test2 only after test1 has finished, 
and run test3 only if test1 passed. 

For more information, see Chapter 29, “Scheduling Test Runs.”

Running Tests Manually

Once you have defined test sets, you can begin executing the tests. When 
you run a test manually, you execute the test steps that you defined during 
test planning. You pass or fail each step, depending on whether the 
application’s actual results match the expected output. 

For example, suppose you are testing the process of booking a flight in the 
sample Mercury Tours application. You open the application, create a new 
order, and book a flight, following the instructions detailed by the test steps.

For more information, see Chapter 30, “Running Tests Manually.”
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Running Tests Automatically

Once you have defined test sets, you can begin executing the tests. You can 
select all the tests in a test set, or specific tests. Your selection can include 
both automated and manual tests. 

When you run an automated test, the selected testing tool opens 
automatically, runs the test, and exports the test results to Quality Center. 
When you run a manual test, email is sent to a designated tester, requesting 
that they run the manual test.

For more information, see Chapter 31, “Running Tests Automatically.”

You can also run an automated system test to provide system information, 
capture a desktop image, or restart a machine. For more information on 
running system tests, see Chapter 23, “Working with System Tests.”

Analyzing Test Results

Following a test run, you analyze test results. Your goal is to identify failed 
steps and to determine whether a defect has been detected in your 
application, or if the expected results of your test need to be updated. If a 
defect has been detected, you can create a new defect and link it to the test 
run, or link an already-existing defect with the test run. For more 
information, see Chapter 36, “Linking Defects.”

You can validate test results regularly by viewing run data and by generating 
reports and graphs. For more information, see Chapter 40, “The Dashboard 
Module,” and Chapter 44, “Generating Live Analysis Graphs.”

For more information on understanding the data that appears in 
Quality Center following a test run, see Chapter 32, “Viewing Test Results.”
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27
The Test Lab Module at a Glance

This chapter introduces the key elements in the Test Lab module.

This chapter includes:

 ➤  The Test Lab Module on page 368

 ➤  The Test Lab Menu Bar on page 370

 ➤  The Test Lab Toolbars on page 371

 ➤  The Execution Grid on page 373

 ➤  The Execution Flow on page 378
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The Test Lab Module 

You create test sets and perform test runs in the Test Lab module of 
Quality Center, which you open by clicking the Test Lab button on the 
sidebar. 

The Test Lab module contains the following key elements:

➤ Test Lab menu bar. Displays drop-down menus of Test Lab module 
commands. For more information, see “The Test Lab Menu Bar” on 
page 370.

➤ Test Set toolbar. Contains buttons of commands commonly used when 
creating and modifying test sets in the test sets tree. For more information, 
see “Test Set Toolbar” on page 371.

➤ Test Set pane. Displays your test sets hierarchically in the test sets tree. By 
default, the tests are grouped in folders. You can also view your test sets as a 
list, by choosing View > Test Sets Grid. For more information on creating a 
test sets tree, see “Creating a Test Sets Tree” on page 384.

➤ Details tab. A description of the test set currently selected in the test sets 
tree. For more information, see “Adding Test Sets” on page 386.
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➤ Execution Grid tab. Displays test data in a grid. For more information, see 
“The Execution Grid” on page 373.

➤ Execution Flow tab. Displays test data in a diagram. For more information, 
see “The Execution Flow” on page 378.

➤ Attachments tab. A list of attachments that provide additional information 
for the test set currently selected in the test sets tree. The tab includes an 
icon  if the selected test set has any attachments. For more information, 
see Chapter 5, “Adding Attachments.”

➤ Automation tab. Displays email notification rules and On Failure 
instructions for the test set currently selected in the test sets tree. For more 
information, see Chapter 28, “Creating Test Sets.”

➤ Linked Defects tab. Displays a list of entities linked to the current test set. 
For more information, see Chapter 36, “Linking Defects.”

➤ Select Tests pane. Displays tests in the right pane to enable you to add tests 
to a test set. To open this pane, click the Select Tests button. The Select Tests 
pane contains two tabs. The Test Plan Tree tab displays the test plan tree. 
The Requirements Tree tab displays tests according to associated 
requirements.

➤ Live Analysis tab. A graphical representation of test data related to the 
selected test set folder in the test set tree. For more information, see 
Chapter 44, “Generating Live Analysis Graphs.”

Tip: Right-click a test in the Execution Grid or Execution Flow, and choose 
Go to Test in Test Plan Tree to open the Test Plan module and highlight the 
selected test in the test plan tree.

Quality Center Starter Edition: Fields and functionality related to release 
management are not available in the Test Lab module if you are working 
with the Starter Edition. 
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The Test Lab Menu Bar

The Test Lab menu bar has the following menus:

➤ The Test Sets menu contains commands that enable you to create, manage, 
and run your test sets. You can purge runs, set test set notifications and 
failure rules, add hosts and set host groups, and export the contents of the 
Execution Grid to a file. For more information, see Chapter 28, “Creating 
Test Sets”. 

➤ The Edit menu contains commands that enable you to cut, copy, paste, 
rename, or delete a test set, or to find a folder or test set. In the Execution 
Flow tab, it enables you to find the test in the flow.

➤ The View menu contains commands that enable you to filter and sort test 
sets, and set the display in the Test Sets Tree and the Test Sets Grid.

➤ The Tests menu contains commands that enable you to run tests, remove 
tests from test sets, set the display in the Execution Grid, view test instance 
properties, reorder tests, find tests, select tests, and view last run result. For 
more information, see Chapter 28, “Creating Test Sets”.

You can also view and add alerts for tests and flag tests for follow-ups. For 
more information, see Chapter 4, “Alerting on Changes”.

➤ The Analysis menu contains commands that enable you to generate 
execution reports and graphs. For more information on execution reports, 
see Chapter 42, “Generating Standard Reports.” For more information on 
execution graphs, see Chapter 41, “Generating Graphs,” and Chapter 44, 
“Generating Live Analysis Graphs.”

Tip: You can access the Test Lab menu bar from the Test Lab module by 
pressing the shortcut key F9. Additionally, you can perform many other 
Quality Center operations using shortcut keys. For a list of shortcut keys, see 
Appendix B, “Quality Center Keyboard Shortcuts.”
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The Test Lab Toolbars

The Test Lab module includes the following toolbars: Test Set and Select 
Tests.

In addition, you can use the toolbars in the Execution Grid tab and 
Execution Flow tab. For more information, see “The Execution Grid 
Toolbar” on page 374 and the “The Execution Flow Toolbar” on page 379.

Test Set Toolbar
The Test Set toolbar has the following buttons:

New Folder. Opens the New Folder dialog box, enabling you to create a new 
test set folder. The folder is added to the test sets tree in the left pane. For 
more information, see “Creating a Test Sets Tree” on page 384.

New Test Set. Opens the New Test Set dialog box, enabling you to create a 
new test set in an existing folder. For more information, see “Adding Test 
Sets” on page 386.

Delete. Deletes folders and test sets from the test sets tree. Deletes test sets 
from the test sets grid. For more information, see “Deleting Test Sets” on 
page 404.

Assign To Cycle. Includes the following options:

➤ Assign To Cycle. Enables you to assign a test set folder to a cycle. For 
more information, see “Assigning Test Set Folders to Cycles” on page 385.

➤ Clear Assigned Cycle. Clears the assigned cycle from the test set folder.

Refresh All. Refreshes the test sets tree or test sets grid so that it displays the 
most up-to-date test sets.

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
test sets. 

➤ Clear Filter/Sort. Clears any filters or sorts that you have applied.

For more information, see “Filtering Records” on page 56.
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Select Tests Toolbar
To display the test plan tree in the right pane, click the Select Tests button. 
The Test Plan Tree tab is displayed. If you click the Requirements Tree tab, 
the tests are displayed according to associated requirements.

The Select Tests toolbar has the following buttons:

Add Tests to Test Set. Adds tests to a test set. 

Refresh All. Refreshes the tree.

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
tests. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied.

Find. Searches for a specific test in the tree. If the search is successful, the test 
is highlighted in the tree.

Go To Test. Searches for a specific test by Test ID in the tree. If the search is 
successful, the test is highlighted in the tree.

Go To Requirement. Searches for a specific requirement by ReqID in the tree. 
If the search is successful, the requirement is highlighted in the tree.
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The Execution Grid 

In the Execution Grid, your test data is organized and displayed in a grid. 
Each line in the grid displays a separate test record. 

The Execution Grid tab contains the following key elements:

➤ Execution Grid toolbar. Contains buttons of commands commonly used 
when executing and viewing tests. See “The Execution Grid Toolbar” on 
page 374.

➤ Indicator columns. Indicates that the specified test instance has 
attachments, linked defects, alerts, and follow up flags. Choose Tests > 
Indicator Columns to display these columns.
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➤ Grid filter. Displays the filter that is currently applied to a column. To 
display grid filters, choose Tests > Grid Filters.

➤ Last Run Result pane. Displays the results of the last test run. To display the 
last run result pane, choose Tests > Last Run Result or click the Show arrow.

The Execution Grid Toolbar
The Execution Grid toolbar has the following buttons:

Select Tests. Displays the test plan tree in the right pane. You use the test 
plan tree to select tests to add to a test set. You can also click the 
Requirements Tree tab to view tests according to associated requirements. 
For more information, see “Adding Tests to a Test Set” on page 388.

Run. If you select a manual test, opens the Manual Runner dialog box to run 
the test. If you select an automated test, opens the Automatic Runner dialog 
box to run the test. It also includes the following options:

➤ Run Manually. Runs an automated test manually.

➤ Continue Manual Run. Resumes a manual test run.

For more information on running a test manually, see Chapter 30, 
“Running Tests Manually”. For more information on running a test 
automatically, see Chapter 31, “Running Tests Automatically”.

Column Description

Attachments Click the  icon to view attachments for the test instance. 
For more information, see Chapter 5, “Adding 
Attachments.”

Linked Entities Click the  icon to view linked entities for the test 
instance. For more information, see Chapter 36, “Linking 
Defects.”

Alerts Click the  icon to view alerts for the test instance. For 
more information, see “Viewing Alerts” on page 80.

Follow Up Flags Click the  icon to view follow up alerts for the test 
instance. For more information, see “Flagging for Follow 
Up” on page 82.
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Run Test Set. Opens the Automatic Runner dialog box to run the test set. 
Test sets can include both manual and automated tests. For more 
information, see “Running a Test Automatically” on page 432.

Remove Tests from Test Set. Removes the selected tests from the test set. For 
more information, see “Removing Tests from a Test Set” on page 400.

Refresh All. Refreshes the Execution Grid so that it displays the most 
up-to-date tests based on the filters you have selected.

Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
the tests in the Execution Grid. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter and sort 
tests. 

➤ Clear Filter/Sort. Clears any filters or sorting that you have applied in the 
Execution Grid.

For more information, see “Filtering Records” on page 56.

Select Columns. Opens the Select Columns dialog box, enabling you to 
determine which columns to display in the Execution Grid and their order. 
For more information, see “Arranging Columns” on page 52.

Test Instance Properties. Opens the Test Instance Properties dialog box to 
display the properties of the selected test instance. For more information, 
see “Viewing Test Results” on page 443.

Attachments. Opens the Test Instance Properties dialog box, enabling you to 
add an attachment to a test run instance. For more information, see 
Chapter 5, “Adding Attachments.”

Flag for Follow Up. Opens the Flag For Follow Up dialog box, enabling you 
to add or modify a follow up flag for a test instance. For more information, 
see “Flagging for Follow Up” on page 82.
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Execution Grid Columns
The Execution Grid displays test planning and test run data columns. For 
more information on the test planning data columns, see “Test Grid 
Columns” on page 260.

Column Description

Exec Date The date on which the test was last executed.

Modified The date and time of the last change to the test in the 
Execution Grid.

Planned Exec Date The date on which it was planned to execute the test.

Planned Exec Time The time at which it was planned to execute the test.

Planned Host Name The name or IP address of the machine to run the test.

Responsible Tester The user name of the person responsible for running the 
test.

Status The status of the last test run. Execution status can be one 
of the following: Failed, N/A, No Run, Not Completed, 
Passed.

Target Cycle Indicates the cycle in which the test was assigned. Click 
the down arrow to select a different cycle.

Tester The user name of the person who last executed the test.

Time The time at which the test was last executed.
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Notes: 

➤ You can add user-defined fields and change the label of any of the fields 
in the Execution Grid. You can also customize project lists. For more 
information, refer to the HP Quality Center Administrator Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Execution Grid. For more information, refer to 
the HP Quality Center Administrator Guide.

➤ When you select an Execution Grid column with a user name value, 
Quality Center displays a list with the name and full name of each user. 
You can search for users, sort users, group users by user group, and select 
users from the users list or a group tree. For more information, see 
“Selecting Users” on page 55.
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The Execution Flow 

In the Execution Flow, your test data is organized and displayed in a 
diagram. You use the Execution Flow to control the way your tests are 
executed. You can specify when and under what conditions you want a test 
to be executed. 

For more information on the Execution Flow tab, see Chapter 29, 
“Scheduling Test Runs.” 

The Execution Flow tab contains the following key elements:

➤ Execution Flow toolbar. Contains buttons of commands commonly used 
when scheduling test executions. See “The Execution Flow Toolbar” on 
page 379.

➤ Execution Flow diagram. Displays tests with conditions in a diagram. For 
more information, see Chapter 29, “Scheduling Test Runs.”
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The Execution Flow Toolbar
The Execution Flow toolbar has the following buttons:

Select Tests. Displays the test plan tree in the right pane. You use the test 
plan tree to select tests to add to a test set. You can also click the 
Requirements Tree tab to view tests according to associated requirements. 
For more information, see “Adding Tests to a Test Set” on page 388.

Run. If you select a manual test, opens the Manual Runner dialog box to run 
the test. If you select an automated test, opens the Automatic Runner dialog 
box to run the test. It also includes the following options:

➤ Run Manually. Runs an automated test manually.

➤ Continue Manual Run. Resumes a manual test run.

For more information on running test manually, see Chapter 30, “Running 
Tests Manually”. For more information on running test automatically, see 
Chapter 31, “Running Tests Automatically.”

Run Test Set. Opens the Automatic Runner dialog box to run the test set. 
Test sets can include both manual and automated tests. For more 
information, see “Running a Test Automatically” on page 432.

Find Test In Flow. Opens the Find Test dialog box, enabling you to find a test 
in the Execution Flow. For more information, see “Finding Tests” on 
page 418.

Remove Tests from Test Set. Removes the selected tests from the test set.

Refresh Flow. Refreshes the Execution Flow diagram so that it displays the 
most up-to-date tests.

Arrange Layout. Rearranges the tests in a hierarchical layout, enabling you 
to view dependencies between different tests.

Zoom In. Increases the magnification level so that you can view a section of 
the Execution Flow more closely.

Zoom Out. Decreases the magnification level so that you can view more of 
the Execution Flow.
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Fit Picture In Window. Redisplays the diagram to fit the window. Click the 
Fit Picture In Window arrow to select a magnification option. For more 
information, see “Viewing the Execution Flow Diagram” on page 418.

Add Time Dependency to Flow. Adds a time dependency icon to the 
diagram. To create a time dependency for a test, link the arrow from the 
icon to a test in the Execution Flow. The default time dependency is the 
Quality Center server’s current date and time. For more information, see 
“Scheduling a Test Run” on page 411.
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28
Creating Test Sets

You can organize test execution by creating test sets. A test set contains a 
subset of the tests in your project. The test sets tree organizes and displays 
your test sets hierarchically.

Quality Center Starter Edition: Fields and functionality related to release 
management and baselining are not available when creating test sets with 
the Starter Edition. 

This chapter includes:

 ➤  About Creating Test Sets on page 382

 ➤  Creating a Test Sets Tree on page 384

 ➤  Assigning Test Set Folders to Cycles on page 385

 ➤  Adding Test Sets on page 386

 ➤  Adding Tests to a Test Set on page 388

 ➤  Setting Test Set Notifications on page 390

 ➤  Setting Test Set On Failure Rules on page 392

 ➤  Managing Test Sets on page 396
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About Creating Test Sets

After you design tests in the Test Plan module, you create a test sets tree. A 
test sets tree enables you to organize your application management process 
by grouping test sets in folders and organizing them in different hierarchical 
levels in the Test Lab module. A test set is a group of tests in a 
Quality Center project designed to achieve specific test goals. Test sets can 
include both manual and automated tests. After you create a test sets tree, 
you assign test set folders to cycles defined in the releases tree in the Releases 
module.

To decide which test sets to create, think about the goals you defined at the 
beginning of the application management process. Consider issues such as 
the current state of the application and the addition or modification of new 
features.

Following are examples of general categories of test sets you can create:

Test Set Description

Sanity Checks the entire application at a basic level—focusing on 
breadth, rather than depth—to verify that the application is 
functional and stable. This set includes fundamental tests 
that contain positive checks, validating that the application 
is functioning properly. For example, in the Mercury Tours 
application, you could test whether the application opens, 
and enables you to log in.

Regression Tests the system in a more in-depth manner than a sanity set. 
This set can include both positive and negative checks. 
Negative tests attempt to fail an application to demonstrate 
that the application is not functioning properly.

Advanced Tests both breadth and depth. This set covers the entire 
application, and also tests the application’s advanced 
options. You can run this set when there is ample time for 
testing.

Function Tests a subsystem of an application. This could be a single 
feature or a group of features. For example, in the Mercury 
Tours application, a function set could test all activities 
related to booking a flight.
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Suppose you want to test new features added to Release 10.5 of the Mercury 
Tours application. Release 10.5 consists of four cycles, and you want to test 
the new features for the release in Cycle 1, Cycle 2, and Cycle 4. Because the 
tests you need to run to test the new features are the same for each of these 
cycles, you want to use the same test set as a basis for testing new features in 
each of the cycles.

In the test sets tree, you can create the folder Release 10.5 for the release. 
Under this folder, you create the folder Cycle 1 for the first cycle of the 
release. In the Cycle 1 folder, you create a test set New Features containing 
the tests necessary to test new features for the release. After you create this 
test set and add its tests, you can copy and paste the Cycle 1 folder and use it 
as a basis for the other cycles that test new features.

Note that by default, the uppermost level in a test sets tree is the Root folder. 
You cannot delete the Root folder or add test sets directly to it. Under the 
Root folder, the Unattached folder contains all test sets no longer associated 
with a folder. You cannot add a test set to the Unattached folder. When you 
delete a folder, you can instruct the Test Lab module to move the folder's 
test sets to the Unattached folder or to permanently delete the test sets. 



Chapter 28 • Creating Test Sets

384

Creating a Test Sets Tree

You define a hierarchical framework for your test sets by creating a test sets 
tree. The test sets tree can contain folders at the main level and subfolders 
below the main folders. For each folder in the test sets tree, you define a test 
set and add test instances to it. You start a test sets tree by adding a folder to 
the Root folder.

After you have created a test sets tree, you assign test set folders to cycles 
defined in the releases tree in the Releases module. For more information, 
“Assigning Test Set Folders to Cycles” on page 385.

To create a test sets tree:

 1 Choose View > Test Sets Tree to display the test sets tree view in the Test Set 
pane.

 2 In the test sets tree, select the Root folder.

 3 Click the New Folder button or choose Test Sets > New Folder. The New 
Folder dialog box opens.

 4 Type the Folder Name and click OK. Note that a folder name cannot include 
the following characters: \ ^ * 

The new folder appears under Root in the test sets tree.

 5 In the Details tab, complete the test set folder details by assigning the test 
set folder to a cycle. For more information, see “Assigning Test Set Folders to 
Cycles” on page 385.

 6 In the Description tab, type a description of the test set folder. 

 7 Click the Attachments tab to add an attachment to the new test set folder if 
necessary. An attachment can be a file, URL, snapshot of your application, 
an item from the Clipboard, or system information. For more information, 
see Chapter 5, “Adding Attachments.”

 8 To create additional folders, select a folder and repeat steps 3 to 7. 
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Assigning Test Set Folders to Cycles

After you have created a test sets tree, you assign test set folders to cycles 
defined in the releases tree in the Releases module. For more information, 
see Chapter 10, “Developing the Releases Tree.”

Quality Center Starter Edition: Assigning test set folders to cycles is 
unavailable.

To assign a test set folder to a cycle:

 1 In the test sets tree, select the test set folder that you want to assign to a 
cycle. 

 2 Click the Assign To Cycle button or choose Test Sets > Assign To Cycle. 
Alternatively, in the Details tab, click the browse button next to the 
Assigned to cycle box. The Assign To Cycle dialog box opens. 

 3 Expand the tree and select a cycle. 

 4 Click OK to close the Assign To Cycle dialog box. In the test set tree, the test 
set folder icon  is replaced by the assigned test set folder icon .

The Details tab displays the following test set folder details:

You can click the Show button to view the following details:

Field Description

Assigned to cycle Indicates the cycle to which the selected test set folder 
is assigned.

Cycle start date The date on which the cycle starts. 

Cycle end date The date on which the cycle ends. 

Remaining days in cycle The total number of days remaining in the cycle.

Field Description

Total test instances The total number of test instances in the selected test 
set folder.

Remaining test 
instances to run

The total number of test instances in the selected test 
set folder that have not yet run.
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 5 To clear an assigned test set folder, select it, click the Assign To Cycle arrow, 
and choose Clear Assigned Cycle. Alternatively, select an assigned test set 
folder and choose Test Sets > Clear Assigned Cycle. 

Adding Test Sets

You can add a test set to a folder in your test sets tree, or to the test sets grid.

To add a test set:

 1 You can add a test set to the test sets tree or test sets grid:

➤ Display the test sets tree by choosing View > Test Sets Tree. In the test 
sets tree, choose a folder and click the New Test Set button or choose Test 
Sets > New Test Set.

➤ Display the test sets grid by choosing View > Test Sets Grid. Click the 
New Test Set button  or choose Test Sets > New Test Set.

The New Test Set dialog box opens.

If you opened the dialog box from the test sets tree, the Test Set Folder box 
displays the preselected folder name.

 2 If you opened the New Test Set dialog box from the test sets grid, click the 
browse button in the Test Set Folder box, and choose a folder.
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 3 In the Test Set Name box, type a name for the test set. Note that a test set 
name cannot include the following characters: \ ^ , " *

 4 In the Description box, type a description of the test set.

 5 Click OK. The test set name is added to the test sets tree. 

 6 Click the Details tab.

Enter the following information:

➤ Quality Center Enterprise and Premier Editions: In Baseline, select a 
baseline to which to pin the test set. For more information, see “Pinning 
a Test Set to a Baseline” on page 525.

➤ In Close Date, select the planned closing date for the test set.

➤ In Open Date, select a date from the calendar. By default, the date is set 
to the current database server date.
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➤ In ITG Request Id, add the IT Governance request ID. Note that this is 
relevant only when integrating with an IT Governance tool.

➤ In Status, set the status of the test set to Open or Closed.

 7 Click the Attachments tab to add an attachment to the test set. An 
attachment can be a file, URL, snapshot of your application, an item from 
the Clipboard, or system information. For more information on 
attachments, see Chapter 5, “Adding Attachments.”

 8 Click the Automation tab and perform the following steps:

➤ Click the Notifications link to instruct Quality Center to send email to 
specified users if certain events occur. For more information, see “Setting 
Test Set Notifications” on page 390.

➤ Click the On Failure link to set rules for the automated tests in the test set 
in the event of a test failure. For more information, see “Setting Test Set 
On Failure Rules” on page 392.

Adding Tests to a Test Set 

After you have defined a test set, you can add manual and automated tests 
from the test plan tree, or tests covering requirements from the 
requirements tree, to the test set. You can also include instances of the same 
test in different test sets or add more than one instance to the same test set.

To add tests from the test plan tree to a test set:

 1 Select a test set from the test sets tree or test sets grid.

 2 In the Execution Grid tab or Execution Flow tab, click the Select Tests 
button. By default, the right pane displays the test plan tree in the Test Plan 
Tree tab.

 3 Select a test or folder and click the Add Tests to Test Set button. 

Tip: You can also add tests by double-clicking or dragging a folder or test in 
the test plan tree to the Execution Grid or Execution Flow.
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 4 If you are adding a folder, a message box opens. Click Yes to confirm.

Note: Only tests that match the current filter in the Test Plan Tree tab are 
added.

 5 If any of the tests you are adding are already in the test set, the Create Test 
Instance dialog box opens. It displays the tests that already exist in the test 
set and how many instances there are. Select the tests you still want to add 
to the test set and click Create.

 6 If the test you are adding has parameters that have not been assigned actual 
values, the Parameters of Test dialog box opens. Assign actual values for the 
parameters. These values will be used for all test runs of the test. For more 
information, see “Assigning Actual Values” on page 322.

 7 Click the Close button to close the right pane.

To add tests covering requirements from the requirements tree to a test set:

 1 Select a test set from the test sets tree or test sets grid.

 2 In the Execution Grid tab or Execution Flow tab, click the Select Tests 
button. 

 3 In the right pane, click the Requirements Tree tab, the tests are displayed 
according to associated requirements. 

 4 To add a test, select the test and click the Add Tests Covering Requirement 
button.

Tip: You can also add tests by double-clicking or dragging a test or 
requirement in the Requirements Tree tab to the Execution Grid or 
Execution Flow.



Chapter 28 • Creating Test Sets

390

 5 To add all tests that cover a selected requirement, select the requirement and 
click the Add Tests Covering Requirement button.

To add all tests that cover a selected requirement and its children, select the 
requirement. Click the Add Tests Covering Requirement arrow and choose 
Add Tests Covering Requirement and Children.

A message box opens. Click Yes to confirm.

Note: Only tests that match the current filter in the Requirements Tree tab 
are added.

 6 If any of the tests you are adding are already in the test set, the Create Test 
Instance dialog box opens. It displays the tests that already exist in the test 
set and how many instances there are. Select the tests you still want to add 
to the test set and click Create.

 7 If the test you are adding has parameters that have not been assigned actual 
values, the Parameters of Test dialog box opens. Assign actual values for the 
parameters. These values will be used for all test runs of the test. For more 
information, see “Assigning Actual Values” on page 322.

 8 Click the Close button to close the right pane. 

Setting Test Set Notifications 

You can instruct Quality Center to send email to a specified user if any of 
the following events occur for a test set:

➤ Any test in the test set fails.

➤ A test in the test set fails due to reasons other than the test logic itself. 
Environmental failure could include, for example, function calls not 
returning, access violations, version incompatibility between application 
components, a missing DLL, inadequate permissions, and many other 
reasons.

➤ All tests in the test set that were run have finished running. Note that this 
does not include tests that were not run.
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To set test set notifications:

 1 Select a test set from the test sets tree or the test sets grid.

 2 Click the Automation tab and select the Notifications link.

 3 Select one or more events for the test set.

 4 To specify who should receive the email, enter a valid email address.

Alternatively, click the To button. The Select Recipients dialog box opens. 
Select individual users or an entire user group. Click OK. To send an email to 
a user, the user must have a valid email address set up in their user 
properties. For more information on defining user properties, refer to the 
HP Quality Center Administrator Guide.

 5 In the Message box, type a message for the email.
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Setting Test Set On Failure Rules 

You can set On Failure rules for a test set which instruct Quality Center in 
the event that an automated test in the test set fails. This includes 
instructions on how many times the test should be rerun, and the cleanup 
test that should be run before the test is rerun. For any automated test in the 
test set, you can change the default On Failure rules. 

To set test set On Failure rules:

 1 Select a test set from the test sets tree or test sets grid.

 2 Click the Automation tab and select the On Failure link.

 3 To set the test set On Failure rule, select the first check box and specify the 
number of times an automated test should be rerun. 

 4 To include a cleanup test before each test rerun, select the second check box 
and click the browse button to select the cleanup test from the test plan tree 
in the Select Cleanup Test dialog box.

 5 You can change the default failure rules for a specific test in the test set. For 
more information, see “Changing the Default Failure Rules for Specific 
Tests” on page 393.
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 6 On the final failure of any test in the test set, you can instruct 
Quality Center to:

➤ Do nothing.

➤ Stop the test set.

➤ Run the test set again a specified number of times.

Changing the Default Failure Rules for Specific Tests
You can change the default failure rules for specific tests in a test set. These 
rules instruct Quality Center in the event that the test fails. This includes 
the number of times the test should be rerun and the cleanup test that 
should be run before the test is rerun.

Note: You can also use the Run Events view in the Test Instance Properties 
dialog box to set the On Failure rules for a test in a test set. For more 
information, see “Viewing Test Run Events” on page 455.

To change the default failure rules for specific tests:

 1 Set the default failure rules. For more information, see “Setting Test Set On 
Failure Rules” on page 392.



Chapter 28 • Creating Test Sets

394

 2 To change the default failure rules for specific tests, click the Settings per 
test button. The On Test Failure dialog box opens.

 3 You can use the following options to specify the number of times an 
automated test should be rerun:

➤ To specify for a selected test, double-click the corresponding cell in the 
Number of Reruns column. The Number of Reruns dialog box opens. 
Specify the number of reruns and click Apply. 

➤ To specify for selected tests, select the tests or click the Select All button. 
Press CTRL and double-click any cell in the Number of Reruns column. 
Alternatively, click the Change Selected Tests arrow and choose Change 
Number of Reruns. The Number of Reruns dialog box opens. Note that 
the Apply to all selected tests option is selected. Specify the number of 
reruns and click Apply.
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 4 You can use the following options to specify a cleanup test:

➤ To specify for a selected test, double-click the corresponding cell in the 
Cleanup Test column. The Select Cleanup Test dialog box opens. Select a 
cleanup test from the test plan tree and click Apply.

➤ To specify one cleanup test for the selected tests, select the tests or click 
the Select All button. Press CTRL and double-click any cell in the Cleanup 
Test column. Alternatively, click the Change Selected Tests arrow and 
choose Change Cleanup Test. The Select Cleanup Test dialog box opens. 
Note that the Apply to all selected tests option is selected. Select a 
cleanup test from the test plan tree and click Apply.

 5 To reset the default failure rules, select a test and click the Set to Default 
button. Click Yes to confirm.

 6 To clear the settings for a test, select a test and click Clear. Click Yes to 
confirm.

 7 To copy the settings from one test to another, select a test to copy and click 
the Copy Test Settings button.

Select a test to paste and click the Paste Test Settings button.

 8 Click OK to save your changes and close the On Test Failure dialog box. 
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Managing Test Sets 

This section on managing test sets includes the following topics:

➤ Finding Test Sets in the Tree

➤ Finding Tests in the Execution Grid

➤ Replace Field Values in the Execution Grid

➤ Removing Tests from a Test Set

➤ Copying Test Sets in a Project

➤ Copying Test Sets Across Projects

➤ Copying URLs of Test Sets

➤ Renaming Test Sets

➤ Deleting Test Set Folders

➤ Deleting Test Sets

➤ Resetting Test Sets

➤ Purging Test Runs from a Test Set
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Finding Test Sets in the Tree
You can search for a folder or test set in the test sets tree. If you have applied 
filters to the test sets tree, the Test Lab module restricts the search to the test 
sets currently displayed.

To find a test set in the tree:

 1 Select a folder in the test sets tree.

 2 Choose Edit > Find Folder/Test Set. The Find Folder/Test Set dialog box 
opens and displays the folder name in the Find in box. If you are searching 
the entire tree, the folder name is Root.

 3 In the Value To Find box, type the name (or part of the name) of the folder 
or test set. You cannot use the asterisk (*) wildcard. Note that the search is 
not case sensitive.

 4 Check Include Test Sets to include test sets in the search.

 5 Click Find.

The Test Lab module attempts to locate the folder or test set. If the search is 
successful, the Search Results dialog box opens and displays a list of possible 
matches. Select a result from the list and click the Go To button to highlight 
the folder or test set in the test sets tree. 

If the search is unsuccessful, an information box opens.
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Finding Tests in the Execution Grid
You can search for tests in the Execution Grid, based on the value of a 
particular field. If you have applied filters to the grid, the search is restricted 
to the tests currently displayed.

To find a test in the Execution Grid:

 1 Choose Tests > Find. The Find dialog box opens.

 2 In the Find in Field box, select a field in the grid.

 3 In the Value to Find box, type or select the value of the field, for which you 
want to search.

 4 Select Exact Match if you want to find tests with field values that exactly 
match the Value to Find string.

 5 Select Case Sensitive if you want the search to distinguish between 
uppercase and lowercase characters.

 6 Select Use Wildcard if you want to use asterisk (*) characters in your search 
string in order to type only part of the item.

 7 Click Find Next. If the search is successful, the matching test is highlighted 
in the grid. If the search is unsuccessful, an information box opens.

 8 Click Find Next again to find the next test that matches the criteria.
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Replace Field Values in the Execution Grid
You can replace field values in the Execution Grid using the Replace 
command.

To replace a field value in the Execution Grid:

 1 Choose Tests > Replace. The Find/Replace dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value. 

 3 In the Value to Find box, type or select the value to find. 

 4 In the Replace with box, type or select a replacement field value.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.

 7 To start the search from the top of the grid, select the From Beginning check 
box.

 8 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 9 To replace the found item and find the next occurrence, click Replace.

 10 To replace all occurrences of the value in the grid, click Replace All.
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Removing Tests from a Test Set
You can remove tests from a test set.

To remove a test from a test set:

 1 Select a test set from the test sets tree or the test sets grid. The tests are 
displayed in the Execution Grid or Execution Flow.

 2 Select the test that you want to remove. To remove more than one test from 
the Execution Grid or Execution Flow, press the CTRL key and select the tests 
you want to remove.

 3 Click the Remove Tests from Test Set button.

 4 Click Yes to confirm. 

Copying Test Sets in a Project
You can copy a test set within the same project. Test run information is not 
copied. 

To copy a test set in a project:

 1 Select a test set or a test set folder from the test sets tree. To copy more than 
one test set or folder, use the CTRL key.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Select the folder to which you want to copy the test set or subject folder.

 4 Choose Edit > Paste. Alternatively, right-click and choose Paste.

Copying Test Sets Across Projects
You can copy test sets from one project to another. If the test sets contain 
calls to other tests, or if the test sets are dependent on test resources, you can 
instruct Quality Center to copy them using one of the following methods:

➤ Copy test sets and link them to existing called tests and related test 
resources in the target project. If a called test or a related test resource does 
not exist in the target project, Quality Center copies it to the target project.

➤ Copy test sets along with called tests and related test resources into the 
target project. 
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➤ Copy test sets without copying called tests and related test resources into the 
target project.

Notes:

➤ To copy test sets or test set folders across projects, both projects must use 
the same Quality Center version and patch level.

➤ When copying test sets or test set folders, test run information is not 
copied.

For more information on related entities, see “Viewing Dependencies” on 
page 357.

To copy a test set across projects:

 1 Select the test set or the test set folder that you want to copy in the test sets 
tree. To copy more than one test set or folder, use the CTRL key.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 Open another instance of Quality Center and log in to the project to which 
you want to paste the tests.

 4 Select the folder to which you want to copy the test sets or test set folders.

 5 Choose Edit > Paste. Alternatively, right-click and choose Paste. The Paste 
Test Sets/Test Set Folders to Target Project dialog box opens. 
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 6 Select one of the following options:

➤ Copy test sets/test set folders and link to existing related entities. 
Quality Center copies the test sets or test set folders and pastes them into 
the target project. The copied test sets or test set folders are linked to 
existing test resources and called tests with the same name and path. If a 
related test resource or a test does not exist in the target project, 
Quality Center copies it to the target project.

➤ Copy test sets/test set folders and related entities. Quality Center copies 
the test sets or test set folders along with the related test resources and 
called tests, and pastes them into the target project. If a related test 
resource or a called test already exists in the target project, the copied 
related test resource or called test is renamed to resolve the duplicate 
name.

➤ Copy test sets/test set folders and related entities. Quality Center copies 
the test sets or test set folders without copying the related test resources 
or called tests, and pastes them into the target project. The copied items 
are not linked to any related entities.

Click OK. 

Copying URLs of Test Sets
You can copy a test set and paste its URL as a link. The test set itself is not 
copied. Instead, you can paste the address into another location, such as an 
email or a document. Clicking on the link opens Quality Center and takes 
you to the test set. 

To copy a URL of a test set:

 1 Select a test set from the test sets tree or grid. 

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.
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Renaming Test Sets
You can rename a test set or test set folder. Note that you cannot rename the 
default test set.

To rename a test set:

 1 Select a test set or test set folder from the test sets tree or the test sets grid.

 2 Right-click the test set or test set folder and choose Rename.

 3 Edit the test set name and press ENTER. 

Deleting Test Set Folders
You can delete a folder and move all of its test sets to the Unattached folder, 
or you can permanently delete a folder with all its test sets.

To delete a test set folder:

 1 Select a folder from the test sets tree. To delete more than one folder, press 
the CTRL key and select the folders you want to delete.

 2 Click the Delete button, or choose Edit > Delete. The Confirm Delete Folder 
dialog box opens.
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 3 To delete, you can:

➤ Select Delete folders only to delete the folder and move all test sets to the 
the Unattached folder. The Unattached folder contains all test sets that 
are no longer associated with a folder.

➤ Select Delete folders and test sets to permanently delete the folder and 
all its test sets.

 4 Click Yes to confirm.

Deleting Test Sets
You can delete a test set from a project. Note that you cannot delete the 
default test set.

To delete a test set:

 1 Select a test set from the test sets tree or the test sets grid. To delete more 
than one test set, press the CTRL key and select the test sets you want to 
delete.

 2 Click the Delete button, or choose Edit > Delete.

 3 Click Yes to confirm. 

Resetting Test Sets
Resetting a test set changes the status of all the tests in the test set to No 
Run. When resetting a test set, you can also decide if you want to delete the 
test run results. 

To reset a test set:

 1 Select a test set from the test sets tree or the test sets grid.

 2 Choose Test Sets > Reset Test Set. The Confirm Reset Test Set dialog box 
opens.

 3 To instruct the Test Lab module not to delete the test run results for the test 
set, clear the Delete all the test run results in test set check box.

 4 Click Yes to confirm.
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Purging Test Runs from a Test Set 
You can use the Purge Runs wizard to delete old test run results in your 
project.

To purge a test run from a test set:

 1 Choose Test Sets > Purge Runs. The Select Test Sets to Purge dialog box 
opens, enabling you to select test sets to purge.

Using the arrows, move the appropriate test set names from the Available 
Test Sets box to the Selected Test Sets box. 

Tip: You can also drag the test sets between lists.
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 2 Click Next. The Choose Type of Purge dialog box opens, enabling you to 
select the purge type and define the purge conditions.

 3 To delete run steps but keep the overall run details:

➤ In the Delete box, select Run Steps Only. 

➤ Under From runs older than, select a period of time before which you 
want to delete run steps.

 4 To delete test run results:

➤ In the Delete box, select Runs. 

➤ Under From runs older than, select a period of time before which you 
want to delete test run results. 

➤ In Keep last, select the number of test run results to keep for each test.
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 5 Click Next. The Confirm Purge Request dialog box opens, summarizing the 
deletions you chose to make.

 6 Click Purge to confirm.
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29
Scheduling Test Runs

The Test Lab module enables you to control the execution of the tests in a 
test set.

This chapter includes:

 ➤  About Scheduling Test Runs on page 409

 ➤  Scheduling a Test Run on page 411

 ➤  Modifying a Test Run Schedule on page 414

 ➤  Arranging Tests Sequentially on page 417

 ➤  Finding Tests on page 418

 ➤  Viewing the Execution Flow Diagram on page 418

About Scheduling Test Runs 

In the Execution Flow, you can specify a date and time, and set conditions 
for executing a test. A condition is based on the results of another specified 
test in the Execution Flow. By setting conditions, you can instruct the Test 
Lab module to postpone execution of the current test until the other 
specified test has either finished running or passed. You can also set the 
sequence in which to execute the tests. 

For example, in a test set, you can determine that test2 will run only if test1 
passed, and test3 will run only if test2 passed. 
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Unlike the Execution Grid, which displays the tests with only test run 
information, the Execution Flow displays the tests with conditions in a 
diagram.

In the Execution Flow, a test set is represented by the Test Set  icon. Each 
test in the diagram is represented by a test icon. 

A dashed line  arrow indicates that the test is to be executed after 
the previous test, with no conditions. 

A solid line  arrow indicates a condition and can be blue or 
green. If the solid line is blue, it indicates that the test is to be executed only 
if the previous test has status Finished. If the solid line is green, it indicates 
that the test is to be executed only if the previous test has status Passed.

When a test is time-dependent, a Time Dependency  icon is added to the 
diagram. 
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Scheduling a Test Run 

The Execution Flow tab enables you to watch the execution process as it 
happens and to control the way your tests are executed. You can specify 
under what conditions you want a test to be executed (execution 
conditions) and when (time dependency).

For information on running tests, see “Running Tests Manually” on 
page 421 and “Running Tests Automatically” on page 431.

To schedule a test run:

 1 In the Execution Flow tab, double-click a test. Alternatively, right-click a test 
and choose Test Run Schedule. The Run Schedule dialog box opens and 
displays the Execution Conditions tab.
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 2 To add a condition, click New. The New Execution Condition dialog box 
opens.

 3 In the Test box, select the test on which you want the current test to be 
dependent.

➤ Select Finished (default) to instruct the Test Lab module to execute the 
current test only after the specified test has finished executing.

➤ Select Passed to instruct the Test Lab module to execute the current test 
only if the specified test has finished executing and has passed.

 4 In the Comments box, add any relevant information regarding the 
condition.

 5 Click OK. The condition is added to the list.

Tip: You can also add a condition directly in the Execution Flow. Click a test 
icon (not the test name) and drag the arrow to another test. By default, the 
condition is set to Finished. To change the condition, double-click the 
condition arrow and select Passed. 
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 6 Click the Time Dependency tab to specify when you want the test to be 
executed.

 7 Select Run At Specified Time, and select a Date and/or Time.

Tip: You can schedule the test run date and time by clicking the Add Time 
Dependency To Flow  button, and linking the arrow from the icon to a 
test. Double-click the icon to set the time in the Time Dependency dialog 
box. The default time dependency is the Quality Center server’s current date 
and time.

 8 Click OK to close the Run Schedule dialog box. In the Execution Flow, the 
diagram displays the tests and the conditions. 



Chapter 29 • Scheduling Test Runs

414

Modifying a Test Run Schedule

You can modify and delete conditions and time dependency information for 
a test run schedule.

This section includes:

➤ Editing Execution Conditions

➤ Deleting Execution Conditions

➤ Editing Time Dependency

➤ Deleting Time Dependency

➤ Deleting All Conditions and Dependencies

Editing Execution Conditions
You can edit conditions connected to a test run.

To edit an execution condition:

 1 In the Execution Flow, double-click a condition arrow. Alternatively, right-
click a condition arrow and choose Execution Condition. The Execution 
Condition dialog box opens.

 2 Modify any relevant information regarding the condition and click OK.
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Deleting Execution Conditions
You can delete a single condition or all conditions connected to a test. 

To delete an execution condition for a test:

 1 In the Execution Flow, right-click a condition arrow and choose Remove 
Execution Condition.

 2 Click Yes to confirm. The condition arrow is removed.

To delete all execution conditions for a test:

 1 In the Execution Flow, right-click a test and choose Remove Test’s Execution 
Conditions.

 2 Click Yes to confirm. All connecting arrows are removed.

Editing Time Dependency
You can modify the date and time of a scheduled test run.

To edit time dependency:

 1 In the Execution Flow, double-click the Time Dependency  icon 
connected to a test. The Time Dependency dialog box opens. 

 2 Modify the date and/or time, and click OK.
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Deleting Time Dependency
You can delete a specified time dependency.

To delete time dependency:

 1 In the Execution Flow, right-click a Time Dependency  icon connected to 
a test and choose Remove Time Dependency. 

 2 Click Yes to confirm. The Time Dependency icon is removed from the 
Execution Flow.

Deleting All Conditions and Dependencies
You can delete all execution conditions and time dependencies in a test set.

To delete all execution conditions for a test set:

 1 Right-click in the Execution Flow and choose Remove All Execution 
Conditions.

 2 If your test set includes both execution conditions and time dependencies, 
the Remove All Execution Conditions dialog box opens.

Choose one of the following options:

➤ Run conditions and time dependencies. Removes the execution 
conditions and time dependencies from your test set.

➤ Run conditions only. Removes the execution conditions from your test 
set.

➤ Time dependencies only. Removes the time dependencies from your test 
set.

Click OK. The execution conditions and/or time dependencies are removed.

 3 If your test set contains only execution conditions or only time 
dependencies, a confirm dialog box opens. Click Yes to confirm. The 
execution conditions or time dependencies are removed.
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Arranging Tests Sequentially 

In the Execution Flow, you can change the execution order of the tests 
displayed in the diagram.

To arrange tests sequentially:

 1 In the Execution Flow, press the CTRL key and select two or more tests.

 2 Right-click a test and choose Order Tests. The Order Tests dialog box opens. 

 3 Select a test from the list and click the up or down arrow to change the 
position of the test in the sequence.

 4 Click OK. 
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Finding Tests 

You can search for a test in the Execution Flow.

To find a test:

 1 Click the Find Test In Flow button on the toolbar, or choose Edit > Find Test 
in Flow. The Find Test dialog box opens.

In the Value to Find box, type the name (or part of the name) of the test. 
The search is not case sensitive.

 2 Click Find. The Test Lab module attempts to locate the test.

 3 If the search is successful, the Search Results dialog box opens and displays a 
list of possible matches. Select a result from the list, and click the Go To 
button to highlight the test in the Execution Flow. 

Click the Keep on Top button to display the Find Results dialog box on top 
of all open windows. 

To display a selected window on top of the Find Results dialog box, click the 
Not on Top button.

 4 If the search is unsuccessful, an information box opens. 

Viewing the Execution Flow Diagram

You can change the way the Execution Flow is displayed. This includes 
zooming in and out of the diagram, rearranging the tests in a hierarchical 
layout, refreshing the diagram, and displaying full test names in the 
diagram. You can also copy the diagram to the Clipboard.

Layout

Click the Arrange Layout button to rearrange the tests in a hierarchical 
layout. This enables you to view dependencies between different tests.

Zoom In

Click the Zoom In button to increase the magnification level of the diagram 
to make it appear larger.
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Zoom Out

Click the Zoom Out button to reduce the magnification level of the diagram 
to make it appear smaller.

Fit Picture In Window

Click the Fit Picture in Window button to redisplay the diagram to fit in the 
window. You can also click the down arrow to select a magnification option:

➤ Select a specific magnification level, such as 25%, 50%, 150% or 200%.

➤ Select Normal to display the diagram at 100% magnification.

➤ Select Fit In Window to display the entire diagram in the window.

➤ Select Custom Zoom to specify a zoom level. In the Custom Zoom dialog 
box, type a zoom level and click Zoom.

Refresh Flow

Click the Refresh Flow button to refresh the Execution Flow diagram so that 
it displays the most up-to-date tests.

Show Full Test Names

Choose Tests > Flow > Show Full Test Names to display full test names in the 
Execution Flow diagram. By default, long names are truncated.

Copy to Clipboard

Choose Tests > Flow > Copy to Clipboard to copy the Execution Flow 
diagram to the Clipboard as a bitmap.
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Running Tests Manually

When you run tests manually, you follow the test steps and perform 
operations on the application under test. You pass or fail each step, 
depending on whether the actual application results match the expected 
output. You can run both manual and automated tests manually.

This chapter includes:

 ➤  About Running Tests Manually on page 421

 ➤  Running a Test Manually on page 422

 ➤  Editing the Test Steps on page 428

 ➤  Resuming a Manual Test Run on page 429

About Running Tests Manually

You run tests manually by following the test steps you defined during test 
planning: 

 1 Perform operations on the application under test. Follow the instructions 
detailed in the test step descriptions.

 2 Compare the actual results with the expected results. When performing the 
steps, decide whether the application responds according to the expected 
results.

 3 Assign a pass or fail status to each step, depending on whether or not the 
expected results match the actual results. 
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 4 If a step fails, explain how the application actually responded. A test fails if 
one or more steps fail.

You can execute tests more than once in the same set. Each execution is 
considered a new test run. 

After test execution is complete, you can view a summary of test results in 
the Test Lab module. The updated status for each test run appears in the 
Execution Grid. Results for each test step appear in the Last Run Result pane. 
You can view more detailed results in the Test Instance Properties dialog 
box. For more information on viewing test results, see Chapter 32, “Viewing 
Test Results.”

Running a Test Manually 

When you run a test manually, you follow the test steps and perform 
operations on the application under test. You compare the expected results 
with the actual outcome and record the results. You can execute a test as 
many times as you want. Test results are stored separately for each run. You 
can run both manual and automated tests manually.

Note that while executing a test manually you can modify the test steps. You 
can choose to save the modifications in the original test in the Test Plan 
module and the test instance in the Test Lab module. Alternatively, you can 
save them for the current test run only. For more information, see “Editing 
the Test Steps” on page 428.

You can also resume a manual test run that was paused during execution. 
For more information, see “Resuming a Manual Test Run” on page 429.

Note: If you are running a business process test, refer to the HP Business 
Process Testing User Guide.
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To run a test manually:

 1 In the Execution Grid tab or Execution Flow tab, select the tests you want to 
run manually. 

➤ To run a single manual test, select the test and click the Run button.

➤ To run two or more manual tests, select the tests and click the Run 
button. The Manual Test Run dialog box opens.

By default, the Manual Runner (Run according to the order in the 
Execution Grid) option is selected. This option runs the tests according to 
the order displayed in the Execution Grid.

To run manual tests automatically, select Automatic Runner (Run 
according to the order in the Execution Flow). This option runs the tests 
according to the order displayed in the Execution Flow. For more 
information on running tests automatically, see “Running a Test 
Automatically” on page 432.

If you do not want the Manual Test Run dialog box to be displayed the 
next time you run manual tests, select Don’t show this again. To enable, 
choose Tests > Enable Manual Test Run Confirmation. 

Click OK. 

➤ To run automated tests manually, select the tests, click the Run arrow, 
and choose Run Manually. 
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The Manual Runner dialog box opens.

 2 Under Run Details, you can edit the following run information:

➤ Run Name. The name of the test run.

➤ Tester. The user name of the person who executed the test.

 3 Click the Operating System Info link to display operating system 
information. The Operating System Information dialog box opens.

You can edit the following operating system information:

➤ Operating System. The operating system on the machine where you 
perform your test steps. By default, the operating system on your 
Quality Center client machine is displayed.

➤ OS Service Pack. The operating system service pack.

➤ OS Build Number. The operating system build number.
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 4 Under Test Details, you can view details of the test. Click More to open the 
Test Properties dialog box and display test details and attachments. For more 
information on test properties, see Chapter 18, “Developing the Test Plan 
Tree.”

 5 To add attachments to the test run, click the Attach to Run button. An 
attachment can be a file, URL, snapshot of your application, an item from 
the Clipboard, or system information. For more information on 
attachments, see Chapter 5, “Adding Attachments.”

 6 To add a defect to the test run, click the New Defect button. The New Defect 
dialog box opens. Quality Center automatically creates a link between the 
test run and the new defect. For more information, see Chapter 35, “Adding 
and Tracking Defects”, and Chapter 36, “Linking Defects”.

 7 To end the run at this point, you can click the End Run button. 
Quality Center saves the test run. To cancel the run completely, click the 
Cancel Run button and click No to confirm.

 8 Click the Begin Run button to start the test run.

If the test you are running has parameters that have not been assigned 
actual values, the Parameters of Test Run dialog box opens. Assign actual 
values for the parameters. For more information, see “Assigning Actual 
Values” on page 322.
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The Manual Runner: Step Details dialog box opens.

In Filter by, you can filter the steps in the test according to the Status 
column.

Tip: You can conveniently read each test step and record the results using 
the compact view display of this dialog box. To open this display, click the 
Compact View button. To return to the steps grid, click the Back to Steps 
Grid button.

 9 If there are no test steps, or if you want to make changes to the steps, you 
can edit the test steps before you begin executing them. For more 
information, see “Editing the Test Steps” on page 428.

 10 To view the values of test parameters, click the Show Parameters button. 
The Parameter Values for Run dialog box opens.
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 11 Open the application being tested and execute the first step of the test.

➤ Click Pass Selected if the actual result is the same as the expected result. 
A green check is added to the step and the step status changes to Passed. 
(To pass all the test steps at once, click the Pass Selected arrow and 
choose Pass All.)

➤ If the actual result is different from the expected result, type the actual 
result in the Actual box and click the Fail Selected button. A red X is 
added to the step and the step status changes to Failed. (To fail all the test 
steps at once, click the Fail Selected arrow and choose Fail All.)

 12 Click Attachments to add attachments to the test step. To add attachments 
to the entire test run, click the Attachments arrow and choose Attach to 
Run. For more information on attachments, see Chapter 5, “Adding 
Attachments.”

 13 Click New Defect if you detect an application flaw while running the test. 
The New Defect dialog box opens, enabling you to add the defect. 
Quality Center automatically creates a link between the test run and the 
new defect. For more information, see “Adding New Defects” on page 479 
and “Linking Defects” on page 497.

 14 Click the Keep on Top button to display the Manual Runner: Step Details 
dialog box on top of all open windows. To display selected windows on top 
of the Manual Runner: Step Details dialog box, click the Not on Top button.

 15 Perform the remaining steps.

 16 Click the End Run button when you complete the test run, or to pause 
execution of the test run. To resume a manual test run that was paused 
during execution, see “Resuming a Manual Test Run” on page 429.
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Editing the Test Steps 

While executing a test in the Manual Runner: Step Details dialog box, you 
can add, delete, or modify test steps. After you finish executing the test, you 
can save your design steps with the changes you make. 

To edit a test step:

 1 Open the Manual Runner: Step Details dialog box. For more information, 
see “Running a Test Manually” on page 422.

 2 Click the Add Step button to add a step. A new step with a default step 
name is added. You can type details about the new step in the Description 
box.

 3 Click the Delete Selected button to delete a selected step or steps, and click 
Yes to confirm.

 4 Click the End Run button to close the dialog box. A message box opens. 

 5 Click Yes to save your changes and update your test in the Test Plan and Test 
Lab modules. Click No to save your changes in the current test run only.

Note that the Test Lab module enables you to update changes made to called 
tests in the current test run only. The called tests are not affected. For more 
information on called tests, see “Managing Design Steps” on page 309.
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Resuming a Manual Test Run 

If a manual test run was paused during execution, you can continue the run 
at a later stage. 

Note: The Continue Manual Run command continues the last run of the 
selected test. If you want to resume running a previous run, click the Test 
Instance Properties button, select All Runs on the sidebar and choose the 
test run you want to resume. Click the Continue button.

To resume a manual test run:

 1 In the Execution Grid tab or Execution Flow tab, select the test you want to 
resume running.

 2 Choose Tests > Continue Manual Run. Alternatively, click the Run arrow and 
choose Continue Manual Run. The Manual Runner dialog box opens for the 
selected test.

 3 Continue running the test.
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31
Running Tests Automatically

You can run tests automatically, directly from Quality Center. You can 
choose to run tests on your machine or on remote hosts.

This chapter includes:

 ➤  About Running Tests Automatically on page 431

 ➤  Running a Test Automatically on page 432

 ➤  Viewing the Execution Log on page 436

 ➤  Setting Up Hosts for Remote Test Execution on page 437

 ➤  Ordering Tests in the Execution Grid on page 439

 ➤  Finding and Replacing Values in the Execution Grid on page 441

About Running Tests Automatically

You can run tests automatically on your machine or on remote hosts. A host 
is any machine connected to your network on which a testing tool has 
already been installed.

You can select the tests you want to run from the Execution Grid tab or 
Execution Flow tab. Note that you can choose to run all of the tests in a test 
set, or specific tests, and that you can include both automated and manual 
tests. The selected tests are displayed in the Automatic Runner dialog box. 

When you run an automated test, Quality Center opens the selected testing 
tool automatically, runs the test on your local machine or on remote hosts, 
and exports the results to Quality Center. 
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When you run a manual test from the Automatic Runner dialog box, 
Quality Center notifies a designated tester by email to run the test on a 
specified host.

You can also run an automated system test to provide system information, 
capture a desktop image, or restart a machine. For more information on 
system tests, see Chapter 23, “Working with System Tests.”

Running a Test Automatically

When you run an automated test, Quality Center opens the selected testing 
tool automatically, runs the test, and exports the test results to 
Quality Center. When you run a manual test, email is sent to a designated 
tester, requesting that they run the manual test.

You can run an entire test set or specific tests including both automated and 
manual tests. Your selected tests are displayed in the Automatic Runner 
dialog box.

The following should be considered when running tests automatically:

➤ Before running a test on a remote host, you must first set up hosts in the 
Host Manager dialog box. For more information, see “Setting Up Hosts 
for Remote Test Execution” on page 437.

➤ To run the same test concurrently on multiple remote hosts, add multiple 
instances of the test to your test set. For more information, see “Adding 
Tests to a Test Set” on page 388.

➤ To run several test sets concurrently on multiple remote hosts, open a 
new Automatic Runner dialog box instance for each test set.

➤ To enable Quality Center to run QuickTest Professional or WinRunner 
tests on a remote host, open the relevant application on the remote host 
and select the required option. For more information, refer to the 
HP QuickTest Professional User Guide or the HP WinRunner User Guide.

➤ If you run a WinRunner test in batch mode, each test that is called from 
the batch test is considered a separate test, and not part of the batch test 
itself. Any test called from the batch test that is not already included in 
the test set is added to the test set at the end of the test run.
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QuickTest Professional users should consider the following:

➤ Before running a QuickTest test, Quality Center loads the QuickTest 
add-ins that are associated with the selected test. You must ensure that 
you run the test on a machine on which the required QuickTest add-ins 
are installed. For more information on working with add-ins and 
associated add-in lists in QuickTest, refer to the QuickTest Professional 
documentation and the relevant QuickTest add-in documentation.

➤ When you run QuickTest Professional tests from the Test Lab module, 
they are automatically run in Fast mode. They cannot be run in Normal 
mode.

To run tests automatically:

 1 Select a test set from the test sets tree or the test sets grid.

 2 You can set conditions and schedule the date and time for executing your 
tests. You can also set the order in which you want your tests to be executed. 
For more information, see Chapter 29, “Scheduling Test Runs.”

 3 You can run all the tests in a test set or select specific tests:

➤ To run a test set, in the Execution Grid tab or Execution Flow tab, click 
the Run Test Set button. Alternatively, choose Test Sets > Run Test Set.

➤ To run selected tests, in the Execution Grid tab or Execution Flow tab, 
select one or more tests and click the Run button. Alternatively, choose 
Tests > Run.
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The Automatic Runner dialog box opens and displays the tests.

 4 You can run your tests locally or remotely:

➤ To execute the tests locally, select the Run All Tests Locally check box.

➤ To execute the tests remotely, clear the Run All Tests Locally check box. 
For each test, you must select a host machine. Click the Run on Host grid 
box, and click the browse button. The Select Host dialog box opens. 
Under <Any Host>, you can select a host to run the test.

Alternatively, you can select a host group. Note that if you select a host 
group, Quality Center runs the test on the first available host in the 
group, not on every host in the group.

 5 To instruct Quality Center to create an execution log file during the test run, 
select the Enable Log check box. For more information, see “Viewing the 
Execution Log” on page 436.
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 6 Click Run to run the selected tests. Click Run All to run all the tests in the 
Automatic Runner dialog box. 

For an automated test, Quality Center opens the selected testing tool 
automatically and runs the test. Test execution commences only when the 
selected host becomes available to run tests.

For a manual test, Quality Center notifies a designated tester by email to run 
the test. This notification can be sent only if you have designated a tester for 
the test with a valid email address. To designate a tester, locate the test in the 
Execution Grid tab, place the mouse pointer in the Responsible Tester 
column, and click the arrow button. Select a name from the list.

The test execution progress is displayed in the Status column.

 7 If you need to terminate test execution before it has been completed, click 
Stop.

 8 If you selected Enable Log before you started the test run (see Step 5), you 
can view the Execution Log by choosing Run > View Execution Log. For 
more information, see “Viewing the Execution Log” on page 436.

 9 Choose Run > Exit to close the Automatic Runner dialog box.

 10 After the test run is complete, you can view a summary of test results in 
Quality Center. The updated status for each test run appears in the 
Execution Grid tab. Results for each test step appear in the Last Run Result 
pane. You can view more detailed results in the Test Instance Properties 
dialog box. For more information on test results, see Chapter 32, “Viewing 
Test Results.”
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Viewing the Execution Log 

The Execution Log contains details about the executed tests, such as the 
project name, user name, and test set name. For each test, the log includes 
the date and time of the run, the host, and a description of the run.

Note: You can only view the Execution Log if you selected Enable Log in the 
Automatic Runner dialog box before you executed the test. For more 
information, see Step 5 on page 434.

To view the Execution Log:

 1 After the test run is complete, choose Run > View Execution Log in the 
Automatic Runner dialog box. The Execution Log dialog box opens.
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 2 To filter the execution log:

➤ In the Test list box, select a test and click the Refresh button. 

➤ In the Host list box, select a host and click the Refresh button. 

 3 Choose Log > Open to display another execution log file.

 4 Choose Log > Delete to delete the execution log. Click Yes to confirm.

 5 Choose Log > Exit to close the Execution Log.

Setting Up Hosts for Remote Test Execution 

You can run tests on any host connected to your network. Using the Host 
Manager dialog box, you can create a list of available hosts for test 
execution. You can also organize hosts into groups to be used for a specific 
project.

Note: If you specify a host group for remote test execution, Quality Center 
runs the test on the first available host, not every host in the host group.
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To set up hosts for remote test execution:

 1 Choose Test Sets > Host Manager. The Host Manager dialog box opens.

If no hosts are displayed in the Available Hosts list, click the Get Hosts on 
the Network button. Quality Center scans the Network Neighborhood 
directory and inserts each host found into the Available Hosts list.

To synchronize the hosts in the Available Hosts list with the hosts in the 
Network Neighborhood directory, click the Get Hosts on the Network arrow 
and choose Synchronize Hosts in the Project with Hosts on Net. 
Quality Center adds hosts found in the Network Neighborhood directory 
and deletes hosts that were not found in the Network Neighborhood 
directory.

 2 To add a host to the Available Hosts list, click the New Host button. The 
New Host dialog box opens. In the Host Name box, type the name of the 
host machine. In the Description box, type a description of the host. Click 
OK. 
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 3 To delete a host from the Available Hosts list, select the host and click the 
Delete Host button. Click Yes to confirm.

 4 To create a host group, click the New Host Group button. The New Host 
Group dialog box opens. In the Group Name box, type a name for the host 
group. In the Description box, type a description of the host group. Click 
OK.

 5 To add a host to a host group, select a group from the Host Group list. Select 
a host from the Available Hosts list, and click the Add Host To Host Group 
button. Alternatively, double-click a group.

 6 To remove a host from a host group, select a group from the Host Group list. 
Select a host from the Hosts in Group list. Click the Remove Host From Host 
Group button.

 7 To delete a host group, select the group from the Host Group list. Click the 
Delete Host Group button. Click Yes to confirm.

 8 Click Close to close the Host Manager dialog box.

Ordering Tests in the Execution Grid 

You can change the order of the tests in the Execution Grid. Quality Center 
runs the tests according to the specified order, grouped by host type. For 
example, if you have your tests ordered as test1, test2, and test3, 
Quality Center runs test1 and test3 first if they are set to run on the same 
host, followed by test2 on a different host.

Note: When determining the order for running tests, Quality Center first 
checks the Execution Flow. The order you define in the Execution Grid is 
only used if there are no conditions set in the Execution Flow. For more 
information on scheduling tests in the Execution Flow, see Chapter 29, 
“Scheduling Test Runs.”
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To order tests in the Execution Grid:

 1 Choose Tests > Order Tests. The Order Tests dialog box opens. 

 2 Select a test from the list, and click the up or down arrow to change the 
position of the test in the sequence. 

Tip: You can also drag the tests up or down.

 3 Click OK.
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Finding and Replacing Values in the Execution Grid 

You can search and replace field values in the Execution Grid.

To find a value:

 1 Choose Tests > Find. The Find dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value.

 3 In the Value to Find box, type or select the value to find.

 4 You can select Exact Match to search for an exact value.

 5 You can select Case Sensitive to distinguish between uppercase and 
lowercase characters.

 6 You can select Use Wildcard to use asterisk (*) characters in your search 
string in order to type only part of the item.

 7 Click Find Next. Quality Center attempts to locate any tests with the 
specified value. If the search is successful, the test is highlighted in the 
Execution Grid. If the search is unsuccessful, an information box opens.
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To replace a value:

 1 Choose Tests > Replace. The Find/Replace dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value.

 3 In the Value to Find box, type or select the value to find.

 4 In the Replace with box, type or select a replacement field value.

 5 You can select Case Sensitive to distinguish between uppercase and 
lowercase characters.

 6 You can select Exact Match to search for an exact value.

 7 You can select From Beginning to start the search from the top of the 
Execution Grid.

 8 You can select Use Wildcard to use asterisk (*) characters in your search 
string in order to type only part of the item.

 9 To replace:

➤ Click Replace to replace the found item and find the next occurrence.

➤ Click Replace All to replace all occurrences in the Execution Grid.
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32
Viewing Test Results

After running test instances, you analyze the test results to determine which 
test instances failed, and which steps caused the failure.

This chapter includes:

 ➤  About Viewing Test Results on page 444

 ➤  Viewing Test Results on page 445

 ➤  Viewing Details of a Test Run on page 447

 ➤  Comparing Results of All Runs on page 449

 ➤  Viewing Configuration of a Test Run on page 452

 ➤  Viewing Linked Defects on page 457

 ➤  Viewing Test Run History on page 458
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About Viewing Test Results

After running test instances, you can view the results in Quality Center. Test 
results consist of the overall pass/fail status of a test instance and the 
pass/fail status of each step in a test instance. These results help you 
determine whether a defect was detected in your application. In some cases, 
you may decide that a step failed because the expected results are no longer 
valid and need to be updated. 

Following the execution of manual and automated tests, you can view 
results and general test information in the Execution Grid. Use the Test 
Instance Properties dialog box to view test run details, compare the results of 
the most recent test run with previous runs, manage attachments, view test 
run configuration information, view linked defects, and view a history of 
test run changes.

Note: For information on viewing system test results, see Chapter 23, 
“Working with System Tests.”

In addition, you can analyze the progress of a test set by periodically 
generating execution reports and graphs. For further information, see 
Chapter 42, “Generating Standard Reports,” Chapter 41, “Generating 
Graphs,” and Chapter 44, “Generating Live Analysis Graphs.”
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Viewing Test Results

You can view the test results from the Test Instance Properties dialog box.

To view the test results:

 1 In the Execution Grid, double-click a test, or select a test instance and click 
the Test Instance Properties button. The Test Instance Properties dialog box 
opens. By default, the All Runs view is displayed.

In the Execution Flow, right-click a test instance and choose Test Instance 
Properties. The Test Instance Properties dialog box opens. By default, the 
Details view is displayed.
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 2 Click a view on the sidebar. The Test Instance Properties dialog box contains 
the following views:

 3 You can click the First Test button to display the first test instance, or the 
Previous Test button to display the preceding test instance in the current 
Execution Grid.

View Description

Details Displays run details of a test instance. For more 
information, see “Viewing Details of a Test Run” on 
page 447.

All Runs Display the results of all test runs. For more information, 
see “Comparing Results of All Runs” on page 449.

Attachments Displays any attachments to a test instance. Also includes 
any attachments that were added to the test during test 
planning. For more information, see Chapter 5, “Adding 
Attachments.”

Configuration Displays run configuration information for a test instance. 
For more information, see “Viewing Configuration of a 
Test Run” on page 452. 

Linked Defects Displays linked defects and requirements coverage for a 
test instance. For more information, see “Viewing Linked 
Defects” on page 457.

Note: If coverage between test instances and requirements 
is enabled with the ALLOW_REQ_COVERAGE_BY_
TEST_INSTANCE parameter, the Linkage and Coverage 
view is available instead of the Linked Defects view. The 
Linkage and Coverage view displays linked defects and 
requirements coverage for a test instance. For more 
information on this parameter, see the HP Quality Center 
Administrator Guide. For more information on 
requirements coverage, see “Linking Requirements to a 
Test” on page 290.

History Displays the history of changes to the test instance. For 
more information, see “Viewing Test Run History” on 
page 458.
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 4 You can click the Next Test button to display the next test instance, or the 
Last Test button to display the final test instance in the current Execution 
Grid.

 5 You can click the Flag for Follow Up button to add or modify a follow up 
flag for the test instance. For more information, see Chapter 4, “Alerting on 
Changes.”

 6 If the test instance has an alert, you can click the Alerts button to open the 
Alerts dialog box. For more information, see “Viewing Alerts” on page 80.

Viewing Details of a Test Run 

You can view run details of a test instance in the Details view. 

To view details of a test run:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 445.
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 2 In the Test Instance Properties dialog box, click Details on the sidebar. 

 3 In the Details view, you can verify the following test information:

Option Description

Description The description of the test.

Exec Date The date on which the test was last executed.

Planned Exec Time The time at which the test was planned to be executed.

Responsible Tester The user name of the user who last executed the test.

Planned Exec Date The date on which the test was planned to be executed.
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If you edit the test information, the changes you make are reflected in the 
Execution Grid.

Note: You can change the label of any of the fields in the Details tab. You 
can also add user-defined fields to the Details view. For more information, 
refer to the HP Quality Center Administrator Guide.

Comparing Results of All Runs 

Quality Center enables you to compare the results of a test run with the 
results of previous runs. Using the All Runs view, you can view run details 
and step results for all the runs of a selected test instance.

To view results of all runs for a test:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 445.

Planned Host Name The name or IP address of the machine on which the test 
was planned to run.

Status The current status of the test. A test status can be one of 
the following:

Failed. The test run failed.

N/A. The current status of the test is not applicable.

No Run. The test has not been run.

Not Completed. The test run was not completed. 

Passed. The test run was successful.

Tester The user name of the user that is actually executing the 
test.

Time The time at which the test was last executed.

Option Description
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 2 In the Test Instance Properties dialog box, click All Runs on the sidebar. 

 3 To view run records with a certain status, choose a status from the View 
Runs list.

 4 To filter, sort, or group the run records, click the Set Filter/Sort button. For 
more information on filtering, sorting, and grouping records, see Chapter 3, 
“Working with Quality Center Data.” If you set a filter, the description is 
displayed above the grid.

 5 To clear any filters or sorting that you have applied to the run records, click 
the Set Filter/Sort arrow and choose Clear Filter/Sort.

 6 To refresh the grid so that it displays the most up-to-date runs based on the 
filters you have selected, click the Refresh button.
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 7 To set column appearance and order in the grid, click the Select Columns 
button. For more information on the Select Columns dialog box, see 
“Arranging Columns” on page 52.

 8 To remove a run from the grid, select a run and click Delete Selected. Click 
Yes to confirm.

 9 To view the test steps of a run, select a run and click Show Run Steps. The 
Run Steps dialog box opens and displays details of the test steps, their 
description, expected results, and actual results. For more information on 
test steps, see Chapter 20, “Building Tests.”

 10 To add an attachment to a test run, select a run and click the Attachments 
button. The Attachments dialog box opens. For more information on 
attachments, see Chapter 5, “Adding Attachments.”

 11 To add defect links to a run, select a run and click Linked Defects. The 
Linked Defects dialog box opens. For more information on linked defects, 
see Chapter 36, “Linking Defects.”

 12 To continue running a previous run, select a run and click Continue.

 13 For automated test instances, you can click one of the following buttons or 
links:

Button/Link Test Type Description

LR-SCENARIO Opens and displays the results in 
LoadRunner Analysis.

QUICKTEST_TEST Opens and displays the report in 
QuickTest Professional. 

Note that the Launch Report button is 
only enabled if you have installed the 
QuickTest Professional Add-in from the 
HP Quality Center Add-ins page. For 
more information on installing add-ins, 
refer to the HP Quality Center Installation 
Guide.
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Viewing Configuration of a Test Run

You can view or set the test parameter values for a manual test instance or 
an automated test instance in the Configuration view. You can also view and 
edit the On Failure rules for an automated test instance. 

This section includes:

➤ Setting Parameter Values for Manual Test Instances

➤ Setting Automated Test Parameters

➤ Viewing Test Run Events

Setting Parameter Values for Manual Test Instances
You can set actual parameter values for manual test instances. Actual values 
that you assign for parameters in the test instance are used for all test runs of 
the test instance.

To set parameter values for a manual test instance:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 445.

Collected System 
Info

Captured 
Desktop Image

SYSTEM-TEST The Collected System Info link opens 
the System Information dialog box.

The Captured Desktop Image link 
opens the captured image. 

For more information on viewing 
system tests, see “Viewing System Test 
Results” on page 336.

WR-AUTOMATED 
or WR-BATCH

Opens and displays the report in 
WinRunner.

Button/Link Test Type Description
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 2 In the Test Instance Properties dialog box, click Configuration on the 
sidebar. The Manual Parameters tab opens. The tab shows all the test 
parameters that are used in the test steps, including parameters of called 
tests that have not already been assigned actual values.

 3 In the Actual Value column, type the value that will be used for the 
parameter during the test run. After you start typing, a text box opens. Click 
OK to save the value.

 4 To use a parameter’s default value as its actual value, select a parameter, and 
click the Take Default Values button. The current Actual Value is replaced by 
the Default Value.
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Setting Automated Test Parameters
You can set parameter values and other configuration options for an 
automated test instance from the Configuration view. 

To set automated test parameters and other configuration options:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 445.

 2 In the Test Instance Properties dialog box, click Configuration on the sidebar 
and click the Automated tab. 

 3 In the Parameter Value column, you can view and edit the value of each 
parameter. Note that if you change a parameter value, the change is 
implemented in the next test run. 
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Note: When defining the WinRunnerCommandLine parameter, you must 
specify the path within quotes. For example:

-ini “C:\program files\wrun.ini”

 4 You may be able to set additional configuration options, depending on the 
type of automated test you are running. For more information, refer to the 
user guide for your automated test.

Viewing Test Run Events
You can view and edit the On Failure rules for an automated test instance 
using the Run Events view. These rules instruct Quality Center in the event 
that the test instance fails. This includes the number of times the test 
instance should be rerun and the cleanup test that should be run before the 
test instance is rerun. 

Notes: 

➤ If you change the failure rules in the Run Events view, your changes are 
implemented in the next test run.

➤ You can also set On Failure rules for a test by choosing Test Sets > 
Automation > On Failure and clicking the Settings per Test button. For 
more information, see “Setting Test Set On Failure Rules” on page 392.
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To view test run events:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 445.

 2 In the Test Instance Properties dialog box, click Configuration on the 
sidebar, and click the Run Events tab. 

 3 To set the test On Failure rule, select the first check box and specify the 
number of times the test instance should be rerun. 

 4 To include a cleanup test, select the Run cleanup test check box and click 
the browse button. In the Select Clean Up Test dialog box, select the test 
from the test plan tree and click the Add Test icon.
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Viewing Linked Defects

You can view and manage defect links made to other Quality Center 
entities.

To view linked defects:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 445.

 2 In the Test Instance Properties dialog box, click Linked Defects on the 
sidebar.
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Note: If coverage between test instances and requirements is enabled with 
the ALLOW_REQ_COVERAGE_BY_TEST_INSTANCE parameter, click Linkage 
and Coverage on the sidebar. For more information on this parameter, see 
the HP Quality Center Administrator Guide.

 3 In the Linked Defects tab, you can view, add, and remove defect links. For 
more information, see Chapter 36, “Linking Defects.”

Viewing Test Run History

You can view a list of changes made to the test instance in the History view.

To view the history of changes to a test run:

 1 Open the Test Instance Properties dialog box. For more information, see 
“Viewing Test Results” on page 445.
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 2 In the Test Instance Properties dialog box, click History on the sidebar. 

For each change to the test instance, the grid displays the date and time of 
the change and the name of the user who made the change.

 3 Expand a change to view a list of fields modified during the change. For 
each field, the grid displays the old value and the new value. To expand all 
changes, click the Expand All button.

 4 You can specify which changes are displayed in the grid. In the Field list, 
select a field name to view only changes made to that field. Select <All> to 
view changes made to all fields.

For information on preserving the history of changes made to a field, refer 
to the HP Quality Center Administrator Guide.
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33
The Defect Tracking Workflow

Locating and repairing application defects efficiently is essential to the 
development process. Defects can be detected and added to your 
Quality Center project by users during all stages of the application 
management process. Using the Quality Center Defects module, you can 
report design flaws in your application, and track data derived from defect 
records.

Quality Center Starter Edition: Fields related to release management are not 
available in the Defects module if you are working with the Starter Edition. 
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This chapter describes how you track defects. The defects tracking workflow 
consists of the following: 

Adding Defects

When you discover a defect in your application, you submit a defect to the 
Quality Center project. The project stores defect information that can be 
accessed by authorized users, such as members of the development, quality 
assurance, and support teams. You can associate this new defect with the 
cycle and release in which it was detected.

Suppose you are testing the Mercury Tours application. You just ran the 
Cycle 1 test set under the Release 10.5 test set folder and one of the test runs 
revealed a defect when entering expiration dates for credit card numbers. 
When the defect is initially submitted to the project, the Detected in 
Release field is assigned to the Release 10.5 release, and the Detected in 
Cycle field is assigned to the Cycle 1 - New Features cycle. For more 
information on releases and cycles, see Chapter 8, “The Release 
Management Workflow.”

Define Testing 
Scope

Create
Requirements

Create
Requirements

Detail 
Requirements

Detail 
Requirements

Analyze 
Requirements

Analyze 
Requirements

Add
Defects

Review
New Defects

Repair
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You can link this new defect with the test you ran, for future reference. You 
can also link defects to other Quality Center entities, such as requirements, 
tests and other defects. For more information, see Chapter 36, “Linking 
Defects.”

You can also view, update, and analyze defects in the project. For more 
information, see Chapter 35, “Adding and Tracking Defects”.

Reviewing New Defects

Review all new defects in the project and decide which ones to fix. This task 
is usually performed by the project manager. Change the status of a new 
defect to Open, and assign it to a member of the development team. 

In the Target Release field, assign the open defect to the release that is 
targeted to be fixed. In the Target Cycle field, assign the defect to the cycle 
that is targeted to be closed. For example, suppose the defect detected when 
entering expiration dates for credit card numbers is planned to be fixed in 
the next cycle. Assign the Target Release field to Release 10.5, and the 
Target Cycle field to Cycle 2 - New Features + Regression. 

While reviewing new defects, if duplicate defects appear in the project, 
change their status to either Closed or Rejected, or delete them from the 
project.
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Repairing Open Defects

Fix the Open defects. This involves identifying the cause of the defects, and 
modifying and rebuilding the application. These tasks are performed by 
application developers. When a defect is repaired, assign it the status Fixed. 
For example, suppose the defect detected when entering expiration dates for 
credit card numbers was repaired in a new application build. You would 
update the defect status from Open to Fixed.

Testing a New Application Build

Run tests on the new build of the application. If a defect does not recur, 
assign it the status Closed. If a defect is detected again, assign it the status 
Reopen, and return to the previous stage (see “Repairing Open Defects” on 
page 466). This task is usually performed by the quality assurance manager 
or project manager. For information on running tests, see Chapter 30, 
“Running Tests Manually” and Chapter 31, “Running Tests Automatically.”

Analyzing Defect Data

View data from defect reports to see how many defects were resolved, and 
how many still remain open. As you work, you can save settings that are 
helpful in the defect-tracking process, and reload them as needed. For more 
information, see Chapter 6, “Working with Favorite Views.”

Reports and graphs enable you to analyze the progress of defect repairs, and 
view how long defects have been residing in a project. This helps you 
determine when the application can be released. For more information, see 
Chapter 40, “The Dashboard Module.”
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34
The Defects Module at a Glance

This chapter introduces the key elements in the Defects module.

This chapter includes:

 ➤  The Defects Module on page 468

 ➤  The Defects Menu Bar on page 471

 ➤  The Defects Toolbar on page 472

 ➤  The Defects Grid on page 474
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The Defects Module 

You track defects in the Quality Center Defects module, which you open by 
clicking the Defects button on the sidebar. 

The Defects module contains the following key elements:

➤ Defects menu bar. Displays drop-down menus of Defects module 
commands. For more information, see “The Defects Menu Bar” on page 471.

➤ Defects toolbar. Contains buttons for commands commonly used when 
adding, managing, and tracking defects. For more information, see “The 
Defects Toolbar” on page 472.
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➤ Indicator Columns. Indicates that the specified defect has attachments, 
linked entities, alerts, and follow up flags. Choose View > Indicator Columns 
to display these columns.

➤ Grid Filters. Displays the filter that is currently applied to a column. Choose 
View > Grid Filters to display the grid filter boxes.

➤ Defects Grid. Displays defect data in a grid. For more information, see “The 
Defects Grid” on page 474.

Column Description

Attachments Click the  icon to view attachments for the defect. 
For more information, see Chapter 5, “Adding 
Attachments.”

Linked Entities Click the  icon to view linked entities for the 
defect. For more information, see Chapter 36, 
“Linking Defects.”

Alerts Click the  icon to view alerts for the defect. For 
more information, see “Viewing Alerts” on page 80.

Follow Up Flags Click the  icon to view follow up alerts for the 
defect. For more information, see “Flagging for 
Follow Up” on page 82.
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➤ Information Panel. Displays the following tabs: Description, Attachments, 
and History. Choose View > Information Panel > Show or click the Show 
arrow  to display these tabs.
 

Tip: To find a specific defect by Defect ID in the Defects Grid, choose Defects 
> Go To Defect. 

Tab Description

Description Displays the description for the currently selected 
defect. You can also display the following options:

➤ Summary. Choose View > Information Panel > 
Summary to display a defect’s summary. 

➤ Comments. Choose View > Information Panel > 
Comments to view and add comments for a 
defect.

For more information, see “Updating Defects” on 
page 485.

Attachments Displays the attachments for the selected defect. For 
more information, see Chapter 5, “Adding 
Attachments.”

History Displays a defect’s history. For more information, 
see “Viewing Defect History” on page 489.
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The Defects Menu Bar 

The Defects menu bar has the following menus:

➤ The Defects menu contains commands that enable you to add, go to, mail, 
print, and export defects, as well as view defect details.

➤ The Edit menu contains commands that enable you to copy, paste, or delete 
defects, find and replace field values, search defects, update selected defects, 
and find similar defects or text. You can also view and clear alerts for defects 
and flag defects for follow-ups. For more information on alerts and follow-
ups, see Chapter 4, “Alerting on Changes.”

➤ The View menu contains commands that enable you to set the display in 
the Defects Grid. 

➤ The Favorites menu contains commands that enable you to view a selected 
item in the Favorites list, add a Defects Grid view to your Favorites list, and 
organize the Favorites list. For more information on favorite views, see 
Chapter 6, “Working with Favorite Views.”

➤ The Analysis menu contains commands that enable you to generate defect 
reports and graphs. For more information on defect reports, see Chapter 42, 
“Generating Standard Reports.” For more information on defect graphs, see 
Chapter 41, “Generating Graphs.”

Tip: You can access the Defects menu bar from the Defects module by 
pressing the shortcut key F9. Additionally, you can perform many other 
Quality Center operations using shortcut keys. For a list of shortcut keys, see 
Appendix B, “Quality Center Keyboard Shortcuts.”
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The Defects Toolbar 

The Defects toolbar has the following buttons:

New Defect. Opens the New Defect dialog box, enabling you to add a new 
defect to the Defects Grid. For more information, see “Adding New Defects” 
on page 479.

Delete. Deletes the selected defects from the Defects Grid. For more 
information, see “Deleting Defects” on page 495.

Refresh All. Refreshes the Defects Grid so that it displays the most up-to-date 
defects based on the filters you have selected. 

Set Filter/Sort. Includes the following options:

➤ Set Filter/Sort. Opens the Filter dialog box, enabling you to filter, sort, 
and group the defects in the Defects Grid.

➤ Clear Filter/Sort. Clears any filters, sorting, or grouping that you have 
applied to the Defects Grid. 

For more information on filtering and sorting defects, see Chapter 3, 
“Working with Quality Center Data.”

Select Columns. Opens the Select Columns dialog box, enabling you to 
define which columns appear in the Defects Grid, and the order in which 
they appear. For more information, see “Arranging Columns” on page 52.

Defect Details. Opens the Defect Details dialog box to display the details of 
the selected defect. For more information, see “Updating Defects” on 
page 485.

Attachments. Opens the Defect Details dialog box, enabling you to add an 
attachment to a defect. For more information, see Chapter 5, “Adding 
Attachments.”

Flag for Follow Up. Opens the Flag For Follow Up dialog box, enabling you 
to add or modify a follow up flag for a defect. For more information, see 
“Flagging for Follow Up” on page 82.
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Send by E-mail. Opens the Send E-mail dialog box, enabling you to send 
defect email to recipients selected from a list, or to any other email address. 
For more information, see “Mailing Defects” on page 490.

Find Similar Defects. Includes the following options:

➤ Find Similar Defects. Conducts a search for similar defects and, if any are 
found, displays them in the Similar Defects dialog box. 

➤ Find Similar Text. Opens the Find Similar Text dialog box, enabling you 
to search for similar defects by specifying a text string and, if any are 
found, displays them in the Similar Defects dialog box.

For more information on finding similar defects, see “Matching Defects” on 
page 481.

Text Search. Opens the text search pane in the lower part of the window, 
enabling you to type keywords and search predefined fields. For more 
information, see “Searching Records” on page 72.

Favorite. Click the Favorite arrow to display a list of favorite views. Favorite 
views enable you to reload a Quality Center window with the settings you 
apply to it. If you do not see the Favorite bar, choose View > Favorite Bar to 
display it. For more information on favorite views, see Chapter 6, “Working 
with Favorite Views.”
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The Defects Grid

Quality Center organizes and displays defect data in a grid. Each line in the 
Defects Grid displays a separate defect record. The Defects Grid can display 
the following columns:

Column Description

Actual Fix Time Indicates the actual number of days needed to fix the 
defect. If this field is left blank, Quality Center 
automatically calculates the Actual Fix Time as Closing 
Date - Detected on Date.

Assigned To The user name of the person who is assigned to fix the 
defect. Click the down arrow to display a list displaying 
the name and full name of each user. 

Closed in Version Indicates the application version in which the defect was 
closed. Click the down arrow to display a list of versions.

Closing Date Indicates the date on which the defect was closed. Click 
the down arrow to display a calendar and select a closing 
date.

Comments Displays comments about the defect.

Defect ID A unique numeric ID for the defect, assigned 
automatically by Quality Center. The Defect ID is read-
only.

Description Describes the defect in detail.

Detected By The user name of the person who found the defect. By 
default, Quality Center inserts the login user name into 
this field.

Detected in Cycle Indicates the cycle in which the defect was detected. Click 
the down arrow to select a different cycle. 

Note that when assigning a defect to a cycle in the 
Detected in Cycle field, Quality Center automatically 
assigns its release to the Detected in Release field.

Detected in Release Indicates the release in which the defect was detected. 
Click the down arrow to select a different release.
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Detected in Version Indicates the application version in which the defect was 
detected. Click the down arrow to display a list of 
versions.

Detected on Date The date on which the defect was detected. By default, the 
current database server date is displayed. Click the down 
arrow to select a different detection date.

Estimated Fix Time Indicates the estimated number of days required for fixing 
the defect.

Modified Indicates the date and time when this defect was last 
changed.

Planned Closing 
Version

Indicates in which version the defect is planned to be 
fixed. Click the down arrow to display a list of versions.

Priority The priority of the defect, ranging from low priority 
(level 1) to urgent priority (level 5).

Project The name of the project where the defect occurs. Click the 
down arrow to display a list of projects.

Reproducible Indicates whether the defect can be recreated under the 
same conditions by which it was detected. Click the down 
arrows to choose Y or N.

Severity The severity of the defect, ranging from low (level 1) to 
urgent (level 5).

Status The current status of the defect. By default, the status is 
New. Defect status can be one of the following: Closed, 
Fixed, New, Open, Rejected, Reopen. 

Subject Indicates the subject folder. Click the down arrow to 
display a list of subjects.

Summary A brief summary of the defect.

Column Description
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Notes: 

➤ You can add user-defined fields and change the label of any of the fields 
in the Defects Grid. You can also customize project lists. For more 
information, refer to the HP Quality Center Administrator Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Defects Grid. For more information, refer to the 
HP Quality Center Administrator Guide.

➤ When you select a defects column with a user name value, 
Quality Center displays a list with the name and full name of each user. 
You can search for users, sort users, group users by user group, and select 
users from the users list or a group tree. For more information, see 
“Selecting Users” on page 55.

➤ Quality Center Starter Edition: Fields related to release management are 
not available in the Defects module if you are working with the Starter 
Edition. 

Target Cycle Indicates in which cycle the defect is targeted to be fixed. 
Click the down arrow to select a different cycle.

Note that when assigning a defect to a cycle in the Target 
Cycle field, Quality Center automatically assigns its 
release to the Target Release field.

Target Release Indicates in which release the defect is targeted to be 
closed. Click the down arrow to select a different release.

Column Description
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35
Adding and Tracking Defects

You use the Defects module to add application defects directly to a 
Quality Center project. You can then track defects until the application 
developers and application testers determine that they are resolved.

This chapter includes:

 ➤  About Adding and Tracking Defects on page 478

 ➤  Adding New Defects on page 479

 ➤  Matching Defects on page 481

 ➤  Updating Defects on page 485

 ➤  Finding and Replacing Values on page 487

 ➤  Updating Multiple Records on page 489

 ➤  Viewing Defect History on page 489

 ➤  Mailing Defects on page 490

 ➤  Copying Defects on page 493

 ➤  Copying URLs of Defects on page 494

 ➤  Printing Defects on page 494

 ➤  Deleting Defects on page 495
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About Adding and Tracking Defects

Defect records inform members of the application development and quality 
assurance teams of new defects discovered by other members. By sharing 
defect information, both the application development and defect repair 
processes are faster, more efficient, and more comprehensive. As you 
monitor the progress of defect repair, you update the information in your 
Quality Center project.

Suppose you detect a defect in the Mercury Tours application. When you 
initially report the defect in Quality Center, by default it is assigned the 
status New. A quality assurance manager or project manager reviews the 
defect, determines a repair priority, changes its status to Open, and assigns it 
to a member of the development team. A developer repairs the defect and 
assigns it the status Fixed. You retest the application, making sure that the 
defect does not recur. The quality assurance manager or project manager 
determines that the defect is actually repaired and assigns it the status 
Closed.

Notes: 

➤ You can link defects to other Quality Center entities, such as 
requirements, tests and other defects. For more information, see 
Chapter 36, “Linking Defects.”

➤ You can use the Workflow Script Editor to restrict and dynamically 
change the fields and values in the Defects module. You can also 
customize the fields for a specific user group. For more information, refer 
to the HP Quality Center Administrator Guide.

➤ Quality Center Premier Edition: You can share defects across multiple 
Quality Center projects. You share and synchronize defects using the 
HP Quality Center Synchronizer. For more information, see the 
HP Quality Center Sychronizer User Guide, available from the Quality 
Center Adds-ins Page.
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Adding New Defects 

You can add a new defect to a Quality Center project from any module at 
any stage of the application management process.

Note: In addition to adding defects directly in Quality Center, you can also 
import defect data from Microsoft Excel to your Quality Center project. To 
import from Excel, you must install the Microsoft Excel Add-in and the 
HP Quality Center Connectivity Add-in. You can install these add-ins from 
the HP Quality Center Add-ins page. For more information, refer to the 
HP Quality Center Installation Guide.

To add a new defect:

 1 To add a new defect from any module, click the Tools button on the 
upper-left corner. Select New Defect.

To add a new defect from the Defects module, click the New Defect button. 
The New Defect dialog box opens.
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 2 Enter the relevant defect details. Note that a required field is displayed in red 
and that Quality Center fills in some fields by default. For more information 
on available fields in the New Defect dialog box, see Chapter 34, “The 
Defects Module at a Glance.”

 3 To clear the data in the New Defect dialog box, click the Clear button.

 4 You can add an attachment to your defect:

➤ Click the Attach File button to attach a file.

➤ Click the Attach URL button to attach a URL.

➤ Click the Attach Snapshot button to capture and attach an image.

➤ Click the Attach SysInfo button to attach information about your 
machine.

➤ Click the Attach Clipboard Content button to attach an item from the 
Clipboard.

For more information about adding attachments, see Chapter 5, “Adding 
Attachments.”

 5 To eliminate duplicate or similar defects, you can:

➤ Click the Find Similar Defects button to conduct a search for similar 
defects based on keywords from the Summary and Description fields.

➤ Click the Find Similar Defects arrow and choose Find Similar Text to 
search for similar defects by specifying a text string.

For more information, see “Matching Defects” on page 481.

 6 You can check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word 
which is misspelled together with replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way Quality Center checks spelling. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.
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 7 Click the Submit button to add the defect to the project. Quality Center 
assigns a Defect ID to the new defect.

 8 Click Close.

Matching Defects 

Matching defects enables you to eliminate duplicate or similar defects in 
your project. Each time you add a new defect, Quality Center stores lists of 
keywords from the Summary and Description fields. When you search for 
similar defects, keywords in these fields are matched against other defects.

Note that keywords are more than two characters, and letter case does not 
affect your results. The following are ignored: articles (a, an, the); coordinate 
conjunctions (and, but, for, nor, or); boolean operators (and, or, not, if, then); 
and wildcards (?, *, [ ]). 

There are two methods you can use to conduct a search for similar defects:

➤ Find Similar Defects. Compares a selected defect with all other existing 
defects in your project. You can conduct a search for similar defects in the 
Defects Grid, or before submitting a new defect in the New Defect dialog 
box. See “Finding Similar Defects” on page 482.

➤ Find Similar Text. Compares a specific text string against all other existing 
defects in your project. You can conduct a search for similar defects in the 
Defects Grid, or before submitting a new defect in the New Defect dialog 
box. You can limit your results by specifying a percentage of detected 
similarity. See “Finding Similar Text” on page 483.

Tip: If is available, Text Search is a more powerful search tool that enables 
you to search for keywords and variations of keywords. For information on 
using the text search, see “Searching Records” on page 72.
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Finding Similar Defects
You can match defects by comparing a selected defect with all other existing 
defects in your project. When similar defects are found, they are displayed 
according to the percentage of detected similarity. 

To find similar defects:

 1 In the Defects Grid, select a defect and click the Find Similar Defects button. 
Alternatively, in the New Defect dialog box, before you submit a defect, click 
the Find Similar Defects button.

Results are displayed in the Similar Defects dialog box, ordered by 
percentage of detected similarity, as listed in the Similar column. If no 
similar defects are found, a message is displayed.
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 2 To see more details for a defect in the Similar Defects dialog box, 
double-click the defect.

 3 Click Close to close the Similar Defects dialog box.

Finding Similar Text
You can match defects by comparing a specific text string with all other 
existing defects in your project. You can limit the results of defects found to 
those that meet a specific similarity percentage. For example, suppose that 
you are searching for defects with the word Help. If you limit your results to 
25 percent, the search returns the following results:

If you limit your results to 100 percent, the search returns the following 
result:

To find similar text:

 1 In the Defects Grid, click the Find Similar Defects arrow and choose Find 
Similar Text. Alternatively, in the New Defect dialog box, before you submit 
a defect, click the Find Similar Defects arrow and choose Find Similar Text.

The Find Similar Text dialog box opens. 
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 2 To limit the results of defects found to those with a minimum similarity, 
type a percentage in the Percent of Similarity box. By default, Quality Center 
returns defects with a similarity of at least 25 percent.

 3 In the Text to Find box, type the text string. 

 4 Click OK. Results are displayed in the Similar Defects dialog box, ordered by 
percentage of detected similarity, as listed in the Similar column. If no 
similar defects are found, a message is displayed.

 5 To see more details for a defect in the Similar Defects dialog box, 
double-click the defect.

 6 Click Close to close the Similar Defects dialog box.
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Updating Defects

Tracking the repair of defects in a project requires that you periodically 
update defects. You can do so directly in the Defects Grid, or in the Defect 
Details dialog box.

To update defects:

 1 In the Defects Grid, double-click the defect you want to update. 
Alternatively, select the defect and click the Defect Details button. The 
Defect Details dialog box opens. 

 2 You can click the First button to display the first defect in the grid, or the 
Previous button to display the preceding defect.

 3 You can click the Next button to display the next defect in the grid, or the 
Last button to display the final defect in the grid.
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 4 To display a specific defect in the Defect Details dialog box, click the Go To 
Defect button. The Go To Defect dialog box opens. Type a Defect ID and 
click OK.

 5 You can click the Flag for Follow Up button to add or modify a follow up 
flag for the defect. For more information, see Chapter 4, “Alerting on 
Changes.”

 6 If the defect has an alert, you can click the Alerts button to open the Alerts 
dialog box. For more information, see “Viewing Alerts” on page 80.

 7 Click the Send by Email button to send email with the defect details. For 
more information on mailing defects, see “Mailing Defects” on page 490.

 8 Click the Create Report For This Defect button to generate a report that 
displays detailed information about the defect. 

 9 If the defect is linked to a test run, you can click the Execution Report link at 
the bottom of the Defect Details dialog box to generate an execution report. 
The execution report displays detailed information about the linked test 
run. 

 10 In the Details view, you can add or modify information for the selected 
defect. For more information on available fields in the Details view, see 
Chapter 34, “The Defects Module at a Glance.”

To add a new comment, click the Add Comment button. A new section is 
added to the Comments box, displaying your user name and the database’s 
current date.

 11 Click Attachments on the sidebar to add an attachment to the defect. 
An attachment can be a file, URL, snapshot of your application, system 
information, or an item from the Clipboard. A clickable attachment icon  
is placed next to the defect in the Defects Grid. For more information on 
attachments, see Chapter 5, “Adding Attachments.”

 12 Click Linked Entities on the sidebar. The following tabs are available:

➤ Defects. Enables you to view and add links to existing defects. For 
example, you can link a defect to a duplicate defect.

➤ Others. Enables you to view and remove links from other entities. You 
cannot add new links.

For more information on linked defects, see Chapter 36, “Linking Defects.”
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 13 Click History on the sidebar to view the history of changes made to the 
defect. For more information, see “Viewing Defect History” on page 489.

 14 Click OK to save your changes and return to the Defects Grid.

Finding and Replacing Values 

You can search and replace field values in the Defects Grid using the 
Find/Replace command.

Tip: If text search is available, you can use it to search for defects in the 
Defects Grid. Text search provides a more powerful search by allowing you 
to search for keywords and variations of keywords. For information on using 
the text search, see “Searching Records” on page 72.

To find a value:

 1 In the Defects Grid, choose Edit > Find. The Find dialog box opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value.

 3 In the Value to Find box, type or select the value to find. 

 4 To search for an exact value, select the Exact Match check box.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.
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 6 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 7 Click Find Next. Quality Center attempts to locate any defects with the 
specified value. If the search is successful, the defect is highlighted in the 
Defects Grid. If the search is unsuccessful, an information box opens.

To replace a value:

 1 In the Defects Grid, choose Edit > Replace. The Find/Replace dialog box 
opens.

 2 In the Find in Field box, select the column in which you want to search for a 
specific value. 

 3 In the Value to Find box, type or select the value to find. 

 4 In the Replace with box, type or select a replacement field value.

 5 To distinguish between uppercase and lowercase characters, select the Case 
Sensitive check box.

 6 To search for an exact value, select the Exact Match check box.

 7 To start the search from the top of the Defects Grid, select the From 
Beginning check box.

 8 To use asterisk (*) characters in your search string in order to type only part 
of the item, select the Use Wildcard check box.

 9 To replace the found item and find the next occurrence, click Replace.

 10 To replace all occurrences of the value in the Defects Grid, click Replace All.
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Updating Multiple Records

You can update a field value for multiple records in the Defects Grid. To 
update, select the records in the grid and choose Edit > Update Selected. 
The Update Selected dialog box opens. For more information, see “Updating 
Multiple Records” on page 70.

Viewing Defect History

You can view a list of changes made to a defect. Note that you can only see 
changes for selected fields predefined by the project administrator in Project 
Customization. For more information on enabling the history option for a 
field, refer to the HP Quality Center Administrator Guide.

To view the history of changes to a defect:

 1 To display the history in the Defects Grid, select a defect and choose 
View > Information Panel > Show. Click the History tab. 

Alternatively, in the Defects Grid, double-click a defect to open the Defect 
Details dialog box and click History on the sidebar.

The history of changes made to the defect is displayed in a grid.

For each change to the defect, the grid displays the date and time of the 
change and the name of the user who made the change.

 2 Expand a change to view a list of fields modified during the change. For 
each field, the grid displays the old value and the new value. To expand all 
changes, click the Expand All button.
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 3 You can specify which changes are displayed in the grid. In the Field list, 
select a field name to view only changes made to that field. Select <All> to 
view changes made to all fields.

Mailing Defects 

You can send email about a defect to another user. This enables you to 
inform development and quality assurance personnel about defect repair 
activity. Quality Center includes a Go To Defect link in the email, which 
enables the recipient to go directly to the defect.

Note: By default, Quality Center sends email in HTML format. To send email 
as plain text instead, edit the MAIL_FORMAT parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator Guide.
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To mail a defect: 

 1 In the Defects Grid, select one or more defects and click the Send by Email 
button. The Send Email dialog box opens.

Tip: You can automatically send the email to a specific user type. This can be 
any defect column with a user name value, including user-defined fields. 
Click the Send by Email arrow and choose an option. For example, choose 
Send Mail to Detected By to send the email to the user who detected the 
defect.
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 2 Type a valid email address or user name. Alternatively, click the To button or 
CC button to select users. The Select Recipients dialog box opens. 

You can sort the users list, search for users, group users by user groups, and 
select users from the list or from a group tree. For more information, see 
“Selecting Users” on page 55.

Select the users or user groups to which you want to send the email, and 
click OK. 

 3 In the Subject box, type a subject for the email. By default, if you select only 
one defect, the domain, project, defect ID, and summary of the defect are 
displayed in the Subject box.

 4 In the Items box, you can clear any items you do not want to include in the 
email.

 5 Select whether you want to include the Attachments and/or History of the 
defect.

 6 In the Additional comments box, add any comments you have.
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 7 You can check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word 
that is misspelled together with replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way Quality Center checks spelling. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.

 8 Click Custom to customize the email. In the Select Fields dialog box, you 
can specify fields to include in the email.

 9 Click Send to send the email.

Copying Defects

You can copy a defect to any Quality Center project.

To copy a defect:

 1 In the Defects Grid, select the defect you want to copy. To copy more than 
one defect, press the CTRL key and select the defects you want to copy.

 2 Choose Edit > Copy. Alternatively, right-click and choose Copy.

 3 In the project to which you want to copy the defects, in the Defects Grid, 
choose Edit > Paste. Alternatively, right-click and choose Paste.
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Copying URLs of Defects

You can copy a defect and paste its URL as a link. The defect itself is not 
copied. Instead, you can paste the address into another location, such as an 
email or a document. Clicking on the link opens up Quality Center and 
takes you to the defect. If you are not already logged in, Quality Center first 
prompts for login details. 

To copy a URL of a defect:

 1 From the Defects Grid, select a defect. 

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.

Printing Defects

You can print all defects or selected defects in the Defects Grid.

To print defects:

 1 You can print all defects or selected defects:

➤ To print all defects, choose Defects > Print > All.

➤ To print selected defects, select the defects using the CTRL or SHIFT keys 
and choose Defects > Print > Selected. 

The Print Preview dialog box opens. 

 2 Use the buttons on the toolbar to adjust and set up the page before printing.

 3 Click the Print button or choose File > Print.
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Deleting Defects

You can delete old or duplicate defects from a project. When you delete a 
defect, Quality Center does not reuse the Defect ID.

To delete a defect:

 1 In the Defects Grid, select a defect to delete.

 2 Click the Delete button or choose Edit > Delete. Alternatively, right-click the 
defect and choose Delete.

 3 Click Yes to confirm.
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36
Linking Defects

You can link defects to other entities in Quality Center.

This chapter includes:

 ➤  About Linking Defects on page 497

 ➤  Viewing Defect Links on page 500

 ➤  Adding Defect Links on page 501

 ➤  Removing Defect Links on page 502

About Linking Defects

You can link a defect to the following entities: requirements, tests, test sets, 
test instances, runs, run steps, and other defects. Defect linkage is useful, for 
example, when a new test is created specifically for a defect. By creating this 
linkage, you can determine if the test should be run based on the status of 
the defect.

A defect can be linked directly or indirectly to an entity. When you add a 
defect link to an entity, Quality Center adds a direct link to this entity and 
indirect links to other related entities. In addition, during a manual test run, 
if you add a defect, Quality Center automatically creates a linkage between 
the test run and the new defect.
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The following diagram illustrates the flow of indirect linkage:

For example, when you link a defect to a run step, Quality Center adds an 
indirect link to its run, test instance, test set, and test. If the same test is 
covered by a requirement, an indirect link is also added to the requirement. 
Note that the indirect linkage is a one-directional flow. For example, if you 
link a defect to a run it is not indirectly linked to its run steps.

Using the Linked Defects dialog box or tab, you can view and manage defect 
links.
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The Linked Defects grid contains the following columns:

For more information on the defect fields, see “The Defects Grid” on 
page 474.

Column Description

Created By The user name of the person who created the link.

Creation Date The date on which the link was created.

Defect ID A unique numeric ID for the defect, assigned 
automatically by Quality Center. The Defect ID is read-
only.

Link Comment Enables you to add comments about the link.

Link ID A unique numeric ID for the link, assigned 
automatically by Quality Center. The Link ID is read-
only.

Link Type A value of the Link Type customized list. For more 
information on lists, refer to the HP Quality Center 
Administrator Guide.

Linked By Status The current status of the linked entity.

Linked Entity ID A unique numeric ID for the linked entity, assigned 
automatically by Quality Center. The Linked Entity ID 
is read-only.

Linked Entity Name The linked entity name. For example, the requirement 
name.

Link Entity Type The linked entity type (for example: step, test, test set).
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Viewing Defect Links

You can filter links, set column appearance and order in the grid, and refresh 
the grid. In addition, you can view details of a defect and instruct 
Quality Center to go to a module and highlight a linked entity.

➤ To refresh the grid, click the Refresh All button. 

➤ To filter and sort the defect links, click the Set Filter/Sort button. For more 
information on filtering and sorting, see “Filtering Records” on page 56. If 
you set a filter, the description of the filter is displayed above the grid.

➤ To set column appearance and order in the grid, click the Select Columns 
button. For more information, see “Arranging Columns” on page 52.

➤ To view details of a defect, select a defect link and click the Defect Details 
button. The Defect Details dialog box opens. For more information, see 
“Updating Defects” on page 485.

➤ To open the Defects module and highlight the linked defect, select a defect 
link. Click the Go To arrow and choose Go To Defect. 

Alternatively, click the Defect ID link to open the Defects module and 
highlight the linked defect.

➤ To open the relevant module and highlight the linked entity, select a defect 
link. Click the Go To arrow and choose Go To ’Linked By’ Entity.

Alternatively, click the Linked Entity Name link to open the relevant module 
and highlight the linked entity.

➤ To display direct links, from the Type of Link list, select Direct Links. To 
display direct and indirect links, select All Links. Not available in the Defects 
module.

➤ To display defect links added to parent requirements, select Current Req 
Links from the Show Links For list. To display defect links added to parent 
and children requirements, select Including Child’s Links. Available only in 
the Requirements module.
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Adding Defect Links

You can add a defect link by submitting a new defect or by selecting an 
existing defect. When you link an entity to a defect, Quality Center adds the 

 icon to the entity and to the linked defect. 

Adding Links by Submitting New Defects
You can add a defect link by submitting a new defect.

To add a link by submitting a new defect:

 1 In the Linked Defects tab or dialog box, click the Add and Link Defect 
button, or right-click the grid and choose Add and Link Defect. The New 
Defect dialog box opens.

 2 Enter the relevant defect details. For more information on adding defects, 
see “Adding New Defects” on page 479. 

 3 Click the Submit button in the New Defect dialog box. The defect is added 
to the project and the defect link is displayed in the Linked Defects grid.

Adding Links by Selecting Existing Defects
You can add a defect link by selecting an existing defect.

To add a link by selecting an existing defect:

 1 In the Linked Defects tab or dialog box, click the Link Existing Defect arrow, 
or right-click the grid and choose Link Existing Defect. 

 2 Choose By ID or Select:

➤ To add a link by typing a defect ID, choose By ID. In the Link Existing 
Defect dialog box, type the defect ID and click Link. The defect link is 
displayed in the grid.

➤ To add a link by a selecting a defect, choose Select. In the Defects to Link 
dialog box, select the defect. To select more than one defect, press the 
CTRL key and select the defects you want to link. Click Link. The defect 
links are displayed in the grid.
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Removing Defect Links

You can remove defect links from the Linked Defects grid.

Note: You can only remove direct links. Indirect links are removed 
automatically when the direct links are removed.

To remove a defect link:

 1 In the Linked Defects tab or dialog box, select a link in the grid. To select 
more than one defect, press the CTRL key and select the defects you want to 
remove.

 2 Click the Remove Link button, or right-click and choose Remove Link.

 3 Click Yes to confirm.
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37
The Libraries Module at a Glance

This chapter introduces the key elements in the Libraries module.

Quality Center Editions: Quality Center Premier Edition includes all 
Libraries module functionality and Quality Center Enterprise Edition 
includes some functionality. This module is not available with 
Quality Center Starter Edition. 

This chapter includes:

 ➤  The Libraries Module on page 506

 ➤  The Libraries Menu Bar on page 507

 ➤  The Libraries Toolbar on page 507

 ➤  The Library and Baseline Fields on page 508
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The Libraries Module

You define libraries in Quality Center using the Libraries module. To display 
this module, click the Management button on the sidebar, and then click 
the Libraries tab.

The Libraries module contains the following key elements:

➤ Libraries menu bar. Displays drop-down menus of Libraries module 
commands. For more information, see “The Libraries Menu Bar” on 
page 507.

➤ Libraries toolbar. Contains buttons of Libraries module commands. For 
more information, see “The Libraries Toolbar” on page 507.

➤ Libraries tree. Displays libraries and baselines in a hierarchical tree structure. 
For more information, see Chapter 38, “Libraries and Baselines.”

➤ Details tab. Describes the library folder, library, or baseline currently selected 
in the libraries tree. For more information on the Libraries module fields, see 
“The Library and Baseline Fields” on page 508.

The Entities pane lists the root folders associated with the library. For more 
information, see Chapter 38, “Libraries and Baselines.”
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➤ Quality Center Premier Edition: The following additional tabs are available 
for importing libraries:

➤ Imported By tab. Lists the projects that imported the selected library. For 
more information, see “Viewing Associated Libraries” on page 540. This 
tab is visible only when the current project or other projects have 
imported the selected library.

➤ Imported From tab. Displays details about the library from which the 
currently selected library was imported. For more information, see 
“Viewing Associated Libraries” on page 540. This tab is visible only when 
the selected library is imported.

The Libraries Menu Bar

The Libraries menu bar contains the following menus:

➤ The Libraries menu contains commands that enable you to add library 
folders, libraries and baselines. It also contains a command enabling you to 
compare libraries and baselines. For more information, see Chapter 38, 
“Libraries and Baselines.”

➤ The Edit menu contains commands that enable you to cut, paste, delete, 
and rename library folders, libraries, and baselines.

➤ The View menu contains a command that enables you to refresh the 
libraries tree.

The Libraries Toolbar

The Libraries toolbar contains the following buttons:

New Folder. Adds a new folder to the libraries tree.

Create Library. Adds a new library to the libraries tree.

Quality Center Premier Edition: Import Library. Imports a new library and 
adds it to the libraries tree. For more information, see Chapter 39, 
“Importing Libraries.”
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Create Baseline. Creates a baseline and adds it to the libraries tree.

Compare To. Compares the currently selected library or baseline with other 
libraries or baselines. For more information, see “The Compare Baselines 
Tool” on page 518 and “The Compare Libraries Tool” on page 544.

Cut. Cuts a library folder or a library from the libraries tree to move it to a 
different location in the tree.

Paste. Pastes a cut library folder or library to the specified location in the 
tree.

Delete. Deletes the selected item. Deleting a library folder also deletes its 
libraries and baselines. Deleting a library also deletes its baselines.

Refresh. Refreshes the libraries tree and tabs so that they display the most 
up-to-date data.

The Library and Baseline Fields

The Details tab of the Libraries module displays the following fields:

Field Description

Name The name of the library folder, library, or baseline.

Created By The user name of the person who created the library or 
baseline.

Creation Date The date on which the library or baseline was created.

Library ID A unique numeric ID for the library that Quality Center 
assigns automatically.

Baseline ID A unique numeric ID for the baseline that Quality Center 
assigns automatically.

Modified The date and time on which the baseline was last renamed or 
the description was changed.

Description The library folder, library, or baseline description.
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Notes: 

➤ You can add user-defined fields and change the label of any of the fields 
in the Details tab. You can also customize project lists. For more 
information, refer to the HP Quality Center Administrator Guide.

➤ You can use the Script Editor to restrict and dynamically change the 
fields and values in the Libraries module. For more information, refer to 
the HP Quality Center Administrator Guide.
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38
Libraries and Baselines

You create libraries in the Libraries module. After you create a library, you 
can create and compare baselines for the library to track changes in your 
project over time.

Quality Center Editions: The Libraries module functionality described in this 
chapter is available for Quality Center Enterprise Edition and Quality Center 
Premier Edition.

This chapter includes:

 ➤  About Libraries and Baselines on page 512

 ➤  Creating a Libraries Tree on page 513

 ➤  Creating Libraries on page 513

 ➤  Creating Baselines on page 515

 ➤  The Compare Baselines Tool on page 518

 ➤  Configuring the Comparison Settings on page 522

 ➤  Viewing Baseline History on page 524

 ➤  Pinning a Test Set to a Baseline on page 525

 ➤  Modifying the Libraries Tree on page 526

 ➤  Comparing Entities on page 528



Chapter 38 • Libraries and Baselines

512

About Libraries and Baselines

In the Libraries module, you define a hierarchical libraries tree to create and 
manage your libraries. A library represents a set of entities in a project and 
the relationships between them. The entities in a library can include 
requirements, tests, test resources, and business components. For more 
information, see “Creating a Libraries Tree” on page 513.

After you create a library, you can create a baseline. When you create a 
baseline for a library, you have a snapshot of the library at a specific point in 
time. Baselines enable you to keep track of changes made to your project 
over time. For more information on baselines, see “Creating Baselines” on 
page 515.

You can compare baselines at all stages of the application development life 
cycle. For example, you can compare two baselines in a library to review 
changes made to requirements in the library over time. You can also 
compare a baseline to the current entities in the library. For more 
information, see “The Compare Baselines Tool” on page 518.

Quality Center Premier Edition: You can also import a library. Importing a 
library enables you to reuse an existing set of entities. For more information, 
see Chapter 39, “Importing Libraries.”

Creating and managing libraries and baselines requires appropriate user 
permissions. For more information, refer to the HP Quality Center 
Administrator Guide.
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Creating a Libraries Tree

You define a hierarchical framework for your libraries by creating a libraries 
tree that can contain folders and subfolders.

To create a libraries tree:

 1 In the Libraries module, select the Libraries folder.

 2 Click the New Folder button, or select Libraries > New Folder. The New 
Library Folder dialog box opens.

 3 In the Library Folder Name box, type a name for the folder and click OK. 
The new folder is added to the libraries tree.

 4 In the Details tab, in the Description pane, type a description of the library 
folder.

 5 To create additional folders, select a folder and repeat steps 2 to 4.

Creating Libraries

After creating the libraries tree, you add libraries to your library folders. You 
can create a new library, or import a library. For more information on 
importing a library, see Chapter 39, “Importing Libraries.”

To add a library to a library folder:

 1 In the libraries tree, select a library folder.
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 2 Click the Create Library button, or select Libraries > Create Library. The 
Create Library dialog box opens.

 3 In the Name box, type a name for the library. A library name cannot include 
the following characters: \ / : * ? " < > |

 4 Under Select Entities, select folders to include in the library. You can select 
one or more root folders for each of the Requirements, Business 
Components, Test Plan, and Test Resources modules. For more information 
on Business Components, see the HP Business Process Testing User Guide.

 5 In the Description box, type a description for the library.

 6 Click OK. The new library is added to the libraries tree. 
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Creating Baselines

After you create a library, you can create a baseline. A baseline is a snapshot 
of your library at a specific point in time. You can use a baseline to mark any 
significant milestone in the application development life cycle. A baseline 
includes all the entities defined in the library, including requirements, tests, 
and test resources. Baselines also include the relationships between the 
entities in the library, such as traceability and coverage. Baselines enable you 
to keep track of changes made to your project over time.

When you create a baseline, Quality Center first verifies the library. The link 
verification process checks whether there are entities in the library that are 
associated with entities not contained in the library.

You can use baselines in the following ways:

➤ Compare two baselines to view the changes in a library at different stages of 
development. For more information, see “The Compare Baselines Tool” on 
page 518.

➤ Pin a test set to a baseline. This ensures that when you run the test set, 
Quality Center runs the versions of the tests stored in a baseline you specify. 
For more information, see “Pinning a Test Set to a Baseline” on page 525.

➤ Quality Center Premier Edition: Use a baseline to share the entities in a 
library. This enables you to reuse the library’s entities within your project, or 
in a different project. To import a library, the library must contain a 
baseline. For more information, see Chapter 39, “Importing Libraries.”

Baseline Examples

The following examples demonstrate how you can use baselines:

➤ Establish content of a release - stakeholder sign off.

Your organization is starting development of a new version of an 
application. A business analyst presents a group of requirements to the 
stakeholders to review. After the requirements are reviewed and approved, 
you create a baseline. Stakeholders can then sign off on the agreed upon 
release content.
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➤ Monitor change.

A product manager finds that product development is being implemented 
differently than he expected. He reviews the requirements for the product 
and discovers that some have changed. He compares the current 
requirements with the requirements in the baseline created and agreed upon 
at the start of the release.

➤ Evaluate the impact of changes.

A tester is responsible for a large group of tests that are part of the latest 
application release. She is updating some of the tests in accordance with the 
requirements for the release. Following the latest requirements review 
meeting, she is notified that some of the requirements have been changed. 
The tester compares the current requirements with the requirements in the 
baseline created at the start of the release. She identifies which changes 
affect tests she is working on, and updates the tests to reflect the changes.

Creating a Baseline

You can create a baseline for a library.

To create a baseline:

 1 In the libraries tree, select a library.

 2 Click the Create Baseline button, or select Libraries > Create Baseline. The 
verification process begins.

For each entity in the library that is associated with another entity in the 
project, Quality Center verifies that the associated entity is also contained in 
the library. For example, for each test that has requirements coverage, 
Quality Center checks if the associated requirement is also contained in the 
library.
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If there are entities in the library that are associated with entities not 
contained in the library, Quality Center creates a list of these entities, and 
the Broken Links Verification dialog box opens.

 3 To save the verification results in a text file, click Save Log. In the Save As 
dialog box, type a name for the file and click Save. The Broken Links 
Verification log is downloaded and saved to the location you specified. 
Review the log and resolve any issues, if necessary, before continuing to 
create the baseline.

 4 To continue to create the baseline, click Continue. The New Baseline dialog 
box opens.

 5 In the Baseline Name box, type a name for the new baseline.

 6 Click OK. The baseline is added to the libraries tree, and the creation process 
begins. 

The baseline is created in a background process, and may take some time. 
You can continue working in Quality Center during the baseline creation 
process.
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 7 Click the View Log button in the Details tab. The Log: Create Baseline dialog 
box opens and displays progress. Click Close to close the dialog box.

Note: When the process is complete, view the log before refreshing the 
display. If you refresh the display after the baseline is created, the View Log 
button is no longer displayed, and you cannot view the log.

 8 Click the Refresh button on the module toolbar to refresh the display. The 
baseline details are displayed in the Details tab. For more information on 
the available fields in the Details tab, see “The Library and Baseline Fields” 
on page 508.

 9 In the Details tab, click the Description pane to add a description to the 
baseline.

The Compare Baselines Tool

You can compare two baselines in a library. For example, you can compare 
baselines at different stages of development to assess the impact of changes 
made to requirements in your project. You can then update the relevant 
tests in your project accordingly.

You can also compare a baseline to the current entities in the library. For 
example, suppose you create a baseline at the start of a new release. Over 
time, changes are made to requirements in the library. To determine 
whether product development is proceeding as planned, you can compare 
requirements in the initial baseline with the current requirements in the 
library.
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Notes:

➤ Quality Center does not consider changes made to Target Release and 
Target Cycle fields when determining whether an entity has been 
modified.

➤ If coverage or traceability between two entities was deleted and then 
added again, those entities are considered modified.

To compare baselines:

 1 In the libraries tree, expand a library and select a baseline. Click the 
Compare To button or select Libraries > Compare To, and select a baseline 
with which to compare.

➤ Select Select Baseline to compare the baseline you selected with another 
baseline in the library. The Select Baseline dialog box opens. Click the 
browse button and select a baseline from the list. Click OK. 

Click OK to close the Select Baseline dialog box.

➤ Select Current Entities to compare the baseline you selected with the 
current entities in the library.
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 2 The Compare Baselines Tool dialog box opens.

The baselines are displayed in separate panes, with the more recently 
created baseline or current entities displayed in the right pane. In each pane, 
the library’s entities are displayed in the same hierarchical tree structure as 
defined in the specific module. 

Differences between the two baselines are indicated in the Changes column. 
The following types of changes are identified by the Compare Baselines 
Tool:

Change Description

Added The entity did not exist in the older baseline.

Modified There is a difference in the entity between the 
baselines.

Deleted The entity does not exist in the newer baseline.

Moved The entity is in a different location in the tree 
structure in the newer baseline.
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The number of entities that were added, modified, deleted, or moved is 
indicated in the counter above each pane.

A deleted or moved entity is displayed in its original location in the tree, 
indicated by a placeholder. This maintains the hierarchical structure, 
enabling you to compare changes between baselines.

 3 Click a button on the sidebar to view comparison results for entities in a 
particular module. For example, click the Tests button to view comparison 
results for the Test Plan module. The sidebar displays only the modules that 
are included in the library.

 4 Click the Go to Next Change button in the right pane to move to the next 
change, or Go to Previous Change to move to the previous change.

 5 To view additional details for an entity, select the entity and click the Details 
button on the toolbar. The Details dialog box for the entity opens. For 
example, select a requirement and click the Details button. This opens the 
Requirement Details dialog box, and displays details of the selected 
requirement in the selected baseline.
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 6 To compare a modified entity between baselines, select the entity and click 
the Compare Entities button on the toolbar. The Compare Entities dialog 
box opens and displays details of the entity in each baseline. For more 
information, see “Comparing Entities” on page 528.

 7 To set options for the Compare Baselines Tool, click the Comparison 
Settings button on the toolbar. For more information, see “Configuring the 
Comparison Settings.”

Configuring the Comparison Settings

You can define settings for comparing libraries or baselines. The 
Comparison Settings dialog box enables you to select which fields 
Quality Center considers when determining whether an entity has been 
modified.

Note: Quality Center does not consider changes made to Target Release and 
Target Cycle fields when determining whether an entity has been modified.
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To configure the comparison settings:

 1 In the Compare Baselines Tool or the Compare Libraries Tool, click the 
Comparison Settings button. The Comparison Settings dialog box opens.

 2 Click the tab for the entity type you want to configure. For example, click 
the Tests tab. The current settings display:

➤ Considered Fields. Quality Center displays the entity as modified based 
on changes made to fields in this box.

➤ Ignored Fields. Quality Center does not display the entity as modified 
based on changes made to fields in this box.

 3 Select field names and click the arrow buttons (> and <) to move them 
between the Ignored Fields and Considered Fields boxes. Click the double 
arrow buttons (>> and <<) to move all the fields from one list to the other. 
You can also double-click a field name to move the field between lists.

 4 Under Additional Considered Fields, select any additional fields to include. 
To instruct Quality Center to ignore coverage, you must clear the Coverage 
check box in both the Requirements and Tests tabs.
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Viewing Baseline History

You can view all versions of an entity that are stored in a baseline. This 
includes entities in the Requirements, Business Components, Test Plan, and 
Test Resources modules. You can also compare two baseline versions. For 
more information on Business Components, see the HP Business Process 
Testing User Guide.

Version Control: You can view all previous versions of an entity. For more 
information, see “Viewing Version History” on page 109.

To view baseline history:

 1 Select an entity in the tree or grid. Click the History tab, and then click the 
Baselines tab.

Version Control: In the History tab, click the Versions and Baselines tab. In 
the View By box, select Baselines.

The baseline history is displayed in a grid.

 2 Under Description for selected baseline, view the description typed by the 
user when creating the baseline.

 3 To view a version of the entity stored in a baseline, select a baseline and click 
View. A Details dialog box opens, displaying read-only details for the version 
of the entity stored in the selected baseline. Click the buttons on the sidebar 
to view additional information. The buttons displayed may change 
according to the entity you selected in the tree or grid.

Column Description

Baseline The name of the baseline in which the entity appears.

Library The library for which the baseline was created.

Date The date the baseline was created.

Created By The name of the user who created the baseline.
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Note: If you are viewing information for a QuickTest test, clicking the Test 
Script button opens the test in a QuickTest viewer, enabling you to view the 
test or open the test in QuickTest. For more information, refer to the HP 
QuickTest Professional User Guide.

Click Close to close the Details dialog box.

 4 To compare two baseline versions, press the CTRL key and select each 
version. You can compare two baseline versions when the baselines belong 
to the same library.

Click Compare. For more information on comparing baseline versions, see 
“Comparing Entities” on page 528.

Pinning a Test Set to a Baseline

You can pin a test set to a baseline. This associates the test set with the tests 
stored in a baseline that you specify. When you run a test set that is pinned 
to a baseline, Quality Center runs the versions of the tests that are stored in 
the specified baseline.

A test set that is pinned to a baseline can include only tests that are included 
in the baseline. When you pin a test set to a baseline, tests that are not a part 
of the baseline are removed from the test set. In addition, all test runs are 
deleted from the test set.

For more information on baselines, see “Creating Baselines” on page 515.

To pin a test set to a baseline:

 1 In the Test Lab module, select a test set from the test sets tree.

 2 Select Tests Sets > Pin to Baseline, or right-click and select Pin to Baseline. 
The Pinned to Baseline dialog box opens and displays the Libraries tree.

 3 Select a baseline and click OK. A confirmation message displays. Click OK to 
confirm. In the test sets tree, the test set icon  is replaced by the pinned 
test set icon .
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 4 To clear a pinned test set, select the test set and select Tests Sets > Clear 
Pinned Baseline. A confirmation message displays. If the test set includes 
tests that do not exist in the Test Plan module, Quality Center deletes the 
tests from the test set. In addition, all test runs in the test set are deleted. 
Click OK to confirm. The tests in the test set are associated with the current 
tests in the Test Plan module.

Modifying the Libraries Tree

This section describes the following:

➤ Renaming Library Folders, Libraries, and Baselines

➤ Moving Library Folders and Libraries

➤ Deleting Library Folders, Libraries, and Baselines

Renaming Library Folders, Libraries, and Baselines
You can rename a library folder, library, or baseline.

To rename a library folder, library, or baseline:

 1 Select an item from the libraries tree.

 2 Select Edit > Rename. Alternatively, right-click the item and select Rename.

 3 Edit the name and press ENTER.

Moving Library Folders and Libraries
You can move a library folder or a library to a different location in the 
libraries tree. Moving a library folder also moves its libraries and baselines. 
Moving a library also moves its baselines. You cannot move a baseline or the 
root Libraries folder.

Tip: You can also move a library folder or a library to a new location in the 
libraries tree by dragging it.
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To move a library folder or a library:

 1 Select a library folder or library from the libraries tree. To move more than 
one item, press the Ctrl key and select the items you want to move.

 2 Click the Cut button. Alternatively, select Edit > Cut.

 3 Select a folder in the libraries tree.

 4 Click the Paste button. Alternatively, select Edit > Paste.

Deleting Library Folders, Libraries, and Baselines
You can delete a library folder, library, or baseline. You cannot delete a 
library folder that contains libraries, or delete a library that contains 
baselines. Deleting a library or baseline does not delete the library’s entities 
from your project.

Consider the following before deleting a baseline:

➤ If you delete a baseline, you can no longer compare between the baseline’s 
library and another library that was imported from or synchronized with 
the baseline.

➤ Deleting a baseline clears the baseline from pinned test sets. For more 
information, see “Pinning a Test Set to a Baseline” on page 525.

To delete a library folder, library, or baseline:

 1 Select an item from the libraries tree. To delete more than one item, press 
the CTRL key and select the items you want to delete.

 2 Click the Delete button. Alternatively, select Edit > Delete. A confirmation 
message displays.

 3 Click Yes to confirm. The items are deleted.
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Comparing Entities

You compare entities in the Compare Entities dialog box. You can access the 
Compare Entities dialog box in the following ways:

➤ Compare an entity between two baselines from the History page of the 
Requirements, Test Plan, and Test Resources modules. For more information, 
see “Viewing Baseline History” on page 524.

➤ Compare an entity between two baselines from the Compare Baselines Tool 
dialog box. For more information, see “The Compare Baselines Tool” on 
page 518.

➤ Compare an entity between two libraries from the Compare Libraries Tool 
dialog box. For more information, see “The Compare Libraries Tool” on 
page 544.

➤ Version Control: Compare two versions of an entity from the History page of 
the Requirements, Test Plan, and Test Resources modules. For more 
information, see “Viewing Version History” on page 109.

Notes: 

➤ Changes made to Target Release and Target Cycle fields do not cause the 
fields to be marked as modified.

➤ Version Control: When you compare two versions of an entity, not all 
sidebar buttons are displayed. The buttons available depend on the 
information stored under version control. For more information, see 
“Version Control Overview” on page 100.
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To compare entities:

 1 In the Compare Entities dialog box, click Details on the sidebar. 

The Field Name column displays the entity’s fields. You can compare the 
field values between the entity versions. Fields that have been changed are 
marked as Modified in the Changes column.

Version Control: Changes to some fields are not stored under version 
control. For more information, see “Non-versioned Fields” on page 103.

 2 In the View box, select one of the following options:

➤ Show All. Displays all entity fields.

➤ Show Only Changed. Displays fields whose values have changed.

➤ Show Only Unchanged. Displays fields whose values are the same.
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 3 Click the Rich Text tab to compare the entity’s rich text. Each pane in the 
Rich Text tab indicates if rich text has been added, deleted, or modified for 
the relevant entity version.

 4 You can open or save the rich text as a file to view and compare changes.

➤ To view rich text, click the Open button for either version of the entity.

➤ To save rich text to a file, click the Save As button for either version of 
the entity. In the Save As dialog box, type a name for the file and click 
Save. The rich text is downloaded and saved to the location you 
specified.

 5 Click a button on the sidebar to view additional comparison results, such as 
traceability and coverage. The buttons displayed depend on the type of 
entity you are comparing.
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Notes:

➤ If you are comparing a QuickTest entity, the QTP Comparison button is 
displayed, enabling you to open the QuickTest Asset Comparison Tool. 
For more information on working with QuickTest, refer to the HP 
QuickTest Professional User Guide.

➤ For traceability and coverage, if a linked entity is marked as both Deleted 
and Added, or is displayed as Missing on both sides, this can indicate 
that the link between the entities was deleted and then added again.

 6 Click Attachments on the sidebar to compare the entity’s attachments. The 
Changes column indicates if an attachment has been added, deleted, or 
modified. 

 7 You can open or save attachments to view and compare changes.

➤ To view an attachment, double-click the attachment, or select the 
attachment and click the Open Attachment button.

➤ To save an attachment, select the attachment and click the Save As 
button. In the Save As dialog box, type a name for the file and click Save. 
The attachment is downloaded and saved to the location you specified.
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39
Importing Libraries

You can import a library to reuse the library’s entities within a project or in 
different projects across your enterprise.

Quality Center Premier Edition: The Libraries module functionality 
described in this chapter is only available for Quality Center Premier 
Edition.

This chapter includes:

 ➤  About Importing Libraries on page 534

 ➤  Importing a Library on page 536

 ➤  Viewing Associated Libraries on page 540

 ➤  The Compare Libraries Tool on page 544

 ➤  Synchronizing Libraries on page 547

 ➤  Mailing Libraries on page 550
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About Importing Libraries

Importing a library enables you to share and reuse an existing set of entities. 
You import a library by selecting a baseline in another library from which to 
import. You can import a library from the same project, or from a different 
project. For more information on creating libraries and baselines, see 
Chapter 38, “Libraries and Baselines.”

You can compare associated libraries at all stages of the application 
development life cycle. For example, you can compare an imported library 
with the source library from which it was imported. For more information, 
see “The Compare Libraries Tool” on page 544.

When changes are made to entities in a library, you can synchronize 
libraries to update the entities in an associated library. For more 
information, see “Synchronizing Libraries” on page 547.

Importing and synchronizing libraries requires appropriate user 
permissions. For more information, refer to the HP Quality Center 
Administrator Guide.

Note: You can also share defects across multiple Quality Center projects. You 
share and synchronize defects using the HP Quality Center Synchronizer. For 
more information, see the HP Quality Center Sychronizer User Guide, available 
from the Quality Center Adds-ins Page.

Library Examples

The following examples demonstrate how you can use libraries.

➤ Reuse requirements and tests for a new release.

While developing a new application, you create a library that includes all 
the entities in your project that are relevant to the application. After work is 
complete, you release the new application. As you are about to begin work 
on the next version, you can import the library, and start making 
adjustments to requirements and tests to meet the needs of the new version.
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➤ Create a set of requirements, tests, and resources for use by multiple 
applications.

Your project contains requirements in the Requirements module that are 
relevant to an application you are developing. The project also contains 
tests in the test plan module that you developed to test those requirements. 
In addition, you have created relationships between the requirements and 
tests, such as traceability and coverage. You can create a library that 
represents the application. Then import this library as a self-contained 
component of other applications.

➤ Update imported libraries with changes made in the source library.

A library in your project includes requirements and tests for a calculator 
application. Multiple other projects have imported the library, and are using 
the application’s requirements and tests in other applications they are 
developing. The business analyst has revised some requirements for the 
calculator application. To update the imported libraries with these changes, 
you can synchronize the imported libraries with the source library.

➤ Update a source library with developments in an imported library.

A tester works with an imported library that contains a set of regression tests 
for the banking application currently in development. During testing, she 
develops new tests to test the added functionality in the new version of the 
banking application. When testing is complete, the tester wants to update 
the regression tests in the source library. The source library can be 
synchronized with the imported library to update the tests for future testing 
needs.
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Importing a Library

You can import a library to your libraries tree from the same project or from 
a different project. When you import a library, the library is added to your 
libraries tree, and the library’s entities are copied to the corresponding 
modules in your project. If the library includes associated entities, such as 
requirements that have test coverage, this relationship is also copied. An 
imported library is displayed with an Imported Library icon  in the 
libraries tree.

You import a library by selecting a baseline in another library from which to 
import. After you import a library, Quality Center automatically creates a 
baseline for the new library in your project. This baseline is the basis for 
comparing the libraries at any point in time and should not be deleted. For 
more information on baselines, see Chapter 38, “Libraries and Baselines.”

When you import a library, Quality Center first verifies that the library can 
be successfully imported. The verification process includes the following 
checks:

➤ Requirement type check. Checks that your project contains the necessary 
requirement types. If the source library contains customized requirement 
types, your project must contain the same requirement types. For more 
information on customized requirement types, see HP Quality Center 
Administrator Guide.

➤ Entities compatibility check. Checks that your project has the necessary 
extensions enabled. If the source project has a Quality Center extension 
enabled, and the source library includes entities for that extension, your 
project must also have that extension enabled. For more information on 
extensions, see HP Quality Center Administrator Guide.
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You cannot import a library under the same previously imported library in 
the requirements, test plan, or test resources tree. For example, in the 
requirements tree, the Travel Application folder is an imported library. If 
you want to import the Travel Application library again, you cannot define 
the Travel Application folder or any of its child folders as the root folder for 
the requirements in the library.

Importing a Library

You can import a library by selecting a baseline from the same project or 
from a different project. You cannot import an imported library.

To import a library:

 1 In the libraries tree, select a library folder.
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 2 Click the Import Library button, or select Libraries > Import Library. The 
Step 1 of 3: Select a Baseline dialog box opens.

 3 Select one of the following options:

➤ From Current Project. Enables you to import a library from the project in 
which you are working.

➤ From Project. Enables you to select a domain and project from which to 
import a library.

In the Domain list, select a domain.

In the Project list, select a project.

 4 In the Select a Baseline box, click the browse button. The libraries tree for 
the project you selected opens, and displays the libraries that can be 
imported. Expand a library and select a baseline from which to import the 
library and click OK. The library and baseline descriptions are displayed in 
the Description box.

 5 Click Next. The Step 2 of 3: Library Verification dialog box opens, displaying 
verification results and the list of fields to be imported.

If any of the verification checks have the status Failed, you cannot proceed 
with the import process. Click Cancel.

If the verification checks all have the status Passed, click Next to continue.
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 6 The Step 3 of 3: Select Target Root Folders dialog box opens.

 7 In the Name box, type a name for the library or accept the default name. By 
default, the name of the library from which you are importing is displayed 
with the suffix _Imported.

 8 Under Select Target Root Folders, select a location in your project for each 
of the imported root folders. For example, in the Requirement Root Folder 
box, specify a location for the imported requirements. All of the 
requirement folders defined in the library are imported under the 
requirement folder you specify. Click the browse button to display the 
requirements tree in your project. Select a location for the imported 
requirements.

 9 In the Description box, type a description for the library or accept the 
default description. By default, if the source library and baseline contain 
descriptions, the descriptions are displayed.

 10 Click Finish to import the library. The imported library is added to the 
libraries tree, and the import process begins.

The library is imported in a background process, and may take some time. 
You can continue working in Quality Center during the import process.

 11 Click the View Log button in the Details tab. The Log: Import Library dialog 
box opens and displays progress. Click Close to close the dialog box.
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Note: When the process is complete, view the log before refreshing the 
display. If you refresh the display after the library is imported, the View Log 
button is no longer displayed, and you cannot view the log.

 12 Click the Refresh button on the module toolbar to refresh the display. The 
library details are displayed in the Details tab. For more information on the 
available fields in the Details tab, see “The Library and Baseline Fields” on 
page 508.

 13 In the Details tab, click the Description pane to add a description to the 
library, or modify the existing description.

Viewing Associated Libraries

You can view information about associated libraries. You can view details of 
projects that imported a selected library in the Imported By tab. You can 
also view details of the source project from which a library was imported in 
the Imported From tab.

This section includes:

➤ Viewing the Imported By Tab

➤ Viewing the Imported From Tab
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Viewing the Imported By Tab
For a selected library, you can view a list of projects that imported this 
library.

To view the Imported By tab:

 1 In the libraries tree, select a library and click the Imported By tab. The 
projects that have imported the selected library are listed in a grid.

The Imported By tab displays the following columns for each library that 
imported the selected library:

Column Description

Domain The domain in which the imported library is 
located.

Project The name of the project that imported the library.

Library Name The name of the imported library.
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You can rearrange columns by dragging the column headers.

 2 Click the Refresh button to refresh the display.

 3 To send email to a library owner, select an entry in the grid and click the 
Send Mail button. For more information, see “Mailing Libraries” on 
page 550.

 4 To compare the source to an imported library, click the Compare To button. 
For more information, see “The Compare Libraries Tool” on page 544.

Source Baseline Name The initial value indicates the name of the baseline 
in the source project from which the library was 
imported. After synchronization, indicates the 
name of the baseline in the source project with 
which the library was synchronized.

Import Date The date the library was imported.

Last Synchronization The date of the most recent synchronization of the 
imported and source libraries.

Library Owner The user name of the person who imported the 
library.

Column Description
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Viewing the Imported From Tab
You can view details of the source library from which a selected library is 
imported.

To view the Imported From tab:

 1 In the libraries tree, select an imported library and click the Imported From 
tab.

The Imported From tab displays the following fields:

Column Description

Domain The domain in which the source project is located.

Project The name of the source project.

Library Name The name of the library in the source project.

Baseline Name The name of the baseline in the source project from 
which the project was imported.
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 2 To send email to the source library owner, click the Send Mail to Owner 
button. For more information, see “Mailing Libraries” on page 550.

 3 To compare the imported library to the source library, click the Compare To 
Source button. For more information, see “The Compare Libraries Tool” on 
page 544.

The Compare Libraries Tool

You can compare two associated libraries. The Compare Libraries Tool 
enables you to compare an imported library with the source library from 
which it was imported.

Notes:

➤ Quality Center does not consider changes made to Target Release and 
Target Cycle fields when determining if an entity has been modified.

➤ If coverage or traceability between two entities was deleted and then 
added again, those entities are considered modified.

You can also synchronize two associated libraries. For more information, see 
“Synchronizing Libraries” on page 547.

To compare libraries:

 1 In the libraries tree, select a library. Click the Compare To button or select 
Libraries > Compare To.

Last Synchronization The date of the most recent synchronization of the 
imported and source libraries. When the library is 
first imported, the value of this field is N/A.

Source Library Owner The user name of the person who created the library 
in the source project.

Column Description
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 2 Select a baseline with which to compare the library.

➤ Select Latest Baseline Created to compare the library with the most 
recent baseline created in the other library.

➤ Select Select Baseline to select a baseline in the other library with which 
to compare. The Select Baseline dialog box opens. Click the browse 
button and select a baseline from the list. Click OK. 

Click OK to close the Select Baseline dialog box.

 3 The Compare Libraries Tool dialog box opens.

The libraries are displayed in separate panes. The left pane displays the 
library you selected in the library tree. The right pane displays the baseline 
in the library to which you are comparing. Each library’s entities are 
displayed in the same hierarchical tree structure as defined in the specific 
module.
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Differences between the two libraries are indicated in the Changes column 
of each pane. The following types of changes are identified by the Compare 
Libraries Tool:

The number of entities that were added, modified, deleted, or moved is 
indicated in the counter above each pane.

A deleted or moved entity is displayed in its original location in the tree, 
indicated by a placeholder. In addition, a placeholder is displayed in the tree 
where an entity was added in the other library. This maintains the 
hierarchical structure, enabling you to easily compare changes between the 
libraries.

Change Description

Added The entity does not exist in the other library.

Modified The entity has been modified in the library.

Deleted The entity was deleted from the library.

Moved The entity is in a different location in the tree 
structure in the library.
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 4 Click a button on the sidebar to view comparison results for entities in a 
particular module. For example, click the Tests button to view comparison 
results for the Test Plan module. The sidebar displays only the modules that 
are included in the library.

 5 Click the Go to Next Change button on the library toolbar to move to the 
next change, or Go to Previous Change to move to the previous change.

 6 To view additional details for an entity, select the entity and click the Details 
button on the library toolbar. The Details dialog box for the entity opens. 
For example, select a requirement click the Details button. This opens the 
Requirement Details dialog box, and displays details of the selected 
requirement.

 7 To compare a modified entity between libraries, select the entity and click 
the Compare Entities button on the toolbar. The Compare Entities dialog 
box opens and displays details of the entity in each library. For more 
information, see “Comparing Entities” on page 528.

 8 Click the Comparison Settings button on the toolbar to set options for the 
Compare Libraries Tool. For more information, see “Configuring the 
Comparison Settings” on page 522.

 9 To synchronize the libraries, click the Synchronize button. Data from the 
other library is copied to your library. For more information, see 
“Synchronizing Libraries” on page 547.

Synchronizing Libraries

You can synchronize two associated libraries to update one library with 
changes made in another library. You can update an imported library with 
changes made in the source library. You can also update a source library 
with changes made in the imported library.

When you synchronize libraries, Quality Center first verifies that the 
libraries can be successfully synchronized. The verification process includes 
the following checks:
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➤ Requirement type check. Checks that your project contains the necessary 
requirement types. If the other library contains customized requirement 
types, your project must contain the same requirement types. For more 
information on customized requirement types, see HP Quality Center 
Administrator Guide.

➤ Entities compatibility check. Checks that your project has the necessary 
extensions enabled. If the other library’s project has a Quality Center 
extension enabled, and the library includes entities for that extension, your 
project must also have that extension enabled. For more information on 
extensions, see HP Quality Center Administrator Guide.

During synchronization, data from the other library’s baseline is copied to 
your library. The following table summarizes how the entities in your library 
are updated:

Entities in a library must not be edited during synchronization. If entities in 
your library are being edited by another user during the synchronization 
process, synchronization cannot complete successfully.

Version Control: All entities in your library must be checked in before 
synchronization. If an entity in your library is checked out, synchronization 
cannot complete successfully.

Event in Source Library Event in Your Library

An entity was added. The entity is added.

An entity was modified. The entity is updated.

If the entity was modified in both libraries, 
Quality Center overwrites the entity in your library.

Version Control: A new version is created.

An entity was deleted. Quality Center creates a new folder and moves the 
deleted entity to the new folder. The new folder is 
named 
SYNC_OBSOLETE_<library_id>_<current_date> and 
is located under the module’s root folder.

An entity was moved. The entity and its children are moved.
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After you synchronize libraries, Quality Center automatically creates a 
baseline for the updated library. This baseline is the basis for comparing the 
libraries at any point in time and should not be deleted. For more 
information on baselines, see Chapter 38, “Libraries and Baselines.”

Synchronizing Libraries

You can synchronize two libraries to update your library with changes made 
in another library. You synchronize libraries by selecting a baseline in the 
library with which to synchronize.

To synchronize libraries:

 1 In the libraries tree, select the library that you want to update. Using the 
Compare Libraries Tool, compare the library by selecting a baseline in the 
other library. For more information, see “The Compare Libraries Tool” on 
page 544.

The Compare Libraries Tool displays your library in the left pane, and the 
baseline of the other library in the right pane. When you synchronize the 
libraries, Quality Center updates your library with the changes indicated in 
the baseline in the right pane.
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 2 In the Compare Libraries Tool, click the Synchronize button. The Library 
Verification dialog box opens, displaying the verification results.

 3 Click Continue to start the synchronization. Quality Center copies data 
from the other library’s baseline to your library.

 4 Click Close to close the Compare Libraries Tool dialog box. Synchronization 
continues in a background process, and may take some time. You can 
continue working in Quality Center during the synchronization process.

 5 Click the View Log button in the Details tab. The Log: Synchronize Libraries 
dialog box opens and displays progress. Click Close to close the dialog box.

 6 Click the Refresh button on the module toolbar to refresh the display. When 
the process completes, the Last Synchronization date is updated in the 
Imported By or Imported From tab.

Mailing Libraries

You can send email about a library to other users. This enables you to inform 
them about the status of your libraries. For example, after updating 
requirements in a library, you can notify imported library owners of the 
changes. A link is included in the email that enables the recipient to go 
directly to the library.

By default, Quality Center sends email in HTML format. To send email as 
plain text instead, edit the MAIL_FORMAT parameter in the 
Site Configuration tab in Site Administration. For more information, refer to 
the HP Quality Center Administrator Guide.
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To mail a library:

 1 In the libraries tree, select a library. Click the Imported By or Imported From 
tab. In the Imported By tab, you can select a library, or press the CTRL key 
and select multiple libraries.

 2 Click the Send E-Mail button. The Send E-mail dialog box opens.
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 3 By default, the library owner is listed in the To box. To add a user, type a 
valid email address or user name. Alternatively, click the To button or CC 
button to select users. The Select Recipients dialog box opens. 

You can sort the users list, search for users, group users by user groups, and 
select users from the list or from a group tree. For more information, see 
“Selecting Users” on page 55.

Select the users or user groups to which you want to send the email, and 
click OK.

 4 In the Subject box, type a subject for the email.

 5 In the Item box, you can view the name of the library included in the email.

 6 In the Additional comments box, add any comments you have.
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 7 You can check the spelling in the dialog box:

➤ Click the Check Spelling button to check the spelling for the selected 
word or text box. If there are no errors, a confirmation message opens. If 
errors are found, the Spelling dialog box opens and displays the word 
that is misspelled together with replacement suggestions.

➤ Click the Spelling Options button to open the Spelling Options dialog 
box, enabling you to configure the way Quality Center checks spelling. 

➤ Click the Thesaurus button to open the Thesaurus dialog box and display 
a synonym, antonym, or related word for the selected word. You can 
replace the selected word or look up new words.

 8 Click the Custom button to customize the email. In the Select Fields dialog 
box, you can specify fields to include in the email.

 9 Click Send to send the email.
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40
The Dashboard Module

In the Dashboard module, you create, view and manage graphs, standard 
reports, and Excel reports, for analyzing Quality Center data. You also create 
dashboard pages that display multiple graphs side-by-side.

This chapter includes:

 ➤  About the Dashboard Module on page 557

 ➤  The Dashboard Module at a Glance on page 558

 ➤  Developing the Analysis and Dashboard Trees on page 559

 ➤  Creating Analysis Items on page 560

 ➤  Generating Dashboard Pages on page 561

 ➤  Managing Analysis Items and Dashboard Pages on page 565

About the Dashboard Module

The Dashboard module includes two tabs: The Analysis View tab and the 
Dashboard View tab.

The Analysis View tab contains a tree in which you organize all of your 
analysis items. Analysis items can be any of the following analysis types: 
graphs, standard reports, and Excel reports.

The Dashboard View tab contains a tree in which you organize dashboard 
pages. In Dashboard pages you arrange multiple graphs that you created in 
the analysis tree, and display them in a single view.

This chapter describes how to develop and manage the analysis tree and the 
dashboard tree, and how to generate dashboard pages.
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Additional Analysis Tools

➤ Live Analysis graphs. Enables you to create and display a dynamic graphic 
representation of data related to test plans and test sets. For more 
information, see Chapter 44, “Generating Live Analysis Graphs.”

➤ Document Generator. Enables you to create a Microsoft Word document 
containing a project’s requirements, planning, test list, test set folders, and 
defect tracking data. For more information, see Chapter 45, “Generating 
Project Documents.”

The Dashboard Module at a Glance

You define analysis items — graphs, standard reports, Excel reports — and 
dashboard pages using the Dashboard module. To open the Dashboard 
module, click the Dashboard button on the sidebar.
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The Dashboard module contains the following key elements:

➤ Analysis and Dashboard trees. Structures of private and public folders that 
contain your analysis items and dashboard pages. For more information on 
developing the trees, see “Developing the Analysis and Dashboard Trees” on 
page 559.

➤ Analysis View tab. Enables you to create and manage graphs, standard 
reports, and Excel reports.

➤ For more information on graphs, see Chapter 41, “Generating Graphs.”

➤ For more information on standard reports, see Chapter 42, “Generating 
Standard Reports.”

➤ For more information on Excel reports, see Chapter 43, “Generating 
Excel Reports.”

➤ Dashboard View tab. Enables you to create and manage dashboard pages, 
that display multiple graphs on a single page. For more information on 
creating dashboard pages, see “Generating Dashboard Pages” on page 561.

Developing the Analysis and Dashboard Trees

The Dashboard module includes trees for analysis items and dashboard 
pages. Each tree consists of Private and Public root folders. Under each root 
folder you develop separate trees. Analysis items or dashboard pages that 
you create in a public folder are accessible to all users. Analysis items or 
dashboard pages that you create in a private folder are accessible only to the 
user who created them. Public dashboard pages can include only public 
graphs.

Analysis items and dashboard pages in public folders may show different 
results for different users, depending on the data hiding definitions for the 
user group. For more information on data permissions, refer to the 
HP Quality Center Administrator Guide.

To develop the analysis or dashboard tree:

 1 In the Dashboard module, click either the Analysis View tab or the 
Dashboard View tab.

 2 In the tree, select the folder under which you want to create a new folder.
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 3 Click the New Folder button. Alternatively, right-click and choose New 
Folder. The New Folder dialog box opens.

 4 In the Folder Name box, type a name for the folder and click OK. The folder 
name cannot include the following characters: \ ^ *

The new folder appears as a sub-folder of the folder you selected.

 5 Click the Details tab. The Details tab displays the following fields:

Creating Analysis Items

You create graphs, standard reports, and Excel reports in the Analysis View 
tab of the Dashboard module.

➤ To create a graph, see “Creating Graphs with the Graph Wizard” on 
page 570, or “Creating Graphs in the Dashboard Module” on page 576.

➤ To create a standard report, see “Creating Standard Reports in the Dashboard 
Module” on page 612.

➤ To create an Excel report, see “Creating Excel Reports” on page 625.

Field Description

Name The name of the folder.

Owner Indicates the user that created the folder. 
Permissions to modify public folders may be limited 
to the owner only.

Description A description of the folder.
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Generating Dashboard Pages

In the dashboard pages, you can arrange and view multiple graphs on a 
single page. You select the graphs to include in the dashboard page from the 
graphs in the analysis tree. You can arrange the graphs on the page in any 
order you like, and you can expand or reduce their size.

This section includes:

➤ Creating Dashboard Pages

➤ Configuring Dashboard Pages

➤ Viewing Dashboard Pages

Creating Dashboard Pages
You create dashboard pages in the Dashboard View tab of the Dashboard 
module.

To create a dashboard page:

 1 In the Dashboard module, click the Dashboard View tab.

 2 In the dashboard tree, select a public or a private folder. For more 
information on folders in the dashboard tree, see “Developing the Analysis 
and Dashboard Trees” on page 559.

 3 Click the New Page button. Alternatively, choose Dashboard > New Page.

The New Dashboard Page dialog box opens. Enter a dashboard page name, 
and click OK. A dashboard page name cannot include the following 
characters: \ ^ *

A dashboard page is added to the dashboard tree under the selected folder.

 4 Click the Details tab.
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The Details tab displays the following fields:

 5 Select and arrange the graphs that you want to include in the dashboard 
page. For more information, see “Configuring Dashboard Pages” on 
page 562.

 6 View the dashboard page. For more information, see “Viewing Dashboard 
Pages” on page 563.

Configuring Dashboard Pages
You configure dashboard pages by selecting and arranging graphs on your 
page. Each row on the dashboard page can include one or two graphs. In 
public dashboard pages you may include only public graphs.

Note: You can change the maximum number of graphs that Quality Center 
allows you to include in a dashboard page, by setting the DASHBOARD_
PAGE_ITEM_LIMIT site parameter. For more information, refer to the 
HP Quality Center Administrator Guide.

Field Description

Name The name of the dashboard page.

Modified Indicates the date and time on which the dashboard 
page was last modified.

Modified By Indicates the user that last modified the dashboard 
page.

Page Owner Indicates the user that created the dashboard page. 
Permissions to modify public pages may be limited 
to the owner only.

Title The title that displays in the header of the 
dashboard page view.

Description A description of the dashboard page.
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To configure a dashboard page:

 1 In the Dashboard module, click the Dashboard View tab.

 2 In the dashboard tree, select the dashboard page that you want to configure.

 3 Click the Configuration tab. The Select Graphs pane opens.

 4 To refresh the graphs tree, click the Refresh button.

 5 Select a graph, and click the Add Graph to Dashboard Page button. You can 
also drag a graph to a new row above or below existing graphs, or to an 
empty box alongside a graph.

A placeholder for the graph is created in the Configuration tab displaying 
the graph’s title.

Note: You cannot include a graph from a private analysis folder in a public 
dashboard page.

 6 To move a graph sideways, upwards or downwards, select and drag the 
placeholder to a new position. You cannot leave blank lines between graphs.

 7 To expand the width of a graph to cover a whole row, make sure that the 
graph is in a row of its own, and click the Expand button, located in the 
upper-left corner of the placeholder.

 8 To reduce the width of a graph to cover half a row, click the Contract 
button, located in the upper-left corner of the placeholder.

 9 To remove a graph from the dashboard page, click the Remove button, 
located in the upper-right corner of the placeholder.

Viewing Dashboard Pages
After you arrange graphs on your dashboard page, you view the graphs in 
the View tab.

To view a dashboard page:

 1 In the Dashboard module, click the Dashboard View tab.

 2 In the dashboard tree, select the dashboard page that you want to view.
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 3 Click the Generate button on the Dashboard View toolbar. Alternatively, 
click the View tab. Quality Center generates and displays the graphs in the 
dashboard page.

At any time, two rows of graphs are visible in the window. Use the vertical 
scroll bar to move up or down the dashboard page.

 4 In bar charts or pie charts, you can drill down from segments of the graph to 
the records that they represent. For more information, see “Drilling Down 
to Graph Records” on page 585.

 5 To view the dashboard page in full-screen mode, click the View Page in Full 
Screen button, located in the upper-right corner of the page.

To return to the standard view, click the Close button, located in the 
upper-right corner of the page.

 6 To view a single graph in full-screen mode, click the View Graph in Full 
Screen button, located in the upper-right corner of the graph.

You can use the toolbar buttons to adjust the graph’s display, save or print 
the graph. The adjustments you make to the graph’s display are reset when 
you next generate the dashboard page. For more information on viewing 
the graph, see “Viewing Graphs” on page 583.

To return to the dashboard page view, click the Close button, located in the 
upper-right corner of the graph.

 7 To refresh the data in all the graphs, click the Generate All Graphs in Page 
button, located in the upper-right corner of the page.

To refresh the data in a single graph, click the Generate Graph button, 
located in the upper-right corner of the graph.

Quality Center refreshes the graph and updates the Last Generated time and 
date.

 8 To navigate to a graph in the analysis tree, click the Go To Graph in Analysis 
Tree button, located in the upper-right corner of the graph. Alternatively, 
double-click the graph. The Analysis View opens and the graph is selected in 
the analysis tree.
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Managing Analysis Items and Dashboard Pages

This section includes editing commands for managing analysis items and 
dashboard pages in the analysis tree and the dashboard tree. It includes the 
following topics:

➤ Moving Items and Folders

➤ Copying Analysis Items or Folders

➤ Copying the URL of an Item or Folder

➤ Renaming an Item or Folder

➤ Deleting Items or Folders

Moving Items and Folders
You can move items and folders to a new location in the tree. Before you 
move an item or folder, consider the following:

➤ When you move a folder, all the analysis items or dashboard pages it 
contains move with it.

➤ When you move an analysis item from a public folder to a private folder, it 
is removed from public dashboard pages in which it is included.

➤ When you move a dashboard page from a private folder to a public folder, 
Quality Center removes any private graphs from the dashboard page.

To move an item or folder:

 1 In the tree, select an item or folder. To move more than one item or folder, 
hold down the CTRL key and select the items or folders you want to move.

 2 Click the Cut button. Alternatively, right-click and choose Cut.

 3 Select a folder in the tree.

 4 Click the Paste button. Alternatively, right-click and choose Paste.

Tip: You can also move items or folders by dragging them to a different 
folder.
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Copying Analysis Items or Folders
You can copy analysis items or folders within the same project, or to another 
Quality Center project.

To copy an analysis item or folder:

 1 In the analysis tree, select the item or folder you want to copy. To copy more 
than one item or folder, hold down the CTRL key and select the items or 
folders.

 2 Click the Copy button. Alternatively, right-click and choose Copy.

 3 To copy to another project, open another browser window, and log in to the 
target project.

 4 Select the folder to which you want to copy the item or folder.

 5 Choose Edit > Paste. Alternatively, right-click and choose Paste.

Copying the URL of an Item or Folder
You can copy an item or folder and paste its URL as a link. The item is not 
copied. Instead, you can paste the address into another location, such as an 
email or a document. Clicking on the link opens up Quality Center and 
takes you to the item or folder. If you are not already logged in, 
Quality Center first prompts for login details. 

To copy a URL of an item or folder:

 1 In the tree, select an item or folder.

 2 Choose Edit > Copy URL. Alternatively, right-click and choose Copy URL.

 3 Paste the URL.

Renaming an Item or Folder
You can rename an item or folder.

To rename an item or folder:

 1 In the tree, select an item or folder.

 2 Right-click the item or folder and choose Rename.

 3 Edit the item or folder name and click Enter.
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Deleting Items or Folders
You can delete an item or folder from the tree. Before you delete an item or 
folder, consider the following:

➤ Deleting a folder deletes all the items included in it.

➤ Deleting a graph removes it from dashboard pages that contain it.

To delete an item or folder:

 1 In the tree, select an item or folder. To delete more than one item or folder, 
hold down the CTRL key and select the items or folders you want to delete.

 2 Click the Delete button, or right-click and choose Delete.

 3 Click Yes to confirm.
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41 
Generating Graphs

You can generate graphs that let you view images describing the 
information in a Quality Center project. You can also design graphs that 
combine data from multiple projects.

This chapter includes:

 ➤  About Generating Graphs on page 569

 ➤  Creating Graphs with the Graph Wizard on page 570

 ➤  Creating Quick Graphs on page 575

 ➤  Creating Graphs in the Dashboard Module on page 576

 ➤  Configuring Graphs on page 578

 ➤  Creating Cross-Project Graphs on page 581

 ➤  Viewing Graphs on page 583

 ➤  Quality Center Graph Types on page 591

About Generating Graphs

Quality Center graphs help you analyze and view the relationships between 
different types of data. Graphs can represent data in the Requirements, Test 
Plan, Test Lab, and Defects modules. Depending on the module, you have 
different graph options. For more information on available graph types, see 
“Quality Center Graph Types” on page 591.

Quality Center Premier Edition: You can create graphs that include data 
from multiple Quality Center projects.
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You launch graphs either in the Dashboard module, or during your work in 
the Requirements, Test Plan, Test Lab, or Defects modules. In either case, 
you can save the graphs in the Dashboard module for future reference.

Quality Center provides a graph wizard that guides you through the stages 
of creating a graph. For more information, see “Creating Graphs with the 
Graph Wizard” on page 570.

When viewing the graphs, you can drill down to the records represented by 
each segment. For more information, see “Drilling Down to Graph Records” 
on page 585.

You can display multiple graphs in a single view, by including them in a 
dashboard page. For more information, see “Generating Dashboard Pages” 
on page 561.

Creating Graphs with the Graph Wizard

You can create a graph using the graph wizard. The graph wizard takes you 
through the steps involved in creating a graph and defining its settings.

To create a graph using the graph wizard:

 1 Launch the graph wizard:

➤ Open either the Requirements, Test Plan, Test Lab, or Defects module. 
Choose Analysis > Graphs > Graph Wizard.

➤ Open the Dashboard module and select the Analysis View tab. Click the 
New Item button, and select Graph Wizard.
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The graph wizard opens on the Select Graph Type dialog box.

 2 The following step applies if you launched the graph wizard from the 
Dashboard module. Under Entity, select the Quality Center module for 
which you want to create the graph.

 3 Under Graph Type, select the type of graph that you want to display. For 
more information on graph types, see “Quality Center Graph Types” on 
page 591. Click Next.

 4 Quality Center Premier Edition: The Select Projects dialog box opens.
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Under Project Selection, specify the projects that you want to include in the 
graph:

➤ Use Current Project. The graph uses the current Quality Center project.

➤ Use Selected Projects. The graph uses the projects that appear in the grid. 
To change the selected projects, click Select. For more information on 
creating cross-project graphs, see “Creating Cross-Project Graphs” on 
page 581.

 5 The following step applies if you launched the graph wizard from the Test 
Lab module. The Select Test Set Option dialog box opens. Select whether to 
include in the graph the selected test set only, or all the test sets. Click Next.

 6 The Select Filter dialog box opens.

Under Filter Selection, specify which filter to use to define the records 
included in the graph:

➤ Use current filter. Available if you launched the graph wizard from the 
Requirements, Test Plan, Test Lab, or Defects modules. Uses the current 
filter applied to the data.

➤ Do not use a filter. Includes all records of the selected module.

➤ Define a new filter. Enables you to define a new filter or cross-filter. Click 
the Filter button to open the Filter dialog box, and define the filter.

For more information on filtering, see “Filtering Records” on page 56.
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Quality Center Premier Edition: If your graph includes multiple projects, 
you can filter using only fields that are in all the selected projects.

 7 Click Next. The Select Graph Attributes dialog box opens.

In the Group By field box, select the field by which you want data to be 
grouped in the graph. For progress and trend graphs, you can only select a 
field for which history has been enabled. For more information on enabling 
history for a field, refer to the HP Quality Center Administrator Guide. 

Quality Center Premier Edition: If your graph includes multiple projects, 
you can only select from fields that are in all the selected projects. To group 
the data by project, select the QC Project value.

 8 If you are creating a summary graph, in the X-Axis box, select the field that 
you want to use for the x-axis. 

Quality Center Premier Edition: If your graph includes multiple projects, 
you can only select from fields that are in all the selected projects. To list the 
projects along the x-axis, select the QC Project value.
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 9 This step applies if you are working in the Requirements module. The Select 
Coverage dialog box opens. Under Select a coverage option, select which 
requirements to include in the graph:

➤ Do not show ’Not Covered’ parents. Does not include parent 
requirements with a ’Not Covered’ status. 

➤ Show ’Not Covered’ parents. Includes all requirements. 

For more information on coverage, see Chapter 19, “Requirement and Test 
Coverage.”

 10 Click Next. The Select Name and Folder dialog box opens.

In the Graph Name box, type a name for the graph, or leave the default 
name.

 11 Under Destination Folder, select the folder in which the graph will be 
located in the Dashboard module. To create a new folder, select the parent 
folder and click the New Folder button. For more information on folders in 
the analysis tree, see “Developing the Analysis and Dashboard Trees” on 
page 559.

 12 Click Finish. The graph opens in the View tab of the Dashboard module, 
with the settings you defined.
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Creating Quick Graphs

You can create quick graphs during your work in the Requirements, Test 
Plan, Test Lab, and Defects modules. Quick graphs enable you to create 
several types of graphs in each module, using the existing module filter. You 
can use quick graphs for one-time reference, or save them in the Dashboard 
module, where you can continue to configure their data and appearance. 

Note: You can also create graphs from the Requirements, Test Plan, Test Lab, 
and Defects modules using the graph wizard. For more information, see 
“Creating Graphs with the Graph Wizard” on page 570.

To create a quick graph:

 1 Open the Quality Center module in which you want to generate the graph.

 2 Choose Analysis > Graphs and select a graph type. For more information on 
graph types, see “Quality Center Graph Types” on page 591. 

The graph opens with default data and appearance settings. 

 3 Use the toolbar buttons to browse the graph, adjust its appearance, and 
output the results. For more information on viewing graphs, see “Viewing 
Graphs” on page 583.

 4 In bar and pie charts, you can drill down to the records that are represented 
by the segments by clicking a segment. For more information, see “Drilling 
Down to Graph Records” on page 585.

 5 To save the graph in the Dashboard module, click Save. The New Graph 
dialog box opens.

 6 Under Graph Name, type a name for the new graph.

 7 Under Select Folder, select the folder in the Analysis tree in which to save 
the graph, or click New Folder to create a new folder. For more information 
on folders in the analysis tree, see “Developing the Analysis and Dashboard 
Trees” on page 559.
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 8 Click Save. The Dashboard module opens in the Analysis View, and the 
graph opens under the View tab.

 9 You can configure the graph content in the Configuration tab. For more 
information, see “Configuring Graphs” on page 578.

Creating Graphs in the Dashboard Module

You can create graphs in the Dashboard module, that display data from the 
Requirements, Test Plan, Test Lab, and Defects modules.

Note: You can also create a graph using the graph wizard. For more 
information, see “Creating Graphs with the Graph Wizard” on page 570.

To create a graph in the Dashboard Module:

 1 In the Dashboard module, click the Analysis View tab.

 2 In the analysis tree, select the folder under which you want to add a graph. 
For more information on adding folders in the analysis tree, see 
“Developing the Analysis and Dashboard Trees” on page 559.

 3 Click the New Item button, and select New Graph. The New Graph dialog 
box opens.

 4 Under Entity, select the entity for which you want to create a graph.
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 5 Under Graph Type, select the type of graph you want to create. For more 
information on graph types, see “Quality Center Graph Types” on page 591.

 6 Under Graph Name, type a name for the graph.

 7 Click OK. The graph is added to the analysis tree.

 8 Click the Details tab. The Details tab displays the following fields:

 9 You can configure the graph content in the Configuration tab. For more 
information, see “Configuring Graphs” on page 578.

 10 View the graph in the View tab. For more information, see “Viewing 
Graphs” on page 583.

Field Description

Entity Indicates the data set sampled by the graph.

Type Indicates the analysis item type.

Sub Type Indicates the graph type.

Name The name of the graph.

Modified Indicates the date and time on which the graph was 
last modified.

Modified By Indicates the user that last modified the graph.

Owner Indicates the user that created the graph. 
Permissions to modify public graphs may be limited 
to the owner only.

Description A description of the graph.
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Configuring Graphs

You can define what data appears in a graph, and how the data is organized.

To configure the graph:

 1 In the analysis tree, select the graph you want to configure.

 2 Click the Configuration tab.
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 3 Configure the following settings that apply to your graph type:

Setting Description

Age Grouping You can group all defects older than a certain period (for 
example, older than six months) in one column, and all 
defects more recent than that period in a second column. 
Alternatively, you can group the defects by all available 
periods.

➤ Select a period to group the defects in two columns.

➤ Select No grouping to view all of the available periods.

Display Options ➤ Select Regular to view the number of requirements, 
tests, or defects over the period of time you selected.

➤ Select Changes over Time to view the change in the 
number of requirements, tests, or defects over the 
period of time you selected. Each record begins at 0.

Grouped By Select a field to determine the information by which 
Quality Center groups data in the graph. You can group 
the data only by string or list fields.

Tip: For cross-project graphs, select QC Projects to group 
the data by project.

Period Select the period of time you want the graph to show.

Show Daily Info Select this option to display each day along the x-axis.

Show ’Not Covered’ 
parents

In Requirements graphs, you can choose to include in the 
graph parent requirements with a Not Covered status.
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 4 To apply a filter or cross-filter to the graph content, click the Set Filter 
button. For more information on filtering, see “Filtering Records” on 
page 56. For more information on cross filtering, see “Advanced/Cross 
Filtering Records” on page 61.

 5 Quality Center Premier Edition: To change the projects whose data is 
included in the graph, under Cross Project Selection, click the Select 
Projects button. For more information on creating cross-project graphs, see 
“Creating Cross-Project Graphs” on page 581.

X-Axis Select a field to determine the information displayed 
along the x-axis of the graph.

Tip: For cross-project graphs, select QC Projects to display 
the data by project.

Y-Axis In Defects graphs, you can select the data that displays on 
the y-axis.

➤ Select Count to display the total number of items (for 
example, a count of open defects).

➤ Select Sum of and choose a numerical field. For 
example, choose Estimated Fix Time to display the 
estimated time required for fixing the defects. Choose 
Actual Fix Time to display the actual time spent on 
fixing the defects. (Available only in Defects graphs.)

Setting Description
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Creating Cross-Project Graphs

Quality Center Premier Edition: You can create cross-project graphs that 
combine data from several projects in a single graph. In the graph wizard, 
you select the projects that the graph will include as part of the wizard’s 
procedure. You can also change the selected projects at any time in the 
graph’s Configuration tab. You can only select projects in which you are 
listed as a user.

Note: You can change the maximum number of projects that Quality Center 
allows you to include in a graph, by setting the PROJECT_SELECTION_
MAX_PROJECTS site parameter. For more information, refer to the 
HP Quality Center Administrator Guide.

To create cross-project graphs:

 1 Select one of the following options:

➤ In the graph wizard: Proceed to the Select Projects dialog box, and click 
the Select button.

➤ In the analysis tree: Select the graph, click the Configuration tab, and 
click the Select Projects button.
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The Select Projects dialog box opens.

The Projects Tree includes only projects in which you are listed as a user.

 2 To add a project to the grid, expand the Projects Tree, select a project and 
click the Add button. You can also drag a project from the Projects Tree to 
the grid, or double-click the project.

Tip: To include all of a domain’s projects in the graph, select a domain in the 
Projects Tree, and add it to the grid. All the domain’s projects are listed 
individually in the grid.

 3 Click OK to close the Select Projects dialog box.

 4 You can display project data separately in the graph, by selecting QC Project 
in the X-Axis or Grouped By fields. Select one of the following options:

➤ In the graph wizard, proceed to the Select Graph Attributes dialog box.

➤ In the Configuration tab, set the X-Axis or Grouped By fields. For more 
information, see “Configuring Graphs” on page 578.
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Considerations for Creating Cross-Project Graphs

➤ Every time you add or remove projects in your graph, Quality Center 
updates the Filter Condition list, and the drop-down lists of the following 
boxes: X-Axis, Y-Axis, and Grouped By. The lists contain only fields that are 
identical in all the selected projects. Identical fields are fields that have the 
same field name, label and data type. For more information on customizing 
fields, see the HP Quality Center Administrator Guide.

➤ If you defined a filter condition using a field that becomes unavailable, that 
condition is removed.

➤ If you selected a field in the X-Axis, Y-Axis, and Grouped By boxes that 
becomes unavailable, the first field in the drop-down list is selected.

Viewing Graphs

This section includes the following topics:

➤ Viewing the Graph

➤ Drilling Down to Graph Records

➤ Setting the Graph Appearance

➤ Editing Graph Categories

Viewing the Graph
You can change the graph format, browse the graph, set the graph 
appearance, change the graph categories, save, and print the graph.

To view the graph:

 1 Select a graph:

➤ In the analysis tree, select a graph, and click the View tab.

➤ Select the Requirements, Test Plan, Test Lab, or Defects module, choose 
Analysis > Recently Used, and select a graph.

 2 In progress and trend graphs, click the categories in the legend box to show 
or hide the categories in the graph.
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 3 Browse the graph using the graph view toolbar. The toolbar includes the 
following buttons, depending on the graph type:

Generate. Refreshes the graph with the most recent data.

Bar Chart. Available in summary, trend, and age graphs.

Pie Chart. Displays the x-axis categories as pie segments. The y-axis 
quantities are represented by the size of the segments. Pie charts do not 
display the Grouped By field. Available in summary graphs.

Line Chart. Available in progress graphs.

Data Grid. The grid creates a matrix of the graph’s x-axis and Grouped By 
categories. A Total row is added that displays the total of each Grouped By 
category. Available in all graph types.

Show/Hide Total Values. Available in progress graphs. Toggles between 
showing and hiding a category representing the total of the Grouped By 
categories.

Scroll to the Left. Scrolls the graph to the left. This button is enabled when 
the Zoom In and Zoom Out buttons are in use.

Scroll to the Right. Scrolls the graph to the right. This button is enabled 
when the Zoom In and Zoom Out buttons are in use.

Show All. Returns the graph to its normal size. This button is enabled when 
the Zoom In and Zoom Out buttons are in use.

Zoom In. Increases the magnification of the graph.

Zoom Out. Decreases the magnification of the graph.

Save Graph Data. Saves the contents of a graph as a file. When viewing the 
graph as a bar chart, a pie chart, or a line chart, you can save the graph as a 
graphic file in various graphic formats. When viewing the data grid, you can 
save the data as an Excel spreadsheet, a Word file, an HTML document, or a 
text file.

Set Graph Appearance. Changes the appearance of the graph, enabling you 
to customize the graph title, graph color, and graph display. For more 
information, see “Setting the Graph Appearance” on page 587.
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Copy Graph to Clipboard. Includes the following options:

➤ Copy Graph (Color). Copies the graph in color to the Clipboard.

➤ Copy Graph (Monochrome). Copies the graph in monochrome to the 
Clipboard.

➤ Copy Full Screen Graph (Color). Copies the graph in color to the Clipboard, 
enlarged to fit full screen.

➤ Copy Full Screen Graph (Monochrome). Copies the graph in monochrome 
to the Clipboard, enlarged to fit full screen.

Print Graph. Includes the following options:

➤ Print Graph (Color). Prints the graph in color. This is the default button 
option.

➤ Print Graph (Monochrome). Prints the graph in monochrome.

➤ Print Graph and Details (Color). Prints the graph and its description in 
color.

➤ Print Graph and Details (Monochrome). Prints the graph and its description 
in monochrome.

Edit Categories. Enables you to combine X-Axis and Grouped By field values 
into categories. For more information, see “Editing Graph Categories” on 
page 588.

Full Screen. Opens the graph in a new window and maximizes its display. 
Available in the Dashboard module.

Drilling Down to Graph Records
You can drill down to the graph’s records by clicking on segments in the 
graph.

To drill down to graph records:

 1 Display the graph in the pie chart format or the bar chart format.

 2 Click a segment or a bar.
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 3 If the segment or bar represents records from only the project you are 
currently working in, the Drill Down Results dialog box opens. In this case, 
proceed to step 6.

 4 Quality Center Premier Edition: If the segment or bar represents only records 
from another project, the records display in a separate browser window:

➤ If you are already logged in to the other project in another browser window, 
the appropriate module is selected in that window, and the relevant records 
are listed.

➤ If you are not logged in to the other project, click OK to confirm. A new 
browser window opens. After you log in, Quality Center displays the 
relevant records in the appropriate module.

 5 Quality Center Premier Edition: If the segment or bar represents records 
from multiple projects, the Project Selection dialog box opens.

 a Under Select Project, select a project, and click OK.

 b If you selected the current project, the Drill Down Results dialog box 
opens. In this case, proceed to step 6.

 c If you selected another project, the records display in a separate browser 
window:

➤ If you are already logged in to the other project in another browser 
window, the appropriate module is selected in that window, and the 
relevant records are listed.

➤ If you are not logged in to the other project, click OK to confirm. A 
new browser window opens. After you log in, Quality Center displays 
the relevant records in the appropriate module.

 6 In the Drill Down Results dialog box, click the Select Columns button, 
located in the upper-right corner, to define which columns appear in the 
grid, and the order in which they appear. For more information, see 
“Arranging Columns” on page 52.

 7 Double click a record to open the record details.

 8 The <Module> Details dialog box opens. You can edit the record details in 
this dialog box.



Chapter 41 • Generating Graphs

587

 9 Click OK or Cancel to close the dialog box and return to the Drill Down 
Results dialog box.

 10 Close the Drill Down Results dialog box to return to the View tab.

Setting the Graph Appearance
After you have created your graph, you can change its titles and appearance. 
For a bar chart, you can specify the display parameters for the bars. For a line 
chart, you can specify the display parameters for the lines.

To set the graph appearance:

 1 Click the View tab. Click the Set Graph Appearance button located in the 
graph toolbar. Alternatively, click the graph title. The Graph Appearance 
dialog box opens.

 2 Click the Titles tab to change the titles of the graph, the y-axis, or the x-axis. 
You can click the Font button to change a title’s font or color. You can click 
the Reset Titles button to restore the original titles. Note that for a pie chart, 
you can only change the title of the graph.

 3 Click the Appearance tab to set the default format of your graph, to modify 
the orientation of the labels at the base of the graph (for a bar chart and a 
line chart only), to determine the format in which dates are displayed on 
the x-axis, to display the graph with a 3-D effect, or to change the colors of 
the various components in your graph.
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 4 For a bar chart, click the Bar Parameters tab to specify whether you want the 
values for each bar to be displayed. You can also adjust the bar width. If you 
specify that the values of each bar are to be displayed, you can change the 
data that is displayed for each bar, or its position relative to the bar. 

 5 For a line chart, click the Line Parameters tab to specify whether you want 
the line frame to be displayed.

Editing Graph Categories
You can combine values in the X-Axis and Grouped By fields into categories. 
This enables you to group together data for different field values and display 
the combined data as one category. For example, suppose the Priority field 
has five values: Low, Medium, High, Very High, and Urgent. You might 
combine the values Medium and High into a category Important, and the 
values Very High and Urgent into a category Critical. The graph would then 
display data divided into three categories: Low, Important, and Critical.

To edit categories for a graph:

 1 Click the View tab. Click the Edit Categories button located in the graph 
toolbar and select one of the following options:

➤ Edit X-Axis Categories. Enables you to combine X-Axis field values into 
categories for graph display. This option is only available for summary 
graphs and Requirements Coverage graphs. This is the default button 
option.

➤ Edit Grouped By Categories. Enables you to combine Grouped By field 
values into categories for graph display. 
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The Edit ‘X-Axis’ Categories or Edit Grouped By Categories dialog box 
opens.

 2 To create a new category, click the New button. The New Category dialog 
box opens.

 3 In the Category Name box, type a name for the category.
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 4 To select which field values to include in the category, select field values and 
click the arrow buttons (> and <) to move them between Available groups 
and Groups in new category. Click the double arrow buttons (>> and <<) to 
move all the field values from one list to the other. You can also drag field 
values between lists. You cannot include a field value in more than one 
category.

Click OK to close the New Category dialog box.

 5 To edit a category, select the category and click the Edit button. Repeat 
steps 3 to 4.

 6 To delete a category, select the category and click the Delete button.

 7 To delete all categories, click the Clear All button. Click Yes to confirm.

 8 Click OK to close the Edit X-Axis Categories or Edit Grouped By Categories 
dialog box.

 9 To reset the X-Axis or Group By categories to their default settings, click the 
Edit Categories button located in the graph toolbar and select one of the 
following options:

➤ Reset X-Axis Categories. Restore the X-Axis categories. This option is only 
available for summary graphs and Requirements Coverage graphs.

➤ Reset Group By Categories. Restore the Group By categories.

Click Yes to confirm. The X-Axis or Group By categories are reset.
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Quality Center Graph Types

Quality Center enables you to generate graphs for the Requirements, Test 
Plan, Test Lab, and Defects modules. For each module, different graph types 
are available.

Requirements Module Graphs
You can generate the following graphs for the Requirements module:

Graph Description

Requirements - 
Summary Graph

Shows how many requirements are currently in a 
Quality Center project. For more information, see 
“Requirements - Summary Graph” on page 594.

Requirements - 
Progress Graph

Shows how many requirements accumulated in a 
Quality Center project at specific points during a period of 
time. For more information, see “Requirements - Progress 
Graph” on page 595.

Requirements - 
Trend Graph

Shows the history of changes to specific requirement 
fields in a Quality Center project, for each time interval 
displayed. For more information, see “Requirements - 
Trend Graph” on page 597.

Requirements - 
Coverage Graph

(Available from the 
Requirements 
module only.)

Shows how many requirements are currently in a 
Quality Center project, according to their test coverage 
status. For more information, see “Requirements - 
Coverage Graph” on page 596.
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Test Plan Module Graphs
You can generate the following graphs for the Test Plan module:

Test Lab Module Graphs
You can generate the following graphs for the Test Lab module:

Graph Description

Test Planning - 
Summary Graph

Shows how many tests are currently in a Quality Center 
project. For more information, see “Test Planning - 
Summary Graph” on page 598.

Test Planning - 
Progress Graph

Shows how many tests accumulated in a Quality Center 
project at specific points during a period of time. For more 
information, see “Test Planning - Progress Graph” on 
page 599.

Test Planning - 
Trend Graph

Shows the history of changes to specific Test Plan fields in 
a Quality Center project, for each time interval displayed. 
For more information, see “Test Planning - Trend Graph” 
on page 600.

Graph Description

Test Execution - 
Summary Graph

Shows how many tests in a Quality Center project belong 
to the current test set, or to all test sets. For more 
information, see “Test Execution - Summary Graph” on 
page 601.

Test Execution - 
Progress Graph

Shows how many tests accumulated in the current test 
set, or in all test sets, at specific points during a period of 
time. For more information, see “Test Execution - Progress 
Graph” on page 602.



Chapter 41 • Generating Graphs

593

Defects Module Graphs
You can generate the following graphs for the Defects module:

Graph Description

Defects - Summary 
Graph

Shows a summary of the number of defects in a 
Quality Center project, or the estimated/actual amount of 
time taken to fix these defects. For more information, see 
“Defects - Summary Graph” on page 603.

Defects - Progress 
Graph

Shows the accumulation of defects in a Quality Center 
project, or the estimated/actual amount of time taken to 
fix these defects, at specific points during a period of time. 
For more information, see “Defects - Progress Graph” on 
page 604.

Defects - Age Graph Shows the lifetime of defects in a Quality Center project. 
For more information, see “Defects - Age Graph” on 
page 605.

Defects - Trend 
Graph

Shows the history of changes to specific defect fields in a 
Quality Center project, for each time interval displayed. 
For more information, see “Defects - Trend Graph” on 
page 606.
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Requirements - Summary Graph 
The Requirements - Summary Graph shows how many requirements are 
currently in a Quality Center project. The number of requirements is 
displayed according to the criteria that you specify. You can specify the type 
of data displayed along the x-axis, and the requirement information by 
which Quality Center groups the data. 

For example, choose Author from the X-Axis list to display the number of 
requirements that exist in your project, according to author. Select Priority 
from the Grouped By list to group requirements in the graph columns 
according to their level of priority. You can select the Show ‘Not Covered’ 
parents check box to include parent requirements with a ‘Not Covered’ 
status in the graph.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

By default, the graph appears as a bar chart.
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Requirements - Progress Graph 

The Requirements - Progress Graph shows how many requirements 
accumulated in a Quality Center project at specific points during a period of 
time. The number of requirements is displayed according to the criteria that 
you specify. You can specify the time interval displayed along the x-axis, and 
the requirement information by which Quality Center groups the data. You 
can also specify whether you want to view the number of requirements or 
the change in the number of requirements. 

For example, choose Direct Cover Status from the Grouped By list to group 
the displayed requirements according to their test coverage status. Under 
Period, select Last 5 weeks to display this interval along the x-axis. Note that 
the graph displays data measured on the last day of each week. Under 
Display Options, select Changes Over Time to view the changes in the 
number of requirements over time, as opposed to the number of 
requirements.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

The graph can be viewed as a line chart only.
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Requirements - Coverage Graph 

The Requirements - Coverage Graph shows how many requirements are 
currently in a Quality Center project, according to their test coverage status.

You can specify the requirement information by which Quality Center 
groups the data. For example, select Priority from the Grouped By list to 
group requirements in the graph’s columns according to their level of 
priority. Select the Show ‘Not Covered’ parents check box to include parent 
requirements with a Not Covered status in the graph.

Note: The Requirements - Coverage Graph is a specific type of summary 
graph. If you select a different requirement field from the X-Axis list, a 
regular Requirements - Summary Graph is displayed.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart button.
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Requirements - Trend Graph 

The Requirements - Trend Graph shows the history of changes to specific 
requirement fields in a Quality Center project, for each time interval 
displayed. You specify the field for which you want to view the number of 
changes, and the time period for which you want to view data. 

For example, choose Direct Cover Status from the Count Changes in Field 
list to display the number of changes made to the “Direct Cover Status” 
requirement field. Under Period, select Last 5 weeks to display this time 
period along the x-axis. Note that the graph displays a sum of the data 
measured for each week.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

Note that each status change is only recorded once for the purpose of this 
graph. For example, if a field was changed from “Not Completed” to 
“Passed” to “Not Completed”, the “Not Completed” status change will only 
be recorded once in this graph.

The Requirements - Trend Graph can be viewed as a bar chart only.



Chapter 41 • Generating Graphs

598

Test Planning - Summary Graph 

The Test Planning - Summary Graph shows how many tests are currently in 
a Quality Center project. The number of tests is displayed according to the 
criteria that you specify. You can specify the type of data displayed along the 
x-axis, and the test plan information by which Quality Center groups the 
data. 

For example, choose Designer from the X-Axis list to display the number of 
tests that exist in your project, according to designer. Select Priority from the 
Grouped By list to group tests in the graph’s columns according to their 
level of priority. Click the Generate button to refresh the graph display.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart button.
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Test Planning - Progress Graph
The Test Planning - Progress Graph shows how many tests accumulated in a 
Quality Center project at specific points during a period of time. The 
number of tests is displayed according to the criteria that you specify. You 
can specify the time interval displayed along the x-axis and the test plan 
information by which Quality Center groups the data. You can also specify 
whether you want to view the number of tests or the change in the number 
of tests. 

For example, choose Status from the Grouped by list to group the displayed 
tests according to their level of priority. Under Period, select All days and 
Show daily info to display each day along the x-axis. Under Display Options, 
select Changes Over Time to view the changes in the number of tests over 
time, as opposed to the number of tests.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

The Test Planning - Progress Graph can be viewed as a line chart only.
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Test Planning - Trend Graph
The Test Planning - Trend Graph shows the history of changes to specific 
Test Plan fields in a Quality Center project, for each time interval displayed. 
You specify the field for which you want to view the number of changes, 
and the time period for which you want to view data. 

For example, choose Status from the Count changes in field list to display 
the number of changes made to the Test Plan “Status” field. Under Period, 
select Last 5 weeks to display this time period along the x-axis. Note that the 
graph displays a sum of the data measured for each week.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

Note that each status change is only recorded once for the purpose of this 
graph. For example, if a field was changed from “Ready” to “Repair” to 
“Ready”, the “Ready” status change will only be recorded once in this graph.

The Test Planning - Trend Graph can be viewed as a bar chart only.
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Test Execution - Summary Graph
The Test Execution - Summary Graph shows how many tests in a 
Quality Center project belong to test sets. You can specify whether the graph 
refers to the current test set, or to all test sets. The number of tests is 
displayed according to the criteria that you specify. You can specify the type 
of data displayed along the x-axis, and the test plan and test in test set 
information by which Quality Center groups the data. 

For example, choose Status from the X-Axis list to display the number of 
tests that exist in your project, according to test status. Select Plan: Priority 
from the Grouped By list to group tests in the graph’s columns according to 
their level of priority. Click the Generate button to refresh the graph 
display.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart button.
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Test Execution - Progress Graph
The Test Execution - Progress Graph shows how many tests accumulated in 
test sets at specific points during a period of time. You can specify whether 
the graph refers to the current test set, or to all test sets. The number of tests 
is displayed according to the criteria that you specify. You can specify the 
time interval displayed along the x-axis, and the test plan and test in test set 
information by which Quality Center groups the data. You can also specify 
whether you want to view the number of tests or the change in the number 
of tests. 

For example, choose Status from the Grouped by list to group the displayed 
tests according to their status. Under Period, select Last 5 weeks to display 
this interval along the x-axis. (Note that the graph displays data measured 
on the last day of each week.) Under Display Options, select Changes Over 
Time to view the changes in the number of tests over time, as opposed to 
the number of tests.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

The Test Execution - Progress Graph can be viewed as a line chart only.
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Defects - Summary Graph
The Defects - Summary Graph shows a summary of the number of defects in 
a Quality Center project, or the estimated/actual amount of time taken to 
fix these defects. The information is displayed according to the criteria that 
you specify. You can specify the type of data displayed along the x-axis, the 
type of data displayed along the y-axis, and the defect information by which 
Quality Center groups the data. 

For example, choose Assigned To from the X-Axis list to display the number 
of defects that exist in your project, according to the people to whom they 
are assigned. Select Status from the Grouped By list to group defects in the 
graph’s columns according to their status. Under Data Type, select Count to 
display the number of defects along the y-axis. Click the Generate button to 
refresh the graph display.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

By default, the graph appears as a bar chart. To view the graph as a pie chart, 
click the Pie Chart button.
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Defects - Progress Graph
The Defects - Progress Graph shows the accumulation of defects in a 
Quality Center project, or the estimated/actual amount of time taken to fix 
these defects, at specific points during a period of time. The information is 
displayed according to the criteria that you specify. You can specify the time 
interval displayed along the x-axis, the defect information by which 
Quality Center groups the data, and the data displayed along the y-axis. You 
can also specify whether you want to view the number of defects or the 
change in the number of defects. 

For example, choose Status from the Grouped by list to group the displayed 
defects according to their status. Under Data Type, select Count to view the 
number of defects along the y-axis, as opposed to the estimated/actual 
amount of time taken to fix the defects. Under Period, select Last 5 weeks to 
display this interval along the x-axis. (Note that the graph displays data 
measured on the last day of each week.) Under Display Options, select 
Changes Over Time to view the changes in the number of defects over time, 
as opposed to the number of defects.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

The Defects - Progress Graph can be viewed as a line chart only.
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Defects - Age Graph
The Defects - Age Graph shows the lifetime of defects in a Quality Center 
project. The lifetime of a defect begins when it is reported, and ends when it 
is closed. The information in this graph is displayed according to the criteria 
that you specify. You can specify the defect information by which 
Quality Center groups the data, and the data displayed along the y-axis. You 
can also specify the time interval that you want to use to divide the data, if 
you want to view graph content in two data columns. 

For example, choose Status from the Grouped by list to group the displayed 
defects according to their status. Under Data Type, select Count to view the 
number of defects along the y-axis, as opposed to the estimated/actual 
amount of time taken to fix the defects. Under Age Grouping, select No 
Grouping to display all of the available age groupings. Click the Generate 
button to refresh the graph display.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

Note that the age of a “Closed” defect is the difference between the date on 
which it was reported and the date on which it was closed. After a defect is 
closed, its age is fixed.

The Defects - Age Graph can be viewed as a bar chart only.
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Defects - Trend Graph
The Defects - Trend Graph shows the history of changes to specific defect 
fields in a Quality Center project, for each time interval displayed. You 
specify the field for which you want to view the number of changes, and the 
time period for which you want to view data. 

For example, choose Priority from the Count Changes in Field list to display 
the number of changes made to the “Priority” defect field. Under Period, 
select Last 5 weeks to display this time period along the x-axis. (Note that 
the graph displays a sum of the data measured for each week.) Click the 
Generate button to refresh the graph display.

For more information on configuring the graph, see “Configuring Graphs” 
on page 578. 

Note that each priority change is only recorded once for the purpose of this 
graph. For example, if a field was changed from “Urgent” to “Very High” to 
“Urgent”, the “Urgent” priority change will only be recorded once in this 
graph.

The Defects - Trend Graph can be viewed as a bar chart only.
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Generating Standard Reports 

Standard reports offer you a variety of report types that list data from 
Quality Center modules.

This chapter includes:

 ➤  About Generating Standard Reports on page 607

 ➤  Creating Quick Standard Reports on page 608

 ➤  Creating Standard Reports in the Dashboard Module on page 612

 ➤  Configuring Standard Reports on page 615

 ➤  Adding Sub-Reports on page 617

 ➤  Viewing Standard Reports on page 620

About Generating Standard Reports

Standard reports help you monitor requirements and test coverage, the test 
plan, test runs, and defect tracking.

You create standard reports either in the Dashboard module, or during your 
work in the Requirements, Test Plan, Test Lab, or Defects modules. In either 
case, you can save the standard reports in the Dashboard module for future 
reference.

When you create standard reports in the Requirements, Test Plan, Test Lab, 
or Defects modules, you can choose from a variety of predefined reports. 
You can also create reports on selected records for immediate display.
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Standard reports that you create in the Dashboard module allow you to 
define the data that the report includes. You can also add sub-reports, that 
add extra layers of related data.

Notes:

➤ You can create Excel reports that extract data by running SQL queries. For 
more information, see Chapter 43, “Generating Excel Reports.”

➤ You can export grid data as a text file, Microsoft Excel spreadsheet, 
Microsoft Word document, or HTML document. You export data from 
the Requirements Grid, Test Grid, Execution Grid, or Defects Grid. For 
more information, see “Exporting Data to a File” on page 74.

Creating Quick Standard Reports

Quick reports are reports that display data in the Requirements, Test Plan, 
Test Lab and Defects modules. You can use quick reports for one-time 
reference, or save them in the Dashboard module, where you can continue 
to configure their data and appearance.

When you create quick reports, you can choose from a list of predefined 
reports, or you can generate a report of selected data. For more information 
on predefined report types, see “Available Predefined Reports” on page 610.

To create a quick standard report:

 1 Select the Quality Center module in which you want to create a report.

 2 To create a predefined report, choose Analysis > Reports, and select the type 
of report you want to create.
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 3 To create a quick report of selected records:

 a Select the requirements, tests, or defects that you want to include in the 
report. To include more than one record, hold down the CTRL key and 
select the records.

 b Choose Analysis >Reports > Report Selected. Alternatively, right-click the 
records and choose Report Selected. The report opens and displays data 
from the selected records.

In the Requirements module, to create a quick report for a requirement 
and its children, choose Analysis > Report Selected with Children. 
Alternatively, right-click the requirement and choose Report Selected 
with Children. The report opens with data from the selected requirement 
and its children.

 4 Use the buttons in the report toolbar to adjust the report view. For more 
information, see “Viewing Standard Reports” on page 620.

 5 To save the report in the Dashboard module, click Save. The New Standard 
Report dialog box opens.

 6 Under Standard Report Name, type a name for the new report.

 7 Under Select Folder, select the folder in the Analysis tree in which to save 
the report, or click New Folder to create a new folder. For more information 
on folders in the analysis tree, see “Developing the Analysis and Dashboard 
Trees” on page 559.

 8 Click Save. The Dashboard module opens in the Analysis View, and the 
report opens under the View tab.

 9 After you save the report, you can configure the report content, and adjust 
its viewing settings. For more information, see “Configuring Standard 
Reports” on page 615.
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Available Predefined Reports
You can select predefined reports from the Requirements, Test Plan, Test 
Lab, and Defects modules.

Requirements Module Reports

The following reports are available for the Requirements module:

Test Plan Module Reports

The following reports are available for the Test Plan module:

Report Description

Standard Requirement 
Report

Lists the requirements that appear in the current 
requirements view.

Tabular Report Displays the requirements that appear in the current 
requirements view, in a grid format. 

Requirements with 
Coverage Tests

Lists the requirements that appear in the current 
requirements view, with their test coverage 
information. 

Requirements with 
Coverage Tests and 
Steps

Lists the requirements that appear in the current 
requirements view, with their test coverage 
information. It also displays the test steps for each 
tests coverage. 

Requirements with 
Linked Defects

Lists the requirements that appear in the current 
requirements view, with their linked defects. 

Requirements with 
Traceability

Lists the requirements that appear in the current 
requirements view, with their associated traced to and 
traced from requirements. 

Report Description

Standard Test Planning 
Report

Lists the tests in the current test plan view.

Subject Tree Report Lists the tests in the current test plan view by subject.
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Test Lab Module Reports

The following reports are available for the Test Lab module:

Tests with Design Steps Lists the tests that appear in the current test plan view, 
including their design steps.

Tests with Covered 
Requirements

Lists the tests that appear in the current test plan view, 
with their requirement coverage information. 

Tests with Linked 
Defects

Lists the tests that appear in the current test plan view, 
with their linked defects.

Report Description

Current Test Set Lists the tests that appear in the current test set.

Cross Test Set Lists the tests that appear in the Test Sets list, without 
listing their tests.

Test Set Hierarchy with 
Tests

Lists the test sets hierarchically, as well as the status of 
each of the test sets.

Cross Test Set with 
Tests

Lists the test sets that appear in the Test Sets list, 
including their tests.

Current Test Set with 
Failed Test Runs

Lists tests from the current test set, with “Failed” test 
run status.

Cross Test Set with 
Failed Test Runs

Lists tests from all test sets, with “Failed” test run 
status.

Execution Notification Lists the tests that are displayed in the current test set 
with the results of their last test run.

Report Description
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Defects Module Reports

The following reports are available for the Defects module:

Creating Standard Reports in the Dashboard Module

You create standard reports in the Dashboard module, that display data 
from the Requirements, Test Plan, Test Lab, and Defects modules.

Note: You can also create standard reports from the Requirements, Test Plan, 
Test Lab, and Defects modules. For more informations, see “Creating Quick 
Standard Reports” on page 608.

Report Description

Standard Defect Report Lists the defects that appear in the defects grid.

Tabular Report Displays the defects that appear in the defects grid, in 
a grid format.

Defects with Linked 
Tests and Runs

Lists the defects with their linked tests and test run 
results.

Fixed or Rejected 
Defects

Lists defects with “fixed” or “rejected” status.

Fixed or Rejected 
Defects Detected by 
Current User

Lists defects with “fixed” or “rejected” status that were 
detected by the current user.

Opened Defects 
Assigned to Current 
User

List defects with “open” status that are assigned to the 
current user.
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To create a standard report in the Dashboard module:

 1 In the Dashboard module, click the Analysis View tab.

 2 In the analysis tree, select the folder under which you want to add the 
report. For more information on creating folders in the analysis tree, see 
“Developing the Analysis and Dashboard Trees” on page 559.

 3 Click the New Item button, and select New Standard Report. The New 
Standard Report dialog box opens.

 4 Under Entity, select the data set for which you want to create a report.

 5 Under Standard Report Type, select the type of report you want to create. 
For more information on the available report types, see “Available Report 
Types” on page 614.

 6 Under Standard Report Name, type a name for the report.

 7 Click OK. The report is added to the analysis tree.

 8 Click the Details tab. The Details tab displays the following fields:

Field Description

Entity Indicates the data set sampled by the report.

Type Indicates the analysis item type.

Sub Type Indicates the report type.

Name The name of the report.

Modified Indicates the date and time on which the report was 
last modified.
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 9 You can configure the report content, and adjust its viewing settings. For 
more information, see “Configuring Standard Reports” on page 615.

 10 To view the report, click the Generate button, or click the View tab. For 
more information, see “Viewing Standard Reports” on page 620.

Available Report Types
When you create standard reports in the Dashboard module, you select one 
of the available report types. Different report types are available for each 
data entity.

Modified By Indicates the user that last modified the report.

Owner Indicates the user that created the report. Permissions 
to modify public reports may be limited to the owner 
only.

Description A description of the report.

Report Description

Requirements Report Lists the requirements in the Requirements module.

Subject Test Report Lists the hierarchy of test subjects in the Test Plan 
module.

Test Plan Report Lists the tests in the Test Plan module.

Cross Test Set Report Lists the tests sets that appear in the Test Lab module, 
without listing their tests.

Execution Report Lists the test instances with their testing status.

Test Set Hierarchy 
Report

Lists the hierarchy of test set folders in the Test Lab 
module.

Defects Report Lists the defects in the Defects module.

Field Description
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Configuring Standard Reports

You can determine the appearance and contents of your Quality Center 
reports. You can set the configuration of the main report and each of its sub-
reports separately.

To configure a standard report:

 1 In the analysis tree, select a report.

 2 Click the Configuration tab.

 3 Under Page, you can set the number of items from the main report that 
display per page:

➤ To limit the number of items per page, select Limit items per page to and 
specify the number of items per page.

➤ To display all items in one page, select All items in one page.

 4 Under Template, you can use the Quality Center default report template or 
your own template.
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 5 To add a sub-report, click the Add Sub-Report button. For more information 
on sub-reports, see “Adding Sub-Reports” on page 617.

 6 In tree to the left side of the tab, select the main report or a sub-report that 
you want to configure.

 7 Under Filter, you can define or clear filters and sorting priorities:

➤ Click the Set Filter/Sort button to filter and sort your data according to 
the criteria you choose.

➤ Click the Clear Filter/Sort button to clear all filters and sorting priorities.

For more information, see Chapter 3, “Working with Quality Center Data.”

 8 Under Fields, you can set the fields you want to appear in the report and 
their order.

➤ Select All Fields (auto-layout) to display all fields in the report.

➤ Select Custom Fields (layout), and click the Select Fields button to choose 
the fields and set their order. For more information, see “Arranging 
Columns” on page 52.

 9 Under Options, select the following options, depending on the report type.

Option Description

Attachments Displays a list of associated attachments.

Grid View Displays the report as a grid.

History Displays a list of all the changes made to a 
requirement, test, or defect.

Keep Parent-Child 
Order

Displays the requirement topic with the child 
requirement below it. Selecting this option deactivates 
your defined filters and sorting priorities. 

Rich Text Includes rich text for the requirements in the report.

Show Full Coverage Displays the tests coverage for each requirement in the 
tree. 
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 10 Click the View tab to generate a report with the updated settings. For more 
information on viewing reports, see “Viewing Standard Reports” on 
page 620.

Adding Sub-Reports

After you create a report, you can add sub-reports. A sub-report adds an extra 
layer of information related to the parent report. For example, if you create a 
report of defects, you can add a sub-report of linked requirements. The 
report then displays the requirements that are linked to each defect. For 
more information on available sub-report types, see “Available Sub-Reports” 
on page 619.

Show Paragraph 
Number

Displays the assigned hierarchical numbers to each 
requirement in the tree. Note that the numbers are not 
related to the unique Req ID assigned to each 
requirement. 

Show Steps only for 
“Failed” Runs

If you add a Run Steps sub-report, the steps are listed 
only for Failed runs.

Option Description
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To each sub-report you can add further sub-reports. At each level you can 
include multiple sub-reports.

For an overview of standard reports, see Chapter 42, “Generating Standard 
Reports.”

To add a sub-report:

 1 In the analysis tree, select a report, and click the Configuration tab.

 2 In the Reports pane, select the report or sub-report to which you want to 
add a sub-report.

 3 Click the Add Sub Report button. In the Type list, select a sub-report and 
click OK. Alternatively, right-click the report, and select a sub-report from 
the Add Sub Report list. The sub-report is added to the Reports list.

 4 To delete a sub-report, select the sub-report, and click the Delete Sub Report 
button. Alternatively, right-click the report, and select Delete Sub Report. If 
you delete a parent report, all its sub-reports are deleted as well.
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Available Sub-Reports
The available sub-reports depend on the type of the parent report.

The following sub-reports may be available:

Report Description

Contained Test Sets Lists the test sets in a test set folder.

Contained Tests Lists the test instances in a test set.

Coverage Requirements Lists information for requirements covered by a test.

Design Steps Lists the design steps for a test.

Linked Defects Lists the defects that are linked to a record.

Linked Entities List all entities that are linked to a defect.

Parent Test Lists the parent test instance of a test run.

Related Requirements Lists the requirements that are linked to a defect.

Requirements Coverage Lists the tests that cover a requirement.

Run Steps Lists the run steps for a test run.

Runs Lists all runs of a test instance.

Source Execution Test Lists the executed test instances that are linked to a 
defect.

Source Run Lists the test runs that are linked to a defect.

Source Test Lists the tests that are linked to a defect.

Trace To Lists the requirements traced to a requirement.

Trace From Lists the requirements traced from a requirement.
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Viewing Standard Reports

You can view, print, and save your Quality Center reports.

To view a standard report:

 1 Select a report:

➤ In the analysis tree, select a report, and click the View tab.

➤ Select either the Requirements, Test Plan, Test Lab, or Defects module, 
choose Analysis > Recently Used, and select a report.

 2 To refresh the report so that it displays the most recent data, click the 
Generate button.

 3 To view the report in full-screen mode, click the Full Screen view button. 
The View toolbar remains visible in full-screen mode.

To exit the full-screen mode, click the Close button.

 4 Click the First Page button to display the first page of the report, or the 
Previous Page button to display the preceding page.
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 5 Click the Next Page button to display the next page of the report, or the 
Last Page button to display the final page.

 6 To print your report, click the Print arrow and choose Current Page or 
All Pages. The Print dialog box opens. Change the printer settings, if 
necessary. Click Print.

 7 To save your report as a Web page or text file, click the Save arrow and 
choose Current Page or All Pages. The Save Web Page dialog box opens. 
Change the file name if necessary. To save the report in its original format, 
select Web Page, complete in the Save as type list. To save it as a text file, 
select Text File and click Save.
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43
Generating Excel Reports

You can generate Excel reports that enable you to export Quality Center 
data to Microsoft Excel, and analyze the data in Excel.

Note: To verify supported versions of Microsoft Excel, refer to the 
HP Quality Center Installation Guide.

This chapter includes:

 ➤  About Generating Excel Reports on page 624

 ➤  Creating Excel Reports on page 625

 ➤  Creating SQL Queries on page 626

 ➤  Adding Parameters to SQL Queries on page 630

 ➤  Creating Post-Processing Scripts on page 634

 ➤  Running Excel Reports on page 635
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About Generating Excel Reports

You can export Quality Center data to Microsoft Excel. This enables you to 
analyze your data using any of the capabilities available in Excel. An Excel 
report consists of a set of data defined by SQL queries on the project 
database. You can also run a Visual Basic script on the extracted data to 
process and analyze the data.

For example, you could create a pivot table to summarize Defects module 
data, such as to display in tabular format the number of defects assigned to 
different users with different statuses.

You can also create a report with parameters. This enables you to create a 
more flexible report that you only need to create once but can be used in a 
number of different contexts. 

Tip: The Quality Center Demo Project contains sample Excel reports. You 
can use the SQL queries and Visual Scripts in those reports as a basis for 
developing your own queries and scripts.

Note: Users who belong to groups that have data-hiding filters, are able to 
access the restricted data through Excel reports. To overcome this, you can 
exclude user groups from performing Excel report tasks. For more 
information on user groups and permissions, refer to the HP Quality Center 
Administrator Guide.
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Creating Excel Reports

You create Excel reports in the Dashboard module.

To create an Excel report:

 1 In the Dashboard module, click the Analysis View tab.

 2 In the analysis tree, select the folder under which you want to add the Excel 
report. For more information on managing folders in the analysis tree, see 
“Developing the Analysis and Dashboard Trees” on page 559.

 3 Click the New Item button, and select New Excel Report. The New Excel 
Report dialog box opens.

 4 Under Excel Report Name, type a name for the Excel report.

 5 Click OK. The Excel report is added to the analysis tree.

 6 Click the Details tab. The Details tab displays the following fields:

 7 Create one or more SQL queries to define the data that is extracted. For more 
information, see “Creating SQL Queries” on page 626.

Field Description

Entity In Excel reports, this field displays Unspecified Entity.

Type Indicates the analysis item type.

Sub Type In Excel reports, same as Type.

Name The name of the Excel report.

Modified Indicates the date and time on which the Excel report was 
last modified.

Modified By Indicates the user that last modified the Excel report.

Owner Indicates the user that created the Excel report. 
Permissions to modify public Excel reports may be limited 
to the owner only.

Description A description of the Excel report.
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 8 Optionally, create a post-processing script that runs in Excel after the data is 
exported. For more information, see “Creating Post-Processing Scripts” on 
page 634.

 9 Export the data to Excel. For more information, see “Running Excel Reports” 
on page 635.

Creating SQL Queries

After you have added an Excel report in the Dashboard module, you define 
which project data you want to include in the report. You define this data by 
creating SQL queries. You can create multiple queries in an Excel report. 
When you generate the report, the results of each query are displayed in 
separate Excel worksheets.

This section includes:

➤ Protecting the Database

➤ Creating an SQL Query

Protecting the Database
To ensure the integrity of the database, you should run only queries that 
extract data from the project database. You should not run queries that alter 
the project database by adding, modifying, or deleting database records.

By default, to ensure that your queries are valid and do not alter the project 
database, Quality Center checks that the following conditions are fulfilled:

➤ The query starts with the command SELECT.

➤ The query contains only one SQL statement.
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➤ The query does not contain any of the following commands (except in 
comments): INSERT, DELETE, UPDATE, DROP, CREATE, COMMIT, ROLLBACK, 
ALTER, EXEC, EXECUTE, MERGE, GRANT, REVOKE, SET, INTO, or TRUNCATE.

You can customize whether this verification is performed, and how it is 
performed, using the SQL_QUERY_VALIDATION_ENABLED and 
SQL_QUERY_VALIDATION_BLACK_LIST parameters in Site Administration. 
For more information, see the HP Quality Center Administrator Guide.

Creating an SQL Query
You create an SQL query in the Query tab, or in the Query Builder. You can 
write the SQL query manually directly in the Query tab. To take project 
entities from a list, and to define or add parameters to your query, use the 
Query Builder.

To create an SQL query:

 1 In the analysis tree, select an Excel report.

 2 Click the Configuration tab, and then click the Query tab.

Write the SQL query in the Query tab, or perform the following steps to 
write the SQL query using the Query Builder.
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 3 Click the Query Builder button. The Excel Reports Query Builder dialog box 
opens. 

The query builder consists of the following panes and tabs:

➤ SQL pane. Contains the SQL statements for the queries in the report.

➤ Query Parameters tab. Contains a list of parameters for the query.

➤ Query Results tab. Contains the results of tests of the query.

➤ Entities pane. Contains a list of Quality Center database fields and 
entities that you can add to the query. You can view fields and entities by 
their name, their database column name, or by both. To change the view, 
click the Entities View button and select a view.

 4 You must write the SQL query using the SQL type used by the project 
database. To view the type of database used for your project database, click 
the Database Type button.

SQL pane

Entities pane
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 5 To add a new query, click the Add Query button. A new tab is added to the 
query builder with the default name Query<number>.

 6 In the SQL pane, type an SQL query to define the data set you want to use 
for your report.

Note: The @ and \ characters have a special meaning and are not read 
literally when running SQL queries on the project database. If you want 
these characters to be read literally, you should replace @ by \@ and \ by \\. 
For example, if you want the statement 
SELECT * FROM BUG WHERE BUG.BG_SUMMARY = ‘@parameter@’ 
to be run literally on the Quality Center database, type 
SELECT * FROM BUG WHERE BUG.BG_SUMMARY = ‘\@parameter\@’.

 7 You can add a project entity to your SQL query. The following options are 
available:

➤ To add a project entity without a column alias, double-click an entity in 
the Entities pane, or select an entity and click the Add Entity to Query 
button. 

➤ To add a project entity with the column alias defined by the entity title, 
select the entity you want to add. Click the Add Entity to Query arrow 
and choose Add Entity to Query with Entity Title as Alias.

The entity is added to your SQL query at the current cursor location. 
Separate multiple project entities with a comma.

 8 You can add parameters to your SQL query. For more information, see 
“Adding Parameters to SQL Queries” on page 630.
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 9 You can test the query and view the results of the test in the Query Results 
tab. You can choose to view all the results of the query or only the first ten 
records:

➤ Click Run Query to view all the results of the query in the Query Results 
tab. If your query contains parameters, you are prompted to type a value 
for each parameter, or confirm the default value.

➤ Click Test Query to display only the first ten records from the results of 
the query. If your query contains parameters, Quality Center uses the 
default values for the parameters.

 10 You can search for text in your query. To search for text, type the string you 
want to search for in the Find box and click the Find button.

 11 You can rename a query. To rename a query, select the query and click the 
Rename button. In the Rename query dialog box, type the new name and 
click OK. The Excel worksheet containing the data extracted by the query 
will have the same name as the query.

 12 To delete a query, select the query and click the Delete button. Alternatively, 
right-click the query and choose Delete. Click Yes to confirm.

Adding Parameters to SQL Queries

You can include parameters in the SQL queries for your Excel reports. For 
each query parameter, you can assign a default value. When you generate 
the report, you are prompted to enter the value of the parameter, or confirm 
the default value. Alternatively, you can choose to always use the default 
value, without being prompted by Quality Center each time you generate 
the report.

For example, suppose you want to create a report that displays a graph of 
the number of requirements added to your project over a period of time. 
You might want to run the report several times, each time for a different 
period of time. You can avoid the need to create multiple reports by creating 
a single report with query parameters for the start date and end date of the 
period. Each time you generate the report, you are prompted to enter the 
start and end dates for the period.
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You first add query parameters to the Parameters list. You can add global 
parameters that are accessible to all queries in a report, or you can add 
parameters that can only be used in particular queries. After you add 
parameters to the Parameters list, you insert parameters into the query.

Important: 

➤ You cannot use parameters for SQL identifiers, such as a table name or a 
column name.

➤ Parameter values cannot include an SQL statement.

Adding Query Parameters to the Parameters List
Before you can add a parameter to a query, you must add it to the 
Parameters list.

To add a parameter to the Parameters list:

 1 In the analysis tree, select an Excel report.

 2 Under the Configuration tab, click the Query tab, and then click the Query 
Builder button.
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 3 In the Query Parameters tab, click the New Query Parameter button. The 
New Query Parameter dialog box opens.

 4 In the Parameter Name box, type a name for the parameter. A parameter 
name cannot include the following character: @

 5 In the Default Value box, type a default value for the parameter. 

Select Hide On Run to use the default value every time you generate the 
report. Do not select this option if you want Quality Center to prompt you 
to confirm or change the default value when you generate the report.

 6 Select Global Parameter to make the parameter available in all queries in 
your report. If you do not select this option, the parameter is only available 
in the current query.

 7 In the Description box, type a description for the parameter.

 8 Click OK. The parameter is added to the Parameters list and the dialog box 
closes.
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 9 To delete a parameter from the Parameters list, in the Query Parameters tab, 
select the parameter and click Delete. Click Yes to confirm.

Important: If you delete a parameter that is in use in a report query, queries 
containing the parameter will not be valid.

 10 To edit a parameter in the Parameters list, select the parameter and click Edit 
Parameter. In the Edit Parameter dialog box, edit the parameter settings and 
click OK.

Adding a Parameter to an SQL Query
After you have added a parameter to the Parameters list, you can add it to 
your SQL query.

To add a parameter to an SQL query:

 1 In the analysis tree, select an Excel report.

 2 Under the Configuration tab, click the Query tab, and then click the Query 
Builder button.

 3 In the SQL pane, place the cursor in the location that you want to add the 
parameter.

 4 In the Query Parameters tab, select a parameter from the Parameters list, 
and click the Add Parameter to Query button. Alternatively, drag the 
parameter to the query pane. The parameter is added to the query.

Note: For a parameter representing a text value, you must manually add 
single quotes (') around the parameter in the SQL pane. For example, if the 
SQL pane contains the phrase WHERE BUG.BG_DETECTED_BY = 
@name@, you must replace the text @name@ with '@name@'.
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Creating Post-Processing Scripts

You can create a Visual Basic script to run after the data is exported to Excel. 
You use this script to manipulate the data in Excel. For example, you can 
present requirements data in Excel as a pivot table, you could perform 
calculations on defects data to calculate the average time an open defect 
takes to be fixed, or you could create a graph based on exported data.

Guidelines for Creating a Post-Processing Script

When writing the post-processing script, consider the following guidelines:

➤ Before you run a post-processing script, you must configure your Microsoft 
Excel security settings so that Excel can run the script. In Excel, choose Tools 
> Macro > Security. The Security dialog box opens. In the Security Level tab, 
select Low. In the Trusted Publishers tab, select Trust access to Visual Basic 
Project. Close Excel.

➤ Your post-processing script must contain a sub-procedure named 
QC_PostProcessing. This procedure serves as the entry point to your script. 
This procedure cannot return a value and cannot take any arguments.

➤ Before you can work with the report data in Excel, you must first define the 
range containing the report data. You define this range in two steps: 

➤ You first define the worksheet containing the report data by creating a 
worksheet object containing the data. For example, if the worksheet is 
named Query1, you can use the statement Set MainWorksheet = 
ActiveWorkbook.Worksheets(“Query1”).

➤ After you define the worksheet containing the report data, you define the 
range containing the data by creating a range object containing the data. 
For example, you if defined the worksheet object with name 
MainWorksheet, you can use the statement Set DataRange = 
MainWorksheet.UsedRange. 

After you define this range, you can manipulate the data contained in it 
using Visual Basic code.
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Creating a Post-Processing Script

You create a post-processing script in the Post-processing tab.

To create a post-processing script:

 1 In the analysis tree, select an Excel report.

 2 Under the Configuration tab, click the Post-processing tab.

 3 In the script editor box, type the Visual Basic script you want to run after the 
data defined in your query is exported to Excel. You should base this script 
on the template script already displayed in the Script Editor box. For further 
guidelines for creating a post-processing script, see “Guidelines for Creating 
a Post-Processing Script” above.

 4 To run the post-processing script after the data is exported to Excel, select 
Run post-processing. If you do not select this option, the script is not run 
when you generate the report.

 5 You can search for text in your post-processing script. To search for text, 
type the string you want to search for in the Find box and click the Find 
button.

Running Excel Reports

After you have configured your report, you can run it. Running the report 
extracts the data you specified in the SQL queries from the project database, 
saves the data in an Excel workbook, and runs the post-processing script.

To run an Excel report:

 1 In the analysis tree, select an Excel report.
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 2 Under the Configuration tab, click the Generation Settings tab.

 3 To instruct Quality Center to open the report in Excel after it is generated, 
select Launch report in Excel.

 4 In the Status box, select the status of your report. The report status informs 
other users whether the report is ready to be generated. The following 
options are available for the report status:

➤ Ready. Indicates that the report is ready to be generated. 

➤ Not Ready. Indicates that the report is not ready to be generated. If a user 
tries to generate a report with this status, a warning message displays.

 5 In the Save report as target file box, type the location and name of the 
Excel file to which you want the data to be exported. Click the browse 
button to select a location from the Save Report dialog box.

 6 Click the Generate button to generate the report.

➤ If the status of the report is Not Ready, a warning displays. Click Yes to 
generate the report despite the warning.

➤ If the report query contains parameters, the Report Parameters dialog box 
opens. Type the parameter values in the Value column and click OK.

The report is saved in the location you define. If you selected Launch report 
in Excel, Excel opens and displays the report. If not, a confirmation message 
displays.
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44 
Generating Live Analysis Graphs

Live Analysis graphs enable you to create and display a dynamic graphical 
representation of data related to test plans and test sets. You use Live 
Analysis graphs to view data that relates to a test subject folder or test set 
folder. Each time that you click on a test subject folder or test set folder, the 
graphs change to reflect the data related to your selection.

This chapter includes:

 ➤  About Generating Live Analysis Graphs on page 637

 ➤  Creating Live Analysis Graphs on page 638

 ➤  Deleting Live Analysis Graphs on page 644

 ➤  Setting the Graph Appearance on page 645

About Generating Live Analysis Graphs

You create Live Analysis graphs to provide a dynamic quick visual overview 
of all the tests in a folder, or test sets in a test set folder. After you have 
created a graph, you can access it by choosing the Live Analysis tab when 
you are in the tree view of the Test Plan or Test Lab modules.

When you update a record in the folder, the data change is reflected in the 
graph, without the need for the graph to be manually regenerated.

Live Analysis graphs differ from the graphs described in Chapter 41, 
“Generating Graphs”, in that you do not have to recreate a graph to view 
data that has changed. In addition, the layout and settings of the graph are 
preserved when you select another folder in the same module. This enables 
you to view the same graphical analysis of different folders without the need 
to recreate the graphs.
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Creating Live Analysis Graphs

You can create Live Analysis graphs for test subject folders and test set 
folders. For more information on creating Live Analysis graphs for test 
subject folders, see “Creating Test Subject Folder Graphs” on page 638. For 
more information on creating Live Analysis graphs for test set folders, see 
“Creating Test Set Folder Graphs” on page 641.

Note: The Live Analysis graphs that you create are unique for your user 
login. Each project user can create Live Analysis graphs which will be visible 
only to that user but will not be visible to other users.

Creating Test Subject Folder Graphs
In the Live Analysis tab, you can create Live Analysis graphs for tests in your 
test subject folders. After you define the data that you want to display, the 
graphs are automatically updated each time the data changes in one or more 
of the tests in the test subject folder for which you created the graph.

Note: Live Analysis graphs only represent tests which are located directly 
below the selected test subject folder. They do not include tests located at a 
lower hierarchical level in child folders of the selected test subject folder.

To create a test subject folder graph:

 1 Click the Test Plan button on the sidebar to display the Test Plan module.

 2 Choose View > Test Plan Tree. The test plan tree view is displayed.

 3 In the test plan tree, select a test subject folder.

 4 Click the Live Analysis tab. The Live Analysis tab is divided into two panes, 
each of which can display a graph. 

 5 If you already have two graphs displayed and you want to create a new 
graph, delete one of the existing graphs. For more information, see 
“Deleting Live Analysis Graphs” on page 644.
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 6 Click the Add Graph link in the pane in which you want to display the 
graph. Alternatively, choose Analysis > Live Analysis > Add Graph. The 
Graph Wizard: Test Plan Module dialog box opens.

 7 Under Graph type, select the type of graph that you want to display. You 
can generate the following graphs from the Test Plan module:

 8 Click Next. In the Group By box, select the field by which you want the tests 
to be grouped in the graph. For progress and trend graphs, you can only 
select a field for which history has been enabled. For more information on 
enabling history for a field, refer to the HP Quality Center Administrator Guide

 9 If you chose to create a summary graph, click Next. In the X-Axis box, select 
the field that you want to use for the X-axis. 

Graph Description

Summary Graph Shows how many tests are currently in the selected test 
subject folder.

Progress Graph Shows how many tests accumulated in the selected test 
subject folder, at specific points during a period of time.

Trend Graph Shows the history of changes to specific Test Plan fields in 
the selected test subject folder, for each time interval 
displayed. 
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 10 Click Finish. The Live Analysis graph is displayed in the pane that you 
selected.

The graph properties that you specified are displayed at the top of the graph. 

Note: The data displayed in the graph reflects the filters that you have set 
for the test plan tree. For more information on filtering, see “Filtering 
Records” on page 56.

 11 Click the Full Screen View button to maximize the graph. To return to the 
normal view, click the Close button.
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 12 To further analyze your data, click a segment in the graph. The Drill Down 
Results dialog box opens and displays a grid with more details. You can 
determine the column appearance and order. You can also export the 
contents of a grid as a text file, Microsoft Excel spreadsheet, Microsoft Word 
document, or HTML document. For more information, see “Exporting Data 
to a File” on page 74. 

 13 To change the color of a bar in a bar graph or a line in a line graph, right-
click the bar or line, or click the corresponding entry in the graph legend. In 
the Color dialog box that opens, select the new color from one of the color 
palettes.

 14 Click the Set Graph Appearance button to customize the graph title, graph 
color, and graph display. For more graph appearance options, see “Setting 
the Graph Appearance” on page 645.

Creating Test Set Folder Graphs
In the Live Analysis tab, you can create Live Analysis graphs for the test sets 
in your test set folders. After you define the data that you want to display, 
the graphs are automatically updated each time the data changes in one or 
more test sets in the folder for which you created the graph. 

Note: Live Analysis graphs only represent test sets which are located directly 
below the selected test set folder. They do not include test sets located at a 
lower hierarchical level in child folders of the selected test set folder.

To create a test set folder graph:

 1 Click the Test Lab button on the sidebar to display the Test Lab module.

 2 Choose View > Test Sets Tree. The Test Sets Tree view is displayed.

 3 In the test sets tree, select a test set folder.

 4 Click the Live Analysis tab. The Live Analysis tab is divided into two panes, 
each of which can display a graph. 
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 5 If you already have two graphs displayed and you want to create a new 
graph, delete one of the existing graphs. For more information, see 
“Deleting Live Analysis Graphs” on page 644.

 6 Click the Add Graph link in the pane in which you want to display the 
graph. Alternatively, choose Analysis > Live Analysis > Add Graph. The 
Graph Wizard: Test Lab Module dialog box opens.

 7 Under Graph type, select the type of graph that you want to display. You 
can generate the following graphs from the Test Lab module:

Click Next.

Graph Description

Summary Graph Shows how many tests belong to the test sets in the 
selected folder. 

Progress Graph Shows how many tests accumulated in the test sets in the 
selected folders, at specific points during a period of time.
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 8 In the Group By box, select the field by which you want the tests to be 
grouped in the graph. For a progress graph, you can only select a field for 
which history has been enabled. For more information on enabling history 
for a field, refer to the HP Quality Center Administrator Guide.

 9 If you chose to create a summary graph, click Next. In the X-Axis box, select 
the field that you want to use for the X-axis.

 10 Click Finish. The Live Analysis graph is displayed in the pane that you 
selected.

The graph properties that you specified are displayed at the top of the graph. 
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Note: The data displayed in the graph reflects the filters that you have set 
for the test sets tree. For more information on filtering, see “Filtering 
Records” on page 56.

 11 Click the Full Screen View button to maximize the graph. To return to the 
normal view, click the Close button.

 12 To further analyze your data, click a segment in the graph. The Drill Down 
Results dialog box opens and displays a grid with more details. You can 
determine the column appearance and order. You can also export the 
contents of a grid as a text file, Microsoft Excel spreadsheet, Microsoft Word 
document, or HTML document. For more information, see “Exporting Data 
to a File” on page 74.

 13 To change the color of a bar in a bar graph or a line in a line graph, right-
click the bar or line, or click the corresponding entry in the graph legend. In 
the Color dialog box that opens, select the new color from one of the color 
palettes.

 14 Click the Set Graph Appearance button to customize the graph title, graph 
color, and graph display. For more graph appearance options, see “Setting 
the Graph Appearance” on page 645.

Deleting Live Analysis Graphs

You can delete a Live Analysis graph. If you have two Live Analysis graphs 
displayed for a folder and you want to create a new graph, you must first 
delete one of the existing graphs.

To delete a Live Analysis graph:

 1 Click the Remove Graph button located at the top of the graph you want to 
delete. Alternatively, choose Analysis > Live Analysis > Remove Graph.

 2 Click Yes to confirm. The graph is deleted from the selected pane and the 
Add Graph link is displayed.
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Setting the Graph Appearance

After you have created your graph, you can change its titles and appearance. 
For a bar chart, you can specify the display parameters for the bars. For a line 
chart, you can specify the display parameters for the lines.

To set the graph appearance:

 1 Click the Set Graph Appearance button located at the top of the graph. 
Alternatively, choose Analysis > Live Analysis > Set Graph Appearance. The 
Graph Appearance dialog box opens and displays the General tab.

The General tab displays read-only information about the graph.

 2 Click the Titles tab to change the titles of the graph, the Y-axis, or the X-axis. 
You can click the Font button to change a title’s font, size, formatting, or 
color. You can click the Reset Titles button to reset the original titles.

 3 Click the Appearance tab to change the colors of the various components in 
your graph, to modify the orientation of the labels at the base of the graph, 
or to display the graph with a 3-D effect.
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 4 For a bar chart, click the Bar Parameters tab to specify whether you want the 
values for each bar to be displayed. You can also fix the bar width. If you 
specify that the values of each bar are to be displayed, you can change the 
data that is displayed for each bar, or its position relative to the bar. 

For a line chart, click the Line Parameters tab to specify whether you want 
the line frame to be displayed and which format you want to use for the 
date on the X-axis.
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45
Generating Project Documents

The Quality Center Document Generator enables you to create a Microsoft 
Word document containing a project’s requirements, planning, test list, test 
set folders, and defect tracking data.

Notes: 

➤ The Document Generator can only be run if Microsoft Word has been 
enabled to run macros. If you receive a security message while using the 
Document Generator, you must set the security level of Microsoft Word 
to medium or low. To do this, choose Tools > Macro > Security from the 
Word menu bar. On the Security Level tab, select the desired level of 
protection (Medium or Low), and click OK.

➤ To verify supported versions of Microsoft Word, refer to the 
HP Quality Center Installation Guide.

This chapter includes:

 ➤  About Using the Document Generator on page 648

 ➤  Launching the Document Generator on page 650

 ➤  Setting Formatting Instructions on page 651

 ➤  Specifying Project Data on page 657

 ➤  Generating a Project Document on page 681
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About Using the Document Generator

The Document Generator enables you to create a hard copy of the data 
contained in a Quality Center project. You create the document by 
performing the following tasks:

 1 Set document format.

 2 Specify document content.

 3 Generate and edit the document.

First, you set formatting instructions in order to determine how your project 
document will look. For example, you can print a company logo on each 
page of the document, create a table of contents and an index, and place test 
scripts and file attachments in the text of your document.

Next, you specify the project data that will be presented in your document. 
You can select information from the Quality Center modules. For example, 
from the Test Plan module, you can choose which folders and tests to 
include from the test plan tree, sort this data alphabetically or in a custom 
sort order, and display the data as lists or tables. 

After you have set the formatting instructions and specified the document’s 
content, you can save the document settings as a favorite view for future use 
and generate the document. After document generation is complete, you 
can view and edit the document in Microsoft Word. The information for 
each module that you select is printed in a separate chapter of the project 
document. 
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Below is a sample page from a Microsoft Word project document generated 
by the Document Generator. 
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Launching the Document Generator

To start the Document Generator, click the Tools button on the upper-left of 
the Quality Center window. Choose Document Generator. The Document 
Generator opens. 
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Setting Formatting Instructions

Before you can generate a document, you set formatting instructions that 
control how the document will look and what is included in the cover page.

To set formatting instructions:

 1 Open the Document Generator. By default, the Document link is selected in 
the Document Generator tree and the Document Settings tab is displayed.

 2 Type a Title for the document, Author details, and a Description of the 
document.
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 3 Click the Options tab. 

 4 Under Include with Document, you can select the following options to 
include in the project document:

Option Description

First page The cover page of the project document. This displays the 
title of the document, the date the document was created, 
and the name of the document’s author. You specify this 
information in the Document Settings tab.

Table of contents A list of all sections in the project document.

Index An alphabetical list of all the information in the project 
document. The index appears at the end of the document.
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 5 Under Attachment Placement Options, choose where attachments will 
appear in the document: 

 6 Under Attachment Embedding Options, choose whether the project 
document contains the data from attachments as a linked icon or as 
embedded text:

 7 Under Test Script Options, choose where test scripts will appear in the 
document:

 8 Under Graph Options, choose where graphs will appear in the document:

 9 Select Do not generate a paragraph if there is no corresponding project 
information if you do not want to include empty data fields in the project 
document.

Option Description

In text Displays attachments in the main text of the document.

In appendix Places attachments in a separate appendix.

Option Description

As icons Places a link to the attachment in the document as an 
icon.

As expanded text Adds the attachment to the document as expanded text.

Option Description

In text Displays test scripts in the main text of the document.

In appendix Places test scripts in a separate appendix.

Option Description

In text Displays graphs in the main text of the document.

In appendix Places graphs in a separate appendix.
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 10 To set the image that is placed at the top of each page of the project 
document, click the Logo tab.

You can define a logo for the project document, and save the image so that 
it is available for other users in the current project. If you do not select an 
image, the Document Generator uses the HP logo in the project document.

 11 Click the Load from File button. The Open dialog box opens. 

 12 Locate the image and click Open. The image is displayed in the Logo tab. To 
unload the image, click Unload.

 13 To save the displayed image in the current project, click the Save button. To 
delete the image, click the Remove Saved button. 

 14 To load a saved image that was cleared (using the Unload button), click the 
Load from Saved button.
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 15 To set paper properties, click the Customization tab and click the Page Setup 
button.
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The Page Setup dialog box opens.

 16 Set the measurement units, margins, orientation, and paper size to be used 
for project documents. Click OK to return to the Customization tab.
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Specifying Project Data 

Select a check box in the Document Generator tree to specify project data to 
include in your project document.

Check Box Description

Document Use the Document Settings, Options, Logo, and 
Customization tabs to set formatting instructions. For 
more information, see “Setting Formatting Instructions” 
on page 651. Note that this option is always selected.

Requirements Specify which requirements, traced requirements, tests 
coverage, and linked defects to include from the 
Requirements module. For more information, see 
“Specifying Requirements Module Data” on page 658.

Business 
Components

If you use HP Business Process Testing, refer to the HP 
Business Process Testing User Guide.

Test Plan Expand to specify which test subject folders and which 
tests to include from the Test Plan module. For more 
information, see “Specifying Test Plan Module Data from 
the Test Plan Tree View” on page 662 and “Specifying Test 
Plan Module Data from the Test Grid View” on page 666.

Select Subject Tree to specify which test subject folders to 
include from the Test Plan module.

Select Subject Tests to specify which tests to include from 
the selected folders.

Select Test List to specify which tests to include from the 
Test Grid.
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Specifying Requirements Module Data
You use the Requirements page to specify the requirement information from 
the Requirements module that should appear in the Requirements section of 
the project document.

Note: Microsoft Word is limited to nine header levels in the table of 
contents. If the requirements tree has more than nine hierarchical levels, 
these levels will not appear in the table of contents of the generated project 
document.

Test Lab Specify which test set folders to include from the Test Lab 
module. Expand to select which test sets, tests and test 
runs to include. For more information, see “Specifying 
Test Lab Module Data” on page 670.

Select Test Sets to specify which test sets to include.

Select Tests to specify which tests to include from the 
selected test sets.

Select Runs to specify which test runs to include from the 
selected tests in a test set.

Defects Specify which defects to include from the Defects module. 
For more information, see “Specifying Defects Module 
Data” on page 679.

Check Box Description
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To specify Requirements module data:

 1 Select the Requirements check box in the Document Generator tree and 
click the Requirements link. The Requirements page is displayed.

 2 Under Requirements, select one of the following options:

Option Description

All Includes all the requirements from the requirements tree.

By status Includes only requirements with the selected status.

Selected Includes only selected requirements. To include child 
requirements, click First Selected with Children. 

Click the Filter & Sort button to specify the criteria for 
selecting requirements. For more information on using 
the Filter dialog box, see Chapter 3, “Working with 
Quality Center Data.”



Chapter 45 • Generating Project Documents

660

 3 Under Requirements Layout, select one of the following options:

 4 If you selected Full page as the Requirements Layout, you can set the 
following options:

Option Description

Full page Displays a list of the selected requirements. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays the requirements as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the table. Use the Tabular Layout dialog box to 
choose the columns that will appear in the table, and set 
the column order, width, and captions.

Coverage Analysis Displays a graphical breakdown of the direct cover status 
for each requirement. Click the Customize button to open 
the Coverage Analysis dialog box to choose whether to 
display the analysis in color or black and white, the 
number of hierarchical levels to display, and whether to 
display a legend.

Option Description

Page break after 
each requirement

Inserts page breaks in the project document after each 
requirement.

Rich text Includes Microsoft Word content for each requirement.

Trace from Includes traced from requirements in the document. Click 
the Customize button to open the Tabular Layout dialog 
box to customize the traceability table. Use the Tabular 
Layout dialog box to choose the columns that will appear 
in the table, and set the column order, width, and 
captions.
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 5 To include graphs in the project document, select Graphs and select graphs 
from the graph list located at the bottom of the page. Only graphs that you 
saved as favorites are included in the list. For more information on favorite 
views, see Chapter 6, “Working with Favorite Views.”

Trace to Includes traced to requirements in the document. Click 
the Customize button to open the Tabular Layout dialog 
box to customize the traceability table. Use the Tabular 
Layout dialog box to choose the columns that will appear 
in the table, and set the column order, width, and 
captions.

Coverage Includes test coverage for the requirements in the 
document. Click the Customize button to open the 
Tabular Layout dialog box to customize the coverage 
table. Use the Tabular Layout dialog box to choose the 
columns that will appear in the table, and set the column 
order, width, and captions.

Attachments Includes requirement attachments in the document. 
Requirement attachments are files that have been 
associated with the requirement, such as text files, images, 
or URLs.

Linked defects Includes linked defects in the document. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the linked defects table. Use the Tabular 
Layout dialog box to choose the defect columns that will 
appear in the table, and to set the column order, width 
and captions. You can also specify whether to display only 
defects that have been directly linked to requirements or 
to include indirectly-linked defects as well.

Option Description
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Specifying Test Plan Module Data from the Test Plan Tree 
View
You use the Subject Tree and Subject Tests pages to specify the information 
from the test plan tree view of the Test Plan module that should appear in 
the project document.

Note: Microsoft Word is limited to nine header levels in the table of 
contents. If the test plan tree has more than nine hierarchical levels, these 
levels will not appear in the table of contents of the generated project 
document.

To specify Test Plan module data from the test plan tree view:

 1 Expand the Test Plan node in the Document Generator tree. Select the 
Subject Tree check box and click the Subject Tree link. The Subject Tree 
page is displayed.
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 2 Under Tree Sort, determine the order of the test plan tree information in the 
document:

 3 Under Folders, specify which test plan tree folders you want to include in 
the document:

 4 To include folder attachments in the document, select Attachments. Folder 
attachments are files that have been associated with the folder, such as text 
files, images, or URLs.

 5 To insert page breaks in the project document after each test subject folder, 
select Page break after each folder.

Option Description

Alphabetical The contents of the folders will be organized according to 
the alphabetical order of the folders in the test plan tree. 
For example, suppose the test plan tree contains two 
folders, Automated Tests and Manual Tests. The tests in 
the Automated Tests folder will be printed before the tests 
in the Manual Tests folder.

Custom The contents of the folders will be organized according to 
the custom sort order you set for displaying test plan tree 
folders. By default, subject folders in the test plan tree 
appear in alphabetical order (by name). For example, 
suppose the test plan tree contains two folders, 
Automated Tests and Manual Tests. You can create a sort 
order that prints the tests in the Manual Tests folder 
before the tests in the Automated Tests folder. For more 
information about creating a custom sort order for the test 
plan tree, see Chapter 18, “Developing the Test Plan Tree.”

Option Description

All Includes all the folders in the test plan tree.

Selected Includes only the folders you choose from the test plan 
tree. You select the folders from the test plan tree 
displayed on the right side of the Subject Tree page.
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 6 To include graphs in the document, select Graphs and select graphs from 
the list. Only graphs you saved as favorites are included in the list. For more 
information on favorite views, see Chapter 6, “Working with Favorite 
Views.”

 7 To include test data in the project document, expand the Subject Tree node 
in the Document Generator tree. Select the Subject Tests check box and 
click the Subject Tests link. The Subject Tests page is displayed.
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 8 Under Tests, specify which tests you want to include in the document:

 9 To include design steps from the test, select Design steps.

Under Layout, specify how design steps will be organized:

Under Properties, specify what to include from the design steps:

 10 To include test scripts in the document, select Test scripts.

Option Description

All tests Includes all the tests from the selected test plan tree 
folders.

Selected Includes only selected tests. Click the Filter & Sort button 
to specify the criteria for selecting tests. For more 
information on using the Filter dialog box, see Chapter 3, 
“Working with Quality Center Data.”

Option Description

Full page Displays a list of all the design steps in a test. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays all the design steps in a test as a table. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the table. Use the Tabular Layout dialog box 
to choose the columns that will appear in the table, and 
set the column order, width, and captions.

Option Description

Recursive Includes called tests from the design steps.

Attachments Includes all design step attachments.
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 11 If you use Business Process Testing, you can include the layout of the 
components included in the tests. Select Components detailed layout and 
choose what to include in the detailed layout:

➤ To include component steps, select Component steps. Click the 
Customize button to open the Tabular Layout dialog box to customize 
the component steps table. Use the Tabular Layout dialog box to choose 
the defect columns that will appear in the table, and to set the column 
order, width and captions. 

➤ To include the iteration list, select Iterations list.

 12 To include test attachments in the document, select Attachments.

 13 To display a list of all the changes made to the tests, and which user made 
each change, select History.

 14 To insert page breaks in the project document after each test, select Page 
break after each test.

 15 To include a table of linked defects, select Linked defects. Click the 
Customize button to open the Tabular Layout dialog box to customize the 
linked defects table. Use the Tabular Layout dialog box to choose the defect 
columns that will appear in the table, and to set the column order, width 
and captions. You can also specify whether to display only defects that have 
been directly linked to tests or to include indirectly-linked defects as well.

Specifying Test Plan Module Data from the Test Grid View
You use the Test List page to specify the tests from the Test Grid that should 
appear in the project document. For more information about the Test Grid, 
see Chapter 3, “Working with Quality Center Data.”
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To specify Test Plan module data from the Test Grid view:

 1 Expand the Test Plan node in the Document Generator tree. Select the Test 
List check box and click the Test List link. The Test List page is displayed.

 2 Under Tests, specify which tests you want to include in the document:

Option Description

All tests Includes all the tests from the Test Grid.

Selected Includes only selected tests. Click the Filter & Sort button 
to specify the criteria for selecting tests. For more 
information on using the Filter dialog box, see Chapter 3, 
“Working with Quality Center Data.”
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 3 Under Test Layout, specify how the tests will be organized:

 4 To insert page breaks in the project document after each test, select Page 
break after each test.

 5 If you selected Full page as the Test Layout, you can select Design steps to 
include design steps from the test.

Under Layout, specify how design steps will be organized:

Under Properties, specify what to include from the design steps:

Option Description

Full page Displays a list of all the tests in the project. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays all the tests as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the table. Use the Tabular Layout dialog box to 
choose the columns that will appear in the table, and set 
the column order, width, and captions.

Option Description

Full page Displays a list of all the design steps in a test. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays all the design steps in a test as a table. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the table. Use the Tabular Layout dialog box 
to choose the columns that will appear in the table, and 
set the column order, width, and captions.

Option Description

Recursive Includes called tests from the design steps.

Attachments Includes all design step attachments.
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 6 If you selected Full page as the Test Layout, you can also set the following 
options:

 7 To include graphs in the document, select Graphs and select graphs from 
the graph list located at the bottom of the page. Only graphs you saved as 
favorites are included in the list. For more information on favorite views, see 
Chapter 6, “Working with Favorite Views.”

Option Description

Test scripts Includes test scripts in the document.

Components 
detailed layout

If you use HP Business Process Testing, you can include 
the detailed layout of the components included in the 
tests. Choose what to include in the detailed layout:

Component steps. Includes component steps. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the component steps table. Use the Tabular 
Layout dialog box to choose the defect columns that will 
appear in the table, and to set the column order, width 
and captions. 

Iterations list. Includes the iteration list.

Attachments Includes test run attachments in the document.

Linked defects Includes a table of linked defects. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the linked defects table. Use the Tabular Layout 
dialog box to choose the defect columns that will appear 
in the table, and to set the column order, width and 
captions. You can also specify whether to display only 
defects that have been directly linked to tests or to include 
indirectly-linked defects as well.

History Displays a list of all the changes made to the tests, and 
who made them.
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Specifying Test Lab Module Data
You use the Test Lab, Test Sets, Tests, and Runs pages to specify the 
information from the Test Lab module that should appear in the project 
document.

Note: Microsoft Word is limited to nine header levels in the table of 
contents. If the test sets tree has more than nine hierarchical levels, these 
levels will not appear in the table of contents of the generated project 
document.

To specify Test Lab module data:

 1 Select the Test Lab check box in the Document Generator tree and click the 
Test Lab link. The Test Lab page opens.
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 2 Under Folders, specify which test lab folders you want to include in the 
document:

 3 To include test set attachments, select Attachments.

 4 To insert page breaks in the project document after each test sets folder, 
select Page break after each test sets folder.

 5 To include graphs in the document, select Graphs and select graphs from 
the graph list located at the bottom of the page. Only graphs you saved as 
favorites are included in the list. For more information on favorite views, see 
Chapter 6, “Working with Favorite Views.”

Option Description

All Includes all the folders in the test sets tree.

Selected Includes only the folders you choose from the test sets 
tree. You select the folders from the test sets tree displayed 
under Folders.
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 6 Expand the Test Lab node in the Document Generator tree.

To include test set data in the project document, select the Test Sets check 
box and click the Test Sets link in the Document Generator tree. The Test 
Sets page is displayed.

 7 Under Available Test Sets, specify which test sets you want to include in the 
document:

Option Description

All Includes all the test sets in the selected test set folder.

Selected Includes only selected test sets. Click the Filter & Sort 
button to specify the criteria for selecting the test sets. For 
more information on using the Filter dialog box, see 
Chapter 3, “Working with Quality Center Data.”
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 8 To include linked defects, select Linked defects. Click the Customize button 
to customize the linked defects. Use the Tabular Layout dialog box to choose 
the defect columns that will appear in the table, and to set the column 
order, width and captions. You can also specify whether to display only 
defects that have been directly linked to test sets or to include indirectly-
linked defects as well.

 9 To insert page breaks in the project document after each test set, select Page 
break after each test set.

 10 To include graphs in the document, select Graphs, and select graphs from 
the list. Only graphs you saved as favorites are included in the list. For more 
information on favorite views, see Chapter 6, “Working with Favorite 
Views.”

 11 Expand Tests Sets in the Document Generator tree.

To include test data in the project document, select the Tests check box and 
click the Tests link. The Test Page is displayed.
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 12 Under Tests, specify which tests you want to include in the document:

 13 Under Test Layout, specify how the tests will be organized:

Option Description

All tests Includes all the tests in the selected test set.

Selected Includes only selected tests. Click the Filter & Sort button 
to specify the criteria for selecting tests. For more 
information on using the Filter dialog box, see Chapter 3, 
“Working with Quality Center Data.”

Option Description

Full page Displays test information as a list. Click the Customize 
button to choose the information to appear in the 
document.

Tabular Displays test information as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the table. Use the Tabular Layout dialog box to 
choose the columns that will appear in the table, and set 
the column order, width, and captions.

Note: If you select Tabular, you cannot include test runs 
in the document.
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 14 If you selected Full page as the Test Layout, you can also set the following 
options:

Option Description

Test scripts Includes test scripts in the document.

Components 
detailed layout

If you use HP Business Process Testing, you can include 
the detailed layout of the components included in the 
tests. Choose what to include in the detailed layout:

Component steps. Includes component steps. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the component steps table. Use the Tabular 
Layout dialog box to choose the defect columns that will 
appear in the table, and to set the column order, width 
and captions.

Iterations list. Includes the iteration list.

Attachments Includes test run attachments in the document.

Linked defects Includes linked defects as a table. Click the Customize 
button to customize the linked defects table. Use the 
Tabular Layout dialog box to choose the defect columns 
that will appear in the table, and to set the column order, 
width and captions. You can also specify whether to 
display only defects that have been directly linked to tests 
or to include indirectly-linked defects as well.

History Displays a list of all the changes made to the tests, and 
who made them.

Page break after 
each test

Inserts page breaks in the project document after each 
test.
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 15 To include test run data in the project document, expand Tests in the 
Document Generator tree. Select the Runs check box and click the Runs link. 
The Runs page is displayed. 

 16 Under Runs, choose one of the following options:

Option Description

Last run Includes only the last run of the test.

All runs Includes all runs of the test. 

Selected Includes only selected runs in the document. Click the 
Filter & Sort button to specify the criteria for selecting 
tests. For more information on using the Filter dialog box, 
see Chapter 3, “Working with Quality Center Data.”
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 17 Under Run Layout, choose one of the following options:

 18 If you selected Full page as the Run Layout, you can select Run steps to 
include a list of run steps in the document.

If you are including run steps in the document, choose one of the following 
options under Layout:

You can also select Defects to include a table of defects linked with run 
steps. Click the Customize button to open the Tabular Layout dialog box to 
customize the linked defects table. Use the Tabular Layout dialog box to 
choose the defect columns that will appear in the table, and to set the 
column order, width and captions. You can also specify whether to display 
only defects that have been directly linked to run steps or to include 
indirectly-linked defects as well.

If you are including run steps in the document, you can select Attachments 
to include run steps attachments in the document.

Option Description

Full page Displays a list of all the test runs. Click the Customize 
button to choose the information to appear in the 
document.

Tabular Displays all the test runs as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the table. Use the Tabular Layout dialog box to 
choose the columns that will appear in the table, and set 
the column order, width, and captions.

Option Description

Full page Displays a list of all the steps in a run. Click the Customize 
button to choose the information to appear in the 
document.

Tabular Displays all the steps in a run as a table. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the table. Use the Tabular Layout dialog box 
to choose the columns that will appear in the table, and 
set the column order, width, and captions.
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 19 If you selected Full page as the Run Layout, you can set the following 
options:

Option Description

Linked defects Includes a table of defects linked with test runs. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the linked defects table. Use the Tabular 
Layout dialog box to choose the defect columns that will 
appear in the table, and to set the column order, width 
and captions. You can also specify whether to display only 
defects that have been directly linked to test runs or to 
include indirectly-linked defects as well.

Attachments Includes test run attachments in the document.



Chapter 45 • Generating Project Documents

679

Specifying Defects Module Data
You use the Defects page to specify the defect information from the Defects 
module that should appear in the Track Defects section of the project 
document.

To specify Defects module data:

 1 To include defect data in the project document, select the Defects check box 
and click the Defects link in the Document Generator tree. The Defects page 
is displayed.
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 2 Under Defects, choose one of the following options:

 3 Under Defects Layout, choose one of the following options:

 4 If you selected the Full page as the Defects Layout, you can also set the 
following options:

Option Description

All defects Includes all the defects from the Defects Grid.

Selected Includes only selected defects. Click the Filter and Sort 
button to specify the criteria for selecting defects. For 
more information on using the Filter dialog box, see 
Chapter 3, “Working with Quality Center Data.”

Option Description

Full page Displays all the selected defects as a list. Click the 
Customize button to choose the information to appear in 
the document.

Tabular Displays all the selected defects as a table. Click the 
Customize button to open the Tabular Layout dialog box 
to customize the table. Use the Tabular Layout dialog box 
to choose the columns that will appear in the table, set 
the column order, width, and captions.

Option Description

Attachments Includes defect attachments in the document.

Linked defects Includes linked defects as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the linked defects table. Use the Tabular Layout 
dialog box to choose the defect columns that will appear 
in the table, and to set the column order, width and 
captions. You can also specify whether only direct links 
will be displayed.
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 5 To include graphs in the document, select Graphs and select graphs from 
the list. Only graphs you saved as favorites are included in the list. For more 
information on favorite views, see Chapter 6, “Working with Favorite 
Views.”

Generating a Project Document

After you set formatting instructions and specify project data, you can 
generate the project document. You save the document as a Microsoft Word 
file.

Tip: You can generate a preview project document that enables you to 
quickly see how the document will look, without all the detail included. To 
generate a preview project document, click the Preview button. 
Quality Center opens Microsoft Word and displays the preview project 
document.

To generate a project document:

 1 If there are open project document files from previous runs of the 
Document Generator, close the files.

 2 Click the Full Document button. The Save As dialog box opens.

Linked entities Includes linked entities as a table. Click the Customize 
button to open the Tabular Layout dialog box to 
customize the linked entities table. Use the Tabular Layout 
dialog box to choose the defect columns that will appear 
in the table, and to set the column order, width and 
captions. You can also change the captions and the width 
of the table columns.

History Displays a list of all the changes made to the defects.

Page break after 
each defect

Inserts page breaks in the project document after each 
defect.

Option Description
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 3 In the Save As box, set the location for the document in your network file 
system.

 4 In the File name box, assign the document a name.

 5 Click the Save button. 

Quality Center begins generating the document and a dialog box displays 
document creation progress. To cancel document generation, click the Stop 
button.

When the process is complete, Microsoft Word opens and displays the 
document.

If the generated document contains links to attachments, a folder is created 
in the same location as the document, and the attachment files are copied 
to this folder. The name of the attachment folder is the name of the 
document with the suffix “_Attachments”. If you send the document to 
someone, you can send the attachment folder along with it so that the 
recipient can access the attachments by using the links.
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A
Working with VAPI-XP

The VAPI-XP open test architecture API testing tool enables you to create 
new testing scripts, or edit existing scripts, and integrate them into your 
application management process.

This chapter includes:

 ➤  About Working with VAPI-XP on page 686

 ➤  Creating VAPI-XP Test Scripts on page 686

 ➤  Editing VAPI-XP Test Scripts on page 696

 ➤  Using the VAPI-XP API on page 701

 ➤  Running VAPI-XP Tests in Debug Mode on page 706

 ➤  Running VAPI-XP Tests in Test Mode on page 707

 ➤  Debugging VAPI-XP Test Scripts on page 709
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About Working with VAPI-XP

The VAPI-XP testing tool enables you to create new testing scripts using 
Microsoft VBScript, Microsoft JavaScript (JScript version), PerlScript, and 
PythonScript, and integrate these scripts into your application management 
process. Using VAPI-XP test scripts, you can test COM/DCOM servers, SOAP-
based Web services, Java APIs (such as Java classes and EJBs), and console 
applications. You can also use VAPI-XP to create a LoadRunner virtual user.

In addition, VAPI-XP is fully integrated with Quality Center, enabling you to 
design your VAPI-XP test script to call any Quality Center test or test set, and 
execute it as part of your own script. This allows you to build a more 
advanced test set execution flow, in which you can filter tests in a test set 
during execution, based on the status or type of each test.

VAPI-XP is also fully integrated with the Quality Center Open Test 
Architecture API. All open test architecture API classes and methods can be 
referenced from the VAPI-XP user interface so that you can easily include 
them in your test script. 

Creating VAPI-XP Test Scripts

You create a VAPI-XP test script from the test plan tree in the Test Plan 
module.

Note: You can also convert a manual test to a VAPI-XP test. In the Design 
Steps tab, click the Generate Script button and select VAPI-XP-TEST. 
Quality Center creates a VAPI-XP test script that includes code for the steps 
that you defined. It also includes code for called tests that were part of the 
original manual test. For more information on manual tests, see Chapter 20, 
“Building Tests.”
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To create a VAPI-XP test script:

 1 Choose a subject folder in the test plan tree.

 2 Click the New Test button or choose Tests > New Test. The Create New Test 
dialog box opens.

 3 In the Test Type box, select VAPI-XP-TEST.

 4 In the Test Name box, type a name for the test. Note that a test name 
cannot include the following characters: \ / : " ? < > | * % ‘

Click OK.

Note: If required test fields were defined in the Project Customization 
window, the Required Test Fields dialog box opens. Select values for the 
required fields, and click OK.
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The HP VAPI-XP Wizard opens.

 5 In the Script Language box, select a script language. 

Notes: 

➤ To create a VAPI-XP test script using ActiveState’s ActivePython or 
ActivePerl scripts, you must install the script language on your machine. 
From the Help menu in the Test Script tab, select ActivePython Home 
Page or ActivePerl Home Page, and follow the appropriate installation 
instructions.

➤ Microsoft’s VBScript and JScript are usually installed with Internet 
Explorer. If they are not installed on your machine, select VBScript Home 
Page or JScript Home Page from the Help menu in the Test Script tab, 
and follow the appropriate installation instructions.

 6 In the Script Name box, type a name for the VAPI-XP test script.
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 7 If you selected VBScript or JavaScript as your test scripting language, you can 
select Create HP LoadRunner Vuser to create a LoadRunner virtual user 
script that can be run in the LoadRunner Controller. 

Note: To run this virtual user in the Controller, you must install the latest 
version of the HP Quality Center Connectivity Add-in on your LoadRunner 
client machine. This add-in is available from the HP Quality Center Add-ins 
page. For more information, refer to the HP Quality Center Installation Guide.

 8 Click Next to continue creating the test script using the HP VAPI-XP Wizard. 
The following dialog box opens.

Note: In each dialog box, you can click Finish to close the Wizard and 
continue creating the test script in the Test Script tab.
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 9 Select the type of test you want to create.

 10 Click Next to continue creating the test script using the HP VAPI-XP Wizard. 

➤ If you selected COM/DCOM Server Test, choose the Program IDs of the 
COM/DCOM objects in your machine’s registry that you want to test, 
and click the + button. Each selected COM/DCOM object and its 
description is displayed in the box below.
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➤ If you selected Java Class Test, type the full name of the Java class that 
you want to test in the Java Class Name box, and click the + button. The 
Java class name you typed appears in the text box below.

Note: You can only use a Java class that has a public constructor that does 
not take arguments.

Under Java Virtual Machine, select Other JVM if you do not want to use 
the default Microsoft Java virtual machine, and specify the following: 

➤ JVM Runtime. The Java virtual machine runtime executable file 
(usually java.exe).

➤ Java Compiler. The executable file that recompiles the bytecode at the 
execution platform (usually javac.exe).
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➤ Classpath. A list of additional (non-standard) Java libraries, separated 
by semi-colons (;), required to run the specified Java application. Note 
that if you do not specify the Java classpath, Quality Center uses the 
environment variable CLASSPATH.

➤ JVM Parameters. The parameters for the Java virtual machine run-time 
executable file.

If the Microsoft Java virtual machine (required to support the debugging 
of your test script) is not installed on your machine, run the 
msjavx86.exe file located in the Redist directory on your 
HP Quality Center DVD.

To use other Java virtual machines, install the Bean Scripting Framework 
(BSF) Java package on the client machine. Unzip the bsf-bin-22.zip file 
located in the Redist directory on your HP Quality Center DVD. In the 
unzipped file, locate the path of the bsf.jar file and add it to the 
CLASSPATH field. Ensure that the CLASSPATH environment variable 
contains a dot (.) to specify the current directory.

When working with other Java virtual machines, add the location of the 
BSF DLLs to the system path, as follows: In the Control Panel, choose 
System > System Properties, and then click the Advanced tab. Click the 
Environment Variables button, and in the System Variables area, edit the 
Path parameter by adding the path of the following DLLs: msvcp60.dll, 
bsfactivescriptengine.dll, and bsfactivescriptengine_g.dll. Click OK.
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➤ If you selected Web Service (SOAP) Test, choose the SOAP client library 
from the SOAP Client Library list, and type or select the URL you want to 
test in the Web Service Definition box. Click the + button. The URL you 
typed appears in the text box below.

Note: Two SOAP client libraries are supported: Microsoft SOAP SDK and 
PocketSOAP. Note that even if you choose to work with PocketSOAP, you 
must install Microsoft SOAP SDK to parse Web services. If Microsoft SOAP 
SDK is not already installed on your machine, run the SoapToolkit30.exe file 
located in the Redist directory on your HP Quality Center DVD.
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➤ If you selected Console Application Test, type the name of the 
application file you want to test in the Application Executable File box, 
and its parameters in the Command Line Parameters box. 

Clear the Use VAPI-XP Output instead of Standard Output box if you do 
not want to replace the standard output with the VAPI-XP output 
window.

In the Application Timeout box, type the time, in milliseconds, for 
Quality Center to wait for the application to finish running. Note that if 
the timeout is set to -1, Quality Center waits an infinite amount of time 
for the application to finish running.

Click the + button. The data you entered appears in the text box below.
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 11 Click Next to continue creating the test script using the HP VAPI-XP Wizard. 
The following dialog box opens.

 12 In the Service list, select the functions you want to add to your test script. 
Double-click each function, or drag and drop it, to add it to your script code. 
The function is added to the box below the Service list.

 13 If required, enter additional parameters or add extra code to the script in the 
lower pane.

 14 Click Finish. The new test appears in the test plan tree under the subject 
folder you selected.

Note: You can choose to add details and attachments to the VAPI-XP test 
you created, or define requirements coverage. For information, see 
Chapter 18, “Developing the Test Plan Tree.”
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Editing VAPI-XP Test Scripts

After you have created a VAPI-XP test script using the HP VAPI-XP Wizard, 
you can edit it in the Test Script tab.

Tip: You can display the Test Script tab in a separate window by selecting 
View > Window Screen, or clicking the Window Screen button.

To edit a VAPI-XP test script:

 1 In the test plan tree, select a VAPI-XP test, and click the Test Script tab. The 
test script is displayed.

Note: To view or edit the properties of the test script you created, choose 
Test > Properties.
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 2 To view a list of object definitions, methods, and properties that you can 
add to your script, select one of the following options:

➤ Test > References > COM Library References. Opens the References dialog 
box in which you can choose the COM object definitions, methods, and 
properties you want to view.

➤ Test > References > SOAP Web Service References. Opens the Add Web 
Service Reference dialog box in which you can type the Web service 
object definition or method you want to view. 

➤ Test > References > Java Class References. Opens the Add Java Class 
Reference dialog box in which you can type the Java class object 
definition or method you want to view.

 3 Select View > Browsers, or click the Show/Hide Browsers button. The 
following tabs are displayed.

➤ Library tab. Displays a list of VAPI-XP (SRunner), Quality Center 
(TDAPIOLELib), and COM/DCOM object definitions, methods, and 
properties that you can add to your script. For an explanation of VAPI-XP 
object definitions, methods, and properties, see “Using the VAPI-XP API” 
on page 701. For an explanation of Quality Center object definitions, 
methods, and properties, refer to the HP Quality Center Open Test 
Architecture API Reference.

➤ Soap tab. Displays a list of Web service object definitions and methods 
that you can add to your script. 

➤ Java tab. Displays a list of Java class object definitions and methods that 
you can add to your script. 
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➤ Function tab. Displays a list of functions contained in your script.

➤ Object tab. Displays a list of objects with defined names that you can add 
to your script.

Note: For a description of each object definition, method, or property, select 
View > Output, and click the Help tab.

 4 To add an object definition, method, or property to the current function in 
your script, place the cursor in the appropriate place in your code, and 
double-click the object definition, method, or property in the Library, Soap, 
or Java tabs. 
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 5 To add an object with a defined name, select the object definition, method, 
or property in the Library, Soap, or Java tabs, and choose Test > Add Object. 
In the Add Object dialog box, type the name you want to assign to the 
object and click OK. The object is added to the Object tab.

To add the object to your script, double-click the object, or right-click it and 
select Insert into Script.

 6 To check the syntax of your code, choose Test > Check Syntax, or click the 
Syntax Check button. Select View > Output to view the verification results in 
the Output tab.
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Additional Editing Functions
You can also perform the following editing functions in the Test Script tab:

➤ To undo a previous action, click the Undo button. To restore an action that 
was undone, click the Redo button.

➤ To remove a section of code from one part of your script, and place it in 
another part of the script, select the section and click the Cut and Paste 
buttons. 

➤ To copy a section of code from one part of your script, and place it in 
another part of the script, select the section and click the Copy and Paste 
buttons. 

➤ To delete a section of code, select it and click the Delete button.

➤ To locate specific text within your script, click the Find in Script button. In 
the Find Text dialog box, type the text for which you want to search. Select 
the options, direction, scope, and origin for your search, and click OK. 

To find another occurrence of the text within the script, choose 
Search > Find Next.

➤ To locate specific text within your script and replace it with different text, 
click the Replace button. In the Find Text dialog box, type the text you want 
to search for in the Text to find box. Type the text with which you want to 
replace this text in the Replace with box. Select the options, direction, 
scope, and origin for your search, and click OK. To replace all instances of 
the text in the script, click the Replace All button.

➤ To locate a specific line number within your script, choose Search > Go to 
Line Number. In the Go to Line Number dialog box, type the line number 
you want to find, and click OK.

➤ To change the editor options, such as the margins, fonts, and screen/text 
colors, click the Editor button. Set the properties you want in the Editor, 
Display, and Colors tabs, and click OK.

After you have finished editing your script, click the Save button to save the 
changes you made.
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Using the VAPI-XP API

The VAPI-XP tool contains a built-in library of VAPI-XP object definitions 
that you can reference as you are creating your test script.

Using the TDHelper Object
The TDHelper object supplies the following functions that you can use to 
perform Quality Center-related tasks.

RunTestSet

Executes the selected test set and returns the accumulated test set execution 
status.

RunTestSet([Name = "default"], [Filter = ""], [Locally = FALSE], [Host = ""], 
[HostGroup = ""])

Name. Test set name. Optional. Default = "default"

Filter. Test filter. Defines tests to run. If empty, instructs Quality Center to 
run all the tests in a specified test set. Optional. Default = ""

Locally. If set to TRUE, instructs Quality Center to run test set locally. 
Optional. Default = FALSE

Host. Host on which test set will be run. Optional. Default = ""

HostGroup. Host group in which test set will be run. Optional. Default = ""

RunTest

Executes the selected test and returns the test execution status. 

RunTest(Name, Instance, TestSet, [Locally = FALSE], [Host = ""], [HostGroup = ""])

Name. Test name.

Instance. Test instance.

TestSet. Test set name.

Locally. If set to TRUE, instructs Quality Center to run test set locally. 
Optional. Default = FALSE
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Host. Host on which test set will be run. Optional. Default = ""

HostGroup. Host group in which test set will be run. Optional. Default = ""

AddDefect

Adds a new defect to the current test, if the test is being run in debug mode. 
If the test is being run in test mode, a new defect is added to the current run 
of the test instance in the current test set. Returns a created defect object.

AddDefect([Fields], [StepKey])

Fields. Two-dimensional array—the first dimension is for the field name, 
and the second for the field value. Optional.

StepKey. Step ID for step related to new defect. Optional.

AddDefectUI

Adds a new defect to the current test (in debug mode) or the current run (in 
test mode), using the Quality Center New Defect dialog box.

AddDefectUI([StepKey])

StepKey. Step ID for step related to new defect. Optional.

AddStepToRun

Adds a new step to the current run. Returns a created step object.

AddStepToRun(Name, [Desc], [Expected], [Actual], [Status])

Name. Step name.

Desc. Step description. Optional.

Expected. Expected step result. Optional.

Actual. Actual step result. Optional.

Status. Step status. Optional.
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DownLoadAttachment

Downloads the attachment associated with a test object. Returns the local 
path to which the download was performed.

DownLoadAttachment(Name, item)

Name. The attachment name.

item. Reference to the object with the attachment.

UpLoadAttachment

Uploads an attachment and associates it with a test object.

UpLoadAttachment(path, item)

path. The local path (fully specified file name) of the item to upload.

item. Reference to the object to which to associate the attachment.

Using the TDInput Object
The TDInput object supplies the following function that you can use to 
obtain an input value from an end user.

GetInput

Displays the Input dialog box, enabling you to obtain an input value from 
an end user.

GetInput([Caption],[Name])

Caption. Dialog box caption. Optional.

Name. Name of the input value. Optional.
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Using the TDOutput Object
The TDOutput object supplies the following functions that you can use to 
control the VAPI-XP Output tab.

Clear Method

Clears the Output tab.

Clear

Print Method

Prints the text message to a new line in the Output tab.

Print(Msg)

HookDebug Property

Sets or removes the hook for the OutputDebugString tab API function.

HookDebug

Text Property

Gets or sets the Output tab text.

String Text
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Using the XTools Object
The XTools object supplies the following functions that you can use to 
perform general tasks.

run

Runs command line with passed attributes.

run(Command, [Args = ""], [Timeout = -1], [UseOutput = TRUE])

Command. Application executable file.

Args. Application arguments. Optional. Default = ""

Timeout. Timeout in milliseconds. If this is -1, Quality Center waits an 
infinite amount of time for the application to finish running.

UseOutput. If TRUE, Quality Center replaces the standard output with the 
VAPI-XP output window.

WrapArray

Creates an array of variants from an array of objects. For example, if a called 
object returns as a method result an array of strings, none of the supported 
script engines is able to read the array. Calling the WrapArray function and 
passing the returned array as a function parameter creates an array of 
variants that can be understood by the scripting engine.

WrapArray (array)

array. Array to wrap. 

Sleep

Suspends script execution for a specified amount of time.

Sleep(interval)

interval. Time (in milliseconds) for script execution suspension
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Running VAPI-XP Tests in Debug Mode

Once you have created and edited your VAPI-XP test script, you can run it in 
debug mode or test mode. Running a VAPI-XP test in debug mode enables 
you to execute the test without including it in a test set and without 
creating test run data in the Quality Center project. It is generally 
recommended that you use the debug mode while you are developing your 
test, and the test mode once you have completed creating your test.

To run a VAPI-XP test in debug mode:

 1 In the Test Plan module, select a VAPI-XP test from the test plan tree, and 
click the Test Script tab.

 2 Select Test > Execute (Debug Mode), or click the Execute Script button. 
Quality Center begins executing the test script you selected.

 3 Select View > Output to view the output generated by the test script.

➤ To clear the Output tab, click the Clear Output button.

➤ To copy the output text to the clipboard, select it and click the Copy 
Selected Text to Clipboard button.

➤ To view the test script output in a Web browser, click the Open Output 
Text in Web Browser button.

➤ To print the test script output, click the Print Output button.

 4 To stop executing the VAPI-XP test before it finishes running, select Test > 
Stop, or click the Stop button.
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Running VAPI-XP Tests in Test Mode

You can run your VAPI-XP test in test mode once you have added the test to 
a test set in the Test Lab module. For information on adding tests to test sets, 
see Chapter 28, “Creating Test Sets.”

Note that when you run a VAPI-XP test in test mode, test run data is created 
in the Quality Center project.

You can run your VAPI-XP test in test mode from either the Test Plan or Test 
Lab module.

Note: To run VAPI-XP tests remotely, you must install the HP Quality Center 
Client Side Setup Add-in and the HP Quality Center Connectivity Add-in on 
the host machine on which the tests are executed. For more information on 
HP Quality Center add-ins, refer to the HP Quality Center Installation Guide.

To run a VAPI-XP test in test mode from the Test Plan module:

 1 Select a VAPI-XP test from the test plan tree, and click the Test Script tab.

 2 Select Test > Execute (Test Mode). The Select Test Set dialog box opens.

 3 In the Test Set box, select the test set containing the current VAPI-XP test. 

 4 In the Instance box, select the test instance that you want to run. 

 5 In the Run Name box, type the name you want to assign to the test run. 

 6 Click OK. Quality Center begins executing the test you selected.
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 7 To view the output generated by the test script, select View > Output. For an 
explanation of the Output tab, see “Running VAPI-XP Tests in Debug Mode” 
on page 706.

 8 To stop executing the VAPI-XP test before it finishes running, select 
Test > Stop, or click the Stop button.

To run a VAPI-XP test in test mode from the Test Lab module:

 1 From the Test Sets list, select the test set containing the VAPI-XP test you 
want to run.

 2 In the Execution Grid, select the test you want to run, and click the Run 
button. The Automatic Runner dialog box opens, displaying the selected 
test.

 3 In the Run on Host column, select a host machine on which to run the 
VAPI-XP test, or choose Run All Tests Locally to run the test on your local 
machine.
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 4 Click the Run button. The VAPI-XP Test Script window opens as 
Quality Center begins executing the selected VAPI-XP test. When 
Quality Center finishes executing the test, the Automatic Runner dialog box 
displays the status of the test run.

Debugging VAPI-XP Test Scripts

If your test run was not successfully completed, you can use VAPI-XP’s 
Integrated Debugger to assist you in debugging your VAPI-XP test script. 

Note: You cannot use the Integrated Debugger to debug PerlScript or 
PythonScript test scripts.

To debug a VAPI-XP test script:

 1 In the Test Script tab of the Test Plan module, select Debug > Integrated 
Debugger. Additional buttons controlling the debugging process are 
displayed on the toolbar.

 2 To set a breakpoint in a script, select the line in the script where you want to 
set the breakpoint, and choose Debug > Toggle Breakpoint or click the 
Toggle Breakpoint button. Alternatively, click the gray margin next to the 
line in the script. The line you selected is highlighted in red.
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 3 Click the Execute Script button. Quality Center begins executing the script, 
stopping at the defined breakpoint. The Output tab displays the following 
message. 

 4 To instruct Quality Center to enter the script after the breakpoint, choose 
Debug > Step Into or click the Step Into button. The line in the script that 
follows the breakpoint is highlighted in blue.

 5 To instruct Quality Center to step over a line in the script, click the Step 
Over button or choose Debug > Step Over.



Appendix A • Working with VAPI-XP

711

 6 To instruct Quality Center to execute the script, choose Debug > Step Out or 
click the Step Out button. The output is displayed in the Output tab.

 7 To view or edit the value of each variable in the script, choose 
Debug > Variables or click the Show Variables button. The Variables dialog 
box opens, displaying the variables available in the current script. Select a 
variable to view its properties.

To change a variable’s value, type the new value you want to assign to it in 
the Value box and click Update. Click OK to save your changes and close the 
Variables dialog box.

 8 To view information about a specific variable while debugging, choose 
Debug > Watch or click the Show Watch Window button to display the 
Watch tab. 
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To add a variable to the Watch tab, click +, type a variable name in the 
Prompt box, and click OK. The variable and its values are displayed in the 
Watch tab.

 9 To instruct Quality Center to resume executing the script, choose 
Debug > Resume Execution or click the Resume Execution button.

 10 Choose Debug > Stop Debugging, or click the Stop Debugging button to 
stop the Integrated Debugger from debugging your script. 
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B
Quality Center Keyboard Shortcuts

You can navigate Quality Center, and perform many Quality Center 
commands by using shortcut keys.

This chapter includes:

 ➤  Switching Between Quality Center Modules on page 714

 ➤  General Keyboard Shortcuts on page 714

 ➤  Attachments Shortcuts on page 716

 ➤  Send Email Dialog Box Shortcuts on page 716

 ➤  Management Module Shortcuts on page 717

 ➤  Requirements Module Shortcuts on page 717

 ➤  Test Plan Module Shortcuts on page 718

 ➤  Test Resources Module Shortcuts on page 719

 ➤  Test Lab Module Shortcuts on page 719

 ➤  Defects Module Shortcuts on page 720

 ➤  Dashboard Module Shortcuts on page 721
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Switching Between Quality Center Modules

You can switch between the Quality Center modules using 
CTRL+SHIFT+<number> shortcut keys. The number represents the sequential 
order in which the module is displayed in the module sidebar, starting with 
“0”. For example, if Requirements is the first module, press CTRL+SHIFT+0. If 
Business Components is the second module, press CTRL+SHIFT+1.

General Keyboard Shortcuts

You can navigate Quality Center, and perform common commands by 
pressing the following shortcut keys:

Shortcut Key Function

DOWN ARROW or UP 
ARROW

Selects the previous and next item respectively.

LEFT ARROW or RIGHT 
ARROW

In the tree folders, collapses or expands the folders 
respectively.

In the grid view, selects the previous and next grid 
column respectively.

TAB Selects the next data box in a tab or dialog box.

SHIFT+TAB Selects the previous data box in a tab or dialog box.

CTRL+SHIFT+ 
<sequence number>

Switches between the sidebar views in the Requirement 
Details, Defect Details, and Test Instance Properties 
dialog boxes.

CTRL+TAB Moves forward through the tabs.

CTRL+SHIFT+TAB Moves backward through the tabs.

F9 or ALT Focuses on the module menu options. Press LEFT ARROW, 
RIGHT ARROW, DOWN ARROW or UP ARROW to navigate 
the menus.

ALT+DOWN Opens the drop-down lists for list boxes. Press DOWN 
ARROW or UP ARROW to select a list value.
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LEFT ARROW Expands a folder that contains sub-folders in the tree 
view (if it is collapsed).

RIGHT ARROW Collapses a folder that contains sub-folders in the tree 
view (if it is expanded).

ALT+G Goes to the selected entity.

ALT+HOME/END Displays the first or last entity respectively in the 
Requirement Details, Defect Details, or Test Instance 
Properties dialog box. 

ALT+LEFT/RIGHT 
ARROW

Displays the previous or next entity respectively in the 
Requirement Details, Defect Details, or Test Instance 
Properties dialog box. 

CTRL+F Opens a Find dialog box that helps you search for 
specified text. 

CTRL+C Copies the selected item and puts it on the Clipboard.

CTRL+V Pastes the contents of the Clipboard to the selected 
location.

CTRL+X Cuts the selected item and puts it on the Clipboard.

CTRL+Z Undoes the last action.

CTRL+A Selects all items.

F1 Displays help for the selected dialog box.

F2 Renames an entity.

F5 Refreshes all data in the selected tree, grid, or folder.

F7 Spell checks the selected word or text box.

SHIFT+F7, 
SHIFT+CTRL+F7

Opens the Thesaurus dialog box and displays a 
synonym, antonym, or related word for the selected 
word.

CTRL+SHIFT+T OR 
CTRL+T

Creates a tab for memo fields.

Shortcut Key Function
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Attachments Shortcuts

You can perform the following commands in the Attachments tab/dialog 
box by pressing the corresponding shortcut keys:

Send Email Dialog Box Shortcuts

You can perform the following commands in the Send Email dialog box by 
pressing the corresponding shortcut keys:

Shortcut Key Function

CTRL+F Attaches a file.

CTRL+W Attaches a URL.

CTRL+P Attaches a snapshot.

CTRL+I Attaches system information.

CTRL+B Attaches Clipboard content.

SPACE Downloads and opens an attachment.

CTRL+U Uploads an attachment.

CTRL+S Saves an attachment.

CTRL+DELETE Deletes an attachment.

Shortcut Key Function

ALT+C OR ALT+T Opens the Select Recipients dialog box.

ALT+S Sends the email.

CTRL+ALT+O Opens the Spelling Options dialog box.

CTRL+ALT+T Opens the Thesaurus dialog box.
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Management Module Shortcuts

You can perform the following commands in the Management module by 
pressing the corresponding shortcut keys:

Requirements Module Shortcuts

You can perform the following commands in the Requirements module by 
pressing the corresponding shortcut keys:

Shortcut Key Function

ALT+B Adds a new baseline.

ALT+M Imports a library.

CTRL+ALT+N Adds a new library folder.

ALT+N Adds a new library.

CTRL+N Creates a new release folder.

CTRL+R Creates a new release.

CTRL+Y Creates a new cycle.

CTRL+D Creates a copy of a cycle.

Shortcut Key Function

CTRL+ALT+N Creates a new folder.

ALT+G Opens the Create New Requirement dialog box.

ALT+N Creates a new requirement.

CTRL+I Zooms in.

CTRL+O Zooms out one level.

SHIFT+CTRL+O Zooms out to root level.
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Test Plan Module Shortcuts

You can perform the following commands in the Test Plan module by 
pressing the corresponding shortcut keys:

CTRL+A Adds test to coverage.

CTRL+M Sends requirement by email (from Requirement Details 
dialog box).

Shortcut Key Function

ALT+G Opens the Go To Test dialog box.

ALT+N Creates a new step (from Design Steps tab).

CTRL+P Inserts a parameter (from Design Steps tab).

SHIFT+ALT+A Adds attachments (from Design Steps tab).

CTRL+L Adds a call to manual test (from Design Steps tab).

CTRL+S Saves a step (from Design Steps tab).

ALT+N Creates a new parameter (from Test Parameters 
tab).

CTRL+DELETE Deletes a parameter (from Test Parameters tab).

ALT+R Removes a requirement from coverage (from Req 
Coverage tab).

Shortcut Key Function
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Test Resources Module Shortcuts

You can perform the following commands in the Test Resources module by 
pressing the corresponding shortcut keys:

Test Lab Module Shortcuts

You can perform the following commands in the Test Lab module by 
pressing the corresponding shortcut keys:

You can perform the following commands in the Manual Runner dialog box 
by pressing the corresponding shortcut keys:

Shortcut Key Function

CTRL+N Creates a new test resource folder.

CTRL+R Creates a new test resource.

Shortcut Key Function

ALT+N Creates a new test set.

ALT+G Opens the Go To Test Set dialog box.

CTRL+A Adds test to test set.

CTRL+F9 Runs test.

CTRL+ALT+F9 Runs test manually.

CTRL+SHIFT+F9 Continues manual run.

ALT+F9 Runs test set.

CTRL+DELETE Removes selected test instances from test set (from 
Execution Grid tab).

Shortcut Key Function

CTRL+R Begins the run.

CTRL+Q Ends the run.
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Defects Module Shortcuts

You can perform the following commands in the Defects module by 
pressing the corresponding shortcut keys:

CTRL+K Cancels the run.

CTRL+U Opens the Attachments dialog box.

CTRL+B Adds a new defect.

CTRL+S Adds attachments to the test step.

CTRL+P Passes the selected test run steps.

CTRL+F Fails the selected test run steps.

CTRL+A Passes all the test run steps.

CTRL+G Fails all the test run steps.

CTRL+UP ARROW/
CTRL+DOWN ARROW

Selects the previous or next test step.

Shortcut Key Function

ALT+N Adds a new defect.

ALT+G Opens the Go To Defect dialog box.

CTRL+DELETE Deletes the selected defects.

CTRL+ALT+G Finds similar defects.

CTRL+ALT+F Finds similar text.

CTRL+L Finds the next instance of the specified text.

CTRL+M Sends defect by email (from Defect Details dialog box).

CTRL+N Clears all fields in the New Defect dialog box.

Shortcut Key Function
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Dashboard Module Shortcuts

You can perform the following commands in the Analysis View tab of the 
Dashboard module by pressing the corresponding shortcut keys:

Shortcut Key Function

ALT+A Opens the Set Graph Appearance dialog box.

ALT+F Displays the graph in full screen mode.

ALT+C Copies graph to clipboard, in color.

ALT+F Displays graph or standard reports in full screen.

ALT+G Generates selected graph or standard report and 
displays it the View tab.

ALT+I Displays summary graphs in pie chart format.

ALT+L Displays progress graphs in line chart format.

ALT+M Copies graph to clipboard, in monochrome.

ALT+O Displays the graph in bar chart format.

ALT+P In graphs: Prints graph in color.

In standard reports: Prints current page.

ALT+Q Opens the Excel Report Query Builder dialog box, 
when in the Query tab.

ALT+R Displays the graph as a data grid.

ALT+S In graphs: Saves graph image.

In standard reports: Saves current page.

ALT+T In progress graphs, shows/hides total values.

ALT+U Opens Edit Group By Categories dialog box.

ALT+V Resets group by categories.

ALT+X Opens Edit X-Axis Categories dialog box.

ALT+Y Resets x-axis categories.
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ALT+RIGHT ARROW In graphs: Scrolls graph to the right, when zoom is 
active.

In standard reports: Displays last page.

ALT+LEFT ARROW In graphs: Scrolls graph to the left, when zoom is 
active.

In standard reports: Displays first page.

ALT+UP ARROW In graphs: Increases zoom level.

In standard reports: Displays next page.

ALT+DOWN ARROW In graphs: Decreases zoom level.

In standard reports: Displays previous page.

ALT+SPACE Resets graph zoom.

CTRL+E Opens the New Excel Report dialog box.

CTRL+G Opens the New Graph dialog box.

CTRL+R Opens the New Standard Report dialog box.

CTRL+W Opens the Graph Wizard.

CTRL+DELETE Deletes the selected folder, or analysis item.

CTRL+ALT+C Copies full-screen graph to clipboard, in color.

CTRL+ALT+F Opens the New Folder dialog box.

CTRL+ALT+M Copies full-screen graph to clipboard, in 
monochrome.

CTRL+ALT+P In graphs: Prints graph in monochrome.

In standard reports: Prints all pages.

CTRL+ALT+S Saves all standard reports pages.

Shortcut Key Function
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You can perform the following commands in the Dashboard View tab of the 
Dashboard module by pressing the corresponding shortcut keys:

Shortcut Key Function

ALT+A Goes to the selected graph in the analysis tree.

ALT+F Displays the selected graph in full screen.

ALT+G Generates selected dashboard page and displays it in 
the View tab.

ALT+I Generates the selected graph.

CTRL+P Opens the New Dashboard Page dialog box.

CTRL+DELETE Deletes the selected folder or dashboard page.

CTRL+ALT+F Opens the New Folder dialog box.

UP ARROW Moves selected graph placeholder to row above.

DOWN ARROW Moves selected graph placeholder to row below.

LEFT ARROW Moves selected graph placeholder to the left, if vacant.

RIGHT ARROW Moves selected graph placeholder to the right, if 
vacant.

BACKSPACE Removes selected graph placeholder from dashboard 
page.

DELETE Removes selected graph placeholder from dashboard 
page.

SPACE Expands/reduces selected graph placeholder.

ENTER Adds selected graph to the dashboard page.
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C
Quality Center Editions

Quality Center is available in three different editions — Starter, Enterprise 
and Premier. This section explains what functionality is provided in each 
edition.

This chapter includes:

 ➤  About Quality Center Editions on page 725

 ➤  Quality Center Functionality by Edition on page 726

About Quality Center Editions

The following Quality Center editions are available:

➤ Quality Center Starter Edition. Existing Quality Center edition for 
application teams managing small releases with a maximum of five 
concurrent users.

➤ Quality Center Enterprise Edition. Existing Quality Center edition for 
application teams managing medium to large releases. Formerly TestDirector 
for Quality Center.

➤ Quality Center Premier Edition. New Quality Center edition for mature 
Center of Excellence (CoE) organizations managing enterprise releases.



Appendix C • Quality Center Editions

726

Quality Center Functionality by Edition

The following table indicates the availability of Quality Center functionality 
according to editions. Further information on each function is provided 
below.

Functionality
Starter 
Edition

Enterprise 
Edition

Premier 
Edition

Licensing  

up to five

Modules  

some 
exclusions

Excel Reporting

Test Resources

Versioning  

single 
entity

Point and Click Installation

Multiple Requirement Types

Requirement to Requirement 
Traceability

Release Management

Risk-based Quality Management

Sharing Requirements and Tests
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Licensing

Quality Center Starter Edition enables a maximum of five concurrent 
licenses. For Quality Center Enterprise Edition and Quality Center Premier 
Edition, licensing is determined according to your purchase agreement. 

The site administrator can monitor the license usage from Site 
Administration. For more information, refer to the HP Quality Center 
Administrator Guide.

Modules

Quality Center Enterprise Edition and Quality Center Premier Edition 
enable access to all Quality Center modules. Quality Center Starter Edition 
allows for access to the following modules: Requirements, Test Plan, Test 
Resources, Test Lab, Defects and Dashboard. 

Excel Reporting

All editions enable exporting Quality Center data to Excel for reporting. For 
more information, refer to Chapter 43, “Generating Excel Reports.”

Sharing Defects

Cross Project Customization

Cross Project Reporting

Extra Options

Upgrading Editions —

Functionality
Starter 
Edition

Enterprise 
Edition

Premier 
Edition
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Test Resources

All editions include the Test Resources module for managing resources used 
by your tests. For more information, refer to Chapter 24, “Managing Test 
Resources.”

Versioning 

All editions allow for single entity versioning of your Quality Center 
projects. For more information, refer to Chapter 7, “Working with Version 
Control.” 

Quality Center Enterprise Edition and Quality Center Premier Edition also 
include baselining of multiple entities in a library. For more information, 
refer to Chapter 38, “Libraries and Baselines.”

Point and Click Installation

Quality Center Enterprise Edition and Quality Center Premier Edition 
require a full installation over a supported database. 

Quality Center Starter Edition is installed on Windows XP with a simple 
point and click wizard. This includes automatic installation of a JBoss 
application server, JBoss web server, and SQL 2005 Express.

For more information on installation and supported environments, refer to 
the HP Quality Center Installation Guide.

Multiple Requirement Types

Quality Center Enterprise Edition and Quality Center Premier Edition 
include support for multiple requirement types. For more information on 
requirement types, refer to “The Requirement Fields” on page 171. 
Quality Center Starter Edition does not support multiple requirement types. 

Requirement to Requirement Traceability 

Quality Center Enterprise Edition and Quality Center Premier Edition 
include support for defining links between requirements. For more 
information on requirements traceability, refer to Chapter 14, “Tracing 
Requirements.” Quality Center Starter Edition does not support 
requirements traceability. 
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Release Management

Quality Center Enterprise Edition and Quality Center Premier Edition 
include the Releases module. For more information on the Releases module, 
refer to Chapter 8, “The Release Management Workflow.”

Quality Center Starter Edition does not support release management. If you 
are working with this edition, fields and commands related to cycles and 
releases are not available in Quality Center. For example, Target Cycle and 
Target Release are not available.

Risk-based Quality Management

Quality Center Enterprise Edition and Quality Center Premier Edition 
include risk-based quality testing. For more information on risk-based 
quality management, refer to Chapter 15, “Calculating Requirement Risks.”

In the Quality Center Starter Edition, the Risk tab is unavailable in the 
Requirements module. In addition, any risk related fields are not available in 
Quality Center. 

Sharing Requirements and Tests

Quality Center Starter Edition and Quality Center Enterprise Edition do not 
include reuse of requirements, tests and test resources. In the Quality Center 
Starter Edition, the Libraries module is unavailable. In the Quality Center 
Enterprise Edition, you can use the Libraries module to create and compare 
baselines made up of requirements, tests and test resources. In the 
Quality Center Premier Edition, you can use the Libraries module to create 
and compare baselines, in addition to importing, synchronizing and 
comparing libraries across multiple projects.

For more information on the Libraries module, refer to Chapter 37, “The 
Libraries Module at a Glance.”

Sharing Defects

With the Quality Center Premier Edition, you can share defects across 
multiple Quality Center projects. You share and synchronize defects using 
the HP Quality Center Synchronizer. For more information, see the 
HP Quality Center Sychronizer User Guide, available from the Quality Center 
Adds-ins Page.
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Cross Project Customization 

Quality Center Premier Edition includes cross project customization, 
enabling you to work with template projects. For more information, refer to 
the HP Quality Center Administrator Guide.

Cross Project Reporting 

When you create graphs in Quality Center Premier Edition, you can 
combine and compare data from multiple projects. For more information on 
the Quality Center reports and graphs, refer to Chapter 40, “The Dashboard 
Module.”

Extra Options

The following extra options are available with Quality Center Enterprise 
Edition and Quality Center Premier Edition: Business Process Testing (BPT), 
Service Test Management (STM) and Change Impact Testing (CIT).

Upgrading Editions

You can upgrade Quality Center 10.00 to another edition. You can upgrade 
Quality Center Starter Edition to Quality Center Enterprise Edition or 
Quality Center Premier Edition. Likewise, you can upgrade Quality Center 
Enterprise Edition to Quality Center Premier Edition.

For more information on upgrading, refer to the HP Quality Center 
Installation Guide.
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Glossary

This glossary lists terminology that is used throughout Quality Center.

A

alert

A notification that informs specified users of changes in requirements, 
tests or defects. An alert can be triggered as a result of automatic 
notification rules or as a follow up reminder that you set up for 
yourself.

associated libraries

Two libraries in the same project or in different projects, in which one 
library, the source library, was used as the basis for creating the other, 
imported library. You can compare associated libraries to track 
changes over time, or synchronize libraries to update one library with 
changes made to the other library.

B

baseline

A snapshot of a library at a specific point in time. It includes all the 
entities defined in the library and the relationships between them, 
such as coverage and requirements traceability. You can compare 
baselines to track changes in a project over time, or use a baseline to 
reuse or share the entities in a library.
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Business Components module

Functional area of Quality Center accessible by selecting the Business 
Components button in the sidebar. This module enables subject 
matter experts to work with Business Process Testing (BPT), the HP test 
automation solution. You use reusable business process components 
and flows to create business process tests. You can also combine 
manual components to manually test your application. Access to this 
module is dependent on your Quality Center license.

Business Criticality

A risk-based quality management (RBQM) category that measures 
how crucial a requirement is for the business. Risk is calculated based 
on the combined results of the Business Criticality and the Failure 
Probability assessment.

C

check in

When using version control, the process in which a new, updated 
version of an entity is created and made available to other users. After 
you check out the entity and make changes, you check in a new 
version of the entity.

check out

When using version control, the process in which you lock an entity 
to make changes, preventing other users from overwriting your 
changes. The checked out version of an entity is not visible to other 
users.

coverage

The links you create to keep track of the relationship between your 
requirements and tests. In the Test Plan module, you create 
requirements coverage by selecting requirements to link to a test. 
Alternatively, in the Requirements module, you create test coverage 
by selecting tests to link to a requirement. A test can cover more than 
one requirement, and a requirement can be covered by more than one 
test.
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cross filter

An advanced, second-level filter on an associated item, such as 
requirements, tests, test sets, or defects. For example, in the 
Requirements module, you can define a cross filter to exclude 
requirements whose covering tests have the Passed status.

cross project customization

The process of customizing a template project to define and maintain 
a common set of project customizations for multiple Quality Center 
projects. You link a template project to one or more other projects. 
You then customize the template and apply customization to the 
linked projects. Template customization applied to linked projects can 
include user groups and permissions, project entities, requirement 
types, lists, and workflow.

cycle

A set of development and quality assurance efforts performed to 
achieve a common goal based on the release timeline. After you 
define a release, you add cycles to the release. You can then assign 
requirements, defects, and test set folders to the cycles.

D

Dashboard module

Functional area of Quality Center accessible by selecting the 
Dashboard button in the sidebar. This module enables you to analyze 
Quality Center data by creating, viewing and managing graphs, 
standard reports, and Excel reports. You also create dashboard pages 
that display multiple graphs side-by-side.

dashboard page

A selection of graphs that you view in a single display. You design and 
view dashboard pages in the Dashboard View tab of the Dashboard 
module.
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defect

A problem detected in the project application during any phase of the 
application management process. You can link defects to other project 
entities, such as requirements, tests, or other defects. A defect can be 
linked directly or indirectly to other entities. When you add a defect 
link to an entity, Quality Center adds a direct link to this entity and 
indirect links to other related entities.

Defects module

Functional area of Quality Center accessible by selecting the Defects 
button in the sidebar. This module enables you to submit and track 
defects, determine repair priorities, and analyze the data.

domain

Quality Center projects are grouped by domain. A domain contains a 
group of related Quality Center projects and assists you in organizing 
and managing a large number of projects. Each domain contains a 
Projects folder and a Template Projects folder to organize your 
Quality Center projects and template projects. 

E

entity

A data set in a Quality Center project that works as a unit, such as the 
requirement entity which stores data on all Quality Center 
requirements. Entities contain data entered by users for a specific 
application management process and the data is stored in tables. Each 
entity can contain system fields and user-defined fields.

Alternatively, an individual record containing unique data, such as a 
single requirement in the Requirements module. You can create and 
modify an entity, mail an entity, maintain a history of changes made 
to an entity, or create links between entities.

Excel Add-in

You can import requirement, test plan, or defect data from a Microsoft 
Excel worksheet to a Quality Center project. To import from Excel, 
you first install the HP Quality Center Microsoft Excel Add-in on your 
client machine.
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F

Failure Probability

A risk-based quality management (RBQM) category that indicates 
how likely a test based on the requirement is to fail. Risk is calculated 
based on the combined results of the Failure Probability and the 
Business Criticality assessment.

Functional Complexity

A risk-based quality management (RBQM) category that indicates the 
complexity of the requirement’s implementation.

I

imported library

You can create a new library by importing an existing library. An 
imported library is a library that you create by importing an existing 
library from the same project or from a different project.

L

Libraries module

Functional area of Quality Center accessible by selecting the 
Management button in the sidebar, and then clicking the Libraries 
tab. This module enables you to define and create libraries and 
baselines to track changes in your project, reuse entities in a project, 
or share entities across multiple projects. 

library

A defined set of entities in a project and the relationships between 
them, such as coverage and requirements traceability. The entities in 
a library can include requirements, tests, test resources, and business 
components. After you define a library, you then create a baseline, 
enabling you to track changes in a project over time, reuse the entities 
in a project, or share entities across multiple projects.

linked project

A project connected to a template project. You apply template 
customization updates to the linked project as a part of cross project 
customization.
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M

Management module

Functional area of Quality Center accessible by selecting the 
Management button in the sidebar. This module includes two sub-
modules: Releases module and Libraries module.

P

pinned test set

A test set that is linked to a baseline. In the Test Lab module, after you 
create a test set, you can link the test set to a baseline that you specify. 
When you run the test set, Quality Center runs only the versions of 
the test stored in the baseline.

project

Collects and stores data relevant to the application life cycle 
management process, including requirements, tests, defects, and 
additional resources. Projects are stored in the Quality Center project 
repository on the application server’s file system.

Project Customization

The process of adapting a project to meet the specific needs of your 
organization. Using the Project Customization window, you can 
control access to a project by defining the users who can access the 
project, determining the types of tasks each user can perform, and 
adding and modifying fields.
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Q

Quality Center Editions

Quality Center is available in three different editions - Starter, 
Enterprise, and Premier. The functionality available varies for each 
edition.

Quality Center Starter Edition: For application teams managing small 
releases with a maximum of five concurrent users, and has limited 
capabilities.

Quality Center Enterprise Edition: For application teams managing 
medium to large releases.

Quality Center Premier Edition: For mature Center of Excellence (CoE) 
organizations managing enterprise releases.

R

release

A group of changes to the application that will be available for 
distribution at the same time. You can divide a release into cycles. You 
can then assign requirements and defects to the release and cycles.

Releases module

Functional area of Quality Center accessible by selecting the 
Management button in the sidebar, and then clicking the Releases tab. 
This module allows you to organize and track your upcoming releases 
by defining releases and cycles for the application management 
process.

requirement

A detailed description of a specific objective of your application under 
development. You organize your requirements in a requirements tree, 
a hierarchical structure in which you can group your application’s 
requirements according to function or objective. You can link a 
requirement to releases and cycles in the Releases module. You can 
also create links between a requirement and other requirements, tests, 
and defects.
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requirements coverage

The links you create to keep track of the relationship between your 
requirements and tests. In the Test Plan module, you create 
requirements coverage by selecting requirements to link to a test. 
Requirements coverage assists you in assessing the impact of a change 
in the test or requirement. A test can cover more than one 
requirement. The direct cover status of a requirement reflects the 
execution status of the tests covering the requirement.

Requirements module

Functional area of Quality Center accessible by selecting the 
Requirements button in the sidebar. This module enables you to 
create, manage and analyze requirements in a hierarchical tree-
structure. You can also create links between requirements and other 
requirements, tests, or defects.

requirements traceability

A link you create to establish a relationship between requirements. 
When analyzing the impact of a proposed change in a requirement, 
traceability identifies other requirements that may be affected by the 
change. You define traceability relationships in the Requirements 
Traceability tab of the Requirements module. You can add traceability 
links to and from a selected requirement.

requirement type

A category for a requirement that describes the purpose of the 
requirement, such as a functional requirement, or a testing 
requirement. You assign each requirement to one of the 
Quality Center default requirement types, or to a customized 
requirement type that the project administrator can create.

risk-based quality management (RBQM)

A feature that assists you in determining a testing strategy for your 
requirements, based on risk and functional complexity, testing time, 
and the resources you have available. You work with risk-based quality 
management in the Risk tab of the Requirements module.
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S

source library

You can create a new library by importing an existing library from the 
same project or from a different project. A source library is a library 
used as the basis for creating another library. 

system field

A Quality Center default field for entering data in a Quality Center 
project. System fields cannot be added or deleted, only modified.

T

template project

A customized project used to apply a common set of project 
customizations to other projects as a part of cross project 
customization. Enables you to standardize policies and procedures 
across projects in your organization.

template test

A test that includes common steps you often want to perform as part 
of other tests. You can mark a manual test in the test plan tree as a 
template test so that you can easily select it for calling from another 
test.

test

One or more steps you define to verify a specific function or 
requirement of your application. You can create manual tests, or 
automated tests that are executed by a testing tool. You organize your 
tests in a test plan tree, a hierarchical structure that divides your 
application into testing units, or subjects. 

test coverage

The links you create to keep track of the relationship between your 
requirements and tests. In the Requirements module, you create test 
coverage by selecting tests to link to a requirement. Test coverage 
assists you in assessing the impact of a change in the test or 
requirement. A requirement can be covered by more than one test.
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test instance

A test that is included in a test set. Each test that you add to a test set 
is known as a test instance. You can add more than one instance of a 
test to a test set. You can also include the same test in multiple test 
sets.

Test Lab module

Functional area of Quality Center accessible by selecting the Test Lab 
button in the sidebar. This module enables you to create and manage 
test sets, and perform test runs. You can schedule tests to run either 
manually or automatically.

Test Plan module

Functional area of Quality Center accessible by selecting the Test Plan 
button in the sidebar. This module enables you to develop and 
manage tests in a hierarchical tree-structure. Tests can be linked to 
requirements and defects.

test resource

Test resources are files or folders stored in the Quality Center 
repository that are used by tests. A test resource can be used by one or 
more tests. For example, a test resource can be a data file containing 
data needed as input for a number of tests.

Test Resources module

Functional area of Quality Center accessible by selecting the Test 
Resources button in the sidebar. This module enables you to manage 
test resources in a hierarchical tree-structure. Test resources can be 
associated with tests.

test run

The execution of a test instance in a test set. You run tests in the Test 
Lab module. You can run tests manually or automatically, schedule 
the date and time of test runs, and set the conditions for when a test 
can be run. You can view results for a single test run, or view and 
compare details of all the runs for a selected test instance.
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test set

A group of tests in a Quality Center project designed to achieve a 
specific testing goal, such as sanity or regression testing. Grouping the 
tests in your project into test sets helps you organize test execution to 
meet your testing goals. You can assign test set folders to cycles.

test step

Detailed instructions on how to execute a test. Can include the action 
to perform on your application, the input to enter, or the expected 
outcome.

U

user-defined field (UDF)

Data fields that you can add to a Quality Center project. You can 
customize user-defined fields to meet the specific needs of your 
organization.

V

version control

Tracks changes made to entities in your project, by maintaining 
previous versions of entities. In a version control enabled project, 
version history is maintained for entities, including requirements, 
tests, test resources, and business components. You can view and 
compare previous versions of an entity, or restore a previous version.

W

Word add-in

You can import requirement or test plan data from a Microsoft Word 
document to a Quality Center project. To import from Word, you first 
install the HP Quality Center Microsoft Word Add-in on your client 
machine.

workflow

A feature that offers tools to generate or edit scripts used to customize 
fields and values of the Quality Center modules, and to control the 
actions that users can perform. You can customize workflow from the 
Workflow page, available from the Project Customization window.
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A

Actual execution rate, Progress tab 138, 139
Actual Fix Time, Defects Grid 474
actual value, test parameters 322
Add and Link Defect button 501
Add Comment button 486
Add Entity to Query button 629
Add Favorite dialog box 94, 96
Add Graph link 639
Add Graph to Dashboard Page button 563
Add Host to Host Group button 439
Add Object command 699
Add Object dialog box 699
Add Parameter to Query button 633
Add Query button 629
Add report as attachment check box 235
Add Requirement Traceability button 211, 

212
Add Step button, manual test run 428
Add Sub Report button 618
Add Tests to Test Set button 388, 389
Add Time Dependency To Flow button 413
Add to Coverage button

Req Coverage tab 293
Test Coverage tab 297

Add to Favorites command 94, 96
Add to Traceability button 212
AddDefect VAPI-XP function 702
AddDefectUI VAPI-XP function 702
Add-ins Page command 22
AddStepToRun VAPI-XP function 702
Adjust Rows Height button 311
Adobe Reader 19
advanced filters 61
advanced test set 382
alerts 75
Alerts button 80, 486

Alerts dialog box 81
Alerts flag 80
All Runs view 449
Analysis command

Graph Wizard 570
Graphs 575
Reports 608

Analysis Results tab 237
analysis tree 559
Analysis View tab 560
analyzing projects

Document Generator 647
Live Analysis graphs 637

Arrange Layout button, Execution Flow 418
ASCII sort order 65
Assign To Cycle dialog box 183, 385
Assign To Release dialog box 183
Assigned requirements, Progress tab 140
Assigned To, Defects Grid 474
attachments

attaching a file 87
attaching a snapshot 88
attaching a URL 87
attaching items from Clipboard 90
attaching system information 89
deleting 92
modifying 91
saving 91
viewing 90

Attachments dialog box 86
Attachments tab, Defect Details dialog box 

486
Attachments tab, Defects Grid 470
Attachments view, Requirement Details 

dialog box 186
Authenticate button 40
Author, Requirements module 171

Index
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Auto Complete Children check box 203
Automated tab, Test Instance Properties 

dialog box 454
automated tests

generating test script 328
running 431
running manually 421
when not to automate 328
when to automate 327

Automatic Runner dialog box 434
Automation tab

Notifications 391
On Failure 392

Available Columns list 53
Available Fields list 66

B

Back button 45
Back to Steps Grid button 426
Bar Chart button 584
Baseline ID, Libraries module 508
Baseline Name, Libraries module 543
baselines

comparing 518
configuring comparison settings 522
creating 515
examples 515
pinning a test set 525
viewing baseline history 524

Begin Run button 425
Broken Links Verification dialog box 517
Browsers command 697
Business Components module 45
Business Criticality tab 225
Business Criticality, definition 224
Business Process Testing 45
Business Process, test type definition 268
By ID (Trace From) command 212
By ID (Trace To) command 212

C

Call to Test button 308
calling manual tests 307
camera icon 88

Cancel Run button, manual test run 425
Change Password dialog box 48
Change Project command 46
Check In button 109
Check In command 107
Check In dialog box 107
Check Out button 112
Check Out command 106
Check Out dialog box 105, 106
Check Spelling button

New Defect 181, 480
Send Mail 196, 277, 493

Check Spelling command 46
Check Syntax command 699
checking in entities 106
checking out entities 104
checkout

automatic 105
manual 105

Choose Type of Purge dialog box 406
Clear All button 81
Clear button, New Defect dialog box 480
Clear button, New Requirement dialog box 

181
Clear Filter button 71
Clear Filter/Sort button 71, 450
Clear Filter/Sort, Test Coverage tab 295
Clear Method, VAPI-XP 704
Clear Output button 706
Clear Pinned Baseline command 526
Clear Test Sets Filter/Sort command 71
Clear Tests Filter/Sort command 71
clearing history 49
Clipboard button 90
Closed in Version, Defects Grid 474
Closing Date, Defects Grid 474
Collapse command

requirements tree 192
test plan tree 272

Comments
Requirements module 171
Test Grid 260

Comments pane, Defects Grid 470, 474, 486
Comments tab, test plan tree 270
Comments, test resource tree 345
Compact View button, manual test run 426
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Compare Baselines Tool dialog box 520
Compare button 111, 525
Compare Entities button 547
Compare Entities dialog box 528
Compare Libraries Tool dialog box 545
Compare To button 519, 544
Compare To Source button 544
comparing defects 481
Comparison Settings button 523, 547
Comparison Settings dialog box 523
condition, setting for a test run 411
Configuration tab, dashboard pages 562
Configuration tab, Excel reports 626
Configuration tab, graphs 578
Configuration tab, standard reports 615
Configuration view, Test Instance Properties 

dialog box 452
Confirm Purge Request dialog box 407
Confirm Reset Test Set dialog box 404
Considered Fields list 523
Continue button, All Runs view 450
Continue Manual Run command 429
Contract button, dashboard pages 563
Convert all requirements to subjects 201
Convert lowest child requirements

to design steps 201
to tests 201

Convert to Tests command 201
Copy button

requirements tree 197
VAPI-XP 700

Copy Filter Settings button 71
Copy From button 329
Copy Graph To Clipboard button, 

Dashboard module 585
Copy Selected Text to Clipboard button 706
Copy Steps button, Design Steps tab 312, 313
Copy Test Settings button 395
Copy to Clipboard command 419
Copy URL command 198, 283, 350, 402, 

494
copying

defects 493
design steps, across projects 313
design steps, same project 312
requirements 197

test resources, across projects 349
test resources, same project 348
test sets, across projects 400
test sets, same project 400
tests, across projects 281
tests, same project 281
URL of a defect 494
URL of a requirement 198
URL of a test 283
URL of a test resource 350
URL of a test set 402

coverage
analyzing 298
requirements 290
tests 294

Coverage Analysis 298
Coverage Analysis button 299
Coverage Analysis dialog box 298, 660
Coverage Analysis view 165
Coverage calculation by cycle box 299
Coverage Chart 295
coverage grid

Req Coverage tab 290
Test Coverage tab 294

Coverage Type
Req Coverage tab 290
Test Coverage tab 294

Create Baseline button 516
Create Baseline log 518
Create Library dialog box 514
Create New Requirement dialog box 180
Create New Requirement Folder dialog box 

179
Create New Test dialog box 267
Create Report For This Defect button 486
Create Test Instance dialog box 389, 390
Created By, Libraries module 508
Created By, Linked Defects Grid 499
Created By, test resource tree 345
Created By, Traceability Grid view 213
Creation Date

Libraries module 508
Linked Defects Grid 499
Requirements module 171
Test Grid 260
test plan tree 270
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test resource tree 345
Traceability Grid view 213

Creation Time, Requirements module 171
Cross filter by section 64
Cross Filter dialog box 64
cross filters 61

filtering tests not in any test set 64
filtering tests with no requirement 

coverage 64
cross-project graphs 581
Custom button 196, 277, 493
Custom Sort option, test plan tree 283
Custom Zoom dialog box 419
Customization tab, Document Generator 

655
Customize command 46, 47
Cut button, Releases module 144
Cycle ID 124
cycles. See releases tree

D

Dashboard module
at a glance 558
creating analysis item 560
dashboard pages 561
developing trees 559
Excel reports 623
graphs 569
managing items and folders 565
standard reports 612

dashboard pages
configuring 562
creating 561
overview 561
viewing 563

dashboard tree 559
Dashboard View tab 561
Data Grid button, Dashboard module 584
Database Type button 628
databases supported by Quality Center 35
date, specifying for a test run 411
Days progress bar, Progress tab 139
Debug Mode, VAPI-XP tests 706
Defect Details dialog box 485

Defect ID
Defects Grid 474
Linked Defects Grid 499

defect links
adding 501
direct 497
indirect 497
overview 497
removing 502
viewing 500

Defect Opening Rate graph, Quality tab 141, 
142

Defects button 468
Defects button, All Runs view 450
Defects check box, Document Generator 679
Defects Grid

adding defects 479
column definitions 474
copying 493
copying URL 494
deleting defects 495
finding and replacing 487
mailing defects 490
matching defects 481
matching text 481
printing defects 494
updating defects 485
updating multiple records 489
viewing defect history 489

Defects link, Document Generator 679
Defects menu, Defects module 471
Defects module

at a glance 467
column definitions 474
Defects Grid 477
generating project documents 679
graphs 593
main window 468
menu bar 471
overview 478
standard reports 607
toolbar 472
workflow 463

Delete Alert button 81
Delete button

All Runs view 450
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folders in Test Lab module 403
Releases module 145
test plan tree 285
test sets in Test Lab module 404
VAPI-XP 700

Delete command
Defects Grid 495
requirements tree 199

Delete Host button 439
Delete Host Group button 439
Delete Resource dialog box 355
Delete Selected button

attachments 92
Design Steps tab 312
manual test run 428

Delete Selected Tests button, Test Grid 259
Delete Sub-Report button 618
Delete Test dialog box 286
demonstration project 41
dependencies

Dependencies tab 357
Used By grid 358
Using grid 358
viewing 357

Dependencies tab
Test Plan module 253
Test Resources module 348

Description
Defects Grid 474
details of test run 448
Libraries module 508
Releases module 124
releases tree 134, 135
Requirements module 171
Test Grid 260
test resource tree 345

Description command 203
Description of Criterion box 225, 226, 228
Description tab

Defects Grid 470
Requirements module 157, 160, 163, 

166
test plan tree 270

Design Step Editor 303
design steps

adding 305

arranging columns 312
calling manual tests 307
copying, across projects 313
copying, same project 312
definition 303
deleting 312
finding and replacing 314
modifying 309
renumbering 311
reordering 311
resizing 311

Design Steps tab, Test Plan module 253, 304
Designer

Test Grid 260
test plan tree 270

Details tab
Defect Details dialog box 486
Releases module 134, 135
Requirements module 160
Test Plan module 252, 270

Details tab, Test Lab module 387
Details tab, Test Resources module 342, 344
Details view

Requirement Details dialog box 186
Test Instance Properties dialog box 

447
Detected By, Defects Grid 474
Detected in Cycle, Defects module 474
Detected in Release, Defects module 474
Detected in Version, Defects Grid 475
Detected on Date, Defects Grid 475
Direct Cover Status, Requirements module 

171
Document Generator 647

Document Generator tree 657
formatting project documents 651
generating and viewing project 

documents 681
launching 650
overview 648
project data 657
specifying Defects module data 679
specifying Requirements module data 

658
specifying Test Grid data 666
specifying Test Lab module data 670
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specifying Test Plan module data 662
Document Settings tab, Document 

Generator 651
Documentation Library 19
documentation updates 22
Domain list, Login window 41
Domain, Libraries module 543
Download and Open button, attachments 90
DownLoadAttachment VAPI-XP function 

703
Drill Down Results dialog box 641, 644
drill down, graphs 585
Duplicate Cycle button 144

E

Edit Categories button 588
Edit Group By Categories dialog box 588
Edit menu

Test Lab module 370
Test Plan module 254

Edit Parameter button, Excel reports 633
Edit Step button 310
Edit X-Axis Categories dialog box 588
editions, Quality Center 725
Editor button 700
Enable Log check box, Automatic Runner 

dialog box 434, 436
Enable Manual Test Run Confirmation 

command 423
End Date

Releases module 124
releases tree 134, 135

End Run button, manual test run 425, 427, 
428

Enterprise Edition, defined 725
entities

copying test sets or test set folders 
between projects 400

copying tests or subject folders 
between projects 281

deleting tests 285
Entities pane, Excel reports 628
entity dependencies

copying test sets or test set folders 
between projects 400

copying tests or subject folders 
between projects 281

deleting tests 285
Entity Name

Req Coverage tab 290
Test Coverage tab 294

Entity Status
Req Coverage tab 290
Test Coverage tab 294

Estimated development time box 223
Estimated DevTime, Test Grid 260
Estimated Fix Time, Defects Grid 475
Excel

exporting grid data from Quality 
Center 74

importing to Quality Center 36
Excel reports

adding parameters 630
creating 625
creating SQL queries 626
post-processing script 634
running 635
security settings 634

Exclude command 203
Exclude from Analysis check box 223
Exec Date

details of test run 448
Execution Grid 376

Execute (Debug Mode) command 706
Execute (Test Mode) command 707
Execute Script button 706, 710
Executed coverage, Progress tab 140
executing test sets 431
executing tests

automatically 431
manually 421

Execution Condition dialog box 414
Execution Conditions tab, Run Schedule of 

Test dialog box 411
execution conditions, setting 411
Execution Flow 409

adding a condition 412
adding time dependency 411
adding time dependency to flow 413
arranging tests sequentially 417
at a glance 378
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changing the magnification level 419
deleting all conditions and 

dependencies 416
deleting conditions 415
deleting time dependency 416
editing conditions 414
editing time dependency 415
finding a test 418
overview 409
running tests automatically 431
running tests manually 421
showing full test names 419
test sets 381
toolbar 379
viewing test results 443
viewing tests in hierarchical layout 

418
viewing the Execution Log 436
zooming in 418
zooming out 419

Execution Flow tab 369
Execution Grid

at a glance 373
column definitions 376
finding and replacing 441
ordering tests 439
replacing field values 399
running tests automatically 431
running tests manually 421
test sets 381
toolbar 374
viewing test results 443
viewing the Execution Log 436

Execution Grid tab 369
Execution Log 436
Execution Report link, Defect Details dialog 

box 486
Execution Status, Test Grid 260
exiting Quality Center 41, 44
Expand All command, requirements tree 192
Expand button, dashboard pages 563
Expand command, test plan tree 272
Export All Grid Data dialog box 74
Export command 74
Export Selected Grid Data dialog box 74
Export Word Document command 302

exporting grid data 74

F

Fail All command 427
Fail Selected button, manual test run 427
Failed requirement status 171
Failure Probability tab 226
Failure Probability, definition 224
Favorite Bar command 95
favorite views 93

adding 94
changing properties 96
definition 93
deleting 96
loading 95
private folder 93
public folder 93
recently used 95
updating 95

File button 87
filter box in a grid 60
Filter Condition box 58
Filter dialog box

Filter tab 57
Group tab 69
View Order tab 66
with advanced filters 63

Filter/Sort command 57, 66, 71
filters

advanced/cross 61
clearing 71
copying 71
drop-down user list 55
filtering tests not in any test set 64
filtering tests with no requirement 

coverage 64
grouping users 55
refreshing 71
searching users 55
setting 56
viewing user groups 55

Find button
Req Coverage tab 292
Requirements Traceability tab 211
Test Coverage tab 297
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Find command
Defects Grid 487
Execution Grid 441
requirements grid 188
requirements tree 187
Test Grid 279

Find dialog box 188, 279, 487
Defects Grid 487
Design Steps tab 315
Execution Grid 441

Find Folder/Test dialog box 278
Find Folder/Test Set command 397
Find in Script button 700
Find Next command

Defects Grid 487
requirements grid 188
Test Grid 279
VAPI-XP 700

Find Requirement dialog box 187
Find Similar Defects button 482, 483
Find Similar Text dialog box 483
Find Test dialog box, Execution Flow 418
Find Test In Flow button 418
Find Text button 315
Find/Replace dialog box 190, 280, 399

Defects Grid 190, 280, 399, 488
Execution Grid 442

Find/Replace Text button 316
First Page button, standard reports 620
Fit Picture In Window button, Execution 

Flow 419
Fixed Columns, Select Columns dialog box 

54
Flag for Follow Up button 83, 486
Flag for Follow Up dialog box 83
flags for follow up

creating 83
modifying and deleting 83
overview 82

Flow, test type definition 268
Folder ID, test resource tree 345
follow up flags

creating 83
modifying and deleting 83
overview 82

Forgot Password link 42

Forward button 45
Full Coverage check box, Test Coverage tab 

295
Full Document button 681
Full Screen View button 640
function test set 382
Functional Complexity tab 228
Functional Complexity, definition 227

G

Generate All Graphs in Page button 564
Generate button, dashboard pages 564
Generate button, Excel reports 636
Generate button, graphs 584
Generate Report button 235
Generate Script button 328
Generate Test dialog box 205
generating automated test scripts 328
Get Hosts on the Network button 438
Get Net button 438
GetInput VAPI-XP function 703
Getting Started 19
Global Parameter check box 632
Glossary 731
Go To Defect button 486
Go to Defect command 470
Go to Entity button 74
Go To Graph in Analysis Tree button 564
Go to Line Number command, VAPI-XP 700
Go to Next Change button 521, 547
Go to Previous Change button 521, 547
Go to Requirement command

Coverage Analysis view 167
Requirement Details view 161
Requirements Grid view 164
Requirements Tree view 158
Test Lab module 372

Go To Requirement in Requirements Tree 
command 291

Go to Test command
Test Grid 259
Test Lab module 372
test plan tree 254

Go to Test in Test Plan Tree button, Test Grid 
259
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Go to Test in Test Plan Tree command 295
Test Lab module 369

Go to Test in Test Set command 295
Test Plan module 273

Graph Appearance dialog box
graphs 587
Live Analysis graphs 645

graph categories 588
graph wizard 570
graphs

configuring 578
creating graphs manually 576
creating quick graphs 575
creating with graph wizard 570
cross-project graphs 581
customizing appearance 587
customizing appearance for Live 

Analysis 645
Defects - Age Graph 605
Defects - Progress Graph 604
Defects - Summary Graph 603
Defects - Trend Graph 606
drilling down 585
editing categories 588
graph types 591
Live Analysis graphs 637
Live Analysis, test set folder 641
Live Analysis, test subject folder 638
overview 569
Requirements - Coverage Graph 596
Requirements - Progress Graph 595
Requirements - Summary Graph 594
Requirements - Trend Graph 597
Test Execution - Progress Graph 602
Test Execution - Summary Graph 601
Test Planning - Progress Graph 599
Test Planning - Summary Graph 598
Test Planning - Trend Graph 600
viewing 583

grid filter box 60
Grid Filters command 61
group criteria

copying 71
setting 67

Group tab, Filter dialog box 69
grouping grid records 67

H

Help button 46
Help on this page command 19
Hide On Run check box 632
Hide Risk-Based Quality Management 

Columns check box 58, 66, 69
history

clearing 49
History tab

Defect Details dialog box 487
Defects Grid 470, 489
requirements tree 193
Test Grid 258
version history 110

History view, Requirement Details dialog box 
186

History view, Test Instance Properties dialog 
box 458

HookDebug Property, VAPI-XP 704
Host Manager 437
hosts 437

adding host group 439
adding to host group 439
definition 431
deleting host 439
deleting host group 439
removing from host group 439

HP Software Support Web site 21
HP Software Web site 22
HTML Document, exporting grid data 74

I

icons for tests 271
Ignored Fields list 523
images, attaching 88
Impact Analysis tab, Requirements 

Traceability 215
Import Library button 538
Import Library log 539
Imported By tab 541
Imported From tab 543
Imported Library icon 536
importing to Quality Center

from Excel 36
from Word 36
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Indicator Columns command
Defects module 469
Execution Grid 258, 373
Requirements Grid 160, 163, 166
Test Grid 157

Information Panel command
Coverage Analysis view 166
Defects Grid 470, 489
Requirements Grid 163
Requirements Tree view 157

Insert Parameter button, test parameters 306
Insert Parameter dialog box, test parameters 

321
Integrated Debugger, VAPI-XP 709
ITG Request Id 388

K

keyboard shortcuts 713
Knowledge Base 21

L

Last Page button, standard reports 621
Last Run Results pane, Execution Grid 373
Last Synchronization 544
Launch button 330
libraries

comparing 544
creating 513
importing
synchronizing 547

Libraries module
at a glance 506
baseline examples 515
comparing baselines 518
comparing libraries 544
configuring comparison settings 522
creating baselines 515
creating libraries 513
deleting baselines 527
deleting libraries 527
examples 534
field definitions 508
Imported By tab 541
Imported From tab 543

Imported Library icon 536
importing a library 536
mailing libraries 550
menu bar 507
moving libraries 526
overview 512
renaming baselines 526
renaming libraries 526
synchronizing libraries 547
toolbar 507

libraries tree. See Libraries module
Library ID 508
Library Name 543
Library Verification dialog box 538
Line Chart button 584
Link Comment, Linked Defects Grid 499
Link Entity Type, Linked Defects Grid 499
Link Existing Defect button 501
Link ID, Linked Defects Grid 499
Link Type, Linked Defects Grid 499
Linkage and Coverage view, Test Instance 

Properties dialog box 457
Linked By Status, Linked Defects Grid 499
Linked Defects dialog box 498
Linked Defects dialog box, for a test run 451
Linked Defects tab 369, 498

Test Instance Properties dialog box 
457

Test Plan module 253
Linked Defects view, Requirement Details 

dialog box 186
Linked Entities tab

Defect Details dialog box 486
Linked Entity ID, Linked Defects Grid 499
Linked Entity Name, Linked Defects Grid 

499
linking defects

adding links 501
directly 497
indirectly 497
overview 497
removing links 502
viewing links 500

Live Analysis graphs
creating in test set folder 641
creating in test subject folder 638
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customizing appearance 645
deleting 644

Live Analysis tab 638, 641
Load from File button, Document Generator 

654
Load from Saved button, Document 

Generator 654
load testing 246
LoadRunner Scenario, test type definition 

267
Login button 41
Logo tab, Document Generator 654
Logout button 41, 44

M

Mail Requirement button 194
Management button 122
Manual Parameters tab, Test Instance 

Properties dialog box 453
Manual Runner - Step Details dialog box 426
Manual Runner dialog box 424
manual tests

converting to VAPI-XP 686
running 421

Manual, test type definition 267
Mark as Template Test command 269, 307
matching defects 481
Maximize Content button 183
Mercury Quality Center Login window 40
Mercury Quality Center Options window 38
Microsoft Excel

exporting grid data from Quality 
Center 74

importing to Quality Center 36
Microsoft Word

exporting grid data from Quality 
Center 74

generating project documents 681
importing to Quality Center 36
rich text 183

missing assessment link 233
Modified

Defects Grid 475
Execution Grid 376
Libraries module 508

Requirements module 171
Test Grid 260
Traceability Grid view 213

Move Field Down button, Filter dialog box 
67

Move Field Up button, Filter dialog box 67

N

Name
Libraries module 508
Releases module 124
Requirements module 171

Name, test resource tree 345
New Baseline dialog box 517
New Cycle button 134
New Dashboard Page dialog box 561
New Defect button, manual test run 427
New Defect command 46
New Execution Condition dialog box 412
New Folder button 179, 384, 513
New Folder dialog box 266, 384
New Host button 438
New Host dialog box 438
New Host Group button 439
New Host Group dialog box 439
New Item button, Excel reports 625
New Item button, graph wizard 570
New Item button, graphs 576
New Item button, standard reports 613
New Library Folder dialog box 513
New Page button 561
New Parameter dialog box, test parameters 

319
New Query Parameter button, Excel reports 

632
New Release button 134
New Release Folder button 133
New Requirement button 180
New Resource button 343
New Resource dialog box 343
New Resource Folder button 342
New Resource Folder dialog box 342
New Step button 305
New Test button 267
New Test Set button 386
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New Test Set dialog box 386
Next Page button, standard reports 621
No Run requirement status 171
No. of Requirements per Risk Category graph 

233
Normal magnification level 419
not assessable link 233
Not Completed requirement status 171
Not Covered requirement status 171
Notifications link 391

O

Old Type (obsolete), Requirements module 
172

On Failure link 392
On Test Failure dialog box 394
Open button, attachments 90
Open Output Text in Web Browser button 

706
Options tab, Document Generator 652
Order Tests dialog box

Execution Flow 417
Execution Grid 439

Organize Favorites dialog box 96
Output command 699
Output tab 699
Outstanding Defects graph, Quality tab 141, 

142
Owner Description, Used By grid 359
Owner ID, Used By grid 359
Owner Name, Used By grid 359
Owner Type, Used By grid 359

P

packaging, Quality Center 725
Page Setup button, Document Generator 655
Page Setup dialog box, Document Generator 

656
Parameter details dialog box, Test Plan 

module 320
Parameters of Test dialog box 323
parameters, in Excel reports 630
parameters, manual tests 317
Pass All command 427

Pass Selected button, manual test run 427
Passed coverage, Progress tab 140
Passed requirement status 171
password

changing 47
reset 42

Paste button, VAPI-XP 700
Paste command, releases tree 144
Paste command, requirements tree 198, 199
Paste Design Steps to Target Project dialog 

box 314
Paste Filter Settings button 71
Paste Resources to Target Project dialog box 

350
Paste Steps button, Design Steps tab 313, 314
Paste Test Sets/Test Set Folders to Target 

Project dialog box 401
Paste Test Settings button 395
Paste Tests/Subject Folders to Target Project 

dialog box 282
pasting release folders, releases, and cycles 

144
pasting requirements 198, 199
Path, Test Grid 261
Pending Check In command 108
Pending Check In dialog box 108
Percent of Similarity box 484
Perform Risk Analysis button 233
performance testing 246
Pie Chart button 584
Pin to Baseline command 525
Pinned to Baseline dialog box 525
Planned Closing Version, Defects Grid 475
Planned coverage, Progress tab 140
Planned Exec Date

details of test run 448
Execution Grid 376

Planned Exec Time
details of test run 448
Execution Grid 376

Planned Host Name
details of test run 449
Execution Grid 376

post-processing script, Excel reports 634
Premier Edition, defined 725
Preview button, Document Generator 681
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Previous Page button, standard reports 620
Print command, in Defects Grid 494
Print Graph button, graph toolbar 585
Print Method, VAPI-XP 704
Print Output button 706
Priority

Defects Grid 475
Requirements module 172

private folder, in favorites 94, 97
privileges 35
Product, Requirements module 172
Progress tab, Releases module 137
project databases 35
Project list, Login window 41
Project, Defects Grid 475
Project, Libraries module 543
Properties dialog box 96
properties, changing 47
public folder, in favorites 94, 97
Purge Runs command 405

Q

QAInspect Test 268
Quality Center

changing projects 46
editions 725
exiting 41, 44
keyboard shortcuts 713
Login window 40
main window 43
Options window 38
overview 25
Quality Center URL 38
starting 38

Quality tab, Releases module 141
QualityCenter_Demo project 41
Query Builder 626
Query Parameters tab 628
Query Results tab 628
quick graphs 575
quick standard reports 608
QuickTest Professional, test type definition 

268

R

RBQM Business Impact 172
RBQM Custom Business Impact 172
RBQM Custom Failure Probability 172
RBQM Custom Functional Complexity 172
RBQM Custom Risk 172
RBQM Custom Testing Hours 172
RBQM Custom Testing Level 172
RBQM Date of Last Analysis 173
RBQM Effective Business Impact 173
RBQM Effective Failure Probability 173
RBQM Effective Functional Complexity 173
RBQM Effective Risk 173
RBQM Estimated RnD Effort 173
RBQM Exclude from Analysis 173
RBQM Failure Probability 173
RBQM Functional Complexity 173
RBQM Risk 173
RBQM Testing Hours 173
RBQM Testing Level 174
RBQM Use Custom Business Impact 174
RBQM Use Custom Failure Probability 174
RBQM Use Custom Functional Complexity 

174
RBQM Use Custom Results 174
RBQM Use Custom Risk 174
Readme 19
Refresh All button

Releases module 140, 143
Req Coverage tab 292
Requirements module 192
Select a Test dialog box 308
Test Coverage tab 212
test plan tree 272

Refresh All command
Req Coverage tab 292

Refresh button, Test Coverage tab 297
Refresh Filter/Sort button 71
Refresh Test Sets Filter/Sort command 71
Refresh Tests Filter/Sort command 71
regression test set 382
Related Description, Using grid 360
Related ID, Using grid 359
Related Name, Using grid 360
Related Type, Using grid 359
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Relationships tab, Requirements Traceability 
213

Release ID 124
Releases module 122

adding cycles 134
adding releases 134
assigning requirements 182
assigning test set folders to cycles 385
at a glance 121
field definitions 124
menu bar 123
modifying the tree 143
pasting folders, releases, and cycles 

144
Progress tab 137
Quality tab 141
releases tree 127
statistics 136
toolbar 123
viewing assigned requirements 136
viewing assigned test set folders 136
viewing coverage progress 137
viewing defects 141
workflow 115

Releases tab 122
releases tree 127

adding cycles 134
adding releases 134
deleting folders, releases, and cycles 

145
duplicating cycles 144
modifying 143
moving folders and releases 144
overview 128
renaming folders, releases, and cycles 

143
root folder 133
statistics 136
viewing assigned requirements 136
viewing assigned test set folders 136
viewing coverage progress 137
viewing defects 141

Remaining days in cycle, Progress tab 139
Remaining days in release, Progress tab 138
Remaining test instances to run, Progress tab 

138, 139

remote execution 431
remote hosts, setting up 437
Remove All Execution Conditions dialog box 

416
Remove button, dashboard pages 563
Remove Execution Condition command 415
Remove From Coverage button, Test 

Coverage tab 297
Remove from Traceability button 217
Remove Graph button 644
Remove Host From Host Group button 439
Remove Link button 502
Remove Saved button, Document Generator 

654
Remove Selected button, Req Coverage tab 

293
Remove Test’s Execution Conditions 

command 415
Remove Tests from Test Set button 400
Remove Time Dependency command 416
Rename command

Releases module 143
requirements tree 197
test plan tree 285
test resources 354
test set 403

Renumber Steps button 311
reordering design steps 311
Replace All button, VAPI-XP 700
Replace button, VAPI-XP 700
Replace command

Defects Grid 190, 280, 399, 488
Execution Grid 399, 442
requirements tree 189

Report Selected command 609
Report Selected with Children command 609
reporting defects

adding defects 479
at a glance 467
Defects Grid 474
deleting defects 495
finding and replacing 487
mailing defects 490
matching defects 481
matching text 481
updating defects 485
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viewing defect history 489
workflow 463

reports
Excel reports 623
generating project documents 647

reports. See standard reports
Reproducible, Defects Grid 475
Req ID, Requirements module 174
Req Parent, Requirements module 174
Reqs Coverage tab, Test Plan module 253
Required execution rate, Progress tab 138, 

139
Requirement Details button 185
Requirement Details dialog box 185
Requirement Details view 159
Requirement Trace ID, Traceability Grid view 

214
Requirement Type, Requirements module 

175
requirements

adding traceability 211
finding 187
finding in grid 188
finding in tree 187
removing traceability 217
replacing field values in grid 190
trace from links 208
trace to links 208
updating multiple records 198
viewing traceability 213, 215

Requirements button 155
Requirements check box, Document 

Generator 659
requirements coverage 290

adding requirements 291
analyzing 298
example 288
overview 287
removing requirements 293
viewing 291

requirements grid
copying URL 198
field definitions 171
finding requirements 188

Requirements Grid view 162

Requirements link, Document Generator 
659

Requirements module
assigning requirements to releases or 

cycles 182
coverage 294
Coverage Analysis 298
Coverage Analysis view 165
creating requirements 179
field definitions 171
generating project documents 658
graphs 591
mailing a requirement 194
menu bar 167
pasting requirements 198, 199
Requirement Details view 159
Requirements Grid view 162
Requirements Tree view 156
standard reports 607
toolbar 169

requirements traceability 207
adding 211
removing 217
trace from links 208
trace to links 208
viewing 213, 215

Requirements Traceability view 186
requirements tree

assigning requirements to releases or 
cycles 182

copying a requirement 197
copying URL 198
creating 179
creating tests from 200
deleting a requirement 199
expanding and collapsing 192
field definitions 171
filtering 192
finding requirements 187
mailing a requirement 194
moving a requirement 199
overview 178
refreshing 192
renaming a requirement 197
replacing field values 190
replacing values 189
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showing in Test Plan module 292
tests coverage 294
viewing requirement history 193
zooming out 192

Requirements Tree view 156
requirements, replacing values in tree 189
reset password 42
Reset Test Set command 404
Reset Titles button 587, 645
Resource ID, test resource tree 345
Resource Viewer tab 347
Resources root folder, test resource tree 342
resources. See test resources
Responsible Tester

details of test run 448
Execution Grid 376

Restrict to current filter check box 73
results for test run 443
Resume Execution button, VAPI-XP 712
Reviewed, Requirements module 175
rich text 183
RichContent tab, Requirement module 183
Risk Assessment tab 223, 225
Risk Category, determining 224
Risk tab, Requirement Details view 223, 230, 

232, 235
Risk view, Requirement Details dialog box 

186
risk-based quality management 219

defining settings 229
determining Risk Category 224
example 239
finalizing testing policy 231
restoring default constants 231

risk-based quality management report 234
Run All Tests Locally check box 434
Run button

Execution Flow tab 423, 433
Execution Grid tab 423, 433

run conditions, setting 411
Run Events view, Test Instance Properties 

dialog box 455
Run Manually button

Execution Flow tab 423
Execution Grid tab 423

Run on Host, Automatic Runner dialog box 
434

Run post-processing check box 635
Run Query button 630
Run Schedule of Test dialog box

Execution Conditions tab 411
Time Dependency tab 413

Run Steps dialog box 451
Run Test Set button

Execution Flow tab 433
Execution Grid tab 433

run VAPI-XP function 705
Run VC Status 102
Run VC User 102
Run VC Version 102
running test sets 431
running tests

automatically 431
manually 421

Runs check box, Document Generator 676
Runs link, Document Generator 676
RunTest VAPI-XP function 701
RunTestSet VAPI-XP function 701

S

sanity test set 382
Save and Apply to Children button 234, 235
Save button, Document Generator 654
Save Graph Data button 584
Save Steps button 306
scheduling test execution 409
scope 150
script, generating 328
Scroll To The Left button, graph toolbar 584
Scroll To The Right button, graph toolbar 

584
Search Results dialog box

Execution Flow 418
requirements tree 187
test plan tree 278
test sets tree 397

search text 72
Searchable Fields Information button 74
security testing 246
Select a Test dialog box 308
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Select Cleanup Test dialog box 392, 456
Select Columns button, Design Steps tab 312
Select Columns command, Design Steps tab 

312
Select Columns dialog box 53
Select Destination Subject dialog box 204
Select Fields dialog box 196, 277, 493
Select Filter Condition dialog box 58
Select Host dialog box 434
Select Projects button 581
Select Recipients dialog box 195, 276, 353, 

492
Select Req button 292
Select Test Set dialog box 707
Select Test Sets to Purge dialog box 405
Select Tests button, Test Coverage tab 296
Select Tests button, test plan tree 388, 389
Send by E-mail button

defects 491
tests 275

Send E-mail dialog box
defects 490
requirements 194
test resources 352
tests 275

Set Filter/Sort button 57, 66, 450
Set Filter/Sort button, Requirements module 

192
Set Filter/Sort, Requirements Traceability tab 

212
Set Filter/Sort, Test Coverage tab 295, 297
Set Graph Appearance button 587, 641, 644, 

645
Set Test Sets Filter/Sort command 57, 66
Set Tests Filter/Sort command 57, 66
Set to Default button 395
Settings per test button 394
Severity, Defects Grid 475
sharing. See importing libraries
shortcuts 713
Show Advanced Filter arrow 63
Show All button, graph toolbar 584
Show Full Path command 291
Show Full Test Names command 419
Show Last Run Results command 373
Show only Template Test check box 308

Show Parameters button, test parameters 426
Show Requirements command 136, 137
Show Run Steps button, All Runs view 450
Show Test Set Folders command 137
Show Variables button 711
Show/Hide Browsers button 697
Show/Hide Total Values button 584
Similar Defects dialog box 482
Site Administrator, viewing messages from 

50
Sleep VAPI-XP function 705
Snapshot button, Attachments dialog box 88
Snapshot dialog box, Attachments dialog 

box 88
Sort Ascending button, Filter dialog box 67
sort criteria

clearing 71
copying 71
refreshing 71

Sort Descending button, Filter dialog box 67
Sort Folders button 283
Sort Folders in Test Plan Tree dialog box 283
Sorted Fields list 66
Source Library Owner, Libraries module 544
Spelling and Grammar command

Check Spelling 46
Spelling Options 46
Thesaurus 46

Spelling Options button
New Defect 181, 480
Send Mail 196, 277, 493

Spelling Options command 46
SQL pane 629
SQL queries, Excel reports 626
standard reports

adding sub-reports 617
configuring 615
creating in Dashboard module 612
creating quick reports 608
overview 607
predefined reports 610
report types 614
viewing 620

Start Date
Releases module 124
releases tree 134, 135
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Starter Edition, defined 725
starting Quality Center 38
Statistics, Releases module 124
Status

Defects Grid 475
details of test run 449
Execution Grid 376
Test Grid 261
test plan tree 270

Status Filter list, Test Coverage tab 295
Step command 203
Step Into button 710
Step Out button 711
Step Over button 710
steps, test steps 303
Stop button

Automatic Runner dialog box 435
Document Generator 682
VAPI-XP 706

Stop Debugging button 712
stress testing 246
Subject

Defects Grid 475
Test Grid 261

Subject command 203
subject folders

adding to test plan tree 265
definition 264
deleting 285
finding in test plan tree 278
renaming 285
sorting in test plan tree 283

Subject Tests check box, Document 
Generator 664

Subject Tests link, Document Generator 664
Subject Tree check box, Document 

Generator 662
Subject Tree link, Document Generator 662
sub-reports 617
Summary pane, Defects Grid 470
Summary, Defects Grid 475
Synchronize button 550
Syntax Check button 699
System Info button 89
System Information dialog box 89
System Test, test type definition 268

System tests 331

T

Take Default Values button 323, 453
Target Cycle

Defects module 476
Execution Grid 376
Requirements module 175

Target Release
Defects module 476
Requirements module 175

TDHelper Object, VAPI-XP 701
TDInput Object, VAPI-XP 703
TDOutput Object, VAPI-XP 704
template test 307
Template Test command 269
Template, Test Grid 261
Test command 203
test coverage

removing test instances from 297
removing tests from 297
viewing 295

Test Coverage view, Requirement Details 
dialog box 186

test execution
automatically 431
manually 421
test sets 431

Test Grid 257
column definitions 260
copying URL 283
deleting tests 259
finding a test 279
generating project documents 666
mailing a test 275
main window 257
replacing field values 280
toolbar 259
updating multiple records 281

Test ID, Test Grid 261
Test Instance Properties dialog box 443

All Runs view 449
Automated tab 454
Configuration view 452
Details view 447
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History view 458
Linkage and Coverage view 457
Linked Defects tab 457
Manual Parameters tab 453
Run Events view 455

Test Instance Runs progress bar, Progress tab 
139

test instances, linking to a requirement 294
Test Lab button 368
Test Lab check box, Document Generator 

670
Test Lab link, Document Generator 670
Test Lab module

assigning test set folders to cycles 385
at a glance 367
Automation tab 369
Execution Flow tab 369
Execution Grid tab 369
generating project documents 670
graphs 592
Linked Defects tab 369
Live Analysis graphs 641
main window 368
menu bar 370
running tests automatically 431
running tests manually 421
Select Tests toolbar 372
standard reports 607
Test Set toolbar 371
test sets 381
viewing test results 443
workflow 363

Test List check box, Document Generator 
667

Test List link, Document Generator 667
test management process 27

planning tests 31
running tests 33
specifying requirements 29
tracking defects 34

Test Name, Test Grid 261
test parameters

assigning actual values 322
defining 319
inserting in design step 321

setting parameter values for manual 
test instances 452

Test Plan
Dependencies tab 357

Test Plan button 252
Test Plan module

at a glance 251
automating tests 327
generating project documents 662
graphs 592
Live Analysis graphs 638
main window 252
menu bar 254
requirements coverage 290
standard reports 607
Test Grid 257
test parameters 317
test plan tree 263
test steps 303
toolbar 255
workflow 245

test plan tree 263
adding tests 266
copying URL 283
creating 265
deleting folders or tests 285
expanding and collapsing 272
finding a folder or test 278
mailing a test 275
overview 264
refreshing 272
renaming folders or tests 285
requirements coverage 290
showing in Requirements module 

296, 297
showing in Test Lab module 388, 389
sorting folders 283
test icons 271
viewing 272

Test Query button 630
test resources

adding a resource file 342
adding a resource folder 342
copying URL 350
copying, across projects 349
copying, same project 348
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creating a tree 342
deleting 355
downloading 347
filtering 351
finding 351
mailing 352
managing 339
moving 354
renaming test resources 354
Resources root folder 342
uploading 346
viewing dependencies 348
viewing history 356

Test Resources button 341
Test Resources module, Dependencies tab 

357
Test Run Schedule command 411
Test Script tab 253, 329
test script, generating 328
test sets 381

adding 386
adding tests to 388
assigning folders to cycles 385
copying, across projects 400
copying, same project 400
definition 381
deleting folders 403
deleting test sets 404
finding in tree 397
overview 382
pinning to a baseline 525
purge runs 405
removing tests from 400
renaming 403
resetting 404
running tests 431
setting notifications 390
setting On Failure rules 392
types 382

Test Sets check box, Document Generator 
672

Test Sets Filter/Sort button 57, 66
Test Sets Grid command 386
test sets grid, copying URL 402
Test Sets link, Document Generator 672
Test Sets menu, Test Lab module 370

test sets tree
assigning folders to cycles 385
copying URL 402

Test Sets Tree command 384, 386
test sets tree, tests coverage 294
test steps 303
test steps, editing during test run 428
Test Type list, Test Plan module 267
TestDirector, see Quality Center
Tester

details of test run 449
Execution Grid 376

Testing Level 229
testing policy

defining settings 229
finalizing 231

Testing Policy grid 231
Testing Time 229
tests

adding to test plan tree 266
automating 327
continuing manual run 429
copying, across projects 281
copying, same project 281
creating from requirements tree 200
creating test steps 303
deleting from test plan tree 285
finding in Test Grid 279
finding in test plan tree 278
linking requirements to a test 290
linking tests to a requirement 294
renaming in test plan tree 285
replacing field values in grid 399
running automatically 431
running locally 434
running manually 421
running remotely 434
scheduling test runs 409
test sets 381
types 267
viewing all 257
viewing run results 443

Tests check box, Document Generator 673
tests coverage 294

adding test instances 296
adding tests 296
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analyzing 298
example 289
overview 287

Tests Coverage Chart 301
Tests Coverage dialog box 302
Tests Filter/Sort button 57, 66
Tests link, Document Generator 673
Tests menu

Test Lab module 370
Test Plan module 254

Text Property, VAPI-XP 704
text search 72
Text Search button 73
Thesaurus button

New Defect 181, 480
Send Mail 196, 277, 493

Thesaurus command 46
Time

Execution Grid 376
specifying for a test run 411

Time Dependency icon 415
Time Dependency of Test dialog box 415
Time Dependency tab, Run Schedule of Test 

dialog box 413
Time, details of test run 449
Toggle Breakpoint button 709
Toggle Breakpoint command 709
toolbars

Defects module 472
Execution Flow 379
Execution Grid 374
Releases module 123
Requirements module 169
Select Tests 372
Test Grid 259
Test Plan module 255
Test Set 371

Tools button 45
Customize command 46
Document Generator command 650
New Defect command 46

Total allocated testing time box 233
Total days in cycle, Progress tab 139
Total days in release, Progress tab 138
Total test instances for cycle, Progress tab 

139

Total test instances for release, Progress tab 
138

Total Testing Time per Risk Category graph 
233

Trace Comment, Traceability Grid view 214
Trace Existing Requirement dialog box 212
trace from links 208
Trace From Tree view 215
trace to links 208
Trace To Tree view 215
Traceability Grid view 213
traceability, requirements 207

adding 211
removing 217
trace from links 208
trace to links 208
viewing 213, 215

tracking defects
adding defects 479
at a glance 467
Defects Grid 474
deleting defects 495
finding and replacing 487
mailing defects 490
matching defects 481
matching text 481
updating defects 485
viewing defect history 489
workflow 463

Troubleshooting and Knowledge Base 21
Type, Test Grid 261
Type, test resource tree 345

U

Unattached folder, test plan tree 285
Undo Check Out button 109
Undo Check Out command 108
Unload button, Document Generator 654
Update Selected command 70, 198, 281, 489
updates, documentation 22
updating multiple records 70
Upload Selected button, attachments 91
UpLoadAttachment VAPI-XP function 703
URL button 87
URL for Quality Center 38
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URL, copy 198, 283, 350, 402, 494
Use custom Business Criticality check box 

226
Use custom Failure Probability check box 

227
Use custom Functional Complexity check 

box 228
Use custom Risk check box 227
Used By grid 358
user groups 35
user privileges 35
User Properties link 48
User Properties window 48
user properties, changing 47
users

grouping 55
searching 55
selecting 55
sorting 55

Using grid 358

V

VAPI-XP
API 701
test type definition 268

VAPI-XP tests 685
creating 686
debugging 709
editing 696
running in debug mode 706
running in test mode 707

Variables command 711
Version Check Out Date, Requirements 

module 176
Version Check Out Time, Requirements 

module 176
Version Checked Out By, Requirements 

module 176
version control

automatic checkout 105
cancel changes 107
checking in entities 106
checking out entities 104
examples 103
manual checkout 105

non-versioned fields 103
overview 100
undoing checkout 107
viewing checked out entities 108
viewing version history 109
working with 99

Version Date, Test Plan module 262
version history 109
Version Number

Requirements module 176
Test Plan module 262
test resource tree 345

Version Owner, Test Plan module 262
Version Status

Requirements module 176
Test Plan module 262

Version Time, Test Plan module 262
Versions and Baselines tab 110
View By Group check box 56
View Graph in Full Screen button 564
View menu

Test Lab module 370
Test Plan module 254

View Order tab, Filter dialog box 66
View Page in Full Screen button 564
View Runs list, All Runs view 450
View tab, dashboard pages 563
View tab, graphs 583
View tab, standard reports 620
viewing site administrator messages 50
views, favorite 93
Visible Columns list 53
Visual Basic script, Excel reports 634

W

Warn Before Check Out command 105
Web page, attaching 87
Welcome Page 41
What’s New command 19
Window Screen button 696
WinRunner Automated, test type definition 

267
WinRunner batch test 272, 432
WinRunner parameters 454
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Word
exporting coverage analysis to 302
exporting grid data from Quality 

Center 74
generating project documents 681
importing to Quality Center 36

Word Document, Export command 302
WrapArray VAPI-XP function 705

X

XML document, exporting grid data 74
XTools Object, VAPI-XP 705

Z

Zoom In button, Execution Flow 418
Zoom In button, graph toolbar 584
Zoom Out button, Execution Flow 419
Zoom Out button, graph toolbar 584
Zoom Out One Level button 192
Zoom Out To Root button 192
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