Summary
When running an IR Query using special characters ($,%,#,+,@,&,*) no results are returned even though characters exist in brief.description and update.action.
Error
No results returned for IR Query using special characters.
Steps to reproduce
1) Login into ServiceCenter 6.2 system
2) Select Incident Management
3) Select Search IM Tickets
4) Run a true search
5) Select 1st record in list and add &&&& or ++++ or %%%% to text in brief description (may also add characters when prompted for an update).
6) Save changes to record
7) Go back to search (apm.search.probsummary.g)
8) Select IR Query tab
9) In IR Search Text add &&&& or use any of the characters that were added to brief.description and update.action.
10) Select Search
11) No results returned
Cause
This is a limitation within IR searching. In stepping through the RTE, special characters are removed before the search is performed.
Fix
No workaround exists. SCR 43183 has been opened as an enhancement request