HP Quality Center Synchonizer cannot connect to ClearQuest

  • KM634296
  • 31-Mar-2009
  • 07-May-2013

Summary

The following error is returned when attempting to connect from QC Synchronizer to ClearQuest: ERROR #1- adapter.CONNECTION_FAILURE : Failed to connect to endpoint of type ClearQuest

Error

When starting synchronization between Quality Center (QC) and ClearQuest (CQ), the Quality Center connection validates correctly, but when checking the connection to ClearQuest the user gets the following error:

ERROR #1- adapter.CONNECTION_FAILURE : Failed to connect to endpoint of type ClearQuest. Error: com.hp.qc.synchronizer.adapters.exceptions.AdapterConnectionException: Failed to connect. Reason: AutomationException: null.
ERROR #2- Failed to connect. Reason: AutomationException: null
ERROR #3- AutomationException: null

Steps to reproduce the problem:

1. Open Quality Center Syncrhonizer
2. Connect to the server
3. Click on link, select Create
4. Set up general properties:

- Endpoint 1: Quality Center
- Endpoint 2: Clear Quest

5. Click Next
6. Assign QC endpoint, connection properties:

- User name: [QC_Username]
- Password: [QC_Username_Password]
- Server URL:
http://[QC_Server_URL]:[Port_Number]/qcbin/
- Domain: [QC_Domain]
- Project: [QC_Project]

7. Click Next
8. Assign ClearQuest endpoint properties:

- User name: [ClearQuest_Username]
- Password: [ClearQuest_Password]
- Database: [ClearQuest_DB]
- SchemaRepository: [ClearQuest_SchemaRepository]

9. Click Next or click Check Connectivity, the error pops up

 

Cause

This particular error message, indicates that there are some permission issues to connect to ClearQuest.

Fix

  • Check that the Synchronizer Client is installed on the same machine as the Synchronizer Server
  • Check that the ClearQuest client installed on the Synchronizer Server and that it is connected to a ClearQuest database
  • Check that a QC client is installed on the Synchronizer Server
  • Make sure that the user that is running the Synchronizer Service have permissions to 'Log on as a Service' and that the Group Policy (GPO) does not remove the permission (It's on page 24 of the Synchronizer Installation manual)
  • Check that the PostgreSQL service is running and make sure that no previous PostgreSQL installations was present before
  • Make sure to launch the ClearQuest client using the sync service account, then connect to the CQ schema/database.