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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty statements 
accompanying such products and services. Nothing herein should be construed as constituting an additional 
warranty. HP shall not be liable for technical or editorial errors or omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. Consistent 
with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software Documentation, and 
Technical Data for Commercial Items are licensed to the U.S. Government under vendor's standard 
commercial license.

Copyright Notices

© Copyright 2003 – 2009 Hewlett-Packard Development Company, L.P.

Trademark Notices

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation.

UNIX® is a registered trademark of The Open Group.
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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product support service. 
Contact your HP sales representative for details.
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Support

You can visit the HP Software Support Online web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and support that HP 
Software offers.

HP Software Support Online provides customer self-solve capabilities. It provides a fast and efficient way to 
access interactive technical support tools needed to manage your business. As a valued support customer, you 
can benefit by using the HP Software Support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many also require a 
support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 

To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 
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1 Introduction
HP Operations Smart Plug-ins (SPIs) work in conjunction with HP Operations Manager 
(HPOM) to help you monitor, detect, solve, and prevent problems in your enterprise IT 
environment. The combination of HPOM and SPIs enables you to simplify the following tasks 
in your IT resource:

• Monitoring availability and health

• Detecting performance lapse

• Detecting, preventing, and solving problems

• Documenting problem solutions

• Generating reports

Microsoft Exchange SPI

The Microsoft Exchange SPI enables you to oversee your distributed Microsoft Exchange 
environment from a central, easy-to-use console. With the help of the Microsoft Exchange SPI, 
you can:

• Increase Microsoft Exchange availability and performance

• Reduce support costs associated with the Microsoft Exchange services

• Improve capacity management and planning for Microsoft Exchange

With the Microsoft Exchange SPI integrated into the HP Operations Manager (HPOM), you 
can apply the performance and problem management processes that you use for networks and 
systems to monitor Microsoft Exchange Server.

After you install and configure, the Microsoft Exchange SPI will monitor critical Exchange 
application/database resources including:

• Processes (for monitoring the amount of CPU time being used by core Exchange 
processes)

• Inactive Processes (for monitoring core Microsoft Exchange processes for activity and 
status)

• Exchange Services (for monitoring Exchange Server processes for activity levels)

• Message Transfer Agent (MTA) and Simple Mail Transfer Protocol (SMTP) message 
process data

• MTA Work Queue and SMTP Queues

• IS Public and Private/Mailbox Average Delivery Time

• Cluster environments

• Unified communication environment
11



The Microsoft Exchange SPI sends the information to the HPOM console through messages 
and alerts. You can also view the information in the form of reports or graphs. 

Upgrading a Microsoft Exchange Node from DCE to HTTPS

If an Exchange server node is already managed under a DCE agent, make sure the HP 
Performance Agent log files are cleared before re-managing it under HTTPS. 

To clean the log files, run the following command:

C:\usr\OV\bin\OpC\monitor\ddfutil.exe 
"C:\usr\OV\exspi\dsi\log\exspi_data" -rm all

Working with the Microsoft Exchange SPI

The Microsoft Exchange SPI collects data from managed nodes according to rules and 
schedule specifications contained within the Microsoft Exchange SPI templates. The 
Microsoft Exchange SPI collects data related to health, availability, and performance of 
Microsoft Exchange Server. The Microsoft Exchange SPI stores the collected data into a data 
store on the managed node and sends alert messages to the HPOM message browser.

Data Collection

When the collection’s scheduled time occurs, the Microsoft Exchange SPI collector/analyzer 
program runs and, if required, forwards metric values to the data store on the node. At the 
same time, the Microsoft Exchange SPI compares the collected metric data against predefined 
threshold settings and triggers alarms when violations occur.

The collected data is stored into the data store residing on the managed node, at pre-defined 
intervals. 

Messages appear in the HPOM Message Browser with message details containing instruction 
text to help you diagnose problems. If HP Performance Manager is present, you can generate 
graphs from metric values. If HP Reporter is installed, you can view reports generated from 
the collected metric values.

Microsoft Exchange SPI Components

The following components appear on the HPOM management server after you install the 
Microsoft Exchange SPI:

• Templates

• Applications

• Service maps

• Message groups

• Reports and graphs
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Microsoft Exchange SPI Templates

Templates include the details that help the SPI collect data from managed nodes at a regular 
interval of time, compare the data against preset thresholds, and generate alarms in the event 
of threshold violation. The Microsoft Exchange SPI provides you with a range of templates 
that enable you to monitor the health of your Exchange environment. Installing the Microsoft 
Exchange SPI adds the SPI for Exchange template folder to the HPOM console tree. You can 
double-click SPI for Exchange to display the Exchange 2007, Exchange 2003, and Exchange 
Service Discovery folders. By selecting a template group in the console tree, you can see the 
underlying templates and template sub-groups in the details pane.

For a complete listing of templates, see the HP Operations Smart Plug-in for Microsoft 
Exchange Server Reference Guide.

Microsoft Exchange SPI Service Discovery

The Microsoft Exchange SPI discovers Exchange services on HPOM managed nodes. 
Exchange service discovery requires the HP Service Navigator, which can be installed on the 
management server with other components when HPOM is installed initially, or installed 
alone at a later date. Refer to the HPOM Installation Guide for more details.

Microsoft Exchange SPI Service Maps

The service graph generated by the Microsoft Exchange SPI Service Discovery application is a 
snapshot of the Exchange services on the managed nodes at the time at which the application 
is run. The discovered Exchange topology is maintained in HPOM and dynamic views are 
available of its current state in the service maps and views.
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Figure 1 Example Service Map

Template Groups

The top level of the template Groups is:

SPI for MS Exchange

Exchange 2007

Exchange 2003

Exchange Service Discovery

Exchange 2007

The templates for Exchange 2007 are organized into the Standard Groups. In those folders 
the templates are arranged in the following groups:

• Availability

• EXSPI Client Access (EX2007)

• EXSPI Cluster(EX2007)
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• EXSPI Edge Transport Server

• EXSPI Hub Transport Server

• EXSPI EXBPA Integration

• EXSPI Mailbox Server

• EXSPI Unified Messaging Server

Refer to the SPI for Microsoft Exchange Server Reference Guide for more information on the 
templates for Exchange 2007.

Exchange 2003:

The templates for Exchange 2003 are organized into Specialized Groups and Standard 
Groups. In those folders the policies are arranged in the following groups:

EXSPI Specialized Groups

• EXSPI Exchange Server

– EXSPI Message Delivery

– EXSPI Server Availability

– EXSPI Server Transaction Logs

• EXSPI Site Replication Server

EXSPI Standard Groups (Ex2003)

• EXSPI Availability

• EXSPI Client Access (Ex2003)

– EXSPI IMAP4

– EXSPI MAPI

– EXSPI OWA

– EXSPI POP3

• EXSPI Cluster (Ex2003)

• EXSPI Directory

• EXSPI Information Store (Ex2003)

– EXSPI Epoxy (Ex2003)

– EXSPI Full Text Index

– EXSPI Mailbox (Ex2003)

– EXSPI Performance (Ex2003)

– EXSPI Public Folder (Ex2003)

– EXSPI Transaction Log

– EXSPI Virus Scan

• EXSPI Messaging

– EXSPI MTA

– EXSPI NNTP

– EXSPI SMTP
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– EXSPI Tracking Log

• EXSPI OVO Exchange SPI core

– EXSPI Data Collection

For a complete listing of templates, see the HP Operations Smart Plug-in for Microsoft 
Exchange Server Reference Guide.

Exchange Service Discovery

This group contains EXSPI_Discovery_2k7 and EXSPI_Discovery_2k3 for service discovery.

Template Types 

Within the Exchange group are:

•  Schedule templates that determine when and what metrics are collected

•  Monitor templates that implement the actual metric condition (threshold, object, 
message text, instructions, etc.) 

• Message templates that intercept the Microsoft Exchange SPI messages

• Logfile encapsulator templates that monitor for Exchange server related messages in 
the Windows event log, and send them to the HPOM Message browser. 

For information on customizing template settings, see Basic Customization on page 67.

Microsoft Exchange SPI Application Groups and Applications

The Microsoft Exchange SPI applications enable you to perform certain tasks on managed 
nodes to simplify monitoring Microsoft Exchange Server. Applications also help you configure 
the managed nodes to facilitate data collection process.

You can view the Microsoft Exchange SPI applications in the OVO Application Bank window 
under EXSPI Admin, in the Exchange 2007 and Exchange 2000 and 2003. To open the 
OVO Application Bank, select Window > Application Bank.

Figure 2 EXSPI Admin Application Group in the OVO Application Bank Window
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Exchange 2000 and 2003 Applications

Figure 3 Exchange 2000 and 2003 Microsoft Exchange SPI Applications

In the Exchange 2000 and 2003 group are the following applications:

• EXSPI Add DataSource: Microsoft Exchange SPI application to configure data sources 
and start the logging of data.

• EXSPI MBOX Config: Starts the mailbox configuration program that automatically 
creates a mailbox.

— The script supports two options. The syntax is:        

exspi_e2k_cfg [-m mailBoxName] [ -ou OU ]

– -m (optional parameter) is the mailBoxName prefix.

– -ou (optional parameter) is the Organizational Unit.

– If the -m parameter is not specified, the default prefix is MSXSPI.

– The mailbox enabled service account is created as MSXSPI<hostname>. This 
mailbox name is added to the exspi\defaults file as line MAILBOX mailBoxName.

– If the -ou parameter is not specified, the mailbox will be created in the USERS 
container. 

— By default a mailbox named MSXSPI<hostname> is created on the Exchange server 
where "hostname " is the name of the Exchange server. 

— The mailbox is created hidden from the GAL.

• EXSPI Node Config: Configures the service account with special Exchange privileges 
(MSXSPI) on the managed node. This account is for templates distributed in the 
Advanced Configuration section.

• EXSPI Ping Config: Configures the Advanced Configuration template: End To End 
Message Ping.

• Self-Healing Info: This application gathers system information (command output, 
configuration, log and trace files), and writes this data to a file which HP support services 
can use during troubleshooting. For more information, see Self-Healing Information for 
Enhanced Troubleshooting on page 113. 
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• Enable Message Tracking (for Exchange 2003 only): Turning message tracking on will 
cause the Exchange server to write tracking log files. The Microsoft Exchange SPI track 
log schedule template parses these log files to collect data for the four tracklog reports: 
Exchange Top Destinations, Exchange Top Recipients, Exchange Top Senders, and 
Exchange Top Sources.

• Enable EXSPI Tracing: Enables tracing; default setting is OFF. This application is 
generally used for troubleshooting. When tracing is turned on the results are written to:  
%OvAgentDir%\exspi\log\trace.                                              Note: The trace file will 
grow very large. It is advisable to leave tracing enabled only long enough to recreate the 
problem, or in order to comply with HP support instructions.

• Disable EXSPI Tracing: Disables tracing; (default tracing setting is OFF). 

• Enable Data Logging: Starts Microsoft Exchange SPI data logging, the default setting 
is ON. This is normally used after Disable Data Logging, to restart data logging.

• Disable Data Logging: Stops Microsoft Exchange SPI from logging data.

• EXSPI Cluster Config: The Exchange Cluster Config application prints apminfo data, 
which can be used to create the apminfo.xml file used by the Microsoft Exchange SPI to 
recognize clustered instances. For further information about Microsoft Exchange SPI 
monitoring clusters, see Using the Microsoft Exchange SPI in High-Availability 
Environments on page 61. Regarding privileges: This application can be run as any 
account that has the ability to read wmi, such as a Domain admin or an Exchange admin 
account

• Mount Exchange DB: This application can search for and mount dismounted mailboxes 
or public folder store databases. It requires the user name and password of a special 
account that has Exchange administrative privileges, as the application must be modified 
with this info before executing, see Creating a Service Account for Exchange 2003 Nodes 
on page 131. 

     The application can take one or all of the following parameters: 

— -s    Search for dismounted databases.

— -m  Search for dismounted databases and attempt to mount any found.

— -p   Print the output.

— -a   Forward an alarm message to the HPOM Management server.

— -t   Timeout: the time the tool can take to re-mount a dismounted database (in 
seconds). If not provided, the script will automatically set the timeout value to be 5 
seconds. If the database cannot be remounted within the time frame given, you can set 
a higher timeout value, e.g. 30 seconds. If remounting the dismounted database still 
fails, and there is not an error in the output of the tool, there is probably a problem 
with the Exchange information store service. 

• EXSPI List CODA Data Sources: Lists the data sources and objects in CODA. Run it 
after executing "EXSPI Add DataSource" so you know if the EXSPI_DATA data source 
was created or not.
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Exchange 2007 Applications

Figure 4 Exchange 2007 Application Bank

In the Exchange 2007 group, the following applications are included

• Create Data Sources: The Create Data Sources application helps you create databases 
on managed nodes. This application creates databases into the configured data store for 
your HPOM environment. Without running this application, you cannot log information 
on a managed node.

• Register DataCollector: The Register DataCollector application registers necessary 
COM components on the nodes.

• Start ExData Collection Manager: Use this application to start the Collection 
Manager process on a managed node.

• Start PowerShell Collector: Use this application to start the PowerShell Collector 
process on a managed node.

• Stop PowerShell Collector: Use this application to stop the PowerShell Collector 
process on a managed node. 
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• Stop Collection Manager: Use this application to stop the Collection Manager process 
on a managed node.

• Set EXSPI Trace Levels: This application sets the trace levels on managed nodes. 
Launch this application if you need to collect troubleshooting information from nodes.

Microsoft Exchange SPI Message Groups and Messages

Figure 5 OVO Message Group Bank Window

There are three Microsoft Exchange SPI message groups located in the OVO Message Group 
Bank window and all messages generated by the Microsoft Exchange SPI fall into one of these 
message groups. They are:

1 EXSPI: contains messages generated by Exchange-SPI programs. They contain 
instruction text to help to diagnose/remedy problems.

2 EX_Perf: contains messages regarding Exchange performance.

3 EX_Fault: contains messages regarding error conditions.
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Microsoft Exchange SPI Reports and Graphs

Microsoft Exchange SPI Reports

Microsoft Exchange SPI reports come in a separate package, EXSPI-Reporter.msi which is 
found in the HP Operations Manager for Unix Application CD-ROM. HP OV Reporter can be 
used to access the Microsoft Exchange SPI data source (EXSPI_DATA) on managed nodes, 
and generate reports using Crystal Reports. 

For Exchange 2003 reports, see Microsoft Exchange SPI Reports on page 79 for complete lists 
of out-of-the-box Microsoft Exchange SPI reports.

Microsoft Exchange SPI Graphs

Microsoft Exchange SPI graphs include HP Performance Manager graphs for Exchange 2003 
and 2007. HP Performance Manager graphs require an installation procedure. See Installing 
Microsoft Exchange SPI Graph templates on page 105 for details.

For a list of available graphs, see Exchange 2003 Graphs on page 109.
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2 Installation and Configuration
This chapter offers instructions for installing, configuring and removing Microsoft Exchange 
SPI components. It covers the following topics:

• Prior to installing Microsoft Exchange SPI

• Installing and configuring the Microsoft Exchange SPI

• template Groups: installation considerations

• Installation and Basic Configuration

• Advanced Configuration

• Removing the Microsoft Exchange SPI

• Deleting Microsoft Exchange SPI templates, applications and message groups. 

Prior to Installation

• This version of the SPI works with HPOM/OVO for UNIX 8.28, 8.29, and 8.30. Verify your 
current HPOM/OVO version.

• Before installing this version of the Microsoft Exchange SPI, you must remove any 
previous version of the Microsoft Exchange SPI (see Removing the Microsoft Exchange 
SPI on page 40).

• The installation of Microsoft Exchange SPI depends on the following pieces of software, 
verify that they are present on the management server before installing the Microsoft 
Exchange SPI: 

— DSI2DDF 2.25.10.0 or higher

— SPI-SHS-OVO 2.40.000 or higher

You can install these component from the HP Operations Smart Plug-ins DVD.

• Microsoft Exchange SPI reports require HP Reporter, and the Microsoft Exchange SPI 
EXSPI-Reporter.msi must be installed on a Windows node in the same domain where 
Microsoft Exchange SPI is managing nodes.

• You can install Microsoft Exchange SPI graph templates on an HP Performance Manager 
server with the HPOvSpiExGc.msi file, which is included in the HP Operations Smart 
Plug-ins DVD.

• Service Discovery Framework (SPI-SVCDISC-OVO) version A.02.010 must be present on 
management server. You can install this component from the HP Operations Smart 
Plug-ins DVD.
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Pre-Installation Task

Before the start installing the Microsoft Exchange SPI on the management server, make sure 
that you have installed HP Operations agents on the management server.

Installing the Microsoft Exchange SPI

To install the Microsoft Exchange SPI on the HPOM management server from the command 
line interface, follow these steps: 

1 Insert the Microsoft Exchange SPI DVD into the DVD-ROM drive of the management 
server.

2 Run the following command:

For an HP-UX management server, enter:

swinstall -s /cdrom/OV_DEPOT/11.OHPUX.depot EXSPI

For a Solaris management server, enter:

pkgadd -s /cdrom/OV_DEPOT/SOLARIS.sparc EXSPI

The installer installs the Microsoft Exchange SPI on the management server.

Configuring the Microsoft Exchange SPI

After you install the Microsoft Exchange SPI, you must configure it to monitor the Microsoft 
Exchange Server nodes in your organization. The configuration process involves adding nodes 
to the management server, enabling the Microsoft Exchange SPI to discover nodes, and so on.

Prerequisite

Before you start configuring the Microsoft Exchange SPI, you must create a Microsoft 
Exchange user account with necessary user privileges, which can be used by the SPI to 
achieve service discovery.

Prerequisites to Monitor Exchange 2003 Nodes

Create a user on the domain controller with the user name— msxspi. This user must be a 
member of the following groups:

— Exchange Domain Servers

— Domain Users

— Local Administrator on all Exchange 2003 nodes that you want to monitor

Prerequisites to Monitor Exchange 2007 Nodes

If you want to monitor Microsoft Exchange Server 2007, the msxspi user must have the 
privileges of an Exchange View Only administrator. Also ensure that the user also has the 
privileges of a Local Administrator of the Microsoft Exchange Server.
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Add Nodes

After you install the Microsoft Exchange SPI on the HPOM management server, a new node 
group—EXSPI—is created. You must add all Microsoft Exchange Server nodes to this group. 
To add Exchange nodes to the EXSPI node group, follow these steps:

1 In the Root window, click Window → Node Group Bank. The OVO Node Group Bank 
window opens.

2 In the Root window, click Window → Node Bank. The OVO Node Bank window opens.

3 Select a node in the OVO Node Bank window, and then drag and drop the node on EXSPI 
in the OVO Node Group Bank window.

4 Repeat step step 3 to add another available node.

Alternatively, follow these steps:

1 In the root window, click Window → Node Group Bank. The OVO Node Group Bank window 
opens.

2 In the OVO Node Group Bank window, double-click EXSPI. The Node Group: EXSPI 
window opens.

3 In the Node Group: EXSPI window, click Actions → Node → Add. The Add Node dialog box 
opens.

4 Specify details of the Exchange node that you want to add, and then click OK.

5 Repeat step 2 to step 4 to add another node.

If you do not select to automatically install the agent software on nodes, you must manually 
install agents on the added nodes. Refer to the following documents for more information on 
agent installation on nodes:

• HP Operations Manager Administrator’s Reference

• HP Operations HTTPS Agent Concepts and Configuration Guide

Distribute the Microsoft Exchange SPI Actions, Monitors, and Commands

To collect data from Microsoft Exchange Server nodes, you the Microsoft Exchange SPI 
actions, monitors, and commands must be available on nodes. To distribute the Microsoft 
Exchange SPI actions, monitors, and commands, follow these steps:

1 In the OVO Node Group Bank window, click EXSPI, and then click Actions → Agents → 
Install/Update SW & Config. The Install/Update OVO Software and Configuration window 
opens.

2 In the Install/Update OVO Software and Configuration window, click the following 
components:

— Actions

— Monitors

— Commands
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3 Click Nodes in list.

4 Click Force Update.

5 Click OK.

After successful distribution, the following message is displayed in the message browser:

The following configuration information was successfully distributed: 
Actions, Commands, Monitors
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Review the remactconf.xml File

On HTTPS-agent-based nodes, verify and make sure that the remactconf.xml file in the /
etc/opt/OV/share/conf/OpC/mgmt_sv/ location on the management server contains the 
following content:

<rule>

    <doc>Allow ALL certified actions</doc>

    <allow/>

</rule>

Run the EXSPI Node Config Application

To run the EXSPI Node Config application (EX2007 Node Config for Exchange 2007 nodes), 
follow these steps:

1 Select all the desired Exchange managed nodes. 

2 Drag these nodes and drop them on the EXSPI Node Config application located in the 
EXSPI Admin application group. 

3 When prompted, enter the domain, user and password for the user account (the account 
mentioned in Prerequisite on page 24). 

Skip this procedure if you want to monitor only Exchange nodes with the Local System 
account as $AGENT_USER. 

When you run this application, be sure to enter the correct domain name, user and 
password. This domain is not the DNS domain name but the NT domain name. 
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If you add additional nodes after running this application, you must run this application 
on all newly added nodes.

Initiate Data Collection for Exchange 2007

Skip this section if you do not want to monitor Exchange 2007 nodes. If you are using 
Microsoft Exchange Server 2007, you must initiate the data collection process on nodes after 
running the Create DataSources application. The data collection mechanism on Exchange 
2007 nodes are governed by two daemons — Collection Manager and PowerShell Collector. 
Before you start using the SPI for Exchange 2007 nodes, you must perform the following steps 
to initiate data collection:

1 Open the OVO Node Group Bank window.

2 In the OVO Node Group Bank window, double-click EXSPI. The Node Group:EXSPI 
window opens.

3 Run the Register Data Collector application to register COM components on Exchange 
2007 nodes. Perform the following steps:

a From the Node Group:EXSPI window, drag and drop a node on Register Data 
Collector in the Application Group: Exchange 2007 window. The Output of Application 
No. 2 window appears.

b After the window displays output, click Close.

c Repeat step a through step b for all Exchange 2007 nodes.

4 Run the Create DataSources application to on nodes. Perform the following steps:
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a From the Node Group:EXSPI window, drag and drop a node on Create DataSources in 
the Application Group: Exchange 2007 window. The Output of Application No. 3 
window appears.

b After the window displays output, click Close.

c Repeat step a and step b for Exchange 2007 nodes.

5 Run the Start ExData Collection Manager application to start the Collection Manager 
daemons on nodes. Perform the following steps:
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a From the Node Group:EXSPI window, drag and drop a node on Start ExData 
Collection Manager in the Application Group: Exchange 2007 window. The Output of 
Application No. 5 window appears. 

b Click Close.

c Repeat step a and step b for Exchange 2007 nodes.

6 Run the Start PowerShell Collector application to start the Start PowerShell Collector 
daemons on nodes. Perform the following steps:

a In the Application Group: Exchange 2007, right-click Start PowerShell Collector, and 
then click Modify. The Modify OVO Application: Start-PowerShell-Collector window 
opens.

b In the User Name section, specify the user name and password of an Exchange user 
with the privileges mentioned in Prerequisites to Monitor Exchange 2007 Nodes on 
page 24.
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c From the Node Group:EXSPI window, drag and drop a node on Start PowerShell 
Collector in the Application Group: Exchange 2007 window. The Output of Application 
No. 4 window appears.

d Click Close.

e Repeat step c and step d for Exchange 2007 nodes.

Initiate Data Collection for Exchange 2003

To initiate the data collection mechanism on Exchange 2003 nodes, run the EXSPI Add 
DataSource application on the Exchange 2003 nodes that you want to monitor.

Run Discovery

Run the discovery templates to discover services from the managed Exchange Server nodes. If 
you want to use a user other than  the Local System user as $AGENT_USER, perform the 
tasks in the Prerequisite section. 
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Prerequisite

If you want to use the Local System user as $AGENT_USER on nodes, skip this section and 
go to Run the Discovery Template on page 32.

• For Exchange 2007 nodes:

a Open the exspi_discreg_2k7.txt file from the following location:

For HTTPS 64-bit nodes: /var/opt/OV/share/databases/OpC/mgd_node/
customer/ms/x64/win2k3/cmds/

b Remove the # character from the following line:

#SPI_for_Exchange::ROOT::::EXSPI_SwitchUser_2k7.exe::exchange_discover
y.exe

c Add the # character in the beginning the following line:

SPI_for_Exchange::ROOT::::exchange_discovery.exe

d Deploy the exspi_discreg_2k7.txt file on all Exchange 2007 nodes by distributing 
Actions, Monitors, and Commands.

• For Exchange 2003 nodes:

a Open the exspi_discreg_2k3.txt file from the following location:

For HTTPS 32-bit nodes: /var/opt/OV/share/databases/OpC/mgd_node/
customer/ms/x86/winnt/cmds/

b Remove the # character from the following line:

#SPI_for_Exchange::ROOT::::EXSPI_SwitchUser_2k3.exe::exchange_discover
y.exe

c Add the # character in the beginning the following line:

SPI_for_Exchange::ROOT::::exchange_discovery.exe

d Deploy the exspi_discreg_2k3.txt file on all Exchange 2003 nodes by distributing 
Actions, Monitors, and Commands.

Run the Discovery Template

To run the discovery template, follow these steps:

1 Open the OVO Node Bank window.

2 Select the management server.

3 Click Actions → Agents → Assign Templates from the menu bar.

4 In the Define Configuration window, click Add.

5 In the Add Configuration window, click Open Template Window....

6 In the Message Source Templates window double-click the SPI for MS Exchange group to 
display the subgroups.

If $AGENT_USER is set to a user other than the Local System user when you run discovery, 
make sure $AGENT_USER has sufficient privileges to perform the following tasks:

• Act as part of the operating system.

• Adjust Memory Quotas for a process.

• Replace a process-level token
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7 Double-click Exchange Service Discovery.

8 Select one of the following templates:

• Exchange_Discovery_2k7 for Exchange 2007 nodes

• Exchange_Discovery_2k3 for Exchange 2003 nodes

9 Click Get Template Selection in the Add Configuration window, and the click OK.

10 In the Define Configuration window, click OK.

11 Click Actions → Agents → Install/Update SW & Config.

12 Click Template, and then click OK.

13 If you want to monitor Exchange 2007 cluster nodes, deploy the EXSPI-8X Exchange 
Cluster Discovery SysLog template (from the group SPI for MS Exchange > EXSPI Exchange 
2007 > EXSPI Cluster (EX2007) ) on all cluster nodes.

Assign/Distribute Templates

To assign and distribute templates to managed nodes:

1 Open the OVO Node Bank.

2 Select the desired managed node(s) designated to run Microsoft Exchange SPI.

3 To assign (select) the templates for distribution, click Actions → Agents → Assign 
Templates from the menu bar.

4 In the Define Configuration window, click Add.

5 In the Add Configuration window, click Open Template Window....

6 In the Message Source templates window double-click the SPI for Exchange group to 
display the subgroups.

7 Select, and double-click Exchange 2007 and Exchange 2003. 

8 Select the desired EXSPI template group or individual templates.

9 Click Get Template Selections from the Add Configuration window.

10 Click OK from the Add Configuration window.

11 Click OK from the Define Configuration window.

12 The desired templates have been selected for distribution. Next, distribute them to the 
managed nodes.

13 To distribute the assigned templates, select Actions  → Agents → Install/Update SW & Config 
from the Node Bank menu. 

14 In the Install/Update OVO Software and Configuration window, check the Templates 
checkbox to select it.
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15 Check the Nodes in List and the Force Update checkboxes.

16 If a node was not selected previously, select the node in the node bank and click Get Map 
Selections to list the target node(s), and then click OK to distribute templates to the 
managed node(s).

17 The following message appears in the message browser:

The following configuration information was successfully distributed: 
Templates

Assign Responsibilities for HPOM Operator

All Microsoft Exchange SPI target hosts must be HPOM managed nodes running on HPOM 
intelligent agents. 

1 Log on to HPOM as the HPOM administrator (opc_adm).

a Select Window > User Bank

b Select the opc_adm user

c Choose Actions > User > Modify

d Press the Responsibilities button and use the Responsibilities for Operator 
(opc_adm) window to view messages.
34 Chapter 2



Figure 6 The Responsibilities for Operator window

2 In the Node Group that contains your Exchange managed node, select the following 
Microsoft Exchange SPI message groups:

— EXSPI

— EX_Fault

— EX_Perf

— EXSPI_2007

3 Use the Actions > Browser > Start/Reload from the OVO User Bank menu.

Additional Configuration for Microsoft Exchange Server 2003

You need perform some additional configuration steps depending on your requirement if you 
are using Microsoft Exchange Server 2003.

 Enable Message Tracking

To ensure that all messages routed through a server are added to the HPOM message 
tracking logs you need to enable message tracking. You can record information about the 
sender, the message, and the recipient. If you need to log more detailed information, you can 
also record the subject line of the Email message.
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 Enabling Message Tracking for Exchange 2003

Use the Microsoft Exchange SPI application Enable Message Tracking to set message 
tracking on, for servers only. All messages that are routed through the selected servers will 
then be added to the message tracking logs. This information is collected by the EXSPI-6X 
Dc-TrackLog Data collection templates.You can record information about the sender, the 
message, and the recipient. If you need to log more detailed information, you can also record 
the subject line of Email messages.

The Enable Message Tracking application needs to be modified to include the user name 
and password of a service account that has Exchange administrative privileges. Open the 
Enable Message Tracking application, and add the user name and password.to the Execute 
as User field, before executing.

Figure 7 Enabling Message Tracking for Exchange 2003

If the Internet Mail Service connector does not exist, skip the following steps.
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 Run the EXSPI MBOX Config Application and Create Mailboxes

In addition to the MSXSPI user, a mailbox is required for accessing mailbox and folder 
information, necessary for End to End Message Ping and Reporter Collection templates. Use 
the Microsoft Exchange SPI application MBOX Config (located in the EXSPI Admin 
application group) to create the mailbox:

1 Modify the MBOX Config application. The user name and password of a service account 
with Exchange administrative privileges needs to be given for the application to execute. 
(Change the Execute as User field, add user name and password.) 

2 Run the EXSPI MBOX Config application to configure mailboxes for the Exchange 
servers (you can select multiple nodes simultaneously).

For each Exchange server a mailbox is created with the prefix MSXSPI and Windows 
hostname. For an Exchange 2003 server, it creates the mailbox MSXSPI<host_name> for 
account MSXSPI<host_name> (which it also creates.)

For example, for the node rosspi4.rose.hp.com (Internet name) and Windows name 
ROSSPI4 a mailbox is created called MSXSPIROSSPI4. 

Figure 8 MBox Config application output

In order to create a different mailbox with a different name, see the procedure 
Changing the Mailbox name on page 74.

If you receive an error in the above step or you cannot automatically create mailboxes, you 
must manually complete the following on each Exchange server:

1 For each Exchange server create a mailbox with the prefix MSXSPI and Windows 
hostname.

e For Exchange 2003, create this mailbox with primary Windows account 
MSXSPIROSSPI4 (this must first be created).
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 Set Up Message Ping Server Connections and Alarms 

To measure the round trip time required for a message to travel from one server to another 
and then back to the originating server, you can use the EXSPI-6X End to End Message Ping 
template group. 

Before you can use the End to End Message Ping templates, you must configure the pair of 
servers that you want to test. 

Procedure for EXSPI Ping Config for Exchange2003 Servers

1 Select the Exchange managed nodes that you wish to configure in the OVO Node Bank.

2 Drag these nodes and drop them on the EXSPI Ping Config application located in the 
EXSPI Admin application group, under the appropriate Exchange version.

3 A window appears with the configuration file, as shown in the figure below.

4 Edit the file as necessary, then click Esc.

5 You will be prompted to save the configuration. Accept the default choice [Yes].

6 A validation will be performed to check if the Timeout is greater than the sum of MetSLA 
and AlmostMetSLA. After validation, you will be prompted to accept and install the 
configuration file in the monitors directory: /var/opt/OV/share/databases/OpC/
mgd_node/customer/ms/nt/monitor/

7 You have completed configuring the end-to-end Ping, now distribute monitors to the 
required EXSPI managed nodes. For details about distributing the monitors, see 
Distribute the Microsoft Exchange SPI Actions, Monitors, and Commands on page 25.
38 Chapter 2



The format of the Exchange 2003 EXSPI Ping Config file is:

Src-Srv:Dest-Srv:Timeout:MetSLA:AlmostMetSLA

The user only needs to fill in the following fields:

— Src-Srv

— Dest-Srv

— Timeout (to be entered in seconds, with no suffix)

— MetSLA (to be entered in seconds, with no suffix)

— AlmostMetSLA (to be entered in seconds, with no suffix).

Figure 9 EXSPI Ping Config for Exchange 2003

Set Up Different Conditions/ Thresholds for Different Server Pairs Using OVO Object Field & Alarming     

Alarms can be set to occur with metric EXSPI-60 1002 (Ping). Because you may need to set 
different thresholds for multiple server pairs, the following examples are offered. The 
examples show the syntax to insert in the template Conditions, using the OVO object pattern 
fields so that you can set differing thresholds. Metric 1002 sends the 
"FromMailbox,ToMailbox" in the object pattern fields with the following definitions:

FromMailbox = FromServer:FromMailbox
ToMailbox    = [ToServer]:ToMailbox
where [ToServer] is optional

Config Entry Object

EXCH1:MSXSPIEXCH2:25m:1m:1m EXCH1:MSXSPIEXCH1,:MSXSPIEXCH2
EXCH1:MAILBOXEXCH1:
MAILOXEXCH3:2h:5m:2m

EXCH1:MAILBOXEXCH1,:MAILOXEXC
H3

EXCH2:MAILBOXEXCH2:
MAILOXEXCH4:1h:20m:10m

EXCH2:MAILBOXEXCH2,:MAILOXEXC
H4
Installation and Configuration 39



After completing the advanced configuration steps, you can assign and distribute templates 
from any of the various EXSPI template groups to the managed node(s) running Microsoft 
Exchange Server. 

The EXSPI Advanced/Specialized template groups contain two logfile templates which 
capture Exchange warning and information events. Because Exchange generates numerous 
warning and information events, you might want to assign these templates only for 
troubleshooting Exchange: 

— Logfile EXSPI-6X Exchange Information

— Logfile EXSPI-6X Exchange Warnings

Removing the Microsoft Exchange SPI

This process completely removes the Microsoft Exchange SPI installation from the HPOM 
management server. Any customized templates or copies of Microsoft Exchange SPI default 
templates residing in other HPOM template groups should also be removed. 

Follow these steps in order to ensure a proper removal of the Microsoft Exchange SPI:

Task 1: De-assign Microsoft Exchange SPI Templates from Managed Nodes

Follow these steps to remove Microsoft Exchange SPI templates from your managed nodes:

1 Open the OVO Node Bank window.

2 To de-assign the templates from the node, select Actions>Agents>Assign Templates 
from the menu bar.

3 In the Define Configuration window select all Microsoft Exchange SPI templates or 
template groups, including any user-customized templates.

4 Click Remove Templates.

5 Click OK.

Task 2: Remove Microsoft Exchange SPI software from the management server

Use the following programs to remove the Microsoft Exchange SPI package 

1 Open a terminal window and log on as root.

2 In the terminal window run the following command:

—  For HP-UX: /usr/sbin/swremove EXSPI

— For Solaris: /usr/sbin/pkgrm EXSPI

EXCH3:MSXSPIEXCH3:EXCH4.AM.HP.COM
:
MSXSPIEXCH4:25m:5m:5m

EXCH3:MSXSPIEXCH3,EXCH4.AM.HP.C
OM:
MSXSPIEXCH4

If you are upgrading from an earlier version of Microsoft Exchange SPI, you must remove the 
old version from the management server and the managed nodes before installing the new 
Microsoft Exchange SPI version.
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Task 3: Delete Templates, Applications and Message Groups from the Management Server

After successful removal, Microsoft Exchange SPI templates and certain applications (EXSPI 
admin group) and message groups (EXSPI, EX_Perf, EXSPI_2007, and EX_Fault), must 
be deleted manually. 

1 To delete the Microsoft Exchange SPI Message Source templates, select Window: 
Message Source Templates from the menu bar.

2 Open all Microsoft Exchange SPI template groups and use SHIFT+click to select all 
templates for deletion.

3 Select Delete from All to delete the templates.

4 Click Yes to the message: Do you really want to delete the template(s)?

5 To delete from the EXSPI messages group, from the menu bar select Window>Message 
Group Bank.

6 Select the EXSPI EX_Perf and EX_Fault message groups.

7 From the menu bar select Actions>Message Group>Delete.

8 Click Yes to the message: Do you really want to delete the message groups? 

9 To delete any Microsoft Exchange SPI application groups and their contents, select 
Window: Application Bank from the menu bar.

10 Select all Exchange EXSPI Admin Applications and Graphs.

11 From the menu bar select Action>Application>Delete.

12 Click Yes to the message: Do you really want to delete the application 
groups.

Task 4: Delete Microsoft Exchange SPI Spec Files from the Management Server

Remove regular and compressed EXSPI spec files (EXSPI*.spec, EXSPI*.spec.Z, and 
EX2007*.spec) from the following directories on the management server: 

For HTTPS:

— For Exchange 2003: /var/opt/OV/share/databases/OpC/mgd_node/customer/ms/
x86/winnt/cmds/ 

— For Exchange 2007: /var/opt/OV/share/databases/OpC/mgd_node/customer/ms/
x64/win2K3/cmds/

Task 5: Remove Microsoft Exchange SPI from Managed Nodes

After successfully removing the Microsoft Exchange SPI from the management server, follow 
these steps to remove the Microsoft Exchange SPI software from your managed nodes:

1 Select Actions: Agents>Install/Update SW & Config from the menu bar.

2 Check the following checkboxes to select these components for removal:

• Templates

• Actions

• Monitors

The swremove/pkgrm program removes the files from the file system only. The components 
listed below must be deleted manually:
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• Commands

3 Click the Nodes in List Requiring Update button.

4 If you did not select a node previously, click the Get Map Selections button to list the 
target node(s).

5 Click the Force Update button.

6 Click OK. The following message appears in the message browser:

The following configuration information was successfully distributed:

Templates Actions Commands Monitors

The Microsoft Exchange SPI templates and software have now been removed from the 
selected managed node(s). 
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3 Using the Microsoft Exchange SPI
Like other SPIs, the Microsoft Exchange SPI is easy to use. This chapter describes some 
special usage features and functionality, including:

• Daily Tasks

• Microsoft Exchange SPI template group requirements

• Microsoft Exchange SPI Service Discovery

• Using Microsoft Exchange SPI Service Views

• Data Collection Templates for Exchange 2003 Messaging Ports

• Changing the data collection agent setup

• Command Line Parameters

Daily Tasks

A suggested daily task list for monitoring your Exchange environment with the Microsoft 
Exchange SPI:

1 Use the HPOM message browser to watch for warning and critical messages or multiple 
alarms. Read the associated instruction text.

2 Adjust alarm thresholds if too many alarms are being generated (see Customizing the 
Threshold on page 71).

3 Use the HPOM graphing and reporting applications for additional information, or to view 
history or see trends.

4 Check the active Message Browser frequently. Note the message group a metric belongs 
to:

• EXSPI. Messages generated by EX-SPI programs.They contain instruction text to 
help to diagnose/remedy problems.

• EX_Perf. Messages regarding performance.

• EX_Fault. Messages regarding error conditions.

5 Click Perform Action (if available) from the message or message browser to 
automatically perform a pre-defined operator action. Click Details from the message or 
message browser to view details of the set action.

6 Click Instructions from the message browser or the message itself to read and follow 
suggested instructions to help diagnose/remedy problems (see example below).
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Figure 10 Sample Instruction Text from Microsoft Exchange SPI Alarm Message

7 Use HP Performance Agent to export data if desired. Consult the HP Performance Agent 
User’s Guide for details.

Exspi Template Group Requirements

Some templates in the SPI for Exchange template groups require that particular software 
components/services are installed on Exchange server systems before the distributed 
templates will work, and some require the existence of a service account with special 
Exchange privileges. To create such an account, see Creating a Service Account for Exchange 
2003 Nodes on page 131.

Templates requiring a service account with special Exchange privileges

The following list contains all the templates requiring this special service account for 
Exchange 2003:

• EXSPI-6X Dc-Transaction Log Space Usage

• EXSPI-6X Transaction Log Backup Check

• EXSPI-6X 1h-Public Folder Space Usage

• EXSPI-6X Dc-IS Public Folder Performance

• EXSPI-6X-Dc-Public IS Sum Data

•  EXSPI-6X-Dc-Public Folder Data

• EXSPI-6X-Dc-Mailbox Data

• EXSPI-6X-Dc-Mailbox IS Sum Data

If the agent on the node runs with the Local System account, you can use these templates 
without modifications. Alternatively, you can run these templates with the System account.
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• EXSPI-6X-Dc-IS Mailbox Performance

• EXSPI-6X-1h-Mailbox Space Usage

• EXSPI-6X Dc-Full Text Index

• EXSPI-6X-15m-300001

• EXSPI-6X-Dc SMTP Queues

• EXSPI-6X-Dc SMTP Virtual Server Storage

• EXSPI-6X-Dc SMTP Server Performance

• EXSPI-6X SMTP NDR Percentage

• EXSPI-6X SMTP Outbound Connections Refused

• EXSPI-6X MTA Message Delay

• EXSPI-6X MTA Rejected Inbound Associations

• EXSPI-6X MTA Rejected Inbound Messages

• EXSPI-6X MTA Work Queue Length

• EXSPI-6X MTA Failed Outbound Association

• EXSPI-6X MTA Failed Conversions

• EXSPI-6X Dc-X400 Service MTA Queue

• EXSPI-6X Dc-TrackLog Data

• EXSPI-65-ISClientRPCFailRate

• EXSPI-6X-Dc-OWA Back End

• EXSPI-6X-Dc-OWA Front End

• EXSPI-6X-Dc-POP3 Performance

• EXSPI-6X-POP3FailedConnRate

• EXSPI-6X-POP3RejectedConnRate

• EXSPI-6X-Dc-IMAP4 Performance

• EXSPI-6X-IMAP4FailedConnRate

• EXSPI-6X-IMAP4RejectedConnRate

• EXSPI-6X End to End Message Ping

If you want to use these templates with a user other than the System user or the agent’s 
default Local System account, make sure the user includes all the privileges mentioned in 
Creating a Service Account for Exchange 2003 Nodes on page 131.

While configuring these templates to run with a service account, follow these steps before you 
deploy them on nodes:

1 From the Message Source Template window, double-click the template.

2 Go to the Command text box.

3 Add -s after *.exe.  For example, if the command was specified as exspi_perfmon.exe 
-l -o 102002, change the command to exspi_perfmon.exe -s -l -o 102002.

4 Click OK.
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Table 1 Schedule Template Prerequisites in Exchange 2003 Template Groups

Exchange 2003 template Groups Required Manual Configuration

EXSPI Standard Groups

EXSPI INFORMATION STORE (Ex2003)
EXSPI Transaction Log
 EXSPI-6X Dc-Transaction Log Space Usage                                                                                     
EXSPI-6X Transaction Log Backup Check
EXSPI Public Folder (Ex2003)
EXSPI-6X 1h-Public Folder Space Usage   
EXSPI-6X Dc-IS Public Folder Performance     
EXSPI-6X-Dc-Public IS Sum Data  
EXSPI-6X-Dc-Public Folder Data
EXSPI Mailbox (Ex2003)
EXSPI-6X-Dc-Mailbox Data
EXSPI-6X-Dc-Mailbox IS Sum Data 
EXSPI-6X-Dc-IS Mailbox Performance   
EXSPI-6X-1h-Mailbox Space Usage
EXSPI Full Text Index
EXSPI-6X Dc-Full Text Index

These templates require the completion of tasks 1-3 of
Configuring the Microsoft Exchange SPI on page

EXSPI MESSAGING
EXSPI SMTP
EXSPI-6X-15m-300001
EXSPI-6X-Dc SMTP Queues
EXSPI-6X-Dc SMTP Virtual Server Storage
EXSPI-6X-Dc SMTP Server Performance
EXSPI-6X SMTP NDR Percentage
EXSPI-6X SMTP Outbound Connections Refused
EXSPI MTA
EXSPI-6X MTA Message Delay
EXSPI-6X MTA Rejected Inbound Associations
EXSPI-6X MTA Rejected Inbound Messages
EXSPI-6X MTA Work Queue Length
EXSPI-6X MTA Failed Outbound Associations
EXSPI-6X MTA Failed Conversions
EXSPI-6X Dc-X400 Service MTA Queue
EXSPI Tracking Log
EXSPI-6X Dc-TrackLog Data

These templates require the completion of tasks 1-3 of
Configuring the Microsoft Exchange SPI on page
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 up 
EXSPI Specialized Groups

EXSPI Exchange Server
     EXSPI Message Delivery
           EXSPI-6X End to End Message Ping

This template requires the completion of tasks 1-3 of th
Configuring the Microsoft Exchange SPI on page
In addition:

 - Edit the MBOX Config Application to contain User Passw

- Create mailbox using MBOX Config application

- Configure EXSPI End to End Message Ping template to set
server pairs

Exchange 2003 template Groups Required Manual Configuration
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Table 2 Schedule Template Prerequisites in Exchange 2003 Template Groups

Exchange 2003 Template Groups Required Manual Configuration

EXSPI Standard Groups

EXSPI INFORMATION STORE (Ex2003)
EXSPI Transaction Log
    EXSPI-6X Dc-Transaction Log Space Usage                                                                                     
EXSPI-6X Transaction Log Backup Check
EXSPI Public Folder (Ex2003)
EXSPI-6X 1h-Public Folder Space Usage   
EXSPI-6X Dc-IS Public Folder Performance     
EXSPI-6X-Dc-Public IS Sum Data  
EXSPI-6X-Dc-Public Folder Data
EXSPI Mailbox (Ex2003)
EXSPI-6X-Dc-Mailbox Data
EXSPI-6X-Dc-Mailbox IS Sum Data 
EXSPI-6X-Dc-IS Mailbox Performance   
EXSPI-6X-1h-Mailbox Space Usage
EXSPI Full Text Index
EXSPI-6X Dc-Full Text Index

These templates require the completion of tasks 1-3 of
Configuring the Microsoft Exchange SPI on page

EXSPI MESSAGING
EXSPI SMTP
EXSPI-6X-15m-300001
EXSPI-6X-Dc SMTP Queues
EXSPI-6X-Dc SMTP Virtual Server Storage
EXSPI-6X-Dc SMTP Server Performance
EXSPI-6X SMTP NDR Percentage
EXSPI-6X SMTP Outbound Connections Refused
EXSPI MTA
EXSPI-6X MTA Message Delay
EXSPI-6X MTA Rejected Inbound Associations
EXSPI-6X MTA Rejected Inbound Messages
EXSPI-6X MTA Work Queue Length
EXSPI-6X MTA Failed Outbound Associations
EXSPI-6X MTA Failed Conversions
EXSPI-6X Dc-X400 Service MTA Queue
EXSPI Tracking Log
EXSPI-6X Dc-TrackLog Data

These templates require the completion of tasks 1-3 of
Configuring the Microsoft Exchange SPI on page
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EXSPI CLIENT ACCESS
EXSPI Outlook 2003
EXSPI-65-ISClientRPCFailRate
EXSPI OWA
EXSPI Back End:
EXSPI-6X-Dc-OWA Back End
EXSPI Front End:
EXSPI-6X-Dc-OWA Front End
EXSPI POP3
EXSPI-6X-Dc-POP3 Performance
EXSPI-6X-POP3FailedConnRate
EXSPI-6X-POP3RejectedConnRate
EXSPI IMAP4
EXSPI-6X-Dc-IMAP4 Performance
EXSPI-6X-IMAP4FailedConnRate
EXSPI-6X-IMAP4RejectedConnRate

These templates require the completion of tasks 1-3 of
Configuring the Microsoft Exchange SPI on page

Exchange 2003 Template Groups Required Manual Configuration
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t up 
EXSPI Specialized Groups

EXSPI Exchange Server
     EXSPI Message Delivery
          EXSPI-6X End to End Message Ping

This template requires the completion of tasks 1-3 of th
Configuring the Microsoft Exchange SPI on page
In addition:

 - Edit the MBOX Config Application to contain User Passw

- Create mailbox using MBOX Config application

- Configure EXSPI End to End Message Ping  template to se
server pairs

Exchange 2003 Template Groups Required Manual Configuration
50 Chapter 3



Microsoft Exchange SPI Service Discovery

The Microsoft Exchange SPI contains a scheduled data collection template to discover 
Exchange services on HPOM managed nodes and the EXSPI-6x Exchange Cluster Discovery 
SysLog and EXSPI-6x Exchange Cluster Discovery for discovering Exchange in cluster 
environments. The discovery process can be initiated at any time by running the templates on 
the HPOM management server. Out-of-the-box the templates are set to run once a day at 
00:24 am in the morning, to discover Exchange services.

The service graph generated by the Discovery templates is a snapshot of the services on the 
managed nodes at the time at which the template is run. The discovered Exchange topology is 
maintained in HPOM and is made available in the various dynamic Exchange maps and 
views.

The views of discovered services enable operators to see at a glance the current operational 
status of their Exchange environment, and can help them to analyze events in terms of their 
impact on the overall business service.

Prerequisites for Microsoft Exchange SPI Service Discovery

• Microsoft Exchange SPI service discovery requires the HP Service Navigator, this can be 
installed together with other HPOM components at initial HPOM installation. For details 
on how to install it at a later date, refer to the HPOM Installation Guide.

• The machine where the HPOM management server is installed should also be a managed 
node of that management server, with the HP Operations agent software installed and 
running successfully.

• For Exchange 2003. It is necessary to create a privileged user with the name “msxspi” on 
the domain controller of the domain to which each managed Exchange server belongs, and 
to make this user account a member of  the “Administrators”, “Domain Admins”, “Domain 
Users”, and  “Exchange Domain Servers” groups.

• For each managed node where Exchange Service Discovery should run, make sure that 
the EXSPI Node Config tool is run, using the “msxspi” user account details. Running this 
tool will write and encrypt the local.cfg file with the username and password 
information of the privileged user account [msxspi] on the managed node.

Mechanism for Gathering Service Information

The mechanism the Microsoft Exchange SPI uses to gather service information is a simple 
one: a discovery server on the HPOM management server uses the list of managed nodes as 
parameters to trigger a discovery client on each of the HPOM managed nodes listed. The 
discovery clients on the various HPOM managed nodes use discovery modules that are 
installed during the installation of the agent software, to gather information about the 
services present on the managed nodes. The discovery server writes error messages to the 
following file:

/var/opt/OV/log/SPISvcDisc/discovery_error.log

Tracing can be enabled on the Management server by turning ‘ON’ the SPI_DISC_TRACE 
variable in the EXSPI_DiscConfig.sh file which is found under:
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/opt/OV/EXSPI/bin/

The trace file (discovery_trace_EXSPI.log) can be found on the management server 
from the following location:

/var/opt/OV/log/SPISvcDisc/

The discovery client on the managed node writes generic error information into:

%OvAgentDir%\log\SPISvcDisc\discovery.log

Apart from these files, EXSPI discovery errors can also be found in EXSPI error log file:

%OvAgentDir%\exspi\log\exspierror.

If tracing is enabled, any tracing information can be found in:

%OvAgentDir%\exspi\log\trace

The service configuration files compiled by the discovery process are written to the directory 
on the management server using the following file-naming conventions:

/var/opt/OV/SPISvcDisc/conf/EXSPI/EXSPISvcDisc_<nodename>.xml

where nodename is the name of the node on which discovery has run.

The discovery server validates the syntax of the Service configuration file. If the file is valid, 
discovery server activates the service file and assigns operators to the Root service EXSPI. By 
default, the operator, opc_adm will be assigned. The activated services can be viewed through 
Java GUI of OVO/Unix, when logged in as 'opc_adm'.

Turning off Discovery failure messages:

When Microsoft Exchange SPI Discovery fails to discover services, failure messages are sent 
to the HPOM Management server. To turn off these messages, the user has to modify the file 
EXSPI_DiscConfig.sh located in /opt/OV/EXSPI/bin on the Management server. 

The user has to change MSG_ALLOW=Y to MSG_ALLOW=N. (The default value is Y, which means 
messages are allowed).

Upon successful discovery, a message window will notify that a significant change has 
occurred in the service configuration on the management server, and it is necessary to reload 
the configuration and update the service map.

To Reload The Configuration

1 Logon to the HPOM Java console as the HPOM Administrator opc_adm.

2 Select File-> Reload Configuration.

3 A window will notify that the reload configuration is in progress.

4 View the updated service maps.

Manual Update

Changes to the service configuration of a managed node do not appear automatically in the 
SPI for Exchange Server service tree. In order to update the contents in the OV Service 
Navigator, the Discovery templates have to be run.
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Figure 11 Service Tree View of Service Map

Using Microsoft Exchange SPI Service Views

The Microsoft Exchange SPI integrates with the HP Service Navigator to provide an 
additional perspective on the Exchange organization by offering Service views. This feature is 
available only if the HP Service Navigator software is installed and running and allows 
individual systems to be seen in terms of the configured hardware, the installed software, and 
the operating system services that are running.
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Microsoft Exchange SPI discovers Exchange services when the Microsoft Exchange SPI 
discovery templates are run, and uses the discovered data to generate the service SPI for 
Exchange Server tree. 

Views Are Snapshots

The service graph generated by the Microsoft Exchange SPI is a snapshot of the services on 
the managed nodes at the time at which the EXSPI Discovery templates are run. If the service 
configuration on a managed node subsequently changes, you have to run the discovery process 
again to have the changes reflected in the service tree.

Calculation and Propagation Rules in Discovery Process

Propagation rules for the objects in the SPI for Exchange Server tree are defined by default as 
unchanged. This means that a parent service does not change the status of a child object by, 
for example; attaching a priority to it. Such a scenario would be feasible if a parent service 
considered the status of one child service to be more important than the status of another 
child service.

Calculation rules for the SPI for Exchange Server tree are set by default to Most Critical. 
This means that if a parent service has more than one child service, it assumes the status 
equal to the highest severity of its child services. For more information about calculation and 
propagation rules, as well as how to go about modifying them, see the HP Service Navigator 
Concepts and Configuration Guide.

HPOM messages are associated with all the low-level services and, in addition, the 
higher-level services: Exchange Information store and Exchange Messaging
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Figure 12 Exchange 2003 Service Graph

Data Collection Templates for Exchange Messaging Ports

The EXSPI_PORTS.exe examines the Exchange messaging port availability of an Exchange 
2003 server.

Command line parameters

Usage Syntax: [-a] [-p] [-l] [-m 60, 61…metric number(s) or ranges 60-63] 

[[-x key=value] [...]]

-a: alarming with the management server console

-p: to print out data collected to stdout

-l: to log data collected to the embedded performance agent (Coda)

-m: metric number or range
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 e.g. -m 1006, 1008-1009

-x key=value: to specify argument value

e.g., "-x timeout=10" is to set port connection timeout to be 10 seconds.

Default value for Timeout Interval = 5 seconds.

Metric IDs for Ports:

• SMTP 1006

• POP3 1007 

• IMAP4 1008

• HTTP 1009

Message sent to management server console

The <SMTP/POP3/IMAP4/HTTP (whichever is applicable)> protocol (<1006/1007/1008/
1009(respectively)>) was not available before timeout (<timeout interval> seconds).

Default values for Protocol Ports

SMTP_PORT = 25

IMAP_PORT = 143

POP3_PORT = 110

HTTP_PORT = 80

Templates calling exspi_ports.exe

Template Name: EXSPI-6X HTTP Port Response

Description: Determines if the HTTP port is responsive.

Execution Schedule:    

MINUTE   0, 10, 20, 30, 40, 50

HOUR     0-23

Schedule Program: exspi_ports.exe -a -l -m 1009

USER: $AGENT_USE

Failure Message Details:

SEVERITY: Warning

Message Group: EXSPI

TEXT: EXSPI-6X HTTP Port Response failed.

Template Name: EXSPI-6X IMAP4 Port Response

Description: Determines if the IMAP4 port is responsive.

Execution Schedule:    

  MINUTE   0, 10, 20, 30, 40, 50    
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  HOUR    0-23

Schedule Program: exspi_ports.exe -a -l -m 1008

USER: $AGENT_USER

Failure Message Details:

SEVERITY: Warning

Message Group: EXSPI

TEXT: EXSPI-6X IMAP4 Port Response failed.

Template Name: EXSPI-6X POP3 Port Response

Description: Determines if the POP3 port is responsive.

Execution Schedule:    

MINUTE   0, 10, 20, 30, 40, 50

HOUR     0-23

Schedule Program:  exspi_ports.exe -a -l -m 1007

USER: $AGENT_USER

Failure Message Details:

SEVERITY: Warning

Message Group Name: EXSPI

Message Text: EXSPI-6X POP3 Port Response failed.

Template Name: EXSPI-6X SMTP Port Response

Description: Collects SMTP queue metrics

Execution Schedule:    

MINUTE   1, 11, 21, 31, 41, 51

HOUR     0-23

Schedule Program:   exspi_ports.exe -a -l -m 1006

USER: $AGENT_USER

Failure Message Details:

SEVERITY: Warning.

Message Group Name: EXSPI

Message Text: EXSPI-6X SMTP Port Response failed.

Port settings:

First the Exspi_ports binary checks the port entry in 
C:\WINDOWS\system32\drivers\etc\services. If the search fails, the binary takes the 
default entries for the ports from the code.

/***************************************************************

Protocol ports
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***************************************************************/

SMTP_PORT                     = 25;

IMAP_PORT                     = 143;

POP3_PORT                     = 110;

HTTP_PORT                     = 80; 

If the SSL inclusion changes the port number you must change the port number in the 
services file to the new one manually, then Exspi_port takes this modified port number. 
Exspi_port binary does not modify the services file by passing any parameter.

Changing the Data Collection Agent Setup

The Microsoft Exchange SPI can detect whether or not you are using HP Performance Agent. 
If you are, your new Microsoft Exchange SPI installation will automatically use it as well. As 
a result, if you use HP Performance Manager, your new installation also supports that 
configuration. 

To override the use of HP Performance Agent:

For Exchange 2007 nodes, change the command parameters  exspidatasource.exe -A 
-V -SPEC EX2007_*.spec -OVOU to exspidatasource.exe -A -V -CODA -SPEC 
EX2007_*.spec -OVOU, and then launch the application Create DataSources on the 
target managed node.

For Exchange 2003 nodes, change the command parameters  exspidatasource.exe -A 
-V -SPEC EXSPI_*.spec -OVOU to exspidatasource.exe -A -V -CODA -SPEC 
EXSPI_*.spec -OVOU, and then launch the application EXSPI Add DataSource on the 
target managed node.
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Command Line Parameters

The collector/analyzer executable exspi_e2k.exe can be used with the following command 
line parameters:

Parameter Description

-m <metric range> -m (metric range) is used to specify the metric 
number or range of metric numbers.

-t <tag> -t (tag) allows the collector/analyzer to use a 
different set of templates than those originally 
provided with the Microsoft Exchange SPI when 
collecting metrics.
NOTE: Additional information about the tag 
feature is found at the end of the “Customizing 
Microsoft Exchange SPI” section.

-p -m <range> [-v] -p (print) executes specified metrics and prints 
their values to standard output, for example:
<exspi_e2k.exe> -p -m 1-1001

-a -a directs the collector/analyzer to send the metric 
value to HPOM for alarm generating

-s -s executes the collector as the special service 
account user (MSXSPI). Requires completion of 
the advanced configuration (see Configuring the 
Microsoft Exchange SPI on page 24).

-l -m <metric range> 
-x <extended_option> 

Data collection metrics start at 0500. Types:
Value: logs the actual value
Delta: logs the difference between current and 
previous
Average: logs the average over a specific interval 
(e.g. 1h)
where:
-l collector logs data to logfile instead of reporting 
it to HPOM
-x <extended_option> is one of: 
 logtype: is either "value, delta, or avg"
 logfreq: can only be "hourly" and is used only  
with "avg"
 runfreq: tells the collector the interval in seconds. 
If the schedule interval of EXSPI is every 10 
minutes, the runfreq option must be set to 10*60 = 
600: -x runfreq=600. The runfreq option can only 
be used with "avg."
 mbox: followed by "=<mailbox_name>" allows 
specification of certain mailboxes with certain 
metrics, specifically metrics:
611,612,622,623,630,631,632,640 and 641 
Example of a command line using this option:  
exspi -p -m 611 -x mbox=obrab
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4 Clustering Support
Using the Microsoft Exchange SPI in High-Availability 
Environments

The Microsoft Exchange SPI can be configured to accommodate cluster environments where 
fail-overs allow uninterrupted Exchange availability. 

Synchronized with the cluster environment, Exchange SPI monitoring can be made to switch 
off for the failed node and switch on for the active node. 

For recognizing clustered Exchange instances, Exchange SPI relies on XML configuration 
files. These files allow the OVO agent to automatically enable instance monitoring on the 
currently active node after disabling instance monitoring on the inactive node.

The Exchange SPI setup for a cluster environment requires the following steps: 

1 Add the nodes to be managed.

2 Modify, if necessary, the Exchange SPI monitoring configuration file included with the 
Exchange SPI (msexchange.apm.xml).

3 Create the clustered application configuration file (apminfo.xml) that associates 
Exchange SPI-monitored instances (Exchange virtual servers), with their corresponding 
cluster resource groups.

4 Restart the agent on the managed node.

Task 1: Add the Exchange Cluster nodes to be managed.

Add the Exchange cluster nodes to be managed. 

Task 2: Modify the Exchange SPI monitoring configuration file (if necessary)

The Exchange SPI includes a monitoring configuration file, (msexchange.apm.xml), which is 
an XML file that describes the templates that should be cluster-aware.

The (msexchange.apm.xml file works in conjunction with the clustered application 
configuration file (apminfo.xml) that you need to create for your Exchange cluster.

The purpose of the Exchange SPI msexchange.apm.xml file is to list all the Exchange SPI 
templates on the managed node, in order that these templates can be disabled/enabled, as 
appropriate, for inactive/active managed nodes. 

The Exchange SPI msexchange.apm.xml file is normally ready to use with no configuring. 
However, if you have renamed any templates, you need to modify the file accordingly. The file 
is in the monitor directory on the management server. After modifying this file, you need to 
redistribute the monitors to the Exchange nodes that are part of the Exchange cluster.
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Task 3: Create the clustered application configuration file

Apminfo.xml is an XML file that describes the cluster instances (Exchange virtual servers).

Apminfo.xml, working in conjunction with the Exchange SPI monitoring configuration file 
(msexchange.apm.xml), allows you to associate Exchange SPI monitored instances 
(Exchange virtual servers) with their associating cluster resource groups. As a result, when a 
resource group is moved from one node in a cluster to another node in the same cluster, 
monitoring stops on the failed node and starts on the new node.

To generate the content of this file:

1 Launch the Exchange SPI Exchange Cluster Configuration application on an Exchange 
cluster node, see Exchange Cluster Configuration application on page 63.   

2 Save the generated output in a temporary file by clicking on the Save.. button.

3 Open this temporary file and remove all the lines above: 

<?xml version="1.0" ?>

4 Save the remaining lines as the completed apminfo.xml file. 

If the node is managed under OVO 8 / HTTPS.save it to:

<OVO_DATADIR>\conf\conf

Task 4: Restart the agent on the managed node

After constructing and saving apminfo.xml, stop and restart the OVO agent by running the 
following commands on each node: 

opcagt -kill
opcagt -start 

Example apminfo.xml file

The following is an example apminfo.xml file, where ASPIVM6 is the name of the 
Exchange resource group):

<?xml version="1.0" ?>
<APMClusterConfiguration>

If the Exchange Cluster is managed under OVO 8 / HTTPS then msexchange.apm.xml 
needs to be manually copied from:

$OvDataDir\bin\instrumentation

to

$OvDataDir\bin\instrumentation\conf

for each managed node.

You can get the full path name for OVO_DATADIR by running the following command from a 
CMD window on the managed node: 

opcagt -type -verbose
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  <Application>

    <Name>msexchange</Name>

    <Instance>

      <Name>ASPIVM6</Name>

      <Package>aspivm6</Package>

    </Instance>

  </Application>

</APMClusterConfiguration>

Figure 13 Example Exchange resource group 

Exchange Cluster Configuration application

Use the Exchange Cluster Configuration application to generate the content of the 
apminfo.xml file. To execute this application:

1 Select all the Exchange managed nodes you wish to configure in the OVO Node Bank.

2 Drag these nodes and drop them on the Exchange Cluster Config application located in 
the EXSPI Admin > Exchange 2000 and 2003 or Exchange 2007 application group.

3 Use the generated output to construct the apminfo.xml. For details, refer to 
Create the clustered application configuration file on page 62).
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Figure 14 Example output of Cluster Configuration application

Data Collection on virtual servers

In order for reports and graphs to show data for any nodes, appropriate data collection 
templates need to be distributed to those nodes. See the section Using Microsoft Exchange 
SPI Reports and Graphs on page 104.

Run the Enable Message Tracking application on all nodes in the cluster before 
distributing the EXSPI 6.X Dc-TrackingLog Data template, so that the tracking log reports 
will generate. The application must run on the physical nodes of a cluster where the Exchange 
virtual server is running.

Seeing virtual servers in reports and graphs

The Exchange SPI will show Exchange virtual servers in reports and graphs as though they 
were physical Exchange servers.

After constructing and saving apminfo.xml, you need to restart the agent on the node, using 
the following commands:

Opcagt -kill

Opcagt -start
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Setting up End-to-End Message Ping on an Exchange Cluster

Using Exchange SPI, End-to-End Message Ping can be configured on Exchange clusters. 

1 Run the EXSPI MBox Config application on all nodes in the cluster. The application 
must run on the physical nodes of a cluster where the Exchange virtual server is running 
on. This is a necessary step for configuring and distributing End-to-End Message Ping. 

2 Follow the directions in Set Up Message Ping Server Connections and Alarms on page 38.

What happens during a failover:

When a failover happens, dependencies to the failed node will be removed and replaced with 
new dependencies to the newly active node. For example, if EXCHVIRTSERV1 moves from 
OVRNTTC1B to OVRNTTC1A, the dependencies to OVRNTTC1B will automatically be 
removed and will be replaced with a new set of dependencies to OVRNTTC1A..

When a failover happens, messages that occurred before the failover will not be propagated to 
the virtual node

For this mechanism to work EXSPI-6X-Exchange cluster discovery Event Log template must 
be distributed
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5 Customizations
This chapter outlines the following customization procedures:

• Choosing metrics to monitor Exchange

• Customizing the Exchange SPI

— Basic Customization procedures

— Creating custom groupings

— Creating custom templates

— Modifying message generation

— Modifying metric template conditions

— Customizing the Threshold

— Customizing Schedules

— The Tag Feature

— Advanced Customization procedures

— Changing the Windows User Account Name

— Changing the Mailbox Name

• Returning to original factory settings

Choosing metrics to monitor Microsoft Exchange Server

Before beginning customization, first decide which templates can remain without changing 
the thresholds (see the Microsoft Exchange SPI Reference Manual).

Basic Customization 

Creating Custom Groupings

Create custom template groups as follows:

1 Log onto HPOM as the HPOM Administrator.

2 Select Window>Message Source Templates.

It is recommended that you make a copy of the original template group and use the 
copy for customization purposes
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3 In the Message Source templates window select the desired template group and click the 
Add... button (if Add Logfile... is displayed, pull down the list and select Add Group) and 
select a name and description for this group.

4 To copy templates to the new group:

• In the Message Source templates window, double-click to open the group containing 
the desired templates.

• Select the templates to copy and choose Edit>Copy from the Message Source 
Templates menu to copy the templates.

• Return to the newly created template group and choose Edit>Paste from the menu.

Figure 15 Creating a New Template Group

Creating Custom Templates

You can create a custom template by copying an original template, making any desired 
changes, and saving it with a new name.

When the HPOM environment scales, the Exchange SPI tag feature provides a way to 
partition templates into groups with each group customized in a specific manner. 

Modifying Message Generation 

Alarms are generated with Reset, without Reset or Continuously. To change the 
Metric Generation Type (usually in conjunction with the Threshold, Polling 
Interval and Reset value) follow these steps:

1 Select the Message Source Templates window.

2 Double-click to open the template group containing the metric to modify.

3 Click the Modify button. 
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Figure 16 Modifying Message Generation

4 Select one of the Message Generation types:

— with Reset: Alarms are generated after the monitoring threshold has been 
exceeded. No additional alarms are generated until metrics drop below a specified 
Reset threshold and subsequently exceed the monitoring threshold.

— without Reset: Alarms are generated after the monitoring threshold has been 
exceeded. No additional alarms are generated until metrics drop below the 
threshold and subsequently exceed it.

— Continuous: Alarms are generated continuously when metrics exceed the 
threshold.
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Modifying Metric Template Conditions

Modify metric attributes as follows.

1 Select the Message Source Templates window.

2 Double-click the template group containing the metric to modify.

3 Double-click the desired metric

4 In the Message and Suppress Conditions window select the condition to modify and click 
the Modify button.

Figure 17 The Message and Suppress Conditions Window

5 The Condition window displays.

The following attributes can be easily modified:

Threshold. Set the desired threshold.

Reset. This is a limit under which the object's value must drop (or exceed for 
minimum thresholds) to return the alarm state of the object to normal. After an 
object's alarm state has returned to normal, a new message can be issued if the 
monitored parameter again exceeds (or drops below for minimum thresholds) the 
threshold value. Do not enter a value if you do not wish to impose a reset limit. Note 
that you can enter a reset value greater than the threshold value (or less for minimum 
threshold types), which has the same effect as if you don't specify a reset value.
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Duration. Most metrics are defined as Message Generate type without Reset 
and without a Duration. Please consult the HPOM Concepts Guide or online Help 
prior to modifying this field.

Severity. Click the [Severity] button and select the desired severity setting.

Message Text. Be careful not to modify any of the parameters in a message. 
Parameters are surrounded by <> brackets and begin with $.

Actions. This field provides the ability to add custom programs. Two types of actions 
are available: 

Operator initiated: These actions are only performed upon the initiation of an 
operator.

Automatic: These actions are performed automatically when the metric alarms.

Customizing the Threshold

Customize the threshold as needed. To do so, copy the existing condition to use as the default, 
and modify the original condition to serve as the exception. Follow these steps:

1 Double-click the metric you want to customize (for example, EXSPI-60-0001). 

2 In the Message and Suppress Conditions window select the desired condition and select 
the Copy button to make a copy of the condition. 

3 Enter a name for the condition; for example, EXSPI-6X-0001.3.

4 Click OK to close EXSPI-6X-0001.3. This will be the default condition.

5 Select the original condition, EXSPI-6X-0001.1.

6 Click the Modify button to display the Condition window.

7 In the Object Pattern field, enter the desired characters to use for pattern matching 
(see the HPOM online help or the HPOM Administrators Task Guide for pattern matching 
syntax).

8 Click the Test Pattern Matching… button to test the pattern and verify pattern 
matching (you must set up a match file first).

9 Change the value in the value in the Threshold field.

Figure 18 Testing Pattern Matching from the Condition Window

Some metrics have an operator-initiated action which will display a graph if HP 
Performance Manager is installed on the management server.
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Customizing Schedules

Schedule templates define the schedule by which the collector/analyzer will gather metric 
information. To modify a schedule template, follow these steps:

1 Select Window>Message Source Templates and double-click the template group 
containing the template to modify.

2 Double-click the desired template

3 In the Modify Scheduled Actions change any of the schedule information or other 
parameters. 

4 Click OK to close and save the changes.

5 Distribute the template to the desired managed node(s).
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Figure 19 Customizing a Schedule template
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The Tag Feature

When servers are dedicated to specific sites or business units, you may find it more effective if 
those servers do not all share the same set of Exchange SPI templates. In such cases, the tag 
feature is useful in allowing you to change existing templates and rename them. In this way 
you can associate template assignments with specific servers and the areas with which they 
are associated. For example, you might create a business administration group of templates 
and tag those templates with “ADM-” or a branch office group and tag those with “BR-.”

The tag feature allows you to create custom templates in a quick way. To summarize the steps, 
you:

a Make copies of existing monitor templates that you want to modify. 

b (optional) Modify the monitor template settings. 

c Save each modified template under the same name with a prefix.

d Enter each metric and - <prefix tag> after the collector/analyzer command in the 
Program Monitor or MIB ID box of the schedule template.

Using this method allows the collector/analyzer to recognize a set of templates different from 
those originally provided with the Exchange SPI. This method allows you to enlarge the single 
set of templates to adjust to differing conditions among the servers you use.

To use this feature, make copies of the original Exchange SPI templates. The names you give 
these new templates must contain a prefix with the original template name. To tell the 
collector/ analyzer to use this new template rather than the original template, specify the tag 
option on the schedule template command line.

New collector templates can also be created in this way, for example:

exspi_e2k -m 16 -t ADM-

In this case the new collector template is called "ADM-EXSPI-15min."

Advanced Customization

Changing the Windows User Account name

A Windows user account, used for creating a mailbox, is referenced in the EXSPI MBOX 
Config application. To change the account name, edit the EXSPI Mbox Config application and 
change the user name setting. This application requires a user with Exchange administrative 
privileges.

Changing the Mailbox name

For all schedule templates in the template group EXSPI-6X Data Collection (Adv), add -x 
<mailbox_name> to the command which is executed under the schedule. For example: 

exspi_e2k -l -m 630,631,632 -x logtype=value -x mbox=MSXSPI

The default mailbox MSXSPI <hostname> can be changed by supplying the mailbox name to 
EXSPI MBOX Config:
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Use the OVO Customized Startup to start EXSPI MBOX Config, and add 
-m <mailbox name prefix> [-ou <organizational unit>]
to the Application Parameter box.

Returning to Original Factory settings

To re-install all Microsoft Exchange SPI templates, applications and message groups with 
original factory settings, run the following command:

/opt/OV/bin/OpC/opccfgupld -verbose -replace /var/opt/OV/share/tmp/
OpC_appl/EXSPI/exspiset

Do not add the domain before the user name. The user must be in the domain where 
the Exchange Server is located, and cannot be a local user.

Any customization of the original templates will be overwritten.
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6 Integration with HP Reporter
This chapter describes how to install and generate reports within Reporter from Exchange 
SPI data. It contains the following sections:

• Installing Exchange SPI reports

• Exchange SPI report template requirements

• Lists of Exchange SPI reports, by Exchange version

• Using Exchange SPI reports and graphs

– Distributing data collection templates

– Distributing Reporter Collection templates

• Exchange SPI graphs

• Deinstalling Exchange SPI Reporter templates

Data Collection for Graphing and Reporting

Exchange SPI reports display data collected from EXSPI templates distributed to Exchange 
servers. The Exchange SPI collects data for graphing and reporting through data collection 
templates. Exchange and Windows data is collected, summarized, and forwarded to the 
HPOM data collecting agent. Reporter can be used to access the data source EXSPI_DATA 
and write reports using Seagate Crystal Reports.

Data is collected through data collection templates, see the HP Operations Smart Plug-in for 
Microsoft Exchange Server Reference Guide, for a complete listing of Schedule Data Collection 
templates for each Exchange version. 

The specific Schedule Data Collection templates that must be distributed for Exchange SPI to 
generate particular reports are as follows:

Table 3  Data Collection Templates Required for Reports

Report Name Template Name Report Group

Exchange 2003 Active Sync 
Usage 

EXSPI-65-Dc-ActiveSync Client Access

Exchange 2003 Active Sync 
Notifications

EXSPI-65-Dc-ActiveSyncNotify Client Access

Exchange 2003 OMA Sync Usage EXSPI-65-Dc-OMA Client Access

Exchange 2003 and 2000 IMAP4 
Connections 

EXSPI-65-Dc-IMAP4 
Performance

Client Access
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Exchange 2003 and 2000 IS Users 
and Connection

EXSPI-6X-Dc-Information Store 
Performance

Client Access

Exchange 2003 and 2000 
Messaging Ports

EXSPI-6X SMTP Port Response 
EXSPI-6X POP3 Port Response 
EXSPI-6X IMAP4 Port Response 
EXSPI-6X HTTP Port Response 

Client Access

Exchange 2003 and 2000 OWA 
Usage

EXSPI-6X-Dc-OWA Back End Client Access

Exchange 2003 and 2000 OWA 
Authentications

EXSPI-6X-Dc-OWA Back End Client Access

Exchange 2003 and 2000 OWA 
Connections

EXSPI-6X-Dc-OWA Front End Client Access

Exchange 2003 and 2000 POP3 
Connections

EXSPI-6X-Dc-POP3 Performance Client Access

Exchange 2003 and 2000 System 
Information Summary

EXSPI-6X-Dc-Mailbox IS Sum 
Data EXSPI-6X-Dc-Public IS Sum 
Data

Exchange Server

Exchange 2003 and 2000 Full 
Text Indexing Stats

EXSPI-6X Dc-Full Text Index Information Store

Exchange 2003 and 2000 
Transaction Log Stats

EXSPI-6X Dc-Transaction Log 
Space Usage

Information Store

Exchange 2003 and 2000 Inactive 
Mailboxes

EXSPI 6X-Dc-Mailbox Data Mailbox Store

Exchange 2003 and 2000 Mailbox 
Details

EXSPI 6X-Dc-Mailbox Data Mailbox Store

Exchange 2003 and 2000 Mailbox 
Store Stats

EXSPI-6X-Dc-Mailbox IS 
Sumdata

Mailbox Store

Exchange 2003 and 2000 Mailbox 
Summary

EXSPI 6X-Dc-Mailbox IS Sum 
Data

Mailbox Store

Exchange 2003 and 2000 Mailbox 
Usage Trends

EXSPI-6X Dc-Mailbox IS Sum 
Data

Mailbox Store

Exchange 2003 and 2000 Mailbox 
Store Messaging Trends

EXSPI-6X-Dc-IS Mailbox 
Performance 

Mailbox Store

Exchange 2003 and 2000 Top 100 
Mailboxes

EXSPI-6X-Dc-Mailbox Data Mailbox Store

Exchange 2003 and 2000 
Message Delivery SLA 

EXSPI-6X End to End Message 
Ping

Messaging

Exchange 2003 and 2000 Top 
Destinations

EXSPI-6X Dc-TrackLog Data Messaging

Exchange 2003 and 2000 Top 
Recipients

EXSPI-6X Dc-TrackLog Data Messaging

Report Name Template Name Report Group
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Microsoft Exchange SPI Reports

Installing Exchange SPI Report Templates

 To install Exchange SPI reports on the system where Reporter is installed:

1 Double-click EXSPI-Reporter.msi on the HP Operations Manager for Unix Application 
CD-ROM. This opens the EXSPI-Reporter InstallShield Wizard.

2 Click Next on the welcoming dialog.

Exchange 2003 and 2000 Top 
Senders

EXSPI-6X Dc-TrackLog Data Messaging

Exchange 2003 and 2000 Top 
Sources

EXSPI-6X Dc-TrackLog Data Messaging

Exchange 2003 and 2000 All 
Local Msg Delivery SLA

EXSPI-6X Dc-TrackLog SLA 
Delivery 

Messaging

Exchange 2003 and 2000 MTA 
Msg Trends

EXSPI-6X Dc-MTA Performance Messaging

Exchange 2003 and 2000 MTA 
Queue Data Stats

EXSPI-6X Dc-X400 Service MTA 
Queue 

Messaging

Exchange 2003 and 2000 
Message Tracking Stats

EXSPI-6X-Dc-Message Tracking 
Log Space Usage 

Messaging

Exchange 2003 and 2000 SMTP 
Connections

EXSPI-6X Dc-SMTP Server 
Performance 

Messaging

Exchange 2003 and 2000 SMTP 
Msg Trends

EXSPI-6X Dc-SMTP Server 
Performance

Messaging

Exchange 2003 and 2000 Virtual 
Server Stats 

EXSPI-6X Dc-SMTP Virtual 
Server Storage

Messaging

Exchange 2003 and 2000 
Exchange Folder Summary

EXSPI-6X-Dc-Public IS Sum 
Data

Public Folder Store

Exchange 2003 and 2000 
Exchange Folder Usage Trends

EXSPI-6X-Dc-IS Public Folder 
Performance

Public Folder Store

Exchange 2003 and 2000 Inactive 
Folders

EXSPI 6X-Dc-Public Folder Data Public Folder Store

Exchange 2003 and 2000 Public 
Folder Store Stats 

EXSPI-6X-Dc-Public IS Sum 
Data

Public Folder Store

Exchange 2003 and 2000 Public 
Folder Store Msg Tnd 

EXSPI-6X-Dc-Public IS Sum 
Data

Public Folder Store

Exchange 2003 and 2000 Top 100 
Public Folders

EXSPI-6X-Dc-Public Folder Data Public Folder Store

Report Name Template Name Report Group
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3 The next dialog confirms that EXSPI-Reporter is now installed, click Finish to exit the 
wizard.

4 Open Reporter to see the SPI for Exchange folder under Reports.

5 Open the SPI for Exchange group of reports, and see the groupings of Exchange reports. 
As you select each group, see in the details pane the individual reports available in that 
group.

Reports for Exchange 2007 Servers

The SPI for Microsoft Exchange Server 2007 provides the following reports:

Exchange 2007 Availability

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Availability in 
the HP Reporter console. 

Report Template File Name: g_Exchange 2007 Availability.rpt 

This report indicates the availability status of Microsoft Exchange Server 2007. The Microsoft 
Exchange SPI monitors the availability of the services that are necessary for Microsoft 
Exchange Server 2007 to run smoothly. The Exchange 2007 Availability report helps you 
identify if any of these services are unavailable.  

Report content 

This report (pie chart) displays the duration (percentage of time) for which the Exchange 2007 
services could successfully run. Possible causes of availability failure are: lack of system 
resources, wrong configuration, or performance failures in the Exchange 2007 environment.

Available: Next day. 

Required Templates: 

For this report to work properly, deploy the following template: 

EXSPI-8X Get Exchange Availability

Template Schedule: Once in every 5 minutes 

Metrics:

This report uses the following metrics, which are logged into the Reporter database:

• SERVER_NAME 

• AVAILABILITY 

Reporter table: 

EX2007_AVAILABILITY 

Exchange 2007 Client Access Server Availability

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Client Access 
Server Availability in the HP Reporter console. 

Report Template File Name: g_Exchange 2007 Client Access Server Availability.rpt 
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This report indicates the availability status of the nodes with the Client Access Server role in 
the Exchange Organization. The Microsoft Exchange SPI monitors the availability of the 
services that are necessary for Microsoft Exchange Server 2007 nodes with the Client Access 
Server role to run smoothly. The Exchange 2007 Client Access Server Availability report 
helps you identify if any of these services are unavailable.  

Report content 

This report (pie chart) displays the duration (percentage of time) for which the Exchange 2007 
Client Access Server services could successfully run. Possible causes of availability failure 
are: lack of system resources, wrong configuration, or performance failures in the Exchange 
2007 environment.

Available: Next day. 

Required Templates:

For this report to work properly, deploy the following template: 

EXSPI-8X Get Exchange Availability

Template Schedule: Every 5 minutes 

Metrics:

This report uses the following metrics, which are logged into the Reporter database:

• SERVER_NAME 

• AVAILABILITY 

• SERVER_ROLE 

Reporter table: 

EX2007_AVAILABILITY 

Exchange 2007 Edge Transport Server Availability

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Edge Transport 
Server Availability in the HP Reporter console.

Report Template File Name: g_Exchange 2007 Edge Transport Server Availability.rpt 

This report indicates the availability status of the nodes with the Edge Transport Server role 
in the Exchange Organization. The Microsoft Exchange SPI monitors the availability of the 
services that are necessary for Microsoft Exchange Server 2007 nodes with the Edge 
Transport Server role to run smoothly. The Exchange 2007 Edge Transport Server 
Availability report helps you identify if any of these services are unavailable.  

Report content

This report (pie chart) displays the duration (percentage of time) for which the Exchange 2007 
Edge-Transport services could successfully run. Possible causes of availability failure are: 
lack of system resources, wrong configuration, or performance failures in the Exchange 2007 
environment.

Available: Next day. 

Required Templates

For this report to work properly, deploy the following template: 

EXSPI-8X Get Exchange Availability
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Template Schedule: Every 5 minutes 

Metrics:

This report uses the following metrics, which are logged into the Reporter database:

• SERVER_NAME 

• AVAILABILITY 

• SERVER_ROLE 

Reporter table: 

EX2007_AVAILABILITY 

Exchange 2007 Hub Transport Server Availability

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Hub Transport 
Server Availability in the HP Reporter console.

Report Template File Name: g_Exchange 2007 Hub Transport Server Availability.rpt 

This report indicates the availability status of the nodes with the Hub Transport Server role 
in the Exchange Organization. The Microsoft Exchange SPI monitors the availability of the 
services that are necessary for Microsoft Exchange Server 2007 nodes with the Hub Transport 
Server role to run smoothly. The Exchange 2007 Hub Transport Server Availability report 
helps you identify if any of these services are unavailable.  

Report content

This report (pie chart) displays the duration (percentage of time) for which the Exchange 2007 
Hub Transport Server services could successfully run. Possible causes of availability failure 
are: lack of system resources, wrong configuration, or performance failures in the Exchange 
2007 environment.

Available: Next day. 

Required Templates:

For this report to work properly, deploy the following template: 

EXSPI-8X Get Exchange Availability

Template Schedule: Every 5 minutes 

Metrics:

This report uses the following metrics, which are logged into the Reporter database:

• SERVER_NAME 

• AVAILABILITY 

• SERVER_ROLE 

Reporter table: 

EX2007_AVAILABILITY 

Exchange 2007 Mailbox Server Availability

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Mailbox 
Availability in the HP Reporter console.
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Report Template File Name: g_Exchange 2007 Mailbox Server Availability.rpt 

 This report indicates the availability status of the nodes with the Mailbox Server role in the 
Exchange Organization. The Microsoft Exchange SPI monitors the availability of the services 
that are necessary for Microsoft Exchange Server 2007 nodes with the Mailbox Server role to 
run smoothly. The Exchange 2007 Mailbox Server Availability report helps you identify if any 
of these services are unavailable.  

Report content 

This report (pie chart) displays the duration (percentage of time) for which the Exchange 2007 
Mailbox Server services could successfully run. Possible causes of availability failure are: lack 
of system resources, wrong configuration, or performance failures in the Exchange 2007 
environment.

Available: Next day. 

Required Templates:

For this report to work properly, deploy the following template: 

EXSPI-8X Get Exchange Availability

Template Schedule: Every 5 minutes 

Metrics:

This report uses the following metrics, which are logged into the Reporter database:

• SERVER_NAME 

• AVAILABILITY 

• SERVER_ROLE 

Reporter table: 

EX2007_AVAILABILITY 

Exchange 2007 Unified Messaging Server Availability

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Unified 
Messaging Availability in the HP Reporter console.

Report Template File Name: g_Exchange 2007 Unified Messaging Server Availability.rpt 

This report indicates the availability status of the nodes with the Unified Messaging Server 
role in the Exchange Organization. The Microsoft Exchange SPI monitors the availability of 
the services that are necessary for Microsoft Exchange Server 2007 nodes with the Unified 
Messaging Server role to run smoothly. The Exchange 2007 Unified Messaging Server 
Availability report helps you identify if any of these services are unavailable.  

Report content

This report (pie chart) displays the duration (percentage of time) for which the Exchange 2007 
Unified Messaging Server services could successfully run. Possible causes of availability 
failure are: lack of system resources, wrong configuration, or performance failures in the 
Exchange 2007 environment.

Available: Next day. 

Required Templates:

For this report to work properly, deploy the following template: 
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EXSPI-8X Get Exchange Availability

Template Schedule: Every 5 minutes 

Metrics:

This report uses the following metrics, which are logged into the Reporter database:

• SERVER_NAME 

• AVAILABILITY 

• SERVER_ROLE 

Reporter table: 

EX2007_AVAILABILITY 

Exchange 2007 Top 100 Mailboxes

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Top 100 
Mailboxes in the HP Reporter o console. 

Report Template File Name: g_Exchange 2007 Top Mailboxes.rpt 

This report lists the top 100 mailboxes by disk space usage across all mailbox databases for all 
Exchange 2007 servers. It contains the most recent information available as of the date 
indicated. 

Report sections

Top Mailboxes by Disk Space Usage: This section contains information on high disk space 
usage mailboxes, as obtained from Exchange database queries through the Exchange cmdlets. 

Size (MB): Logical size of the mailbox based on the sum of the size of all messages in the 
mailbox. Units are in megabytes.

Mailbox Name: Display name of the Exchange mailbox.

Location: Name of the server and location of the mailbox

Storage Limit: Has one of the following values: Not Available, Below Limit, Issue Warning, 
Prohibit Send, No Checking, and Mailbox Disabled.

No. Msgs: The number of messages in the Mailbox. 

Available: The day after collection. This is a weekly collection. 

Each template must execute once, and the data must be gathered to the Reporter database, 
and the report is generated from this data. The report only shows data from the most recent 
day; therefore all Exchange Systems should log this data during the same time period. This 
data is collected and logged weekly. The schedule out of the box is set to collect and log data 
late Friday. If the data is gathered to the Reporter database nightly, this report will be 
refreshed with data and can be viewed on Saturday.

Required Templates

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Get Mailbox Details 

Metrics:

• MB_SIZE (MB)

• MB_MSGCOUNT: Number of Messages
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• MB_STGLIMIT

• MB_LASTACCESS

• MB_SGNAME

• MB_DBNAME

Reporter  Table: EX2007_MBDETAIL

Exchange 2007 Public Folder Store Message Trends by Server

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Public Folder 
Store Msg Tnd in the HP Reporter console.

Report Template File Name: g_Exchange 2007 Public Folder Store Msg Trends.rpt

 This report contains summary and detail trend graphs showing Public Folder Store message 
volumes. The summary graph for each server shows overall messaging trends on the 
Exchange server. Detail graphs show messaging trends for each public folder store in every 
public folder store and storage group, by server. 

Report sections 

This report contains two sections for each Exchange Server:

• Summary of Public Folder Store Messages Processed on Exchange Server: This 
section of the report provides a daily summary of all messages processed by all public 
folder hosted on the server. The default retention period for these metrics is 7 days. 

• Number of Messages Processed by : This section of the report provides a daily 
summary of all messages processed by the stated store. The default retention period for 
these metrics is 7 days. 

Available: Next Day.

Required Templates

EXSPI-8X Dc-IS Public Folder Performance

Metrics:

• PFDELIVER

• PFSENT

• PFSUBMITTED

• PFRECIPIENT 

Table: EX2007_PFPERF

Exchange 2007 IMAP4 Connections by Server

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 IMAP4 
Connections in the HP Reporter console. 

Report Template File Name: g_Exchange 2007 IMAP4 Connections.rpt 

This report provides a graph of the averaged connection counts for hours of the day over the 
time period indicated. The table shows the hourly plotted connection count values.  
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Report sections:

Two report sections are populated for each Exchange server where the IMAP4 service is 
running. 

The first report section graphs the hourly averaged Connections, Failed, and Rejected 
connections for the time period indicated. This means that when a full week of data is 
consolidated to the database, connections over all of the days are averaged for plotting on the 
graph. 

The second section is a table of the data used in the preceding graph. The Failed and Rejection 
Percentages are also calculated. The Rejection Percentage is the number of rejected 
connections divided by the number of connections; the Failed Percentage is the number of 
rejected connections divided by the number of connections. 

Available: Next day. 

Prerequisite: The MSExhangeIMAP4 service must be running on the server, and the 
associated Performance Object must be available through perfmon.

Required Templates

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-IMAP4 Performance

Schedule: Hourly

Metrics:

• IMAP4CON

• IMAP4FAILEDCON

• IMAP4REJECTEDCON

Table: EX2007_IMAP4PERF

Exchange 2007 Users and Connections by Server

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 IS Users and 
Connections in the HP Reporter console. 

Report Template File Name: g_Exchange 2007 IS Connections.rpt 

This report provides a graph of the averaged user and connections count for hours of the day 
over the time period indicated. The table shows the hourly plotted connection count values. 
Each Exchange server is analyzed.  

Report sections: 

Graph and Table of User and Connection Activity: The graph shows hourly trends of user 
connection statistics.

• Avg of Users: Average number of users connected to the information store.

• Avg of Active Users:  Average number of active users connected to the information 
store.

• Avg of Connections : Average number of connections to the information store.

• Avg of Active Connections: Average number of active connections to the information 
store.

• Avg of Anonymous Users : Average number of anonymous users.
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• Avg of Active Anonymous Users : Average number of active anonymous users.

Available:  Two days. 

Prerequisites:  The User that the template runs under must have the read access to perfmon 
data. 

Deploy the template EXSPI-8X Dc-Information Store Performance. This template gathers the 
perfmon data information store statistics and writes this data to CODA.

Collection Detail: The schedule template EXSPI-8X Dc-Information Store Performance is 
scheduled to run every 15 minutes. Data is gathered to the reporter database, and the report 
is generated the following day.

Required Templates 

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-Information Store Performance

Schedule: Every 15 mins

Metrics:

• ISUSERCNT

• ISACTIVEUSERCNT

• ISANONUSERCNT

• ISACTIVEANONUSERCNT

• ISCONNECTCNT

• ISACTIVECONNECTCNT

Table: EX2007_ISPERF

Exchange 2007 Mailbox Store Msg Trends by Server

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Mailbox Store 
Msg Trends in the HP Reporter console. 

Report Template File Name: g_Exchange 2007 Mailbox Store Msg Trends.rpt 

This report contains summary and detail trend graphs showing Mailbox Store message 
volumes. The summary graph for each server shows overall messaging trends on the 
Exchange server. Detail graphs show messaging trends for each mailbox store instance.  

Report sections

This report contains two sections for each Exchange server: 

• Summary of Mailbox Store Messages Processed on Exchange Server: This section 
of the report provides a daily summary of all messages processed by all mailbox stores 
hosted on the server. The default retention period for these metrics is 7 days.

• Number of messages processed by <Store Name>: This section of the report provides 
a daily summary of all messages processed by the stated store. The default retention 
period for these metrics is 7 days. 

Available:   Next day.

Required Templates 

For this report to work properly, deploy the following template: 
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Template Name: EXSPI-8X Dc-IS Mailbox Performance

Schedule: Every 15 mins

Metrics:

• MBDELIVER

• MBSENT

• MBSUBMITTED

• MBRECIPIENT

• MBLOCALDELIVER

Table: EX2007_MBPERF

Exchange 2007 POP3 Connections by Server

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 POP3 
Connections in the HP Reporter console.

Report Template File Name: g_Exchange 2007 POP3 Connections.rpt 

This report provides a graph of the averaged connection counts for hours of the day over the 
time period indicated. The table shows the hourly plotted connection count values.  

Report sections

Two report sections are populated for each Exchange server where the POP3 service is 
running. 

The first report section graphs the hourly averaged Connections, Failed, and Rejected 
connections for the time period indicated. This means that when a full week of data is 
consolidated to the database, connections over all of the days are averaged for plotting on the 
graph. 

The second section is a table of the data used in the preceding graph. The Failed and Rejection 
Percentages are also calculated. The Rejection Percentage is the number of rejected 
connections divided by the number of connections; the Failed Percentage is the number of 
rejected connections divided by the number of connections. 

Available: Next day. 

Prerequisite: The MSExhangePOP3 service must be running on the server, and the associated 
Performance Object must be available through perfmon.

Required Templates

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-POP3 Performance

Schedule: Hourly

Metrics:

• POP3CON

• POP3FAILEDCON

• POP3REJECTEDCON

Table: EX2007_POP3PERF
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Exchange 2007 SMTP Receive Messaging Trends by Server

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 SMTP Msg Recv 
Trends in the HP Reporter console.

Report Template File Name: g_Exchange 2007 SMTP Receive Messaging Trends.rpt 

This report contains trend graphs showing the Simple Mail Transport Protocol (SMTP) 
incoming message volume. Graphs show trends in incoming message volume by messages and 
megabytes.  

Report sections 

Two report sections are populated for each Exchange server where the SMTP service is 
running. 

The first report section graphs the Number of Messages Processed by each SMTP server 
instance. The number of messages received is graphed for each SMTP server instance active 
on the server. 

The second section graphs the message megabytes processed by each SMTP server instance. 
The message size in megabytes of Received is graphed for each SMTP server instance active 
on the server. 

Available: Next day. 

Prerequisite: The SMTP service must be running on the server, and the associated 
Performance Object must be available through perfmon.

Required Templates

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-SMTP Performance for Inbound Connections 

Schedule: Hourly

Metrics:

SMTPMSGSENT, SMTPMSGRECEIVE, SMTPMSGBYTESENT, 
SMTPMSGBYTERECEIVE

Table: EXSPI_SMTPPERF

Exchange 2007 Inactive Mailboxes by Server

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Inactive 
Mailboxes in the HP Reporter console. 

Report Template File Name: g_Exchange 2007 Inactive Mailboxes.rpt 

This report lists all the mailboxes on the server that have not been accessed in 20, 40, and 60 
or more days. 

Report sections:

This report contains data collected on Mailboxes grouped by Storage Group and Mailbox 
Store, sorted by Last Logon Date. It is in the form of a table with the following columns: 

• Mailbox Name: The name of the mailbox.

• Last Sent Date: The date when mail was last sent.
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• Size (MB): Logical size of the mailbox based on the sum of the size of all messages in the 
mailbox. Units are in megabytes.

• No. Messages: The number of messages in the mailbox.

Available: The day after collection. This is a weekly collection. 

Collection Detail: Each template must execute once, and the data must be gathered to the 
Reporter database. The report is generated from this data. The report only shows data from 
the most recent day; therefore all Exchange Systems should log this data during the same 
time period. This data is collected and logged weekly. The schedule out of the box is set to 
collect and log data late Friday. If the data is gathered to the Reporter database nightly, this 
report will be refreshed with data for Saturday viewing.

Mailbox size and Last Logon Date are extracted from the Active Directory for each mailbox 
logged to the EX2007_MBDETAIL table. 

Storage Group and Mailbox Store for each mailbox on the server are extracted from the Active 
Directory and logged to the EX2007_MBDETAIL table. 

Required Templates

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Get Mailbox Details 

Location: Manual Deploy Groups \ Mailbox Server\ Mailbox 

Metrics:

• MB_SIZE (MB)

• MB_LASTACCESS

• MB_SGNAME

• MB_DBNAME

Table: EX2007_MBDETAIL

Exchange 2007 Mailbox Details by Server

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Mailbox Details 
in the HP Reporter console.

Report Template File Name: g_Exchange 2007 Mailbox Details.rpt 

Provides detailed information about the mailboxes on the server including summary totals, 
size distribution, and top mail users. 

Report sections 

This report lists all the mailboxes on the server sorted by disk space usage. It contains the 
most recent information available as of the date indicated. Mailboxes are sorted by name, and 
grouped by storage group and database. The report is organized as a table with the following 
columns: 

• Mailbox Name: The name of the mailbox.

• Size (MB): Logical size of the mailbox based on the sum of the size of all messages in the 
mailbox. Units are in megabytes. 

• No. Messages: The number of messages in the mailbox. 
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• Storage Limits: Has one of the following values: Not Available, Below Limit, Issue 
Warning, Prohibit Send, No Checking, and Mailbox Disabled.

Available: The day after collection. This is a weekly collection. 

Collection Detail: Each template must execute once, and the data must be gathered to the 
Reporter database. The report is generated from this data. The report only shows data from 
the most recent day; therefore all Exchange Systems should log this data during the same 
time period. This data is collected and logged weekly. The schedule out of the box is set to 
collect and log data late Friday. If the data is collected in the Reporter database nightly then 
this report will be refreshed with data for Saturday viewing. 

Required Templates

For this report to work properly, deploy the following templates: 

Template Names: EXSPI-8X Get Mailbox Details 

Metrics: 

• MB_SIZE (MB)

• MB_MSGCOUNT: Number of Messages

• MB_STGLIMIT

• MB_LASTACCESS

• MB_SGNAME

• MB_DBNAME

Table: EX2007_MBDETAIL

Exchange 2007 Top Senders

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Top Senders in 
the HP Reporter console.

Report Template File Name: g_Exchange 2007 Top Senders.rpt 

This report lists the top senders of emails based on the number of megabytes of e-mail sent. 
Each message is counted only once regardless of the number of recipients. 

Report contents:

This report displays tables indicating the size of the emails sent by every server with the data 
that was gathered by HP Reporter over a period of one week. 

Available:   Next day.

Required Templates 

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-Get Top Sender Details

Schedule: Every week 

Metrics:

SERVER_NAME

Table: EX2007_SENDER
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Exchange 2007 Top Senders Per AD Site

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Top Senders Per 
AD Site in the HP Reporter console.

Report Template File Name: g_Exchange 2007 Top Senders Per ADSite.rpt 

This report lists the top senders of emails based on the size of the emails sent by each server 
of every Active Directory site. The size of each email message is counted only once regardless 
of the number of recipients. 

Report contents

This report displays tables indicating the size of the emails sent by every server for every 
Active Directory site with the data that was gathered by HP Reporter over a period of one 
week. 

Available:   Next day.

Required Templates 

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-Get Top Sender Details

Schedule: Every week 

Metrics:

ADSITE_NAME

Table: EX2007_SENDER

Exchange 2007 Top Outgoing E-mail

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Top Destination 
in the HP Reporter  console.

Report Template File Name: g_Exchange 2007 Top Destinations.rpt 

This report lists the top destinations of emails based on the number of megabytes of e-mail 
sent. Each message is counted once for every destination. 

Report contents 

This report displays tables indicating the sizes of the emails sent to different destinations 
with the data that was gathered by HP Reporter over a period of one week. The table 
indicates the following types of email destinations:

• EX2007: The destination server is another Exchange 2007 Mailbox server within your 
organization. The actual destination name displayed is the combination of the site name 
and Mailbox Server name. 

• EX: The destination server is another Exchange server (2003) within your organization. 
The actual destination name displayed is the name of the Exchange Server. 

• SMTP: The destination is an Internet address. The destination is not located in your 
Exchange organization. 

Available:   Next day.

Required Templates 

For this report to work properly, deploy the following template: 
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Template Name: EXSPI-8X Dc-Get Top Destination Details

Schedule: Every week 

Metrics:

SERVER_NAME

Table: EX2007_DEST

Exchange 2007 Top Outgoing E-mail Per AD Site

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Top Destination 
Per AD Site in the HP Reporter console.

Report Template File Name: g_Exchange 2007 Top Destinations.rpt 

This report lists the top destinations of emails based on the number of megabytes of e-mail 
sent for every Active Directory site. Each message is counted once for every destination. 

Report contents 

This report displays tables indicating the sizes of the emails sent to different destinations 
with the data that was gathered by HP Reporter over a period of one week. The table 
indicates the following types of email destinations:

• EX2007: The destination server is another Exchange 2007 Mailbox server within your 
organization. The actual destination name displayed is the combination of the site name 
and Mailbox Server name. 

• EX: The destination server is another Exchange server (2003) within your organization. 
The actual destination name displayed is the name of the Exchange Server. 

• SMTP: The destination is an Internet address. The destination is not located in your 
Exchange organization. 

Available:   Next day.

Required Templates 

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-Get Top Destination Details

Schedule: Every week 

Metrics:

ADSITE_NAME

Table: EX2007_DEST

Exchange 2007 Mailbox Server Messages Sent

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 MB Server Msg 
Sent in the HP Reporter console.

Report Template File Name: g_exchange 2007 mailbox msg sent per AD Site.rpt 

This report shows the number of messages sent from each managed Exchange Server 2007 
Mailbox Server for different Active Directory sites.
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Report contents:

This report displays bar graphs indicating the number of messages sent from Mailbox Servers 
for different Active Directory sites over a period of one day. The X-axis represents different 
servers in every Active Directory site and the Y-axis represents the number of messages sent 
from every server.

Available:   Next day.

Required Templates 

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-Get Top Sender Details

Schedule: Every hour 

Metrics:

• ADSITE_NAME

• SERVER_NAME 

• NUM_MSGS_SR

Table: EX2007_SENDER

Exchange 2007 Mailbox Server Top 20 Sender Servers of Messages

Launch this report by clicking Reports > SPI for Exchange 2007 > Top 20 Sender MB Servers 
in the HP Reporter console.

Report Template File Name: g_exchange 2007 Top 20 mailbox servers msg sent.rpt 

This report lists the top senders of emails based on the size of the emails sent by each server. 
The size of each email message is counted only once regardless of the number of recipients.

Report contents

This report displays bar graphs indicating the numbers of messages sent from mailboxes by 
20 different servers with the data that was gathered by HP Reporter over a period of one 
week.

Available:   Next day.

Required Templates 

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-Get Top Sender Details

Schedule: Every week 

Metrics:

• SERVER_NAME

• NUM_MSGS_SR

Table: EX2007_SENDER

Exchange 2007 Top Recipients Per AD Site

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Top 
Recipients Per AD Site in the HP Reporter console.
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Report Template File Name: g_Exchange 2007 Top Recipients per AD Site.rpt 

This report lists the top senders of emails based on the size of the emails received by each 
server of every Active Directory site. The size of each email message is counted only once 
regardless of the number of recipients. 

Report contents

This report displays tables indicating the size of the emails received by every server for every 
Active Directory site with the data that was gathered by HP Reporter over a period of one 
week. 

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-Get Top Recipient Details

Schedule: Every week 

Metrics:

ADSITE_NAME

Table: EX2007_RECP

Exchange 2007 Top Recipients

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Top Recipients in 
the HP Reporter console.

Report Template File Name: g_Exchange 2007 Top Recipients.rpt 

This report lists the top senders of emails based on the number of megabytes of e-mail 
received. Each message is counted only once regardless of the number of recipients. 

Report contents

This report displays tables indicating the size of the emails received by every server with the 
data that was gathered by HP Reporter over a period of one week. 

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-Get Top Recipient Details

Schedule: Every week 

Metrics:

SERVER_NAME

Table: EX2007_RECP

Exchange Top Incoming E-mail

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Top Sources in 
the HP Reporter console.

Report Template File Name: g_Exchange Top Sources.rpt 
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This report lists the top sources of emails based on the number of megabytes of e-mail 
received. Each message is counted only once regardless of the number of recipients. If an 
email contains recipients intended for different Mailbox Servers, the email is counted once for 
each server.

Report contents

This report displays tables indicating the sizes of the emails sent by different sources with the 
data that was gathered by HP Reporter over a period of one week. The table indicates the 
following types of email sources:

• EX2007: The source server is another Exchange 2007 Mailbox server within your 
organization. The actual source name displayed is the combination of the site name and 
Mailbox Server name. 

• EX: The source server is another Exchange server (2003) within your organization. The 
actual source name displayed is the name of the Exchange Server. 

• SMTP: The source is an Internet address. The source is not located in your Exchange 
organization. 

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-Get Top Source Details

Schedule: Every week 

Metrics:

SERVER_NAME

Table: EX2007_SOURCE

Exchange 2007 Top Incoming E-mail Per AD Site

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Top Sources Per 
AD Site in the HP Reporter console.

Report Template File Name: g_Exchange 2007 Top Sources Per AD Site.rpt 

This report lists the top sources of emails based on the number of megabytes of e-mail 
received for every Active Directory site in the organization. Each message is counted only once 
regardless of the number of recipients. If an email contains recipients intended for different 
Mailbox Servers, the email is counted once for each server.

Report contents: 

This report displays tables indicating the sizes of the emails sent by different sources for 
every Active Directory site with the data that was gathered by HP Reporter over a period of 
one week. The table indicates the following types of email sources:

• EX2007: The source server is another Exchange 2007 Mailbox server within your 
organization. The actual source name displayed is the combination of the site name and 
Mailbox Server name. 

• EX: The source server is another Exchange server (2003) within your organization. The 
actual source name displayed is the name of the Exchange Server. 

• SMTP: The source is an Internet address. The source is not located in your Exchange 
organization. 
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Available:   Next day.

Required Templates 

For this report to work properly, deploy the following template: 

Template Name: EXSPI-8X Dc-Get Top Source Details

Schedule: Every week 

Metrics:

ADSITE_NAME

Table: EX2007_SOURCE

Exchange 2007 Mailbox Server Top 20 Receiver Servers of Messages

Launch this report by clicking Reports > SPI for Exchange 2007 > Top 20 Receiver MB Server in 
the HP Reporter console.

Report Template File Name: g_exchange 2007 Top 20 mailbox servers msg received.rpt 

This report shows the top 20 receivers of messages.

Report contents 

This report displays bar graphs indicating the number of messages received by 20 different 
servers with the data that was gathered by HP Reporter over a period of one week. 

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-Get Top Recipient Details

Schedule: Every week 

Metrics:

• SERVER_NAME

• NUM_MSGS_RR

Table: EX2007_RECP

Exchange 2007 Mailbox Server Top 20 Receiver Servers of Largest Messages

Launch this report by clicking Reports > SPI for Exchange 2007 > Top 20 Largest Msg Receiver MB 
Servers in the HP Reporter console.

Report Template File Name: g_exchange 2007 Top 20 mailbox servers msg size received.rpt 

This report shows the top 20 receivers of messages (based on message size).

Report contents

This report displays bar graphs indicating the sizes of messages received by 20 different 
servers with the data that was gathered by HP Reporter over a period of one week.

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-Get Top Recipient Details
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Schedule: Every week 

Metrics:

• SERVER_NAME

• NUM_BYTES_RR

Table: EX2007_RECP

Exchange 2007 Mailbox Server Size of Messages Received

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 MB Server Msg 
Size Received in the HP Reporter console.

Report Template File Name: g_exchange 2007 mailbox msg size received per AD Site.rpt 

This report shows the number of bytes of messages received by each managed Exchange 2007 
Mailbox Server for different Active Directory sites.

Report contents

This report displays bar graphs indicating the bytes of messages received by Mailbox Servers 
for different Active Directory sites with the data that was gathered by HP Reporter over a 
period of one week. The X-axis represents different servers in every Active Directory site and 
the Y-axis represents the bytes of messages received by each server.

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-Get Top Recipient Details

Schedule: Every week 

Metrics:

• ADSITE_NAME

• NUM_BYTES_RR

Table: EX2007_RECP

Exchange 2007 Messages Received per Server by AD Site 

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 MB Server Msg 
Received in the HP Reporter console.

Report Template File Name: g_exchange 2007 mailbox msg received per AD Site.rpt 

This report shows the number of messages received in each managed Exchange 2007 Mailbox 
Server for different Microsoft Active Directory Sites.

Report contents

This report displays bar graphs indicating the number of messages received from Mailbox 
servers over a period of time. 

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-IS Mailbox Performance
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Schedule: Every 15 mins

Metrics:

• MBDELIVER

• MBSENT

• MBSUBMITTED

• MBRECIPIENT

• MBLOCALDELIVER

Table: EX2007_MBPERF

Exchange 2007 Mailbox Store Msg Trends by Server

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 Mailbox Store 
Msg Trends in the HP Reporter console. 

Report Template File Name: g_Exchange 2007 Mailbox Store Msg Trends.rpt 

 This report contains summary and detail trend graphs showing Mailbox Store message 
volumes. The summary graph for each server shows overall messaging trends on the 
Exchange server. Detail graphs show messaging trends for each mailbox store instance.  

Report sections: 

This report contains two sections for each Exchange server: 

• Summary of Mailbox Store Messages Processed on Exchange Server: This section of the 
report provides a daily summary of all messages processed by all mailbox stores hosted on 
the server. The default retention period for these metrics is 7 days.

• Number of messages processed by <Store Name>: This section of the report provides a 
daily summary of all messages processed by the stated store. The default retention period 
for these metrics is 7 days. 

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-IS Mailbox Performance

Schedule: Every 15 mins

Metrics:

• MBDELIVER

• MBSENT

• MBSUBMITTED

• MBRECIPIENT

• MBLOCALDELIVER

Table: EX2007_MBPERF

Exchange 2007 Mailbox Server Top 20 Sender Servers of Largest Messages

Launch this report by clicking Reports > SPI for Exchange 2007 > Top 20 Largest Msg Sender MB 
Servers in the HP Reporter console.
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Report Template File Name: g_exchange 2007 Top 20 mailbox servers msg size sent.rpt 

This report shows the top 20 senders of messages (based on message size). 

Report contents

This report displays bar graphs indicating the sizes of messages sent from mailboxes by 20 
different servers with the data that was gathered by HP Reporter over a period of one week. 

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-Get Top Sender Details

Schedule: Every week 

Metrics:

• SERVER_NAME

• NUM_BYTES_SR

Table: EX2007_SENDER

Exchange 2007 Mailbox Server Size of Messages Sent

Launch this report by clicking Reports > SPI for Exchange 2007 > Exchange 2007 MB Server Msg 
Size Sent in the HP Reporter console.

Report Template File Name: g_exchange 2007 mailbox msg size sent per AD Site.rpt 

This report shows the number of bytes of messages sent from each managed Exchange Server 
2007 Mailbox Server for different Active Directory sites.

Report contents

This report displays bar graphs indicating the bytes of messages sent from Mailbox Servers 
for different Active Directory sites with the data that was gathered by HP Reporter over a 
period of one week. The X-axis represents different servers in every Active Directory site and 
the Y-axis represents the bytes of messages sent from every server.

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-Get Top Sender Details

Schedule: Every week 

Metrics:

• ADSITE_NAME

• NUM_BYTES_SR

Table: EX2007_SENDER

Percentage of successful RPC client server operations between clients and Exchange 2007

Launch this report by clicking Reports > SPI for Exchange 2007 > Percentage of successful RPC 
operations in the HP Reporter console.

Report Template File Name: g_Exchange 2007 Percentage Successful RPC Operations.rpt 
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This report displays the percentage of successful RPC client/server operations between clients 
(Microsoft Office Outlook 2003 and higher) and Exchange Server 2007.

Report contents

This report displays pie charts indicating the percentage of successful RPC client/server 
operations between clients and Exchange Server 2007.

Available:   Next day.

Required Templates 

Template Name: EXSPI-8X Dc-Outlook Client

Schedule: Every 5 minutes 

Metrics:

• SYSTEMNAME

• ISCRPCATTEMPT

• ISCRPCSUCCEED

Table: EX2007_ISCLIENT

Reports for Exchange 2003 Servers 

Client Access

• Exchange 2003 ActiveSync Notifications

• Exchange 2003 ActiveSync Usage

• Exchange 2003 and 2000 IMAP4 Connections

• Exchange 2003 and 2000 Messaging Ports Availability

• Exchange 2003 and 2000 OWA Authentications

• Exchange 2003 and 2000 OWA Connections

• Exchange 2003 and 2000 Usage

• Exchange 2003 and 2000 POP3 Connections

• Exchange 2003 OMA Sync Usage

Exchange Server

• Exchange 2003 and 2000 System Information Summary: Contains summary 
information about the OS and Exchange versions, mailboxes and public folders.

Information Store

• Exchange 2003 and 2000 Full Text Indexing Stats

• Exchange 2003 and 2000 IS Users and Connections

• Exchange 2003 and 2000 Transaction Log Stats: Provides information concerning 
usage and availability of storage, by and for the Exchange Transaction log.
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Mailbox Store

• Exchange 2003 and 2000 Inactive Mailboxes: This report lists all the mailboxes on 
the server that have not been accessed. The report also lists mailboxes that have not been 
accessed in 20, 40 and 60 or more days.

• Exchange 2003 and 2000 Mailbox Details: Provides detailed information about the 
mailboxes on the server including summary totals, size distribution, and top mail users.

• Exchange 2003 and 2000 Mailbox Store Msg Trends

• Exchange 2003 and 2000 Mailbox Store Stats: Provides database volume statistics for 
Mailbox Store database files, for each managed Exchange Server. The report gives a 
snapshot of the volume usage, as of the most recent data collection.

• Exchange 2003 and 2000 Mailbox Summary: Provides summary information about 
the mailboxes on the server including summary totals, size distribution, and top mail 
users.

• Exchange 2003 and 2000 Mailbox Usage Trends: Contains graphs showing trends in 
database size, number of messages, and average size of mailboxes. The trends are 
associated per storage group and are shown for the time period selected when the report is 
generated.

• Exchange 2003 and 2000 Top 100 Mailboxes: Lists the top 100 mailboxes by disk 
space usage across all mailbox databases.

Messaging

• Exchange 2003 and 2000 Message Delivery SLA (Service Level Agreement): Provides 
a trend graph showing how message delivery, messages read, and directory read service 
levels are being met across all monitored connections.

• Exchange 2003 and 2000 Top Destinations: Identifies the top Email destinations 
(local, other Exchange sites, internet, gateway) for Email being sent by an Exchange 
server.

• Exchange 2003 and 2000 Top Recipients: Identifies the top recipients of Email for an 
Exchange server.

• Exchange 2003 and 2000 Top Senders: Identifies the top senders of Email for an 
Exchange server. Only Email sent by users that have Exchange mailboxes is counted. 
Email sent by clients such as Netscape and UNIX that do not have a corresponding 
Exchange mailbox are not counted. 

• Exchange 2003 and 2000 Top Sources: Identifies the top Email sources (local, other 
Exchange sites, internet, gateway) for Email being received by an Exchange server.

• Exchange 2003 and 2000 Message Delivery SLA from Tracking Log data

• Exchange 2003 and 2000 Message Tracking Log Space Usage

• Exchange 2003 and 2000 MTA Msg Trends: Provides trend graphs showing messaging 
volume for the Message Transfer Agent, Information Store and SMTP server message 
volume.

• Exchange 2003 and 2000 MTA Queue Data Stats

• Exchange 2003 and 2000 SMTP Connections

• Exchange 2003 and 2000 SMTP Msg Trends 

• Exchange 2003 and 2000 SMTP Virtual Server Data Stats
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Public Folder Store

• Exchange 2003 and 2000 Folder Summary: Provides summary information about the 
public folders on the server.

• Exchange 2003 and 2000 Folder Usage Trends: Contains graphs showing trends in 
database size, number of messages and average size of public folders. The trends are 
shown for the time period selected when the report is generated.

• Exchange 2003 and 2000 Inactive Folders: This report lists all the folders on the 
server that have not been accessed. The report also lists folders that have not been 
accessed in 20, 40 and 60 or more days.

• Exchange 2003 and 2000 Public Folder Store Msg Tnd:

• Exchange 2003 and 2000 Public Folder Store Stats: Provides database volume 
statistics for Public Folder Store database files, for each managed Exchange Server. The 
report gives a snapshot of the volume usage, as of the most recent data collection. 

• Exchange 2003 and 2000 Top 100 Public Folders: Lists the top 100 public folders by 
disk space usage.

Troubleshooting Reports

If the report is not being generated or if it is empty, follow these steps:

1 Check the Reporter database. 

• Check if the data is available in the Reporter database. 

• Check the Reporter database on the HP Reporter server. 

• Run the following SQL commands to see if data for a particular metric is being 
collected:

SELECT * FROM EX2007_<HP Reporter Table Name>

or

SELECT * FROM EXSPI_<HP Reporter Table Name>

• If there is data in the Reporter database for every metric listed above and the 
Reporter trace files do not reveal the cause of the problem, contact the HP Support 
Team. 

• If the data for some or all of the above metrics are missing from the Reporter 
database, go to the next step. 

2 Check the reporter package installation. 

• Make sure that the EXSPI Reporter package was installed on the HP Reporter server. 

• Check for errors in the Reporter Status pane. 

• If there are Reporter installation errors, report the problem. 

3 Check the data store.

If there is no data in the Reporter database and the EXSPI Reporter package is installed 
properly, check that the data is being collected/logged on the managed node into the data 
store (CODA or HP Performance Agent). 

If you are using CODA: 
Integration with HP Reporter 103



— Run the following CODA diagnostic command on the managed node to get the last 
logged record: 

On an HTTPS-managed node: ovcodautil -dumpds EX2007_DATA  or 
ovcodautil -dumpds EXSPI_DATA

4 If there is no data in the CODA database, check if the CODA agent is running. 

You can restart CODA on the managed node by running: 

On HTTPS-managed nodes: ovc -start -id 12

Check that the acknowledged messages queue was acknowledged. 

If you are using the HP Performance Agent, refer to the HP Performance Agent 
documentation. 

5 Have the templates been deployed?

There will be no data unless the REQUIRED template IS deployed. Check on the 
managed node to ensure this template was deployed and is enabled by running the 
command opctemplate.

6 Is the agent on the managed node running?

Check if the HP Operations agent is running. Run the following command on the 
managed node to get the status of the agent: 

On the HTTPS-managed nodes: ovc -status 

If the HP Operations agent is not running, restart with the following command: 

On the HTTPS-managed nodes: ovc -start 

Using Microsoft Exchange SPI Reports and Graphs

Microsoft Exchange SPI report and graph generation require that you complete the 
following:

• Distribute the data collection templates.

• Configure and distribute Exchange SPI reporter collection templates.

Distributing the Data Collection Templates

In order to collect data for reports and graphs the General Data Collection templates in the  
EXSPI OVO Exchange SPI core (Exchange 2003) template groups need to be distributed.

For the procedure to distribute templates, see Assign/Distribute Templates on page 33.

Time Interval for Exchange SPI Reports or Graphs

Exchange SPI reports and graphs will not be available until data has been gathered to the 
management server from the managed nodes. This occurs each night, so at least one day of 
activity is needed for the reports to populate. Where a report or graph type requires data from 
a Sat/Sun collection, those reports/graphs will require a weekend to pass.
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Deinstalling Microsoft Exchange SPI Reporter

Remove the Exchange SPI reporter in one of the following ways:

1 Using the Windows Start menu.

2 Using the EXSPI-Reporter InstallShield wizard.

Using the Windows Start menu:

1 Select Start > Settings > Control Panel > Add/Remove Programs.

2 Select EXSPI-Reporter.

3 Click Remove. 

Using the EXSPI-Reporter InstallShield wizard.

1 Double-click EXSPI-Reporter.msi. This opens the EXSPI-Reporter InstallShield 
Wizard. Click Next on the Welcome screen.

2 Confirm the next screen by clicking Remove.

3 The InstallShield Wizard has deinstalled EXSPI-Reporter. Click Finish.

Microsoft Exchange SPI Graphs

Exchange SPI comes with a set of preconfigured graph templates. These graph templates 
need to be installed on an HP Performance Manager system, and require that CODA or HP 
Performance Agent is running on the managed node.

Installing Microsoft Exchange SPI Graph templates

There are three template files:  VPI_GraphsEXSPI2K3.txt for Exchange 2003 graphs and 
VPI_GraphsEXSPI2K7.txt for Exchange 2007 graphs. 

These files are located:

— on the HPOM for UNIX management server at  /var/opt/OV/share/databases/
OpC/mgd_node/customer/ms/intel/nt/cmds 

— on the Microsoft Exchange SPI managed nodes:

on HTTPS nodes at <OvDataDir>\bin\instrumentation 

To install the EXSPI graph templates on an HP Performance Manager system, copy these 
files to the graph template installation directory on the HP Performance Manager system:

— on Windows HP Performance Manager systems to <OVInstallDir>/newconfig/
OVPM 

— on UNIX HP Performance Manager systems to $OvInstallDir/newconfig/OVPM 

Once installed these graphs are located in the Application Bank under: EXSPI Admin.

When setup is complete, the following graphs are available:
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Exchange 2007 Graphs

Exchange 2007Client Access

Outlook Client Failures

This graph shows the percentage of RPCs failed in different categories. Run this graph only 
on nodes with the Mailbox Server role. This graph uses the data collected by the EXSPI-8X 
Dc-Outlook Client template. In the data store of the node, the EX2007_ISCLIENT table is 
used to construct this graph.

IMAP4 Connections

This graph shows the IMAP4 connection activity.  This graph uses the data collected by the 
EXSPI-8X Dc- IMAP4 Performance template. In the data store of the node, the 
EX2007_IMAP4PERF table is used to construct this graph.

MAPI RPC Performance

This graph shows metrics of information store RPC requests and RPC operations rate 
(operations/sec). Run this graph only on nodes with the Mailbox Server role. This graph uses 
the data collected by the EXSPI-8X Dc Information Store Performance template. In the data 
store of the node, the EX2007_ISPERF table is used to construct this graph.

MAPI RPC Latency Levels

This graph shows the number of successful RPCs with different Outlook client latency levels. 
The graph displays three different levels of latency: RPC Latency > 10, RPC Latency > 5, and 
RPC Latency > 2. Run this graph only on nodes with the Mailbox Server role. 

This graph uses the data collected by the EXSPI-8X Dc-Outlook Client template. In the data 
store of the node, the EX2007_ISCLIENT table is used to construct this graph.

POP3 Connections

This graph shows the POP3 connection activity. The graph displays POP3 connection, failed 
POP3 connections, and rejected POP3 connections for a server with the help of three line 
graphs. This graph uses the data collected by the EXSPI-8X Dc-POP3 Performance template. 
In the data store of the node, the EX2007_POP3PERF table is used to construct this graph.

POP3 Performance

This graph shows POP3 messages delivered to mailboxes.  This graph uses the data collected 
by the EXSPI-8X Dc-POP3 Performance template. In the data store of the node, the 
EX2007_POP3PERF table is used to construct this graph.

Outlook Client RPC Performance

This graph shows the Outlook Client RPC Performance. The graph displays the following 
details: RPCs attempted, RPCs failed, and RPCs succeeded. Run this graph only on nodes 
with the Mailbox Server role.  This graph uses the data collected by the EXSPI-8X Dc-Outlook 
Client template. In the data store of the node, the EX2007_ISCLIENT table is used to 
construct this graph.
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Information Store

Information Store Users and Connections 

This graph shows user and connection count metrics for the current day.  This graph uses the 
data collected by the EXSPI-8X Dc Information Store Performance template. In the data store 
of the node, the EX2007_ISPERF table is used to construct this graph.

Virtual Memory 16MB Free Block Trend

This graph shows information store virtual memory 16MB free block use trends. This graph 
uses the data collected by the EXSPI-8X Dc Information Store Performance template. In the 
data store of the node, the EX2007_ISPERF table is used to construct this graph.

Virtual Memory Large Free Block Megabytes Usage

This graph shows information store virtual memory large free block megabytes usage. This 
graph uses the data collected by the EXSPI-8X Dc Information Store Performance template. 
In the data store of the node, the EX2007_ISPERF table is used to construct this graph.

Virtual Memory Largest Block Size

This graph shows the change of the information store virtual memory largest block size.

This graph uses the data collected by the EXSPI-8X Dc Information Store Performance 
template. In the data store of the node, the EX2007_ISPERF table is used to construct this 
graph.

Mailbox Store

Mailbox Store Delivery Time

This graph shows hourly metrics for the average delivery times of messages to Exchange 
server private and public mailboxes. The graph shows the average delivery time of local 
messages to Exchange Server private mailboxes for every hour. This graph uses the data 
collected by the EXSPI-8X Dc-IS Mailbox Performance template. In the data store of the node, 
the EX2007_MBPERF table is used to construct this graph.

Mailbox Store Message Volume

This graph shows Exchange server private mailbox volume. The graph displays the following 
details: local deliveries, the number of messages delivered to all recipients, the number of 
messages sent to the transport, the number of messages submitted by clients, and the number 
of recipients that have received a message.

This graph uses the data collected by the EXSPI-8X Dc-IS Mailbox Performance template. In 
the data store of the node, the EX2007_MBPERF table is used to construct this graph. 

Mailbox Store Queues

This graph shows Exchange server mailbox store queue lengths. 

This graph uses the data collected by the EXSPI-8X Dc-IS Mailbox Performance template. In 
the data store of the node, the EX2007_MBPERF table is used to construct this graph.
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Exchange 2007 Mailbox Store EDB Database Statistics

This graph shows Exchange Server Mailbox Store EDB Database (edb) Statistics. The graph 
displays the following details: the physical amount of space used by the mailbox database (in 
megabytes), the physical amount of space available for use by mailbox database (in 
megabytes), and the amount of space that is not available for use by the mailbox database.

This graph uses the data collected by the EXSPI-8X Get Mailbox IS Sum Data template. In 
the data store of the node, the EX2007_MBSUMMARY table is used to construct this graph.

Public Folder Store

Public Folder Store Delivery Time

This graph shows hourly metrics for the average delivery times of local messages to Exchange 
servers.  This graph uses the data collected by the EXSPI-8X Dc-IS Public Folder Performance 
template. In the data store of the node, the EX2007_PFPERF table is used to construct this 
graph.

Public Folder Store Message Volume

This graph shows Exchange server public folder volume. The graph displays the following 
details: the number of messages delivered to all recipients, the total number of messages sent 
to the transport, the number of messages submitted by clients, and the number of recipients 
that have received a message. This graph uses the data collected by the EXSPI-8X Dc-IS 
Public Folder Performance template. In the data store of the node, the EX2007_PFPERF table 
is used to construct this graph. 

Public Folder Store Queues

This graph shows Exchange server public folder store queue lengths. The graph displays the 
following details: length of the Receive Queue and length of the Replication Receive Queue.

This graph uses the data collected by the EXSPI-8X Dc-IS Public Folder Performance 
template. In the data store of the node, the EX2007_PFPERF table is used to construct this 
graph. 

Exchange 2007 Public Folder Store EDB Database Statistics

This graph shows Exchange Server Public Folder Store Database (edb) Statistics. The graph 
displays the following details: the physical amount of space used by the public folder database 
(megabytes), the physical amount of space available for use by the public folder database 
(megabytes), and the amount of space that is not available for use by the public folder 
database.

This graph uses the data collected by the EXSPI-8X Get Public IS Sum Data template. In the 
data store of the node, the EX2007_PFSUMMARY table is used to construct this graph.

Transport Server Role 

Transport Server Queues

This graph shows Exchange 2007 Server Transport Server queue lengths. The graph displays 
lengths of the following queues: 

• Poison Queue

• Submission Queue

• Aggregate Delivery Queue
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• Unreachable Queue

• Retry Mailbox Delivery Queue

• Active Remote Delivery Queue

• Retry Remote Delivery Queue

• Largest Queue

• Active Mailbox Delivery Queue 

This graph uses the data collected by the EXSPI-8X Dc Transport Queues template. In the 
data store of the node, the EX2007_TRANSQ table is used to construct this graph.

Exchange 2003 Graphs

Exchange SPI graphs are located in the following folders: 

• Client Access

• Directory Service

• Information Store

• Mailbox Store

• Messaging

• Public Folder Store

Client Access 

ActiveSync Performance: This graph shows the ActiveSync Microsoft Exchange active 
directory, connection, and pending requests. 

ActiveSync Users: This graph shows the current users of Microsoft Exchange 
ActiveSync. 

IMAP4 Connections: This graph shows the IMAP4 connection activity. 

IMAP4 Performance: This graph shows the IMAP4 transaction activity. 

MAPI RPC Latency levels: This graph shows the number of successful RPCs with 
Outlook client latency levels.

MAPI RPC Performance: This graph shows metrics of information store RPC requests 
and RPC operations rate (operations/sec). 

Number of Successful RPCs with Different Latency Levels: This graph shows the 
number of successful RPCs with different Outlook client latency levels. 

Outlook Client RPC Performance: This graph shows the Outlook Client RPC 
Performance. 

OWA Connections: This graph shows the OWA connection activity. 

OMA Response Time: This graph shows the MSExchangeOMA last response time in 
seconds. 

POP3 Connections: This graph shows the POP3 connection activity. 

POP3 Performance: This graph shows POP3 messages delivered to mailboxes. 
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Directory Service

DSAccess Cache Hit-Miss Ratio: This graph shows MSExchangeDSAccess cache hit 
and miss ratio for Exchange 2003 servers.

Site Replication Service Space Free: This graph shows the percentage of free space on 
the Site Replication Service volume.

Site Replication Service Space Used: This graph shows Site Replication Service space 
usage on the Exchange server.

Information Store

Full-Text Indexing Space Usage: This graph shows disk space usage for full-text 
indexing of Microsoft Exchange information stores. 

Information Store Users and Connections: This graph shows user and connection 
count metrics, for the current day. 

Virtual Memory 16MB Free Block Trend: This graph shows information store virtual 
memory 16MB free block use trends. 

Virtual Memory Large Free Block Megabytes Usage: This graph shows information 
store virtual memory large free block megabytes usage. 

Virtual Memory Largest Block Size: This graph shows the change of the information 
store virtual memory largest block size. 

Transaction Log Percentage Free: This graph shows the percentage of free space on 
the transaction log volumes. 

Transaction Log Space Used: This graph shows Exchange server transaction log space 
usage on the Exchange server. 

Mailbox Store

Mailbox Store Delivery Time: This graph shows hourly metrics for the average 
delivery times of messages to Exchange server private and public mailboxes. 

Mailbox Store EDB Database Statistics: This graph shows Exchange server private 
mailbox store database statistics.

Mailbox Store Streaming Database Statistics: This graph shows Exchange mailbox 
store streaming database statistics.

Mailbox Store Storage Usage: This graph shows mailbox store storage usage.

Mailbox Store Message Volume: This graph shows Exchange server private mailbox 
volume.

Mailbox Store Queues: This graph shows Exchange server mailbox store queue lengths.

Messaging

MTA Message Volume: This graph shows Exchange server Message Transfer Agent 
volume. 

MTA Queues: This graph shows Exchange server queue lengths. 

SMTP Connections: This graph shows SMTP virtual server connections on the 
Exchange server. 

SMTP Queues: This graph shows SMTP server queues on the Exchange server 

SMTP Message Volume: This graph shows SMTP volume on the Exchange server. 
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SMTP Queue, Badmail, and Pickup Counts: This graph shows SMTP badmail, 
pickup and queue item counts for each SMTP virtual server. 

SMTP Queue, Badmail, and Pickup Size: This graph shows SMTP badmail, pickup 
and queue sizes for each SMTP virtual server. 

X400 MTA Queue Space Usage: This graph shows disk space usage for X400 service 
MTA queue.

Public Folder Store

Public Folder Store Delivery Time: This graph shows hourly metrics for the average 
delivery times of local messages to Exchange servers. 

Public Folder Store EDB Database Statistics: This graph shows Exchange server 
public folder store (edb) database statistics. 

Public Folder Store Message Volume: This graph shows Exchange server public 
folder volume. 

Public Folder Store Streaming Database Statistics: This graph shows Exchange 
Public Folder store streaming database statistics. 

Public Folder Store Storage Usage: This graph shows Exchange server public folder 
usage. 

Public Folder Store Queues: This graph shows Exchange server public folder store 
queue lengths.
Integration with HP Reporter 111



112 Chapter 6



7 Troubleshooting
This chapter offers troubleshooting suggestions for Exchange SPI. It includes the following 
sections:

• Self-Healing Information for enhanced troubleshooting

• Verifying Software Installation on the Management Server

• The Exchange SPI Error Log

• Turning on/ Disabling Tracing

• Common Errors

• Verifying the MSXSPI account has the right privileges 

• Verifying HP Performance Agent Integration

• Installing Old DSI Log Files

• Advanced Configuration Template Failures

• Exchange Service Discovery errors

Self-Healing Information for Enhanced Troubleshooting

The Microsoft Exchange SPI now includes a Self-Healing Info application that gathers data 
useful for troubleshooting issues. The application can be launched on the managed node to 
gather specific error messages, and other relevant data that can help you diagnose problems. 

Using the Self-Healing Info application

1 Turn on tracing, see Turning on Tracing on page 115.

2 Reproduce your problem.

3 Open the Node Bank window and locate the node on which you want to run the 
Self-Healing Info application.

4 Open the Application Bank window and double-click EXSPI.Admin.

5 Drag and drop the node onto the Self-Healing Info application.

6 In the message that appears, note where the compressed file will be stored.
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Verifying Microsoft Exchange SPI Installation on the Management 
Server

To check the integrity of Exchange SPI files on the HPOM management server, run the 
following command: 

/usr/sbin/swverify EXSPI

This command produces output similar to the following:

 (non-interactive) (jobid=ovruxr13-0161)
       * Session started for user "root@ovruxr13".
       * Beginning Selection
       * Target connection succeeded for "ovruxr13:/".
       * Software selections:
+ DSI2DDF.DSI2DDF,l=/,r=A.02.00.00,a=HP/SunOS,v=HP
EXSPI.EXSPI,l=/,r=A.08.20.6,a=HP-UX_B.11.00_32/HP-UX_B.11.00_64,v=HP
+SPI-SHS-OVO.SPI-SHS-AIX,l=/,r=A.01.00.00,a=HP_UX_10/11,v=HP
+SPI-SHS-OVO.SPI-SHS-CORE,l=/,r=A.01.00.00,a=HP_UX_10/11,v=HP
+SPI-SHS-OVO.SPI-SHS-HPUX,l=/,r=A.01.00.00,a=HP_UX_10/11,v=HP
+SPI-SHS-OVO.SPI-SHS-LXx86,l=/,r=A.01.00.00,a=HP_UX_10/11,v=HP
+SPI-SHS-OVO.SPI-SHS-OSF,l=/,r=A.01.00.00,a=HP_UX_10/11,v=HP
+SPI-SHS-OVO.SPI-SHS-SOL,l=/,r=A.01.00.00,a=HP_UX_10/11,v=HP
+SPI-SHS-OVO.SPI-SHS-UX64,l=/,r=A.01.00.00,a=HP_UX_10/11,v=HP
+SPI-SHS-OVO.SPI-SHS-WIN,l=/,r=A.01.00.00,a=HP_UX_10/11,v=HP
+SPI-SVCDISC-OVO.SPI-SVCDISC-AGT-AIX,l=/
,r=A.02.00,a=HP_UX_11,v=HP,fr=A.02.00,fa=HP_UX_11
           +SPI-SVCDISC-OVO.SPI-SVCDISC-AGT-HP,l=/
,r=A.02.00,a=HP_UX_11,v=HP,fr=A.02.00,fa=HP_UX_11
+SPI-SVCDISC-OVO.SPI-SVCDISC-AGT-LNX,l=/
,r=A.02.00,a=HP_UX_11,v=HP,fr=A.02.00,fa=HP_UX_11
+SPI-SVCDISC-OVO.SPI-SVCDISC-AGT-SOL,l=/
,r=A.02.00,a=HP_UX_11,v=HP,fr=A.02.00,fa=HP_UX_11
+SPI-SVCDISC-OVO.SPI-SVCDISC-AGT-TRU64,l=/
,r=A.02.00,a=HP_UX_11,v=HP,fr=A.02.00,fa=HP_UX_11
+SPI-SVCDISC-OVO.SPI-SVCDISC-AGT-WIN,l=/
,r=A.02.00,a=HP_UX_11,v=HP,fr=A.02.00,fa=HP_UX_11
+SPI-SVCDISC-OVO.SPI-SVCDISC-SRV-HP,l=/
,r=A.02.00,a=HP_UX_11,v=HP,fr=A.02.00,fa=HP_UX_11
       * A "+" indicates an automatic selection due to dependency or the 
automatic selection of a patch or reference bundle.
       * Selection succeeded.
       * Beginning Analysis
       * Session selections have been saved in the file:
        /root/users/afshinsu/.sw/sessions/swverify.last
NOTE: More information may be found in the agent logfile using the 
command 
swjob -a log ovruxr13-0161 @ ovruxr13:/

This utility is not available for Sun Solaris
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The Microsoft Exchange SPI Error Log

HPOM for UNIX 8/HTTPS errors are logged to:

<Installation_Directory>\Data\exspi\log\exspierror 

For example:

04/01/02 08:43:57 ERROR exspi(488) [colamain.cpp:333]: EXSPI-60-40:
Exchange Server Software not installed on this system (Check: 
SOFTWARE\Microsoft\Exchange\Setup). Unable to perform collection!

Turning on Tracing

If a problem occurs and you are asked to turn on tracing by the EX-SPI support team, use the 
Enable EXSPI Tracing application for the relevant Exchange version. 

1 Select all the Exchange managed nodes you wish to configure in the OVO Node Bank.

2 Drag and drop these nodes on the Enable EXSPI Tracing application located in the 
EXSPI Admin application group under the appropriate version.

3 Verify whether there are any errors in the Output of Application window.

Figure 20 Output of Application window
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Disabling Tracing

For disabling the tracing, use Disable EXSPI Tracing.

Common Errors

1 When re-installing or upgrading Exchange Server, Exchange Setup program shows errors.

Symptom: Exchange Server re-install or upgrade (e.g., new Service Pack), the 
Exchange Setup generates error messages about DLLs that can't be overwritten.

Solution: Stop HPOM (opcagt -stop) and HP Performance Agent (mwacmd 
stop), then retry the operation.

2 Schedule template fails with message:
EXSPI xxxxx Metric Collection failed.

Symptom: The scheduled command failed with an exit code other than 0.

Solution: This error sometimes occur if the system is rebooted just before the 
collector/analyzer program was executed. 

However, if this is not the case do the following: To find out more information about the 
failure, modify the failing schedule template, check the Send Output of Action check box 
and re-distribute templates again.

The browser message should now contain an annotation with more information about the 
failure. Also, check the exspierror for more information.

Verifying the MSXSPI Account has Sufficient Privileges

In order to verify that you have created the MSXSPI account with the right amount of 
privileges to run advanced metrics such as 5, 841, or 630, do the following:

1 Log into your Exchange 2003 server as MSXSPI user (in the correct NT domain).

2 Open a DOS command prompt window.

3 cd to the directory where exspi collector is located 
(<InstallDir>\data\bin\instrumentation).

4 Run the following series of commands:

exspi_e2k.exe  -m 5   -p

exspi_e2k.exe  -m 841   -p

exspi_e2k.exe  -m 630   -p

5 These will print the results to the screen.

The trace file will grow very large. It is advisable to leave tracing enabled only long 
enough to recreate the problem.
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6 If these executed properly and the correct results printed on the screen, your MSXSPI 
account has the right permissions.

Advanced Configuration Template Failures

Symptom: 

The following data collectors fail and a critical message is shown in the HPOM  browser:

— EXSPI 6X Dc-Private IS Sum. Data

— EXSPI-6X Dc-Public IS Sum. Data

— EXSPI-6X Dc-Mailbox Data

— EXSPI-6X Dc-Public Folder Data

Solution: 

These collectors access Exchange directly and require MSXSPI user and 
MSXSPI<hostname> mailbox.

1 Verify MSXSPI user, MSXSPI<hostname> mailbox, MSXSPI rights in Exchange and HP 
Performance Agent:

2 Verify MSXSPI user setup.

— Use Windows User Manager to verify MSXSPI account. The user must exist in the 
same domain as that which the Exchange Server is part of. Note: there must be no 
local MSXSPI user.

3 Verify MSXSPI rights in Exchange.

The MSXSPI user must have "Receive As" and "Send As" Exchange Admin permissions. See 
Creating a Service Account for Exchange 2003 Nodes on page 131.

4 Verify MSXSPI<hostname> mailbox.

Use Exchange Admin to verify that a MSXSPI<host_name> mailbox exists and click on 
Recipients. In the right pane, a MSXSPI<host_name> user must show up for each server 
which belongs to the site.

Exchange Service Discovery Failures

Symptom: 

The error message: 

Error: Specified file was not found

Solution: 

Verify that the distribution of Exchange SPI commands was successful. Refer to Distribute 
the Microsoft Exchange SPI Actions, Monitors, and Commands on page 25.

Symptom: 

The error message: Problem in Executing opcservice
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Solution: 

Check if the HP Service Navigator Component is installed.

The HP Service Navigator component is included on the media with the OVO bundle
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8 Using the PowerShell Collection Configuration 
Utility
The PowerShell collection configuration utility enables you to create or modify collection 
configurations and components of collection configurations. The PowerShell collection 
configuration utility helps you create a modified collection configuration, which you can 
associate with an existing template by using the HPOM console. You can use this utility to 
modify data collection mechanism on Microsoft Exchange Server 2007 nodes.

The Microsoft Exchange SPI saves every change made through the PowerShell collection 
configuration utility in the SPI metadata file (an XML file). After the updated SPI metadata 
file is deployed on a node, the collection manager (a background process that runs on managed 
nodes) reads the SPI metadata file and creates necessary objects to analyze the collections.

About Collection Configuration

A collection describes the complete workflow of a collector. A collection configuration defines 
the mechanism to collect metric data. It also defines how to store the metric data. You must 
associate every collection configuration with a scheduled task template. When you invoke a 
scheduled task template on a managed node, a collector retrieves the following information 
from a collection configuration:

• The metric value to be collected

• The mechanism to send the collected data to the analyzer for data analysis

• The mechanism to receive the analyzed data

• The mechanism to send the analyzed data to a data store (if required)

A collection configuration consists of the following building blocks:

• MetricSets

• OpCMsg Calls

• OpCMon Calls

• DataStores

About MetricSets

The Microsoft Exchange SPI monitors various metrics of Microsoft Exchange Server. A metric 
is a measurement that defines a specific operational or performance characteristic of a system 
or an application. Collectors collect metric data on managed Exchanged nodes. These metric 
data give an indication of the health, availability, and performance of Microsoft Exchange 
Server.

A MetricSet—a component of a collection configuration—is a group of related metrics. If you 
run an Exchange Management Shell cmdlet on an Exchange Server node, the Exchange 
Server returns a group of metrics with metric values. These metrics, returned by a particular 
Exchange Management Shell cmdlet, form a MetricSet.
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About OpCMsg Calls

An OpCMsg Call is an element of a collection configuration that generates an alert message 
when a metric value does not match a preset value or range of values. Alarm enables the 
collection to compare the actual value with the preset value with the help of arithmetic 
comparators. You can set a severity level and associate a message text to an alarm.

About OpCMon Calls

An OpCMon Call sets a limiting value for numeric metric data. You can associate an OpCMon 
Call to a monitor template and use it with a collection configuration.

About DataStores

A DataStore helps a collector log the collected data to a data store (for example, CODA). The 
DataStore defines the way in which the collected data can be stored in the data store. You 
must add a DataStore to a collection configuration if you want to log the data collected by the 
collection. A collector retrieves data formatting information from a DataStore before logging it 
to a data store.

Installing the PowerShell collection configuration utility

You must install the PowerShell collection configuration utility on a Windows machine. To 
install the PowerShell collection configuration utility, follow these steps:

1 Collect the following file from the management server: 

/opt/OV/EXSPI/bin/Exspi-Configuration-Utility.Z

2 Transfer the Exspi-Configuration-Utility.Z file on a Windows machine.

3 Rename the Exspi-Configuration-Utility.Z file to 
Exspi-Configuration-Utility.ZIP.

4 Extract the contents of the file on the Windows machine.

Working with the PowerShell collection configuration utility

The PowerShell collection configuration utility enables you to create a new collection 
configuration with new DataStores, OpCMsg Calls, or OpCMon Calls. You can also view the 
default settings of existing collection configurations, DataStores, OpCMsg Calls, OpCMon 
Calls, and MetricSets that are provided with the SPI for Microsoft Exchange Server 2007. The 
PowerShell collection configuration utility provides you with a graphical user interface to 
perform necessary tasks to modify existing collection definitions, or create new definitions.

Before you begin

If you have already modified the default collection mechanism of the Microsoft Exchange SPI 
by manually modifying the spimetadata.xml file, follow these steps:

1 Go to the following location on the management server: /var/opt/OV/share/
databases/OpC/mgd_node/customer/ms/x64/win2k3/cmds

2 Collect the spimetadata.xml file.
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3 Copy the spimetadata.xml file on the Windows machine into the folder where you have 
extracted the Exspi-Configuration-Utility.Z file.

Launch the PowerShell collection configuration utility

To launch the PowerShell collection configuration utility, follow these steps:

1 Go to the location on the Windows machine where the 
Exspi-Configuration-Utility.Z file was extracted.

2 Double-click the hp.ov.spi.composer file. The Select Server dialog box opens.

3 Select the Load from Local File option, and then click Load. The user interface of the 
PowerShell collection configuration utility opens.

Use the user interface

The PowerShell collection configuration utility’s graphical user interface consists of the 
following elements:

• Menu bar

• Toolbar

• Left pane

• Right pane

PowerShell collection configuration utility menu bar

You can use the menu options in the menu bar to perform tasks like adding and removing an 
element of collection definition. You can also view a preview of every element (in the form of 
XML markups) by using the Preview menu option.

Menu Options Description

File Save Saves any changes that you make.

Save as Enables you to save the updated 
spimetadata.xml file on a different location 
and with a different name.

Reload/ Cancel All Changes Reloads the utility, cancels all unsaved 
changes.

Exit Exits the PowerShell collection configuration 
utility.

Edit Deletes the selected collection configuration or component from this menu.

Insert Add New MetricSet Adds a new MetricSet to the list of available 
MetricSets.

Add New Metric Adds a new Metric to the list of available 
metrics in a particular MetricSet. This option is 
enabled only when you select a MetricSet.
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PowerShell collection configuration utility toolbar

You can use the toolbar to add collection elements, such as MetricSets, DataStores, OpCMsg 
Calls, and OpCMon Calls.

The left pane lists all available metrics, MetricSets, collections, DataStores, OpCMsg Calls, 
and OpCMon Calls in a tree like structure. You can navigate to specific collection elements 
with the help of the left pane. The right pane provides you an interface to view and modify 
properties and settings for every collection element.

Add New Collection Adds a new collection to the list of available 
collections.

Add New DataStore Adds a new DataStore to the list of available 
DataStores.

Add New OpCMon Call Adds a new OpCMon Call to the list of 
available OpCMon Calls.

Add New OpCMsg Call Adds a new OpCMsg Call to the list of available 
OpCMsg Calls.

Menu Options Description

Icon Tool Name Description

Add MetricSet Use this tool to add a new MetricSet.

Add Collection Use this tool to add a new collection.

Add DataStore Use this tool to add a new DataStore.

Add OpCMsg Call Use this tool to add a new OpCMsg Call.

Add OpCMon Call Use this tool to add a new OpCMon Call.
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Adding a MetricSet

A MetricSet is a group of related metrics. Microsoft Exchange Server 2007 returns a 
MetricSet when you run an Exchange Management Shell command (cmdlet). The Microsoft 
Exchange SPI collects these metrics to monitor the health, availability, and performance of 
Microsoft Exchange Server 2007. By default, Microsoft Exchange SPI makes use of 23 
MetricSets (corresponding to 23 cmdlet commands). The PowerShell collection configuration 
utility enables you to add a new MetricSet to the list of existing MetricSets and link the new 
MetricSet with a cmdlet to start metric data collection.

To add a new MetricSet, follow these steps:

1 Click Insert > Add New MetricSet from the menu bar. A new MetricSet (with the name New 
MetricSet) appears in the list of MetricSets.

2 In the right pane, specify the following options:

3 Click Apply Changes.

4 Click File > Save.

Adding a metric

The metric values of Microsoft Exchange Server indicate its health condition, availability, and 
performance ability. The SPI collects these metric values to project the status of Microsoft 
Exchange Server on HPOM. In the PowerShell collection configuration utility, you can find a 
list of related metrics under every MetricSet. The PowerShell collection configuration utility 
enables you to add a new metric under a MetricSet. You can also modify or delete an existing 
metric.

To add a new metric, follow these steps:

1 In the left pane, expand MetricSets.

2 Right-click an available MetricSet, and then click Add New Metric.

Alternatively, select an available MetricSet, and then click Insert > Add New Metric from the 
menu bar.

3  A new metric (with the name New Metric) appears in the list of metrics under the 
selected MetricSet.

Option Description

MetricSet Name Type an appropriate name.

Command Select a command from the list of available commands. 
The list presents the cmdlets that have been used with 
the existing MetricSets. If you want to use a new 
cmdlet, which is not used with the default MetricSets, 
you must type the cmdlet in the Command box. You 
can use any valid cmdlet (or multiple cmdlets with 
pipeline characters).

Do not modify the default MetricSets. You can modify a newly added MetricSet.
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4  In the right pane, specify the following options:

5 Click Apply Changes.

6 Click File > Save.

Adding or modifying an OpCMsg Call

If some metric values cross a certain limiting value, you can receive alert messages on the 
HPOM message browser. The SPI retrieves alert message information from an OpCMsg Call. 
An OpCMsg Call is an element of a collection definition, which holds the following 
information:

• Limiting value (or range of values) for a metric

• Alert message if the metric does not match the above value or crosses the range of values

• Severity level of the event when the metric does not match the limiting value

The PowerShell collection configuration utility enables you to add a new OpCMsg Call or 
modify an existing one.

To add a new OpCMsg Call, follow these steps:

1 In the left pane, expand Collection Components, and then right-click OpCMsg Calls.

2 Click Add New OpCMsg Call.

Option Description

Metric Name Select a metric name from the list of available metrics. 
If you want to use a metric returned by a newly added 
MetricSet, you must type the metric name in the text 
box. Do not use a metric that can hold multiple values. 
The Microsoft Exchange SPI does not support 
multi-valued metrics.

Metric Description Type a description of the metric.

Metric Data Type After you choose the metric, suitable data type appears 
by default. Do not change the default setting.

Category Select this option to specify the unit of measure of the 
metric.

Scale To convert the metric value to a unit of your choice, 
specify the multiplying factor. For example, if the 
metric value is in the form of KB and you want to 
collect the metric in the form of bytes, specify 1024 in 
this field.

Suffix Specify the element of the metric value that you want 
to eliminate. For example, if the metric value is 
appended with the unit B (as in 1200B), you can 
eliminate B by typing B in the Suffix text box.

Do not modify the existing set of metrics in an existing MetricSet. You can add a new 
MetricSet, and then you can modify the metrics of the newly added MetricSet at any point of 
time.
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3 In the right pane, specify the following options:

4 Click Apply Changes.

5 Click File > Save.

To modify an existing OpCMsg Call, follow these steps:

1 In the left pane, expand Collection Components, and then click the OpCMsg Call that you 
want to modify.

2 In the right pane, specify the following options:

Option Description

OpCMsg Call Set Name Type an appropriate name.

Application Type an appropriate name of the application that will 
be affected. You can view this text in the HPOM 
message browser when you open the Message 
Properties dialog box. You can leave this field blank.

Object Type an appropriate name of the object of the 
application that will be affected. You can view this text 
in the HPOM message browser when you open the 
Message Properties dialog box. You can leave this field 
blank.

Severity Select the severity level of the event.

Message Text Type the message that you want to generate.

MetricSet Ref Select an available MetricSet from the list.

Metric Ref Select an available metric from the list.

Select Arithmetic Operator Select an available arithmetic operation from the list.

Select Logical Operator to 
combine with Previous Rule

This field is enabled only when you choose more than 
one limiting value or condition for the chosen metrics. 
Select AND or OR to combine the rules that you create 
based on the available arithmetic operators.

Value to compare Select the limiting (threshold) value of the selected 
metric.

Option Description

OpCMsg Call Set Name Type an appropriate name.

Application Type an appropriate name of the application that will 
be affected. You can view this text in the HPOM 
message browser when you open the Message 
Properties dialog box. You can leave this field blank.

Object Type an appropriate name of the object of the 
application that will be affected. You can view this text 
in the HPOM message browser when you open the 
Message Properties dialog box. You can leave this field 
blank.

Severity Select the severity level of the event.

Message Text Type the message that you want to generate.

MetricSet Ref Select an available MetricSet from the list.
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3 Click Apply > Changes.

4 Click File > Save.

To delete an existing OpCMsg Call, right-click the OpCMsg Call in the left pane, and then 
click Remove this.

Adding or modifying an OpCMon Call

The PowerShell collection configuration utility enables you to add a new OpCMon Call or 
modify an existing one. An OpCMon Call sets a limiting value for metric data through a 
monitor template. The SPI retrieves information like message text and severity from the 
template.

You can use OpCMon Calls only for numeric metric values.

To add a new OpCMon Call, follow these steps:

1 In the left pane, expand Collection Components, and then right-click OpCMon Calls.

2 Click Add New OpCMon Call.

3 In the right pane, specify the following options:

4 In the Measurement Threshold Policy name text box, type the name of a monitor template 
to which you want to associate this OpCMon Call.

5 Click Apply > Changes.

6 Click File > Save.

To modify an existing OpCMon Call, follow these steps:

1 In the left pane, click the OpCMon Call that you want to modify.

Metric Ref Select an available metric from the list.

Select Arithmetic Operator Select an available arithmetic operation from the list.

Select Logical Operator to 
combine with Previous Rule

This field is enabled only when you choose more than 
one limiting value or condition for the chosen metrics. 
Select AND or OR to combine the rules that you create 
based on the available arithmetic operators.

Value to compare Select the limiting (threshold) value of the selected 
metric.

Option Description

Option Description

Name Type an appropriate name for the OpCMon Call.

MetricSet Ref Select an available MetricSet.

Metric Ref Select the metric name for which you want to set the 
OpCMon Call.
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2 In the right pane, modify the following options, if necessary:

3 In the Measurement Threshold Policy name text box, type the name of a monitor template 
to which you want to associate this OpCMon Call.

4 Click Apply > Changes.

5 Click File > Save.

To delete an existing OpCMon Call, right-click the OpCMon Call in the left pane, and then 
click Remove this.

Adding a DataStore

DataStores define the way in which you can store metric data. After the SPI collects metric 
data by using collectors, you can store the collected data either in the HP Operations/OVO 
agent's data store (CODA) or in HP Performance Agent (if you have it installed in your HPOM 
environment). The PowerShell collection configuration utility enables you to add a new 
DataStore or modify an existing one.

To add a new DataStore, follow these steps:

1  In the left pane, right-click DataStores.

2 Click Add New DataStore.

3 In the right pane, specify the following options:

4 From the Select MetricSet reference drop-down list, select a MetricSet.

5 From the Select Metric reference drop-down list, select a metric. While selecting the 
metrics, maintain the order of metrics as presented in the MetricSet element.

6 In the Select Data column reference box, type a name for the data column in which the 
DataStore will store the metric selected above. Do not leave this field blank if you want to 
add more than one metric.

7 Click Add. You can add more than one MetricSet and metric.

Option Description

Name Type an appropriate name for the OpCMon Call.

MetricSet Ref Select an available MetricSet.

Metric Ref Select the metric name for which you want to set the 
OpCMon Call.

Option Description

Name Type an appropriate name for the DataStore.

Capacity Type the number of rows for the DataStore.

Data Source Type EX2007_DATA.

Data Table Type EX2007_<table name>, where <table name> is 
an appropriate name for the table.

Index By Type DAY.

Roll By Type the interval at which the data should be flushed 
out of the data store. You can specify DAY, WEEK, or 
MONTH. You cannot store data for more than a 
month.
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8 Click Apply > Changes.

9 Click File > Save.

After you create a new DataStore, you must add it to an existing collection configuration. 
After adding the newly created DataStore to an existing collection configuration, follow these 
steps:

1 Go to the newly created DataStore.

2 In the right pane, click Generate SPEC. The Spec File Generator dialog box opens.

3 In the Spec File Generator dialog box, type an appropriate label name in the Table Label 
text box, and then click Create. The details of the SPEC file appear in the Preview of the 
SPEC File section. A new file with the .spec extension is placed into the directory where 
you extracted the Exspi-Configuration-Utility.Z file.

4 Click Save.

5 Close the Spec File Generator dialog box.

If you create a new DataStore and generate a spec file by using the PowerShell collection 
configuration utility, you must launch the Create Data Source application on the nodes on 
which you want the new collection mechanism to take effect.

Adding a collection configuration

A collection defines the complete mechanism of metric data collection. A collector can collect 
metric data, log it to a data store, or send a message to the HPOM message browser for 
threshold violation. A collection configuration consists of all the elements that collectively 
describe the complete life cycle of the collection mechanism for a MetricSet.

To add a new collection configuration, follow these steps:

1 In the left pane, right-click Collection Configurations, and then click Add New Collection. 
A new collection appears in the left pane under Collections and the Add metrics to a 
Collection dialog box opens.

2 Select a MetricSet from the drop-down list.

3 To add an OpCMsg Call to this collection, click Add OpCMsg in the right pane. The Add 
OpCMsg Call to a Collection dialog box opens.

4 Select an OpCMsg Call from the drop-down list.

5 To add an OpCMon Call to this collection, click Add OpCMon in the right pane. The Add 
OpCMon Call to a Collection dialog box opens.

6 Select an OpCMon Call from the drop-down list.

7 To add a DataStore, click Add DataStore in the right pane. The Add DataStore to a 
Collection dialog box opens.

8 Select a DataStore from the drop-down list.

9 In the right pane, type an appropriate name in the Collection Configuration Name text 
box.

10 Click File > Save.

Do not modify an existing DataStore. You can add a new DataStore, and modify the new 
DataStore in future.
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11  Note the command displayed in the Schedule Task Policy Command text box. You must 
use this command with the scheduled action template that will be mapped to the new 
collection configuration.

Transferring the Data Files to the Management Server

When you modify the collection mechanism from the user interface of the PowerShell 
collection configuration utility, the changes are recorded in the spimetadata.xml file. The file 
resides into the folder where you extracted the Exspi-Configuration-Utility.zip file. After you 
save the configuration information from the user interface, you must transfer the updated 
XML file on the management server. In addition, if you create a new DataStore, the resulting 
.spec file must also be transferred to the management server. Only after transferring the 
updated spimetadata.xml file (and .spec files, if necessary) on the management server, the 
changes will take effect. To transfer the files, follow these steps:

1 Send the updated spimetadata.xml file (and the .spec files) on the HPOM 
management server by using a file-transfer mechanism.

2  On the management server, store the files into a temporary location—for example, /tmp.

3 Copy the files into the following location: /var/opt/OV/share/databases/OpC/
mgd_node/customer/ms/x86/winnt/cmds

4 Run the following command at the /tmp directory (where you originally stored the files): 
compress -f <file_name> 2>/dev/null where <file_name> is the name of the file 
(spimetadata.xml and the .spec files). The files are converted into compressed files 
(with the extension .Z).

5 Copy the compressed files into the following directory: /var/opt/OV/share/
databases/OpC/mgd_node/customer/ms/intel/nt/cmds

6 Re-distribute the Actions, Monitors, and Commands for the Microsoft Exchange SPI on 
the nodes where you want the modified data collection mechanism to take effect.

7 If you created new DataStores, which resulted in creation of .spec files, you must run the 
Create DataSources application on the nodes where you want the modified data collection 
mechanism to take effect.

Additional Configuration

If you create a new collection configuration, you must create a new scheduled action template 
on the management server. To map the new collection configuration to a scheduled action 
template, follow these steps:

1 Create a new scheduled action on the management server.

2 To specify the command for the template, use the command displayed in the Schedule 
Task Policy Command text box in the user interface for the new collection configuration 
(step 11 on page 129).

3 Deploy the newly created template on the nodes where you want the modified collection 
mechanism to take effect.

Do not modify an existing collection configuration. You can add a new collection 
configuration, and modify the new collection configuration in future.
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A Creating a Service Account for Exchange 2003 
Nodes
The Microsoft Exchange SPI collects data from many sources. In order to collect some types of 
data, the Exchange SPI requires advanced user credentials. 

This chapter outlines:

• Which templates/applications have user account requirements

• For templates and applications requiring specific user permissions, how to create the 
service account and grant proper access permissions.

APPLICATIONS 

For all versions of Exchange, the following applications need to run with this special type of 
service account:

— Enable Message Tracking

— EXSPI MBOX Config.

POLICIES

For Exchange 2003: 

All templates in the EXSPI Specialized Groups require to run under this type of account.

See Exspi Template Group Requirements on page 44 for more information about which 
templates require the service account with special Exchange privileges.

Creating a Service Account with Adequate Access Permissions

Some templates and applications require a service account for each logon domain where 
Exchange servers reside (see Exspi Template Group Requirements on page 44). This service 
account enables the Microsoft Exchange SPI to access information from the Exchange 
database. This is required only for Exchange 2003.

The service account must be created and the access privileges granted for Exchange 2003 
nodes in a Windows 2000/2003 Domain

Exchange 2003 nodes in Windows 2000/2003 Domain 

To create a service account with special Exchange privileges for Exchange 2003 nodes the 
following steps are required:
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Task 1: Enable Viewing of the Administrative Groups Folder

Task 2: Create User Account

Task 3: Add the service account user to the Local Administrators group.

Enable Viewing of the Administrative Groups Folder

To create the user account, it is necessary to first enable viewing the administrative groups 
folder. To enable viewing of the Administrative Groups folder, follow these steps:

1 Open the Exchange server Properties.

2 Select Display administrative groups.

3 Click Apply, and then OK.

Create User Account

To create the user account with necessary privileges, follow these steps:

1 Log on to the system that hosts the managed node’s domain.

2 Select Start > Settings > Control Panel > Administrative Tools > Active Directory Users and 
Computers.

3 Expand the Active Directory Users and Computers and right-click Users and select New 
> User.
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Figure 21 Active Directory Users and Computers dialog

4 In the New Object - User dialog, enter a user name for the new service account into the 
First Name and the User logon name fields.  

You must create a service account with these privileges in each Windows domain. 
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Figure 22 Entering the new service account name   

1 In the next window, enter Password/Confirm Password for the service account.

2 Select Password Never Expires. Then click Next.

Figure 23 Setting password properties   
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3 In the New Object dialog, deselect Create an Exchange mailbox, and click Next

Figure 24 Deselecting creating a mailbox   

4 In the next dialog, complete creating the user by clicking Finish.

5 You are now back at the Active Directory Users and Computers dialog. In the right 
pane, right-click on the service account user just created and select Properties.

6 In the service account Properties page, select the General tab. Enter HPOM Exchange 
SPI in the Display name and Description fields.

Figure 25 Entering names in Properties dialog   

7 Select the Member Of tab, and click Add.

8 In the Select Group dialog select Exchange Domain Servers from the top pane.

9 Click OK and exit the Active Directory Users and Computer dialog.

10 Open Active Directory Users and Computers.

11 Right-click on the domain to which the Exchange server belongs and click Properties.

12 Choose the Group Policy tab and select the Default Domain Policy.
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13 Click Edit. Browse to Computer Configuration > Windows Settings > Security 
Settings > Local Policies > User Rights Assignment.

14 Double-click the Log on as a Batch Job group policy and add the MSXSPI account to 
this policy.

Figure 26 Confirming membership privileges   

e Add the service account user to the Local Administrators group on the Exchange 
server. 

a On each targeted Exchange 2003 server, select Start > Settings > Control Panel. 

b Double click Administrative Tools. Double click Computer Management, then 
open the Local Users and Groups folder. Select and open the Groups folder, then 
double click Administrators.

c In the Administrators Properties dialog, click the Add button. Select the correct 
Domain from the Look in drop down list. Select the new service account user from 
the list, and click Add. Click Apply and then OK.
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Figure 27  Adding service account user to Local Administrators group

It can sometimes take a few hours for new group membership and rights to be 
applied to a service account.
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B File Names
Introduction

This chapter lists the Exchange SPI file names, along with their descriptions, owners, groups, 
and permissions. Exchange SPI files are grouped as follows:

• Management server files

• Management server/managed node files

• Managed node files

• Logging and trace files
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Management Server Files

Templates for opccfgupld (HPOM Upload Facility)

All files listed in this table can be found on the management server in the following directories 
(the location of these files varies by platform):

/var/opt/OV/share/tmp/OpC_appl/EXSPI/exspiset/C/

Table 4 Management Server Files

File Description

exspiset.idx HPOM upload control file. This 
file defines what is being 
uploaded into HPOM: message 
groups, monitor templates, logfile 
templates, applications and 
template groups.

TEMPLATES/LOGFILE
/logfile.dat

Definition file for logfile 
encapsulation. 

TEMPLATES/MONITOR
/monitor.dat

Definition file for HPOM 
templates: collector/analyzer 
program, external monitor for 
each metric and file system 
monitor. Contains all details for 
monitoring all metrics.

TEMPLATES/SCHEDULE
/schedule.dat

Definition file for Exchange SPI 
schedule templates.

TEMPLATES/TEMPLGROUP
/templgrp.dat

Definition file for HPOM 
template group structure.

TEMPLATES/MSGGROUPS
/msggrps.dat

Definition file for HPOM 
message group structure.

TEMPLATES/INTERFACE
/msgi.dat

Definition file for Exchange SPI 
specific error message.
140 Appendix B



Miscellaneous Management Server Files

Table 5 Miscellaneous Other Management Server Files

File Description

/etc/opt/OV/share/conf
/OpC/mgmt_sv/
reports/exspi_lc.sql

Report that lists all nodes that have 
Exchange SPI templates assigned (for 
license check).

/opt/OV/EXSPI/bin/exspipv Script to run HP Performance Manager as 
metric operator actions and bring up graphs.

/opt/OV/EXSPI/bin/exspircfg                         Script for EXSPI Node Config.

/opt/OV/EXSPI/bin/EXSPI_DiscConfig.sh            Script for setting Exchange SPI related 
variables. 

/opt/OV/EXSPI/bin/exspipngcfg_e2k.sh        Script for End-to-End Ping config for 
Exchange 2003
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Management Server/Managed Node Files

When you run swinstall, the following monitor and command files are installed on the 
Management Server. They are also installed on managed nodes when you distribute monitors, 
commands and actions from the Management Server to the managed nodes.

Monitor Files

On Management Server:

/var/opt/OV/share/databases/OpC/mgd_node/customer/ms/x86/ winnt/monitor/ 
(for HTTPS)

On Managed Node:

<OVO-DATADIR>\bin\instrumentation (for HTTPS)

Table 6 Monitor Files 

 File  Description

exspi_e2k.exe  Exchange 2003 SPI Collector/Analyzer program.

msexchange.apm.xml Template list for cluster fail-over

OVAMTLog2k.dll  Tracking.Log access library for Exchange 2003

OVAMDa.dll  LDAP access library

hpudm.txt  Internal data file

end-to-end.xml End-to-End configuration file

All files in Table 3: Monitor Files, are in compressed ".Z" format to improve distribution 
performance.
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Command Files 

Command files are located in the following directories:

Management Server:

/var/opt/OV/share/databases/OpC/mgd_node/customer/ms/

x86/winnt/cmds (for HTTPS)

Managed Node:

<OvDataDir>\bin\instrumentation  (for HTTPS)

All files in this table are in compressed ".Z" format to improve distribution performance.

Table 7 Command Files

File Description

exspitra.vbs Turns EXSPI Tracing on/off
-v ON
-v OFF

exspimwd.vbs Turns data forwarding to HP Performance Agent on/off 
(collector/analyzer will only forward data to HP 
Performance Agent if set to on:
-v ON
-v OFF

exspienc.exe For configuring managed node; part of the advanced 
configuration.

exspi_e2k_cfg.vbs For configuring an Exchange 2003 server mailbox.

exspi_perfmon.exe For perfmon counter data logging and threshold 
alarming.

EXSPI_DataObjects.xml

EXSPI Coda data source 
and objects.doc
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EXSPI_asnotify.spec/ 
EXSPI_async.spec
EXSPI_deliv.spec/ 
EXSPI_dsaccess.spec
EXSPI_ftdata.spec/ 
EXSPI_imap4perf.spec
EXSPI_isclient.spec/ 
EXSPI_isperf.spec
EXSPI_m0660.spec/ 
EXSPI_m0661.spec
EXSPI_m0662.spec/ 
EXSPI_m0663.spec
EXSPI_m1002.spec/ 
EXSPI_mbdetail.spec
EXSPI_mbperf.spec/ 
EXSPI_mbsummary.spec
EXSPI_mtadata.spec/
EXSPI_multi.spec
EXSPI_oma.spec
EXSPI_owabe.spec
EXSPI_owafe.spec
EXSPI_pfdetail.spec
EXSPI_pfperf.spec
EXSPI_pfsummary.spec
EXSPI_pop3perf.spec
EXSPI_ports.spec
EXSPI_single.spec
EXSPI_smtpdata.spec
EXSPI_smtpq.spec
EXSPI_srs.spec
EXSPI_translog.spec

Data log specification

exspi_e2k_clust_config.js  Generates xml output, which can be used for editing the 
apminfo.xml file

exspi_dbmount.vbs 
(NOTE: This file is also present 
under monitor and actions 
directories) -

Checks and mounts dismounted information store(s)

File Description
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Windows Managed Node Files

Monitor templates

When templates are distributed from the management server to the Windows managed nodes, 
the monitor templates are encrypted and stored in the following directory:

%OVAgentDir%\conf\OpC\<hostname>\
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Logging and Trace Files

Logging and trace files are located in the following directory on the managed node:

%OVAgentDir%\exspi\log

Table 8 Logging and Trace Files

File Description

trace When TRACE ON is set in 
%OVAgentDir%\exspi\defaults, tracing and debug 
information is written to  %OVAgentDir%\exspi\log. This 
file can get very large.

exspierror Error information when the Exchange SPI collector/analyzer 
encounters an error condition. Messages written to this file are 
also sent to the OVO message browser.
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C spimetadata.xml File
The spimetadata.xml file contains the information related to the collection mechanism of 
the Exchange SPI for Microsoft Exchange Server 2007 nodes. The example below shows a 
sample spimetadata.xml file with all basic elements. It is not recommended to modify the 
spimetadata.xml file manually as incorrect modification can lead to incorrect operation of 
the Exchange SPI.

Sample spimetadata.xml File

<?xml version="1.0" encoding="utf-8"?>

<CollectionDefinitions>

  <MetricSets>

    <MetricSet>

      <Name>MetrciSet1</Name>

      <Parameters>

      </Parameters>

      <SourceDefinition>

        <Type>

        </Type>

        <Command>Get-ReplicationAge</Command>

        <DataSource>

        </DataSource>

        <DataObject>

        </DataObject>

      </SourceDefinition>

      <Metric>

        <Name>CopyQueueLength</Name>

        <Datatype>System.Int64</Datatype>

        <Description>

        </Description>

        <Type>

        </Type>

      </Metric>
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      <Metric>

        <Name>StorageGroupName</Name>

        <Datatype>System.String</Datatype>

        <Description>

        </Description>

        <Type>

        </Type>

      </Metric>

    </MetricSet>

  </MetricSets>

  <Collections>

    <Collection>

      <Name>1</Name>

      <DisplayName>New Collection</DisplayName>

      <Description>New Collection</Description>

      <Interval>00:05:00</Interval>

      <CollectionSet>

        <MetricSetNameRef>MetrciSet1</MetricSetNameRef>

      </CollectionSet>

      <Calculations />

      <Filters />

      <PublishMetrics>

        <PublishSetNameRef>Replication_Publish</PublishSetNameRef>

      </PublishMetrics>

      <AlertSets>

        <ThresholdSetNameRef>OpcMonCallForReplication</ThresholdSetNameRef>

        <AlarmSetNameRef>OpcMsgForReplicationAge</AlarmSetNameRef>

      </AlertSets>

    </Collection>

  </Collections>

<PublishedSets>

  <PublishedSet>

    <Name>Replication_Publish</Name>

    <Database>DATASOURCENAME</Database>

    <ClassName>TABLENAME</ClassName>

    <IndexBy>DAY</IndexBy>

    <RollBy>MONTH</RollBy>
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    <Capacity>720</Capacity>

    <Metrics>

      <Metric>

        <MetricRef>

          <SetNameRef>SGNAME</SetNameRef>

          <MetricNameRef>StorageGroupName</MetricNameRef>

        </MetricRef>

      </Metric>

      <Metric>

        <MetricRef>

          <SetNameRef>CPQLEN</SetNameRef>

          <MetricNameRef>CopyQueueLength</MetricNameRef>

        </MetricRef>

      </Metric>

    </Metrics>

  </PublishedSet>

 </PublishedSets>

  <AlertSets>

    <AlarmSets>

      <AlarmSet>

        <Name>OpcMsgForReplicationAge</Name>

        <Rules>

          <Rule>

            <MetricSetName>MetrciSet1</MetricSetName>

            <MetricName>CopyQueueLength</MetricName>

            <ArithmeticOperator>GreaterThan</ArithmeticOperator>

            <ValueToCompare>0</ValueToCompare>

            <LogicalOperator>LastRule</LogicalOperator>

          </Rule>

        </Rules>

        <MessageDetails>

         <Application>MyApp</Application>

          <Object>MyObj</Object>

          <Text>Sending Messge with warning as severity and  value of 
%CopyQueueLength%</Text>

          <Severity>Warning</Severity>

          <ServiceID>
149



          </ServiceID>

          <MessageKey>

          </MessageKey>

        </MessageDetails>

      </AlarmSet>

    </AlarmSets>

    <ThresholdSets>

      <ThresholdSet>

        <Name>OpcMonCallForReplication</Name>

        <MetricSetName>MetrciSet1</MetricSetName>

        <MetricName>CopyQueueLength</MetricName>

        <ThresholdPolicy>Any Threshold Policy Name</ThresholdPolicy>

        <AutoBaseline IsEnable="False" />

      </ThresholdSet>

    </ThresholdSets>

  </AlertSets>

</CollectionDefinitions>

Elements of the spimetadata.xml File

The spimetadata.xml file consists of the following major elements:

MetricSets — The MetricSets element contains the following information:

• Metrics to be collected from the nodes

• Cmdlet to be used to collect the metrics

• Type of the metric data

PublishedSet —  The PublishedSet element describes the mechanism to store the metric 
data to a data store.

AlertSets — The AlertSets element contains the information on calculating the metric data 
with a threshold value and the mechanism to generate an alarm in the event of threshold 
violation.

Collections — The Collections element contains the Collection sub-element. The Collection 
sub-element holds all information on individual collection configurations. Each Collection 
element contains the following information:

• Name of the collection

• MetricSets to be used

• Mechanism to store metric data on a data store

• Mechanism to generate alarm in the event of threshold violation
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click on the bookmark “Comments”.

In case you do not have the email client configured, copy the information below to a web mail 
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