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Introducing Work Management
The Work Management guide was designed to give the ServiceCenter 
administrator, manager or user an introduction to and overview of Work 
Management, and to get them started in its use.

The Work Management guide has been divided into the following chapters:

� Installing Work Management on page 13 explains the installation process.

� Getting Started on page 19 provides an introduction to the ServiceCenter 
Work Management application and provides information on how to use 
Work Management and the component Help system.

� Defining Contacts on page 51 provides an introduction to the process of 
establishing contacts and tying them in with other elements in the 
ServiceCenter database.

� Categories on page 65 provides an introduction to the process of 
establishing Incident, Change, Request, and Task categories, including 
tying them in with other elements in the ServiceCenter database.

� Operators and Managers on page 95 provides an introduction to the 
process of establishing system operators, including managers and group 
managers. 

� Interpreting ServiceCenter Record Item Details on page 119 provides an 
introduction to the features of the Incident ticket, Change request, and 
Request Management quote, and their various views.
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� Scheduling on page 143 explains Work Management scheduling, including 
how to schedule, reschedule, lock, and unallocate Incident tickets, Change 
requests, Request quotes, and their associated tasks as well as explaining 
autoschedule functionality. 

� Creating Custom Configurations on page 173 discusses the various 
customization options and procedures for tailoring your Work 
Management environment to fit your specific business needs.

� Function Reference on page 197 provides a quick overview of various key 
functions or processes used during the standard implementation of Work 
Management and ServiceCenter. 

� Microsoft Outlook Integration on page 211 explains how to load 
appointments for all operators belonging to a manager from the Microsoft 
Outlook calendar into the Work Management Schedule window. 

Examples 

The sample windows and the examples included in this guide are for 
illustration only, and may differ from those at your site. 

Contacting Customer Support

For more information and help with this new release or with ServiceCenter 
in general, contact Peregrine Systems’ Customer Support.

Peregrine’s CenterPoint Web Site
You can also find information about version compatibility, hardware and 
software requirements, and other configuration issues at Peregrine’s 
CenterPoint web site: http://support.peregrine.com

1 Log in with your login ID and password. 

2 Select Go for CenterPoint.

3 Select ServiceCenter from My Products at the top of the page for 
configuration and compatibility information.

Note: For information about local support offices, select Whom Do I Call? 
from Contents on the left side of the page to display the Peregrine 
Worldwide Contact Information.
10 � Introducing Work Management 
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Corporate Headquarters

North America and South America

Europe, Asia/Pacific, Africa
For information about local offices, see Peregrine’s CenterPoint Web Site. You 
can also contact Corporate Headquarters.

Contacting Education Services

Training services are available for the full spectrum of Peregrine Products 
including ServiceCenter. 

Current details of our training services are available through the following 
main contacts or at: 

Address: Peregrine Systems, Inc.
Attn: Customer Support
3611 Valley Centre Drive
San Diego, CA 92130

Telephone: +(1) (858) 794-7428

Fax: +(1) (858) 480-3928

Telephone: (1) (800) 960-9998 (US and Canada only, toll free)

+(1) (858) 794-7428 (Mexico, Central America, and 
 South America)

Fax: +(1) (858) 480-3928

E-mail: support@peregrine.com
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http://www.peregrine.com/education 

Address: Peregrine Systems, Inc.
Attn: Education Services
3611 Valley Centre Drive
San Diego, CA 92130

Telephone: +1 (858) 794-5009

Fax: +1 (858) 480-3928
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CHAPTER

1
 Installing Work Management
This chapter describes the Work Management installation and configuration 
process for a ServiceCenter administrator or implementer. 

Read this chapter for information about:

� Installation Procedure on page 14

� Configuration on page 14

� Troubleshooting on page 16
Installing Work Management � 13
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Installation Procedure

The ServiceCenter installation may include some updated shared files from 
Microsoft. The screens will inform you as these files are copied. You may be 
prompted to restart Windows at the end of the installation. 

To install Work Management:

� Follow the instructions in the Client/Server Installation Guide for Windows, 
for installing ServiceCenter, using the instructions for a custom installation. 

1 When the Select Components dialog box appears, select Work Management.

2 Do not clear any other checked components or you will uninstall them.

3 Continue following the directions in the Client/Server Installation Guide for 
Windows until the Custom installation is complete.

Configuration

If there has been a previous installation of Work Management on this 
computer, it may be necessary to configure the ODBC driver so that it points 
to the correct ServiceCenter P4 database. 

On Windows NT or 2000 systems, the default path is: Start\Settings\Control 
Panel\Data Sources(ODBC). Select WorkMgmt32 and click Configure. 
Point the driver to the same P4 database as the SC express client, by filling in 
the Server.Port field. 

To change the server port:

1 Open the ODBC Data Source Administrator. 

a Click the Windows Start button.

b Select Settings > Control Panel.

c Double-click Data Sources (ODBC). 
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2 Double click WorkMgmt32. The Wishbone-P4 ODBC Data Source Setup 
dialog box will appear.

Figure 1-1: Setting the ODBC Data Source

3 Enter the correct server port in the Server.Port text box. 

a Right-click the ServiceCenter Client Icon on the desktop. This should be a 
client that points to the server you wish to use, (most likely the one you 
just installed.)

b Select Properties from the menu that appears. 

c Select the Shortcut tab.
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Figure 1-2: Copying the Server and Port

d Copy the server and port from the Target text box, and paste it into the 
Server.Port text box.

4 Reboot the computer.

Troubleshooting

If you are having problems getting Work Management to work properly, you 
can use the trace function to try to detect the error.

To get a trace file:

1 Open WorkMgmt32.ini in the Windows or the Winnt directory. 

2 On the third line, change Trace= 0 to Trace = 1. Save and exit.

3 Now run Work Management till the error occurs. The file wmtrace.out is 
created at the path specified in the Path= WorkMgmt32.ini parameter. By 
default, this is C:\)

4 Open WorkMgmt32.ini in the Windows or the Winnt directory. 

5 On the third line, change Trace= 1 to Trace = 0. Save and exit.

6 Open wmtrace.out in Notepad. Examine the end of it for a a clue as to where 
the problem has occurred. 
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7 Search for "error" in the file. 

Note: Send the trace file wmtrace.out to customer support.
Troubleshooting � 17



ServiceCenter
18 �Chapter 1—Installing Work Management 



CHAPTER

2
 Getting Started
This chapter is an overview of Work Management to the ServiceCenter 
administrator, manager or user. It provides an introduction to the Work 
Management application, and information about using Work Management 
and the component Help system.

Read this chapter for information about:

� Introduction on page 20

� Work Management and the Help Desk on page 21

� Accessing Work Management on page 22

� Logging In to Work Management on page 24

� Exiting Work Management on page 29

� The Work Management Desktop on page 29

� The Schedule Window on page 30

� Work Management Menu Structure on page 41

� Work Management Time Scale Configuration on page 47
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Introduction

Work Management manages a Help Desk system through comprehensive 
scheduling, tracking, and reporting functions. It is designed for 
organizations seeking to improve organizational productivity by decreasing 
downtime, improving operator utilization, and enhancing Help Desk 
efficiency.

A central issue for Help Desks becomes scheduling — assigning Incidents 
tickets, Change requests, Request quotes, and their associated tasks to the 
right Operator to be performed in the right sequence. Sequencing the 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
ultimately determines how long contacts are kept waiting, as well as the 
overall organizational downtime.

One example is a Help Desk department with eight support analysts, who are 
resolving computer hardware and software incidents for 1000 users. At any 
given time, there are hundreds of Incidents tickets, Change requests, Request 
quotes, and their associated tasks reported by users waiting in the queue to 
be resolved. 

The automatic scheduler in Work Management schedules Incidents tickets, 
Change requests, Request quotes, and their associated tasks in the most 
efficient sequence possible so that organizational downtime is minimized. 
Work Management makes assignments to the support Operators according 
to their expertise and availability.

Once the Operator is allocated an Incident, Change, Request, or Task, you 
can periodically report the status of the item, so at any given time the current 
status of the Incident, Change, Request, or Task is maintained. Access to the 
history of how different types of Incidents tickets, Change requests, Request 
quotes, and their associated tasks were resolved in the past and the history of 
the contact is also provided to help the Operators address incidents.

Work Management is built on a relational database using ODBC. Reporting 
capabilities are built into the system with a set of pre-defined reports that 
measure Help Desk performance, volume, tracking, and so on. You can 
create any number of Custom reports using Crystal Reports and attach them 
to Work Management. In addition, importing data into the system or 
exporting out to an external system is completely open.
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Work Management and the Help Desk

The initial function of a Help Desk is to record a request for technical 
assistance (Incident, Change, Request, or Task). Help Desk personnel may 
enter this information during a call or they may enter it later from a message 
left by the contact.

Most organizations strive to resolve the Incident quickly and remotely, using 
front-line support, possibly with guidance from the many incident 
resolution knowledge bases available in the marketplace. Work Management 
users can for instance, utilize the ServiceCenter Knowledge Base resources. 

If the incident requires follow-up or a visit to the contact, Work Management 
refers to this as an Incident. An Incident needs to be scheduled in order to 
close the call. The Incident should be properly identified and classified so the 
appropriate technical staff can respond.

The Help Desk environment is constantly changing as new Incident tickets 
come in and older Incident tickets remain scheduled and are yet to be 
completed. Since all Incident tickets are not equal in terms of urgency and 
priority, the current state of the Help Desk must be constantly managed 
based on a variety of criteria.

As the Help Desk and technical support team resolve contact Incidents, 
metrics on such issues as call volume and response time are being maintained 
and made accessible for analysis and decision support.

Work Management provides two modules for supporting the functions 
specified above:

� Work Management shows the current state of the Help Desk in both 
graphical and table-based presentations. The Help Desk manager can 
coordinate outstanding Incidents by assigning them to technicians. This 
function is accomplished manually using a drag and drop interface, or it 
is done automatically by the system.

� The automatic scheduling of Incident tickets, and some of the manually 
assigned Incident tickets, abide by certain rules established by the 
manager. Issues such as priority, required expertise, responsiveness, 
existing scheduled Incident tickets, and workload distribution goals can 
all be modeled to provide optimum results when scheduling. The 
Operators to whom the Incident tickets are assigned are immediately 
notified, and they can view any changes made to their existing schedule.
Work Management and the Help Desk � 21



ServiceCenter
Accessing Work Management

To start Work Management the ODBC driver needs to be pointed at the 
appropriate ServiceCenter P4 database. You may need to configure the 
ODBC driver so that it points to the correct ServiceCenter P4 database. For 
more information, see Configuration on page 14.

Important: The ServiceCenter Server must be running before Work 
Management is started. The ServiceCenter Client must be 
started before ServiceCenter data, such as Incident tickets can be 
accessed.

There are three ways to start Work Management: 

� Opening Work Management from the Windows Start Menu on page 22.

� Opening Work Management from a Desktop Shortcut on page 22.

� Opening Work Management from within ServiceCenter on page 23.

Opening Work Management from the Windows Start Menu
To open Work Management from the Windows Start menu:

� From the Windows Start menu, select Programs > Peregrine ServiceCenter 
> Work Management.

Opening Work Management from a Desktop Shortcut
In order to open Work Management from the desktop, you will first need to 
create a desktop shortcut.

To create a shortcut: 

1 Right-click your mouse on the desktop.

2 Select New from the menu which appears.

3 Select Shortcut from the side menu.

4 At the Create Shortcut dialog provide the path to the Work Management 
executable file on your computer, or use the Browse button to navigate to the 
location. The default path is: 

C:\Program Files\ServiceCenter\WorkMan\System\WDManager32.exe

5 Select WDManager32.exe and click Open.
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6 Click Next to continue.

7 Create a name for the shortcut, such as Work Management.

8 Click Finish to create the shortcut and place it onto the desktop.

To open Work Management from the Windows desktop :

� Double-click the Work Management shortcut.

Opening Work Management from within ServiceCenter
A Work Management button is located on the ServiceCenter administrator 
main menu.

To open Work Management from within Service Center:

1 Click the Work Management button on the Main Menu. 

Figure 2-1: System Administrator Main Menu
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Logging In to Work Management

There are several ways to log in to Work Management:

� Logging in as an Operator on page 24

� Logging in as a Shared Operator on page 25

� Logging in as a Manager on page 26

� Logging in as a Group Manager on page 27

� Logging in to Microsoft Outlook on page 28

Logging in as an Operator
To log in as an operator:

1 From the Windows Start menu, select Programs > Peregrine ServiceCenter 
> Work Management. Figure 2-2 shows the Login window.

Figure 2-2: Work Management Login Window

2 Enter your login name and password, both should be the same as those used 
for ServiceCenter. 

3 Click OK.
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Work Management opens and the Incidents tickets, Change requests, 
Request quotes, and their associated tasks that have been scheduled to you 
appear in the Schedule window.

Figure 2-3: Work Management Schedule Window

Logging in as a Shared Operator
Shared operators have more than one manager assigning tasks to them. 

To log in as a shared operator:

1 From the Windows Start menu, select Programs > Peregrine ServiceCenter 
> Work Management. Figure 2-2 on page 24 shows the Login window.

2 Enter your login name and password, both should be the same as those used 
for ServiceCenter. 

3 Click OK.
Logging In to Work Management � 25



ServiceCenter
Work Management opens and the Manager List dialog opens. The list of 
schedules you are able to view is based on the list of managers to which you 
are assigned and with whom you are shared.

Figure 2-4: Work Management Manager List Dialog for Shared Operators

4 Highlight the manager’s schedule upon which you wish to work and click 
OK. 

When logging in as an operator, the schedule for only that operator is 
displayed.

5 You can also double-click a manager's name in the Manager List, to open the 
schedule assigned to you.

Logging in as a Manager
Managers schedule tasks for operators and shared operators. Managers are 
not able to view or edit the schedules of other managers.

To log in as a Manager:

1 From the Windows Start menu, select Programs > Peregrine ServiceCenter 
> Work Management. Figure 2-2 on page 24 shows the Login window.

2 Enter your login name and password, both should be the same as those used 
for ServiceCenter. 

3 Click OK. Work Management opens, and the schedule defined for your set 
of assigned operators, Incidents tickets, Change requests, Request quotes, 
and their associated tasks is displayed. 
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Note: The login names for all users must be defined in the ServiceCenter 
operator file before-hand. You do not have the ability to change the 
password associated with your login name from Work Management.

Figure 2-5: Schedule Window with Incidents, Changes, Requests, and Tasks

Logging in as a Group Manager 
Group managers view and edit the schedule of at least one manager. 

To login as a group manager:

1 From the Windows Start menu, select Programs > Peregrine ServiceCenter 
> Work Management. Figure 2-2 on page 24 shows the Login window.

2 Enter your login name and password, both should be the same as those used 
for ServiceCenter. 

3 Click OK. 
Logging In to Work Management � 27



ServiceCenter
Work Management opens and The Manager List dialog opens. The list of 
schedules you are able to view is based on the list of managers assigned to 
you. For more information, see Defining Managers on page 100.

4 To open a schedule in Work Management, select the manager whose 
schedule you wish to view. 

5 Do one of the following:

� Click OK on the Manager List dialog to open Work Management. 

� Double-click a manager's name in the Manager List dialog to open that 
manager's schedule.

Figure 2-6: Work Management Manager List for Group Managers

6 If you wish to shift the view from one manager’s schedule to another, you 
must exit and login again. Then select a different manager from the Manager 
List dialog box.

Logging in to Microsoft Outlook
If your Work Management user name and MS Outlook profile name are the 
same, you are automatically logged in to MS Outlook when you login to 
Work Management. This allows all scheduled obligations from your MS 
Outlook calendar to be displayed in Work Management, and prevents the 
scheduling of any Incidents, Changes, Requests, or Tasks during times when 
you have defined previous obligations. For more information, see Microsoft 
Outlook Integration on page 211. 

If your Work Management user name and MS Outlook profile name are 
different, Work Management may display this message at login: The profile 
name is not valid. Enter a valid profile name.
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To select a profile name:

1 Click OK.

The system displays the MS Outlook Choose Profile dialog with User 
profiles.

2 Select your profile name from the list.

3 Click OK. 

4 Click Cancel if you do not want MS Outlook appointments and events to 
display in your Schedule window.

Exiting Work Management

To log out of Work Management:

1 Pull down the Schedule menu.

2 Do one of the following:

� Select the Exit option. 

� Exit a session by pressing Alt-F4.

� Double-click the ServiceCenter icon in the top left corner of the Work 
Management Home screen, and select the Close option from the menu 
which appears.

If you have made any changes to the schedule and have not saved them, you 
will be prompted to save the changes prior to exiting Work Management.

The Work Management Desktop

Work Management manages a changing body of outstanding Incidents, 
Changes, and their Tasks and other issues using five key metrics. Each of 
these metrics is displayed in a gauge on the main menu screen.

Work Management makes assignments of Incidents tickets, Change requests, 
Request quotes, and their associated tasks to operators in a way that balances 
and blends one or more of these metrics to achieve organizational goals.

By default, the system minimizes the total downtime to contacts and 
optimizes the operator utilization, while keeping track of the other metrics. 
The manager can then assess the impact of alternative assignments on the 
four metrics. These rules of responsiveness can be captured and finely tuned 
to achieve the highest efficiency and result.
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The Schedule Window

The main window displayed by Work Management is called the Schedule 
window.

The main function of the Schedule window is to enable you to:

� View the current status of your Help Desk.

� Schedule your Incidents tickets, Change requests, Request quotes, and 
their associated tasks.

� Analyze the performance of your Help Desk.

Work Management shows the status of the Help Desk in terms of these 
specific performance metric: Total Downtime/Response Time, 
Threshold/Satisfaction, Operator Utilization, Workload, and Unallocated 
Incidents. The gauges displaying these metrics are updated in real-time and 
change as modifications are made to the schedule.

Total Downtime and Threshold/Satisfaction are customer-oriented. They 
indicate customer satisfaction. 

Operator Utilization, Workload, and Unallocated Incidents are organization 
oriented. They indicate the workload level and efficiency of operator 
utilization.

At the top of the Schedule window, below the menu bar, are five performance 
gauges. These gauges track the total downtime or response time of the 
current schedule (as specified using the Customize... option from the 
Options menu), the customer satisfaction, the workload, the operator 
utilization rate, and the number of unscheduled Incidents tickets, Change 
requests, Request quotes, and their associated tasks waiting in the system. For 
more information, see The Performance Gauges on page 32.

Below the performance gauges is the Schedule pane. This lists the operator 
names assigned to the logged-in manager. It also displays the scheduled 
Incident tickets across the given time scale. The time scale is divided into 
hourly (or user defined) segments. Only those Incident tickets associated 
with the manager's assignment group(s) will be displayed. 

� Use the scroll bars to slide back and forth along the time scale to view all 
assigned Incident tickets for the given period. 
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The Count column to the right of the time scale shows the outstanding 
(incomplete) Incidents tickets, Change requests, Request quotes, and their 
associated tasks for each Operator. The Utilization column shows the 
operator utilization rates for the selected time scale. 

� Click the right mouse button and select the column(s) to be displayed in 
the Schedule window. 

Note: You must select at least one column.

For more information, see The Schedule Pane on page 36.

At the bottom of the Schedule window is the Spreadsheet pane. This is a 
read-only spreadsheet, divided into columns that contain the details of each 
Incident, Change, Request, and Task in the system. For more information, 
see The Task Spreadsheet Pane on page 39.

Figure 2-7: Schedule Window

Performance Metric Gauges  Schedule Pane Spreadsheet Pane
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The Performance Gauges

Total Downtime/Response time
The first gauge displays either the downtime or 
response time of the schedule, according to what 
you select in the Customize dialog box, reached 
through the Customize... option in the Options 
menu. For more information, see Gauge Panel on 
page 182. The display format is days:hours. 

Response Time is never displayed when Total Downtime is, and vise versa. 
The label of this gauge changes to reflect the selected measurement.

Total Downtime is a measure of the amount of time contacts wait until their 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
are resolved. This measure can be monitored to choose the assignment group 
for the best responsiveness. Total downtime is calculated by summing the 
downtime for all of the Incidents tickets, Change requests, Request quotes, 
and their associated tasks in the schedule. 

Response Time is the average time of all unallocated Incident tickets in the 
schedule and mailbox. Response time is an average calculated by dividing the 
total response time for all Incidents tickets, Change requests, Request quotes, 
and their associated tasks by the number of Incidents tickets, Change 
requests, Request quotes, and their associated tasks in the schedule. 

For calculation purposes, Incidents tickets, Change requests, Request quotes, 
and their associated tasks in the mailbox are assumed to be scheduled at the 
current time.

Threshold/Satisfaction
The second gauge shows either the Threshold or 
Satisfaction. Incidents tickets, Change requests, Request 
quotes, and their associated tasks that have a downtime 
greater than the Threshold downtime value as a 
percentage of the total number of items in the Schedule 
window. The Threshold downtime value can be set from 

the Customize dialog box, reached through the Customize... option in the 
Options menu. For more information, see Gauge Panel on page 182. 
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Threshold shows (in percentage terms) the ratio of Incidents tickets, Change 
requests, Request quotes, and their associated tasks which have a downtime 
value greater than the Overall downtime threshold value, versus the total 
number of items in the schedule and the mailbox. The Overall downtime 
threshold can be defined using the Customize option from the Options 
menu.

Satisfaction is the average customer satisfaction associated with the current 
schedule in the scale 1 to 10. This value is calculated from all the Incidents 
tickets, Change requests, Request quotes, and their associated tasks in the 
Schedule window and the mailbox, using the Satisfaction values defined in 
the Category dialog box. If no satisfaction values are entered into the system, 
Work Management retains a value of 10, the highest satisfaction rating, for 
all Incident categories. Any category without a satisfaction definition 
automatically defaults to 10 as well.

Workload
The third gauge indicates the workload of the incomplete 
Incidents tickets, Change requests, Request quotes, and 
their associated tasks. It is calculated as the sum of the 
durations of all the incomplete Incidents tickets, Change 
requests, Request quotes, and their associated tasks that 
have been scheduled and all Incidents tickets, Change 

requests, Request quotes, and their associated tasks from the mailbox. The 
duration of the Incidents tickets, Change requests, Request quotes, and their 
associated tasks in the mailbox is assumed to be the default duration for that 
category as given in the Category dialog.

Workload is an internal measure that gives the total workload of the 
Incidents tickets, Change requests, Request quotes, and their associated 
tasks. It is calculated as the sum of the durations of all the incomplete 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
that have been scheduled and all Incidents tickets, Change requests, Request 
quotes, and their associated tasks from the mailbox. The duration of the 
items in the mailbox is assumed to be the default duration for that category 
as given in the Category dialog box.
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Operator Utilization
The fourth gauge indicates the operator utilization for the 
selected time scale. This utilization percentage pertains to 
those operators listed at the left of the Schedule window. 
The utilization is calculated by comparing the amount of 
time each operator is scheduled to spend resolving 
Incidents, Changes, Requests, or Tasks over a given time 

period. For example, if an operator spends 7 out of 8 hours resolving assigned 
items, the utilization rate for that period will be 88%. If the time scale were 
two days, and if no additional Incidents, Changes, Requests, or Tasks were 
scheduled for the following day, then the utilization rate would drop to 44%.

Factors that affect operator utilization are the number of Incidents tickets, 
Change requests, Request quotes, and their associated tasks in the schedule 
and the length of the time scale or the availability of the operator. Provides 
an internal measure. It is more important to the Help Desk than the contact, 
displaying the degree to which a Help Desk effectively utilizes its technical or 
related support staff (operators). This metric allows managers to schedule 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
with target operator utilization in mind. Skill levels can be specified if desired 
to allow for even more sophisticated deployment.

Unallocated Count/Mailbox
The fifth gauge shows the number of unallocated Incidents 
tickets, Change requests, Request quotes, and their 
associated tasks waiting to be scheduled against the total 
number of incomplete Incidents tickets, Change requests, 
Request quotes, and their associated tasks in the schedule. 
Incidents tickets, Change requests, Request quotes, and 

their associated tasks that have been entered into the system, but remain 
unscheduled, are considered unallocated. This includes items that were 
removed from the schedule by selecting Unallocate from the Operations 
menu. (Also referred to as the Mailbox) lists all Incidents tickets, Change 
requests, Request quotes, and their associated tasks (quotes) in the queue 
currently open. The number of unallocated (unassigned) Incidents tickets, 
Change requests, Request quotes, and their associated tasks is stated versus 
the number of total items.
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Mailbox Dialog Box

To display current unallocated Incidents tickets, Change requests, Request 
quotes, and their associated tasks:

1 Click the Unallocated count (mailbox) gauge.

The mailbox dialog box displays a list of unscheduled Incidents tickets, 
Change requests, Request quotes, and their associated tasks (those not 
assigned to an operator). 

The mailbox lists the number, contact, and category for each item.

Figure 2-8: Mailbox List

2 Unallocated items are sorted by descending order of age by default. 

To change the sort order:

a Click the right-mouse button on the Mailbox dialog box.

b Select either Sort by Age or Sort by Priority. 

c Select either Ascending or Descending order.

3 Double-click any item listed in the mailbox. 
The Schedule Window � 35



ServiceCenter
The standard ServiceCenter Details screen is displayed in a separate window.

Figure 2-9: ServiceCenter Incident Record

The Incident, Change, Request, or Task Details screen provides more 
information on the nature of the item, the contact who reported it, and any 
resolutions used in the past to handle similar Incidents, Changes, Requests, 
or Tasks.

4 To close the window, click Back. For more information, see Additional 
Record Details on page 128.

The Schedule Pane

Operator List Column
The operator list column displays the operators assigned to the manager 
currently logged in. The operators are listed and sorted alphabetically by 
name, either first or last, according to how they were entered into the system. 
36 �Chapter 2—Getting Started 



Work Management
Schedule Column
The Schedule Column displays the assigned Incidents tickets, Change 
requests, Request quotes, and their associated tasks for each operator. 
Figure 2-10 shows how the items are presented as bars, color coded to denote 
priority level and status (incomplete or complete). The color values and 
captions are modified through the Customize dialog box, reached through 
the Customize... option in the Options menu. For more information, see 
Colors on page 178.

The Incidents tickets, Change requests, Request quotes, and their associated 
tasks bars are positioned to correspond to the date and time they are 
scheduled. The length of the bar across the Time scale represents the 
estimated duration of the item, or how long it should take that operator to 
resolve the Incident, Change, Request, or Task (based on the operator’s 
experience and the difficulty or experience requirements of the particular 
item). Each item carries a unique ServiceCenter ticket number, for example, 
PM123, displayed on the color-coded ticket bars. The vertical grey bar 
represents the start and end of a break period.

Figure 2-10: Scheduled Tasks and Break Period

Timescale Timeline
The time scale is an adjustable time line that appears at the top of the 
Schedule pane. It displays the period of time in which Incidents tickets, 
Change requests, Request quotes, and their associated tasks are scheduled for 
help desk operators. 
The Schedule Window � 37



ServiceCenter
The time scale is adjusted by double-clicking on the time line or from the 
Customize dialog box, reached through the Time scale option in the Options 
menu. For more information, see Work Management Time Scale 
Configuration on page 47.

Count Column
The Count column shows the outstanding Incidents tickets, 
Change requests, Request quotes, and their associated tasks for 
each Operator. Outstanding Incidents tickets, Change requests, 
Request quotes, and their associated tasks are those items that 
are incomplete.

Utilization Column

The Utilization column displays the utilization of each operator 
as a percentage based on the timescale duration or the available 
time of the operators

Filtering the Schedule Window
Users can select certain attributes of an Incident, Change, Request, or Task 
and apply the filter to see all the item bars that satisfy the condition in the 
Schedule window. The filter can be a combination of different Incident, 
Change, Request, or Task attributes. To specify dates in the Value column, 
double-click to select from the calendar.

Actual Duration
Actual End date 

and time
Actual Start date 

and time

Assignment Group Brief Description Category

Contact Cost Downtime
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The Task Spreadsheet Pane
At the bottom of the Schedule window is the Spreadsheet pane. This is a 
read-only spreadsheet, divided into columns that contain the details of each 
Incident, Change, Request, and Task in the system.

Figure 2-11: The Task Spreadsheet

To adjust the column width:

1 Move the cursor to the right edge of any of the column headers. 

The cursor changes to a vertical bar with arrows facing both left and right. 

2 Press and hold the left mouse button.

3 Drag the column border either left or right. 

4 Release the mouse button when the border is positioned as desired. 

Date & time Incident was 
reported

Expertise Required Estimated Duration

Lock Number Operator

Priority Scheduled start date and 
time

Scheduled End date and 
time

Status Total pages User-defined fields

Ticket type Phase Parent

Actual Duration
Actual End date 

and time
Actual Start date 

and time
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5 To hide a column, drag its right border left until it meets the right border of 
the next column.

Verifying Data Elements in the Spreadsheet Pane

The following data elements of Work Management can be viewed by 
scrolling side-to-side using the scroll bar at the bottom of the Incident 
Spreadsheet pane:

Incident, Change, Request, and Task viewing from the 
Spreadsheet Pane
When you highlight any ticket bar in the Schedule pane of the Schedule 
window, the associated row in the Spreadsheet pane is also highlighted. For 
more information, see The Schedule Window on page 30. Work Management 
automatically scrolls the spreadsheet so that the corresponding row is visible 
at the top of the spreadsheet pane.

When you click a row in the Spreadsheet pane, the action highlights the 
corresponding ticket bar in the Schedule pane.

When you double-click any of the cells in a particular row, or on the ticket 
bar in the Schedule window, this action opens the ServiceCenter Incident, 
Change, Request, or Task dialog. The selected item is displayed. For more 
information, see Schedule Window on page 127.

� Number (Incident ID) � Priority � Scheduled Priority

� Contact � Total pages � Brief description

� Reported on � Operator � Category

� Assignment � Locks � Severity

� Expertise � Scheduled 
(start date & time)

� Scheduled End 
(date and time)

� Actual start 
(date and time)

� Actual end 
(date and time)

� Duration

� Actual duration � Downtime � Cost

� User-defined field � Completed � Color

� Task Type � Percent Utilization � Phase 

� Parent
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Work Management Menu Structure

The following menus and menu item selections are available from the 
Schedule window. 

� The Schedule Menu on page 41

� The View Menu on page 42

� The Operations Menu on page 44

� The Options Menu on page 45

� The Help Menu on page 46

The Schedule Menu

Figure 2-12: The Schedule Menu

Option Definition

Refresh All Refreshes and updates the Schedule window display to show any 
changes that occurred since the last Refresh or database save.

Refresh Tasks Refreshes and updates the Tasks window display.

Save Saves the current schedule to the database.

Exit Closes Work Management.
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The View Menu

Figure 2-13: The View Menu 

Menu Item Definition

Toolbar Shows and hides the Work Management toolbar/

Schedule Offers several options:

Apply Filter: Applies the existing filter for contact, category to 
incident/change to the items displayed in the Schedule 
window. The filter settings are reached through the Customize 
dialog box, reached from the Filters... option on the Options 
menu. 

Show Related: Shows all those tasks which are related to the 
selected task, and hides all others.

Show Dependency: Modifies display to show relationships 
between Changes, Tasks, and Requests in the Schedule 
window. For more information, see Show Dependency on 
page 151. 

Show Over Commitment: Shows those areas in the schedule 
where resources are over committed. 

Schedule Details... Displays the Incident/Change Details dialog in the current 
window, showing details of which operator has which ticket, 
when the ticket was received, assignments, etc.

Show Pages... Displays the SC record for the selected Incident, Change, 
Request, or Task.

Print Pages... Prints the record for the selected Incident, Change, Request, 
or Task.
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Show Contact... Displays details of the contact reporting the issue in a selected 
Incident ticket.

View Task... Opens the SC record for the selected task.

Define 
Dependency...

Opens a dialog box which allows the creation of 
dependencies.

Contact... Opens the Contact dialog box to allow viewing/editing of the 
contact list and related attributes.

Category... Opens the Category dialog box to allow viewing/editing of 
Incident, Change, Request, and Task categories.

Operator... Opens the Operator dialog box to allow viewing/editing of 
help desk operators and their expertise information.

Location... Opens the Location dialog box to allow viewing/editing of 
operator location and travel time.

Operator
Analyzer...

Opens the Operator Analyzer and displays the task count, 
utilization, remaining availability, or total availability for each 
operator. 

Operator
Commitment... 

Opens the Operator Commitment dialog box to allow 
adding/viewing/editing of commitment for each operator.

All Tasks... Opens the All Tasks Details dialog box, and allows viewing of 
all the contact, operator and other details associated with each 
Incident, Change, Request, or Task in the system.

Reports... Opens the Reports dialog box to allow selection and output of 
reports.

Menu Item Definition
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The Operations Menu

Figure 2-14: The Operations Menu

Menu Item Definition

Lock Provides the option of locking a selected ticket to a specific 
operator and the option to lock an Incident, Change, Request, 
and Task to a specific operator and time.

Highest Priority Modifies the priority/severity of the selected item to the 
highest on the system, including changing the ticket bar color.

Unallocate Unassigns the selected Incident, Change, Request, or Task, 
returning it to the mailbox (Unallocated Incidents gauge).

Compact Moves all tickets in the schedule together, removing spaces 
between tickets and positioning all in current time scale.

Re-arrange Compresses superfluous assignment rows of the Schedule 
pane, created as Incidents tickets, Change requests, Request 
quotes, and their associated tasks are assigned, then moved 
throughout the schedule

Advisor... Provides recommendations on scheduling a task.

Advisor Options... Opens the dialog box and allows viewing/editing of operator 
advisor options based on either location, response time, 
earliest start date, or latest end.

Work Requestor Allocates the requested number of tasks.
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The Options Menu

Figure 2-15: The Options Menu

Work Requestor
Options...

Opens the Work Requestor Options dialog box. Allows 
requestor options based on priority, location, or earliest start 
date. Also allows either allocated or unallocated tasks to be 
requested.

 Autoschedule Allocates all Incidents tickets, Change requests, Request 
quotes, and their associated tasks in queue to appropriate 
operators, based on user-defined criteria and operator 
expertise.

Menu Item Definition

Menu Item Definition

Timescale... Opens the Timescale dialog box to allow changing of the 
timescale.

Customize... Opens the Customize dialog box to allow changing of system 
options.
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The Help Menu

Figure 2-16: The Help Menu

User-Defined 
Fields... 

Opens the User-defined Fields dialog box to allow editing of 
user-defined fields.

Filters Opens the filter option controls. 

Contact: Opens Contact filter setup dialog box, where the user 
specifies which contacts should be known when the Contact 
dialog is opened. For more information, see Filtering the 
Contacts List on page 63.

Incident/Change Details: Opens the Incident/Change Details 
filter setup dialog box, where the user specifies conditions which 
are used to filter Incidents tickets, Change requests, Request 
quotes, and their associated tasks. Only tickets which satisfy 
these conditions are displayed in the All Incident ticket Details 
window. For more information, see Filtering ServiceCenter 
Record Items on page 129.

Schedule Window: Opens the Schedule Filter dialog box, where 
the user specifies conditions which are used to control how 
Incident, Change, Request, and Task data is organized in the 
Schedule pane of the Schedule window. For more 
information, see Filtering the Schedule Window on page 38.

Menu Item Definition

Menu Item Definition

Contents Displays the Help system contents topic.

Search Displays the Help system search page.

Index Displays the Help system Index page.
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Work Management Time Scale Configuration

The Timescale determines the length of time presented in the Schedule 
window. Modifying the Timescale setting will allow you to zoom in or out of 
the schedule to see a day, week or month at a glance.

To open the Timescale dialog box:

1 Pull down the Options menu. For more information, see The Options Menu 
on page 45.

2 Select Timescale….

Knowledge Base 
Support

Starts an external knowledge base help file as specified on the 
Others tab on the Customize dialog box, reached from the 
Customize... option on the Options menu.

About Work 
Management... 

Displays the About dialog with version and licensing 
information for this particular copy of Work Management.

Menu Item Definition
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� You can also access this dialog box by double-clicking the Time scale bar in 
the Schedule window. For more information, see The Work Management 
Desktop on page 29.

Figure 2-17: The Timescale Dialog Box

Field Definition

Start Date Identifies the beginning date of the Timescale period. Setting this to 
Today's date will ensure that the Timescale start date will always 
correspond to the system date. The default value for Start Date is 
Today's date, or the current system date.

Start Time Defines the start time of the Timescale. The default value for Start 
Time is the start of the working hours of the organization, as defined 
in the Calendar.

Duration of 
each column 

Refers to the number of hours shown by each column of the Time 
scale. The default duration setting is Hourly, one hour per cell. 
Changes tasks, and requests often require more than a single day for 
fulfillment, therefore, additional options in the drop down menu 
include Daily, Weekly and Monthly. 
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Timescale Setting Modifications
To change the Start Date setting:

1 Highlight the Date field in the Start panel.

2 Enter the new value. 

For the date, make sure to use the same format as defined in the Windows 
Control Panel (in most cases, the format will be mm/dd/yy). This overwrites 
the default value, Today's date.

The option, Today's date, as well as the last user-selected date, are saved by 
Work Management and available for selection in the Start Date menu. 

To select an entry in the drop-down menu:

a Click the arrow to the right of the box. 

b Select a value. From the keyboard, use the arrow keys to navigate through 
the list.

3 To change the Start Time setting:

a Highlight the Time field in the Start panel.

b Type in the desired time, including AM or PM. If you omit AM or PM, 
Work Management automatically inserts AM. For example, with working 
hours of 9:00 AM to 5:00 PM, Work Management reads both 11:00 and 
3:00 as AM.

4 To change Duration of each column:

a Select the arrow fill button to the right of the field.

b From the drop down menu, click a duration option.

c The duration of each column must be one of the provided option from 
Hourly to Monthly.

Number of 
columns

Determines the total amount of time displayed in the Schedule 
window. Changing this setting lengthens or shortens the scope of 
the Timescale. The default setting is 40 columns.

View each 
column

Determines how many pixels are associated with the time duration 
of each column. Modifying this setting allows you to define how 
much time is actually visible on the screen; you could zoom in or 
out to see hours or days or weeks worth of work on the same 
Schedule window. The default setting is 100 pixels.

Field Definition
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5 To change Number of columns or View each column:

a Click the desired field.

b Enter your selection. 

c For the View of each column% field, use the scroll bars at the right of the 
field to raise/lower the value.

The Number of columns setting must be between 1 and 320. 

The View each column setting is measured in percentage, and it must be 
between 100 and 1, 000. 

The values given in these final three fields are interdependent; you are not 
able to use the maximum values defined in the fields simultaneously.
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3
 Defining Contacts
This chapter is an introduction to Contact Records in Work Management for 
the ServiceCenter administrator, manager, or user. It introduces process of 
establishing contacts and tying them in with other elements in the 
ServiceCenter database.

Read this chapter for information about:

� Introduction on page 52

� Viewing and Editing Contact Records on page 53

� Viewing Contact Details on page 56

� Adding New Contacts on page 57

� Deleting Contacts on page 60

� Editing an Existing Contact Filter List on page 61

� Filtering the Contacts List on page 63
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Introduction

The Work Management system diagram below shows the basic functions 
performed by the Help Desk and the order in which they occur. During this 
sequence, the status of Incidents tickets, Change requests, Request quotes, 
and their associated tasks are periodically updated and recorded in the Work 
Management database.

Figure 3-1: Work Management Structure

Record Data

Contacts Users who issue requests for Help Desk assistance.

Incidents Specific incidents reported by contacts.

Change Requests put forth by a contact or a member of the organization.

Tasks The various tasks involved in completing a change. 

Categories Types of Incidents tickets, Change requests, Request quotes, and 
their associated tasks identified by an organization.

Operators People assigned by the Help Desk to resolve the Incidents tickets, 
Change requests, Request quotes, and their associated tasks for 
the contacts.

Schedule Incidents,
Changes, Requests and
Their Associated Tasks

Work Management Database

Resolve Incidents,
Changes, Requests and
Their Associated Tasks

Analyze Performance
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Viewing and Editing Contact Records

Capturing information about your contacts and their needs is the key to 
operating a successful Help Desk. Work Management maintains a database 
of contact information, complete with assigned priority levels and service 
level requirements. From the Work Management Schedule window, you can 
view all of the contacts currently defined in Work Management. 

Displaying the Contacts List 
To add new contact details or edit some of the attributes of a contact:

1 Log in as a Manager.

2 Pull down the View menu.

3 Select the Contact… option.

The Contacts filter list is displayed — a list of the first 150 contacts, based on 
the setting of the Contact Filter. 

Note: The default setting for the Contact Filter is to show contacts starting 
with A; however if the total number of contacts exceeds 150, only the 
first 150 contacts are displayed.

Figure 3-2: Contact List Dialog
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Work Management has ten attributes for each contact, displayed in the 
columns of the Contact Filter list.

Column Data

Name This is a required field and must contain a name for every 
contact. Name is a required field and must contain a 
unique value for each record. The list of contacts is 
displayed in sequential fashion, sorted alphabetically by 
name. You can enter first names first or last names first. 
Work Management will sort the contacts by the first letter 
of the first word in the name. For example, if you were to 
enter a contact as Jones, Henry, the name would be sorted 
by J. If you were to enter the same contact as Henry Jones, 
the name would be sorted by H.

Phone Used to enter the telephone or voice mail number of the 
contact.

Priority Used to enter the priority you assign to the contact. This 
value is not used by the Scheduler to arrive at an optimized 
schedule. Work Management will automatically update 
the Priority column with the default value of 10.

Minimum Expertise Indicates the lowest acceptable expertise level for any 
operator assigned to resolve a contact's Incident tickets. By 
capturing the Minimum Expertise requirements, you can 
ensure that certain contacts receive preferred levels of 
service. When scheduling, Work Management will only 
assign technicians who meet or exceed the minimum skill 
required. You can choose from a combo box menu of 
expertise levels when defining the Minimum Expertise for 
a contact. If the cell is left blank, the system will default to 
the lowest minimum expertise level defined in the system 
for all new contacts. The default setting for this value is 
Beginner.

User-defined Fields
Attribute 1, Attribute 2, 
Location, Company

The labels and data values tracked by the user-defined 
fields can be changed at the home menu by pulling down 
the Options menu and choosing the User Defined fields... 
option. You can enter any value in these fields. These 
values are not validated against any list of data values; they 
are used for reporting purposes only.

Location Record the contact’s address or other relevant location 
information, such as a location number.

Travel Time Specify the distance to the contact’s location in units of 
time.
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Navigating The Contacts Filter List
You can navigate through the Contacts Filter list as follows:

� Resize columns by positioning the cursor on the divider and sliding the 
divider to the right size. Click the OK button to save these changes.

� Use the Tab key to move through the entire range of buttons in the panel, 
then move the focus to the first cell of the spreadsheet, after which the 
directional keys are used to move through the cells.

� Use the Enter key to move between cells in each row.

� Use the Up, Down, Left, and Right Arrow keys to move within the 
spreadsheet.

� Double-clicking one of the cells in the Outstanding Count field will open 
the Incident/Change dialog box.   The incomplete Incidents tickets, 
Change requests, Request quotes, and their associated tasks for that 
contact are displayed in the ascending order of item numbers. This 
includes Incidents tickets, Change requests, Request quotes, and their 
associated tasks that have not yet been allocated. Only items belonging to 
the manager logged in will be displayed. On exiting the dialog box, you 
will return to the same row in the Contact spreadsheet.

� Click OK to save any changes made to the database during the session.

� Click Cancel to ignore any changes.

Keyboard Shortcuts
You can utilize the following keyboard shortcuts when navigating the 
Contacts list:

� Ctrl+End moves the cursor to the last cell of the list.

� Ctrl+Home highlights the Name cell of the first record in the list.

� The Home key highlights the Name cell of the current row.

� The End key highlights the Outstanding Count cell of the current row.

E-mail address Used to enter the e-mail address of the contact.

Outstanding count Indicates the number of incomplete Incidents tickets, 
Change requests, Request quotes, and their associated 
tasks for each contact. This value is computed by Work 
Management and cannot be edited.

Column Data
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Viewing Contact Details

The Show Contact dialog shows the details of the contact for the Incident, 
Change, Request, or Task, which is currently active.

The Show Contact option is accessed in the following ways:

To access Show Contact through the Incident/Change Details dialog:

1 Select the Incident, Change, Request, or Task.

2 Click with the right mouse button to reveal the short-cut menu.

3 Select Show Contact.

To access Show Contact through the Incident Spreadsheet pane:

1 Highlight an Incident, Change, Request, or Task.

2 Click with the right mouse button to reveal the short-cut menu.

3 Select Show Contact.

To access Show Contact through the Schedule window pane:

1 Highlight an Incident, Change, Request, or Task. 

2 Click with the right mouse button to reveal the short-cut menu.

3 Select Show Contact. The contact details window is displayed.

Figure 3-3: Contact Details
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4 Click the window to close it and return to regular operations in the Schedule 
window.

Adding New Contacts

Contacts are added to Work Management from ServiceCenter. Since Work 
Management displays the Incidents tickets, Change requests, Request quotes, 
and their associated tasks from ServiceCenter, it also uses the same database 
files for contacts. It displays those contacts satisfying the Work Management 
contacts filter criteria.

Adding a Contact in ServiceCenter
To add a new contact to ServiceCenter and Work Management:

1 Logon to ServiceCenter.

2 Click the Database Manager button on the Toolkit tab of the ServiceCenter 
home menu. 

Table 3-1: Toolkit Tab of the ServiceCenter Home Menu
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Database Manager opens.

Figure 3-4: Database Manager

3 Enter =contacts in the Form Name field.

4 Press the Enter key or click the Search button.

The ServiceCenter Contact Information form is displayed.

5 Enter data for a new contact in the blank record as described below. 

Figure 3-5: ServiceCenter Contact Record
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By default the Work Management filter has been set up to recognize only 
contacts whose name begins with an uppercase A. For more information, see 
Filtering the Contacts List on page 63.

6 Add a user whose name begins with A, as shown in Figure 3-5.

7 Click the Add button to save this new contact to the contacts file.

A message appears at the bottom of the screen confirming that the Contact 
Information record has been added to the contacts file.

8 Verify the contact has been recognized by Work Management and appears in 
the Contacts Filter list. If it has not, perform steps 1 through 6 again and 
ensure the contact’s name starts with an uppercase A.

Viewing the Contacts List
To view the Contact list:

1 From the Work Management home menu, pull down the Schedule menu.

2 Select the Refresh All option to make sure the latest data has been imported 
from the ServiceCenter database into Work Management.

3 From the View menu, select the Contact… option. 

The Contact Filter list is displayed.

Figure 3-6: Work Management Contacts
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Once a new contact name has been entered, the system automatically assigns 
a default Priority value of 10 and the lowest defined value for Minimum 
Expertise. 

The cells for Phone and E -mail address remain blank. 

Two of the user-defined fields, Attribute 1 and Attribute 2, default to a value 
of None. The other two user-defined fields, Company and Location are 
populated with the values defined in ServiceCenter for this contact. 

Outstanding count is updated as Incidents tickets, Change requests, Request 
quotes, and their associated tasks are reported by this contact.

Refreshing the List of Contacts
At the top of the Contact Filter list is the Refresh button. This button is used 
to refresh your list with any new information captured by Work 
Management, such as the creation or modification of a contact by another 
user. Using refresh also updates the Contact column in the Schedule window 
with the latest number of outstanding Incidents tickets, Change requests, 
Request quotes, and their associated tasks for each contact.

To refresh the list:

� Click the Refresh button at the top of the Contact Filter dialog box.

This automatically updates your Contact information to make it current with 
the latest changes in the ServiceCenter/Work Management shared database.

Deleting Contacts

Contacts can only be removed from the ServiceCenter side.

To delete a contact:

1 Logon to ServiceCenter.

2 Click the Database Manager button from the Toolkit tab on the 
ServiceCenter home menu, as shown in Figure 3-1 on page 57. The Database 
Manager prompt appears as shown in Figure 3-4 on page 58.

3 Enter =contacts in the Form Name field.

4 Do one of the following:
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� Press the Enter key to retrieve a list of all contacts in the file, then sort 
through the record list to locate the desired contact record.

� Enter the name of the contact in the Contact Name field, and click the 
Search button.

5 When the Contact record appears, click the Delete button.

A prompt dialog box asks you to confirm the delete action.

6 Press the Yes button to delete. Press the Cancel button to cancel the delete 
operation.

A message will appear in the status bar confirming the deletion.

Editing an Existing Contact Filter List

Editing in ServiceCenter
Name, Phone, Company, Location and Email address values must be edited 
in ServiceCenter using the contact information form. 

To edit contact information in ServiceCenter:

1 Logon to ServiceCenter.

2 Click the Database Manager button from the Toolkit tab on the 
ServiceCenter home menu, as shown in Figure 3-1 on page 57. The Database 
Manager prompt appears, as shown in Figure 3-4 on page 58.

3 Enter =contacts in the Form field.

4 Do one of the following:

� Press the Enter key to retrieve a list of all contacts in the file, then sort 
through the record list to locate the desired contact record.

� Enter the name of the contact in the Contact Name field, and click the 
Search button.

To edit attributes of a contact:

1 In a blank form, enter the name of the contact in the Contact Name field. 

2 Press Enter.

3 If a QBE list returns with several records meeting your search, select the 
desired contact from the list. If not, go to step 5.

4 Press Enter.

The selected Contact Information form appears.
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5 Place the cursor in the field you wish to modify.

6 Enter the new values or overwrite the existing contents.

7 When completed, click the Save button in the tool tray to record your 
modifications.

A confirmation message appears at the bottom of the screen indicating that 
the record has been updated in the contacts file. 

Important: If this message indicates an error or does not appear, be sure to 
select the View Messages button in the menu bar to reveal the 
messages generated during this action. The processing messages 
indicate which actions occurred and where (if) any errors 
occurred in the process.

8 Return to the Work Management home menu.

9 Refresh the contacts display to see the modifications made to the Contact 
Information record. For more information, see Viewing the Contacts List on 
page 59.

Editing in Work Management
Priority, Minimum Expertise, and the user-defined field values not listed 
above can be edited directly in Work Management.

To enter new values for Priority:

1 Click in the desired cell.

2 Change Priority by entering a new value between 1 and 10 in the field.

To enter new values for Minimum Expertise:

1 Click the arrow to the right of the combo box.

2 Select a Minimum Expertise value from the drop-down menu.

To update the user-defined fields (Attribute 1 and Attribute 2):

1 Click the arrow to the right of the combo box.

2 Select your choice from the list of options (if any are available). 

Note: You can also use the F2 key to toggle into Edit mode on the fields with 
arrow keys, and then use the Up and Down directional arrow keys to 
navigate through the list of choices.
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3 Click OK to save any changes to the database.

4 Click Cancel to ignore them. 

Once the changes have been saved, Work Management automatically 
re-sorts the list of contacts alphabetically by name to include any new entries.

Filtering the Contacts List

Work Management allows customization for how Contacts are filtered into 
Work Management. 

Access the Contact Filter dialog box from the Work Management home 
menu:

1 Do one of the following:

� From the Options menu select Filters > Contact.

� From the Contact dialog box, right-mouse click a contact name and select 
Filter from the pop-up menu. 

The Contact Filter dialog box appears.

Figure 3-7: Work Management Contacts Filter Setup
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2 In the Contact Filter dialog box provide field values as follows:

a Enter the wild card for the Contact name field. 

This value is used to determine which contact to display, for example, * 
imports all contacts in ServiceCenter and all their data; A* displays all 
contacts whose names begin with A and are followed by any other 
characters.

b Enter the condition for the Priority field. 

This is another condition determining which contacts to bring into Work 
Management. Your options in the first value field include, equals (=), less 
than (<), greater than (>), less than or equal to (<=), greater than or equal 
to (>=), and greater than or less than (<>). 

The second value field lists the priority levels 1-10. For example, if you 
select =2 in these fields, only contacts who have Incidents with a priority 
of 2 will be imported into Work Management, where =>2 brings in all 
with a priority of 2 or higher.

c Select the user-defined lists (Attribute 1 and Attribute 2) if required.

Use the Shift or Ctrl keys to make multiple selections.

3 Click OK to save the filter option changes.

This filter is then used to display the contacts list in the Contact dialog box.
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CHAPTER

4
 Categories
This chapter is an introduction to Categories in Work Management for the 
ServiceCenter administrator, manager, or user. It describes how to establish 
Incident, Change, Request, and Task categories, and tie them in with other 
elements in the ServiceCenter database.

Read this chapter for information about:

� Viewing Categories on page 66

� Adding New Categories on page 69

� Deleting Categories on page 80

� Editing Categories on page 85

� Viewing and Defining Satisfaction for Categories on page 91
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Viewing Categories

Work Management tracks incoming contact requests by category.

Work Management also records the priority levels and duration estimates for 
each category. From Work Management, you can view categories or edit the 
attributes of any existing category. 

To view categories from the home menu:

1 Pull down the View menu.

2 Select the Category… option.

The Category record appears, displaying a list of categories.

Figure 4-1: Work Management Categories
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Each category has the following attributes: Name, Duration, Actual duration, 
Priority, Downtime that increases priority, Outstanding count, Satisfaction, 
Tips and four user-defined fields (Attribute 1, Attribute 2, Type, Information). 

Attribute Definition

Name Identifies category name. 

Duration Amount of time required to resolve Incidents tickets, Change 
requests, Request quotes, and their associated tasks. This 
estimate is used by Work Management to allot an appropriate 
amount of time when scheduling these items. If no value is 
specified for an item category or type, the default value 
assigned by the system is one hour (00:01:00). Duration is 
expressed in the format days:hours:minutes, where a day is 
comprised of the available work hours, not necessarily 24 
hours. If the work shift for a day is 8 hours, then every 8 hours 
of the duration is counted as a day. In this instance, if you 
enter a duration of 18 hours as 00:18:00, Work Management 
automatically changes the value to 2:02:00. 

Actual Duration Amount of time operators require to complete Incidents 
tickets, Change requests, Request quotes, and their associated 
tasks for a particular category. This value is computed by 
Work Management from the start and end times during a 
specified number of months for each completed item; this 
value cannot be edited. The method of calculating Actual 
Duration is defined for the organization. This default 
definition can be viewed from the Work Management home 
menu by opening the Options pull-down menu, selecting the 
Customize... option, and then clicking on the Others tab. The 
value is stated in the Information box at the bottom of the 
window.

Priority Priority you assign to the category. This value is not used by 
the scheduler to arrive at an optimized schedule.

Downtime That 
Increases Priority

Length of time it takes to raise an Incident, Change, Request, 
or Task priority by one unit. For example, if the category 
called MS Paintbrush has a priority of 10 and a downtime 
value of 4 days, then an outstanding Incident, Change, 
Request, or Task of this type becomes a priority 9 after 4 days, 
a priority 8 after 8 days, and so on.

Attribute 1 and 
Attribute 2

User-defined fields. Data is entered into these cells using a 
combo box of choices. The labels and data values tracked by 
the user-defined fields can be modified by selecting the User 
Defined fields... option in the Options pull-down menu in the 
Work Management home menu. 
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Navigating
Use the following information to navigate through the category record:

� Resize columns by positioning the cursor on the divider and sliding the 
divider to the right size. Click the OK button to save these changes.

� Use the Tab key to move through the entire range of buttons in the panel, 
and then to move the focus to the first cell of the spreadsheet. 

� The Arrow keys are used to move through the cells.

� Use the Enter key to move between cells in each row.

� Use the Up, Down, Left, and Right Arrow keys to move within the 
spreadsheet.

Type Displays the category type; Incident, Change, Request, or 
Task, defined in ServiceCenter.

Information User-defined field indicating the assignment group 
responsible for Incidents tickets, Change requests, Request 
quotes, and their associated tasks of a certain category, for 
example, HelpDesk, MIS, etc. Note: The Type and 
Information fields are not validated against any list of data 
values. They are used for reporting purposes only.

Outstanding count Number of open or unresolved Incidents tickets, Change 
requests, Request quotes, and their associated tasks for a 
particular category. This value is automatically calculated by 
Work Management, and cannot be edited.

Tips Free-form text field that allows you to enter basic tips on 
solving Incidents, Changes Tasks, and Requests for a 
category. The Tips text box, visible at the bottom of the 
screen, contains applicable information unique to each 
attribute.

Satisfaction Values that are used to calculate the overall customer 
satisfaction for the Help Desk and can be defined for each 
category. For more information, see Viewing and Defining 
Satisfaction for Categories on page 91.

Satisfaction can be accessed by clicking the Satisfaction 
button near the top of the window

Attribute Definition
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� Double-clicking one of the cells in the Outstanding count field will open 
the Incident/change dialog box.   The incomplete Incidents tickets, Change 
requests, Request quotes, and their associated tasks for that category are 
displayed in order of ascending item number. This includes items that 
have not yet been allocated. Only Incidents tickets, Change requests, 
Request quotes, and their associated tasks belonging to the manager 
logged in are displayed. On exiting the dialog box, you return to the same 
row in the Category spreadsheet.

� Click OK to save any changes made to the database during the session. 

� Click Cancel to ignore any changes.

Keyboard Shortcuts
The following are some helpful keyboard shortcuts that you can use to 
navigate through the Category record:

� Ctrl+End moves the cursor to the last cell at bottom of the list.

� Ctrl+Home highlights the Name cell of the first record in the list.

� The Home key highlights the Name cell of the current row.

� The End key highlights the Outstanding count cell of the current row.

Adding New Categories

The following sections provide information on introducing new categories 
into both ServiceCenter and Work Management.

Note: Work Management displays data that exists in the ServiceCenter 
database. New categories, therefore, must be added from 
ServiceCenter.

ServiceCenter Actions
The key point to remember when adding Incident categories for Work 
Management is that Work Management should not receive all Incidents 
tickets, Change requests, Request quotes, and their associated tasks and all 
associated categories. Work Management organizes the scheduling and 
completion of software support issues rather than facilities issues, for 
example. For this reason, you should create an assignment group for Work 
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Management. For more information, see Adding Assignment Groups on 
page 121. All operators who will be using Work Management and any 
Incident categories that need to appear in Work Management must be 
directed to this assignment group.

Note: Changes, Tasks, and Requests appear in Work Management based on 
the manager to which they are assigned in ServiceCenter, not their 
category. The category of the change, task, or request is automatically 
recognized in Work Management, based on the category definition 
provided in ServiceCenter.

Incident Categories
To add a new Incident category:

1 Click the Incident Management button from the Services tab on the 
ServiceCenter main menu shown in Figure 2-1 on page 23. The Incident 
Management application tabs appear.

2 Click the Security Files button on the Incident Management Menu tab 
shown in Figure 4-2. 

Figure 4-2: Incident Management Menu
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The Security Files and Environment tabs appear. 

Figure 4-3: Security Files Tab

3 Click the Add button in the Categories section of the Securities Files tab.

4 Enter the name of the new category in the dialog which appears, for this 
example, enter WMexample.

5 Click OK.

Another prompt appears asking if this category profile should be based on 
the profile of an existing category.
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6 If you want to base this category on another, Click the arrow button to the 
right of the field, then select a category from the drop-down menu. Click Yes 
to confirm the base action. If you do not want to base this category on 
another, click No.

Note: An Active Notes dialog box may appear after you click No with the 
message The incident.WMexample.g format was created. Click OK. 

Figure 4-4: New Category

The configuration for the new category is displayed with a message at the 
bottom indicating the record has been added to the database.

7 Add an assignment group to the Assignment Group Name field to direct all 
tickets of this category to the assignment group monitored by Work 
Management.

8 Click the Formats tab.
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Two groups of forms are detailed on this tab:

� The forms used to display open, update, close, and browse tickets of this 
category are listed. If a specific form is not listed, the default form for 
categories is used.

� The forms used to print opened, updated, closed, tickets of this category 
are listed. If a specific form is not listed, the default form for categories is 
used.

Figure 4-5: New Category Form

9 Click Save to record your additions.

10 Click OK to return to the Security Files tabs.

11 Click Back twice to return to the main ServiceCenter menu.

12 Click the Work Management button.
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Change and Task Categories
To add new change and task categories:

1 Click the Change Management button from the Services tab on the 
ServiceCenter main menu shown in Figure 2-1 on page 23. The Change 
Management application tabs shown in Figure 4-6 appear.

Figure 4-6: Change Management Menu — Changes Tab

2 Do one of the following:

� Depending on the type of category you are adding, click the Change 
Categories button on the Changes tab. 

� Click the Task Categories button on the Tasks tab.

The category form appears. 

3 Enter a category name and provide a brief description.

4 Make the Availability value true if this category is to be available for all users.

5 Provide at least one phase in the Phase array. Phases are listed in a drop down 
menu accessed from each array field.
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6 Click New to record the category definition.

Figure 4-7: New Change Category Record

7 Click OK to exit the form.

8 Click Back to return to the Change Management tabs. 

9 Click Back to return to the main ServiceCenter menu.

10 Click the Work Management button.
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Request Quote Categories
To add new request categories:

1 Click the Request Management button from the Services tab on the 
ServiceCenter main menu shown in Figure 2-1 on page 23. The Request 
Management application tabs shown in Figure 4-8 appear.

Figure 4-8: Request Management — Quotes Tab

2 Click the Quote Categories button on the Quotes tab.

An empty category form (ocmqcat.g) appears.

3 Enter a category name and provide a brief description.

4 Make the Availability value true if this category is to be available for all users.
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5 Provide at least one phase in the Phase array.

Figure 4-9: Request Category Phases

6 Click Add to record the category definition.

7 Click OK to exit the form.

8 Click Back to return to the Request Management tabs. 

9 Click Back to return to the main ServiceCenter menu.
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Work Management Actions
The Work Management side of adding new categories is to verify that new 
categories appear in the system. Most of the creating and editing of category 
information is done in ServiceCenter.

To verify that a new category has been added:

1 Login to Work Management.

2 Select View > Category….

The Work Management Category table appears, listing the Incident, Change, 
Request, and Task categories separated into sections based on type.

Figure 4-10: Category List
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Note: You may need to scroll down the list to see all of the categories you 
added.

The following conditions are stated in each new category: 

� The Duration field value defaults to one hour (00:01:00)

� The Priority field value defaults to 10. 

Customizing Categories

To change the Duration or Priority values:

1 Select the cell and type in the new value. 

Note: Duration values must be in the format d:hh:mm. Priority values must 
be between 1 and 10.

� Actual Duration is calculated by the system and cannot be edited.

� Work Management does not require that you input a number in the 
Downtime that increases priority column. However, you must enter a 
value to escalate outstanding Incidents tickets, Change requests, Request 
quotes, and their associated tasks. Categories without a Downtime value 
entered will not automatically escalate in Work Management. 

2 To input a Downtime escalation value, type a numeric value in the cell using 
the format d:hh:mm.

� The first two user-defined fields (Attribute 1 and Attribute 2) default to a 
value of None. 

� Type and Information (the other two user-defined fields) values are 
imported directly from the ServiceCenter Category records.

� Outstanding count values are automatically updated by the system and 
cannot be edited.

3 Click OK to save any changes to the database. 

4 Click Cancel to ignore changes made. 

Note: If Incident, Change, Request, or Task record tickets already exist on 
the schedule, a warning prompt will ask if you want to apply the new 
category settings to these items. Click Yes to apply the changes.

Once the changes have been saved, Work Management automatically 
re-sorts the categories alphabetically and by type to include any new entries.
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Adding/Editing Tips values
To enter new Tips for a category, or to edit existing Tips: 

1 Select a category in the spreadsheet.

Any tips corresponding to that category are presented in the Tips field at the 
bottom of the window. 

2 Use the Tab key to move from the category in the spreadsheet to the Tips 
field.

Tips is a free-form text field, allowing you to use the Up, Down, Left and 
Right arrow keys to navigate through the displayed field.

3 Make the required changes.

4 Click OK to save any changes to the database. 

5 Click Cancel to ignore changes made. 

Deleting Categories

Categories do not reside in Work Management; therefore, you need to go 
into ServiceCenter to delete a category.

Incident Categories
To delete an Incident category from the database:

1 Click the Incident Management button from the Services tab on the main 
ServiceCenter menu shown in Figure 2-1 on page 23. The Incident 
Management application tabs appear. 

2 Click the Security Files button on the Incident Management Menu tab 
shown in Figure 4-2 on page 70. The Security Files and Environment tabs 
appear.

3 Click the Delete button in the Categories section of the Securities Files tab. A 
dialog box prompts you for the name of the category to delete.

4 Type the category name.

5 Click OK. 
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6 From the confirmation screen, select the associated forms that also need to 
be deleted. These forms display tickets for the selected category.

Figure 4-11: Removing Incident Category Forms

7 Click OK to confirm the delete action along with the associated forms.

You are returned to the Security Files tab, which has a message at the bottom 
of the screen indicating the selected record has been deleted from the 
category file.

Change and Task Categories
To Delete change and task categories:

1 Click the Change Management button from the Services tab on the 
ServiceCenter main menu, as shown in Figure 2-1 on page 23. The Change 
Management application tabs appear.

2 Do one of the following:

� Depending on the type of category you are adding, click the Change 
Categories button on the Changes tab, as shown in Figure 4-6 on page 74.

� Click the Task Categories button on the Tasks tab.

The category form appears. 
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3 Enter the name of the category and press Enter, or leave all fields blank and 
click Search to perform a true query and retrieve a list of all categories. If you 
are presented with a QBE list, select the desired item from the list. Figure 4-12 
shows the category record.

Figure 4-12: ServiceCenter Change Record

4 Click Delete from the system tray to initiate the record delete process. A new 
set of buttons appear in the system tray.

5 Select Delete All to remove all pieces of this category.
82 �Chapter 4—Categories 



Work Management
A new screen displays all remaining pieces of the category.

Figure 4-13: Confirm Change Category Delete

6 Click Delete to remove the name and all associated elements in 
ServiceCenter. You are returned to a QBE list of existing categories with a 
confirmation message at the bottom of the screen.

Request Categories
To delete request categories:

1 Click the Request Management button from the Services tab on the 
ServiceCenter main menu. The Request Management application tabs 
appear. 

2 Click the Quote Categories button on the Quotes tab, as shown in Figure 4-8 
on page 76. An empty category form (ocmqcat.g) appears.
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3 Enter the name of the category and press Enter, or leave all fields blank and 
click Search to perform a true query and retrieve a list of all categories. If you 
are presented with a record list, select the desired item from the list.

Figure 4-14: ServiceCenter Quote Category Record

4 Click Delete from the system tray to initiate the record delete process.

5 A warning prompt appears, asking if you actually want to remove this 
category, click Yes to confirm the deletion, or No to cancel the action.

When the category record is deleted, a message appears at the bottom of the 
screen indicating it has been removed from the quote category file, and you 
are returned to the following record in the record list.
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Editing Categories

Editing from Work Management
Not all Work Management category fields can be edited in Work 
Management. Duration, Priority, and Downtime That Increases Priority are 
the only fields that the user can edit from Work Management. The Actual 
Duration and Outstanding Count fields are calculated by the system. The 
user-defined fields contain data imported from ServiceCenter or have 
non-editable default values.

Note: Press F2 or single-click to enter edit mode on those cells which can be 
edited in Work Management. Once a cell is highlighted for edit mode, 
enter any new values, then click the right mouse button to bring up a 
shortcut menu. Use the refresh option to update the display with the 
edited cell values. 

To edit categories:

1 Select the entire contents of the cell by double-clicking the displayed field 
value. Use the Cancel button to ignore your most recent change.

The following conditions are stated in each new category: 

� The Duration field value defaults to one hour (00:01:00)

� The Priority field value defaults to 10. 

2 To change the Duration or Priority value, select the cell and begin typing in 
the new value. 

Note: Duration values must be in the format days:hours:minutes. And 
Priority values must be between 1 and 10.

� Actual Duration is calculated by the system and cannot be edited.

Work Management does not require that you input a number in the 
Downtime that increases priority column. However, you must enter a value 
to escalate outstanding Incidents. Categories without a Downtime value 
entered will not automatically escalate in Work Management. 

3 To input a Downtime value, type a numeric value in the cell using the format 
days:hours:minutes.

4 Edit user-defined field values:

� The first two user-defined fields (Attribute 1 and Attribute 2) default to a 
value of None. 
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� Type and Information (the other two user-defined fields) values are 
imported directly from the ServiceCenter Category record.

� Outstanding count values are automatically updated by the system and 
cannot be edited.

5 Click OK to save any changes to the database. 

6 Click Cancel to ignore changes made. 

Once the changes have been saved, Work Management automatically 
re-sorts the categories alphabetically by Name to include the new entry.

Categories may be modified or new ones added by other managers. Using the 
Refresh button at the top of the window will update the Category record 
dialog with the latest data from the database.

To enter new Tips for a category, or edit existing Tips, see Adding/Editing 
Tips values on page 80.

Editing from ServiceCenter

Incident Categories
To edit an Incident category:

1 Click the Incident Management button on the Services tab on the main 
ServiceCenter menu. The Incident Management tabs appear.

2 Click the Security Files button on the Incident Management Menu tab 
shown in Figure 4-2 on page 70. The Security Files and Environment tabs 
appear.

3 Click Edit in the Categories section of the Securities Files tab shown in 
Figure 4-2 on page 70. A dialog box prompts you for the name of the 
category to edit.

4 Type the category name.

5 Click OK.
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The category form appears displaying the features of the category you have 
selected.

Figure 4-15: Editing a ServiceCenter Incident Category

6 Click the Category, Formats, and Alerts tabs to view and modify various 
aspects of the category configuration. Modifications to this record will affect 
how it is processed both in ServiceCenter and Work Management.

7 Click Save after making edits, to record and update the record in the 
database.

Change and Task Categories
To update and edit change and task categories:

1 Click the Change Management button from the Services tab on the 
ServiceCenter main menu.

The Change Management application tabs appear.

2 Do one of the following:

� Depending on the type of category you are adding, click the Change 
Categories button on the Changes tab shown in Figure 4-6 on page 74.

� Click the Task Categories button on the Tasks tab.

The category form appears. 
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3 Enter the name of the category and press Enter, or leave all fields blank and 
click Search to perform a true query and retrieve a list of all categories.

4 If you are presented with a QBE list, select the desired item from the list.

The category record is displayed.

Figure 4-16: Updating ServiceCenter Change Category Record

5 Modify the various aspects of the category configuration. 

Modifications to this record will affect how it is processed both in 
ServiceCenter and Work Management.

6 Select Save when finished modifying the record to commit your changes to 
the database.

Request Categories
To update and edit request categories:

1 Click the Request Management button from the Services tab on the 
ServiceCenter main menu. The Request Management application tabs 
appear.
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2 Click the Quote Categories button on the Quotes tab shown in Figure 4-8 on 
page 76. An empty category form (ocmqcat.g) appears.

3 Do one of the following:

� Type the name of the category and press Enter. Figure 4-17 shows a 
Request Management Quote Category record.

� Click Search to perform a true query and retrieve a list of all categories. 
Select the desired item from the list.

Figure 4-17: Request Management Quote Category Record

4 Modify the various aspects of the category configuration. Modifications to 
this record will affect how it is processed both in ServiceCenter and Work 
Management.

5 Select Save when finished modifying the record to commit your changes to 
the database.
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Refreshing list of Categories in Work Management
All modifications of and additions made to Category records while in 
ServiceCenter are eventually displayed in Work Management.

Work Management refreshes periodically on its own; however you can also 
manually refresh the listings.

At the top of the Category screen is a Refresh button. Clicking this button 
updates your list of categories with any new information captured by Work 
Management, including the creation or modification of a category by 
another user. Using refresh also updates the display with the latest number of 
outstanding Incidents tickets, Change requests, Request quotes, and their 
associated tasks for each category.

To refresh a list:

� Click Refresh at the top of the Category screen. Your category information is 
automatically updated to the latest changes in the Work Management 
database. For more information, see Category List on page 78.

Updating Duration
As Incidents tickets, Change requests, Request quotes, and their associated 
tasks are completed for a particular category, Work Management tracks the 
actual amount of time used by the Help Desk operators. This information is 
presented in the Actual duration column of the Category screen. You can use 
the Actual duration column to update the values in the Duration column. 
However, this option will not be available when the actual duration column 
is blank for a particular category.

To update with latest Actual duration information:

1 Click Recalculate at the top of the Category screen. From the keyboard, 
access the range of buttons by using the Tab key. 

This action calculates the actual duration based on the completed Incidents 
tickets, Change requests, Request quotes, and their associated tasks over a 
known period of time. For more information, see Creating Custom 
Configurations on page 173 and see Category List on page 78.

2 Click OK to save the newly calculated actual duration. These same values are 
displayed until the next recalculation.

Note: At this time, the user-access is not enabled to replace Duration values 
with Actual duration values.
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Viewing and Defining Satisfaction for Categories

For each category, you can define a penalty when an Incident is not resolved 
within a specific time frame. This is a way to identify and uphold a service 
contract. You can determine the amount of downtime that affects the 
satisfaction of your contacts, as well as the rate at which satisfaction 
decreases. This measure of performance is used to calculate the overall 
customer satisfaction for all outstanding Incidents tickets, Change requests, 
Request quotes, and their associated tasks.

Your satisfaction scores are presented on the Satisfaction gauge of the 
Category window. The Satisfaction gauge is accurate only when satisfaction 
is defined for all categories. Any category without a satisfaction definition 
automatically defaults to 10, the highest rating. Since the Satisfaction gauge 
describes the average calculation for all of the categories in the system, 
categories that default to 10 will influence those that do have satisfaction 
defined.

To view or edit the satisfaction associated with a particular category:

� Click Satisfaction at the top of the Category screen. If extreme data points are 
specified, the intermediate values are interpolated. For more information, 
see Category List on page 78.

Satisfaction is calculated by Work Management from two attributes: score 
and downtime. 

Attribute Definition

Score A value between 0 and 10. A score of 10 indicates the highest possible 
satisfaction, while a score of 0 is the lowest. 

Downtime Expressed in the format days:hours:minutes, downtime is associated 
with each score. Based on the downtime entered for each score, 
Work Management builds a line graph where the Y-axis is downtime 
expressed in hours, and the X-axis is the score. A minimum of 2 
points must be entered for the satisfaction curve to be generated. If 
no satisfaction is defined, the system default is 10.
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Figure 4-18 shows a satisfaction time graph.

Figure 4-18: Satisfaction Time Graph

Updating Satisfaction Values
To enter the downtime for each of the scores:

1 Highlight the desired cell.

2 Type in the appropriate value.
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Downtime must be expressed in terms of days:hours:minutes. Increasing 
downtimes should correspond to lower scores.

Figure 4-19: Customizing Satisfaction Values

The Downtime in hours graph displays the satisfaction curve relating 
increasing downtime to a decreasing satisfaction score. As you key in 
satisfaction values in the table, Work Management updates the satisfaction 
curve to reflect your entries.

3 Click OK to save your changes or click Cancel to ignore changes.
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CHAPTER

5
 Operators and Managers
This chapter is an introduction to using Operators and Managers in Work 
Management for the ServiceCenter administrator, manager, or user. It 
describes how to establish system operators, including managers and group 
managers, and describes how to tie these operations to other elements in the 
ServiceCenter database.

Read this chapter for more information about:

� Viewing and Editing Operator Information on page 96

� Adding Operators and Managers on page 99

� Editing Operators in Work Management on page 105

� Defining Operator Commitment on page 113
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Viewing and Editing Operator Information

Work Management retains a log of all ServiceCenter operators registered to 
the Help Desk assignment group, complete with their individual areas of 
expertise and times of availability. This information is used to generate a 
schedule that takes the particular skill sets and availability of the operators 
into account. Each manager can update the areas of expertise for those 
operators assigned to him/her directly in Work Management.

New operators must be created in ServiceCenter and assigned to the Help 
Desk (For Example, the Work Management assignment group) before they 
can appear in Work Management. When created, an operator is 
automatically assigned to the manager of that assignment group.

To view or edit operator information:

1 Do one of the following:

� From the View menu, select Operator.

� Double-click the operator column in the Schedule window.

The list of operators appears.

This list of operators includes only those operators that have been assigned 
to the individual manager logged into Work Management. 

The attributes defined for each operator include Name, Login, Password, 
Outstanding count, Expertise (in button bar) and the user-defined fields 
(Attribute 1, Attribute 2, Voice Mail and Beeper).
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Figure 5-1: Work Management Operator Details

Field Definition

Name Identifies an operator within an organization. The name 
must be unique for each operator. All operators are sorted 
alphabetically by name. You can enter first names first or last 
names first. Work Management sorts the operators by the 
first letter of the first word in the name. For example, if you 
were to enter an operator as Jones, Henry, the name is sorted 
by J. If you enter the same contact as Henry Jones, the name is 
sorted by H.

Login Defines the login ID for the operator when logging into Work 
Management. The value of this field must be unique for each 
operator. 

User-defined Fields Used for reporting only, the user-defined fields are not 
validated against any list of data values. Labeled as Attribute 1, 
Attribute 2, Voice Mail and Beeper. These fields can be 
modified from the User Defined fields... option in the 
Options pull-down menu on the Schedule window. For more 
information, see Schedule Window on page 127.
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Navigating
Use the following information to navigate through the Operator record:

� Resize columns by positioning the cursor on the divider, and sliding the 
divider to the right size. Click the OK button to save these changes.

� Use the Tab key to navigate through the entire range of buttons in the 
panel and then move to the first cell of the spreadsheet.Use the arrow keys 
to navigate within the spreadsheet.

� Use the Enter key to move between cells in each row.

� Use the Up, Down, Left, and Right Arrow keys to move within the 
spreadsheet.

� Click OK to save any changes made to the database during the session. 

� Click Cancel to ignore any changes.

Outstanding count Indicates the number of open tickets assigned to each 
operator. This value is automatically computed by the system 
and cannot be edited.

Expertise

(Click the button at 
top of window to 
reveal this item.)

Identifies which categories an operator is qualified to resolve. 
You may select any number of ServiceCenter or Work 
Management defined categories. To schedule Incidents 
tickets, Change requests, Request quotes, and their associated 
tasks, each operator must have defined areas in the Expertise 
column. If no values are entered for Expertise, the Auto 
Scheduler task is unable to assign any Incident ticket to that 
operator. In the instance where no operators have the 
expertise to complete a given item, Work Management holds 
the item in the Mailbox as unallocated assignments. 
However, the Manager can drag and drop such Incidents 
tickets, Change requests, Request quotes, and their associated 
tasks to any Operator even if the operator does not have the 
expertise.

Field Definition
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� Double-click a cell value in the Outstanding count field to open the 
Incident/Change Details dialog box. Incomplete Incidents tickets, Change 
requests, Request quotes, and their associated tasks for that operator are 
displayed in the ascending order of item numbers. This includes Incidents 
tickets, Change requests, Request quotes, and their associated tasks that 
have not yet been allocated. Only Incidents tickets, Change requests, 
Request quotes, and their associated tasks belonging to the manager 
logged in will be displayed. On exiting the dialog box, you return to the 
same row in the Operator spreadsheet.

Keyboard Shortcuts
The following are some helpful keyboard shortcuts that you can use to 
navigate through the Operator record:

� Ctrl+End moves the cursor to the last cell of the list.

� Ctrl+Home highlights the Name cell of the first record in the list.

� The Home key highlights the Name cell of the current row.

� The End key highlights the Outstanding Count cell of the current row.

Adding Operators and Managers

New operators originate in ServiceCenter. Operator names, logins and 
passwords defined in ServiceCenter are used by Work Management. See the 
System Administrator’s Guide for information on how to do the following 
steps in ServiceCenter.

In the operator record:

1 Set up an operator record for the user or manager. 

2 In user’s operator record, select type of resource this operator is.

3 Select which profiles or user roles the operator will use.

4 Enter operator’s name in an assignment group if one was not already 
assigned.
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Work Management Actions
The operator has to be created and configured in ServiceCenter, but the 
operator will not appear in Work Management until you refresh the session, 
or log in as that operator or manager. 

To refresh the session:

1 From the Schedule window, pull down the Schedule menu.

2 Do one of the following:

� Select the Refresh All option.

� Press Ctrl+R. The new operator(s) appear in the Schedule window in 
alphabetical order according to the first letter of the name. 

For more information, see Viewing and Editing Operator Information on 
page 96. 

Note: For tickets assigned to a new manager to appear you need to switch to 
that manager’s login. For more information, see Logging in as a 
Manager on page 26.

Defining Managers

Work Management uses the user profiles established in ServiceCenter for 
operators and managers. This means a user must be defined as a manager or 
group manager from within ServiceCenter before that user can be recognized 
as a manager in Work Management.

Note: To create a new user and make that user a manager, see the System 
Tailoring and the System Administrator’s Guide .

To make an existing user a manager in ServiceCenter:

1 Start and login to ServiceCenter from desktop. 

2 Select the Utilities tab.

3 Click the Administration button.

4 Select the Operators button under the Security group.
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5 Enter the name of the operator to modify and press Enter, or leave all fields 
empty and press Enter to list all available users. If a QBE list of users appears, 
highlight a user name in the list, using the cursor and press Enter. Figure 5-2 
shows the operator record.

Figure 5-2: Operator Record — Login/Contact Profiles Tab

6 Select the Login/Contact Profiles tab. 

7 Click the drop-down arrow beside the Resource Type field.

8 From the displayed list of resource type options, select Manager or Group 
Manager.

Note: If this operator is to be a group manager, a profile record containing 
those managers this operator will supervise needs to be created, with 
the group manager listed as the manager of that group. 

9 Click the Save button to record this change.

10 Click Back to return to the main ServiceCenter menu.
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Assigning Resources to a Manager
Once a manager is defined as such on his/her operator record, the operator 
must also be defined as the manager of a specific assignment group. The 
manager’s login must appear in the Manager Name field of an assignment 
group to become recognized as a manager by Work Management.

To add a managers name to a specific assignment group:

1 Click the Incident Management button from the Services tab on the main 
ServiceCenter menu. For more information, see Figure 2-1 on page 23. The 
Incident Management application tabs appear.

2 Click the Security Files button on the Incident Management Menu tab. 

3 Click Search/Add under Assignment Groups.

4 Type in the name of the new Assignment Group and click Add. Figure 5-3 
shows the new profile.

Figure 5-3: New Assignment Group
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5 If the shift information for this group differs from the group upon which you 
based this record, select a different value for the Calendar Name field. 
Otherwise leave the field value as it appears.

6 Enter the manager name in the Manager Name field, or select the arrow (Fill) 
button and select the name from the user list

If this is to be a group of managers, select an operator whose operator record 
identifies him as a Group Manager in the Manager Name field.

7 Select the Operators tab.

Figure 5-4: Configuring an Assignment Group

8 Enter the names of the operators or managers who are in the group under 
this manager. 

9 Click Save.

You are returned to the Security Files tab.

10 Click Back to exit.
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Logging in as a Manager in Work Management
To see the tickets assigned to this manager’s group, you need to switch to the 
manager’s login. For more information, see Logging in as a Manager on 
page 26.

To switch to another login:

1 Start Work Management, described in Getting Started on page 19.

2 Login as the manager created in Defining Managers on page 100. If you 
logged in as a Resource manager, the Schedule window appears immediately, 
displaying the list of operators assigned to that manager and the Incidents 
assigned to those operators. 

3 If you logged in as a Group manager, a Manager List dialog box displays the 
list of subordinate managers. Click a name from the list.

4 Click the OK button to display the operator schedule beneath that manager, 
as shown in Figure 5-5.

Figure 5-5: Group Manager List of Managers

3
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Editing Operators in Work Management

Press F2 to switch to edit mode on those cells that can be edited with Work 
Management. To access the contents of the combo boxes, click the arrow 
button beside the field, and use the direction keys to select from the list. 
Figure 5-6 shows the Operator Details record.

Figure 5-6: Work Management Operator Details

To edit and operator record:

1 Select the entire contents of the cell by double-clicking the displayed field 
value.

2 Use Cancel to cancel your most recent editing changes.

The following list explains the edit capabilities for each column:

� Name is retrieved from the ServiceCenter operator record and is 
non-editable from Work Management.

� Login is retrieved from the ServiceCenter operator record and is 
non-editable from Work Management.
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� Attribute 1 and Attribute 2 are user-defined fields. To modify these use the 
combo box buttons to the right of the cells. The default value is None and 
the menu contains no options unless Work Management is configured to 
do so.

� Voice mail is retrieved from the ServiceCenter operator record and is 
non-editable from Work Management.

� Beeper is retrieved from the ServiceCenter operator record and is 
non-editable from Work Management.

� Outstanding count is updated automatically and cannot be edited.

� Operator Expertise (accessed via the Expertise button) is defined from the 
Expertise screen. For more information, see Assigning Expertise 
Information to an Operator on page 108.

3 After making changes, click OK to save the modified information to the 
database. Click Cancel to ignore the changes. 

Deleting Operators
Operators are managed in ServiceCenter and are picked up by Work 
Management; therefore, operators must be deleted in ServiceCenter.

To delete an operator:

1 With the operator record open, open the ServiceCenter Options menu.

2 Select Completely Remove User. 

3 A prompt will appear confirming that you want to delete the user and all 
related groups and profiles. Click Yes to proceed, or click No to exit the 
dialog box without removing the record.

Important: This will remove the users relationship to any profiles, all CM 
message groups, assignment groups, and deletes any personal 
inboxes. This user will no longer be able to access ServiceCenter.

After everything has been deleted, you will be returned to the previous menu.
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Refreshing Operator list
At the top of the Operator dialog box is a Refresh button. This button is used 
to refresh your list of operators with any new information captured by Work 
Management, such as the creation or modification of operator information 
by another user. Using refresh will also update the Operator column with the 
latest number of outstanding Incidents tickets, Change requests, Request 
quotes, and their associated tasks for each operator.

To update the list:

� Click the Refresh button at the top of the Operator dialog box. This 
automatically updates your operator information to be current with the 
latest changes in the Work Management database. Figure 5-7 shows the 
Operator Details record.

Figure 5-7: Refreshing Work Management Operator Details

Sorting Operators
You can sort the operator list in the Operator pane alphabetically, or you can 
sort by primary or secondary resource. 

Click Refresh
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Sort the operator list using the options on the Schedule tab of the Customize 
dialog. For more information, see Operator (Sort) Order on page 183.

Work Management Read Only View
Work Management allows a read only view of the scheduler for users who are 
not on the Help Desk team.

These users can only make changes to the Timescale, Customize and Filter 
dialogs. All other dialogs are read only. 

Configuration

Read only view attributes are defined for a user in ServiceCenter using the 
wdlsReadOnlyView logical field located in the operator file. This field is not 
currently available on any default ServiceCenter operator form, but the field 
has been established in the operator file. The system administrator must add 
this field to a form using Forms Designer in order to use this option.

Once available, if this field is set to true for an operator, the user has a read 
only view when logging into Work Management. They cannot allocate, 
unallocate, drag or drop Incidents, Changes, Requests, or Tasks.

Assigning Expertise Information to an Operator
The Operator window displays the Expertise areas for the selected operator 
only. Three attributes describe Expertise for each operator. These attributes 
are Category, Expertise level, and Hourly rate.

Attribute Definition

Category Derived directly from the category database.

Expertise level Indicates the extent of the operator's expertise in a particular 
category. This value is used to ensure that a contact's Minimum 
Expertise requirement is upheld during scheduling. Minimum 
Expertise will default to the lowest Expertise level defined in the 
system. 

Hourly rate Used to compute the cost of completing Incidents. 
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To assign Expertise information to an operator:

1 Double Click the Operator Name in the Schedule Panel. For this example, 
pick HELPDESK, BOB.

2 The Operator dialog box will be displayed, with that operator’s name 
highlighted. 

Figure 5-8: Assigning operator expertise

3 Click the Expertise button from the window header.

The Expertise dialog box will be displayed.
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Figure 5-9: The Expertise Dialog Box

4 Double-click an empty category cell to display the Select Category dialog 
box. Categories that have already been assigned to the operator are displayed 
in blue. 

Figure 5-10: Selecting a Category of Expertise
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5 Choose from the list of available categories by clicking with the mouse or by 
typing in the first few letters of the category name.

6 Click OK or press Enter to assign the new category to the operator. 

7 Click Cancel to close the Select Category dialog box without assigning a new 
Expertise to the operator.

Figure 5-11: Selecting a Level of Expertise

8 On the Expertise screen, select the combo box to display a list of expertise 
options.

9 Select a value from the list to define the operator's Expertise level for the new 
category. 

Work Management defaults to the lowest defined expertise level for all newly 
assigned categories, i.e., Beginner.

Hourly Rate
To change the Hourly rate:

1 Select the appropriate cell by clicking its contents.

2 Overwrite its contents with a new numeric value. 
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Figure 5-12: Assigning an Hourly Rate

Note: You do not need to include a dollar sign with the hourly rate. 

3 To edit a portion of the value: 

a Double-click the cell.

b Use the cursor to navigate.

c Make edits to the value.

If the Hourly rate cell is left blank, Work Management assigns a default rate 
of ($)1.00.

4 Click OK to save these changes to the database. 

5 Click Cancel to ignore changes.

Deleting an Expertise
To delete an Expertise entry:

1 Highlight a cell in the appropriate row.

2 Click the Delete button. 

3 You can also remove an Expertise by pressing the Delete key on the keyboard.

2
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4 Click OK to save these changes to the database. 

5 Click Cancel to ignore changes. Work Management allows you to save the 
changes to the schedule before proceeding with the deletion.

Defining Operator Commitment

Operators may not be available full-time to work on Incidents, Changes, 
Requests, or Tasks, due to vacations, internal meetings, or outside projects. 
Work Management tracks the availability of each operator, and uses that 
information when scheduling Help Desk tickets. Operator commitment can 
be added or modified from within Work Management. Managers can define 
operator commitment for only those operators assigned to them.

Viewing Operator Commitment
To view commitment information for an operator:

1 Click the appropriate operator name in the Schedule window.

2 Pull down the View menu.

3 Click the Operator Commitment… option.

Figure 5-13: Viewing Operator Commitment
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The operator commitment record appears.

Figure 5-14: Operator Commitment Details

The following characteristics are used in the Operator Commitment record 
to define commitments. 

Field Definition

From date The starting day of the period of commitment. The first six (6) letters 
are displayed on the commitment bar of the Schedule window. 

To date The ending day of the period of commitment. The first six (6) letters 
are displayed on the commitment bar of the Schedule window. 

Weekday The day out of the given period that the commitment is applicable. 

From time The starting time of the period of commitment. 

To time The ending time of the period of commitment. 

Type The type of commitment. The first six (6) letters are displayed on the 
commitment bar of the Schedule window. 

Shared to The manager the operator is shared with - only enabled for shared 
operators. To share an operator, select Shared in the Type column.

Notes You may enter whatever additional information you want in 
the Notes field, which can be seen only in this screen.
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Creating New Operator Commitment Information
To add new operator commitment information:

1 Select the appropriate operator. 

2 Figure 5-15 on page 115 shows the Operator Commitment record. For more 
information, see Viewing Operator Commitment on page 113. 

Figure 5-15: Viewing Operator Commitment Details

3 Use the Down arrow key, or the Ctrl+End keys to move to the last row of the 
record.

Note: Dates must be entered in the format defined in the Control Panel. In 
most cases, this will be in the format mm/dd/yy. 

4 Click OK to save changes to the database. 

5 Click Cancel to ignore changes.

6 Return to Schedule window. By default the system sets all new times entered 
under 12 to a value of AM. All times stated in military (24 hour clock) time, 
switch to the appropriate AM/PM time.
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Important: If you add commitments that conflict with assigned Incidents 
tickets, Change requests, Request quotes, and their associated 
tasks, Work Management does not update the schedule by 
pushing the assigned tickets back to the next point of availability 
for the operator. Instead, any overlap creates a new line of ticket 
bars for the operator. The manager must reschedule these items 
manually, or select the Autoschedule option from Operations. 

Figure 5-16 shows a typical scheduling conflict.

Figure 5-16: Scheduling Conflict — must reschedule to resolve

1 Perform necessary rescheduling, if conflicts arise.

2 Save schedule. For more information, see Allocating Tasks Across 
Commitments on page 167.

Editing Operator Commitment Information
To edit operator commitment information:

1 Select the cell you wish to edit.

2 Begin typing to overwrite the contents of the cell.

3 Do one of the following:

� Double-click the cell.

� Press F2 to place you in edit mode. 

4 Use the Left and Right arrow keys to move within the cell and make any 
changes. Use Cancel to ignore your most recent editing changes.

5 Enter the date range in the From and To date fields. 

6 Select the Weekday from the drop down list. 
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7 Enter the time range in he From and To time fields. 

8 Select the Type from the drop down list. 

9 If you selected SHARED as the type, select the manager with whom the 
operator is shared from the from the Share to drop down list. For more 
information, see Sharing An Operator with Another Manager on page 117.

Deleting Operator Commitment
To delete operator commitment: 

1 Select the row of commitment you wish to delete.

2 Click the Delete button, or use the Delete key on the keyboard.

3 Click OK to save the changes to the database. Click Cancel to ignore changes.

Sharing An Operator with Another Manager
To share an operator:

1 Select the appropriate operator at the Operator Commitment dialog box.

2 Specify the time period when the operator is shared, using the From date and 
To date fields.

3 Select the days in the week from the Weekday cell when the operator is 
shared.

4 Specify the time during the selected period when the operator is shared, using 
the From time and To time fields.

5 Selected the commitment type as SHARED.

6 Select the manager's name to whom the operator is lent to or shared with 
from the Share to list box.

7 Click OK to save the changes. Click Cancel to undo the changes. A row for 
the Secondary Manager name appears under the operator’s name in the 
Schedule window. For more information, see Allocating Tasks Across 
Commitments on page 167.
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CHAPTER

6
 Interpreting ServiceCenter Record 
Item Details
This chapter was designed to give the ServiceCenter administrator, manager, 
or user an introduction to ServiceCenter Records. It provides an 
introduction to the features of the Incident ticket, change task, and request 
quote; and their various views.

Topics in this chapter include:

� Introduction on page 120

� Posting ServiceCenter Records to Work Management on page 121

� Viewing Details in Work Management on page 127

� Viewing Item Details in ServiceCenter on page 140

� Editing Tickets on page 140
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Introduction

The attributes of Incidents tickets, Change requests, Request quotes, and 
their associated tasks in the Schedule window can be viewed and modified 
selecting View > Schedule Details from the Schedule window.

In addition to the information box shown in Figure 6-1, Work Management 
displays a dialog box showing more details about the ServiceCenter record 
items, such as Incidents tickets, Change requests, Request quotes, and their 
associated tasks. The information in this dialog box also corresponds to the 
details displayed in the Spreadsheet pane of the Schedule window. For more 
information, see The Task Spreadsheet Pane on page 39. 

Using this dialog box, you can view and modify any Incident, Change, 
Request, or Task belonging to the manager or operator logged in.

Figure 6-1: Work Management Schedule Window Details

Information Box

Incident
Spreadsheet
pane
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Posting ServiceCenter Records to Work Management

Each ServiceCenter system record to appear in Work Management needs to 
be specified as such, either by assigning it to a particular group or assigning 
it to a specific operator/manager. It is the manager’s assignments that are 
displayed in the Schedule window. All items (Incidents tickets, Change 
requests, Request quotes, and their associated tasks) to be scheduled will be 
distributed by that manager through Work Management. You may use a 
out-of box assignment group, such as HELPDESK, or create your own. 

Adding Assignment Groups
To create an Assignment Group:

1 Login to ServiceCenter. 

2 Click Administration on the Utilities Tab on the ServiceCenter System 
Administrator Main Menu. 

3 Click User Administration on the Information/Security/Insight tab.

4 Click Assignment Groups on the Incident tab. The Incident Assignment 
Records window is displayed.

Figure 6-2: Incident Assignment Records
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5 Add a name for the new assignment group. For this example, Work 
Managment.

6 Select the Manager from the Manager Name drop down list.

7 Add other information.

8 Select the Operators tab.

9 Specify the number of operators for this assignment group. When you are 
finished, it will look something like this:

Figure 6-3: New Assignment Group

Note: There is no limit to the number of operators in an assignment group; 
however, consider how many users should respond to an incident 
when you create and populate a new assignment group.

10 Click Add to Add the new group and click back to exit.

Note: See the Application Administration and the System Administrator’s 
Guides for more information on Assignment Groups 

The list is updated once a day. To avoid waiting a day, reboot the server or 
update the global lists file in Database Manager.

To update Assignment Group in the global lists file:

1 Log in to ServiceCenter.
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2 Select Database Manager from the Toolkit tab of the System Administrator’s 
main menu.

3 Enter globallists in the File text box.

Figure 6-4: Opening the Globallist File

The Globallist Definition search form will open.

4 Enter Assignment Group in the List Name text box and click Search.

Figure 6-5: Globallist Definition Search Form
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The Global List Definition for Assignment Groups will open. 

Figure 6-6: Global List Definition for Assignment Groups

5 Enter a date which has passed in the Expiration text box and click Save.

6 Click OK to exit.

7 Log out of ServiceCenter and log back in again.

8 The new assignment group can now be used.

Incidents
Incident tickets appear in Work Management according to the assignment 
group of the manager or specific assignments of the operator logged in. 

For example, the Work Management assignment group, created in Adding 
Assignment Groups on page 121, is managed by MAX.MANAGER. When 
MAX.MANAGER logs in, all operators assigned to the Work Management 
assignment group are also displayed, along with their availability and the 
Incident tickets that have been assigned to them. Tickets to be managed in 
Work Management by MAX.MANAGER, should contain the Work 
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Management assignment group (or another group he manages) in the 
Primary Assignment group field of the record when they are created in 
ServiceCenter.

Figure 6-7 shows an Incident ticket that appears in MAX.MANAGER’s Work 
Management mailbox. For more information, see the Application 
Administration Guide.

Figure 6-7: Setting Incident to Appear in Work Management

Changes and Tasks
Change and task records are designated for pick up by Work Management, 
according to the value in the Work Manager field. If MAX.MANAGER is 
specified in this field, when he logs into Work Management, the new change 
or task record will appear in his mailbox. 
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Figure 6-8 shows a change record that appears in MAX.MANAGER’s Work 
Management mailbox.

Figure 6-8: Setting Change to Appear in Work Management

For more information, see the Application Administration Guide.

Requests
Request quotes like the other ServiceCenter action items have a complex 
approval and assignment process. At the appropriate point in the 
procurement or service request cycle, a quote must be assigned to an 
operator to be completed/delivered. If a request quote is to appear in Work 
Management for a specific operator/manager, that operator/manager must 
be named in the Assigned to field. A quote whose individual line items have 
a specific operator/manager defined in the Coordinator field will also appear 
in the Work Management mailbox of that user.
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Figure 6-9 shows a request record that appears in MAX.MANAGER’s Work 
Management mailbox.

Figure 6-9: Setting Request to Appear in Work Management

For more information, see the Request Management Guide.

Viewing Details in Work Management

Schedule Window
There are several ways to view details of the ServiceCenter records displayed 
in the Schedule window. The first method brings up the respective 
ServiceCenter form used to display Incidents, Changes, Requests, or Tasks, 
and the latter two ways display the data through Work Management forms.
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To view the detail through the Schedule window:

1 Double-click any item in the Schedule pane or Spreadsheet pane.

2 Highlight an item with the mouse pointer. 

3 Click the right mouse button to display a shortcut menu of options. 

4 Choose More Details.

5 Select View > Schedule Details...

Additional Record Details

To view additional Incident, Change, Request, and Task details:

1 Select Options > Filters > Task Details. Figure 6-10 shows the Task filter 
setup dialog box.

Figure 6-10: Work Management Task Details Filter 
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2 You can modify your filter to display certain Incidents, Changes, Tasks, 
Requests, and details. For more information, see Filtering ServiceCenter 
Record Items on page 129.

3 Return to the Schedule window.

4 Select View > Schedule Details. Figure 6-11 shows the Task Details dialog 
box that displays the first Incident, Change, Request, or Task in the list. 

Figure 6-11: Task Details Dialog Box

5 Do one of the following:

� Use the scroll buttons in the top panel to browse through the records.

� Enter the Incident, Change, Request, or Task ID in the edit box between 
the scroll buttons and press Enter.

Note: You cannot modify the attributes of an Incident, Change, Request, or 
Task in this dialog box. Do that in ServiceCenter.

Filtering ServiceCenter Record Items
To filter ServiceCenter record items:

1 Select View > All Tasks...

2 Right-click the Task Details dialog. 
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A menu with the following options appears: 

� Filter

� Show Pages

� Print Pages

� Show Contact

� View Task

3 Select Filter to open the Task Filter dialog. For more information, see Work 
Management Task Details Filter on page 128.

4 Select the values from the different tabs described in the following table. 

5 You can also set the filter options by selecting Options > Filters > Task 
Details....

Note: The filter option is not available in the Task Details dialog when it is 
invoked by selecting Views > Schedule Details....

Filtering locked Incidents, Changes, Requests, and Tasks
1 Do one of the following:

� Select Options > Filters > Schedule window.

� Right-click to invoke the shortcut menu from the Schedule window, then 
select Filter from the displayed menu.

2 Select Lock from the Data element combo box.

3 Select equal to from the Operator combo box.

4 Set the Value to Operator Lock.

Tab Function

Detail Allows you to select the Period start date, Period type, and Number of 
periods during which the filter will operate. You also can select to 
display Incidents, Changes, Requests, or Tasks that have already been 
completed and whether tickets from selected assignment groups are to 
be displayed. Use the drop down arrow menus to select from predefined 
options.

Operator Allows you to select which operator’s items will be displayed.

Category Allows you to select which Incident, Change, Request, and Task 
categories to display.

Contact Allows you to select whether items from specific contacts are to be 
displayed.
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5 Set the Logical field value to OR.

6 On the next line down, use the same values for Data element, Operator and 
Logical field, but choose Time Lock for the Value field, as shown in 
Figure 6-12. 

Figure 6-12: Schedule Window Filter Settings

7 Click Save to save the filter condition. If the new filter settings do not 
immediately take effect, clear the Schedule window setting to apply the filter. 

8 To apply the filter to the Schedule window, do one of the following:

� Select View > Schedule > Apply Filter.

� Right-click while in the Schedule pane to invoke shortcut menu, then click 
Apply Filter. 
Viewing Details in Work Management � 131



ServiceCenter
This changes the view in the main Schedule window, where the Operator and 
Time locked items are highlighted while others appear grayed.

Figure 6-13: Locked Work Management Schedule View

For more information, see Locking Tickets on page 152.

Filtering Incidents, Changes, Requests, and Tasks on Downtime

To filter on downtime:

1 Do one of the following:

� Select Options > Filters > Schedule window.

� Right-click to invoke shortcut menu from the Schedule window, then 
select Filter from the displayed menu.
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2 Select Downtime from Data element combo box, as shown in Figure 6-14.

Figure 6-14: Work Management Schedule Filter

3 Select greater than in the Operator combo box.

4 Specify 03:00:00 for the Value field.

5 Select OR in the Logical field.

6 Repeat steps 5 through 8 on another line; however, specify equal to for the 
Operator value.

7 Click OK to save the filter condition.

8 Do one of the following:

� If the Schedule window display does not refresh, applying the filter, select 
View > Schedule > Apply Filter.

� Right-click while in the Schedule pane to invoke shortcut menu, then click 
Apply Filter. 

This changes the view in the Schedule window, those items with a downtime 
greater than or equal to three days appear highlighted while others are 
dimmed.
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Task Details Dialog Box
The Task Details dialog box has three pages of information about the 
Incident, Change, Request, or Task:

� The Contact page, which provides details on the contact who reported the 
Incident, Change, Request, or Task. For more information, see Contact 
Page on page 135.

� The Operator Assignment page, which presents details on the operator 
assignment and the scheduled start date and time. For more information, 
see Operator Assignment Page on page 136.

� The Other page, which describes the nature of the Incident, Change, 
Request, or Task. For more information, see Other Page on page 137.

In addition to viewing information about an Incident, Change, Request, or 
Task, you can use the Task Details dialog box to create a new Incident, 
Change, Request, or Task, or edit existing Incidents, Changes, Requests, or 
Tasks.

Figure 6-15 shows navigation buttons at the top of the Task Details dialog 
box to help navigate through Incidents tickets, Change requests, Request 
quotes, and their associated tasks selected from the database.

.

Figure 6-15: Task Details: Contact Page

Navigation Buttons
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To the right of the scroll buttons you may see icons.

� If the icon is a human figure, the Incident, Change, Request, or Task is 
locked to the Operator.

� If the icon is a padlock and a human figure, the Incident, Change, Request, 
or Task is locked to the operator and time.

� If the icon is a flag, the Incident, Change, Request, or Task is set to Highest 
Priority.

Contact Page
Contact information has ten attributes, displayed in the fields of the Task 
dialog box and described as follows: 

Field Definition

Contact The name of the contact who issued this Incident, Change, 
Request, or Task is displayed in this field. If the contact name 
is not given, CONTACT_UNKNOWN is displayed

Expertise Level The required expertise to solve the Incident, Change, Request, 
or Task.

Category The ServiceCenter category that describes the record. 

Number The unique number assigned to each Incident, Change, 
Request, or Task.

Action The specific information about the contact request. This field 
cannot be edited.

Status The current resolution and alert status of the Incident, 
Change, Request, or Task and whether assigned yet, mapped to 
the respective fields in the probsummary table (file) in 
ServiceCenter.

Reported Date
and 
Reported Time

The date and time that the record was first entered into the 
system. 

Priority The level of immediacy that is associated with the record, 1 
being the highest priority level.

Assignment group The current assignment group associated with each Incident, 
Change, Request, or Task, and other groups available.

Total pages The number of times the record has been updated.
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Operator Assignment Page

Figure 6-16: Task Details: Operator Assignment page

The Operator page describes the assigned operator and the ongoing status of 
the Incident, Change, Request, or Task. The operator page also lists the 
Scheduling information for the record. Its fields are as follows:

Field Definition

Operator Identifies which operator has been assigned to the current 
Incident, Change, Request, or Task. The combo box of 
operators lists all operators; the operators that do not have 
the required expertise to complete the Incident, Change, 
Request, or Task are grayed. The manager can override the 
suggested list of operators presented by Work Management 
by choosing an operator that is grayed. 

Completed Indicates if the item is completed or not. 

Earliest start date
Earliest start time

User-entered earliest date/time for addressing task.

Schedule Travel time User-entered travel time schedule, if necessary.

Schedule start date
and 
Schedule start time 

Automatically entered by the system, recording when the 
Incident, Change, Request, or Task is allocated to an 
operator. 

Schedule Duration Updated by Work Management with the Duration estimate 
for the Incident, Change, Request, or Task category. 
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You can reschedule an Incident, Change, Request, or Task from this screen 
by entering in a new Start date or time. Modifications made from here are 
updated on the main Schedule window.

The Actual metrics for the Incident, Change, Request, or Task are also 
displayed on the Operator page. On completion, Work Management 
automatically updates the Actual Start date, Actual Start time, Actual Travel 
time, Actual End date, and Actual End time field with the values recorded by 
the operators as they complete the work. These fields are grayed out and 
inaccessible until the Incident has been marked as Completed, as noted by a 
Yes value in the Completed field.

Note: All operator details can be created, edited and deleted via the 
right-click shortcut menu, and the field's contents can be overwritten.

Other Page

Figure 6-17: Task Details: Other Incident or Change Information Page
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There are four different fields for adding and displaying information about 
an incoming item. The first two fields are user defined. Choose Options > 
User Defined Fields… in the Schedule window to select the field labels and 
combo boxes to be customized. For more information, see The Schedule 
Window on page 30.

Show Pages
Whenever a record is updated in ServiceCenter, a new page is created with the 
name, date and content of the update.

To view the pages of an item:

1 In the Task Details dialog, select the record.

2 Click the right mouse button to reveal a short-cut menu.

3 Do one of the following:

� Method 1: Select Show Pages.

� Method 2:

� Highlight an Incident, Change, Request, or Task on the Spreadsheet 
pane.

� Click the right mouse button to reveal a short-cut menu.

� Select Show Pages.

� Method 3:

� Highlight an Incident on the Schedule window pane.

� Click the right mouse button to reveal a short-cut menu.

� Select Show Pages.

Field Definition

Brief Description The overview information about the Incident, Change, 
Request, or Task, used for organizational or reporting 
purposes. Work Management does not require that the Brief 
Description field be filled in when creating new Incidents 
tickets, Change requests, Request quotes, and their associated 
tasks.

Update Action/

Resolution

The specific notes or resolution recorded about the Incident, 
Change, Request, or Task.
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At the bottom of the Show Pages dialog is a group of scroll buttons used to 
navigate through the pages of an Incident, Change, Request, or Task.

Note: Instead of using the right mouse button, you can also invoke Show 
Pages from the View menu.

The Show Pages option either shows the Show Pages dialog of ServiceCenter 
or that of Work Management. This can be configured only by the 
ServiceCenter Administrator.

Figure 6-18: Incident Pages

Printing Pages
To print the pages of an Incident ticket, change, task, or request: 

1 Click the Print button from the system tray in the ServiceCenter display if it 
is available.

2 Select File > Print screen to also print the record.
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Opening New Incidents, Changes, Requests, or Tasks
Incidents tickets, Change requests, Request quotes, and their associated tasks 
cannot be opened from within Work Management. All new Incident, 
Change, Request, and Task records must originate in ServiceCenter. 

See the ServiceCenter User’s Guide and the IM Tailoring Guide for more 
information on creating and opening ServiceCenter records.

Viewing Item Details in ServiceCenter

Once an Incident ticket has been opened and registered in ServiceCenter, if 
it is assigned to the Help Desk, Work Management detects it. This ticket is 
then in the Work Management mailbox (Unallocated count gauge) until it 
has been assigned to a specific operator on the Help Desk. The same is true 
for Changes, Tasks, and Requests as well.

To view Incidents, Changes, Requests, and Tasks from the mailbox:

1 Click the mailbox icon to reveal the list of unallocated items.

2 From the list that appears, select a record to view.

3 Double-click the selected item.

The selected record is displayed within the ServiceCenter form. 

4 Close the record by clicking OK or Cancel.

5 To view records from the Schedule window or Task dialog, double-click the 
colored ticket bar or spreadsheet listing in the Schedule window.

The record is displayed in the ServiceCenter format.

6 Close the record by clicking OK or Cancel.

Editing Tickets

Few fields (Expertise Level field on the Contact page, the Operator, 
Utilization, Earliest, and Schedule date/time fields on the Operators page, 
and the two user-defined Attribute fields on the Other page) are editable 
from within Work Management. The majority of modifications and edits to 
records must occur in ServiceCenter. See the ServiceCenter Quick Start Guide 
and PM Custom Guide for more information.
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To make edits to the fields accessible from within Work Management:

1 Figure 6-19 shows the Task Details form. For more information, see Viewing 
Details in Work Management on page 127.

Figure 6-19: Task Details

2 Move through the fields with the arrow keys.

3 Make the required changes. For the Expertise Level, Operator, and the 
Attribute fields, click the arrow (Fill) button to the right of the combo box. 

For the Percent Utilization, Earliest, and Schedule date or time values, 
position the cursor in the field and type in the new values.

4 Right-click to display the shortcut options menu.

5 Select Replace from the short-cut menu to save the changes to the database. 
This overwrites the contents of the record with the new information.
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Deleting Tickets
Tickets can only be closed and deleted from within ServiceCenter. See the 
ServiceCenter User’s Guide for more information.

Marking Tickets as Completed
Tickets can only be closed (marked as complete) from within ServiceCenter. 
Please see the ServiceCenter User’s Guide for more information.

Assigning Tickets to a Different Assignment Group
The Task Details dialog box displays only those Incidents tickets, Change 
requests, Request quotes, and their associated tasks associated with the 
defined assignment group(s). You can change the assignment group 
definition for Incidents tickets, Change requests, Request quotes, and their 
associated tasks viewed through the Task Details dialog box, however, 
definitions must be changed on the item record itself in ServiceCenter. See 
the ServiceCenter User’s Guide for more information.
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7
 Scheduling
This chapter describes scheduling in Work Management to for the 
ServiceCenter administrator, manager, or user. It has information about how 
to schedule, reschedule, lock, and unallocate Incidents tickets, Change 
requests, Request quotes, and their associated tasks, as well as how to use 
autoschedule functionality. 

Read this chapter for information about:

� Introduction on page 144

� Manual Scheduling on page 144

� Scheduling Controls on page 151

� Using the Auto Scheduler on page 156

� Resource Sharing on page 169
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Introduction

Work Management displays the schedule information, including assigned 
and unassigned Incidents tickets, Change requests, Request quotes, and their 
associated tasks, in the Schedule window for a specific manager. Work 
Management uses the manager’s login ID to identify which group of 
operators and tickets to present.

When auto scheduling is enabled, Work Management schedules incoming 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
to simultaneously minimize down time, maximize operator utilization, and 
account for Incident, Change, Request, or Task priorities.

Work Management permits each manager to schedule only Incidents tickets, 
Change requests, Request quotes, and their associated tasks that fall within 
the manager’s assignment group. Only operators assigned to the logged in 
manager are able to receive new Incidents tickets, Change requests, Request 
quotes, and their associated tasks. Each manager maintains an independent 
schedule of work. In this way, Work Management supports multiple work 
schedules, each pertaining to different functional areas of the organization.

Contact, category, and operator data are also displayed from the menu 
options on this screen. The main function of the Schedule window, however, 
is to display the current status of an assignment group; schedule Incidents 
tickets, Change requests, Request quotes, and their associated tasks; and 
analyze team performance.

For more information, see Background Scheduling on page 183.

Manual Scheduling

Mailbox Method
From the Schedule window, a manager manually assigns Incidents tickets, 
Change requests, Request quotes, and their associated tasks to operators by 
dragging them from the mailbox onto an operator’s line in the Schedule 
pane.
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To schedule from the mailbox:

1 Click the Unallocated count gauge shown in Figure 7-1. 

Figure 7-1: Unallocated Count gauge

2 The Mailbox opens. Figure 7-2 shows the mailbox list.

Figure 7-2: Work Management Mailbox

3 Click an Incident, Change, Request, or Task. 

Closed

Open
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4 Hold down the left mouse button, drag and drop the selected item into an 
operator’s line in the Schedule window.

Figure 7-3: Manual Scheduling

When dragging the Incident, Change, Request, or Task from the mailbox, 
Work Management grays out the operators that lack the necessary expertise 
to handle it. The list of acceptable operators remains enabled. However, you 
can assign Incidents tickets, Change requests, Request quotes, and their 
associated tasks to operators, even if they do not have the expertise to handle 
them.

You can drop Incidents tickets, Change requests, Request quotes, and their 
associated tasks anywhere on the timescale, as long at they fall after the 
Reported date and time for the Incident, Change, Request, or Task.
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Task Details Dialog Box Method
A manager may also assign Incidents tickets, Change requests, Request 
quotes, and their associated tasks to an operator by updating the Operator, 
Scheduled Start date and Scheduled Start time information using the 
following process.

To schedule from the Details dialog box:

1 Click an Incident in the Spreadsheet pane of the Schedule window. 

2 Scroll through the records using the scroll bar until you reach an unassigned 
item, usually at the bottom of the list and containing no operator name in the 
Operator column.

3 Open the Task Details dialog box by right-clicking on the record and 
selecting More Details from the short-cut menu.

4 Click the Operator tab to open the Operator page of the Schedule Details 
dialog box. 

5 Assign an operator to the item by clicking the arrow button on the Operator 
combo box and selecting an operator from the drop-down list. 

This box lists all operators associated with the assignment group. Work 
Management grays out the names of operators without experience to resolve 
this Incident, Change, Request, or Task. Those who have the required 
expertise to complete the item appear in black. 
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6 Enter the Earliest and Schedule date and time values. 

Figure 7-4: Task Schedule Details

7 Double-click the ServiceCenter icon in the upper left corner to close the 
dialog box.

You are prompted to confirm whether your changes are to be saved or 
canceled.

8 Select Yes to save the changes, or No to reject the changes.

You are returned to the Schedule window.

These changes are reflected in the Work Management Schedule window of 
the appropriate manager (according to the associated assignment group for 
the Incident).

4

5

6

7
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Incidents tickets, Change requests, Request quotes, and their associated tasks 
that are placed in positions that overlap in the timescale of the Schedule 
window are put on another line for that operator. 

Figure 7-5: Multiple Schedule Rows

Multiple Rows
Listed below are the instances where multiple rows for an operator are 
created:

� When the operator or manager drags and drops an Incident, Change, 
Request, or Task over another Incident, Change, Task, or commitment, 
this results in overlapping of the bars. Multiple rows are created to remove 
the overlapping.

� Assigning Incidents tickets, Change requests, Request quotes, and their 
associated tasks from the Task details dialog box can result in Incidents 
tickets, Change requests, Request quotes, and their associated tasks being 
assigned at the same time to the same operator. This results in overlapping 
of the bars. Multiple rows are created to remove the overlapping.

� If there are Incidents tickets, Change requests, Request quotes, and their 
associated tasks with varying percent utilization, Auto Scheduling and 
Compact may result in more than one Incident, Change, Request, or Task 
assigned to an operator within the same time frame. In this case again, the 
Schedule window displays the bars on different rows.
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To correct the overlap manually:

1 Drag and drop the items to rearrange the placement of Incidents tickets, 
Change requests, Request quotes, and their associated tasks. 

2 Select Operations > Re-arrange to remove extra rows beneath an operator. 

To automatically correct any scheduling conflict:

� Select Operations > Compact > All to remove any scheduling conflicts.

Rescheduling Records
You use the same drag and drop method used to assign tickets from the 
mailbox to change the Scheduled Operator, Date, and Time of an Incident, 
Change, Request, or Task.

To reschedule:

1 Click any item in the Schedule window.

2 Press and hold the left mouse button to select the Incident, Change, Request, 
or Task. 

3 Drag the item to another operator’s line.

4 Release the mouse button.

The status bar at the bottom of the window displays more information on 
where you are moving the Incident, Change, Request, or Task.

Important: Work Management uses the defined areas of expertise to 
determine which operators can handle a given issue. However, 
you can assign Incident tickets to operators who do not have the 
expertise to complete them. If you use the auto scheduler after 
assigning a ticket to an unqualified operator, the Incident, 
Change, Request, or Task is unallocated and, if possible, 
reallocated to an operator who has the necessary expertise.

Note: Incidents tickets, Change requests, Request quotes, and their 
associated tasks can be rescheduled to any point in time after the initial 
Reported date and time.

As you move the Incidents tickets, Change requests, Request quotes, and 
their associated tasks, and modify the schedule, the performance gauges at 
the top of the screen automatically update the information in the Downtime, 
Workload, and Operator Utilization gauges to reflect the changes.
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Scheduling Controls

Show Dependency
This option displays the dependency between the parent change and the child 
tasks. To see the dependency between a change and task, both the change and 
the task should be visible in the Schedule window. The system will not display 
dependencies for unassigned Changes, Tasks, and Requests.

Note: If both Apply filter and Show Related are applied, Show Related takes 
precedence for display. The schedule filter is applied only after Show 
Related is unchecked.

To display a connector between a parent change and a child task:

1 Allocate the parent change and child tasks to operators.

2 Scroll to put the parent change or child tasks in the Schedule window.

3 Do one of the following:

� Select View > Schedule > Show Related.

� Click the right mouse-button on a change task, or request to display a 
shortcut menu, and select Show Related.

Figure 7-6 shows the dependency between the parent change 1002 and child 
task 10011.

Figure 7-6: Parent-Child Connection
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Locking Tickets
You can lock Incidents tickets, Change requests, Request quotes, and their 
associated tasks at their present position in the Work Management Schedule 
window. Locking Incidents, Changes, Requests, or Tasks prevents the Auto 
scheduler from assigning them to either another operator or another time. 
You have the option of locking an item to a specific operator or to both a 
specific operator and time. If an Incident, Change, Request, or Task is locked 
to an operator only, the scheduled date and time for the item may change. 
Locking both the operator and the time will prevent this from occurring.

If you want to assign an Incident, Change, Request, or Task to an operator 
who does not have the expertise, and if you do not want the Auto scheduler 
to unallocate or reassign it, you can lock the ticket.

To lock an Incident ticket, change, task, or request:

1 Select a particular Incident, Change, Request, or Task in the Schedule 
window, Spreadsheet pane, or Schedule Detail dialog box.

2 Select Operations > Lock. A submenu opens to the right.

3 Select either the Operator lock or the Operator & Time lock option. 

From the keyboard, you can also use the Ctrl+L key combination to activate 
the Operator lock and the Ctrl+K key combination to activate the Operator 
& Time lock.

Once locked, the Incident, Change, Tasks, or Requests bar displays one of 
two icons:

� For an Operator lock, a human figure appears. 

� For an Operator and Time lock Work, a tiny padlock and human figure 
appear.

4 If you are in the Schedule window (as shown above) pull down the Schedule 
menu. Select the Save option to record the changes to the locked ticket.

5 Do one of the following:

� If you are in the Task Details dialog box, right-click to reveal the Edit 
menu.

� Pull the Task menu down from the menu bar behind the Schedule 
window.

6 Select the Replace option from either menu to save the changes to the locked 
item. 
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To Unlock an Incident ticket:

1 Select a particular Incident in the Schedule window, Spreadsheet pane, or 
Schedule Detail dialog box.

2 Select Operation > Lock. 

The type of lock currently applied to the Incident will have a check mark 
beside it. 

3 To remove the lock, select the appropriate menu option. 

Work Management automatically returns the Incident, Change, Request, or 
Task to an unlocked status.

Establishing Highest Priority
You may want to schedule one Incident, Change, Request, or Task ahead of 
all other items, whatever the current item priority is. You can do this by 
declaring that the Incident, Change, Request, or Task is of highest priority.

To declare an Incident priority status as Highest Priority:

1 Select the particular Incident, Change, Request, or Task in the Schedule pane.

2 Select Operations > Highest Priority.

You can also use the Ctrl+H keys to perform the same function from the 
keyboard.

The item bar in the Schedule pane displays a flag icon. You can customize 
Work Management so that the color will change also. For more information, 
see Taskbar Tab on page 176. 

Note: If you are in the Schedule window, pull down the Schedule menu.

3 Select the Save option to record the changes to the locked ticket.

4 If you are in the Task Details dialog box, right-click with the mouse to reveal 
the Edit menu, or pull the Task menu down from the menu bar behind the 
Schedule window.

5 Select the Replace option from either menu to save the changes to the locked 
ticket. 
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Unallocating Incident tickets
Incidents tickets, Change requests, Request quotes, and their associated tasks 
that are not scheduled are considered unallocated. Incidents tickets, Change 
requests, Request quotes, and their associated tasks that are unallocated are 
not deleted from the system, but are available for future scheduling.

To unallocate an Incident, Change, Request, or Task currently scheduled to 
an operator:

1 Highlight the Incident, Change, Request, or Task.

2 Select Operations > Unallocate.

You can also use the Ctrl+U keys to perform the same function from the 
keyboard. 

This action moves the Incident, Change, Request, or Task back to the 
mailbox. The system prompts you with a message asking for your 
confirmation. The number of Incidents tickets, Change requests, Request 
quotes, and their associated tasks in the mailbox is updated dynamically to 
reflect changes to the schedule.

Viewing and Editing Operator Details
1 In the Schedule window click an operator in the Operator column.

2 Double-click the name to open the Operator dialog box. 

The dialog box lists the operator details for all of the operators assigned to the 
logged in manager. The following information is included: the login ID, 
outstanding count (the number of outstanding Incidents, Changes, 
Requests, or Tasks currently assigned), areas of expertise, and two 
user-defined fields.

3 To edit any of these values, you must determine if these changes need to be 
made in ServiceCenter to appear in the Operator dialog box. For more 
information, see Viewing and Editing Operator Information on page 96.

Percentage Utilization
A task may take a duration of one month to be resolved or completed, but 
this does not mean that it requires an effort of 100% during that time. The 
manager can identify the percent utilization required to complete these tasks. 
Percent utilization can be defined for all imported ServiceCenter records.
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For example, an operator is assigned a task with a duration of two hours and 
with percent utilization of 50%. This means this operator can be assigned 
with another task at the same time, with a percent utilization less than or 
equal to 50%. 

To define the percent utilization, use the following process:

1 Highlight an Incident, Change, Request, or Task with the mouse pointer. 

2 Click with the right mouse button to display a shortcut menu.

3 Do one of the following:

� Choose More Details.

� Select an Incident, Change, Request, or Task.

4 Select View > Schedule Details.

The Task Details dialog box is displayed.

Figure 7-7: Ticket Details

5 Go to the Operator page in the Task Details dialog box. 

6 Change the value in the Percent utilization field. 

You can select a number between 10% and 100%. By default the value will be 
100%. 

Note: For all completed tasks Percent utilization is always 100%.
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If the Percent utilization is less than 100%, the operator can be assigned 
additional tasks in the remaining availability, which may result in multiple 
rows of assigned Incidents tickets, Change requests, Request quotes, and 
their associated tasks. 

For example, if change 1001 has a percent utilization of 50%, Incident 
IM1002 a percent utilization of 30%, and request 1003 a percent utilization 
of 20%, and if all these tasks are 2 hours long, then they all can be assigned to 
the same operator with a Schedule start time at 9 a.m. and end time 11 a.m. 
on the same day. This is possible because the effort percent utilization for all 
these Incidents equals 100% and therefore can be fit within the same time 
period.

Using the Auto Scheduler

Work Management provides the option to enable automatic scheduling. 
When the number of Incidents, Changes, Requests, or Tasks to be scheduled 
exceeds twenty four, the thousands of possible schedule combinations make 
it impossible for the user to manually generate the best schedules. It becomes 
difficult to find a schedule that meets all possible metrics. The automatic 
scheduling option manages both schedules and metrics to formulate an 
on-the-fly schedule that satisfies the greatest needs.

Automatic scheduling affects only those Incidents tickets, Change requests, 
Request quotes, and their associated tasks; and operators assigned to the 
manager currently logged into Work Management. The Automatic 
scheduling option does not affect the schedule for any of the other managers 
in the organization.

When scheduling Incidents tickets, Change requests, Request quotes, and 
their associated tasks, Work Management is bound by several guidelines. 

User-defined parameters include:

� Overall priority for Incidents tickets, Change requests, Request quotes, 
and their associated tasks

� Required minimum operator expertise

� Operator areas of expertise

� Operator availability/commitment
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� Downtime that increases priority

� Percent utilization for each Incident, Change, Request, and Task

Scheduling Criteria

Priority
Work Management creates an overall priority for each Incident, Change, 
Request, and Task, based on its status and severity. Work Management then 
uses a priority lookup table to determine an overall priority. Overall priority 
affects the way Incidents tickets, Change requests, Request quotes, and their 
associated tasks are automatically scheduled — Incidents tickets, Change 
requests, Request quotes, and their associated tasks with a higher priority are 
scheduled earlier in time than Incidents tickets, Change requests, Request 
quotes, and their associated tasks with a lower priority.

Incident, Change, Request, and Task priorities are not fixed. As Incidents 
tickets, Change requests, Request quotes, and their associated tasks wait to be 
resolved, they can escalate in priority and receive more preference during 
scheduling. The amount of time required to increase the priority of an 
Incident, Change, Request, and Task is determined by the Downtime that 
increases priority value. This value appears in the Category dialog box. 

To access the Category dialog box, select View > Category. For more 
information, see Viewing Categories on page 66.

Note: The Auto scheduler schedules based on the priority of Incidents 
tickets, Change requests, Request quotes, and their associated tasks, 
apart from other considerations. The overall priority of an item is 
arrived at from the Status and Severity of an Incident, Change, 
Request, or Task.

The priority for a particular combination of Status and Severity, is 
determined by the System ServiceCenter Administrator. A lookup table 
is maintained in the Work Management database that is used while 
scheduling.

The priority of an Incident, Change, Request, or Task is seen in the 
Schedule window in the form of colors. The color for the status or 
priority is defined in the Schedule window tab of the Customize dialog. 
For more information, see Information Box on page 177.
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Operator Attributes
Work Management also uses the attributes of operators to determine 
whether or not they can resolve particular Incidents, Changes, Requests, or 
Tasks. Operators are assigned Incidents tickets, Change requests, Request 
quotes, and their associated tasks only if they have the required areas and 
levels of expertise, and they are available to do the work. 

To define operator attributes for those operators assigned to the manager 
who is currently logged in:

� Select View > Operator to open the Operator dialog box. 

The Operator dialog box displays information for only those operators 
assigned to the current manager. For more information, see Viewing and 
Editing Operator Information on page 96.

Downtime
There are many possible schedules the Auto scheduler can generate that 
satisfy the established conditions for operator commitment and priority. 
Unless you choose not to schedule based on priorities, the objective of the 
scheduler is to minimize the organizational downtime and to optimize the 
operator utilization or load. 

In terms of downtime, Incidents tickets, Change requests, Request quotes, 
and their associated tasks are scheduled so that the overall wait time for your 
contacts is the least possible. At the same time, all of the Incidents tickets, 
Change requests, Request quotes, and their associated tasks are evenly 
distributed between operators with the needed expertise. Only the schedule 
that meets the required constraints and has the best values for downtime and 
operator utilization is selected.

For an example of how downtime can affect the order in which Incidents 
tickets, Change requests, Request quotes, and their associated tasks are 
scheduled, take a case where two contacts have reported Incidents to the help 
desk. Contact A, with a difficult Incident that requires 7 hours to complete, 
reports the Incident before Contact B. Contact B has a small Incident that 
only requires 1 hour to complete. Both Incident tickets are assigned to the 
same operator. As happens in many cases, Contact A's Incident will be 
scheduled before Contact B because Contact A reported the Incident first.
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For example, Contact A has a downtime of 7 hours, which is simply the 
amount of time required to resolve the Incident. Contact B has a downtime 
of 8 hours: 1 hour to complete the Incident, but 7 hours of waiting while the 
operator completes Contact A's Incident first. In this case, the organizational 
downtime (the sum of Contact A’s and Contact B's individual downtimes) is 
15 hours.

Rearranging the order in which these two Incident tickets are completed 
reduces the downtime to the organization. 

By resolving Contact B's shorter Incident first, the overall downtime to the 
organization drops from 15 hours to 9 hours — a 40% improvement. In the 
schedule shown below, Contact B has an individual downtime of 1 hour and 
Contact A, who waits 1 hour for the technician to start work, has a downtime 
of 8 hours.

If you set Work Management to focus on priorities, the highest priority 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
are scheduled before the rest, even if it creates a greater organizational 
downtime. Once priorities have been accounted for, Work Management 
seeks to minimize the downtime and maximize the operator utilization.

When creating schedules, locked Incidents tickets, Change requests, Request 
quotes, and their associated tasks are left as is. Other Incidents tickets, 
Change requests, Request quotes, and their associated tasks are scheduled 
around the locked item.

The schedule is not automatically saved, so you can explore various 
scheduling scenarios by rearranging Incidents tickets, Change requests, 
Request quotes, and their associated tasks before you decide to save the 
schedule. 

To have the schedule created automatically:

1 Select Options > Customize.

2 Choose Background Scheduling on the Schedule window tab. For more 
information, see Background Scheduling on page 183.
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Configuring the Scheduler
To achieve the most efficient schedule for your needs, you must provide the 
scheduler with information specific to your operation. 

To Autoscheduler tasks:

1 Select Operations > Autoschedule... > All (or the name if the operator). 

The Autoschedule window will appear.

Figure 7-8: Autoschedule Settings
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1 Select the desired settings.

2 Click OK to have create the schedule automatically, or click Cancel to exit 
with out scheduling.

3 Examine the schedule and edit it if desired. 

4 Click Save on the Work Management Schedule menu to keep the changes or 
exit Work Management without saving them.

Fine Tuning the Schedule
Although Work Management attempts to generate an optimal schedule, 
there are often special considerations in assigning Incidents tickets, Change 
requests, Request quotes, and their associated tasks to operators. A manager 
may want to cater to special situations. (For example, the Sales department 

Field Definition

Start Allows the user to enter specific dates and times for beginning 
the Auto scheduler, enabling a future or current start date or 
time to be set.

Select Requires the user to specify which Incidents tickets, Change 
requests, Request quotes, and their associated tasks are to be 
affected by autoschedule actions. Selecting All incidents or 
Unallocated incidents only includes items currently in the 
mailbox, scheduling them to users automatically. Allocated 
incidents only rearrange Incidents, Changes, Requests, or 
Tasks currently in the queue of one of the operators.

Priority Allows the user to exclude the priority component when 
determining the most efficient schedule. This places the 
components of Downtime and Operator Attributes as the 
prime criteria.

Location Allows the user to schedule based on where the specified issue 
is located.

Dependency Allows the user to schedule based on which issues’ resolutions 
are contingent upon the resolution of other issue(s).

Earliest start date Allows the user to schedule based on which items can be 
started on the soonest.

Forced Allocations Allows the user to schedule tasks based on the Force 
Allocation option in the More Details dialogue box. Tasks will 
only be scheduled for the allocated operator.
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needs special attention this week, or the Purchasing department manager 
only wants certain people to help him). Catering to special constraints can 
require the user to make adjustments to the schedule generated by the 
autoscheduler. These are quickly performed using manual drag-and-drop 
procedures from the Schedule window. For more information, see 
Rescheduling Records on page 150.

Refreshing the Schedule
The status of the Help Desk is constantly changing. The Refresh option 
allows you to update the current schedule with any changes to the status of 
scheduled Incidents tickets, Change requests, Request quotes, and their 
associated tasks, allowing the manager to keep abreast of which items are 
completed and which are ongoing.

To refresh the schedule:

� Select Schedule > Refresh All from the Schedule window.

From the keyboard, you can activate the Refresh function by using the Ctrl+R 
keys.

The Schedule window is automatically updated with any changes made to the 
status of Incidents tickets, Change requests, Request quotes, and their 
associated tasks.

Using Compact
The autoscheduler will not move the Operator & Time locked Incidents 
tickets, Change requests, Request quotes, and their associated tasks, as a 
result you may have gaps in the schedule. The Compact feature is useful after 
you fine tune a schedule. After a number of drag and drop operations, there 
are likely to be gaps among Incidents tickets, Change requests, Request 
quotes, and their associated tasks, depending on where the items were placed 
in the schedule. You can remove the gaps by compacting the schedule. You 
can compact Incidents tickets, Change requests, Request quotes, and their 
associated tasks for a particular operator or the entire schedule.

Compacting will not alter the sequence of the Incidents tickets, Change 
requests, Request quotes, and their associated tasks; it places all items one 
after the other, without any breaks or gaps between them. Compacting the 
schedule will also move the start of the schedule to correspond to the start of 
the current Timescale.
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To compact the schedule:

1 Select Operations > Compact from the Schedule window.

2 Do one of the following:

� Select an operator’s name from the Compact sub-menu to compact the 
Incidents tickets, Change requests, Request quotes, and their associated 
tasks of a particular operator.

� Select Operations > Compact from the Schedule window.

3 Select All to compact all Incidents tickets, Change requests, Request quotes, 
and their associated tasks displayed in the Schedule window. 

You can also access the Compact feature from the keyboard by using the 
Alt+R or Alt+A keys respectively.

Note: You have the option to instruct the Compact function not to move any 
Operator & Time locked Incidents, Changes, Requests, or Tasks. In 
this case, gaps between Incidents tickets, Change requests, Request 
quotes, and their associated tasks might continue to exist.

Saving the Schedule
Saving the schedule updates the Operator with all of the current operator 
assignments. If you are using the Background scheduling function, the 
schedule is automatically saved. However, if you are manually scheduling 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
or fine tuning an existing schedule, you will need to save the changes.

To save the current schedule:

1 Pull down the Schedule menu from the Schedule window.

2 Select the Save option.   

From the keyboard, you can also access this function by using the Ctrl+S keys.

The status bar at the bottom of the screen indicates the current schedule is 
being saved.

Travel Time
This functionality enables travel time to be automatically added to the task 
based on the location the task is to be worked on. In addition allow the user 
modify this default travel time.
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The amount of time, if any, required for an operator to reach the location of 
the task to which he has been assigned. Work Management utilizes two forms 
of travel time: Estimated travel time and Actual travel time. Estimated travel 
time is the theoretical time value entered into the system prior to the 
beginning of the task. After the task has been completed and the information 
updated, Work Management will calculate the actual travel time associated 
with that location. Actual time is calculated by averaging all the past travel 
times to a specific location. For example, if an operator has traveled three 
times to location A with each trip lasting 20, 25, and 30 minutes respectively, 
the actual travel time would be 25 minutes. 

The Actual travel time is calculated by averaging all past travel times if the 
tasks are closed and the Actual Start Date\Time, Actual End Date\Time and 
the Actual Travel time are entered in Service Center before closing the task.

Any default Travel time can be associated to a location using the 
View/Location menu in Work Management in days:hours:minutes 
(00:00:00) format (this populates the field wdTravelTime in seconds in the 
location table). This is the time taken by an operator to travel from the home 
office to customer's location (place of work) and back to the office.

Any default Duration can be associated to a task category using the 
View/Category menu in Work Management in days:hours:minutes 
(00:00:00) format. (This is populated in the wdClsDuration field in seconds 
in the wdCategory table.)

Manual Drag and Drop
Once a task is manually dragged out from the Mail Box to assign to an 
operator, the length of a Task bar on the Schedule window is drawn based on 
the {(default duration from the category table adjusted for skill level) +   
(default travel time from the location table)}

At this point the user can save the task on the schedule window and the 
default values are saved (into the wdSchDuration and wdSchTravelime field 
in the work table) and can be seen in the Schedule Duration and Scheduled 
Travel time field in the Operator tab in the Mode details dialog in Work 
Management.

The user also has the option to modify the value in the Schedule Duration or 
and the Scheduled Travel Time field in the Operator tab in the More Details 
dialog and then save.
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Note: If the user has modified the Scheduled Travel time value in More 
Details dialog and then for some reason unallocated the task back to 
the Mail box, the modified value of the Scheduled Travel time will 
always be used (and not the default Travel time) once the task is 
reassigned to another operator and a Save AND Refresh is done.

Advisor and Auto Schedule

If any of these above two methods are used to assign tasks to operators with 
the Location option checked, the system will ensure that for a given day, if a 
task of one location is assigned to an operator with a travel time then a second 
task of the same location will be assigned to the same operator (assuming that 
the operator has the skill for the task's category) making the Scheduled Travel 
time = Zero

Other Information
� For those tasks for which locations have not been defined a default value 

of Travel time can be set in the wdCodeDetails table (wdCodeType = 205, 
wdCodeID = 0 and wdCodeDesc = <default travel time in seconds>.

� In the Mode Details dialog the Schedule Travel time displays blank (read 
only) if the Task is unassigned. Values are displayed and modified only if 
the task is assigned to an operator. 

� Value in Travel time field in the Bottom spread and in Mail box after a 
Save AND Refresh: 

� The Travel time field in the Bottom spread and Mail box displays the 
default value of Travel time from the location table or the actual value 
if modified by the user in the Schedule Travel time field in the More 
Details dialog.

� If the task is not associated to any location then the Travel time field in 
the Bottom spread and Mail box displays the value as set in the 
wdCodeDetails table.)

Defining Travel Time and Location
Work Management calculates operator travel time associated with locations 
when scheduling work. For example, if an operator in location A requires 30 
minutes to travel to an assignment in location B, and the task itself requires 
1 hour, Work Management will schedule the task has having an overall 
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duration of 2 hours (1 hour round trip travel time and 1 hour to resolve the 
task). In order to accomplish this, travel times must be entered into the 
System through the Location dialog. After travel times have been estimated, 
Work Management will update these times with actual values. 

Travel time is based on the time it takes for the operator to travel from some 
central location to the location of the task. In the example above, example 
Location A is the Manager’s office (this is a central location for the basis of 
using travel time) and Location B is the location of the task. 

To define, view, or edit travel times from the Location dialog box:

1 Select View > Location from the main menu. This brings up the Location 
dialog box.

2 Find the location you wish to view or edit. (If there are more than twelve 
locations you may have to scroll through the list).

3 Double click in the Travel time column and enter time value associated with 
the location you wish to define/edit. Make sure to enter the time in 
days:hours:minutes (00:00:00) format. (All travel times are null by default).

4 Click Recalculate to update travel time values with actual values, if actual 
values are entered in closed tasks for the same location by the users.

5 Click Refresh to update scheduled task durations with the new travel time 
values. 

6 Click OK to accept changes or Cancel to ignore.

After a task has been scheduled, the travel time can be edited in the Task 
Details.

Note: Travel time cannot be edited in the Task Details dialog box until a task 
has been scheduled. 

To edit travel times from the Task Details dialog box:

1 Right click on the task from the Task Details dialog box. 
A popup window is displayed.

2 Select More details.
The Task Detail window is displayed. 
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3 Select the Operator tab.

Figure 7-9: Task Details — Operator Tab

4 Enter the Travel Time in the Schedule travel time text box. 

5 Click  to go on to the next task. When the necessary changes have been 

made click  to exit. 

6 Click Yes to save your changes when prompted. 

Allocating Tasks Across Commitments
Incidents tickets, Change requests, Request quotes, and their associated tasks 
can be allocated over commitments (For example, breaks, meetings, shared 
resource time.) using the Auto schedule and Compact options. When an 
Incident, Change, Request, or Task is allocated over a commitment, the 
duration of the commitment is added to the Incident, Change, Request, or 
Task duration. The Incident, Change, Request, or Task bar in the Schedule 
window is displayed longer than its actual duration, to account for the time 
spent on the commitment. 

Note: The Schedule spreadsheet, Task Details dialog box, and information 
box display the actual duration of the Incident, Change, Request, or 
Task, however, rather than the elongated duration.
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When you drag and drop an item which has occupied a space with a prior 
commitment, the size of the Incident, Change, Request, or Task bar reduces 
to the original duration.

The following is an example of how an Incident, Change, Request, or Task 
can be scheduled over a Commitment:

� IM1001 has a percent utilization of 50% and a duration of 1 hour and 
IM1002 has a percent utilization of 50% and duration of 2 hours. These 
two Incidents are allocated to operator Kim Dickens with schedule start 
date as 01/04/99 and start time as 9 a.m..

� Operator Kim Dickens has an Operator Commitment with start date as 
01/04/99 and start time as 10 AM and end time as 12 PM.

To allocate PM1002 over the Operator Commitment:

1 Select operator Kim Dickens in the Schedule window.

2 Select the Compact option from the Operations menu. 

The bar of PM1002 starts at 9 a.m. and ends at 1 p.m.. The elongated 
duration of PM1002 is 4 hours, as the duration of the Operator Commitment 
is added with the actual duration of the bar.

The following is the Schedule window of Kim Dickens:

Figure 7-10: Assignment Extending through Commitment
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Resource Sharing

Each operator in Work Management is assigned primarily to a manager. This 
primary manager has to manage and allocate Incidents tickets, Change 
requests, Request quotes, and their associated tasks to the team of operators. 
Resource sharing becomes a factor in the scheduling equation when the 
primary manager lends or shares an operator to another manager for a 
specified period of time. The manager who loans the operator is referred to 
as the secondary manager.

The secondary manager schedules Incidents tickets, Change requests, 
Request quotes, and their associated tasks to the shared operator during the 
period of availability of the operator. The secondary manager sees his 
standard operator as well as the operator shared by the other manager in the 
Operator pane of the Schedule window and in the Operator dialog box. A 
visual cue — * — in the Operator pane identifies the shared operator to the 
secondary manager.

A green hatched bar titled Not Available appearing in the Schedule window 
of the secondary manager indicates the time when the shared operator is 
unavailable. The secondary manager cannot auto-schedule, drag-and-drop 
or compact Incidents, Changes, Requests, or Tasks to that shared operator 
during those periods. A secondary manager cannot lend a shared operator to 
another manager. 

In the Schedule window of the primary manager, a hatched green bar with 
the secondary manager's name indicates with whom that operator is shared 
and over what time period that operator is unavailable.

When a shared operator logs in, the system displays a list of managers to 
whom this operator has been assigned and shared. 

This list contains the primary and secondary manager names: 

� If the operator wishes to see the Incidents tickets, Change requests, 
Request quotes, and their associated tasks assigned by the primary 
manager, selecting the primary manager name displays that schedule. 

� If the Operator wishes to see the Incidents tickets, Change requests, 
Request quotes, and their associated tasks assigned by the secondary 
manager(s), selecting the respective secondary manager name from the 
Manager list displays the corresponding schedule.
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Sharing Example
The following example provides a practical process of resource sharing. 
MAX.MANAGER wishes to lend operator JENNIFER FALCON on every day 
for two hours between 10 a.m. to 12 p.m. for the month of April 2002 to 
manager ISP ADMIN 3. 

To share an operator:

1 Select the Operator name in the Schedule window. For this example, select 
FALCON, JENNIFER. 

2 On the View menu, select Operator Commitment….

Figure 7-11: Operator Commitment Window

3 Enter a From date, for example, 3/1/02 

4 Enter a To date, for example, 4/1/02.

5 Select <All Days> in the Weekday field.

6 Enter a From time, for example, 10:00 AM 

7 Enter a To time, for example, 12:00 PM.

8 Select a commitment type, Shared in this example.

9 Select the manager with whom the resource is to be shared, ISP ADMIN 3 in 
this example, in the Share to field.

10 Click OK to process and schedule the share.
170 �Chapter 7—Scheduling 



Work Management
A green hatched bar shown in the MAX MANAGER’s Schedule window 
indicates that JENNIFER FALCON is shared with ISP ADMIN 3 during the 
specified time.

Figure 7-12: Shared Operator as Seen by MAX MANAGER

When ISP ADMIN 3 logs into Work Management, the Schedule window 
displays JENNIFER FALCON in the Operator pane for the entire month of 
March 2002. ISP ADMIN 3 can assign Incidents tickets, Change requests, 
Request quotes, and their associated tasks to Jennifer, but the Schedule time 
must be between 10 a.m. to 12 p.m.

Figure 7-13: Shared Operator as Seen by ISP ADMIN 3 
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CHAPTER

8
 Creating Custom Configurations
This chapter describes how to customize Work Management if you are a 
ServiceCenter administrator or manager. It describes customization options 
and procedures to tailor the Work Management environment to fit your 
specific business needs. 

Read this chapter for information about:

� Introduction on page 174

� Customize... on page 175

� User Defined Fields on page 189

� Filters on page 192
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Introduction

Several aspects of Work Management can be customized to your 
requirements. These include scheduling options, presentation formats, and 
modifications to the performance gauges. The options are accessed through 
the Options menu.

The Options Menu

Menu Item Definition

Timescale Opens the Timescale dialog box to allow changing of the 
timescale. For more information, see Work Management 
Time Scale Configuration on page 47.

Customize Opens the Customize dialog box to allow changing of system 
options. For more information, see Customize... on 
page 175.

User-defined Fields Opens the User-defined Fields dialog box to allow editing of 
user-defined fields. For more information, see User Defined 
Fields on page 189.

Filters Opens the filter option controls. For more information, see 
Filters on page 192.
Contact: Opens Contact filter setup dialog box, where the 
user specifies which contacts should be known when the 
Contact dialog is opened. For more information, see 
Filtering the Contacts List on page 63.

Task Details: Opens the Incident/Change Details filter setup 
dialog box, where the user specifies conditions which are 
used to filter Incidents tickets, Change requests, Request 
quotes, and their associated tasks. Only tickets which satisfy 
these conditions are displayed in the All Incident ticket 
Details window. For more information, see Filtering 
ServiceCenter Record Items on page 129.

Schedule Window: Opens the Schedule Filter dialog box, 
where the user specifies conditions which are used to control 
how Incident, Change, Request, and Task data is organized 
in the Schedule pane of the Schedule window. For more 
information, see Filtering the Schedule Window on page 38.
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Each manager can configure the way Incidents, Changes, Tasks, and other 
pertinent schedule information is displayed. Changes made to the 
configuration of Work Management are saved with the manager ID. Each 
time that manager logs into Work Management, the options used are saved 
for subsequent sessions.

Customize...
Work Management allows you to customize the performance gauges, 
Incident, Change, Request, and Task summaries, and even the colors 
associated with different item priorities. 

To open the Customize dialog box:

1 Pull down the Options menu from the Schedule window.

2 Select the Customize…option. 

The Customize dialog box is divided into the following tabs: 

� The Taskbar tab of the Customize Dialog box affects the appearance of 
data displayed on the Task bar in the Schedule window, containing the 
customize options for the bar caption, information box, and bar colors. 
For more information, see Taskbar Tab on page 176.

� The Schedule window tab of the Customize dialog box affects the 
management of data displayed in the Schedule window, containing the 
customize options for the priority weightages, overall downtime 
threshold, gauge panel, utilization figures, and operator list order. For 
more information, see Schedule Window Tab on page 180.

� The Others tab of the Customize dialog box is used to customize 
background scheduling and knowledge base support. This tab is also used 
to view how the category duration is calculated and the expertise levels 
defined by Work Management. For more information, see Others Tab on 
page 186.
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Taskbar Tab
The Task bar tab of the Customize Dialog box effects the appearance of data 
displayed on the Task bar in the Schedule window, containing the customize 
options for the bar caption, information box, and bar colors.

Figure 8-1: Customize Dialog Box — Taskbar Tab

Panels in the Taskbar Tab include:

� Caption

� Information Box

� Drag and Drop

� Colors

� Task Overlap
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Caption

To change the caption displayed on the task bar:

1 Click the arrow to the right of the combo box. 

2 Move through the list of values which appears, using the scroll bar or the 
directional arrow keys.

The field value you select is displayed on the task bar.

3 Select the information you would like to see in the task bar. 

4 Click OK to save the changes. 

5 Click Cancel to ignore them.

The following are item bar captions that can be displayed for each item in the 
Schedule window:

Information Box
The Information box is a small window that appears when the mouse pointer 
stops on an item (Incident, Change, Request, or Task) bar in the Schedule 
pane. It displays summary information about each item, including Category, 
Contact, Reported on and several additional pieces of information, which 
can be set up from the Customize dialog box.

Field Definition

Caption Display Displays an identifying piece of information about each in the 
Schedule Pane. A drop down menu at the right of the field 
displays a list of options, including Number, Phase, and 
Reported On.

Caption Separator Select a character symbol for demarcating different items of 
information displayed in the task bar caption. 

� Assignment � Attribute 2 � Brief Description

� Category � Color � Contact

� Cost � Downtime � Expertise

� Location � Number � Parent

� Percent utilization � Phase � Priority

� Incident ID � Reported on � Scheduled priority

� Status � Task type � Total pages
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The Information box displays up to three 
rows of information about each 
scheduled Incident, Change, Request, 
and Task in the schedule. You define 
here which fields are displayed in the 
Information box, which appears when 
you leave the cursor on an Incident, Change, Request, or Task in the 
Schedule pane for several seconds. The system defaults to the following fields 
in the Information box: Category (including type - Incident, Change, 
Request, or Task), Contact and Reported On. 

To change the fields displayed on the Information box:

1 Click the arrow to the right of the combo box for the appropriate row in the 
Information box area of the Schedule Window tab. 

2 Move through the list using the scroll bar or the arrow keys.

The field value for the first row is displayed in the first row of the Information 
box. The field value for the second row is displayed in the second row of the 
box, and so on. There are several field options which are tracked in Work 
Management for each Incident, Change, Request, or Task.

3 Select the information to display in the three rows.

4 Click OK to save the changes. 

5 Click Cancel to ignore changes.

Drag and Drop
Using this feature tasks will automatically be assigned to the nearest specified 
time segment during drag-and-drop task allocation procedures. For 
example, assume the value is set to 15 (minutes). If you drag-and-drop a task 
to 2:10 PM, the task will be snapped to (assigned to) the 2:15 PM time slot. If 
the snap to value were set to 60 (one hour), this same task would be scheduled 
for 2:00 PM. By default no value will appear in this field.

Colors 
Allows you to select which colors are associated with different priority levels 
or with completed Incidents tickets, Change requests, Request quotes, and 
their associated tasks. Color changes to the item ticket bars on the Schedule 
window are made in these fields. 
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To change one of the colors used for the item bars in the Schedule window:

1 Click the appropriate color box.

2 Click the color you wish to use.

3 Click OK.

To define a custom color:

a Click the Define Custom Colors button. 

b Select the desired color by sliding the cursor up or down with the mouse 
pointer to change the tone or value. 

c Move the new color to the main Color dialog box by clicking the Add to 
Custom Colors button.

Figure 8-2: Color Dialog Box

d Click OK to save your changes.

The new color appears in the color box on the Task bar tab. 

4 Click OK to save the changes to the database. 

5 Click Cancel to ignore changes.

Work Management automatically updates the Schedule window to reflect 
any changes.

Task Overlap
Selecting this option will shift to the right all scheduled tasks in the Schedule 
window to accommodate the introduction of a new task where there would 
not otherwise be sufficient time.
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Schedule Window Tab
The Schedule window tab of the Customize dialog box effects the 
management of data displayed in the Schedule window, containing the 
customize options for the priority weightages, overall downtime threshold, 
gauge panel, utilization figures, and operator list order.

Figure 8-3: Customize Dialog Box — Schedule Window Tab
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Panels in the Schedule window tab:

� Options

� Gauge Panel

� Utilization Computation

� Operator (Sort) Order

� Background Scheduling

Options

Options sets the downtime limit for Incidents tickets, Change requests, 
Request quotes, and their associated tasks, which is displayed in the 
downtime gauge. The Overall downtime threshold setting is specific to each 
manager. The default setting for Overall downtime threshold is 3 days.

To change the Overall downtime threshold setting:

1 Highlight the field by double-clicking its contents.

2 Overwrite the contents. 

Use the format ddd:hh for the Overall downtime threshold value.

The default value for the threshold is 3 days. With this default setting, any 
Incident, Change, Request, or Task that exceeds a downtime of 3 days is 
highlighted in the Downtime display.

3 Click OK to save the changes to the database. 

4 Click Cancel to ignore them.

Field Definition

Total downtime Totals all downtimes for Incidents tickets, Change requests, 
Request quotes, and their associated tasks in the current 
schedule, where downtime is the amount of time between 
being reported and being resolved. 

Response time Shows the average response time for any Incident, Change, 
Request, or Task on the current schedule; calculated as the 
difference between the Reported date/time and the Scheduled 
or Actual Start date/time for all Incidents tickets, Change 
requests, Request quotes, and their associated tasks in the 
schedule, divided by the number of Incidents tickets, Change 
requests, Request quotes, and their associated tasks.
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Gauge Panel
Gauge Panel allows you to toggle the first gauge on the Schedule window 
from Total downtime to Response time. The default setting for this gauge 
panel is Total downtime. The gauge panel selection is specific to the manager 
logged into Work Management.

The first gauge on the Schedule pane can track either total downtime or 
response time for incomplete Incidents, Changes, Requests, or Tasks in the 
schedule.

To change the Performance gauge panel:

1 Click the appropriate radio button to select either Total Downtime or 
Response Time.

2 Click OK to save the changes to the database. Work Management 
automatically updates the view on the Schedule window.

Utilization Computation
Utilization Computation options allow a manager to select whether the 
shared operator appears on a full time scale or one limited by the time that 
the operator is scheduled to be a shared resource. Operator utilization 
computation can be changed by selecting one of the options in the table 
below.

Field Definition

Use total time scale 
duration 

Calculates operator utilization for the selected 
timescale duration.

Use only available time Calculates operator utilization for the availability of the 
operator.
182 �Chapter 8—Creating Custom Configurations 



Work Management
Operator (Sort) Order
Operator Order options determine how operators are organized in the Schedule 
Pane, whether they are displayed in alphabetical order or an order based on their 
resource type. The operator list in the operator pane can be sorted using the options 
in the table below.

Background Scheduling 

Background Scheduling enables the system to automatically schedule 
Incidents tickets, Change requests, Request quotes, and their associated 
tasks. Background scheduling also saves any changes to the database as it 
schedules new Incidents tickets, Change requests, Request quotes, and their 
associated tasks. The default setting for Background scheduling is to schedule 
all Incidents tickets, Change requests, Request quotes, and their associated 
tasks at the current system date and time, every 60 minutes, starting at 12:00 
AM, based on the priority of the ticket. Background scheduling can be 
configured to affect all Incidents tickets, Change requests, Request quotes, 
and their associated tasks in the mailbox and those that have been assigned, 
through assignment groups, to the manager currently logged in. These 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
are scheduled to manager-assigned operators.

Background scheduling enables the system to automatically schedule 
incoming Incidents tickets, Change requests, Request quotes, and their 
associated tasks. Background scheduling will also save any changes to the 
database as it schedules new Incidents tickets, Change requests, Request 
quotes, and their associated tasks. 

Field Definition

Primary secondary Lists the primary operator and than the secondary operator.

Alphabetical order Sorts both primary and secondary operator alphabetically.
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The default setting for Background scheduling is to schedule all Incidents 
tickets, Change requests, Request quotes, and their associated tasks at the 
current system date and time, every 60 minutes.

To activate background scheduling:

1 Open Options > Customize. 

2 Select the Schedule window tab.

3 Select the Scheduling check box under Background scheduling.

Once selected, the values for frequency and starting time become available 
for editing.

The system defaults to a scheduling frequency of every 60 minutes. 

4 To change this value, double-click in the field.

5 Type in the new value.

The default start time for automatic scheduling is 12:00 AM. 

6 To change this time, double-click in the field.

7 Overwrite the contents, including AM or PM with the new value. You may 
also enter the start time in the 24-hour format.

Field Definition

Schedule Activates the control options for the schedule. 

Based on priorities Determines whether priority of the Incident, Change, Request, 
or Task is the highest factor in how the Background scheduler 
assigns items.

Schedule Defines the criteria for the automatic background scheduling 
process. 

All affects all Incidents tickets, Change requests, Request 
quotes, and their associated tasks, including those currently 
unallocated. 

Unallocated only affects only those Incidents tickets, Change 
requests, Request quotes, and their associated tasks currently 
in the mailbox, scheduling them to users automatically based 
on operator expertise. 

Allocated only rearranges the Incidents tickets, Change 
requests, Request quotes, and their associated tasks that are 
already in operator queues for highest efficiency.
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8 In the Schedule areas, select the appropriate radio button to schedule 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
for either all Incidents tickets, Change requests, Request quotes, and their 
associated tasks; unallocated Incidents tickets, Change requests, Request 
quotes, and their associated tasks only; or only allocated Incidents tickets, 
Change requests, Request quotes, and their associated tasks.

� Choosing All creates a schedule that blends previously scheduled Not 
Started Incidents tickets, Change requests, Request quotes, and their 
associated tasks with those in the mailbox. 

� Selecting Unallocated incidents only appends those Incidents tickets, 
Change requests, Request quotes, and their associated tasks in the 
mailbox to the end of the current schedule. 

� Choosing Allocated incidents only reschedules those Incidents tickets, 
Change requests, Request quotes, and their associated tasks that are 
already assigned and available for viewing in the Schedule window.

9 Click OK to save the changes to the database. 

10 Click Cancel to ignore changes.
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Others Tab
The Others tab of the Customize dialog box is used to customize background 
scheduling and knowledge base support. This tab is also used to view how the 
category duration is calculated and the expertise levels defined by Work 
Management.

Figure 8-4: Customize Dialog Box — Others Tab

Panels on the Others Tab:

� Report

� Operator Expertise Table

� Knowledge Base Support

� Information
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Report
Report is used to connect to a report directory (alternative location) other 
than Work Management's default report directory, enter the directory path 
and DSN in the appropriate fields. 

Operator Expertise Table 

The Operator Expertise table identifies the possible levels of expertise for 
operators. The values are made available in the combo boxes used to define 
either the minimum expertise of contacts, or the expertise levels of operators. 
The expertise table has three columns of information with 10 rows maximum 
of expertise entries. 

Knowledge Base Support 
Defines the path for any knowledge bases or reference databases to be used 
with Work Management. The knowledge base is accessed using the Help 
menu on the Schedule window.

Field Definition

Level Organizes the Expertise Description information from 
lowest to greatest skill sets, numbered from 1 to 10. These 
values cannot be changed.

Expertise description Displays a user-defined name for the skill level. Work 
Management provides six default descriptions for expertise: 
Beginner, Basics, Intermediate, Experienced, Expert and 
Guru.

% (Percentage Factor) Defines the relative amount of time 
required by each levels of expertise to complete a given 
Incident, Change, Request, or Task. This is based on the 
principle that a highly skilled operator will complete similar 
projects faster than a beginner. 

Work Management uses the percentage factor to modify 
the duration estimates for Incidents tickets, Change 
requests, Request quotes, and their associated tasks based 
on the expertise level of the assigned operator, for example, 
take a change with a duration estimate of 1 hour. If the 
percentage factor for beginners is 100%, and the percentage 
factor for experts is 50%, then the duration estimate used by 
the autoscheduler would remain at 1 hour for the beginner, 
and drop to ½ hour for the expert.
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To define Knowledge base support:

1 Enter the full path to the knowledge base. (The knowledge base bundled with 
Work Management, WDManager32.hlp, resides in the ServiceCenter Run 
directory.) Work Management accepts knowledge bases in a .HLP format.

2 If you are not sure of the path or file name, click the Browse… button.

3 In the Open File dialog box, select the drive and directory to search.

4 Select All Files in the Format Type field of the Open dialog box to display 
everything in the current directory.

5 Once you have located the knowledge base, double-click the file.

6 Click OK.

The file and its path appear in the field. 

7 Click OK on the Customize dialog box to save the changes.

Information
Displays the manner in which Work Management calculates category 
duration. Category duration affects the actual duration calculation tracked 
by the system. The system default for calculating the actual duration is to take 
the average of all Incidents tickets, Change requests, Request quotes, and 
their associated tasks that were completed during the previous one month. 
The Information box displays the current setting for category duration. 

Only the ServiceCenter Administrator can set the duration method to 
Average or Median. The default time frame used for calculating the Actual 
duration is one month. Only those Incidents tickets, Change requests, 
Request quotes, and their associated tasks that fall within the date range are 
used to calculate the Actual duration. The ServiceCenter Administrator may 
also change the time frame to be used for the calculation.

Auto Refresh Tasks allows the user to set up an auto refresh of tasks. User sets 
the start time and interval at which the tasks will refresh.

The actual duration is calculated using all completed tasks with a category of 
actuals data. Completed tasks for the last n months are taken into account for 
this calculation where n is configured as follows.
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To Calculate the duration:

1 In ServiceCenter, open the Database Manager Utility from the Toolkit tab on 
the main menu. 

2 Open the wdCustomize form. 

3 Search for a record where wdResourceID = ADMIN. 

4 Change the value in the wdNumMonths field to the number of months to be 
used for category actual duration calculation. 

Note: This is a global setting for all Work Management users and not a user 
setting.

Important: actuals data can only be entered if ServiceCenter Incident close 
forms are customized to capture this information and save it to 
the work table. This requires implementation and does not come 
with the out of box system.

User Defined Fields

It is possible to change the names of user-defined fields for contacts, 
operators, and categories. Four data element groups of user-defined fields are 
available for editing: Incident/Change Details, Contact, Category, and 
Operator. These groups correspond to the dialog boxes where these fields are 
available.

To modify these settings:

1 Select Options > User Defined Fields... 
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The User Defined Fields dialog box will open.

Figure 8-5: User Defined Fields Dialog Box

Element Definition

Data Element Identifies to which of the four types of data the associated fields 
apply.

Current label Represents the current field heading. Values for Current label field 
are defined by the system and cannot be edited. 

Field name Allows for modifications to the heading for any of the user-defined 
fields.

Data Values... 

(button)

Displays the data values for the first two user-defined fields of each 
group.
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To add, delete, or change data values:

1 Highlight the appropriate Field Name cell in the User Defined Fields dialog 
box.

2 Click the Data Values... button. The Data Values dialog box will open.

Figure 8-6: Configuring User-Defined Fields

3 To add a new entry, select the first empty field and begin typing.

4 To delete an entry, select the field and press the Delete key. 

Work Management asks you to confirm the deletion.

5 To edit an existing entry, double-click the field, to start the edit mode. 

a Position the cursor to change a value.

b Make necessary changes or corrections to the value.

6 Click OK to save the changes to the database. 

7 Click Cancel to ignore changes.
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Filters
The following filters can be edited.

� Contact Filters

� Incident, Change, Request, and Task Filter Setup

� Schedule Filters

� Location Filters

To open a filter for editing:

� Select it from the Options > Filters list.

Location Filters
To customize the Location filter:

1 Select Options > Filters > Location from the main menu. This brings up the 
Location Filter dialog box.

Figure 8-7: Location Filter Setup

2 Enter the wild card for the Location name field. 
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3 This value is used to determine which contact to display, for example, * 
imports all contacts in ServiceCenter and all their data; A* displays all 
locations whose names begin with A and are followed by any other 
characters.

4 Enter the expected Travel time in the Travel time field. 

Your options in the first field include, equals (=), less than (<), greater than 
(>), less than or equal to (<=), greater than or equal to (>=), and greater than 
or less than (<>). 

Enter the days, hours and minutes in the second field. 

5 Enter the Actual travel time in the Actual Travel time field

6 Click OK to accept changes or Cancel to ignore.

Schedule Filters
Figure 8-8 shows the Schedule Filter form. For information on using the schedule 
filter, see Filtering the Schedule Window on page 38.

Figure 8-8: Schedule Filter Setup
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Task Filters
Figure 8-9 shows the Incident, Change, Request, and Task Filter form. For 
more information, see Additional Record Details on page 128.

Figure 8-9: Incident, Change, Request, and Task Filter Setup
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Contact Filters
Figure 8-10 shows the Contact Filter setup form. For more information, see 
Filtering the Contacts List on page 63.

Figure 8-10: Contact Filter Setup
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APPENDIX

A
 Function Reference
This appendix describes Work Management functions during setup if you 
are a ServiceCenter administrator. It has a quick overview of various key 
functions or processes used during a standard implementation of Work 
Management and ServiceCenter. 

Read this appendix for information about:

� Administrator Functions on page 198

� Manager functions on page 203

� Team Member Functions on page 205

� Keyboard Shortcut Table on page 208
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Administrator Functions

Create Managers
Creating managers is done from ServiceCenter.

To create managers:

1 Go to the Administration, Operators form (operator.g). 

2 If the operator to be defined as a manager already exists, select that operator. 

3 If the operator does not exist, create a new operator. 

4 In the Resource Type combo, pick resource type as Manager if this operator 
needs only managerial capabilities. 

5 Pick Manager/Resource if this operator is both a manager and an operator. 

As both a manager and operator, the manager is able to assign tickets to 
himself/herself using Work Management. 

6 Save the record.

Configure Each Assignment Group
Configuring assignment groups is accomplished from ServiceCenter. 

To configure assignment groups:

1 Go to Database Manager.

2 Select the assignment form (assignment.g). 

3 Select the assignment group to be configured. 

4 In the Manager name combo, select the manager for this assignment group. 

This operator needs to be configured as a manager. 

5 In Calendar name, select the calendar for this assignment group. 

6 On the Operators tab, select the operators that belong to this 
manager/assignment group. 

7 Save the record.
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Mapping Priority with Status and Severity
Mapping of priority with status and severity is accomplished from 
ServiceCenter. 

To map priorities:

1 Go to Database Manager.

2 Select the wdPriorityLookUp.g form.

Work Management ticket priorities can be defined as a combination of 
severity and status. 

3 Select the status from the status combo.

4 Enter the severity and priority values. 

5 Click Add. 

6 Repeat this process for as many combinations of severity and status as need 
to be defined. 

For all combinations not defined in this manner, Work Management assigns 
a priority of 10 (lowest).

Operator Commitment Types
Operator commitment type is set from ServiceCenter. 

To set operator commitment:

1 Go to Database Manager.

2 Select the wdCodeDetails.g form. 

3 Enter 90 in the Code type edit box. 

4 Enter 1 in the Code ID edit box.

5 Enter the commitment type as a string in the Code description edit box.

6 Click Add. 

7 Repeat for as many types as need to be defined. 

The values in code ID have to be unique for each commitment type.
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Define Expertise Levels for the Organization
Expertise levels in the organization are defined from ServiceCenter. 

To define expertise levels:

1 Go to Database Manager.

2 Select the wdCodeDetails.g form. 

3 Enter 98 in the Code type edit box. 

4 Enter in 1 in the Code ID edit box. 

5 Click Search. 

6 If the record is not found, add a new one. 

7 Enter the description of the lowest expertise level in the Code description 
edit box. 

The factor in the Code Description edit box should be 100 for Code 
Type=99, Code ID=1. 

8 For more expertise levels, enter expertise level and the corresponding factor 
in the Code Description string edit box, for Code Type 98 and 99 
respectively, with the same Code ID for each level. 

The Code ID should be unique for each level.

Assign Expertise to Each Operator
Each operator is assigned expertise using Work Management. 

To assign operator expertise:

1 Double-click the operator name in the left pane of the Schedule window or 
go to View menu, and select Operator and select the operator. 

2 Click the Expertise button. 

3 Double-click an empty row.

4 Double-click to select the category as expertise. 

5 Modify the expertise level. 

6 Repeat for adding additional category expertise. 

7 Click OK twice to save the configuration. 

While assigning tickets to operators, Work Management makes operators 
gray who do not have expertise for a ticket of a particular category, indicating 
their non-availability of expertise.
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Estimate Effort for Each Category
Estimation of effort for each category is done using Work Management. 

To estimate effort

1 Go to the View menu, and select Category. 

2 In the Duration column, enter the duration for each category. 

Tickets of this category default to this duration. 

3 Click OK to save.

Finalize Color Codes for Priorities
Color codes for priorities is finalized using Work Management. 

To choose color codes:

1 Go to the Options menu, and select Customize.

2 Select the Schedule window tab. 

3 Click the colored boxes and select colors for each priority. 

4 Click OK to save. 

Tickets on the Schedule window will be color-coded based on these settings.

Information Box Options
This is done using Work Management. 

To select information box options:

1 Go to the Options menu, and select Customize.

2 Select the Schedule window tab. 

3 In the Information box section, select the data element that you want to see 
in the information box. 

The Information box is displayed as a popup when the mouse is moved over 
a ticket on the Schedule window.
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Threshold Definition
This is done using Work Management. 

To define the threshold duration:

1 Go to the Options menu, and select Customize.

2 Select the Schedule window tab. 

3 Define the overall downtime threshold duration. 

The downtime display option and the threshold gauge on the Schedule 
window use this threshold to filter tickets.

User Defined Fields
This is done using Work Management. 

To define User defined fields:

1 Go to the Options menu, and select User defined fields. 

2 You can edit labels and define values for the first two user defined fields for 
operator, ticket, category and contact. 

3 You can only edit the labels for the other two user defined fields. 

These values appear in a combo box in the operator, incident/change/task, 
contact, and category dialogs and you can filter using these in the contacts 
and all incident/change/tasks dialogs. 

4 Click OK to save.

Integrating with MS Outlook
The settings for integration with MS Outlook are established from 
ServiceCenter. 

To integrate with MS Outlook:

1 Go to Database Manager.

2 Select the wdCustomize.g form. 

3 Enter ADMIN as the wdResourceID. 

4 Set the wdReadOutlook field to 1 to enable MS Outlook integration, and 0 to 
disable MS Outlook integration.

5 To display the subject as the bar caption, set the wdTaskBarCaptionID field 
to 0. 
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Setting this field to 1 displays Not defined as the caption for the MS Outlook 
appointments displayed in the Schedule window.

Manager functions

View Workload
This is done through Work Management. You will be able to view all 
Incidents tickets, Change requests, Request quotes, and their associated tasks 
assigned and unassigned in your assignment group. 

Unassigned Incidents, Changes, Requests, or Tasks appear in a mailbox. 

To view the workload:

1 Click the mail box gauge to open or close the mailbox. 

By default the system displays the schedule for the current date. 

2 To change this time scale, double-click the time scale bar or select the 
Timescale option from the Options menu. 

The bottom spreadsheet displays details of Incidents tickets, Change 
requests, Request quotes, and their associated tasks. 

3 To view more details, select the Incidents, Changes, Requests, or Tasks on the 
spreadsheet or on the Schedule window. 

4 Double-click or right-click to produce a shortcut menu.

5 Select More details. 

6 Move mouse over the Incident, Change, Request, or Task on the Schedule 
window to see a popup information box. 

7 To view only locked tickets or tickets above the downtime threshold, select 
Schedule from the View menu.

Assign Incidents, Changes, Tasks to Operators
This is done through Work Management.

To make assignments:

1 To assign an Incident, Change, Request, or Task to an operator from the 
mailbox or to reassign from one operator to another, drag the item to the 
operator. 

2 Drop the Incident, Change, Request, or Task on the Schedule window. 
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3 To unallocate an Incident, Change, Request, or Task, select the ticket and 
select Unallocate from the Operations menu. 

4 You can also assign a ticket by right-clicking on the ticket on the Schedule 
window or spreadsheet, which produces a shortcut menu.

5 Select More Details. 

6 On the Operator tab, select the operator that you want to assign the ticket to. 

7 Right-click to bring up the shortcut menu, and select Replace to save.

Refresh/Save Schedule
This is done through Work Management.

All changes to the Schedule window are saved only when you click the Save 
option from the Schedule menu. 

Any changes in the Incident/Change Details dialog are saved only when you 
right-click to reveal the shortcut menu, and select Replace. 

To view changes made by other users or to refresh the mailbox, click Refresh 
from the Schedule menu.

Compact Incident Tickets
This is done through Work Management. This function brings all tickets up 
to display within the current timescale. All tickets scheduled before or after 
the current timescale are not visible until you select Compact from the 
Operations menu. 

You can compact the entire schedule or just the schedule for one operator. 
Compact prompts you whether to compact time and operator locked tickets.

Locking Incident Tickets
This is done through Work Management.

To lock Incident tickets:

1 Select Lock from the Operations menu.

A submenu with two lock options appears.

2 The Operator lock option locks the ticket to the operator. 
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The auto schedule function will not reassign this ticket but can reschedule it. 
This can also be used as a visual indicator to ensure a ticket is not re-assigned 
to another operator. 

3 The Operator and time lock option locks the ticket to a particular scheduled 
time. 

The auto schedule function will not reassign or reschedule this ticket. This 
can also be used as a visual indicator to denote committed client 
appointments.

Automatic Background Scheduling
The goal of the automatic scheduler is to optimize resource utilization. This 
is done through Work Management. 

To start background scheduling:

The automatic scheduler allocates tickets to individual operators based on 
the following criteria:

� Availability of operators

� Expertise levels of the operators 

� Priority of the Incident ticket/change/task

� Age of the ticket 

Minimize Organizational Downtime
This is done through Work Management. You can also set an option to 
instruct the system to schedule tickets at regular intervals. This option can be 
set by selecting the Customize option from the Options menu.

Team Member Functions

View Schedule
This is done through Work Management. You can view only tickets assigned 
to you and all unassigned tickets in your assignment group. Unassigned 
tickets appear in a mailbox. 

To view the schedule:

1 Click the mail box gauge to open or close the mailbox. 

By default the system displays the schedule for the current date. 
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2 To change this time scale, double-click the time scale bar or Timescale option 
from the Options menu. 

The bottom spreadsheet displays details of tickets. 

3 To view more details, select the ticket on the spreadsheet or on the Schedule 
window. 

4 Double-click or right-click, then select More details from the shortcut menu. 

5 Move the mouse over the ticket on the Schedule window to see a popup 
information box. 

6 To view only locked tickets or tickets above the downtime threshold, select 
Schedule from the View menu.

Define Commitments
This is done through Work Management.

To define commitments:

1 Select Operator Commitment from the View menu. 

2 Enter the dates and type of commitments. 

3 Click OK to save. 

Commitments appear as blocked time in the Schedule window and cannot 
be moved.

Update Ticket Status
To update ticket status:

1 Double-click a ticket on the bottom spreadsheet or Schedule window.

2 Update or close the ticket using the ServiceCenter form.

3 Click Save to save.

Work on Unassigned Tickets
This is done through Work Management.

To work on unassigned tickets:

1 Double-click a ticket in the mailbox. 

2 Update or close the ticket using the ServiceCenter form.

3 Click Save to save. 
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4 Drag and drop the ticket to the Schedule window to assign the ticket to 
yourself.

Filters for Contact Dialog
This is done through Work Management.

To change filters:

1 To change filters while you are in the Contact dialog or Incident/Change, 
Details dialog, right-click to reveal a shortcuts menu.

2 Select Filters. 

3 You may also select Filters from the Options menu to change the filter 
settings.

Spreadsheet Defaults
This is done through Work Management. The columns in the bottom 
spreadsheet can be resized or completely hidden.

Colors in the Spreadsheet and Mailbox
This is done for Work Management.

To edit colors:

1 To view colors in the mailbox and spreadsheet, open workmgmt.ini in your 
windows directory. 

2 Go to the [Colors]section and set ShowColors=1.

Mailbox Sort Options
This is done through Work Management.

To select options:

� Right-click the mailbox to view the sort options. Tickets will be sorted based 
on these selections.
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Count and Utilization Columns
1 Right-click either of the columns, to reveal a shortcut menu.

2 Click the column which is to be displayed. 

Only the column options which have a tick mark are displayed.

Keyboard Shortcut Table
Many of the menu commands in Work Management can be accessed using 
keyboard short cuts or accelerator keys. The following table lists the 
accelerator keys currently available.

Key Alt Ctrl

A Accesses the Compact for All the 
Operators command from the 
Operations menu in Work 
Management. 

---

B Selects the Brief Description field on 
Incident, Change, Request, or Task 
page. 

Accesses the Incident/Change Filter 
screen.

C Selects the Completed field on the 
Operator page.

Copy.

D Selects the Reported date in the 
Contact page.

---

E Selects the Operator in the Operator 
page.

Accesses the Replace command on 
the Incident ticket menu. The 
Incident/Change menu is available 
when the Incident/Change Details 
dialog is open.

F --- Accesses the Apply Filter command 
on the View menu.

H Accesses the Help menu. Selects the 
Scheduled Start date field on the 
Operator page in the 
Incident/Change Details dialog box.

Selects the Highest Priority on the 
Operations menu.

K --- Accesses the Operator & time lock 
command on the Operations | Lock 
menu.

L --- Accesses the Operator lock 
command on the Operations | Lock 
menu.
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M Selects the Assignment group in 
Contact page.

---

N Selects the Contact on Contact page. Accesses the New command on the 
Incident/Change menu. The 
Incident/Change menu is available 
when the Incident/Change Details 
dialog is open.

O Selects the Category on Contact 
page; Accesses the Operations menu.

---

P Selects the Total pages on Contact 
page.

---

R Accesses the Compact for the current 
operator command on Operations 
menu.

Accesses the Refresh command on 
the Schedule menu.

S --- Accesses the Save command on the 
Schedule menu.

T Selects the Action on Contact page. Accesses the Contact filter on the 
Options menu.

U Selects the Actual date/time on 
Operator page.

Accesses the Unallocate command 
on the Operations menu.

V Accesses the View menu. Paste.

W --- Accesses the Schedule Window Filter 
on the Options menu.

X Selects the Expertise level in Contact 
page.

---

Key Alt Ctrl
Team Member Functions � 209



ServiceCenter
210 �Appendix A—Function Reference 



APPENDIX

B
 Microsoft Outlook Integration
This appendix was designed to aid the ServiceCenter administrator, 
manager, or user in integrating Microsoft Outlook with Work Management. 
It explains how to load Appointments for all operators belonging to a 
manager from the Microsoft Outlook calendar into the Work Management 
Schedule window.

Topics in this appendix include:

� Overview on page 212

� MS Exchange Server and Client Set Up on page 212

� Granting Review Rights on page 213
Microsoft Outlook Integration � 211



ServiceCenter
Overview

Appointments for all operators belonging to a manager can be loaded from 
Microsoft Outlook calendar into the Work Management Schedule window. 
These appointments are then displayed as blue hashed bars in the Schedule 
pane. 

For integrating appointments and events from Outlook with Work 
Management, a Microsoft Exchange Server has to be setup and all Work 
Management users must have accounts on this server.

Each team member must create a profile to log into MS Outlook. The team 
member then must grant reviewer permission to the manager, so the manager 
can view the appointments set for the required operators. The subject of the 
appointments or events is displayed as the bar caption instead of the number 
of Incidents, Changes, Requests, or Tasks. 

MS Exchange Server and Client Set Up

To set up the Microsoft Exchange Server and Clients:

1 A Microsoft Exchange Server should be setup and all Work Management 
users should have accounts on this server.

2 MS Exchange clients should be setup at each user's desktop.

3 Profile names for each team member must be created on the client side.

4 Each team member has to grant Reviewer permission to his manager to be 
able to view the appointments set in his calendar folder.

5 Once the team member is granted Reviewer rights to his manager, he is all set 
to use Outlook to set up the appointments for training programs, status 
meetings, company meetings, etc. in the various time slots of the Calendar. 
These appointments will be displayed by Work Management in the Schedule 
window. 

Appointments will be displayed as blue hashed bar in the Schedule window, 
similar to off-hour commitment bars, and the subject of the appointments or 
events is displayed as the bar caption.
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Granting Review Rights

To grant review rights:

1 Login to Outlook. 

2 Right-click the Calendar folder.

A short-cut menu is displayed.

3 Choose Properties.

4 In the Calendar Properties dialog box, go to the Permission tab.

5 Set the name of the manager reviewing the list, as well as the group managers, 
secondary managers and team members.

6 Set the Role as Reviewer.

Marking Events and Appointments Private
When a user marks an appointment or event as Private in Outlook, Work 
Management displays these appointments and events as a commitment bar, 
but the appointment/event subject is not provided as the bar caption. The 
system displays Private instead as the caption.

To mark items as private:

1 Login to Outlook. 

2 Right-click the Calendar folder.

A short-cut menu is displayed.

3 Choose Calendar.

4 Select the New Appointment or New Event option.

The New appointment or New Event dialog appears.

5 Enter the new appointment or event.

6 Select the start date and time and end date and time. 

7 Click Private.
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The following is a sample Schedule window with Outlook appointments and 
events.

Figure B-1: Outlook Appointments
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C
 Work Management Tables
This appendix lists the tables used by Work Management that assist the 
ServiceCenter administrator who is setting up Work Management. Work 
management uses tables to contain data and communicate with 
ServiceCenter. 

Read this appendix for information about:

� Service Center Tables on page 216

� Work Management Tables on page 216
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Service Center Tables

The following ServiceCenter Tables are used by Work Management

Work Management Tables
The following tables are created and used by Work Management for 
ServiceCenter. 

Table Function

assignment Contains mail groups

caldutyhours  

calholidays 

contacts 

location 

operator 

work  Contains all task information to be read by Work Management. 
Task information is transferred, when required, from the SC table. 
For example, in probsummary, cm3t, cm3r, ocml, ocmq, etc. using 
triggers, links and applications.

Table Function

wdCategory Contains all category information (transferred from the SC 
table. For example, category, or cm3tcategory, etc. using 
triggers, links and applications.)

wdCodeDetails Contains code pertaining to certain Work Management 
functions, as well as label information, user defined fields, 
resource commitment types, and expertise types and 
percentages

wdColors Contains color definitions for various areas of Work 
Management (including task bars, rows, and priority 
definitions), associated to resources (Will be updated by 
Work Management)

wdCustomFilter Contains custom filter criteria defined for Work 
Management. (Internal, not to be edited.) 
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wdCustomize Contains customize information as defined in Work 
Management. An imported record contains default (ADMIN) 
settings for all users which can be edited in initial Work 
Management configuration. 

wdCustomReports Contains customized report definitions for reports viewing in 
Work Management (Internal, not to be edited.)

wdCustomSections Contains customized report data as defined in Work 
Management (Internal, not to be edited.) 

wdDependency Contains dependency information for tasks as defined in 
Work Management (predecessor - successor relationships) 
(Will be updated by Work Management)

wdOffHours Contains resource commitments defined in Work 
Management (meetings, vacations) (Will be updated by Work 
Management.)

wdPriorityLookUp Contains a matrix that defines priority for tasks in Work 
Management, based on combinations of values from two 
implementation-defined fields

wdResExp Contains resource expertise definitions (with varying levels of 
expertise associated to categories for each resource) (Will be 
updated by Work Management)

wdResHierarchy Contains a hierarchy of resources, managers, and group 
managers for the corresponding Work Management views 
available

wdSCFDefinition Contains Supply Chain Factors definitions for use within 
Work Management as service provider-defined criteria for 
scheduling

wdSchFilter Contains filter definitions created in Work Management for 
the use of the Schedule Filter (which filters the tasks displayed 
in Work Management based on certain criteria) (Will be 
updated by Work Management)

wdSchOptions Contains options defined in Work Management for the use of 
the Background Scheduling function (Will be updated by 
Work Management)

wdShowContact Contains the labels of the fields, which you can customize, 
that appear in the Show Contact popup invoked by a 
right-click over a task in Work Management. The default data 
consists of out-of-box label definitions which match up with 
fields defined in the imported field mappings

Table Function
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wdSLADefinition Contains Service Level Agreement definitions, for use within 
Work Management as customer-specific service level criteria 
for scheduling

wdTauCounter Contains counters for adding tables. (Internal, not to be 
edited.)

wdWROption Contains options for the use of the WorkRequester function 
in Work Management (Will be updated by Work 
Management)

wdMapFields Contain mapping information for each field it need to 
connect to (Internal, not to be edited.) 

wdMapTables Contains a list of all tables used by Work Management 
(Internal, not to be edited.) 

Table Function
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actual duration 67, 85, 90
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categories 78
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tips 80
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contacts
adding new 57, 59
defining 53
definition 52
deleting 60
editing 61
e-mail address 60
email address 55
filtering 63
form 58
keyboard shortcuts 55
minimum expertise 54, 60, 62
name 54
navigating through screens 55
outstanding count 55, 69
outstanding problems 60
priority 54, 60, 62
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telephone 60
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duration 67, 79, 85
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rescheduling 150–151
scheduling 144, 157, 158
unallocating 154
viewing 40, 127

incident/change
contact page 135
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default value 79, 85
editing 85
highest priority status 153
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unallocating incident tickets 154
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