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About This Guide
The ServiceCenter® User’s Guide provides an introduction to ServiceCenter, 
including an overview of its applications, modules, and utilities, and a 
discussion on the best practices in processes and workflow. For an extensive 
glossary on ServiceCenter terms used throughout this guide, refer to the 
Introduction and Best Practices guide.

The ServiceCenter applications covered in this guide are:

Service Management on page 105

Incident Management on page 197

Scheduled Maintenance on page 145

Inventory Management on page 257

Service Level Management on page 345.

Root Cause Analysis on page 377

Change Management on page 407
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ServiceCenter
This guide also includes information on the main ServiceCenter window and 
to use the applications, log on to and log off from ServiceCenter, and using 
the menus and buttons, including:

Getting Started on page 23

IR Expert on page 521

The Java Client Desktop on page 87

Printing on page 539

The Contacts File on page 547

Knowledge Base - Diagnostic Aids on page 561

Knowledge Requirements

As a ServiceCenter user, you need a basic knowledge of the environment in 
which you are working (Windows, UNIX, or OS/390).

Who Uses ServiceCenter?

Anyone in your company can benefit from using ServiceCenter. Help desk 
operators can open call reports to report hardware problems for their users, 
such as printing problems. IS can use Asset Management to track the 
hardware and software used by your company. Managers can use Request 
Management to approve and to track equipment orders.
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Organization of this Guide
This guide is organized around the main functions associated with the 
ServiceCenter applications and modules. The following chart shows you 
which parts of the manual you need to reference to find the information you 
need. 

To find this... Look here...

ServiceCenter Overview; get to know 
ServiceCenter’s applications and utilities

Who Uses ServiceCenter? on page 14

How to use the menus, toolbar, and 
buttons

Using the Menus, Toolbar, and 
Buttons on page 40

Logging on to and logging out from 
ServiceCenter, setting up inboxes, and 
editing records

Getting Started on page 23

Accessing Service Management, searching 
call reports, creating categories for Service 
Management and Incident Management

Service Management on page 105

Accessing Asset Management, searching 
Asset Management, asset record tabs, 
creating and updating an asset record

Incident Management on page 197

Accessing Change Management, changes 
and tasks, using Change Management, 
approving a change or task phase

Change Management on page 407

Printing Printing on page 539

Accessing contact records, creating and 
updating a contact record

The Contacts File on page 547

Plain language queries, using the 
Knowledge Base form

Knowledge Base - Diagnostic Aids on 
page 561
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Sample Forms and Examples 

The sample forms and examples included in this guide are for illustration 
only, and may differ from those at your site. 

Documentation Web Site

For a complete listing of the current ServiceCenter documentation, see the 
Documentation pages on the Peregrine CenterPoint Web site at 
http://support.peregrine.com/. 

You need your current login and password to access this Web page.

For copies of the manuals, you can download.PDF files of the documentation 
using the Adobe Acrobat Reader (also available on the Web site). 
Additionally, you can order printed copies of the documentation through 
your Peregrine Systems sales representative.

Contacting Peregrine Systems

For further information and assistance with ServiceCenter in general, contact 
Peregrine’s Customer Support.

Peregrine’s CenterPoint Web Site
Current details of local support offices are available through Peregrine’s 
CenterPoint Web site at http://support.peregrine.com/ .

To find Peregrine Worldwide Contact Information:

1 Log on with your login User Name and Password.

2 Click Go for CenterPoint.

3 Select Whom Do I Call? in the navigation bar on the left side of the page.

Peregrine worldwide information displays for all products.
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Contacting Education Services

Training services are available for the full spectrum of Peregrine Products 
including ServiceCenter. 

Current details of our training services are available through the following 
main contacts or at: 

http://www.peregrine.com/education 

Address: Peregrine Systems, Inc.
Attn: Education Services
3611 Valley Centre Drive
San Diego, CA 92130

Telephone: +1 (858) 794-5009

Fax: +1 (858) 480-3928
Contacting Education Services  17
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CHAPTER

1
 Introduction
The User’s Guide provides step-by-step instructions for using ServiceCenter 
applications, including logging on and off ServiceCenter and using the 
menus and buttons. Before you begin you’ll need a basic knowledge of the 
working environment (Windows, UNIX, or OS/390).

Note: If you have not read Introduction and Best Practices, please do so before 
continuing with the User’s Guide.

This chapter contains:

How do You Locate ServiceCenter Records? on page 20

Sample Data in the System on page 20

DDE Support on page 21

Accessing the Knowledge Base on page 22
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ServiceCenter
How do You Locate ServiceCenter Records?

The ServiceCenter database is a set of files containing records. As a 
ServiceCenter user, you can search, modify, create, and delete these records. 
Examples of records are:

Users

Inventory of assets

Call reports

Incident tickets

Changes

Requests

Throughout this guide you will see the term query. A query is a search of the 
ServiceCenter database. A Query-by-Example (QBE) is a search of the 
database using the information you know about the record for which you are 
searching.

If multiple records are found matching your search parameters, a QBE 
Record list displays from which you can select the record you want to see.

Once you have accessed a record, you can browse (view only), or update the 
record. Your ability to do this depends on how your system administrator 
configured your user profile. For example, as a user, you may not have the 
ability to approve a change record.

Instructions for searching the ServiceCenter database are found in the 
following chapters: Service Management on page 105, Incident Management 
on page 197, Change Management on page 407, Inventory Management on 
page 257, and the Request Management Guide.

Sample Data in the System

ServiceCenter comes with a set of sample data to help you work with and 
learn the system. The sample data is referenced throughout this guide to 
illustrate ServiceCenter applications and processes. You can modify or delete 
these records as you learn the system, and you can create new records. Also, 
your ServiceCenter administrator can use these records as a model for your 
actual data. 
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Sample data includes information in the following areas:

Users. The sample data includes a set of fictitious users with associated 
profiles and records. 

Inventory. A simulated network inventory is included with the sample 
data. This sample inventory database includes modems, PCs, 
workstations, mainframe hosts, and so forth.

Call Reports. A set of sample call reports is included. You can review, 
update, and close these reports as you would a call report in a production 
system.

Incident Tickets. A set of sample incident tickets is included. You can 
review, update, and close these tickets as you would an incident ticket in a 
production system.

Changes. The sample database includes a set of change records. You can 
review, update, close, or approve the change records according to the 
permissions granted to your current user level (for example, user or 
administrator).

Requests. A set of sample equipment orders is included with Request 
Management. You can modify and approve these orders according to the 
permissions granted to your current user level.

DDE Support

If you are running a ServiceCenter client in a Windows environment, you can 
export information to Microsoft Excel. Utilizing Dynamic Data Exchange 
(DDE), you can export call lists and incident lists to any product, such as a 
Microsoft Excel spreadsheet. When you select the menu option to export to 
Excel, a spreadsheet automatically opens and the data displays in the 
spreadsheet. This DDE function requires Excel 95 or later.

ServiceCenter DDE support is available in both Windows 16-bit          
(Windows 3.11) and 32-bit environments (Windows NT and so forth). DDE 
support is created in a ServiceCenter RAD (Rapid Application Development) 
application. ServiceCenter DDE support for other applications can be 
created through RAD.

Note: You can export some ServiceCenter records to a text file, which is not 
part of the DDE support. You can run this from clients other than 
those operating in Windows.
DDE Support  21



ServiceCenter
Accessing the Knowledge Base

To access the ServiceCenter Knowledge Base:

1 Click Search Knowledge Base from an application home menu (Service 
Management, Incident Management, or Root Cause Analysis).

The Knowledge Base form displays.

Note: Refer to Knowledge Base - Diagnostic Aids on page 561 for a detailed 
description of the process used to search the Knowledge Base.

Figure 1-1: Knowledge Base Search form
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2
 Getting Started
This chapter helps you get started using ServiceCenter and includes 
instructions for starting a client session, logging in and logging out, accessing 
the applications, and navigating around the ServiceCenter GUI (graphical 
user interface.)

The forms displayed in this guide may differ from your system because 
ServiceCenter is customizable and may be configured differently for your 
site. More advanced features may only be available to certain personnel, such 
as system administrators. Contact your ServiceCenter administrator with 
any questions about differences you find in the applications.

This chapter has been divided into the following sections:

Starting a Client Session on page 24

Logging Out of ServiceCenter on page 28

ServiceCenter Home Menu on page 31

Finding Data in Extended Text Fields on page 66

Fill and Find Functions on page 68

Changing the Column Headings in a QBE Record List on page 72

Navigating Tabs on page 74

Bitmaps on page 76

Inboxes on page 77

Editing Records on page 85
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Starting a Client Session

The platform you are using determines the way in which you start a 
ServiceCenter client session.

To start a client session in a Windows-based environment:

Double-click the ServiceCenter icon on your desktop.

To start a client session from a UNIX prompt:

In text mode, type the command: 
 scenter

To start a client session in a 3270 session:

Type the command: 
logon applid=applid 
where applid is the ServiceCenter-specified application ID.

Accessing ServiceCenter Using the Java Client
You can also access ServiceCenter from your PC by connecting directly to a 
ServiceCenter Express Server, using the ServiceCenter Java client. The Java 
client supports the same functionality as the traditional ServiceCenter 
Windows clients without any need for application or format customization. 
To learn more about the Java client, see The Java Client Desktop on page 87, 
as well as the Java Client Installation and Configuration Guide.

Access to ServiceCenter by Persons with Disabilities
When Section 508 recently became an addendum to the Rehabilitation Act 
of 1973, Federal government agencies were required to make electronic and 
information technology usable by persons with disabilities. ServiceCenter 
has been enhanced to accommodate persons with disabilities, making it 
compliant to Section 508 through use of its Java client.

The following components enable 508 compliance:

Java Accessibility API

An application development interface that provides information and content 
to assistive technologies, such as Jaws for Windows.
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Java Accessibility Utility Package

Provides assistive technology vendors the ability to locate and gain access to 
all components (fields, buttons, check boxes, and radio buttons) within a 
form and track events.

Java Accessibility Bridge

A native platform implementation that provides the connection between the 
Java application and the native mode assistive technology program.

Note: This is currently implemented only for the Windows operating 
system.

Viewing Options

Pluggable look-and-feel architecture currently includes emulations of 
common GUIs, such as Windows and Unix Motif, and optional color 
schemes to enhance the user's viewing experience. It also provides support, 
so that assistive technology vendors can implement custom look-and-feels to 
support non-visual presentation, such as audio or tactual devices.

Note: The Java client currently sets the look-and-feel to that of the native 
platform on which it is running.

To set viewing preferences:

Choose View>Preferences>Look and Feel.

—or—

Choose View>Preferences>Color Scheme.

Set up preferences for the look and feel of the system, including the overall 
look of the menus (forms) and choices of color scheme.

Editing Options

Set preferences for disabling animation and gaining access to all components 
(such as, fields, buttons, check boxes, and radio buttons), including 
read-only fields.
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To set accessibility and animation preferences:

Choose Edit>Preferences>Accessibility>Access all Fields.

Setting these preferences enables text reader assistive technologies to read 
through the components of a form (fields, buttons, check boxes, or radio 
buttons) within ServiceCenter. Users can also set a preference to disable 
animation, such as blinking status lights, that could become burdensome to 
the user.

Choose Edit>Preferences>Accessibility>Disable Animation.

Check this option to disable the blinking status light and messages within the 
status bar. This helps to ease any distractions caused by the blinking status 
light or flashing messages within the status bar.

Choose Edit>Preferences>Accessibility>Ignore Server Tab Order. 

If this option is selected, the hard-coded tab order is overridden, allowing the 
user to use top-down, left-to-right tabbing. 

To learn more about tailoring your system using Forms Designer, see the 
System Tailoring guide.

Logging In to ServiceCenter
Your system administrator sets up your user name to have certain 
capabilities. For example, as a Help Desk operator, you can open incident 
tickets in Incident Management, but you may not be able to change 
capabilities.

Sample users are shipped with ServiceCenter with each of them having 
different user rights. These sample users are for training, testing, and product 
demonstrations. This guide uses five of these users. The capabilities of each 
of these users varies depending on their jobs. Login names of the sample users 
and the types of users that they represent are as follows. Note that the login 
name of each user is typed in UPPERCASE letters.

BOB.HELPDESK—first-level help desk person

SUSIE.SUPERTECH—service technician (such as IS personnel) 

MAX.MANAGER—manager (personnel with approval authority)

FALCON—system administrator 

JACK—system user
26 Chapter 2—Getting Started 



User’s Guide
When you first access ServiceCenter, a login form prompts you to enter your 
user name and password (Figure 2-1).

Figure 2-1: ServiceCenter Login form

To log on to ServiceCenter:

1 Type one of the login names of the sample users in the Name field. 

The login is case-sensitive. For example, type BOB.HELPDESK. Notice that as 
soon as you type the B, ServiceCenter automatically fills in the rest of the 
name since this name is included in the login list. 

You can also select the login name from the Name field drop-down list.

2 By default, no password is required for the predefined users.
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3 Select a language if you want to use a language other than the default.

4 Click OK, or press Enter.

Note: When you select a language, ServiceCenter forms are automatically 
adjusted to that language’s default form width. This is done to 
accommodate the proportions of different languages. In the basic 
system, forms in English are widened by 25%. All other languages are 
widened to 50%. You can adjust the width further by pressing 
Shift+Ctrl+W. This command widens the form in 25% increments. To 
narrow the form, press Shift+Ctrl+N.

Logging Out of ServiceCenter

ServiceCenter provides several options for logging out.

To log out of ServiceCenter from any form:

1 Choose File>Exit ServiceCenter from the menu. 

A confirmation window displays asking if you want to end the current 
session.

2 Click OK to exit.

-or-

Click Cancel to return to the current ServiceCenter form.

To log out of ServiceCenter from the Home menu:

1 Click Logout. 

The logout form displays asking you to confirm that you want to exit 
ServiceCenter.

2 Click Exit.

-or-

Click Logout to exit this client session.

-or-

Click Home to return to the Home Menu.
28 Chapter 2—Getting Started 



User’s Guide
From the command prompt (administrator client):

1 Type Logout.

2 Press Enter.

No confirmation message displays. 

In text mode:

1 Type Logout.

2 Press Enter. 

No confirmation message displays. 

Note: For information on text mode, see the System Administrator’s Guide.
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ServiceCenter Interface
Each ServiceCenter form displays in a main ServiceCenter window. The main 
window contains a menu bar with options that vary, depending upon the 
ServiceCenter form that is active. Tool bars and system trays are provided on 
each ServiceCenter form displayed in the main window.

Figure 2-2: ServiceCenter Interface

Menu Bar Toolbar System TrayTitle Bar ServiceCenter Main Window
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ServiceCenter Home Menu

The ServiceCenter Home menu is the first window displayed after you log on 
to ServiceCenter. The Home menu displayed depends on how you are 
configured as a ServiceCenter user. This section explains some of the 
differences between the user and system administrator Home menus.

Help Desk Home Menu
ServiceCenter ships with a default help desk user profile (BOB.HELPDESK). 

When logging on as BOB.HELPDESK, the Help Desk home menu displays as 
follows:

Figure 2-3: Help Desk Home Menu

The tabs in the form shown in Figure 2-3 access options available to help desk 
users.

View System
Bulletin

Change my
Password

View
Contacts Directory

View my
Application Profiles

Tabs

Form 
Name

Application 
Buttons

Status Bar

System 
Tray-Logout

Insert/
Overlay 
Indicator

Search 
Incidents

Marquee

Queues 
Button
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Utilities tab

Maintenance tab

Figure 2-4: Help Desk Maintenance tab

Field Description

Take New Calls Creates new call reports.

Search Knowledge Accesses the ServiceCenter Knowledge Base. See 
Knowledge Base - Diagnostic Aids on page 561 for more 
information on the knowledge base.

View Work Queues Examines call, incident, and change reports.
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System Tray and Buttons

Figure 2-5: System Tray and Buttons

Field Description

Contacts Examines or creates contact records.

Locations Examines or creates location records.

Probable Cause Examines or creates probable cause records for Service and 
Incident Management. Probable cause records describe 
common symptoms and their resolutions.

Subcategories Examines or creates subcategory records for Service 
Management and Incident Management.

View System
Bulletin

Change my
Password

View
Contacts Directory

View my
Application Profiles

Tabs

System 
Tray: Logout 
button

Button Function

Logout Closes the ServiceCenter client that you are running. This 
does not affect the ServiceCenter server.

View Contacts 
Directory

Accesses a blank contacts record. From this form, you can 
search for information about customers.

View System Bulletin Displays a separate message window containing important 
status information provided by your system administrator.

Change my Password Allows you to change your ServiceCenter password.

View my Application 
Profiles

Accesses a user profile list that displays information about 
your user privileges as an operator and user of the 
ServiceCenter applications.
ServiceCenter Home Menu  33



ServiceCenter
Technician Home Menu
ServiceCenter ships with a sample user profile for a technician 
(SUSIE.SUPERTECH). The Technician Home menu is shown as follows:

Figure 2-6: Technician Home menu

Call Remote Manager View my Mail
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Button Function

Take New Calls Accesses Service Management to create a call report.

Search Knowledge 
Base

Searches the ServiceCenter database.

Call Queue Allows you to examine call reports.

Incident Queue Allows you to examine incident tickets.

My Work Orders Checks Request Management for work orders.

My Change Tasks Checks Change Management for tasks you need to complete 
in a change.

Call Remote 
Manager

If installed, accesses the Remote Management application.

View my Mail Accesses the ServiceCenter Mail utility.
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Manager Home Menu
ServiceCenter ships with a sample user profile for a manager 
(MAX.MANAGER). Managers have wider ranging capabilities than the other 
users, including approval authority. However, managers do not have 
administrative functionality.

Figure 2-7: Manager Home Menu—ServiceCenter tab

ServiceCenter tab

Button Function

Service Management Accesses the call queue.

Incident Management Accesses the incident ticket queue.

Change Management Accesses the Change Management menu.

Root Cause Analysis Accesses the Root Cause Analysis menu.

Request Management Accesses the Request Management main menu.

Check/Send Mail Exit ServiceCenter
36 Chapter 2—Getting Started 



User’s Guide
Inventory 
Management

Accesses the Asset Management menu.

Work Management Accesses the Work Management utility if installed. Work 
Management is added through a Custom installation. 
Refer to the Client/Server Installation Guide for Windows 
NT for more information.

Approve Requests Accesses the Request Management orders which this user 
can approve.

Find High Priority 
Incidents

Searches the ServiceCenter database for incident tickets 
marked as High Priority. The results are displayed in a 
QBE Record list.

Check/Send Mail Accesses the ServiceCenter Mail utility.

Exit ServiceCenter Closes the ServiceCenter client that you are running. This 
does not affect the ServiceCenter server.

Button Function
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Statistical Information tab

Figure 2-8: Manager Home Menu—Statistical Information tab

By clicking the corresponding number button in the graph, you can view the 
changes listed in that category.

Graph Description

Incidents by Priority Graphs the number of open incident tickets in the 
database based on ticket priority: 1, 2, 3, or 4. Click on a 
priority number button in the graph to view tickets with 
that priority.

Changes by Category Graphs the number of changes in the database according 
to the change category:

Application 
Server HW (hardware)
Hardware
Move/Add/Change
RFC
RFC - Advanced
Security
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Administrator Home Menu
ServiceCenter ships with a sample profile for a user with system 
administration privileges (FALCON). The System Administrator’s Guide 
describes in detail the role of the administrator and the applicable 
functionality.

Figure 2-9: Administrator Home menu

Logout

Command Line

Tabs

Status 
Bar

Call Remote 
Management

Exit 
ServiceCenter

ServiceCenter
Internal Mail

System StatusStart Command 
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Buttons

System Tray Buttons

Tabs

Using the Menus, Toolbar, and Buttons
The ServiceCenter main window contains a menu bar. Each menu, except 
Options and List Options, has the same choices in each form. The choices in 
the Options and List Options menus vary from form to form. 

The ServiceCenter tool bar is located at the top of each form. The tool bar 
provides shortcut buttons for choosing some of the menu options. Click the 
button to take the action represented by the equivalent menu option. 

Button Function

Call Remote 
Management

Accesses the Remote Management module.

Exit ServiceCenter Logs out of the current ServiceCenter client session.

ServiceCenter Internal 
Mail

Accesses the internal ServiceCenter Mail utility (unrelated 
to external email).

System Status Accesses the system status list to display status information 
about users and processes.

Button Function

Logout Logs you out of the current ServiceCenter client session. This 
button is the same as the Exit button.

Command Displays the ServiceCenter command prompt.

Tab Function

Services Accesses the main ServiceCenter applications.

Support Accesses the Contacts, Locations, Vendors, and Models files. See 
The Contacts File on page 547 for more information on the 
Contacts file. Refer to the System Administrator’s Guide for 
information on the Locations, Vendors, and Models files.

Utilities Accesses utilities used to administer and tailor ServiceCenter.

Toolkit Accesses applications that are used to customize ServiceCenter. 
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Many ServiceCenter forms also contain tabs. Tabs allow quick access to other 
applications or a set of grouped fields, which eliminates the need to open 
additional forms.

Status Light

Figure 2-10: Status Light

The status light in the ServiceCenter Home menu indicates current 
ServiceCenter activity. See below for the activity indicator color descriptions 
on the ServiceCenter status light.

Status Light

Activity 
indicator color

Status light description

Black Scrolling a table while more data is being pulled from the 
system.

Blue Packaging data to send to the server.

Cyan Requesting rows of information for a table, requesting active 
notes messages/heartbeat, or processing a form event.

Green Ready to interact.

Magenta Building the form.

Red Running RAD code on the server.

Yellow Running RAD code on the client.
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File Menu
The File menu contains these options:

File Menu Option Description

Print Screen Issues a command that prints the current ServiceCenter 
window on the printer selected in the Print Setup dialog 
box. The Print Setup dialog box is accessed from Client 
Page Setup in the Printing Options dialog box. The Print 
Screen option only applies to the current form displayed.

Print List Only available if an inbox or a QBE Record List displays. 
The list is printed to the user’s default ServiceCenter 
printer.

Printing Options Displays a dialog box, so you can configure ServiceCenter 
printing.

Client Page Setup—accesses the client platform print 
dialog box to select and configure a printer.
Client Font Setup—accesses the client platform font set 
to select a font to be used when ServiceCenter prints a 
record.
Print reports on—allows you to select where 
ServiceCenter reports are spooled for printing. The 
default is the server printer. An [S] displays in the right 
corner of the Status bar of a form if the server printer is 
chosen (as shown in Figure 2-3 on page 31). If the client 
printer is selected, a [P] displays. You can change this 
setting from any ServiceCenter form. Pressing 
Ctrl-Shift+P toggles between the two settings.

Note: Selecting Client printer ensures that reports are 
sent to a printer connected to the client. This option 
only operates when reports are printed in the 
foreground. Background print jobs are always 
performed using the server printer.

Limit client reports to <N> pages—sets the limit of 
report data sent from a ServiceCenter server to a client. 
Reports printed from a client are downloaded from the 
server. Some are lengthy, which prolongs the download 
time.

Note: ServiceCenter reads client print settings from the 
default print settings set within your operating system. 
To avoid the need to reset these settings from session to 
session, select the appropriate default settings outside 
of ServiceCenter. For instance, in Windows you can 
make default print selections from the Control Panel.
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Edit Menu and Toolbar Button

Figure 2-11: Edit Menu

The Edit menu and toolbar buttons provide standard text editing options for 
the current ServiceCenter form: Cut, Copy, Paste, Find, Clear, Select All, 
Magnify, and Spell Check. To use the Edit options, the cursor must be in a 
field. A field is an area where you can enter information. Text must be 
selected (highlighted) to use Cut and Copy.

The Edit menu’s Cut, Copy, Paste, Find, Clear, Select All, Magnify, and Spell 
Check options can be executed with standard keystroke shortcuts. For 
example, Ctrl+X executes a Cut operation in a Windows client. The shortcut 
keys differ between platforms. For Windows, the shortcut key is the Control 
key. For Windows and other platforms, the keys are displayed in the menu 
next to the options.

The edit options also can be executed using the buttons in the tool bar. See 
the buttons with descriptions of each edit option described below.

Client Side 
Load/Unload

Allows an Express client to perform loads and unloads to 
and from the client machine. If this option is not selected, 
loads and unloads are performed on the server.

Clear Messages Clears messages in the message pop-up window for the 
current client session.

Close Closes the current form. If the form is your starting 
ServiceCenter point, you are taken to the exit form to log 
out of ServiceCenter.

Exit ServiceCenter Logs you out of the current ServiceCenter session.

File Menu Option Description

Cut to clipboard Copy to 
clipboard

Paste from 
clipboard

Help on field View 
Messages

Edit window

Close 
application
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Note: The Cut, Copy, Paste, and Clear options only apply to the current 
form. If the field with the same information is repeated in multiple 
forms that are related, you need to use an update function to apply the 
change to all those forms. The update function is discussed later in this 
guide under the various applications.

Spell Check
The Spell Check Edit option is a standard text spell checker that verifies the 
spelling of text for any extended text field, such as the Description field in an 
Incident Management ticket, within a document. You can also check the 
spelling of a selected word(s) by highlighting and right-clicking the word.

Edit Option Description

Cut Removes selected text from a field and places the text on a 
clipboard. A clipboard is a location in memory where 
information is temporarily stored. If you cut text from one 
field, then Cut or Copy more text, the new information 
replaces the old information on the clipboard. You could 
use Cut to remove text that has been entered in the wrong 
field, but needs to be placed elsewhere.

Copy Places the selected text on a clipboard without removing 
the text from the field. You could use Copy if you wanted 
the same text placed in another field.

Paste Allows you to place cut or copied text into a field. You can 
repeat the Paste and place the information from the 
clipboard into multiple fields, or you can paste the text 
into fields in other forms. 

Find Searches for and highlights text in the current field.

Clear This is a menu option only. It deletes text from the field 
where the cursor currently is located. The text is not placed 
on the clipboard.

Select All Selects all of the text in the current field.

Magnify (Edit 
window)

Opens a pop-up window for editing the text in the current 
field. The text editor contains the following options to 
make text editing easier: Cut, Copy, Paste, and Clear.
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The Spell Check Edit option is available to Windows clients and Java clients. 
The functionality is the same for each client, but presentation of the spell 
checker slightly varies for each. Also, access to the Spell Check Edit option is 
different for each client type and is described below.

To activate the Spell Check Edit option:

1 Put the cursor in the extended text field in which you want to verify the 
spelling of text entered.

For example: You have entered a description of a reported problem in an 
Incident ticket and would like to verify the text within this field.

If you choose to have all the text verified within a document, begin the spell 
checker.

-or-

If you want to verify a selected word(s), highlight and right-click on the word. 
Begin the spell checker to verify the selected text.

For Windows clients, choose Edit>Spell Check to begin the spell checker.

For Java clients, click Spell Check in the tool bar or press Ctrl+S.

2 You are prompted with the Check Spelling dialog box where the words are 
verified for correct spelling against the spell checker’s dictionary. 

Figure 2-12: Check Spelling dialog box
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The Spell Check Edit options presented in the dialog box include:

3 When the spell checker is finished processing all the suggested changes and 
additions, the following prompt displays: The spell check is complete. 

4 Click OK to return to the previous form.

Note: ServiceCenter is using Wintertree Software's Sentry Spelling Checker, 
which uses Standalone Windows help engine (WINNT\winhlp32.exe) 
to display the help file. Therefore, if you open Help and then cancel the 
spell checker or exit ServiceCenter without closing the Help dialog 
box, the dialog box does not automatically close.

Options within the Check Spelling dialog box

When the following options are selected, the spell checker works as explained 
in each option below.

Spell Check Edit Option Description

Ignore Tells the spell checker to ignore this word and 
continue checking the rest of the text.

Ignore All Tells the spell checker to ignore this word or 
highlighted text and continue checking the rest of 
the text.

Add Adds a word to the dictionary, so that the spell 
checker recognizes it as a valid word.

Change Changes the misspelled word to the suggested word 
highlighted in the list of Suggestions.

Change All Changes all the words that are equally misspelled to 
the suggested word highlighted in the list of 
Suggestions.

Suggest Suggests a replacement word from the dictionary 
and displays in the list of Suggestions.

Dialog Box Option Description

Ignore capitalized 
words (e.,g., Canada)

Ignores words that are capitalized, yet not at the beginning 
of a sentence.

Ignore all caps words 
(e.g., ASAP)

Ignores words, such as acronyms, that are all in uppercase.

Ignore words with 
numbers (e.g., Win98)

Ignores words that contain numbers. Do not consider 
these misspelled.
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Ignore words with 
mixed case (e.g., 
SuperBase)

Ignores words with mixed case. Upper and lower case 
within a word is acceptable.

Ignore domain names 
(e.g., xyz.com)

Ignores domain names, which are not contained in the 
dictionary.

Report double words 
(e.g., the the)

Reports double words as errors, so that the second word is 
highlighted and can be deleted.

Case sensitive Looks for case-sensitive words. For example, if the month 
of april is all lower case, suggest the correct spelling of 
April.

Phonetic suggestions Suggests words that sound the same as the misspelled 
word that has been identified.

Typographical 
suggestions

When a word has been identified as being misspelled, 
suggests a list of similar words with their correct spelling 
from within the dictionary.

Suggest split words Suggests words that should be split. For example, if the 
spell checker identifies a word, such as follow-up, that 
should be split, suggest correctly splitting up the word into 
follow up.

Auto correct When the spell checker identifies a misspelled word and 
the operator clicks change, automatically corrects the 
word to the suggested word in the list.

Main dictionary 
language

If there are several language versions of a dictionary within 
the spell checker, selects the main dictionary language to 
be used, such as English.

Suggestions When the spell checker looks for suggestions from the 
dictionary for misspelled words, uses one of the following 
processes to determine how accurately and efficiently the 
suggestions should be found.

Fast but less accurate—use fast search with suggested 
results not being totally accurate.
Moderately fast and accurate—use a moderate search, 
which results in a more accurate list of suggestions.
Slow but accurate—use a slow search and have the 
results be as accurate as possible.

Dialog Box Option Description
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Dictionary options

Dictionaries are what the spell checker refers to when checking text for 
misspelled words within an extended text field. You can add, delete, import, 
and export words and word files. You can also add, create, and remove 
dictionaries so that you have multiple dictionaries, custom dictionaries, or a 
single dictionary.

Note: English only language dictionaries are supported.
Multiple language dictionaries are not supported at this time.

To work with dictionaries:

Open the Spell Check Edit option and click Dictionaries in the Check 
Spelling dialog box.

Click Add File to browse through your directories and add dictionary files 
to the Spell Check Edit option within your client.

Note: You can add a file, but this option is not supported at this time.

Click New File to create a custom dictionary and add it to the Spell Check 
Edit option within your client.

Click Remove File to delete the dictionary from your Spell Check Edit 
option files. 

Note: Be sure you are removing the correct file when you click Remove File, 
as the file is automatically deleted without any warning.

Preferences 
The Preferences Edit menu option contains Accessibility options that are 
available only to the Java clients. Java clients can choose to use the 
Accessibility options to gain optimum use of the ServiceCenter system.

To access the Preferences Edit options:

1 Choose Edit>Preferences>Accessibility.

2 From within the Accessibility Edit menu option, you have three choices:

a Access All Fields

Check this option to enable installed assistive technologies to read through 
tabbed fields, including read-only fields, on any ServiceCenter form, such 
as an Incident ticket.
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b Disable Animation

Check this option to disable the blinking status light and messages within 
the status bar. This helps to ease any distractions caused by the blinking 
status light or flashing messages within the status bar.

c Ignore Server Tab Order

If this option is selected, the hard-coded tab order is overridden, allowing 
the user to use top-down, left-to-right tabbing. 

View Menu
The View menu allows you to configure the features displayed in each 
ServiceCenter window. When an option is selected, a check mark ( ) 
displays next to the option. The View menu contains the following options:

View Menu Option Description

Toolbar Displays the ServiceCenter toolbar below the menus.

Status bar Displays the ServiceCenter status bar at the bottom of the 
window. The status bar is discussed later in this section.

Key numbers Replaces the icons on the system tray buttons with the 
function key (F Key) number and a label for each option. 
For example:

Tray captions Displays captions on the system tray buttons.

Tall tray Changes the height of the system tray from one row of 
buttons to two rows of buttons.

Dock tray on top Places the system tray at the top of the form. If this option 
is not chosen, the system tray sits above the status bar at 
the bottom of the form.

Active notes Instructs ServiceCenter to display the messages in a 
pop-up window. Active Notes must be selected for the 
ServiceCenter Publish and Subscribe feature to update 
messages, marquees, and graphs. Publish and Subscribe is 
discussed in the System Tailoring guide. If this option is 
not chosen, the messages appears at the bottom of the 
form.

Prompt for save Instructs a ServiceCenter client session to ask if you want 
to save any unsaved changes before exiting the record. 

becomes
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Format Menu
The Format menu has one option: Font. This option displays a dialog box 
that allows you to change the font display in all the ServiceCenter forms in 
your current client session.

Figure 2-13: Font dialog box

Command Line Displays the ServiceCenter command prompt to enter 
commands for accessing files, running applications, 
queries, scripts, and command shortcuts, searching 
command shortcuts, and changing the currently-active 
menu in Menu Manager. This menu option is only 
displayed for a system administrator.

Record list Displays the QBE Record list in a split interface at the top 
of a record, allowing the user to quickly browse records 
without switching forms. Clearing Record list from the 
View menu causes the QBE Record list to display in a 
separate window. 

Attachments Enables using and accessing attachments in forms.

Form name Displays the name of the current form in the status bar.

Screen name Displays the current screen name in parentheses in the 
status bar.

View Menu Option Description
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The Font dialog box contains the following fields:

Note: The availability of fonts depends on what fonts are installed on your 
system. How a font displays depends on the type and size of the font.

Sans serif fonts have no tails on the characters. Helvetica is a sans serif 
font.

Serif fonts have tails. The font used in this guide, New Century 
Schoolbook, is a serif font. Times is a common serif font that is used on 
many systems.

Variable fonts have different widths for each character. Helvetica and 
New Century Schoolbook are variable fonts.

Fixed fonts have the same width for each character. Courier is a fixed 
font.

Using font styles such as Bold or Italic also affects the spacing of the 
characters on a form. If labels are being clipped in the forms, select a 
different font, style, or size.

Options Menu
The selections available under the Options menu are dependent on the 
current ServiceCenter application and user profile record settings. The 
Options menu offers additional functionality tailored to specific forms.

Refer to the individual application chapters for information about Options 
menus.

Font Dialog Box Option Description

Font Sets a new font. 

Font Style Specifies how the font displays: Regular, Bold, Italic, 
or Bold Italic.

Size Sets the font point size (the font dimensions).

Sample Provides an example of the selected font settings.

Script Not applicable.
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List Options Menu
Record List must be selected in the View menu for the List Options menu to 
be active. If Record List is selected, the List Options menu becomes available 
when a list of records is being viewed. The selections available under List 
Options are used to control the list of records, and are dependent on the 
current ServiceCenter application. 

If Record List is cleared in the View menu, some of the selections available 
under the List Options menu may be available under the Options menu.

Help Menu
The Help menu provides online information about ServiceCenter. The Help 
menu contains two options:

Help Menu Option Description

Help on Field Provides general, online information about the field 
where the cursor is located. A box at the bottom of the 
form displays the help information.

Press F3 (end) to exit Help and return to the current form. 

About ServiceCenter Displays a window providing the ServiceCenter release 
number plus network, system, and hardware information 
about the client and server.

Click OK to close the window.
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Toolbar Buttons
In addition to the Cut, Copy, Paste, and Edit window buttons, also available 
as Edit Menu options, and the Help On field button, available as a Help 
Menu option, the toolbar includes the following buttons:

Toolbar Button Description

View Messages Displays a message pop-up window showing any 
messages currently in the status bar at the bottom of the 
form. An asterisk (*) preceding a message in the status bar 
indicates the message has multiple lines. To see all 
message lines in their entirety, click View Messages.

Active when error, alert, or warning messages are issued, 
but not for status messages, such as Ready. The color of 
this visual icon indicates the type of message waiting: Blue 
is a call to action, black is informational, and red indicates 
an error message. When messaging is active, 
ServiceCenter automatically displays the message 
window when a message is issued.

Close Application Returns you to the previous ServiceCenter application 
you were running. This option avoids repeatedly clicking 
Back and operates in a hierarchical method. If you are 
down one level from the Home menu, you are returned 
to the Home menu. If you are in a utility or application 
within one of the primary applications or utilities, such as 
Incident Management, you are returned to the previous 
level of the application or utility. For example, if you are 
searching the knowledge base from an incident ticket, 
Close Application returns you to the incident ticket.
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System Tray Buttons, Function Keys, and Pop-Up Menus
The system tray buttons represent standard ServiceCenter functions that are 
available for the currently displayed form. These options are also available by 
using function keys. 

Note: Functions accessed by system tray buttons and function keys can also 
be launched from the pop-up menu, which is accessed by clicking the 
right mouse button.

Function Description

OK Saves the information in the current form or executes the 
action to be taken by the current form, then exits to the 
previous form.

Add

(F2)

Creates a new record from the information in the current 
form.

New

(F1)

Opens a form to create a new record.

Refresh

(F2)

Updates queues.

Logout

(F3)

Logs you out of the current ServiceCenter client session 
(from the Home menu only).

Back

(F3)

Returns you to the previous form.

Cancel

(F3)

Returns you to the previous form without saving any 
changes you have made to the record.

Save

(F4)

Saves any changes you have made to the current form. 
Save is used in some applications to save a new record.

Delete

(F5)

Deletes the active record.

Search

(F6)

Searches (queries) the ServiceCenter database for a record 
matching the search criteria.

F7 Displays a list of related views (forms) for the currently 
accessed application or utility.
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A pop-up menu with options displays by holding down the right mouse 
button. Options available vary, depending on the form.

Function keys (F keys) also access these options. The function keys for each 
option are displayed in the pop-up menu.

The function key numbers can be displayed on the system tray buttons by 
choosing View>Key numbers from the menu bar.

Find

(F8)

Searches the database for values for the field where the 
cursor is placed. the record for the resulting information 
displays. A list of possible records displays if multiple 
records match the search criteria. If no matching records 
are found, an error message displays. Refer to Fill and Find 
Functions on page 68.

Clear Removes any data that has been entered in fields.

Fill

(F9)

Searches for values to populate the field where the cursor 
is placed. A list displays with possible entries for the field. 
The Fill function automatically fills the selected field and 
any linked fields with the appropriate information. For 
example, this feature populates an incident ticket with 
asset information when a Logical Name is specified. 
ServiceCenter looks at a link record for the information 
required. If no matching records are found, an error 
message displays. Refer to Fill and Find Functions on 
page 68.

Next

(F10)

Access the next record.

Previous

(F11)

Access the previous record.

Function Description
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You can also access a pop-up menu by right-clicking a field (such as the 
Contact field) that contains data that has been selected.

Figure 2-14: ServiceCenter Window with a Pop-up Menu Displayed

You can then cut or copy the selected text and paste the text into another 
field, including a field on another form.
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Field Buttons
ServiceCenter forms contain the following four field buttons, which perform 
the designated function for the associated field:

Status Bar

Figure 2-15: Status Bar

Status
When the Status bar option is selected in the View menu, the following 
information displays for both ServiceCenter and the current form.

The status bar displays:

Displays error and informational messages 

Indicates whether insert mode is active on the user’s keyboard 

Provides the current form name 

Provides the current screen name 

Indicates which printer is active 

Button Function

Fill button Activates the Fill function for a field. If partial information 
is entered, the appropriate records are accessed to fill in the 
associated information.

Down arrow Accesses a drop-down list with selections for a 
combination box.

Find Accesses a list of all possible entries for a field.

Dot Accesses a QBE Record list to change a value in a read-only 
field. 

Messages Response/Draw Insert/Overlay mode Form name Screen name
Active
Printer
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The status area displays the status of the current form, error messages, and 
ServiceCenter information. The status area tells the user what is or is not 
happening in the system. For example, the status area can read: 

“Ready”—the system is ready for user input. 

“Please specify a Category”—a required field, Category, was not 
populated. 

“Invalid syntax for query”—a query was entered improperly. 

Different icons appear in the status area depending on the type of message 
displayed. For example, if a required field has not been populated, a red 
exclamation point displays. 

The status area only displays a single line of text. If a message has multiple 
lines of text, an asterisk appears at the beginning of the message. The entire 
contents of the message area can be viewed in the Message Popup Window 
by selecting the View Messages button located in the tool bar or clicking the 
icon in the status bar.

Response/Draw
Toggles the Response Time Monitor (RTM) parameter and activates the 
statistics in the status bar of the current form.

Response—This is the response time of the server and the time spent 
executing the RAD code when the system leaves one form and enters 
another.

Draw—This is the time the system takes to redraw the form when 
changing the forms.

Insert/Overlay
Indicates if the keyboard is in the Insert or Overlay mode for entering data in 
the form. 

Insert mode allows you to add new text without disturbing the text that is 
currently in the field. 

Overlay mode allows you to type over existing text. 

You can toggle between the modes using the Insert key.
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Form and Screen Name
ServiceCenter has both forms and screens. 

Form name—refers to the format file that stores the attributes of the form 
being viewed.

Screen name—refers to the display screen file that defines the functionality 
of the form displayed. A user can access this record to tailor each form 
individually. 

The name of the current form displays on the right side of the status bar. The 
screen name displays to the right of the form name in parentheses. 

It is possible to toggle on and off in the View menu the form name and screen 
name.

Printer Selection
The letter immediately to the right of the form or screen name indicates the 
printing set up. 

[S]—Printing from this session outputs to the server’s default printer. 

[P]—Printing from this session outputs to the client’s default printer. 

It is possible to toggle between the two printing options. 

Press Ctrl + Shift + P. 

Choose File>Printing Options.

Fields
Fields are areas of the form where pertinent information for that record 
appears. That information might be an asset name or a description of a 
problem. You can enter information into some of these fields while other 
fields are filled in automatically by ServiceCenter. You can determine the 
type of a field by its display. 

Data entered and displayed in the fields is stored in the appropriate 
ServiceCenter records.
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Required Fields
Required fields are those fields necessary to complete a form. For example, if 
you are opening an incident ticket, a category is required.

These fields are denoted by a red triangle in the upper left-hand corner of the 
field.

If you do not enter data in this field before saving the record, an error 
message displays. In some forms, a list of possible values displays.

Protected Fields
Protected fields are those fields you cannot modify. Using the incident ticket 
as an example, the incident number field cannot be changed when you have 
accessed an existing incident ticket.

Which fields are protected is dependent on the form you are in and the 
configuration set up for you. Although you can place your cursor in a 
protected field, you cannot edit that field.

Working with Multiple Sessions
Working with multiple sessions on your desktop is a handy and efficient 
option that allows you to perform multiple tasks within the same client’s 
desktop. 

For example: You can open a call in Service Management, search for 
changes in Change Management, or open a new incident in Incident 
Management, all within the same client. 

To maneuver to and from each task, click the window you wish to make 
active to bring it to the front, allowing you to work in the selected task. When 
you are ready to move to a different session, either minimize the window you 
are currently in or click the next window to make it active and bring it to the 
top of your tasks. 

Required field
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Figure 2-16 displays working within multiple sessions in the Java client. For 
the Java client, select the sessions you would like to open from the tree 
navigation.

Figure 2-16: Working with Multiple Sessions in the Java Client
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Multiple Display Interface (MDI mode) versus Single Display 
Interface (SDI mode)
In Multiple Display Interface (MDI mode), ServiceCenter can display 
multiple ServiceCenter windows within an overall client session window. 
The menu bar remains displayed at the top of the main ServiceCenter 
window, and each form displays within the window. The system tray and 
toolbar display on each form within the window (Figure 2-18 on page 63), 
not at the top of the main ServiceCenter window as shown in the Single 
Display Interface (SDI) mode (Figure 2-17 on page 62).

Figure 2-17: ServiceCenter in SDI Mode
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If you wish to change to SDI mode, contact your system administrator to 
have the MDI feature disabled.

Figure 2-18: ServiceCenter in MDI Mode
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Record List mode versus Document mode
Users usually want QBE Record lists to display together above a form 
displaying data from one record on the list (Record List mode). Information 
from the highlighted list entry displays in the body of the form.

Figure 2-19: QBE in Record List Mode
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If you prefer, you can change the interface to display the QBE Record list in 
a separate window.

Figure 2-20: QBE list with Record List Mode Turned Off (Document Mode)

To turn off the QBE Record List mode:

1 Search for a record (for example, an incident ticket or call report) in any of 
the applications (for example, Incident Management or Service 
Management).

The record displays with the QBE list at the top of the form, as shown in 
Figure 2-19 on page 64.

2 Choose View>Record list to clear the option, which is selected. 

3 Click Cancel or Back to return to the previous form.

The QBE list is now displayed in a separate window, as shown in
 Figure 2-20 on page 65. This change is saved when you log out. The change 
affects only your account. 

You can change back to QBE Record List mode at any time by choosing 
View>Record list on the menu.
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Automatic Refresh of Record List
The record lists can be updated to display records that have been added. After 
a record is added you must close the function that is being used and re-open 
the function to display the added record. See the System Administrator’s 
Guide for more details about this feature.

Finding Data in Extended Text Fields

There are numerous extended text fields in ServiceCenter, such as the 
Incident Details field in an incident ticket, that contain large amounts of 
data, making it difficult for you to search through the history of a reported 
incident and find what you need. ServiceCenter includes a find capability 
that helps you easily find the information you need.

When you’re in an extended text field, such as a lengthy description of an 
incident in Incident Management, you can initiate a search within that field 
to find the information you need. 

To initiate a search of a text field:

1 Place your cursor in the extended text field you want to search.

2 Click Edit window.

An editing shortcut window displays, displaying the selected text.

3 Choose Edit>Find or press Ctrl + F.
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A dialog box for searching the text field displays. 

4 Select the appropriate options for your search from the following table.

5 Click Find Next.

The first instance of the search is highlighted.

6 Click Find Next again to find the next instance of the search.

7 When you are finished with your search, exit out of the shortcut editing 
window. 

You are returned to the original field where you started the search.

Field Description

Find What Initiates the IR Expert search so that you can locate specific text 
within the field. 

Search Allows you to search the extended text field and find historical 
data or comments without having to scroll through multiple 
lines of text.

Match Case Allows a search for specific words or phrases that match the 
‘case’ with which they were typed. For example, all capitalized 
letters and lower case letters should match the original typed 
text. This helps you to locate instances where acronyms may 
have been used, helping to limit your search so that you can 
quickly find what you need.

Find Whole Words 
Only

Allows the search to find only instances where whole words are 
used (Partially typed words are not located.).

Cancel Allows you to cancel the search and return to the View 
Messages window.
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Case-Insensitive Mode in P4 Database
Case-insensitive mode exists so that you can enter user information into the 
P4 database without having to consider the case sensitivity of the alphabetic 
lettering. This optional mode can be very useful, since you do not have to be 
concerned with whether or not database information has been entered in all 
uppercase, all lowercase, or first letter only as uppercase, etc. Before you 
consider turning on the case-insensitive mode, read all about it in the 
Database Management and Administration Guide, so that you are aware of the 
ramifications of turning on, and back off again, this optional mode.

Fill and Find Functions 

The Fill and Find functions query the database for information, such as 
component or location. The query can be done from another ServiceCenter 
application. For example, data from an asset record in Asset Management 
can be accessed from an incident ticket in Incident Management. 

Note: The down arrow to the right of a field, accesses a drop-down list of 
possible entries for a field.

Fill Function

Fill Functionality for a Single Field
The Fill function allows you to quickly enter data into a record, such as an 
incident ticket. If partial information is entered in a field, the Fill function 
finds the appropriate record and adds any related information. For example, 
if you enter Br in a name field and click Fill, ServiceCenter finds the record 
for Nicholas Brown, along with the assets linked to his contacts record.
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To use the Fill function for a single field:

1 Place the cursor in the field that you want to fill.

2 Do one of the following:

Click Fill to the right of the field, if available.

Click Fill in the menu bar.

Press F9.

A QBE Record list displays with possible entries for the selected field.

Note: If Fill functionality isn’t available for a field, you receive the following 
error message: No link exists for this field; fill function cannot be 
performed.

3 Double-click the record you want to use. 

The field and any other related fields are filled.

Fill Functionality for Array Fields
The Fill function for array fields allows you to select multiple values for the 
array. 

To use the Fill function for a multiple fields:

1 Place the cursor in the first field that you want to fill.

2 Click Fill or press F9.

3 Select the appropriate record(s) using one of the following methods:

Click Fill All if you want all records added.

Select all records one at a time by clicking each row that contains the 
record you want to add.

Choose Options>Toggle Multiple Selection. Toggle Multiple Selection 
allows you to select more than one record at a time. 

When Toggle Multiple Selection is activated, the title bar reads, “Select 
Related Records Multiple Selections are ENABLED.” (If the Toggle 
Multiple Selection is not activated, the title bar reads, Select Related 
Records Multiple Selections are DISABLED.”)

Each time you select a record, a message displays in the status line 
indicating, # records filled, where # is the total number of records selected 
thus far.
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Find Function
The Find function allows you to locate data for selected fields by accessing a 
related field in a different ServiceCenter file. Certain fields have link records 
that allow Find to locate related details for that field. Find locates and 
associates records for fields, such as asset, logical or contact names, locations, 
vendors, or users (for example, Reported By in an incident ticket).

A record can be viewed or modified within the application in which it was 
created. As an end-user, your options are determined by the rights assigned 
by your ServiceCenter administrator. For example, you may be able only to 
view, not modify, Asset Management records.

To use the Find function:

1 In any editable form, place the cursor in the field where you want to view the 
related ServiceCenter records. You can enter partial data in a field to narrow 
the search.

2 Click Find, or press F8.

A record with information related to that field displays.

If no records are found, or the selected field is not linked to the Find function, 
an error message displays in the status bar.
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The result of a Find query run on a Reported by field in a call report is shown 
in The Contacts File on page 547. The Contact Information form displays 
with information about the name (Brown) entered in the Reported by field 
on the call report. 

Figure 2-21: Contact Information Record

To leave the related record, do one of the following:

Click Cancel, OK, or Close.

-or-

Press F3 to return to the form from which you ran Find.

Note: The information from the record is not placed in the form from which 
you accessed Find. Use Fill to enter data automatically.
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Changing the Column Headings in a QBE Record List

You can change the information included in a record list by changing the 
columns that are displayed in the list.

To change the columns in a QBE Record list:

1 With the QBE Record list displayed that you want to modify, choose List 
Options>Modify Columns (or the Options menu if Record List mode is not 
active).

A form displays that allows you to select the columns you want to change in 
the record list.

Figure 2-22: Form for Modifying QBE Record List Columns

2 Click the Down arrow for each column you want to change, then select the 
new heading from the drop-down list.

3 If you want to add a column, select a column heading from the drop-down 
list next to a blank field.

4 If you want to add a column heading between two existing headings, place 
the cursor in the field below where you want to add a new line. Click Insert 
Line.

5 If you want to delete an existing line, place the cursor in the field you want to 
delete. Click Delete Line.
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6 When you have completed your selections, click Proceed.

The QBE Record list displays with new column headings and related 
information filled into the list (Figure 2-23 on page 73).

-or-

Click Back to cancel your selections.

Note: The changes you make to the columns are saved when you log out. 
These changes are made to your account only and do not affect other 
users.

Figure 2-23: Incident Ticket with Modified Column Heading
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To return to the default column settings:

1 With the QBE Record list displayed, choose List Options>Modify Columns 
from the menu.

2 Click Use Default.

The QBE Record list displays showing the default column headings.

Navigating Tabs

Many ServiceCenter forms use tabs. Instead of opening multiple forms, you 
can click on a tab to get a specific area of information in a record.

For example, if you access the Asset Management PC asset form, you see tabs 
for System Summary, Components, Software, and so forth.

To select a tab or switch between tabs:

Click a tab.

Press <Shift> <Ctrl> I to navigate between tabs.

Press the Tab key to move to the first tab. You can then use the keyboard 
arrow keys to navigate back and forth between tabs.
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Use the arrows at the end of the tabs to access more tabs. 

Figure 2-24: Sample Asset form with Tabs
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Bitmaps

ServiceCenter can store bitmaps directly into the ServiceCenter database, 
regardless of the type of physical database being used. Whether you are trying 
to attach a picture of a location in the Attachments tab of a Change ticket or 
trying to attach an Excel spread sheet to a new contact record, the option to 
attach and save these bitmaps is available. Your forms can be set up to attach 
bitmaps by going into the Forms Designer utility. See the System Tailoring 
guide for information about designing your forms to have the correct 
properties set to attach bitmaps.

Right-Click Options for the Java-Based Client
When you right-click a bitmap within a Java-based client, you are presented 
with the following options:

Open—opens the bitmap file.

Open With—opens the bitmap file with the application of your choice.

Save As—saves the bitmap file into the directory/file of your choice. You 
are given access to your computer neighborhood where you can browse to 
find the location of choice to save and store a copy of this file.

Copy

Cut

Delete

Insert File

Add

OK

Cancel
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Inboxes 

Inboxes allow you to save queries to quickly and easily conduct a search with 
the same parameters for any file within the system. Frequently used inboxes 
can be saved within the Current Inbox list. See the Application 
Administration Guide for more information on maintaining Inboxes. As a 
way of sorting the information within queries, Inboxes are based on 
parent/child relationships. All queries are filtered through the parent query. 
For example, a child query of Open Incidents Assigned to Me filters through 
the parent query All Open Incidents.

This section gives instructions for creating and using inboxes. Specific 
instructions for application inboxes are included in the chapters for each 
application. Also see the Application Administration Guide for information 
on maintaining inboxes.

Note: Inboxes are available for all files whether you are working within a 
utility or an application. By default, inboxes are automatically set up 
for Service Management, Incident Management, Root Cause Analysis, 
Change Management, and Request Management. Also, inboxes are 
only available to you in the application where your user profiles allow 
their use.

Creating an Inbox Definition 
Inboxes are used in most ServiceCenter applications and can be defined for 
any file within ServiceCenter. 

Once inboxes are established, queries can be viewed and modified within an 
inbox. Queries can be saved to update the contents of an inbox. For example, 
you may want to search for all incident tickets with an alert status of Deadline 
Alert for a specified user. Instead of configuring these search parameters each 
time, click Switch Inbox and select a different inbox or go to your Current 
Inbox list for quick and easy access.
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To create a new inbox:

1 Click Search in a menu or queue.

A Search form displays. An example of an Incident Management search form 
with basic search fields displayed is shown in Figure 2-25.

Figure 2-25: Incident Management Basic Search Fields

2 Enter search parameters in the Basic Search, Advanced Search, or IR Query 
tabs. See Search Incident Management on page 206 for details on the search 
tabs and descriptions of their fields.

3 Click Search or press Enter.

A QBE Record list of matching records displays, with the first record in the 
list displayed in the form.

Note: If only one record matches the search, that record displays. If no 
matching records are found, a message displays stating No Records 
Found.
78 Chapter 2—Getting Started 



User’s Guide
4 Choose List Options>Save List as Inbox (if Record List is selected in the 
View menu) or choose Options>Save as Inbox (if Record List is cleared in 
the View menu). 

Note: This option only displays if your User Profile for this application 
allows you to create inboxes.

The following question displays in a pop-up window: Save this record as an 
inbox?

5 Click Yes.

An inbox edit form displays. The This is an inbox of type field is filled in 
automatically.

Figure 2-26: Incident Management Inbox Edit form

6 Enter a name for the inbox in the What would you like to call this inbox? 
(Use a short name if possible) field.

7 From the This inbox should be visible to field drop-down list, select which 
users can see the inbox:

Only Me—only the creator (you, the user) of the inbox. This is the default 
setting.

All Users—all users, according to application, such as all IM users.
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8 Advanced administrators only: in the This inbox should be sorted by field, 
specify a sort sequence that matches an existing key, if needed to select the 
appropriate key for this query. Use this option only if truly needed and if you 
understand the file’s key structure enough to ensure a fully keyed query.

9 Click the Advanced Options tab.

Figure 2-27: Inbox Edit form—Advanced Options tab

The This inbox is defined by (Only advanced users should change this) field 
displays the syntax that defines the query. A default setting of true is 
automatically placed in this field. 

Note: This field should be changed only by an advanced user with knowledge 
of query language. 
If the query is not fully keyed (doesn’t have a matching key in the 
dbdict), you can experience server performance problems with 
ServiceCenter. Make sure that inbox queries are tuned for your 
database.

The Normalize Date Fields option (default setting) allows Incident 
Management to modify a query to search from the current date, not the date 
the inbox was created. For example, if you create an inbox on March 1 to look 
for incident tickets opened before March 1, and today is March 7, the query 
is normalized to look for tickets one week from the current date because one 
week has passed since the inbox was created.
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The Use Literal Date Fields option, if chosen, causes the inbox to always 
query from the date it was created. If you created an inbox on March 1, 2001 
to look for tickets before that day, whenever this inbox is accessed, the query 
looks for tickets before March 1, 2001.

10 Click the Information tab if you want detailed descriptions of all the fields in 
all the tabs on this form.

11 Click Save, or press F2. 

A message displays, stating that the inbox definition has been added.

Note: To view the new inbox, you must exit your ServiceCenter client and 
log on again. 
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Using Inboxes
Inboxes are used within queues. Except for buttons that are specific to an 
application, each queue contains the same buttons. Components of a queue 
are shown in Figure 2-28.

Figure 2-28: Incident Management Queue

Access Buttons
Access buttons allow you to search the database or create a new record (for 
example, a call report, incident ticket, change record, or change task).

New starts the process to create a new record.

Search accesses the search function.

Access Buttons

Queue Selection 
Buttons

Inbox List

Control Buttons

List Header 
Buttons
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Control Buttons
These buttons allow you to control which inbox displays. The buttons allow 
you to move between inboxes and ServiceCenter applications, change the 
lists, update (refresh) a list to include the latest records, and count the 
number of records in a list.

Queue Selection Buttons
These buttons allow you to select the application queue to display. The 
buttons allow you to access other application queues without going back to 
the main menu to access the new application.

Note: The button for the currently accessed application is not displayed.

Call Queue—accesses the initial Call List. This button is also used to access 
Service Management from other menus.

Incident List—accesses the initial Incident List. This button is also used to 
access Incident Management from other menus.

Switch Inbox—displays a dialog box 
in which you can select another 
inbox associated with that queue. (If 
you are in Incident Management, 
only IM inboxes are available.)

Starting Lists—returns to your 
default inbox for this queue.

Refresh—updates the currently 
displayed list.

Count—tallies the number of 
records in the currently displayed list 
and displays a message box with the 
results.

Back—returns you to the previous 
form.
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Root Cause List—accesses the initial Root Cause List. This button is also 
used to access Root Cause Analysis from the other menus.

CM Change List—accesses the initial Change List.

CM Task List—accesses the initial Task List.

RM Quote List—Accesses the Request Management quote QBE Record list.

RM Order List—Accesses the Request Management order QBE Record list. 

RM Line Item List—Accesses the Request Management line item QBE 
Record list

Inventory Management—Accesses the Asset Management menu Resources tab.

Header Buttons
Header buttons provide labels for the list columns. The labels vary between 
applications. By clicking on a header button, you can order the list according 
to that heading.

Current Inbox Drop-Down List
This list provides a subset of all inboxes from which a user can select one. It 
functions like a favorites list and can contain entries for all queues and not 
just the current one.
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Inbox List
This list provides the results of the search conducted by the current inbox. 
For some users, a general list displays when an inbox is first accessed.

You can select a record in an inbox list by double-clicking the listing. 

Editing Records

When you access a ServiceCenter record, the form first displays in view mode. 
View mode means the record is not locked and no conflict resolution 
management is required. As soon as you place start typing in a field, or 
otherwise start to change the record, ServiceCenter attempts to lock the 
record. This is a background process and is often transparent to the user. This 
process locks the user into the record and prevents other users from 
simultaneously editing the same record. To do this, ServiceCenter checks the 
record to see if another user is using that record and creates the following 
scenarios:

If the record is in use, a message displays indicating another user is 
updating the record.

If the record is not in use, but you do not have the current version of the 
record, you are prompted to refresh the record.

If the record is not in use and you have the most current version, you may 
continue typing without interruption.

Inbox Search Result Description

Switch Inbox Changes the list to display the results of the search for a 
different inbox in that application.

Inbox Selection 
Buttons

Changes to an inbox in another application.
Editing Records  85



ServiceCenter
Manual Saving
To manually save changes in records:

1 Click OK, or press F2 or Enter. This updates the record and returns you to 
the previous form.

2 Click Save, or press F4. This updates the record and leaves the current form 
displayed.

Autosaving
ServiceCenter records are automatically saved (autosaved) when certain 
actions take place in a writable record if the record has been updated. A 
record is autosaved when you:

Click Back, or press F3.

Click Next.

Click Previous.

Note: Clicking Cancel does not autosave the current record.
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3
 The Java Client Desktop
The Java client for ServiceCenter includes an interface that incorporates a 
tree-based method of navigation called ServiceCenter Explorer. The previous 
menu-based method of navigating through ServiceCenter is still available for 
those users who are more comfortable with menu-based navigation. 

In addition to the ServiceCenter Explorer menu, unique features in the 
ServiceCenter Java client include:

Multiple Document Interface (MDI) support

A Favorites Bar, similar to that found in Web browsers

Frequently used forms access

Restore Forms on Startup option

Multiple sessions ability

Activity indicator in the status bar

Message button in the status bar

Save windows on exit

The Java client also supports hyperlinks, such as, http://, mailto:, and ftp://, 
in a text field. Clicking a link automatically launches the default browser if 
you're running the client as an application. Links are shown as blue, 
underlined text within the field. When the cursor is over a clickable link, 
it changes to a hand.
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The Java client incorporates user interface enhancements only, so the forms 
with which you interact and the functionality of those forms remains the 
same throughout ServiceCenter.

The two features you are likely to notice and appreciate most are the MDI 
support and the ServiceCenter Explorer. Using ServiceCenter Explorer, you 
can quickly drill down to a form. MDI support allows for easy management 
of multiple open forms (see Multiple Display Interface (MDI mode) versus 
Single Display Interface (SDI mode) on page 62).

You should note, however, that the ServiceCenter Explorer and Menu forms 
views are completely independent of one another. For example, certain 
actions can only be performed with the ServiceCenter Explorer. Also, forms 
available in the ServiceCenter Explorer tree and forms available in the 
form-based menus may differ, depending on how your server has been 
configured.

The ServiceCenter Java client displays as an applet within a Web browser, or 
as a standalone Java application. 
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Java Client Features

The Java client has several unique features that operate differently than the 
standard Windows client. The forms, methods, and process used have not 
changed; however, the method of access has changed. In addition, users can 
revert to the traditional Windows client look and feel by selecting the 
forms-based navigation feature from the menu bar. See Switching Between 
Forms and ServiceCenter Explorer on page 92.

Figure 3-1: The Java Client Interface

ServiceCenter Explorer
(tree-based navigation)

Desktop Area

ServiceCenter Menu Bar

Form-Specific Tool Bar

Favorites Bar

Message Button
Activity Indicator
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ServiceCenter Explorer: Tree-based Navigation 
The ServiceCenter Explorer is a tree-based navigation component that allows 
you to quickly drill down the menu hierarchy to get to the forms with which 
you want to work. In addition, system administrators can customize the 
Explorer tree. See the Java Client Installation and Configuration Guide for 
more information.

The options a user sees are the same as the Menu forms based navigation 
area. Users only see and are able to access those areas for which they have 
privileges, as with the form-based navigation system.

The Favorites Bar, Frequently Used forms menu, and Restore Forms on 
Startup options are only enabled when using the ServiceCenter Explorer.

Note:  Forms available in the ServiceCenter Explorer tree and forms 
available in the form-based menus may differ depending on how your 
server has been configured.

ServiceCenter Explorer menu with both available and unavailable 
forms shown. Grayed out forms are unavailable to this user. 
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Testing Client Server Bandwidth
Press Ctrl-Shift+S, while Java client is the active window, to test the 
transmission speed between the server and the Java client. This test takes 
about 15 seconds, sending small packets of data to the server and displaying 
the results in the Message window (see Figure 3-2 on page 91). This a quick 
test of the network for trouble-shooting purposes, and differs from the 
About Connection Speed option available from the options menu.

Figure 3-2: Active message window

Printing From the Java Client
The Java client print behavior is set in the sc.ini file. See the Java Client 
Installation and Configuration Guide for more information. The options set 
in the sc.ini file do not affect the first three options available from the File 
menu. 

The first three print options found under the Java client File menu are set to 
always Print on Client.

The first three options available under the File 
menu are not affected by the settings in the 
sc.ini file.
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For example, if the sc.ini file is set to “Print on Server,” and the user selects 
either Print Window, Print List, or Print Preview from the ServiceCenter File 
menu, then the print jobs use the client’s default printer.

If this same user selects Print List from the List Options menu, then the print 
jobs use the server’s primary printer, as specified in the sc.ini file. 

Switching Between Forms and ServiceCenter Explorer
When the ServiceCenter Java client first starts, ServiceCenter Explorer 
navigation is turned on by default. To change the default so that the Menu 
Form is displayed at startup, see the ServiceCenter Java Client Installation 
and Configuration Guide.

To switch between Menu Form and ServiceCenter Explorer navigation:

1 Open the Java client.

Note: If you installed the Java client to a local or network directory, the 
ServiceCenter server must be started in order for the Java client to be 
launched. In addition, if you installed the Java client to a Web 
directory, then your Web server must also be running. 

Click View on the ServiceCenter menu bar. 

2 Select SC Explorer. The check mark next to the SC Explorer option is 
removed and the familiar form-based main menu of ServiceCenter displays 
on the desktop. 

3 To turn off Menu Forms, repeat the previous steps and make sure there is a 
check mark next to SC Explorer.

Menu Forms turned off, and ServiceCenter 
Explorer navigation selected
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Dynamic Toolbars
The Java client displays forms on the desktop portion of the Windows 
display. Each form in ServiceCenter has a specific set of options associated 
with the form (Figure 3-1 on page 89). Switching to a different form loads 
that form’s toolbar options.

Toolbars, menu items, and options are all form specific and dynamically 
update to reflect the currently active form on the desktop.

Hiding ServiceCenter Explorer
You can hide or show the ServiceCenter Explorer by clicking either the right 
or left arrows next to the ServiceCenter Explorer menu. Click the left facing 
arrow to expand the desktop area and hide the ServiceCenter Explorer menu. 
Click the right facing arrow to push back the desktop and expose the 
ServiceCenter Explorer menu. Click the right arrow once more to hide the 
desktop.

Hiding the ServiceCenter Explorer tree does not disable the feature, as 
selecting the Menu forms option does.
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You can also adjust the relative width of the ServiceCenter Explorer by 
clicking and dragging the vertical separator bar. 

Figure 3-3: Hiding ServiceCenter Explorer

Controlling Forms
Multiple forms can be displayed on the Java client desktop by tiling, 
cascading, or floating the forms. The Java client also allows you to remember 
open forms when you exit and reopen them the next time you login. 

Note: The Save Windows on Exit option is only available if you are in SC 
Explorer view. 

To access the form window options:

1 Click Window on the Java client menu bar.

Hide the desktop or the 
Explorer by clicking an 
arrow. 
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2 Select the display option. Your choices are:

Display Option Description

Tile Each form is assigned a section of the Java client 
desktop with a portion of all open forms visible. You 
can choose to tile horizontally or vertically. 

Cascade Forms stack behind one another, with a portion of each 
form visible. Clicking on a form brings it to the front.

Close Selecting this option closes the currently active form on 
the Java client desktop. 

Close All Closes all open forms. Floating forms are not affected.

Float  Floating a form allows you to move the currently active 
form out of the Java client to anywhere on your 
computer desktop. Drag the currently active form 
anywhere on your computer’s desktop by clicking and 
holding on the form’s title bar. Refer to Figure 3-4 on 
page 96. 

Restore Forms on 
Startup

With this option enabled, any forms that were open 
when you closed the Java client or logged out of 
ServiceCenter are displayed the next time you start the 
Java client. This feature is turned off by default. See 
Restore Forms on Startup Option on page 102 for more 
information.
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The names of any open forms are displayed at the bottom of the Window 
menu. Click on a form name to bring that form to the front.

Figure 3-4: Floating a form out of the ServiceCenter Java client 
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Changing the Desktop Color
You can change the color of the Java client desktop.

To change the desktop color:

1 Right-click anywhere in the desktop area. 

The Set Desktop Color option displays. 

2 Click Set Desktop Color. 

A color chooser displays.
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Choose a new color by clicking on the color you want, and then click OK.

3 The new desktop color is applied.

The desktop color information is saved and displays the next time you start 
the ServiceCenter Java client 

Favorites Bar
The Favorites Bar allows you to access forms that are used on a regular basis 
with one click, similar to Netscape’s bookmarks or Internet Explorer’s 
Favorites Bar. 

Placing Forms
To place a form on the Favorites Bar:

1 Open ServiceCenter with the ServiceCenter Explorer navigation view 
selected. 
See Switching Between Forms and ServiceCenter Explorer on page 92.

2 In the ServiceCenter Explorer menu, right-click on the name of the form you 
want to place in the Favorites Bar. 

A shortcut menu with two options displays.
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3 Select Add to Favorites. The form name is placed on the Favorites bar. 

Although you can only place forms on the Favorites Bar from the 
ServiceCenter Explorer view, once they are placed you can access your 
favorites from either the Forms Menu or ServiceCenter Explorer views. 

Renaming Forms
To rename a form currently on the favorites bar:

1 Right-click the form name on the Favorites Bar. 

A shortcut menu displays.

2 Select Rename. 

The name changes to an editable text box. 

3 Type the new name of the form and press Enter. 

The form name on the toolbar changes to the new name. 

Renaming a form affects the name of the form only as it displays on the 
Favorites Bar.

If there are more forms on the Favorites bar than can be displayed at once, a 
Browser button displays on the right edge of the Favorites Bar, indicating 
there are forms on the Favorites Bar that are hidden from view. Click the 
button to view a drop-down menu listing the hidden forms. 

Accessing Forms
To access a form from the Favorites bar:

Click the form name on the Favorites bar. 

Deleting Forms
To delete a form from the Favorites bar:

1 Right-click the form name on the Favorites bar. 

A shortcut menu displays.

2 Select Delete. The form is removed from the Favorites bar. 
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Using the Message Button
The Message button is located on the far left side of the Status bar (see 
Figure 3-5) and acts as a toggle to allow you to turn on and off the active 
messages window display. 

Figure 3-5: Viewing active messages via the Status bar’s Message button

Click Message once to see the active ServiceCenter Messages window display 
(Figure 3-6).

Figure 3-6: Active message window

Click Message again to close the Messages window.

Message button
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The Frequently-Used Forms Menu
The Java client automatically tracks the forms you work with most often, and 
lists them in the Frequently Used Forms menu.

To open a form with which you frequently work:

1 Click View from the menu bar. 

A shortcut menu displays.

2 Select the Frequently Used menu option. A submenu displays, listing up to 
ten forms and starting with the form that is most frequently used.

3 Click on the name of the form you want to access. The form displays on the 
Java client desktop. 

This feature is only available when using ServiceCenter Explorer.

Figure 3-7: The Frequently Used Forms menu
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Restore Forms on Startup Option
The Java client includes a Restore Forms on Startup option. Suspending a 
session simply means that any forms that were open when you close the Java 
client or logged out of ServiceCenter are displayed the next time you log on 
to the Java client. This feature is turned off by default. 

Note: The Restore Forms on Startup option is bypassed if you exit the Java 
client through the browser controls.

To enable the Restore Forms on Startup option:

Choose Window>Restore Forms on Startup on the Java client menu bar.

When you exit the Java client with a form open, the save session dialog box 
displays.

All open forms are displayed with a check mark next to the form name, 
indicating the forms are opened when you start your next ServiceCenter 
session.
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Turn Off Restore Forms on Startup Options

Don’t ask again—if you select the Don’t ask again check box and click OK, 
then all forms are deselected and the Restore Forms on Startup option is 
turned off when you start your next ServiceCenter session. You can choose 
Don’t ask again and then select a form to open on return. The form you select 
will open when you start your next session, but the Restore Forms on Startup 
option will be deselected.

Note: The actual state of a form cannot be restored unless you save the form 
before suspending your session. Also, any sub-forms that were opened 
as a result of working with a particular form will not be restored.

Option Description

All Places a check mark next to all forms, indicating they are 
opened automatically when you start your next 
ServiceCenter session.

None Removes check mark from all forms, indicating no forms 
are opened when you start your next ServiceCenter session.

OK Confirms your choices and ends your ServiceCenter 
session.

Cancel Cancels the exit option and returns you to the 
ServiceCenter Java client. 
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CHAPTER

4
 Service Management
ServiceCenter’s Service Management allows you, as a help desk operator, to 
document and track the calls that you receive. Service Management provides 
one-button access to other ServiceCenter applications to automatically enter 
information received in the call.

Information in a call can be:

Used to open an incident ticket.

Note: An incident ticket was referred to as a problem ticket in earlier releases. 
Problem Management was renamed to Incident Management to 
better align with the naming scheme used in the Information 
Technology Infrastructure Library (ITIL). See the Introduction and 
Best Practices guide for more information.

Added to a record in another ServiceCenter application, such as Change 
Management.

This chapter describes Service Management, including:

Accessing Service Management on page 106

How Service Management Works on page 108

Call List in the Call Queue on page 112

Search Call Reports on page 117

Call Reports on page 122

What is a Category? on page 109
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Accessing Service Management

The examples in this chapter are based on the default first-level help desk 
support user, BOB.HELPDESK. Instructions for starting a client and logging 
on are provided in Getting Started on page 23.

To access Service Management:

1 Start a ServiceCenter client. 

2 Enter the user’s name in the Name field.

For this example, enter BOB.HELPDESK. 

3 Enter the password, if necessary, when prompted.

Note: The BOB.HELPDESK user does not have a password by default.

4 Click OK, or press Enter.

The Home menu for the user logged in as BOB.HELPDESK displays.

Figure 4-1: Help Desk Home menu
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Service Management Option Buttons
Take New Calls—serves two functions, depending on the user. For a help 
desk operator or a technician, this button accesses a blank call report form to 
enter information from a customer call. From this form, you can open a call 
report to log the call, check for related call reports, and add call information 
to other ServiceCenter records, such as an incident ticket. For a system 
administrator and a manager, this button provides general access to Service 
Management. 

View Work Queues—allows you to check the Incident queue, Call queue, 
Root Cause list, Change and Task lists, and Request Management Quotes and 
Order lists for all users, yourself, or another user.

Search Knowledge Base—accesses the ServiceCenter Knowledge Base search 
form. The Knowledge Base is discussed in Knowledge Base - Diagnostic Aids 
on page 561.

If you have access to the various ServiceCenter applications and utilities, you 
can use the menu tabs that are displayed in your home menu to access each 
of the applications and utilities. The availability of applications is dependent 
on the configuration your system administrator has set up in your Operator 
Record.0
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How Service Management Works

Network users run into problems or have needs with their computers or the 
services associated with the computer, such as printing. The users call their 
help desk for assistance. ServiceCenter operators can create and view call 
reports.

Service Management allows you to keep track of calls by opening (creating) 
and viewing call reports. If a reported issue requires further action, you can 
open an incident ticket to track an incident. See Figure 4-2 on page 111 for the 
workflow of the call report and incident ticket process.

Each contact with the help desk is designated as a call. Out-of-the-box, the 
contact can be a telephone call or e-mail. You, as the help desk operator, open 
a call report with the user’s name, the component with the problem, and a 
description of the incident. Once this information is collected, you can:

Close the call report if the contact was informational or the incident was 
resolved without requiring an incident ticket. 

Look for existing incident tickets affecting either the same component or 
one of the component parent assets. If such an incident ticket exists, the 
operator can associate the call report with the ticket in question. If an 
incident ticket does not already exist, the operator can open an incident 
ticket based on the call. Pertinent information from the call report is 
automatically copied into the newly created incident ticket.

Example: A user cannot print to the network printer. The user calls the help 
desk. You, the ServiceCenter operator, enter the information in a call report. 
The problem cannot be resolved during the call, so you open an incident 
ticket. The ticket is assigned to IS. A technician discovers that the printer 
network connection is broken. The technician fixes the problem and closes 
the ticket.

Call reports are assigned categories to organize the different types of reports. 
For example, a call report describing an e-mail incident stores different 
information than a call report looking for equipment for a new employee.
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What is a Category?
Call reports and incident tickets are classified by category. Service 
Management and Incident Management use the same categories. The 
category determines:

Who is responsible for resolving a call report or incident ticket (the default 
assignment group).

What information is needed to open the call report or incident ticket.

Solutions in the Knowledge Base.

Applicable SLAs.

Default severity of the ticket.

Default priority of the ticket.

How quickly a ticket must be resolved.

The time interval for escalating a ticket to a higher alert stage.

Who must be notified as the ticket is escalated.

The processing logic for each category is primarily the same. However, 
ServiceCenter can contain different ticket forms for each category. The tabs 
on the forms are specific to the category. 

For example: Information needed to solve a software problem is different 
than information needed to solve an equipment problem.

To enter information, based on a category:

1 When you first enter information about an incident, you enter the 
information in an initial form. 

2 Select a category from the drop-down list displayed by clicking the down 
arrow next to the Category field in the initial incident ticket form.

3 Click New to open the ticket.

The form displays the ticket category with which it is associated. If a ticket is 
assigned to the wrong category, the appropriate category can be assigned 
after the ticket is opened.
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Predefined categories

The following table lists the predefined categories:

You may have other categories available in your initial call report or incident 
ticket form. Categories can be created and revised by a ServiceCenter user 
with administrative privileges.

Note: The following workflow (Figure 4-2 on page 111) can be changed by 
modifying ServiceCenter scripts to meet your business process flow.

Category Use

business applications Incidents involving a business-specific application (as 
opposed to a generic user application such as email). 

change Calls or incidents opened specifically for the purpose of 
starting a change process.

client system Enduser desktop incidents involving the client’s 
hardware or generic user software such as email.

enquiry Call or incidents requesting only information.

network Incidents involving network connectivity, performance, 
or availability.

other Incidents that do not fit into any other category.

printing Incidents involving printer or printing hardware or 
software.

security Incidents involving inappropriate (excessive or 
incomplete) access to any area, asset, application, 
module, or function.

shared infrastructure Incidents involving shared hardware not covered by 
other categories; for example, servers.

TBD For tickets that are to be quickly opened and later looked 
at and edited.

telecoms Incidents involving telecommunications hardware or 
software.
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.

Figure 4-2: Call Workflow
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Call List in the Call Queue

You can quickly view call reports in the Service Management Call Queue 
(sc.manage.call form). See Figure 4-3 on page 112. When logged on as 
BOB.HELPDESK, click View Work Queues. The Incident List 
(sc.manage.problem) form displays. Select Calls I Report in the current 
Inbox. The Call Queue form displays.

You can create a predefined search of records with an inbox. An inbox is 
created in the search mode and saved in the database. Refer to Creating an 
Inbox Definition on page 77.

To access a Call List in the Call Queue:

1 Click Call Queue in the queue area.

 -or-

Click Call Queue in the inbox of another application.

The Call List form displays (Figure 4-3 on page 112). 

Figure 4-3: Call List form

Select an 
Inbox
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2 Click Switch Inbox, By Owner, or By Assignment Group to select the inbox 
you want to view.

3 In the View Records in which Inbox dialog box displayed, choose an inbox 
from the drop-down list.

4 Click OK in this box to confirm that you want to display the selected inbox 
in the Call List form (Figure 4-4 on page 113). 

5 Double-click on a listed record to access that call report.

Figure 4-4: Call List Inbox
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Call List Columns
The Call List contains a series of columns listing the general information 
about the call report records. The column header buttons can be used to sort 
the list by that column.

Call List Column Description

Call ID Call report number.

Severity Indicates how pressing an incident is for the caller. The 
severity can be classified as one of the following. The default 
is 4 - Low.

1 - Critical—(Severe business disruption) the business unit 
or sub-unit is unable to operate; critical system component 
failed or severely impaired.
2 - Major—(Major business disruption) critical user or 
user group is unable to operate, or the business unit is 
experiencing a significant reduction in system 
performance.
3 - Medium—(Minor business disruption) single user is 
unable to operate with no available work around.
4 - Low—(Minor disruption) single user or user group is 
experiencing incidents, but a work around is available.
5 - Very Low—(Inquiry) single user or user group 
requiring assistance, but with no direct impact on business, 
such as request for information.

Open Time Date and time the call report was opened.

Owner ServiceCenter user who opened or was assigned the call 
report.

Status Status of the call report.

Brief description Brief description of the reported incident.
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CallList Inbox Buttons
Each inbox contains a series of buttons providing quick access to various 
Service Management functions and applications. Most buttons are the same 
between the various application inboxes. These buttons are described in 
Using Inboxes on page 82. Only two buttons are different in each inbox. For 
Service Management, those buttons are:

By Owner—displays a list of records for the 
operator.

By Assignment Group—displays a list of records 
for another assignment group.

Options Menu—Call Queue
The Options menu in the Call Queue provides shortcuts to other 
ServiceCenter applications. 

Option Description

Select Queue Selects a queue from which to work.

Switch Queue Displays a dialog window to select another inbox. Functions the 
same as Switch Inbox. Below are the other inboxes from which 
to choose:

Asset Management—accesses Asset Management.
Quote List—accesses the current user’s Quote List (Request 
Management inbox).
Order List—accesses the current user’s Order List (Request 
Management inbox).
Line Item List—accesses the current user’s Line Item List 
(Request Management inbox).
Incident List—accesses the current user’s Incident List 
(Incident Management inbox).
Change List—accesses the current user’s Change List (Change 
Management inbox).
Task List—accesses the current user’s Task List (Change 
Management inbox).
Root Cause—accesses Root Cause Analysis.

New Accesses a new call report form.

Search Accesses the Service Management search function to search 
calls.
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List Options Menu—Call List

Refresh Updates the current list.

Edit Favorite 
Inboxes

Edit your list of Favorite Inboxes.

Use Stored 
Query

Access the list of stored queries.

Starting Lists Displays the initial Call List.

Count Tallies the number of records in the current Call List.

By Assignment 
Group

Searches for call reports assigned to a specified assignment 
group. A message box prompts you to select an assignment 
group.

By Owner Searches for call reports assigned to a specified ServiceCenter 
user. A message box prompts you to select an owner. 

Option Description

List Option Description

Export to Excel Exports the current Call List to a Microsoft® Excel 
spreadsheet. Excel automatically opens with the list placed 
in a spreadsheet. Basically, you can export information to 
any product that has DDE (Dynamic Data Exchange) 
support. This DDE function requires Excel 95 or later.

Export to Text File Exports the Call List to a text file. This option is not part of 
the DDE support and can be run from clients other than 
those operating in Windows.

Modify Columns Allows you to change the column headings and related 
information in the record list.
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Search Call Reports

Service Management allows you to query for call report records. You can also 
save these queries as inboxes (refer to Creating an Inbox Definition on 
page 77).

Call Report Search Fields
The Call Report search form displays three tabs: Basic Search, Advanced 
Search, and IR Search.

Figure 4-5: Call Report Search form
Search Call Reports  117



ServiceCenter
Call Report Basic Call Search tab
You can leave any or all fields in this tab blank. For fastest searching, use the 
fields identified as key (indexed) fields at your site. If these are not clearly 
identified on the form, ask your ServiceCenter administrator for a list of key 
fields.

Field Description

Call ID Call report number. Enter the call report number, if you know 
it, in the form of CALLxx, where xx is the number. If you have 
Smart Search selected, enter the call report number without the 
CALL prefix, as Smart Search performs when a number only is 
entered.

Note: You can enter a partial number to access a QBE Record 
list. For example, if you enter CALL2, you get a list of all call 
numbers starting with 2: CALL2, CALL20, CALL200, and so 
forth. Wildcards cannot be used.

Smart Search? Allows searches for call reports by number only (prefixes or 
suffixes, such as CALL, are omitted). Smart Searches return the 
call requested regardless of its state (such as, open or closed). If 
any settings on the search form other than the default are 
entered, a normal query is performed and the Smart Search 
feature is ignored.

Asset Id Name of the affected asset listed in the call report.

Contact Name of the user who reported the incident, for example, the 
caller.

Department Department in which the contact works.

Ticket Owner Service Management user who opened the call report.

Assignment Name of the Assignment Group or possible groups to which 
the call report was assigned.
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Severity Severity (1 through 4) assigned to the call report. Indicates how 
pressing an incident is for the caller. The severity can be 
classified as one of the following. The default is 4 - Low.

1 - Critical—(Severe business disruption) the business unit 
or sub-unit is unable to operate; critical system component 
failed or severely impaired.
2 - Major—(Major business disruption) critical user or user 
group is unable to operate, or the business unit is 
experiencing a significant reduction in system performance.
3 - Medium—(Minor business disruption) single user is 
unable to operate with no available work around.
4 - Low—(Minor disruption) single user or user group is 
experiencing incidents, but a work around is available.
5 - Very Low—(Inquiry) single user or user group requiring 
assistance, but with no direct impact on business, such as 
request for information.

Status Status of the call report: Closed, Open-Idle, or Open-Callback.

Location Office location from which the call was received. Location can 
be typed in, or click browse to pick a location from the QBE 
Record list.

Service Contract Select a service contract from the drop-down list.

Company Select a company from which the call was received.

Field Description
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Call Report Advanced Search tab
Any or all of the fields in this tab can be left blank.

Call Report IR Search tab
The IR Search tab displays a blank text box where you can enter a plain text 
query. ServiceCenter can add the plain text to the search parameters.

Field Description

Opened After and 
Last Updated After

Enter the date and time (optional) the report was opened or 
updated Before and After. The default format is mm/dd/yyyy 
hh:mm:ss. If a time is not entered, the default is 00:00:00.

Note: The date and time format can be set by your 
system administrator in the System Wide 
Company Record or in individual operator 
records. Therefore, the date and time format you 
use may vary from the default shown above.

By Enter the name of the operator who opened or updated the 
call record. You can type the name or choose a name from the 
drop-down list.

Field Description

IR Search Text Access ServiceCenter’s IR Expert application where you can 
enter a plain text query. (IR Expert is an intelligent, 
concept-based information retrieval engine that searches the 
ServiceCenter database for similar or related information, 
based on a simple, natural language query).

Discovery Options Where you can designate which kind of search you want by 
selecting one of the following options:

Complete Match—system searches for an absolute match 
to the text you have typed.
Shallow—search uses narrower parameters and returns 
fewer records than with a deep search.
Deep—performs a broad search. Try using a deep search if 
a shallow search does not return the desired records.
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Search Procedures
To search for call report records:

1 Click Call Queue on the Service Management Menu.

2 Click Search in the Call List.

A Basic Search form displays.

3 Fill in the fields in the Basic Search tab in one of the following ways:

Type known information.

Click Fill, or press F9 to access a QBE Record list.

Click Down arrow to access a drop-down list. 

Press Down arrow to toggle through selections from the drop-down list.

Note: The more information you enter, the narrower the search parameters. 

To narrow the search parameters further:

1 Click the Advanced Search tab. 

Advanced search fields allow you to narrow the time frame when a record 
was opened or updated. You also can enter the names of the operators who 
opened or updated the report. These fields are independent of each other and 
can remain blank.

2 Click the IR Search tab.

3 Enter a plain text description in the IR Search Text array.

4 Select a search option from Discovery Options: Complete Match, Shallow, or 
Deep.

5 Click Search or press F6.

The matching record displays.

If multiple records match the search parameters, the QBE Record list 
includes these, and the first entry in the list displays in the call report form.

Note: If a message is returned stating No Records Found, you can broaden the 
search by eliminating some of the search parameters.

6 Click the desired record in the QBE Record list.

To sort a QBE Record list:

Click the column header button by which you want to search the list. For 
example, to search the list by status, click on the Status header button.
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Call Reports

When a user calls the help desk, you can create a call report to log the specific 
information provided in the call. The call reports are logged in the incidents 
file. As you talk with a user you can enter information about the call, the 
affected equipment, the caller, and other pertinent information.

Form for Taking New Calls
The form for opening a new call report (Figure 4-6 on page 122) allows you 
to quickly log calls and create call reports. 

Figure 4-6: New Call form
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Buttons
The call report form contains a series of quick access buttons:

Button Function

Cancel Returns you to the Service Management menu.

Undo Clears the changes entered in the current form without saving 
that data.

Quick Open Allows you to save a call report in the inactive state. When the 
report is saved, the record is saved to the incidents file. The 
form is then cleared and ready for a new report. See Creating 
an Incident Ticket—Quick Open on page 220 for more 
information.

Close Closes the current call report.

Find Accesses the ServiceCenter Find function.

Fill Accesses the ServiceCenter Fill function.

Create Incident Starts the process for placing the information in a new 
incident ticket. The currently displayed call report is 
automatically associated with the new incident ticket. See 
Creating an Incident Ticket on page 223.

Request Change Starts the process for placing the information in a new 
Change Management change. The currently displayed call 
report is automatically associated with the change record. 

Show Related Displays the call reports associated with the contact listed in 
the Reported By field. If this contact has multiple call reports 
open, a QBE Record list displays.

Find Solution Accesses ServiceCenter’s Knowledge Base to locate possible 
solutions for a reported incident. See Knowledge Base - 
Diagnostic Aids on page 561 for more information.

Add/Edit Contact Accesses the ServiceCenter contacts records. Once you have 
accessed a record, you can edit the information for the caller 
(Reported by) or add a contacts record for a new caller. See 
The Contacts File on page 547 for more information.
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Fields

Call Detail tab

Field Description

Call ID Number entered automatically by ServiceCenter when the 
form is accessed.

Contact Name The Contact Name related to the company from which 
the call was received. Click Fill to select a Contact Name 
from the QBE list of contact names. The non-editable 
fields (Full Name, Email, and Payroll No.) and editable 
fields (Corp Struct/Div, Phone, Ext., and Fax) are 
automatically filled in from the contacts record for this 
caller. For more information, see Contacts File Appendix 
A.

Asset ID Asset for which an incident is being reported. When you 
select a Contact Name, you are prompted to select the 
Asset ID associated with the call. Noneditable fields, Type 
and Model, are automatically filled in from the asset 
record of the asset. Asset records are created in Asset 
Management.

Reported By different 
from Contact Name

Check this box if the name of the caller is different than 
the contact name in the Contacts file. 

Reported By Click Fill to select the caller’s name from the QBE list of 
contact names, or create a new record. The editable fields 
associated with this caller (Reported By, Phone, Ext., and 
Fax) are automatically filled in from the contacts record 
for this caller. For more information, see The Contacts File 
on page 547.

Location The office location from where the call originated.

Room/Floor Ref The room and floor references as to where the asset is 
located.

Cost Center The cost center for the contract.

User Type The type of user calling.

Company The name of the company calling to report the incident.

Description Description of the reported incident.

Site Site or campus-based location with on-site support 
resources.
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Home Home location of remote or field-based user. help desk 
and user agree on level of support required to resolve the 
issue.

Mobile Mobile user, which is not considered a critical user and 
affects the severity level of the incident.

Status State of the call report:

Closed—the call report is closed.
Open-Idle—the call report remains open, with no 
action required. Open-Idle is the default setting.
Open-Callback—the call report remains open and a 
callback to the user is required.

Owner Name of the Service Management operator who opened 
this call report.

Category Classify asset’s category within the business, such as 
network.

Subcategory Classify asset’s subcategory within the primary category, 
such as lan.

Product Type Asset product type.

Problem Type Type of problem being reported.

Assignment Assignment group to review this call.

Severity Indicates how pressing an incident is for the caller. The 
severity can be Critical, Major, Medium, Low, or Very Low. 
The default is Low.

Site Category Indicates the level of support to be dispersed.

A - Critical Site—large site or campus location that 
justifies on-site support resources. A critical site 
routinely requires extended hours of support.
B - Major Site—medium size location that justifies 
resources support by field-based technicians.
C - Satellite Site—small location that is supported by 
field-based or visiting technicians.
D - Home Site—home location of remote or 
field-based user. This site is supported by field-based or 
visiting technicians.

Projected SLA Service Level Agreement covering the affected equipment.

Field Description
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Resolution Detail tab

Entitlement Noneditable field. The system automatically checks to 
determine if a particular caller, based upon his or her SLA, 
has the right to help desk service at the current time of day 
and/or day of the week. If the service level agreement does 
not provide service to the caller for that period, the system 
automatically notifies the first level technician by 
displaying an entitlement prompt.

Notify By How the caller should be notified when the call report is 
closed:

None—no notification is sent.
Email—Email is sent. Email is the default setting.
Telephone—help desk personnel call the caller.

GL Number General ledger number.

Bill To To where the bill should be mailed, whether it be a 
department or a person.

Dept—bill the department.
Contact—bill the contact.

Cause Code Links this ticket to a Probable Cause record. Cause codes 
allow incident tickets to be more easily categorized and 
assigned, simplifying reporting and tracking. When a 
cause code is added to an incident ticket using the Fill 
function, accompanying information, such as Category 
and Description, can also be added to the ticket from the 
corresponding probable cause record.

Field Description

Call Resolution How the call was resolved.

Resolution Code Code to allow the call ticket to be more easily categorized, 
simplifying reporting and tracking. When a cause code is 
added to a ticket using the Fill function, accompanying 
information, such as Category and Description, can also be 
added to the ticket from the corresponding probable cause 
record.

Field Description
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Options Menu

Option Description

Find Solution Accesses the Knowledge Base to search for possible solutions 
to the incident reported in the call. See Knowledge Base - 
Diagnostic Aids on page 561 for more information.

SM Call List Access the Call List for the current user.

Related | Quotes Accesses related open quotes.

Get-Answers>Open Opens Get-Answers in a browser. Choose this option when 
you want Get-Answers opened, so that you can type your 
own query. This option is only available when Get-Answers 
is integrated with ServiceCenter.

Get-Answers>
Search Solution

Uses the text in the Description field as the query string for 
Get-Answers. A browser window opens with a list of results 
from the search query. Choose this option when you think 
the Description will "find" quality answers within 
Get-Answers. This option is only available when 
Get-Answers is integrated with ServiceCenter. 

Get-Answers>
Retrieve Solution

Inserts a Get-Answers solution into the ServiceCenter call 
record. This option requires a Get-Answers record to be 
open. Choose this option after you have searched for a 
solution and you have found the one to apply to the call. 
This option is only available when Get-Answers is integrated 
with ServiceCenter.

Get-Answers>
Author Solution

Allows users to add new entries derived from ServiceCenter 
to the Get-Answers knowledge base. This option is available 
only for resolved calls and when Get-Answers is integrated 
with ServiceCenter.

Knowlix>Search 
Solution

Access Peregrine Systems’ Knowlix product. 

Knowlix>Retrieve 
Solution

Retrieve information from the Knowlix product.

Get SLA ID Get the Service Level Agreement ID that covers the tickets 
for a particular service.

Get Contract/SLA Get Service Level Agreement covering the affected 
equipment.

Notify Users to be notified when the call report is closed:

Add/Edit Contact Accesses the contact record for the caller entered in the 
Reported By field. If this field is blank, a blank contacts form 
displays from which you can search for a contact record.
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Creating a Call Report
To open a new call report:

1 Click Take New Calls on the ServiceCenter Home menu.

The call report form (Figure 4-6 on page 122) displays.

ServiceCenter automatically fills in the Call ID field, assigning a unique 
number with a CALL prefix to the call.

2 Enter the caller’s name in the Contact Name field.

-or-

Click Fill, or press F9, to access a QBE Record list of ServiceCenter users 
(contacts). 

Note: When using the Fill function to replace the information in a field 
already containing data, clear the field before attempting to fill new 
data into the field. If the field contains data, the Fill function cannot 
operate.

3 Double-click on the desired contact in the QBE Record list, for example, Greg 
Hawthorne (HAWTHORNE, GREG). The associated fields are automatically filled 
in.

Note: If an asset is linked to this contact, that information is automatically 
added to the call record. If multiple assets are linked to the contact, a 
QBE Record list displays. Double-click the affected asset. This example 
used ACMEpc015.

Remote 
Control>Remote 
Manager

Connects to the Remote Management utility, if installed. 
Refer to the Remote Management/ServiceCenter Interface 
Guide.

Remote 
Control>Connect to 
Device

Allows you to connect to the network address of the asset 
listed in the current record. Part of the Remote Management 
application.

Get Service Contract Get service contract covering the affected equipment.

Option Description
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The information for ACMEpc015 and the contact name (Hawthorne) are 
filled into the call report form (Figure 4-7 on page 129).

Figure 4-7: New Call form

4 By default, the Service Level Agreement (SLA) feature is unavailable. If your 
system has Service Level Management, refer to the Application 
Administration Guide for instructions.

5 If the Asset ID field is blank or the incorrect asset is listed, update this field 
with the information from this call. 

a Click Fill, or press F9, to access a QBE Record list of ServiceCenter assets.

b Double-click the desired asset in the QBE Record list. 

6 The Owner field is automatically filled in with the name of the current 
Service Management user (the user ID you used to log on). 
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7 In the Severity field, enter a severity code for the call. You can type the code 
or click the down-arrow and select from the drop-down list.

For this example, use 3- Medium.

8 The Status field automatically defaults to Open-Idle.

9 In the Notify By field, enter the preferred method to notify this caller when 
the call is closed. Use the down arrow to select a notification method. By 
default, the setting is Email.

For this example, use the default setting. 

For more information on this field, refer to the section Importance of the 
Notify By Field on page 132.

10 Select a Category for the call report. Click Fill to bring up a record list of 
categories and select a category. Then, select further refinements, as asked, 
for the Subcategory, Product type and Problem type.

For this example, use client system and, when asked for further choices, select 
hardware, desktop, and keyboard for the Subcategory, Product type and 
Problem type.

Important: If you intend to open a request for change in Change 
Management, be sure to select a Change category here. This 
activates the Request Change button, allowing you to have 
access to and create a ticket in Change Management.

11 Enter the Assignment group responsible for this call. You can enter two 
groups. You can accept the defaults for this call category, subcategory, 
product type, and problem type; you can type the code; or you can use the 
down arrow.

For this example, accept the presented default, ONSITE SUPPORT.
130 Chapter 4—Service Management 



User’s Guide
12 Enter a call Description.

For this example, enter: 
The space bar is sticking on my keyboard

Enter a resolution in the Call Resolution field if the incident is resolved 
during the call.

For this example, leave this field blank.

13 Click Qopen, or press F2. This creates a call report record and saves the 
information to the incidents file. 

At this point, ServiceCenter performs all necessary validations to determine 
if the information entered is valid. If invalid information is detected, 
ServiceCenter returns an error message or a list of values to select for that 
field.

A message displays in the status bar stating:
Call CALLxxx has been saved
where xxx is the Call ID.

The fields in the form are cleared and the Call ID number is automatically 
incremented by one. You are now ready to enter a call report for your next 
call.
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Importance of the Notify By Field
The way in which you fill out the Notify By field can affect how a call is closed 
if it has been associated to another record. For example, if you associate an 
incident ticket to a call report, when the incident ticket is closed the related 
call report is also closed according to the information in the Notify By field, 
as follows:

Note: Page and fax notification are not available out of the box. These 
notification types must be added and configured by an administrator.
In addition, there is no dependency between the Notify By field and 
the Notification Engine.

Notification Description

None The call is closed. 

Email An e-mail is sent to the contact listed in the call informing 
him that the related record has been closed. The call is then 
closed.

E-mail Notification An event with critical problems triggers either a single 
e-mail notification message or several different messages to 
be emailed to one or more designated individuals or group 
of people, based on the selections made in the Notification 
table. See the System Tailoring guide to learn about the 
notification message. 

Fax A fax is sent to the contact listed in the call. The call is then 
closed.

Page A page is sent to the contact listed in the call. The call is then 
closed.

Telephone A required action is added for the call. This tells the user 
why the customer needs to be called back. It also prevents 
the call from being closed until call required actions have 
been inactivated.
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Creating a Call Report by Copying an Existing Record
You can create a new call report by copying an existing report. 

To clone (copy) an existing report:

1 Access an existing call report.

2 Change any appropriate data in the fields to create your new record.

Note: You must clear the data in a field to use the Fill and Find functions.

3 Click Clone, or press F1. The next available Call ID number in the system is 
used.

Note: The new Call ID number is not dependent upon the Call ID number 
of the call being cloned.

4 Click Save or press F2. This creates a new call report record and saves the 
information to the incidents file.

Options Menu—Existing Call Report
An existing call report Options menu contains the following options:

Option Description

Get-Answers>Open Opens Get-Answers in a browser. Choose this option when 
you want Get-Answers opened, so that you can type your 
own query. This option is only available when Get-Answers 
is integrated with ServiceCenter.

Get-Answers>Search 
Solution

Uses the text in the Description field as the query string for 
Get-Answers. A browser window opens with a list of results 
from the search query. Choose this option when you think 
the Description will "find" quality answers within 
Get-Answers. This option is only available when 
Get-Answers is integrated with ServiceCenter. 

Get-Answers>
Retrieve Solution

Inserts a Get-Answers solution into the ServiceCenter call 
record. This option requires a Get-Answers record to be 
open. Choose this option after you have searched for a 
solution and you have found the one to apply to the call. 
This option is only available when Get-Answers is integrated 
with ServiceCenter.

Get-Answers>
Author Solution

Allows users to add new entries derived from ServiceCenter 
to the Get-Answers knowledge base. This option is available 
only for resolved calls and when Get-Answers is integrated 
with ServiceCenter.
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Set Reminder Allows you to schedule a reminder to be sent to you at a 
specified time through e-mail, a page, or a pop-up message.

Print Record Prints this call report record to the user’s default 
ServiceCenter printer.

Notify Allows you to send a message containing the data in call 
report ticket to other ServiceCenter users.

See Service Records 
for this Contact

Searches the ServiceCenter database for incident tickets 
associated to the caller (contact) in this call report. The 
contact is the person listed in the Reported By field. The 
results are displayed in a QBE Record list. Double-click on a 
record to display it.

Related Opens sub-menus that allow you to associate the current 
call report to an existing incident ticket, Change 
Management change, or Request Management quote; view 
related incidents, changes, or quotes; or open a new 
incident, change, or quote.

Add Required Action Allows you to add a required action to this call report. See 
Add a Required Action on page 142.

Find Solution Accesses the Knowledge Base to search for possible solutions 
to the incident reported in the call. See Knowledge Base - 
Diagnostic Aids on page 561 for more information.

Create Hot News Create Hot News item within the Knowledge Base. See 
Knowledge Base - Diagnostic Aids on page 561 for more 
information on Hot News.

Knowlix>Search 
Solution

Access Peregrine Systems’ Knowlix product. 

Knowlix>Retrieve 
Solution

Retrieves information from the Knowlix product.

Remote 
Control>Remote 
Manager

Connects to the Remote Management utility, if the utility is 
installed. Refer to the Remote Management/ServiceCenter 
Interface Guide.

Remote 
Control>Connect to 
Device

Allows you to connect to another asset. Part of Remote 
Management.

IND System 
Analyzer

Launches remote data collection for a system asset. Part of 
Network Discovery.

Option Description
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List Options Menu—Existing Call Report
The existing call report form List Options menu contains the following 
options:

List Option Description

Count Counts the number of records in the current call list.

Print List Allows you to print a copy of the current call list.

Refresh List Updates the current list.

Modify Columns Allows you to change the column headings and related 
information in the record list.

Export to Excel Exports the current Call List to a Microsoft Excel 
spreadsheet. Excel automatically opens with the list placed in 
a spreadsheet. Basically, you can export information to any 
product that has DDE (Dynamic Data Exchange) support. 
This DDE function requires Excel 95 or later.

Export to Text File Exports the Call List to a text file. This option is not part of 
the DDE support and can be run from clients other than 
those operating in Windows.

Save as Inbox Allows you to save the current list as an inbox.
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Associating a Call Report with Another Application Record
You can associate a call report with an existing Incident Management ticket, 
Request Management quote, or Change Management change. Before 
associating a call report with another record, make note of the ID number of 
the record. For example, an incident ticket could have an ID number of 
IM1001. You need to enter this number in the following process. 

To associate a call report with another record:

1 Access a call report.

2 Select Options>Related>Incident/Quote/Change>Associate.

A dialog box displays asking:

Associate Call xxxxxx with which Incident/Quote/Change?

3 Enter one of the ID numbers:

For an Incident ticket, enter the number in the form of IMxx, where xx is 
the incident ticket number.

For a Quote, enter the number in the form of Qxx, where xx is the quote 
number.

The Change number does not have a defining letter. 

-or-

4 Click Search in the Associating Records dialog box to locate the appropriate 
ID number.

5 Click OK. A confirmation displays in the status bar.

Updating a Call Report
To modify a call report:

1 Access the call report from either the Call List or from a search.
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For example, you could access the call report created in Creating a Call Report 
on page 128.

 

Figure 4-8: Call Report Record

2 Modify any fields that need revision.

Note: If you are modifying a field that uses the Fill and Find functions, clear 
that field of any existing data before using these functions.
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3 Save the updated record.

a Click Save or press F4 to save the record and leave it displayed.

b Click OK or press F2 to save the record and return to the form from which 
you accessed this report.

Setting a Reminder
From an existing call report, you can schedule a reminder to be sent to you 
at a specified time.

To access the Set Reminder feature and schedule a reminder:

1 With an existing call report displayed, select Set Reminder from the Options 
menu.

The Set Reminder form displays.

Figure 4-9: Set Reminder form
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2 Choose one of the following to set the time when the reminder occurs:

Select Remind At to set a reminder for a particular day and time.

Select Remind In to set the reminder to occur at a particular interval. This 
options brings up two fields; enter the time interval, and select the shift 
you are working from the drop-down list.

3 Click Browse (next to the Remind At field) to bring up the ServiceCenter 
Calendar. You can use the calendar to select the date and time you want the 
reminder to occur.

a Enter the time in the Time field. 

b Click on the day you want the reminder to occur. The dialog box closes 
and the information is filled into the Remind At field. (You can use the 
arrows at each side of the month and year to move forward or backward.)

c If you want to return to today’s date, click Goto Today.

d If you want to go to a specific date, click Select Date and type the date in 
the dialog box displayed. Click OK to accept the entry and return to the 
Calendar. Click the back arrow to return to the Calendar with no change.
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4 In the Remind if field, select an option from the drop-down list:

Always (the default).

Call has not been updated

Call is still open

Call is still assigned to me

5 In the Pop-up Message area of the form, select the type of notification you 
want:

Pop-up

Page

Email

SCMail

If you select Pop-up or Page, type the reminder message in the Message field.

6 Choosing Email or SCMail displays two Message Type option buttons. Select 
the type of e-mail message you want to send. 
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Note: There is also a Title field where you can enter a title for the e-mail 
message.

Figure 4-10: Set Reminder form with Fixed Text Field Displayed

7 Select the message type option in the Message Type frame.

Send Call Record. This option includes a copy of the call record in the 
e-mail.

Fixed Text. Selecting this option displays a text box in which you can type 
the message you want to display in the e-mail.

8 When you have made all your selections, click OK.

The initial call report from which you set the reminder displays.
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Add a Required Action
The call report form contains the Required Actions tab, listing any required 
actions for this call report. These actions can be added only to existing call 
reports. The Required Actions function allows you to track the steps 
necessary to resolve a call report.

To add a required action:

1 Select Add Required Action from the Options menu in an existing call 
report. The dependency form displays.

Figure 4-11: Required Actions Prompt

2 Enter the required action in the What is the required action? field.

3 Enter a reason for needing the required action.

4 Enter the Incident number to associate to this call report.

5 Click OK.

-or-

Click Cancel to exit the form and return to the call report without adding any 
required actions.
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Closing a Call Report
If your Incident Management environment is set up for full model checking 
or cascading closures, call reports are automatically closed when an 
associated incident ticket is closed. 

If your Incident Management environment is set up for call dependent ticket 
closures or for independent ticket and call closures, you need to close a call 
report individually.

To close a call report:

1 Access the call report record.

2 Click Close, or press F7.

If you accessed the call report from a QBE Record list, notice that the status 
of the call is now listed as Closed.
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CHAPTER

5
 Scheduled Maintenance
Scheduled Maintenance has been designed to help new users understand 
basic Scheduled Maintenance usage. 

Topics in this chapter include:

Overview on page 146

Accessing Scheduled Maintenance on page 148

Menu Buttons on page 150

Creating a Scheduled Maintenance Task on page 150

Saving a Task on page 182

Using the Cost Estimate Tool on page 182

Executing a Task on page 184

Verifying a Task is Working on page 185

Sample Time Scheduled Tasks on page 189
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Overview

What is Scheduled Maintenance?
Scheduled Maintenance is a module for ServiceCenter that enables users to:

Establish a formalized Scheduled Maintenance system, proactively 
reducing unplanned outages and system failures by servicing systems 
before they fail rather than afterwards. 

Define and schedule re-occurring maintenance tasks, including Incident 
tickets, Change requests and Request Management quotes, using closed 
loop integration with ServiceCenter. 

Keep all Scheduled Maintenance tasks in a single repository, insuring that 
important maintenance is done.

Automatically notify staff of all maintenance items as they become due, via 
ServiceCenter. 

Easily enter and update Scheduled Maintenance tasks even when 
unfamiliar with ServiceCenter.

Have audit information available as necessary.

Create sophisticated or detailed maintenance tasks.

Keep existing ServiceCenter customizations and tailoring.

Why Use Scheduled Maintenance?
Scheduled Maintenance makes it easy for ServiceCenter users to know when 
to do a particular piece of standard maintenance. It enables users to define 
and schedule maintenance tasks, and automatically generates the 
appropriate Incident tickets, Change requests, or Request Management 
quotes. Scheduled Maintenance supports the definition and storage of as 
many maintenance tasks as are required for your organization. 

Scheduled Maintenance expedites these three things:

Creation and storage of maintenance tasks.

Generation and distribution of maintenance requests at appropriate 
times.

Execution and tracking of Scheduled Maintenance tasks.
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With Scheduled Maintenance, users can define and schedule maintenance 
tasks and store them in a central repository. The stored maintenance tasks 
automatically generate Incident tickets, Change requests, or Request 
Management quotes as they become due. The maintenance history and the 
auditing information for each task is available if and when it is required.

Scheduled Maintenance has an easy-to-use point and click task creation 
system. This enables users who are familiar with maintenance requirements 
to enter tasks, even if they are unfamiliar with ServiceCenter customization. 
Additionally, the powerful tailoring options allow advanced users to create 
extremely sophisticated and detailed maintenance tasks.

Scheduled Maintenance runs within the ServiceCenter system. It installs 
without requiring an upgrade, and has no impact on future ServiceCenter 
upgrades. Its seamless integration into a pre-existing ServiceCenter 
installation protects your organization’s investment in the ServiceCenter 
system, including all tailoring and customizations.
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Accessing Scheduled Maintenance

When installing ServiceCenter 4.0 or later, Scheduled Maintenance can be 
started from the command line, or from ServiceCenter’s Main menu. If you 
have purchased and installed Scheduled Maintenance separately, the 
command line option works, but the menu may be configured differently. 
(See the Application Administration Guide for more information.)

To open the Scheduled Maintenance menu:

1 Log onto ServiceCenter. 

2 Do one of the following:

Click the Scheduled Maintenance menu button on the Main Menu. 

The Scheduled Maintenance menu appears. 

- Or -

Bring up the command line inside of your ServiceCenter system (from the 
main menu, choose View>Command Line in the tool tray) and type *mRT. 

Figure 5-1: Command Line

Command Line
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The Scheduled Maintenance menu appears.

Figure 5-2: Scheduled Maintenance Menu

Note: By entering *m on the command line you are telling ServiceCenter to 
immediately jump to a menu whose name immediately follows the *m. 
Entering *mRT jumps you to the menu named RT, the Scheduled 
Maintenance main menu. Entering *mCC takes you to the menu 
named CC, the Service Management main menu. 

To exit Scheduled Maintenance:

Click Back.

You return to the main form. 
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Menu Buttons

The Scheduled Maintenance menu contains the following buttons:

Creating a Scheduled Maintenance Task 

Follow these steps to create and execute a Scheduled Maintenance Task:

Step 1 Opening a Scheduled Maintenance Task, next section. 

Step 2 Naming and Describing a Task on page 152

Step 3 Defining a Task's Execution Criteria on page 153

Time Scheduled Tasks on page 154

Demand Based Tasks on page 163

Step 4 Defining a Task's Effect and Details on page 167

The Scheduled Maintenance button allows 
you to create and edit Scheduled Maintenance 
tasks.

The Execution History button displays a list of 
each time a Scheduled Maintenance task was 
launched for execution. 

The Execution Details button displays the 
results of a Scheduled Maintenance task’s 
execution. The result may be that an incident 
ticket was generated, or change request was 
generated, or a request management quote was 
generated. From there, the appropriate ticket 
or tickets (Incident, Change, or Request) may 
be viewed.

The Administration Options button allows 
users to select options for the template base 
generation Scheduled Maintenance tasks from 
Incident tickets, Change requests, or Request 
Management quotes.
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Step 5 Saving a Task on page 182

Step 6 Executing a Task on page 184

Opening a Scheduled Maintenance Task
Scheduled Maintenance tasks can be created from:

The Scheduled Maintenance menu

A ticket in Incident Management, Change Management, or Request 
Management

An asset in Inventory Management

Open a new ticket using one of the following methods.

Create a task from the Scheduled Maintenance menu:

1 Open Scheduled Maintenance using the steps provided in Accessing 
Scheduled Maintenance on page 148.

2 Click the Scheduled Maintenance button. 

A blank ticket opens in Scheduled Maintenance. 

-Or-

Create a task from a specific ticket in Incident Management, Change 
Management, or Request Management:

1 Open a ticket in Incident Management, Change Management, or Request 
Management. 

2 Choose Options>Generate Maintenance. 

A new ticket opens in Scheduled Maintenance, with some data automatically 
filled in from the ticket, and from the ticket that was selected as the template. 
See Automated Task Generation in the Application Administration Guide for 
more information on this process. 

-Or-

Create a task for an asset in Inventory Management:

1 Open the asset record in Inventory Management. 

2 Choose Options>Scheduled Maintenance>Generate Recurring Incidents, 
Generate Recurring Changes, or Generate Recurring Requests.

A task opens in Scheduled Maintenance, incorporating some data from the 
asset record, and from the ticket that was selected as the template. See 
Automated Task Generation in the Application Administration Guide for more 
information on this process. 
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Naming and Describing a Task
The first step in creating a task is to name it and enter the necessary 
descriptive information, including whether or not the task is active. Each task 
has a name, for easy reference, and a description, for detailed information. 

To name and describe a task:

1 Click Scheduled Maintenance. This takes you into Database Manager and 
allows you to start working on Scheduled Maintenance tasks. 

2 Type a name for the task in the Name field. 

Every task needs a unique name. This name can offer some insight into what 
the task does, but you may use any naming scheme, as long as each name is 
unique.

3 Click the Description tab and enter a description for the task in the text 
window, if desired. A description is optional, but can often be useful to 
someone looking at the task later.

4 Select the Active? check box to make the task active, if desired. Every task 
must be active or inactive. Inactive tasks are still in the system, but create no 
work orders or take any other action. No task is active unless the Active? 
check box is selected.
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When you are finished your task looks like this: 

Figure 5-3: Describing a Task

Defining a Task's Execution Criteria
Maintenance tasks can be broadly differentiated into two classes:

Scheduled tasks execute according to a particular chronological pattern 
e.g. run every Tuesday at 4:00 AM, or run on the first monday of January 
every year. 

Demand based tasks as well which are triggered by changes within your 
inventory module e.g. run this task whenever the available drive space on 
the file server drops below 10 GB, or run this task every time the printer 
prints 8,000 pages.

The two types of tasks are differentiated by using the Demand check box on 
the top bar of a maintenance task definition. The default is creating and 
defining a time scheduled task. If you select the Demand check box, you will 
create and define a demand based task. 
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Time Scheduled Tasks
Time scheduled tasks execute according to a defined chronological pattern, 
such as run every Tuesday at 4:00 AM or the second Thursday of every 
month. Scheduled Maintenance supports several different types of 
scheduling. Select the one that best suits the task.

There may be a delay between the time you select a task to run and the time 
that it actually does run. This is because Scheduled Maintenance, by default, 
checks for tasks to execute every minute. If it checked at 11:59:30 and 
12:00:30 then the Incident ticket, Change request, or Request Management 
quote would be opened at 12:00:30, not at 12:00:00. 

Also, there can be a few seconds delay as the Incident ticket, Change request, 
or Request Management quote is generated and saved. Changing the 
frequency on the inhook scheduler as discussed in Load Balancing in the 
Application Administration Guide, can minimize this delay. 

If your system is down when a task is supposed to run, the task executes as 
soon as the system comes back up, and reschedules for the next appropriate 
time according to the schedule you set up.

To set the schedule for a task:

1 Click the Schedule tab. 

2 Choose the appropriate option button to select a repeat interval in the Repeat 
Task frame. The available selections change depending on which repeat 
interval you select. 

The only options available for each repeat interval are those options that lie 
on the same line as the selected option button. No other options work. 

3 Select the time zone using the Start Task at or the (Execute Task at) field. If 
you leave this field blank, it defaults to your current time zone.

4 Set one of the following schedules: 

Use Regular Scheduling on page 155 to set up simple repeat interval.

Use Weekly Scheduling on page 156 to set up a weekly repeat interval. 

Use Monthly Scheduling by Date on page 158 to set up a monthly repeat 
interval. 

Use Monthly Scheduling by Day on page 159 to set up a monthly by day 
repeat interval.
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Use Annual Scheduling by Date on page 160, to set up an annual repeat 
interval. 

Use Annual Scheduling by Day on page 161 to set up an annual by day 
repeat interval. 

Use Arbitrary Scheduling on page 162 to set up an arbitrary schedule. 

5 Select one of the following duration options in the Range of Recurrence 
frame, if desired.

No End—for a task that should recur forever.

End After _ Occurrences—enter a number in the field for a task that 
should recur a specified number of times. 

End by—enter a date for a task that should recur until a certain date.

6 After you have scheduled the task, go to Defining a Task's Effect and Details 
on page 167 and set its effects. 

Regular Scheduling
Use this option to select a simple repeat interval or to make a task run at a 
certain time of day. For example, starting at 11/30/01 00:00:00 execute this 
task every hour on the hour. 

To make a task run at the same time every day you would set the start time 
and then a select a repeat interval of 24 hours. You do this by setting the 
interval to '00:00:00'. ServiceCenter won't accept '24:00:00'.
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To set a regular repeat interval schedule:

1 Select the Regularly option button.

2 Enter the date and time for the first occurrence in the Start Task At field. 

In the following screenshot, we have created a task that runs every two hours, 
starting at 6:00 a.m., February 26th, US/Pacific Time.

Figure 5-4: Regular Scheduling

Weekly Scheduling
To set a weekly repeat schedule:

1 Select the Weekly option button.

2 Enter the time that you want the task to run in the Execute Task At field.

3 Select the day of the week from the Every field drop-down list.
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In the example screenshot below, we have set up a task to run every Monday 
at 6 AM, Pacific time.

Figure 5-5: Weekly Scheduling
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Monthly Scheduling by Date
To set a monthly repeat schedule:

1 Select the top Monthly option button.

2 Enter the time that you want the task to run in the Execute Task At field.

3 Enter the day of the month (an integer between 1 and 31, inclusive) on which 
you want this task to run in the Every _ of the Month field.

In the example screenshot below, we have set up a task to run on the first of 
every month at 6 AM, Pacific time. 

Figure 5-6: Monthly Scheduling by Date
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Monthly Scheduling by Day
To set a monthly repeat schedule:

1 Select the bottom Monthly option button. 

2 Enter the time that you want the task to run in the Execute Task At field.

3 Enter the week on which you want this task to run by selecting it from the 
Every field drop-down list. 

4 Enter the weekday on which you want this task to run by selecting it from the 
Every field drop-down list. 

In the example screenshot below, we have set up a task to run on the every 
second Tuesday of the month at 6 AM, Pacific time.

Figure 5-7: Monthly Scheduling by Day
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Annual Scheduling by Date
To set an annual repeat schedule:

1 Select the top Annually option button.

2 Enter the time that you want the task to run in the Execute Task At field.

3 Enter the month on which you want this task to run by selecting it from the 
Every field drop-down list. 

4 Enter the day of the month (an integer between 1 and 31, inclusive) on which 
you want this task to run in the field to the right of the one where you entered 
the month.

In the following screenshot, we have set up a task to run every year on August 
29th at 6 AM, Pacific time.

Figure 5-8: Annual Scheduling by Date
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Annual Scheduling by Day
To set an annual by day schedule:

1 Select the bottom Annually option button.

2 Enter the time that you want the task to run in the Execute Task At field.

3 Select the week on which you want this task to run by selecting it from the 
Every field drop-down list.

4 Enter the weekday on which you want this task to run by selecting it from the 
Every field drop-down list.

5 Enter the month on which you want this task to run by selecting it from the 
Every field drop-down list.

In our example, we have chosen to run a task at 6 AM Pacific time, on the 
second Wednesday of December, every year. 

Figure 5-9: Annual Scheduling by Day
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Arbitrary Scheduling
Arbitrary scheduling allows you to execute a task according to an arbitrary, 
user defined schedule. If you choose an arbitrary recurrence schedule, you 
need to fill in any and all dates upon which you want this task to recur. 

To set an arbitrary schedule:

1 Select the Arbitrary Schedule option button in the Repeat Task panel. 

2 Enter the specific dates and times in the Recurrence Schedule fields.

In the following example, we have a task which occurs on three birthdays 
from the author’s family.

Figure 5-10: Arbitrary Scheduling
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Demand Based Tasks
Demand based tasks execute in response to certain trigger conditions based 
on the contents of your inventory module. You can instruct ServiceCenter to 
monitor a particular device within ICM and execute when, and if, the device 
meets certain threshold criteria. For example, a task can be set to require a log 
dump whenever the available disk space on a server drops below 2 GB, or a 
task can execute when the number of devices attached to a particular router 
approaches the number of ports it has available.

Understanding Demand Triggers
Conceptually, demand triggers are defined by two things. The device you 
want to monitor, and the criteria which, when applied to that device, is to 
trigger your maintenance.

To Set the Demand Criteria for a Task:

1 Select the Demand check box.

2 Click the Demand Trigger tab.

3 Define the device you want to monitor. This name must match the logical 
name of a device within your inventory.

4 Define the criteria which triggers this task. 

a Enter the name of the field to monitor in the Field to Monitor edit box. 
This name must match a field name for the device you chose in the 
previous step.

b Define a threshold sign e.g. Greater Than or Less Than

c Define the trigger value that, if met, will trigger this maintenance task.

The combination of a field name, a sign, and a threshold value can be viewed 
as a simple equation in the form:

execute task if <field name> is <sign> <threshold>.
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Understanding Repeat Criteria
Demand based maintenance supports three different types of repeat criteria 
in an effort to model real-world maintenance activity as effectively as 
possible:

Increment Based Repetition

Quiescent Repetition

Manual Repetition

Increment Based Repetition

Some maintenance activity is tied to a steadily increasing (or decreasing) 
value. Example, you want to change the oil in your car every three thousand 
miles. Thus, you'd expect a maintenance task to fire when you care reached 
3,000 miles, then fire again at 6,000 miles, and again at 9,000, etc.

This sort of repetition is modeled by selecting either the add to the previous 
value check box or subtract from the previous value check box as you repeat 
criteria and complete the Repeat Increment field. The system then 
automatically recalculates a new threshold value by adding or subtracting 
your repeat increment from the previous threshold value when your task 
runs. 

Thus, a task set to fire when the mileage field hits 12,000 with a repeat option 
of "add to the previous value" and a repeat increment of 3000 will file once 
when mileage reaches 12,000 and then automatically recalculate itself to fire 
at 12,000+3,000 or a mileage of 15,000.

Quiescent Repetition

This sort of repetition is modeled by selecting stop monitoring device for a 
specified time check box and completing the Pause for field. The purpose of 
this pause is to allow you time to execute the existing maintenance and 
resolve the issue which triggered the maintenance without creating multiple 
maintenance tasks on the issue.

Thus a task set to fire whenever the available disk space on a file server drops 
below 10 GB can be set to pause for a week to allow your change team time 
to put a new drive on the server. If, within this one week window, the 
available space on the server continues to fall even further below the 
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maintenance task's threshold value, the task does not fire a second time. If, 
however, at the end of the week, the available space is still beneath the 
threshold, the task fires again, creating a second change request, and then 
sleeps again for seven days.

Manual Repetition

This is a mechanism you can use when your demand based task doesn't fit 
into either of the above categories. A task set to Do Not Run Again fires once 
when its trigger conditions are met, and then inactivates itself until it is 
manually activated again. You can use this mechanism either to model 
one-time maintenance events or those which require human intervention to 
recalculate the trigger conditions.

To Set the Repeat Criteria for a Demand Task:

Choose one of the three possible repetition models in the Determine when 
to run next by drop-down list field.

If you chose an increment repetition, then you will be prompted for a 
repeat increment in the edit box of the same name.

If you chose a quiescent repetition, you will be prompted for a quiescence 
interval in the “Pause For” edit box.

If you chose manual repetition, no additional information is required.

In the following example, we have set up a task to monitor device, 
MF-1000001 and execute whenever the available.memory field drops below 
1000. Furthermore, we have specified that after this task executes, it will stop 
monitoring the device in question for one day in order to allow the situation 
to be resolved.
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Note that we haven’t yet defined what is supposed to occur when this task 
executes, merely under what conditions it executes.

Figure 5-11: Demand Trigger Example

Notes/Limitations
Many fields within ServiceCenter inventory which hold numeric values 
are, nonetheless, character fields. In general, this was implemented to 
allow for the storage of units along with the raw number e.g. 1,024MB or 
2,000 lbs. Scheduled maintenance is capable of performing comparative 
operations on these quasi-numeric fields by stripping out any non 
numeric characters and casting the result as a number. Thus 1,024MB 
becomes the number 1024 for purposes of comparing it to a threshold 
value.
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Scheduled Maintenance monitors the requested field on the requested 
device, no matter what mechanism is used to modify it. Thus Scheduled 
Maintenance reacts to a change whether the change was via an interactive 
user, or via a background task or remote agent.

It is possible to have multiple demand maintenance tasks linked to the 
same device. If more than one demand task is triggered by a single update 
to a record, then each of the tasks fires. Thus you can potentially create 2 
(or more) maintenance tasks as a result of a single change to a device.

Scheduled Maintenance reacts to changes in the device record, not 
changes in the maintenance task. Thus creating, or modifying, a 
maintenance task such that it is triggered by the current state of a 
monitored record will not trigger that record until a modification occurs 
to the monitored device.

Defining a Task's Effect and Details
Scheduled Maintenance allows you to create several types of tasks. When you 
create a task, all normal default values are enforced, messages are sent, 
Format Control and macros are executed, etc. All of the usual validations run 
as well. However, if an automatically generated Incident ticket, Change 
request, or Request Management quote does not match the validation rules, 
Scheduled Maintenance tries to ignore the validation rules and save the ticket 
anyway. 

Scheduled Maintenance also allows you to open a collection of incident 
tickets, change requests, or request management quotes for every asset in 
inventory which meets certain predefined criteria, or which matches a 
specific user-defined query. Using one of these methods, a maintenance task 
can be created for any arbitrary subset of the inventory. 

The Scheduled Maintenance Advanced Query option has a built in 
anti-spam feature. By default, the system only generates 50 tickets, regardless 
of how many records the advanced query returns. This threshold is user 
definable under the Administrative Options section of the Scheduled 
Maintenance Menu. See the Application Administration Guide for 
information on this feature. 
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To define a task’s effect and details:

1 Click the Effect tab.

2 Specify the type of task you would like to create by selecting one of the 
following choices. 

Create One Incident Ticket.

Create One Change Request.

Create One Request Management Quote.

Create one Incident Ticket for each Device of Class X at location Y. 

Create one Change Request for each Device of Class X at location Y.

Create one Request Management Quote for each Device of Class X at 
location Y.

Create Nothing: Only Execute Expressions and Format Control.

Note: You can limit the creation of multiple tasks to only those assets at a 
particular location by filling in the Location field. If you do not specify 
a location, then the task creates an Incident ticket, Change request, or 
Request Management quote for every asset of the appropriate type in 
your inventory, regardless of its location. 

3 Enter a title. This is the title on the Incident ticket, Change request, or 
Request Management quote.

4 Enter description text. This is the description on the Incident ticket, Change 
request, or Request Management quote Scheduled Maintenance creates.

5 Click the Details tab. 

6 Enter the task details.

See Creating One or More Incident Tickets on page 170, for details on how 
to create a single Incident ticket.

See Creating One or More Change Requests on page 174, for details on how 
to create a single Change request.

See Creating One or More Request Management Quotes on page 177, for 
details on how to create a single Request Management quote.

See Creating One or More Incident Tickets on page 170, for details on how 
to create one Incident ticket for each asset of a particular class in inventory 
at a specific location. For example, one ticket for every printer in Austin.
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See Creating One or More Change Requests on page 174, for details on how 
to create one Change request for each asset of a particular class in 
inventory at a specific location. For example, one request for every server 
in Dallas.

See Creating One or More Request Management Quotes on page 177, for 
details on how to create one Request Management quote for each asset of 
a particular class in inventory at a specific location. For example, one 
request for every server in Houston.

See Using Expressions and Format Control Only on page 180, for details on 
how to schedule Expressions and Format control without generating 
tickets of any kind.

When you are finished your task looks something like this: 

Figure 5-12: Defining a Task’s Effect and Details
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Creating One or More Incident Tickets
Incident tickets can specify:

To create one or more Incident tickets:

1 Click the Effect tab and select Create One Incident Ticket or Create one 
Incident Ticket for each Device of Class X at location Y. 

If you selected Create One Incident Ticket for each Device of Class X at 
location Y, do steps a-c; otherwise, proceed to step 2.

a Select the asset type, using the Open for this Device Type field.

b Select the location, using the At Location field.

c If desired, further specify the selection of assets to be maintained, by 
selecting the Use Advanced Query check box. The location and asset based 
selection boxes disappear and are replaced by the All Devices Matching 
THIS Query field. 

d Enter the query in the All Devices Matching THIS Query field.

Warning: Unless the Max Generation Count has been changed, no more 
than 50 tickets are generated, even if you want them to be. See the 
Application Administration Guide for information on this feature. 

Scheduled Maintenance requires that you enter something in the All 
Devices Matching THIS Query field if you select the Use Advanced Query 
check box. It does not, however, require that what you type makes sense. 
Test all queries, using Asset Management, before you enter it here, to 
insure that it returns the correct records before you use it on a live 
Maintenance Task.

2 Click the Details tab to bring up a list of fields for the Incident ticket(s).

3 Complete the following fields:

Assignment Group (assignment) Category (category)

Expression Format Control 

Incident description (action) Incident title (brief.description)

Maintained Device (logical.name) Owner (ticket.owner)

Priority Code (priority.code) Status (problem.status) 
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Incident Details Tab Fields

4 If you are creating one Incident ticket, then select the particular asset that you 
want worked on, using the appropriate drop-down list. 

If you are creating a group of Incident tickets, then the Work on This Device 
field is not available. Instead, Scheduled Maintenance automatically sets this 
field as it works its way though your inventory, creating tickets for each 
relevant asset.

5 Enter Expressions for the ticket, if desired. For more information, see the 
Application Administration Guide. 

6 Enter Format Control Record for the ticket, if desired. For more 
information, see the Application Administration Guide.

Field Definition

Open Incident Tickets
of Category

Select a Category for the Incident ticket(s) using the 
drop-down list. (Required field.)

Assign to Select an Assignment group for the ticket(s) using the 
drop-down list.

Set Status to Select a Status for the ticket(s), using the appropriate 
drop-down list.

With Ticket Owner of Select an Owner for the ticket(s), using the drop-down list.

With Priority Code of Select a Priority Code for the ticket(s), using the 
drop-down list.

With a Company of Select a Company for the ticket(s), using the drop-down 
list.
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When you are finished your task looks something like this: 

Figure 5-13:  Creating an Incident Ticket—Main Information

7 Click the Parts & Labor tab.

Any parts and labor estimates you enter here will automatically be entered 
into the Incident ticket when it is generated. Additionally, the information 
entered here is used by the cost estimating tools as described below.
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Your Parts & Labor tab should look something like this:

Figure 5-14: Create and Incident Task—Parts & Labor tab
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Creating One or More Change Requests
Change requests can specify:

To create one or more Change requests:

1 Click the Effect tab and select Create One Change request or Create one 
Change request for each device of class x at location y.

If you selected Create one Change request for each device of class x at 
location y, do steps a-c, otherwise, proceed to step 2.

a Select the asset type, using the Open for this Device Type field.

b Select the location, using the At Location field.

c If desired, further specify the selection of assets to be maintained, by 
selecting the Use Advanced Query check box. The location and asset based 
selection boxes disappear and are replaced by the All Devices Matching 
THIS Query field. 

Enter the query in the All Devices Matching THIS Query field.

Warning: Unless the Max Generation Count has been changed, no more 
than 50 tickets are generated, even if you want them to be. See the 
Application Administration Guide for information on this feature. 

Expressions Format Control

Maintained Device (logical.name) Request Assignee (assigned.to)

Request Category (category) Request Coordinator (coordinator)

Request Description (description) Request Priority (priority)

Request Work Manager (work.manager)
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Scheduled Maintenance requires that you enter something in the All 
Devices Matching THIS Query field if you mark the Use Advanced Query 
check box. It does not, however, require that what you type in makes 
sense. Test all queries, using Asset Management, before you enter it here, 
to insure that it returns the correct records before you use it on a live 
Maintenance Task.

2 Click the Details tab to bring up a list of fields for the Change request(s).

Change Details Tab Fields

3 Enter Expressions for the Request(s), if desired. For more information, see 
the Application Administration Guide. 

4 Enter Format Control Record for the Request(s), if desired. For more 
information, see the Application Administration Guide.

Field Definition

Open Change of Category Select a Category for the Change request(s) using the 
appropriate drop box. (Required field.)

Coordinator Select a Coordinator for the Request(s) using the drop 
box.

Work Manager Select a Work Manager for the Request(s) using the 
drop box. 

Set Priority to Select a Priority for the Request(s) using the 
appropriate drop box.

Assign to Select an Assignee for the Request(s) using the 
appropriate drop box. 

With a Company of Select a Company for the Request(s), using the 
drop-down list.

Work on this Device Select an inventory item to work on, using the fill box. 
This appears only if you selected Create One Change 
request.
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When you are finished your task looks something like this: 

Figure 5-15: Creating a Change Request—Details tab

5 Click the Parts and Labor tab.

6 Enter Parts and Labor Information. 

Any parts and labor estimates you enter will automatically be entered into the 
Change Request when it is generated. Additionally, the information entered 
here is used by the cost estimating tools as described below.
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Your parts and labor tab should look something like this.

Figure 5-16: Create a Change Task—Parts & Labor tab

Creating One or More Request Management Quotes
Request Management quotes can specify:

Expressions Format Control 

Quote Assignee (assigned.to) Quote Category (category)

Quote Coordinator (coordinator) Quote Description (description)

Quote Priority (priority) Quote Requestor (requestor.name)
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To create one or more Request Management quotes:

1 Click the Effect tab and select Create One Request Management quote or 
Create one Request Management quote for each device of class x at location 
y.

If you selected Create one Request Management quote for each device of 
class x at location y, do steps a-c, otherwise, proceed to step 2.

a Select the asset type, using the Open for this Device Type fill box.

b Select the location, using the At Location fill box.

c If desired, further specify the selection of assets to be maintained, by 
marking the Use Advanced Query check box. The location and asset based 
selection boxes disappear and are replaced by the All Devices Matching 
THIS Query field. 

Enter the query in the All Devices Matching THIS Query field.

Warning: Unless the Max Generation Count has been changed, no more 
than 50 tickets are generated, even if you want them to be. See the 
Application Administration Guide for information on this feature. 

Scheduled Maintenance requires that you enter something in the All 
Devices Matching THIS Query field if you mark the Use Advanced Query 
check box. It does not, however, require that what you type in makes 
sense. Test all queries, using Asset Management, before you enter it here, 
to insure that it returns the correct records before you use it on a live 
Maintenance Task.

2 Click the Details tab to bring up a list of fields for the Request Management 
quote(s).

Request Details Tab Fields

Field Definition

Open RM Quote of Category Select a Category for the Request Management 
quote(s) using the drop box. (Required field.)

Requestor Name Select the Requestor’s Name for the Quote(s) using 
the drop box. 

Assign to Select an Assignee for the Quote(s) using the drop 
box. 

Set Priority to Select a Priority for the Quote(s) using the drop 
box.
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3 Enter Expressions for the Quote(s), if desired. For more information, see the 
Application Administration Guide. 

4 Enter Format Control Record for the Quote(s), if desired. For more 
information, see the Application Administration Guide.

Note: Parts and labor information is not available for request generating 
tasks.

When you are finished your task looks something like this: 

Figure 5-17: Creating a Request Management Quote

Coordinator Select a Coordinator for the Quote(s) using the 
drop box. 

With a Company of Select a Company for the Quote(s), using the 
drop-down list.

Field Definition
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Using Expressions and Format Control Only
You can use Scheduled Maintenance to run Expressions and Format Control 
without generating tickets of any kind by:

1 Selecting Create Nothing: Only execute expressions and Format Control.

2 Entering the desired expressions and Format Control on the details tab.

To execute expressions and Format Control:

1 Click the Effect tab and select Create Nothing: Only execute expressions and 
Format Control.

2 Click the Details tab to bring up a list of fields for the expressions & Format 
Control.

3 Enter Expressions for the ticket, if desired. For more information, see the 
Application Administration Guide. 

4 Enter Format Control Record for the ticket, if desired. For more 
information, see the Application Administration Guide.

When you are finished your task looks something like this:

Figure 5-18: Using Format Control and Expressions Only
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Adding Attachments

Attachments are not carried over into the tickets, requests or quotes created 
by the Scheduled Maintenance task. They are associated with the task and 
exist to add documentation or associated information to the task itself. 
Attachments placed on the attachments tab will not be copied into or 
otherwise associated with any incidents, changes, or requests created by the 
task in question.

To add an attachment:

1 Select the Attachments tab.

2 Copy and paste (or drag and drop) the attachment into the Attachments 
window.

When you are finished your task looks something like this: 

Figure 5-19: Adding an Attachment
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Saving a Task

Once you have created a task, set its schedule and defined its effect, be sure to 
save it.

To save a task:

Click Add on your tool tray. 

If this is a time-based task, then you will notice that the system has calculated 
the next time this task should execute and populated in the Next Scheduled 
at field.

If this is a time based task, Scheduled Maintenance executes the task the next 
time it is scheduled to take effect. You may want Scheduled Maintenance to 
execute the task immediately in order to verify it works properly. 

If this is a demand based task, it runs as soon as an update is made to its 
monitored device such that it meets the trigger criteria.

Using the Cost Estimate Tool

Version 5.1 of Scheduled Maintenance introduces a new tool to help estimate 
the costs associated with your scheduled maintenance program. This tool 
allows you to select a subset of your maintenance tasks, and then calculate for 
you the estimated cost of executing those tasks within a specified time frame 
e.g. from 01/01/03 until 03/31/03.

Using the tool is a two-step process. First, you select a set of task records from 
within scheduled maintenance. Second, you invoke the tool and provide it 
the criteria it requires.

To use the Cost Estimate Tool:

1 Select Scheduled Maintenance from the main ServiceCenter menu.

2 Select Scheduled Maintenance again from within the Scheduled 
Maintenance menu.

3 Query the set of records you are interested in performing cost estimates on 
via the usual query tools.

4 Once your query completes, choose List Options>Estimate Costs.
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5 When the cost estimate screen appears, enter a start and an end date for your 
estimation period. For example, start on 01/01/03 and end on 03/31/03 for 
the first calendar quarter of 2003.

6 Press Proceed.

7 The system automatically calculates the number of times that each task will 
execute within the time frame you specified as well as the cost for running 
each task once. The results of these calculations display in a spreadsheet 
format as below.

Figure 5-20: Scheduled Maintenance Cost Estimates

Notes/Limitations
The tool estimates the number of times a task runs by using a 
mathematical function rather than by manually cranking through the task 
dozens or potentially hundreds of times. These functions are fast and 
generally highly accurate. However, there are cases where rounding errors 
or other factors result in the estimated number of times a task will run 
within a given time frame being either one higher or one lower than the 
actual number of runs.
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The tool makes no provision for tasks which expire halfway through the 
listed time frame and instead assumes that all listed tasks continue 
throughout the time series.

If the tool must make foreign currency conversions, it executes them via 
either today's exchange rate or, if that is unavailable, the most recent 
exchange rate it has on file. 

Note: Actual exchange rates fluctuate significantly, and may result in tasks 
later in the time frame performing under a dramatically different 
exchange rate from that used in the estimation process.

The cost estimates are only as good as the parts and labor information 
provided. Inaccurate or incomplete part and labor descriptions on 
maintenance tasks result in inaccurate or incomplete cost estimates.

The tool cannot and does not estimate the number of times that demand 
based maintenance tasks runs within the budget time frame. Demand 
based tasks have their names marked with an asterisk (*) and have their 
estimated run count set to zero. The product will, however, calculate their 
cost per run information for you to allow you to enter your own run count 
estimates based on your judgement.

Executing a Task

When the time comes for a maintenance task to be executed, the Scheduled 
Maintenance system creates an Incident ticket, Change request, or Request 
Management quote exactly as though a technician at your service desk had 
manually typed it in. 

It then uses your existing ServiceCenter code, with all of your validations, 
and tailoring to create the appropriate Incident ticket, Change request, or 
Request Management quote. Scheduled Maintenance then tracks the 
execution of these Incident ticket, Change request, or Request Management 
quote in order to store a complete service history for each task.

As soon as a task is created and stored, Scheduled Maintenance immediately 
calculates when that task should next be executed. At the appropriate time, 
an Incident ticket, Change request, or Request Management quote is 
automatically created for each of those tasks. The system then tracks the 
execution of each Incident ticket, Change request, or Request Management 
quote it generates, thus creating a historical maintenance record.
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Verifying a Task is Working

Once a task has been saved, you check at the task or tasks that Scheduled 
Maintenance has created for you by:

Forcing a Task to Execute Immediately on page 185

Checking the Execution History of a Task on page 186 

Checking the Execution Details of a Task on page 187

Forcing a Task to Execute Immediately
Forcing a task to execute immediately allows you to see if a task executes. 

To force a time based task to execute immediately:

1  Bring up the task you want to test inside of Scheduled Maintenance. 

Locate Next Scheduled At: field. This field contains a calculated time when 
the system thinks this task should execute next. 

2 Set the time to some point in the past like 01/01/1990.

3 Make certain that the Active check box is selected. (Only active tasks 
execute.)

4 Press F4 to save your Changes, and F2 to exit.

By default, the system only checks to see if it has any tasks to execute every 60 
seconds. You may have to wait anywhere from no time at all to one minute 
before your task executes. 

When enough time has passed, go back into Database Manager and look at 
your task. If it has executed, the Next Scheduled At field changes. Once a task 
executes, Scheduled Maintenance automatically reschedules it for the next 
appropriate time. This means that the task was executed, however, that is no 
guarantee that it did what you expected it to. 

To force a demand based task to execute immediately:

1 Locate the monitored device within ICM.

2 Update the device such that it meets the trigger criteria for the maintenance 
task.

The maintenance task runs as soon as you update the record.
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Checking the Execution History of a Task
To find out whether a task was executed or not, check the execution history 
log. An entry is written here every time a task executes. For a newly created 
task there should only be a few entries. A task that has run every ten minutes 
for a year, however, would have many entries in its execution log. 

There are two ways to access the execution log. You can:

Search for tasks by specified criteria.

View the history of a particular task. 

To search by criteria:

1 Open the Scheduled Maintenance Main menu.

2 Click Execution History. A search window appears. 

3 Enter the search criteria. You can search by:

Task ID

Event Date

Result

Creation Count

4 Press F6 or click Search to find all items with that criteria. 

To check the history of a particular task or one that is already open:

1 Open the task inside of Scheduled Maintenance. 

2 Click the History tab.

3 Click Execution History. 

Tasks have four possible execution results.

Success: Executed Successfully

Your task executed successfully, and an Incident ticket, Change request, or 
Request Management quote was created. No problems were encountered. 
This is the result you want to see.

Reject: Incident/Change was rejected by Format Control
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The Format Control rejected the record. Remember that Scheduled 
Maintenance fills in a record just like a user. So, if a certain field is required 
when a user creates an Incident ticket, Change request, or Request 
Management quote, it is also required when Scheduled Maintenance 
creates the same Incident ticket, Change request, or Request Management 
quote. 

If the required field isn't one of those that Scheduled Maintenance fills in 
by default, you'll probably have to use expressions to populate it. For more 
information, see the Application Administration Guide.

Error: Encountered an Error while executing task expressions

This means that you completed the Expressions field on the Details tab of 
the task, and that one or more of the expressions entered didn't execute 
properly. Identify and fix the problem. 

Error: Encountered an unknown error

This usually means that an unhandled error occurred inside the 
ServiceCenter code as opposed to the Scheduled Maintenance Code. This 
is a very rare event.

Checking the Execution Details of a Task
You can check the execution details for a task, by taking a look at the Incident 
tickets, Change requests, or Request Management quotes that were generated 
by the task.

To search for items by criteria:

1 Open the Scheduled Maintenance Main menu.

2 Click Execution Details. A search window appears. 

3 Click Fill by the Number field, to select from the complete list of Incidents, 
Quotes or Requests.

Or enter the search criteria and press F6 or click Search to find a particular 
item.
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You can search by:

ID—a unique identifier that Scheduled Maintenance gives to every task it 
creates

Class—one of three values: Incident, Change, or request.

Number—the Incident number, Change number, or request number of 
the created task.

Opened at—the time the task was opened.

Closed at—the time the task was opened.

Task ID—the ServiceCenter ID of an Incident ticket, Change request or 
Request Management quote.

Logical Name—the ServiceCenter asset against which scheduled 
maintenance was run e.g. all maintenance history for the email server.

4 Select an item from the list to see the details of the Incident, the Change, or 
the request that was created.

To see what was generated particular for a task:

1 Access the task in Scheduled Maintenance.

2 Click the History tab.

3 Click Execution Details.

You see a list of all Incident tickets, Change requests, or Request 
Management quotes created as a result of this task, when they were opened, 
and when they were closed.

4 To view an Incident ticket, Change request, or Request Management quote: 

a Select the item from the list.

b Place the cursor in the Number field.

c Click Find in the toolbar, or press F8.
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Sample Time Scheduled Tasks

For these examples, we give a description of the task and then show 
screenshots that demonstrate how to input that task.

Purging the IDOC Table on page 189

Maintaining the Printers on page 193

Purging the IDOC Table
The company has an item in inventory called SAP003. It is one of the SAP 
instances, and a lot of external transactions are done on it. As a result, the 
IDOC table gets extremely clogged and needs to be purged occasionally to 
reclaim storage space. The SAP basis team has been doing this on an as 
needed basis, but it almost ran out of space last month. The company wants 
to formalize the process and purge the IDOC table monthly from now on.

The basis team is accustomed to getting requests like this via Change 
Management, so we'll create Change requests rather than Incident tickets or 
Request Management quotes. It is an application category Change, we want 
MAX.MANAGER to coordinate the effort, and SUSIE.SUPERTECH to do 
the actual purging. 

Figure 5-21: Purging the IDOC Table: Description tab
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Figure 5-22: Purging the IDOC Table: Scheduling tab
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Figure 5-23: Purging the IDOC Table: Effect tab
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Figure 5-24: Purging the IDOC Table: Details tab
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Maintaining the Printers
The company has just made an investment in upgrading all of its 
departmental printers to the new company standard, 1200 dpi HP LaserJet 6. 
The new printers are working well, but according to the manufacturer, the 
printers should receive full cleaning every month to keep them in top 
condition. There are about 300 printers, in twelve sites. The technicians are 
never going to be able to keep track of which ones have been cleaned and 
which ones have not.

Scheduled Maintenance can automate this task for them. The hardware 
technicians are accustomed to getting requests like this via Incident 
Management, so we'll create Incident tickets rather than Change requests or 
Request Management quotes. For organizational purposes, we schedule 
printer maintenance on one site at a time. For this example, we set up 
maintenance for all the printers at our Houston office.

 

Figure 5-25: Maintaining the Printers: Description tab
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Figure 5-26: Maintaining the Printers: Schedule tab

Figure 5-27: Maintaining the Printers: Effect tab
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Figure 5-28: Maintaining the Printers: Details tab
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CHAPTER

6
 Incident Management
Incident Management allows you, as a help desk operator, to report various 
types of problems, such as software, equipment, facilities, or network 
problems. As a manager or technician, you can track the progress of the 
resolution of these problems. Incident Management automates the process 
of reporting and tracking an incident or groups of incidents associated with 
a business environment.

This chapter has been divided into the following sections:

How Incident Management Works on page 199—how you can use Incident 
Management to report a problem. 

Accessing Incident Management on page 202—how to access the application, 
with an introduction to the Incident Management menu.

Help Desk Basics on page 203—describes the Incident List inbox.

Search Incident Management on page 206—how to perform a query for an 
incident ticket.

Opening Incident Tickets on page 215—how to open, update, and close an 
incident ticket.
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Status, Alerts, and Escalation on page 252—how ServiceCenter escalates 
incident tickets through alerts.

Cause Codes and Probable Cause on page 254—how to enter a Cause Code 
into an incident ticket and how Cause Codes relate to the ServiceCenter 
Probable Cause feature.

A help desk operator can open an incident ticket for the incident reported. An 
incident ticket also can be opened from a call report.

Incident tickets can be:

Created and opened by help desk operators or automatically opened by 
the ServiceCenter Event Services module.

Sent automatically to the proper system personnel.

Tracked and resolved by the personnel and system managers. 

Sent by e-mail or fax to the user with a resolution to the reported incident.

See instructions for printing from Incident Management in Printing on 
page 539
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How Incident Management Works

Service Management allows you, as a help desk operator, to keep track of calls 
by creating a call report (see Creating a Call Report on page 128 for more 
details). If a reported incident requires further action, use Incident 
Management to open an incident ticket to track the problem.

Incident Management forms are provided for you to enter the appropriate 
information and incident categories. The Fill function within the form helps 
you to complete portions of the ticket. From there, you can review the 
incident ticket and decide what action to take.

If the incident needs to be resolved by another technician or department, 
the incident ticket can be forwarded. Once the problem is resolved, the 
incident ticket can be returned to you with the resolution for 
confirmation.

If the ticket is reporting an incident that is a recurring problem, you can 
choose to open a Root Cause ticket. The Root Cause ticket can then be 
further investigated (see Root Cause Analysis on page 377 for more details 
about Root Cause Analysis and how to open a Root Cause ticket). 

You can check the incident ticket at any time to see the current status. 

Figure 6-1 on page 201 shows the workflow of the incident report and 
incident ticket process. 
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For example: A user cannot print to the network printer, so the user calls you 
at the help desk. You, as the help desk operator, open a call report to make a 
record of the call. In talking with the user, you discover that you cannot 
resolve the problem during the phone call, so you open an incident ticket. 
You send the ticket to a technician, who discovers that the printer’s network 
connection is broken. The technician updates the incident ticket and 
forwards the ticket to the network administrator with a message that the 
printer network connection is broken. The network administrator has the 
connection repaired, updates the ticket, and sends the ticket back to you for 
closing.

Incident Management allows you to automatically view related incident 
ticket records, which can be selected and opened directly from the list view.

Incident tickets are assigned categories that determine the type of information 
stored. For example, an incident ticket describing an e-mail incident stores 
different information than an incident ticket for a printer.

The appropriate personnel can escalate and reassign incident tickets. The 
system can also automatically issue alerts and escalate a problem that is not 
getting resolved. For information about the capability required to escalate 
and reassign incident tickets, see the Application Administration Guide.

Note: The workflow Figure 6-1 on page 201 can be changed by modifying 
ServiceCenter scripts to meet your business process flow.
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Figure 6-1:  Incident Management/Call Report Workflow 

Associate the call report 
with an incident ticket.

Create a new incident 
ticket associated with 
this call report.

Resolved? Resolve and close the 
call report.

No

A user calls to report an 
incident.

Call report opened.

Is an existing 
problem the 
cause?

Yes

Finished with this Call.

No

Yes
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Accessing Incident Management

You can access Incident Management from the ServiceCenter Home menu.

If you are logged on as FALCON or MAX.MANAGER, click Incident 
Management.

If you are logged on as SUSIE.SUPERTECH, click Incident Queue.

If you are logged on as BOB.HELPDESK, click Incident, Call and Change 
Queues.

Figure 6-2 shows the home menu for BOB.HELPDESK.

Figure 6-2: Help Desk Incident Management tab

Queues 
Button
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Help Desk Basics

Most user interaction in Incident Management takes place in the help desk 
functions. From the help desk, you can open, update, and close incident 
tickets and call reports.

Accessing the Incident List Inbox
To access the Incident List inbox:

1 Click Incident Management (or Incident Queue). This button may be in an 
Incident Management tab or on the Home menu, depending on how you are 
logged on.

An Incident Management inbox displays (Figure 6-3 on page 203). 

2 Double-click on one of the records listed to access that incident ticket.

Figure 6-3: Incident Management Inbox

Incident Ticket Access Inbox List
ServiceCenter 
Application Buttons
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Incident List Inbox Buttons
Each inbox contains a series of buttons providing quick access to other 
ServiceCenter applications and inboxes. The buttons are the same in each 
inbox, except for two that are specific to the application.

Incidents by Owner—displays a list of records for 
the operator.

By Assignment Group—displays a list of records 
for another assignment group.

Options Menu—Incident List
The Options menu provides shortcuts to other ServiceCenter applications, 
and access to Incident Management, Search, and Inbox functions.

Option Description

Asset Management Accesses Asset Management.

New Incident Accesses a new incident ticket form.

Search Incidents Accesses the Incident Management search function.

Quote List Accesses the current user’s Quote List (Request Management 
inbox).

Order List Accesses the current user’s Order List (Request Management 
inbox).

Line Item List Accesses the current user’s Line Item List (Request 
Management inbox).

Call List Accesses the current user’s Call List (Service Management 
inbox).

Change List Accesses the current user’s Change List (Change Management 
inbox).

Task List Accesses the current user’s Task List (Change Management 
inbox).

Administer Accesses the Incident Management Security Administration 
Utility.

Refresh Updates the current list.

Switch Inbox Displays a dialog window to select another inbox. Functions 
the same as the Switch Inbox button.

Starting Lists Displays the initial Call List.
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List Options Menu—Incident List
The List Options menu is available when a QBE Record list displays.

Count Tallies the number of records in the Call List.

Assignment 
Group’s Incidents

Searches for incident tickets assigned to a specified assignment 
group. A message box prompts you to select an assignment 
group.

Owner’s Incidents Searches for incident tickets assigned to a specified 
ServiceCenter user (owner). A message box prompts you to 
select an owner. 

Sort by Sorts the Incident List by the ID, Open Time, Category, or 
Alert Level. These options function the same as clicking on the 
inbox header buttons.

List Option Description

Export to Excel Exports the current Incident List to a Microsoft® Excel 
spreadsheet. Excel is opened automatically and the list is 
placed in the spreadsheet. Basically, you can export 
information to any product that has DDE (Dynamic Data 
Exchange) support. This DDE function requires Excel 95 or 
later.

Export to Text File Exports the current Incident List to a text file. This option is 
not part of the DDE support and can be run from clients 
other than those operating in Windows.

Option Description
Help Desk Basics  205



ServiceCenter
Search Incident Management

Incident Management allows you to query for incident ticket records. The 
records are displayed in an Incident List. You can also save these queries as 
inboxes. Inboxes are discussed in Inboxes on page 77.

The search form fields allow you to narrow the search parameters. The 
procedures for searching Incident Management are discussed in Search 
Procedures on page 214.

Incident Ticket Search Fields
The Incident Ticket search information displays in three tabs: Basic Search, 
Advanced Search, and IR Query.

Incident Ticket—Basic Incident Search tab
You can leave any or all fields in this tab blank (see Figure 6-4 on page 207). 
For fastest searching, use the fields identified as key (indexed) fields at your 
site. If these are not clearly identified on the form, ask your ServiceCenter 
administrator for a list of key fields.
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Most fields have Arrow or Browse buttons, which allow you to select from a 
drop-down list or QBE list.

Figure 6-4: Basic Search tab
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Fields

Field Description

Number Type the incident ticket number, if you know it, in the form of 
IMxxxx, where xxxx is the number. For best results, enter the 
full incident ticket number. If you have a partial number, you 
can enter that partial number to access a QBE list of possible 
records, but your list does not necessarily include all possible 
records. To begin a search with an incident ticket number, 
first deselect the Smart Search check box. Do not use 
wildcards (for example, *) in your search.

Smart Search? Allows searches for incident tickets by number only (prefixes 
or suffixes, such as IM, are omitted). Smart Searches return 
the ticket requested regardless of its state (such as, open or 
closed). If any settings on the search form other than the 
default are entered, a normal query is performed and the 
Smart Search feature is ignored.

Note: If a search is being performed to include any value 
other than the incident ticket number, Smart Search is 
disabled.

Company Name of the company from the company file.

Division Name of the division for which the contact works.

Alert Level Enter the alert level of the incident ticket or tickets you are 
searching. See Status, Alerts, and Escalation on page 252, for 
details on alerts.

Contact ServiceCenter contact who called.

Status Enter the status of the incident tickets for you are searching: 
Open, Pending other, Work in progress, Reject, Resolved, 
Pending vendor, Closed, Pending customer, Referred, Replaced 
Problem, and Suspended.

Owned By Enter the Incident Management operator responsible for the 
ticket or tickets.

Reported By Enter the user who reported the incident.

Category Enter the Incident Management category classifying the ticket 
or tickets.

Sub Category Enter an Incident Management sub-category for a more 
detailed breakdown of the incident category. The contents of 
the subcategory drop-down list are determined by the 
Category chosen.
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Owned By Enter the assignment group responsible for the ticket or 
tickets.

Primary Asgn 
Group

Select the level of the assignment group selected in the 
Assigned To field.

Assignee Name Person responsible for resolving the problem.

Severity Indicates how pressing an incident is for the caller. The 
severity can be Critical, Major, Medium, Low, or Very Low. The 
default is Low.

User Priority Enter the priority of the ticket or tickets: Critical, Major, 
Medium, Low, or Very Low.

Product Type Asset product type.

Problem Type Type of problem being reported.

SLA Select if you want to search for tickets covered by a particular 
service level agreement.

Contact Name The Contact Name related to the company from which the 
call was received. Click Browse to select a Contact Name from 
the QBE list of contact names. See Contacts File Appendix A 
for information on contacts.

Contact Location The contact’s location from where the call originated.

Alternate Name Name of caller other than the contact name.

Manufacturer The asset manufacturer.

Class Related to the Manufacturer field and allows the incident or 
problem to be classified with the type of asset being reported. 

For example: Manufacturer=Dell, Class=Laptop.

SDUs unable to fix Service delivery units unable to fix the reported problem.

Total Loss of 
Service

Asset reported has total loss of service.

Cost Center The cost center for the contract.

Asset ID Enter or select the name of the asset listed in the incident 
report.

Assigned As: Select the assigned status of the tickets you want to search:

Primary
Secondary
Either

Field Description
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Fix that is: Select the current type of fix or solution for the tickets you 
want to search:

Open
Closed
Either

Tickets that are: Select the status of the tickets you want to search:

Open
Closed
Either

Search Which 
Site?

Used only in distributed ticketing to indicate the location to 
search for records. Distributed ticketing is discussed in the 
Application Administration Guide. This field is available only if 
distributed ticketing is activated for ServiceCenter.

Field Description
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Advanced Search tab
Displays a search window that allows you to specify date ranges and 
additional criteria not normally used for a Basic Search. Fields in this tab 
(Figure 6-5 on page 211) can be left blank.

Figure 6-5: Advanced Search tab

Note: Choose Option>Expert Search to write your own search query and 
sort the results by keyed fields. 
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Fields

Field Description

Opened, Last 
Updated, and Closed

Enter After as well as And Before to narrow down dates 
and times (optional) the report was opened, updated, or 
closed. The format is mm/dd/yyyy hh:mm:ss. If a time is 
not entered, the default is 00:00:00.

Note: The date and time format can be set by your 
system administrator in the System Wide Company 
Record or in individual operator records. Therefore, 
the date and time format you use may vary from the 
default shown above.

By Enter the name of the Incident Management operator 
who opened or updated the incident record. You can type 
the name, or you can use the Arrow button or Down 
arrow key to access a drop-down list.

Location Enter the location of the asset for which the incident was 
reported.

Search Which Site Enter the site where the asset is located. Used only in 
distributed ticketing to indicate the location to search for 
records. Distributed ticketing is discussed in the 
Application Administration Guide. This field is available 
only if distributed ticketing is activated for ServiceCenter.

Date of Visit Enter the date of the site visit.

Technician Enter the technician involved with helping to resolve the 
ticket.

Hardware Details Enter the details of the asset being reported.

Platform 
Manufacturer

Enter the platform manufacturer.

Serial Number Enter the serial number of the asset for which the incident 
was reported.

Model Enter the model of the asset listed in the ticket or tickets.

Operating Systems 
Details

Enter the operating system details.

Operating System Enter the operating system.

OS Version Enter the OS version.

Service Level/Pack Enter the application service level/pack number.

Failing Component 
Details

Enter the details of the failing component of the asset 
being reported.
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IR Query tab
The IR Query tab displays in Figure 6-6 on page 213. 

Figure 6-6: IR Query tab

Manufacturer Enter the asset manufacturer.

Unit Enter the unit number of the asset.

Serial Number Enter the serial number of the failing component.

Third Party 
References

Enter the details of any third party references.

Company Enter the reference’s company name.

Number Enter the reference’s company number.

Field Description
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 Search Procedures
To search for incident ticket records:

1 Click Incident Management (or Queue).

The incident ticket inbox displays.

2 Click Search.

A Search form (Figure 6-4 on page 207) displays.

3 Enter any Basic Search information you know. The more information you 
enter, the narrower the search parameters. 

Use one of the following options to fill in the fields:

Type known information. 

Click Fill, or press F9 to access a QBE list.

Click the Arrow button to access a drop-down list, or press the Down 
arrow to toggle through the selections.

4 Click the Advanced Search tab to further narrow the search parameters. 
Advanced search fields allow you to narrow the time frame when a record 
was opened or updated. You can also enter the name of the operator who 
opened or updated the report. These fields are independent of each other and 
can remain blank.

To fill in these fields: type known information, or click the Arrow button, or 
press the Down arrow to access a drop-down list.

5 To further narrow the search parameters, click the IR Query tab.

6 Enter a plain text description in the IR Search Text field.

Field Description

IR Search Text A blank text box where you can enter a plain text query.

Discovery Option Options where you can designate which kind of search you 
want:

Complete Match The system searches for an absolute match to the text you 
have typed.

Shallow The system searches using narrower parameters and returns 
fewer records than with a deep search.
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7 Click Search, or press F6.

The matching record displays.

If multiple records match the search parameters, a QBE Record list displays 
with the first record in the list displayed in the incident ticket form. Click on 
a record in the list to display it in the incident ticket form.

8 If a message is returned stating: No Records Found, broaden the search by 
eliminating some of the search parameters that you entered.

Note: You can sort a QBE Record list by clicking the column header of the 
area by which you want to sort the list. For example, to sort the list by 
status, click the Status header button.

Opening Incident Tickets

Opening an incident ticket for a reported incident creates a record that can 
be used to track the progress of the problem resolution. You, as a help desk 
operator, can fill in the incident ticket fields and update the ticket 
information. Message areas are provided to include descriptions of the 
incident, the actions taken, and, finally, the resolution of the incident.

Incident Management Records (Paging Feature)
As incident tickets are updated and closed, a new record is created for that 
ticket. These new records, also called pages, are created by the Incident 
Management paging feature. Enabling and disabling paging is discussed in 
the System Administrator’s Guide.

When an incident ticket is accessed, the most recent page (record) displays.
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Incident Ticket Fields
Not all the fields in the quick-open incident ticket form (Figure 6-7 on 
page 216) are required to open an incident ticket. Some fields are 
automatically filled in by ServiceCenter.

Figure 6-7: Quick-Open Incident Ticket (apm.quick) form

Fields

Field Description

Category Select an Incident Management category to begin a quick 
open and to classify the Incident ticket. This field is 
required. If you have a default category already specified, 
this category is entered automatically into the field.

Primary Asgn Group Select an assignment group that is responsible for resolving 
the Incident ticket.
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Once you make these selections, continue filling in other details in the fields 
described below.

Fields—Incident Ticket Top Section

Fields—Incident Details tab
See the Incident Details tab pictured in Figure 6-7 on page 216.

Field Description

Ticket Status Current status of the ticket:

Open—ticket currently active.
Pending other—action awaiting action on another incident 
ticket.
Work in progress—work currently underway to resolve this 
incident.
Reject—ticket rejected. No resolution at this time.
Resolved—ticket resolved.
Pending vendor—update awaiting action from a vendor.
Closed—incident ticket resolved.
Pending customer—update awaiting action from the 
customer who reported the incident.
Referred—referred incident for further analysis.
Replaced Problem—update reported problem.
Suspended—incident ticket has been suspended.

Title Incident title, based on reported incident.

Field Description

Reported By User (contact) who reported the incident.

Category
(required)

Earlier you selected an Incident Management category to 
begin the quick open process and classify the Incident 
ticket. If you have a default category already specified, this 
category is entered automatically into the field.

Sub Category
(required)

More specific breakdown of the category.

Product Type Asset product type.

Problem Type Type of problem being reported.

Company Name of the company from the company file.
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Fields—Actions/Resolution tab

Figure 6-8: Quick-Open Incident Ticket—Actions/Resolution tab

Owner ServiceCenter operator opening the ticket. By default, 
Incident Management automatically enters the name of 
the user who is currently logged on.

Primary Asgn Group This is the selection you made earlier when you started the 
Quick Open process. The primary assignment group is 
responsible for resolving the Incident ticket.

Assignee Name Person responsible for resolving the problem.

Second Asgn Group Backup assignment group responsible for the ticket.

Total Loss of Service Asset has total loss of service.

Severity Indicates how pressing an incident is for the caller. The 
severity can be Critical, Major, Medium, Low, or Very Low. 
The default is Low.

Site Category Enter the site category.

Cause Code Defines the probable cause of the incident. Refer to Cause 
Codes and Probable Cause on page 254.

Description Description of the incident.

Field Description
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Fields—Contact tab

Figure 6-9: Quick-Open Incident Ticket—Contact tab

Field Description

Corrective Actions Text box where corrective actions can be entered to show 
how the incident was resolved.

SDU unable to fix Check here if service delivery unit unable to fix.

Solution Text box where you can enter details about the resolution of 
the incident.

Resolution Code Provides a list of similar incidents from which you can 
choose a resolution. The resolution code and a description 
of the steps taken to resolve the incident are entered in the 
incident ticket.

Field Description

Reported By The Contact Name related to the company from which the call 
was received. Click Browse to select a Contact Name from the 
QBE list of contact names. The fields (Full Name, Phone, Ext., 
Site Name, Email, Payroll No., and Cost Center are automatically 
filled in from the contacts record for this caller. For more 
information, see Contacts File Appendix A.
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Fields—Asset tab

Figure 6-10: Quick-Open Incident Ticket Asset tab

Creating an Incident Ticket—Quick Open
In a busy help desk environment, the quick open function expedites the 
process of opening incident tickets. Basic information about the incident is 
recorded and saved. A new form is then displayed, in which you can open 
another incident report.

Field Description

Affecting Asset Asset for which an incident is being reported. When you select 
a Contact Name, information related to the associated 
Affecting Asset automatically populates the asset information 
fields (Type, Make, Model, Cost Center, Serial Number, 
Critical Asset, User, Supervisor, Install Date, and Maint 
Contract) from the asset record of the asset created in Asset 
Management.
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To do a quick open of an incident ticket:

1 Access Incident Management.

If you logged on as a manager or technician, click Incident Management 
(or Incident Queue) in your Home menu. The Incident Queue displays.

Click New.

If you logged on as a help desk user or system administrator, click Queues 
and New in the Incident list.

An incident ticket quick open form (Figure 6-11) displays.

Figure 6-11: Quick-Open Incident Ticket (apm.quick) form

2 Click Browse for the Category field to access a drop-down list. Select a 
category for the incident ticket.

If the Category field is left blank, you are prompted to select a category when 
you attempt to save the ticket. The categories are displayed in a QBE list.

3 Enter information about the incident in Incident Details.

4 Enter any other information you have about the incident in the other fields.
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5 Click Qopen (quick open), or press F2.

You are returned to a blank incident ticket form. 

A message displays in the status bar that states: Incident INxxxx has been 
opened (where xxxx is the incident number).

Options Menu—New Incident Ticket 
The Options menu in the new incident ticket form contains the following 
options:

Option Description

Lookup Cause Allows you to search the probable cause file for a 
possible cause and solution to the reported incident. 
This option works like the Find function, only 
displaying the record. The Cause Code is not placed in 
the incident ticket. See Cause Codes and Probable Cause 
on page 254.

Knowlix>Search 
Solution

Accesses Peregrine Systems’ Knowlix product. 

Knowlix>Retrieve 
Solution

Retrieves information from the Knowlix product.

Get-Answers>Open Opens Get-Answers in a browser. Choose this option when 
you want Get-Answers opened, so that you can type your 
own query. This option is only available when Get-Answers 
is integrated with ServiceCenter.

Get-Answers>
Search Solution

Uses the text in the Description field as the query string for 
Get-Answers. A browser window opens with a list of results 
from the search query. Choose this option when you think 
the Description will "find" quality answers within 
Get-Answers. This option is only available when 
Get-Answers is integrated with ServiceCenter. 

Get-Answers>
Retrieve Solution

Inserts a Get-Answers solution into the ServiceCenter 
incident record. This option requires a Get-Answers record 
to be open. Choose this option after you have searched for a 
solution and you have found the one to apply to the 
incident. This option is only available when Get-Answers is 
integrated with ServiceCenter.

Get-Answers>
Author Solution

Allows users to add new entries derived from ServiceCenter 
to the Get-Answers knowledge base. This option is available 
only for resolved incidents and when Get-Answers is 
integrated with ServiceCenter.
222 Chapter 6—Incident Management 



User’s Guide
Creating an Incident Ticket
Information in this section includes an example for opening a new incident 
ticket, using the complete ticket open process rather than the quick open 
process. The completed example is shown in Figure 6-23 on page 233.

Two forms are used in the process of opening an incident ticket. The initial 
form is the same as the form used to open an incident ticket as a quick open 
ticket. The second form provides additional fields specific to the category of 
the incident ticket, which allows you to add more detailed information about 
the incident.

This procedure is divided into four sections:

Accessing the Initial Form for Opening a New Incident Ticket on page 223.

Completing the Top Portion of the Initial Incident Ticket Form on page 224.

Completing the Fields to Log the Incident on page 225.

Completing the Expanded Incident Ticket Form on page 228.

Accessing the Initial Form for Opening a New Incident Ticket
If you logged on as a help desk user, click Queues. In the Incident list, click 
New.

If you logged on as an administrator, click Incident Management on the 
Home menu. Then click Open New Incident.

If you logged on as a technician or a manager, click Incident Queue on the 
Home menu. In the Incident List inbox displayed, click New.

Remote 
Control>Remote 
Manager

Connects to the Remote Management utility, if installed.

Remote 
Control>Connect to 
Device

Allows you to connect to another asset. Part of the Remote 
Management application.

Find Solution Accesses the Knowledge Base to search for possible solutions 
to the incident reported in the call. See Knowledge Base - 
Diagnostic Aids on page 561 for more information.

Option Description
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An initial blank incident ticket form displays. This form is the same as the 
form used for the quick-open process.

Figure 6-12: Initial Incident Ticket form

Completing the Top Portion of the Initial Incident Ticket Form
1 If you haven’t chosen a company, you receive the following message in the 

status bar (Figure 6-12): You have chosen to have multiple companies 
available.

Click Browse in the Company field to select a company from the record list.

2 Note that the Ticket Status field is already filled in. You can change this field 
as needed. 

a The ticket status defaults to Open (as shown in the Ticket Status field). This 
status can be changed to:

Pending other

Work in progress

Reject
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Resolved

Pending vendor

Pending customer

Closed

Referred

Replaced Problem

For this example, use the default setting (Open).

Completing the Fields to Log the Incident
1 The Owner field is automatically filled in with the name of the person who is 

logged on and is filling out the ticket.

2 In Category, select a category for the ticket. This field is required. Categories 
are discussed in What is a Category? on page 109 in the Service Management 
chapter of this guide.

For this example, select client system.

3 In Sub Category, select a subcategory for the field if desired. This field is 
optional. 

For this example, select hardware.

4 In Primary Asgn Group, select an assignment group to resolve the incident.

For this example, select HELP DESK.

5 In Severity, modify the urgency of the incident. You can change the value by 
selecting another priority from the drop-down list.

For this example, select 3 - Normal.

6 In Site Category, select the site description. You can select the value by 
selecting a site code and description from the drop-down list.

For this example, select D - Home Site.

7 In the Contact tab, click Fill. When the Search dialog box displays, click 
Search. Select a contact name to enter the caller’s name in the Reported By 
field. The remaining information about the caller (contact) is filled in 
automatically from the database.

If an asset is associated with this contact, ServiceCenter automatically fills in 
the Asset ID field. If multiple assets are associated with this user, a QBE list 
displays prompting you to select the affected asset. 

For this example, click MILLER.
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8 In the Incident Details tab, select a group for Secondary Assign to back up 
the primary assignment group.

For this example, leave this field blank.

9 The Affecting Asset field in the Asset tab is automatically filled in if the name 
entered in the Reported By field was associated with an asset. If not, click Fill 
to select the asset number for this field.

For this example, AdamPC was automatically entered when the Reported By 
field was filled.

10 Enter a Product Type.

For this example, select desktop.

11 Enter a Problem Type.

For this example, select monitor.

12 Type a description of the incident at the bottom of the Incident Details tab.

For this example, type Monitor screen is flickering.

13 Cause Code is an optional field. Click Fill, or press F9 to access a QBE list of 
ServiceCenter cause codes. Cause codes allow incident tickets to be more 
easily categorized and assigned. See Cause Codes and Probable Cause on 
page 254 for more information.

For this example, no cause code is entered.

14 Click New, or press F4.

Note: If a required field is left blank, a prompt displays asking you to enter 
the information.

Depending on how you have logged on, a QBE list of existing incident tickets 
that are similar to your new incident ticket may be displayed. Click New to 
continue.
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An open incident ticket form displays that is specific to the selected category. 
The information you entered in the initial incident ticket form displays in the 
second (expanded) form (Figure 6-13 on page 227).

Figure 6-13: Expanded Incident Ticket form

Note: If any of the Incident Matching Options in your user profile are 
selected (Check Similar Incidents, Check Incident Duplicates on 
Device, or Check Incident Duplicates on Parents), a QBE list of 
existing incident tickets that match these options displays. Those that 
are similar to the description you have entered in your new incident 
ticket and are specific to the category you selected are displayed 
(Figure 6-12 on page 224). 

Double-click an entry in the list to view the incident record. Check to see 
if an incident ticket has already been created to avoid creating a duplicate 
incident ticket.
Opening Incident Tickets  227



ServiceCenter
If you do not find another ticket that is a match to the current incident, 
click New to continue processing your new incident ticket. The expanded 
ticket form is opened (Figure 6-13).

Figure 6-14: QBE list of similar incident ticket records

Completing the Expanded Incident Ticket Form
The information you entered in the initial incident ticket form displays in the 
second form, which is an expanded form with more tabs containing 
information, such as SLA, history, and billing information (Figure 6-13 on 
page 227).

The expanded incident ticket form can be filled in as described below:

1 The first sentence from the Incident Description expanded field is entered in 
the Incident Title field at the top of the form. You can change this if you wish.

2 In the Assignee field in the Incident Details tab (pictured in Figure 6-13 on 
page 227), select the name of the person who is assigned to and is responsible 
for resolving the incident.

For the example, select SUSIE.SUPERTECH.
228 Chapter 6—Incident Management 



User’s Guide
3 You can use the Second Asgn Groups field to assign one or more additional 
assignment groups. To assign more than one group:

a Select a group from the drop-down list.

b Select a second group from the list.

c Use the arrow keys to the right of the drop-down list to scroll between the 
selected groups.

For the example, leave this field blank.

Note: If you have the Work Management application installed, you can use 
the Scheduled Start and Scheduled End fields to enter your estimates 
for the time needed for incident ticket resolution.

For this example, leave these fields blank.

4 Click the Contact tab for more information on the contact listed in the 
Contact field and the associated asset, if applicable.

Figure 6-15: Expanded Incident Ticket form—Contact tab

If a contact is not entered in the Contact field, click Options>Add/Edit 
Contact. Click Fill, or press F9 to access a QBE list of contacts. The contact 
records are stored in the ServiceCenter database. The associated fields are 
automatically filled.

If you need to select a different user, clear the field and double-click on the 
desired contact in the QBE list.

If an asset record is linked to this user, that asset is automatically entered 
in the Affected Item field.
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If no asset is associated with this contact, the Affected Asset field of the 
Asset tab is left blank. Click Fill to select a asset. The associated fields are 
automatically filled.

If you need to select a different asset, clear the field and double-click the 
desired asset in the QBE list. 

For this example, AdamPC is already entered (see Figure 6-16).

Figure 6-16: Expanded Incident Ticket form—Asset tab

5 Click the Hardware/Operating System tab to view information about the 
affected asset (pc in this example). See Figure 6-17.

Figure 6-17: Expanded Incident Ticket form—Hardware/Operating System tab
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6 Click the SLA tab to view the Service Level Agreement for the asset 
(Figure 6-18). This option may not be available if Service Level Management 
is not enabled. Only the name of the agreement displays.

Figure 6-18: Expanded Incident Ticket form—SLA tab

a If there are multiple agreements, click the Down arrow to select an 
agreement.

b Click Find to view details on an SLA.

7 Click the History and Billing Information tabs (Figure 6-19 on page 231 and 
Figure 6-20 on page 231) to view information about the reported incident.

Figure 6-19: Expanded Incident Ticket form—History tab

Figure 6-20: Expanded Incident Ticket form, Billing Information tab
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8 Click the Attachments tab (Figure 6-21) to add files from other applications 
(for example, an Excel spreadsheet) that provide additional information 
about the incident. 

Figure 6-21: Expanded Incident Ticket form—Attachments tab

9 To attach a file, copy or drag it into the field provided on the Attachments 
tab.

10 Click Save, or press F2. This opens an incident ticket and saves the 
information to the probsummary file. ServiceCenter automatically assigns an 
incident number and a status of open to the ticket.

A message displays in the status bar that states: Incident INxxx has been 
opened.

Figure 6-23 on page 233 shows the completed example incident ticket.

Note: Due to the default setting in the SLA options, outages are 
automatically posted. However, if you have this default setting 
unchecked (false), you are prompted with the Post Which Outages? 
form (Figure 6-22).

Figure 6-22: Post Which Outages? form

11 Click Proceed.
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The incident ticket is redisplayed with a message in the status that states: 
Incident IMxxx has been opened. See Figure 6-23 on page 233.

Figure 6-23: Example Incident Ticket

Updating an Incident Ticket
To update an existing incident ticket:

1 Access Incident Management to search for the incident ticket you want to 
update:

Click Incident Queue to access an Incident Management inbox.

-or-

If logged in as an administrator, click Search IM Tickets to access a search 
form.
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2 Find the incident ticket you want to update:

a Double-click on the desired incident in the Incident Management list.

b Use the search function to locate the incident ticket. Refer to Search 
Incident Management on page 206.

If you know the ticket number, enter that number in the Number field. If 
you have Smart Search selected, you need only enter the number. If you 
do not have Smart Search activated, you must enter the incident ticket 
prefix (IM), for example, IM109.

If you do not know the number, enter any information you know about 
the ticket in the appropriate fields. This narrows the search parameters for 
the ticket.

3 Modify any fields that require updating in the Incident Details tab.

For example, you could change the Priority of the incident if it has changed 
since the incident was first reported. Click the Arrow button or the arrow 
keys to choose a new setting.

4 Click the Actions/Resolution tab. Enter any new information about the 
incident under Corrective Actions.

For the example, you can enter an update of Technician dispatched.

5 Click Save, or press F2.

A message displays in the status bar that states: Incident IMxxx has been 
updated.
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Options Menu—Existing Incident Ticket
The existing incident ticket form Options menu contains a set of options 
similar to the call report options. Some of these options are described in 
more detail in the following sections.

Option Description

Get-Answers>
Open

Opens Get-Answers in a browser. Choose this option when you 
want Get-Answers opened, so that you can type your own query. 
This option is only available when Get-Answers is integrated with 
ServiceCenter.

Get-Answers>
Search Solution

Uses the text in the Description field as the query string for 
Get-Answers. A browser window opens with a list of results from 
the search query. Choose this option when you think the 
Description will "find" quality answers within Get-Answers. This 
option is only available when Get-Answers is integrated with 
ServiceCenter. 

Get-Answers>
Retrieve 
Solution

Inserts a Get-Answers solution into the ServiceCenter incident 
record. This option requires a Get-Answers record to be open. 
Choose this option after you have searched for a solution and you 
have found the one to apply to the incident. This option is only 
available when Get-Answers is integrated with ServiceCenter.

Get-Answers>
Author 
Solution

Allows users to add new entries derived from ServiceCenter to 
the Get-Answers knowledge base. This option is available only 
for resolved incidents and when Get-Answers is integrated with 
ServiceCenter.

Set Reminder Allows you to set up a reminder to be sent to you at a specified 
time through e-mail, a page, or a pop-up message.

Print Record Prints this incident ticket record to the user’s default 
ServiceCenter printer.

Clone Copies the currently displayed record to create a new record.

Notify Allows you to send a message containing the data in this incident 
ticket to other ServiceCenter users.

Page List Displays the open and update pages (records) that have been 
created for this incident ticket. If a ticket contains multiple pages, 
a QBE list displays to select the page you want to display. Each 
page can be printed.
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Lookup Cause Allows you to search the probable cause file for a possible cause 
and solution to the incident. This option works like the Find 
function, only displaying the record. The Cause Code is not 
placed in the incident ticket. See the Cause Codes and Probable 
Cause on page 254.

Callback List List of contacts who can be notified when an incident ticket is 
closed.

Find Solution Accesses the Knowledge Base to search for possible solutions to 
the incident reported in the call. See Knowledge Base - Diagnostic 
Aids on page 561 for more information.

Related 
>Calls 
>Associate 

Allows you to associate this incident ticket to an existing call 
report.

Related 
>Calls 
>View 

Displays a QBE list of the Service Management call reports 
associated to this incident ticket.

Related 
>Calls 
>Open 

Allows you to open a call report that is associated to this incident 
ticket.

Related 
>Incidents 
>Associate 

Allows you to associate this incident ticket to another incident 
ticket.

Related 
>Incidents 
>View 

Displays a QBE list of the other incident tickets associated to the 
current incident ticket displayed.

Related 
>Incidents 
>Open 

Allows you to open an incident ticket associated to the current 
incident ticket displayed.

Related 
>Changes 
>Associate 

Allows you to associate this incident ticket with a Change 
Management change.

Related 
>Changes 
>View 

Displays a QBE list of the Change Management changes 
associated to this incident ticket.

Related 
>Changes 
>Open 

Allows you to open a Change Management change that is 
associated to this incident ticket.

Option Description
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Related 
>Quotes 
>Associate

Allows you to associate this incident ticket to a Request 
Management request (quote).

Related 
>Quotes 
>View 

Displays a QBE list of the Request Management requests 
associated to this incident ticket.

Related 
>Quotes 
>Open 

Allows you to open a Request Management quote that is 
associated to this incident ticket.

Related 
>Root Causes 
>Associate

Allows you to associate a recurring problem to a Root Cause 
ticket that is associated to this incident ticket.

Related 
>Root Causes 
>View 

Displays a QBE list of the Root Cause tickets associated to this 
incident ticket.

Related 
>Root Causes 
>Open 

Allows you to open a Root Cause ticket that is associated to this 
incident ticket.

Change 
Category

Allows you to change the category of this incident ticket.

Add/Edit 
Contact

Displays the Contact record for the contact identified with the 
current incident ticket. 

Knowlix>
Search Solution

Access Peregrine Systems’ Knowlix product. 

Knowlix>
Retrieve 
Solution

Retrieve information from the Knowlix product.

Notes Allows you to create side notes about an incident ticket. These 
notes are saved with the ticket.

Remote 
Control>
Remote 
Manager

Accesses the Remote Manager application. 

Remote 
Control>
Connect to 
Device

Allows you to connect to the network address of the asset listed 
in the current incident ticket. Refer to the Remote 
Management/ServiceCenter Interface Guide for more 
information.

Option Description
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List Options Menu—Existing Incident Ticket

IND System 
Analyzer

Launch the Network Discovery System Analyzer, which allows 
you to analyze the network path between two assets to isolate 
problems, from an incident ticket.

Generate 
Maintenance

Option available for changes only. Allows you to schedule the 
creation of changes, using the current record as a template.

Create Hot 
News

Create Hot News item within the Knowledge Base. See Knowledge 
Base - Diagnostic Aids on page 561 for more information on Hot 
News.

Option Description

List Option Description

Count Counts the number of records in the current QBE Record 
list.

Print List Allows you to print a copy of the current QBE Record list.

Refresh List Updates the current list.

Modify Columns Displays a dialog box where you can change the fields that 
determine the column headings of the QBE Record list.

Export to Text File Exports the QBE Record list to a text file. This option is not 
part of the DDE support and can be run from clients other 
than those operating in Windows.

Save List as Inbox Allows you to save the current list as an inbox.

New Displays a blank form for opening a new incident ticket.

View All Related
>Calls

Allows you to view all calls related to this incident ticket.

View All Related
>Incidents

Allows you to view all incidents related to this incident 
ticket.

View All Related
>Changes

Allows you to view all change records related to this 
incident ticket.

View All Related
>Root Causes

Allows you to view all root cause records related to this 
incident ticket.
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Setting a Reminder
From an existing incident ticket, you can schedule a reminder to be sent to 
you at a specified time.

To access the Set Reminder feature:

1 With an existing incident ticket displayed, select Set Reminder from the 
Options menu.

The Set Reminder form displays (Figure 6-24 on page 239).

Figure 6-24: Set Reminder form

2 There are two options for setting the time when the reminder occurs.

a Select Remind At to set a reminder for a particular day and time.

b Select Remind In to set the reminder to occur at a particular interval. This 
options brings up two fields; enter the time interval, and select the shift 
you are working from the drop-down list.
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3 Click Fill to bring up the ServiceCenter Calendar. You can use the calendar 
to select the date and time you want the reminder to occur. 

a Enter the time in the Time field. Click on the day you want the reminder 
to occur. The dialog box closes and the information is filled into the 
Remind At field. 

b To move forward or backward, click the Arrow buttons at each side of the 
month and year. 

c To return to today’s date, click Goto Today.

d To go to a specific date, click Select Date and type the date in the dialog 
box displayed. Click OK to accept the entry and return to the Calendar. 
Clicking the back arrow returns you to the Calendar with no change.

4 In the Remind if field, select an option from the drop-down list:

Always (the default)

Incident has not been updated

Incident is still open

Incident is still assigned to me
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5 In the Pop-up Message area of the form, select the type of notification you 
want:

Pop-up

Page

Email

SCMail

If you select Pop-up or Page, type the message in the Message field that you 
want to display in the reminder.

Choosing Email or SCMail displays two Message Type option buttons 
(Figure 6-25 on page 241). Select the type of e-mail message you want sent. 
There is also a Title field where you can enter a title for the e-mail message.

Figure 6-25: Set Reminder form with Message Type Displayed
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6 Select the type of e-mail you want sent:

Send Incident Record. This option includes a copy of the incident ticket 
in the e-mail.

Fixed Text. This option displays a text box in which you can type the 
message you want to display in the e-mail message (Figure 6-26 on 
page 242).

Figure 6-26: Set Reminder form with Fixed Text Field Displayed

7 When you have made all your selections, click OK.

The initial incident ticket from which you set the reminder displays.
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Related Records

Associating an Incident Ticket with Another Record
You can associate an incident ticket with an existing Service Management call 
report, a Request Management request (quote), a Change Management 
change, another incident ticket, or a Root Cause ticket. Before associating an 
incident ticket with another record, make note of the ID number of the 
record. For example, a call report could have an ID number of CALL1001. 
You need to enter this number in the following process. 

To associate an incident ticket with another record:

1 Access the incident ticket.

2 Select Options>Related>Calls/Incidents/Changes/Quotes/Root 
Causes>Associate/View/Open ticket.

A dialog box displays asking:

Associate Incident xxxxxx with which Call/Incident/Change/Quote/Root Cause 
ticket

3 Type the ID number or search for the record to which you want to associate 
this incident ticket. 

For a call report, type the number in the form of CALLxx, where xx is the 
call number.

For an incident ticket, type the number in the form of IMxx, where xx is the 
incident ticket number.

For a quote, type the number in the form of Qxx, where xx is the quote 
number.

For a change record, type the number in the form of xx. The change 
number does not have a defining letter.

For a root cause ticket, type the number in the for of RCxx, where xx is the 
root cause number.

4 Click OK. A confirmation displays in the status bar.

Opening a Related Record
You can open an incident ticket, a Service Management call report, a Request 
Management request (quote), Change Management change, or Root Cause 
ticket from Incident Management. The new record is related to an existing 
incident ticket.
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To open a related record from Incident Management:

1 Open an existing incident ticket. Refer to Search Procedures on page 214 for 
help in accessing an existing incident ticket.

2 Open the Options menu and highlight one of the related options, such as 
Related, Incidents, or Open to open incident tickets.

3 Open Related>Calls/Incidents/Changes/Quotes/Root Causes from the 
Options menu.

If you are opening a related incident ticket, a QBE category list displays. 
Double-click on the desired category and a form for opening the new 
incident ticket displays.

If you are opening a related change, a QBE category list displays. 
Double-click on the desired category and a change record displays with 
the category and related information from the incident ticket filled in.

If you are opening a related quote, a new quote form displays with 
information related to the incident ticket already filled in.

If you are opening a related root cause, a new form displays with 
information related to the incident ticket already filled in.

Refer to the appropriate chapters in this guide (Service Management on 
page 105; Incident Management on page 197; Change Management on 
page 407; and Root Cause Analysis (RCA) and Incident Management on 
page 379, as well as the Request Management guide for help in filling out the 
forms).

4 Save the related record. Click OK.

You are returned to the initial incident ticket.

Notifying Other ServiceCenter Users
You can send the information in an incident ticket to other ServiceCenter 
users without reassigning the ticket via the Notification Engine. 

Note: Notification methods can include: Email, fax, and SCMail.

To make sure a user is set up to send notification messages:

Go into that user’s Incident Management profile and make sure the Notify 
privilege is checked (true). 

-and-

Make sure the Notify option is selected in the Options menu. 
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Only users with the Notify privilege can send notification messages (see 
Figure 6-28 on page 246). Messages are generated by ServiceCenter events, 
such as opening or closing an incident ticket. 

Note: Only administrators can edit these messages, add new messages, 
change the conditions under which the messages are sent out, as well 
as select who receives the messages. See the System Tailoring guide, 
Notification Engine, for more information.

To notify other ServiceCenter users:

For this example, FALCON is notifying other ServiceCenter users of an 
Incident ticket that has just been opened.

1 Access Incident Management from the ServiceCenter home menu.

2 Click Search to bring up the apm.search.probsummary form.

3 Enter the Incident Management new ticket number and click Search to 
retrieve the new IM ticket.

4 When you locate the new ticket, click Options>Notify (Figure 6-27).

Figure 6-27: Notifying other ServiceCenter users
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A Notify form displays and the basic information about the ticket is 
automatically entered (Figure 6-28 on page 246). 

Figure 6-28: Incident Management Notification

5 Click Fill, or press F9, to enter the ServiceCenter users to whom you want to 
send the message.

6 In the Message field, type any message you want to include with this 
notification.

7 Select the method by which you want to send the notification.

Click Mail, or press F2, to send the message by email.

Click FAX, or press F5, to send the message by fax.

Click SC Mail, or press F6, to send the message through the ServiceCenter 
mail function.
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After selecting how to send the message, you are returned to the incident 
ticket. A message displays in the status bar in the incident ticket stating that 
the notification has been scheduled to be sent.

Creating Notes
You can create notes for an existing incident ticket, as long as you have the 
Notes privilege checked (true) in your Incident Management profile. Notes 
are remarks that are not placed in the Description, Action, or Resolution 
fields.

To create Notes:

1 Select Options>Notes from an existing incident ticket. 

A Notes form displays (Figure 6-29 on page 247). 

Figure 6-29: Incident Management Notes

2 Enter the information in the Notes field.

3 Click Save or press F2 to save the notes, and then click Back to return to the 
incident ticket.

-or-

Click Back or press the Esc key to return to the incident ticket without saving 
the notes.

The notes are kept with the ticket. More notes can be added by selecting the 
Notes option. Each set of notes is tagged with a time stamp and the name of 
the ServiceCenter operator who created the notes.
Opening Incident Tickets  247



ServiceCenter
Launching the IND System Analyzer
ServiceCenter integrates Peregrine’s Network Discovery product to provide 
network monitoring capabilities within ServiceCenter. See the Event Services 
guide.

IND’s System Analyzer allows you to examine the network path between two 
assets to isolate problems. By checking the status colors of the lines and assets 
in the object path, you can quickly determine where communication 
problems are occurring. Network Discovery also lists the service problem 
detected on the path.

To launch the Service Analyzer from an incident ticket:

Select Options>IND Systems Analyzer from the menu bar.

The System Analyzer is launched, and the asset in the incident ticket is listed 
in the IND dialog box. Simply enter a second asset and launch the analyzer. 

See the Network Discovery User’s Guide for more information on using the 
System Analyzer.

Closing an Incident Ticket
When an incident is resolved, the ticket can be closed. This does not delete 
the ticket from the probsummary file, but marks the ticket as inactive.

Note: If Resolve status is enabled in the Incident Management Security 
Environment settings, then the two-step close process is used.

To close an open incident ticket:

1 Access the incident ticket you want to close by:

Double-clicking on the desired incident in the Incident List.

-or-

Using the search function to locate the incident ticket.

If you know the ticket number, enter that number in the Number field. 
If you have Smart Search selected, you need only enter the number. If 
you do not have Smart Search activated, you must enter the incident 
ticket prefix (IM), for example, IM109.

If you do not know the number, enter any information you know about 
the ticket in the appropriate fields. This narrows the search parameters 
for the ticket.
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2 Click Close, or press F6. 

The incident ticket is redisplayed as an incident close form (Figure 6-30 on 
page 249).

Figure 6-30: Incident Ticket in Close form

Actions/Resolution Tab
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3 Select the Actions/Resolution tab.

Figure 6-31: Selecting the Actions/Resolution tab

4 You can either enter a solution or select a resolution code that automatically 
enters a solution.

In the Closure Code field, enter a code. This field is optional. Click Fill, or 
press F9, to access a QBE list of possible resolutions.

A solution is automatically entered.

-or-

In the Solution field, enter a solution if one was not entered with a 
Resolution Analysis Code.

5 If the resolution should be saved to the ServiceCenter Knowledge Database, 
select the Candidate for Knowledge DB? box. The Knowledge Database 
stores common incidents and solutions which can be found using the 
ServiceCenter IR Query function. See Knowledge Base - Diagnostic Aids on 
page 561.
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6 Click Save, or press F2.

A form displays (Figure 6-32 on page 251) showing the date and time the 
outage for this asset was ended.

Note: Due to the default setting in the SLA options, outages are 
automatically posted. If you want to be prompted to post outages and 
receive the Post Which Outages? form, do the following:

a Click Service Level Mgmt.

b Click Configure Module.

c Uncheck Auto Post Outages. The default is true (checked), which 
automatically posts outages. When unchecked (false), you are prompted 
with the Post Which Outages? form.

Figure 6-32: Post Which Outages? form

7 Click Proceed.

The incident ticket is redisplayed with a message in the status bar that states:

Incident IMxxx has been closed by xxxxx. (See Figure 6-33 on page 252.)
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Note: Depending on the type of incident ticket, a Post Availability form may 
be displayed. At this point, click OK.

Figure 6-33: Incident ticket has been closed (problem.template.close form)

8 If you are closing an incident ticket that has been associated to a Call, a 
message displays in the status bar that states: IMxxxx has been closed by 
<user>. Related calls will be processed normally.

For information on how related closed calls are processed, refer to Service 
Management on page 105.

9 Click OK to complete the close process.

Status, Alerts, and Escalation

ServiceCenter can automatically notify users when an incident ticket is not 
updated within a specified time period. This escalation is accomplished 
through the alert process. Alerts are triggered after a set period of time 
defined in a category record.

An alert is a message stating that an incident ticket has not been resolved. 

ServiceCenter supports four alert stages:

Alert Stage 1

Alert Stage 2

Alert Stage 3

Deadline Alert
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As various alert stages are reached, notification is sent to the operators in any 
affected Assignment Group. For example, when a ticket reaches Alert Stage 
3, the operators from the ticket’s primary Assignment Group, the Alert Stage 
2 Assignment Group, and Alert Stage 3 Assignment Group are notified of the 
escalation. Additional notifications can be set up using macros or the 
Notification Engine.

Notification can be sent to:

All contacts in the current contact list for the Assignment Group, except 
the manager.

The user who opened the ticket.

The current primary contact in the owner group.

The current manager of the Assignment Group.

The current manager of the owner group.

The service level manager and client manager of the company and 
department specified in the ticket.

Within each category record, a time interval is specified for each alert level. 
This time interval can be adjusted according to the priority assigned to the 
ticket. Refer to What is a Priority? on page 254. An incident ticket reaches 
each alert stage after the specified time period passes without an update to the 
incident ticket. At this time interval, the next alert level is reached.

For alert stages 1, 2, and 3, the alerts are reset each time the ticket is updated. 
The Deadline Alert is always scheduled for an interval after the open time of 
the ticket, and is not affected by updates to the ticket.

As an incident ticket passes through the alert stages, the ticket is escalated.

What is Escalation?
Escalation is the process of increasing the urgency of an incident ticket. 
Escalation is accomplished automatically through alerts. As the various alert 
levels are reached, the escalation increases:

Stage 1 to Stage 2

Stage 2 to Stage 3

Stage 3 to Deadline Alert
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At each alert level, ServiceCenter forwards the incident ticket to the next 
Assignment Group. These groups are set by the ServiceCenter administrator.

The interval between alerts is set in the category records, and it can be 
impacted by the priority set for the ticket.

What is a Priority?
The priority of a ticket indicates the urgency of an incident, based on a 
business need. Priorities are set by the user when an incident ticket is opened. 
The priority is entered in the Priority Code field of the initial incident form:

1 - Priority one—critical

2 - Priority two—urgent

3 - Priority three—normal

4 - Priority four—low

Priorities can be based on the impact the incident has on users and the 
category of the ticket. For example, an equipment problem that brings down 
a group of users is critical. A user wanting to know how to adjust the colors 
on a monitor is a low priority. 

The priority of a ticket can be changed by the user as an incident ticket goes 
through updates. However, priorities are not changed automatically as alerts 
progress.

Cause Codes and Probable Cause

The Cause Code field is an optional incident ticket field that allows you to 
define the probable cause of the incident. By using a standard series of cause 
codes, it is easier to track incidents that have a common cause.

Cause codes are derived from the probable cause records defined by the 
ServiceCenter administrator to simplify the reporting and tracking of 
incident tickets. The cause code links the probable cause record to the 
incident ticket. Cause codes allow incident tickets to be more easily 
categorized and assigned. 
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To add a Cause Code to an incident ticket:

1 Place the cursor in the Cause Code field.

2 If you are opening a new Incident ticket, click Fill, or press F9.

-or-

If you are updating an existing Incident ticket:

a Put your cursor in the read-only Cause Code field. 

b Select Options>Lookup Cause. 

The Cause search window is opened.

c Put your cursor in the Category field and click Search.

A QBE list of predefined Cause Codes displays (Figure 6-34 on page 255).

Figure 6-34: QBE List of Cause Codes

3 Double-click on the listing for the Cause Code that applies to the incident.

When the cause code is placed in the ticket, the Cause Code field in the 
Incident Details tab is also filled in.
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CHAPTER

7
 Inventory Management
Inventory Management helps you keep track of the hardware and software 
on your network and any other assets that have value to your organization. 

Other ServiceCenter applications access the asset records from Inventory 
Management. For example, if you are opening an incident ticket, Incident 
Management gets the component information from the inventory database. 
The information can be placed in the ticket when you are creating that ticket.

You can also create asset records with Inventory Management to add new 
assets, including software, hardware, office electronics, telecommunication 
devices and furnishings to the inventory database. Besides viewing asset 
records, your level of access depends on the type of user you are and how 
your operator profile is configured by your system administrator.

Inventory Management also allows you to create contracts, add assets 
(including software licenses) to those contracts, make payments against 
those contracts, and manage contract and payment details.

Topics covered in this chapter include:

Asset Management on page 258

Contract Management on page 302

Network Discovery Integration with Inventory Management on page 334
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Asset Management

Topics covered in this section include:

Key Asset Management Terms and Concepts on page 259.

Accessing the Asset Information Form on page 263.

Options Menu on the Asset Information Form on page 264.

Fields on the Asset Information Form on page 265.

Searching Inventory Management on page 267.

Creating New Asset Records on page 270.

Common Fields and Tabs on the New Asset Form on page 273.

Unique Fields on the New Asset Form based on the Type and Subtype on 
page 285.

Updating Asset Records on page 288.

Viewing or Modifying Software Installation Information on page 294.

Fields on the Installed Software Information Form on page 295.

Viewing Service Level Agreement Information on page 298.

Scheduled Maintenance and Inventory Management on page 299

The Assets tab provides access to Inventory Management functionality that 
allows you to:

Add or edit assets via the Asset button.

Manage assets using pre-defined inboxes to find your workload via the 
Asset Queue button.

View or modify software installation information via the Installed 
Software button.

View or modify Service Level Agreement information via the SLA 
Information button.
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Key Asset Management Terms and Concepts
Device

Anything that is considered to be an asset (has value to the organization). It 
may include anything from IT equipment and software licenses to furniture 
items.

Asset record

A data record containing details of a piece of equipment or other component.

Device type file

Each asset in the inventory database has a specified device type. Features of 
the devtype file include the following:

The device type (devtype) file contains one record for each defined device 
type. 

When a new device type is created, a new record for that device type is 
created in the devtype file.

ServiceCenter includes the following out-of-box device types and subtypes:

Type Subtype

Applications Anti-Virus / Security

Back-up

Business

Development Tools

Entertainment

Graphics

Internet/Web

Networking

Operating System

Reference

Other

Computers Desktop

Dumb Terminal

Laptop

Tower

MAC

Server
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Display Devices Monitor

Projector

Examples Template of common device fields. Can 
use it to create a new device type.

Furnishings Artwork

Armoire

Bookcase

Chair

Computer Desk

Desk Collection

File Cabinet

Meeting Table

Hand Held Devices PDA

Cell Phone

Pager

Blackberry Device

GPS Device

Mainframes Controller

Host CPU

FEP

NCP

LPAR

Network Components Router

Hub

Switch

Modem

Network Interface Card

Gateway

Firewall

Type Subtype
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Office Electronics Copy Machine

Printer

Fax Machine

Paper Shredder

Camera

Speaker

Calculator

Multifunction

Word Processor

Typewriter

VCR

Television

UPS

Software Licenses DBMS License

Development Tool License

Enterprise Management License

Operating System License

Outlook

Productivity Tools License

Project Management License

Utility Software License

Storage CDRW

Direct Attached Storage (DAS)

HDD

Network Attached Storage (NAS)

Storage Area Network (SAN)

ZIP

CD Burner

Telecommunications Desk Phone

Flush Wall Mount

Headsets and Accessories

NBX

PBX

Paging Solution

Surface Mount

Type Subtype
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Device file

A ServiceCenter file that contains all asset records. It contains the unique 
name of the asset and the pointers to other files. The device file stores data 
common to all device types.

Example: serial.no and vendor are common fields for both the server and 
modem device types.

Attribute file

A supporting file within Inventory Management that holds data specific to an 
asset, based on its device type. If an attribute file exists for a device type, then 
each asset record for that device type has a corresponding attribute record in 
the device type’s attribute file. 

Example: A storage device type has an attribute file named storage and 
contains fields that are specific to a storage asset, such as storage.type. A 
software license device type has an attribute file named softwarelicense and 
contains fields that are specific to a software license asset, such as 
product.pool.

Join file

When you access a record for a specific asset, Inventory Management 
displays the record taking information from both the device and the attribute 
file for the specified device type. In the same manner, when any changes are 
made to the data, the changes are written to the corresponding records in the 
device and attribute files. A join file facilitates this process.

Example: A server device type has a join file named deviceserver and contains 
fields that are a combination of the device file and the relevant attribute file, 
such as serial.no and vendor from the device file and printer.queues from the 
server file.

The information you see on the form that displays the asset record 
information is the result of the device, attribute, and join files working 
together.
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Accessing the Asset Information Form
Authorized users can directly access asset records. The Asset Information 
form (Figure 7-1 on page 264) allows you to:

Search for and update existing asset records.

Begin the process of creating new records.

You typically access asset records from your asset queue. You can modify 
what you see in the asset queue by selecting a different inbox.

To access the Asset Information form via your asset queue:

1 Click Inventory Management in your Home menu. 

2 Click Asset Queue on the Assets tab. 

The asset queue displays.

3 Click New to create a new asset record.

-Or-

Click Search to access an existing asset record.

The Asset Information form displays.

To access the Asset Information form:

1 Click Inventory Management in your Home menu. 

2 Click Assets on the Assets tab.
Asset Management  263



ServiceCenter
The Asset Information form displays. 

Figure 7-1: Asset Information form

Options Menu on the Asset Information Form
When you first access the Asset Information form, the Options menu 
contains the following options:

Menu Item Description

Restore Returns the fields in the form to the previous values.

Clear Clears the data entered in the asset form. 

Advanced Search Displays a dialog box in which you can enter advanced 
search parameters. This option can also be used to store a 
query.

Search Specific Type Allows you to search the joined attribute and asset files for 
an asset record.

Open Inbox Opens an existing inbox for Inventory Management.
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Fields on the Asset Information Form
Each type of inventory record contains general fields for information that 
applies to all asset records. Other fields are used to supply information that is 
specific to a device type.

Some fields in other ServiceCenter applications, such as Incident 
Management, are populated with values that are specified in inventory 
records. For example, data from the Incident Category field on an inventory 
record is populated in the Category field when an incident ticket is opened 
for an asset.

You can enter data in these fields to search for specific records. Searches are 
discussed on page 267.

Fill locates information in another record and copies it into the current 
record. Select the data you want to enter in the field by double-clicking the 
desired entry. 

The following describes the fields in the header area of the Asset Information 
form and talks about the tabs within the Inventory Management record.
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Fields in the Header Area

General tab

Field Description

Asset ID Unique identifier for each asset.

Asset Tag Name assigned to the asset.

Type Device type categorizing this asset.

Subtype A more specific classification for the asset.

Department Department to which this asset is assigned.

Status Indicates whether or not the asset is currently installed.

Asset Pending 
Change

Flags an asset record to indicate a change ticket exists against 
the asset.

Critical Asset Determines the priority of an incident ticket should one be 
opened against this asset.

System Down? Identifies if the asset is currently down.

Field Description

Serial Number Manufacturer’s serial number for the asset.

Part Number Company’s identification no. for the asset.

Domain Internet domain in which the asset resides, such as 
company.com.

Incident Category Category the asset is placed in when an incident ticket is 
opened for that asset. See Chapter 4 for more information on 
incident tickets and incident categories.

Assignment Group assigned to handle a particular type of ticket based on 
the type of asset.

Vendor Name Vendor who is contacted for service on the asset.

Service Contract Service contract covering the asset

Cost Center The company entity paying for the asset.
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Comments tab

Searching Inventory Management
You can search for a specific asset record or a set of asset records. For 
example, if you enter ACME in the Asset field and click Search, a QBE list of 
ACME records displays. If you enter a partial name, such as pc, and click 
Search, a QBE Record list displays the assets with an asset ID starting with pc, 
and the first record in the list displays in the asset form.

If you leave all fields blank, click Search to perform a true query without 
entering any values in the asset form. A QBE Record list is returned 
containing all the records for that area of Inventory Management. For 
example, leaving all the fields blank in the asset form returns a QBE Record 
list of all assets in the database.

Protocol The agreed-upon format for transmitting data between two 
devices. The protocol determines the following: 

The type of error checking to be used 
Data compression method, if any 
How the sending device will indicate that it has finished 
sending a message 
How the receiving device will indicate that it has received a 
message 

Protocol Address A numerical address used to locate device on a network, an 
intranet or the Internet.

Contact Name Name of the user of the asset.

Location Physical location of the asset.

Building Building in which the asset is located.

Floor Floor on which the asset is located.

Room Room in which the asset is located.

Field Description

Brief Description One-line description of any comments.

Comments Free-form text area to document any information about the 
asset.

Field Description
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To search Inventory Management:

1 From the Asset Information form, enter the information you know in the 
appropriate fields.

Note: You can leave any or all fields blank. For fastest searching, use the 
fields identified as key (indexed) fields at your site. If these are not 
clearly identified on the form, ask your ServiceCenter administrator 
for a list of key fields.

2 Click Search, or press F6. 

3 If multiple records match the search, the QBE Record list displays these 
records with the first record in the list displayed in the asset form. 

4 Select the asset record you want to access. 

Joined Queries
Joined queries allow you to search a specific device type using the search form 
for that device type. 

To create a joined query:

1 Access the Asset Information form.

2 Choose Options>Search Specific Type.
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The Select Device Type to Search wizard displays.

Figure 7-2: Select Device Type to Search wizard

3 Choose the type of device for which you want to search from the Search for 
what Type of Device? drop-down list, and click Next.

For example, choose Computer.

The search form for that device type is displayed.

4 To make your search more specific, optionally enter additional information 
about the asset for which you are searching.

For example, if you know the PC for which you are searching has a logical 
name of BobPC, enter this name in the Asset ID field.

5 Click Next.

The asset record(s) displays.
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Creating New Asset Records
You can begin creating an asset record on the Asset Information form. 
However, it is not until you have specified the asset that you get access to all 
the tabs and fields relevant to a specific device type and subtype.

There are two ways to access the New Asset form to create a an asset record:

Selecting a device type using the Add New Asset wizard.

Prepopulating data on the Asset Information form before clicking the 
New button.

Note: Prepopulating data on the Asset Information form allows you to 
bypass the wizard as long as the device type is defined.
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To create an asset record using the Add New Asset wizard:

1 Click New, or press F1, on the Asset Information form. 

The Add New Asset wizard displays.

Figure 7-3: Add New Asset Wizard

2 Choose the device type from the Create what type of asset? field drop-down 
list. 

3 Click Next.
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In this example you see the Computer New Asset form.

Figure 7-4: Computer New Asset form

4 Populate the fields of the different tabs according to your needs.

5 Click Save or Add, or press F4, to save the record and leave it displayed.

A message displays in the status bar: Asset record added.
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To create an asset record by prepopulating data on the Asset Information 
form:

1 Access the Asset Information form.

2 Populate the fields with the information you know about the asset record you 
are creating. Be sure to enter a device type in the Type field.

Note: If you prepopulate fields on this form, but do not enter a device type in 
the Type field, when you click New, the system takes you to the Add 
New Asset wizard.

3 Click New. 

The Asset Type form displays.

Common Fields and Tabs on the New Asset Form
There are several tabs and fields on the New Asset form that document 
general information which applies to all assets, regardless of type or subtype.

Note: The type and number of tabs differ between the various component 
forms. For example, a hub form does not contain a Software tab, while 
a PC form contains a Software tab listing the various software installed 
on a PC.

In an asset record, the Fill function is available for the Part No. field. If you 
clear the field and select another part number, the related information, 
including serial number and manufacturer, is automatically entered.

System Summary tab: Ownership Information
The Ownership Information fields are standard across all device types and 
subtypes. If you used the Asset Information form to begin adding an asset to 
inventory, some of the following fields are prepopulated.
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Note: Depending on the asset, there may be additional fields on the System 
Summary tab to complete. For example, when entering an asset with a 
Type of computer, the Summary tab also includes fields to enter 
information specific to computers, such as operating system, bios, 
power keyboard, total memory, and available memory data.

Field Description

Asset ID Unique identifier for each asset. It is a required field.

Subtype A more specific classification for the asset.

Asset Tag Name assigned to the asset.

Network Name Network to which the asset is connected.

Domain Internet domain in which the asset resides, such as 
company.com.

Assignment Group assigned to handle a particular type of ticket based 
on the type of asset.

Serial Number Manufacturer’s serial number for the asset.

Part Number Company’s identification number for the asset.

In an asset record, the Fill function is available for the part 
number (Part Number.) field. If you clear the field and 
select another part number, the related information, 
including model and manufacturer, automatically 
displays.

Manufacturer The company who manufactured the asset. Data in this 
field is read-only since it displays based on the Part 
Number you enter.

Model Manufacturer’s model number for the asset. Data in this 
field is read-only since it displays based on the Part 
Number you enter.
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Status Availability of the asset. This field is only displayed in 
existing records.

Installed—asset is in place and operational.

Available—asset can be used, but is not currently 
installed; for example, the asset is unpacked and is stored 
in a stock room.

Warehouse—asset is still packed in its box, stored in a 
warehouse.

Transfer—asset is being moved between locations.

RMA—asset is being returned to the manufacturer or 
vendor for repairs or replacement.

Replaced—asset has been replaced.

Reserved—asset is being reserved for future use.

Retired—asset is obsolete and has been removed from 
service.

Department Name of the department where this asset resides.

Cost Center The company entity paying for the asset.

Service Contract Vendor with whom there is a service contract for the asset.

Incident 
Category

Category the asset is placed in when an incident ticket is 
opened for that asset. See Incident Management, Chapter 6 
for more information on incident tickets and incident 
categories.

Priority One of the parameters used to determine which SLA is 
used when a ticket is opened against an asset. 

Asset Pending 
Change?

Flags an asset record to indicate a change ticket exists 
against the asset.

Critical Asset? Determines the priority of an incident ticket should one be 
opened against this asset.

System Down? Indicates if the asset is down.

Field Description
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Contact tab

The Contact tab is linked to the contacts file to provide the contact 
information for this asset. You can add or change the contact information on 
the record by clicking Fill in the Contact Name field. The remaining 
information is filled in automatically from the contacts record. 

Location tab

The Location tab is linked to the location file to provide the location 
information for this asset, such as location, building, floor, and room. You 
can:

View location information on the record by clicking Find in the Location 
field. 

Change the location information on the record by clicking Fill in the 
Location field. 

The remaining information is populated automatically from the location 
record. The location file is discussed in the System Administrator’s Guide.

Site Category

You can also designate the site category with one of the following in the Site 
Category field:

Critical Site—large site location that justifies on-site support resources. 
and typically requires extended support hours.

Major Site—medium-sized site location that justifies support resources of 
field-based technicians.

Satellite Site—small location supported by field-based or visiting 
technicians.

Home Site—home location of remote or field-based user who is 
supported by field-based or visiting technicians.
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There is also a free-form text area that allows you to document any additional 
information about the asset location.

Figure 7-5: Asset Record, Location tab

Vendor tab

The Vendor tab is linked to the vendor file to provide the vendor 
information for this service. It provides standard information about the 
vendor from whom you acquired the asset, including name, address, sales 
representative name and number, contact name and number for support, 
hours support is available and any information about the vendor’s escalation 
policy. 
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You can add or change the vendor information on the record by clicking Fill 
in the Vendor Name field. The remaining information is filled in 
automatically from the vendor’s record. The vendor file is discussed in the 
System Administrator’s Guide.

Figure 7-6: Device Record, Vendor tab

Relationships tab
The Relationships tab provides data about related assets, both upstream 
(parent assets) and downstream (children assets).

Parent / child relationships

ServiceCenter uses parent / child relationships to organize inventory records. 
These relationships are based on how the assets are connected either 
physically or logically through a network. 

A parent asset can have a single child or multiple children. A child asset can 
also have children making that asset both a parent and a child. 
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Viewing parent / child relationships allows an organization to identify the 
scope of the assets impacted by an incident. For example, if an incident ticket 
is opened regarding an exchange server being down, the helpdesk 
administrator can view the parent / child relationships and identify the 
affected PCs. This allows the helpdesk administrator to proactively notify the 
users of those PCs.

The following figure shows two relationships for a PC in the asset record. 
This PC has two parent assets. The relationship to the hub is physical because 
the PC is directly attached to the hub through a network segment. 

The parent relationship with the server is logical because the PC is not directly 
attached to the server, but is attached through the network. 

If we were looking at either the asset record for the hub or the server, this PC 
would be listed as a child of these assets.

Figure 7-7: Asset Record, Relationships tab
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Financial tab

Contracts
subtab

If there are any contracts associated with this asset, contract information 
displays. 

To view the details for a specific contract in the list, double-click the desired 
contract to get contract details.

Figure 7-8: Asset Record, Financial tab, Contracts subtab

For more detailed information about these fields see the section, Fields on the 
New Contract Form on page 307.

Field Description

Contract ID A unique identifier that specifies the contract number.

Company The company the contract is with.

Type Lease—enables you to define general leasing conditions.
Maintenance—enables you to define a maintenance 
contract.
Software—allows you to define software license 
agreements.
Support—allows you to define asset support.
Warranty—allows you to track warranty data about your 
asset.
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Expense
Lines subtab

The Expense Line subtab is an itemized accounting of expenses, such as labor 
and parts, incurred for the asset.

Figure 7-9: Asset Record, Financial tab, Expense Lines subtab

Status This field reflects the existing status of the contract. The 
Status field is a read-only field and is dependent on the start 
date and expiration date of the contract. 

Draft
Current
Cancelled
Renewed 

Start Date The commencement date of the contract term. The start 
date of a contract must occur before the expiration date.

Expiration Date The date on which the contract term ends. This date 
determines whether or not the status of a contract becomes 
“expired” or “renewed” depending on the renewal 
conditions set in the contract. 

Field Description
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Labor subtab The Labor subtab documents information about any labor efforts expended 
on an asset.

Figure 7-10: Asset Record, Financial tab, Labor subtab

Field Description

Date Date the expense was created.

Currency The currency of the contract.

Amount The amount spent by the provider.

Type The type of expenditure involved, such as labor, parts, 
handling, and outage.

Contact Name The name of the individual who can provide additional 
information about the expense.

Field Description

Date Worked Date work was performed on the asset.

Technician The individual who serviced the asset.

Hours Worked The amount of time the technician worked on the asset.
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Parts subtab The Parts subtab displays data about any parts used on the asset.

Figure 7-11: Asset Record, Financial tab, Parts subtab

Contact Name The name of the individual at the company who provided 
the labor.

Company The name company who provided the labor.

Field Description

Field Description

Date Used The date the parts were used.

Part Number Company’s identification number for a part.

Quantity The date the parts were used.

Contact Name The name of the individual at the company who supplied the 
parts.

Company The name of the company that provided the parts.
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Outage History tab
The Outage History tab displays the start and end times when this asset was 
out of service.

Figure 7-12: Asset Record, Outage History tab

Attachments tab
The Attachments tab (Windows- and Java-based clients only) provides a 
blank field in which you can attach files from other applications (for 
example, a Microsoft Excel spreadsheet or a picture) that have information 
about the asset.

Figure 7-13: Asset Record, Attachments tab
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Unique Fields on the New Asset Form based on the Type and 
Subtype

Some of the tabs, subtabs, and fields on the Asset Type form are specific to 
the device subtype. For example, if you are adding an asset with a device type 
of Computer and a subtype of Laptop, the New Asset form appears as 
follows:

Figure 7-14: New Asset form with Type—Computer and Subtype—Laptop

Notice that the System Summary tab includes fields specific to computers, 
such as IP address, operating system, bios, and disk capacity.
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If you look at the New Asset Information form for Display Device device type 
and Monitor subtype, the form includes a Monitor tab to document 
information specific to monitors, such as size, viewable area, resolution and 
pitch.

Figure 7-15: New Asset form with Type—Display Devices and Subtype—Monitor

Subtypes of the Hand Held Devices, Display Device, Mainframe, Network 
Components, and Office Electronics types have unique tabs and fields 
specific to their subtype.
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Sample Scenario
To create an asset record with a type of Display Device and a subtype of 
Monitor:

1 Click Inventory Management in the Services tab of your Home menu. 

2 Click the Assets tab.

3 Click Assets. The Asset Information form displays.

4 Choose Display Device from the Type field drop-down list.

5 Choose Monitor from the Subtype field drop-down list.

6 Click New. Notice that the Subtype field is prepopulated with Monitor.

7 Complete the following field on the System Summary tab:

Asset ID: ACMEVIEW261

Assignment: Onsite Support

Part Number:

Status: Available

Department: Customer Support

Cost Center: Operations

Service Contract: ACME US

Incident Category: client system

Priority: 3

8 Complete the following fields on the Monitor tab:

Size: 21”

Viewable Area: 19”

Resolution: 1280X1024

Pitch: 800dpi

Horizontal Frequency: 75 z

Vertical Frequency: 75 z

Plug and Play: True

9 Save the new record as follows:

a Click Add, or press F1, to save the record and leave it displayed.

b Click OK, or press F2 to save the record and return to the Asset 
Information form.

A message displays in the status bar: Asset record added.
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Updating Asset Records
This section explains how to update and how to change the device type of a 
specific asset record or a list of asset records. Options and List Options menu 
items are also described in this section.

To update an asset record(s):

1 Search for the record you want to update. Refer to Accessing the Asset 
Information Form on page 263.

In the search form, enter the name of the asset, if known, in the Asset ID 
field.

If you do not know the name of the asset, enter any information you know 
in the appropriate fields. This narrows the search parameters.

Note: You can leave all fields blank for the search. If you do, a list of all asset 
records displays.

2 Click Search, or press F6 or Enter.

If enough specific data is entered in the fields, a single record displays in 
the Asset Type form.

If no data is entered in any of the fields, or multiple fields meet the search 
criteria, a QBE Record list displays. Select the desired record.

The selected record displays in the Asset Type form.

3 Modify any fields that need revision.

4 Save the updated record.

Click Save, or press F4, to save the record and leave it displayed.

Click OK, or press F2, to save the record and return to the blank asset 
form.

To change the device type of an asset record(s) using the Change Device 
Type wizard:

1 Access the Asset Information form.

2 Search for an individual record or list of records for which you want to 
change the device type. (For details, see Searching Inventory Management on 
page 267.)

3 To make your search more specific, optionally enter additional information 
about the asset for which you are searching.
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For example, if you know the PC for which you are searching has a logical 
name of BobPC, enter this name in the Asset ID field.

4 Click Search.

A specific asset record or a QBE list of asset records displays, depending on 
how specific your search was in step 2 and/or step 3.

5 From the Options menu, choose Change Device Type.

The Change Device Type wizard displays.

6 Do one of the following:

For a specific asset record:

From the New Device Type drop-down list, choose the new device type 
you want for the device, and click Next.

From the Subtype drop-down list, optionally choose a subtype for the 
device, and click Next.
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The Change Device Type Status of Attribute Files dialog displays 
confirming current and new attribute file device types.

Figure 7-16: Specific Asset Change Device Type form

For a QBE list of asset records:

From the New Device Type drop-down list, choose the new device type 
you want for the list of devices, and click Next.

From the Subtype drop-down list, optionally choose a subtype for the 
list of devices, and click Next.
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The Change Device Type Status of Attribute Files dialog displays 
confirming the new attribute file device type.

Figure 7-17: QBE List Change Device Type form

7 Click Next.

The updated asset record(s) displays with new device type (and subtype, if 
you selected one) information.
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Options Menu Items

Menu Item Description

Clone Copies the currently displayed record to create a new record. 

Print Prints the information in the current record to the default 
ServiceCenter printer.

Change Device Type Displays a wizard to allow you to change a device type and 
subtype. If fields don’t match between the old and new 
attribute files, data in the fields of the old file is lost.

Related>Incidents Open—allows you to open an incident ticket for this 
asset.
View Existing—allows you to view any existing incident 
tickets against this asset.

Related>Changes Open—allows you to open a change record for this 
asset.
View Existing—allows you to view any existing change 
records against this asset.

Related>Quotes Open—allows you to open a request for this asset.
View Existing—allows you to view any existing requests for 
this asset.

Find Solutions Accesses the ServiceCenter Knowledge Base.

Scheduled 
Maintenance>
Maintenance Tasks

Selecting this option accesses Scheduled Maintenance and 
shows any maintenance tasks which are specifically linked to 
this device. Please note that this shows only those tasks that 
are specifically bound to this device. Tasks which reference a 
range on inventory devices (e.g. every server in Topeka) are 
not accessed in this fashion.

Scheduled 
Maintenance>
Maintenance History

Selecting this option accesses Scheduled Maintenance and 
lists any incident tickets, change requests, or Request 
Management quotes that were created as a result of 
Scheduled Maintenance. From this list, you can access the 
individual problem tickets, change requests and RM quotes 
in detail.

Scheduled 
Maintenance>
Generate 
Recurring>Incidents

Selecting this option generates a Scheduled Maintenance 
task based on this particular device, creating an Incident 
ticket. This Scheduled Maintenance task is based on a 
template Incident ticket and some information from 
Inventory Management.
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List Options Menu Items
Note: List options are available only when viewing a QBE list, either in 

Record List or standalone mode.

Scheduled 
Maintenance>
Generate 
Recurring>Changes

Selecting this option generates a Scheduled Maintenance 
task based on this particular device, creating a Change 
request. This task is based on a template Change request and 
some information from Inventory Management.

Scheduled 
Maintenance>
Generate 
Recurring>Requests

Selecting this option generates a Scheduled Maintenance 
task based on this particular device, creating a Request 
Management quote. This task is based on a template Request 
Management quote and some information from Inventory 
Management.

Menu Item Description

Refresh Updates the QBE Record list.

Modify Columns Allows you to change the column headings in a QBE Record 
list.

Export to Excel Allows you to export the QBE search results to a Microsoft® 
Excel spreadsheet. Excel automatically opens with the list 
placed in a spreadsheet. Basically, you can export 
information to any product that has DDE (Dynamic Data 
Exchange) support. This DDE function requires Excel 95 or 
later.

Export to Text File Allows you to export the QBE search results to a text file. This 
option is not part of the DDE support and can be run from 
clients other than those operating in Windows.

Save As Inbox Allows you to save the search results as an inbox. See Chapter 
2 for more information on inboxes.

Menu Item Description
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Viewing or Modifying Software Installation Information
Through Inventory Management, you can view software installation data. 
You can view and modify software installation data via:

Asset records

Software installation records

Asset records
To view software installation data via an asset record:

1 Click Inventory Management in the Services tab of your Home menu. 

2 Click the Assets tab.

3 Click Assets. 

The Asset Information form displays.

4 Type the Asset ID in the Asset ID field. For this example, type JoePC in the 
Asset ID field.

5 Click Search. 

The asset record for JoePC displays.

6 Click the Software tab. 

All the software installed on JoePC displays here.

7 Double-click an install record to see detailed information about it.

Installed Software option on the Inventory Management menu
To view software installation data via the Installed Software option on the 
Inventory Management menu:

1 Click Inventory Management in the Services tab of your Home menu. 

2 Click the Assets tab.

3 Click Installed Software.

4 Click the Installed Computer System tab.

5 Type the name of the asset, JoePC, in the Installed System field.

6 Click Search. 

The list of applications installed on JoePC displays.

7 Double-click an install record to see detailed information about it.
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Fields on the Installed Software Information Form

Application Information tab

Figure 7-18: Installed Software Information form-Application Information tab

Field Description

Application Name Name of the software

Description A short description of the software. 

Part Number Company’s identification number for the asset.

In an asset record, the Fill function is available for the part 
number (Part Number.) field. If you clear the field and select 
another part number, the related information, including 
serial number and manufacturer, automatically displays.

Manufacturer The company who manufactured the asset. Data in this field 
is read-only since it displays based on the Part Number you 
enter.
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Model Manufacturer’s model number for the asset. Data in this 
field is read-only since it displays based on the Part Number 
you enter.

Serial No. Manufacturer’s serial number for the software.

Last Scanned Date the software was last scanned by a discovery tool.

Last Update Date of the last software update.

Updated By The name of the person who performed the software update.

Version The number and/or name of the software release.

Status Availability of the software. 

Installed

Removed

Unknown

License ID Unique identifier of the software license.

Counts For The number of points a software installation consumes. e.g 
An office software license credits you 1,000 rights. Each 
software installation consumes 10 points. The software 
installation counter enables you to verify that the software 
has not been installed more than 100 times.

The value of this field determines what happens when 
installations for a single software item are associated with the 
same workstation or the same user.

File Name Name of the executable file used to launch the software.

File Size The size of the executable file.

Installed Directory The network or hard drive directory where the software is 
installed.

Media Type The means by which the software is installed—CD, floppy 
disk, tape.

Execution Count Number of times the software has been run.

Last Execution The date of the last time the software was run.

Suite Component? Indication that the software is part of an application suite. 
(e.g. Word is a suite component of Microsoft Office.)

Authorized? Indication that the software installation on the PC is legal.

Field Description
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Installed Computer System tab

Figure 7-19: Installed Software Information form-Installed Computer System tab

Field Description

Installed System Identifies the system on which the software is installed.

Contact Name Name of individual who uses the computer system. 
Prepopulated from the asset record of the computer system 
on which the software is installed.

Network Name Network to which the computer system is connected. 
Prepopulated from the asset table.

Model Manufacturer’s model number for the computer system. 
Prepopulated from the asset record of the computer system 
on which the software is installed.

Type Prepopulated from the asset record of the computer system 
on which the software is installed.

Serial No. Manufacturer’s serial number for the asset. Prepopulated 
from the asset record of the computer system on which the 
software is installed.
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Viewing Service Level Agreement Information
Through Inventory Management you can view service level agreements 
related to a particular asset. 

To view service level agreement information about a particular asset:

1 Click Inventory Management in the Services tab of your Home menu. 

2 Click the Assets tab.

3 Click SLA Information. 

The SLA Search form displays.

4 Enter the data for the asset for which you want to view any related SLAs. (If 
you know the Asset ID, type it in the Affected Hardware field.)

Installation Date Date software is installed on the system.

Installed By Who installed the software.

Removal Date Date software is uninstalled on the system.

Removed By Who uninstalled the software.

Field Description
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Scheduled Maintenance and Inventory Management

Scheduled Maintenace is integrated with Inventory Management. Users of 
Inventory Management can access Maintenance Options in the Inventory 
Management pull-down menu.

Scheduled Maintenance Items in the Inventory Management 
Options Menu 
To access scheduled maintenance items:

1 Open an existing asset record.

2 Choose Options>Scheduled Maintenance.

Figure 7-20: Options>Scheduled Maintenance menu

Maintenance History
The Maintenance History function tracks how many incident tickets, change 
requests, or request management quotes were created when a given 
maintenance task ran. For maintenance tasks which are designed to create 
one incident, change, or request, this number is always one. For maintenance 
tasks that create a collection of incidents, changes, or requests for every 
record in inventory matching certain parameters, this value may be different 
every time the task is run. Thus, on May 1, there might be two servers in 
Topeka, but by June 1, we might have installed a third server. Thus, a task 
which generates a change for every server in Topeka would generate two 
changes in May, and three in June.
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To check the Maintenance History of an asset:

1 Open the asset record in Inventory Management. 

This can be done through the Inventory Management menu, or through 
Scheduled Maintenance. See the Scheduled Maintenance chapter for details.

2 Choose Options>Scheduled Maintenance>Maintenance History.

Maintenance Tasks
To check the Maintenance Tasks that have been created for an asset:

1 Open the asset record in Inventory Management. 

This can be done through the Inventory Management menu, or through 
Scheduled Maintenance. See the ServiceCenter Scheduled Maintenance 
chapter for details.

2 Choose Options>Scheduled Maintenance>Maintenance Tasks.

Generate Recurring Incident Tickets, Change Requests, or 
Request Management Quotes from Inventory Management
The Scheduled Maintenance Advanced Query has a built-in anti-spam 
feature. By default, the system only generates 50 tickets, regardless of how 
many records the advanced query returns. This is to prevent, for example, an 
errant user from creating a Scheduled Maintenance task that opens a ticket 
for every asset in inventory. However, if you want to be able to generate a 
larger number of tickets, you can increase that number. This threshold is user 
definable under the administrative options section of the Scheduled 
Maintenance menu. 
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To generate recurring Incidents, Changes, or Quotes:

Follow the instructions given in the chapter, Scheduled Maintenance.

Tasks created in this fashion default to the following Schedule: Regularly: 
Every day (1 00:00:00), starting at the current date and time. In all likelihood, 
this needs to be changed by the user to the recurrence model they actually 
want. 

For more information on date and time formats, see the System 
Administrator’s Guide.

If the no template task is referenced in the Scheduled Maintenance 
Administrative Options, or the template listed does not exist, the system still 
creates a skeletal Scheduled Maintenance Task.

Tasks created in this fashion default to an inactive state. Be sure to click the 
Active box to true to begin executing the task.

To learn more about Inventory Management and Scheduled Maintenance, 
see the Scheduled Maintenance chapter.
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Contract Management

This section includes the following topics:

Contract Management Terms and Concepts on page 302

Creating Contracts on page 304

Creating a Contract By Contract Type on page 304

Fields on the New Contract Form on page 307

Creating a Contract By Template on page 321

Cancelling contracts on page 323

Renewing contracts on page 323

Managing contracts on page 324

Generating a Payment Schedule on page 332

The Contracts tab provides access to Inventory Management functionality 
that allows you to:

Create contracts from contract types or user-defined templates.

Track contract and payment details.

Add payments for contracts and generate payment schedules.

Associate contracts to multiple assets.

Maintain table of standard contract terms and conditions.

Create contract templates.

Renew contracts automatically.

Contract Management Terms and Concepts

The Contract Lifecycle
1 Create the contract.

The status of the contract is draft. 

Note: You can delete a contract only while it is in draft status.

2 Contract term begins based on the start date entered in ServiceCenter.

The status of the contract changes to current.

3 Contract term ends based on the expiration date entered in the system. 

At the end of the contract term, the contract is renewed or expires.
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Renewal

For a contract to renew automatically, the Auto-Renew flag must be 
selected prior to the expiration date. At the time of renewal, the system 
updates the start and expiration dates to reflect the new renewal term of 
the contract.

When a contract has been renewed, the status changes to renewed.

Expiration

Once a contract reaches its expiration date, the system changes the status 
to expired if the Auto-Renew flag is not selected. At that time, you can no 
longer make any modifications to the contract. 

To make changes to an expired contract, you must reopen the contract by 
choosing Options>Reopen Contract. Reopening the contract changes its 
status to draft and clears the Signed Date, Start Date, and Expiration Date 
fields.

If you change your mind about reopening a contract after you have chosen 
Options>Reopen Contract, click Back. (If you click another contract 
record in record list mode, or click Previous or Next, ServiceCenter 
automatically saves the reopened contract with a draft status.

Note: You can cancel a contract any time up until it expires. When you 
cancel a contract, the status of the contract becomes cancelled. (To 
cancel a contract, choose Options>Cancel Contract.)

Contract Types
Contract Management is for companies that have assets under contract. 
ServiceCenter supports the following contract types:

Lease—enables you to define general leasing conditions.

Maintenance—enables you to define a maintenance contract.

Software—allows you to define software license agreements.

Support—allows you to define asset support.

Warranty—allows you to track warranty data about your asset.

Note: In order to use the contract management functionality, your company 
must be licensed for the Inventory Management application.
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Contract Terminology

Lessee

Person or entity that has the right to use property under the terms of a lease. 

Lessor

Owner of property, the temporary use of which is transferred to another 
leasee under the terms of a lease. 

Creating Contracts
There are three ways to access the New Contract form to create a contract:

Selecting a contract type by the way of the Add New Contract wizard.

Selecting a template by the way of the Add New Contract wizard.

Prepopulating data on the General Contract Information form before 
clicking New.

Note: Prepopulating data on the initial form allows you to bypass the wizard 
as long as the contract type is defined.

Creating a Contract By Contract Type
To create a contract using a contract type:

1 Click Inventory Management in the Services tab of your Home menu. 

2 Click the Contracts tab.

3 Click Contracts. 

The General Contract Information form displays.

4 Click New. 

The Add New Contract wizard displays.

5 Click Create what type of contract? option.
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6 Choose the contract type from the Create what type of contract? field 
drop-down list.

Figure 7-21: Add New Contract Wizard
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7 Click Next. The Lease Contract Information form displays.

Figure 7-22: Lease Contract Information form

In this example you see the Lease Contract Information form.

8 Populate the fields of the different tabs according to your needs.
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Fields on the New Contract Form
Each contract record contains fields of general information that apply to all 
contract types. 

Field Description

Contract ID Each contract is identified by its unique Contract ID. The 
Contract ID field is mandatory. If you modify the Contract 
ID field after the contract has been added, the Contract ID 
field is updated on any associated asset records. Any pending 
payments for the contract are modified as well.

Creation Date This is the system date and time when the contract was 
added to the system. This is a read-only field and is for 
informational purposes only.

Submitted By This field contains the SC operator id of the user who added 
the contract to the system. This is a read-only field and is for 
informational purposes only.

Negotiated By The name of the individual who is in charge of negotiating 
the terms and conditions of the contract. This field is 
optional and is for informational purposes only.

Assignee This field contains the ServiceCenter operator id of the user 
to whom the contract has been assigned. This field is 
optional and is for informational purposes only.

Note: This field will serve a function when approvals and 
notifications are implemented in a future release. At that 
time data entered in the Assignee field is validated against 
the operator table. The Assignee has to be someone who has 
a valid ServiceCenter operator id. 
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Status This field reflects the existing status of the contract. The 
Status field is a read-only field and is dependent on the start 
date and expiration date of the contract. The system 
populates this field with the appropriate status depending on 
those dates.

There are five status conditions: 

Draft—A contract is in draft status when the contract 
term has not yet begun (e.g. the start date is in the future). 
The initial state of any contract is draft when first added to 
the system. 
Current—Once a contract term has begun, the system 
changes the status of the contract to current. 
Expired—When the expiration date has passed, the 
system changes the status of the contract to expired. 
Cancelled—If at any time a user cancels the contract, the 
status reverts to cancelled. 
Renewed—If the Auto-Renew flag for the contract is set to 
true, when the contract reaches its expiration date, the 
system sets the status of the contract to renewed.

Contract Type Lease
Maintenance
Software
Support
Warranty

Signed Date The date when the contract was signed. If populated, this 
date must occur before the contract start date. This field is 
optional and is for informational purposes only.

Start Date The commencement date of the contract term. The start 
date of a contract must occur before the expiration date. 
This is a mandatory field whenever the contract is not in 
draft status (e.g. the field becomes mandatory after the status 
of a contract is current or renewed). This field must be 
populated in order for the contract term to begin.

Field Description
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General tab

Figure 7-23: General tab

Expiration Date The date on which the contract term ends. This date 
determines whether or not the status of a contract becomes 
expired or renewed depending on the renewal conditions set 
in the contract. This is a mandatory field whenever the 
contract is not in draft status (e.g. the field becomes 
mandatory after the contract term has started).

Brief Description A short one-line description of the contract. This field is 
intended to supplement a more detailed description that 
would be entered into the Notes field on the Notes tab. It is 
optional and is for informational purposes only.

Field Description
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Field Description

Customer ID This is the id of the customer associated with the contract. 
It is a required field at all times and must reflect a valid 
customer id in the company table. The field is for 
informational purposes only.

Department The department to whom the contract belongs. This field 
is optional and is for informational purposes only. There is 
a link from this field to the dept table.

Budget Center The budget center (profit center) with which the contract 
costs are associated. This field is optional and is for 
informational purposes only. There is a link from this field 
to the budgetcenter table. 

Budget Code The budget code with which the contract is associated. 
This field is optional and is for informational purposes 
only. There is a link from this field to the budgetcode table.

Project ID The project number with which the contract is associated. 
This field is optional and for informational purposes only.

Accounting Code The accounting code with which the contract costs are 
associated. This field is optional and for informational 
purposes only.

Language This field indicates the primary language being used to 
convey the terms and conditions. This field is optional and 
is for informational purposes only. There is a link from 
this field to the language table.

Authorized Callers This is a list of all the individuals who are allowed to call 
about the contract. This field is optional and is for 
informational purposes only. There is a link from this field 
to the contacts table.

Notification Group / 
Notification Contact

These two fields are reserved for future use; however, they 
can still be populated for informational purposes at this 
time.

Part No. This field indicates the part number of the asset, if 
applicable. This field is optional and is for informational 
purposes only. There is a link from this field to the model 
table.

Manufacturer Indicates the manufacturer of the asset, if applicable. This 
field is optional and is for informational purposes only. 
There is a link from this field to the vendor table.
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Model This field indicates the model of the asset, if applicable. 
This field is optional and is for informational purposes 
only. There is a link from this field to the model table.

Product No. Denotes the product number of the asset if applicable. This 
field is optional and is for informational purposes only.

Purchase Order No. Number of the purchase order associated with the 
contract.

Purchase Req No. Number of the purchase requisition for the contract and 
any related assets.

Invoice No. Displays the invoice number of the asset, if applicable. This 
field is optional and is for informational purposes only.

Field Description
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Lessor or Vendor/Contact tab

Figure 7-24: Lessor /Contact tab

Field Description

Lessor This field identifies the lessor associated with the 
contract. This field is optional and for informational 
purposes only. There is a link from this field to the 
lessor table. In addition, there are read-only fields 
below the Lessor field which provide more detailed 
information about the lessor, including: address, sales 
representative, and phone number.

Contact This field indicates the lessor contact. This field is 
optional and for informational purposes only. There is 
a link from this field to the contacts table. In addition, 
there are read-only fields below the Contact field 
which provide more detailed information about the 
contact, such as full name, phone, company, location, 
E-mail, and building.
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Financial tab

Figure 7-25: Financial tab

Field Description

Cost Center The cost center with which the contract costs are associated. 
This field is optional and for informational purposes only. 
There is a link from this field to the costcenter table. 

Rent Cost The amount of rent paid toward a leased asset in a contract 
(or in the case of a lease contract, the acquisition cost). The 
amount due can be scheduled to be paid over several 
payments, or single payments can be scheduled. There is an 
option on the Payment Information tab (see Figure 7-36 on 
page 328) to automatically generate a payment schedule 
against the rent cost.

Note: For vendor contacts, this field is called Purchase Cost 
for the amount paid for an asset in a contract.

One-Time Charge These three fields fully quantify the one-time charge amount 
that is due for a contract. The amount due can be scheduled 
as a one-time charge payment on the Payment Information 
tab (see Figure 7-36 on page 328) by scheduling a single 
payment. The Payment Code on the payment form, in this 
case, is “one-time”.

Acquisition Cost The cost to payoff or acquire assets in a contract.

Renewal Cost The cost to renew a contract.

Currency The currency of the contract.
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Note: Depending on the contract type the Rent Cost, One-Time Charge, 
Acquisition Cost, or Renewal Cost fields may not be available on the 
Financial tab of all contract type information screens. For example, on 
the Financial tab of the Warranty Contract Information screen, 
Acquisition Cost fields are not available.

Terms tab
The Terms tab specifies the contract terms and conditions.

Figure 7-26: Terms tab

Currency EX Date If the currency of the base system is different than the 
currency of the contract, the system requires that you enter 
the date on which you are basing the exchange rate of the 
contract. The date must be today’s date or a previous date.

Amount in <base 
currency>

This is the amount of the contract in the currency of the base 
system once the exchange rate conversion has been applied 
to the cost amount entered. This field only displays if the 
Currency field is populated.

Field Description

Item This field relates to the actual physical number on the 
itemized contract which must be manually entered into the 
system.

Term/Condition This field enables you to specify the terms and conditions 
unique to your organization. 

Field Description
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To populate the Term/Condition field from your repository of standard 
terms:

1 Click Inventory Management in the Services tab of your Home menu. 

2 Click the Contracts tab.

3 Click Contracts. 

4 Locate the contract for which you want to add the terms and conditions.

5 Click the Terms tab. 

6 Click the Term/Condition field.

7 Click Fill.

To add standard terms and conditions to the repository:

1 Click Inventory Management in the Services tab of your Home menu. 

2 Click the Contracts tab.

3 Click Terms and Conditions.

4 Choose the contract type in the Contract Type drop-down list field.

Note: If you want the term/condition to apply to all contract types, leave the 
Contract Type field blank.

5 Type a brief description in the Term/Condition field.

6 Click Add, or press F1, to add the record.

A system-generated, unique ID for the record displays in the Internal System 
ID field. A message also displays in the status bar: Contract Terms record 
added.

Renewal Info tab
At the end of a lease, you can:

Renew the leased assets.

Return the assets.

Purchase (buyout) the assets.
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The Renewal Info tab documents if the contract is going be renewed.

Figure 7-27: Renewal Info tab

Field Description

Auto-Renew? ServiceCenter functionality that allows you to automatically 
renew leases by selecting this check box. If you select this 
check box, you must indicate the length of the renewal 
period in days in the Renewal Period field.

Renewal Period Required if the Auto-Renew check box is selected. It is the 
length of time in days of the new contract.

Notify in Advance Selecting this check box indicates that you want to notified 
before a contract expires. If you select this check box, you 
must also indicate the number of days in advance in the How 
Many Days? field.

How Many Days? Required if the Notify in Advance check box is selected. 
Enter the number of days you want to be notified in advance 
of the contract expiration.

Renewal Dates This field documents all the renewal dates for the specified 
lease contract.
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Notes tab

Figure 7-28: Notes tab

The Notes tab includes a free-form field that allows you to document any 
pertinent information about the contract.

Attachments tab

Figure 7-29: Attachments tab

The Attachment tab includes a free-form field in which you can attach 
electronic copies of the actual contract.
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Tabs Unique to Each Contract Type
The second tab on the Contract form displays information specific to each 
contract type.

Lease Info tab
Field information specific to a contract type is located on the second tab. In 
this example, the details of a lease contract display on the second tab, the 
Lease Info tab.

Figure 7-30: Lease Info tab

Field Description

Lease Rate Factor % Used in the rent calculation formula of contracts:

Contract rent = Value of the contract rent x Lease rate factor

The lease rate factor varies according to the type of asset 
under contract. It is contractual and can change from lease 
contract to lease contract. The Lease Rate Factor field is 
informational only.

Insurance Value Indicates the monetary value for which you are insuring the 
assets in the contract.

Shipping Method Displays the means by which the asset is being sent to you.

Shipping Date The date the assets are shipped from the vendor.

Acceptance Date The date you receive and accept the assets into your 
organization.
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Maintenance Info tab
Details specific to a maintenance contract display on the Maintenance Info 
tab.

Figure 7-31: Maintenance Info tab

End-of-Term 
Options

Documents what you are planning to do at the end of the 
contract.

Purchase
Return
Renewal

Note: The Renewal option button is tied to the Auto-Renew 
flag on the Renewal Info tab. If renewal is selected here, the 
Renewal tab shows the renewal flag as activated once the 
contract is saved.

Notes Free-form field document any notes about the end-of-term 
action.

Field Description

Response Time Use this field to indicate the typical response time of the 
vendor when a call is placed for service.

Service Notes Document any pertinent information about the 
maintenance work orders in the Service Notes field.

Field Description
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Support Info tab
Details specific to a support contract display on the Support Info tab.

Figure 7-32: Support Info tab

Field Description

Response Time Documents the response time based on the severity of 
the support call.

Escalation Policy This multi-line field can be used to specify an 
organization’s rules about its escalation policy if a 
problem cannot be solved through typical support 
channels.

Problem Log Use this multi-line field to document all support calls 
tied to the contract. It is a good idea to include 
resolution.
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Warranty Info tab
Details specific to a warranty contract display on the Warranty Info tab. In 
particular, the tab documents the warranty type.

Figure 7-33: Warranty Info tab

Creating a Contract By Template
In order to create contract by template, you must first create the template. 
You can create the template two ways: 

From an existing contract

Using the template form

To create a template from an existing contract:

1 From the Contracts tab, click Contracts.

2 Click Search to locate the contract from which you are creating the template.
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3 Choose Options>Create Template.

Figure 7-34: Contract Template form

4 Type the name of the template in the Name field.

5 Change any necessary information.

Note: Only complete those fields with information that can be standardized 
across contracts.

6 Click Add. 

The new template has been added to the system.
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To create a template using the contract templates form:

1 From the Contracts tab, click Contract Templates.

The Name field and the Contract Type field are required fields.

2 Type the template name in the Name field.

3 Choose the contract type in the Contract Type drop-down list field.

4 Populate the fields of the different tabs according to your needs.

5 Click Add to add the template to the system.

To create a contract using a template:

1 On the Add New Contract wizard form, click Create a contract from which 
template? option.

2 Choose the template from the Create a contract from which template? 
drop-down list field. The New Contract form displays.

Cancelling contracts
Cancelling a contract does not delete from the system; it merely changes the 
status. You can cancel a contract up until its expiration date. 

To cancel a contract:

Choose Options>Cancel Contract.

Notice the Status field indicates cancelled. Once a contract is cancelled, you 
can not reinstate it.

Note: When you cancel a contract, all outstanding payments against that 
contract are cancelled as well

Renewing contracts
To renew a contract:

1 Access the contract you want to renew.

2 Click the Renewal Info tab.

3 Select the Auto-Renew? check box.

4 Type the numbers of days you are renewing the contract for in the Renewal 
Period field. 

This is a required field.

5 If you want to be notified in advance of a contract that is expiring, select the 
Notify in Advance? check box. 
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6 Type the number of days you want to be notified in advance of the contract 
expiration in the How Many Days? field. 

This field is required if the Notify in Advance check box is selected.

7 Click Save. 

A message in the status bar displays, “Contract record updated.”

Managing contracts

Tracking contract details and payments
To track contract details and payments:

1 Click Contract Queue on the Contracts tab on the Home menu of Inventory 
Management.

2 Use the inbox functionality to manage contracts.

To learn more about using inbox functionality, see the Getting Started 
chapter on page 77.

Adding assets to a contract
Note: You can add assets to only the following contract types:

Lease

Maintenance

Support 

Warranty

To add assets to a contract:

Note: The ability to add assets is granted only to users who have the 
appropriate security privileges in their user profile.

1 Open the contract to which you want to add assets.

2 Click the Assets tab.

3 Click Add Assets. 

The Select Assets to Add to Contract wizard displays.

4 Click Fill next to the first field. 

A Search criteria form displays.
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5 Complete the necessary fields to further filter the list to locate the assets you 
want to add to the contract.

6 Click Search.

7 Select the assets using one of the following methods:

Click Fill All if you want all assets added to a contract.

Select assets one at a time by clicking each row that contains an asset you 
want to add to a contract.

Choose Options>Toggle Multiple Selection. Toggle Multiple Selection 
allows you to select more than one record at a time. 

When Toggle Multiple Selection is activated, the title bar reads, “Select 
Related Records Multiple Selections are ENABLED.” (If the Toggle 
Multiple Selection is not activated, the title bar reads, Select Related 
Records Multiple Selections are DISABLED.”)

Each time you select an asset record, a message displays in the status line 
indicating, # records filled, where # is the total number of records selected 
thus far.

You are returned to the wizard form.

8 Click Next. 

All the assets you selected to add to the contract are displayed on the Assets 
tab of the Contract Information form.

9 If you want to allocate costs to an asset you have added, double-click the row 
in which the asset appears. 

The Allocation Information form displays.

10 Type the percentage of the cost you are allocating to this asset in the % Cost 
Allocation field.

11 Click Save. 

You return to the Assets tab of the Contract Information form.
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Note: If you want the system to allocate costs for all of the assets in the 
contract, click Generate %.

Figure 7-35: Assets tab of the Contract form

Note: Adding licenses to a software contract follows the same procedure as 
adding assets to other types of contracts. 
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Asset tab

Note: On software contracts, you add assets (licenses) via the Licenses tab. 

Scheduling payments
To schedule a single payment for a contract:

1 Access the contract for which you are making a payment.

2 Click the Financial tab.

Field Description

Asset Specifies one of the following device types:

devices
location
contacts

ID Indicates the asset ID.

% Cost Allocation Indicates the percentage of the cost allocated to a particular 
asset.

Status If the status of an asset is not installed when payment is 
submitted for that asset, the system won’t prorate it.
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3 Click the Payment Information tab.

Figure 7-36: Payment Information tab

4 Click Schedule Single Payment.

5 Type the amount of the payment in the Amount field.

6 Type the currency in which you are making the payment.

7 Select the payment code in the Payment Code field.

There are several codes you can enter:

One time—a one-time only cost indicated on the contract.

Purchase—payment towards the purchase costs. (For a lease it is payment 
towards acquisition costs.) 

Renewal—payment towards renewal costs.

Buyout—payment to payoff the lease contract. (It only applies to lease 
contracts.)

Other—payment of other costs, such as administrative costs.
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8 Type the date the payment is due in the Date Due field.

A message displays in the status bar: Payment record added.

9 Click Add. 

If this is a new payment, the system assigns it a status of pending.

Note: The due date is always a date past the current date. Otherwise, the 
system does not process the payment.

To schedule a payment via the Payment Information form:

1 From the Contracts tab, click Payments. 

The Payment Information form is displayed.

Figure 7-37: Payment Information form

2 Type the Contract ID in the Contract ID field.

The Contract ID is the number of the contract to which you are adding a 
payment.

3 Type the amount of the payment in the Amount field.

4 Type the currency in which you are making the payment.
Contract Management  329



ServiceCenter
5 Select the status of the payment in the Status field.

There are three statuses you can select:

Pending—the initial status when you first add a payment to a contract. 

Submitted—indicates that the payment is processed and cannot be 
retrieved for modification or deletion.

Cancelled—payment is cancelled. It still appears in the list of payments, 
but it can no longer be submitted for payment.

6 Select the payment code in the Payment Code field.

There are several codes you can select:

One time—indicates you are making a one time payment.

Purchase—payment towards the purchase or acquisition of assets in the 
contract.

Renewal—payment to be applied to any renewal costs.

Buyout—payoff of the contract.

Other—negotiation, administrative, addendum, cancellation, 
prepayment costs.

7 Type the payment due date in the Due Date field.

8 Populate the remaining fields according to your needs.

9 Click Add.

Submitting a Payment
To submit a payment:

1 From the Contracts tab, click Payments.

2 Locate the payment you want to process and select it.

3 Click Submit Payment.

When you submit a payment, you prorate costs of each asset in the contract.

Cancelling a payment
To cancel a payment:

Note: You can only cancel payments still in pending status.

1 On the Contracts tab of the ServiceCenter Home menu, click Payments.

2 On the Payment Information form, type any information you have about the 
payment you want to cancel.
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3 Click Search.

Figure 7-38: Payment Information form

4 In the results list, click the payment you want to cancel.

Specific information about the payment you are cancelling appears in the 
detail area below the table.

5 Click Cancel.

Notice the Status field now shows cancelled.

Deleting a Payment
1 On the Contracts tab of the Inventory Management menu, click Payments.

2 On the Payment Information form, type any information you have about the 
payment you want to cancel.

3 Click Search.

4 Click Delete.
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Generating a Payment Schedule
ServiceCenter has the functionality to generate a payment schedule for your 
contracts. 

To generate a payment schedule:

1 Access the contract for which you are making a payment.

2 Click the Financial tab.

3 Click the Payment Information tab.

4 Click Generate Payment Schedule.

The Generate Payment Schedule Wizard displays.

Figure 7-39: Generate Payment Schedule Wizard
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5 Complete the following required fields:

Payments—the amount of each payment in the payment schedule.

Frequency—how often you want to make payments. 

Starting Date—the first date you want to make a payment.

Currency—the currency of the payments.

Currency EX date—is required only if the system currency and payment 
currency aren’t the same.

6 Click Next.

For the amount of the payments and the frequency with which you want to 
make them, the system checks to see if the payment schedule fits within the 
start and end date of the contract. If the amount and frequency of payments 
doesn’ t fit within those date parameters, an error message displays.

Figure 7-40: Error Message

Note: The ability to schedule a payment, generate a payment schedule, 
update, submit, cancel, or delete a payment depends on the privileges 
granted by the administrator in the user profile. In addition, the 
Generate Payment Schedule, Schedule Single Payment, Submit or 
Cancel Payment buttons are not available if there is no outstanding 
cost to make a payment against.(See the Purchase Cost Outstanding 
field.)
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Network Discovery Integration with Inventory 
Management

ServiceCenter integrates with the Network Discovery product to provide 
network monitoring capabilities within ServiceCenter. See the Events Services 
guide for more information about Network Discovery.

The assets discovered by Network Discovery are recorded in the 
ServiceCenter database in the asset records. When an asset is discovered by 
Network Discovery, a new asset record is created. If Network Discovery 
determines that the information has changed, the ServiceCenter asset record 
is updated. If Network Discovery determines that the asset is no longer on the 
network, the asset record is flagged.

The data written from the Network Discovery database to the ServiceCenter 
asset records are mapped to specified fields within the asset records. This 
mapping is set within the Connect.It product.

This section includes the following topics:

IND Device Types on page 334

Launching Network Discovery’s Device Manager on page 335

Network Discovery-Related Fields Added to Asset Records on page 339

Passing Network Discovery Device Information to ServiceCenter on page 341

IND Device Types
Network Discovery provides numerous device type classifications in the IND 
Device Type field. Network Discovery categorizes devices in two classes: real 
and virtual.

Real Assets
Real assets are network assets that Network Discovery can positively identify 
and assign a device type. The device type as identified by Network Discovery 
corresponds to the asset button assigned by Network Discovery.
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Virtual Assets
Virtual assets are connectivity tools. When Network Discovery determines 
that two assets are connected by an undetermined path, it inserts a virtual 
asset between the assets as a placeholder.

There are two types of virtual assets: cloud and diamond. The cloud asset 
represents a single or group of real assets that Network Discovery cannot 
identify. The diamond asset represents connectivity that Network Discovery 
cannot identify.

Launching Network Discovery’s Device Manager
Network Discovery’s Device Manager provides details of the assets 
discovered on the network. The Device Manager can be launched from an 
asset record generated by asset information from Network Discovery. The 
Device Manager provides several panels of information for each asset in the 
network. The data includes the asset state, status, port information and the 
asset address.

To launch the Device Manager from an asset record:

Select Options>View IND Device from the menu bar.

For more information on using the Device Manager, see the Network 
Discovery User’s Guide.
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Network Discovery Device Types and Their ServiceCenter 
Equivalents
Not all Network Discovery device types are listed in ServiceCenter. Instead, 
the Network Discovery device type is mapped to a type that is equivalent to 
a type in ServiceCenter. This type is listed in the Type field of an asset record. 
Network Discovery Device types and their ServiceCenter equivalents are 
shown below:

Network Discovery 
DeviceType

Network Discovery 
Device Class

ServiceCenter Device Type

Enterprise Router Network device.router

Enterprise ATM Network device.switch

Enterprise Switch L3+a Network device.switch

Enterprise Switch L2-b Network device.switch

Access Switch Network device.switch

Router Network device.router

ATM Switch Network device.switch

Switch L3+c Network device.switch

Switch L2- Network device.switch

Ethernet/1000 Network device.netcard

Ethernet/100 Network device.netcard

FDDI Network device.netcard

100VG AnyLAN Network device.netcard

Ethernet/10 Network device.netcard

Token Ring Network device.netcard

Wireless Access Point Network device.netcard

Transceiver Network device.netcard

Firewall Network device.router

VPN Gateway Network device.router

Local/Remote Access Server Network device.router

Gateway Network device.router
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Backplane Network device.circuit

Server Server device.server

Mainframe/Large Server Server device.server

Storage Server Server device.server

Web Server Server device.server

Microsoft Server Server device.server

Novell Server Server device.server

Banyan Server Server device.server

UNIX Server Server device.server

NMS Appliance Server device.server

Workstation Workstation device.workstation

Network Computer Workstation device.workstation

Laptop Workstation device.workstation

POS/ATM Workstation device.workstation

Apple Workstation Workstation device.workstation

Microsoft Workstation Workstation device.workstation

UNIX Workstation Workstation device.workstation

X Terminal Workstation device.workstation

Printer I/O device.printer

Color Printer I/O device.printer

Printer Server I/O device.server

Image Input I/O device.peripheral

Robot/Controller Controller device.peripheral

UPS Miscellaneous device.peripheral

Analyser Miscellaneous device.peripheral

Gadget Miscellaneous device.peripheral

Unknown Unknown device.example

Unknown NCD Unknown device.example

Network Discovery 
DeviceType

Network Discovery 
Device Class

ServiceCenter Device Type
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Cloud Cloud Virtual Device device.hub

Radio Cloud Cloud Virtual Device device.hub

Carrier Network Cloud Virtual Device device.hub

Unmanaged Hub Cloud Virtual Device device.hub

Shared Port Diamond Virtual 
Device

device.port or none

Approximate Diamond Virtual 
Device

device.hub or none

Unmapped IP Diamond Virtual 
Device

None

Logical View Diamond Virtual 
Device

None

LV Unmapped IP Diamond Virtual 
Device

None

LV Unmapped Diamond Virtual 
Device

None

aLevel 3 or above.
bLevel 2 or below.
cLevel 3 or above.

Network Discovery 
DeviceType

Network Discovery 
Device Class

ServiceCenter Device Type
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Network Discovery-Related Fields Added to Asset Records
The Network Discovery asset information is placed in the asset records and 
displayed in added fields in the asset formats. This section describes the fields 
containing Network Discovery information and where those fields are 
located.

 Inventory Management Database Changes

The following fields are added to the ServiceCenter device database file and 
all child asset files (such as deviceworkstation and deviceserver). These fields 
are added to the various tabs in the asset records, as shown in the following 
sections.

Field Type

family.name character

family.uri character

model.uri character

vendor.uri character

operating.system character

os.uri character

mtbf character

total.downtime character

install.date datetime

server.id number

port.desc character

port.index number

dest.mac character

dest.port.index number

ind.removed logical

breaks number

primary.app.name character

primary.app.uri character
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General tab
The following Network Discovery related fields are in the General tab of the 
device records.

Note: Mean Time Between Failure (mtbf) is a value that is not directly 
provided by Network Discovery. Instead, this value is derived by 
dividing Total Breaks (breaks) by Total Downtime (total.downtime).

Software tab
The following Network Discovery-related fields are in the Software tab of the 
asset records.

Field Label

family.name Family Name

family.uri Family URI

model.uri Model URI

mtbf Mean Time Between Failure. 

total.downtime Total Downtime

install.date Installed on

server.id Network Discovery Server ID

ind.removed Removed from Network Discovery

breaks Total Number of Breaks

Field Label

operating.system OS Installed

os.uri OS URI

primary.app.name Primary Application

primary.app.uri Primary Application URI
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Relationship tab
The following Network Discovery related fields are in the Relationship tab of 
the asset records.

Vendor tab
The following Network Discovery related fields are in the Vendor tab of the 
asset records.

Passing Network Discovery Device Information to ServiceCenter
Network Discovery also provides the following asset properties. When Event 
Services maps these properties, they are mapped to specific ServiceCenter 
fields in the translation process. See the Events Services guide for information.

Network Discovery Asset Property Definitions
The following table defines the Network Discovery asset properties that are 
passed to ServiceCenter: 

Field Label

port.desc Port Description

port.index Port Index

dest.mac Destination MAC Address

dest.port.index Destination Port Index

Field Label

vendor.uri Vendor URI

Asset Property Description

SystemName The SNMP system name. 

SystemDescription The SNMP system description.

SystemLocation The SNMP system location.

SystemContact The SNMP system contact.

SystemObjectID The SNMP system object ID. 

SWCompanyName The Company associated with SystemObjectID.
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SWCompanyURI The URI associated with SWCompanyName.

FamilyName The Device Family.

FamilyURI The URI associated with FamilyName.

ModelName The Device Model.

ModelURI The URI associated with ModelName.

OSName The Operating System.

OSURI The URI associated with OSName.

ApplicationName The main Application of this server.

ApplicationURI The URI associated with ApplicationName.

IPv4Address One IPv4 address associated with the device (if any).

DeviceTag The device tag (aka the other title that displays on the 
map).

DeviceTitle The device title that displays on the map, as assigned by the 
prime account.

Breaks The total number of breaks on the device since the device 
was found or since the administrator has reset the counter.

Downtime The total downtime of the device in seconds since the asset 
was found or since the administrator has reset the counter.

Asset Property Description
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Port-to-Port Information
Network Discovery also provides connectivity information about each port 
on the asset. The following information is passed to ServiceCenter:

For ServiceCenter, the port property Connection is further broken down by 
the Connect.It product for the following:

Destination MAC Address

Destination port index number

Device PORT Property Description

Device PORT Property Description

PortIndex The MIB index of the port.

PortDescription The description associated with the MIB index.

Connection If it exists, it contains a Device and optionally a Port 
object to which the asset has a connection. Neither the 
Device nor the Port object have any attributes except for 
their required NMID.
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CHAPTER

8
 Service Level Management
This chapter provides an introduction to Service Level Agreements, including 
general definition of service level agreements (SLAs) and how they are used 
in ServiceCenter, general description of the SLM interface with other 
ServiceCenter applications and external sources, knowledge requirements, 
and integrating of SLM information into ServiceCenter applications (Service 
Management, Incident Management, Change Management, and Inventory 
Management)

Service Level Agreements (SLAs) track performance and provide system 
feedback on service agreements between departments within a company. 
SLAs are integrated into the ServiceCenter suite of applications, but they may 
be implemented separately to monitor the quality of both external and 
internal service.

This chapter is organized into the following main sections:

Understanding Service Level Management on page 346

SLM Module on page 347

SLAs and ServiceCenter Applications on page 348

Service Management Integration with SLM on page 348

Incident Management Integration with SLM on page 355

Change Management Integration with SLM on page 363

Inventory Management Integration with SLM on page 366
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Understanding Service Level Management

What Is an SLA?
An SLA (service level agreement) is an agreement between a service provider 
and a customer. An SLA can be internal (between the departments within an 
organization) or external (between an organization and a vendor). These 
agreements encompass two important facets of service:

Availability of a specific resource within a specified time frame.

Performance guarantees for service response times.

Why Are SLAs Important?
How do you quantify the level of service you receive both from within your 
organization and from service contracts with outside vendors? 

Are your resources available when you need them? 

If an outage occurs for a resource specified in a service agreement, did the 
provider respond as promised? 

Accumulating accurate service performance data manually and evaluating it 
properly over an extended period is not feasible for a large enterprise. Your 
organization must accumulate such data automatically to track service 
guarantees efficiently. You must detect the failure of a service guarantee to 
protect yourself from the economic consequences of lost productivity.

How Are SLAs Implemented?
Typically, SLAs are used internally to track the service performance of an IT 
department within an organization. Service guarantees are defined between 
IT and other departments in the organization regarding object (e.g., devices 
or software) availability and response performance. For example, the IT 
department might guarantee that a development department server is 
available 98% of the time and that 99% of the time IT will respond to an 
outage involving that device within one hour.

The SLA reflects the foregoing guarantees. The SLA also tracks compliance 
and displays the potential economic impact of outages. 
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Most organizations apply SLAs in the following manner:

Focus on discrete measures of object performance such as hardware 
availability. 

Add metrics for help desk performance, technician response time, and 
customer satisfaction. 

Assess economic impact on the enterprise resulting from SLA 
performance.

Publish SLAs to the user community in an effort to increase end user 
satisfaction. 

SLM Module

The SLM module provides a centralized repository of SLM information and 
is fully integrated into the ServiceCenter suite of applications. The module is 
fully automatic and continuously recalculates SLA performance. Availability 
and response metrics are fed into the module and charted in a graphic 
display. Outage information is gathered from such sources as Incident tickets 
and change requests and compared with service guarantees to determine the 
health of the SLAs in the system.

The SLM module can also help prioritize Incident resolution. For example, 
as a system administrator you can use the SLM module to escalate an 
Incident ticket inside ServiceCenter if the service guarantee is in jeopardy.

Interfacing with External Sources 
Through external event interfaces, information about network health or 
technician performance is fed into the SLM module from external enterprise 
management sources, even if no other elements of the ServiceCenter suite are 
installed at your site.
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SLAs and ServiceCenter Applications

This section explains the procedures for integrating SLA information into 
ServiceCenter applications (Service Management, Incident Management, 
Change Management, and Inventory Management).

Service Management Integration with SLM

The Service Management application uses the SLM module to determine the 
level of service to extend to a particular caller. The module does this by the 
following two methods:

SLA Determination — The SLM module evaluates new calls and 
determines the SLA to apply to the call. 

Entitlement Checking — The system checks to see if the caller, based on 
the SLA chosen, has rights to help desk service at that particular time (time 
of day/day of week).

If the caller is entitled to service, the call report is opened. If the call is outside 
the time frame of the service level agreement, the system prompts the 
technician of the violation and seeks to close the call.

The SLM Configuration module allows the system administrator to 
configure the controls to allow for overrides and ignore service hour 
limitations. The SLM module can be switched off altogether so that it does 
not function with ServiceCenter applications. Refer to the System 
Administrator’s Guide for more information on the administration for 
Service Management.

SLA Determination 
The SLM module determines which SLAs to use for a particular caller based 
on two models:

Default department SLA

Category/Priority mapping
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Default department SLA

The default department SLA model bases a call’s SLA on the caller’s 
department. All departments have a default SLA defined, which the system 
selects when a call report is opened. For details on defining default 
department SLAs, refer to the Service Level Management chapter in the 
Application Administration Guide.

Category/Priority Mapping 

The Category/Priority mapping model bases a call’s SLA upon a combination 
of the caller’s department, the call’s category, and the priority assigned to the 
call. SLAs defined by these criteria are used first by the system when the 
Enable Category/Priority mapping option is selected in the SLA 
configuration record. Category/Priority maps may have as many SLAs within 
a priority as there are categories. For details on defining advanced SLA 
assignments, refer to the Service Level Management chapter in the Application 
Administration Guide.

Entitlement checking 
The system automatically checks to determine if a particular caller, based 
upon his or her SLA, has the right to help desk service at the current time of 
day and/or day of the week. If the service level agreement does not provide 
service to the caller for that period, the system automatically notifies the first 
level technician by displaying the following entitlement prompt:

If the system has been configured for overrides, the technician can click the 
Override button and proceed with the call report. For information on the 
override and service hours options, refer to the Application Administration 
Guide.
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Opening a new call report 
When the SLM module is enabled, you must provide the system with certain 
SLM information to open a new call report. You may either choose an SLA 
from a drop-down list or provide the following information when prompted, 
so the system can select the proper SLA for the caller’s department:

Name of the individual reporting the Incident.

Category of the call.

Priority of the call.

This information determines the SLA used for the call and whether or not the 
caller is entitled to service at that time.

To open a new call:

1 Click Service Management in the System Administrator’s home menu.
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The Service Management menu appears.

Figure 8-1: Service Management menu
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2 Click Take New Calls in the Service Management menu. A call report form 
displays.

Figure 8-2: Call Report form

3 Complete the form.

4 To have the SLA automatically selected, complete the following fields: 

Contact Name

Severity

Site Category

Description

If more information is required for the SLA to be selected, the SLA 
information dialog box opens. Complete the blank fields in the SLA 
information dialog box.
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5 Open a call or an incident, as follows:

Open the call.

a Click QOpen.

If a required field is not completed, a message appears in the status bar 
asking you to fill in the field. 

If Enable Category/Priority mapping has been selected in the SLA 
configuration record, the SLA Information dialog box displays. 

For more information about Enable Category/Priority mapping, see the 
Application Administration Guide.

Figure 8-3: SLA Information dialog box

b Complete the missing information.

c Click OK.

A message in the status bar tells you that the ticket was opened. The system 
has selected an SLA and fills in the appropriate fields in the Call. The selected 
SLA appears the next time you view the call record.

Open an Incident. 

a Click Create Incident.

The Incident ticket opens. After the incident has been opened and saved, 
the next time the incident is viewed the SLA tab appears. 

b To see the SLA information in the Incident ticket, select the SLA tab. 
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For definitions of the fields in the SLA tab, see the Incident Management 
chapter in this guide.

Figure 8-4: SLA tab in an incident ticket
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Calls outside service hours
If the caller is not entitled to service at the current time (as specified by the 
SLA selected), the system notifies the help-desk technician by displaying the 
following prompt:

Respond to the prompt in one of the two following ways:

Click OK to close the call.

Click Override to override the system and open the call.

Note: The Override button functions only if the Check Service Hours option 
is selected in the SLA configuration record. 

Incident Management Integration with SLM

Much like Service Management, Incident Management uses the SLM module 
to determine the level of service to extend to a particular caller. Incident 
Management supports both SLA determination and entitlement checking. 
For additional information on level of service determination, refer to Service 
Management Integration with SLM on page 348. Refer to the System 
Administrator’s Guide for more information on the administration for 
Incident Management.

The SLM module provides another dimension to the category-driven 
escalation model for Incident tickets. Options in the Configuration module 
allow system administrators to escalate tickets based on the availability of 
objects and the response metrics. For information on escalation options, 
refer to the SLA Options section in the Service Level Management chapter of 
the Application Administration Guide.

Open Incident tickets display SLA guarantees and current response metrics 
for SLAs selected in a tab labeled SLA.
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Opening a Ticket 
When the SLM module is enabled, the system automatically assigns an SLA 
to the ticket based on the following workflow:

1 Is Category/Priority mapping enabled?

a If it is enabled, is the contact’s department, the incident ticket’s category, 
and the incident ticket’s priority defined in the slaassign table? This data 
makes up the key to the slaassign table. (For information on creating this 
map, refer to the SLA Maintenance Tasks section in the Application 
Administration Guide.)

If it is defined in the slaassign table, the SLA specified on the slaassign 
record is used as the SLA for the ticket.

If it is NOT defined in the slaassign table, go to Number 2.

b If Category/Priority mapping is NOT enabled, go to Number 2.

2 Is there an SLA defined for the department to which the contact belongs?

If there is an SLA defined for the contact’s department, that SLA is used as 
the SLA for the incident ticket.

If there is NO SLA defined for the contact’s department, go to Number 3.

3 Is there a default SLA defined for the contact’s company?

If there is an SLA defined for the contact’s company, that SLA is used as 
the SLA for the incident ticket.

If there is NO SLA defined for the contact’s company, go to Number 4.

4 Is there a default SLA defined in the SLA Configure Module?

If there is a default SLA defined in the SLA Configure Module, that SLA is 
used as the SLA for the incident ticket.

If there is no default SLA defined in the SLA Configure Module, the 
incident is NOT assigned an SLA.
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To open a new Incident ticket:

1 Click Incident Management in the system administrator’s home menu. 

The Incident Management menu displays.

Figure 8-5:  Incident Management menu

2 Click Open New Incident in the Incident Management Menu. 
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A blank Incident ticket form displays.

Figure 8-6: Incident ticket form

3 Complete the Incident ticket form. Refer to the User’s Guide for complete 
instructions on creating Incident tickets. 

4 Click Quick Open. 

5 Complete the fields in the SLA information dialog box.

If a required field is not filled in, a message appears in the status bar asking 
you to fill in the field. 

If Enable Category/Priority mapping has been selected in the SLA 
configuration record, the SLA Information dialog box displays. 
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Enter the missing information and click OK.

A message in the status bar tells you that the ticket was opened. The system 
has selected an SLA and fills in the appropriate fields in the Incident ticket. 
To see the SLA information in the Incident ticket, select the SLA tab. For 
definitions of the fields in the SLA tab, see the User’s Guide.

Calls outside service hours

If the caller is not entitled to service at the current time (as specified by the 
SLA selected), the system notifies the help-desk technician by using the 
following prompt:

Respond to the prompt in one of the two following ways:

Click OK to close the call.

Click Override to override the system and open the call.

Note: The Override button functions only if the Allow Override of Service 
Hours Violation option is selected in the SLA configuration record 
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SLA Information in Open Tickets 
Once a ticket has been opened and the SLA selected, all SLA information 
displays in the SLA tab in an Incident ticket. 

Figure 8-7: SLA tab in an incident ticket
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Fields

Note: All the fields in the SLA tab are read-only. 

Escalations 
Settings in the Configure Module for SLA allow you to escalate incident 
tickets by availability and response metrics rather than by the normal 
parameters. If the Response Escalations option in the SLA configuration 
record is selected, the system automatically escalates the alert stages of an 
incident ticket to the values defined in the Response Threshold fields. Refer 
to the Application Administration Guide for details on setting thresholds.

Posting outages 
The Incident Management application can be used to post outage 
information about devices in the system into the SLA module when Incident 
tickets are opened and closed. The system posts outages both manually and 
automatically:

Manual Posting

The system displays a table for the selected device in which the user can 
manually enter the start and stop time of the outage. Use this option to 
establish the exact time of an outage rather than the time the outage was 
reported. Click Proceed to continue the open or close process.

Field Description

SLA Contract# Displays the selected SLA.

Expiration Expiration date and time of the current SLA.

Service Hours Hours (time of the day/days of the week) for which the user is 
entitled to the service guaranteed by this SLA.

Target Performance percentage guaranteed by this SLA.
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The outage table displays at two different phases of processing a 
ticket—when the ticket is opened (shown in the following figure) and when 
it is closed.

Figure 8-8: Outage posting form—when ticket is opened

Note: The system enters the current time as the default in the manual mode. 
You may either accept the default or enter the exact time.

Automatic Posting 

If the Auto Post Outages option in the SLA configuration record is selected, 
the system automatically posts the outage with the current time (the time the 
ticket was opened or closed). The outage table is not displayed with this 
option, and no user interaction is necessary.

Note: The SLA module must be enabled before the system can post outages. 
To turn on the SLA module, select the Enable Module check box in the 
SLA configuration record. Stop your system and restart it to activate 
the SLA function. 
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Related outages
If the SLA module is configured to do so (the Spread Outages option in the 
SLA configuration record is selected), the system posts outage records for any 
related device experiencing an outage. Parent/child relationships in the 
system are defined in the Inventory Management module (see the System 
Administrator’s Guide). The posting method for a related device is the same 
as that for the original device. 

Change Management Integration with SLM

In the Change Management application, the SLA module calculates the cost 
of a particular change based on the object being changed and the scheduled 
hours of the outage. The system automatically calculates the cost impact of 
the outage on each affected SLA. This data is an important factor in 
minimizing the economic impact of planned outages across your system. 

Refer to the System Administrator’s Guide for information on the 
administration for Change Management.

To view a table of outage cost estimates:

1 Open an existing change record for a particular device.
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2 Choose Options>Affected SLAs. A table displays itemizing the downtimes of 
the device and the resultant cost of each outage in three SLAs.

Figure 8-9: Change request—selecting an affected SLA
364 Chapter 8—Service Level Management 



User’s Guide
Note: The Affected SLAs table cannot calculate downtime costs unless the 
Downtime Start and Downtime End fields contain valid times. If you 
have entered Scheduled Downtimes in the change record, those values 
appear in the appropriate fields in the Affected SLAs calculation table. 

If you have not entered times in the change record, you may enter Start 
and End times for the outage in the Affected SLAs table.

Figure 8-10: SLA cost calculation

3 Click Recalculate to recalculate the down time cost if you change the times in 
the Downtime Start or Downtime End fields.

4 Sort each column by selecting the appropriate sorting option from the 
Options menu.

5 Click OK to return to the change record.
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Inventory Management Integration with SLM

Service level agreements (SLAs) perform two functions in the Inventory 
Management application:

Provide a complete outage history of an object (device).

Provide automated tracking of availability of a device.

Refer to the System Administrator’s Guide for information on the 
administration for Inventory Management.

Outage history
Inventory Management receives outage data from the SLA module and 
displays device records indicating current outage status as well as a complete 
outage history.

To view outage information from within the Inventory Management 
application:

1 Click Inventory Management in the system administrator’s home menu.
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The Inventory Management menu displays.

Figure 8-11: Inventory and Configuration Management menu

2 Click Assets in the Assets tab of the Inventory Management menu. 
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A blank device record form displays.

Figure 8-12: Device record search form

3 Enter the name of the device whose record you want to view in the Asset field.

4 Click Search or press Enter. 
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The complete device record, indicating a current outage, displays. The fields 
displayed change according to the device.

Figure 8-13: Device record

Note: If the System Down? check box is selected, the device is currently 
experiencing an outage.

5 Scroll the tabs to the right to show additional tabs, using the directional 
button.

6 Select the Outage History tab. The outage history of the selected device 
displays.
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Tracking performance 
The Options menu provides access to SLA definitions and metrics from 
within Inventory Management. 

To access SLA definitions and metrics:

1 Click Inventory Management in the system administrator’s home menu.

The Inventory Management menu displays. 

2 Click SLA Information in the Assets tab of the Inventory Management 
menu. The SLA search form displays.

Figure 8-14: SLA search form

3 Enter search information and click Search or press Enter to display an SLA 
record list. The first record in the list displays in the SLA form.
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4 Click the SLA record in the list that you want to view.

Figure 8-15: SLA record

5 Choose Options>View Monthly Outages. 
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A breakdown of outages for the selected SLA for the current month displays.

Figure 8-16: Outage record for a selected SLA

6 Click Back to return to the SLA record.

7 Select Options>View Current Availability. 
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A graph showing the current availability of all the devices covered by this SLA 
displays.

Figure 8-17: Graph of device availability

8 Click Back to return to the SLA record.

9 Choose Options>View Current Response Metrics. 
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The response metrics for a single SLA display.

Figure 8-18: Graph of SLA response metrics

10 Click Back to return to the SLA record.

11 Choose Options>View Monthly Availability. 
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The monthly availability record for a single SLA displays.

Figure 8-19: Graph of SLA monthly availability 

12 Click Back to return to the SLA record.

13 Select Options>View Monthly Response.
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The monthly response metrics record for a single SLA displays.

.

Figure 8-20: Graph of SLA monthly response metrics

14 Click Back to return to the SLA record, or click Return to return to the 
Inventory Management Menu. 
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9
 Root Cause Analysis
Root Cause Analysis helps you to identify the underlying or “root” cause of 
an incident, and initiate steps to correct that Root Cause with a permanent 
solution. When the underlying issue has been found, a Known Error record 
is created to document the solution for future use. Known errors are then 
used to initiate the Change Management process. This chapter describes how 
to use Service Center’s Root Cause Analysis module. 

Root Cause Analysis locates and finds solutions to repeated incidents within 
the IT infrastructure. To learn more about ITIL standards, see the 
Introduction and Best Practices Guide.

See the following for details and discussion about:

The Goals of Root Cause Analysis (RCA) on page 378

Root Cause Analysis (RCA) and Incident Management on page 379

How Root Cause Analysis Works on page 380

Root Cause Analysis Flow on page 381

Access Root Cause Analysis (RCA) on page 382

Root Cause Records on page 388

Root Cause Options on page 395

Search Root Cause Analysis on page 401
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The following terms are used throughout the chapter:

Incident—a call to the service desk that was not immediately resolved and 
for which an incident ticket has been issued.

Issue—a specific problem that may, or may not, have a set of related 
incidents.

Known Error—an issue for which the root cause has been diagnosed, and 
a solution or work-around has been determined.

Root Cause—the underlying cause of an issue for one or more incidents.

The Goals of Root Cause Analysis (RCA)

The main goal of Root Cause Analysis (RCA) is to minimize the effects of 
system down time or lost productivity caused by errors in the IT 
infrastructure, and to prevent their recurrence. RCA functions both 
reactively and proactively. It is reactive in that it is used to resolve situations 
related to incidents. It is proactive in that it is used to identify issues and solve 
the underlying causes of those issues and known errors, before incidents 
occur. 

By taking action to prevent incidents, rather than just reacting to them, an 
organization provides better service, is more efficient, and saves time and 
money.

The Goals of Root Cause Analysis are:

To find errors in the IT infrastructure, record them, track their history, 
find resolutions for them, and prevent their recurrence.

To record resolutions so that they are quickly and easily available to 
support, training, and documentation personnel.

To find needs for improvements in training or documentation, and make 
the data to fix them easily accessible.

To reactively resolve situations related to incidents

To proactively identify issues and solve the underlying causes of those 
issues and known errors, before incidents occur.
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Root Cause Analysis (RCA) and Incident Management

The main goal of Incident Management is to get the customer up and 
running quickly. This is often done through a work-around, rather than 
through a permanent solution. 

The main goal of RCA is to find the underlying cause and a permanent 
solution that prevents future incidents. This takes more time initially, but 
causes service to improve over time.

Root Cause Analysis is related to Incident Management in several ways.

Root Cause records can be opened from Incident Tickets. 

Details and histories included in Incident records are used for analysis 
purposes. RCA cannot function effectively without those details.

Incident records are linked with RCA records.

The knowledge base that is built and maintained in RCA supplies 
solutions for Incident tickets.

Life Cycle of a Root Cause Record
If an Incident ticket pertains to a recurring issue, the help desk opens a Root 
Cause record. The life cycle of a Root Cause record is as follows:

1 A user creates a Root Cause record. (This can be done when opening an 
Incident ticket.)

2 RCA takes Root Cause details from the Incident ticket, configuration details 
from Inventory Management, any known workarounds from other sources 
and adds them to the record.

3 Users save gathered information and solutions in the RC record.

If the incident has not been resolved, the Root Cause (RC) is updated.

When a work-around or solution for a Root Cause or issue has been 
found, RCA generates a Known Error.

If a solution has been found, RCA generates a Request for Change and 
closes the record.

4 RCA updates related Root Cause and Known Error records.

5 After generation, Known Errors must be permanently resolved through 
Change Management.
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How Root Cause Analysis Works

The Root Cause Analysis lets you view related incidents and Known Error 
records from within the module. These associated records can be selected 
and opened directly from the list view.

Root Cause records are assigned categories to help classify the information 
being stored. For example, a Root Cause record describing a server stores 
different information than a Root Cause record for a printer. 

The appropriate personnel can escalate and reassign Root Cause records. The 
system can also automatically issue alerts and escalate a Root Cause that is 
not getting resolved. 

Root Cause records can be:

Opened for any incident reported.

Sent automatically to the proper system personnel.

Tracked and resolved by the personnel and system managers.

Sent by e-mail or fax to the user with a resolution to the reported Root 
Cause.
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Root Cause Analysis Flow

This workflow can be changed by modifying ServiceCenter scripts to meet 
your business process flow.

Root Cause Analysis

Service Desk Call
Can Incident

be immediately
resolved?

Resolve IncidentYes

Create Incident ticket

Match
in Known Error

database?

No

Match
in RCA

database?
Yes

No

Open new RCA

Yes
Give workaround or

solution
to customer

Update Incident ticket
with Known

Error ID

Update Known Error
ticket with Incident

count

Is further work
required?

Check for problem
resolution in Know

Error database.

Yes

No

Yes

No

Implement solution

Is further work
required?

Update Incident ticket
with Classification Data

Update Incident ticket
with RCA ID

Update RCA ticket with
Incident count

Check for problem
resolution in RCA

database.

Update Incident ticket
with Classification Data

RCA team works
on solution

No

Add solution to
Known Error or RCA

Give solution to
customer
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Access Root Cause Analysis (RCA)

Root Cause can be accessed from the System Administrator’s home menu, or 
from any ServiceCenter Application queue, including Service Management, 
Incident Management, Change Management, and Request Management. 

You can access Root Cause Analysis for administrative purposes from the 
Central Administration Utilities menu, or from the Root Cause section of the 
System Administrator’s home menu. 

The Central Administration Utilities menu allows a system administrator to 
access the operator’s record for user and contact information, application 
profile privileges and the Mandanten utility. This allows the administrator to 
control and access several users or a group’s access from one central location, 
rather than having to control access from within each application or utility.

To learn more about Central Administration Utilities, see the System 
Administrator’s Guide.

Access Root Cause from the System Administrator’s Home Menu
The System Administrator’s home menu allows you to access the Root Cause 
Analysis home menu. The buttons on the Root Cause Analysis menu allow 
you to open new Root Cause records, access existing records, search Root 
Causes and the Knowledge base, as well as configure the module. 
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To access Root Cause Analysis from the System Administrator’s home 
menu:

Open the System Administrator’s Home menu and click Root Cause 
Analysis.

Figure 9-1: Root Cause Menu

Root Cause Menu
The Root Cause menu allows you to Open a new Root Cause, View the Root 
Cause Queue, Search the Root Cause database, Administer Security Profiles 
and Search the Knowledge base. 

To open a new Root Cause, click Open New Root Cause. For more 
information on opening a new Root Cause, see Open a Root Cause Record 
on page 391.

To search the Root Cause database, click Search Root Causes. For more 
information on searching the Root Cause database, see Search Root Cause 
Analysis on page 401. 
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To access the Root Cause Queue, click Root Cause Queue. For more 
information on the Root Cause Queue, see Root Cause Queue on page 385.

To administer Security Files, click Security Files. For more information on 
administering security files, see the Application Administration Guide. 

To search the Knowledge base, click Search Knowledge base. For more 
information on searching the Knowledge base, see Knowledge Base - 
Diagnostic Aids on page 561.

Access Root Cause Analysis from Other ServiceCenter Applications
Most user interaction in Root Cause Analysis takes place in the Root Cause 

Queue. From the Root Cause Queue, you can open, update, and close Root 
Cause records. 

You can access the Root Cause queue from any ServiceCenter application 
that has the Root Cause List button on its queue screen. These include 
Service Management, Incident Management, Change Management, and 
Request Management.

Note: You can also access the Root Cause queue by choosing 
Options>Related>Root Causes in the above-mentioned 
ServiceCenter applications.

For this example, we access the Root Cause Inbox from Incident 
Management, but the same instructions apply to the other applications.

To access the Root Cause Queue:

1 Open the Incident Queue. For instructions on how to open the Incident 
Queue, see Accessing the Incident List Inbox on page 203.

2 To open the Root Cause Inbox, click Root Cause List. The Root Cause 
Analysis inbox displays. 
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Root Cause Queue
From the Root Cause Queue, you can open a new Root Cause, search the 
Root Cause database, and view and edit existing Root Cause records.

To open a new Root Cause, click New. For more information on opening 
a new Root Cause, see Open a Root Cause Record on page 391.

To search the Root Cause database, click Search. For more information on 
searching the Root Cause database, see Search Root Cause Analysis on 
page 401. 

To view or edit a record in the Root Cause list, double-click the line item. 
For more information on using the Root Cause Queue, see Root Cause 
Queue on page 385.

Root Cause Queue Buttons
Each of the ServiceCenter queues contains a series of buttons, providing 
quick access to other ServiceCenter applications and queues. The application 
opened with a button displays if you place your pointer (mouse) over that 
button. The buttons are the same in each queue, except for a few that are 
specific to the application.
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Root Cause Options Menu
The Root Cause Options menu provides shortcuts to other ServiceCenter 
applications, and access to Root Cause Analysis, Search, and Root Cause 
functions. When you are in Root Cause, the Options menu contains:

Option Description

Select Queue Brings up a dialog box and gives you the opportunity to 
change the queue you are in. Make your selection, and then 
click OK.

Switch Queue Allows you to switch to a different application queue. The 
following selections are available.

Inventory Management—accesses Inventory Management.
Quote List—accesses the current user’s Quote List (Request 
Management inbox).
Order List—accesses the current user’s Order List (Request 
Management inbox).
Line Item List—accesses the current user’s Line Item List 
(Request Management inbox).
Call List—accesses the current user’s Call List (Service 
Management inbox).
Incident List—accesses the current user’s Incident List 
(Incident Management inbox).
Change List—accesses the current user’s Change List 
(Change Management inbox).
Task List—accesses the current user’s Task List (Change 
Management inbox).

New Accesses a new Root Cause record form.

Search Accesses the Root Cause Analysis search function.

Refresh Updates the current list.

Switch Inbox Displays a dialog window to select another inbox. Functions 
the same as the Switch Inbox button.

Edit Favorite 
Inboxes

Edit your favorites list to add or modify your most frequently 
accessed inboxes.

Use Stored Query Access a QBE list of stored queries.

Starting Lists Displays the initial Call List.

Count Tallies the number of records in the Call List.
386 Chapter 9—Root Cause Analysis 



User’s Guide
Root Cause List Options Menu
The List Options menu is available when a QBE Record list displays.

List Option Description

Modify Columns Displays a dialog box where you can change the fields that 
determine the column headings of the QBE Record list.

Export to Excel Exports the current Root Cause List to a Microsoft® Excel 
spreadsheet. Excel is opened automatically and the list is 
placed in the spreadsheet. Basically, you can export 
information to any product that has DDE (Dynamic Data 
Exchange) support. This DDE function requires Excel 95 or 
later.

Export to Text File Exports the current Root Cause List to a text file. Enter the 
path and file name of the text file you want to be used. If no 
path is specified, the file is created in the directory the 
Service Center Client was launched from. This option is not 
part of the DDE support and can be run from clients other 
than those operating in Windows. 
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Root Cause Records

This section describes how to open, update, and close Root Cause Records. 
The following is discussed.

Priority on page 388.

Root Cause Record Fields on page 389.

General tab on page 389.

Description tab on page 390.

Root Cause tab on page 390.

History tab on page 391.

Open a Root Cause Record on page 391.

Update a Root Cause Record on page 393.

Close Root Cause Records and Known Errors on page 394.

Paging
As Root Cause tickets are updated and closed, a new record (or page) is 
created for each ticket. New records, also called pages, are created by the Root 
Cause Analysis paging feature. To read about enabling and disabling paging, 
see the discussion in the ServiceCenter System Administrator’s Guide. When 
a Root Cause ticket is accessed, the most recent page (or record) is displayed.

Priority
The priority of a Root Cause record indicates the severity of the root cause, 
so it is critical that the correct priority be set according to the severity of a 
known error for each root cause. Priorities are set by the user when a Root 
Cause record is opened. The priority of a ticket can be changed by the user as 
a Root Cause (RC) ticket gets updated. 

The priority of an RC is determined by its impact and urgency, meaning the 
potential for damage to the IT infrastructure of the company. This potential 
must be addressed for all RCs. When determining the impact of an RC, pay 
attention to the following: 

volume of incidents

number of customers impacted
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cost to the business

duration and cost of the resolution

Urgency refers to the time available to reduce the impact. RCs are less urgent 
if a temporary fix or work-around is available, or if delayed resolution is 
planned.

Root Cause Record Fields
It is not necessary that you fill in all the fields in a new Root Cause record. 
Some fields are automatically filled in by ServiceCenter, and some is filled in 
during later updates.

General tab
The General tab allows the user to enter information about the issue and any 
related incidents.

Field Description

Root Cause ID A unique Root Cause record number is automatically assigned 
by ServiceCenter.

Category Classify asset’s category within the business, such as network.

Subcategory Classify asset’s subcategory within the primary category, such 
as lan.

Problem Type Type of problem being reported. If the Company field is filled 
in first, then this is filled in automatically.

Product Type Device product type. If the Company field is filled in first, then 
this is filled in automatically.

Company Name of the company reporting the issue. 

Note: Filling in the Company information first helps the auto 
fill to work for the Problem Type and Product Type fields.

Asset ID Device having the problem.

Type Type of device. If you selected the Asset ID from the browse 
list, this is auto-filled.

Model Device model. If you selected the Asset ID from the browse list, 
this is auto-filled.

Critical Asset Primary asset involved.
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Description tab

Root Cause tab
The Root Cause tab is where you enter the Root Cause, once determined. 

Status Status of the Root Cause record.

Open—ticket currently active.

Closed—ticket resolved.

Reopened—ticket currently active - was closed previously.

Severity Severity of the issue reported.

Priority Priority of the Root Cause record. If you selected the Asset ID 
from the browse list, this is auto-filled. The priority is entered 
in the Priority Code field of the initial Root Cause form:

Major
Medium
Low
Very Low

Assignment 
Group

Group assigned to work on the issue.

Assignee Designated person to work on the issue.

Owner The person responsible for the ticket and the person to be 
contacted when the issue is resolved.

Field Description

Brief Description Brief (one line) description of the related incident or issue, or 
other identifying information.

Description Full description of the related incident or problem, including 
all new information from updates.

Updates Updates made since the Root Cause record was initiated. 
(Only available on an existing record.)

Field Description

Root Cause True cause of the issue or problem described in the 
Description field is entered here, once it has been found. 

Work-Around Solution used to resolve an issue.

Field Description
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History tab
The History tab contains the history of the Root Cause. The History tab is not 
editable. It contains only system stamped fields, indicating the activity date 
and time, and by whom.

Related Records tab

Open a Root Cause Record
Root Cause records can be opened from the Root Cause menu, from the 
Incident Queue, or from the List Options menu when an existing Root Cause 
record is open. 

To open a new Root Cause record:

1 Open the Root Cause Queue, the Root Cause Menu, or an existing Root 
Cause record. 

2 Click Open New Root Cause (on the Root Cause Menu and the Root Cause 
Inbox).

For instructions on how to open the Root Cause Inbox, see Access Root Cause 
Analysis from Other ServiceCenter Applications on page 384.

For instructions on how to open the Root Cause menu, see Access Root Cause 
from the System Administrator’s Home Menu on page 382.

-or-

If you are already in an existing Root Cause record, open the List Options 
menu and click New. 

Field Description

Opened Date record was opened.

Last Updated Date record was last updated.

Closed Date record was closed.

Re-Opened By Date record was re-opened.

Field Description

Incidents Lists all incidents related to this Root Cause record, giving 
you access to open the related incident tickets.

Changes Lists all changes related to this Root Cause record, giving you 
access to open the related change tickets.
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For instructions on Editing an existing Root Cause record, see Update a Root 
Cause Record on page 393. 

3 A Root Cause record open form displays with the Root Cause record number 
automatically assigned by ServiceCenter.

Figure 9-2: Root Cause Open

4 Select the appropriate owner from the Owner fill (ellipsis) box.

5 The Status field automatically reports this ticket at an Open status.

6 Enter a one line description of the related incident or problem, or other 
identifying information in the Brief Description field.

7 On the General tab, select the Asset ID from the Asset ID fill (ellipsis) box. 
This causes the Type, Model & Priority fields to be filled automatically. 
Check for accuracy.

8 Select a category from the Category drop-down list

9 Enter a full explanation of the issue or problem in the Description box.

10 Enter other information you have about the Root Cause in the other fields.

11 Click Save.
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Update a Root Cause Record
To update an existing Root Cause record:

1 If you are in one of the ServiceCenter applications, click Root Cause List to 
access the Root Cause Analysis Queue for the option to access the RCA.

-or-

If you are logged in as an administrator, click Search Root Causes on the 
System Administrator home menu to access a search form.

2 Find the Root Cause record you want to update:

a Double-click on the desired Root Cause in the Root Cause Analysis list.

b Use the search function to locate the Root Cause record. Refer to Search 
Root Cause Analysis on page 401.

If you know the ticket number, enter that number in the Number field. 
If you have Smart Search selected, you need only enter the number. If 
you do not have Smart Search activated, you must enter the Root Cause 
record prefix (RC), for example, RC109.

If you do not know the number, enter any information you know about 
the ticket in the appropriate fields. This narrows the search parameters 
for the ticket.

3 Modify any fields that require updating in the Root Cause General 
description tab.

For example, you could change the Priority of the Root Cause if it has 
changed since the Root Cause was first reported. Click the Arrow or arrow 
keys to choose a new setting.

4 Enter any new information about the root cause under Brief Description 
field.

5 If the true cause of the issue or problem has been found, click the Root Cause 
tab, and enter the cause, a work-around, and the solution in the Root Cause 
box, and close the ticket. (For more information, see Close Root Cause 
Records and Known Errors on page 394).

6 Click Save to save and remain in the ticket, or click OK or press F2 to save 
and be returned to the queue.

A message displays in the status bar stating Root Cause RCxxx has been 
updated.
Root Cause Records  393



ServiceCenter
Close Root Cause Records and Known Errors
When a work-around for a Root Cause has been discovered, the record can 
be closed. This does not delete the record from the file, but can change the 
record to a Known Error. The Known Error is then closed when a permanent 
solution to the problem is found. 

To close a Root Cause record:

1 Access the Root Cause record you want to close by:

Double-clicking on the desired root cause in the Root Cause list.

Using the search function to locate the Root Cause record.

If you know the ticket number, enter that number in the Number field. If 
you have Smart Search selected, you need only enter the number. If you 
do not have Smart Search activated, you must enter the Root Cause record 
prefix (RC), for example, RC109.

If you do not know the number, enter any information you know about 
the ticket in the appropriate fields. This narrows the search parameters for 
the ticket.

2 Click the Root Cause tab and enter the work-around in the Root Cause box. 
Enter the permanent solution or the true cause of the issue or problem as 
well, if known.

3 Click Close, or press F6, to close the Root Cause.

4 Click Save.

5 A dialog box displays with a question that asks if you want to open a Known 
Error for this root cause. If the root cause is a problem with the 
infrastructure, click Yes. If the root cause is procedural, click No. If you click 
yes, the root cause is flagged as a Known Error for future reference. You are 
returned to the Root Cause form. 

The label on the form, in the upper left part of the form, is now Known Error 
rather than Root Cause. 
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To close a Known Error:

1 Access the Known Error ticket you want to close by:

Double-clicking on the desired Known Error in the Root Cause List.

Using the search function to locate the Known Error ticket.

If you know the ticket number, enter that number in the Number field. If 
you have Smart Search selected, you need only enter the number. If you 
do not have Smart Search activated, you must enter the Root Cause record 
prefix (RC), for example, RC109.

If you do not know the number, enter any information you know about 
the ticket in the appropriate fields. This narrows the search parameters for 
the ticket.

2 Click the Root Cause tab and enter the permanent solution and the true 
cause of the problem.

3 Click Close, or press F6, to close the known error.

4 If you want to open a Request for Change.

a Click Options>Related>Changes>Open. 

b Select RFC or RFC - Advanced from the category list.

c Fill out the form. For more information on RFCs, see Using Change 
Management on page 419. 

5 Save the Change and click OK to return to the Root Cause form.

Root Cause Options

This section explains the Root Cause Options menus. It is divided into the 
following parts. 

Options Menu—New Root Cause Record on page 396

List Options Menu—Existing Root Cause Record on page 397

Set a Reminder on page 398

Related Records on page 399

Associating Records on page 399

Opening a Related Record on page 400

Viewing Associated Records on page 400
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Options Menu—New Root Cause Record 
The Options menu changes depending on what form is visible. In some cases, 
more than one Options menu is visible. When you are opening a new Root 
Cause record, the Options menu contains these options:

Options Menu—Existing Root Cause Record
When you are updating an existing Root Cause record, the Options menu 
contains the following options (similar to the call report options.) Some of 
these options are described in more detail in other sections.

Field Description

Set Reminder Allows you to set up a reminder to be sent to you at a specified 
time through e-mail, a page, or a pop-up message. This option 
is discussed in detail in Set a Reminder on page 398. 

Clone Copies the current Root Cause record and places the data in a 
new Root Cause record.

Find Solution Accesses the Knowledge Base to search for possible solutions 
to the Root Cause. See Knowledge Base - Diagnostic Aids on 
page 561 for more information.

Field Description

Set Reminder Allows you to set up a reminder to be sent to you at a 
specified time through e-mail, a page, or a pop-up 
message. This option is discussed in detail in Set a 
Reminder on page 398. 

Print Record Prints this Root Cause record to the user’s default 
ServiceCenter printer.

Clone Copies the current Root Cause record and places the 
data in a new Root Cause record.

Related>Incidents 
>Associate

Allows you to associate this Root Cause record to an 
Incident ticket. This option is discussed in detail in 
Related Records on page 399.

Related>Incidents>View Allows you to view the associated Incident ticket. This 
option is discussed in detail in Related Records on 
page 399.

Related>Incidents>Open Allows you to open the associated Incident ticket. This 
option is discussed in detail in Related Records on 
page 399.
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List Options Menu—Existing Root Cause Record
When you are updating an existing Root Cause record and are using Record 
List mode, the List Options menu is visible. (The same options are available 
from the Options menu if you are viewing a QBE list and do not have Record 
List mode active.) The List Options menu contains the following options. 

Related>Changes 
>Associate

Allows you to associate this Root Cause record to a 
Change Request. This option is discussed in detail in 
Related Records on page 399.

Related>Changes>View Allows you view the associated Change Request. This 
option is discussed in detail in Related Records on 
page 399.

Related>Changes>Open Allows you to open the associated Change Request. 
This option is discussed in detail in Related Records on 
page 399.

Field Description

Field Description

Count Counts the number of records in the current QBE Record 
list.

Print List Allows you to print a copy of the current QBE Record list.

Refresh List updates the current list.

Save List as Inbox Allows you to save the current list as an inbox.

Modify Columns Displays a dialog box where you can change the fields that 
determine the column headings of the QBE Record list.

Export to Excel Exports the current QBE Record list to a Microsoft Excel 
spreadsheet. Excel automatically opens with the list placed in 
a spreadsheet. Basically, you can export information to any 
product that has DDE (Dynamic Data Exchange) support. 
This DDE function requires Excel 95 or later.

Export to Text File Exports the QBE Record list to a text file. Enter the path and 
file name of the text file you want to be used. If no path is 
specified, the file is created in the directory the Service Center 
Client was launched from. This option is not part of the DDE 
support and can be run from clients other than those 
operating in Windows.

New Displays a blank form for opening a new Root Cause record.
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Set a Reminder
From a new or existing Root Cause record, you can schedule a reminder to 
be sent to you at a specified time.

To access the Set Reminder feature:

1 With an existing Root Cause record displayed, choose Options>Set 
Reminder.

The Set Reminder form displays.

2 There are two options for setting the time when the reminder occurs.

a Select Remind At to set a reminder for a particular day and time.

b Select Remind In to set the reminder to occur at a particular interval. This 
options brings up two fields; enter the time interval, and select the shift 
you are working from the drop-down list.

3 Click Fill to bring up the ServiceCenter Calendar. You can use the calendar 
to select the date and time you want the reminder to occur. 

a Enter the time in the Time field. Click on the day you want the reminder 
to occur. The dialog box closes and the information is filled into the 
Remind At field. 

b To move forward or backward, click the Arrow buttons at each side of the 
month and year. 

c To return to today’s date, click Goto Today.

d To go to a specific date, click Select Date and type the date in the dialog 
box displayed. Click OK to accept the entry and return to the Calendar. 
Clicking the back arrow returns you to the Calendar with no change

4 In the Remind if field, select an option from the drop-down list:

Always (the default).

Root Cause has not been updated.

Root Cause is still open.

Root Cause is still assigned to me.

5 In the Pop-up Message area, select the type of notification:

Pop-up

Page

Email

SCMail
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If you select Pop-up or Page, type the message in the Message field that you 
want to display in the reminder.

Choosing Email or SCMail displays two Message Type option buttons. Select 
the type of e-mail message you want sent. There is also a Title field where you 
can enter a title for the e-mail message.

6 Select the type of e-mail you want sent:

Send Record. This option includes a copy of the Root Cause record in the 
e-mail.

Fixed Text. This option displays a field in which you can type the message 
you want to display in the e-mail message.

7 When you have made all your selections, click OK.

The initial Root Cause record from which you set the reminder displays.

Related Records
The Options menu allows you to create an association between existing 
records, view a list of associated records, and open new associated records. 
The Root Cause records Options menu allows you to work with Incident 
tickets; the Known Errors Options menu allows you work with Change 
records as well as Incident tickets.

Associating Records
Root Cause records can be associated with Incident tickets, and Known 
Errors can be associated with Incident tickets and with Change records.

Before associating a Root Cause record with another record, make note of the 
ID number of the Incident you want to relate it too. You need to enter this 
number in the following process.

In the following example, we associate a Root Cause with an Incident. The 
procedure is the same for associating other types of records.

To associate a ticket with another record:

1 Access the Root Cause record.

2 Choose Options>Related>Incident>Associate.

A dialog box displays with the following question: 

Associate Root Cause RCxxxx with which Incident?
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3 Type the Incident ID number. Type the number in the form of IMxxx, where 
xx is the incident number.

-or-

Click Search to select a RCA record and enter the number after selection.

4 Click OK. A confirmation message displays in the status bar.

Opening a Related Record
You can open an Incident ticket from a Root Cause record. You can open 
Incident tickets and Change records from a Known Error.

In the following example, we open a Change from a Known Error. The 
procedure is the same for opening other types of records.

To open a related record:

1 Open an existing Known Error. Refer to Search Procedures on page 401 for 
help in accessing an existing Known Error.

2 Choose Options>Related>Change>Open.

3 The Change Select Category form displays. Select Request for Change and fill 
out the form. For more information on RFCs, see Using Change Management 
on page 419.

4 Save the related record. Click OK. You are returned to the initial Known 
Error record.

Viewing Associated Records
You can view and edit an Incident ticket from a Root Cause record. You can 
view and edit Incident tickets and Change records from a Known Error. 

In the following example, we view an Incident from a Known Error. The 
procedure is the same for associating other types of records.

To view an associated record:

1 Open an existing known error. For help in accessing an existing known error, 
refer to Search Procedures on page 401.

2 Choose Options>Related>Incident>View. 

A list of related Incidents displays.

3 Double-click on an Incident to view the details. The ticket opens. You can 
edit the Incident ticket from here, as well as resolve the ticket.
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Search Root Cause Analysis

This sections describes how to search the Root Cause database. It is divided 
into the following parts. 

Search Procedures on page 401

Root Cause Record Search Fields on page 403

Basic Search tab on page 403

Advanced Search tab on page 404

IR Search tab on page 406

Search Procedures
Root Cause Analysis allows you to search for Root Cause record records. The 
records are displayed in a Root Cause List. You can also save these queries as 
inboxes. Inboxes are discussed in Using Inboxes on page 82. The search form 
fields allow you to narrow the search parameters. The procedures for 
searching in Root Cause Analysis are discussed in Search Procedures on 
page 401.

Three types of searching are available for the Root Cause database. They are 
the Basic Search, Advanced Search, and IR Search. Use Basic Search to search 
for RCA records by various key criteria. Use Advanced Search to search for 
records opened, updated, or closed within a certain time frame. Use IR 
Search to search for text within records. 

To search for Root Cause records:

1 Click Root Cause Analysis (or Queue).

The Root Cause record queue displays.

2 Click Search.

A Search form displays.
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3 Enter any Basic Search information you know. The more information you 
enter, the narrower the search parameters. For more information on filling 
the basic search tab, see Basic Search tab on page 403. You can leave any or all 
fields blank. For fastest searching, use the fields identified as key (indexed) 
fields at your site. If these are not clearly identified on the form, ask your 
ServiceCenter administrator for a list of key fields.

Use one of the following options to fill in the fields:

Type known information. 

Click Fill, or press F9, to access a QBE list.

Click the Arrow to access a drop-down list, or press the Down arrow to 
toggle through the selections.

4 Click the Advanced Search tab to further narrow the search parameters. 
Advanced search fields allow you to narrow the time frame when a record 
was opened or updated. You can also enter the name of the operator who 
opened or updated the report. These fields are independent of each other and 
can remain blank. For fastest searching, use the fields identified as key 
(indexed) fields at your site. If these are not clearly identified on the form, ask 
your ServiceCenter administrator for a list of key fields.For more 
information on the filling the advanced search tab, see Advanced Search tab 
on page 404

To fill in these fields, do one of the following: Type known information, click 
the Arrow, or press the Down arrow to access a drop-down list.

5 To further narrow the search parameters, click the IR Search tab.   For more 
information on the filling the IR Search tab, see IR Search tab on page 406

6 Enter a plain text description in the IR Search Text field.

7 Click Search, or press F6.

The matching record displays.

If multiple records match the search parameters, a QBE Record list displays 
with the first record in the list displayed in the Root Cause record form. Click 
on a record in the list to display it in the Root Cause record form.

8 If a message is returned stating No Records Found, broaden the search by 
eliminating some of the search parameters that you entered.

You can sort a QBE Record list by clicking the column header of the area by 
which you want to sort the list. For example, to sort the list by status, click 
Status.
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Root Cause Record Search Fields
The Root Cause record search information displays in three tabs: Basic 
Search, Advanced Search, and IR Search. The tabs are described below.

Basic Search tab
You can leave any or all of the fields in this tab blank. Most of the fields have 
Arrow or Fill buttons which allow you to select from a drop-down list or QBE 
list.

Field Description

Root Cause ID Type the Root Cause record number, if you know it, in the 
form of RCxx, where xx is the number. (See the Smart Search 
definition below.) You can enter a partial number to access a 
QBE list of possible records. To do this, first deselect the 
Smart Search check box. For example, if you enter RC2, you 
would get a list of all Root Cause record numbers starting 
with 2: RC2, RC20, RC21, and so forth. Wildcards (for 
example, *) cannot be used.

Smart Search? Allows searches for tickets by number only (prefixes or 
suffixes, such as RC, are omitted). Smart Searches return the 
ticket requested regardless of its state (such as, open or 
closed). If any settings on the search form other than the 
default are entered, a normal query is performed and the 
Smart Search feature is ignored.

Device Select or enter the device type.

Category Select the Root Cause Analysis category 

Assignment Select the assignment group responsible for the ticket or 
tickets.

Status Select the status to search for.

Priority Select the priority to search for.

Severity Select the severity to search for.

Open Mark this button to search for records that are currently 
open.

Closed Mark this button to search for records that are currently 
closed

Either Mark this button to search for records that are either open or 
closed.

Root Causes Mark this button to search for Root Cause records only.
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Advanced Search tab
Any or all of the fields in this tab can be left blank.

Opened

Known Errors Mark this button to search for Known Error records only.

Either Mark this button to search for both Root Cause and Known 
Error records.

Field Description

Opened After Enter the date and time (optional) the report was Opened After. 
The format is mm/dd/yyyy hh:mm:ss. If a time is not entered, 
the default is 00:00:00. The date and time format can be set by 
your system administrator in the System Wide Company 
Record or in individual operator records. Therefore, the date 
and time format you use may vary from the default shown 
above.

And Before Enter the date and time (optional) the report was Opened 
Before. The format is mm/dd/yyyy hh:mm:ss. If a time is not 
entered, the default is 00:00:00. 

By Enter the name of the Root Cause Analysis operator who 
Opened the Root Cause record. You can type the name, or you 
can use the Arrow button or Down arrow to access a drop-down 
list.

Field Description
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Last Updated

Closed

Field Description

Last updated After Enter the date and time (optional) the report was Updated, 
After. The format is mm/dd/yyyy hh:mm:ss. If a time is not 
entered, the default is 00:00:00. The date and time format 
can be set by your system administrator in the System Wide 
Company Record or in individual operator records. 
Therefore, the date and time format you use may vary from 
the default shown above.

And Before Enter the date and time (optional) the report was Updated 
Before. The format is mm/dd/yyyy hh:mm:ss. If a time is not 
entered, the default is 00:00:00.   

By Enter the name of the Root Cause Analysis operator who 
Updated the Root Cause record. You can type the name, or 
you can use the Arrow or Down arrow to access a 
drop-down list

Field Description

Closed After Enter the date and time (optional) the report was Closed After. 
The format is mm/dd/yyyy hh:mm:ss. If a time is not entered, 
the default is 00:00:00. The date and time format can be set by 
your system administrator in the System Wide Company 
Record or in individual operator records. Therefore, the date 
and time format you use may vary from the default shown 
above.

And Before Enter the date and time (optional) the report was Closed 
Before. The format is mm/dd/yyyy hh:mm:ss. If a time is not 
entered, the default is 00:00:00.   

By Enter the name of the Root Cause Analysis operator who 
Closed the Root Cause record. You can type the name, or you 
can use the Arrow or Down arrow to access a drop-down list.
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IR Search tab

Field Description

IR Search Text Enter plain text here.

Discovery Option Designate which kind of search you want:

Complete Match—The system searches for an absolute 
match to the text you have typed.
Shallow—The system searches using narrower 
parameters and returns fewer records than with a deep 
search.
Deep—The system performs a broad search. Try using a 
deep search if a shallow search does not return the desired 
records.
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10
 Change Management
ServiceCenter’s Change Management (CM) provides the process for 
requesting, managing, approving, and controlling changes that modify your 
organization’s infrastructure, including assets, such as your network 
environment, facilities, telephony, and resources. Change Management 
automates the approval process and eliminates the need for continuous 
memos, e-mail, and phone calls.

This chapter has been divided into the following sections:

Overview on page 408

Elements of Change Management on page 412

Need for Change Management on page 415

Workflow on page 415

Changes and Tasks on page 418

Using Change Management on page 419

Open a Change on page 427

Approving a Change or Task Phase on page 446

Request for Change (RFC) Category on page 456

RFC Phases on page 458

Assessment Phase on page 459

Building Phase on page 471

Testing Phase on page 474

Implementation Phase on page 477
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Request for Change (RFC) - Advanced Category on page 482

RFC - Advanced Phases on page 484

Open a Call on page 484

Assessment (Assess) Phase on page 493

Plan Phase on page 497

Build Phase on page 509

Implement Phase on page 514

This list is described in greater detail in the following section.

Overview

If you find yourself asking when you should use Change Management versus 
Request Management, here are some guidelines.

Change Management is designed to handle any change to your business 
environment that modifies or disrupts the current state of that 
environment. Usually these modifications or disruptions affect multiple 
users or business units. 

Request Management is designed to handle common user requests for 
products and services. These requests usually affect only the person 
making the request or a small group of people for which the requestor is 
responsible.

The Change Management functions available to you depend on your 
Operator record user type. 

ServiceCenter is shipped with the following user types and Change 
Management access capabilities.

Help desk operators can submit and approve changes.

Technicians can update tasks. 

Managers can create and approve tasks and changes. 

System administrators have full functionality.

Example: If your server hard drive is running out of space, you can submit a 
change request, outlining the need for a larger hard drive. The change is 
routed to the proper personnel for approval and action.
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This chapter provides:

Elements of Change Management on page 412, which provides a summary 
of the components of Change Management, including:

Changes on page 412.

Categories on page 412.

Phases on page 413.

Tasks on page 413.

Approvals on page 414.

Alerts and Messaging on page 415.

Instructions on how to open a change.

Instructions on how to approve a change.

This chapter also includes procedures for:

Opening a Task Record on page 439.

Setting a Reminder on page 438.

Request for Change (RFC) Category on page 456.

Request for Change (RFC) - Advanced Category on page 482.

Other features.
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Glossary
The following terms are used in Change Management:

Term Definition

Alerts A series of checkpoints taken against a change request or 
task to ensure that required work activities occur within 
specified time frames.

Approvals A list of groups or operators who must acknowledge or 
accept the risk, cost, and so on associated with the 
implementation of a change request or task. Approvals give 
controlling authorities the ability to stop work and to 
control when certain work activities can proceed.

Approval sequence The order in which approval requirements are made active. 
The process first makes the lowest sequence numbers 
available for approval activity. Once these are approved, the 
next highest number is made available. Groups with the 
same sequence number can approve in any order.

Category The major logical classification of change requests and tasks. 
The category determines the data to be collected for a 
particular change or task, the forms presented to the user for 
data entry, the approvals needed, and the intervals at which 
alerts are sent. ServiceCenter includes a series of default 
categories, or administrators can create new categories.

Changes Changes are the records submitted seeking the change. The 
change has a life cycle containing approvals, alerts, tasks, 
phases, and closure. Changes are based on categories.

Change number Unique number assigned to a change when it is submitted.

Change owners Required to give a technical approval for the phase to 
proceed.

Change sponsors Required to authorize the change from the customer 
business perspective. If a Change Sponsor does not have 
access to ServiceCenter, Change Administrators (CAs) are 
responsible for ensuring that authorization is obtained from 
the Change Sponsor. CAs must approve the RFC on behalf 
of the Change Sponsor on the ServiceCenter system.

Event The occurrence of a specific detectable action or condition; 
such as the opening of a change request or task, an approval, 
an update, and so on.

Group One or more operators assigned to a common area of 
responsibility. Typically, each group reflects a business or 
technical area (or department).
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Initiator The person who starts the process of a Request for Change.

Master form The form that controls the display of data. It contains 
objects that identify the subforms that are to be displayed. 
The master form name is used to identify the Format 
Control, link, and validity records used.

Phase An administrative step within the change or task that is 
needed to complete the work. Phases are sequential, 
repeatable steps characteristic of a Change category. You 
can approve or close a phase. When you take an action on a 
phase, you can move to the next phase. When a task or 
Change has no more phases, that task or Change can be 
closed.

Profile The security record that defines which options and 
authorities are available to the operator or group using the 
profile.

Projected data Data copied from fields in a model record to identically 
named fields in the newly opened Request record (source).

Subform A form that displays on a master form. It is used to access 
data stored in a structure in the Database Dictionary. No 
Format Control, link, or validity records should be 
associated with a subform.

Task Work processes necessary to complete the change and 
related to the Change. For example, the tasks involved in 
replacing a hard drive with a larger model might include: 
ordering the new drive, backing up the old drive, and 
installing the new drive.

Tasks must belong to a phase of a Change. Work cannot 
proceed to the next phase until all tasks beneath it are 
complete. Task start and end dates, if specified, must fall 
within the start and end dates of the parent change. 

Tasks are classified by categories.

Task number A unique number assigned to a task.

Term Definition
Overview  411



ServiceCenter
Elements of Change Management

Change Management effectively manages change processes, such as upgrades 
to central servers and network or telecommunication system installations, 
for large numbers of users within your organization. The following outlines 
the elements involved in the change process.

Changes
Changes are the records submitted seeking a change. Each change has a life 
cycle containing approvals, alerts, tasks (if required), phases, and closure.

When a change is submitted, Change Management assigns a change number 
that is unique to the change record.

Changes are based on categories.

Note: Before going through the process of a change, you need to create user 
profiles and groups for your ServiceCenter system. For information 
on operator records, user roles, and user profiles, refer to the System 
Administrator’s Guide and the Application Administration Guide.

Categories
Setting up Change Management requires you to customize general Change 
categories, which are used to classify changes and tasks that the system 
handles. Categories are also used to define the phases of a change. A user may 
then enter a change to anything that fits in these categories.

ServiceCenter includes a series of default categories, such as HW server 
(Hardware Server) and MAC (General Purpose Move/Add/Change). 
However, administrators are not limited and can create new categories. Keep 
in mind that the change and task categories must have at least one phase, but 
can have multiple phases.

Important: ServiceCenter’s best practices and work flows introduce two 
Change categories in Change Management: 
RFC and RFC-Advanced.
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The first category, Request for Change (RFC), is based on the ITIL 
standards. Refer to Request for Change (RFC) Category on page 456 for a 
discussion on this specific Change category.

The second category, Request for Change (RFC) - Advanced, is an 
out-of-box model that manages the operational risks and costs of system 
wide changes, such as moving personnel, assets, and systems of a single 
business unit or multiple business units. The RFC - Advanced Change 
category also shares information with other ServiceCenter modules. Refer 
to Request for Change (RFC) - Advanced Category on page 482 for a 
discussion on this out-of-box Change category.

Phases
Phases are groupings of activities, or logically sequential and repeatable steps, 
within an implementation cycle. A phase is an administrative step within the 
change or task, which determines: 

The behavior of a change

Forms to be used for change and task records

Approval and review requirements

Alerts

General system options to be available during a phase

Tasks
Tasks are the work processes necessary to complete the change requests that 
require one or more tasks. For example, to put a new hard drive in your 
network server, the tasks might include ordering the new drive, backing up 
the old drive, and replacing the old drive with the new drive.

In order to assign tasks, tasks must belong to a change.

Note: The tasks must be valid for a change phase. For example, the HW 
deploy task is not available to the Analysis phase of a Change.

Each task must have a start date and an end date within the parameters set in 
the parent change. Tasks can be worked on simultaneously.

Tasks are assigned categories. Tasks can also be divided into phases.
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Approvals
An approval is the verification that the change process can start. Approvals 
allow the phases and the tasks in the phases to proceed. 

For a change to be completed, that change must be approved. If you are 
making a change, you submit the change for Approval. The category and 
phase drive the approvals required which could be one or more Approval 
Groups, individuals or the operator’s manager.

Approval Group
You can also be part of an Approval Group. Approval groups are used for 
setting security and approval functions, and have control over the movement 
of items from one phase to another. An Approval Group consists of a 
member list of reviewers and approvers. If you are a member of an Approval 
Group, your task is either to look over the change (as a reviewer) or to accept 
or deny the change (as an approver).

Approver
As an approver, your user profile must contain the Approval Type for the 
approvals you need to make and you must be a member of that Approval 
Group.

For example: The out-of-box Change Management COORDINATOR user 
profile assigns the Approval Type of Assessment. If you are a member of the 
Assessment Approval Group, you can approve the Change request with 
this needed Approval Type. You can approve Change requests that require 
the Assessment Approval Type. 

However, if your user profile changes and you no longer have the 
Assessment Approval Type, you cannot approve Change requests that 
require the Assessment Approval Type (even if you remain a member of 
the approver list for the Assessment Approval Type). You must be a 
member of the Approval Type group and your user profile must contain 
the valid Approval Type.
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Alerts and Messaging
Alerts trigger a series of checkpoints taken against a change or task to ensure 
that the required work activities occur within the specified time frames. 
Alerts serve as reminders to ensure that a change or task gets completed in 
the allotted time frame.

Messages are sent to specified users when important events occur in a change 
or a task. These events include alerts, open, update, and close.

Need for Change Management

Utilizing Change Management:

Requires a change to follow a set process.

Notifies the appropriate personnel at key points in the process.

Monitors the progress of a change and issues notifications if deadlines are 
not met.

Supports the change throughout a simple or complex life cycle.

Workflow

Change Management allows the user to quickly and easily request a change 
to software, hardware, network connections, or facilities. Figure 10-1 on 
page 416 provides a flow chart of the change process, using the example of 
requesting a new hard drive for your server.
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Figure 10-1: Change Management Flow
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The workflow can be changed by modifying ServiceCenter scripts to meet 
your business process flow (see the Application Administration Guide, Change 
Management, for more information on how to create scripts). For example, 
if you discover the hard drive in a PC is not large enough, you can request a 
new hard drive by following the Change Management process in the flow 
diagram shown in Figure 10-1 on page 416:

1 You open a change from Change Management and you become the requestor. 
In this example, you are requesting the larger hard drive in a PC.

2 After you submit your change, approval groups are notified. In this example, 
the change is sent to your manager.

3 Your manager reviews the change.

4 A decision is made on the change. Your manager either:

a Approves the change. The change process then moves to 
step 5.

b Denies the change. The change process then moves to step 9 to notify the 
user who opened the change.

5 The process moves to the next task phase, which is notifying the personnel 
who can implement the change. In this example, the IS department is notified 
of the change.

6 In the next phase, the tasks are determined. In this example, the IS manager 
notifies the appropriate technician of the change. Work to complete the 
change can be broken down into phases and tasks.

7  The technician makes the change—installs the hard drive. 

8 The technician closes the task. 

9 You, as the requestor, are notified.

10 The change is closed.
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Changes and Tasks

Changes are the basis for Change Management. A change can be broken 
down into tasks. Changes and tasks can be further broken down into 
categories and phases. (Categories and phases are discussed in detail in the 
Application Administration Guide.)

Figure 10-2: Components of a Change—Task Breakdown

For example, a change can be opened to install a larger hard drive in a PC. 
The tasks could include: ordering the new hard drive, backing up the old 
drive, and installing the new hard drive. The change in Figure 10-2 uses 
process flow in Figure 10-3.

Figure 10-3: Change Process Flow

Throughout the life cycle of a change, managers can track the progress of the 
change, granting approvals where necessary.

A task is not a stand-alone element, but is part of the life cycle to complete a 
change. A change can have multiple tasks, although none are required. Tasks 
can run simultaneously.

Instructions for opening a task are included in Opening a Task Record on 
page 439.
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Using Change Management

Change Management access differs between the sample user profiles 
included with ServiceCenter. For example, the technician login can view 
tasks, but can’t approve a change; the administrator and management logins 
have full Change Management access.

Change Management functions are accessed by two buttons:

Change Management—access is dependent on how the operator is logged 
on.

Technician—My Change Tasks.

Manager and system administrator—access Change Management 
menu.

Approve Changes—allows the operator to approve changes. This button 
is used in the help desk operator shipped with the system for 
demonstration purposes.
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Search for a Change or Task
You can query the Change Management database for a change or task. Log 
on as administrator or manager to run this search. Searches can be saved as 
inboxes. See Inboxes on page 77 for more information.

To perform a search:

1 Click Search Changes.

The Change Management Query form (Figure 10-4 on page 420) displays.

Figure 10-4: Change Management Query form

2 Enter any information you know about the change or task.

3 Click Search, or press F6.

If only one record matches the search parameters, that record displays. If 
more than one record matches the search parameters, these records are 
included in the QBE list, and the first record in the list displays.
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Change Management Basic Search Fields
Any or all of these fields can be left blank.

Field Description

Number Enter the change or task number, if you know it. Unlike call 
reports and incident tickets, change and task ID numbers do not 
have a preceding letter.

Status Enter the status of the changes or tasks for which you are 
searching.

closed
initial
reopened
waiting

Approval 
Status

Enter the Change Management status of the changes or tasks for 
which you are searching.

pending 
approved 
denied 

Category Enter the Change Management category classifying the change or 
task.

Cost Center Enter the cost center specified on the ticket.

Assigned To Enter the ServiceCenter user responsible for the change or task.

Assigned Dept Enter the ServiceCenter department responsible for the change or 
task.

Change 
Initiator

Enter the name of the person who asked for the change.

Coordinator Enter the ServiceCenter operator responsible for the ticket or 
tickets.

Phase Search on tickets within the selected phase of the change or task.

Impact Search on tickets with the selected impact code.

1 Major Business Change
2 Business Change
3 Minor Change

Priority Search on tickets with the selected priority code.

1 Emergency Change
2 Expedited Change
3 Normal Change
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Affected Asset Enter the name of the device that has been affected by the change 
or task.

Active/Inactive Search on tickets with the selected activity state of the change or 
task: Active, Inactive, Deferred or All.

Closure Code Search on tickets with the selected closure code.

(1) completed
(2) failed
(3) rejected - financial
(4) rejected - technical
(5) rejected - security
(6) withdrawn

Company Select a company name from the list provided for which this 
change has been requested.

Corporate 
Struct/Div

Use the Fill feature and select a record from the list to specify the 
company’s corporate structure/division involved with this 
change.

Field Description
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Change Management Advanced Search Fields
Any or all of the fields in the Change Management Query form (Figure 10-9 
on page 428) can be left blank. These fields define the time frame affecting the 
change or task. The format is mm/dd/yyyy hh:mm:ss. If a time is not entered, 
the default is 00:00:00.

Figure 10-5: Change Management Query form—Advanced Search tab

Field Description

Starting After/Before Search tickets with work scheduled to start after and 
before the selected dates and times.

Ending After/Before Search tickets with work scheduled to end and be 
complete after and before the selected dates and times.

Closed After/Before Search tickets that have been closed after and before the 
selected dates and times.

Created After/Before Search tickets that were created after and before the 
selected dates and times.
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IR Query tab
The IR Query tab displays a blank text box where you can enter a plain text 
query and Discovery Options to determine how in depth you want your 
search to be. ServiceCenter can add the plain text to the search parameters.

Figure 10-6: Changes IR Search form
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Change IR Search tab
The IR Search tab displays a blank text box where you can enter a plain text 
query. ServiceCenter can add the plain text to the search parameters.

Fields

Field Description

IR Search Text Access ServiceCenter’s IR Expert application where you can 
enter a plain text query. (IR Expert is an intelligent, 
concept-based information retrieval engine that searches 
the ServiceCenter database for similar or related 
information, based on a simple, natural language query).

Discovery Options Where you can designate which kind of search you want by 
selecting one of the following options:

Complete Match—system searches for an absolute match 
to the text you have typed.
Shallow—search uses narrower parameters and returns 
fewer records than with a deep search.
Deep—performs a broad search. Try using a deep search 
if a shallow search does not return the desired records.
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Change Management Inboxes
A Change Management search can be saved as an inbox. Inboxes on page 77 
provides details about creating and using inboxes. Change and task inboxes 
(Change List and Task List, respectively) can be accessed from inboxes in 
other applications. A Change Management Change List is shown in 
Figure 10-7 on page 426. 

Figure 10-7: Change Management Change List

Change List/Task List buttons
The buttons in the Change List and Task List are identical to other inboxes, 
except for two buttons in each inbox that are specific to the applications.

For Approval—displays a list of changes 
or tasks in the approval process.

For Review—displays a list of changes or 
tasks in the review process.
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Open a Change

Only managers and system administrators can create a new change record 
from the Change Management menu. However, a typical help desk analyst, 
such as BOB.HELPDESK, also has access to opening a change while either 
taking a call or accessing an existing call ticket. In order to do this, 
BOB.HELPDESK must select a Change category, which activates the Request 
Change button and allow a request for change to be opened.

To open a change as a system administrator:

1 Click Change Management in the Home menu.

The Change Management menu displays.

2 Click Open New Change.

A list of change categories displays Figure 10-8 on page 427. The categories 
listed depend on the level of the user.

Figure 10-8: Change Categories

3 Double-click on the category in which you want to open the change.

The change form for that category displays.

For example, you can upgrade the hard drive in a PC. Select Hardware.
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The change form for the requested category displays (Figure 10-9 on 
page 428).

Figure 10-9: Change form

4 The fields in the top structure are similar for each category, while the 
remaining sections are dependent on the category. The following fields are 
automatically filled in by Change Management:

Field Description

Change No. A unique number, beginning with the prefix letter C, is 
automatically assigned to the change when the change is 
opened.

Category The change category you selected when you opened this 
change. 

Phase Indicates the phase of the change.
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5 Enter dates in the Planned Start and Planned End fields.

The format for these fields is mm/dd/yyyy hh:mm:ss. If you do not enter the 
time, Service Center uses the default time.

For example, type 12/19/2001 in the Planned Start field and press Enter. Do 
the same for the Planned End field. ServiceCenter enters 12/19/2001 00:00:00 
in both fields.

Note: The date and time format can be set by your system administrator in 
the System Wide Company Record or in individual operator records. 
Therefore, the date and time format you use may vary from the 
defaults shown in the previous steps.

You can use the ServiceCenter Calendar to help enter the date. For example, 
if you are opening a change in the Application category, click in the Planned 
Start field, and then click Fill to access the Calendar. Refer to Setting a 
Reminder on page 438 for instructions on using the Calendar.

6 Enter a value (0 through 5) in the Risk Level field to indicate the hazard of 
the change to the existing state (this field is blank by default):

0 - no risk

1 - low risk

2 - some risk

3 - moderate risk

4 - somewhat high risk

5 - very high risk

Status The current status of the change. When a change is first 
opened, initial is entered by default. The other values are:

deferred—indicates the change was not approved, but has 
been returned to the initial notification process, which 
occurs after the change is submitted.
staged—indicates the change is complete and is now waiting 
for implementation. For example, software has been 
updated, and the next step is to put the software into use.

Approval Status Indicates the current status of the approval process. The default 
value when opening a change is pending.

Note: If the phase requires no approvals the approval status is 
automatically set to "approved."

Initiated On The date and time the change was opened.

Field Description
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7 Enter a value (1 through 5 or E) in the Priority field to indicate the urgency 
of implementing the change over other activities, such as testing and 
production:

1 (if time allows)—indicates implementation can take place when 
convenient for the personnel implementing the change and when the 
change does not create a serious interruption.

2 (normal)—indicates the change should be implemented in a normal 
manner, for example, when the production and test systems are not 
running.

3 (below test and production)—indicates that neither the test nor 
production systems should be stopped to implement the change.

4 (above test)—implementing the change takes precedence over operating 
the test system but not the production system, for example, the 
production system should not be brought down to implement the change.

5 (above test and production)—implementing the change takes priority 
over what is running on the test and production systems. These systems 
can be stopped to implement the change.

E (emergency)—indicates the implementation needs to occur as soon as 
possible because the current condition is seriously affecting the system 
where the change is requested. 

8 In the Coordinator structure, click Fill to display a QBE list for the Name 
field. Double-click a name in the operator record list to select it. The Phone 
No. field is automatically filled in.

9 Enter downtime in the Scheduled Downtime fields, meaning the Start and 
End times that the device is unavailable while the change is completed. If you 
press the Fill, the current date and time are entered in these fields.

10 In the Change Initiator structure, click Fill to display a QBE list for the Name 
field. This name comes from the contacts file. The related fields are 
automatically filled in.

11 Enter a description of the change in the Description tab.

12 Click the Inventory tab. In the Asset ID field, click Fill to display a QBE list 
of devices. Select the device affected by this change.

In this example, select TRAIN pc 100.
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13 Click the Justification tab.

A text box displays. Enter a Justification for the change.

For this example, the PC could require a new hard drive because the old drive 
does not have enough space.

14 Click the Backout Method tab.

A text box displays. Enter a Backout Method for the change.

For this example, the backout procedure could be reinstalling the old hard 
drive.

Note: The Approvals and Tasks tabs remain blank until the appropriate 
actions are taken during the change process. Alert Stage is 
automatically placed and updated in the change form by Change 
Management when specified tasks are not accomplished by the 
defined dates.

15 Click the Parts & Labor tab to review information about device part numbers 
and a list of any work done on the device.

Note: The Parts & Labor tab appears only if the Service Contracts module 
has been enabled.

16 The Attachments tab (Windows- and Java-based clients only) can be used to 
add files from other applications (for example, an Excel spreadsheet) that 
provide additional information about the change. 

a To attach a file, copy (drag) it into the field provided on the Attachments 
tab.

17 Save the record. 

a Click Save, or press F4, to save the record and leave it displayed.

A message displays in the status bar stating: 
Change # Phase xx Opened by operator, 
where # is the Change Number, xx is the phase of the change, and operator 
is the person opening the change.

b Click OK, or press F2, to save the record and return to the Change 
Management menu.
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Options Menu
Options menus vary, depending on the current form; according to whether 
you are opening an existing change/task or new change/task.

Set Reminder—Allows you to schedule a reminder to be sent to you at a 
specified time through e-mail, a page, or a pop-up message.

Print—Prints the current record to the user’s default printer.

Audit History—Enables revision tracking.

Search Duplicates—Queries the Change Management database for duplicate 
changes or tasks. The search is based on the field where the cursor is placed 
and the data entered in the current form.

Note: You cannot query duplicate Date and Time fields.

Validity Lookup—Checks the selected field against the ServiceCenter 
validity tables.

Open New Task—Allows you to open a new task for the current change. 
(Available only for existing changes.) 

View Opened Tasks—Displays the tasks open for the current change. 
(Available only for existing changes.)

Show Parent Change—Accesses the RFC to which this task is associated.

Change Category—Allows you to select a different change category.

Change Phase—Allows you to change the phase of the current change 
record.

Alerts—Changes the system tray buttons to alert options (Alert options vary 
based upon whether or not the change you have accessed is locked).

Reason—Displays the current change’s alert stage in the system tray. Alert 
stages trigger alerts.

ScheduleDisplays a QBE list of scheduled ServiceCenter alerts.
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Alrtsof/Alrtso—Changes the alert status for the current change from on to 
off. This button changes to Alrtson when the status is off.

ShowAll—Shows all alerts associated with the current change.

Alerts are discussed in the Application Administration Guide.

Approval Options—Accesses the Approval Requirements form with 
approval options for the current record; approval buttons display in the 
system tray for the current record displayed.

List Pages—Allows you to display a list of each update if paging is used on 
the phase.

Calculate Risk—Calculates a value for the Risk field based on the data 
entered in the record, such as planned start and category.

Copy Record—Copies the information in the current change/RFC into a 
new change/RFC record. You can modify that new record and save it to 
create a new change/RFC.

If the copied record has associated tasks, you’ll be prompted as to whether 
you want the tasks copied along with the change. If yes, a new task is created 
for each original task: if you click OK, the copied task is saved, and you 
continue to the next task; if you click Cancel, the copied task is not saved.

Affected SLAs—Lists the Service Level Agreements impacted by this change 
or task.

Related:
Related Incidents>View|Open|Associate—Displays call reports (incidents) 
related to this change. Allows you to view, open, or associate related incidents 
to this change.

Related Calls>View|Associate—Displays calls related to this change. Allows 
you to view or associate related calls to this change.

Related Quotes>View|Open|Associate—Displays Request Management 
quotes related to this change. Allows you to view, open, or associate related 
RM quotes to this change.
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Related Root Causes>View|Open|Associate—Displays Root Cause tickets 
related to this change. Allows you to view, open, or associate related Root 
Cause tickets to this change.

I/R Query—Accesses the ServiceCenter IR Expert application and allows 
you to run a query against a specified file.

Notify—Accesses the mail.notify form containing a message window and the 
record. You can attach a message to the record and send the record to 
someone else via standard e-mail, SCmail, or a fax. See Notifying Other 
ServiceCenter Users on page 244 for details.

Expand Array—Allows you to add a field to an array. A separate window 
displays to enter the data.

Refresh—Updates the display of the current record.

View IND Device—View the details of a device from Network Discovery’s 
Device Manager, which provides details of the devices discovered on the 
network.

List Options Menu
List Options are visible if the Record List option in the View menu bar is 
checked.

The List Options menu contains the following options, and varies depending 
on whether you are opening an existing change/task or new change/task.

Field Description

New Displays a blank form for opening a new change/task/RFC.

Count Counts the number of records in the current record list.

Print List Allows you to print a copy of the current record list/RFCs 
awaiting approval.

Refresh List Updates the display of the current list.

Modify Columns Allows you to change the column headings in the QBE record 
list.
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Launch the Network Discovery Device Manager from Change 
Management

ServiceCenter integrates the Network Discovery product to provide network 
monitoring capabilities within ServiceCenter. See the Event Services guide.

Network Discovery’s Device Manager provides details of the devices 
discovered on the network. The Device Manager can be launched from a 
change record to display information about the device impacted by the 
change. The Device Manager provides several panels of information for each 
device in the network. The data includes the device state, status, port 
information and the device address.

To launch the Device Manager from a change record:

Select Options>View IND Device from the menu bar.

See the IND User’s Guide for more information on using the Device Manager.

Export to Excel Exports the current record list to a Microsoft Excel 
spreadsheet. Excel automatically opens with the list placed in 
a spreadsheet. Basically, you can export information to any 
product that has DDE (Dynamic Data Exchange) support. 
This DDE function requires Excel 95 or later.

Export to Text File Exports the record list to a text file. This option is not part of 
the DDE support and can be run from clients other than 
those operating in Windows.

Save as Inbox Allows you to save the current list as an inbox.

Mass Approve Allows you to approve multiple records awaiting approval. 
See Change and Task Mass Approvals on page 452.

Field Description
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Associating a Change with Another Application Record
You can associate a change record with an existing Service Management call 
report, Incident Management incident ticket, Request Management request 
(quote), or Root Cause Analysis Root Cause ticket.

Note: Before associating a change to another record, make a note of the ID 
number of that record. You need to enter this number in the following 
process. 

To associate a change with another record:

1 Access the change record.

2 Select 
Options>Related>Incidents|Calls|Quotes|Root Causes>Associate.

A dialog box displays the following question:

Associate Change xxxx with which Incident/Call/Quote/Root Cause?

3 Type the ID number. 

a For an incident ticket, type the number in the form of IMxx, where xx is 
the incident ticket number.

b For a call report, type the number in the form of CALLxx, where xx is the 
call number.

c For a quote, type the number in the form of Qxx, where xx is the quote 
number.

d For a Root Cause ticket, type the number in the form of RCxx, where xx is 
the Root Cause ticket number.

4 Click OK. 

A confirmation displays in the status bar.
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Opening a Related Record
You can open an Incident Management incident ticket, Request 
Management request (quote), or Root Cause Analysis Root Cause ticket 
from Change Management. The new record is related to the existing change 
record.

To open a related record from Change Management:

1 Create a new change record and save the record, or access an existing change. 
See Open a Change on page 427.

2 Select 
Options>Related>Incidents|Calls|Quotes|Root Causes>Open from the 
pull-down menu.

a If you are opening a related incident ticket, a QBE category list displays. 
Double-click on the desired category and a new incident ticket displays 
with the category and related information from the change record filled in.

b If you are opening a related quote, a new quote form displays with 
information related to the change record already filled in.

c If you are opening a related Root Cause ticket, a QBE category list displays. 
Double-click on the desired category and a new Root Cause ticket displays 
with the category and related information from the change record filled in.

Refer to the appropriate chapters in this guide (Incident Management on 
page 197 and Root Cause Analysis on page 377), as well as the Request 
Management guide for help in filling out the forms.

3 Save the related record, then click OK.

You are returned to the initial change record.
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Setting a Reminder 
From an existing change or task record, you can schedule a reminder to be 
sent to you at a specified time. The following example is for a change record, 
but the same procedure is used to set a reminder from a task record.

To access the Set Reminder feature:

1 With an existing change record displayed, select Set Reminder from the 
Options menu.

You select one of the options for setting the time when the reminder occurs:

2 Click Browse in the Remind At field to bring up the ServiceCenter Calendar. 
Use the calendar to select the date and time you want the reminder to occur. 

a Select Remind At to set a reminder for a particular day and time.

b Enter the time in the Time field. Click on the day you want the reminder 
to occur. The dialog box closes and the information is filled into the 
Remind At field. 

c Click the arrows at each side of the month and year to move forward or 
backward. 

d To return to today’s date, click Goto Today.

e To go to a specific date, click Select Date and type the date in the dialog 
box displayed. Click OK to accept the entry and return to the Calendar. 
Clicking the Back arrow returns you to the Calendar with no change.

f Select Remind In to set the reminder to occur at a particular interval. This 
option brings up two fields; enter the time interval, and select the shift you 
are working from the drop-down list.

3 In the Remind if field, select an option from the drop-down list:

Always (the default).

Change is still open.

Change is still assigned to me.

4 In the Pop-up Message area of the form, select the type of notification you 
want:

Pop-up

Page

Email

SCMail
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If you select Pop-up or Page, type the message in the Message field that you 
want to display in the reminder.

Choosing Email or SCMail displays two Message Type option buttons. Select 
the type of e-mail message you want to send. There is also a Title field where 
you can enter a title for the e-mail message.

5 Select the type of e-mail you want sent:

Send Change Record. This option includes a copy of the change record in 
the e-mail.

Fixed Text. This option displays a text box in which you can type the 
message you want to display in the e-mail message.

6 When you have made all your selections, click OK.

The initial change record from which you set the reminder displays.

Opening a Task Record
Tasks can be opened either from a change record or from the Change 
Management menu. A task must be associated with a change to be executed. 

To access the Tasks function:

1 If you are in the Change Management menu, click Open New Task in the 
Tasks tab to open a new task.

-or-

If you are in a saved change record, select Options>Open New Task from the 
menu bar.

2 Select the Task profile that you wish to use for this session.

Note: You can select a Task profile only if you have been assigned more than 
one Change Profile.

A list of valid task categories displays. The contents of the list depend on the 
change category. The QBE list in Figure 10-10 on page 440 shows an example 
of the hardware categories.
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Figure 10-10: Hardware task categories

3 Double-click on the task category you want to use.

In this example, click HW maintain.

A new task is opened and a message displays in the status bar that states: Data 
from Change < # > has been copied to the Task per Link definition 
cm3t.task.request.

Note: If you are opening the new task from the Change menu, you are 
prompted to select a task profile.

Next, a QBE list displays, prompting you to select a Parent Change for 
the new task. Double-click the change record in the QBE list that is the 
parent of this task.

A new task record displays with a task number assigned.
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Figure 10-11 shows an example of a Task Open Prompt form for the HW 
maintain category. 

Figure 10-11: Task Open Prompt form

4 The Category and Phase fields are filled in by default, but can be changed:

a If you want to change the category, click Browse next to the Category field 
to access a QBE list of the task categories.

b If you want to change the phase, click Browse next to the Phase field to 
access a QBE list of the change phases. Phase indicates the change phase 
under which this task falls.

5 Dates in the Planned Start and Planned End fields are entered by default. 
Modify these fields to meet your timetable.
Open a Change  441



ServiceCenter
6 Fill or modify fields in the General tab as needed. Some fields are filled in by 
default, but can be modified to meet the specifications of the task.

a In Risk Level, click the down-arrow to fill this field with a value 
(0 through 5) to indicate the hazard of the task to the existing state:

0 - no risk

1 - low risk

2 - some risk

3 - moderate risk (default value)

4 - somewhat high risk

5 - very high risk

b In Priority, click the down-arrow to fill this field with a value 
(1 through 5 or E) to indicate the urgency of implementing the task over 
other activities, such as testing and production. 

1 (if time allows)—indicates implementation can take place when it is 
convenient for the personnel implementing the task and when the task 
does not create a serious interruption. This is the default value.

2 (normal)—indicates the task should be implemented in a normal 
manner (for example, when the production and test systems are not 
running).

3 (below test and production)—neither the test nor production 
systems should be stopped to implement this task.

4 (above test)—implementing the task takes precedence over operating 
the test system but not the production system (the production system 
should not be brought down to implement the task).

5 (above test and production)—Implementing the change takes 
priority over what is running on the test and production systems. 
Systems can be stopped to implement the change.

E (emergency)—indicates the implementation needs to occur as soon 
as possible, as the current condition is seriously affecting the system. 

c In Status, the current status of the task is indicated.

d In Approval Status, the approval stage for this task is indicated. This field 
defaults to pending when a task is created.

e In Alert Stage, the field is automatically filled in when the task hits an alert 
trigger. 
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f In Scheduled Downtime:Start, enter the date (mm/dd/yyyy) and time 
(hh:mm) the downtime is to begin. The time is optional.

g In Scheduled Downtime:End, enter the date (mm/dd/yyyy) and time 
(hh:mm) the downtime is to be completed. The time is optional.

Note: The date and time format can be set by your system administrator in 
the System Wide Company Record or in individual operator records. 
Therefore, the date and time format you use may vary from the 
defaults described in the previous steps.

7 In the Assigned To structure, click Fill to display a QBE list for the Name 
field. The other fields are filled in automatically.

For example, you can select the technician to complete this task.

8 In the Coordinator structure, click Fill to display a QBE list for the Name 
field. The Phone No. field is automatically filled in, as data is passed in from 
the change. This information is read-only on most task forms.

For example, you can select the manager to oversee this task.

9 Enter a brief description of the task in the Description tab. 

10 Select the Inventory tab.

The Asset selected in the change displays in the Asset field.

If no Asset ID is listed, click Fill to display a QBE list of devices. Select the 
device affected by this task.

11 Select the Work Notes tab. 

Note: Not all task categories have this tab.
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12 Enter the necessary start and end times and notes (Figure 10-12 on 
page 444).

a a Start Time for the task.

b Enter an End Time for the task.

c Enter Notes about the task.

Figure 10-12: Work Notes tab

13 Select the Backout Method tab and enter a Backout Method for the change. 
For this example, the backout procedure could be reinstalling the old hard 
drive.

14 Select the Approvals tab to view a history of any approvals made or pending 
for this task.

15 Use the Attachments tab to add files from other applications (for example, an 
Excel spreadsheet) that provide additional information about the task.

16 To attach a file, copy (drag) it into the field provided on the Attachments tab.

17 Click Save, or press F2, to save the task record. 

A message displays: Task xxxx Phase yyy Opened by zzz, where xxxx is the task 
number, yyy is the phase and zzz is the user.

Viewing Tasks
To view tasks created for a change:

1 Click the Tasks tab in the Change Management home menu.

2 Click Task Queue.

3 Click Switch Inbox to select a view of tasks. 

ServiceCenter displays the Change Request Inbox dialog box.
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a Click the down arrow in the QBE list box to display the Inbox options.

b Select All Open Tasks and click OK. 

ServiceCenter displays a QBE list of all open tasks. If there is only one task, 
ServiceCenter displays the specific Task form.

4 Double-click a task in the Task list to display a Task form.

5 Click OK to return to the Task List form.

6 Click Back to return to the RFC form.

Closing Tasks
Close tasks once you have completed them. A change cannot progress to the 
next phase until all tasks in the current phase are closed.

To close the task:

1 Log on as Task Owner.

2 From the Inbox form, you can either:

a Display the RFC and display the tasks for that RFC:

Double-click on the selected RFC in the Changes Inbox form to display 
the selected RFC form.

Click the Tasks tab on the Change form to display the task. Continue 
with step 3.

If there is only one task for the RFC, ServiceCenter automatically 
displays the specific task form.

-or-

b Display the Task list for all tasks assigned to your area of responsibility:

Click RFC:Task List on the Inbox form to display the Tasks Inbox:All 
Open Tasks list form.

Switch Inbox view to view tasks in Inbox:My Tasks list form.

Double-click the appropriate task to display the specific Task form.

3 Open the task by double-clicking on the task.

4 Click Close and select the appropriate Completion Code.

5 Make any closing comments in the Closing Comments field.

6 Click OK to return to the Task list or RFC form.

7 When you have completed all actions to your RFC tasks, click Back through 
the successive application forms to return to the home menu.
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Approving a Change or Task Phase

As a manager or technician, you may be part of the change approval process. 
The ServiceCenter administrator gives you approval authority by creating 
approval groups. You can become a member to review and/or approve 
changes coming from these groups. Approvals are granted to change phases 
and task phases.

Phase definition records define whether or not a change or task phase needs 
approvals, and are created for each phase. Phase definition records are 
discussed in the Application Administration Guide.

What are Approvals?
An approval is the verification that the change process can start. Approvals 
allow the phases and the tasks in the phases to proceed.

A denial denies the approval of the change. The change can then be closed or 
deferred, sending it back through the approval process.

Without the approval process, the life cycle of the change is put on hold. If 
certain tasks are not completed in the specified time frames, alerts are issued.

Change Management contains multiple options for approving a change or 
task phase, either by individual record or mass approval. Changes and task 
phases also can be denied, or an approval or denial can be overridden.
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Approval Buttons
Change Management contains approval buttons for those with the proper 
approval rights. When reviewing a change or task, click Approvals tab, and 
then double-click on the Approval Type (see Figure 10-13).

 

Figure 10-13: Approval Type and Approval Status in the Approvals tab

The Approval form is opened (Figure 10-14 on page 448).

Depending upon the status of the current change or task, the appropriate 
buttons are made available.

When you have Record List turned off in the View menu and the Mass 
Approve option is selected (checked) in your Change user profile, the 
MassApprove button displays when a QBE list of records displays. This 
allows you to mass approve the records in the QBE list awaiting your 
approval.

Button Description

Approve—to approve the change or task 
phase.

Deny—to deny the approval of the 
change or task phase.

Retract—to undo a previous approval.

MassApprove—to approve all current 
tasks or changes in that user’s approval 
queue.
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Approve and Deny buttons are available to approve or deny a change or task 
phase (see Figure 10-14 on page 448).

Figure 10-14: Approve and Deny buttons made available in the Approval form
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The Retract button is made available to a user with the proper approval 
rights, giving that user the opportunity to retract a previously approved 
change or task phase (see Figure 10-15 on page 449).

Figure 10-15: Retract button available in the Approval form
Approving a Change or Task Phase  449



ServiceCenter
Approval Options
Access to these options is granted in the Approval form. When reviewing a 
change or task phase, click Approvals tab, and then double-click on the 
Approval Type (shown in Figure 10-13 on page 447). 

The Approval form is opened and the following options are made available in 
the Options menu (see Figure 10-16 on page 451).

Option Description

Print To print the current record on the default printer.

Override To access the override options, which include approve, deny, or 
retract one or all of the approvals within a record and approve 
current to approve the current record. Override authority is 
controlled in an operator’s Change Management security profile 
record.

The override option is a powerful tailoring feature and is 
normally made available only to operators with SYSADMIN or 
CM3ADMIN capability.
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A message in the status bar indicates whether you approved, denied, or 
printed the change.

Figure 10-16: Print and Override options available in the Approval form
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Using Approvals in an Individual Change or Task Phase
You can approve a change or task phase only if it is designated for approval 
and you have approval authority.

1 Access a change or task phase record.

2 Select Options>Approval>Approve from the menu bar.

Note: If approvals are not required for the category of a record, Approval is 
not displayed in the Options menu.

-or-

a Go to the Approval form and access the approval buttons and options, as 
described in Approval Buttons on page 447 and Approval Options on 
page 450.

b Click Approve or Deny.

Change and Task Mass Approvals
To approve multiple change or task records:

1 Access the Change Queue or Task Queue (sc.manage.cmr) form, or click 
Search Changes or Search Tasks to query for a list of open changes or tasks.

For information on querying for changes or tasks, see Search for a Change or 
Task on page 420.

Note: The following steps use changes as an example. You can use the same 
steps to mass approve tasks by accessing tasks. If you do not have a 
login with the proper approval and you want to do this exercise, try 
login CA 1 or CM 1.

Note: Typically the ADMIN and SYSADMIN Change user profiles should 
have Mass Approval rights checked. Be sure Mass Approve is checked 
(true) in the Approval/Print tab of the Change user profile.

2 Select Options>Approval>Approve from the menu bar in the sc.manage.cmr 
form.
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If you have approval in multiple groups, a Select Groups approvals box 
displays for the records you selected (see Figure 10-17 on page 453).

Figure 10-17: Approval Group Selection box

3 Select the Approval Group for which you want to approve records.

a All groups are selected (checked) by default. Leave the boxes selected for 
the group or groups you want to approve. You may uncheck any others 
that you do not want to approve in this session.

b Click OK.

A list of changes pending approval displays (Figure 10-18 on page 454).

If you checked the Record List option in the View menu, the mass 
approval option is available in the List Options menu (see Figure 10-18 
on page 454).
Approving a Change or Task Phase  453



ServiceCenter
If the Record List option in the View menu is unchecked, the 
MassApprove button displays instead.

Figure 10-18: Changes Pending Approval

Important: Before you go on to the next step, understand that when you 
seek to Mass Approve, you are not prompted to make sure this is 
the action you want to take. When you select the Mass Approve 
option, all the records in the list that are awaiting your approval 
are immediately approved.
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4 There are two ways you can approach mass approval. 

If you checked the Record List option in the View menu, the Mass 
Approve option is available in the List Options menu (see Figure 10-18 on 
page 454). Click Mass Approve.

-or-

If the Record List option in the View menu is unchecked, the 
MassApprove button displays instead (see Figure 10-19 on page 455). 
Click the MassApprove button.

Figure 10-19: MassApprove button displayed in the cm3r.qbe form

A message displays in the status bar that states the change numbers and 
phases that have been approved.

If all the approvals have been made, the message in the status bar states: The 
approval status has been set to approve. No other groups are pending approval.
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Request for Change (RFC) Category

A Request for Change (RFC) is opened when it is determined that a problem 
is caused by a failure of a Configuration Item (CI) in the IT infrastructure. 
An RFC is also opened when a new CI is added.

The RFC process consists of four phases of which no tasks are involved. Each 
phase is closed before the next phase is processed.

1 Assessment—the RFC is opened and approved.

2 Building—a change implementer is assigned. The implementer establishes a 
procedure for executing the change.

3 Testing—a change tester checks the procedure created by the change 
implementer.

4 Implementation—the RFC is implemented. The process is reviewed and the 
RFC is closed.

Figure 10-20 on page 457 shows the Request for Change (RFC) process.
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Figure 10-20: Request for Change Process
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5 Assessment phase—an RFC is opened from Change Management. 

6 The RFC is submitted for approval by the appropriate managers.

7 A decision is made on the change. The change manager either:

a Approves the change. The Assessment phase is closed. The change process 
then moves to step 4.

b Denies the change. The user who opened the change is notified.

8 Building phase—a change implementer is assigned to set up a process for 
implementing the change.

9 A change tester is assigned when the Building process has been completed.

10 Testing phase—the implementation process is checked by the change tester. 

a If the testing passes, the Testing phase is closed.

b If the testing fails, the RFC returns to the Building phase for further 
assessment.

11  Implementation phase—the change is implemented and reviewed. 

a If implementation is successful, the RFC is closed.

b If implementation fails, the RFC returns to the Assessment phase and the 
RFC must be reevaluated.

RFC Phases 

The following procedures follow an example RFC through the four RFC 
phases. It is assumed that each phase would be processed by the person with 
the appropriate skills and responsibilities within an IT department. 
Therefore, although much of the functionality described can be reached from 
several ServiceCenter sample logins, specific logins for each phase are used in 
these procedures.

A bar chart on the manager Home menu displays the total number of open 
RFCs by current phase. 
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Assessment Phase
The Assessment phase consists of two parts:

Initial opening of the new RFC.

Approval of the RFC.

In this example, the RFC is opened by an administrator. It requests that a 
printer in the marketing department be moved to accounting.

Opening an RFC
To open a new RFC:

1 For this example, log on as an administrator.

2 On the Home menu, click Change Management.

3 On the Change Management menu, click Open New Change.

A QBE list of Change Management categories displays.

Figure 10-21: QBE List of Change categories

4 Double-click the RFC Category entry. 
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The Request for Change form displays.

Figure 10-22: . New Request for Change form

The following fields are already filled in:

RFC No.: xxxx

Phase: Assessment

Status: Initial

Approval Status: pending

The Alert Stage field is grayed out and is filled in automatically by the system 
as the RFC reaches various alert stages. For more information on alerts, refer 
to Elements of Change Management on page 412.

5 Fill in the other fields at the top of the form as follows. 

a In the Planned Start field, type the date and time you want the work to 
start. Use the format mm/dd/yy hh/mm/ss. Click Fill to bring up a 
calendar and select a date.

b In the Planned End field, type the date and time you want the work to be 
completed. Click Fill to bring up a calendar and select a date.
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c In the Priority field, click the Down arrow to access a list of priority codes:

0 - Urgent

1 - High Priority

2 - Medium Priority

3 - Low Priority

For this example, select 2 - Medium Priority.

d In the Categorization field, click the Down arrow to access a list of 
categorization codes:

1 - Minor Impact

2 - Significant Impact

3 - Major Impact

For this example, select Minor Impact.

e In the Reason for Change field, click the Down arrow to access a list of 
possible reasons for the change. 

For this example, select Incident/Problem Resolution.

6 Go to the General tab (pictured in Figure 10-22 on page 460) and fill out the 
fields as follows:

a In the Coordinator field, click the Down arrow to access a list of possible 
change coordinators (such as, CM 1 or CM 2).

For this example, select CM 1.

b In the Initiated By field, click Browse and then click Search to display a 
QBE list of contacts. Double-click on an entry to populate the contact 
information into the field. 

For this example, select Brown.
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c The Initiated On field is automatically filled in with the current date and 
time.

Figure 10-23: New Request for Change

7 Click the Description tab and fill out the fields as follows:

a In the Description of Change field, type a brief description of the nature 
of the change. 

For this example, type Move printer001 from marketing to accounting.

b In the Impact Assessment/Risk Analysis field, type a brief description of 
the impact or risk involved with making this change.
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8 Click the Inventory tab and fill out the fields as follows:

a In the Asset IDs field, click Browse. A Search Criteria box displays 
(Figure 10-24 on page 463) to help you narrow your search and select 
from a QBE list of assets with the search criteria you select. 

Figure 10-24: Asset IDs field Search Criteria dialog box

For example, Press Enter in the Asset field to look through and select from 
a QBE list of assets. To continue to narrow your search, click Browse in the 
Company field to select a company. The Type, Subtype, and Status fields 
offer a drop-down selection list to help refine your search. These selections 
populate the asset information into the fields on the RFC form. 

For this example, press Enter in the Asset field of the Search Criteria dialog 
box and select printer001.

The information about the asset is filled into the fields on the RFC, 
including the asset ID, model, serial number, vendor name, and location.

b In the Changed Properties structure of the Inventory tab, there are two 
columns: Name and New Value.

In the Name column, click the down arrow by a field to display a 
drop-down list. Select the properties of the asset that you would like to 
change. In the example select Building, Floor, and Room, since the 
example RFC involves moving a printer from one location to another.
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In the New Value column, type the changes you want to take effect. In 
the example enter the new building, floor, and room numbers (see 
Figure 10-25 on page 464).

Figure 10-25: Inventory tab of New Request for Change form

9 Click the Asset Info tab. Add any other pertinent information or comments 
about the asset.

10 Click the Implementation tab. Type a Start Date/Time and End Date/Time 
in the Scheduled Implementation structure. Click Fill to bring up a calendar 
and select a date. 

The Actual Implementation structure fields is filled out later in the process 
when the change has been implemented.

11 Click the Backout Method tab. Type a process for backing out of the change. 
For the example: The printer is not moved to the new location.

Note: The fields in the Approvals tab are filled in automatically when the 
RFC is approved.
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12 Click the Parts & Labor tab. If the asset is covered by a service contract, select 
the contract name from the drop-down list in the Service Contract field. The 
other fields are filled in when the work is performed.

13 Click the Attachments tab (available for Windows- and Java-based clients 
only). You can add files from other applications (for example, an Excel 
spreadsheet) that provide additional information about the change. 

To attach a file:

Drag the file into the field provided on the Attachments tab.

-or-

Right-click in the Attachments box. On the pop-up menu, select Insert. 
A dialog box displays. Select Insert Object then Create from File. 
Browse to the location of the file you want to attach. Double-click the 
file name, and then click OK when the dialog box is redisplayed.

14 When you have finished filling out the RFC form, click Save.

The following message displays in the status bar: Change <#> Phase 
Assessment is Opened by <Login Name> (Figure 10-26 on page 465).

Figure 10-26: Saved Request for Change
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Approving an RFC
Approvals are based on the Service Level Agreements (SLAs). So when you 
have approval managers and change sponsors involved, the managers and 
sponsors must be on the approver list for each appropriate phase. Once an 
RFC has been opened, it must be approved before it can move on to the 
Building phase.

All new RFCs must be approved by a manager or Change Sponsor associated 
with the SLA. An RFC may require other approvals, based on the 
Categorization field:

An RFC with a risk assessment of 3 (Major Impact) also requires approval 
by an IT director.

An RFC with a risk assessment other than 1 (Minor Impact) must be 
approved by a member of the Change Advisory Board (CAB).

To approve an RFC:

1 Log on as a Change Manager (for example, CM 1).

2 Access the RFC you want to approve. Refer to Search for a Change or Task on 
page 420.

3 Click the Approvals tab to find out which approvals are needed (Figure 10-27 
on page 466). The type and status of approvals are listed. For this example, 
note that there is an Approval Type of Assessment and Approval Status of 
pending. This information lets you know who should be involved with the 
approvals at this phase. In this case, an Approval Group with the Assessment 
Approval Type is needed for the approval.

 

Figure 10-27: Approval Type and Approval Status in the Approvals tab
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Note: When an RFC requires more than one approval, the approvals must be 
done in the order listed in the Sequence columns, with number 1 first, 
and so on.

4 Double-click the approval type in the Approval Type field to learn what 
Approval Group has this Approval Type. 

For this example, double-click Assessment. Currently pending approvals 
information displays in the Approval form (Figure 10-28 on page 467).

Figure 10-28: Currently pending approvals information in the Approval form

Note that the COORDINATOR user profile holds the Approval Type of 
Assessment. 
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Important: The login name must be a member of the necessary Approval 
Group and have the correct Change Management user profile. 
Otherwise, the login name cannot approve the change. 
Approvals rely on both the correct Change user profile and 
membership in the Approval Group.

For this example: The Login Name of CM 1 has an out-of-box 
Change Management user profile of COORDINATOR and is a 
member of the ASSESSMENT Approval Group type, so CM 1 
can approve this RFC.

5 Click the General tab and decide, from the information provided, whether 
you wish to approve or deny the RFC.

Note: If approvals are not required for the category of a record, Approval is 
not displayed in the Options menu.

6 Choose Options>Approval>Approve.

The Approval Status is changed to approved (Figure 10-29). The following 
message displays in the status bar: The Approval Status has been set to 
approved. No other groups are pending approval.

If you wish to use the approval buttons and options available in the Approval 
form:

a Go to the Approval form and access the approval buttons and options, as 
described in Approval Buttons on page 447 and Approval Options on 
page 450.
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b Click Approve or Deny.

To approve an RFC, see Approving an RFC on page 466 and 
Approving/Denying RFCs on page 499.

To deny an RFC, see Approving/Denying RFCs on page 499.

Figure 10-29: Approving an RFC Change Request

7 Click the Approval Log tab to view the results of the approval (Figure 10-30). 

Figure 10-30: Details of the approval in the Approval Log tab

The following information displays:

The approval action taken (Approved).

The Change Management user profile and login name of the person 
processing the approval.

The date and time of the approval.
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8 If this is the only approval required for this RFC, click Back, and then click 
Close to complete the Assessment phase.

Note: If other approvals were needed for the RFC Change request, the other 
approvers would have to review and handle the approval process.
For this exercise, however, there is only one approval needed for this 
RFC Change request.

When all required approvals have been completed and the Assessment phase 
of the RFC has been closed, a new field, Assigned To, displays on the RFC 
form (Figure 10-31). This field allows you to assign the RFC to the 
appropriate person to implement the change.

Figure 10-31: Request for Change with Assigned To Field

9 In the Assigned To field, click the down arrow to display a drop-down list 
and select the name of the person to whom you want to assign the RFC.

For this example, select SUSIE.SUPERTECH.

10 Click Close, and then click OK to complete the Assessment phase and move 
on to the Building phase.
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Note: The Phase field has changed to Building and the Status field has 
changed to initial -- the initial status of the Building phase.

The following message displays in the status bar: Change <#> Phase Building 
Opened by <login name>.

Figure 10-32: RFC Building phase opened in the RFC Change request

Building Phase

The Building phase of an RFC allows the personnel involved with 
implementing the change to ensure that all processes work smoothly.

For example, in the sample RFC, a printer is being moved from one 
department to another. The change coordinator could check with both 
departments to make sure that this move does not adversely impact either 
department. The implementer would also need to ensure that facilities 
personnel are available to process the move.
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1 There are no tasks involved with the RFC Change request, so the change 
coordinator notifies SUSIE.SUPERTECH of her new assignment through SC 
mail. 

a Choose Options>Notify. 

For this example, prepare the notification and address it to 
SUSIE.SUPERTECH.

b Click Mail to send the notification to SUSIE.SUPERTECH through SC 
mail.

SUSIE.SUPERTECH is notified of her new assignment and the details of 
the assignment is be included in the SC mail message.

2 If the change tester is not the change implementer (in this case, 
SUSIE.SUPERTECH), assign that task now.

For this example, assign BOB.HELPDESK as the Change Tester.

3 Click Save and exit the new RFC Change request.

Receiving Notification of an Assigned Task Through SC Mail
Because the newly created RFC Change request does not create tasks, you 
send notification of the new assignment through SC mail. 

Note: The mail is delivered within ServiceCenter and not an email client 
such as Microsoft Outlook.

For this example, you sent SUSIE.SUPERTECH a notification to let her know 
of her new assignment. 

The steps that SUSIE.SUPERTECH takes to learn of and work on her new 
assignment are as follows:

1 Choose Mail>Read Mail>Change Management.

SUSIE.SUPERTECH receives notification of the new assignment for Change 
number C5. 

2 Click Show Change in the menu bar.

SUSIE.SUPERTECH views the Change request number C5 as it displays.

3 SUSIE.SUPERTECH works on her new assignment.

4 When her written procedure or assignment is complete, SUSIE.SUPERTECH 
clicks Close.
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This allows SUSIE.SUPERTECH to complete her written procedure and 
either assign herself or somebody else as the change tester, if one was not 
originally assigned. For instructions on assigning a Change Tester, see Testing 
Phase on page 474.

For this example, BOB.HELPDESK was earlier assigned as the Change Tester. 
BOB.HELPDESK tests the change implementer’s written procedure. 

5 Click OK. 

The following message displays in the status bar: Change <C##> Phase RFC 
Testing Opened by <login name>. See Figure 10-33.

Figure 10-33: Change Implementer opening the Testing phase
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Testing Phase

In the Testing phase, the change tester checks the procedure created by the 
change implementer to see if the expected implementation succeeds.

Assigning a Change Tester
Technicians and managers have access to assigning a change tester.

Logged in as a technician and assigning a change tester:

1 Logged in as a technician (such as, SUSIE.SUPERTECH), access the RFC you 
want to assign to a change tester. In this case you access the RFC by clicking 
on CM Task List within the Call Queue or Incident Queue.

2 A new field displays where you can assign a person to test the work. Click the 
down arrow in the Change Tester field and select the name of the person you 
want to assign to do the testing.

3 Click Save and Close to move on to the Testing phase.

Logged in as a manager and assigning a change tester:

1 Logged in as a manager (such as, MAX.MANAGER), click close. 

2 Click the down arrow in the Change Tester field and select the name of the 
person you want to assign to do the testing (Figure 10-34 on page 475).

3 Click OK.

The Building phase is closed, and the RFC Initial Testing phase with an initial 
status is opened.

Note: While in the Building phase, the format is cm3r.rfc.build.g.

While in the RFC Initial Testing phase, the format is cm3r.rfc.test.g.

Testing Phase Completed
After testing has been completed by the assigned change tester (in this 
example, BOB.HELPDESK), log on as the change implementer (technician - 
SUSIE.SUPERTECH in this example) and fill in the test data as follows:

1 Click on Call Queue or Incident Queue. Click Change Management at the 
top of the inbox to access the Change Management inbox. 

2 In the list of changes displayed, double-click the RFC you want to view. 
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3 Click Close to complete the Testing phase. A new tab, Test Results, displays.

4 Click the Pass or Fail check box, and fill out the Testing Results field 
(Figure 10-34 on page 475).

Figure 10-34: Request for Change Test Results

Note: If the test failed, the RFC cycle returns to the Building phase.
If the test passed, the RFC moves on to the Implementation phase.

5 Click OK to move on to the Implementation phase.

The RFC Testing phase is closed and the RFC Implementation phase is opened 
at an initial status.

6 The following Confirmation dialog box displays (Figure 10-35 on page 476), 
so that the change implementer can review and verify the new asset 
information. The change implementer makes any necessary information 
updates.
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In this example, printer 001 has been moved to the accounting department 
which is located at Building 3, Floor 4, Room 222. This information is 
correct.

Figure 10-35: Review and verify new asset information

7 Once the information has been changed and verified, click OK to exit back to 
the original mail request where you can forward the original mail request or 
notify the change coordinator through regular office procedures that this 
change has been implemented.
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Implementation Phase

Figure 10-36: RFC Implementation phase has been closed

After testing has been completed, the change requested by the RFC is opened 
in the Implementation phase. After the implementation has been completed, 
you can record information about the implementation. A review process is 
included in the Implementation phase.

1 Log on as a change manager (such as, CM 1).

2 Access the RFC you want to process. Refer to Search for a Change or Task on 
page 420 for details on searching for a change or task.
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3 Click the Implementation tab, and fill in the Actual Implementation fields 
with the Start date/time and End date/time (Figure 10-37 on page 478).

Figure 10-37: Request for Change Implementation tab

4 In the Implementation Comments field, type any pertinent information 
about the implementation.

5 In the Header fields at the top, go to the Reason for Change field (if not filled 
in earlier) and select a reason for the change in the drop-down list.

6 If there are any assets involved, go to the Inventory tab and enter the 
information about the assets in the Asset IDs field(s) (if not filled in earlier). 
Click Fill to bring up a record list and make the appropriate selection(s).

7 Click Save, and then click Close.

A new tab, Review, is added to the RFC.
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Review
The review process allows you to document the success or failure of the 
change implementation. You can also record any problems encountered 
during the implementation.

1 Complete the Review tab fields as follows (Figure 10-38 on page 479):

The Review Date field is automatically filled in with the current date and 
time.

a In the Review Results field, click the down arrow to select the appropriate 
code for this RFC.

b In the Review Comments field, enter any pertinent data about the RFC.

Figure 10-38: Request for Change Review tab

2 Click OK.

The RFC process is now complete and the RFC is closed. 

Note: The RFC Implementation phase is at a closed status.

If a search is done later for this RFC, the record displays in read-only form, 
unless the RFC is reopened.
Implementation Phase  479



ServiceCenter
3 In this example RFC, a printer was moved from one location to the other. 
These location values were changed on the Inventory tab of the RFC (refer to 
Figure 10-25 on page 464). When an RFC is closed in which the properties of 
a device were changed, a dialog box displays to confirm these changes 
(Figure 10-39 on page 480).

Click Save to confirm the changes.

Figure 10-39: Confirm Posting Action
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When you search on this RFC later, a Reopen button is added to the system 
tray (Figure 10-40 on page 481). A message in the status bar indicates that the 
Implementation phase is closed. 

Figure 10-40: Reopen button
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Request for Change (RFC) - Advanced Category

Request for Change (RFC) - Advanced is an out-of-box Change 
Management category solution, stemming from ServiceCenter’s best 
practices and workflows. RFC - Advanced manages the operational risks and 
costs of system-wide changes, such as moving personnel, assets, and systems 
in a single business unit or multiple business units. The workflow is broken 
down into Opening a Call and the following five phases.

1 Assess—flag affected assets, making note of which assets are affected by the 
RFC, and create an estimate for RFC impact

2 Plan—Service Management team, Change owners, and Change Sponsors 
approve, produce a plan and quote, confirm or enter asset details, schedule 
tasks

3 Build—Service Management and Change sponsor approve, allocate and 
manage outside tasks

4 Implement—Service Management and Change Sponsor approve, define, 
view, close tasks, and manage outside implementation tasks

5 Accept—Change Owner and Change Sponsor review before final closure of 
RFCs

Each phase is closed before the next phase is processed.
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Figure 10-41 on page 483 diagrams the Request for Change (RFC) - 
Advanced flow.

Figure 10-41: RFC - Advanced Flow

Open a Call

1. Assess Phase

2. Plan Phase

4. Implement Phase

3. Build Phase

5. Accept Phase

Take a new call
Open an RFC-Advanced 

Flag affected assets
Create an estimate for RFC impact

Service Management, Change Owner, 
and Change Sponsor

Approve
Produce a plan and quote
Confirm or enter asset details

Review RFC for closure

Service Management and Change 
Sponsor

Approve
Define, view, and close tasks

Service Management and Change 
Sponsor

Approve
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RFC - Advanced Phases

All RFC - Advanced changes are opened initially by opening a call. From 
there, the RFC - Advanced changes phases begin. The following procedures 
follow an example RFC - Advanced category through its change phases. It is 
assumed that each phase would be processed by the person with the 
appropriate skills and responsibilities within an IT department. Therefore, 
although much of the functionality described can be reached from several 
ServiceCenter sample logins, specific logins for each phase are used in these 
procedures.

A bar chart on the manager Home menu displays the total number of open 
RFCs by current phase. 

Open a Call

Requests for Change (RFCs) come from three major sources: electronic 
forms, Incident Management, and Root Cause Analysis. Opening a call 
consists of two parts:

Taking a Call on page 485

Service Desk Agents (SDAs) and Change administrators log details of a 
change request. Calls to the help desk are routed to RFC management after 
the call is logged and the tasks are described in the Incident Management 
and Root Cause Analysis process. Electronic input is through the Intranet. 
For example a Java-based client enables a user to fill out an RFC using the 
Intranet.

-and-

Opening an RFC on page 489

Calls, incidents, root causes, quotes, and changes are associated to each 
other when both are open and closed. For example, a fix has been applied 
to a network server and allows associations in both directions, such as 
change to call/root cause/incident/quote and call/incident/quote/root 
cause to change.
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Taking a Call
To take a new call:

1 For this example, log on as an administrator (FALCON).

2 On the Service Management main menu, click Take New Calls.

3 A blank New Calls form displays (Figure 10-42 on page 485).

Figure 10-42: Taking a new call

4 Enter the initiator’s details in the Contact Name field. Either:

Type the full name (surname first) in the Reported By field and click 
Browse to complete other details of that person, including address, 
telephone number, and so forth.

-or-

Click Browse. 
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A Search Criteria dialog box displays. Enter any particulars to narrow 
your search, or press Enter without entering any field values to display 
a QBE list of names. 

Double-click a name in the list to insert the name and details (address, 
telephone number, and so forth) in the appropriate fields of the New 
Call form. 

Double-click the asset name associated with the contact name. If you do 
not know the associated asset, click Skip.

5 If the call was taken from someone else other than the main contact, check 
the Report By different than Contact Name field. Then fill in the Reported 
By, Phone, Ext. and Fax fields with the information for the person from 
whom you took the call.

6 Once the contact details are complete, enter a description of the request in 
the Description field.

7 Click Browse in the Category field. 

The category.qbe form displays (Figure 10-43). 

Figure 10-43: Selecting the Change category

8 Double-click the Change category to display a list of RFC - Advanced change 
categories (RFC Type 1).
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A valid list of call subcategories displays (Figure 10-44 on page 487).

Figure 10-44: Change Categories form (RFC Type 1)

9 Double-click the required RFC - Advanced Subcategory. 

For example, click imac (Installations: Moves Additions & Changes).

The cm3sla.qbe form displays (Figure 10-45).

Figure 10-45: Selecting an RFC Product Type 2
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10 Double-click the required Product Type (RFC Type 2) to request a product 
type.

For this example, click move up to 10 items (Figure 10-45 on page 487).

You return to the Call (cc.incquick) form (Figure 10-46 on page 488).

Figure 10-46: Adding Change Category and Product Type information

11 Select a severity level according to the urgency of this RFC.

1 - Critical

2 - Major

3 - Medium

4 - Low

5 - Very Low

For this example, select 2 - Major severity level.
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12 Select a site category from the drop down list in the Site Category field.

A - Critical Site

B - Major Site

C - Satellite Site

D - Home Site

For this example, select A - Critical Site.

At this stage, all the mandatory fields (red flagged fields) have been 
completed (Contact name, Category, Subcategory, Product Type, Problem 
Type, Assignment, Severity, and Site Category description).

You are now ready to create an RFC. See Opening an RFC below.

Opening an RFC
When you have completed the call details, you must create the RFC.

To open a new RFC-Advanced category change:

For this example, we remain logged in as an administrator.

1 If you are in the same call form, click Request Change.

-or-

From the Service Management menu:

a Click Search SM Calls to open an existing call ticket.

b Enter the call number into the Call ID field and click Search.

-or-

Click Search to perform a true query without entering any values in the 
blank call form. A record list with the requested call records displays. 
Make your selection by double-clicking on a call record.
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c Select Options>Related>Changes>Open (see Figure 10-47 on page 490).

Figure 10-47: Relating a change to an existing call

A new Change ticket is opened (see Figure 10-48).

Figure 10-48: New RFC - Advanced category change opened in the 1. assess phase
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The Change Number displays at the top of the form.

The Phase field has the current phase (1.assess) entered.

The General tab in the cm3r.assess.default. form is currently selected.

Note: The active company displays at the bottom of the General tab. If this 
is incorrect, click Back to the first entry form and select an alternative 
company from the Company field.

The Description tab has the description of the request as entered on the 
Calls Details form. You can add a title and update the description, if 
needed.

The Assets tab is empty, unless you have selected a contact that has assets 
already assigned.

2 Enter details of the Coordinator in the Coordinator frame.

Click Browse on the Name field to display the QBE list of Coordinator 
names.

Ask the Change Initiator who, from the business unit, is the Coordinator 
and double-click the name to return to the RFC form with the 
coordinator’s name entered.

3 Enter the Impact level of the RFC. Click the down arrow in the Impact field 
to display a list of Impact ratings. Select from the following:

1 - Major Business Change

2 - Business Change

3 - Minor Change

4 Enter the Priority of the RFC. Click the down arrow in the Priority field to 
display a list of Priority ratings. Select from the following:

1 - Emergency Change

2 - Expedited Change

3 - Normal Change
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5 Click the Contact tab. The name of the Change Initiator (Contact) and the 
contact’s details are displayed here (Figure 10-49 on page 492).

Figure 10-49: Contact tab

This completes opening an RFC.

6 Click Save. ServiceCenter saves the RFC-Advanced Change request. 

The following message displays in the status bar: Change C<##> Phase 
1.assess Opened by <login name>.

7 Click OK. 

ServiceCenter displays a blank Call form, if you opened the Request for 
Change from the new call form.

If you opened the Request for Change from an existing call form, you are 
returned to the cc.incident.quick call form and the following message displays 
in the status bar: SM Call <CALL#####> associated with CM Request <C##>.

Note: The SLA clock starts running at this stage.

Click Back to close the successive application forms to return to the 
ServiceCenter home menu.
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Assessment (Assess) Phase

The Assessment (Assess) phase consists of:

Retrieving RFCs

Flagging affected assets

Creating an estimate for RFC impact

Change administrators retrieve details from an RFC-Advanced request and 
generate estimates or quotes. Change owners are responsible for providing 
quotes and estimates for Impact Category 1 and 2 RFCs. These may display 
in your Inbox list, but you do not need to take any action on them at this 
stage.

The Assess phase produces an estimate or quote for approval by the relevant 
change owners and change sponsor. At the end of the Assess phase, the RFC 
moves into the Plan phase (see Plan Phase on page 497 for more 
information).

Note: The SLA (Service Level Agreement) for providing an estimate, quote, 
or response to an RFC is five days.

Note: Certain categories of RFC, such as Training, System Admin, and 
Procurement, do not use the Plan and Build phases.

Flagging Affected Assets
Where possible, you should obtain details of affected assets from the change 
initiator and enter the details on the RFC.

To flag affected assets:

1 Click the Assets tab to display asset information.

2 Click Browse on the Assets field to display a list of assets.

3 Double-click the required assets for inclusion in the RFC.

When you are finished with each asset, click Save. You are returned to the 
General tab.

4 Make any necessary notes and date any comments.

5 Repeat as many times as necessary for all assets to be flagged.

6 Click Save on the toolbar.
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Creating an Estimate for RFC Impact Category 1, 2, and 3 RFCs
You learn how change administrators generate estimates or quotes for RFC 
Impact Category 1, 2, and 3 RFCs. Each category is affected by the approver 
in the Service Level Agreement (SLA).

Note: An RFC with a risk assessment of 3 (Major Impact) also requires 
approval by an IT director.

An RFC with a risk assessment other than 1 (Minor Impact) must be 
approved by a member of the Change Advisory Board (CAB).

Category Impact 3 RFCs also generate estimates or quotes by selecting a 
standard catalog price.

To enter an estimated price for Impact Categories 1, 2, and 3 RFCs:

1 Access the RFC with an Impact Category of 1, 2, or 3. See Retrieving RFCs on 
page 506 to learn more about retrieving RFCs.
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The cm3r.assess.default form is opened (Figure 10-50).

Figure 10-50: RFC - Advanced with Impact Category 2

2 Click Save on the toolbar if you have made any changes to the RFC.

3 Click Close.
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If Impact Category 1 or 2, ServiceCenter displays the Estimate page 
(Figure 10-51 on page 496). If Impact Category 3, the standard price catalog 
form displays.

Figure 10-51: Estimate form (cm3r.assess.close form)

The Description and Estimated Price fields are red flagged, indicating that 
they are mandatory fields.

4 Complete the Description field with details of the change.

5 Enter the cost estimate for the change in the Estimated Price field.

6 Check that there is a value in the Units Requested field. If there is no value, 
enter the required value.

7 Complete the Budget and Impact/Justification fields.

8 Click OK to open the Plan phase and to return to the RFC queue form.

The following message displays in the status bar: Task T<##> Phase plan 1/2 
Opened by <login name>.
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The next time you enter into this RFC:

If all mandatory fields have been completed, the form is refreshed and the 
Phase field column now shows that the RFC has changed to the Plan 
(2.plan) phase.

If any mandatory fields for Assess phase closure have not been completed, 
ServiceCenter displays the appropriate page with the cursor in the 
required field. Enter the requested information and click OK to advance 
to the next phase. The Phase field now shows the RFC has changed to the 
Plan (2.plan) phase.

Plan Phase

The Plan phase involves Service Management, change owners, and change 
sponsors. It consists of:

Approvals

Producing a plan and quote

Confirming or entering asset details

Scheduling tasks

Service Management Team and Change Owners
Depending upon the type of RFC, ServiceCenter generates approval 
requirements from specified personnel at the beginning of each RFC phase.

On completion of the Assess phase (see Assessment (Assess) Phase on page 493 
for more details), approvals for the start of the Plan phase may be required 
from one or more of the job roles/groups listed below, specified in the SLA 
(cm3sla) record.

Service Management team

Change Owners

Change Sponsors 

ServiceCenter lists all the approvals that are outstanding for each phase on 
the Approvals page of the RFC.
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All current pending approvals required for the start of the Plan phase must 
be entered in ServiceCenter before the RFC can progress into the detailed 
planning stage.

Note: Service Managers are required to give business approval for the 
change. Change Owners are required to give technical approval for the 
Plan phase to proceed.

After the RFC is approved by all nominated approval groups, the change 
must be submitted to the Change Sponsor to provide authorization.

Note: The SLA is still running -- the clock is still ticking, so the amount of 
time spent on servicing the customer is being tracked.

Change Sponsors
Once the cost of an RFC has been estimated, all required approvals for the 
Assess phase (as listed on the Approvals form) must be implemented before 
the change progresses to the detailed planning stage.

The previous section, Service Management Team and Change Owners on 
page 497, described how Change Owners and the Service Manager provide 
technical and business approval at the onset of the Plan phase. The Change 
Sponsor must now provide customer business approval for the RFC and 
approve the estimate.

Note: The SLA clock is suspended, awaiting Change Sponsor approval. As 
soon as approval is granted, the SLA clock starts running again.

Change Sponsors are required to authorize the change from the customer 
business perspective. If a Change Sponsor does not have access to 
ServiceCenter, Change Administrators (CAs) are responsible for ensuring 
that authorization is obtained from the Change Sponsor. When 
authorization is obtained (for example, from email), CAs must approve the 
RFC, on behalf of the Change Sponsor, on the ServiceCenter system.
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Approving/Denying RFCs
Approvals for multiple phases are based upon the Change SLA record that 
has been selected, which is determined by the subcategory type (RFC Type 1 
or RFC Type 2) chosen for the change. Once the SLA record is selected, 
ServiceCenter determines how approvals behave and which approvals are 
needed for each phase. So there can be approvals for multiple phases, 
depending upon the values of the subcategory involved (RFC Type 1 or RFC 
Type 2).

ServiceCenter generates approval requirements from specified personnel at 
the beginning of each RFC phase. At the start of the Implement phase, 
approvals for RFC Impact Categories 1 and 2 may be required from one or 
more of the Change Management personnel.

Service Managers are required to give business approval for the Implement 
phase.

Other groups are required to give technical approval for the Implement 
phase.

Once an RFC has been opened, it must be approved before it can move on to 
the Build phase.

Important: When an RFC requires more than one approval, the approvals 
must be done in the order listed in the Sequence columns, with 
number 1 first, and so on.

Note: The Approval Process Comments area at the bottom of the form is 
reserved for denied and retracted items. There are a number of 
indicators as to the current status:

The Phase field is in the Plan Phase, if there are approvals outstanding.

The Action field displays approved as the current status.

Click Back to return to the QBE list of records -- Changes awaiting approval.

When you have completed approvals, click Back to exit through the 
successive application forms until you return to the ServiceCenter home 
menu.
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Retrieving RFCs for Approval
To retrieve RFCs for approval:

Display RFCs assigned to your area of responsibility.

1 Log on as Service Manager, Change Owner, Change Sponsor, or Change 
Administrator.

2 From the change sponsor’s home menu, click Approve RFCs.

-or-

a Log on with your own login id and password to display the Entry form.

b Click Change Queue.

ServiceCenter displays a QBE list of RFCs by urgency (default view). See 
Figure 10-52.

Figure 10-52: Inbox form (sc.manage.cmr form)

3 Click For Approval on the Inbox form (Figure 10-52).
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ServiceCenter displays the Change Approval Group Selection dialog box.

Figure 10-53: Approval dialog box

4 Click the appropriate box, or leave all checked to default to all groups.

If you click OK, you are returned to the Unassigned Changes inbox of the 
Change Sponsor’s queue.

5 Click Switch Inbox and select RFCs by urgency from the drop-down list in 
the dialog box.

A QBE list of RFCs by urgency are displayed (see Figure 10-52 on page 500).

6 At this stage, you need to approve RFCs in the Plan phase.

Note: You can sort RFCs by phase by clicking on the Phase column header.

7 Double-click the RFC you wish to approve, or click Search and enter the 
number of a specific RFC that you wish to approve. 

The Approvals tab displays the pending approvals needed (Figure 10-54 on 
page 502).
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For this example, the following approvals are pending:

Change Sponsor Approval from the Change Coordinator, 
BOB.HELPDESK

Onsite Support Approval from ONSITE SUPPORT

Service Management Approval from SERVICE MANAGEMENT

Figure 10-54: Current pending approvals in the cm3r.plan.default form

8 Continue with Approving RFCs on page 502 to approve or deny an RFC.

Approving RFCs
As an approver, you have to select and open the RFCs awaiting your 
approval. When there are multiple approvals needed, these must be done 
sequentially. For example, if approvals are needed from BOB.HELPDESK, 
ONSITE SUPPORT, and SERVICE MANAGEMENT, the approvals must be 
approved in that order.

1 Select and open an RFC for approval. 

For information on retrieving RFCs, see Retrieving RFCs for Approval on 
page 500.

The pending approvals are listed in the Approvals tab.
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For this example, the following approvals are pending (see Figure 10-54 on 
page 502):

Change Sponsor Approval from the Change Coordinator, BOB.HELPDESK

Onsite Support Approval from ONSITE SUPPORT

Service Management Approval from SERVICE MANAGEMENT

2 Each approver (BOB.HELPDESK, ONSITE SUPPORT, and SERVICE 
MANAGEMENT) selects and opens the necessary RFCs awaiting their review 
and approval.

BOB.HELPDESK:

Logs on and clicks View Work Queues.

Selects All Open RFCs from the drop-down list in the Current Inbox 
field.

Clicks For Approval.

Clicks OK.

Sorts the RFCs by phase and reviews each RFC awaiting approval, or 
searches for a particular RFC awaiting approval.

Double-clicks the RFC awaiting approval.

Clicks Options>Approval>Approve.

The RFC has been approved and the following message displays in the 
status bar: Change C<##> Phase 2.plan Approved by HELPDESK.BOB.

ONSITE SUPPORT 1:

Logs on and clicks View Work Queues.

Selects All Open RFCs from the drop-down list in the Current Inbox 
field.

Clicks For Approval.

Clicks OK.

Sorts the RFCs by phase and reviews each RFC awaiting approval, or 
searches for a particular RFC awaiting approval.

Double-clicks the RFC awaiting approval.

Clicks Options>Approval>Approve.

The RFC has been approved and the following message displays in the 
status bar: Change C<##> Phase 2.plan Approved by CM ONSITE 
SUPPORT SDU 1.
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SM 1:

Logs on and clicks Change Mgt tab.

Clicks Change Queue.

RFCs by urgency are listed by default.

Clicks For Approval.

Clicks OK.

Sorts the RFCs by phase and reviews each RFC awaiting approval, or 
searches for a particular RFC awaiting approval.

Double-clicks the RFC awaiting approval.

Clicks Options>Approval>Approve.

The RFC has gone through the approval process and received all the 
necessary approvals. 

The following message displays in the status bar: The Approval Status has 
been set to approved. No other groups are pending approval.

Denying an RFC

Important: Do not use this option unless directed to do so by Service 
Control.

1 Click Options>Approval>Deny in the menu bar.

ServiceCenter displays a Denial Reason comments box where you must enter 
the reason for the denial.

2 Enter the mandatory reason for the denial.

3 Click OK to return to the Approvals Requirements.

Comments are displayed in the Approval Process Comments area at the 
bottom of the form, and the current denial is now displayed in the Approved 
Groups frame on the form, showing Action:denied ().

The Change Sponsor has moved from the Current Pending field to the 
Approved Groups field.

There are a number of indicators as to the current status:

The Phase field has changed to Accept phase. Only the Change Manager or 
a Change Administrator can reverse a deny flag and change this to an 
approved status.

The Action field displays denied as the current status.
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4 Click Back to return to the Changes awaiting approval form.

5 If you wish to deny other RFCs, repeat these steps.

6 When you are finished, click Back to exit the successive application forms to 
return to the ServiceCenter home menu.

Important: If you re-open a denied change from the Change Sponsor box, it 
displays a red exclamation point to the right of the Approval 
Status field. Only the Change Manager or a Change 
Administrator has the authority to alter the denied RFC status.

Producing a Plan and Quote
This section describes how Change Owners progress Impact Category 1 and 
2 RFCs through the Plan phase, following approval of the RFC by the Change 
Sponsor.

Once approvals are obtained, the Change Owner must produce plans to 
implement the RFC. The level of planning varies with the Impact Category of 
the RFC. For Impact Category 1 and 2 RFCs, the Change Owner must 
produce a detailed plan for approval by the relevant Change Owners and the 
Change Sponsor (CS). Where an estimate was produced at the Assess phase, 
the Change Owner must now produce a quote for the relevant Change 
Owners and the CS. 

Note: The activities at this stage are paper-based.

For Impact Category 3 RFCs, Change Owners must check the estimate and 
schedule the work with the Change Initiator. These activities are described in 
the Plan Phase - Schedule and Close Category Impact 1, 2, and 3 RFCs on 
page 508.

Note: The SLA is still running.
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Retrieving RFCs
To display RFCs assigned to your area of responsibility:

1 Log on as a Change Owner to display the Entry form.

2 Click Incident Queue, Call Queue, or Change Queue. When you click Call 
Queue, ServiceCenter displays the Calls Inbox form.

3 Click Switch Inbox to select a view of calls assigned to the Change Owner.

The Change Request Inbox dialog box displays.

4 In the QBE list box, select RFCs for SDU action and click OK. 

ServiceCenter displays a QBE list of RFCs assigned to the Change Owner 
for action.

Note: All RFCs requiring Change Owner input to the planning stage are in 
the Plan phase.

5 Click on the Phase column header to sort RFCs by phase. (This makes it 
easier to find the RFCs that require planning actions.) Locate the RFC you 
require from the QBE list.

If you cannot locate the RFC, click Search and enter the RFC number in 
the Search dialog box. If you do not know the number, you can use any of 
the other fields as search criteria.

Click Search to display the search results.

6 Highlight the RFC to progress from the list and double-click to display the 
form for that particular RFC.

Producing a Plan and Quote for Impact Category 1 and 2 RFCs
You must gather additional information to generate a detailed 
implementation plan and quote for Impact Category 1 and 2 RFCs at the 
Plan phase.

For Impact Category 1 and 2 RFCs, you must produce a detailed plan for 
approval by the relevant Change Owners and the CS (Change Sponsor). This 
phase ensures that this planning is completed to the satisfaction of the 
Change Manager, prior to building and implementing the change.

Where an estimate was produced at the Assess phase, you must now produce 
a quote for the relevant s and the CS.
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Confirming or Entering Asset Details
For RFCs involving less than 10 assets, asset details should be entered at the 
Assess phase. These details need to be confirmed at the Plan phase, and input 
on the Asset page of the RFC. Also update the Description with the details of 
any documents produced and input the intended next action.

For RFCs without flagged assets from the Assess phase, you must obtain 
details from the Change Initiator and enter these in the system.

To enter asset details:

1 Click the Asset tab to select the Asset page.

2 Click Browse on the Assets field to display a list of assets.

3 Double-click the required assets for inclusion in the RFC. 

ServiceCenter returns you to the Assets page with the asset details entered.

4 Initial and date any comments in your written plan.

5 Repeat this for as many times as necessary for all assets to be flagged.

Note: Each time you add an asset, ServiceCenter returns you to the General 
page of the RFC. You need to click the Asset tab to continue entering 
asset details.

6 Click Save on the toolbar.

Producing a Quote
All RFCs must have a quote for the cost of the change by the end of the Plan 
phase. At the Assess phase, the cost may have been estimated for Impact 
Category 1 and 2 RFCs. You must now produce a quote. Be sure to complete 
the Description, Estimated Price, Budget, Impact, and Justification fields.

Producing the Plan
You must now update the description to show what documents have been 
produced.

To update the description:

1 Click the Description tab to select the Description page and enter any 
additional information.

2 Enter the details of the plan and quote documents in the Update Description 
field.

3 Click Save.
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Plan Phase - Schedule and Close Category Impact 1, 2, and 3 RFCs
This section describes how Change Owners progress Impact Category 1, 2, 
and 3 RFCs through the Plan phase, following approval of the RFC by the 
Change Sponsor.

Once these approvals are obtained, the Change Owner must check the quote 
or estimate for Impact Category 3 RFCs and schedule the work with the 
Change Initiator.

Note: The SLA clock is still running.

You must schedule Impact Category 3 RFCs for approval by the Change 
Owner that implements the change. The Change Owner must produce 
predefined plans, regression rules, and acceptance criteria for Impact 
Category 3 RFCs.

To schedule RFCs for approval:

1 Retrieve the RFCs for action (see Retrieving RFCs on page 506).

2 Update the Description field with any relevant information.

3 Complete the Planned start and Planned end fields with dates and times in 
the format dd/mm/yy hh:mm.

Note: If you try to exit the phase without completing these fields, the RFC 
form is redisplayed with the fields flagged in red, indicating that the 
dates are mandatory.

4 Click Save or OK.

5 Click Close.

ServiceCenter displays the Plan page with the Phase field, showing that the 
RFC has now entered the next phase. The plan should be completed during 
the Build phase.

Plan Phase - Approve and Close Category Impact 1 and 2 RFCs
This section describes how Change Managers approve the tasks generated by 
the system for Impact Category 1 and 2 RFCs. Before approving the RFC in 
Change Management, the Change Manager must approve the paper plans 
and any associated documentation, and agree with the quote for the RFC. 
Following approval of the plan, the Change Manager must close the Plan 
phase for Impact Category1 and 2 RFCs.
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Approvals for tasks are automatically created. When a task is ready to be 
closed, close the task to close the Plan phase.

Note: The SLA clock is running.

Build Phase

The Build phase involves the Service Management and Change Sponsor. The 
Build phase consists of:

Approvals

Allocating tasks

Managing outside tasks

Build Phase Approvals
The Build phase completes activities that can be carried out without affecting 
the live environment. For example, the procurement and building of 
hardware or the development of applications. The Build phase should also 
include the identification of tasks required in ServiceCenter for the 
Implement phase.

This section describes how:

Change Managers approve and close the Plan phase for Impact Category 
1 and 2 RFCs.

Change Owners schedule and close Impact Category 3 RFCs.

Service Managers provide the relevant approvals for the Build phase.

Change Sponsors give approval for the plan and quote at the beginning of 
the Build phase.

Service Manager Approvals
Service Managers provide the relevant approvals for the Build phase. 

Once these approvals are granted, the Change Owner is responsible for 
completing the Build phase activities. 

Note: The SLA clock is running.
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Change Sponsor Approvals
Change Sponsors give approval for the plan and quote at the beginning of the 
Build phase. It is relevant to Change Sponsors and Service Control.

Service Managers provide the relevant approvals for the Build phase from the 
Change Owner’s viewpoint. Change Owners must approve the detailed plans 
and the quote for Impact Category 1 and 2 RFCs, or the quote and scheduling 
for Impact Category 3 RFCs. Once these approvals are granted, the Change 
Sponsor must give permission for the change to proceed to the Build phase.

If a quote was issued and approved by the Change Sponsor at the beginning 
of the Plan phase (see Plan Phase on page 497), Service Control provides the 
approval at this stage without further reference to the Change Sponsor. If a 
Change Sponsor does not have access to ServiceCenter, Service Control seeks 
the appropriate authorization and enter the details into ServiceCenter.

The Build phase should include the identification of tasks required in the 
ServiceCenter system for the Implement phase.

Note: The SLA clock is not running.

Build Phase - Approving RFCs
To approve RFCs assigned to your area of responsibility, retrieve and review 
the necessary RFCs awaiting approval. 

For information on retrieving and approving RFCs, refer to the following 
topics of discussion: Retrieve RFCs for Approval on page 519, Approvals on 
page 414, What are Approvals? on page 446, Approving a Change or Task 
Phase on page 446, and Approving/Denying RFCs on page 499.

When you have approved an RFC, the Approvals tab now displays either the 
Service Manager (SM) or Change Sponsor (CS) approval entry in the 
Approved Groups field. Pending future approvals have been moved to the 
Current Pending field.

There are a number of indicators as to the current status:

The Phase field is still in the Build phase, because there are outstanding 
approvals.

The Action field displays approved as the current status.
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Click Back to return to the Changes Pending Approval form.

If you wish to approve other RFCs, click <<Prev or Next>> to display the 
previous or next RFC in sequence.

When you reach the beginning or end of the Changes awaiting your 
approval, ServiceCenter redisplays the current form.

Build Phase - Denying an RFC

Important: Do not deny an RFC without receiving direction from Service 
Control.

Follow the steps outlined in Denying an RFC on page 504.

Build Phase - Change Owners Define and Close Tasks
This section describes how Change Owners raise and manage tasks required 
for the Build phase.

Note: The SLA clock is not running.

Approving RFCs
To approve RFCs assigned to your area of responsibility, retrieve and review 
the necessary RFCs awaiting approval. 

For information on retrieving and approving RFCs, refer to the following 
topics of discussion: Retrieve RFCs for Approval on page 519, Approvals on 
page 414, What are Approvals? on page 446, Approving a Change or Task 
Phase on page 446, and Approving/Denying RFCs on page 499.

When you have approved an RFC, ServiceCenter adds the Plan page for the 
selected RFC. This is where you enter your backup plan.
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Producing a Backup Plan
All changes must have a regression plan (backup plan) -- a plan that enables 
you to back out of a change -- should the implementation fail in the live 
environment. A small change may have a simple backup plan. However, if 
the plan is complex, produce the plan as a separate document.

Begin to enter your backup plan by filling in the Plan page.

1 Enter the details of the plan in the Plan page. If the plan is a separate 
document, enter the document reference number in the Plan field.

2 Click Update to save details of the plan.

3 Copy the Plan text and paste it into the Update Description field.

When you’re finished entering the plan information in the Plan page, you 
have a backup plan. Be sure to update your plan, as details change.

Managing the Build and Testing External Activities
The Change Owner outside the system manages the activities required to 
build and test the RFC. The Change Owner should monitor all Build and Test 
activities. Go to the Description tab and record significant events in the 
Description field. You find the Description field helpful as a log of 
information on the significant events that occur while you manage the 
activities required to build and test the RFC.

1 Open the RFCs for Change Owner action.

For information on retrieving RFCs, refer to Retrieve RFCs for Approval on 
page 519.

2 Select RFCs for SDU action and click OK.

ServiceCenter displays a QBE list of RFCs assigned to the Change Owner for 
action.

3 Open the next RFC with phase of 3.build. ServiceCenter displays the RFC 
form.

4 Click OK to save your entry and exit the RFC.
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Build Phase - Closure
If all approval requirements have been met, then closure of the Build phase 
can occur. This section describes how Change Owners approve and close the 
Build phase.

Note: The SLA clock is running.

Retrieving RFCs for Closure
To display RFCs assigned to the Change Owner:

1 Logged on as a Change Owner, retrieve the RFCs by urgency. 

For information on retrieving RFCs, refer to Retrieving RFCs on page 506 and 
Retrieve RFCs for Approval on page 519. 

2 Click RFC:Change List. ServiceCenter displays a QBE list of RFCs by urgency 
(default view).

3 Click Search to display the Display which changes? form.

4 In the Number field, enter the RFC number and click Search.

5 Click the Description tab and check the content of the Description field to 
determine if the RFC needs to have the Build phase closed.

Checking RFC Details
Before closing the Build phase of the RFC, check that all the activities have 
been completed and all required information is available for the Implement 
phase.

To check the RFC details:

1 Check the details of the plan in the Plan field. Update the plan, if necessary. 
If you make any changes, click Update to save the new details.

2 Click the Description tab and enter details of any documents that are used 
during the Implement phase in the Update Description field. Click Save to 
save the new details.

3 Check the details on the other pages of the RFC and add or update the 
information, as required. Remember to click Save after any additions or 
updates.

4 For phases two through five (Plan phase, Build phase, Implement phase, and 
Accept phase), click the Tasks tab on the RFC form to display the Task List or 
a specific Task form.
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5 See if any tasks are open. If any tasks remain open, close them.

6 Check that all activities in the detailed plan for the Build phase are complete.

Closing the Build Phase
When you are satisfied that all Build phase activities have been completed, 
close the Build phase.

1 Click Save then Close. 

The RFC form shows the General page as well as the Closure Code field.

2 From the drop down list, select the appropriate closure code.

(1) completed

(2) failed

(3) rejected - financial

(4) rejected - technical

(5) rejected - security

(6) withdrawn

3 Click Save to save and exit. ServiceCenter redisplays the RFC form. The 
Phase field displays the new phase 4.implement and the status bar displays a 
message confirming closure of the Build phase.

4 Click Cancel and OK again. ServiceCenter returns to the Display Which 
Changes form.

5 Click Refresh to update the phase of the RFC in the QBE list.

6 Click Back to exit the successive application forms and return to the home 
menu.

Implement Phase

This section describes how the required approvals are given to start the 
Implement phase.

The Implement phase consists of:

Defining, viewing, and closing tasks

Managing outside implementation tasks

Approvals
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Implement Phase - Raise Tasks
The previous section described the approval process for the Implement phase. 
Once all required approvals are in place, Change Owners must action the 
implementation of the change.

The Implement phase completes the activities that are required to implement 
the change in the live environment, such as the installation, testing, and 
hand-over of hardware and applications. The Implement phase may include 
some or all of the following activities.

Create and allocate task records in ServiceCenter.

Complete all activities required to alter the live environment.

Alter live systems according to the plan.

This section describes how Change Owners raise tasks for the Implement 
phase.

Defining Tasks for an RFC
To open tasks for the RFC:

1 Log on and display the entry form. See Retrieving RFCs on page 506 for 
detailed steps on retrieving RFCs.

2 Click Options>Open New Task in the menu bar to display the list of valid 
categories.

3 Double-click the appropriate category for the current change (for example, 
implement.task). 

ServiceCenter displays the Task form.

4 Make any necessary changes to dates and times in the Planned Start and 
Planned End fields (originally populated from the RFC) for this particular 
task.

5 Click Browse in the Name field in the Assignment to frame to display the 
Related Record list.

Double-click the appropriate entry to assign the task to a Task Owner. 
ServiceCenter redisplays the Task form with the task owner and/or the 
department entered in the appropriate fields.

6 Enter a description of the task by clicking the Description tab and typing a 
description of the task in the Update Description field.
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7 Enter an estimate for the task by clicking the Estimate tab.

a Enter the number of units required in the Units Required field.

b Enter the anticipated number of man hours for the task in the Estimated 
Effort field.

c Enter the level of staff required for the task in the Grade of Staff field.

8 If needed, complete the required details (such as, inventory, work notes, and 
backout method) on the other pages of the Task form and click Update to 
enter the details into the task record.

9 When you have finished entering task details, click OK to return to the RFC 
form.

10 If needed, click the Options pull-down menu and click Options -> Open 
New Task to display the list of valid categories again to raise another task. 
Repeat the steps above for the second and subsequent tasks.

Closing Tasks
When assigned tasks have been completed, they need to be closed for the RFC 
before the Implement phase can be closed. See Closing Tasks on page 445 for 
information on closing tasks.

Manage Implementation External Tasks
During the Implement phase, various activities need to be completed. Details 
of the activities and their progress should be recorded in the RFC. Do this by 
making sure you enter updated information in the RFC form, Update 
Description field, Description tab.

Implement Phase - Closure
The previous section described how Change Owners raise and close tasks in 
the Implement phase.

This section describes how Change Owners close the Implement phase when 
changes to the live environment are completed and tested, and all related 
tasks have been closed.
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Retrieving RFCs
To display RFCs assigned to Service Control for the Implement phase closure:

See Retrieving RFCs for Closure on page 513 for details steps on retrieving 
RFCs for closure. 

Note: If you are on step 4 in the Number field and do not know the RFC 
number, use the Switch Inbox to switch RFCs assigned to Change 
Owner and sort on the phase and open the next RFC that has phase 
4.implement. ServiceCenter displays a list of RFCs by urgency (default 
view).

Checking RFC Details
Before closing the Implement phase of the RFC, check that all the activities 
have been completed and all tasks are closed.

To check the RFC details:

1 Check that the implementation of the RFC is complete.

2 Check whether or not the implementation has been successful.

3 Click the Tasks tab on the RFC form to display the Task List or a specific Task 
form.

4 Check that all tasks are closed.

5 If any tasks are open, close them, as detailed in Closing Tasks on page 445.

6 Enter information on your actions in the Update Description field of the 
Description tab.
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Closing the Implement Phase
When you are satisfied that all Implement phase activities have been 
completed, close the Implement phase.

1 Click Save then Close. 

The RFC form displays with the Financials page as the current page 
(Figure 10-55 on page 518).

Figure 10-55: RFC form—Financials tab

2 From the drop down list, select the appropriate closure code.

(1) completed

(2) failed

(3) rejected - financial

(4) rejected - technical

(5) rejected - security

(6) withdrawn
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3 Enter the amounts in the Actual Cost and Actual Price fields to reflect the 
actual cost of the task versus the actual quoted price upon closure of the task.

4 Click Save to save and exit. ServiceCenter redisplays the RFC form. The 
Phase field displays the new phase 5. accept and the status bar displays a 
message confirming closure of the Implement phase.

5 Click Save or OK.

6 Click Back (or Cancel to make no changes) to exit the successive application 
forms and return to the home menu.

Accept Phase
The Accept phase consists of:

Updating the asset database

Closing the RFC record in ServiceCenter

Retrieve RFCs for Approval
To display RFCs assigned to Service Control for approval of the Accept phase, 
see Approving/Denying RFCs on page 499 for detailed steps on retrieving 
RFCs for closure. 

Note: When ServiceCenter displays the Changes awaiting your approval 
form, listing RFCs assigned to your group(s) for approval, the RFCs 
for approval are in the Accept phase.

Approve RFCs
Check with the Change Initiator to make sure that changes to the RFC have 
been satisfactorily completed. When ready, follow the steps outlined in 
Implement Phase - Raise Tasks on page 515 to approve RFCs in the Accept 
phase.

Repeat the steps for all changes awaiting your approval.
Implement Phase  519



ServiceCenter
Close the Accept Phase
To close the Accept phase:

1 On the Changes awaiting your approval form (see Figure 10-52 on page 500), 
click Switch Inbox to select a view of calls assigned to the Change Owner. 
ServiceCenter displays the Change Request Inbox dialog box.

a Click the down arrow in the QBE list box to display the Inbox options.

b Select RFCs awaiting closure and click OK.

2 ServiceCenter displays the Changes Inbox:RFCs awaiting closure form. Select 
and double-click the RFC ready to be closed.

3 Click Close in the toolbar.

4 If the RFC is successfully completed, leave the default entry of 
1 - successful. Otherwise, select the appropriate closure code from the drop 
down list and continue.

5 Click OK. ServiceCenter returns to the Inbox form.

6 Click Refresh to remove the closed RFC from the Inbox list.

7 Repeat the above steps until you have completed all RFCs allocated to you for 
closure of the Accept phase.

8 Click Back to exit out of the successive application forms and return to the 
home menu.
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11
 IR Expert 
This chapter introduces concepts and components of Information Retrieval 
(IR) Expert and Knowledge Engineering. 

Topics in this chapter include:

Overview on page 522

Using Standard QBE with IR Expert on page 522

Standard IR Expert Access on page 523

Using the IR Query Option on page 528

Using IR Query on page 532

Knowledge Engineering on page 533
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Overview

IR Expert is an intelligent, concept-based information retrieval (IR) engine 
that searches the ServiceCenter (SC) database for similar/related information 
based on a simple, natural language query. Instead of relying on exact-match 
keywords to select like incidents from the ServiceCenter Incident 
Management database, for example, the description of an Incident is used to 
locate similar incidents via IR Expert. The records called up are then assigned 
a probability of relevance, allowing retrieved documents to be ranked in 
order of relevance to the original query. Details of the relevance ordering are 
provided in the Database Management and Administration Guide.

Using Standard QBE with IR Expert

When a query is first received, ServiceCenter checks to see if the file being 
targeted contains any IR keys. If any data is entered in a field that is part of 
an IR key, then an IR query is executed before any other query. However, IR 
queries can be combined with other queries to help pinpoint information. 

For example, in Incident Management you may want to find out about a 
particular application error code, but only for incidents in the sysops 
assignment group. If you enter sysops in the assignment field and 
application fails with 00023.EXE when right button is used in the incident 
description, IR Expert searches first for incidents that are like the incident 
description (containing words related to the stems of each major component 
of the example message). Then, any incidents found by the IR search are 
eliminated if the assignment field does not begin with sysops.

Note: In previous releases of ServiceCenter Incident Management, a 
standard query from the description field is trapped as a non-keyed 
query; users who are prohibited from executing non-keyed queries are 
not be allowed to perform IR queries in Incident Management 
without using the IR Query option, found in the Option menu.

An IR search can also be used in conjunction with the Find option. Simply 
define a link from a field in which you would normally perform your IR 
query in the source file to any field that is part of an IR key in the target file. 
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For example, you can define a link from the Action,action field of the 
problem file to the description.structure,description field of the cm3r file to 
detect similar change requests when opening or updating an Incident. See the 
System Tailoring guide, Link/Join for information on linking records and 
establishing links between fields on forms.

By default, IR Expert returns a QBE list of records for each search. The 
number of records selected is a function of the granularity of the IR 
parameters and the presence or absence of additional, non-IR query 
elements.

Standard IR Expert Access

IR Expert is most often and easily accessed by clicking View Knowledge Base 
on the Toolkit tab of the System Administrator’s home menu.

 

Figure 11-1: Toolkit tab in the System Administrator’s Home menu
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The Knowledge Base tool is a front-end to IR Expert, submitting a query 
against one of the specified databases or files. The user-friendly access form 
of the Knowledge Base allows users with specific search and operator 
restrictions to access problem solutions and other relevant data without 
being compromised by system security.

Figure 11-2: Knowledge Base entry form
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The fields of the Knowledge Base form are defined as follows:

Field Description

Select a Knowledge 
Area to begin search

This is a list of established groups on the database, where 
IR information is stored. Those files with IR keys defined 
are listed here. Pull down the database menu using the 
arrow, and select from the available list of knowledge 
areas. Several files are pre-defined on the system as search 
areas. These include probsummary, knowledge, probcause, 
and incident. You may also search all knowledge areas 
simultaneously, using the Global Knowledge option. This 
option runs a query against the core knowledge file, which 
is a compilation of all knowledge resources.

Restrict Search to 
Which Field in IR key 
(blank=all fields)

This drop-down list displays the fields in the IR Key 
defined for the database named in the previous field. 
Select a field name if you want to restrict your search, or 
leave this field blank to search against all the fields in the 
key.
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To pass a query using the IR Expert system:

1 Fill in these fields with the specific values and data to gather the information 
you want, such as, similar solutions used in previous Incident tickets of the 
same category, for the same asset or related piece of equipment, or recently 
accepted problem solution candidates.

See Using the Knowledge Base on page 562 for specifics on searching the 
Knowledge Base.

2 Click Search to pass the query.

After the query is passed, a QBE list of records displays along with the first 
record in the list, if more than one record is located.

What would you like 
to know?

This field contains a user-entered plain text query. Key 
words and whole phrases can be used in this field. Any 
values inserted here are queried against the values in the 
IR keys of the specific IR file selected in the previous field.

Discovery Option The selection here defines the depth and degree of 
spreading used by IR Expert during the search. A Shallow 
search only returns records, Incident tickets for example, 
containing the keywords or words used in the query. A 
Deep search employs spreading, where a search is 
performed on the query and then the search is continued 
based on words found in the records returned by the 
original search. Using a deep search identifies all files 
satisfying the query and those related to these records. By 
default IR queries accessed through Knowledge are set to 
Deep. 

The Complete Match option returns only records which 
exactly match the query data.

Field Description
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The QBE list of knowledge records displays (Figure 11-3). Each of these 
represents a hit in the IR Expert search. How these results are processed is 
detailed in the Database Management and Administration Guide.

Figure 11-3: QBE list of Knowledge records

3 To view the first record, double-click on the entry. The first entry in the list 
displays in the form.

4 To view another record in the list, click on the entry.

Available options are:

Click Options>Modify Query to return to the Knowledge Base search 
form and run another query. Repeat the steps above.

Click Options>Reselect All to refresh the query record list displayed in the 
queue.
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An example of a selected record from the Knowledge Base search is shown in 
Figure 11-4.

Figure 11-4: Knowledge Base form

Available options are:

Choose Options>View Query to go back to the initial query.

Choose Options>ADL User Modifications to create adaptive learning 
user modifications within the Knowledge Base. See Adaptive Learning on 
page 573 for specifics.

Using the IR Query Option

The Base (IR query) option displays in the Options pull down menu of 
several ServiceCenter applications. This option provides the same 
functionality used by the Knowledge Base tool, employing IR Expert to locate 
specific like or related information in ServiceCenter.

The same query can be successively executed against multiple files.

The query can be tuned or modified and resubmitted.

Information can be copied from a target record into the source field.

Additional mini files or IR specific files can be built while updating 
conventional files based on conditional logic.
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Accessing IR Query 
The IR Query application can be directly accessed when browsing, opening, 
updating or closing incidents, service management calls, and when using the 
Database Manager. 

Refer to Service Management on page 105 and Incident Management on 
page 197 for detailed information on accessing and using the Service 
Management and Incident Management applications. Refer to the Database 
Management and Administration Guide for detailed information regarding 
the Database Management applications, and for instruction on accessing IR 
Query through Database Manager.

From the Service Management (help desk) main application menu the 
Search Knowledge Base option is available as a button. 

From the Call Queue, the IR Query parameters are available on the search 
form called with the Search Calls option in the Options menu, or the 
Search button on the main portion of the form.

From the call open, update and close forms, IR Query is available through 
the Find Solution option in the Options menu.

From the Incident Management main application menu the Search 
Knowledge Base option is available as a button. 

From the Incident Queue the IR Query parameters are available on the 
search form called with the Search Incidents option in the Options menu, 
or the Search button on the main portion of the form.

From the Incident open, update and close forms, IR Query is available 
through the Find Solutions option in the Options menu.

From the Database Manager application, IR query is available from any 
form as an option in the Options menu. 

Once IR Expert has been accessed from a record, you must manually choose 
which database on which to perform the query, and on a separate form insert 
the specific query to run.
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Accessing IR Query from Service Management
To perform an IR query from the initial Service Management Call Queue 
form:

1 Click Search.

The Service Management search form displays.

2 Select the IR Query tab.

Figure 11-5: IR Query issued from Service Management

3 Select a Discovery Option.

4 Fill in your IR query criteria.

5 Click Search.

The IR query is automatically executed against the ir.probsummary file first. 
A record QBE list is returned and the first record displays.
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Accessing IR Query from Incident Management
To perform an IR query from the initial Incident Management queue form:

1 Click Search.

The Incident Management search form displays.

2 Select the IR Query tab.

Figure 11-6: IR Query issued from Incident Management

3 Enter your IR query criteria.

4 Select a Discovery Option.

5 Click Search to run the query.

The IR query is automatically executed against the ir.probsummary file first. 
Then a record QBE list is returned and the first record displays.
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Using IR Query

Depending on how IR query is accessed, you are presented with a search form 
containing a query (if invoked from an Incident Management or Service 
Management application) or a form prompting you to select the file 
(knowledge base) to search. See Figure 11-2 on page 524.

IR Expert requires a specific query to process against the target file. This is a 
plain text query. A true query (inserting no query statement and simply 
pressing Enter) cannot be passed to retrieve all records in the specified file.

A QBE list is then returned containing related records, sorted by relevance.

If you have issued an IR query by selecting the Find Solution option from the 
Options menu within a incident or call record, you can select to record and 
post information from the IR record back to your source (incident or call) 
record.

Copying Fields
To copy information back to your source record:

1 Select a record from the list returned by the IR query.

2 Position the cursor in the field to be copied.

3 Select Use Solution from the Options menu. 

The source record is redisplayed. 

This action copies the information in the source cursor field (the field the 
cursor was in when the copy field button was selected) to the target field (the 
field the cursor is in when the confirm button is selected). The copied 
information replaces the original information in the source file.

Changing Queries
Once you have opened your original record from the IR search, you can also 
modify your original IR query instead of or before copying information back 
to the source record.

To modify your original IR query:

1 From the selected retrieved IR record, pull down the Options menu.

2 Select the Modify Query option.
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3 From the redisplayed IR Query form you can either change the search criteria 
or change the IR file (knowledge base) being searched.

4 Press Enter to execute the query against the new file or using the new query.

This action may produce another QBE list.

5 Select the record from the new file and query you wish to view by activating 
it with the mouse and pressing the Enter key.

Knowledge Engineering 

Knowledge Engineering is the term used to describe developing and 
enhancing the Knowledge base accessed by IR Expert. The application 
provides System Administrators (knowledge engineers) several knowledge 
tools, including solution candidates and a core knowledge resource.

In previous releases, ServiceCenter stored knowledge data in multiple files 
within the system. Users were required to identify which knowledge file to 
search, and often performed multiple searches to locate appropriate data. As 
a result of this process, and limitations on adding new data to these 
knowledge files, not all searches returned satisfactory data. Both issues are 
resolved through the creation of the following knowledge engineering tools. 

The first tool is a centralized knowledge base. Data already contained in 
other knowledge bases, e.g. the knowledge, KnowledgePak, and probcause 
files, is automatically replicated into a central knowledge file, called core. 
New knowledge can either be added directly to the central knowledge 
base, or it can be added to the various individual knowledge bases. As 
records are added to these databases, ServiceCenter automatically 
replicates their contents into the core knowledge file.

The second tool is a new field on Incident tickets and incidents. This field 
is called solution.candidate. When Incident tickets or call records are 
being closed, users can mark the records as solution candidates. Relevant 
information from these solution candidates is automatically extracted and 
moved into a pre-knowledge file, called protocore. Knowledge engineers 
then review the data submitted as candidates, modify it as needed, and 
either promote a problem/solution combination to the core knowledge 
file, or reject it.
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Using Knowledge Engineering

Marking an Incident Ticket as a Solution Candidate
Marking an Incident ticket as a solution candidate is something all users can 
do by default. When they recommend a problem solution, they are 
suggesting to the knowledge engineer that the particular problem is a good 
candidate for the knowledge base. This option is only available when an 
Incident ticket is being closed. 

To mark an Incident ticket as a solution candidate:

1 Select an Incident ticket from Incident Management.

2 Click Close to put the ticket in close mode. 

3 Place a check in the Candidate for Knowledge Base check box. 

4 Continue closing the Incident ticket normally. The system automatically 
replicates relevant data from the Incident ticket into the knowledge holding 
area (protocore file).

See Finding a Solution While Creating a New Incident Ticket on page 568 for 
specifics.

Promoting or Demoting a Solution Candidate
As users work with the system and close Incident tickets as solution 
candidates, the holding area (protocore) fills. Knowledge engineers examine 
these proposed solutions and promote them to the central knowledge base 
(core) if appropriate, or delete them if they are not good problem/solution 
combinations.

Note: If the Autopost Solution Candidates? (auto.post) field is set to true 
(checked) in the Incident Management Environment record, 
recommended solution candidates are automatically approved (sent 
to the core file). The check box must be set to false (unchecked) for the 
solution candidates to be held in the protocore file for approval.
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To work with records in the holding area (protocore):

1 Select Knowledge Engineering from the Utilities tab of the main menu. 

This takes you to the Knowledge Engineering menu. 

2 Click Examine Solution Candidates. 

The system launches the Solution Candidate Editor.

Figure 11-7: Knowledge item record search

The editor works similar to Database Manager. The difference being, once a 
specific record is selected, a different set of options become available. 

3 Click Search to pass a true query.
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A QBE list is presented with the first record displayed. 

Figure 11-8: Knowledge item record

4 Edit the record if necessary.

5 Click Promote to promote the record to the knowledge base. 

The record is moved into the central knowledge area (core file).

-or-

Click Delete to reject the current record. 

The record is deleted from the holding area. 
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Searching the Central Knowledge Base
The central knowledge base (core file) can be searched via the standard 
ServiceCenter knowledge application. The knowledge application can still 
search the various tertiary knowledge bases. However, using the Global 
Knowledge Base searches all knowledge resources. This is the default 
database for any knowledge search in ServiceCenter.

See Knowledge Base - Diagnostic Aids on page 561 for details about searching 
the Knowledge Base.

To search the central knowledge base:

1 Select Knowledge Base from any one of the various menus or methods 
described earlier.

2 In the Select a Knowledge Area to Search combo box, select Global 
Knowledge. 

3 Enter a query

4 Click Search. 

Note: If you accessed the knowledge base via the Find Solution option from 
an incident or call record, your incident description has already been 
copied into the query window when you reach this form.

5 Review search results.

6 Pass another query, if necessary. 
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APPENDIX

A
 Printing
This appendix outlines the procedures for printing from ServiceCenter. You 
can print QBE Record lists or individual records from all the applications.

It has been divided into the following sections:

Overview on page 540

Server Printer [S] and Client Printer [P] Configurations on page 541

Summary on page 546
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Overview

The options available to you for printing from ServiceCenter depend on 
whether your system is configured for client printing or server printing. For 
a discussion of the server and client printer configurations, refer to Server 
Printer [S] and Client Printer [P] Configurations on page 541.

Note: Although the print options vary slightly between applications, the 
basic procedure for printing is the same. An example of printing from 
Incident Management is used to illustrate printing procedures.

Note: Printing from ServiceCenter only supports the usage of text-based 
forms and does not support the printing of GUI objects, such as 
buttons, table objects, and combo boxes.
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Server Printer [S] and Client Printer [P] Configurations

The options available to you for printing from ServiceCenter depend on 
whether your system is configured for client printing or server printing. An 
[S] in the lower right corner of a ServiceCenter form indicates you have the 
server printer option established for your system (see Figure A-1). 
A [P] in the lower right corner of a ServiceCenter form indicates you have the 
client printer configuration selected.

Figure A-1: Printer Configuration indicated in the bottom right hand corner
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Print an Individual Record
1 With the record displayed, select Print Record from the Options Menu.

A Confirm Action dialog box displays (Figure A-2 on page 543), so you can 
choose your Print options. If the server printer configuration [S] has been set 
up, the server printer Print options are then displayed (Figure A-3 on 
page 543). 
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If you are set up with the client printer configuration [P] and would like to 
change to the server printer, see the System Administrator’s Guide.

Figure A-2: Print Record Optio(ns - Client Printer

Figure A-3: Print Record Options - Server Printer

2 Click the Print all Pages check box if you want to print all the pages in the 
incident ticket.

3 If the Server Printer Configuration [S] is set up (Figure A-3):

a Click the Down Arrow to select a different printer from the drop-down 
list.

b Click Printer to display a QBE list of available printers.

c Type the number of copies you want to print (the default is 1).

4 Click OK.

-or-

Click Cancel to cancel the print request.
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Print a QBE Record List or Each of the Records in a List
1 With a QBE list displayed, select Print List from the List Options menu.

A Confirm Action dialog box displays (Figure A-4 on page 544), so you can 
choose your Print options. If the server printer configuration [S] has been set 
up, the server printer Print options are then displayed (Figure A-5 on 
page 545).

2 If you are set up with the client printer configuration [P] and would like to 
change to the server printer, see the System Administrator’s Guide.

Figure A-4: Print List Options - Client Server
544 Appendix A—Printing 



User’s Guide
Figure A-5: Print List Options - Server Printer

3 Select one of the following options:

Print List Only—prints a copy of the QBE list of records.

Print Incident Records—prints a copy of every incident ticket in the list.

Print All Pages of Incident Records—prints all pages associated with all 
incident tickets listed in the QBE list.

4 If the Server Printer Configuration [S] is set up (Figure A-5):

a Click Printer to display a QBE list of available printers.

b Select a printer from the drop-down list in the Printer field to send the 
print command to a printer other than the default.

c In the # of Copies field, type the number of copies you want.

d Check the Background? option to schedule the print job to be printed in 
the background. 

5 Click OK. 

-or-

Click Cancel to cancel the print request.
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Summary

Although the procedures outlined in this chapter use Incident Management 
as an example, you can use the same procedures for printing from the other 
ServiceCenter basic applications (Service Management, Change 
Management, and so forth). Some print options dialog boxes differ slightly 
from those shown here, but the basic process is the same throughout the 
applications.

For more detailed information about printing, see the System Administrator’s 
Guide.
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B
 The Contacts File
The ServiceCenter database contains a contacts file with records of the users. 
These records are used to fill the contact name fields in the ServiceCenter 
applications, such as the Reported By fields in incident tickets and call 
reports.

Contact records can be accessed directly or from the various applications. See 
the chapters on the individual applications for instructions on accessing 
these records from applications.

This appendix provides the discussion of the following topics:

Accessing Contact Records Directly on page 548

Contact Record Fields on page 549

Creating a Contact Record on page 554

Updating a Contact Record on page 557

Options Menus on page 558
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Accessing Contact Records Directly

As a system administrator or help desk operator, you can access a contact 
record directly.

As a help desk operator, click Contacts in the Home menu.

As an administrator, click Contacts in the Support tab of the Home menu.

From a contact field (such as Reported By), click Find, or press F8.

The Contact Information form (Figure B-1 on page 548) displays. 

Figure B-1: Initial Contact Information form
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Contact Record Fields

When you fill in a Reported By field on a form in a ServiceCenter application, 
only the name displays. The detailed information about the contact is stored 
in the Contact record. 

The fields with Find are linked to other ServiceCenter files; for example, 
Company is linked to the company file, Location is linked to the location file, 
and Workstation is linked to the device file.

The top section of the contact form contains the following fields:

Contact Information Form Tabs
The following tabs are found on the Contact Information form.

Business Information tab
The Business Information tab (pictured in Figure B-1 on page 548) provides 
general work information about the contact.

Field Description

Contact Name Name used in the Reported By fields. 

Employee ID Unique alphanumeric string identifying the contact. You can 
enter the employee’s company ID as defined by the Human 
Resources department.

Last Name Contact’s last name.

First Name Contact’s first name.
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Fields

The fields on the right side of the form (Valid From/To, Company Code, 
Cost Center, Personnel Area, Subarea) are related to the SAP application and 
used in administrative functions. Refer to the System Administrator’s Guide.

Field Description

Primary Asset Main device used by this contact (for example, a PC). This 
device is defined in the device file.

Company Company employing the contact.

Dept Name Department in which the contact works, such as engineering, 
development, or accounting. The Dept Name and Corp 
Struct/Div fields work together, so, for best results, always use 
Fill to enter data into either field. Using Fill against either field 
fills related values into both fields. Furthermore, before 
changing data in either field, first delete the existing values in 
both the Dept Name and Corp Struct/Div fields, then click 
Fill. 

Title Contact’s job title.

Group Contact’s work group, for example, data communications, 
quality assurance (QA), or billing.

Shift Shift the contact works, such as day or night.

Email Contact’s e-mail address.

Manager Contact’s manager.

Service Contract Service contract covering the contact.

Corp Struct/Div A single field that unites both the company and department 
for this contact. The Dept Name and Corp Struct/Div fields 
work together, so, for best results, always use Fill to enter data 
into either field. Using Fill against either field fills related 
values into both fields. Furthermore, before changing data in 
either field, first delete the existing values in both the Dept 
Name and Corp Struct/Div fields, then click Fill. 

Critical User check 
box

Check this box to flag that this information should be used to 
populate the critical user flag on calls. This indicates that the 
call is from a critical user and should receive special attention.

Requires 
Entitlement check 
box

Check this box to flag that this information should be used to 
populate the Service Entitlement check on calls. This 
indicator defines if the ticket should be checked for Service 
Entitlement prior to being worked.

ServiceCenter ID Shows the operator name (from the operator file) for contacts 
that are also ServiceCenter operators.
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Address tab
The Address tab (Figure B-2 on page 551) provides information about the 
contact’s location. 

 

Figure B-2: Initial Contact Information form, Address tab

Fields

The Name, Address, and Hours fields are automatically filled in from the 
locations record for this location.

Field Description

Location Alphanumeric string identifying the site where the contact 
works. This code is set in a locations record.

Location Structure Alphanumeric string identifying the company where the 
contact works. This code is set in a locations record.

Name Name of the facility where this contact is located.

Address Street address of the facility.

Hours Hours the location is accessible.

Building Building in which the contact works.

Floor Floor on which the contact works.

Room Overall room where the contact works.

Office/Cube Office or cube, possibly within a larger room, where the 
contact works.

Home Address Contact’s home address.
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Contact Numbers tab
The Contact Numbers tab (Figure B-3 on page 552) provides fields where 
you can enter telephone, fax, and pager information about the contact.

Note: Pager, fax and email (on the Main tab) information accuracy is 
important for utilizing the SC email, paging and fax utilities.

Figure B-3: Initial Contact Information form, Contact Numbers tab

Misc tab
The Misc (miscellaneous) tab contains fields that are used by the SCAuto for 
SAP Human Resources Interface. You can document the contact’s 
aristocratic title, language, and form of address. You can also record the type 
of communication and a communication number.

Figure B-4: Initial Contact Information form, Misc tab
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Comments tab
The Comments tab allows you to enter comments about the contact. This tab 
displays a text box (Figure B-5).

Figure B-5: Initial Contact Information form, Comments tab

Attachments tab
The Attachments tab contains a field (same as Figure B-5) where you can 
attach files from other applications (for example, an Excel spreadsheet) to the 
Contact record. Files can be added by dragging them into the field, or by 
copying and pasting the file.

Portrait tab
The Portrait tab contains a blank frame where you can insert a bit-mapped 
image. For example, this image could be a picture of the contact. This option 
is available for Windows- and Java-based clients only.

To insert a bitmap:

1 Right-click the blank frame of the Portrait tab and choose Insert bitmap.

A standard Windows dialog box displays. 

2 Select the bitmap (.bmp) file that you want displayed in the tab.

3 Click Save or press F4 to save the image with the record.

To delete a bitmap:

1 Access the Portrait tab of the contact record.

2 Right-click the blank frame of the Portrait tab and choose Delete bitmap.

The bitmap is deleted from the Portrait tab.
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Creating a Contact Record

In the following steps, you create a record for a contact named Joe Smith.

1 Access the menu containing the Contacts button. For example, if you are 
logged on as an administrator, access the Support tab from the Home menu. 
Refer to the System Administrator’s Guide for more information about 
creating Contact records as an administrator.

2 Click Contacts. 

A blank contacts form displays.

3 Type a name in the Contact Name field. The name is entered in all capital 
letters by default. This name could be the contact’s last name.

For this example, type SMITH (see Figure B-6 on page 554).

Figure B-6: Sample Contact Record—Business Information tab
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4 Type a unique ID to identify the contact in the Employee ID field. You can 
use the contact’s last name, or an employee number instead of the name. If 
you use the employee number, the value in the field is a unique key. 

For the example, type 12345.

5 Type the user’s last name in the Last Name field. 

For the example, type Smith.

6 Type the contact’s first name in the First Name field.

For the example, type Joe.

7 Enter the contact’s Primary Asset.

a Put your cursor in the Asset field and click Browse to select an asset.

For the example, select JenJopc.

8 If the company has not already been entered, enter the contact’s company.

a Put your cursor in the Company field and click Browse to select a 
company.

For the example, select PRGN.

9 Put your cursor in the Dept Name field and click Browse to select a 
Department Name.

For the example, enter Infrastructure Management. 

Note: The Corp Struct/Div field fills as well.

10 Optionally put your cursor in the Title field and select a title from the 
drop-down list.

For the example, select Facilities Engineer.

11 Enter information in the remaining Business Information fields. 
Figure B-6 on page 554 shows an example for Joe Smith. 
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12 Select the Address tab.

a Click Browse to select a location structure.

b Optionally type location information in the Building, Floor, Room, and 
Office/Cube fields (Figure B-7 on page 556).

Figure B-7: Contact Record—Address tab

13 On the Contact Numbers tab (Figure B-8 on page 556), optionally type the 
contact’s telephone, fax, and pager information. 

Figure B-8: Contact Numbers tab
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14 On the Comments tab, optionally enter any additional information about 
this contact.

15 Click Add, or press F2. 

A message displays in the status bar: Contact Info. record added., indicating 
that the record has been added to the contacts file.

Updating a Contact Record

To update existing contact records:

1 Search for the record you want to modify.

For example, you can access the record for Joe Smith that you created in 
Creating a Contact Record on page 554.

The contact record displays.

2 Edit the fields you want to change.

For example, you want to change Joe Smith’s phone number to 
800 111-2222.

3 Click Save, or press F4.
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Options Menus

The Options menus differ between blank records and existing contacts 
records.

Options Menu—Blank Record

Option Description

Clear Clears the data entered in the form.

Restore Returns the fields in the form to the previous values. Only 
available in the initial form in which you enter data.

Advanced Search Displays a list of possible search parameters. After a 
parameter is selected, a window displays that allows you to 
set a time limit for a query. This time is entered in the 
hh:mm:ss format. Only available in the initial form in which 
you enter data.

IR Query Accesses the ServiceCenter IR Expert application.

Export/Unload Allows you to export this record into a file for importing into 
a spreadsheet, or unload this dataset for loading into another 
ServiceCenter system. Basically, you can export information 
to any product that has DDE (Dynamic Data Exchange) 
support.

Validity Lookup Checks the data in the current field against the ServiceCenter 
validitytable for that field.

Open Inbox Allows you to select an existing Inbox to enter predefined 
search criteria into the contacts form. 

Expand Array Allows you to add a field to an array. 
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Options Menu—Active Record

List Options Menu—Active Record

Option Description

Print Prints the currently displayed record.

Validity Lookup Checks the data in the current field against the ServiceCenter 
validity table for that field.

Export/Unload Allows you to export this record into a file for importing into 
a spreadsheet, or unload this dataset for loading into another 
ServiceCenter system. Basically, you can export information 
to any product that has DDE (Dynamic Data Exchange) 
support.

IR Query Accesses the ServiceCenter IR Expert application.

Expand Array Allows you to add a field to an array.

List Option Description

Mass Unload Accesses the Unload/Export Facility form where you can 
create an external copy of all records in the currently 
displayed contacts QBE list.

Count Counts the number of records in the current contact record 
list.

Print List Allows you to print the record list or all records in the list.

Refresh Updates the contact record list to reflect any recent changes.

Modify Columns Allows you to change the column headings of the record 
list.

Export to Excel Exports the current contact list to a Microsoft® Excel 
spreadsheet. Excel automatically opens with the list placed 
in a spreadsheet. Basically, you can export information to 
any product that has DDE (Dynamic Data Exchange) 
support. This DDE function requires Excel 95 or later.

Export to Text File Exports the contact list to a text file. This option is not part 
of the DDE support and can be run from clients other than 
those operating in Windows.
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C
 Knowledge Base - Diagnostic Aids
ServiceCenter allows you to make plain language queries (such as, searches 
for information about an incoming call or incident ticket, or a question 
about equipment). Through the use of the Knowledge Base Diagnostic Aids, 
you can retrieve resolutions to reported incidents and problems and teach 
the Knowledge Base through use of adaptive learning. You can search for 
resolutions directly from the Knowledge Base, or from Service Management 
or Incident Management.

Diagnostic Aids within the Knowledge Base contain:

Hot News

Common Problems

Error Messages

IR Queries

Search Get-Answers

An example of a Knowledge Base query could yield three Hot News entries, 
four Common Problems, two Error Messages, and fifty IR Query entries. See 
Finding Solutions -- Diagnostic Aids on page 566 to learn more about using 
the Knowledge Base diagnostic aids and finding solutions.
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Using the Knowledge Base

Note: If you are logged on as a system administrator, the View Knowledge 
Base button is in the Toolkit tab. The Knowledge Engineering button 
in the Utilities tab is for maintaining the Knowledge Base. Refer to the 
System Administrator’s Guide for instructions on maintaining IR 
Expert and the Knowledge Base. 

1 Click Search Knowledge Base (BOB.HELPDESK or SUSIE.SUPERTECH 
login). 

The Knowledge Base search form displays (see Figure C-1 on page 562).

Figure C-1: . Knowledge Base Search form

Clear DataSearch Query 
Options

Message Area

Knowledge Area
562 Appendix C—Knowledge Base - Diagnostic Aids 



User’s Guide
2 In the Select a Knowledge Area to begin search field, click the arrows to select 
a knowledge area from the options on the drop-down list:

Change Database—searches the change record database.

Global Knowledge—searches a general knowledge database.

Help Database—searches the help database, which provides information 
about specific fields on forms.

Call Database—searches the call reports (incidents file).

Knowledge Database—searches a knowledge database.

Internal Knowledge—searches the database containing solutions saved 
from call reports and incident tickets.

SLA—searches the database for Service Level Agreements.

Incident Database—searches the incident ticket database.

3 In the Restrict Search to Which Field in IR Key field, select from the 
drop-down list to restrict your search. If this field is left blank, all fields are 
searched.

4 Enter a plain language statement in the What would you like to know? field. 

For example, you enter A workstation is hanging.

5 In the Discovery Option structure, select one of the query options:

Shallow—prevents the search from going past the first level.

Deep—allows the search to go past the first level.

Complete Match—the search results must exactly match the input.

When an IR query is run, the first level search looks for records with certain 
words matching what you entered. Unnecessary words, such as a and is, are 
ignored. The query then spreads to a second level search to locate records 
containing matches to the records found in the first level search.
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6 Use the Fill function for one or more of the following fields to further refine 
your search.

Category—both the Asset category and Incident category of an Incident 
ticket.

Subcategory—both the Asset subcategory and Incident subcategory of an 
Incident ticket.

Product Type—product type reported in the Incident ticket.

Problem Type—problem type specified in the Incident ticket.

Device—device being reported in the Incident ticket.

Company—name of the company calling to report the incident. Defines 
the level of service that is due the caller. It also defines the SLA that 
pertains to the Incident ticket.

Location—site where the caller works.

7 Click one of the Search buttons, or press F6.

A QBE form displays with Hot News items (Figure C-2). If there are no Hot 
News items, then the QBE form remains blank. At the top of the window 
there are four types of diagnostic aids displayed. They are:

Hot News

Common Problems

Error Messages

IR Query

Search Get-Answers

Figure C-2: QBE list with diagnostic aids buttons at top and any Hot News items listed

Note: In this case, the QBE list is blank.
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8 Press the buttons to access the available information. Each button displays a 
total number of entries available for viewing. If there are no entries, then the 
total displayed is 0 (zero).

For this example, notice there are seven IR Query items. When you click this 
button, the QBE list displays with a list of IR Query Knowledge entries 
(Figure C-3).

Figure C-3: QBE list of Knowledge records

9 To view the first record, double-click the entry. The first entry in the list 
displays in the form.

10 To view another record in the list, click the entry.

Available options are:

Choose Options>Modify Query to return to the Knowledge Base search 
form (Figure C-1 on page 562) and run another query. Repeat the steps 
above.

Choose Options>Reselect All to refresh the query record list displayed in 
the queue.
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An example of a selected record from the Knowledge Base search is shown in 
Figure C-4.

Figure C-4: Knowledge Base form

Available options are:

Choose Options>View Query to go back to the initial query.

Choose Options>ADL User Modifications to create adaptive learning 
user modifications within the Knowledge Base. See Adaptive Learning on 
page 573 for specifics.

Finding Solutions -- Diagnostic Aids
Finding solutions to plain language queries (such as, searches for 
information about an incoming call or incident ticket, or a question about 
equipment) can yield four types of Knowledge Base diagnostic aids.

Hot News

Common Problems

Error Messages

IR Query

Search Get-Answers
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Hot News
Hot News entries are designed to present “late breaking” information to the 
help desk analyst, such as server outages, other infrastructure failures, and 
any form of current information. Hot News can be a solution to a new 
incident, or problem, or a hot problem, which would be an existing open 
incident to which the current call could be attached. Hot News could be 
automatically activated by network events (such as, NetView or OpenView).

Common Problems
Common Problems present solutions to problems that have been identified as 
common or routine. These are not based on frequency of access, but rather 
on a Knowledge Engineer’s assessment of what is most useful most often.

Error Messages
Error Messages are a part of the solution base that focus on those problems 
that generate specific Error Messages. These messages are short strings of text, 
which allow solutions to be located based on the error strings.

IR Query
IR Query is a thesaurus-based weighted key word matching algorithm that 
learns through usage.

For example: Two separate queries containing the words screen and 
terminal pull up the same solution. 

Query: My screen image is fuzzy. 

Solution: Adjust font

Query: My terminal is blurry.

Solution: Adjust font

Search Get-Answers
Opens a browser and presents the Get-Answers application. Get-Answers 
presents solutions in their native formats, such as Adobe PDFs and Microsoft 
Office documents.
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Finding a Solution While Creating a New Incident Ticket
The help desk analyst can search for Knowledge Base solutions while opening 
a Call Report or an Incident Ticket. First consider what fields, if any, are 
linked to the Knowledge Base. For example, any of the fields in the list below 
may be linked (see Using the Knowledge Base on page 562 for detailed 
descriptions of these fields). If all the fields are linked and they are populated 
in the Incident ticket before searching for a solution, then that criteria needs 
to be met in order to be considered as part of the solution. This helps to 
narrow down the problem and find a solution, as the Knowledge Base 
searches Incident tickets with an exact match of the criteria.

To begin, consider doing a shallow search first to find as many solutions as 
possible. Fill in the Description field of the Incident ticket, then search for a 
solution. From there you can narrow your search by filling in some of the 
linked fields within the Knowledge Base form, helping to narrow your search.

Category

Subcategory

Product Type

Problem Type

Device

Company

Location

For this example, we’ll do a narrow search, beginning with a brief description 
of the problem.
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To find a solution while creating a new Incident Ticket:

1 Type a brief description in the Description field then choose Options>Find 
Solution (Figure C-5).

Figure C-5: Finding a solution

2 Click Search.
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A QBE list of IR Query solutions displays (Figure C-6).

Figure C-6: QBE list of IR Query solutions

At the top of the window are five buttons that contain diagnostic aids or 
possible solutions. They are:

Hot News

Common Problems

Error Messages

IR Query

Search Get-Answers

Note: If the search finds no matching records, blank out the fields below the 
Discover Option structure and perform a broader search.

3 To view the first record, double-click the entry. The first entry in the list 
displays in the form.

4 To view another record in the list, double-click the entry. (If you are not in 
Record List mode, click Back.)
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5 When you find a solution, choose Options>Use Resolution.

Figure C-7: Selecting a Resolution

Selecting Use Resolution does two things: 

It allows the help desk analyst to use a known solution.

It begins a process whereby the Knowledge Base learns from the resolution 
being used. See Adaptive Learning on page 573 for more information 
about how the Knowledge Base stores knowledge.
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6 Enter any pertinent information in the Confirm Learning Source Text box to 
help build the Knowledge Base entry (Figure C-8 on page 572). See Using a 
Resolution on page 573 for more information on using a resolution.

Figure C-8: Confirm learning source text for the Knowledge Base

7 Finish opening the Incident ticket.

Find Solution - Options

Option Description

Reselect All Refreshes the query record list displayed in the queue.

Modify Query Returns to the Find Solution - Knowledge Base menu.
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Using a Resolution
When a help desk analyst chooses to use a solution from the QBE list, this 
helps to do two things. Firstly, a solution is found to help solve the reported 
problem in the Incident ticket and second, choosing and using the resolution 
from the query list begins to teach the Knowledge Base about how a 
particular problem can be solved.

When a help desk analyst decides to use a suggested solution while in the 
Knowledge Base, selecting the Use Resolution fills in the details of the 
solution from the Knowledge Base in the Actions/Resolution tab of the 
Incident ticket.

If the selected resolution later fails, you may go back into the Knowledge Base 
and choose a different solution. When a new solution is found, choose 
Options>Use Resolution and the details of the new resolution are stored in 
the Incident ticket as a valid solution in the Actions/Resolution tab. The 
Knowledge Base then learns from the new resolution used for the reported 
problem.

Adaptive Learning
When a resolution is used to resolve a reported problem within an Incident 
Ticket or a Call Report, it begins the process of building the Knowledge Base 
with learned solutions to reported problems. There are two options to be 
used when selecting to use a resolution.

1 Confirm the text to be used in the reported problem that is stored in the 
Knowledge Base. This helps the Knowledge Base to learn what problems are 
related to the resolutions used, so that the solution list can contain the 
knowledge item the next time the same or a similar problem is reported. 

The help desk analyst or Knowledge Engineer can do this by modifying the 
text of the problem and adding any extra necessary comments that help the 
Knowledge Base identify problems to particular resolutions (Figure C-8 on 
page 572). The more the same reported problems are used for selected 
resolutions, the more weight the resolution carries in regards to hierarchy in 
the QBE list presented in future searches. The Knowledge Base learns what 
resolutions work best for reported problems.
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2 A Knowledge Engineer has the ability to fine tune the relationship between 
the solution and the problem. With this capability, a Knowledge Engineer 
uses this option to help build the reported problem in the Knowledge Base. 

The Knowledge Engineer can select Options>IR Learning User 
Modifications. Once in this form (Figure C-9 on page 574), the Knowledge 
Engineer builds the reported problem in the Knowledge Base by adding and 
modifying terms within the Knowledge Base for this entry.

Figure C-9: Knowledge Engineer fine tunes the relationship between the solution and 
the problem
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