BAC 7.5 Scheduled email reports are not being sent, but manually sending a report works fine

  • KM547241
  • 11-Feb-2009
  • 11-Feb-2009

Summary

BAC 7.5 Scheduled email reports are not sending but if you manual send a report it sends out fine. From Applications>User reports created 2 custom reports . Once created click on the email button and select recipient and hit ok and never get the email. However from Applications >End user Management select a report and hit the email button users get the email. You will see the following errors in topaz_all.ejb.log 2009-02-11 10:18:39,195 [http-0.0.0.0-8080-1] (EmailService.java:961) ERROR - EmailService:sendMessageWithAttchment Error send mail with attachment javax.mail.SendFailedException: Invalid Addresses; nested exception is: com.sun.mail.smtp.SMTPAddressFailedException: 504 5.5.2 : Sender address rejected: need fully-qualified address

Error

Business Availability Center (BAC) 7.5

Scheduled email reports are not being sent, but manually sending a report works fine

From Applications > User reports created 2 custom reports .
Once created click on the email button and select recipient and hit ok, never get the email. 
However from Applications >End user Management  select a report and hit the email button, users get the email.

You will see the following errors in topaz_all.ejb.log

2009-02-11 10:18:39,195 [http-0.0.0.0-8080-1] (EmailService.java:961) ERROR - EmailService:sendMessageWithAttchment Error send mail with attachment

javax.mail.SendFailedException: Invalid Addresses;

  nested exception is:

      com.sun.mail.smtp.SMTPAddressFailedException: 504 5.5.2 <HP_BAC_Alert_Manager>: Sender address rejected: need fully-qualified address

 

Cause

BAC 7.5 SMTP setting by default have the sender listed as
HP_BAC_Alert_Manager:
The SMTP server requires a fully qualified email sender address that is valid in your network example  joe.tester@hp.com

Fix

1. In BAC, under Admin - Platform - Infrastructure Settings  ->  Context : Foundations -> Scheduled Reports
change the Email sender property from HP_BAC_Alert_Manager to a valid email address. example
joe.tester@hp.com

2. After making this change, see if the scheduled reports are mailed out correctly.

Also check the other SMTP setting are correctly set for your environment like the SMTP server and the port number

1. In BAC Admin -> Monitors, make sure that the profile associated with the scheduled report is running.

2. In the Management database, check the following:

  1. In the System table, verify Alert_SMTPServer is set correctly.
  2. In the SETTING_PARAMETERS table, verify all values are set correctly.

3. Make sure the SMTP server name is set in:

  1. Admin -> Platform -> Setup and Maintenance -> Infrastructure Settings -> Foundation "Alerting" -> SMTP Server
  2. Admin -> Platform -> Setup and Maintenance -> Infrastructure Settings -> Foundation "Scheduled Reports" -> SMTP Server

4. Make sure the SMTP port is port 25 in Admin -> Platform -> Setup and Maintenance -> Infrastructure Settings -> Foundation "Scheduled Reports" -> SMTP Server port. (Port 25 is the default port.)

5. Invalid characters (non-keyboard characters) hamper the generation of reports. Typically, these invalid characters are introduced when copying the text as-is from an application like MS Word to the description box..