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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed as 
constituting an additional warranty. HP shall not be liable for technical or editorial errors or 
omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. 
Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software 
Documentation, and Technical Data for Commercial Items are licensed to the U.S. 
Government under vendor's standard commercial license.

Third-Party Web Sites

HP provides links to external third-party Web sites to help you find supplemental 
information.  Site content and availability may change without notice.  HP makes no 
representations or warranties whatsoever as to site content or availability.

Copyright Notices

©  Copyright 2009 Mercury Interactive (Israel) Ltd.

Trademark Notices

Java™ is a US trademark of Sun Microsystems, Inc. 

Microsoft® and Windows® are U.S. registered trademarks of Microsoft Corporation. 

Oracle® is a registered US trademark of Oracle Corporation, Redwood City, California. 
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Documentation Updates

This guide’s title page contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign-in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

You can visit the HP Software Support web site at:

http://www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software Support Online provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As 
a valued support customer, you can benefit by using the HP Software Support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract.

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 

To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 
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1
Troubleshooting Performance Center 
Assets

This chapter provides information on troubleshooting problems related to 
managing Performance Center assets.

This chapter includes:

 ➤  Cannot Create Monitor Profile on page 11

 ➤  Cannot Save Measurements on page 12

 ➤  Cannot Import Monitor Profile/Vuser Script on page 14

 ➤  Cannot Download and Open Script on page 14

 ➤  Uploading Script From VuGen Fails on page 17

 ➤  Cannot Upload Script From VuGen on page 17

 ➤  Analysis - Performance Center Server Connection Failed on page 18

Cannot Create Monitor Profile

Error message: Monitor is not licensed or was not installed.

Troubleshooting

The problem is because of a misconfiguration of the host license on the 
utility server.

➤ Reset the system as follows:

 a In the Administrator Site, select System Configuration > 
Server Configuration.
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 b Click Reset.

 c Try to create the monitor profile again.

➤ If the problem persists, contact HP Software Support 
(http://www.hp.com/go/hpsoftwaresupport).

Cannot Save Measurements

Problem description: During configuration of a monitor, after you select the 
measurements that you want to monitor and you click Save, instead of 
saving the monitor, Performance Center goes back to the Choose Monitor 
page. 

Troubleshooting

This problem usually occurs when you select a large number of 
measurements. To resolve this issue, you need to increase the value of the 
AspMaxRequestEntityAllowed property in the IIS metabase. This property 
specifies the maximum number of bytes allowed in the entity body of an 
ASP request.

Note: For more information about the AspMaxRequestEntityAllowed 
property, see the Microsoft Terminal Services documentation: 
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/a
6401b5e-c902-4035-90aa-ee46c270d357.mspx?mfr=true, or 
http://support.microsoft.com/kb/327659

To increase the value of the AspMaxRequestEntityAllowed property:

 1 Run the following command from the command line:

where <IIS_installation_drive> is the hard disk where IIS is installed.

cd <IIS_installation_drive>:\inetpub\adminscripts.

http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/a6401b5e-c902-4035-90aa-ee46c270d357.mspx?mfr=true
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/a6401b5e-c902-4035-90aa-ee46c270d357.mspx?mfr=true
http://www.hp.com/go/hpsoftwaresupport
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 2 To view the current value of the AspMaxRequestEntityAllowed property, run 
the following command:

 3 To increase the value of the AspMaxRequestEntityAllowed property, run the 
following command:

where <maximum value> is the maximum value, in bytes, that you want to 
set for the AspMaxRequestEntityAllowed property.

 4 Run the following command:

 5 To verify that the value of the AspMaxRequestEntityAllowed property has 
changed, run the following command again:

Note: If you are still not able to save the measurements in the monitor 
profile, increase the value of the AspMaxRequestEntityAllowed property 
further. 

For more information about this issue, see the Microsoft support Web site: 
http://support.microsoft.com/kb/327659

cscript adsutil.vbs get w3svc/ASPMaxRequestEntityAllowed.

cscript adsutil.vbs set w3svc/ASPMaxRequestEntityAllowed <maximum value>.

iisreset.

cscript adsutil.vbs get w3svc/ASPMaxRequestEntityAllowed.

http://support.microsoft.com/kb/327659
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Cannot Import Monitor Profile/Vuser Script

Error message: Failed to import Monitor Profile/Vuser Script <asset name>. 
For more information, see the Event Log.

Troubleshooting

This problem might occur when, during the import process, another user 
has deleted the asset or modified its name.

Wait a few minutes and try again.

Cannot Download and Open Script

Error message: Windows cannot access the specified device, path, or file. 
You may not have the appropriate permissions to access the item.

Troubleshooting

The problem could be that the registry key associated with VuGen is 
corrupted or not defined.

 1 Select Start > Run and type regedit to open the registry.

 2 Locate the following keys:

➤ HKEY_CLASSES_ROOT\uszfile\shell\open\command.

➤ HKEY_CLASSES_ROOT\usrfile\shell\open\command.

 3 Make sure that the correct files are associated with the keys.

➤ USZ key: <PC home>\bin\VugenLauncher.exe

➤ USR key: %systemroot%\mercuryTestLauncher.exe, or 
<PC home>\bin\Vugen.exe

 4 Make sure that all backslashes are correct: \ and not /.

 5 Make sure all inverted commas are correct (there should be four in total).
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If the problem persists, try applying the following as a reg file on the 
machine:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.usz]
@="uszfile"

[HKEY_CLASSES_ROOT\.usr]
@="usrfile"

[HKEY_CLASSES_ROOT\usrfile]
@="Virtual User Test"

[HKEY_CLASSES_ROOT\usrfile\DefaultIcon]
@="C:\\Program Files\\HP\\Performance Center\\bin\\vugen.exe,1"

[HKEY_CLASSES_ROOT\usrfile\shell]

[HKEY_CLASSES_ROOT\usrfile\shell\open]

[HKEY_CLASSES_ROOT\usrfile\shell\open\command]
@="C:\\WINDOWS\\system32\\MercuryTestLauncher.exe\" \"%1"

[HKEY_CLASSES_ROOT\uszfile]
@="Vugen Launcher"

[HKEY_CLASSES_ROOT\uszfile\DefaultIcon]
@="C:\\Program Files\\HP\\Performance Center\\bin\\VugenLauncher.exe,1"

[HKEY_CLASSES_ROOT\uszfile\shell]

[HKEY_CLASSES_ROOT\uszfile\shell\open]

[HKEY_CLASSES_ROOT\uszfile\shell\open\command]
@="C:\\Program Files\\HP\\Performance Center\\bin\\VugenLauncher.exe\" \"%1"

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileE
xts\.usr]
"Application"="MercuryTestLauncher.exe"

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileE
xts\.USZ]
"Application"="VugenLauncher.exe"
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[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.usr]
@="usrfile"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.usz]
@="uszfile"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\usrfile]
@="Virtual User Test"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\usrfile\DefaultIcon]
@="C:\\Program Files\\HP\\Performance Center\\bin\\vugen.exe,1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\usrfile\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\usrfile\shell\open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\usrfile\shell\open\command]
@="C:\\WINDOWS\\system32\\MercuryTestLauncher.exe\" \"%1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\uszfile]
@="Vugen Launcher"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\uszfile\DefaultIcon]
@="C:\\Program Files\\HP\\Performance Center\\bin\\VugenLauncher.exe,1"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\uszfile\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\uszfile\shell\open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\uszfile\shell\open\command]
@="C:\\Program Files\\HP\\Performance Center\\bin\\VugenLauncher.exe\" \"%1"
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Uploading Script From VuGen Fails

Problem description: Uploading a script from VuGen fails. An error message 
is provided.

Troubleshooting

 1 Make sure the machine is not configured to use a proxy server. If it is, 
disable the proxy server by searching the registry for the ProxyEnable key in 
the Internet Settings folders and setting this key to zero. 

 2 Check whether there are upload timeouts due to a slow network 
connection. In the <Performance Center installation>\dat directory, there is 
a configuration file called OrchidCommUtils.dat that holds the integration 
communication settings. To change the default timeout (60 sec.), you must 
enable the http_timeout_secs key and change its value.

If neither of the above troubleshooting options helps, you can create a log 
file that provides more information and send it to Customer Support 
(http://www.hp.com/go/hpsoftwaresupport). To create the log file, enable the 
log_file key.

Cannot Upload Script From VuGen

Problem description: Cannot upload a new script created in Standalone 
VuGen. Get following error: Failed to upload script. 

Troubleshooting

This problem occurs when Standalone VuGen, Standalone Analysis, and the 
Standalone Load Generator are installed on the same machine, and the 
Standalone Load Generator was installed last.

Workaround: To upload the script, use the Upload all files option.

http://www.hp.com/go/hpsoftwaresupport
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Analysis - Performance Center Server Connection Failed

Problem description: Connection from Anaylsis to Performance Center 
server fails with error message: Connection to <PC Server> failed.

Troubleshooting

Note: This behavior might be inconsistant among different users. 

This problem is usually related to an HTTP timeout. 

When a user who belongs to a large number of projects/scripts tries to 
connect to the Performance Center User Site server, the time taken to 
generate the list of projects/scripts exceeds the HTTP timeout.

To increase the HTTP timeout parameter:

 1 On the Analysis machine, open the following file: 
dat\OrchidCommUtils.dat.

 2 Locate the line containing the following string: http_timeout_secs.

 3 Uncomment the line by removing the semicolon (;).

 4 Change the value of the paramater from 60 to 180.
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2
Troubleshooting Installation and 
Upgrade

This chapter provides information on troubleshooting problems that occur 
during the Performance Center installation and configuration process.

This chapter includes:

 ➤  Error: Method ~ of object ~ Failed During Installation on page 20

 ➤  DllHost.exe – Application Error on page 22

 ➤  Failure to Retrieve License Key on page 23

 ➤  Performance Center Does Not Load - Error 500 on page 24

 ➤  Error on Page During System Configuration on page 25

 ➤  Installation Does Not Recognize Prerequisite Software on page 25

 ➤  Performance Center Prerequisite Software on page 27
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Error: Method ~ of object ~ Failed During Installation

Error message: Operation terminated. Error description: Method '~' of object 
'~' failed.

Troubleshooting

In the IIS, verify that the Default Web Site directory exists under Web Sites. 

If the Default Web Site directory does not exist:

 1 Create the Default Web Site directory.

 2 Restart the installation.

If the Default Web Site directory exists:

 1 Check the server’s System Event log for W3SVC errors.

 2 Verify the configured identity for the IWAM_<SERVER NAME> account.

 3 Make sure that the password for the IWAM account is synchronized in all 
three locations:

➤ Internet Information Server (IIS) metabase

➤ Local Users and Groups

➤ Component Services

For more information on obtaining or setting the account password, see: 
http://support.microsoft.com/default.aspx?scid=kb;en-us;297989.

 4 Verify that the COM+ service is running.

http://support.microsoft.com/default.aspx?scid=kb;en-us;297989
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 5 Verify that the COM+ service is correct:

 a Select Start > Run and type dcomcnfg to open the COM+ manager.

 b Expand Component Services.

 c Expand Computers.

 d Right-click My Computer and select Properties. The My Computer 
Properties dialog box opens.

 e Click the MSDTS tab.

 f Click Security Configuration. The Security Configuration dialog box 
opens.

 g Ensure that Enable XA Transactions is not selected.

 h Click OK to close the Security Configuration dialog box.

 i Click OK to close the My Computer Properties dialog box.

 6 If the problem persists, follow the steps below depending on your version of 
Windows:

Windows 2003 SP2:

 a Disable services such as cluster services, which are installed with 
W2K3 Enterprise Edition.

 b If this fails, re-image the machine as follows:

➤ Reinstall Windows.

➤ Install IIS.

➤ Install SP1.

➤ Install SP2.

 7 If you receive an error message similar to the following:

Updating Applications: 
Name: IIS Out-Of-Process Pooled Applications Key:
{3D14228D-FBE1-11D0-995D-00C04FD919C1}
Error: 80110414
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This might occur because the password for the IWAM_computer account is 
mismatched between the Windows Active Directory and the IIS metabase. 
Therefore, Synciwam.vbs cannot synchronize the processes to the 
IWAM_computer account as needed. It might also occur if the 
IWAM_computer account is locked out or disabled.

You need to match the password that is used by the IWAM_computer 
account in the IIS metabase with the password that is used by the 
IWAM_computer account in Active Directory.

For more information see: http://support.microsoft.com/kb/269367

DllHost.exe – Application Error

Error message: Operation terminated. DllHost.exe – Application Error.

Troubleshooting

(IIS 5 only) Change the application protection level in the Internet Services 
Manager from High (isolated) to Low (IIS Process).

 1 Select Start > Programs > Administrative Tools > Internet Services Manager 
to open the Internet Information Services dialog box.

 2 In the Tree directory, expand Default Web Site and right-click Admin. Click 
Properties to open the Admin Properties dialog box.

http://support.microsoft.com/kb/269367
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 3 Select the Virtual Directory tab, and in the Application Protection list, select 
Low (IIS Process).

 4 After installation, change the Application Protection back to High (Isolated) 
by repeating the above steps and clicking High (Isolated) in step 3.

Failure to Retrieve License Key

Problem description: Configuring or retrieving license key fails.

➤ Administrator site: The License cannot be displayed on th License page. 
Get errors  such as:

➤ Failed to retrieve license key

➤ Object is required

➤ User site: Load test fails to run with similar messages.
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Troubleshooting

This problem could be related to:

➤ .NET Framework installation

Make sure .NET Framework is installed correctly. To repair the installation 
run the following command from command line:

➤ IIS configuration with PCWS directory

Try to re-install the PCWS virtual directory on the Utility Server by running 
the following command from command line:

➤ Performance Center system user should be a domain user

 a Run the System Identity Utility (<PC Admin Site Server Installation 
directory>/bin/IdentityChangerUtil.exe )

 b Change the Performance Center system user to a domain user.   

Performance Center Does Not Load - Error 500

Problem description: After upgrading the database client, Performance 
Center does not load the Web browser and returns Error 500.

Troubleshooting:

There might be a permissions problem between IIS and the Oracle home 
directory.

➤ Make sure oracle_home is well defined in the HKLM\Software\Oracle 
directory.

➤ Make sure the IWAM_<machine> user has execute and write permissions 
in the Oracle home directory.

➤ Make sure tnsnames.ora and sqlnet.ora are defined properly.

c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i 

<Performance Center installation directory>\bin\ AdminInstaller.exe" WebService 
IUSR_METRO MIOrchid#1
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Error on Page During System Configuration

Problem description: After you save your initial system configuration 
settings in the Administration Site, you receive an error in the Log area of 
the Initial System Configuration page stating that the page cannot be 
displayed.

Troubleshooting

During system configuration, IIS is reset on the Administration Site server. 
When the File Server is installed on the same machine as the Administration 
Site server, Error on Page is sometimes displayed as a result of the IIS reset.

Even though this error is displayed, the system configuration is still saved 
successfully. 

To continue configuring your system, log on to the Administration Site 
again and continue working.

Installation Does Not Recognize Prerequisite Software

Problem description: Before you can install Performance Center, specific 
prerequisite software (for example, .NET Framework 3.5) needs to be 
installed on your machine. Without this prerequisite software, Performance 
Center will not function properly. During installation, if the prerequisite 
software is not already installed on your machine, Performance Center lists 
the prerequisite software that you need to install and enables you to 
automatically install the software from the Performance Center disk. 

If the prerequisite software has been installed on your machine in an 
irregular way, Performance Center may not detect the installation and will 
not allow you to proceed with the installation.

Troubleshooting

If you are certain that you have correctly installed all the prerequisite 
software, you can skip the prerequisite software check in the installation 
procedure.



Chapter 2 • Troubleshooting Installation and Upgrade

26

Important: Skipping the prerequisite software check is not recommended 
practice, because Performance Center may not function properly as a result. 
The prerequisite software check should only be skipped under very limited 
circumstances, and after consultation with Customer Support.

To launch the Performance Center installation without the prerequisite 
software check, run the following command:

msiexec.exe /i HP_Performance_Center.msi SKIP_PREREQUISITE_CHECK=1
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Performance Center Prerequisite Software

Before you can install Performance Center, specific prerequisite software (for 
example, .NET Framework 3.5) needs to be installed on your machine. 
During installation, Performance Center checks whether the prerequisite 
software is installed on your machine. If anything is not installed, 
Performance Center enables you to automatically install the software from 
the Performance Center disk.

The following table provides a list of the prerequisite software and how 
Performance Center detects whether the software is installed.

Prerequisite 
Software

Machines Means of detecting

.NET 
Framework 3.5

➤ All Performance Center 
machines

➤ VuGen Standalone

➤ Analysis Standalone

Searches the registry key:

HKLM\\Software\\Microsoft\\NET 
Framework Setup\\NDP\\v3.5

Microsoft Data 
Access 
Components 
(MDAC) 2.8 
SP1 (or later)

➤ All Performance Center 
machines

➤ VuGen Standalone

➤ Analysis Standalone

Searches the registry key:

HKLM\\Software\\Microsoft\\Data
Access 

Microsoft Core 
XML Services 
(MSXML) 6.0

➤ All Performance Center 
machines

➤ VuGen Standalone

➤ Analysis Standalone

Queries the existence and 
version of: 
%systemroot%\system32\msxml
6.dll

Microsoft 
Visual C++ 
2008 
Redistributable 
Package (x86)

➤ All Performance Center 
machines

➤ VuGen Standalone

➤ Analysis Standalone

Queries the MSI manager for 
one of the GUIDs below:

{A49F249F-0C91-497F-86DF-B
2585E8E76B7}

{437AB8E0-FB69-4222-B280-A
64F3DE22591} 
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Microsoft 
Windows 
Installer 3.1

➤ All Performance Center 
machines

➤ VuGen Standalone

➤ Analysis Standalone

Looks for one of the two:

➤ Registration of the 
WindowsInstaller. 
Installer.com object version 
3 or higher 

➤ MSI.dll version 3 or higher 
in the %systemroot% 

Web Services 
Enhancements 
(WSE) 3.0 for 
Microsoft .NET 
Redistributable 
Runtime MSI

➤ All Performance Center 
machines

➤ VuGen Standalone

Queries the MSI manager for 
the GUID: 

{E3E71D07-CD27-46CB-8448-1
6D4FB29AA13} 

Web Services 
Enhancements 
(WSE) 2.0 SP3 
for Microsoft 
.NET 
Redistributable 
Runtime MSI

➤ All Performance Center 
machines

➤ VuGen Standalone

Runtime installation GUID 
{F3CA9611-CD42-4562-ADAB-A
554CF8E17F1} 

Full installation GUID 

{6F 
396FFB-CC3A-4335-BC0B-2AE
F38F4492C} 

Internet 
Information 
Services (IIS)

➤ All Performance Center 
machines

(In a machine used as load 
generator the IIS can be 
uninstalled after installation)

HKLM\\SOFTWARE\\Microsoft\\I
netStp 

Looks for both Major and 
Minor numbers. 

Supports versions 6.0, 5.1 and 
5.0

Prerequisite 
Software

Machines Means of detecting
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3
Troubleshooting Licenses

This chapter provides information on troubleshooting license-related 
problems.

This chapter includes:

 ➤  Invalid License Detected on page 29

 ➤  License Issue – Concurrent Users (Error -2147219264) on page 30

 ➤  License Issue -Concurrent Runs on page 30

 ➤  Failure to Retrieve License Key on page 31

Invalid License Detected

Error message: Cannot run a load test. Invalid license was detected.

Troubleshooting

 1 Make sure that you entered the correct host license key in the 
Administration Site (System Configuration > License).

 2 If the license is correct and there is still a problem, there may be an issue 
with Web services connectivity. For more information about 
troubleshooting Web services, refer to the relevant section in the HP 
Performance Center Administrator’s Guide.

 3 Make sure that the version of Performance Center installed on all servers 
and hosts is the same; otherwise communication between the hosts may 
fail. Check the registry entry under 
[HKEY_LOCAL_MACHINE\SOFTWARE\Mercury 
Interactive\LoadRunner\CurrentVersion] for the following variables:



Chapter 3 • Troubleshooting Licenses

30

➤ Major

➤ Minor

➤ ServicePack

License Issue – Concurrent Users (Error -2147219264)

Error message: Your Performance Center license does not support the 
number of concurrent users.

Troubleshooting

Since you have exceeded the overall number of concurrent users supported 
by your Performance Center license, you must do one of the following: 

➤ Ask your administrator to rearrange the number of Vusers that are being 
used concurrently in all the projects so that some Vusers can be made 
available for your test.

➤ Reduce the number of Vusers for your test.

➤ Upgrade your Performance Center license to enable support of more 
Vusers.

License Issue -Concurrent Runs

Error message: Your Performance Center license does not support the 
number of concurrent runs.

Troubleshooting

Since you have exceeded the overall number of concurrent runs supported 
by your Performance Center license, you must do one of the following: 

➤ Ask your administrator to rearrange the scheduling of the load tests to 
ensure that you are not exceeding the overall number of concurrent runs 
supported by your license. 

➤ Upgrade your Performance Center license to enable support of more 
concurrent runs.
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Failure to Retrieve License Key

Problem description: Retrieve License Key fails. This may occur as a result of 
problems with the .NET Framework installation.

Troubleshooting

Repair the .NET Framework installation as follows:

 1 Select Start > Run. 

 2 Enter the following command:

c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i
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4
Troubleshooting Load Test Design

This chapter provides information on troubleshooting problems related to 
designing load tests.

This chapter includes:

 ➤  Cannot Save Load Test (Error -ORA-03106) on page 33

Cannot Save Load Test (Error -ORA-03106)

Error message: Fatal two-task communication protocol error.

Troubleshooting

This error sometimes occurs after you change the run time settings when 
working with an Oracle database. The new details are not saved to the 
database, although a successful save was indicated.

The cause might be a mismatch between the character set of the Oracle 
client and the Oracle server.

➤ Make sure the NLS_LANG on the client and server match. They should be 
the same type or be of a type that can be converted.

➤ Consult with the database administrator on this issue.
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5
Troubleshooting Starting Load Tests

This chapter provides information on troubleshooting related to starting 
load tests.

This chapter includes:

 ➤  Timeslot Issue - No Available Load Generators (Error -2147219273) 
on page 36

 ➤  Timeslot Issue - No Available Controllers (Error -2147219274) on page 37

 ➤  Failed to Launch Controller (Error -2147220032) on page 38

 ➤  Controller Cannot Connect to Database (Error -2147219979) on page 39

 ➤  Not Enough Disk Space on Controller (Error -2147220152) on page 39

 ➤  Browser Stuck While Initializing Load Test on page 40

 ➤  Failure to Initialize Load Test on page 41

 ➤  License Issue -Concurrent Runs on page 41

 ➤  License Issue – Concurrent Users (Error -2147219264) on page 42

 ➤  Unable to Run Load Test that Is Already Active on page 42

 ➤  Cannot Initialize Load Test (Error -2147219790) on page 43

 ➤  Session Activation Fails on page 44

 ➤  License Manager Component Cannot Be Instantiated on page 45

 ➤  Unable to Instantiate License Manager Component - HTTPS (SSL) on page 45

 ➤  Cannot Run Load Test on Controller - Non-Admin System User on page 46

 ➤  Cannot Run Load Test Over Secure Channels on page 46
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 ➤  Load Test Run Fails. Load Generator Status Change to  Resource Failure 
on page 47

 ➤  Cannot Run Load Test on Controller with Windows XP –  Non-Admin System 
User on page 47

 ➤  Cannot Run Load Test with UNIX Load Generator on page 48

Timeslot Issue - No Available Load Generators 
(Error -2147219273)

Error message: Could not reserve timeslot. There are no available load 
generators.

Troubleshooting

 1 On the User Site Hosts page (Project > Hosts), check whether any load 
generator hosts appear and make sure that their status is operational. 

If no load generators appear, or if they have a status other than operational, 
contact your administrator.

 2 If operational load generators appear on the Hosts page, check on the User 
Site Timeslots page (Project > Timeslots) to see when the load generators are 
available. 

If the load generators are not available during the desired timeslot, try to 
reorganize the timeslots so that the necessary resources are available for your 
load test. 

Before you reorganize the timeslots, you should look at all the tests that you 
have scheduled in your system and consider the following factors:

➤ timeslot utilization. Some tests may have more timeslots reserved than is 
necessary, or there may be timeslots that have been reserved for no 
reason. 

➤ test importance. Less important tests can be moved to different timeslots 
to make space available for the more important tests.

➤ irrelevant tests. Check whether there are tests scheduled that are no 
longer relevant and can be removed from the timeslot schedule.
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Note: On the Administration Site Hosts page (Resources > Hosts), your 
administrator can enable the Controller host to also act as an additional 
load generator. In general, this is not recommended practice and is only 
appropriate for load tests that have a very small number of Vusers.

Timeslot Issue - No Available Controllers 
(Error -2147219274)

Error message: Could not reserve timeslot. There is no available Controller.

Troubleshooting

 1 On the User Site Hosts page (Project > Hosts), check whether any Controller 
hosts appear and make sure that their status is operational. 

If no Controllers appear, or if they have a status other than operational, 
contact your administrator.

 2 If operational Controllers appear on the Hosts page, check on the User Site 
Timeslots page (Project > Timeslots) to see when the Controllers are 
available. 

If the Controllers are not available during the desired timeslot, try to 
reorganize the timeslots so that you can make the necessary resources 
available for your load test. 

Before you reorganize the timeslots, you should look at all the tests that you 
have scheduled in your system and consider the following factors:

➤ timeslot utilization. Some tests may have more timeslots reserved than is 
necessary, or there may be timeslots that have been reserved for no 
reason. 

➤ test importance. Less important tests can be moved to different timeslots 
to make space available for the more important tests.

➤ irrelevant tests. Check whether there are tests scheduled that are no 
longer relevant and can be removed from the timeslot schedule.
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 3 If the Controller machine is also designated as a data processor, the 
Controller may not be available due to a failed analysis or publish operation 
in a previous test. 

If an analysis/publish operation fails, the machine on which this action was 
performed remains allocated to the analysis/publish action, and the 
machine cannot be used as a Controller.

If this is the case, you need to cancel the allocation to the specified 
machine(s) as follows:

 a In the Test Runs page (Site Management > Test Runs), check which runs 
are being analyzed or published. In the case of publishing, this might be 
a few runs.

 b Click Deallocate Hosts in the Test Runs page. The Deallocate Hosts dialog 
box opens.

 c Select Deallocate Analysis host and click OK. Repeat this procedure for 
each test run from which you want to deallocate hosts.

Failed to Launch Controller (Error -2147220032)

Error message: Failed to launch the Controller. 

The above error message also includes more details about the specific 
problem with the Controller license.

Troubleshooting

Contact your administrator to verify why there is problem with the 
Controller license. You can view and update license information on the 
Administration Site License page (System Configuration > License). 

For more information about licenses, see the section about configuring and 
viewing license information in the HP Performance Center Administrator 
Guide.
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Controller Cannot Connect to Database 
(Error -2147219979)

Error message: Controller cannot connect to database. Contact your 
administrator to remove the Controller from the host list and add it again to 
reset configuration. 

Troubleshooting

When you receive this error, it usually means that something changed on 
the Controller host machine. This could be due to someone reformatting or 
reinstalling the Controller. 

Your administrator needs to reset the Controller configuration by removing 
the Controller from the Administration Site Hosts page (Resources > Hosts) 
and then adding it again.

Not Enough Disk Space on Controller (Error -2147220152)

Error message: Not enough disk space left on Controller machine system 
disk 'C:\'.

Troubleshooting

You need to make disk space available on the Controller host machine. For 
more information about the host system requirements, see the section about 
system component requirements in the HP Performance Center System 
Configuration and Installation Guide.
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Browser Stuck While Initializing Load Test

Problem description: During the initialization of a load test, the browser 
gets stuck.

Troubleshooting

 1 Restart your test as follows:

 a Close your browser.

 b Open your browser again and log in to the Performance Center User Site.

 c Start the test again

 2 If your browser gets stuck again, restart the relevant host machines as 
follows:

 a Close the Performance Center User Site. 

 b Restart the host machines (load generators and Controllers) that you are 
using in this test.

 c Open the Performance Center User Site, log in, and start the test again.

 3 If your browser gets stuck again, check with your administrator if there are 
any problems with the utility server that could be causing these issues.

 4 If you are still experiencing problems, contact Customer Support (http://
www.hp.com/go/hpsoftwaresupport) for assistance. 

http://www.hp.com/go/hpsoftwaresupport
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Failure to Initialize Load Test

Problem description: When trying to run a load test, the test fails to 
initialize.

Troubleshooting

 1 Start the test again.

 2 If initialization still fails, restart the relevant Controller host machines as 
follows:

 a Close the Performance Center User Site. 

 b Restart the Controller host machines that you are using in this test.

 c Open the Performance Center User Site, log in, and start the test again.

 3 If initialization still fails, try to assign a different Controller host (if 
available) to your test. 

If this solves the problem, contact Customer Support (http://www.hp.com/go/
hpsoftwaresupport) to check why the test did not work with the original 
Controller host.

 4 If you are still experiencing problems, contact Customer Support for 
assistance. 

 License Issue -Concurrent Runs

Error message: Your Performance Center license does not support the 
number of concurrent runs. 

Troubleshooting

Since you have exceeded the overall number of concurrent runs supported 
by your Performance Center license, you must do one of the following: 

➤ Ask your administrator to rearrange the scheduling of the load tests to 
make sure that you are not exceeding the overall number of concurrent 
runs supported by your license. 

➤ Upgrade your Performance Center license to enable support of more 
concurrent runs.

http://www.hp.com/go/hpsoftwaresupport
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License Issue – Concurrent Users (Error -2147219264)

Error message: Your Performance Center license does not support the 
number of concurrent users. 

Troubleshooting

Since you have exceeded the overall number of concurrent users supported 
by your Performance Center license, you must do one of the following: 

➤ Ask your administrator to rearrange the number of Vusers that are being 
used concurrently in all the projects so that some Vusers can be made 
available for your test.

➤ Reduce the number of Vusers for your test.

➤ Upgrade your Performance Center license to enable support of more 
Vusers.

Unable to Run Load Test that Is Already Active

Error message: Unable to create new load test run. There is already an 
identical active load test.

Troubleshooting

If a load test is running, you cannot run the same load test (with identical 
settings) concurrently. As a workaround, you can copy the settings of the 
test that you want to run and change the name. 

If there are enough host resources to run both tests concurrently, you should 
be able to run the new test.

Note: You copy a test on the Load Tests configuration page (Load Tests > 
Manage) of the Performance Center User Site. For more information about 
copying load tests, see the section about copying a load test in the HP 
Performance Center User Guide.
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Cannot Initialize Load Test (Error -2147219790)

Problem description: You start the load test and get an error that the load 
test cannot be initialized.

This problem can occur for any of the following reasons:

➤ Scripts Are Inaccessible

➤ Unable to Instantiate 'OrchidResourceDB' Component

Scripts Are Inaccessible 
The scripts are inaccessible so the load test fails to initiate.

Error message: Cannot access the load test scripts. Please check load test 
definitions.

Troubleshooting

The script may be inaccessible for any of the following reasons:

➤ The script was deleted.

➤ The script was moved to a different directory. 

➤ There is a network problem preventing access to the script.

➤ Security/permissions issues could be preventing access to the script 
directory. 
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Unable to Instantiate 'OrchidResourceDB' Component
The load test fails to start. When it reaches step "searching for controller," 
get the following error:

In the Administration Site, the Event Log displays an error which ends with 
" RunFixer: Unknown error 0x800A000D] Type mismatch ."

Troubleshooting

 1 Log in to the specific Controller machine that failed.

 2 In the Services window, make sure the "DataCollectionAgent" service is 
running.

Session Activation Fails

Error message: Session activation failed. Reported from method: 
‘SA:AllocResourcesAndStartSes’; Session ID: #; Reason: 

Troubleshooting

 1 Verify that there is network connectivity between the host and the Web 
server. The latency should be less than 20 ms to and from all Performance 
Center machines, excluding the load generators.

 2 Check the Event Viewer administrative tool on both the Web server and 
Controller machines (Start > Settings > Control Panel > Administrative 
Tools > Event Viewer).

 Failed to initialize load test!    
 Error: Unable to run load test.2147219790Details: Activation attempt [1]: Unable to 
instantiate 'OrchidResourceDB' component; Activation attempt [2]: Unable to instantiate 
'OrchidResourceDB' component; Activation attempt [3]: Unable to instantiate 
'OrchidResourceDB' component  
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License Manager Component Cannot Be Instantiated

Error message: Cannot run the load test. Unable to instantiate License 
Manager component.

Troubleshooting

If you receive the above error, remove the PCIMkipper process and perform 
an IIS reset.

Unable to Instantiate License Manager Component - HTTPS 
(SSL)

Problem Description: When trying to run a load test you get the following 
error: Cannot run the Load Test. Unable to instantiate License Manager 
component.

Troubleshooting

You may get this error after configuring your server to work with HTTPS 
(SSL). 

 1 On the Utility Server, open the IIS Manager (Start > Control Panel >  
Administrative Tools  >  Internet Information Services).

 2 In the WebSites/Default Web Site directory, right-click PCWS and click 
Properties.

 3 On the Directory Security tab, under Secure Communication, click Edit.

 4 Make sure that Require Secure Channel SSL is not selected.

 5 Click OK.

 6 Reset IIS.
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Cannot Run Load Test on Controller - Non-Admin System 
User

Problem description: When the system user is a non-administrative user, if 
you try to run load test on a Controller for the first time, the load test does 
not run.

Troubleshooting

Before running load tests on a Controller for the first time, you must log on 
to the host machine with a user that has administrator privileges, open the 
Controller manually, and then close the Controller. The next time you try to 
run a load test on the Controller, the load test should run successfully.

To open the Controller manually:

 1 From the command line, run wlrun. The Controller opens.

 2 Close the Controller.

Cannot Run Load Test Over Secure Channels

Problem description: When you try to run a load test over secure channels,  
the load test cannot initialize because cannot connect to Controller or load 
generator.

Troubleshooting

Verify that the load test cannot run due to a security mismatch by trying to 
run the same load test with the same hosts from a local Controller. 

If a Security Key Mismatch error is displayed in the error log, then the keys 
do not match, and you need to align the security keys on all the machines.
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Load Test Run Fails. Load Generator Status Change to 
Resource Failure

Problem description: When trying to run a load test over secure channels, 
the load test fails to run and the load generator status changes to Resource 
Failure.

Troubleshooting

When trying to run a load test over secure channels, if the security keys on 
the Controller and load generator do not match the load test run fails, and 
the status of the load generators changes to Resource Failure.  To re-enable 
the load generators, you must manually reset the status on each affected 
load generator to Operational. 

Cannot Run Load Test on Controller with Windows XP – 
Non-Admin System User

Problem description: If the system user is a non-administrative user, you 
cannot run a load test on a Controller host in a Windows XP environment.

Troubleshooting

Workaround: Add the system user to the machine’s COM security settings.

To add the system user to the COM security settings:

 1 Select Start > Run, and type dcomcnfg. The Components Services window 
opens.

 2 Under Console Root\Component Services\Computers, right-click My 
Computer and select Properties.

 3 In the My Computer Properties dialog box, click the COM Security tab.

 4 Under Access Permissions, click Edit Default, and add the system user with 
full access to the default security.
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 5 Under Launch and Activation Permissions, click Edit Default, and add the 
system user with full access to the default security.

 6 In the My Computer Properties dialog box, click OK.

Cannot Run Load Test with UNIX Load Generator

Error message: Failed to initialize load test.

Troubleshooting

If Performance Center cannot connect the load generator to the Controller, 
manually change the wlrun7.ini file as follows:

 1 Open the wlrun7.ini file in a text editor.

 2 Change HostUnixDontUseRSH from 0 to 1.

 3 Try to rerun the test.
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6
Troubleshooting Running Load Tests

This chapter provides information on troubleshooting problems related to 
running load tests.

This chapter includes:

 ➤  Data Processor Error When Publishing Load Test on page 50

 ➤  Load Test Seems to Run, But Is Not Actually Running on page 50

 ➤  Load Test Does Not Run All Vuser Groups on page 51

 ➤  Vuser Group Does Not Start Running on page 51

 ➤  Load Test Does Not Stop Running on page 52

 ➤  User Site is Sluggish During a Load Test on page 52

 ➤  Online Graphs Stop Displaying During a Load Test on page 52

 ➤  Transaction Response Time Graph Not Showing Correct  Time Interval 
on page 53

 ➤  New Vusers Stop Initiating During a Load Test on page 54

 ➤  Failed to Run Load Test - Scripts Created with .NET Add-On on page 55

 ➤  Vusers Are Stuck in Initialization on page 56

 ➤  Vuser Replay Fails on page 57

 ➤  Connection to Database Timed Out on page 61

 ➤  Orchid Monitor Error on page 62

 ➤  Cannot Run Load Test with Non-Admin User on page 62

 ➤  SiteScope Server Fails to Retrieve Data from Hosts/Servers on page 63

 ➤  Failure to Run Load Test on page 64
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Data Processor Error When Publishing Load Test

Problem description: When trying to publish a load test from a pool with no 
data processor, an error link appears by the test run in the Load Tests page.

Troubleshooting:

 1 In the Administrator Site, add a data processor to the pool assigned to the 
project.

 2 In the User Site, on the Load Test Results page’s Results vs. Targets tab, click 
Publish. This cancels the publishing process.

 3 Republish the results. The error message disappears.

Load Test Seems to Run, But Is Not Actually Running

Problem description: You are unable to run a load test. The Performance 
Center error message states that a test is currently running, but no tests are 
actually being run.

Troubleshooting

 1 Verify whether a load test is actually running on the target Performance 
Center Controller host. 

 2 If no test is actively running, reset the host state using the Performance 
Center Administration Site, as follows:

 a From the Performance Center left menu, select Site Management > 
Test Runs. The Test Runs page opens.

 b Select the relevant run from the test runs table.

 c In the test runs toolbar, click the Fast Recovery button. 

This cleans the state of hosts in the database, and makes the problematic 
host available for future load tests. If the host is in Resource Failure state 
and cannot be used in your load test, see “Troubleshooting Hosts and 
Servers” on page 79.
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Load Test Does Not Run All Vuser Groups

Problem description: Performance Center did not run all the Vuser groups 
defined in the load test.

Troubleshooting

Performance Center supports running up to 47 Vuser groups in a load test 
run.

Vuser Group Does Not Start Running

Problem description: The Vuser group in the load test does not start 
running.

Troubleshooting

This problem occurs if a Vuser group is scheduled to run after a Vuser group 
that is set to run indefinitely.

If Group A is set to run indefinitely, and Group B is scheduled to run after 
Group A, then Group B will run only if you do one of the following:

➤ Stop Group A manually

➤ Add a Stop Vusers action to Group A’s schedule

➤ Modify Group B’s Start Group action to start running after a specified 
amount of time
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Load Test Does Not Stop Running

Problem description: Vusers in the load test do not stop running.

Troubleshooting

If a load test schedule does not have a Stop Vusers action, the load test does 
not stop running. 

Possible causes:

➤ The Stop Vusers action was deleted

➤ With load tests scheduled to run indefinitely in Performance Center 
versions 8.1 or earlier, during migration no Stop Vusers action is created, 
since the Vusers are not meant to stop running

Solution: Check the Actions defined in the Actions grid of the load test’s 
schedule. If no Stop Vusers action is defined, the schedule continues to run 
indefinitely. To stop running the load test, define a Stop Vusers action in the 
load test schedule.

User Site is Sluggish During a Load Test

Problem description: The Controller machine may be over-utilized.

Troubleshooting

See “New Vusers Stop Initiating During a Load Test” below.

Online Graphs Stop Displaying During a Load Test

Problem description: The Controller machine may be over-utilized.

Troubleshooting

See “New Vusers Stop Initiating During a Load Test” on page 54.
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Transaction Response Time Graph Not Showing Correct 
Time Interval

Problem description: When running a scenario, the Transaction Response 
Time graph displays the whole load test duration, instead of the time 
interval it is configured to display. 

For example, in the illustration below, the graph is configured to display the 
last three minutes, but it still displays the whole load test duration.

Troubleshooting

This occurs if transactions selected in the graph legend did not run during 
the configured time interval. 

In the above example, the vuser_init_transaction finished running at the 
beginning of the run, but it is selected in the graph legend so it is still being 
displayed. 
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To display the correct time interval on the Transaction Response Time 
graph, ensure that transactions that did not run during the configured time 
interval are not selected in the legend. 

New Vusers Stop Initiating During a Load Test

Problem description: During a load test, new Vusers stop initiating.

Troubleshooting

The Controller machine may be over-utilized.

 1 Make sure that you are not running any Vusers on the Controller machine.

 2 Check that the machine is responsive and CPU utilization on the Controller 
machine during a load test is below 100%.

 3 Disable any software that may interfere with the Performance Center 
Controller, file server, or Web server. This includes any auditing or virus 
scanning software.
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 4 If CPU utilization is high, check whether:

➤ the online.exe process is consuming excessive CPU. If it is, this means 
that you might have too many active remote viewing sessions (for 
example, many people are watching the load test from different 
browsers). To fix this problem, either decrease the frequency at which the 
load test viewing sessions are refreshed (from each individual client 
browser), or decrease the number of concurrent viewing sessions for the 
current or problematic load test.

➤ the wlrun.exe process is consuming excessive CPU. If it is, check whether 
your load test is:

➤ producing many error messages. If it is, reduce the number of error 
messages by resolving the reasons for the error messages.

➤ producing many logging messages (for the Controller). If it is, disable 
or reduce the logging level, or avoid using log statements (such as 
lr_message) that send messages to the Controller’s output window.

➤ running scripts without any think times, and thus producing a lot of 
data that is sent back to the Controller.

If CPU consumption cannot be reduced for the load test, consider upgrading 
your Controller hardware.

Failed to Run Load Test - Scripts Created with .NET Add-On

Problem description: Running scripts with protocols such as vbNet (VB.NET 
Template) , CsNet (C#.NET Template), VcNet (C++.NET Template) that were 
created with the .NET add-on (visual studio 2003 or 2005) fails.

Troubleshooting

This problem is related to .NET security definitions with the use of a UNC 
path (see http://social.msdn.microsoft.com/forums/en-US/winformssetup/thread/
f1b4f239-4c53-43a4-89b2-31c1d666ccac/).

http://social.msdn.microsoft.com/forums/en-US/winformssetup/thread/f1b4f239-4c53-43a4-89b2-31c1d666ccac/
http://social.msdn.microsoft.com/forums/en-US/winformssetup/thread/f1b4f239-4c53-43a4-89b2-31c1d666ccac/
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In Performance Center, scripts are stored on the File Server. When running 
Vusers from Performance Center, the host machine accesses Vuser scripts 
stored on the File Server using UNC paths.

To run a load test with these scripts, run the following command from the 
command line on the host machine:

Vusers Are Stuck in Initialization

Problem description: Vusers are stuck in initialization, or never run at all. 
This can occur if you made modifications to a script and overwrote the 
existing script in Performance Center. Although you uploaded the script, 
the new run-time logic of the script is not updated for the load tests that see 
the script.

When the load test is run with the updated script, a pop-up window is 
displayed in wlrun.exe on the Controller. To verify this, run wlrun.exe on 
the Controller as an interactive user (see “Option 3: Launch wlrun.exe 
manually from the Controller host machine” on page 83 for configuration 
details).

Example: A load test named TestLoadTest refers to a script named Test that 
contains four sections: vuser_init, action1, action2, and vuser_end. If you 
modify the Test script so that it includes only three sections—vuser_init, 
action3, and vuser_end—and overwrite the previous Test script by 
uploading the modified script to Performance Center, the Vusers will not 
run when you run TestLoadTest. This is due to the fact that the old script’s 
run-time logic remains and the load test still “thinks” that there are two 
actions sections, action1 and action2, as opposed to the one action section 
in the updated script, action3. 

 %windir%\Microsoft.NET\Framework\v2.0.50727\caspol -m -cg LocalIntranet_Zone 
-allcode FullTrust 
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Troubleshooting

Option 1:

 1 When modifications are made to a script, change the name of the script by 
adding a version number to it. For example, TestScript_1 can be changed to 
TestScript_2. This way, when you upload the updated script, the current 
script remains, and the load test will still run.

 2 Create a new load test, and add the new version of the script to it.

Option 2:

When modifications are made to a script, remove the script from the load 
test, then add it to the load test again.

Note: Option 1 is recommended, as it enables you to keep track of your 
script and load test configuration changes.

Vuser Replay Fails

Problem description: Vusers are not picking up the correct environment 
settings and replay fails.

Troubleshooting

Option 1: Check the environment settings and software installation

The load generator machines on which the test is running must have the 
correct software installed and the proper environment variables set for the 
user.

For Microsoft Media Player:

 1 Log in to the load generator as the Performance Center system user and run 
Windows Media Player Install for Windows Media.

 2 Check the System environment variable Path to make sure that the 
Windows Media Player path is set correctly. Reboot, if necessary, for the 
correct settings to take effect.
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 3 On the load generator machine, use VuGen to run the script and test it.

For Java:

 1 Log in to the load generator machine as the Performance Center system 
user.

 2 Make sure that the Path environment variable for both User and System do 
not have an instance of Java Virtual Machine. Performance Center retrieves 
the JVM information from the registry.

 3 If the script replays on the VuGen machine on which the script was created, 
copy the machine’s CLASSPATH environment variable and place it in the 
System environment variable area of the load generator machine.

 4 On the load generator machine, run a simple script using VuGen to get the 
environment variable settings. Add the following lines to verify that the 
environment variables are set correctly:

Note: Make sure that you add the protocol definition char* getenv(char*); at 
the top of the script file.

For Citrix:

 1 Make sure that the Citrix client is installed on the load generator machine.

 2 Run the script through VuGen on the load generator machine.

For Databases:

Make sure that you have the appropriate database client installed on the 
load generator machine, and the appropriate settings in the System Path 
environment variable.

char *env;
env = getenv(“PATH”);
lr_output_message(“%s”,env);
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For Tuxedo:

 1 Make sure that the Tuxedo client is installed on the load generator machine.

 2 Verify that the following environment variables are set under System:

➤ Path. Add the tuxedo\bin directory to this variable.

➤ TUXDIR. The root directory of the TUXEDO installation. It is called 
ROOTDIR in TUXEDO 4.2 and earlier versions of TUXEDO. This 
environment variable is mandatory on the NT platform (For example: 
TUXDIR=D:\PSHr755\tuxedo).

➤ NLSPATH. Contains sub-directories to support the localization of system 
messages, along with message catalogs for the default locale (U.S. 
English). This environment variable is also mandatory on the NT 
platform (For example: NLSPATH=$TUXDIR\locale\c).

➤ WSNADDR. The address of the TUXEDO server (may need to be set). In 
pre-TUXEDO 6.3 versions this is in hex—for example, 
0x0002ffffc7cb4ebd. The 0002 indicates the IP, ffff indicates the port 
number, and cbcb4ebd indicates the IP address of the machine that 
contains the server. TUXEDO 6.3 also allows a more mnemonic way of 
indicating the server’s address. This environment variable is mandatory 
on the NT platform (For example: WSNADDR=199.35.108.119:7000).

➤ ULOGPFX. Prefix for the TUXEDO log file (may need to be set). The name 
of the log file includes the current date represented as a six-digit 
number—for example, 081797 for August 17, 1997. The ULOGPFX can 
contain a directory name as well as part of the file name itself (For 
example: ULOGPFX=/u/markn/ul).

Note: Make sure that you add the protocol definition char* getenv(char*); 
at the top of the script file.
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Option 2: Configure the Controller to work as an interactive user

Running a GUI script in Performance Center may cause HP WinRunner or 
HP QuickTest Professional to crash due to the configuration of 
Wlrun.Engine. To rectify this situation, configure the Controller to work as 
an interactive user.

To configure the Controller to work as an interactive user:

 1 Make sure the wlrun process is not running on the machine.

 2 Select Start > Run and type dcomcnfg.

 3 Press ENTER to display the list of DCOM applications.

 4 In the displayed application list, right-click wlrun.LrEngine and select 
Properties. 

 5 In the Identity tab, select The interactive user.

 6 Click OK twice to close both dialog boxes.

 7 Log in to the machine in the Performance Center environment as the 
system user. This user, which is installed with Performance Center, is 
displayed in the General Settings page of the Administration Site.
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Connection to Database Timed Out 

Error Message: The connection to database timed out.

Problem description: The load test cannot run. Performance Center runs 
slowly when configured with Oracle 9i or 10g server/client and an error may 
be displayed in the Administration Site stating that the connection to 
database timed out.

Troubleshooting

 1 Make sure that you are accessing the database through TNSNAMES and not 
ONAMES, which can lead to a noticeable and ever-increasing time delay 
connecting to the database. This time delay does not exist if TNSNAMES is 
used. 

To use TNSNAMES, change its priority within the SQLNET.ORA file by 
editing the <Oracle installation directory>\network\admin\sqlnet.ora file 
and setting the NAMES.DIRECTORY_PATH as follows: 

Note that TNSNAMES must be the first entry in the DIRECTORY_PATH.

 2 Comment out the line SQLNET.AUTHENTICATION_SERVICES= (NTS) within 
the <Oracle installation directory>\network\admin\sqlnet.ora file located 
on the database server machine.

 3 Validate connection performance to the Performance Center database. Run 
the TcQA_CheckDatabaseConnection.vbs script (available as a download 
from the Customer Support Web site Knowledge Base, ID39475) to quantify 
the performance of the connection to the Performance Center database. 
Make sure that the connect times are constant and low.

NAMES.DIRECTORY_PATH = (TNSNAMES,ONAMES)

http://support.mercury.com/
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The following is an example of a sample output:

Orchid Monitor Error

Problem description: Error from Orchid monitor in Error Window during 
the run.

Troubleshooting

The Windows Remore Registry Service should be running on the host 
machine.

 1 Select Start > Programs > Administrator Tools > Services to open the services 
window.

 2 Search for the Remote Registry Service

 3 Make sure the service’s status is Started and is set to Automatic.

Cannot Run Load Test with Non-Admin User

Problem description: You cannot run a load test with a non-administrative 
system user, or after a user is changed.

Troubleshooting

 1 Verify that all the required services are running.

 2 Try to run alagentservice and magentservice using the following 
commands:

Database Connection String: Provider=SQLOLEDB.1;User 
ID=OrchidUser;PWD=orchid;Initial Catalog=MI_LRDB;Data 
Source=samurai\mssqla;QuotedID=No Statistics:
Attempt #1: Connect= 1 secs,  Query= 2 secs
Attempt #2: Connect= 1 secs,  Query= 1 secs
Attempt #3: Connect= 2 secs,  Query= 1 secs
Attempt #4: Connect= 2 secs,  Query= 1 secs
Attempt #5: Connect= 2 secs,  Query= 1 secs
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➤ alagentservice

where username and password are those of the Performance Center 
system user.

➤ magentservice

where username and password are those of the Performance Center 
system user.

 3 If the load test fails in the first step, check the LRFS folder. If there is a 
problem configuring the LRFS folder, try restarting the machine. 

 4 Check the identity of the COM objects, especially OrchidActiveSession and 
wlrun.lrengine. The identity should be the Performance Center system user.

SiteScope Server Fails to Retrieve Data from Hosts/Servers

Problem description: If you change the system user to a non-administrative 
user and then enable SiteScope on any of the Performance Center servers or 
hosts, SiteScope cannot retrieve all required data.

Troubleshooting

Manually configure an administrative user on the SiteScope server so that it 
has permissions to monitor the server/hosts machines and retrieve all the 
required data.

%installation folder%\al_agent\bin\alagentservice.exe -remove 

%installation folder%\al_agent\bin\alagentservice.exe -install username password 

%installation folder%\launch_service\bin\magentservice.exe -remove 

%installation folder%\launch_service\bin\magentservice.exe -install username 
password
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To configure an administrative user on the SiteScope server:

 1 In your browser, type the URL for SiteScope as follows:

where sitescope_server is the name of your SiteScope server.

 2 At the top of the SiteScope page, click SiteScope.

 3 Click Remote Windows.

 4 From the list, select the relevant machine and click Edit.

 5 In the Login and Password fields, type the login name and password of a 
system user with administrative privileges.

 6 Click Update.

 Failure to Run Load Test

Problem description: The load test fails to run. This may occur as a result of 
problems with the .NET Framework installation.

Troubleshooting

Repair the .NET Framework installation as follows:

 1 Select Start > Run. 

 2 Type the following command:

http://<sitescope_server>:8888/sitescope

c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i
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7
Troubleshooting Autostart

This chapter provides information on troubleshooting errors related to 
autostarting load tests.

This chapter includes:

 ➤  License Validation Failed on page 66

 ➤  Timeslot Validation Failed on page 66

 ➤  Load Test is Already Active on page 67

 ➤  Load Test Exceeded Timeslot on page 68

 ➤  Cannot Instantiate Session Activator Component on page 69

 ➤  Cannot Activate Load Test Run on page 69
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License Validation Failed

Error Message: License Validation Failed.

Troubleshooting

Each load test’s activation is validated against the Performance Center 
license limitations for the number of Vusers, machines, and concurrent 
runs, as well as project limitations and the license’s expiration date.

➤ Check if the Performance Center license or the project settings were 
modified. If they have been modified, reschedule the load test according to 
the new settings.

➤ Check if the Performance Center license has expired.

Timeslot Validation Failed

Error message: Timeslot validation failed. Please make sure that timeslot 
duration is at least 20 minutes.

Troubleshooting

Reserve a new timeslot for the load test that has at least 20 minutes 
available.
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Load Test is Already Active

Error Message: There is already a run executing for this load test.

Troubleshooting

A load test can have one of the following states: Ready, Running, Stopping, 
Collating Results, or Creating Analysis Data. Each of these states is 
considered an Active state. A load test can only have one Active state at any 
one time. If you try to run a load test that already has an Active state, you 
will receive the above message.

If the current state is Ready, Running, or Stopping, reset the load test using 
the HP Performance Center Administration site as follows:

 a From the Performance Center left menu, select 
Site Management > Test Runs. The Test Runs page opens.

 b Select the relevant run from the test runs table.

 c In the test runs toolbar, click the Fast Recovery button. 

This cleans the state of the load test and makes the host available for future 
load tests.

If the current state is Collating Results, use the fast recovery feature as 
described above, and then deactivate the collator process as follows:

 a On the Administrator Site, select Site Management > Test Runs. The Test 
Runs page opens.

 b Select the relevant run from the test runs table.

 c In the test runs toolbar, click the Deactivate collator process button. The 
Deactivate Collator dialog box opens.

 d Click OK to confirm that you want to deactivate the collator process. A 
dialog box opens confirming that the process was deactivated.

 e Click Close to close the dialog box.
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If the current Active state is Creating Analysis Data, use the fast recovery 
feature as described above, and then kill the process to free up more 
resources as follows: 

 a On the User site, select Project > Hosts. The Hosts page opens.

 b In the Hosts table, click the relevant host. The Host Details page opens.

 c In the Host Details page, select the processes tab.

 d In the relevant process’s Kill column, click Kill Process.

Note: The Creating Analysis Data process is very CPU and I/O intensive. 
Killing this process should be considered only in the event you have not 
been able to resolve the problem in any other way.

Load Test Exceeded Timeslot

Error Message: Load test <test name> exceeded its timeslot. Executing run 
failed to stop in a timely manner.

Troubleshooting

This usually occurs when you reserve consecutive autostart timeslots that 
share resources, or where the first defined load test is very CPU and/or I/O 
intensive and/or has a large number of Vusers scheduled to run at the same 
time. This can cause the first load test to overrun its timeslot and as a result 
the second load test will not run.

When reserving consecutive autostart timeslots:

➤ Make sure that you leave a suitable time interval between the timeslots.

➤ Do not select the Collate and Analyze Results or Collate Only post run 
analysis options for the first timeslot.
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Cannot Instantiate Session Activator Component

Error Message: Unable to instantiate Session Activator Component.

Troubleshooting

This is an indication of an internal error.

➤ Reset the User Site and/or the Utility and/or the Host Machine.

➤ If that does not resolve the problem, contact HP Support.

Cannot Activate Load Test Run

Error Message: Unable to activate and start load test run.

Troubleshooting

➤ Check Session Activator Errors:

➤ Run the load test manually to try resolve issues that arise.

➤ When reserving the timeslot, do not select Manual machine selection. 
Select Automatic instead.

➤ Check the load test for run time settings errors. 



Chapter 7 • Troubleshooting Autostart

70



71

8
Troubleshooting Post Load Test

This chapter provides information on troubleshooting issues that may arise 
after running a load test.

This chapter includes:

 ➤  Cannot Find Data Processor to Publish Load Test Results on page 71

 ➤  Failure to Launch Online Analysis on page 72

 ➤  Cannot Export Trend View Information to CSV Format on page 72

Cannot Find Data Processor to Publish Load Test Results

Problem description: When trying to publish load test results to the 
Dashboard, you get an error that Performance Center cannot find a data 
processor.

Troubleshooting

 1 Log on to the Performance Center Administration Site and edit the host so 
that it also functions as a data processor. (For more information, see the HP 
Performance Center Administrator Guide.)

 2 In the User Site, refresh the Dashboard page.

 3 If Performance Center still cannot find the data processor, unpublish the 
results and republish them.



Chapter 8 • Troubleshooting Post Load Test

72

Failure to Launch Online Analysis

Problem description: Performance Center cannot launch online Analysis 
when the Controller does not have access to the Utility Server. The run 
initialization fails.

Troubleshooting

➤ Check the DNS settings to make sure you can ping the Utility Server from 
the Controller.

➤ In the case of an Oracle database, make sure the tnsnames.ora is defined 
properly.

Cannot Export Trend View Information to CSV Format

Problem description. Performance Center fails to export the information 
contained in a trend report’s trend view to CSV format.

Troubleshooting

Check your Internet Explorer settings as follows:

 1 On your machine, select Tools > Internet Options.

 2 Select the Security tab.

 3 Click Custom Level.

 4 Under Downloads, make sure that the Automatic Prompting for File 
Downloads setting is set to Enable. 
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9
Troubleshooting Terminal Sessions

This chapter provides information on troubleshooting problems related to 
terminal sessions.

This chapter includes:

 ➤  Unable to Create Terminal Sessions on the Load Generator on page 74

 ➤  Controller and Load Generator Cannot Communicate on page 76

 ➤  Running a GUI Script in HP Performance Center Causes  HP WinRunner or 
HP QuickTest Professional to Crash on page 76

 ➤  Unable to Set Terminal Services for a Machine Name Added  as an IP Address/
Domain Name on page 77
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Unable to Create Terminal Sessions on the Load Generator

Error message: Cannot create terminal sessions on the load generator. There 
might be a problem with logon credentials.

Troubleshooting

 1 Verify that the correct terminal server login settings are selected. For 
information about verifying the settings, see “Configuring Terminal Services 
Logon Settings” on page 235.

 2 If you encounter a network connection error stating that the user is not 
mapped to the drive on the terminal server machine (see graphic below), 
create a separate terminal services profile for each user that is used to log in 
to a terminal server session. For more information, see the Microsoft 
Terminal Services documentation (http://technet2.microsoft.com/
windowsserver/en/technologies/featured/termserv/default.mspx). 

 3 Verify that the correct Client Settings are selected:

 a Select Start > Programs > Administrative Tools > Terminal Services 
Configuration > RDP-TCP. Right-click RDP-TCP, and select Properties to 
open the RDP-TCP Properties dialog box.

 b In the RDP-TCP Properties dialog box, select the Client Settings tab.
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 c Make sure that Use connection settings from user settings is disabled.

 4 If the run fails to create terminal services, open the terminal services from a 
specific host and make sure there are no pop-up messages when you log in 
as the Performance Center user. By default, the Performance Center user is a 
local user, MI_LRDB, unless the system user was changed from the General 
Settings page of the Administration site (System Configuration > General 
Settings > Change User).



Chapter 9 • Troubleshooting Terminal Sessions

76

Controller and Load Generator Cannot Communicate

Problem description: There is no connection between the Controller and 
the load generator on the terminal server.

Troubleshooting

 1 Verify that the terminal server is installed correctly.

 2 Verify that there are active sessions on the Terminal Services Manager 
(Start > Programs > Administrative Tools > Terminal Services Manager).

 3 If you are using an existing terminal session, verify that the Performance 
Center agent icon appears in the terminal server’s system tray. This indicates 
that the agent is running.

 4 Make sure that the Performance Center user has Create Global Object 
privileges when running a terminal server session on a Windows Server 
2003, Windows XP SP2, or Windows 2000 Server SP4 machine. Add the 
Performance Center Administrators group (or the group to which the 
Performance Center user belongs) to the Create Global Object privilege, 
under Local Security Policies\Users Rights on the terminal server machine.

Running a GUI Script in HP Performance Center Causes 
HP WinRunner or HP QuickTest Professional to Crash

Problem description: The DCOM configuration of Wlrun.Engine causes HP 
WinRunner or HP QuickTest Professional to crash while running a GUI 
script in Performance Center.

Troubleshooting

Workaround: Configure the Controller to work as an interactive user.

 1 Make sure that the wlrun process is not running on the machine.

 2 Select Run from the Windows Start menu and type dcomcnfg.

 3 Press ENTER to display the list of DCOM applications.
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 4 In the displayed application list, right-click wlrun.LrEngine and select 
Properties. 

 5 In the Identity tab of the dialog box, select The interactive user.

 6 Click OK twice to close both dialog boxes.

 7 Log in to the machine in the Performance Center environment as the 
system user. This user, which is installed with Performance Center, is 
displayed in the General Settings page of the Administration Site.

Unable to Set Terminal Services for a Machine Name Added 
as an IP Address/Domain Name

Problem description: When your environment is configured with a local 
user (in the General Settings page of the Administration Site), you cannot 
set terminal services for a machine name that was added as an IP address or 
a domain name (for example, 127.0.0.1, localhost.hp.com).

Troubleshooting

Workaround: Delete the host from the Hosts page of the Administration 
Site, and add the host machine again using the host name only.



Chapter 9 • Troubleshooting Terminal Sessions

78



79

10
Troubleshooting Hosts and Servers

This chapter provides information on troubleshooting host-related 
problems.

This chapter includes:

 ➤  Host in Resource Failure on page 80

 ➤  Unable to Add a Load Generator Due to High Latency on page 86

 ➤  Problems Changing SiteScope Server in Administration Site on page 87

 ➤  SiteScope Server Fails to Monitor the MS-SQL Database on page 88

 ➤  Failure to Add Host on page 89

 ➤  Failure to Reboot Host from Administration Site on page 91

 ➤  Not Enough Server Storage Available on page 92
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Host in Resource Failure

Problem description: The host is in Resource Failure status.

Troubleshooting

Option 1: Check the host connections

Check the connections between your project’s hosts and the machines 
within your system using the Check Hosts operation in the Hosts page of 
the Administration Site (Resources > Hosts > Check Hosts) or User Site 
(Project > Hosts > Check Hosts).

➤ If Ping to Host fails:

➤ Make sure the host is up and running, and is connected to the network. 
Check the routing table (netstat –r) and make sure that requests to this 
host are properly routed.

➤ Make sure that the host’s IP address can be properly resolved.

➤ Verify that the ping to the target host from the Performance Center Web 
server, utility server, and database is below 20 ms.
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➤ If your firewalls or hosts ignore ICMP requests (pings), use HTTP requests 
to validate response times from the host to the Web server (a simple 
LoadRunner web_url(…) request to http://<server>/loadtest/). 
Alternatively, open a browser and type http://<server>/loadtest in the 
address field.

➤ If the file server fails:

➤ Make sure that the host can ping the file server.

➤ Make sure that the Performance Center system user has access to LRFS 
share on the file server. You can verify this in any of the following ways:

➤ In the command line, execute the following: 

➤ Log in to the host machine as the Performance Center system user, and 
in the command line, execute the following: 

If the above operation fails, check the error message and resolve the 
problem. Contact your Windows administrator for assistance.

➤ Make sure that the security settings on LRFS share allow the HP 
Performance Center system user full control.

➤ Make sure that the Performance Center system user can create, update, 
and delete files from LRFS share.

➤ Make sure that the Performance Center Web server can launch 
applications on the host. For more information, see “Troubleshooting 
Web Service Connectivity” on page 111.

net use \\fileserver\LRFS / user: 
<Performance_Center_user><Performance_Center_user_password>

% net use \\fileserver\LRFS
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➤ If the database fails:

➤ Check the <HP Performance Center>/bin/globals.ini file and make sure 
that the connection string is correct for the database you are using.

➤ See the troubleshooting for “Login to Oracle Database Server Hangs” on 
page 124.

➤ Verify ADODB connectivity to the database as described in “Login to 
Database Server Fails” on page 126.

Option 2: Check the Performance Center version

Make sure that the version of Performance Center service pack level and 
feature pack level on all your host and server machines are the same as those 
on the Performance Center Web and Utility servers. That is, all Performance 
Center hosts and servers MUST be at the same service pack and feature pack 
level.

Check the registry entry under 
[HKEY_LOCAL_MACHINE\SOFTWARE\Mercury 
Interactive\LoadRunner\CurrentVersion] for the following variables:

➤ Major

➤ Minor

➤ ServicePack

Note: Any patches applied to one machine must be applied to all machines 
if and when applicable.
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Option 3: Launch wlrun.exe manually from the Controller host machine

If the host check succeeds, but the host is still not operational, launch the 
Controller manually from the Controller host machine as follows:

 1 Log in to the host machine.

 2 Configure the wlrun.LrEngine application to run as an interactive user: 

➤ Launch dcomcnfg.exe.

➤ In the Application tab, select wlrun.LrEngine from the list of DCOM 
applications.

➤ Click Properties to view the properties for wlrun.LrEngine.

➤ In the Identity tab, set the user account to The interactive user.

➤ Click OK and close the DCOMCNFG window.

Note: When you are finished with this step, set wlrun.LrEngine back to 
its original identity. By default, this is This User with the Performance 
Center user name and password. If you used a different identity, restore 
it.

 3 Launch the Controller (wlrun.exe) from the <HP Performance Center>/bin 
directory (on the Controller host).

 4 If an error message is displayed during the startup of the Controller, resolve 
the error message before continuing. For Performance Center to utilize the 
Controller properly, no error messages should be displayed during startup.
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 5 Create a new, simple load test and reference the scripts from the LRFS share 
(on the Performance Center file server). Run the load test with one or two 
users to verify that the Controller works.

Note: Scripts uploaded to the Performance Center LRFS reside in the 
\\fileserver\LRFS\<ProjectID>\Scripts directory. To obtain the <ProjectID>, 
select User Management > Projects.

The following is an example path to the USR file for a script named MyTest: 
\\myserver\LRFS\2\Scripts\MyTest\MyTest.usr

 6 Close the Controller (wlrun.exe).

 7 From the Performance Center User Site, launch a simple load test.

➤ Check whether the following processes are displayed in the Task Manager 
on the Controller host:

➤ OrchidActiveSession.exe OR ORCHID~1.exe

➤ WLRUN.EXE

➤ Check whether the Controller is displaying a dialog box that requires 
user input before the Controller can proceed with the load test. Address 
the reasons for the dialog box being displayed, and make sure that no 
dialog boxes are displayed when re-running the load test from 
Performance Center.

Examples of dialog boxes that may be displayed include License Has 
Expired, Monitor Not Licensed, and Host is Over-Utilized.

If you are unsure how to resolve the problem indicated in the dialog box, 
contact the Customer Support Web site (http://www.hp.com/go/
hpsoftwaresupport) for assistance. 

http://www.hp.com/go/hpsoftwaresupport
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Note: When you are finished with this step, set wlrun.LrEngine back to 
its original identity. By default, this is This User with the Performance 
Center user name and password. If you used a different identity, restore 
it. 

Option 4: Reinstall Performance Center host on the host machine

If all of the above steps fail to resolve the problem, reinstall the Performance 
Center host on the host machine.

 1 Uninstall Performance Center (Start > Settings > Control Panel > Add/
Remove Programs). (This is really the Performance Center host.)

 2 Delete HKEY_LOCAL_MACHINE\SOFTWARE\Mercury Interactive from the 
registry.

 3 Clean the Performance Center machine, as described in the section about 
cleaning Performance Center machines in the HP Performance Center System 
Configuration and Installation Guide.

 4 Re-install the Performance Center host. For more information, see the HP 
Performance Center System Configuration and Installation Guide. Make sure that 
you install the same version of Performance Center as is installed on your 
Web server.

Note: Do not install an Performance Center server (such as a Utility Server, 
Web Server, or File Server) on the same machine as the Performance Center 
host (such as a data processor, Controller, or load generator).
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Unable to Add a Load Generator Due to High Latency 

Problem description: You are unable to add a load generator host due to 
high network latency or the network policy.

You may have a problem adding a host to the Performance Center 
Administration Site as a load generator if the host has a ping time greater 
than 50 ms. This applies only to hosts added as load generators.

Troubleshooting

 1 Create a temporary host location over a firewall.

 a On the Host Locations page, click Add Host Location.

 b In the Host Location field, type TempOverFirewall.

 c Set Located over Firewall to Yes. (By using the Located over Firewall 
option, many checks that are performed on host machines will not be 
performed.)

 d Click OK.

 2 Add a new host to the temporary location.

 a On the Hosts page, click Add Host.

 b In the Name field, type add.

 c In the Purpose field, select Load Generator.

 d From the Location list, select TempOverFirewall.

 e From the Host Pool list, select the correct host pool.

 f Click Save, and then click OK to confirm.

 g Select the host that was added from the host list.

 h Change the location to the correct location. (Placing the host in the over 
firewall location was done just to bypass some checking that 
Performance Center does when adding host machines.)

 i Click OK. In the next two message boxes that are displayed, click OK.

 3 Repeat Step 2 for all load generators that have high network latency.
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Problems Changing SiteScope Server in Administration Site

Problem description: You are unable to change the SiteScope server details 
on the Server Configuration page in the Administration Site (System 
Configuration > Server Configuration). When you type a new SiteScope 
server in the SiteScope Server box and click Save, you receive one of the 
following error messages:

➤ Service unavailable

➤ An unspecified error occurred while processing your request. Try to 
refresh your browser or to open another browser instance. 

Troubleshooting

 1 On the Server Configuration page (System Configuration > Server 
Configuration), clear the contents of the SiteScope Server box and click 
Save.

 2 In the SiteScope Server box, type the name of the new SiteScope server and 
click Save.

Note: As a result of this action, Performance Center host or server groups 
may have been created on the new SiteScope server. We recommend that 
you remove these groups from the SiteScope server.

 3 Re-enable SiteScope monitoring on the relevant Performance Center hosts 
and servers.

➤ To enable SiteScope monitoring for a host, open the Hosts page 
(Resources > Hosts), and click the relevant host. In the Properties tab, 
click Edit and select Enable SiteScope Monitoring.

➤ To enable SiteScope monitoring for a server, open the Servers page 
(Resources > Servers), and click the relevant server. In the Properties tab, 
click Edit and select Enable SiteScope Monitoring.

 4 Reconfigure the SiteScope alert settings on the Alerts Configuration page 
(System Configuration > Alerts Configuration).
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SiteScope Server Fails to Monitor the MS-SQL Database

When using a SiteScope server to monitor a Performance Center farm 
working with Microsoft SQL Server 2005, SiteScope fails to monitor the 
database service.

Troubleshooting

This problem is caused due to a discrepancy in the service names between 
the Microsoft SQL Server 2000 and Microsoft SQL Server 2005. By default, 
Performance Center is configured with the service name of Microsoft SQL 
Server 2000.  

 1 If SiteScope was already added to monitor the Performance Center farm, and 
was enabled to monitor the database server (from the Administrator Site > 
Servers page), disable SiteScope from monitoring the database server.

 2 Change the SQL Server’s service name in Performance Center by running 
the following SQL statement on the Performance Center database:

 3 Re-enable SiteScope to monitor the database server.

UPDATE SiSMonitors SET Instance='SQL Server (MSSQLSERVER)' WHERE 
Instance='MSSQLSERVER'



Chapter 10 • Troubleshooting Hosts and Servers

89

Failure to Add Host

Problem description: Add host fails. 

This may occur as a result of any of the following problems:

➤ Cannot Add Host as a Performance Center Host

➤ Performance Center Incorrectly Asks for Administrator Account

➤ System User Passwords Do Not Match

➤ .NET Framework

➤ Oracle Database Connection

Cannot Add Host as a Performance Center Host
Problem description: When trying to add a host, you receive an error stating 
that HP Performance Center cannot identify the host as an Performance 
Center host.

Troubleshooting

Verify that the ManagmentUtil.exe COM object is defined as the 
Performance Center system user.

Performance Center Incorrectly Asks for Administrator 
Account 
Problem description: Failure to add hosts is often mistakenly accompanied 
by a request for administrator account credentials.

Troubleshooting

 1 Make sure the Default Web Site directory in IIS is defined with port 80 and 
IP address is set to (All Unassigned).

 2 Make sure that IIS is configured properly.

➤ IIS 5.0.x: In the Default Web Site > PCWS folder’s Properties,  make sure 
that Application Protection is set to High.
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➤ IIS 6.0.x: 

➤ Make sure that Application Pools > PCWSAppPool exists. If not, create 
it with default options.

➤ In the Default Web Site > PCWS folder’s Properties, make sure that the 
application pool selected is PCWSAppPool.

➤ In the Web Service Extensions, make sure that the following are 
allowed:

Active Server Pages;  ASP.NET v2.0.50727; Server Side Includes

If any of them are not allowed, allow them and reset IIS.

 3 Make sure the ServerManagerWS Web Service is available (see “Testing Web 
Service Connectivity” on page 112).

System User Passwords Do Not Match
The Performance Center system user credentials on the new host machine 
must be the same as those of the Performance Center system user on the rest 
of the Performance Center system. 

If the system user exists on the host with a different password, Performance 
Center will not add the host to the system. Before attempting to add a host, 
Make sure that the credentials match.

.NET Framework
There may be a problem with the .NET Framework installation. 

Repair the .NET Framework installation as follows:

 1 Select Start > Run. 

 2 Type the following command:

c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i
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Oracle Database Connection
If you are working with Oracle, this problem might be related to the Oracle 
database connection.

Verify that the following connection works from the host server machine:

If the command fails, check the TNS entry on the host machine (in the 
<Oracle_client installation directory>\network\admin\tnsnames.ora file). 
This should be the same as the TNS entry on the database server (in the 
<Oracle_server installation directory>\network\admin\tnsnames.ora file).

If the TNS entry is different to that of the database server, you need to copy 
the TNS entry from the database server to the host.

Failure to Reboot Host from Administration Site

Problem description: When a host is rebooted from the Hosts page of the 
Administration Site, the host has been rebooted, but the host state is not 
updated accordingly.

Troubleshooting

Reset IIS as follows:

 1 Select Start > Run.

 2 Type iisreset.

 3 Press Enter.

% sqlplus <username>/<password>@<connect_string>
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Not Enough Server Storage Available

Problem description: The following error message appears in the Analysis 
results and Performance Center logs (<Performance Center 
installation>\orchidtmp\LTLogger\ANALYS~1\log.txt) on the host 
machine:

"Not enough server storage is available to process this command."

Troubleshooting

This error occurs when the value of the IRPStackSize entry in the machine’s 
registry is too low.

Important: The following procedure contains steps that instruct you how to 
modify the registry. Serious problems might occur if you modify the registry 
incorrectly. Therefore, make sure that you follow each step carefully. For 
added protection, back up the registry before you modify it. Then, you can 
restore the registry if a problem occurs. For more information about how to 
back up and restore the registry, see the following article in the Microsoft 
Knowledge Base: 322756 (http://support.microsoft.com/kb/322756/)  How 
to back up and restore the registry in Windows.

To increase the value of the IRPStackSize registry entry:

 1 Select Start > Run, type regedit, and click OK.

 2 Locate the following registry subkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Para
meters

http://support.microsoft.com/kb/322756/
http://support.microsoft.com/kb/322756/
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 3 If the IRPStackSize entry is not present in this subkey:

 a From the Edit menu, select New > DWORD Value.

 b Type IRPStackSize, and press ENTER. 

Note: Type IRPStackSize exactly as it appears. The value name is case 
sensitive.

 4 Select IRPStackSize and, from the Edit menu, select Modify.

 5 In the Data Value box, type a higher value, and click OK.

Values may range from 0x1 to 0xC. These values are equivalent to 1 to 12 in 
decimal notation.

If the problem persists after you have completed this procedure,  gradually 
increase the value of IRPStackSize until you find the minimum value that 
resolves the problem. Using a value that is higher than necessary might 
waste system resources. 

Other factors can also lead to this error message. If problems persist after 
you have used all the valid values for IRPStackSize, restore IRPStackSize to its 
original value, and seek another explanation for the error



Chapter 10 • Troubleshooting Hosts and Servers

94



95

11
Troubleshooting WAN Emulation

This chapter provides information on troubleshooting problems related to 
WAN Emulation.

This chapter includes:

 ➤  WAN Emulation Is Already Running on page 95

 ➤  Duplicate Monitor Graphs with Empty Counters Appear on page 96

 ➤  Load Test is Stuck in init Phase on page 96

 ➤  Cannot Run WAN Emulation on Load Generator That Is Also  the Controller 
on page 97

 ➤  User Site Gets Stuck when Starting Load Test Configured  with WAN 
Emulation on page 97

WAN Emulation Is Already Running

Problem description. If you kill the LR_Bridge.exe or magentproc.exe 
processes on a load generator to stop a load test, the next time you define 
WAN Emulation settings and run a load test on that load generator, you will 
receive a message that WAN Emulation is already running on it.  

Troubleshooting

➤ When you kill the processes on a load generator to stop the load test, you 
must manually terminate the WAN Emulation as well. If you do not 
manually stop the WAN Emulation and later try to run another load test on 
the same load generator, the load generator will still be emulated without 
you being aware of it. We strongly recommend that you manually terminate 
the WAN Emulation to prevent this scenario.
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Duplicate Monitor Graphs with Empty Counters Appear

Problem Description. A duplicate of the Windows Resources monitor 
appears with empty counters.

Troubleshooting

If you manually add metrics in addition to those that are automatically 
added, you will see a duplicate of the Windows Resources monitor with 
empty counters representing the manually added metrics.

Load Test is Stuck in init Phase

Problem description. Load Test is stuck in the init phase.

Troubleshooting

➤ If you try to run a load test with the WAN Emulation but the 3rd party 
software is not installed on the load generator, then the load test might get 
stuck in the init phase. In this case, check the 3rd party software error 
message and consult the relevant 3rd party software installation 
documentation.

➤ If you are working with the WAN Emulator in professional mode, and you 
specify a location for the .ntx file on a machine where there are no 
Performance Center User privileges, when you try to run the load test it will 
get stuck during the init phase. 

When working in professional mode, make sure that .ntx file is located on a 
machine that has Performance Center User privileges.
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Cannot Run WAN Emulation on Load Generator That Is Also 
the Controller

Problem description. You receive an error message that you cannot run 
WAN Emulation on a load generator that is also the Controller. 

Troubleshooting

➤ Make sure that the option to allow running Vusers on the Controller in the 
project is disabled.

User Site Gets Stuck when Starting Load Test Configured 
with WAN Emulation

Problem description. You configure a load test to run with WAN Emulation, 
but the User Site gets stuck when you start the load test run.

Troubleshooting

➤ Restart the Controller.
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Troubleshooting Monitors

This chapter provides information on troubleshooting problems related to 
Performance Center monitors.

This chapter includes:

 ➤  Cannot Create a Monitor on page 99

 ➤  Cannot Save Measurements on page 101

 ➤  Port Required for J2EE Monitor Is Already Taken on page 102

 ➤  J2EE Monitor Initialization Errors on page 103

 ➤  Cannot Save SiteScope Monitors with Many Counters on page 103

Cannot Create a Monitor

Problem description: You are unable to create a specific monitor.

Troubleshooting

 1 Make sure that the user trying to access the machine to monitor exists on 
this machine and has proper privileges. Usually IUSR_METRO will be the 
user attempting to monitor.

For example, if you add the Windows Resources monitor, the user 
IUSR_METRO must exist on the machine to be monitored and must have 
proper access rights.



Chapter 12 • Troubleshooting Monitors

100

 2 Some monitors require certain clients to reside on the Utility Server and the 
Controller.

➤ For BroadVision, JDK must be installed.

➤ For WebLogic, JDK and the weblogic.jar file must be present.

➤ For Oracle, the Oracle Client must be installed.

➤ For DB2, the DB2 administrative client must be installed. (OS390 is not 
supported.)

 3 Make sure the agent required for a particular monitor is running on the 
machine that you want to monitor.

 4 For COM+, make sure that the COM+ probe is running on the machine that 
you want to monitor.

 5 Some monitors require access to a particular URL, from both the 
Performance Center utility server and the Controller, for monitoring 
purposes.

➤ For Apache, this URL is: http://<server>:<port>/server-status:auto

➤ For Websphere 4.x & 5.x, this URL is: http://<server>:<port>/wasPerftool/
ervlet/perfservlet
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Cannot Save Measurements

Problem description: During configuration of a monitor, after you select the 
measurements that you want to monitor and you click Save, instead of 
saving the monitor, Performance Center goes back to the Choose Monitor 
page. 

Troubleshooting

This problem usually occurs when you select a large number of 
measurements. To resolve this issue, you need to increase the value of the 
AspMaxRequestEntityAllowed property in the IIS metabase. This property 
specifies the maximum number of bytes allowed in the entity body of an 
ASP request.

Note: For more information about the AspMaxRequestEntityAllowed 
property, see the Microsoft Terminal Services documentation: http://
www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/
a6401b5e-c902-4035-90aa-ee46c270d357.mspx?mfr=true, or http://
support.microsoft.com/kb/327659

To increase the value of the AspMaxRequestEntityAllowed property:

 1 Run the following command from the command line:

where <IIS_installation_drive> is the hard disk where IIS is installed.

 2 To view the current value of the AspMaxRequestEntityAllowed property, run 
the following command:

cd <IIS_installation_drive>:\inetpub\adminscripts.

cscript adsutil.vbs get w3svc/ASPMaxRequestEntityAllowed.

http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/a6401b5e-c902-4035-90aa-ee46c270d357.mspx?mfr=true
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/a6401b5e-c902-4035-90aa-ee46c270d357.mspx?mfr=true
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/a6401b5e-c902-4035-90aa-ee46c270d357.mspx?mfr=true
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 3 To increase the value of the AspMaxRequestEntityAllowed property, run the 
following command:

where <maximum value> is the maximum value, in bytes, that you want to 
set for the AspMaxRequestEntityAllowed property.

 4 Run the following command:

 5 To verify that the value of the AspMaxRequestEntityAllowed property has 
changed, run the following command again:

Note: If you are still not able to save the measurements in the monitor 
profile, increase the value of the AspMaxRequestEntityAllowed property 
further. 

For more information about this issue, see the Microsoft support Web site: 
http://support.microsoft.com/kb/327659

Port Required for J2EE Monitor Is Already Taken

Problem description: The J2EE monitor communicates with Performance 
Center, by default, using port 2004 and this port is already taken.

Troubleshooting

Select another port as follows:

 1 On the application server machine, open the <J2EE Monitor installation 
directory>\dat\monitor.properties file and change the port number 
specified for the webserver.monitor.port property.

cscript adsutil.vbs set w3svc/ASPMaxRequestEntityAllowed <maximum value>.

iisreset.

cscript adsutil.vbs get w3svc/ASPMaxRequestEntityAllowed.

http://support.microsoft.com/kb/327659
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 2 On the Performance Center host machine, open the <Performance Center 
installation directory>\dat\monitors\xmlmonitorshared.ini file and change 
the port number specified in mon_j2ee section under the DefaultPort key.

J2EE Monitor Initialization Errors

Problem description: You are receiving application server initialization 
errors, such as UnsupportedClassVersionError, NoSuchMethodError, or 
NoClassDefFoundError. 

Troubleshooting

There might be a conflict between the JDK version specified using the J2EE 
Monitor Initializer, and the actual JDK version used in the application server 
launch.

Make sure that you selected the correct JDK that is currently being used by 
the application server. Note that if you switched the application server to 
work with a different JDK, you must run the J2EE Monitor Initializer again.

Cannot Save SiteScope Monitors with Many Counters

Problem description: You get an error when trying to save a SiteScope 
monitor profile where the monitor has many counters. 

Troubleshooting

This error occurs when there are more than 160 counters on the SiteScope 
monitor. The error occurs because the value of the IIS parameter, 
ASPMaxRequestEntityAllowed, which defines the maximum size of the Asp 
page body section, is not high enough. To solve this error, increase the value 
of the parameter.

To increase the value of the IIS parameter:

 1 Log in to the User Site server machine.

 2 On the Command line, change the directory to the IIS installation directory, 
C:\Inetpub>\AdminScripts.
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 3 Run the following commands from the user server and from the utility

 a Check the current parameter value.

 b Set a higher value for the parameter:

 c Check that the parameter value was updated.

cscript adsutil.vbs get w3svc/ASPMaxRequestEntityAllowed

cscript adsutil.vbs set w3svc/ASPMaxRequestEntityAllowed 8000000

cscript adsutil.vbs get w3svc/ASPMaxRequestEntityAllowed
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Troubleshooting Web Problems

This chapter provides information on troubleshooting Web-related 
problems.

This chapter includes:

 ➤  HTTP 500.x – Internal Server Error on page 105

 ➤  Cannot Find Server or DNS Error on page 108

 ➤  Maintenance Service Causes IIS Resets on page 109

 ➤  HTTP/1.1 100 Continue Randomly Appears on page 109

 ➤  Internet Explorer Closes When Selecting Script For Vuser Group on page 110

HTTP 500.x – Internal Server Error

Error message: The page cannot be displayed (HTTP 500.x Internal Server 
Error).
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Troubleshooting

 1 Reset IIS by choosing Start > Programs > Administrative Tools > Services, 
locating IIS Admin Service, and clicking Restart Service.

 2 (IIS 5 only) If you cannot restart IIS, reboot the machine.

Make sure that both the Administrator Site and the User Site are set to 
Application Protection level High (isolated) in the Internet Services 
Manager. To set the protection level, see “Option 1 (IIS 5 only): Set the 
Application Protection level to High (isolated)” on page 124.

 3 Make sure that the anti-virus software is not checking the Performance 
Center installation directory and sub-directories and thereby causing the 
error. In addition, make sure that the anti-virus program is not checking the 
file server directory (generally LRFS).

 4 If you are still receiving an error, perform the following steps to see a more 
detailed error:

On the client machine:

 a Open Internet Explorer. 

 b Select Tools > Internet Options. 

 c Click the Advanced tab. 

 d Under the Browsing section, deselect Show Friendly HTTP Error 
Messages.

On the server machine:

 a Select Start > Programs > Administrative Tools > Internet Information 
Services Manager to open the IIS manager.

 b Expand Web Sites.

 c Select Default Web Site.

 d Select the virtual directory relevant to the server’s purpose: Admin for 
Administration Site Server, Loadtest for User Site Server.

 e Right click the selected directory and click Properties. The <directory> 
Properties dialog box opens.

 f Click Configuration. The Application Configuration dialog box opens.
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 g Click the Debugging tab.

 h Select Send detailed ASP error messages to client.

 i Click OK to close the Application Configuration dialog box.

 j Click OK to close the <directory> Properties dialog box.

 k Restart IIS by right clicking the server’s name in the tree. Select All tasks > 
Restart IIS.

At this point you should have a different, more detailed error message. 
Try to address the problem indicated in the message, or contact HP 
Customer Support with this message and all information related to the 
problem.
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Cannot Find Server or DNS Error

Error message: The page cannot be displayed (Cannot find server or DNS 
Error).

Troubleshooting

 1 Make sure that you entered the correct URL address.

 2 Verify that you have access to the Web server.

➤ Use the ping command if you do not have a firewall blocking ICMP 
requests to your Web servers.

➤ From a command prompt, execute: ping <Web server>

➤ From a command prompt, execute: ping <IP Address of Web server>
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 3 On the Web server, verify that IIS is up and running:

 a Select Start > Programs > Administrative Tools > Services.

 b Make sure that IIS Admin Service is Started and that Startup type is set to 
Automatic.

 c Make sure that World Wide Web Publishing Service is Started and that 
Startup type is set to Automatic.

 4 Reset IIS by choosing Start > Programs > Administrative Tools > Services, 
locating IIS Admin Service, and clicking Restart Service.

Maintenance Service Causes IIS Resets

Problem description: IIS is reset every 10 minutes by the maintenance 
service. The maintenance service log shows that the HTTP call to 
MemorySize.asp had a timeout (60 sec.) and after three retries, the service 
reset IIS (as it was designed to do).

Troubleshooting

Make sure that the Utility Server is not configured to work through a proxy 
that might block the HTTP call. To disable the proxy setting, search the 
registry for the key ProxyEnable in the Internet Setting folders and set this 
key to zero.

HTTP/1.1 100 Continue Randomly Appears

Problem description: The message HTTP/1.1 100 Continue randomly 
appears in the middle of a response stream.

Troubleshooting

If you installed the User Site server or Administration Site server on a 
Windows Server 2003 SP1 machine, download the Microsoft patch from the 
the Microsoft Support site (http://support.microsoft.com/kb/898708). This 
patch addresses a known Microsoft issue, when running IIS 6.0 on a 
Windows Server 2003 machine.

http://support.microsoft.com/kb/898708
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Internet Explorer Closes When Selecting Script For Vuser 
Group

Problem description: When trying to select a script for a new Vuser group, 
Internet Explorer closes.

Troubleshooting

When you are designing Vuser groups, there must always be at least one 
available script in the Scripts list. If you try to select a script and the list is 
empty, it triggers a known defect in IE7 [version 0.5730.13CO], causing the 
browser to close.

Make sure that at least one Vuser script has been uploaded to the current 
project. 
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Troubleshooting Web Services

This chapter provides information on troubleshooting Web service-related 
issues.

This chapter includes:

 ➤  Troubleshooting Web Service Connectivity on page 111

 ➤  Testing Web Service Connectivity on page 112

Troubleshooting Web Service Connectivity

This section provides troubleshooting for Web service connectivity issues. 

Important: The following troubleshooting tips apply to the Web service 
requester agent machine.

After each troubleshooting attempt described below, you can test your Web 
service connectivity using the test described in “Testing Web Service 
Connectivity” on page 112.

To troubleshoot Web service connectivity:

 1 Verify that the PCWS virtual directory exists in IIS.

 2 If you are using IIS 6, verify that the ASP.NET V2.0 extension was installed 
and allowed in IIS.

 3 If you are using IIS 6, verify that the PCWSAppPool application pool is not 
locked. If it is locked, you can consult the event viewer for an explanation. 
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 4 If you are using IIS 5, grant full access permission for 
IWAM_<Machine_name> in the <Windows directory>\temp directory.

 5 Verify that the Performance Center system user exists on the machine.

 6 Verify that the following policies are defined for the Performance Center 
system user:

➤ Batch logon rights

➤ Service logon rights

➤ Access this computer from the network

Testing Web Service Connectivity

After you troubleshoot Web service connectivity, you can test your Web 
service connectivity by trying to access the Performance Center ConfigWS 
Web services on the requester agent machine.

To test Web service connectivity:

 1 On the requester agent machine, type the following URL: 

 2 In the Enter Network Password box, type your Performance Center system 
user login details.

http://<provider agent machine>/PCWS/ConfigWS.asmx



Chapter 14 • Troubleshooting Web Services

113

The ConfigWS Web service page opens. 

Note: If this page does not open, there is still a problem with the Web 
service connectivity and you should continue to troubleshoot this issue.

 3 Click the IsAvailable operation.
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 4 On the IsAvailable operation page, click Invoke.

If this action returns a value of True, the Web service connectivity is 
operational.
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Troubleshooting System Identity

This chapter provides information on troubleshooting system 
identity-related issues.

This chapter includes:

 ➤  Administrator Account Requested on page 115

 ➤  Error in Adding Permissions to Folder/Registry on page 116

 ➤  Identity References Cannot Be Translated on page 116

 ➤  Server/Host Configuration Problems on page 117

 ➤  Admin Tasks Take a Long Time/Time-Out/ ThreadAbortException 
on page 117

 ➤  Conflicting Credentials when Changing Users on page 118

 ➤  Oracle Database – Cannot Change System User to  Non-Admin User 
on page 118

 ➤  Remote Management Agent Service Disabled After  Changing System User 
on page 119

 ➤  Load Generator Standalone Limitations on page 120
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Administrator Account Requested

Problem description: An administrator account is requested even if the 
Performance Center system user is an administrator.

Troubleshooting

 1 Verify that you can access the Web service using the browser. 

 2 Verify that the system user exists on the machine.

 3 Check whether the ASP.NET V2.0 extension was installed and allowed in IIS. 

 4 Verify that you have the PCWS virtual directory.

Error in Adding Permissions to Folder/Registry

Problem description: You receive an error when adding permissions to one 
of the file/folders or registry keys. 

Troubleshooting

 1 Try to reconfigure the use case again (by clicking the Reconfigure button in 
the System Identity utility).

 2 Reboot the machine and click the Reconfigure button in the System Identity 
utility. 

 3 Clean out all the unrecognized users from the folder/registry. 
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Identity References Cannot Be Translated

Error message: Some or all identity references could not be translated.

Problem description: You receive the above error in trying to configure the 
system. 

Troubleshooting

 1 Verify that the configuration user is not the same user with which you are 
logged in to the system. If you are logged in to the system with the 
configuration user, log off and then log in again with a different user. 

 2 Reset IIS on the machine on which you received the error.

Server/Host Configuration Problems

Error message: System.Web.Services.Protocols.SoapException: Server was 
unable to process request. Unable to generate a temporary class.

Problem description: This error can occur when trying to configure a server 
or host using the System Identity utililty. 

Troubleshooting

Grant full access permission for the IWAM_<Machine_name> user in the 
<Windows directory>\temp directory.
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Admin Tasks Take a Long Time/Time-Out/
ThreadAbortException

Problem description: In the following cases, a time-out event or 
ThreadAbort exception occurs or the action takes a long time:

➤ The system user is a non-administrative user (lockdown) and you try to 
add a host.

➤ The system user is an administrative user and you try to a change it to a  
non-administrative (lockdown) user. 

Troubleshooting

Click Reconfigure to configure the system user again. 

If the problem persists:
In “lock-down mode,” permissions are granted to specific directories, files, 
and registry keys that Performance Center requires in order to run. Check 
the Security tab of these resources for deleted users/groups (SIDs). These 
deleted SIDs increase the time it takes to perform tasks such as granting 
permissions to a resource. To reduce the performance time for these tasks, 
clean out all the deleted SIDs. 

If the problem still persists, you need to configure the system user manually. 
For details, see the section about configuring the Performance Center system 
user manually in the HP Performance Center Administrator Guide.
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Conflicting Credentials when Changing Users

Error message: The credentials supplied conflict with an existing set of 
credentials.

Problem description: This error can occur when using the System Identity 
utility to change the system user. 

Troubleshooting

Verify that the configuration user is not the same user with which you are 
logged in to the system. If you are logged on to the system with the 
configuration user, log off and then log on again with a different user. 

Note: This problem may be caused due to a Microsoft limitation. For more 
information, see the Microsoft TechNet Web site (http://www.microsoft.com/
technet/prodtechnol/windows2000serv/reskit/w2000Msgs/3860.mspx?mfr=true).

Oracle Database – Cannot Change System User to 
Non-Admin User

Problem description: When working with an Oracle database, you cannot 
change the system user to a non-administrative system user.

Troubleshooting

Before changing the system user to a non-administrative user, you need to 
disable the Oracle Client’s SQLNET Authentication Services option on each 
of the Performance Center servers and hosts. 

http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/w2000Msgs/3860.mspx?mfr=true
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To disable the SQLNET Authentication Services option:

 1 Open the <Oracle installation directory>\network\admin\sqlnet.ora file 
and locate the following line:

 2 At the beginning of this line, insert a # symbol.

 3 Save the file.

Remote Management Agent Service Disabled After 
Changing System User

Problem description: After you change the system user to a 
non-administrative system user, the Remote Management Agent service is 
disabled.

Troubleshooting

You need to remove the service and restart it with the new Performance 
Center system user’s credentials. 

 1 Restart the machine.

 2 Run the Remote Management Agent service using the following command:

where username and password are those of the Performance Center system 
user.

SQLNET.AUTHENTICATION_SERVICES = (NTS)

%installation folder%\al_agent\bin\alagentservice.exe -remove 

%installation folder%\al_agent\bin\alagentservice.exe -install username password 
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Load Generator Standalone Limitations

This section specifies a number of scenarios of changing the system user, 
and the load generator standalone limitations associated with each scenario.

Scenario 1

➤ You changed the system user for all servers and hosts in the Performance 
Center environment.

➤ You did not add the changed user manually to Load Generator machine.

➤ The default Performance Center system user, IUSR_METRO, exists on the 
Load Generator machine. 

Scenario 2

➤ You changed the system user for all servers and hosts in the Performance 
Center environment.

➤ You added the changed user manually to the Load Generator machine.

➤ The default Performance Center system user, IUSR_METRO, exists on the 
Load Generator machine. 

Feature Availibilty

Sitescope monitoring Works with IUSR_METRO credentials

Default load test monitoring Does not work

Remote management 
(reboot and install patch)

Works with IUSR_METRO credentials (type 
username and password upon request)

Feature Availibilty

Sitescope monitoring Works with IUSR_METRO credentials

Default load test monitoring Works with changed user credentials

Remote management
(reboot and install patch)

Works with IUSR_METRO credentials (type 
username and password upon request)
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Scenario 3

➤ You changed the system user for all servers and hosts in the Performance 
Center environment.

➤ You added the changed user manually to the Load Generator machine.

➤ You removed the default Performance Center system user, IUSR_METRO, 
from the Load Generator machine. 

Feature Availibilty

Sitescope monitoring Does not work

Default load test monitoring Works with changed user credentials

Remote management

(reboot and install patch)

Does not work

Workaround: Remove service and reinstall 
service with changed user credentials. For 
details, see “Remote Management Agent 
Service Disabled After  Changing System User” 
on page 119.
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16
Troubleshooting Databases

This chapter provides information on troubleshooting problems that occur 
with database in the Performance Center system.

This chapter includes:

 ➤  Login to Oracle Database Server Hangs on page 124

 ➤  Login to Database Server Fails on page 126

 ➤  Database/User Schema Creation Fails on page 128

 ➤  Warning Message Received During MS-QL Database Migration on page 129

 ➤  Conflict Warnings Received During Database Migration on page 129
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Login to Oracle Database Server Hangs

Error message: Trying to log on to database server.

Troubleshooting

➤ Option 1 (IIS 5 only): Set the Application Protection level to High (isolated)

Make sure that the Application Protection level is set to High (isolated) in 
the Internet Services Manager in both the Administration Site and User Site. 

To set the application protection level: 

 1 Select Start > Programs > Administrative Tools > Internet Services Manager. 
The Internet Information Services dialog box opens.

 2 In the Tree directory, expand Default Web Site and right-click Admin. Click 
Properties to open the Admin Properties dialog box.

 3 Click the Virtual Directory tab.
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 4 In the Application Protection box, select High (Isolated).

 5 Repeat steps 2 through 4 for the User Site. In step 2, right-click LoadTest 
instead of Admin.

Option 2: Set the Correct Permissions Level for the IWAM_<SERVER> user

Problems with logging on might be caused by a permissions level problem 
with the IWAM_<SERVER> user. By default, this account is set to the Guest 
permissions level. However, the IWAM_<SERVER> user must have read/
execute privileges on the Oracle home directory and all of its sub-directories.

To set the correct permissions level: 

 1 In Windows Explorer, right-click the Oracle home directory and select 
Properties.

 2 Click the Security tab.

 3 Click Add and add the IWAM_<SERVER> user.

 4 Check Read & Execute.

 5 Click OK.
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Login to Database Server Fails

Error message: Operation terminated. Error description: Login to the 
database server failed. Check if user name and password are correct.

Troubleshooting

 1 Verify that the database server host name, type, user name, and password 
are correct. Consult your database administrator if you are unsure.

 2 Check whether you can connect to the database server from the 
Administration Site server using the command line SQL client:

➤ For MS SQL Server:

For example:

If your Microsoft SQL Server is configured with integrated security, make 
sure that the Microsoft SQL Server has an operating system account for 
IUSR_METRO (password: MIOrchid#1), and is allowed access to the 
database. IUSR_METRO is the default account under which the 
Performance Center Web server runs.

➤ For Oracle Server:

For example:

If the above command fails, check your TNS entry in the <Oracle 
installation directory>\network\admin\tnsnames.ora file.

% osql –U <username> -P <password> -S <serverID>

% osql –U sa –P manager –S DBSERVER\LRTCDB

% sqlplus <username>/<password>@<connect_string>

% sqlplus system/manager@LRTCORA
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An example of a TNS entry is shown below:

 3 Test the ADODB connectivity to the database:

 a Download the TcIN_AdoDBTester.exe utility from the HP Software 
Support site’s Self-solve Knowledge Search  (http://
support.openview.hp.com/selfsolve/documents) (ID: 39475).

 b Run the utility to test the ADODB connectivity to the database.

➤ Update the username, password, and server fields in the connection 
string:

For MS SQL Server, use the Provider=SQLOLEDB.1;… connection 
string.

For Oracle Server, use the Provider=MSAORA.1;… connection string.

➤ Set a valid SQL statement (based on current database tables).

➤ Execute the statement and check the response. If an error occurs, 
address the error message appropriately.

 4 If you are working with Oracle Server, check that Oracle Client is installed 
properly:

 a Check whether the ORACLE_HOME registry entry under 
[HKEY_LOCAL_MACHINE\Software\Oracle] is correct. It should be 
pointing to the Oracle Client installation.

 b Remove SQLPLUS.EXE from the <Performance Center installation 
directory>\DB directory.

 5 Verify that the version of MDAC is at least 2.8 SP1.

LRTCORA =
(DESCRIPTION =
      (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = TCDBSERVER)(PORT 1521))
      )
(CONNECT_DATA =
            (SERVICE_NAME =LRTCORA)
)

)

http://support.openview.hp.com/selfsolve/documents/
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 6 Verify that the database or user schema was actually created by checking 
whether the db_results.txt file exists in the %temp% directory of the 
Administration Site server. Note that this file is available only after system 
configuration. In addition, you can check whether the MI_LRDB database or 
user schema exists by logging in to the database/user schema.

Note: If you are able to log on to the User Site after system configuration, 
the database or user schema was most likely created properly.

Database/User Schema Creation Fails

Problem description: You cannot create a Performance Center database or 
user schema.

Troubleshooting

Try to create the database or user schema by running the SQL files located in 
the DbSetup directory of the Administration Site server.

➤ For MS SQL Server, run TestCenter.sql to create the database and 
InitDefinitions.sql to initialize the tables.

➤ For Oracle Server, run TC_oracle.sql to create the user schema and 
InitDataOracle.sql to initialize the tables.
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Warning Message Received During MS-QL Database 
Migration

Problem description: The following warning message appears in the log file 
<DB_Migration_directory>\PC_V9_1.log when performing an MS-QL 
database migration:

Troubleshooting

This message is related to a size limit that is related to the Project Options. 
Since this size limit will not be utilized, you can disregard this message.

Conflict Warnings Received During Database Migration

Problem description: The following messages might appear in the log file 
<DB_Migration_directory>\PC_V9_0.log when performing a database 
migration:

Troubleshooting

These messages appear when performing database migration of Performance 
Center 8.14 and earlier. These warnings relate to features that are no longer 
relevant in the current version of Performance Center. You can disregard 
these messages.

Warning: The table 'Companies' has been created but its maximum row size (8227) 
exceeds the maximum number of bytes per row (8060). INSERT or UPDATE of a row in 
this table will fail if the resulting row length exceeds 8060 bytes.

DELETE statement conflicted with COLUMN REFERENCE constraint 
'FK_ResultTransactions_RunPublishedResults'.
The conflict occurred in database 'MI_LRDB', table 'DashboardResultTransactions', 
column 'RunResultId'.

DELETE statement conflicted with COLUMN REFERENCE constraint 
'FK_GoalTransactions_TestGoals'. 
The conflict occurred in database 'MI_LRDB', table 'DashboardGoalTransactions', 
column 'TestGoalId'.
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17
Troubleshooting Accessing the 
Performance Center Sites

This chapter provides information on troubleshooting Web-related 
problems.

This chapter includes:

 ➤  Login Fails on page 131

 ➤  User Site Does Not Exist After Initial Configuration on page 133

 ➤  Unable to Log In to the Administration/User Site on page 134

 ➤  Administration Site Page Cannot Be Displayed on page 135

 ➤  Cannot Connect to Administration or User Site on page 136

Login Fails

Logging in to Performance Center fails in the following cases:

➤ “New Users Cannot Log In to Performance Center” on page 132

➤ “Cannot Log In to Performance Center with Any User or Administrator 
Account” on page 132
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New Users Cannot Log In to Performance Center
Problem description: New users cannot log in to Performance Center. Get 
the following error: The system could not retrieve your personal 
information. Please contact your administrator.

Troubleshooting

This usually happens after upgrading the database.

Make sure that the Default project exists in Performance Center and is 
enabled.

 1 Open the database, and locate the Companies table.

 2 Make sure that for Default project, state is set to 1.

If not, run the following line on the database:

Cannot Log In to Performance Center with Any User or 
Administrator Account
Problem description: You cannot log in to Performance Center with any 
user or administrator account.

Troubleshooting

 1 Make sure that you type the correct user name and password. The password 
is case-sensitive. The default administrator account is Admin, Admin.

 2 There may be a problem with the encryption and decryption of the 
password.

➤ Open Documents And Settings\All Users\Application 
Data\Microsoft\Crypto\RSA\MachineKeys and delete the entry that 
begins with f9416f003254e610da1f9bad8e4c383_.

➤ Restart IIS. Select Start > Programs > Administrative Tools > Services. 
Select IIS Admin Service and click Restart Service.

update MI_LRDB.companies set state=1 where companyID=1
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 3 Make sure that both the Administration Site and the User Site are configured 
to run with the same account credentials as the Performance Center Web 
services virtual directories. For more information about troubleshooting 
Web services, see the relevant section in the HP Performance Center 
Administrator Guide.

 4 Check that you are able to connect to the database server from the Utility 
Server and the Web Server. Download the TcIN_AdoDBTester.exe utility 
from the HP Software Support site’s Self-solve Knowledge Search  (http://
support.openview.hp.com/selfsolve/documents) (ID: 39475).

 5  Make sure that the maximum number of connections to the database server 
has not been exceeded. Run Perfmon.exe or the database server’s 
management tool to verify the number of connections. You should contact 
your database administrator if you need further assistance.

User Site Does Not Exist After Initial Configuration

Error message: ‘Page Not Found’ (displayed in browser).

Problem description: After the initial configuration of Performance Center 
(using http://<servername>/admin/initialfs.htm), the Performance Center User 
Site is created through the Server Configuration page in the Administration 
Site (System Configuration > Server Configuration). In this case, after the 
User Site (http://<servername>/LoadTest) has been created, it does not exist 
on the Performance Center server.

http://support.openview.hp.com/selfsolve/documents/
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Troubleshooting

If the Performance Center Web server was corrupted or reinstalled, launch 
Internet Service Manager and check if the LoadTest virtual directory is 
defined.

 1 If LoadTest is defined, but points to the wrong directory, delete the LoadTest 
virtual directory and continue with the following step.

If LoadTest is not defined, log in to the Performance Center Administration 
Site and check if an entry exists for User Site Servers on the Server 
Configuration page (under System Configuration > Server Configuration). If 
the name of the server is not displayed under User Site Servers, add it and 
save your changes. Try to log in to the User Site (http://<servername>/
loadtest).

 2 From the User Site machine, connect to the database or user schema using 
Microsoft SQL, Oracle Enterprise Manager, or any SQL client and check the 
Web Server entry in the GlobalData table of the MI_LRDB tablespace/
database. If the Web Server entry contains the name of the server on which 
you want to install the Performance Center User Site, remove the server 
name.

 3 Log in to the Performance Center Administration Site and define User Site 
Servers on the Server Configuration page (under System 
Configuration > Server Configuration).

Unable to Log In to the Administration/User Site

Problem description: You are unable to log in to the Administration Site or 
the User Site. The system appears to “spin.”

Troubleshooting

 1 (IIS 5 only) Make sure that both the Administration Site and the User Site are 
set to Application Protection level High (isolated) in the Internet Services 
Manager. For more information, see “Option 1 (IIS 5 only): Set the 
Application Protection level to High (isolated)” on page 124.
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 2 Make sure that the permissions level for the IWAM_<SERVER> user is set 
correctly. For more information, see “Option 2: Set the Correct Permissions 
Level for the IWAM_<SERVER> user” on page 125.

 3 Make sure that the IWAM password for the IIS account is synced. If this is 
the first time you are logging in after installing Performance Center, the 
installation might have been corrupted due to IIS configuration problems. 
This can happen when installing a Windows service pack and/or updates 
before IIS is installed. In this case IIS is not updated (this is a Microsoft 
limitation). For more information, see “Error: Method ~ of object ~ Failed 
During Installation” on page 20.

Administration Site Page Cannot Be Displayed

Problem description: You receive an error message indicating that the 
Administration Site page cannot be displayed, or the Administration Site is 
not displayed correctly.

Troubleshooting

➤ If the Administration Site is not displaying correctly, recreate the 
Administration Site by running <Performance Center installation 
directory>\bin\AdminInstaller.exe1

➤ If you receive an error that the page cannot be displayed:

 a Close the current browser. Relaunch the browser and try to open the 
Administration Site again.

 b Select Tools > Internet Options from the menu. In the General tab, click 
Settings. In the Check for newer versions of stored pages section, make 
sure that the Every visit to the page option is selected.

 c Clear the browser cache and cookies.

 d If the problem is still not resolved, try to open the Administration Site 
from a different machine.

 e Reset IIS by choosing Start > Programs > Administrative Tools > Services, 
locating IIS Admin Service, and clicking Restart Service.
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Cannot Connect to Administration or User Site

Problem description: When trying to connect to the Administration or User 
Site Web servers, you receive a Service unavailable or You are not authorized 
to view this page error message.

Troubleshooting

 1 Verify that the Administration Site virtual directory user exists.

 2 Verify that the user has all the required policies.

 3 Verify that the application pool is not locked. If it is, consult the event 
viewer for an explanation.

 4 Verify that the security policy configuration of the customer domain is 
compatible with the the configuration of your Performance Center 
environment. 



137

18
General Troubleshooting

This chapter provides information on general troubleshooting problems.

This chapter includes:

 ➤  Problem Related to Data Execution Prevention (DEP) on page 137

 ➤  Reserved Timeslots are Not Displayed in the Calendar View on page 138

 ➤  Problems Configuring Performance Center to Work with HTTPS on page 138

 ➤  Performance Center Pages Are Blocked when Using  Internet Explorer 6 on 
Machine with Skype on page 140

 ➤  Performance Center Machine's CPU Usage Reaches 100% on page 142

 ➤  Results Displayed Incorrectly in Standalone Analysis on page 143

 ➤  When Opening Host Security Manager Get Unhandled  Exception 
on page 143

Problem Related to Data Execution Prevention (DEP)

Problem description: When rebooting a Windows XP SP2 or Windows 2003 
machine, you might receive an error message related to Data Execution 
Prevention (DEP).

Troubleshooting

Modify the Windows DEP settings as follows:

 1 Open Start > Control Panel > System.

 2 In the Advanced tab, click Performance settings.
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 3 In the Performance Options Data Execution Prevention tab, select the first 
option, DEP for essential services only.

If you cannot change this option, click Add. Browse to the client program, 
for example IEXPLORE.EXE.

If neither of these options are possible, try to disable DEP completely. 

 a In the Control Panel, click the Advanced tab under System section.

 b Under Startup and Recovery, click Edit.

 c Replace NoExecute=OptOut with NoExecute=AlwaysOff.

 4 Click OK to save the settings.

 5 Reboot the machine.

Reserved Timeslots are Not Displayed in the Calendar View

Problem: Reserved timeslots are not displayed in the calendar view.

Troubleshooting

When working on non-English environments, the calendar view does not 
display reserved timeslots.

Workaround: If you are working on a non-English environment, and you 
want to view reserved timeslots, log in to the User Site server as a 
Performance Center system user (for example, IUSR_METRO) and set the 
regional settings to English.
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Problems Configuring Performance Center to Work with 
HTTPS

Problem description: Unable to configure Performance Center to work with 
HTTPS. The Windows Event Viewer might display one of the following 
errors: 

➤ Unable to bind to the underlying transport for 0.0.0.0:443. The IP 
Listen-Only list may contain a reference to an interface which may not 
exist on this machine. The data field contains the error number.

➤ Cannot register the URL prefix 'https://*:443/LoadTest/' for site '1'. The 
site has been deactivated.

When you try to start IIS, you get the following pop-up error: The process 
cannot access the file because it is being used by another process.

Troubleshooting

Performance Center utilizes port 443 for some of its own features. To enable 
working with HTTPS, you must to assign a different port to the 
al_agent_service service.

To assign a different port:

 1 Open <PC installation directory>\al_agent\dat\mdrv.dat.

 2 Locate the [launcher] section and  add OFWPort=<port>, where port is the 
port number you want to open. 

 3 Save and close the file.

 4 Open < PC installation directory >\al_agent\dat\channel_configure.dat.

 5 Locate the [General] section and add OFWPort=<port>, where port is the 
port number you want to open. 

 6 Save and close the file.

 7  Restart the al_agent_service service.
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Performance Center Pages Are Blocked when Using 
Internet Explorer 6 on Machine with Skype

Problem description: Some of the Performance Center pages (Reports, Load 
Test configuration) are blocked. Get the following message:
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Troubleshooting

Remove the Skype explorer add-on.
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Performance Center Machine's CPU Usage Reaches 100%

Problem description: On one of the Performance Center machines the CPU 
usage reaches 100% with extensive use of DW20.EXE - the Microsoft Error 
Reporting option. (For more details, see http://blogs.orcsweb.com/rick/archive/
2007/02/15/error-reporting-and-dw20-exe.aspx.)

Troubleshooting

Disable the Error Reporting option on all Performance Center machines.

To disable Error Reporting:

 1 Open System Properties (Start > Control Panel > System).

 2 On the Advanced tab, click Error Reporting.

 3 Select Disable error reporting.
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Results Displayed Incorrectly in Standalone Analysis

Problem description: When opening analysis results in Standalone Analysis 
transaction IDs appear where the transaction names should appear.

Troubleshooting

This problem is related to the verison of Analysis. Results created with 
Performance Center 9.5 have to be analyzed and viewed with Analysis 9.5. 
Make sure all Performance Center components are of the same version.

When Opening Host Security Manager Get Unhandled 
Exception

Problem description: On the Administration Site server, when you open 
Host Security Manager for the first time, a message displays the following 
exception: Unhandled exception has occurred....

Troubleshooting

Click Continue to close the message window.
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19
Performance Center Processes and 
Services

Each server runs various components or services based on its particular 
function within the Performance Center system. This chapter provides 
information about these processes and services.

This chapter includes:

 ➤  Processes and Services Diagram on page 146

 ➤  Performance Center Processes on page 147

 ➤  Performance Center Services on page 148
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Processes and Services Diagram

The following diagram contains a list of processes on each Performance 
Center component.

User Site Server

IIS

ASP

ASP.NET

COM

Administration Site Server

ALWrapperServer
ManagmentUtil

OrchidStautsMonitor
PCIMKeeper

IIS

ASP

ASP.NET

COM

Utility Server

OrchidScheduler
ManagmentUtil
Alagentservic
TaskManager
MEApplication
PCIMKeeper

MESyncApplication

IIS

ASP.NET

COM

Host

OrchidActiveSession
ManagmentUtil
Alagentservice

DCA
wlrun
Online

MESyncApplication
Collator

AnalysisOperator
PCIMKeeper

magentservice

IIS

ASP.NET

COM

File Server

SmartDiskCleaner
ManagmentUtil
Alagentservic
PCIMKeeper

IIS

ASP.NET

COM

Database

Database

SessionActivator
ManagmentUtil
Alagentservic
PCIMKeeper

launch_runlogicview
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Performance Center Processes

The following table provides basic information about Performance Center 
processes and their purpose within the Performance Center system.

Name Runs on Purpose

ALWrapperServer Administration 
Site

Used by Performance Center as a 
container and manager of all tasks 
related to: 

➤ Patch installation

➤ Reboot remote machines

➤ Retrieve installed HP products 
from remote machines

AnalysisOperator Host
(Controller)

Invokes the AnalysisManager (that 
retrieves the data from the 
Controller and builds the graphs), 
zips the data and saves it in the File 
Server

Collator(1) Host
(Controller)

Invokes the component that collates 
the results from the load generator 
machines

launch_runlogicview User Site Used by the run-time setings (RTS) 
run logic feature

ManagementUtil All machines Responsible for the entire system 
configuration

MEApplication Utility Server Used for offline monitors 
configuration

MESyncApplication Utility Server 
and Host

Used for offline monitors 
configuration

online Host
(Controller)

responsible for run-time 
information collection
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Performance Center Services

The following table provides basic information about Performance Center 
services and their purpose within the Performance Center system.

OrchidActiveSession Host
(Controller)

Retrieves all the required run details 
from the database, launches the 
Controller and provides it with run 
details, and passes the run data to 
the Web Server

OrchidInstallationUtil.
PdhChecker

All machines Running on all machines during 
installation, it checks the PDH 
version on the machine

PCImkeeper All machines Saves references to COM objects 
that are running on each machine

SessionObject
Activator

User Site Writes all run details to the 
database, and invokes the 
OrchidActiveSession

wlrun Host
(Controller)

The Controller

Name Process Name Runs on Purpose

DataCollection
Agent (DCA)

datacollection
agent

Host Collects system resources 
utilization to avoid over 
utilization during load tests 
execution. Also used for 
updating the routing table in 
the IP target feature.

Runs under system account.

Performance 
Center Agent 
Service

magentservice Host Enables connection from 
Controller machines to load 
generators in order to execute 
Vusers on the load generators

Name Runs on Purpose
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Performance 
Center Disk 
Cleaner

SmartDiskClea
ner

File Server Cleans the File Server of 
unnecessary files.

Runs under system account.

Performance 
Center 
Scheduler

OrchidSchedul
er

Utility 
Server

Initiates auto run load test.

Runs under system account.

Performance 
Center Status 
Monitor

OrchidStatusM
onitor

Admin Site Retrieves machine status from 
SiteScope and updates the 
database.

Runs under system account.

Performance 
Center Task 
Manager 
Service

TaskManager Utility 
Server

Provides a monitoring service 
that checks memory usage and 
IIS server status and validates 
the status of hosts and runs. 
Whenever one of these 
problems are detected, this 
service activates a task to 
resolve it.

Also responsible for deleting 
temporary results after 
collation.

RemoteManage
-ment Agent

alagentservice All 
machines 
except 
Admin Site

Responsible for rebooting and 
installing patches on remote 
machines, remotely 
configuring over firewall 
settings, and providing 
information about the installed 
Performance Center 
components (in the Hosts > 
Properties tab).

Runs under system account.

Performance 
Center 
Trending

Mercury.PC.Tr
ending.Publish
.WindowsServi
ce

Utility 
Server

Trending feature.

Name Process Name Runs on Purpose
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20
Performance Center Communication Flow

When running a load test, the Performance Center system components 
share information via a distinct system of communication. Understanding 
which components communicate with one another and the method of 
communication is essential for configuring your system.

This chapter includes detailed information about the communication paths 
and protocols of the Performance Center system.

This chapter includes:

 ➤  Advanced Communication Diagrams on page 152

 ➤  Ports and Protocols on page 154
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Advanced Communication Diagrams

This section includes detailed communication diagrams that illustrate the 
communication flow of the Performance Center system components.

Performance Center Components: Basic Communication Flow
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Performance Center Components: Advanced Communication 
Flow
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Ports and Protocols 

The following table describes the communication protocols and ports used 
in the Performance Center system.

Protocol Ports Comments

NetBIOS UDP/137 NetBIOS Name Service

UDP/138 NetBIOS datagram service

TCP/139 NetBIOS session service

445 Microsoft-DS Active Directory

HTTPS TCP/443 OFW connection between 
MIListner and LG/Autolab

HTTP TCP/80 Web Services

ADO - SQL TCP/1433 or user-defined

TCP/1521 or user-defined

The database server opens a 
connection back to the client 
via a dynamic port (1024 and 
above)

TCP 50500 OFW connection between PC/
Controller and MIListner

TCP 50500 LGstatus between Admin and 
MIListner

TCP 54245 Autolab agent.

Connection between Admin 
Server and Performance 
Center components

TCP 54345 Load Generator - Controller 
connection

HTTP/HTTPS TCP/8888 SiteScope

HTTP TCP/23472 (443) Host, Admin Site - Diagnostic 
Server

2006 Load Generator - Diagnostic 
Server
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Data 
Collection 
Agent

3333

Standard TCP 5002, 5001

OCI TCP/UDP Ports: 1525, 1527

ODBC TCP/UDP Ports: 1433, 1434

Protocol Ports Comments
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