HP Network Node Manager iSPI NET Server System and Device Support Matrix

Software Version: 8.10 / 30 October 2008

This document provides an overview of the system requirements and supported devices for the HP NNM iSPI Network Engineering Toolset (NNM iSPI NET) Server Software version 8.10.

For the latest updates to the system requirements and device support, see sg-pro-ovweb.austin.hp.com/nnm/ISPI-NET8.10/supportmatrixupdate.htm

This document is intended to augment the Release Notes. You can find both the Support Matrix (supportmatrix_en.html) and the Release Notes (releasenotes_en.html) at the root directory of the installation media.

Installation Guide
Hardware and Software Requirements
    Hardware
    Operating System
    Database
    Web Browser
    Internationalization and Localization Support
Supported Network Devices
    Supported Devices

Installation Guide

Pre-installation requirements, as well as instructions for installing the NNM iSPI NET Diagnostics Server, are documented in the installation guide provided in Adobe Acrobat (.pdf) format. The document file is included on the product's installation media as: install-guide_en.pdf.

Hardware and Software Requirements

Before installing the HP NNM iSPI NET Diagnostics Server, make sure your system meets the following minimum requirements.

Hardware

If you install the NNM iSPI NET Diagnostics Server on the same system as HP Network Node Manager, the resource requirements must be added to those for the base HP NNM product. The HP NNM iSPI NET Diagnostics Server installer only operates on Windows operating systems. It is possible to use an existing HP Operations Orchestration Version 7.20 (HP 00) server as the target for Diagnostics installation. Please see the HP NNM iSPI Network Engineering Toolset Planning and Installation Guide for information on use of an existing HP OO Server.

Operating System

Note: Installation of the NNM iSPI NET Diagnostics Server is not supported on the Linux operating system nor is the use of the diagnostic flows on an existing HP OO installation using the Linux operating system.

Database

The HP NNM iSPI NET Diagnostics Server stores information in a relational database. The HP NNM iSPI NET Diagnostics Server supports MySQL versions 5.0.51b and later. MySQL 5.0.51b is provided with the installer and used if MySQL does not already exist on the system where you install the NNM iSP NET Diagnostics Server. If HP OO already exists on the system, MySQL and HP OO are not installed on the system. Instead the installer requires administrative login information for the existing HP OO Server.

Web Browser

Internationalization and Localization Support

HP NNM 8.10 iSPI NET Diagnostics Server is NOT internationalized and will only operate using the English Locale.

Clustering and High Availability

Use of the iSPI NET Diagnostics Server on systems that are integrated in an NNM cluster is not supported. The iSPI NET Diagnostics Server must be installed on a system separate from the NNM cluster systems. Each node in the cluster can still utilize the separate iSPI NET Diagnostics Server. In addition, the iSPI NET Diagnostics Server is not supported on Windows High Availability implementations. See the release notes document for additional details regarding Clustering and High Availability.

 

HP NNM iSPI NET Supported Network Devices For Diagnostic Flows

Supported Devices

This device support information is based on the latest information available to HP at the time of publication. Note that device vendors can, at any time, alter a device's command syntax and displayed information (for example, in newer IOS or system software versions) and invalidate NNM iSPI NET Diagnostics usage of that device. In general software versions listed indicate minimal versions for proper operation of the diagnostic flow.

Devices are only supported if the device is running in the English locale.

Cisco IOS Version 12.3 offers the best support for executing diagnostic flows on Cisco devices. Earlier versions may work as noted below but some command syntax may indicate a failure when reviewing the diagnostic flow report.

Nortel switch devices, such as the 5510, due to their form based login conventions are required to support SSH as a transport mechanism.

Vendor Family Model Agent's SNMP sysObjectID Software Version Notes
Cisco 2600 Series Multiservice Platform 2621 1.3.6.1.4.1.9.1.209 IOS Version 12.3(19)
All commands except for show spanning tree brief should function.
Cisco 2600 Series Multiservice Platform 2691 1.3.6.1.4.1.9.1.413 IOS Version 12.4(1)  
Cisco 2600 Series Multiservice Platform 2651 1.3.6.1.4.1.9.1.320 IOS Version 12.2(19a) Versions earlier than 12.2(19a) may have problems invoking show vlan commands.
Cisco Cisco 2800 Integrated Services Router 2821 1.3.6.1.4.1.9.1.577 IOS Version 12.4(12)  
Cisco Cisco 2800 Integrated Services Router 2851 1.3.6.1.4.1.9.1.578 IOS Version 12.4(5a)  
Cisco 3600 Series Multiservice Platform 3620 1.3.6.1.4.1.9.1.122 IOS 12.2(15)T13  
Cisco 3600 Series Multiservice Platform 3640 1.3.6.1.4.1.9.1.110 IOS Version 12.3(19) All commands except for show spanning tree brief should function.
Cisco Cisco 3700 Multiservice Access Routers 3725 1.3.6.1.4.1.9.1.414 IOS Version 12.3(9a)  
Cisco 3700 Series Multiservice Platform 3745 1.3.6.1.4.1.9.1.436 IOS Version 12.2(13)T12
All commands except for show spanning tree brief should function.
Cisco 4000M Series Routers 4500 1.3.6.1.4.1.9.1.14 IOS Version 12.2(23)  
Cisco Catalyst 2900 Series XL Switches 2912XL 1.3.6.1.4.1.9.1.219 IOS Version 12.0(5) All commands except for show interface, show protocols, show vlan should function.
Cisco Catalyst 2950 Series Switches 2950T-24 1.3.6.1.4.1.9.1.359 IOS Version 12.1(14)EA1a All commands except for show interface, show protocols, show vlan should function.
Cisco Catalyst 3500 Series XL Switches 3508G-XL 1.3.6.1.4.1.9.1.246 IOS 12.0(5)WC11 All commands except for show interface, show protocols, show vlan should function.
Cisco Catalyst 3500 Series XL Switches 3524XL 1.3.6.1.4.1.9.1.248 IOS 12.0(5) All commands except for show interface, show protocols, show vlan should function.
Cisco Catalyst 3560 Series Switches 3560-24PS 1.3.6.1.4.1.9.1.563 IOS Version 12.2(25)SEB4 All commands except for show vlan and show spanning tree brief.
Cisco Cataylst 3750 Series 3750 1.3.6.1.4.1.9.1.516 IOS Version 12.2(25)SEB4 All commands except for show vlan and show spanning tree brief.
Cisco Catalyst 5000 Series Switches 5000 1.3.6.1.4.1.9.5.7 Version 3.2(8) Only Cisco Switch Spanning Tree Baseline diagnostic supported.
Cisco Catalyst 5000 Series Switches (RSM) WS-X5302 1.3.6.1.4.1.9.1.168 IOS Version 11.2(12a.P1)P1 Only Cisco Switch Baseline supported with some command failures.
Cisco Catalyst 6500 Series Switch 6503 1.3.6.1.4.1.9.1.449 IOS Version 12.2(18)SXD7  
Cisco Catalyst 6500 Series Switch 6506 1.3.6.1.4.1.9.1.282 IOS Version 12.2(18)SXF6  
Cisco Catalyst 6500 Series Switch 6509 1.3.6.1.4.1.9.1.283 IOS 12.2(18)SXD7  
Cisco Cisco 7100 Series VPN Router 7140 1.3.6.1.4.1.9.1.277 IOS Version 12.2(15)T13  
Cisco Catalyst 8500 Series Multiservice Switch Routers 8510 1.3.6.1.4.1.9.1.190 IOS 12.0(1a)W5(6f) All commands except for show interface summary and show spanning tree brief should function.
Cisco Catalyst 8500 Series Multiservice Switch Routers 8540 1.3.6.1.4.1.9.1.203 IOS Version 12.1(6)EY1
All commands except for show interface summary and show spanning tree brief should function.
Nortel BayStack Baystack 5510 1.3.6.1.4.1.45.3.53.1 v5.1.1.017 Must configure SSH to use diagnostic flows.