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Legal Notices

Warranty

The only warranties for HP products and services are set forth in the express warranty 
statements accompanying such products and services. Nothing herein should be construed as 
constituting an additional warranty. HP shall not be liable for technical or editorial errors or 
omissions contained herein.

The information contained herein is subject to change without notice.

Restricted Rights Legend

Confidential computer software. Valid license from HP required for possession, use or copying. 
Consistent with FAR 12.211 and 12.212, Commercial Computer Software, Computer Software 
Documentation, and Technical Data for Commercial Items are licensed to the U.S. 
Government under vendor's standard commercial license.

Copyright Notices

© Copyright 2005, 2008 Hewlett-Packard Development Company, L.P.

Trademark Notices

Windows® and Windows Server™ 2003 are U.S. registered trademarks of Microsoft® Corp.

UNIX® is a registered trademark of The Open Group.

Java™ is a US trademark of Sun Microsystems, Inc.
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Documentation Updates

The title page of this document contains the following identifying information:

• Software Version number, which indicates the software version.

• Document Release Date, which changes each time the document is updated.

• Software Release Date, which indicates the release date of this version of the software.

To check for recent updates or to verify that you are using the most recent edition of a 
document, go to:

http://h20230.www2.hp.com/selfsolve/manuals 

This site requires that you register for an HP Passport and sign in. To register for an HP 
Passport ID, go to: 

http://h20229.www2.hp.com/passport-registration.html 

Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product 
support service. Contact your HP sales representative for details.
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Support

Visit the HP Software Support web site at:

www.hp.com/go/hpsoftwaresupport 

This web site provides contact information and details about the products, services, and 
support that HP Software offers.

HP Software online support provides customer self-solve capabilities. It provides a fast and 
efficient way to access interactive technical support tools needed to manage your business. As 
a valued support customer, you can benefit by using the support web site to:

• Search for knowledge documents of interest

• Submit and track support cases and enhancement requests

• Download software patches

• Manage support contracts

• Look up HP support contacts

• Review information about available services

• Enter into discussions with other software customers

• Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many 
also require a support contract.  To register for an HP Passport ID, go to:

http://h20229.www2.hp.com/passport-registration.html 

To find more information about access levels, go to:

http://h20230.www2.hp.com/new_access_levels.jsp 
4



Contents
1 Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Audience . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Prerequisites  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Quick Start Instructions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

All Users . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
First Time Users . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
Repeat Users . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

Chapter Summary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Related Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Overview of HPOM-TIBCO Business Management  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

Standard Management Functionality . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Advanced Management Functionality (Optional). . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

TIBCO SPI Conceptual Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
TIBCO SPI Backend Service  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
TIBCO SPI Frontend Subagent . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
Resource Explorer. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
TIBCO SPI Reports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

Service Effect Analysis (SEA) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
TIBCO Enterprise Management Advisor . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Deployment Scenarios . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

Consolidated Scenario  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
Scenario 1: Co-located Components Scenario . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Scenario 2: Remote Frontend Subagent  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Scenario 3: Fully Distributed (Recommended) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

WSDM Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
XML interfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

2 Installation and Configuration. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
5



Installation Process Summary  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Third Party License Review . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
Software Requirements for Standard TIBCO SPI Installation . . . . . . . . . . . . . . . . . . 32
Hardware Requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Patches. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
Kernel Parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

Installing and Configuring the TIBCO SPI Components  . . . . . . . . . . . . . . . . . . . . . . . . . 35
Install the TIBCO SPI Depot  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

Install the TIBCO SPI Depot on HP-UX . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
Install TIBCO SPI Depot on Solaris  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Configure the Management Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Install TIBCO SPI Frontend Subagent Component . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

Configure the Backend Service and the Frontend Subagent  . . . . . . . . . . . . . . . . . . . . . . 42
Assign TIBCO SPI Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

Configure Data Sources for Metric Data Collection . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
Assign Backend Service Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
Assign Frontend Subagent Templates. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
Assigning Template Groups . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
Verifying Deployed Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

Start the TIBCO SPI . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
Restarting the TIBCO SPI . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

Stopping the TIBCO SPI . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
Checking the TIBCO SPI Status. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54

Verifying a Start Status . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54
Verify a Stop Status  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55

Install the Java Console (Service Navigator) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
Starting the Java Console  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57

Install the HP Resource Explorer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Starting the HP Resource Explorer from the Java Console . . . . . . . . . . . . . . . . . . . . . 59
Starting the HP Resource Explorer form the Command Line . . . . . . . . . . . . . . . . . . . 60

Install TIBCO SPI Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61
Uninstalling the TIBCO SPI . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62

Uninstalling the Frontend Subagent. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 62
Remove the TIBCO SPI Installed on HP-UX  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
6



Remove the TIBCO SPI Installed on Solaris  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
Remove TIBCO SPI Regroup Condition  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64
Remove TIBCO SPI Message Groups  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64
Remove the TIBCO SPI Application Group  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64
Remove the TIBCO SPI User Profile. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Remove the TIBCO SPI User . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Remove TIBCO SPI Message Templates. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Reinstall the Templates Monitor and Commands  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
Remove the TIBCO SPI Node Groups From the HPOM Database . . . . . . . . . . . . . . . 66

Configuring TIBCO SPI to Run as Non-Root User  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

3 Performing Standard Management Functions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Service Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74
Viewing TIBCO Managed Resources . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74
Linking Other Service Maps  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Filtering Unwanted MO Types  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77

Event Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79
Viewing TIBCO Events  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79
Automatically Responding to Events. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Monitoring and Data Collection  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Metric Definition Configuration Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Modifying Data Collection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84
Collecting Data for Custom Adapters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85
Configuring Multi-Instance Metric Data. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88
Example: Specific Instance Data (Collect). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90
Collection Data for Specific Metrics. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 92
Monitoring Custom Adapter Metric Thresholds with HPOM . . . . . . . . . . . . . . . . . . . 93
Changing the Metric Data Collection Interval . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94
Changing the Metric Threshold Value. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
Changing which Logfile to Monitor . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

Reporting and Performance Graphs . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 97
Using Embedded Performance Component (Coda) . . . . . . . . . . . . . . . . . . . . . . . . . . . . 97
Embedded Performance Component (Coda) Logging . . . . . . . . . . . . . . . . . . . . . . . . . . 98
View TIBCO SPI Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98
Defining a User Friendly Name for an MO. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99

Monitoring Performance Metrics with HP Performance Manager . . . . . . . . . . . . . . . . . 101
7



Configure HP Performance Manager. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101
Create a Bytes Sent HP Performance Manager Graph for RVDs . . . . . . . . . . . . . . . 101
View the RVD Bytes Sent HP Performance Manager Graph. . . . . . . . . . . . . . . . . . . 102
Graphing Instance Metric Data in HP Performance Manager  . . . . . . . . . . . . . . . . . 102

TIBCO SPI Self Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104
Modify Logging and Tracing Levels  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104

Changing Log Levels  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 104
Changing Trace Levels . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105

4 Using Service Effect Analysis (Optional) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107

Overview. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
Service Composer Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108

Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
Prerequisites  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

Apache Tomcat Setup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112
Environment Setup. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 112

Running the SEA Installer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113
Running the SEA Component . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

Enabling MSI  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115
Starting the SEA Component. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

Running the SEA Configuration Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 116
Stopping the SEA Component. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 117
Creating an Event Definition  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118
SEA Logging and Trace Information  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122

Changing Logging Levels . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 122
Changing the MO Update Interval . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 124
Uninstalling the SEA Component. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 125

5 Using the NNM Integration (Optional) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127

Overview. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Service Views of Network Dependencies . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 127
Collecting SNMP Trap Events . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 128
Performance Reports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 129

Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 131
General Setup Requirements . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 131
8



Enabling and Configuring the NNM Integration. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133
NNM Topology Integration Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 134
RVD Data Collection. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 135

6 Implementing Failover. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137

Overview. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 137
Adding Multiple Location Candidates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 139

7 Security Features and Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 141

Overview. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 141
Conceptual Architecture. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 141

Configuring HTTPS Communication . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 144
Configuring the Frontend Subagent . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 144
Creating a Keystore and Importing Certificates. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 146
Configuring the Resource Explorer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 148
Customizing HTTPS Configuration Parameters  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 150

8 Troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 151

Runtime Problems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 151
Frontend Subagent Does Not Stop  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 151
Frontend Subagent Does Not Start . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 151
Frontend Subagent is Unable to Connect to EMA . . . . . . . . . . . . . . . . . . . . . . . . . . . 152
Backend Service is Not Found . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 154
TIBCO SPI Uses Backup EMA Instead of Primary EMA  . . . . . . . . . . . . . . . . . . . . . 154
TIBCO Service is Not Visible . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 154
Missing Operational Notification. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 154
Performance Agent Does Not Start Up . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 163
TIBCO SPI Fails to Detect HP Performance Agent  . . . . . . . . . . . . . . . . . . . . . . . . . . 163

Configure TIBCO SPI Application Errors  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 164
Configure TIBCO SPI Application Does Not Start . . . . . . . . . . . . . . . . . . . . . . . . . . . 164
Configure TIBCO SPI Application Does Not Display Content. . . . . . . . . . . . . . . . . . 164
Configure TIBCO SPI Application Fails to Transfer WCConfig.xml . . . . . . . . . . . . . 164
Configure TIBCO SPI Application Throws AWTException . . . . . . . . . . . . . . . . . . . . 165

Frontend Logfile Errors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 166
Error Starting Notification HTTP Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 166
Error Adding Service to Map . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 166
9



Frontend does not Connect to the Backend. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167
Problem Logging Metric Data  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 167

SEA Component Runtime Problems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 168
Shutdown Problems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 168
Viewing SEA WSMF Events  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 168
ECS Correlation Problems . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 169
No Managed Objects are Deployed  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 171
Mgmt_sv Directory not Present . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 171
Event Subscriptions Persistence . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 174
Managed Object Discovery Problems. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 174
Service Engine Related Problems  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 175

Using the Self-Healing Info Application. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 176

A TIBCO SPI Configuration  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 179

Editing WCConfig.xml . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 179
Using the Configuration Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 179

WCConfig.xml Configuration Parameters  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 180
<FrontendSection> . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 180
<BackendSection>  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184
<NetworkingInfo>. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 184

B SEA Configuration. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 187

Editing AIA.cfg. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 187
Using the Configuration Tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 187

AIA.cfg Configuration Parameters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188
<ManagedObjectInformation> . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 188
<EventSubscription>  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 189
<Event_Reporting>. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 189
<OVSBA_Configuration> . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 189

C List Templates and Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 191

Message Groups . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 192
Applications . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 193
Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 194
TIBCO SPI Self Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 199
Performance Metrics  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 201
10



Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 204

Glossary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 211

Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 215
11



12



1 Introduction
The HP Operations Smart Plug-in (SPI) for TIBCO User Guide provides 
detailed information to set up and configure the management systems that 
enable you to manage a TIBCO environment. The management solution is 
based on two different product packages: the HP Operations SPI for TIBCO, 
and the TIBCO® Enterprise Management Advisor software, a product of 
TIBCO Software Inc. Together, the two products give IT and application 
managers the ability to distinguish between significant infrastructure events 
and events that impact business processes and applications, so that they can 
take more immediate, appropriate action to maintain uptime and keep 
mission-critical applications running efficiently.

Together, HP and TIBCO are delivering on a multipart project that begins 
with a rich, robust SPI to manage the TIBCO environment and ends with the 
ability for our applications to provide intelligent, adaptive management of the 
TIBCO environment.

HP Operations Manager for UNIX (HPOM-U) provides a fully integrated 
management solution for networks, systems, databases, and applications 
found in heterogeneous distributed IT environments. This comprehensive 
product suite represents a complete set of tools enabling IT organizations to 
improve overall availability and reliability, maintain the highest degree of 
management flexibility, and establish management control over virtually all 
aspects of an enterprise environment. This guide contains instructions for 
installing, configuring, and using the TIBCO SPI. The instructions for using 
the HPOM-U Management Console, including the Java console and Service 
Navigator are only specific to the TIBCO SPI and not meant as a 
comprehensive guide for the HPOM-U Management Console or Service 
Navigator. For documentation specific to these products, follow the link 
provided in the section Related Documents on page 17. 
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TIBCO solutions empower users to improve their business performance by 
enabling interoperability between diverse computer systems and help them 
streamline activities that span their extended enterprise. The Enterprise 
Management Advisor software allows users to actively manage TIBCO 
solutions. 

Audience

This User Guide is intended for anyone who is responsible for operating and 
administering HP Operations Manager (HPOM). In particular, the guide is for 
HPOM administrators, HPOM operators, System Administrators, IT 
operators, and TIBCO application managers. It is expected that TIBCO 
application managers will work as HPOM Operators and will use the Java 
console or Service Navigator to manage the TIBCO environment. 

Prerequisites

Users of this Guide should have basic knowledge of the HPOM Management 
Console, and HPOM management solutions, including SPIs. In addition, users 
should have basic knowledge of TIBCO application management and the 
TIBCO software environment. Familiarity with Java™, HP-UX, and Solaris 
are useful when completing some of the instructions. It is also recommended, 
but not required, that a user of this guide have general knowledge of 
management principles.

Quick Start Instructions

This section includes general guidelines that can facilitate installing and 
using the TIBCO SPI. 
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All Users

All users should:

• complete the steps of Chapter 2, Installation and Configuration, which 
provides instructions for installing the TIBCO SPI with standard 
management features

• verify and validate that your installation is working

• add advanced management functionality as needed by following the 
instructions in Chapter 4, Using Service Effect Analysis (Optional) and 
Chapter 5, Using the NNM Integration (Optional)

First Time Users

First time users should read this chapter completely to gain an understanding 
of the:

• standard and advanced functionalities of the TIBCO management 
solution

• conceptual overview and the dependencies required for the various 
solution components

• recommended deployment scenarios to help you decide an appropriate 
deployment configuration for your environment

Repeat Users

Repeat users should read the Release Notes to find out new information about 
the TIBCO SPI and any documented known issues.
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Chapter Summary

The documentation in this guide is organized in a layered approach from 
generic instructions about the TIBCO Smart Plug-in to detailed instructions 
about TIBCO management. Once you have completed and are familiar with 
the instructions in this guide, you can reference specific instructions as 
needed. 

• Chapter 1 – Introduction: Contains overview and contextual 
information about the WSMO-TIBCO integration, including a brief 
introduction to Web Services Distributed Management (WSDM).

• Chapter 2 – Installation and Configuration: Contains detailed steps 
needed to install the standard management features of the SPI for 
TIBCO.

• Chapter 3 – Performing Standard Management Functions: 
Contains information and tasks that are used to perform standard 
management functions, such as service management, event management, 
and performance reports.

• Chapter 4 – Using Service Effect Analysis: Contains instructions for 
installing and using service effect analysis.

• Chapter 5 – Using the NNM Integration: Contains instructions for 
configuring and using the NNM integration.

• Chapter 6 – Implementing Failover: Contains instructions for setting 
up failover between the TIBCO SPI and the TIBCO EMA software.

• Chapter 7 – Security Features and Configuration: Contains 
instructions for securing the communication channels between the TIBCO 
SPI and the TIBCO EMA software.

• Chapter 8 – Troubleshooting: Contains general procedures used to 
troubleshoot common errors encountered when using the TIBCO SPI.

• Appendix A – TIBCO SPI Configuration: Contains a reference of all 
configuration parameters used to configure the TIBCO SPI.

• Appendix B – SEA Configuration: Contains a reference of all 
configuration parameters used to configure the SEA component.

• Appendix C – List Templates and Reports: Contains a reference of the 
templates and the reports for the TIBCO SPI, SEA component, and NNM 
integration.
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Related Documents

The TIBCO SPI contains integrations with several HPOM components. HP 
Software product guides can be downloaded from 
http://h20230.www2.hp.com/selfsolve/manuals.

The following TIBCO documents, in HTML and PDF formats, are available on 
the TIBCO Enterprise Management Advisor installation CD.

• TIBCO Enterprise Management Advisor User's Guide

• TIBCO Enterprise Management Advisor Release Notes
Introduction                                                                                                                                                   17



Overview of HPOM-TIBCO Business Management 

TIBCO provides a suite of enterprise integration products to bring together 
disparate and previously incompatible systems. Most of the TIBCO products 
and applications are management enabled using the TIBCO Hawk™ API. As 
part of the HPOM-TIBCO integration, TIBCO has created the Enterprise 
Management Advisor (EMA), which is responsible for discovering the TIBCO 
software resources and publishing management data for these resources. 
More importantly, the status of the resources is kept current and up to date. 
The TIBCO SPI bridges HPOM and the TIBCO Enterprise Management 
Advisor software using a Web Services Distributed Management (WSDM) 
channel. As the result, the TIBCO SPI enables HPOM to manage TIBCO 
specific applications and products, as well as other elements in the user’s 
environment such as computing and network infrastructure and non-TIBCO 
applications. Figure 1 shows a high level view of the integrated system: 

Figure 1 HPOM-TIBCO Business Management General Architecture

Standard Management Functionality

Standard management functionality that is provided by the TIBCO SPI 
includes:

• Service Discovery Management

• Event and Notifications

• Monitoring and Thresholds
18                                                                                                                                                   Chapter 1



• Performance Reporting and Graphing

These features are available by installing and configuring the TIBCO SPI 
using the instructions in Chapter 2, Installation and Configuration.

Advanced Management Functionality (Optional)

The TIBCO Business Management Solution also includes several advanced 
features that can be used to gain additional management features. These 
features are optional and are not required to use the standard management 
features of the TIBCO SPI. Advanced management functionality includes:

• Network Node Manager (NNM) Integration

• Other SPI Integration

• Metric Data Collection

• Service Effect Analysis (see the section Service Effect Analysis (SEA) on 
page 23)
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TIBCO SPI Conceptual Overview

The TIBCO SPI is comprised of five components. The components are 
distributed and are used to manage the TIBCO environment and its 
applications. 

The components are:

• TIBCO SPI Frontend Subagent

• TIBCO SPI Backend Service

• Resource Explorer

• TIBCO SPI Reports

Figure 2 shows a conceptual overview of the TIBCO SPI components and how 
they interact. While the TIBCO EMA component is not part of the TIBCO 
SPI, it is included in the figure for clarification. For additional information on 
the EMA component, see TIBCO Enterprise Management Advisor on page 24. 

Figure 2 shows a typical deployment scenario that emphasizes the distributed 
nature of the TIBCO SPI solution. For additional deployment scenario 
options, see Deployment Scenarios on page 26.
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Figure 2 Conceptual Overview of the TIBCO SPI Components

TIBCO SPI Backend Service

The Backend Subagent receives management data and information from the 
Frontend Subagent, converts the information to an HPOM recognized form 
and allows HPOM to manage a TIBCO Environment using traditional HPOM 
tools. The Backend Service must be located on an HPOM-U management 
server. 

Both the Frontend and Backend can be located on the same system. In which 
case the system must be the HPOM management server. This may be a likely 
scenario during testing.
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TIBCO SPI Frontend Subagent

The Frontend Subagent is responsible for communicating with the TIBCO 
EMA component to gather management data and information. The Frontend 
Subagent is essentially a WSDM client able to communicate with Managed 
Objects (MOs) exposed as web services by TIBCO EMA. 

Resource Explorer

The Resource Explorer is a User Interface (UI) tool that is used to view and 
interact with MOs. The tool is only available for Windows. The tool can be 
either started from the HPOM Java console (if the Console is installed on 
Windows) or as a standalone application from the Windows command line. 

TIBCO SPI Reports

The TIBCO SPI provides various customized reports that provide 
performance data of the TIBCO Environment. The reports are implemented 
using the HP Reporter, which can interface with both HP Performance Agent 
and the Embedded Performance Component (or Coda). 
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Service Effect Analysis (SEA)

SEA is an optional plug-in to HPOM that enables adaptive management. It 
analyzes and correlates both HPOM native events such as those from 
computing and network infrastructure and application events such as those 
from TIBCO managed objects. The SEA module allows an application to 
receive events by either subscribing to any existing event types or by defining 
new event types and then subscribing to them. Application developers use the 
event definition tool (ECS) and SEA methodology to create new event types. 

Figure 3 shows a high-level conceptual view of the SEA system:

Figure 3 Conceptual View of SEA
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TIBCO Enterprise Management Advisor

TIBCO EMA software is the instrumentation piece that resides in the TIBCO 
environment. EMA is the gateway through which the TIBCO environment is 
managed. 

EMA is responsible for:

• Discovering TIBCO resources.

• Exposing TIBCO resources as MOs.

• Communicating topology changes to the TIBCO SPI using the WSDM 
Channel.

• Communicating TIBCO resource alerts to the TIBCO SPI.

• Invoking operations on TIBCO resources that are initiated by HPOM 
Operators.

• Communicating performance metrics to the TIBCO SPI.

The agent communicates with the HPOM management platform through the 
WSDM channel. Managed resources are instrumented as MOs using the 
TIBCO Hawk API. These MOs are dynamically discovered through the Hawk 
Console API at run time, and they communicate with the managed resources 
through the Hawk enabled MicroAgents. The TIBCO SPI can communicate 
with multiple EMAs, and there is generally one EMA per Hawk domain.

Figure 4 shows a high-level architecture for the TIBCO EMA software. 

The TIBCO EMA software is developed and distributed by TIBCO. The 
information presented in this section is included to provide an end-to-end 
view of the management integration. For detailed implementation 
information about the EMA software, see the TIBCO Enterprise Management 
Advisor User's Guide included with the TIBCO software.
24                                                                                                                                                   Chapter 1



Figure 4 TIBCO Enterprise Management Advisor Architecture

Figure 4 shows a container managing the life cycle of a resource. The state of 
the managed resource is instrumented through the Hawk API in the TIBCO 
environment, and the managed resource itself is exposed to HPOM. Each of 
the TIBCO components has to enlist the set of management aware resources 
used by it in order to provide the service as defined by the component’s 
contract. This information can very well be an acyclic graph, which the NSM 
layer can later modify and create a representative template. The repository 
and the deployment provide this information. For more information on the 
TIBCO EMA architecture, see the TIBCO Enterprise Management Advisor 
User's Guide 
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Deployment Scenarios

As discussed in the section TIBCO SPI Conceptual Overview, the TIBCO SPI 
is a distributed solution. As such, its components can be distributed in several 
different deployment configurations. This section provides some common 
deployment scenarios and does not represent every possible configuration.

Consolidated Scenario

It is possible to have a single system that hosts all of the TIBCO SPI 
components (in addition to the TIBCO EMA component) except for the 
Resource Explorer and HP Reporter, which is only available for Windows. In 
this scenario, the Resource Explorer must be started from the Windows 
command line and cannot be started from the Java console. This scenario uses 
minimal hardware, but results in increased loads on a single system. 
Therefore, it is not recommended for production environments. 

You may need to reconfigure the default ports used by the components if port 
conflicts occur.

Figure 5 Consolidated Scenario

A fully distributed scenario is the recommended deployment scenario. See the 
section Scenario 3: Fully Distributed (Recommended) on page 28.
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Scenario 1: Co-located Components Scenario

In this scenario, both the Frontend Subagent and Backend Service are located 
on the HPOM management server system. Management processing is 
concentrated on a single system. This scenario is good for testing and also for 
less demanding production environments. 

Figure 6 Co-located Component Scenario

Scenario 2: Remote Frontend Subagent

In this scenario, the Frontend Subagent is separated from the HPOM 
management server and is located with the TIBCO EMA component. This 
scenario effectively separates management processing between a managed 
node and the management server. This scenario is ideal for a production 
environment. 

Figure 7 Remote Frontend Subagent Scenario
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Scenario 3: Fully Distributed (Recommended)

In this scenario, the TIBCO SPI components, as well as the TIBCO EMA 
component, are located on different systems. Each system is relegated to a 
single task. This scenario provides the most efficient processing and resource 
utilization. However, this scenario introduces the most overhead. Maximum 
hardware is used and maintaining the solution can become cumbersome. This 
scenario is ideal for a production environment.

Figure 8 Fully distributed Scenario
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WSDM Overview

WSDM is a management specification for managing application resources 
using web services technology as well as managing web services using web 
services. The specification allows a common integration channel between an 
Independent Software Vendor (ISV) and a management station such as 
HPOM. The WSDM standard is defined by the WSDM Technical Community 
(TC) at OASIS. More information on the standard can be found at the WSDM 
TC site at OASIS.

WSDM provides a way to represent and realize management models and is 
based on Managed Objects (MOs) and the relationships between them. MOs 
provide management capabilities by implementing management interfaces. 
The management interfaces are described using WSDL. Hence, WSDM 
provides the architecture for defining management interfaces for MOs. 

The foundational interfaces defined by WSDM can be extended in order to 
better manage resources in specific domains. In the TIBCO SPI, there are two 
types of extensions: 

1 HPOM domain extensions that provide HPOM data and events to TIBCO 
applications

2 TIBCO domain extensions that enable HPOM to access TIBCO specific 
manageability. 

XML interfaces

WSDM defines a set of domain agnostic management interfaces, as well as 
domain specific management interfaces for web services. Vendors are free to 
extend WSDM to their specific domain in order to manage resources 
effectively.

• Discovery – a set of interfaces for discovering MOs and their 
relationships in the managed environments. There is a set of default 
relationship types defined in WSDM, and vendors can extend these 
relationship types as well.

The WSDM implementation in the TIBCO SPI is based on an HP-authored 
preliminary version of WSDM known as the Web Service Management 
Framework (WSMF). 
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• Configuration – a set of interfaces that allows a manager to find out the 
configuration information about a managed object.

• Control – a set of interfaces to control MOs / resources.

• Performance – a set of interfaces that allows a manager find out 
performance information about MOs.

• EventPush & Event Pull – a set of interfaces for subscribing to events 
in either push or pull fashion.

• EventCallback – a set of interfaces for responding to events after 
subscription.
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2 Installation and Configuration
This chapter provides installation instructions for the various components of 
the SPI for TIBCO. The SPI is integrated with HPOM for UNIX. If you are not 
familiar with HPOM, you should refer to the HPOM documentation during 
the SPI installation. In addition, it is recommended that a development-time 
installation of HPOM be used to test the TIBCO SPI integration before 
installing and running the SPI on a production installation of HPOM.

Installation Process Summary

The following list highlights the installation and configuration process and 
provides links to the individual installation and configuration tasks. The 
installation process proceeds as follows: 

1 Review the Deployment Scenarios on page 26 and select a deployment 
scenario.

2 Review the Requirements section for hardware and software 
requirements.

3 Install the TIBCO SPI Depot.

4 Configure the Management Server

5 Install TIBCO SPI Frontend Subagent Component

6 Configure the Backend Service and the Frontend Subagent

7 Assign TIBCO SPI Templates

8 Start the TIBCO SPI

9 Install the Java Console (Service Navigator)

10 Install the HP Resource Explorer

11 Install TIBCO SPI Reports
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Requirements

This section details the requirements for installing and running the TIBCO 
SPI. Make sure that the requirements are met before you begin the 
installation.

Third Party License Review

The TIBCO SPI utilizes third party software. You must review the third party 
licenses before installing the TIBCO SPI. The licenses are located in the 
OV_DOC/TIBCO_SPI_A.01.05.00.xxx/License directory. If you disagree 
with a particular license, you should not install the TIBCO SPI.

Software Requirements for Standard TIBCO SPI Installation

The following recommended software requirements should be met when 
installing and running the TIBCO SPI. 

TIBCO SPI A.01.05.00 can only be used with TIBCO EMA 2.0 and 2.1. Before 
installing the TIBCO SPI, make sure the TIBCO EMA software is installed in 
the TIBCO environment and is operational. For additional TIBCO EMA  
requirements, see the TIBCO EMA documentation.
For HP-UX: 

ps –ef | grep –l ema

For Windows: 

You can check the processes under the Windows Task Manager to check if 
EMA is running.

Additional requirements when using advanced management functions are 
described in Chapter 4, Using Service Effect Analysis (Optional) and Chapter 
5, Using the NNM Integration (Optional).
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Hardware Requirements

The following recommended hardware requirements should be met when 
installing and running the TIBCO SPI.

Table 1 Software Requirements and Supported Platforms

Software Requirements Platforms

OVO-U 7.10 HP-UX 11.x, Solaris 2.8, 5.8, 8.0, 9.0

OVO-U 8.x  HP-UX 11.x, HP-UX 11.23 IA 64 bit, 
HP-UX 11.23 PI, Solaris 2.8, 5.8, 8.0, 
9.0, 10.0

Java console A.07.00 (included with 
HPOM)

Windows 2K / NT

DSI2DDF A.01.23 for OVO 7.x and 
DSI2DDF A.02.00.00 for OVO 8.x

HP-UX 11.x, Solaris 2.8, 5.8, 8.0, 9.0, 
10.0

JRE 1.4.x HP-UX 11.x, Solaris 2.8, 5.8, 8.0, 9.0, 
10.0

HP Reporter 3.5 (required to view 
TIBCO SPI performance reports 
and graphs)

Windows 2K / NT
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Patches

It is important that all recommended patches for HPOM-U and Java are 
installed prior to running any components of the TIBCO SPI. 

• To find the recommended HPOM patches, go to 
http://support.openview.hp.com/patches. 

In the browse by product version section, select Operations for UNIX and 
click the >> button. 

• To find the recommended Java patches for HP-UX, go to 
http://www.hp.com/products1/unix/java. 

From the left side of the screen, click Patches. 

• To find the recommended Java patches for Solaris, go to 
http://sunsolve.sun.com/pubpatch for the latest J2SE patch cluster. 

Table 2 Hardware Requirements

Hardware Minimum Requirements

RAM • 512 MB: System running Frontend 
Subagent

• 512 MB: System running the Backend 
Service

512 MB is sufficient to run both the 
Frontend Subagent and Backend Service if 
they are located on the same system.

Disk Space •  50 MB: Front End Subagent
• 250 MB: Backend Service

Patches must be installed on all systems on which the TIBCO SPI 
components are running. Keep the systems updated with latest patches, 
check for latest available patches regularly.
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Kernel Parameters

Verify that the kernel parameters on both the Backend Service and Frontend 
Subagent nodes meet the recommended settings to run a Java program. If you 
are running the either the Backend Service or the Frontend Subagent or both 
on an HP-UX node, you can use the HPjconfig tool, which provides the 
recommended kernel parameter settings for your system. To download the 
HPjconfig tool, go to: 

http://www.hp.com/products1/unix/java/java2/hpjconfig. 

Installing and Configuring the TIBCO SPI Components

This section includes detailed steps for installing the TIBCO SPI. The 
installation includes installing and configuring the Backend Service on the 
HPOM management server, as well as installing and configuring the 
Frontend Subagent. You must have HPOM for UNIX installed before you can 
install the TIBCO SPI. To install HPOM for UNIX, see the HPOM 
documentation. In addition, you must be logged onto the management server 
and managed nodes as root when completing the instructions in this section. 

Make sure that JRE 1.4 is installed on both the management server and the 
managed node. On the management server, set an environment variable 
JAVA_HOME to the JRE installation directory.
Remove any versions of the TIBCO SPI before completing the installation.
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Install the TIBCO SPI Depot

The TIBCO SPI Depot contains all of the TIBCO SPI components. The 
installation is performed on an HPOM management server. The TIBCO SPI 
Backend Service is installed by default. However, the TIBCO SPI Frontend 
Subagent and Resource Explorer must be installed after the TIBCO SPI 
Depot is installed. In addition, if you want to install the Frontend Subagent 
on a managed node, you can do so from the management server after you 
install the Depot. 

Install the TIBCO SPI Depot on HP-UX

Before installing TIBCO SPI (TIBSPI) make sure to install the following from 
the SPI DVD:

• SPISHS – SPI-SHS-OVO 2.40.000 or older versions of SPI-SHS-OVO.

• DSI2DDF – DSI2DDF A.02.25.010 or older versions of DSI2DDF.

To install, follow these steps:

1 To install SPISHS, type the following command: 

swinstall -s /cdrom/OV_DEPOT/11.0HPUX.depot SPI-SHS-OVO

2 To install DSI2DDF, type the following command:

swinstall -s /cdrom/OV_DEPOT/11.0HPUX.depot DSI2DDF

3 Type the following command on the HP-UX management server to install 
the TIBCO SPI Depot. You must set the enforce_dependencies option to 
false (set this option to false even if you are installing through the GUI):

Both the Frontend Subagent and Backend Service can be located on the same 
system. If which case, the system must be a HPOM management server. This 
may be a likely scenario during testing.

The instructions that follow, cover the command line swinstall installation. 
For HP-UX systems, you can also use the graphical user interface (GUI). 
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swinstall -x enforce_dependencies=false -s /cdrom/
OV_DEPOT/11.0HPUX.depot SPITIB

Install TIBCO SPI Depot on Solaris

Before installing TIBCO SPI (TIBSPI) make sure to install the following from 
the SPI DVD:

• SPISHS – SPI-SHS-OVO 2.40.000 or older versions of SPI-SHS-OVO.

• DSI2DDF – DSI2DDF A.02.25.010 or older versions of DSI2DDF.

To install, follow these steps:

1 To install SPISHS, type the following command: 

pkgadd -d /cdrom/OV_DEPOT/HPOMSpiDVD-8.1.sparc HPOvSpiShs

2 To install DSI2DDF, type the following command:

swinstall -s /cdrom/OV_DEPOT/SOLARIS.depot DSI2DDF

3 Type the following command on the Solaris management server to install 
the TIBCO SPI Depot. You must set the enforce_dependencies option to 
false

swinstall -x enforce_dependencies=false -s /cdrom/
OV_DEPOT/SOLARIS.depot SPITIB

Configure the Management Server

The instructions in this section help you configure the HPOM management 
server to use TIBCO SPI. All of the steps in this section are completed from 
the HPOM management server.

Configuring the opc_adm Operator

TIBCO SPI user profile must be assigned to the HPOM administrator. This 
step is required in order for the administrator to see the notifications for 
TIBCO SPI.

To configure the opc_adm operator: 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.
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2 From HPOM window, select Window → User Bank.

3 From the User Bank window, right-click opc_adm and select Modify from 
the popup menu.

4 In the Modify User: opc_adm window, click the Profiles button.

5 In the Profiles of User: opc_adm window, verify that the TIBSPI User 
Profile icon appears. If the icon does not appear in the window:

a Open the user profile bank window by selecting Window → User Profile 
Bank.

b Drag the TIBSPI User Profile from the HPOM User Profile Bank 
window and drop it into the Profiles of User: opc_adm window.

c Close the HPOM User Profile Bank window.

6 Close the Profiles of user: opc_adm window.

7 Close the Modify User: opc_adm window by clicking on the OK button.

8 Close the User Bank window.

Register the Backend Service

To register the Backend Service: 

1 From the administrator GUI, select the HPOM management server in the 
Node Bank window.

2 Add the HPOM management server into the TIBSPI-UNIX node group:

a From any HPOM window, bring up the Node Bank window by 
selecting Window → Node Bank.

b From any HPOM window, bring up the Node Group Bank window by 
selecting Window → Node Group Bank. If the TIBSPI-UNIX node group 
is currently part of the Node Group Bank, you can skip the remaining 
steps and go to step 3.

c Double-click the TIBSPI-UNIX node group in the Node Group window.

d Drag the HPOM management server node from the Node Bank and 
drop it onto the Node Group: TIBSPI-UNIX window.

e Click the Close icon in the Node Group: TIBSPI-UNIX window to close 
the window.
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3 Install the Monitors and Commands to the HPOM management server 
node:

a Select the HPOM management server in the Node Bank window.

b Select Actions → Agents �→ Install / Update SW & Config

c In the Install / Update HP Software and Configuration dialog box, 
select Monitors, Commands, and Actions in the Components frame.

d Select Force Update in the Options frame.

e Click the OK button.

4 On the HPOM management server, register the Backend Service by 
running:

cd /opt/OV/bin/

./tib-perl tib-register-backend add

Install TIBCO SPI Frontend Subagent Component

The Frontend Subagent collects management data from the TIBCO EMA 
software and makes the data available to the Backend Service. The Frontend 
Subagent can run on the management server system or on a remote system 
configured as a managed node. For detailed steps on installing and 
configuring HPOM managed nodes, refer to the HPOM documentation. 

Add a Managed Node to the TIBSPI-UNIX Node Group

If you are installing the Frontend Subagent on a Managed node, the node 
must be configured as part of the TIBSPI-UNIX Node Group.

You must invoke the command from the /opt/OV/bin directory.

If you are running the Frontend Subagent on the management server, you can 
skip the first two sections: Add a Managed Node to the TIBSPI-UNIX Node 
Group on page 39 and Install the Monitors, Commands, and Actions on a 
Managed Node on page 40.

If you are installing Frontend Subagent on the management server, you can 
skip this section.
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To add a managed node to the TIBSPI-UNIX Node Group: 

1 From any HPOM window, open the Node Bank window by selecting     
Window → Node Bank.

2 From any HPOM window, open the Node Group Bank window by selecting 
Window → Node Group Bank.

3 From the Node Group window, double-click the TIBSPI-UNIX node group.

4 Drag the node where the Frontend Subagent will be installed from the 
Node Bank and drop it onto the Node Group: TIBSPI-UNIX window.

5 Click the Close icon in the Node Group: TIBSPI-UNIX window to close the 
window.

Install the Monitors, Commands, and Actions on a Managed Node

If you are installing the Frontend Subagent on a managed node, the node 
must be configured to use monitors, commands, and actions.

To install monitors, commands, and actions, on a managed node:

1 From the Node Bank window, select the node where the Frontend 
Subagent will be installed.

2 Select Actions → Agent → Install / Update SW & Config.

3 In the Install / Update HP Software and Configuration dialog, select 
Monitors, Commands, and Actions in the Components frame.

4 Select Force Update in the Options frame.

5 Click the OK button.

Install the Frontend Subagent

To install the Frontend Subagent: 

1 From the Node Bank window, select the node where you want to install 
the Frontend Subagent.

2 Select Actions → Subagents → Install/Update

If you are installing Frontend Subagent on the management server, you can 
skip this section.
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3 In the Install / Update Subagents dialog box, select TIBCO SPI Subagent in 
the Subagents frame on the left.

4 Click the OK button. The Install Subagent Packages window appears. It 
might take a few minutes for the Frontend Subagent to be installed. After 
installation, the following message appears:

inst.sh complete installation of tibspi SubAgent product

5 Press Enter.

Verifying the Frontend Subagent Install

You can verify that the Frontend Subagent is installed and registered. On the 
system where Frontend Subagent is installed, if it is an OVO for UNIX 7.x or 
OVO for UNIX 8.x DCE agent node, run the following: 

opcagt -status -id 25

The following message appears:

OVO Managed Node status:
-------------------------
Control Agent /opt/OV/bin/OpC/opcctla   (xxx) is running
...
TIBCO SPI Subagent (Frontend)/opt/OV/bin/tib-perl /opt/OV/
bin/tib-start-frontend isn’t running.

If the Frontend Subagent is installed on an OVO 8.x HTTPS agent node, run 
the command:

ovc -status -id TIB

The following message appears:

tib-frontend TIB SPI Frontend Subagent    TIB       Stopped

You cannot start the Frontend Subagent until you configure it. See Configure 
the Backend Service and the Frontend Subagent on page 42. You might get 
the following critical message in the HPOM message browser:
TIBCO SPI Subagent (Frontend) of subagent 25 aborted; process 
did an exit 0 (OpC30-1040). 
You can ignore this message since the Frontend Subagent cannot be started 
until you configure it.
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Configure the Backend Service and the Frontend 
Subagent

To configure the Frontend Subagent and Backend Service, you must define 
various configuration options. You can define these options using the TIBCO 
SPI Configuration Editor that is present in the TIBCO SPI Tools application 
group.

To configure the Backend Service and the Frontend Subagent: 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

2 From any HPOM window, open the Application Bank window by selecting 
Window → Application Bank.

3 In the Application Bank window, double-click the TIBCO SPI Tools 
application group.

4 In the Application Group: TIBCO SPI Tools window, right-click Configure 
TIBCO SPI application and select Execute from the popup menu.

5 The TIBCO SPI Configuration Editor window appears.

6 From the TIBCO SPI Configuration Editor, click the icon next to Top of 
tree.

7 Click the icon below Back End Configuration.

8 Select OVO Management Server Info.

9 Modify the Host Name and any other fields if required. Make sure the 
default RMI port is not already in use.

10 Click the icon next to Front End Configuration.

11 Select Managed Object Information.

12 Select Wsdl Location Information. 

13 In the Location Candidates list, add a WSDL location for a managed 
object you want the Frontend Subagent to monitor. Managed objects are 
exposed by the TIBCO EMA software. See the TIBCO EMA 
documentation for instructions on finding a managed object’s published 
WSDL location.
42                                                                                                                                                   Chapter 2



14 To configure an additional WSDL location, create a new Location 
Candidate by selecting Managed Object Information and from the menu 
click Edit → New.

Figure 9 TIBCO SPI Configuration Editor

15 In the new Location Candidates list, add a WSDL location for the 
managed object you want the Frontend Subagent to monitor.

16 Repeat steps 13 and 14 to add additional WSDL locations.

17 Select OVO Management Agent Info.

18 Modify the Host Name and other fields if required. Make sure the default 
RMI port is not already in use.

19 Select File �→ Save to save your changes to the configuration file.

20 Select File �→ Exit.

If the WSDL location uses HTTPS, then you must configure the Frontend 
Subagent's security settings. For details, refer Configuring HTTPS 
Communication section in Chapter 7, Security Features and Configuration.

The WSDL locations that are configured in the Managed Object Information 
field must be accessible before starting the Frontend Subagent.
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21 In the Output of Application window, the following message appears:

TIBCO SPI configuration completed.

22 It may take a few minutes for the message to appear. Do not close the 
output of application window before you see the completion message.

23 Click the Close button in the output of application window.
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Assign TIBCO SPI Templates

HPOM-based templates are used to capture management data and metrics. 
The templates are specific to TIBCO SPI and are included with the TIBCO 
SPI installation. In general, the templates collect and monitor data. The data 
includes metric data, operational notifications, logging data, and UDM metrics. 
The data is used to effectively manage the TIBCO environment within 
HPOM. See Appendix B, SEA Configuration for a complete reference of the 
templates included with TIBCO SPI.

Before assigning TIBCO SPI templates, you must configure the data sources 
that are used to store the collected data metrics. 

Configure Data Sources for Metric Data Collection

The metrics collected by the Frontend Subagent templates are stored in a 
data source. A script which creates and configures the data source is provided. 

To configure data source for metric data collection:

1 From a command prompt, change directories to /opt/OV/bin.

2 Run the command:

./tib-perl tib-create-datasources

3 The following message is displayed:

Start Data Logging Integration

Assign Backend Service Templates 

The TIBSPI-UNIX-Backend-V1 template group contains the templates that 
monitor the TIBCO SPI log files on the HPOM management server. This 
template group is assigned and deployed on the management server.

To assign the TIBSPI-UNIX-Backend-V1 template group to the management 
server: 

1 From the administrator GUI, open the Node Bank window by selecting 
Window → Node Bank.
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2 In the Node Bank window, select the management server where the 
Backend Service is running.

3 Select Actions → Agents → Assign Templates

4 In the Define Configuration dialog box, click the Add button.

5 In the Add Configuration dialog box, click the Open Template Window button.

6 In the Message Source Templates dialog box, select SPI for TIBCO template 
group in the Template Groups from the left.

7 Select the TIBSPI-UNIX-Backend-V1 template group.

8 In the Add Configuration dialog box, click Get Template Selections button.

9 Click the OK button in the Add Configuration dialog box.

10 Close the Message Source Templates dialog box by selecting Templates → 
Close Window.

11 Click OK in the Define Configuration dialog box.

Deploy Backend Service Templates

To deploy the Backend Service Templates: 

1 In the Node Bank window, select the management server where the 
Backend Service is running.

2 Select Actions → Agents → Install / Update SW & Config.

3 In the Install / Update HP Software and Configuration dialog box, select 
Templates in the Components frame.

4 Select Force Update in the Options frame.

5 Click the OK button.

Assign Frontend Subagent Templates

The Frontend Subagent template groups must be assigned and deployed to 
the node where the Frontend Subagent is installed before the templates can 
be used.
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To assign Frontend template groups to a node:

1 From the administrator GUI, open the Node Bank window by selecting 
Window → Node Bank.

2 In the Node Bank window, select the node where the Frontend Subagent 
is running.

3 Select Actions → Agents → Assign Templates.

4 In the Define Configuration dialog box, click the Add button.

5 In the Add Configuration dialog box, click the Open Template Window button.

6 In the Message Source Templates dialog box, double-click the SPI for 
TIBCO template group in the Template Groups from the left.

7 Select the TIBSPI-EventService-V1 template group.

8 In the Add Configuration dialog box, click the Get Template Selections 
button.

9 If you want to monitor the Frontend Subagent’s log file, repeat steps 8 and 
9 for the TIBSPI-UNIX-Frontend-V1 template group.

10 If you want to log metrics, repeat steps 8 and 9 for the TIBSPI-Metrics-V1 
template group.

11 Click the OK button in the Add Configuration dialog box.

12 Close the Message Source Templates dialog box by selecting Templates  → 
Close Window.

13 Click OK in the Define Configuration dialog box.

Deploy templates to the Frontend Subagent Node

To deploy the templates to the Frontend Subagent Node: 

1 In the Node Bank window, select the node where the Frontend Subagent 
is running.

2 Select Actions → Agents → Install / Update SW & Config.

3 In the Install / Update HP Software and Configuration dialog box, select 
Templates in the Components frame.

4 Select Force Update in the Options frame.

5 Click the OK button.
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Assigning Template Groups

The TIBSPI-UNIX-V1 template group contains the templates that monitor 
various TIBCO products that are running on UNIX nodes, for instructions to 
assign templates refer to the section, Assign the TIBSPI-UNIX- V1 Template 
Group

The TIBSPI-Windows-V1 template group contains the templates that monitor 
various TIBCO products that are running on Windows nodes, for instructions 
to assign templates refer to the section, Assign the TIBSPI-Windows-V1 
Template Group

Assign the TIBSPI-UNIX- V1 Template Group

The TIBSPI-UNIX-V1 template group contains the templates that monitor 
various TIBCO products that are running on UNIX nodes. 

For this procedure, assume that TIBCO is running on all of the nodes in the 
TIBSPI-UNIX node group. Therefore, assign the TIBSPI-UNIX-V1 template 
group to the TIBSPI-UNIX node group.

To assign the template group to the UNIX node group:

1 From the administrator GUI, open the Node Group Window by selecting 
Window → Node Group Bank.

2 In the Node Group Bank window, select the TIBSPI-UNIX node group.

3 Select Actions → Agents → Assign Templates

4 In the Define Configuration dialog box, click the Add button.

5 In the Add Configuration dialog box, click the Open Template Window 
button.

6 In the Message Source Templates dialog box, double-click the SPI for 
TIBCO template group in the Template Groups from the left.

7 Select the TIBSPI-UNIX-V1 template group.

8 In the Add Configuration dialog box, click Get Template Selections button.

The HP Operations agent must be deployed onto the UNIX nodes where the 
TIBCO products are running before you can deploy the TIBSPI-UNIX-V1 
template group.
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9 Click the OK button in the Add Configuration dialog box.

10 Close the Message Source Templates dialog box by selecting Templates → 
Close Window.

11 Click the OK button in the Define Configuration dialog box.

Deploy the TIBSPI-UNIX- V1 Template Group to the UNIX Nodes

To deploy the template group to the UNIX node group: 

1 In the Node Group Bank window, select the TIBSPI-UNIX node group.

2 Select Actions → Agents → Install / Update SW & Config.

3 In the Install / Update HP Software and Configuration dialog box, select 
Templates in the Components frame.

4 Select Force Update in the Options frame.

5 Click the OK button.

Assign the TIBSPI-Windows-V1 Template Group

The TIBSPI-Windows-V1 template group contains the templates that monitor 
various TIBCO product’s log files that are running on Windows nodes. 

For this procedure, assume that TIBCO is running on all of the nodes in the 
TIBSPI-WINDOWS node group. Therefore, assign the TIBSPI-Windows-V1 
template group to the TIBSPI-WINDOWS node group. 

To assign the template group to the Windows node group:

1 From the administrator GUI, open the Node Group Window by selecting 
Window → Node Group Bank.

2 In the Node Group Bank window, select the TIBSPI-WINDOWS node group.

3 Select Actions → Agents → Assign Templates

4 In the Define Configuration dialog box, click the Add button.

The HP Operations agent must be deployed onto the Windows nodes where 
the TIBCO products are running before you can deploy the 
TIBSPI-Windows-V1 template group.
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5 In the Add Configuration dialog box, click the Open Template Window 
button.

6 In the Message Source Templates dialog box, double-click the SPI for 
TIBCO template group in the Template Groups from the left.

7 Select the TIBSPI-Windows-V1 template group.

8 In the Add Configuration dialog box, click the Get Template Selections 
button.

9 Click the OK button in the Add Configuration dialog box.

10 Close the Message Source Templates dialog box by selecting Templates → 
Close Window.

11 Click OK in the Define Configuration dialog box.

Deploying the TIBSPI-Windows-V1 Template Group to the Windows Nodes

To deploy the templates to the Windows node group: 

1 In the Node Group Bank window, select the TIBSPI-WINDOWS node group.

2 Select Actions → Agents → Install / Update SW & Config.

3 In the Install / Update HP Software and Configuration dialog box, select 
Templates in the Components frame.

4 Select Force Update in the Options frame.

5 Click the OK button.

6 Repeat this procedure for all the Windows Nodes.

Verifying Deployed Templates

The following procedure can be used to verify that TIBCO SPI template 
groups have been deployed.

To verify deployed templates:

1 From a command prompt, change directories to /opt/OV/bin/OpC.

2 Run the command:

opctemplate

3 In the output, verify that the deployed TIBSPI templates are displayed.
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Start the TIBCO SPI

TIBCO SPI can be started from the HPOM Administration GUI. Before 
starting TIBCO SPI, you must have installed and configured the Frontend 
Subagent.

To start TIBCO SPI:

1 Launch the administrator GUI on the HPOM management server and log 
on.

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 From the Application Bank window, double-click the TIBCO SPI Tools icon.

4 From the Application Group: TIBCO SPI Tools window, right-click Start 
TIBCO SPI and select Execute in the popup menu. An Output of Application 
window displays. The following message displays:

Node <machine>.<domain name>:

Starting OpC services...Done.

Starting up the backend...

The backend started.

Starting up the frontend...

The frontend startup is complete when the message 'Service Map Created' 
is emitted in the log file.

5 Use the steps in the section Checking the TIBCO SPI Status on page 54 to 
verify that the TIBCO SPI is started.

Restarting the TIBCO SPI

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

Make sure you have set the JAVA_HOME variable to the JRE installation 
directory. See section Configure the Backend Service and the Frontend 
Subagent on page 42.
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2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 From the Application Bank window, double-click the TIBCO SPI Tools icon.

4 From the Application Group: TIBCO SPI Tools window, right-click Restart 
TIBCO SPI and select Execute in the popup menu. An Output of Application 
window displays. The following message displays:

Node <machine>.<domain name>:

Starting OpC services...Done.

The frontend was stopped successfully

The backend was stopped successfully

Starting up the backend...

The backend started.

Starting up the frontend...

The Frontend startup is complete when the message 'Service Map Created' 
is emitted in the log file.

5 Use the steps in the section Checking the TIBCO SPI Status on page 54 to 
verify that the TIBCO SPI is started.
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Stopping the TIBCO SPI

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 From the Application Bank window, double-click the TIBCO SPI Tools icon.

4 From the Application Group: TIBCO SPI Tools window, right-click Stop 
TIBCO SPI and select Execute in the popup menu. The application window 
displays the following message:

Node xxx:

Shutting down OpC services...Done.

The frontend was stopped successfully.

The backend was stopped successfully.

5 Click the Close button.

6 Use the steps in the section Checking the TIBCO SPI Status on page 54 to 
verify that the TIBCO SPI is stopped.
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Checking the TIBCO SPI Status

You can check the status of the TIBCO SPI to see if it is started and operating 
successfully. You can also check the status to ensure that the TIBCO SPI has 
been stopped successfully. This is helpful when debugging any problems.

To check the Status of the TIBCO SPI:

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 From the Application Bank window, double-click the TIBCO SPI Tools icon.

4 From the Application Group: TIBCO SPI Tools window, right-click Check 
Status TIBCO SPI and select Execute in the popup menu. An Output of 
Application window displays the status of both the Backend and Frontend 
Subagent.

5 After reviewing the status, click the Close button.

Verifying a Start Status

If the TIBCO SPI is started without any errors, the following status displays 
when using the TIBCO SPI Check Status command. 

object manager name: tib-backend
state:               RUNNING
PID:                 4063
last message:        -
exit status:         -

Node <machine>.<domain name>:
OVO Managed Node status:
-------------------------
Control Agent        /opt/OV/bin/OpC/opcctla (2428) is running
Message Agent        /opt/OV/bin/OpC/opcmsga (5944) is running
BBC Local Location Broker /opt/OV/bin/llbserver (5945) is 
running
Subagent 25:
 TIBCO SPI Subagent (Frontend)     
 /opt/OV/bin/tib-perl /opt/OV/bin/tib-start-frontend (4389) 
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is
 running
Done.

When using an OVO 8.x HTTPS agent node, the following status displays:

object manager name: tib-backend
state:               RUNNING
PID:                 4063
last message:        -
exit status:         -

Node <machine>.<domain name>:
OVO Managed Node status:
-------------------------
ovcd        OV Control             CORE         (14629)  Running
ovbbccb     OV Communication Broke CORE         (14630)  
Running
ovconfd     OV Config and Deploy   COREXT       (14631)  
Running
Subagent 25: 
   TIB SPI Frontend Subagent tib-frontend    (4389) is running
Done.

Verify a Stop Status

If the TIBCO SPI has stopped without any errors, the following status 
displays when using the TIBCO SPI Check Status command: 

object manager name: tib-backend
state:               NOT_RUNNING
PID:                 -
last message:        -
exit status:         Exit(0)

If the Frontend Subagent is not running, it may be still starting up. On the 
Frontend Subagent node, look in the /var/opt/OV/log/tib/
frontend.log file for the 'Service Map Created' message. If the message 
is not displayed, it indicates that the Frontend Subagent has not started.
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Node <machine>.<domain name>:
OVO Managed Node status:
-------------------------
Control Agent        /opt/OV/bin/OpC/opcctla (2428) is running
Message Agent        /opt/OV/bin/OpC/opcmsga (5944) is running
BBC Local Location Broker /opt/OV/bin/llbserver (5945) is 
running
Subagent 25:
 TIB SPI Subagent (Frontend) 
 /opt/OV/bin/tib-perl /opt/OV/bin/tib-stop-frontend isn't 
running
Done.

When using an OVO 8.x HTTPS agent node, the following status displays:

object manager name: tib-backend
state:               NOT_RUNNING
PID:                 6677
last message:        -
exit status:         Exit(0)

Node <machine>.<domain name>:
OVO Managed Node status:
ovcd        OV Control              CORE         (14629)  
Running
ovbbccb     OV Communication Broker CORE         (14630)  
Running
ovconfd     OV Config and Deploy    COREXT       (14631)  
Running
Subagent 25: 
   TIBSPI SPI Frontend Subagent tib-frontend isn’t running
Done.
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Install the Java Console (Service Navigator)

HPOM for UNIX includes a Java-based operator’s console that is used to 
monitor an HPOM managed environment. For the TIBCO SPI, the Java 
console is used to: 

• View the status of the TIBCO SPI and TIBCO EMA services.

• Perform impact analysis and root cause analysis for the TIBCO SPI and 
TIBCO EMA services.

• Interact with TIBCO SPI tools.

• View and manage TIBCO SPI and TIBCO EMA messages.

• Access the HP Resource Explorer

The Java console can run on any system where a JRE is installed. However, 
the instructions in this section are specific to installing the Java console on 
Windows. See the HPOM documentation or the Java console’s Online Help 
(once you have installed the Java console on Windows) for instructions on 
additional platform installation instructions.

To install the Java console:

1 Ftp /opt/OV/www/htdocs/ito_op/ITO_JAVA.exe from the HPOM 
management server to the PC where you are installing the console.

2 Execute ITO_JAVA.exe. An install shield displays and guides you 
through the installation process.

Starting the Java Console

To start the Java console:

1 Double-click the Java Console icon on the desktop.

2 Enter the following information in the HPOM Login dialog box (if a 
different operator was configured, use that operator name instead of 
TIBSPI_Op):

To access the HP Resource Explorer from within the Java console, you must 
install the Java console on a Windows system. See the section Install the HP 
Resource Explorer on page 59.
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— User Name: TIBSPI_Op

— Password: TIBSPI_Op

— Management Server: <your OVO management server system>

3 Click OK. The Java console starts and displays information for your 
HPOM environment.

4 From the Object Pane, expand the Services node to view TIBCO services.

5 From the Object Pane, expand the Message Groups node to view the 
TIBCO and TIBCO SPI message groups.

6 From the Object Pane, expand the Applications node to view TIBCO SPI 
Tools.

If you are new to the Java console, see the HPOM documentation or the Java 
console’s Online Help.
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Install the HP Resource Explorer

The HP Resource Explorer is used to interact with TIBCO EMA Managed 
Objects (MOs) that are exposed for management purposes. The Resource 
Explorer interacts directly with the MOs and allows the operator to perform 
many client management tasks. These include:

• Browsing MO published events

• Browsing relationships between MOs

• Browsing and editing MO attributes

• Invoking operations on MOs and editing their parameter values

The HP Resource Explorer must be installed on a Windows platform. In 
addition, when accessing the Resource Explorer from the Java console, the 
Console and Resource Explorer must be installed on the same computer.

To install the HP Resource Explorer:

1 Ftp tib_resource_explorer.zip, located on the management server 
at /opt/OV/bin, to a location on your system where Service Navigator 
GUI is running.

2 Unzip the HP Resource Explorer to any directory on your local machine.

3 Modify the user’s PATH environment variable to include the directory 
where you installed the HP Resource Explorer. The PATH is used by the 
Java console to locate and start the Resource Explorer.

4 Make sure JAVA_HOME is set.

Starting the HP Resource Explorer from the Java Console

The HP Resource Explorer is typically started from the Java console. You can 
start multiple concurrent Resource Explorer sessions. 

To start the Resource Explorer from the Java console:

1 Start the HP Java console.

2 From the Object Pane, expand the Services node.

3 From the TIBService node, right-click a TIBCO service and then from the 
popup menu select Start → Resource Explorer. The Resource Explorer 
starts in its own window in a separate process.
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Online help is included with the Resource Explorer. From the Explorer’s menu 
bar, select Help. The Online Help includes instructions for browsing and 
editing MOs as well as invoking an MO’s operations.

Starting the HP Resource Explorer form the Command Line

The Resource Explorer can also be started from the command line using the 
hp_resource_explorer.bat file. The file is located in the root directory 
where the Resource Explorer is installed.

As part of the command, you must pass the URL of the management web 
service. Once invoked, this web service becomes the root of the functional tree 
in the Resource Explorer. The following is an example command line:

hp_resource_explorer.bat -moUri http://<host>:8888/
?wsdl:objid=tibema://www.tibco.com/ema/2005/01/mo/
identity/ServiceInstance/tibtest1/TIBCOServers/
<machine>.<domain name>-7500
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Install TIBCO SPI Reports

TIBCO SPI integrates with HP Reporter, which is a Windows-based report 
management system. As part of the integration, a set of reports are included 
with the TIBCO SPI and used to view the performance of the TIBCO 
Applications.

To install the TIBCO SPI Reports:

1 From the HP Operations Smart Plug-ins DVD, change directories to 
\OV_REPORTER\TIBCOSPI_A.01.03.xxx.

2 Double-click the TIBSPI-Reporter.msi. An InstallShield Wizard displays.

3 Click Next. The Setup Type screen displays.

4 Accept the default option (Complete) and click Next. The Ready to Install 
the Program screen displays.

5 Click Install to initiate the installation.

6 After the installation is complete, click Finish.

HP Reporter must be installed prior to completing the instructions in this 
section. For detailed installation instructions, see the HP Reporter 
documentation. In addition, the Frontend Subagent system must be running 
either HP Performance Agent or the Embedded Performance Component 
(Coda). See Chapter 3, Performing Standard Management Functions for more 
information on HP Performance Agent or the Embedded Performance 
Component (Coda).
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Uninstalling the TIBCO SPI

To uninstall TIBCO SPI, use the procedures in this section. The procedures 
should be completed in the order in which they are listed. 

Uninstalling the Frontend Subagent

The Frontend Subagent must be stopped before you can stop the TIBCO SPI. 

To uninstall the Frontend Subagent: 

1 On the node where the Frontend Subagent is installed, stop the Subagent 
by running:

opcagt -stop -id 25 (OVO-U 7.x)

ovc -stop -id TIB (OVO-U 8.x)

2 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.

3 In the Node Bank window, select the node where the Frontend Subagent 
is installed.

4 Select Actions → Subagents → Deinstall.

5 In the Deinstall Subagents dialog box, select TIBCO SPI Subagent in the 
Subagents frame on the left.

6 Click the OK button. The Install Subagent Packages dialog box displays. A 
confirmation message appears: 

inst.sh complete (de)installation of tibspi Subagent product.

7 Press Enter.

8 If the opcagt is not running on the node where the Frontend Subagent 
was installed, restart it by running.

opcagt -start -id 25 (OVO-U 7.x)

Make sure that you uninstall the Frontend Subagent before you remove 
TIBCO SPI from the HPOM management server. If you do not, you will 
encounter problems when reinstalling TIBCO SPI.
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ovc -start -id TIB (OVO-U 8.x)

9 Verify that the Frontend Subagent is uninstalled by running the opcagt 
command on the node where the Frontend Subagent was running:

opcagt -status -id 25 (OVO-U 7.x)

ovc -status TIB (OVO-U 8.x)

The output should be:

Error opcctla (Control Agent)(xxx) : Subagent 25 not 
registered

The output on OVO 8.x should be:

(ctrl-4) No component matches target.

Remove the TIBCO SPI Installed on HP-UX

1 Stop the Backend Service on the HPOM management server by running 

ovstop tib-backend 

2 On the HPOM management server, run 
swremove.

3 From the SD Remove - Software Selection dialog box, select the SPITIB.

4 Select Actions → Remove.

5 From the Remove Analysis dialog box, click the OK button.

6 From the Remove Window dialog box, verify that the Status says that it 
completed successfully. If the status is “Completed with Warnings”, this 
is expected and you can proceed. If the status indicates errors, click the 
Logfile button to view the errors.

7 Click the Done button.

8 Select File → Exit to Close the SD Remove - Software Selection dialog box.

Remove the TIBCO SPI Installed on Solaris

To remove TIBCO SPI installed on Solaris:

1 Stop the Backend Service on the HPOM management server by running 
ovstop tib-backend. 
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2 On the HPOM management server, run swremove from the command line 
and include the TIBCO SPI SD install name (SPITIB) in the command.

swremove SPITIB

Remove TIBCO SPI Regroup Condition

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.

2 From the Node Bank, select Actions → Server-Regrouping.

3 In the Regroup Conditions window, select Send SNMP Traps to Service. 

4 Click the Delete button.

5 Click the Yes button to confirm the delete.

6 Click the OK button to save the change and close the window.

Remove TIBCO SPI Message Groups

1 From any HPOM window, select Window → Message Group Bank. 

2 In the Message Group Bank window, right-click the TIBCO message group 
and select Delete from the popup menu.

3 Click the Yes button to confirm the delete.

4 Right-click TIBCO SPI message group and select Delete from the popup 
menu.

5 Click the Yes button to confirm the delete.

6 Click the Close icon to close the window.

Remove the TIBCO SPI Application Group

1 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank. 

2 From the Application Bank window, right-click TIBCO SPI Tools and select 
Delete from the popup menu.

3 Click the Yes button to confirm the delete.
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4 Click the Close icon to close the window.

Remove the TIBCO SPI User Profile

1 From HPOM window, select Window → User Profile Bank. 

2 From the User Profile Bank window, right-click the TIBSPI User Profile and 
select Delete from the popup menu.

3 Click the Yes button to confirm the delete.

4 Click the Close icon to close the window.

Remove the TIBCO SPI User

1 From HPOM window, select Window → User Bank. 

2 From the User Bank window, right-click TIBSPI_Op and select Delete from 
the popup menu.

3 Click the Yes button to confirm the delete.

4 Click the Close icon to close the window.

Remove TIBCO SPI Message Templates

1 From any HPOM window, select Window → Message Source Templates. 

2 In the Message Source Templates window, select SPI for TIBCO in the 
Template Groups frame on the left.

3 Select all of the template groups in the right frame.

4 Click the Delete From All button.

5 Click the Yes button to confirm the delete.

6 Select SPI for TIBCO again in the Template Groups frame.

7 Click the Delete From All button.

8 Click the Yes button to confirm the delete.

9 Select [Toplevel] in the Template Groups frame.
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10 Select all of the template groups that start with TIBSPI in the right 
frame.

11 Click the Delete From All button.

12 Click the Yes button to confirm the delete.

13 Select [Toplevel] again in the Template Groups frame.

14 Select all of the templates that start with TIBSPI in the right frame.

15 Click the Delete From All button.

16 Click the Yes button to confirm the delete.

17 Close the window by selecting Templates → Close Window.

Reinstall the Templates Monitor and Commands

1 From the Node Group Bank window, select the TIBSPI-UNIX node group. 

2 Select Action → Agents → Install / Update SW & Config.

3 In the Install / Update HP Software and Configuration dialog box, select 
Templates, Monitors and Commands in the Components frame on the left.

4 Select Force Update in the Options frame.

5 Click the OK button.

6 In the Node Group Bank window, select the TIBSPI-WINDOWS node group.

7 Select Action → Agents → Install / Update SW & Config.

8 In the Install / Update HP Software and Configuration dialog box, select 
Templates, Monitors and Commands in the Components frame on the left.

9 Select Force Update in the Options frame.

10 Click the OK button.

Remove the TIBCO SPI Node Groups From the HPOM Database

1 From any HPOM window, select Window → Node Group Bank. 

2 In the Node Group Bank window, right-click the TIBSPI-UNIX node group 
and select Delete from the popup menu.

3 Click the Yes button to confirm the delete.
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4 Right-click TIBSPI-WINDOWS node group and select Delete from the popup 
menu.

5 Click the Yes button to confirm the delete.

6 Right-click TIBSPI-EXTERNAL node group and select Delete from the popup 
menu.

7 Click the Yes button to confirm the delete.

8 Click the Close icon to close the window.
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Configuring TIBCO SPI to Run as Non-Root User

HPOM processes normally run as user root on UNIX systems. The root or 
administrative privileges enable the processes to perform the following:

• Access HPOM related files and resources that are normally restricted to 
privileged access only

• Switch user for application specific access rights

• Access operating system resources such as log files and configuration files

• Start application or operating system specific commands and executables

TIBCO SPI processes function in a similar way. But there may be systems 
within IT environments where it is necessary to limit the number of processes 
that have root permissions to a small, well defined and tested group. TIBCO 
SPI on UNIX managed node can be configured to run under a user that does 
not have root permissions. This is often referred to as “running as non-root”. 

Configuring TIBCO SPI to run as non-root is supported on HTTPS agents 
with HPOM. You can do this using the ovswitchuser tool.

To configure SPI as non-root user, do the following:

1 Stop HPOM processes by running the following command:

ovc -kill

2 Run the following script to assign the permissions and ownership to 
non-root user for agent processes:

/opt/OV/bin/ovswitchuser.sh –existinguser <non-root user> 
-existinggroup <non-root group>

For example:

/opt/OV/bin/ovswitchuser.sh –existinguser tibuser –
existinggroup tibcogroup

3 Run the following script to assign the permissions and ownership to 
non-root user for TIBCO SPI:

/var/opt/OV/bin/instrumentation/tib-switch-user.pl 
<non-root user> <non-root group>

This feature is not supported if both the Frontend Subagent and Backend 
Service are located on the HPOM management server.
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4 Change BBC port from 383 (default value) to any available port greater 
than 1024, on both the systems where Backend and Frontend are running.

a On the managed node (where Frontend is installed) run the following 
command.

ovconfchg -ns bbc.cb.ports -set PORTS "<host name of the 
system where frontend is installed>:<port number>"

For Example:

ovconfchg –ns bbc.cb.ports –set PORTS 
“<machine>.<domain name>:8001”

b On the management server (system where the Backend service is 
installed) run the following command.

ovconfchg -ns bbc.cb.ports -set PORTS "<host name of the 
management server>:<default port>,<host name of the machine 
where frontend is installed>:<new port number>"

For Example:

ovconfchg –ns bbc.cb.ports –set PORTS 
“machine1.domain.com:383, machine2.domain.com:8001”

5 If the performance agent is Coda, change the coda port on the managed 
node from 381(default port) to any available port greater than 1024 by 
executing the command:

ovconfchg -ns coda.comm -set SERVER_PORT <port number>

6 Confirm the port change by executing the following command on the 
system where frontend subagent is installed:

ovconfget

7 Start the agent as non-root user by running the following command on the 
system where frontend subagent is installed:

su - <non-root user>

8 Start ovc as non-root user by running the following command:

ovc -start 

When TIBCO SPI is running as a non-root user, and performance agent used 
by HPOM is HP Performance Agent, then data collection is supported only 
with OVPA version 4.5.
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(ensure that all processes are running)

For information on supported agent platforms, refer to the 
HP Operations Smart Plug-in for TIBCO Release Notes.

Refer to the, HP Operations HTTPS Agent Concepts and Configuration Guide, 
for more information on configuring non-root user.
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3 Performing Standard Management 
Functions
This chapter provides management tasks that are typically performed when 
managing a TIBCO environment. In particular, the following sections are 
included:

• Service Management

• Event Management

• Monitoring and Data Collection

• Reporting and Performance Graphs

• Monitoring Performance Metrics with HP Performance Manager

• TIBCO SPI Self Management

• Modify Logging and Tracing Levels
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Service Management

Service management is achieved using the Service Navigator that is included 
in the HPOM Java console and using the HP Resources Explorer plug-in to 
the Service Navigator. During runtime, the TIBCO SPI automatically 
discovers TIBCO managed resources and represents them as a Service Map. 
Any deployment changes that occur in the TIBCO environment are 
dynamically synchronized with the Service Map.

The Service Navigator and HP Resource Explorer also allow detailed 
management of the resources that are presented in the Service Map. The 
detailed management includes browsing the managed resource hierarchy, 
their relationships, attributes, metrics, and invocation of methods that are 
exposed by the resource.

Instructions for installing and starting the Java console (including the Service 
Navigator) and the HP Resource Explorer are located in Chapter 2, 
Installation and Configuration. In addition, Online Help is available for both 
the Java console and HP Resource Explorer.

Viewing TIBCO Managed Resources

To view TIBCO managed resources: 

1 Start and log in to the Java console.

2 From the Object Pane, expand the Services node to view TIBCO resources. 
The resources are represented in a hierarchy. Expand any node to view 
the contained resources. 

3 From the TIBService node, right-click a TIBCO resource and from the 
popup menu select Start → Resource Explorer. The Resource Explorer 
starts in its own window in a separate process. Like the service node, the 
Resource Explorer lists the TIBCO resources in a hierarchy form and 
allows you to select any resource, view its management data, and invoke 
any available operations.

The section is intended only as a quick start reference and does not represent 
a replacement for the Java console or HP Resource Explorer documentation.
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Linking Other Service Maps

This feature allows you to link the TIBCO service map to the infrastructure 
service maps that the TIBCO service nodes depend on. These infrastructure 
elements could be anything from hardware, to other applications like SAP or 
Database. To see an integrated service map in the service navigator, the 
infrastructure components must have a corresponding SPI installed and must 
have its own service map in the service navigator. There are two methods of 
linking other SPI service maps to the TIBCO SPI service map: 

• Automatic

• Manually (based on a configuration file)

Automatically Linking

To automatically link the OS SPI service map, the node hosting RVD should 
be managed using the OS SPI and the OS SPI’s service discovery should be 
enabled.

 Manually Linking

The TIBCO SPI also enables manually linking to other SPIs. For example if 
there is a Data Base (DB) adapter on the TIBCO EMA agent, then this 
adapter can be linked to a DB SPI which is already deployed has a service 
map. 

To manually link other service maps:

1 Launch the administrator GUI on the HPOM management server and 
login. 

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 In the Application Bank window, double-click the TIBCO SPI Tools 
application group.

4 In the Application Group: TIBCO SPI Tools window, right-click Configure 
TIBCO SPI application and select Execute from the popup menu.

The Automatic linking is currently limited to the service map of the 
Operating System (OS) SPI. Manually, you can link any service map.
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5 Enter the following properties:

— AliasInfo/ServiceName: Adapter's service name. The name can be 
found by clicking Properties on the service icon in the Java console’s 
Service Navigator.

— AliasInfo/AliasName: The service name on the SPIs (such as DB SPI, 
OS SPI, SAP SPI) which integrate with TIBCO SPI. The name can be 
found by clicking Properties on the service icon for a SPI in the Java 
console’s Service Navigator.

— AliasInfo/AliasLabel: The service label on the SPIs (such as DB SPI, 
OS SPI, SAP SPI) which integrate with TIBCO SPI. The label can be 
found by clicking Properties on the service icon for a SPI in the Java 
console’s Service Navigator.

6 Restart Frontend Subagent. 

End-to-End View of TIBCO SPI Integrations

The TIBCO SPI provides this unique capability to obtain an end to end view of 
everything – from the highest level domain in TIBCO down to the lowest level 
details. This end-to-end view is provided by integrating TIBCO Smart Plug-in 
with other HP Operations Smart Plug-ins such as DBSPI, SAP SPI, SIEBEL 
SPI and OS SPIs and NNM. This enhanced view from the Operations console 
and the Service Navigator map can include information from other HP 
Operations Smart Plug-ins, NNM, as well as from the TIBCO Plug-ins.

The view can also include information from custom applications that have 
been instrumented with TIBCO management APIs. All of these can be 
correlated with their underlying infrastructure components.

This end-to-end view enhances the root-cause analysis capabilities of the 
TIBCO SPI, so that one can locate the source of the problem easily.
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Filtering Unwanted MO Types

You can define a list of MO types that you do not want to be displayed in the 
Java console’s Service Map. This feature is useful if there are many MOs are 
being exposed. 
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To filter out unwanted MO types:

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 In the Application Bank window, double-click the TIBCO SPI Tools 
application group.

4 In the Application Group: TIBCO SPI Tools window, right-click Configure 
TIBCO SPI application and select Execute from the popup menu.

5 In the WCConfig.xml configuration editor GUI, click the icon next to Top 
of tree.

6 Click the icon next to Front End Configuration.

7 Click the icon next to Misc. Configuration.

8 Select Managed Objects to Ignore

9 Fill in the managed object types you want ignored in the General Info 
section in the right frame.

10 Select File → Save to save your changes to the configuration file.

11 Select File → Exit.

12 In the Output of Application window, you should see the message ‘TIBCO 
SPI configuration completed.’ It may take some time before this 
message displays. Do not close the Output of Application window until you 
see the message.

13 Verify that the Frontend Subagent startup has completed. Look for the 
‘Service map created’ message in the /var/opt/OV/log/tib/
frontend.log file.

14 Start the Java console and log on with the username TIBSPI_Op and 
password TIBSPI_Op (if a different operator was configured, use that 
operator name instead of TIBSPI_Op). The MO that you filtered is no 
longer in the service map.
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Event Management

The TIBCO SPI solution monitors availability and status of TIBCO 
applications as well as providing the ability to invoke applications manually 
or automatically when events are received through both HPOM template, as 
well as a WSDM channel. You can filter events by adding new conditions using 
the TIBSPI-EventService-Msg-V1 template or create your own custom 
template. 

Viewing TIBCO Events

All events through EMA are captured and displayed in the Java console’s 
message browser. 

To view TIBCO Events:

1 Start and log in to the Java console. 

2 From the Object Pane, expand the Message Groups node to view the 
TIBCO and TIBCO SPI message groups.

3 Right-click a message and select Properties. The Message Properties dialog 
box is displayed and lists additional details about the event. 

Automatically Responding to Events

A script which allows you to invoke an MO’s operations from the command 
line or from an HPOM template is provided. Typically, the Resource Explorer 
is used to invoke operations. This script enables you to perform operator 
automated actions, where actions are performed based on captured events.

To invoke operations from the command line:

1 From a command prompt, change directories to /var/opt/OV/OpC/bin/
cmds/.

2 Run the tib-operation script using the following parameters:

— WSDL location of the MO 

— NamespaceURI of the PortType

— PortType Name
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— OperationName

For example:

Tib-operation http://<machine1>.<domain name>:8888/
?wsdl:objid=tibema://www.tibco.com/
ema/2005/01/mo/identity/ServiceInstance/tibtest1/
TIBCOServers/<machine2>.<domain name>-7500   http://
schemas.hp.com/wsmf/2003/03/Foundation   
ManagedObjectConfigurationPT GetName
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Monitoring and Data Collection

The Frontend Subagent uses metric definitions to capture TIBCO 
management data for use in HP Performance Manager or Service Reporter 
(when generating alarms, graphs, and reports). This section provides 
instructions on how to customize the collected data and how to change the 
default collection behavior. A brief overview of how metrics are defined is also 
provided. 

Metric Definition Configuration Files

Metrics are configured using two XML configuration files: 
MetricDefinitions.xml and UDMMetricDefinitions.xml (used for 
custom adapters) files. These files are located on the Frontend Subagent node 
in /var/opt/OV/conf/tib. The elements for these files are described below.

• <MetricDefinitions> – The MetricDefinitions element is the top-level 
element within the document. It contains one collection of metrics, 
consisting of one or more metric definitions.

• <Metric> – The Metric element represents one metric. Each metric has a 
unique ID. If a user-defined metric is an alarming, graphing or reporting 
metric, the metric ID must be "TIBSPI_0xxx" where xxx is a number from 
700 through 799. Otherwise, if the metric is used only within the 
calculation of another metric, the metric ID must begin with a letter 
(case-sensitive) and can be followed by any combination of letters, 
numbers and underscores. A Metric element contains one more source 
elements that represent the metric data source. Two data sources are 
supported: WSM and calculations. The following table lists attributes for 
the Metric element:
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• <WSM> – The WSM element is used when the data source of the metric is 
a TIBCO metric definition. The WSM element contains the following 
sub-elements:

— <MetricName> – The TIBCO metric definition name.

— <ObjectTypeList> – List of MO types that will have metric value 
collected.

Table 3 Metric Element Attributes

Attribute Type/Values Required Default Description

id ID yes N/A The metric ID.

name text no no The metric name, used for 
graphing and reporting. The 
name can be up to 20 
characters in length.

alarm Yes
no

no no If yes, the metric value is 
sent to the agent using 
opcmon.

alarm yes
no

no no If yes, the metric value is 
sent to the agent using 
opcmon.

report yes
no

no no If yes, the metric value is 
logged for reporting.

previous yes
no

no yes If yes, the metric value is 
saved in a history file so that 
deltas can be calculated. If 
you are not calculating deltas 
on a metric, set this to "no" 
for better performance.

graph yes
no

no no If yes, the metric is logged for 
graphing.

description no text “” A description of the metric.
82                                                                                                                                                   Chapter 3



— <ObjectIDList> – List of MO instances that will have metric values 
collected.

• <Calculation> and <Formula> – The Calculation element is used when 
the data source of the metric is a calculation using other defined metrics. 
The Calculation element contains a formula element whose content is a 
string that specifies the mathematical manipulation of other metric 
values to obtain the final metric value. The metrics are referred to in the 
calculated expression by their metric ID. The collector can perform 
calculations that combine one or more metrics to define a new metric. The 
result of the calculation is the metric value. Calculations must use syntax 
as follows:

— Operators supported are +, -, /, *, and unary minus.

— Operator precedence and associativity follows the Java model.

— Parentheses can be used to override the default operator precedence.

— Allowable operands are metric IDs and literal doubles.

A metric ID can refer to either a WSM metric or another calculated 
metric. Literal doubles can be specified with or without the decimal 
notation. The metric ID refers to the id attribute of the Metric element 
in the metric definitions document. The calculation parser also 
supports the following functions. All function names are lowercase 
and take a single parameter which must be a metric ID:

— delta – returns the result of subtracting the previous value of the 
metric from the current value.

— interval – returns the time elapsed since the last time the metric was 
collected in milli-seconds.

The following example defines a metric whose value is the ratio (as 
expressed as a percent) of Metric_1 to Metric_3:

<Formula>(Metric_1/Metric_3)*100</Formula>

The following example could be used to define a metric that is a rate 
(number of times per second) for Metric_1.

<Formula>(delta(Metric_1)/interval(Metric_1))*1000</
Formula>
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Modifying Data Collection

By default, data is collected for all RVDs, JMS Servers and BWEngines. If you 
want to collect data for a subset of the RVDs, JMS Servers or BWEngines or a 
subset of the metrics, you need to modify the /var/opt/OV/conf/tib/
MetricDefinitions.xml file. For example, if you only want to collect 
MissedPackets for RVD:
tibema://www.tibco.com/ema/2005/01/mo/identity/ServiceInstance/
tibtest1/TIBCOServers/ovw010-7500 
you would change:

<Metric id="MissedPackets" alarm="no">

   <WSM>

      <MetricName>Missed Packets</MetricName>

      <ObjectTypeList>

   <ObjectType>
            http://www.tibco.com/ema/2005/01/mo/type/RVD

         </ObjectType>

      </ObjectTypeList>

   </WSM>

</Metric>

to:

<Metric id="MissedPackets" alarm="no">

   <WSM>

      <MetricName>Missed Packets</MetricName>

         <ObjectIDList>

            <ObjectID>
               tibema://www.tibco.com/ema/2005/01/mo/identiy/
                  ServiceInstance/tibtest1/TIBCOServers/
ovw010-7500
            </ObjectID>

         </ObjectIDList>

   </WSM>
</Metric>
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Collecting Data for Custom Adapters

The following procedure allows you to collect data and metrics for custom 
adapters

1 On the Frontend Subagent node:

cd /var/opt/OV/conf/tib

cp UDMMetrics-sample.xml UDMMetricDefinitions.xml

2 Add the metrics for the custom adapters to the 
UDMMetricDefinitions.xml file.

3 Bring up the HP Resource Explorer on the custom adapter MO. Follow the 
instructions in the Starting the HP Resource Explorer from the Java 
Console section.

4 Click the + next to the custom adapter MO.

5 Write down the value for the Type property. This information is required 
for a later step.

6 Click the + next to ManagedObjectMetric Interface.

7 Right-click MetricValues and select Open from the popup menu.

8 Add each metric definition you want to alarm, graph, or report in the 
UDMMetricDefinitions.xml file. For example: 

Custom Adapter Type:

http://www.tibco.com/ema/2005/01/mo/type/ServiceInstance/
Adapter

— Metric Definition Name: A name for the definition.

— Messages Sent: The total number of messages sent since the adapter 
was started.

— Message Drop Rate: The percentage of messages dropped per second.

You want to graph the number of messages sent per collection interval and 
alarm on the message drop rate. Your UDMMetricDefinitions.xml file 
contains the following entries: 

<Metric id="TIBSPI_0700" name=”MessagesSent” alarm="no”

    graph=”yes” report=”no”>

  <Calculation>
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    <Formula>delta(MessagesSentInt)</Formula>

  </Calculation>

</Metric>

<Metric id="MessagesSentInt" alarm="no”>

  <WSM>

    <MetricName>Messages Sent</MetricName>

 <ObjectTypeList>

       <ObjectType>http://www.tibco.com/ema/2005/01/mo/type

                /ServiceInstance/Adapter</ObjectType>

       </ObjectTypeList>

   </WSM>

</Metric>

<Metric id="TIBSPI_0701" name=”MessageDropRate”

  alarm="yes” graph=”no” report=”no”>

  <WSM>

    <MetricName>Message Drop Rate</MetricName>

 <ObjectTypeList>

      <ObjectType>http://www.tibco.com/ema/2005/01/mo/type

               /ServiceInstance/Adapter</ObjectType>

  </ObjectTypeList>

     </WSM>

</Metric>

9 Make sure /var/opt/OV/bin/OpC/monitor is in your PATH.

10 Create the UDM data sources by running the following script:

cd to /opt/OV/bin

./tib-perl tib-create-udm-datasources
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11 Stop the Frontend Subagent by running:

opcagt –stop –id 25 (for OVO-U 7.x)
ovc –stop –id TIB (for OVO-U 8.x)

12 To verify if the Frontend Subagent is stopped, run the command:

ps –ef | grep java

If there is an entry with rmiregistry 1651, the Frontend Subagent is 
still running. So run the command:

kill –9 <rmiregistry pid> <rmiregistry parent pid>

For example, if the output of ps –ef | grep java was:

root 5170 5168 0 08:46:32 ? 0:06

/opt/java1.4/bin/PA_RISC2.0/rmiregistry 1651

Run the command:

kill –9 5179 5168

13 To Start the Frontend Subagent, run the command:

opcagt -start -id 25 (OVO-U 7.x)

ovc -start -id TIB  (OVO-U 8.x)

It is assumed that you have already assigned the TIBSPI-Metrics-V1 
template group to the Frontend Subagent node. Modify the 
TIBSPI-Collect-Mon-V1 template in the TIBSPI-Metrics-V1 template group 
to collect the UDM metrics.

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.

2 From any HPOM window, bring up the Message Source Templates 
window by selecting Window → Message Source Templates.

3 Double click SPI for TIBCO in the Template Groups frame on the left.

4 Select the TIBSPI-Metrics-V1 template group in the Template Groups frame 
on the left.

5 Select the TIBSPI-Collect-Mon-V1 template in the right frame and click the 
Modify button.
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6 In the Modify Threshold Monitor dialog, add the UDM metrics to the 
Monitor Program or MIB ID field. For example, if you added metrics 
TIBSPI_0700, TIBSPI_0701 and TIBSPI_0702 to your 
UDMMetricDefinition.xml file, add ‘700-702’ to the end of the Monitor 
Program or MIB ID field. Click the OK button.

Redeploy the templates by following the instructions in the Deploy templates 
to the Frontend Subagent Node section. 

Configuring Multi-Instance Metric Data 

This procedure configures a metric which has multi-instance data. The metric 
is configured using the MetricDefinitions.xml file. The 
UDMMetricDefinitions.xml file is used for custom adapters. For 
information on graphing instance metric data, refer to the section Graphing 
Instance Metric Data in HP Performance Manager on page 102. 

To configure a metric that has multi-instance metric data modify the 
MetricDefinitions.xml file and add the following:

— For the metric that has multi instance data, add 
instanceType="multi" to the <WSM> tag.

— If you want the metric to only match certain instances, add 
<InstanceList> with <Instance> values.

— If you want the metric to match all instance values, don not include 
the <InstanceList> tag. 

Example: All Instance Data (Collect)

<Metric id="WSFSPI_0011" name="SpotAll" alarm="yes" 
graph="yes"   
   report="yes">
   <WSM instanceType="multi">

      <MetricName>getColorAssignmentCount-Count</MetricName>

The metrics values are not logged to the data source until the 
TIBSPI-Metric-V1 template group is assigned and deployed. See Assigning 
Template Groups and Deploy templates to the Frontend Subagent Node.
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      <ObjectTypeList>
         <Type>http://www.tibco.com/ema/2005/01/
            mo/type/ServiceInstance/Custom </Type>

      </ObjectTypeList>

   </WSM>

</Metric>

Metric WSFSPI_0011 is used to collect all instance data for the TIBCO Spot 
application. The getColorAssignmentCount-Count operation returns the count 
for each color.

return[0].row[0].Color =  red
return[0].row[0].Count =  5
return[1].row[0].Color =  black
return[1].row[0].Count =  1
return[2].row[0].Color =  green
return[2].row[0].Count =  0
return[3].row[0].Color =  orange
return[3].row[0].Count =  0
return[4].row[0].Color =  darkGray
return[4].row[0].Count =  0
return[5].row[0].Color =  pink
return[5].row[0].Count =  0
return[6].row[0].Color =  yellow
return[6].row[0].Count =  2
return[7].row[0].Color =  blue
return[7].row[0].Count =  9
return[8].row[0].Color =  lightGray
return[8].row[0].Count =  0
return[9].row[0].Color =  gray
return[9].row[0].Count =  0
return[10].row[0].Color =  cyan
return[10].row[0].Count =  0
return[11].row[0].Color =  magenta
return[11].row[0].Count =  2

The metric is configured to:

• Call opcmon for each instance with object as 
<servername>:<instancename> and the following options: servername, 
instancename, and serverhost.
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• Log data for graphs. For graphs, only one value is logged and this is the 
sum of the instance values. This is a limitation in the data collector. For 
the user to graph instance data, they have to use the data from the 
reports. For the above example, the graph data logged is 19 for 
Spot-ovw022 (server name).

• Log data for reports. Data is logged for each instance. For the above 
example, the report data logged is:

red       5
black     1
green     0
orange    0
darkGray  0
pink      0
yellow    2
blue      0
lightGray 0
gray      0
cyan      0
magenta    2

Example: Specific Instance Data (Collect)

<Metric id="WSFSPI_0012" name="SpotBlue" alarm="yes" 
graph="no"
   report="no">

   <WSM instanceType="multi">

      <MetricName>getColorAssignmentCount-Count</MetricName>

      <ObjectTypeList>

        <ObjectType>http://www.tibco.com/ema/2005/01
           /mo/type/ServiceInstance/Custom</ObjectType>

      </ObjectTypeList>

      <InstanceList>
        <Instance>blue</Instance>

      </InstanceList>
   </WSM>

</Metric>
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Metric WSFSPI_0012 is used to collect the count for blue for the TIBCO Spot 
application. The metric is configured to call opcmon for the blue instance and 
no graph or report data is logged.

Configuring a Threshold for Multi-Instance Metric Data

Configuring a threshold on multi instance metric data is achieved using a 
monitor template. The ISV developer creates a monitor template with the 
same name as the metric id. The developer then adds conditions for each 
instance. A condition that matches all instances can also be added. For 
example: 

For the WSFSPI_0011 metric, the ISV developer creates a monitor template 
with the following information:

• Monitor Name: WSFSPI_0011

• Monitor: External

• Condition: WSFSPI_0011: Magenta

— Object Pattern: magenta

— Threshold: 1

— Severity: minor

— Message Text: <$OPTION(instancename)> count (<$VALUE>) too 
high (>=<$THRESHOLD>)

— Service Name: <$OPTION(serverhome)>

• Condition: WSFSPI_0011: All

— Object Pattern: <*>

— Threshold: 4

— Severity: warning

— Message Text: <$OPTION(instancename)> count (<$VALUE>) too 
high (>=<$THRESHOLD>)

— Service Name: <$OPTION(serverhome)>

Assuming that opcmon is called with the values defined in the All Instance 
Data (Collect) example and the WSFSPI_0011 monitor template is deployed. 
The following messages would be in the HPOM message browser:

— HPOM message
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– Severity: Min

– Message Text: 'magenta' count (2.00) too high (>=1.00)

— HPOM message

– Severity: Warn

– Message Text: 'red' count (5.00) too high (>=4.00)

— HPOM message

– Severity: Warn

– Message Text: 'blue' count (9.00) too high (>=4.00)

Collection Data for Specific Metrics

The TIBSPI-Collect-Mon-V1 monitor template is used to log the metric data 
for graphs. You can modify the template to collect data for a subset of the 
available metrics. For example, to collect data for metrics TIBSPI_0001 – 
TIBSPI_0004 and TIBSPI_0026, follow these steps: 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.

2 From any HPOM window, bring up the Message Source Templates 
window by selecting Window → Message Source Templates.

3 Double click SPI for TIBCO in the Template Groups frame on the left.

4 Select the TIBSPI-Metrics-V1 template group in the Template Groups 
frame on the left.

5 Select the TIBSPI-Collect-Mon-V1 template in the right frame and click 
Modify.

6 In the Modify Threshold Monitor dialog, modify the Monitor Program or 
MIB ID field to contain:

Tib-perl –s TIBSPI-Collect-data –c 
TIBSPI-Collect-Mon-V1 –m 1-4, 26

7 Click the OK button in the Modify Threshold Monitor dialog.

8 Redeploy the templates by following the instructions in the Assign 
Frontend Subagent Templates section.
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Monitoring Custom Adapter Metric Thresholds with HPOM

To monitor custom adapter metric thresholds with HPOM:

1 The metric has to be in added to the /var/opt/OV/conf/tib/
UDMMetricDefinitions.xml file on the Frontend Subagent node. The 
alarm attribute for the metric has to be set to yes. If you are currently not 
collecting data for the metric, follow the instructions in the Collecting 
Data for Custom Adapters section. 

2 If you made modifications to the UDMMetricDefinitions.xml file in the 
above step then do the following:

a Remove the /var/opt/OV/conf/tib/
UDMMetricDefinitions.ser file on the Frontend Subagent node.

b Stop the Frontend Subagent by running the command:

opcagt -stop -id 25 (OVO-U 7.x)

ovc -stop -id TIB  (OVO-U 8.x)

c Start the Frontend Subagent by running the command:

opcagt -start -id 25 (OVO-U 7.x)

ovc -start -id TIB  (OVO-U 8.x)

3 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.

4 From any HPOM window, bring up the Message Source Templates 
window by selecting Window → Message Source Templates.

5 Double click SPI for TIBCO in the Template Groups frame on the left.

6 Select the TIBSPI-Metrics-V1 template group in the Template Groups frame 
on the left.

7 Select TIBSPI_0009 in the right frame. Click on Copy.

8 In the Copy Threshold Monitor dialog, update the Monitor Name and 
Description fields. The Monitor Name value must be the id value for the 
appropriate metric in the /var/opt/OV/conf/tib/
UDMMetricDefinitions.xml file. For example, if you want to monitor 
the message drop rate and your UDMMetricDefinitions.xml file 
contains the following entry:
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<Metric id="TIBSPI_0701" name=”MessageDropRate”
  alarm="yes” graph=”no” report=”no”>
  <WSM>
    <MetricName>Message Drop Rate</MetricName>
 <ObjectTypeList>
       <ObjectType>http://www.tibco.com/ema/2005/01/mo/type/
        ServiceInstance/Adapter</ObjectType>
    </ObjectTypeList>
  </WSM>
</Metric>

Use TIBSPI_0701 as the Monitor Name value. 

9 Click OK in the Copy Threshold Monitor dialog.

10 In the Message Source Templates window, click on Conditions.

11 Modify the conditions in the Message and Suppress Conditions dialog. 
Click the Close button.

12 Close the Message Source Templates window by selecting Templates → 
Close Window.

13 The TIBSPI-Collect-Mon-V1 template has to be assigned and deployed 
on the Frontend Subagent node. The template also needs to be collecting 
the custom adapter metric’s data. 

a Refer to the instructions at the end of the Collecting Data for Custom 
Adapters section on how to verify that the custom adapter metric’s 
data is being collected.

b Run opctemplate on the Frontend Subagent node. Refer to the Assign 
Frontend Subagent Templates and Deploy templates to the Frontend 
Subagent Node sections if the TIBSPI-Collect-Mon-V1 template is 
not in the returned list.

Changing the Metric Data Collection Interval

To change the metric data collection interval, change the Polling Interval in 
the TIBSPI-Collect-Mon-V1 and TIBSPI-Graph-Mon-V1 templates. For 
example, to change the metric data collection from 5 minutes to 10 minutes, 
follow these steps: 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.
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2 From any HPOM window, bring up the Message Source Templates 
window by selecting Window → Message Source Templates.

3 Double-click SPI for TIBCO in the Template Groups frame on the left.

4 Select the TIBSPI-Metrics-V1 template group in the Template Groups frame 
on the left.

5 Select the TIBSPI-Collect-Mon-V1 template in the right frame and click on 
Modify.

6 In the Modify Threshold Monitor dialog, modify the Polling Interval from 
5m to 10m. Click OK.

7 Select the TIBSPI-Graph-Mon-V1 template in the right frame and click 
Modify.

8 In the Modify Threshold Monitor dialog, modify the Polling Interval from 
5m to 10m.

9 Click the OK button.

10 Redeploy the templates by following the instructions in the Deploy 
templates to the Frontend Subagent Node section.

Changing the Metric Threshold Value

By default, there are a couple of monitor templates monitoring individual 
metrics data. For example, the TIBSPI_0009 monitor template monitors RVD 
re-transmitted packet rate. If the re-transmitted packet rate is >= 5, a 
message of major severity appears in the HPOM message browser. If the 
retransmitted packet rate is >= 2 and < 5, a message with minor severity 
appears in the HPOM message browser. To generate a message with minor 
severity when the retransmitted packet rate is >=1 and < 5, perform the 
following steps: 

1 Run the administrator GUI on the HPOM management server and log on 
as opc_adm.

2 From any HPOM window, open the Message Source Templates window by 
selecting Window → Message Source Templates.

3 Double click SPI for TIBCO in the Template Groups frame on the left.

4 Select the TIBSPI-Metrics-V1 template group in the Template Groups frame 
on the left.
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5 Select the TIBSPI_0009 template in the right frame and click on Conditions.

6 In the Message and Suppress Conditions dialog, select the TIBSPI_0009.2 
condition and click on Modify.

7 Select the TIBSPI-Graph-Mon-V1 template in the right frame and click on 
Modify.

8 In the Modify Threshold Monitor dialog, modify the Threshold from 2 to 1. 
Click OK.

9 Close the Message and Suppress Conditions dialog by clicking on the OK 
button.

10 Close the Message Source Templates window by selecting Templates → 
Close Window.

11 Redeploy the templates by following the instructions in the Deploy 
templates to the Frontend Subagent Node section.

Changing which Logfile to Monitor

If you installed the TIBCO EMA Agent in c:\tibco\ema and TIBCO Hawk 
in c:\tibco\hawk then the templates work as is. Otherwise you need to 
modify the location of the logfile. 

Follow these steps to change the location of the TIBCO Hawk logfile if TIBCO 
Hawk is installed in the same directory on all Windows Nodes:

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.

2 From any HPOM window, open the Message Source Templates window by 
selecting Window → Message Source Templates.

3 Double-click SPI for TIBCO in the Template Groups frame on the left.

4 Double-click TIBSPI-Windows-V1 template group in the Template Groups 
frame on the left.

5 Select the TIBSPI-WIN-HAWK-Agent-V1 template group in the Template 
Groups from on the left.

6 Select the TIBSPI-Hawk-WIN-Log-V1 template in the right frame and click 
on Modify.

7 In the Modify Logfile dialog, modify the log file include the location of the 
TIBCO Hawk Agent log file.
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8 Click the OK button in the Modify Logfile dialog.

9 Redeploy the templates by following the instructions in the Deploy 
templates to the Frontend Subagent Node section.

Reporting and Performance Graphs

This section provides instructions for using the Embedded Performance 
Component (Coda) for the purpose of generating reports and performance 
graphs. In addition, instruction for viewing reports and graphs in HP 
Reporter are also provided. 

Using Embedded Performance Component (Coda)

The Embedded Performance Component (Coda) is a performance subagent 
that is bundled for free with the HP Operations agent in OVO for UNIX 7.0 
and later. It is a light-weight performance agent comparable to HP 
Performance Agent. The Embedded Performance Component (Coda) holds 
only 5 weeks worth of data where as HP Performance Agent can potentially 
hold years worth of data. The Embedded Performance Component (Coda) 
Database is stored in the <OVAgentDataDir>/databases directory. There is 
a coda.db and coda##### logs.

To check if  the Embedded Performance Component (Coda) is running, from 
the command prompt run the command:

opcagt -status -id 12 (OVO-U 7.x)

ovc -status -id coda  (OVO-U 8.x)

The output should verify that the Performance Agent /opt/OV/bin/coda is 
running. You can also run the Coda utility program. On HP-UX, the command 
is 

/opt/OV/bin/codautil –support (OVO-U 7.x)

/opt/OV/bin/ovcodautil –support (OVO-U 8.x)

The result is a list of the last logged interval for all of the standard metrics 
and their values.
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Embedded Performance Component (Coda) Logging

The Embedded Performance Component (Coda) keeps up to 5 weeks of data. 
Every Sunday at 12:00am (midnight), a new log file is created. The Embedded 
Performance Component (Coda) will continue to create a new logfile each 
week until it has accrued 5 weeks of logfiles. When the sixth logfile is created, 
the oldest file is deleted. The Embedded Performance Component (Coda) log 
file (coda.log) is located in <OVAgentDataDir>/log/. For example on 
HP-UX the file is /var/opt/OV/log/coda.log. To check if the Embedded 
Performance Component (Coda) is logging data use the following procedure:

1 Open /var/opt/OV/log/coda.log

2 At the end of the coda.log file, you should see the starting message; 
information about files which were opened, deleted and/or created and 
finally the "Waiting for requests..." message. As the Embedded 
Performance Component (Coda) logs data, the timestamp for the newest 
coda##### log changes. 

View TIBCO SPI Reports

This section provides instructions to use HP Reporter to gather TIBCO SPI 
Metric data and generate TIBCO SPI reports. The section is intended only as 
a quick start reference and does not represent a replacement for the Reporter 
documentation. 

To view TIBCO SPI reports:

1 From the Windows Taskbar, select Start → Programs → HP Software → 
Reporter → Reporter.

2 From the left tree, right-click Discover Area and select the Add Single 
System command. The Add Single System dialog box displays.

3 In the System field, enter the full DNS name of the computer where the 
Frontend Subagent is installed (hostname.mycompany.com).

4 Click Add. The Reporter’s discovery program runs, discovers the system, 
and automatically gathers metric data (collected by either HP 
Performance Agent, or the Embedded Performance Component (Coda)) 
from the system.

5 From the Main toolbar, click the Generate Reports button. The TIBCO SPI 
reports are generated. This may take several minutes to complete.
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6 From the Main toolbar, click the Show Reports button. A browser displays 
and lists all of the TIBCO SPI reports. The reports are organized into 4 
categories that show the metric data over different time ranges: TIBCO 
Full Range, TIBCO Last Full Month, TIBCO Last Full Week, and TIBCO 
Yesterday. 

Defining a User Friendly Name for an MO

You can define a user friendly name for the MOs that appears on TIBCO 
graphs and reports. The name is also used as the name of the file where the 
data is logged for graphs before it is sent to HP Performance Agent, or the 
Embedded Performance Component (Coda). Therefore, the name must be a 
valid file name.

In order to use the Service Reporter reports that compare network and TIBCO 
RVD performance metrics, a user friendly name for each RVD is automatically 
defined in the following format as part of the out-of-box solution: 

<RVD fully qualified host name>-<RVD port>-RVD

For example:

ovw010.hp.com-7500-RVD

To define a user friendly name:

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

2 From any HPOM window, open the Application Bank window by selecting 
Window  Application Bank.

3 In the Application Bank window, double-click the TIBCO SPI Tools 
application group.

4 In the Application Group: TIBCO SPI Tools window, right-click Configure 
TIBCO SPI application and select Execute from the popup menu.

5 From the GUI, click the icon next to Front End Configuration.

6 Click Report Information.

7 In the menu bar, select Edit → New.
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8 Use the ReportGroupObjectID and the ReportGroupName fields to enter 
the group object ID and the group name. Remember that the 
ReportGroupName must be able to be used as a valid file name. For 
example:

Assume:

The WSDL location for the RVD using port 7500 on <machine>.<domain 
name> is http://<machine>.<domain name>:8888/
?wsdl:objid=tibema://www.tibco.com/ema/2005/01/mo/identity/
ServiceInstance/tibtest1/TIBCOServers/machine-7500

Then:

ReportGroupObjectID = http://<machine>.<domain name>:8888/
?wsdl:objid=tibema://www.tibco.com/ema/2005/01/mo/
identity/ServiceInstance/tibtest1/TIBCOServers/machine-7500

ReportGroupName = <machine>.<domain name>-7500-RVD

9 Continue to add new entries for each MO.

10 Select File → Save.

11 Select File → Exit.

12 Click the Close button in the Output of Application window.
100                                                                                                                                                   Chapter 3



Monitoring Performance Metrics with HP Performance 
Manager

As mentioned earlier, you can monitor performance using HP Performance 
Manager. For detailed instructions on HP Performance Manager, see the 
HPOM documentation. 

Configure HP Performance Manager

On the system where HP Performance Manager is installed, add the Frontend 
Subagent host name into the <install_dir>/Data/systemCODA.txt file if 
using the Embedded Performance Component (Coda) or <install_dir>/
Data/systemMWA.txt if using HP Performance Agent. For more information 
on using the Embedded Performance Component (Coda), see the section Using 
Embedded Performance Component (Coda) on page 97.

For example, if HP Performance Manager were installed on 
<machine1>.<domain name> in C:\Program Files\HP OpenView, then the 
Frontend Subagent is running on <machine2>.<domain name>. If you are 
using the Embedded Performance Component (Coda), then you need to add 
<machine2>.<domain name> into the C:\Program Files\HP
OpenView\Data\systemCODA.txt file on <machine1>.<domain name>.

Create a Bytes Sent HP Performance Manager Graph for RVDs

To create an HP Performance Manager graph (bytes sent) for an RVD: 

1 To start the Performance Manager GUI, click on Start → Programs → HP 
Software → performance manager → Performance Manager.

2 In the Performance Manager home page, click on Web Forms Interface.

3 Click the Design tab and enter a title.

4 Select the Frontend Subagent node as the Data Source.

5 Select a Date Range. You can use 1 Hour if you are testing recently logged 
data.

The following procedures must be completed in the order listed.
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6 Select Ending Now if you are testing recently logged data.

7 Select TIBSPI_METRICS:TIBSPI_METRICS as the class.

8 Select B003_BYTESSENT as the metric and enter a label.

9 Scroll up and select SERVERNAME as the Metric Filter.

10 Select = and Fill in the RVD name you want in the graph. To figure out the 
RVD name, you can look in the /var/opt/OV/conf/tib/SiteConfig 
file on the Frontend Subagent node.

11 Scroll down and enter TIBCO as the User Template File.

12 Enter a name for the Save Graph Name.

13 Click the Save Graph button.

14 Scroll up and click the Draw Graph button.

View the RVD Bytes Sent HP Performance Manager Graph

To view the RVD bytes sent HP Performance Manager graph: 

1 Start the Performance Manager GUI by Select Start → Programs → HP 
Software → performance manager → Performance Manager.

2 In the Performance Manager home page, click on Web Forms Interface.

3 Select the Display tab if it is not already selected.

4 Select UserTIBCO for the Template File.

5 Select the RVD graph for the Graph Name.

6 Select the Frontend Subagent node in the System Names list box.

7 Select the desired date range information

8 Click the Draw Graph button

Graphing Instance Metric Data in HP Performance Manager

HP Performance Manager is used to graph instance metric data. When 
graphing metric data, you need to use the report data source and specify the 
appropriate values for SERVERNAME and OBJECTNAME in the Metric 
Filter. 
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To graph instance metric data in HP Performance Manager

1 Start the Performance Manager GUI by Select Start → Programs → HP 
Software → performance manager → Performance Manager.

2 In the Performance Manager home page, click on Web Forms Interface.

3 Click on the Custom Tab.

4 Enter the following information:

— Data Source – select the frontend system. If you don't see your 
frontend system, add it into either systems CODA.txt or 
systemsMWA.txt in C:\Program Files\HP OpenView\Data\. 
Click the Custom Tab again.

— Date Range – to see the latest data, select one hour in Date Range and 
select the Ending Now option box.

— Metric Filter – select SERVERNAME and =. Enter the name of the MO 
you used in the SiteConfig file as SERVER<#>_NAME then 
&&OBJECTNAME=<instance name>. For example:

If we want to graph the blue count for the Spot application and our 
SiteConfig contained the following entry:

SERVER2_NAME=Spot-ovw022

SERVER2_HOME=tibema%3A%2F%2Fwww.tibco.com%2Fema%2F2005%2F
01%2Fmo%2Fidentity%2FServiceInstance%2Ftibtest2%2FDefault
Deployment%2FSpot-ovw022

SERVER2_PORT=0

The Metric Filter value would be:

Spot-ovw022&&OBJECTNAME=blue

— Class – select <SPIName>_RPT_METRICS:<SPIName>_RPT_METRICS.

— Metric – select VALUE.

— Label – Enter in a label name.

5 Click Draw Graph (near the top of the page).
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TIBCO SPI Self Management

The TIBCO SPI is capable of managing itself and all Frontend and Backend 
processes. The SPI has templates that need to be pushed to that node for this 
feature to be activated. In addition, the TIBCO SPI also monitors the EMA 
agent process. For this EMA agent monitor feature to be activated, the host 
where the EMA agent is running has to be a managed node, and the 
templates to monitor the process have to be pushed to that node. Refer to 
Appendix C, List Templates and Reports for a detailed information about 
individual templates.

Modify Logging and Tracing Levels

This section provides instruction for changing log and trace levels for the 
TIBCO SPI. Logging and tracing levels can be changed for both the Frontend 
Subagent and the Backend Service and are useful for debugging and auditing 
purposes.

Changing Log Levels

The TIBCO SPI supports two log levels (ERROR and INFO) for both the 
Frontend Subagent and Backend Service log messages. By default the log 
level is set to INFO for both the Frontend and the Backend. Log levels can be 
customized by modifying the log property files. The property files are

• /var/opt/OV/log/tib/frontend.properties

• /var/opt/OV/log/tib/backend.properties

Changing Frontend Log Levels

To change the Frontend’s log level from INFO to ERROR:

1 Open the /var/opt/OV/conf/tib/Frontend.properties file.

2 Set the java.util.logging.FileHandler.level to ERROR. For 
example:
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java.util.logging.FileHandler.pattern = %h/frontend.log 
java.util.logging.FileHandler.level = ERROR 

3 Save and close the file.

4 Restart the TIBCO SPI. The Frontend log file is /var/opt/OV/log/tib/
frontend.log

Changing Backend Log Levels

To change the Backend’s log level from ERROR to INFO:

1 Open the /var/opt/OV/conf/tib/Backend.properties file.

2 Set the java.util.logging.FileHandler.level to ERROR. For 
example:

java.util.logging.FileHandler.pattern = %h/backend.log 
java.util.logging.FileHandler.level = ERROR

3 Save and close the file. 

4 Restart TIBCO SPI. The Backend log file is /var/opt/OV/log/tib/
backend.log

Changing Trace Levels

The TIBCO SPI provides a mechanism that collects and stores all trace data 
in a trace file. By default, tracing is configured to show INFO messages. To 
get a more detail level of trace messages the trace level has to be set to FINE. 
Trace levels can be customized by modifying the trace property files. The 
property files are:

• /var/opt/OV/log/tib/frontend.trace

• /var/opt/OV/log/tib/backend.trace

Changing Frontend Trace Levels

To change Frontend’s trace levels from INFO to FINE:

1 Open the /var/opt/OV/conf/tib/Frontend.properties file.

2 For the Frontend trace file, set the 
java.util.logging.FileHandler.level value to FINE. For example:
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java.util.logging.FileHandler.pattern = %h/frontend.trace 
java.util.logging.FileHandler.level = FINE

3 Save and close the file.

4 Restart the TIBCO SPI. The Frontend trace file is /var/opt/OV/log/
tib/frontend.trace.

Changing Backend Trace Levels

To change the Backend’s trace levels from INFO to FINE:

1 Open the /var/opt/OV/conf/tib/Backend.properties file.

2 For the Backend trace file, set the 
java.util.logging.FileHandler.level to FINE. For example:

java.util.logging.FileHandler.pattern = %h/backend.trace 
java.util.logging.FileHandler.level = FINE

3 Save and close the file.

4 Restart the TIBCO SPI. The Backend trace file is /var/opt/OV/log/
tib/backend.trace.
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4 Using Service Effect Analysis (Optional)
This chapter provides instructions for using the Service Effect Analysis (SEA) 
component and creating event definitions using the service composer tool 
(ECS composer). The SEA component, including the ECS tool, has a 
separately installation than the TIBCO SPI. In addition, refer to the 
Correlation Composer Guide included with the NNM documentation.

Overview

The SEA component provides advanced manageability features. The SEA 
component enables the end user to monitor and manage a TIBCO 
environment, by receiving correlated management events that combine 
infrastructure and TIBCO application level alerts. The SEA component is an 
add-on to the TIBCO SPI and is not required to use the standard management 
features of the TIBCO SPI. 

The SEA component has both deployment time and run time components. 
During deployment time, domain experts use the rules/correlation definition 
tool (Service Composer) to define the higher level rules that are eventually 
triggered by the events as they are generated at run time. 

The various User/Actor roles in this solution architecture are as follows:

• Network Operator – views the solution from a basic management 
perspective. (The typical HPOM Network Operator) 

• Domain Expert – defines the higher-level SEA events at deployment time. 

• Application manager – receives and views run time SEA events and 
employs adaptive management in the enterprise.

The SEA Component must be installed on the HPOM management server 
system.
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Figure 10 Conceptual View of SEA

Service Composer Tool

SEA Events are created by the domain expert using the Event Correlation 
Services (ECS) Composer tool. These events are then uploaded into the ECS 
engine and hence enable context sensitive, higher level alerts to be generated 
at run-time. These alerts are WSDM-based alerts that are subscribed to by 
the end user, who can then take appropriate corrective action.

The ECS Composer comes packaged with an ECS circuit and a graphic user 
interface to parameterize and define correlation rules to perform event 
correlation. It provides various pre-defined correlation models. The various 
types of correlations are: 

• Blacklist correlation is used to discard a specific category of alarms. 

• Enrich correlation is used when information in an alarm is insufficient. 
This type allows add/delete/modify of event attributes. 
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• Multi-Source correlation is used to identify a relationship between 
arbitrary alarms, potentially from different sources that together form a 
logical set that identifies a problem. 

• Flapping correlation is used to block events that are a logical consequence 
of another event. 

• Rate correlation is used to measure the number of events occurring in a 
defined window of time. 

• Repeated correlation is used to suppress duplicate alarms arriving within 
a specified period of time. 
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Requirements

The following table lists the software that is required to run the SEA 
component and perform service effect analysis.

Table 4 SEA Requirements

Requirement Suggested Minimum

Disk Space on the HPOM 
management server

100 MB

OS HP-UX 11.x, Solaris SPARC 8.0, 9.0, 10.0

Java JRE 1.4.x or later
HP-UX: http://www.hp.com/go/java

Management Software OVO-U 7.1x, 8.x (including Java GUI)
NNM 6.41, 7.01, 7.50

Tomcat 4.1.24 or later
http://jakarta.apache.org/tomcat/ 
(Tomcat 5 is not currently supported)

Correlation Composer 3.2, 
3.30, 3.31, 3.32 (bundled with 
NNM)

HP-UX 11.x, Solaris 2.8, 5.8, 8.0, 9.0, 10.0

ECS OVO patches only for 
ECS versions 3.31 and 3.30

HP-UX: PHSS_29270 for 10x, PHSS_29971 
for 11.x and, PHSS_32496
Solaris: PSOV_03296 and, PSOV_03373

ECS patches HP-UX: PHSS_33409 
Solaris: PSOV_03406

Axis 1.1 HP-UX 11.x, Solaris 2.8, 5.8, 8.0, 9.0, 10.0
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Prerequisites

The following prerequisites are required before installing the SEA component:

• You should be familiar with HPOM, ECS, NNM and also a basic 
understanding of HP Operations Smart Plug-ins. 

• You will need an X session to view the ECS GUI. If you want to run in a 
telnet session, you will need to export the DISPLAY to run it in GUI mode.

• The SEA installation will install in a fixed directory. (The directory is /
opt/OV/nonOV/SEA.) Ensure that there is enough space in the folder 
before starting your installation.

• The SEA solution works with certain versions of HPOM and third party 
products. To verify the versions of the software installed on your system, 
here are a few pointers:

— JRE 1.4: from the command prompt, type java -version.

— For the HPOM related suite of products: from the command prompt, 
use the swlist command.

– To see the GUI use swlist -i.

– To see the command line output, use swlist.

– For a list of all the file sets that are installed on your system, use 
swlist –R. (You could also use this command along with grep to 
find out if a particular product/fileset/patch is installed on 
your system. For example, swlist -r | grep PHSS_29722.)

• For the SEA installation, it is imperative to have super user privileges 
because the SEA installation includes the installation of certain HPOM 
components, which requires a start and stop of HPOM services. 

• The SEA component is configured to use port 4444. If you need to change 
the default port, use the SEA configuration tool. Re-start the SEA 
components after a new port is defined. See Running the SEA 
Configuration Tool on page 116 in this chapter. 
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Apache Tomcat Setup

Install Tomcat Server. Ensure that you do not install in any directory which 
has spaces in the path. Set the Environment variable CATALINA_HOME to the 
directory where Tomcat is installed henceforth referred to as 
%CATALINA_HOME%. 

It is assumed that your environment is set to: 

• host=localhost  - This can be left localhost, or may be changed for your 
machine name.

• port=8080 – The port to start Tomcat on. Edit the entries in 
%WSMF_HOME%/axis/build.properties to match your environment, if 
different.

• port=8005 – The port to shutdown Tomcat on. Edit the entries in 
%WSMF_HOME%/axis/build.properties to match your environment, if 
it is different.

Environment Setup

This section provides instructions on setting up the required system 
environment variables. The following variables must be setup:

• %WSMF_HOME%= /opt/OV/nonOV/SEA/wsmf-sba (The WSMF Smart 
Business Agent is an internal component of the SEA module, which 
enables the creation of a WSDM-based channel).

• %JAVA_HOME% = the location of JRE installation.

• Please ensure that /opt/OV/bin is in the $PATH.

To configure the Tomcat shutdown port, run the command SEA Deploy, and 
then from the location%WSMF_HOME%/axis/tomcat_base/conf,edit the 
server.xml to change the port. This change has to be made in this file every 
time you run the command SEA deploy. Refer to the section Running the SEA 
Component on page 115.

The WSDM implementation in the TIBCO SPI is based on an HP-authored 
preliminary version of WSDM known as the Web Service Management 
Framework (WSMF).
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Running the SEA Installer

SEA has to be installed using the InstallAnywhere wizard. Prior to 
installation ensure the following: 

• opc services and HPOM is operational. (Opcsv –status should show all 
services as running.)

• Log in to HPOM as opc_adm.

• Log in with super user privileges.

To install SEA:

1 Change directories to /opt/OV/bin.

2 From this directory, type:

./SEAInstallation.bin

The InstallAnywhere wizard steps through the installation process. 
Follow the installation instructions and accept the default settings.

When prompted by the Template Upload Step dialog box (shown below), 
complete the following steps before continuing with the installation. This 
manual step is required to upload SEA related templates that enable the 
creation and correlation of the high level SEA events. 

The SEA installer waits until you finish the manual steps.
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3 Log in to HPOM as opc_adm. 

4 From the Menu bar in the VPO Node bank, select Actions → Server → 
Assign Templates.

5 Click open template window.

6 Select Correlation Composer Template.

7 From the Template Configuration window, click Get Template Selections.

8 Click OK.

9 From the Menu bar in the VPO Node bank, select Actions → Server → 
Install/Update server templates.

10 Return and finish the installation. To verify if the above steps were 
successful, check the /var/opt/OV/conf/OpC/mgmt_sv directory. It 
should contain an ecs_comp.eco file.
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Running the SEA Component

The following procedures must be completed in the order in which they are 
presented. 

Enabling MSI

You must enable MSI before you can run the SEA component:

1 Log in to HPOM as opc_adm.

2 From the Menu bar in the VPO Node bank, select Actions → Server → 
Configure.

3 From the Configure Management Server Window, select the following 
options:

— enable output

— send all messages to Server MSI

— Divert messages

4 Click OK.

Starting the SEA Component

To Start the SEA: 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank → TIBCO SPI Tools.

3 Click the Deploy SEA icon. (This step has to be performed only after 
installation). 

4 Click the Start SEA icon. 

5 Verify that the SEA is deployed by pointing a browser to the wsmf 
services. For example, http://localhost:8080/wsmf/services. It should 
show all the WSDLs' of the services available to the SEA component.
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Running the SEA Configuration Tool

The SEA Configuration tool is used to configure various aspects of the SEA 
configuration file. To launch the SEA configuration tool: 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 Click the SEA Configuration Tool icon in the TIBSPI application bank. The 
SEA Configuration Tool will be launched.
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Stopping the SEA Component

Stopping the SEA component includes stopping Tomcat as well. This will 
affect any other applications that are running on the same instance of Tomcat. 

To stop SEA, use the following command:

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

2 From any HPOM window, open the Application Bank window by selecting 
Window → Application Bank.

3 Double-click on the StopSEA icon. A window displays and gives the status 
of the application after it has stopped. This operation may take some time 
to complete.

If SEA does not shutdown properly, type ps -ef | grep java and run the 
command kill -9 on the process id.

You can also stop SEA using the following command:
/opt/OV/bin/stopSEA.sh
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Creating an Event Definition

This section lists the steps involved in creating an event definition. This 
example creates an event definition for a CPU_HIGH message generated by 
HPOM as part of the Smart Plug-in. The predefined ECS Composer 
enrichment correlation model is chosen for this example. 

To create an event definition:

1 From the Application Bank, click the SEA Event Definition icon. The HP 
OpenView Correlation Composer opens.

2 Specify the attributes that will identify the raw event. In this example, the 
CPU event that arrives at the engine is identified by OBJECT=CPU.

Always use the user.fs file enclosed with the SEA Solution to create your 
correlators. Do not update the testCPU correlator. (This correlator is used to 
check the validity of the installation.)
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3 In the advanced filter, use the following:

AIA_EVENT != Constants.IS_AN_AIA_EVENT

4 Create and assign a variable called name. In this example, the event name 
is testCPU. This variable has to be assigned to the AIA_EVENT_NAME 
attribute in the new alarm definition. 
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5 In the new alarm section, select New Alarm Selection. Fill in the fields of 
the new alarm. Make sure that AIA_EVENT is set to 
CONSTANTS.IS_AIA_EVENT and assign a variable for the AIA_EVENT_NAME. 
It is mandatory to set these fields else the event will not be forwarded to 
SBA.

6 Select the Feedback button (see the picture below) to allow the event to be 
fed-back into the correlation engine.

7 Save the correlator in the same user.fs and exit the Composer GUI. The 
custom correlator is now deployed.
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8 To configure SEA, use the application bank SEA Configuration Tool 
application, then use the deploy SEA, followed by Start SEA to start the  
SEA component. 

Proceed to the TIBCO component whose higher level management alerts are 
factored in to your custom correlator, and configure the rule bases for it. This 
enables the relevant TIBCO event to be generated. Please refer to the 
appropriate TIBCO product manual for instructions. 

At run time, when the specified sequence of management alerts occur, the 
SEA event is generated.

The TIBCO SEA component that has subscribed to these alerts receives and 
forwards this SEA event on the RVD Bus. Any TIBCO or other higher level 
applications that are listening on that subject is then capable of receiving this 
event and taking corrective action. See the TIBCO documentation for more 
information about how applications can listen for SEA events on the RVD bus. 

Refer Appendix B, SEA Configuration for details on the SEA Configuration 
properties.
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SEA Logging and Trace Information

The SEA component utilizes the Apache Commons Logging Framework 
and Log4J as the logging system. The Logging feature is used to emit log 
messages. Log messages are used to record component activity and 
troubleshoot problems. 

When you install the SEA component, the logging feature is preconfigured. 
You can change the level of detail you require. The logging feature is 
configured through a properties file:

/opt/OV/nonOV/SEA/wsmf-sba/internal/newconfig/
log4j.properties.

Changing Logging Levels

A log level is used to constrain a log message based on the type of information 
that you want to emit. Logging levels are set in the logging properties file. By 
default, only warning (WARN) messages are emitted. Table 5 describes each of 
the logging levels. 

Logging affects performance. Different logging settings discussed in this 
section should only be used for troubleshooting when you are in a test 
environment.

Table 5 Logging Levels

Logging Level Description

DEBUG Emits output that is used to track events that are 
occurring in the server. The output includes 
problems and non-problems.
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 To change logging levels: 

1 Stop the SEA component if it is currently started.

2 Using a text editor, open /opt/OV/nonOV/SEA/wsmf-sba/internal/
newconfig/log4j.properties. 

3 Set a new logging level for all packages or for a specific package. For 
example:

log4j.rootCategory=DEBUG, STDOUT_MSG_ONLY, ROLL_FILE

or

log4j.category.com.hp.ovms=DEBUG

4 Save and close the properties file.

5 Restart the SEA Component.

INFO The default setting. Emits output that is used to 
track any non-problem events.

WARN Emits output that is used to track errors that have 
occurred but that do not stop the Network Services 
from continuing.

ERROR Emits output that is used to track errors that may 
result in reduced functionality.

Table 5 Logging Levels

Logging Level Description

Levels assigned for a specific package overrides the overall log level.
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Changing the MO Update Interval

By default, managed objects are dynamically updated (added or deleted) every 
five minutes. The default value can be changed by assigning a new polling 
frequency.

To change the polling frequency:

1 Using a text editor, open /opt/OV/nonOV/SEA/wsmf-sba/internal/
newconfig/axis/sea.xml.

2 In the <DiscoveryObjects name=”SEA-OVSBA> node, change the 
<PollFrequency> element to a value in Milliseconds.

3 Save and close the file.

4 Run Deploy SEA and Start SEA from the Application bank.
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Uninstalling the SEA Component

To uninstall the SEA Component: 

1 Log in to HPOM as opc_adm. 

2 From the Menu bar in the VPO Node bank, select Actions → Server → 
Assign Templates.

3 Select Group Correlation Composer from the list.

4 Click Remove Templates.

5 From the Menu bar in the VPO Node bank, select Actions → Server → 
Install/Update server templates.

6 From a command prompt change directories to /opt/OV/nonOV and type 
sh ./ Uninstall_HP_Service_Effect_Analysis.

Files that are placed in /opt/OV/bin/SEA directory while using SEA, either 
by the user or by the SEA Component (For Example, log files) will not be 
deleted. After the uninstallation is complete, you must manually delete such 
files.
If the installation aborts prematurely, the installation does not uninstall itself 
before quitting. If the uninstaller was copied over to the file system, you can 
follow the uninstallation steps. Otherwise, manually delete the SEA directory.
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5 Using the NNM Integration (Optional)
This section describes how to enable the TIBCO SPI and Network Node 
Manager (NNM) integration and how to configure its management features.

Overview

The TIBCO SPI contains an NNM integration that enables an operator to 
view the connection between managed applications and the network 
infrastructure. Application data is obtained from TIBCO EMA; while, the 
network infrastructure data is retrieved from NNM. The integration provides 
the following features:

• Service Views of Network Dependencies

• Collecting SNMP Trap Events

• Performance Reports

Service Views of Network Dependencies

The Service Navigator’s Service viewer provides a graphical view of the 
TIBCO SPI service map and shows an application’s network dependencies. 
The Service viewer contains the networking device directly connected to 
systems running the TIBCO RVD or RVRD. Typically, this device is a switch. 

The following screen capture shows the service view of applications and their 
underlying infrastructure. In the service view, a switch named ovw004 is 
connected to system ovw027.cup.hp.com, which is running a TIBCO RVD.
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Collecting SNMP Trap Events

Network events are forwarded from NNM to HPOM and hence the status of 
network devices in the TIBCO SPI service map are updated. Some examples 
of NNM SNMP trap events which might be forwarded to HPOM include: 

• <$MIB_OBJECT> threshold exceeded. Sampled high of <$HIGH_VALUE> at 
<$TIME> low of <$LOW_VALUE> at <$TIME>

• <$MIB_OBJECT> threshold rearmed. Sampled high of <$HIGH_VALUE> at 
<$TIME> low of <$LOW_VALUE> at <$TIME>

• Agent up with Possible Changes (coldStart Trap) …

• Agent up with No Changes (warmStart Trap) …

• Agent interface down (linkDown Trap) …

• Agent interface up (linkUp Trap) …
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Performance Reports

Lastly, the NNM integration allows an operator to generate and view Service 
Reporter reports that compare network and TIBCO RVD performance 
metrics. These reports include: 

• TIBCO RVD & Network Interface Receive Rates (Yesterday, Last Full 
Week, Last Full Month, and Full Range) 

• TIBCO RVD & Network Interface Send Rates (Yesterday, Last Full 
Week, Last Full Month, and Full Range) 

• TIBCO RVD Retransmissions & Network Interface Errors (Yesterday, 
Last Full Week, Last Full Month, and Full Range) 

The following screen capture is an example performance report generated 
through Service Reporter.
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If you are not able to view the sub-graph, configure the TIBCO domain with 
fully qualified name. For details refer TIBCO documentation.
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Requirements

The TIBCO SPI and NNM integration has several software dependencies. It is 
assumed that HPOM and the TIBCO SPI have been installed and are running 
properly. 

General Setup Requirements

The following lists general setup instructions that must be performed when 
using the NNM integration. In addition, consult the individual component’s 
documentation for installing components such as NNM, NNM ET, and HP 
Reporter.

• NNM must be installed on the HPOM management server.

Requirement Required Version

NNM 6.4.1 with the following patch:
• HP_UX – PHSS_30031: s700_800 11.x 

                   NNM6.4x/ET2.0x

• Solaris – PSOV_03301: sparc SOL 2.x OV 
                 NNM6.4x/ET2.0x

NNM 7.01 is required when using OVO 8.x 

NNM Extended 
Topology (ET)

2.01

HP Reporter 3.5 
MS Access is not supported as the HP Reporter 
database (MSDE, MS SQL Server, and Oracle are 
supported).

If you install HP Performance Agent after starting the TIBCO SPI front-end, 
you need to restart the front-end if you want network metrics logged to PA 
instead of Embedded Performance Component (Coda). 
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• Enable SNMP agents on network devices and switches. SNMP agents 
allow NNM to discover the network topology. 

• Perform an NNM discovery.

• Install NNM ET on the HPOM management server where NNM is 
installed.

• Perform an NNM ET discovery.

• Change the TIBSPI_Op user or user profile to include responsibility for the 
SNMP message group and the TIBSPI-External node group.

• Install and distribute the SNMP 6.20 Trap template on the system 
running HPOM and NNM. If you are already using a custom template for 
NNM traps, make sure this template is distributed to the system running 
HPOM and NNM. You can use an HPOM tool, /opt/OV/bin/OpC/
utils/ovtrap2opc, to upload customized NNM SNMP traps into 
HPOM.

• Follow the instructions in Chapter 2, Installation and Configuration for 
installing the TIBCO SPI reports. If you are unfamiliar with HP Reporter, 
see the View TIBCO SPI Reports section in Chapter 5. 

— Assign the following per-system reports: TIBCO RVD & Network 
Interface Receive Rates (FR, LFM, LFW, and Y), TIBCO RVD & Network 
Interface Send Rates (FR, LFM, LFW, and Y), TIBCO RVD Missed 
Packets (FR, LFM, LFW, and Y), and TIBCO RVD Retransmissions & 
Network Interface Errors.
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Enabling and Configuring the NNM Integration

The TIBCO SPI NNM integration is disabled by default. 

To enable and configure the NNM integration: 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 In the Application Bank window, double-click the TIBCO SPI Tools 
application group.

4 In the Application Group: TIBCO SPI Tools window, right-click Configure 
TIBCO SPI application and select Execute from the popup menu.

5 From the application’s left navigation panel, expand Networking Info to 
view the NNM integration parameters.

6 Select Network Monitoring. 

7 In the right panel, complete the fields. See Appendix A for a description of 
the parameters.

8 Select Network Reporting. 

9 In the right panel, complete the fields. See Appendix A for a description of 
the parameters.

10 Select File → Save to save your changes to the configuration file.

11 Select File  → Exit.

12 In the Output of Application window, verify the message “TIBCO SPI 
configuration completed”. It may take some time for the message to 
appear. Do not close the Output of Application window until you see the 
completion message.

13 Click Close in the Output of Application window.
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NNM Topology Integration Settings

The NNM Integration utilizes OpenView Interconnect (OVI). OVI is bundled 
with the SPI and is part of the standard installation. OVI is installed with 
default settings that may not be applicable for your system. These settings 
include the OVI JAVA setting and the OVI port setting.

Changing the OVI JAVA Setting 

To change the OVI JAVA setting: 

1 Open /var/optOV/conf/tib/ICO_SPI_TIBCO.env

2 Change the line after the JAVA executable to point your JRE installation. 
For example:   

JAVA=<your jre/bin location>

3 Save and close the file.

4 Open /opt/OV/bin/tib-start-backend-isv

5 Change the variable JAVA_HOME according to your JAVA home location.

Changing the OVI Port Setting

The default OVI port is set to 16835. If this port is already being used on your 
system, you must change the port number.

To change the OVI Port setting:

1 Open /var/opt/OV/conf/tib/WCConfig.xml.

2 Change the <OviPort> number.

3 Save and close the file.

4 Open /var/opt/OV/conf/tib/
ResponderProxyPluglet.http.config

5 Change the port number to the same port number you defined in 
WCConfig.xml.

6 Save and close the file.

7 Restart the TIBCO SPI.
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RVD Data Collection

You must be collecting RVD data to be able to compare the TIBCO RVD and 
network performance metrics. If you are not already collecting RVD data, 
follow the steps in the Collection Data for Specific Metrics and Configure Data 
Sources for Metric Data Collection sections. 
Using the NNM Integration (Optional)                                                                                                                                                   



136                                                                                                                                                    Chapter 5



6 Implementing Failover
This chapter provides instructions for implementing failover between the 
Frontend Subagent and two or more TIBCO EMA components. 

Overview

The Frontend Subagent can be configured to use multiple EMA installations. 
This allows the Frontend Subagent to continue collecting management data of 
a TIBCO environment even when a TIBCO EMA stops responding. The 
failover solution depends on multiple installations of the TIBCO EMA.

Specifically, the Frontend subagent uses one or more location candidates. 
Each candidate contains WSDL locations for managed objects that are 
exposed by a particular EMA. The first candidate is considered the primary 
candidate. Any subsequent candidates are considered backups for the primary 
candidate.
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When the Frontend Subagent starts, it tries the first location candidate. If the 
location candidate responds, it is used. If there is no response, the Frontend 
tries the next location candidate. This process is repeated until a location 
candidate responds. For example, you could provide two location candidates:

http://hostA.domain.com:8888/?wsdl:objid=tibema://
www.tibco.com/ema/2005/01/mo/identity/Domain/tibtest

http://hostB.domain.com:8888/?wsdl:objid=tibema://
www.tibco.com/ema/2005/01/mo/identity/Domain/tibtest

In this example, the EMA on hostA is serving as the primary EMA and hostB 
is the backup. If hostA fails, then the EMA on hostB becomes the primary. 
When a failover takes place, the Frontend performs the following actions:

• Discards all managed object information for the EMA on hostA

• Discovers all managed objects for the EMA on hostB

• Reconstructs the service map

• Subscribes the notifications to the EMA on hostB
138                                                                                                                                                   Chapter 6



Adding Multiple Location Candidates

Managed object WSDL locations are configured using the TIBCO SPI 
Configuration Editor, which is available from the TIBCO SPI Tools application 
group. If you want to implement failover, you must provide multiple location 
candidates for the same WSDL location. 

To add multiple location candidates: 

1 From the TIBCO SPI Configuration Editor, click the icon next to Top of 
tree.

2 Click the icon next to Front End Configuration.

3 Select Managed Object Information.

4 In the menu bar, select Edit → New.

5 In the Location Candidates list, add additional WSDL locations for the 
managed objects you want the Frontend Subagent to monitor.

If the WSDL location uses HTTPS, then you must configure the Frontend 
Subagent's security settings. Please refer to the Appendix 7 section in 
Chapter 7, Security Features and Configuration.
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6 Select File → Save to save your changes to the configuration file.

7 Select File → Exit.

8 In the Output of Application window, you should see the message ‘TIBCO 
SPI configuration completed.’ It may take a few minutes for the 
message to appear. Do not close the Output of Application window until 
you see the completion message.

9 Click the Close button in the Output of Application window.
140                                                                                                                                                   Chapter 6



7 Security Features and Configuration
This chapter provides instructions for securing the management channels 
that are used by the TIBCO SPI. Knowledge of SSL and HTTPS security 
principals are required to complete some of the instructions in this chapter. 

Overview

The TIBCO SPI security features are used to prevent unauthorized access to 
the TIBCO Managed Resources exposed by TIBCO EMA. This ensures that 
only trusted/authorized users are able to perform any actions on TIBCO 
Managed Resources in the managed environment. These features do not focus 
on data protection (data being passed to the TIBCO SPI from the TIBCO EMA 
as part of Event Notifications).

Conceptual Architecture

There are various communication channels between the TIBCO EMA and 
TIBCO SPI components as shown in Figure 11. These communication 
channels are secured using HTTPS (SSL over HTTP) to ensure that the 
TIBCO Resources exposed by EMA are securely accessed from various 
components of the TIBCO SPI.

The standards supported for HTTPS include:

• X.509v3 for the certificate format

• SSLv3/TLS1.0 

• Cipher suites available from JDK 1.4 JSSE library
 141



Figure 11 Communication Channel Security

What is Secured

As shown in Figure 11, HTTPS is used to secure the TIBCO resources and any 
operations exposed to these managed resources through the EMA WSMF 
channel.
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What is not Secured

SEA exposes to any WSMF client correlated events and root cause analysis 
information, but does not expose any operations that affect changes in HPOM. 
This channel is not secured using HTTPS. 

The TIBCO SPI also has a notification listener to which TIBCO EMA sends 
asynchronous notifications. This channel is not secured using HTTPS.

Since in both of these instances there is a possibility of “denial of service” 
attacks, future releases of the TIBCO SPI may secure these channels based on 
user feedback.

Current Limitations

The security features of the TIBCO SPI have the following limitations:

• Notifications from TIBCO SPI (SEA) can be subscribed by any client 
including TIBCO EMA over HTTP. The HTTPS protocol is not supported 
for this communication channel.

• Notifications from TIBCO EMA are received by the Frontend Subagent 
over HTTP. The HTTPS protocol is not supported for this communication 
channel.

• An Open View operator can perform all operations exposed for various 
Managed Resources from the Resource Explorer after successfully 
authenticating itself to TIBCO EMA for HTTPS communication. There is 
no mechanism to establish roles that allow only a specific set of operations 
to be accessible to a specific operator depending upon the role of the 
operator, or only allow access to limited set of Managed Resources, etc.

• If the Keystore that contains the client certificate and the associated 
private key for the Frontend Subagent also contains certificates for other 
entities (this may be applicable for an enterprise where all the certificates 
used by various applications are stored in a central Keystore), then the 
TIBCO SPI requires that all the private keys associated with 
corresponding certificates are protected by the same password. Otherwise, 
the TIBCO SPI will not be able to recover the private key for the Frontend 
Subagent from this Keystore.
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Configuring HTTPS Communication

This section provides instructions for implementing HTTPS communication 
for the Frontend Subagent and the Resource Explorer. If you do not currently 
have a Keystore or Truststore, instructions are also included for creating a 
Keystore and Truststore as well as importing signed certificates. 

Configuring the Frontend Subagent

Digital certificates are used for mutual authentication for HTTPS 
communication between the Frontend Subagent and TIBCO EMA. The 
certificate for the Frontend is stored in a Keystore. The default location of the 
Keystore is /var/opt/OV/conf/tib/frontend.ks but can be changed to a 
different location. By default the Keystore format is assumed to be JKS but 
other Keystore types can be used. See the section Customizing HTTPS 
Configuration Parameters on page 150.

The CA's root certificate for TIBCO EMA is stored in the JDK Truststore. The 
default location of the Truststore is /$JAVA_HOME/jre/lib/security/
cacerts but can be changed to some other location. 

Configuring SSL/HTTPS

To configure SSL/HTTPS for TIBCO SPI Frontend: 

1 Start the TIBCO SPI Configuration Editor.

2 Under the Frontend Configuration node on the left panel, click SSL 
Configuration 

3 On the right panel, enter the following information:

— KeyStore Location: The full path to a Keystore file. The Keystore 
contains the client certificate for the Frontend Subagent. The path is 
set by default to /var/opt/OV/conf/tib/frontend.ks

                                                                                                                                                                                                                                                                                                                                                                        

TIBCO EMA uses the term Identity File when referring to a Keystore. The 
term Keystore in this documentation is the same as Identity File in the 
EMA documentation.
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— Keystore Password: The password to access the Keystore.

— Private Key Password: The password used to protect the private key.

— TrustStore Location: The file path to the TrustStore. The default path 
is set to $JAVA_HOME/jre/lib/security/cacerts.

4 Select File → Save.

5 Select File → Exit.

Setting up a Keystore and Truststore for the Frontend Subagent

HTTPS communication for the Frontend Subagent requires the use of a 
Keystore and Truststore as well as a signed certificate. The setup is typically 
completed in the following manner: 

• Obtain (from your preferred Certificate Authority) a client side certificate 
for the Frontend Subagent.

• Import this certificate to the Frontend Subagent's Keystore.

• Import the certificate of the CA who issued the TIBCO EMA certificate to 
the Frontend Subagent’s Truststore if it does not already exist in the 
Truststore. You can get the list of all the CA certificates that are already 
imported to the Truststore by running the following command:

keytool –list –v –keystore <full path to Truststore file> 
-storepass <truststorepassword> 

If you have your own key management tool to create public key-private key 
pair and import certificates to an existing Keystore, then follow your 
procedure to obtain a client certificate for the Frontend Subagent and import 
it to the Frontend Subagent's Keystore In addition, obtain the CA certificate of 
the issuer of the TIBCO EMA certificate and import it to the Frontend 
Subagent's Truststore. You will have to specify the alias name and the 
Keystore type used for the TIBCO SPI Frontend. See Customizing HTTPS 
Configuration Parameters on page 150.

The Keystore does not exist, but needs to be created using a tool described in 
the Setting up a Keystore and Truststore for the Frontend Subagent section. 
If you have an existing Keystore, enter the path to your existing Keystore. 
When using an existing Keystore, the Frontend Subagent certificate must be 
imported into the Keystore.
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If the Frontend Subagent Keystore does not exist or you do not have your own 
tool for managing Keystores, the following section provides instructions for 
creating a Keystore, getting a certificate, and importing certificates to the 
Keystore and Truststore. 

Creating a Keystore and Importing Certificates

A utility is provided that facilitates creating a Keystore and importing 
client-side certificates. The utility is typically used when you do not have an 
existing Keystore to use for the Frontend Subagent. 

The utility is the same as the Java Keytool, but uses the information that is 
stored in WCConfig.xml (Keystore location, Keystore password, private key 
password and trust store location etc.) and will use the default information 
specified in the Frontend, properties file (For example: aliasname, keystore 
type) while generating a key and importing certificates. 

 To create a Keystore and import certificates:

1 From a command prompt, change directories to /opt/OV/bin.

2 Enter the following command:

./tib-perl tib-keymgrutil  -genkey -dname "<distinguished 
name>" [-keyalg <keyalg>] [-sigalg <sigalg>] [-keysize 
<keysize>]

— dname: This argument is entered in the form CN=<your name/
hostname> OU=<org unit> O=<organization> L=<locality/city> 
ST=<state/province> C=<two letter country code>.

— keyalg (optional): The key algorithm to be used. If this argument is 
not specified, the default key algorithm is DSA.

— sigalg (optional): The digital signature algorithm to be used. If this 
argument is not specified, the default signature algorithm is 
SHA1withDSA if the key algorithm is DSA and MD5withRSA if the key 
algorithm is RSA.

— keysize (optional): if this argument is not specified, the default key 
size is 1024 bits.

For example:

./tib-perl tib-keymgrutil –genkey –dname "CN=tibfrontend 
OU=OV O=HP L=Location ST=AB C=CD"
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This will create the frontend.ks (if that’s the name specified for the 
Keystore) which contains the private key and the self signed certificate for 
Frontend Subagent.

3 Create a certificate-signing request into the specified CSR file.

./tib-perl tib-keymgrutil -certreq -file <csr_file> [-sigalg 
<sigalg>]

4 Send the CSR file (typically emailed) to a CA, and save the reply from CA 
in some file <client_cert_file>. This file contains your client certificate.

5 Import the client certificate to the Truststore:

./tib-perl  tib-keymgrutil –importcerts –clientcert 
<client_cert_file> -rootCA <root_cert_file> [-trustcert 
<trust_cert_file>] 

— clientcert: This argument is the file returned from the CA for the 
Frontend Subagent's certificate, which can be a single certificate in 
X.509 format or a certificate chain in PKCS7 format. This argument 
imports the reply into the Keystore as specified during the SSL 
Configuration. 

— rootCA: This argument is optional depending on the format of the 
client certificate.

This argument is required if the certificate reply is in X.509 format. 
In this case, you must import the Root Certificate of the CA who 
issued the Client certificate for the Frontend Subagent into the 
Keystore. This argument is the file that contains the Root Certificate 
of the CA

This argument is not required if the client cert is returned by the 
certificate authority in the PKCS7 format.

— trustcert: This argument is the certificate of the CA that issued the 
server certificate of TIBCO EMA. If the truststore that the user 
specified already has the CA certificate of the issuer of the TIBCO 
EMA certificate, this option is not required. Otherwise the CA 
certificate included in <trust_cert_file> will be imported to the 
Truststore specified during SSL Configuration. If the specified 
Truststore does not exist already, it will be created with a password 
changeit.
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Configuring the Resource Explorer

As mentioned in the Overview section, the communication channel between 
the Resource Explorer and the TIBCO EMA can be secured using HTTPS. It is 
recommended that you reuse the Frontend Subagent client certificate as your 
Resource Explorer client certificate so that you do not need to maintain a 
separate client certificate for the Resource Explorer. However, a section for 
creating a separate client certificate for the Resource Explorer is also provided 
in this section.

Using the Frontend Subagent's Client Certificate 

To use the Frontend Subagent client certificate for the Resource explorer: 

1 Copy the Keystore file from the Frontend Subagent machine to the 
Resource Explorer machine and rename the Keystore file if required. 

2 Stop the Resource Explorer if it is currently started.

3 Using a text editor, open the Resource Explorer script located at 
%RE_HOME%\hp_resource_explorer\hp_resource_explorer.bat.

In the script, specify the Keystore and Truststore locations for the Resource 
Explorer as JVM system parameters. The defaults are set to the security 
directory under the directory %JAVA_HOME% as below: 

set:

JVM_ARGS=%JVM_ARGS%-Ddeployment.user.certs=%JAVA_HOME%\ 
jre\lib\security\client_certs

The –Ddeployment.user.certs argument refers to the full path to the 
Keystore file.

set:

JVM_ARGS=%JVM_ARGS%-Ddeployment.system.certs=%JAVA_HOME%\
jre\lib\security\cacerts

If you have an existing Keystore on the Resource Explorer machine which you 
want to use, you can import the client certificate you obtained for the 
Frontend Subagent into this existing Keystore using your preferred key 
management tool.
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the -Ddeployment.system.certs argument refers to the full path to 
the Truststore file. 

In addition, the file %JAVA_HOME%\jre\lib\security\client_certs 
does not exist and needs to be created using some key management tool.

4 Save and close the Resource Explorer script.

5 Start the Resource Explorer.

Using a Separate Client Certificate for the Resource Explorer

If you do not want to use the Frontend Subagent's client certificate for the 
Resource Explorer, you can use a separate client certificate for the Resource 
Explorer. It is assumed that you are using your own key management tool to 
perform these steps.

To use a separate client certificate for the Resource Explorer:

1 Obtain a client certificate for the Resource Explorer from your preferred 
Certificate Authority.

2 Import the client certificate for the Resource Explorer into the Keystore on 
the Resource Explorer machine. The Keystore file should be located at the 
location specified in the hp_resource_explorer.bat file as explained 
in the previous section.

3 Import the certificate of the CA who issued the TIBCO EMA certificate 
into the Truststore that is specified in the hp_resource_explorer.bat 
file as explained in the previous section. This step needs to be performed 
only if the CA certificate of the issuer of the TIBCO EMA certificate does 
not already exist in the Truststore. To verify if a CA certificate already 
exists in the Truststore, you can run the following command:

keytool –list –v –keystore <full path to truststore file> - 
storepass <truststorepassword>

Starting the Resource Explorer

When the Resource Explorer starts, if the URI to the root managed object uses 
the HTTPS protocol (https://…), a security dialog displays. Enter the 
following information:

You will also have a chance to set or change these values in the security dialog 
when the Resource Explorer starts.
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• Password for the private key

• Keystore location

• Truststore location

Default locations of the Keystore and Truststore are shown in the dialog, 
modify the values as necessary. 

Customizing HTTPS Configuration Parameters 

The Frontend.properties file that is located in the /var/opt/OV/conf/
tib directory contains the following properties for customizing various SSL/
HTTPS settings: 

• com.hp.wsmf.ssl.client.aliasname = <aliasname> 

This value is set to tibFrontEnd by default. If you use a different alias 
name for the Frontend Subagent in your Keystore, then specify that name.

• com.hp.wsmf.ssl.keyStoreType = <type>

This value is set to JKS by default. If you’re using a Keystore of different 
type, specify the type here.

• com.hp.wsmf.ssl.socketTimeout = <timeout in milliseconds>

This value is set to 120000 by default. 

• com.hp.wsmf.certCheckWarnLevel1Days = <days>

This value is set to 15 by default. If a certificate is found to expire within 
the days specified, a major severity message is sent to the HPOM console’s 
message browser.

• com.hp.wsmf.certCheckWarnLevel2Days = <days>

This value is set to 30 by default. If a certificate is found to expire within 
the days specified, a warning severity message is sent to the HPOM 
console’s message browser.

If you get a Connection Timeout Socket Exception at runtime, increase this 
value.
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8 Troubleshooting
This chapter provides common troubleshooting tasks when using the TIBCO 
SPI. In addition, refer to the TIBCO SPI Release Notes for the latest 
information about the TIBCO SPI. 

Runtime Problems

Frontend Subagent Does Not Stop

The Frontend subagent does not stop if there is a problem canceling the 
subscription. 

Solution:

You must manually stop the Frontend Subagent Java processes. 

Frontend Subagent Does Not Start

The Frontend Subagent is not starting up. 

Solution:

To locate the error, look in the /var/opt/OV/log/tib/frontend.log file. 
Refer to the Frontend Logfile Errors section later in this chapter for 
explanations on resolving the error. 
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Frontend Subagent is Unable to Connect to EMA

The Frontend Subagent may fail to connect to EMA for various reasons. 
Depending on the specific scenario, The Frontend logs specific message into 
the frontend.log file when it fails to connect to EMA. The section below 
describes the various error messages logged into frontend.log when 
Frontend Subagent fails to connect to EMA:

WARNING WSF-1097: Problem accessing https://<machine>.<domain 
name>:8888/?wsdl:objid=tibema://www.tibco.com/ema/2005/01/mo/
identity/Root, WSDLException: faultCode=OTHER_ERROR: Unable to 
connect to server. Cause: Connection refused

Solution:

The reason for this error is the EMA Gateway is down. Make sure that EMA is 
started successfully.

SEVERE TIBSPI-105 Fronted Startup Failed : Exception: WSF-1202: 
Failed to retrieve the Client Certificate for tibFrontEnd at the 
KeyStore /var/opt/OV/conf/tib/frontend.ks. Exception: Keystore 
was tampered with, or password was incorrect

Solution:

The reason for this error is the password for the Frontend KeyStore is wrong. 
Verify that you have specified the correct password for the Frontend KeyStore 
when specifying the SSL Configuration Settings.

SEVERE TIBSPI-105 Fronted Startup Failed : Exception: WSF-12105: 
Failed to load the Keystore /var/opt/OV/conf/tib/frontend.ks. 
Exception: Cannot recover key

Solution:

The reason for this error is the password for the Private Key is wrong. Verify 
that you have specified the correct password for the Private Key when 
specifying the SSL Configuration Settings.

WARNING WSF-1097: Problem accessing https://<machine>.<domain 
name>:8888/?wsdl:objid=tibema://www.tibco.com/ema/2005/01/mo/
identity/Root, WSDLException: faultCode=OTHER_ERROR: Unable to 
read WSDL document from 'https://<machine>.<domain name>:8888/
?wsdl:objid=tibema://www.tibco.com/ema/2005/01/mo/identity/
Root'.: sun.security.validator.ValidatorException: No trusted 
certificate found
152                                                                                                                                                   Chapter 8



Solution:

The reason for this error is the CA Certificate of issuer of EMA server 
certificate is not present in the TrustStore. Make sure to import the CA 
Certificate of issuer of EMA server certificate into the TrustStore that you 
specified in SSL Configuration Settings.

SEVERE TIBSPI-105 Fronted Startup Failed : Exception: WSF-1209: 
Client Certificate for tibFrontEnd has expired on Mon Feb 21 
15:33:21 PST 2005. Client Certificate has to be renewed for 
successful SSL communication.

Solution:

The reason for this error is the certificate for Frontend has expired and 
requires to be renewed.

WARNING: WSF-1097: Problem accessing https://<machine>.<domain 
name>:8888/?wsdl:objid=tibema://www.tibco.com/ema/2005/01/mo/
identity/Root, WSDLException: faultCode=OTHER_ERROR: Unable to 
read WSDL document from 'https://<machine>.<domain name>:8888/
?wsdl:objid=tibema://www.tibco.com/ema/2005/01/mo/identity/
Root'.: java.security.cert.CertificateExpiredException: 
NotAfter: Fri Jan 07 16:01:27 PST 2005

Solution:

The reason for this error is the EMA Server Certificate has expired and 
requires to be renewed.

WARNING ><WSF-0004: Problem with push subscribe: http://
<machine>.<domain name>:8888/
?wsdl:objid=tibema%3A%2F%2Fwww.tibco.com%2Fema%2F2005%2F01%2Fmo%
2Fidentity%2FExternalService%2FtibcoDomain%2Fovw009-C%3A%5CTibco
TestApp%5CDebugTest%5CWork; nested exception is:       
java.net.SocketTimeoutException: Read timed out

Solution:

If Frontend is connecting to TIBCO EMA using HTTP, then edit the /var/
opt/OV/conf/tib/Frontend.properties file and increase the value for 
com.hp.wsmf.http.socketTimeout. The time specified here is in 
milliseconds.

If Frontend is connecting to TIBCO EMA using HTTPS, then edit the var/
opt/OV/conf/tib/Frontend.properties file and increase the value for 
com.hp.wsmf.ssl.socketTimeout. The time specified here is in milliseconds.
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Backend Service is Not Found

After registering the Backend Service, the ovstatus and ovstart commands 
indicate that the “tib-backend” cannot be found.

Solution: 

Stop and restart the HPOM server:

ovstop

ovstart

TIBCO SPI Uses Backup EMA Instead of Primary EMA

When using failover, the TIBCO SPI uses the backup TIBCO EMA instance 
instead of the primary TIBCO EMA instance.

Solution:

This occurs when the backup TIBCO EMA instance starts before the primary 
TIBCO EMA instance. Make sure all TIBCO EMA instances are fully started 
before starting the Frontend subagent.

TIBCO Service is Not Visible

The TIBCO Service does not show up in the Resource Explorer.

Solution:

Verify that the username you used to log into the HP Java console is the same 
user name that's configured as <OVOUserName> in the WCConfig.xml file 
on the Frontend Subagent node.

Missing Operational Notification

Operational notifications are not appearing in the HPOM message browser.

Solution: 

Complete the following procedures: 
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Verify TIBSPI-EventService-MSG-V1 Template is Configured

Verify that the TIBSPI-EventService-MSG-V1 template is configured on the 
HPOM managed node where the Frontend Subagent is running.

1 From a window on the Frontend Subagent node, find out which templates 
are configured by running

opctemplate

2 The list of configured templates is displayed. If the 
TIBSPI-EventService-MSG-V1 template is in the list, you can skip the 
rest of the steps in this task.

3 If you do not see the TIBSPI-EventService-MSG-V1 template, launch the 
administrator GUI on the HPOM management server and log on as 
opc_adm.

4 Open the Node Bank window by selecting Window → Node Bank.

5 In the Node Bank window, select the node where the Frontend Subagent is 
running.

6 Select Actions → Agents → Assign Templates.

7 In the Define Configuration dialog box, click the Add button.

8 In the Add Configuration dialog box, click the Open Template Window 
button.

9 In the Message Source Templates dialog box, double-click the SPI for TIBCO 
template group in the Template Group from the left.

10 Click the TIBSPI-EventService-V1 template group.

11 In the Add Configuration dialog box, click the Get Template Selections 
button.

12 In the Add Configuration dialog box, click the OK button.

13 Close the Message Source Templates dialog box.

14 In the Define Configuration dialog box, the Frontend node and 
TIBSPI-EventService-V1 template group should be in the list.

15 Click the OK button.
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Deploy the Templates

Deploy the templates for the Frontend node. You only need to do this if the 
TIBSPI-EventService-MSG-V1 template was not already configured.

1 In the Node Bank window, select the node where the Frontend Subagent is 
running.

2 Select Actions → Agents → Install / Update SW & Config.

3 In the Install / Update VPO Software and Configuration dialog box, select 
Templates in the Components frame.

4 Select Force Update in the Options frame.

5 Click the OK button.

Verify HPOM Messages Display in Message Browser

Verify that an HPOM test message appears in the HPOM message browser.

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm or TIBSPI_Op.

2 From a window on the Frontend Subagent node, send a test message by 
running

opcmsg severity=minor application=test object=test 
msg_text=”my test” msg_grp=TIBCO

3 A message with minor severity should appear in the HPOM message 
browser. If a message does not appear, follow the steps in the section 
Verify Credentials on page 159.

Verify TIBCO EMA Agent is Sending Notifications

Verify that the TIBCO EMA Agent is sending the notification to the Frontend 
Subagent. 

1 Turn debugging on for the EMA Agent. On the system where the EMA 
Agent is installed:

a Modify the <EMAAgentDir>/config/config.xml file. Uncomment 
<role>debugRole</role> at the end of the file.

b Restart the EMA Agent.
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2 Either wait for the Frontend Subagent to detect that the EMA Agent has 
restarted or restart the Frontend Subagent.

3 After the Frontend Subagent has restarted, generate the operational 
notification. For example if you are trying to see the status of an adapter 
reflected in the service map, stop the adapter if it is already running.

4 Look in the <EMAAgentDir>/logs/emaagent.log file. The following 
output is displayed:

2004 Feb 11 10:19:28:174 GMT -8 Info [Application] EMA-35411 
The status of Managed Object 'tibema://www.tibco.com/ema/
2005/01/mo/identity/ServiceInstance/tibtest2/
DefaultDeployment/Spot' changed from 'http://schemas.hp.com/
wsmf/2003/03/Foundation/Status/Operational' to 'http://
schemas.hp.com/wsmf/2003/03/Foundation/Status/Inactive'

Verify Frontend Subagent receives notifications

If the TIBCO EMA Agent is sending the notifications, we need to verify that 
the Frontend Subagent is receiving the notification.

1 Stop the Frontend Subagent.

2 Run the Frontend in a command window. On the system where the 
Frontend is installed, run:

cd to /opt/OV/bin

./tib-perl tib-start-frontend 

The output is written to stdout. Wait until you see the message: Service 
map created.

3 Generate the operational notification. For example, start or stop an 
adapter.

4 The message ‘Received an operation notification’ is printed to 
stdout along with the information sent to opcmsg. For example if the 
sample Spot application is started, the following is printed:

Received an operation notification

opcmsg:

object=Spot

msg_grp=TIBCO
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service_id=<some wsdl>

severity=Normal

msg_text=Status Change from http://schemas.hp.com/wsmf/2003/
03/Foundation/Status/Inactive to http://schemas.hp.com/wsmf/
2003/03/Foundation/Status/Operational

node=<some node>

application=ServiceInstance/Custom

-option 
WSMF_EVENT_TYPE=http://www.tibco.com/ema/2005/01/event/
StatusChange

-option MSG_CORR_ID=tibema://www.tibco.com/ema/2005/01/mo/
identity/
ServiceInstance/tibtest2/DefaultDeployment/Spot

Verify Resource Host Name 

The node must be in the Node Bank and in the TIBSPI-External or 
TIBSPI-UNIX node group. 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.

2 From any HPOM window, open the Node Bank window by selecting 
Window → Node Bank.

3 The node must be a node in the Node Bank or a node in the Holding Area.

4 Close the Node Bank window.

5 From any HPOM window, open the Node Group Bank window by selecting 
Window → Node Group Bank.

6 In the Node Group Bank window, double-click the TIBSPI-External node 
group. 

The node value must be an exact match to the Hostname for the node in the 
Node Bank. The node cannot be an IP address and it must be accessible 
through DNS. It does not work to put the host name in the /etc/hosts file. 
The name needs to be in the DNS tables.
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7 If the node is in the TIBSPI-External node group window, close the 
window and skip the following steps.

8 If the node is not in the TIBSPI-External node group window, click the 
arrow pointing up to get back to the Node Group Bank window.

9 In the Node Group Bank window, double-click the TIBSPI-UNIX node group.

10 If the node is not in the TIBSPI-UNIX node group, add it to either the 
TIBSPI-UNIX or TIBSPI-External node group.

Verify Source Object 

The source object which is entered as the service_id value in the Frontend 
output must be one of the objects that the Frontend Subagent recognizes.

1 Start the HP OVO Java console.

2 Click the + icon in front of the services until you get to the service that 
represents the object that is the service_id value 

3 Right-click the service and select Properties from the popup menu.

4 In the Services Properties [XXX] dialog box, the value in the Name field 
must be an exact match to the service_id value.

5 Click the Close button to close the dialog box.

Verify Credentials

The HPOM operator that you are logged on as is able to see messages in the 
TIBCO message group. We assume for this example that the HPOM operator 
is opc_adm.

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm.

2 From any HPOM window, select Window → User Bank.

3 From the User Bank window, right-click opc_adm and select Modify from 
the popup menu.

4 In the Modify User: opc_adm window, click the Profiles button.

5 In the Profiles of User: opc_adm window, verify that the TIBSPI User 
Profile icon appears. If it does not appear, follow these steps listed:
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a Open User Profile Bank window by selecting Window → User Profile 
Bank.

b Drag the TIBSPI User Profile from the VPO User Profile Bank 
window and drop it into the Profiles of User: opc_adm window.

c Close the VPO User Profile Bank window.

6 Close the Profiles of user: opc_adm window.

7 In the Modify User: opc_adm window, click the OK button.

8 Restart the session. From any HPOM window, select Map → Restart 
Session.

9 In the HP Operations Windows WARNING dialog, click the OK button.

Verify Communication with the HPOM Management Server

If the Frontend is receiving the notification, you now need to check to see if 
there are communication problems between the Frontend node and the 
HPOM management server. To do this, you need to turn on the HPOM 
message tracing.

1 On the HPOM management server, add OPC_TRACE TRUE and 
OPC_TRACE_AREA MSG to the /opt/OV/bin/OpC/install/
opcsvinfo file. Your file should look similar to:

OPC_INSTALLED_VERSION A.07.10

OPC_MGMT_SERVER <machine>.<domain name>

OPC_MGMTSV_CHARSET iso885915

OPC_INSTALLATION_TIME 03/25/03 15:28:11

OPC_SG FALSE

OPC_TRACE TRUE

OPC_TRACE_AREA MSG

2 Run /opt/OV/bin/OpC/opcsv –trace. The trace information is 
written to /var/opt/OV/share/tmp/OpC/mgmt_sv/trace.

Refer to the HPOM documentation for instructions on enabling HPOM 
message tracing.
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3 Run tail -f /var/opt/OV/share/tmp/OpC/mgmt_sv/trace to see 
the trace messages as they are written.

4 On the Frontend node, add OPC_TRACE TRUE and OPC_TRACE_AREA MSG to 
the /opt/OV/bin/OpC/install/opcinfo file.

5 Run /opt/OV/bin/OpC/opcagt –trace. The trace information is 
written to /var/opt/OV/tmp/OpC/trace.

6 Run tail -f /var/opt/OV/tmp/OpC/trace to see the trace messages 
as they are written.

7 Send a notification. For example, you can start or stop the TIBCO Spot 
sample application. In the HP Operations agent trace file (/var/opt/OV/
tmp/OpC/trace), you should see some messages similar to:

02/11 12:18:20.517 opcmsg(9930:001)[MSG]: Queueing message: 
TIBCO 'Status Change from h'

02/11 12:18:20.523 opcmsgi(1791:001)[MSG]: Sending message: 
6f732be6-5ccf-71d8-0be9-0ff414390000 TIBCO 'Status Change 
from h' 15.244.60.103

02/11 12:18:20.534 opcmsga(1778:001)[MSG]: Message/Act.Resp. 
received from agents: 6f732be6-5ccf-71d8-0be9-0ff414390000 
TIBCO 'Status Change from h' 15.244.60.103

02/11 12:18:20.535 opcmsga(1778:001)[MSG]: OpC mgr for msg: 
6f732be6-5ccf-71d8-0be9-0ff414390000 TIBCO 'Status Change 
from h' 15.244.60.103  opcmgr : <machine>.<domain name> 
15.244.20.57

02/11 12:18:20.535 opcmsga(1778:001)[MSG]: forwarding msg: 
6f732be6-5ccf-71d8-0be9-0ff414390000 TIBCO 'Status Change 
from h' 15.244.60.103  opcmgr : <machine>.<domain name> 
15.244.20.57

02/11 12:18:20.538 opcmsga(1778:001)[MSG]: Sending msg (len = 
554): Status Change from http://schemas.hp.com/wsmf/2003/03/
Founda

02/11 12:18:20.543 opcmsga(1778:001)[MSG]: Message forwarded: 
6f732be6-5ccf-71d8-0be9-0ff414390000 TIBCO 'Status Change 
from h' 15.244.60.103  opcmgr : <machine>.<domain name> 
15.244.20.57
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In the OVO management server trace file (/var/opt/OV/share/
tmp/OpC/mgmt_sv/trace), you should see some messages similar 
to:

02/11 12:18:20.542 opcmsgrd(1595:02f)[MSG]: Message received: 
6f732be6-5ccf-71d8-0be9-0ff414390000 TIBCO 'Status Change 
from h' 15.244.60.103

02/11 12:18:20.543 opcmsgm(1611:001)[MSG]: Message received 
from message receiver: 6f732be6-5ccf-71d8-0be9-0ff414390000 
TIBCO 'Status Change from h' 15.244.60.103

02/11 12:18:20.552 opcmsgm(1611:001)[MSG]: Message 
processing: ip_addr=15.244.60.103 (mapped), 
node_name='<machine>.<domain name>'

02/11 12:18:20.552 opcmsgm(1611:001)[MSG]: csm_db_msg_add 
called with msg 6f732be6-5ccf-71d8-0be9-0ff414390000.

02/11 12:18:20.592 opcmsgm(1611:001)[MSG]: csm_db_msg_add 
finished for msg 6f732be6-5ccf-71d8-0be9-0ff414390000. Last 
err: 0-0

02/11 12:18:20.593 opcmsgm(1611:001)[MSG]: Message forwarded 
to DM: 6f732be6-5ccf-71d8-0be9-0ff414390000 TIBCO 'Status 
Change from h' 15.244.60.103

8 Turn tracing off on the HPOM management server by modifying 
OPC_TRACE to FALSE in the /opt/OV/bin/OpC/install/opcsvinfo file.

9 Run /opt/OV/bin/OpC/opcsv –trace. 

10 On the Frontend node, turn tracing off by setting OPC_TRACE to FALSE in 
the /opt/OV/bin/OpC/install/opcinfo file.

11 Run /opt/OV/bin/OpC/opcagt –trace.

Cleanup the HPOM Message Queues

If you do not see the above trace messages, it could be that your HPOM 
message queues are corrupt.

1 Stop opcagt by running opcagt -kill.

2 Remove the temporary files by running
rm -f /var/opt/OV/tmp/OpC/*.

3 Restart the opcagt by running opcagt -start.
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4 Close all HPOM GUIs.

5 Stop the HPOM management server by running ovstop opc ovoacomm.

6 Remove the temporary files by running 
rm -f /var/opt/OV/share/tmp/OpC/mgmt_sv/*

7 Restart the HPOM management server processes by running
opcsv –start.

Performance Agent Does Not Start Up

When you run opcagt -start -id 12 and opcagt –status the output shows 
that the Performance Agent is not running.

Solution:

Verify that Embedded Performance Component (Coda) is not running by 
running ps -ef | grep coda. If Embedded Performance Component (Coda) 
is running it means Embedded Performance Component (Coda) was either 
started up standalone, or the HPOM control agent has stopped, was restarted 
and is longer the parent. 

If Embedded Performance Component (Coda) is not running, look in the 
<OVAgentDataDir>/log/coda.log file for any error messages.

TIBCO SPI Fails to Detect HP Performance Agent

The TIBCO SPI fails to detect the HP Performance Agent even though HP 
Performance Agent is running on the system.

Solution:

Make sure the systemsMWA.txt file is located in /var/opt/OV/conf/perf 
directory. If it is not, you must copy systemsMWA.txt from its existing 
directory to /var/opt/OV/conf/perf. HP Performance Manager should 
than detect HP Performance Agent.
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Configure TIBCO SPI Application Errors

Configure TIBCO SPI Application Does Not Start

The Configure TIBCO SPI application does not start. 

Solution:

Delete /var/opt/OV/conf/tib/appconfig.xml.ser and restart the 
configuration tool.

Configure TIBCO SPI Application Does Not Display Content

The Configure TIBCO SPI application starts, but no content is displayed.

Solution:

This problem occurs when you manually edit WCConfig.xml with a text 
editor and save it with non UTF-8 encoding. This file is expected to be in 
UTF-8.

Open the file in your text editor and make sure to save it in UTF-8 encoding. If 
your editor does not have a save as option to do this and uses system default 
encoding, then make sure you set your session’s LANG variable to UTF-8.

Configure TIBCO SPI Application Fails to Transfer WCConfig.xml

When you run the Configure TIBCO SPI application, the Output of 
Application window has the message
‘Error by transfer file from /var/opt/OV/conf/tib/WCConfig.xml 
to /var/opt/OV/conf/tib/WCConfig.xml (OpC40-745)’.

Solution:

There was a problem transferring the WCConfig.xml file from the HPOM 
management server to the Frontend Subagent node. You need to manually 
transfer the file and restart the Backend service and Frontend Subagent. 

1 Ftp the /var/opt/OV/conf/tib/WCConfig.xml file from the HPOM 
management server to /var/opt/OV/conf/tib on the Frontend 
Subagent node.
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2 Restart the Backend Service by running:

ovstop tib-backend

ovstart tib-backend

3 Restart the Frontend Subagent by running:

opcagt –stop –id 25 (OVO 7.x)

or

ovc –stop –id TIB for (OVO 8.x)

opcagt –start –id 25 (OVO 7.x)

or

ovc –start –id TIB for (OVO 8.x)

4 Check the status:

opcagt –status –id 25 (OVO 7.x)

ovc –status –id TIB (OVO 8.x)

Configure TIBCO SPI Application Throws AWTException

When you close the Configure TIBCO SPI application, you get the following 
exception in the Application Output window:

java.awt.AWTException: cannot open XIM

Solution:

By default, you cannot input Asian (Japanese, Chinese, Korean) characters 
into the Configure TIBCO SPI application. To input Asian characters in a 
Java GUI an input method is required. This input method can be a pure Java 
input method (independent of OS) or an input method provided by the OS. An 
input method is installed with Java 1.4. The Configure TIBCO SPI is a Java 
GUI. Therefore, you need to modify the JAVA_HOME variable in the /var/opt/
OV/bin/OpC/cmds/tib_config script on the HPOM server system to a 
JVM on the system that is configured to display Asian characters. 
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Frontend Logfile Errors

The Frontend subagent’s log file is located in /var/opt/OV/log/tib/
frontend.log. 

Error Starting Notification HTTP Server

NotifMgr: Error: Problem starting notification HTTP server. 
Please make sure port is not already in use: XXXX.

Solution:

Check to see if the Frontend is already running: 

opcagt -status -id 25 (OVO 7.x)

ovc –status -id TIB (OVO 8.x)

If the following message is displayed:

tib-frontend TIB SPI Frontend Subagent    TIB (7990)   Running

it indicates that the Frontend is already running. 

If the following message is displayed: 

tib-frontend TIB SPI Frontend Subagent    TIB Stopped

it indicates that the Frontend is not running, but the Frontend Java process 
might not have been stopped. Wait for few minutes for the port to be released 
and try to start TIBCO SPI again.

Error Adding Service to Map

Problem adding services to map: Connection refused to host: XXX; 
nested exception is: java.net.ConnectException: Connection 
refused

Solution:

Verify that the Backend process is running. On the HPOM management 
server system, run: 

ovstatus tib-backend
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If the response is “NOT_RUNNING”, start the Backend by running:

 ovstart tib-backend

Frontend does not Connect to the Backend

Frontend is not able to connect to the Backend.

Solution:

This message appears just after installing the Frontend Subagent because the 
TIBCO SPI has not been configured yet or the Backend Service is not started.

Make sure that you configure the SPI using the Configure TIBCO SPI 
application located in the Application Bank. See Chapter 2 for complete 
instructions.

After the configuration is complete, use the Start TIBCO SPI application 
located in the Application Bank.

Problem Logging Metric Data

WSF-0009: ddflog returned an error logging 
TIBSPI_RPT_METRICS:256

This error may occur when the data sources for the TIBCO SPI metrics are 
not registered successfully. Make sure you register the TIBCO SPI Metric 
data sources by running the following commands on the Frontend Subagent 
machine:

cd /opt/OV/bin

./tib-perl tib-create-datasources
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SEA Component Runtime Problems

Shutdown Problems

The SEA component does not shutdown.

Solution:

The default shutdown port is already being used. To ensure that SEA is 
shutdown, complete the following:

1 Type ps -ef | grep startSEA.sh and do a kill -9 on the process id. 

2 Check for the port number in the /opt/OV/bin/SEA/conf/AIA.cfg file 
under <OVSBA_CONFIGURATION> (Usually 4444, by default).

3 Type: netstat -na | grep <port number>.

4 If you see the port number in the output, it means the port is being used. 
Change the port number in the AIA.cfg file and restart SBA.

Viewing SEA WSMF Events

You cannot view SEA WSMF events in your SOAP client.

Solution: 

Complete the following procedures. 

Check if HPOM Events Work

1 On the HPOM server, execute the command:

 “opcmsg a=a o=o n=<nodename> msg_text=”testing”

2 Check HPOM browser to see if the message arrives. If it does, then HPOM 
events are OK.
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Check the SEA Log File for Captured Events

You can check  var/opt/OV/log/SEA/SEA.log to ensure that events are 
being captured:

1 Check if an entry for the event sent in the previous section is present. For 
example, if you ran one of the pre-packaged tests, like the no-impact test, 
then you will see an event message with OBJECT= “CPU”.

2 Check if you have connection failed errors. If so, HPOM and SBA may not 
be running properly, or they are looking at the wrong port. Stop HPOM, 
Start HPOM. Stop SBA, Start SBA.

3 Try sending another event.

Check the SEA Log for Event Subscription ERRORS/WARNINGS

Check the SEA log file for the following subscription warning:

Zero length ImpactedObjects: No Subscriptions for this event. 

If you get this warning, please recreate the event definition. It may be 
corrupted.

Check the OVComposer GUI

Check the OVComposer GUI to see if there is a valid service_name under new 
alarm definition pane. In addition, see if this service is actually part of the 
SEA MO. Also make sure there is a valid AIA_EVENT_NAME. Save the events 
and refresh the MOViewer.

ECS Correlation Problems

You are experiencing ECS correlation related problems.

Solution:

Complete the following procedures. 

Clean the Fact Store

1 Delete /var/opt/OV/conf/OpC/mgmt_sv/eco*.fs file.

2 Remove HPOM templates:
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a From the Menu bar in the VPO Node bank, select Actions → Server → 
Assign Templates.

b Click Remove Templates.

c From the Menu bar in the VPO Node bank, select Actions → Server → 
Install/Update server templates.

3 Verify that /var/opt/OV/conf/OpC/mgmt_sv/eco* file is not there.

4 Change directories to /opt/OV/bin, and run:

./seaECS.sh –r

./seaECS.sh -i

5 Log into HPOM as opc_adm/ OpC_adm. (You need to have administration 
privileges)

6 From the Menu bar in the VPO Node bank, select Actions → Server → 
Install/Update server templates.

7 Click open Template Selection window.

8 Select Correlation Composer Template.

9 Go back to the Template Configuration window, and click Get Template 
Selections.

10 Click OK.

11 Verify if the above steps were successful by checking the /var/opt/OV/
conf/OpC/mgmt_sv directory. It should contain an ecs_comp.eco file.

12 Change directories to /opt/OV/bin, and run:

./seaECS.sh -u

For Solaris 8.x

1 Copy ecs_comp.eco from the location /var/opt/ov/conf/SEA/ to the 
location /var/opt/ov/conf/opc/mgmt-sv.

2 Restart the HPOM services by running the following command:

opcsv -stop

opcsv -start
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No Managed Objects are Deployed

No managed objects are deployed

Solution: 

1 Check /var/opt/OV/conf/SEA/AIA.cfg that the root service name 
mirrors the high level service name of the TIBSPI in the service navigator.

2 Check the obj type, to see if they have the right entries.

3 See if service engine is operational by using the command:
opcsv –status.

4 Check for any error messages in /var/opt/OV/log/SEA/SEA.log.

Mgmt_sv Directory not Present

The mgmt_sv directory is not present.

Solution:

To ensure that this directory is created, here are the steps that need to be 
taken:

The following steps involve installing ECS 3.2, which includes installing 
PHSS_30125 patch. Please follow the "Special Installation Instructions" in the 
patch documentation. For your convenience it is enclosed below: 
http://www2.itrc.hp.com/service/cki/
patchDocDisplay.do?patchId=PHSS_30125#Special%20Installation%2
0Instructions)

Special Installation Instructions:

If you want to use the ECS 3.2 Designer, this patch enables you to use the 
ECS 3.2 designer but the ECS 3.2 HPOM integration misses some files 
(see B555016387) so you have to copy them manually before you start the 
ECS designer the first time:

ITO_MODULES= /etc/opt/OV/share/conf/OpC/mgmt_sv/ecs/
modules

OV_CONF= /etc/opt/OV/share/conf

rm -f ${OV_CONF}/ecs/modules.newconfig/ito 2>/dev/null

mkdir -p ${OV_CONF}/ecs/modules.newconfig/ito 2>/dev/null
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if [ -d ${ITO_MODULES} ]

then

  for MODULE in `ls ${ITO_MODULES}/*.ecs`

  do

    cp ${MODULE} ${OV_CONF}/ecs/modules.newconfig/ito 
2>&1

  done

fi

This problem will be addressed with the next ECS patch.

         PHSS_30125.

Patch Installation Instructions

(A1)  Stop all HPOM processes on your management server; this 
includes manager processes, communication processes and 
user-interface processes on the machine.

– Stop all HPOM GUIs (including all Java GUIs connected to this 
server). Use the File: Exit menu bar item.

– Stop the HPOM manager processes: # ovstop opc ovoacomm

    If any HPOM processes are still running, kill them manually:

    # kill -9 <pid-of-orphaned-process>

If you are running HPOM in an MC/ServiceGuard installation, you 
must apply this patch to all MC/SG cluster nodes.

 1. Files on the shared disk volumes at /var/opt/OV/share and/or 
/etc/opt/OV/share

will be patched. Therefore either put the package in maintenance 
mode or mount the shared disks manually before installing

    - Put the package in maintenance mode and leave the shared disks 
mounted:

          # touch /tmp/maint_NNM

           # ovstop opc ovoacomm

- Mount the shared disks manually:
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           # cmhaltpkg OpC

           # vgchange -a e <shared_vg>

           # mount <etc_shared_vol> /etc/opt/OV/share

          # mount <var_shared_vol> /var/opt/OV/share

2. Install the patch on the first cluster node.

3. On the other cluster nodes, make sure the OpC package is not running 
and the shared disks are not mounted when PHSS_30125 is installed.

4. Install the patch on the other cluster nodes.

5. After the patch installation remove the following files from the local 
disks because they already exist on the shared disk:

         # rm -rf /etc/opt/OV/share/*

         # rm -rf /var/opt/OV/share/*

(A2) Install the patch following the standard installation instructions 
provided above under "Installation Instructions". Observe that you can 
use opc_backup(5) for backing up your system before installing a patch.

(A3) After installing PHSS_30125, restart the HPOM processes on your 
management server system:

Restart the HPOM Manager processes, and check that the processes are 
running:

        # /opt/OV/bin/OpC/opcsv -start

        # /opt/OV/bin/OpC/opcsv -status

      If you are running HPOM in an MC/ServiceGuard installation:

     If you entered maintenance mode, return to full monitoring:

        # ovstart opc

        # rm /tmp/maint_NNM

Whenever you need to uninstall PHSS_30125, you need to have the same state 
of the shared disks as during the patch installation. That is, for the patch 
deinstallation they must be mounted where they were mounted during the 
patch installation, and they must not be mounted where they were not 
mounted at that time.
Troubleshooting                                                                                                                                                   173



      - If you stopped the OpC package, restart it:

        # cmrunpkg OpC

(B) Patch Deinstallation Instructions

      ---------------------------------

Event Subscriptions Persistence

I do not wish to persist subscriptions.

Solution:

There is a fault tolerance feature in the SEA that allows for persistence of the 
event subscriptions so that they do not get lost in the case of a system crash. If 
you would like the subscriptions to no longer be in effect, please go to the 
directory configured to be java.io.tmpdir, on your system, and delete the 
file called _wsmf-sba_. Remember to restart SEA after the file is removed. 
The directory is typically set to /var/tmp on UNIX.

Managed Object Discovery Problems

SEA encounters Managed Object Discovery problems. Error is
[java] --> 02-26-04 01:27:50 ERROR 
[hp.thread.12.discovery-main-SEA-OVSBA] MoHConnector: 
getDependency failed. Received null from service engine getXML: 
recv peer closed connecion

Solution:

Before removing the patch, stop all HPOM server processes, as described in 
the Patch Installation Instructions (A1). If you are running HPOM in an MC/
ServiceGuard installation, make sure to mount the shared disks on the node 
and only on the node that had them mounted during the patch installation. 
Otherwise restoring the original files onto the shared disk will fail. Be sure to 
deinstall PHSS_30125 from all cluster nodes so that all cluster nodes have the 
same revision.
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The SEA functionality requires that the Service Engine component in HPOM 
is operational.

1 Make sure that the Service Engine Component is operational. Type:

Opcsv –status at the command prompt.

2 Make sure the SEA Configuration port is not in conflict. Just to make 
sure, change the default 4444 port to something else, and restart HPOM 
and the SEA components. To check for the port usage, type:

netstat -a | grep <ovsba Port>

Service Engine Related Problems

The SEA solution requires the service engine. Make sure service engine is 
operational, before you re-start the SEA solution. 

Service Engine Error

Sometimes the service engine is up as per the opcsv –status command, but 
doing :opcservice -list -services results in the following error:

Error:   Failed to connect to AF_UNIX socket '/var/opt/OV/
sockets/OpC/opcsvcm': No such file or directory

Solution:

Remove and recreate the opcsvcm file: 

1 Stop HPOM service processes 

# /opt/OV/bin/ovstop -v -c 

2 Remove the opcsvcm socket file

# rm /var/opt/OV/sockets/OpC/opcsvcm 

3 Restart the HPOM service processes 

# /opt/OV/bin/ovstart -v -c 

4 The opcsvcm socket should be recreated with the following permissions: 

# ll /var/opt/OV/sockets/OpC/ 
total 0 
srwxrwxrwx 1 root  sys  0 Feb 5 05:04 opcsvcm
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Using the Self-Healing Info Application

The Self-Healing Info application gathers system information as well as 
configuration, log and trace files of TIBCO SPI when a problem occurs in the 
TIBCO SPI.

All the gathered files and information are placed in a pre-defined output 
directory, thereby facilitating faster troubleshooting. Also, the data collector 
application is used to gather real-time data, which reduces the probability of 
troubleshooting with stale data.

Troubleshooting information is enhanced with cross-referencing capabilities 
available through the HP support site: http://support.openview.hp.com/
self_healing.jsp. A link is then automatically set up to the self-healing 
services web site, where your SPI problem can be matched to similar SPI 
problems and solutions for increased troubleshooting effectiveness. 

To greatly enhance troubleshooting, and access the search and 
cross-referencing capabilities of the HP Support web site, you can download 
and use the Self-Healing Services client software. Refer to the relevant section 
in the HP Operations Smart Plug-ins Installation and Upgrade Guide for 
more information on how to download and use the software, and to set up the 
automatic link to the HP support web site. 

If Self-Healing Services client is not installed and configured on the node 
being managed by the SPI, you can use the Self-Healing Info application to 
collect system information. 

Whenever you encounter a problem with the TIBCO SPI, run the data 
collector by launching the Self-Healing Info application in the TIBCO SPI 
Supportability group.

To launch the data collector on the node from where you want to gather data, 
drag the icon of the node and drop it on the Self-Healing Info application in 
the TIBCO SPI Application Group window.

Prior to using the Self-Healing Info application, turn on tracing and 
reproduce the problem, then run the application.

In case both the Frontend and Backend are running on two different 
machines, drag the icons of both the nodes and drop them on the Self-Healing 
Info application in the TIBCO SPI Application Group windows.
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The gathered output is placed as /tmp/SPI_TIBCO_support.tar on UNIX 
nodes. You can submit this file to HP Support for assistance or use this file to 
identify and correct the problem you encountered.

Depending on the Windows setting, the file may be a hidden file on some 
managed nodes. If you do not see the file, open Windows Explorer and from 
the Tools menu select the View tabbed page in the Folder Options. Under 
Hidden Files and Folders, select Show Files and Folders.
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A TIBCO SPI Configuration
This appendix is a reference for the TIBCO SPI configuration parameters. In 
particular, this appendix focuses on the WCConfig.xml configuration file. The 
parameters are discussed throughout this guide; however, they are listed here 
in a reference style so they can be easily accessed. 

Editing WCConfig.xml

The WCConfig.xml file is located in /var/opt/OV/conf/tib/ on the 
system running the TIBCO SPI Front-End Subagent. The WCConfig.xml file 
is structured using XML. You can edit this file using the SPI’s configuration 
tool, or you can manually edit this file using an XML or text editor. If you 
chose to manually edit WCConfig.xml, you must restart the Front-End 
Subagent before the changes take effect. 

Using the Configuration Tool

To edit parameters using the configuration tool: 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 In the Application Bank window, double-click the TIBCO SPI Tools 
application group.

4 In the Application Group: TIBCO SPI Tools window, right-click Configure 
TIBCO SPI application and select Execute from the popup menu.

5 Edit the available parameters.
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6 Select File → Save to save your changes to the configuration file.

WCConfig.xml Configuration Parameters

The WCConfig.xml configuration file contains parameters that configure the 
Backend Service, Frontend Subagent, and the NNM integration. The root 
element of the configuration file is <WcConfiguration>. All elements must 
be children within the root element. 

<FrontendSection>

This node contains parameters that are used to configure the Frontend 
Subagent. It contains six child nodes:

• <ManagedObjectInfo>

• <OVOMgmtAgentInfo>

• <NotifHttpServerInfo>

• <ServiceMapInfo>

• <Miscellaneous>

• <ReportInfo>

FrontendSection/ManagedObjectInfo

This element contains a list of WSDL locations that you want the Frontend 
Subagent to monitor. For each MO you want the Frontend subagent to 
monitor, add the MO's WSDL location.  You only need to add the 'root' MOs' 
WSDL locations because the Frontend subagent recursively discovers the 
children. It retrieves information for the children that are related to the 
parent MO by the relation configured in the Relations to Use list on the 
Service Map Information area. By default, all children that are related to the 
parent MO by http://schemas.hp.com/wsmf/2003/02/Relations/Contains 
and http://schemas.hp.com/wsmf/2003/03/Relations/DependsOn types 
are discovered. You can add more entries to the Relations to Use list but you 
need to be careful about circular dependencies.
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FrontendSection/ManagedObjectInfo/WsdlLocation

MO's WSDL location.

FrontendSection/OVOMgmtAgentInfo

Parameters for the Frontend Subagent

FrontendSection/OVOMgmtAgentInfo/HostName

The Frontend subagent system's host name.

FrontendSection/OVOMgmtAgentInfo/JavaHome 

The location of JAVA_HOME on Frontend subagent system.

FrontendSection/OVOMgmtAgentInfo/RmiPort

The Frontend subagent RMI port number.

FrontendSection/OVOMgmtAgentInfo/AgentType

The Frontend subagent system type. Choices are: UNIX or Windows.  
(Windows is not implemented yet.)

FrontendSection/NotifHttpServerInfo

Configures the HTTP server in the Frontend Subagent to receive WSMF 
notifications

FrontendSection/HTTPPort

The HTTP server’s port number that receives WSMF notifications

FrontendSection/Service MapInfo

This node contains parameters that allow you to configure the  Service Map

FrontendSection/Service MapInfo/ActionsToBeIgnored

The Service Map will ignore actions that are listed in this node.

FrontendSection/Service MapInfo/ActionsToBeIgnored/Action

This node contains parameters for specifying which actions will be ignored.

The MOs configured in the Managed Object Information list must be 
accessible before starting up the Frontend subagent.
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FrontendSection/Service MapInfo/ActionsToBeIgnored/Action/
ActionName

The name of the action to be ignored

FrontendSection/Service MapInfo/ActionsToBeIgnored/Action/
NamespaceURI

Namespace of the action to be ignored

FrontendSection/Service MapInfo/RelationsToBeUsed

List of relations that are used by the Frontend subagent to recursively 
discover children MOs.

FrontendSection/Service MapInfo/RelationsToBeUsed/Relation

Relation to use in discovery

FrontendSection/Service MapInfo/OVOUserForServiceMap

List of HPOM users that can view the TIBCO service.

FrontendSection/Service MapInfo/OVOUserForServiceMap/
OVOUserName

HPOM user name to associate with TIBCO service

FrontendSection/Service MapInfo/ServiceAliasMap

List of service names associated with TIBSPI that can be substituted with 
another service name. For example if there is a DB service node as part of DB 
SPI, the TIBSPI node connected to this DB can use the same service name as 
the DB service node.

FrontendSection/Service MapInfo/ServiceAliasMap/AliasInfo 

FrontendSection/Service MapInfo/ServiceAliasMap/AliasInfo/
ServiceName

Service Name of the TIBSPI.

FrontendSection/Service MapInfo/ServiceAliasMap/AliasInfo/
AliasName

The service name to be replaced with this name.
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FrontendSection/Service MapInfo/ServiceAliasMap/AliasInfo/
AliasLabel

The service label of SPIs (such as DB SPI, OS SPI, SAP SPI) which integrate 
with TIBCO SPI. The label can be found by clicking the properties on the 
service icon for a SPI in the Java console’s Service Navigator.

FrontendSection/Service MapInfo/ServiceIconMap

This node contains parameters for defining icons for MO types.

FrontendSection/Service MapInfo/ServiceIconMap/ServiceIcon

List of icon/MO type. Displays the specified icon in the service map for an MO 
of the specified type

FrontendSection/Service MapInfo/ServiceIconMap/ServiceIcon/
ServiceType

MO type

FrontendSection/Service MapInfo/ServiceIconMap/ServiceIcon/
IconFile

Fully qualified name of the icon file

FrontendSection/miscellaneous/

This node is for miscellaneous parameters.

FrontendSection/miscellaneous/ManagedObjectsToBeIgnored/

This node allows you to list of MO types that you want to ignore. These MO 
types are not discovered and therefore will not appear in the service map.

FrontendSection/miscellaneous/ManagedObjectsToBeIgnored/

ManagedObjectType

MO type to ignore

FrontendSection/miscellaneous/RootServiceName

The root of the MO hierarchy

FrontendSection/ReportInfo

This node allows you to specify a user friendly name for MOs.

FrontendSection/ReportInfo/ReportGroupInfo
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For each MO that you're collecting data for, you can define a user friendly 
name that appears on the graphs and reports to identify the MO.  The name is 
also used as the name of the file where data is logged for graphs before it's 
sent to the Performance Agent.  Therefore the name needs to be a valid file 
name.

FrontendSection/ReportInfo/ReportGroupInfo/ReportGroupObjectID

MO's WSDL location that data is being collected for

FrontendSection/ReportInfo/ReportGroupInfo/ReportGroupName

User friendly name of MO

<BackendSection>

This node contains parameters that are used to configure the Backend 
Service. It contains a single child node, <OVOMgmtServerInfo>.

BackendSection/OVOMgmtServerInfo

This node contains parameters that configure the Backend Service on the 
HPOM management server.

BackendSection/OVOMgmtServerInfo/HostName

Backend Service system's host name

BackendSection/OVOMgmtServerInfo/JavaHome

JAVA_HOME on the Backend Service system

BackendSection/OVOMgmtServerInfo/RmiPort

Backend Service RMI port number

BackendSection/OVOMgmtServerInfo/NodeGroupName

HPOM node group that the host name manager adds nodes to

<NetworkingInfo>

This node allows you to configure the NNM integration. It contains two child 
nodes:

• <NetworkMonitoring>

• <NetworkReporting>
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NetworkInfo/NetworkMonitoring

This node allows you to define parameters that configure the NNM 
integrations’ monitoring behavior.

NetworkInfo/NetworkMonitoring/NNMHostName

This parameter is the fully qualified hostname of the system running HPOM 
and the NNM server.

NetworkInfo/NetworkMonitoring/OviPort

This parameter defines the TCP port that the TIBCO SPI Back-End Subagent 
uses to communicate with the Front-End Subagent NNM integration. This 
parameter is set to 16835 by default. If another application on the HPOM 
server is already using port 16835, you will need to change the port number. If 
you change the port, you will also need to update the serverPort entry in /
var/opt/OV/conf/tib/ResponderProxyPluglet.http.config on the 
HPOM server. The serverPort and OviPort must be the same value.

NetworkInfo/NetworkMonitoring/DiscoveryInterval

This parameter determines how often the TIBCO SPI Front-End Subagent 
checks the NNM topology for changes and modifies the TIBCO SPI service 
view to include any updates. This parameter is set to 4 hours by default.

NetworkInfo/NetworkMonitoring/NNMTopology

This parameter enables the NNM integration in the TIBCO SPI service map. 
Set this parameter to true to enable the NNM integration.

NetworkInfo/NetworkMonitoring/NNMTopologyHosts

This node allows you to specify the topology that is consumed by the NNM 
Integration.

NetworkInfo/NetworkMonitoring/NNMTopologyHosts/ByObjectType

This node allows you to configure a topology by object type.

NetworkInfo/NetworkMonitoring/NNMTopologyHosts/ByObjectType/
ObjectType

This parameter enables the NNM integration to discover the networking 
device which is directly connected to each system running the TIBCO RVD. 
This parameter is set to RVD by default and does not need to be set.

NetworkInfo/NetworkReporting
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This node allows you to define parameters that configure the NNM 
integrations’ reporting behavior.

NetworkInfo/NetworkReporting/ReportingOn

This parameter enables performance reporting. TIBCO SPI Service Reporter 
reports compare TIBCO RVD and network performance metrics. Set this 
parameter to true to enable performance reporting.

NetworkInfo/NetworkReporting/Interval

This parameter determines how often the TIBCO SPI Front-End Subagent 
logs network performance metrics to the HP Performance Agent or Embedded 
Performance Component (Coda). This parameter is set to 5 minutes by 
default.

NetworkInfo/NetworkReporting/CommunityName

This parameter represents the community name for the SNMP agent running 
on each RVD system. Typically, the community name for host systems (as 
opposed to networking devices) is set to public. This parameter is set to public 
by default.

NetworkInfo/NetworkReporting/SnmpPort

This parameter represents the port used by the SNMP agent running on each 
RVD system. Typically, the SNMP port for hosts systems is set to 161. This 
parameter is set to 161 by default.

NetworkInfo/NetworkReporting/ByObjectType

This node allows you to configure a topology by object type.

NetworkInfo/NetworkReporting/ObjectType

This parameter enables the NNM integration to collect network metrics for 
each system running the TIBCO RVD. This parameter is set to RVD by 
default and does not need to be set.
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B SEA Configuration
This appendix is a reference for the TIBCO SPI SEA configuration 
parameters. In particular, this appendix focuses on the AIA.cfg configuration 
file. The parameters are discussed throughout this guide; however, they are 
listed here in a reference style so they can be easily accessed.

Editing AIA.cfg

The AIA.cfg file is located in /var/opt/OV/conf/SEA/ on the system 
running the TIBCO SPI AAE directory. The AIA.cfg file is structured using 
XML. You can edit this file using the SEA’s configuration tool, or you can 
manually edit this file using an XML or text editor. If you chose to modify 
AIA.cfg, you must restart Tomcat and restart SEA from the application bank, 
before the changes take effect. 

Using the Configuration Tool

To edit parameters using the configuration tool: 

1 Launch the administrator GUI on the HPOM management server and log 
on as opc_adm. 

2 From any HPOM window, bring up the Application Bank window by 
selecting Window → Application Bank.

3 In the Application Bank window, double-click the TIBCO SPI Tools 
application group.

4 In the Application Group: TIBCO SPI Tools window, right-click Configure 
SEA application and select Execute from the popup menu.

5 Edit the available parameters.
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6 Select File → Save to save your changes to the configuration file.

AIA.cfg Configuration Parameters

The AIA.cfg configuration file contains parameters that configure the SEA 
solution, and allow for configuration of parameters for Managed Objects, 
Event Subscriptions, SEA ports and so on. The root element of the 
configuration file is <AIA_CONFIGURATION>. All elements must be children 
within the root element. 

<ManagedObjectInformation>

This node contains parameters that are used to configure the Root Service 
name, and the object types for the managed objects that are part of the SEA 
solution.  It has 2 child nodes:

• <ROOT_SERVICE_NAME>

• <BY_OBJTYPES>

ManagedObjectInformation/ROOT_SERVICE_NAME

This element contains the root service name as specified in the Service 
Navigator view of the TIBCO SPI.

For example, TIBCOService

ManagedObjectInformation/BY_OBJTYPES

This element(s) identifies type of service you are interested in. This could be 
an RVService, a logic service, etc. For Example: 

<BY_OBJTYPES> 

  <OBJTYPE>
     http://www.tibco.com/ema/2005/01/mo/type/Folder/
RVServices 

  </OBJTYPE> 

</BY_OBJTYPES> 
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To get both these values, right-click on the Service Node of the TIBCO tree to 
get the properties. The ObjectID value identifies the service name and the 
ObjectType value represents the type of service.

<EventSubscription>

This node allows you to configure the polling interval for the frequency with 
which new event definitions will be discovered.

<Event_Reporting>

This node contains parameters that are currently not supported.

<OVSBA_Configuration>

This section allows you to configure parameters related to the SEA smart 
business agent.  Like the port number where the SEA Smart business agent 
listens for new events.
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C List Templates and Reports
This appendix provides reference information for: 

• Message Groups

• Applications

• Templates

• TIBCO SPI Self Management 

• Performance Metrics

• Reports
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Message Groups

Table 6

Name Description

TIBCO For messages coming from the TIBCO 
environment.

TIBCO SPI For messages coming from TIBCO SPI.

TIBCO SPI SEA For messages coming from TIBCO SPI SEA.
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Applications

Table 7

Name Group Description

TIBSPI SPI Tools Group Contains all of the TIBCO SPI 
applications

Check Status TIBCO SPI Application Checks the status of the Backend and 
the Frontend

Configure TIBCO SPI Application Launches a GUI to modify the TIBCO 
SPI configuration file.  Transfers the 
configuration file to the Frontend 
system and restarts the Backend and 
the Frontend.

Deploy SEA Application Deploys the TIBCO SPI SEA

Restart TIBCO SPI Application Restarts

SEA Configuration tool Application Launches a GUI to modify the SEA 
configuration file.

SEA Event Definition Application Starts the TIBCO SPI SEA wizard

Start SEA Application Starts the TIBCO SPI SEA

Stop SEA Application Stops SEA web service

Start TIBCO SPI Application Starts the Backend and the Frontend

Stop TIBCO SPI Application Stops the Backend and the Frontend
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Templates

Table 8

Name Type Group Description

SPI for TIBCO Group N/A Contains all of the TIBCO 
SPI template groups and 
templates 

TIBSPI-EventService- 
V1

Group SPI for TIBCO Contains templates that 
intercept the HPOM 
messages that are sent by the 
TIBCO SPI

TIBSPI-Metrics-V1 Group SPI for TIBCO Contains the templates 
related to metric data 
collection and metric 
threshold monitoring

TIBSPI-UNIX-Backend-
V1

Group SPI for TIBCO Contains the templates that 
monitor the TIBCO SPI log 
files on the Backend node 

TIBSPI-UNIX-Frontend
-V1

Group SPI for TIBCO Contains the templates that 
monitor the TIBCO SPI log 
files on the Frontend node

TIBSPI-UNIX-V1 Group SPI for TIBCO Contains the templates that 
monitor various TIBCO 
products that are running on 
UNIX nodes

TIBSPI-Windows-V1 Group SPI for TIBCO Contains the templates that 
monitor various TIBCO 
products that are running on 
Windows nodes 
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TIBSPI-EventService- 
Msg-V1

Message 
Template

TIBSPI-EventService
-V1

The Frontend intercepts 
operational notifications from 
the TIBCO EMA.  For each 
operational notification it 
receives, it sends an HPOM 
message that represents the 
notification.  This template 
intercepts these HPOM 
messages that are generated 
by the Frontend. 

TIBSPI-Frontend-MSG-
V1

Message 
Template

TIBSPI-EventService
- V1

Intercepts the HPOM 
message that's sent by the 
Frontend once it's started up.  
Acknowledges previous 
HPOM messages that 
indicated that a TIBCO 
resource was down This 
template must be assigned 
and deployed to capture the 
messages sent from the 
TIBCOSPI-Frontend-Unix-  
Sched-V1

TIBSPI-Collect-Mon-V1 Monitor 
Template

TIBSPI-Metrics-V1 Collects metric data for 
alarming, reports and 
graphs.  Note that the metric 
data is logged into the report 
data source. For the graphs, 
the metric data is saved in 
text files in:
/var/opt/OV/datafiles/
tib/datalog

It is logged into the graph 
data source by the 
TIBSPI-Graph-Mon-V1 
template.
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TIBSPI-Graph-Mon-V1 Monitor 
Template

TIBSPI-Metrics-V1 Logs the metric data collect 
by the 
TIBSPI-Collect-Mon-V1 
template into the graph data 
source

TIBSPI_0009 Monitor 
Template

TIBSPI-Metrics-V1 Monitors the RVD 
Retransmission Packet Rate

TIBSPI_0010 Monitor 
Template

TIBSPI-Metrics-V1 Monitors the RVD Missed 
Packet Rate

TIBSPI-Backend-Log- 
V1

Logfile 
Template

TIBSPI-UNIX- 
Backend-V1

Monitors the Backend log file

TIBSPI-SEA-ECS-Log-
V1

Logfile 
Template

TIBSPI-UNIX- 
Backend-V1

Monitors the SEA ECS log 
file

TIBSPI-SEA-Log-V1 Logfile 
Template

TIBSPI-UNIX- 
Backend-V1

Monitors the SEA log file

TIBSPI-Frontend-Unix-
Log-V1

Logfile 
Template

TIBSPI-UNIX- 
Frontend-V1

Monitors the Frontend log 
file

TIBSPI-UNIX-EMA-V1 Group TIBSPI-UNIX-V1 Contains templates that 
monitor the TIBCO 
Enterprise Management 
Advisor running on a UNIX 
system

TIBSPI-UNIX-RVRD- 
V1

Group TIBSPI-UNIX-V1 Contains templates that 
monitor TIBCO Rendezvous 
running on a UNIX system

TIBSPI-UNIX-HAWK- 
Agent-V1

Group TIBSPI-UNIX-V1 Contains templates that 
monitor the TIBCO Hawk 
Agent running on a UNIX 
system
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196                                                                                                                                                   Appendix C



TIBSPI-EMA-Unix-Log-
V1

Logfile 
Template

TIBSPI-TIBCO-EMA
-UNIX-V1

Monitors the TIBCO 
Enterprise Management 
Advisor log file on a UNIX 
system

TIBSPI-RVRD-Unix- 
Log-V1

Logfile 
Template

TIBSPI-TIBCO- 
RVRD-V1

Monitors the TIBCO 
Rendezvous Routing Daemon 
log file on a UNIX system

TIBSPI-Hawk-Unix-Log
-V1

Logfile 
Template

TIBSPI-UNIX-Hawk-
Agent-V1

Monitors the TIBCO Hawk 
Agent log file on a UNIX 
system

TIBSPI-HawkHMA- 
Unix-Log-V1

Logfile 
Template

TIBSPI-UNIX-Hawk-
Agent-V1

Monitors the TIBCO Hawk 
MicroAgent log file on a 
UNIX system

TIBSPI-HawkTibRende
zvous -Unix-V1

Logfile 
Template

TIBSPI-UNIX-Hawk-
Agent-V1

Monitors the TIBCO Hawk 
Agent Rendezvous log file on 
a UNIX system

TIBSPI- WIN-EMA-V1 Group TIBSPI-Windows-V1 Contains templates that 
monitor the TIBCO 
Enterprise Management 
Advisor running on a 
Windows system

TIBSPI-WIN-RVRD-V1 Group TIBSPI-Windows-V1 Contains templates that 
monitor TIBCO Rendezvous 
running on a Windows 
system

TIBSPI-WIN-HAWK- 
Agent-V1

Group TIBSPI-Windows-V1 Contains templates that 
monitor the TIBCO Hawk 
Agent running on a Windows 
system
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TIBSPI- 
EMA-WIN-Log-V1

Logfile 
Template

TIBSPI- 
WIN-EMA-V1

Monitors the TIBCO 
Enterprise Management 
Advisor log file on a Windows 
system

TIBSPI-RVRD-WIN- 
Log-V1

Logfile 
Template

TIBSPI-WIN-RVRD-
V1

Monitors the TIBCO 
Rendezvous Routing Daemon 
log file on a Windows system

TIBSPI-Hawk-WIN-Log
-V1

Logfile 
Template

TIBSPI-WIN-HAWK-
Agent-V1

Monitors the TIBCO Hawk 
Agent log file on a Windows 
system

TIBSPI-HawkHMA- 
WIN-Log-V1

Logfile 
Template

TIBSPI-WIN-HAWK-
Agent-V1

Monitors the TIBCO Hawk 
MicroAgent log file on a 
Windows system

TIBSPI-HawkTibRende
zvous-WIN-V1

Logfile 
Template

TIBSPI-WIN-HAWK-
Agent-V1

Monitors the TIBCO Hawk 
Agent Rendezvous log file on 
a Windows system

Table 8

Name Type Group Description
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TIBCO SPI Self Management

Table 9

Name
Template 
Group Description

TIBSPI-Mon-Backend- 
V1

TIBSPI-UNIX
-Backend-V1

Monitors the TIBCO SPI 
Backend process on the 
management server. It sends a 
message to the HPOM Message 
Browser if Backend process is 
found not running. An operator 
initiated Action is available for 
that message to restart the 
Backend process.

TIBSPI-Mon-Frontend-
V1

TIBSPI-UNIX
-Frontend-V1

Monitors the TIBCO SPI 
Frontend process on the 
management server. It sends a 
message to the HPOM Message 
Browser if Frontend process is 
found not running. An operator 
initiated Action is available for 
that message to restart the 
Frontend process.
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TIBSPI-EMA-Unix-Mon
-V1

TIBSPI-UNIX
-EMA-V1

Monitors the TIBCO EMA 
process running on UNIX. It 
sends a message to the HPOM 
Message Browser if this process 
is found not running. An 
operator initiated Action is 
available for that message to 
restart the EMA process. HPOM 
Administrator may have to 
modify the operator initiated 
action if they have installed the 
EMA in a directory other than /
opt/tibco/ema/2.0 directory, 
and provide the location where 
EMA is installed in the specific 
environment.

TIBSPI-EMA-WIN-Mon
-V1

TIBSPI-WIN-
EMA-V1

Monitors the TIBCO EMA 
process running on Windows. It 
sends a message to the HPOM 
Message Browser if the process 
is not running. An operator 
initiated Action is available for 
that message to restart the EMA 
process.

Table 9

Name
Template 
Group Description
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Performance Metrics

Table 10

Name MO Type Alarm Graph Report Description

B001_MsgsSent RVD X X Number of messages 
sent by the RVD in 
the last polling 
interval

B002_MsgsRcvd RVD X X Number of messages 
received by the RVD 
in the last polling 
interval

B003_BytesSent RVD X X Number of bytes sent 
by the RVD in the 
last polling interval

B004_BytesRcvd RVD X X Number of bytes 
received by the RVD 
in the last polling 
interval

B005_PcktSent RVD X X Number of packets 
sent by the RVD in 
the last polling 
interval

B006_PcktRcvd RVD X X Number of packets 
received by the RVD 
in the last polling 
interval

B008_MissPckt  RVD RVD X X Number of packets 
missed by the RVD in 
the last polling 
interval
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B009_RetranPcktRate RVD X The RVD's 
retransmitted packet 
rate

B010_MissedPcktRate RVD X The RVD's missed 
packet rate

NumInboundMsgs JMS 
Server

X X Number of inbound 
messages received by 
the JMS Server

InboundMsgRate JMS 
Server

X The JMS Server's 
inbound message rate 
per second

NumOutboundMsgs JMS 
Server

X X Number of outbound 
messages sent by the 
JMS Server

OutboundMsgRate JMS 
Server

X The JMS Server's 
outbound message 
rate per second

NumPendingMsgs JMS 
Server

X X Number of pending 
messages for the JMS 
Server

NumJobsCreated BW 
Engine

X X Total number of jobs 
created for all process 
definitions in the BW 
Engine

NumJobsSuspended BW 
Engine

X X Total number of jobs 
suspended for all 
process definitions in 
the BW Engine

NumJobsSwapped BW 
Engine

X X Total number of jobs 
swapped for all 
process definitions in 
the BW Engine

Table 10

Name MO Type Alarm Graph Report Description
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NumJobsQueued BW 
Engine

X X Total number of jobs 
queued for all process 
definitions in the BW 
Engine

NumJobsAborted BW 
Engine

X X Total number of jobs 
aborted for all process 
definitions in the BW 
Engine

NumJobsCompleted BW 
Engine

X X Total number of jobs 
completed for all 
process definitions in 
the BW Engine

NumJobsCheckpointed BW 
Engine

X X Total number of jobs 
checkpointed for all 
process definitions in 
the BW Engine

TotalElapsedTime BW 
Engine

X X Total elapsed time in 
milliseconds of all 
jobs completed by all 
process definitions in 
the BW Engine

Table 10

Name MO Type Alarm Graph Report Description
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Reports

Table 11

Name Type Report Family Description

TIBCO Full 
Range

Report Family N/A Contains reports with all 
available data

TIBCO Last Full 
Month

Report Family N/A Contains reports with data for 
the last full month

TIBCO Last Full 
Week

Report Family N/A Contains reports with data for 
the last full week

TIBCO Yesterday Report Family N/A Contains reports with data from 
yesterday

TIBCO RVD & 
Network Interface 
Receive Rates 
(FR)

Report TIBCO Full 
Range

This report shows the top 10 
RVDs of all servers connected on 
the system.  The top 10 RVDs 
are selected based on the highest 
rate of packets received.  For 
each RVD also the Network 
Interface Receive Rates per 
second of the server are 
displayed.

TIBCO RVD & 
Network Interface 
Send Rates (FR)

Report TIBCO Full 
Range

This reports shows the top 10 
RVDs of all servers connected on 
the system.  The top 10 RVDs 
are selected based on the highest 
rate of packets sent.  For each 
RVD also the Network Interface 
Send Rates per second of the 
server are displayed.
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TIBCO RVD 
Missed Packets 
(FR)

Report TIBCO Full 
Range

This report shows the top 10 
RVDs of all servers collected on 
the system.  The top 10 RVDs 
are selected based on the highest 
number of missed packets.

TIBCO RVD 
Retrans & 
Network Interface 
Errors (FR)

Report TIBCO Full 
Range

This report shows the top 10 
RVDs of all servers collected on 
the system.  The top 10 RVDs 
are selected based on the highest 
retransmission percentage.  For 
each RVD also the Network 
Interface error percentages of 
the server are displayed.

TIBCO Top 10 
RVD Throughput 
(FR)

Report TIBCO Full 
Range

This report shows the top 10 
RVDs based on the highest 
number of messages sent.  The 
chart displays the daily sum of 
messages sent for each RVD.

TIBCO RVD & 
Network Interface 
Receive Rates 
(LFM)

Report TIBCO Last Full 
Month

This report shows the top 10 
RVDs of all servers connected on 
the system.  The top 10 RVDs 
are selected based on the highest 
rate of packets received over the 
last full month.  For each RVD 
also the Network Interface 
Receive Rates per second of the 
server are displayed.

Table 11

Name Type Report Family Description
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TIBCO RVD & 
Network Interface 
Send Rates (LFM)

Report TIBCO Last Full 
Month

This reports shows the top 10 
RVDs of all servers connected on 
the system.  The top 10 RVDs 
are selected based on the highest 
rate of packets sent over the last 
full month.  For each RVD also 
the Network Interface Send 
Rates per second of the server 
are displayed.

TIBCO RVD 
Missed Packets 
(LFM)

Report TIBCO Last Full 
Month

This report shows the top 10 
RVDs of all servers collected on 
the system.  The top 10 RVDs 
are selected based on the highest 
number of missed packets over 
the last full month.

TIBCO RVD 
Retrans & 
Network Interface 
Errors (LFM)

Report TIBCO Last Full 
Month

This report shows the top 10 
RVDs of all servers collected on 
the system.  The top 10 RVDs 
are selected based on the highest 
retransmission percentage over 
the last full month.  For each 
RVD also the Network Interface 
error percentages of the server 
are displayed.

TIBCO Top 10 
RVD Throughput 
(LFM)

Report TIBCO Last Full 
Month

This report shows the top 10 
RVDs based on the highest 
number of messages sent over 
the last full month.  The chart 
displays the daily sum of 
messages sent for each RVD.

Table 11

Name Type Report Family Description
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TIBCO RVD & 
Network Interface 
Receive Rates 
(LFW)

Report TIBCO Last Full 
Week

This report shows the top 10 
RVDs of all servers connected on 
the system.  The top 10 RVDs 
are selected based on the highest 
rate of packets received over the 
last full week.  For each RVD 
also the Network Interface 
Receive Rates per second of the 
server are displayed.

TIBCO RVD & 
Network Interface 
Send Rates (LFW)

Report TIBCO Last Full 
Week

This report shows the top 10 
RVDs of all servers connected on 
the system.  The top 10 RVDs 
are selected based on the highest 
rate of packets sent over the last 
full week.  For each RVD also 
the Network Interface Send 
Rates per second of the server 
are displayed.

TIBCO RVD 
Missed Packets 
(LFW)

Report TIBCO Last Full 
Week

This report shows the top 10 
RVDs of all servers collected on 
the system.  The top 10 RVDs 
are selected based on the highest 
number of missed packets over 
the last full week.

TIBCO RVD 
Retrans & 
Network Interface 
Errors (LFW)

Report TIBCO Last Full 
Week

This report shows the top 10 
RVDs of all servers collected on 
the system.  The top 10 RVDs 
are selected based on the highest 
retransmission percentage over 
the last full week.  For each RVD 
also the Network Interface error 
percentages of the server are 
displayed.

Table 11

Name Type Report Family Description
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TIBCO Top 10 
RVD Throughput 
(LFW)

Report TIBCO Last Full 
Week

This report shows the top 10 
RVDs based on the highest 
number of messages sent over 
the last full week.  The chart 
displays the daily sum of 
messages sent for each RVD.

TIBCO RVD & 
Network Interface 
Receive Rates (Y)

Report TIBCO Yesterday This report shows the top 10 
RVDs of all servers connected on 
the system.  The top 10 RVDs 
are selected based on the highest 
rate of packets received 
yesterday.  For each RVD also 
the Network Interface Receive 
Rates per second of the server 
are displayed.

TIBCO RVD & 
Network Interface 
Send Rates (Y)

Report TIBCO Yesterday This reports shows the top 10 
RVDs of all servers connected on 
the system.  The top 10 RVDs 
are selected based on the highest 
rate of packets sent yesterday.  
For each RVD also the Network 
Interface Send Rates per second 
of the server are displayed.

Table 11

Name Type Report Family Description
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TIBCO RVD 
Missed Packets 
(Y)

Report TIBCO Yesterday This report shows the top 10 
RVDs of all servers collected on 
the system.  The top 10 RVDs 
are selected based on the highest 
number of missed packets 
yesterday.

TIBCO RVD 
Retrans & 
Network Interface 
Errors (Y)

Report TIBCO Yesterday This report shows the top 10 
RVDs of all servers collected on 
the system.  The top 10 RVDs 
are selected based on the highest 
retransmission percentage for 
yesterday.  For each RVD also 
the Network Interface error 
percentages of the server are 
displayed.

TIBCO Top 10 
RVD Throughput 
(Y)

Report TIBCO Yesterday This report shows the top 10 
RVDs based on the highest 
number of messages sent 
yesterday.  The chart displays 
the daily sum of messages sent 
for each RVD.
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Glossary
Attributes

Represents information about an MO as a set of properties.

Backend Service

The backend service is a software component that receives data and 
information from the frontend subagent, converts the information to an 
HPOM recognized form, and allows HPOM to render the managed 
environment based on the management data.

Conversation 

A managed object that implements the Conversation management interface 
which represents one service’s view of a series of related messages.

Enterprise Management Advisor (EMA)

The TIBCO software that is the gateway through which the TIBCO 
environment is managed.

Event

An event is a change in the state of the MO.

Event Manager 

An Event Manager manages all events emitting from MOs.  The Event 
Manager is responsible for storing, retrieving and (if persistence is 
implemented) recovering events.

Frontend Subagent

The Frontend Subagent is a software component that is responsible for 
communicating with the TIBCO EMA software to gather management data 
about a TIBCO environment and its hosted applications.
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Managed Object (MO)

An MO is a management representation of a resource. An MO implements a 
management interface to provide a means to monitor and/or control the 
underlying resource. HPOM manages all managed resources in TIBCO 
environment through their corresponding MOs. In the context of this 
document, when we talk about the MO, we also refer to the managed resource 
itself.

Management interface

A management interface exposes the management capabilities of a resource. A 
Management interface is presented as a set of attributes, operations, and 
notifications to be accessed through a set of WSDL portTypes.

Managed Resource 

Any TIBCO application, product, or abstract management notion such as a 
class of business process, is referred to as a managed resource.

Model

A model is a set of objects, properties, and their relations.

Namespaces

Namespaces are used to uniquely associate the port types for an interface 
with a URI. Namespaces are defined in an MO and used in the WSDL file for 
an MO. 

Notification

A notification is a message that is sent or retrieved by one or more subscribers 
to inform that an event has occurred.

Notification Types

The set of exceptions and state changes that can be reported by an MO.

Operations

The set of functions that can be provided to support the management of an 
MO.
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PortTypes

A PortType is the atomic unit of management functionality. MOs can choose 
which management portTypes to implement but cannot partially implement a 
portType. A portType is defined for each interface category and is used in the 
WSDL file for an MO.

Resource 

A resource is a component of a deployed environment.

Resource View

An HPOM term that describes a UI representation of a computing 
environment from the system administrator point of view that starts with 
what applications are running on which hosts.

Relation

A relation is a type of association between MOs.

Relationship

A relationship specifies two managed objects and the relation to define how 
two specific objects are associated.

Service

An MO that implements the Service management interface which represents 
the management capabilities of a web service. This web service may be acting 
as the provider and/or the consumer of web service messages.

Service Effects Analysis (SEA)

SEA is a plug-in to HPOM that enables adaptive management.

Service View

The service view is a UI representation of a computing environment that is 
application-centric and describes all application dependencies. This view is 
the bases for root cause analysis of a failure condition, as well as the initial 
AIA and simple event correlations.
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Service Map 

An HPOM term to describe a graphic view into a managed environment. This 
view shows relationships among MOs.

Simple Object Access Protocol (SOAP)

The standard for web services messages. Based on XML, SOAP defines an 
envelope format and various rules for describing its contents. Seen (with 
WSDL and UDDI) as one of the three foundation standards of web services, it 
is the preferred protocol for exchanging web services.

Subscriber 

A subscriber is an entity that is interested in selected notifications from MOs. 
These notifications contain information about the state change in an MO. For 
scalability reason, subscription to notifications has an associated timeout. 
Subscription can be renewed before they expire.

Web Services Description Language (WSDL)

The standard format for describing a web service. Expressed in XML, a WSDL 
definition describes how to access a web service and what operations it can 
perform.

Web Services Execution Environment (WSEE)

An MO that implements the WSEE management interface which 
encapsulates the management capabilities of a web service execution 
environment.
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A
adaptive management, 107

advanced management
NNM integration, 127

advance management
SEA, 107

agent node, 35
adding, 40

AIA.cfg, 187, 188

AIA configuration file
editing, 187
reference, 187

alarms, 119

alerts, 109, 121

application group, 64

application manager, 107

assign template groups, 47

B
backend node

deploy template groups, 46

backend service, 21
configure, 42
register, 38

backlist correlation, 108

business management
architecture, 18

C
CA root certificate, 144, 145

check status
command, 54

client certificate, 146

Composer tool (ECS), 23

configuration
backend service, 38
backend service and frontend subagent, 

42
data sources, 45
frontend subagent, 45
SBA polling frequency, 124
SEA, 187
TIBCO SPI, 179
tool, 179, 187

correlation
architecture, 107
backlist, 108
enrich, 108
flapping, 109
multi-source, 109
rate, 109
repeated, 121

correlator
custom, 118
testCPU, 118

custom adapters, 85

custom adapters metric threshold values, 93
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D
data sources, 45

DEBUG log level, 122

deployment scenarios
co-located components, 27
consolidated, 26
remote frontend subagent, 27

deploy template groups, 46, 47

domain expert, 107

domain extensions, 29
TIBCO, 29

E
ECS, 23

correlation problems, 169

ECS composer, 108, 118

ECS engine, 109

EMASee Enterprise Management Advisor, 
14

Embedded Performance Component (Coda), 
131
errors starting, 163
logging, 98

Embedded Performance Component 
(Coda).log, 98

emiagent.log, 43

enable MSI, 115

enrich correlation, 108

Enterprise Management Advisor, 14
architecture, 24
business management overview, 18
monitor, 104
overview, 24

ERROR log level, 122

event
invoking operations, 79

event definition
creating, 118

event management, 79

events
viewing, 79

F
failover, 137

flapping correlation, 109

frontend.log, 166

frontend subagent, 22
assigntemplate groups, 47
configure, 42, 45
deploy template groups, 47
errors in log file, 166
error starting, 151
install, 39
uninstall, 62
verify install, 41

G
graphs, 97

creating bytes sent, 101
instance metrics, 102
performance, 129
viewing, 102

H
hardware requirements, 33

Hawk API, 18, 24
console, 24

Hawk MicroAgent, 25

HPjconfig tool, 35

HPOM, 31
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HP Performance Agent, 131

HP Performance Manager, 101

HP Reporter, 61, 81

HTTPS, 141
configuration parameters, 150
configuring, 144

I
INFO log level, 122

installation
frontend subagent, 39, 40
resource explorer, 59
SEA, 113
TIBCO SPI, 35

instance metrics
graphing, 102

J
Java console, 13

installing, 57
starting, 57

K
kernel parameters, 35

keystores, 144
setting up, 145
utility, 146

L
license

open source, 32

location candidates, 139

log4j, 122

logging, 122

logging.properties, 122

logging metrics, 81
custom adapters, 85, 93

log levels, 104
changing, 122

log levels, changing, 123

M
manageability, 73

managed nodeSee agent node, 40

managed resources
viewing, 74

management console, 13
Java console, 57
resource explorer, 59

management interfaces, 29

management server, 35

message drop rate, 85

message group, 64

message groups
reference, 191

message templates, 65

MetricDefinitions.xml, 81, 84

metric element attributes, 81

metrics, 81
changing threshold values, 95
collect data, 92
configuration file, 81
data sources, 45
graphing, 102
logging for custom adapters, 85, 93
multi-instance data, 88, 91
performance, 129

MO
filtering unwanted, 77
user friendly name, 99

monitor EMA agent, 104
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MSI, 115

multi-instance metric data
configuring, 88
configuring threshold, 91

multi-source correlation, 109

N
network dependencies, 127

network errors, 129

network monitoring, 133

network operator, 107

NNM
configuring, 133
enabling, 133
integration overview, 127
parameters, 180
requirements, 131

NNM ET, 131

node groups, 66

O
opc_adm operator

configuring, 37

opcmsg, 47

opctemplate, 50

open source license, 32

operational notification, 158
missing, 154

operator automated actions, 79

ovpa, 131

OVPM
RVD graphs, 101
view graphs, 102

P
patches

software, 34

perfomance, 101

performance graphs, 97

performance metrics
reference, 191

R
rate correlation, 109

receive rates, 129

regroup condition, 64

reinstall
templates monitor and commands, 66

remove
TIBCO SPI application group, 64
TIBCO SPI bits, 63
TIBCO SPI message group, 64
TIBCO SPI message templates, 65
TIBCO SPI node groups, 66
TIBCO SPI regroup condition, 64
TIBCO SPI user profile, 65
TIBCO SPI users, 65

repeated correlation, 121

reports, 22, 97
install, 61
performance, 129
reference, 191
view, 98

requirements
hardware, 33
NNM, 131
SEA installation, 32, 110
software, 32
software patches, 34
TIBCO SPI installation, 32
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resource explorer, 22
installing, 59
overview, 22
security configuration, 148
starting from command line, 60
starting from Java Console, 59
using, 47

restarting
TIBCO SPI, 51

runtime problems, 151

RVD
bus, 121
collecting, 84
create graphs, 101
data collection, 135
monitoring, 101
view graphs, 102

S
SBA

polling frequency, 124

sba-wsms.xml, 124

SEA
architecture, 107
composer tool, 108
configuration, 187
configuration tool, 116
default port, 111
error viewing WSMF events, 168
event definition, 118
installation, 113
installation requirements, 32
introduction, 23
MO discovery problems, 175
no MOs are deployed, 171
overview, 107
prerequisites, 111
roles, 107
running, 115
software requirements, 110
stop, 117
uninstall, 125
upload templates, 113

security, 141

self management, for TIBCO SPI, 104

send rates, 129

service
problem adding to map, 166

service engine
error, 175

service management, 74

service map
linking, 75
viewing, 74

service navigator, 13

service reporter, 129

service views, 127

SNMP, 128, 132

software requirements, 32
patches, 34
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SPI(TIBCO), see TIBCO SPI, 13

SPI (TIBCO)See TIBCO SPI, 13

SSL, 141
configuring, 144

standard management, 73

stopping
TIBCO SPI, 53

T
template groups

assign, 47
assign to backend node, 45
assign to Windows nodes, 49
deploy, 47
deploy to backend node, 46
deploy to individual UNIX nodes, 49
deploy to Windows nodes, 50
verify, 50

templates
TIBSPI_0009, 95
TIBSPI-Collect-Mon-V1, 94
TIBSPI-Hawk-WIN-Log-V1, 96
TIBSPI-UNIX-Backend-V1 template 

group, 45
TIBSPI-UNIX-Frontend-V1 template 

group, 47
TIBSPI-UNIX- V1 template group, 48
TIBSPI-Windows-V1 template group, 49
TIBSPI-WIN-HAWK-Agent-V1 template 

group, 96

templates monitor and commands, 66

testCPU correlator, 118

TIBCO Hawk logfile, 96

TIBCO SPI, 18
adaptive management, 107
applications reference, 191
backend service, 21
business management overview, 18
check status command, 54
configuration, 179
frontend subagent, 22
hardware requirements, 33
installation HP-UX and Solaris, 35
installation requirements, 32
Introduction, 13
introduction, 13
message groups, 45
message templates, 65
node groups, 66
remove bits, 63
reports, 22, 61
restarting, 51
self management, 104
self management reference, 191
software requirements, 32
stopping, 53
template groups, 45
troubleshooting, 151
uninstall, 62
user, 65
user profile, 65

TIBSPI_0009 template, 95

TIBSPI-Collect-Mon-V1 template, 94

TIBSPI-EventService-V1, 47

TIBSPI-Hawk-WIN-Log-V1 template, 96

TIBSPI-Metrics-V1, 47

TIBSPI-UNIX-Backend-V1 template group, 
45

TIBSPI-UNIX-Frontend-V1, 47

TIBSPI-UNIX-Frontend-V1 template group, 
47

TIBSPI-Unix node group, 38, 40
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TIBSPI-UNIX- V1 template group, 48

TIBSPI-Windows-V1 template group, 49

TIBSPI-WIN-HAWK-Agent-V1 template 
group, 96

trace levels, 105

trap events, 128

troubleshooting, 151

truststores, 144
setting up, 145

U
UDMMetricDefinition.xml, 81, 88, 93

UDM metric definition file, 85

UDM metrics, 45

uninstall
frontend subagent, 62
SEA, 125
TIBCO SPI, 62
TIBCO SPI bits, 63

V
verify

Frontend subagent installation, 41
start status, 54
stop status, 55
template groups, 50
TIBCO SPI, 54

W
WARN log level, 122

WCConfig.xml, 42, 179
transferring fails, 164

WC configuration file
editing, 179
editor error, 165
parameters, 180
reference, 179

WSDM
alerts, 109
channel, 18
overview, 29
XML interfaces, 29
221



222



We appreciate your feedback!

If an email client is configured on this system, by default an email window opens when you 
click on the bookmark “Comments”.

In case you do not have the email client configured, copy the information below to a web mail 
client, and send this email to docfeedback@hp.com

Product name:

Document title:

Version number:

Feedback:




	User Guide
	1 Introduction
	Audience
	Prerequisites
	Quick Start Instructions
	All Users
	First Time Users
	Repeat Users

	Chapter Summary
	Related Documents
	Overview of HPOM-TIBCO Business Management
	Standard Management Functionality
	Advanced Management Functionality (Optional)

	TIBCO SPI Conceptual Overview
	TIBCO SPI Backend Service
	TIBCO SPI Frontend Subagent
	Resource Explorer
	TIBCO SPI Reports

	Service Effect Analysis (SEA)
	TIBCO Enterprise Management Advisor
	Deployment Scenarios
	Consolidated Scenario
	Scenario 1: Co-located Components Scenario
	Scenario 2: Remote Frontend Subagent
	Scenario 3: Fully Distributed (Recommended)

	WSDM Overview
	XML interfaces


	2 Installation and Configuration
	Installation Process Summary
	Requirements
	Third Party License Review
	Software Requirements for Standard TIBCO SPI Installation
	Hardware Requirements
	Patches
	Kernel Parameters

	Installing and Configuring the TIBCO SPI Components
	Install the TIBCO SPI Depot
	Install the TIBCO SPI Depot on HP-UX
	Install TIBCO SPI Depot on Solaris
	Configure the Management Server
	Configuring the opc_adm Operator
	Register the Backend Service

	Install TIBCO SPI Frontend Subagent Component
	Add a Managed Node to the TIBSPI-UNIX Node Group
	Install the Monitors, Commands, and Actions on a Managed Node
	Install the Frontend Subagent
	Verifying the Frontend Subagent Install


	Configure the Backend Service and the Frontend Subagent
	Assign TIBCO SPI Templates
	Configure Data Sources for Metric Data Collection
	Assign Backend Service Templates
	Deploy Backend Service Templates

	Assign Frontend Subagent Templates
	Deploy templates to the Frontend Subagent Node

	Assigning Template Groups
	Assign the TIBSPI-UNIX- V1 Template Group
	Assign the TIBSPI-Windows-V1 Template Group

	Verifying Deployed Templates

	Start the TIBCO SPI
	Restarting the TIBCO SPI

	Stopping the TIBCO SPI
	Checking the TIBCO SPI Status
	Verifying a Start Status
	Verify a Stop Status

	Install the Java Console (Service Navigator)
	Starting the Java Console

	Install the HP Resource Explorer
	Starting the HP Resource Explorer from the Java Console
	Starting the HP Resource Explorer form the Command Line

	Install TIBCO SPI Reports
	Uninstalling the TIBCO SPI
	Uninstalling the Frontend Subagent
	Remove the TIBCO SPI Installed on HP-UX
	Remove the TIBCO SPI Installed on Solaris
	Remove TIBCO SPI Regroup Condition
	Remove TIBCO SPI Message Groups
	Remove the TIBCO SPI Application Group
	Remove the TIBCO SPI User Profile
	Remove the TIBCO SPI User
	Remove TIBCO SPI Message Templates
	Reinstall the Templates Monitor and Commands
	Remove the TIBCO SPI Node Groups From the HPOM Database

	Configuring TIBCO SPI to Run as Non-Root User

	3 Performing Standard Management Functions
	Service Management
	Viewing TIBCO Managed Resources
	Linking Other Service Maps
	Automatically Linking
	Manually Linking
	End-to-End View of TIBCO SPI Integrations

	Filtering Unwanted MO Types

	Event Management
	Viewing TIBCO Events
	Automatically Responding to Events

	Monitoring and Data Collection
	Metric Definition Configuration Files
	Modifying Data Collection
	Collecting Data for Custom Adapters
	Configuring Multi-Instance Metric Data
	Example: All Instance Data (Collect)

	Example: Specific Instance Data (Collect)
	Configuring a Threshold for Multi-Instance Metric Data

	Collection Data for Specific Metrics
	Monitoring Custom Adapter Metric Thresholds with HPOM
	Changing the Metric Data Collection Interval
	Changing the Metric Threshold Value
	Changing which Logfile to Monitor

	Reporting and Performance Graphs
	Using Embedded Performance Component (Coda)
	Embedded Performance Component (Coda) Logging
	View TIBCO SPI Reports
	Defining a User Friendly Name for an MO

	Monitoring Performance Metrics with HP Performance Manager
	Configure HP Performance Manager
	Create a Bytes Sent HP Performance Manager Graph for RVDs
	View the RVD Bytes Sent HP Performance Manager Graph
	Graphing Instance Metric Data in HP Performance Manager

	TIBCO SPI Self Management
	Modify Logging and Tracing Levels
	Changing Log Levels
	Changing Frontend Log Levels
	Changing Backend Log Levels

	Changing Trace Levels
	Changing Frontend Trace Levels
	Changing Backend Trace Levels



	4 Using Service Effect Analysis (Optional)
	Overview
	Service Composer Tool

	Requirements
	Prerequisites
	Apache Tomcat Setup
	Environment Setup

	Running the SEA Installer
	Running the SEA Component
	Enabling MSI
	Starting the SEA Component

	Running the SEA Configuration Tool
	Stopping the SEA Component
	Creating an Event Definition
	SEA Logging and Trace Information
	Changing Logging Levels

	Changing the MO Update Interval
	Uninstalling the SEA Component

	5 Using the NNM Integration (Optional)
	Overview
	Service Views of Network Dependencies
	Collecting SNMP Trap Events
	Performance Reports

	Requirements
	General Setup Requirements

	Enabling and Configuring the NNM Integration
	NNM Topology Integration Settings
	Changing the OVI JAVA Setting
	Changing the OVI Port Setting

	RVD Data Collection


	6 Implementing Failover
	Overview
	Adding Multiple Location Candidates

	7 Security Features and Configuration
	Overview
	Conceptual Architecture
	What is Secured
	What is not Secured
	Current Limitations


	Configuring HTTPS Communication
	Configuring the Frontend Subagent
	Configuring SSL/HTTPS
	Setting up a Keystore and Truststore for the Frontend Subagent

	Creating a Keystore and Importing Certificates
	Configuring the Resource Explorer
	Using the Frontend Subagent's Client Certificate
	Using a Separate Client Certificate for the Resource Explorer
	Starting the Resource Explorer

	Customizing HTTPS Configuration Parameters


	8 Troubleshooting
	Runtime Problems
	Frontend Subagent Does Not Stop
	Frontend Subagent Does Not Start
	Frontend Subagent is Unable to Connect to EMA
	Backend Service is Not Found
	TIBCO SPI Uses Backup EMA Instead of Primary EMA
	TIBCO Service is Not Visible
	Missing Operational Notification
	Verify TIBSPI-EventService-MSG-V1 Template is Configured
	Deploy the Templates
	Verify HPOM Messages Display in Message Browser
	Verify TIBCO EMA Agent is Sending Notifications
	Verify Frontend Subagent receives notifications
	Verify Resource Host Name
	Verify Source Object
	Verify Credentials
	Verify Communication with the HPOM Management Server
	Cleanup the HPOM Message Queues

	Performance Agent Does Not Start Up
	TIBCO SPI Fails to Detect HP Performance Agent

	Configure TIBCO SPI Application Errors
	Configure TIBCO SPI Application Does Not Start
	Configure TIBCO SPI Application Does Not Display Content
	Configure TIBCO SPI Application Fails to Transfer WCConfig.xml
	Configure TIBCO SPI Application Throws AWTException

	Frontend Logfile Errors
	Error Starting Notification HTTP Server
	Error Adding Service to Map
	Frontend does not Connect to the Backend
	Problem Logging Metric Data

	SEA Component Runtime Problems
	Shutdown Problems
	Viewing SEA WSMF Events
	Check if HPOM Events Work
	Check the SEA Log File for Captured Events
	Check the SEA Log for Event Subscription ERRORS/WARNINGS
	Check the OVComposer GUI

	ECS Correlation Problems
	Clean the Fact Store
	For Solaris 8.x

	No Managed Objects are Deployed
	Mgmt_sv Directory not Present
	Event Subscriptions Persistence
	Managed Object Discovery Problems
	Service Engine Related Problems
	Service Engine Error


	Using the Self-Healing Info Application

	A TIBCO SPI Configuration
	Editing WCConfig.xml
	Using the Configuration Tool

	WCConfig.xml Configuration Parameters
	<FrontendSection>
	<BackendSection>
	<NetworkingInfo>


	B SEA Configuration
	Editing AIA.cfg
	Using the Configuration Tool

	AIA.cfg Configuration Parameters
	<ManagedObjectInformation>
	<EventSubscription>
	<Event_Reporting>
	<OVSBA_Configuration>


	C List Templates and Reports
	Message Groups
	Applications
	Templates
	TIBCO SPI Self Management
	Performance Metrics
	Reports

	Glossary
	Index
	We appreciate your feedback!
	Comments



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (None)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.5
  /CompressObjects /Off
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.1000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 524288
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments true
  /PreserveOverprintSettings false
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Preserve
  /UCRandBGInfo /Preserve
  /UsePrologue true
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
    /Courier
    /Courier-Bold
    /Courier-BoldOblique
    /CourierNewPS-BoldItalicMT
    /CourierNewPS-BoldMT
    /CourierNewPS-ItalicMT
    /CourierNewPSMT
    /Courier-Oblique
    /Futura-Bold
    /Futura-Book
    /Futura-BookItalic
    /Futura-Heavy
    /Futura-Light
    /Futura-Medium
    /Futura-MediumItalic
    /Garamond
    /Garamond-Bold
    /Garamond-Italic
    /Helvetica
    /Helvetica-Bold
    /Helvetica-BoldOblique
    /Helvetica-Narrow
    /Helvetica-Narrow-Bold
    /Helvetica-Narrow-BoldOblique
    /Helvetica-Narrow-Oblique
    /Helvetica-Oblique
    /NewCenturySchlbk-Bold
    /NewCenturySchlbk-BoldItalic
    /NewCenturySchlbk-Italic
    /NewCenturySchlbk-Roman
    /Symbol
    /SymbolMT
    /Times-Bold
    /Times-BoldItalic
    /Times-Italic
    /Times-Roman
    /Webdings
    /Wingdings2
    /Wingdings3
    /Wingdings-Regular
    /ZapfDingbats
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 150
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 150
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /ColorImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 150
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 150
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /GrayImageDict <<
    /QFactor 0.76
    /HSamples [2 1 1 2] /VSamples [2 1 1 2]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 15
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 600
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects true
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile (None)
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /False

  /SyntheticBoldness 1.000000
  /Description <<
    /ENU ()
  >>
>> setdistillerparams
<<
  /HWResolution [600 600]
  /PageSize [612.000 792.000]
>> setpagedevice


