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Documentation Updates

This guide’s title page contains the following identifying information:

e Software Version number, which indicates the software version.

e Document Release Date, which changes each time the document is updated.

e  Software Release Date, which indicates the release date of this version of the software.

To check for recent updates, or to verify that you are using the most recent edition of a
document, go to:

http:/h20230.www2.hp.com/selfsolve/manuals

This site requires that you register for an HP Passport and sign-in. To register for an HP
Passport ID, go to:

http:/h20229.www2.hp.com/passport-registration.html
Or click the New users - please register link on the HP Passport login page.

You will also receive updated or new editions if you subscribe to the appropriate product
support service. Contact your HP sales representative for details.



Support

You can visit the HP Software Support web site at:

http:/www.hp.com/go/hpsoftwaresupport

This web site provides contact information and details about the products, services, and
support that HP Software offers.

HP Software Support Online provides customer self-solve capabilities. It provides a fast and
efficient way to access interactive technical support tools needed to manage your business. As
a valued support customer, you can benefit by using the HP Software Support web site to:

Search for knowledge documents of interest

Submit and track support cases and enhancement requests
Download software patches

Manage support contracts

Look up HP support contacts

Review information about available services

Enter into discussions with other software customers

Research and register for software training

Most of the support areas require that you register as an HP Passport user and sign in. Many
also require a support contract.

To find more information about access levels, go to:

http:/h20230.www2.hp.com/new_access_levels.jsp

To register for an HP Passport ID, go to:

http:/h20229.www2.hp.com/passport-registration.html
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1 HP Storage Essentials SRM Overview

HP Storage Essentials SRM (SE SRM) is a family of open standards-built
storage area network management and storage resource management
solutions that enable you to visualize, monitor, report on, provision, and
manage your heterogeneous storage environment with simplicity and speed.

The HP Storage Essentials SRM suite integrates with HP Systems Insight
Manager (HP SIM) to provide advanced server and storage management
capabilities. It features a base management console and an expanding
portfolio of value added plug-ins. HP Storage Essentials SRM is accessed
through HP SIM menu items that are labeled HP Storage Essentals SRM.

Key Features and Benefits of HP Storage Essentials

SRM

e Visualization

Discovers automatically and maps the storage network (DAS, SAN, NAS)
and backup topology by displaying the objects, path, and zones between
the application and the LUN on which the corresponding data resides.

e Zoning and provisioning

Enables end-to-end zoning and provisioning tasks at the host, switch, and
disk subsystem layers. Provides a common interface for a multi-vendor
storage environment.

e Utilization management



Monitors availability and utilization at hosts, switches, and arrays.
Provides graphical trending and forecasting. Soft Quota management
enables proactive monitoring of consumption levels. File system
management provides file-level scanning, analysis, reporting, and
policy-based management capabilities.

Performance management

Monitors performance from application objects down to storage
subsystems. Monitors applications, hosts, HBAs, switches, and disk
subsystems. Enables quick detection of bottlenecks that cause
performance problems.

Chargeback

Supports customizable chargeback values, depreciation formulas,
asset-based and storage-based chargeback models, and business unit
groupings. Reports enable administrators to associate costs with the
quality and quantity of storage used by different business units.

NAS management
Analyzes the impact of configuration changes and file sharing activities.
Backup management

Offers a single view of backup activities. Identifies unprotected
applications, servers, and files. Enables root cause analysis of backup
failure. Increases utilization of backup resources.

Standards-based architecture

Designs solution on the Storage Management Initiative Specification
(SMI-S), the storage industry standard for heterogeneous storage network
management based on the Common Information Model (CIM) and
Web-Based Enterprise Management (WBEM). Enables support for
multi-vendor storage infrastructures and ensures that investments are
protected.

CIM is a common data model of an implementation-neutral schema for
describing overall management information in a network/enterprise
environment. CIM consists of a specification and a schema. The
specification defines the details for integration with other management
models such as Simple Network Management Protocols (SNMPs),
Management Information Base (MIBs), and the Distributed Management
Task Force’s (DMTFs) Maker Interchange Formats (MIFs). The schema
provides the actual model descriptions.
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e Customizable reports

Generates an extensive set of out-of-the-box reports that satisfy
requirements related to capacity management, planning, performance
management, asset management, and chargeback. Reports can be
customized and scheduled for automatic email distribution. Supports a
wide variety of reporting formats, including HTML, XML, Microsoft Excel,
and PDF.

¢ End-to-end visibility of business applications

Provides an interface to monitor business applications, including their
associated infrastructure and interdependencies.

e Web-based global management console

Manages heterogeneous storage environments through a web-based user
interface.

¢ Reporting

Offers flexible, in-depth report generation in both predefined and
user-defined formats. It can also export data to other management
applications.

e Standards-based architecture

Protects user flexibility and investments with a standards-based interface
for managing heterogeneous storage environments.

e Storage server, network, and subsystem provisioning

Reduces manual processes and risk of downtime caused by free-space
outages with multi-level storage provisioning.

¢ Integrated storage management

Lowers cost of acquiring and managing a heterogeneous storage
environment by using multiple disparate point solutions.

You can find more information on features of HP Storage Essentials SRM and
other HP management products at the following HP web sites:

http:/www.managementsoftware.hp.com/

http:/www.hp.com/go/storageessentials

HP Storage Essentials SRM Overview 9
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HP Storage Essentials SRM SPI Overview

The HP Operations Smart Plug-in for HP SE SRM (the HP Storage Essentials
SRM SPI) integrates HP SE SRM with HP Operations Manager (HPOM). The
HPOM management scope for the HP Storage Essentials SRM SPI includes
storage infrastructure managed by HP SE SRM installed in an environment
that consists of the HPOM.

The HP Storage Essentials SRM SPI is used to monitor the HP SE SRM
services and infrastructure. The HP Storage Essentials SRM SPI, along with
the HP Operations Manager Integration for HP Systems Insight Manager (the
HP SIM Integration), integrates HP SE SRM with HPOM by forwarding
storage events through the HP SIM Integration.

The HP SIM Integration, together with the HP Storage Essentials SRM SPI,
allows the storage network to be monitored and managed from the HPOM
management server console.

The HP Storage Essentials SRM SPI enables HPOM administrators to
troubleshoot problems in the storage network before they become serious
enough to affect tools and, ultimately, the end-users. Storage events are
stored in the HPOM database. The HPOM intelligent agents are configured on
the HP SIM Central Management Server (CMS) and the HP SE CMS..
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Features and Functionality of the HP Storage Essentials

SRM SPI

e Service Discovery

Discovers the HP SE SRM CMS and HP SE SRM-managed hosts CIM
Extension services.

e Service and process monitoring

Monitors the availability of the HP SE SRM CMS and HP SE SRM CIM
Extension. Any service alerts can be communicated to the HPOM service
map and the HPOM active message browser. This enables administrators
to perform root-cause analysis of the inherent HP SE SRM services.

e Policy groups
Contains policies for monitoring the HP SE CMS process
(AppStorManager) and the HP SE CIM Extension process.

e Tool groups

Contains tools to start, stop, and view the status of the HP SE CMS
process (AppStorManager) and the HP SE CIM Extension process. It also
has a tool to import the SE Infrastructure elements to the SE Node Bank.

HP Storage Essentials SRM Overview 77
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2 Installing the HP Storage Essentials SRM
SPI

To avoid problems during installation, you should first read this section and
the documents named in this section before you start the installation process.

Requirements

Hardware Requirements

The following documents explain all the hardware requirements:

e For the HPOM 8.10:

HP Operations Manager for Windows Installation Guide
e For the HPOM 8.10 HTTPS managed nodes:

HP Openview Operations HTTPS Agent Concepts and Configuration
Guide

e For HPOM 8.10 DCE managed nodes:

HP Operations Manager OM DCE Agent Concepts and Configuration
Guide

13



Disk Space Requirements

Table 1

Disk space requirements

System

Operating System

Installation

Runtime
Files

Total

HPOM
management
server 8.10

Windows 2008 EE (32-bit)
Windows 2003 R2 (32-bit)

4 MB

1 MB

5 MB

OVOW 7.5

Windows 2003 (32-bit)

4 MB

1 MB

5 MB

HPOM managed
node

HP-UX 11.11

HP-UX 11.23 TA
HP-UX 11.23 PA
HP-UX 11.31 PA
HP-UX 11.31TA

Solaris 8, 9,10

RedHat Linux Advanced Server
4.0 (32-bit and 64-bit)

RedHat Linux Advanced Server
5.0 (32-bit)

SuSE Linux Enterprise Server
10 (32-bit)

1 MB

1 MB

2 MB

AIX 5.1,5.2, and 5.3

Tru64 5.1B

Microsoft Windows 2003 (32-bit
and 64-bit)

Microsoft Windows 2003 R2
(32-bit and 64-bit)

Microsoft Windows 2008 (32-bit)

1 MB

2 MB

>»
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No additional memory (RAM) is required either on the HPOM or on the
managed nodes for the HP Storage Essentials SRM SPI.
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Software Requirements

e OVO for Windows 7.50 or HPOM for Windows 8.10 updated with the
latest server and agent patches

e HP Systems Insight Manager 5.1 or 5.2
e HP SE 5.1or 5.1.1 (Linux) or HP SE SRM 6.0
e HP SIM Integration, Version 1.70

e HP Operations Smart Plug-In Self-Healing Integration Component,

Version 2.30

e Install OVOW_00244 patch to run the HP Storage Essentials SRM SPI

1.70 on HP OVOW 7.50

For more information on installing the HP SIM Integration, see the HP
Operations Integration for HP Systems Insight Manager Administrator’s
Reference for HP Operations Manager for Windows.

HPOM Management Server Versions

Table 2 Versions of HPOM management server

HPOM Management HPOM Agent
Server Operating System Types
OVO 7.50 e Microsoft Windows 2003 DCE
(32-bit)
HPOM 8.10 e Microsoft Windows 2003 HTTPS
(32-Dbit) DCE
e Microsoft Windows 2003 R2
(32-bit)
e Microsoft Windows 2008
EE (32-bit)
Installing the HP Storage Essentials SRM SPI 15



Table 3

HP Systems Insight Manager CMS Versions

Versions of HP Systems Insight Manager CMS
HP Systems Insight Manager
CMS Operating System
HP SIM 5.1 e Windows 2003 (32-bit)

HP SIM 5.2, 5.2 SP1, 5.2 SP2

Windows 2003 R2 (32-bit)

RedHat Linux AS 4 (32-bit and
64-bit)

RedHat Linux AS 5 (64-bit)
SuSE Linux ES 9 (32-bit)
SuSE Linux ES 10 (32-bit)

HP SE SRM CMS Versions

Table 4 Versions of HP SE SRM CMS

Table 5

16

HP SE SRM

Operating System

HP SE SRM 6.0, SP1, SP2
HP SE 5.1 SP5
HP SE 5.1.1 SP5

Windows 2003 (32-bit))
Windows 2003 R2 (32-bit)
RedHat Linux EL 4.0 (32-bit)
SuSE Linux ES 9 (32-bit)

CIM Extension and HPOM Agent Versions

Versions of CIM Extension and HPOM Agent
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Agent Operating System
CIM Extension Windows 2003 (32-bit and 64-bit)
HPOM Agent Windows 2003 R2 (32-bit and 64-bit)

Windows 2008 (32-bit)
HP-UX 11.11

HP-UX 11.23 PA

HP-UX 11.23 1A

HP-UX 11.31 PA

HP-UX 11.311A

Solaris 9

Solaris 10

RedHat Linux EL 4.0 (32-bit)
RedHat Linux EL 4.0 (64-bit)
SuSE Linux ES 9 (32-bit)
SuSE Linux ES 9 (64-bit)
AIX 5L 5.1

AIX 5L 5.2

AIX 5L 5.3

Tru64 5.1 B

Installing the HP Storage Essentials SRM SPI
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Installing the HP Storage Essentials SRM SPI

You can install the HP Storage Essentials SRM SPI from the HP Operations
Smart Plug-ins DVD. The Installer executable verifies whether HPOM is
installed. It also installs the package and loads the selected packages to the
HPOM management server. Follow these steps:

1 Make sure that the HPOM system where you want to install the HP
Storage Essentials SRM SPI meets the installation requirements listed at
the beginning of this chapter.

2 Log on to HPOM as an administrator.

3 Insert the HP Operations Smart Plug-ins DVD. The installation wizard
opens.

Chapfer 2
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7 HP Operations Smart Plug-ins - Installshield Wizard

Product Selection

Select the products and components wou want bo install,

HP Operations Smart Plug-ins For Windows
Produck/Component Yersion Installed Ackion
I IBM \WebSphere
[ sp1
I~ craphs

'l Reporks
I 2% Mekric Builder

[ InFarmix
[~ spI
[ Graphs
I~ Peports
I Microsoft SQL Server
[~ spI
[ Graphs
I~ Reports

{” Graphs
I~ Reports
I sybase
™ sp1
{” Graphs
I~ Reports
I HP SIM Inteqration
¥ HF Storage Essentials SRM Install  1.70.15

Checkboxes are disabled if the latest wersion of the SPI is already installed, Reparts
checkboxes are disabled if the HP Reporter is not installed or the repaorter service is
disabled and Graphs checkboxes are disabled if HP Peformance Manager is nok installed.

< Back i Blext = i Cancel
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4 Select SPI for HP SE SRM in the Product Selection window and click Next.

’ Selecting SPI for HP SE SRM in the Product Selection window also
installs HP SIM Integration.

5 Follow the on-screen instructions to complete the installation process.
The wizard displays the status of the installation.
6  Click Finish to exit from the installation wizard.

For more information on installing HP Operations new and upgraded
Smart Plug-ins, see the HP Operations Smart Plug-ins DVD, Installation
and Upgrade Guide.

Installing the HP Storage Essentials SRM SPI 2]



Upgrading the HP Storage Essentials SRM SPI

Follow these steps:

1

22

Read the hardware and software requirements provided at the beginning
of this chapter.

Preserve any policy customization you made in the previous version by
making a backup to save the complete and current HP Storage Essentials
SRM SPI policies.

Stop HP System’s Insight Manager SPI Event Listener using the Stop
Event Listener tool.

Remove nodes from the node group using the De-assign node from node
group tool.

Install the HP Storage Essentials SRM SPI from the DVD by following the
steps provided in Installing the HP Storage Essentials SRM SPI on
page 18.

Remove the old HP Storage Essentials SPI user role by following these
steps.

a Select Actions > Configure > User Roles. You can also click User
Roles Configuration Editor, which is located on the menu bar of the
main HPOM.

The User Roles window opens.
b  Select HP Storage Essentials SPI Admin, and click Delete

Ensure that the Auto-deployment registry variable Disable is set to
False.

Assign nodes to the node group that you removed using Assign node to
node group. Redeploy the instrumentations and policies manually if they
are not deployed automatically.

Run the Get HP SIM Credentials and Start Event Listener tools.
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Veritying Installation

Table 6 List of elements to be present on the HPOM console

Open the HPOM console and check that the following elements are present.

HPOM Console

Element

Node Groups

HP SE SRM CMS-Win

HP SE SRM CMS-Unix

HP SE SRM CIM Extn-Win
HP SE SRM CIM Extn-Unix

Tool Groups

HP Storage Essentials SRM

AppStorManager-Win
AppStorManager-Unix
CIM Extension-Win
CIM Extension-Unix
HPSESRMSPI Utils

Policy Groups

HP Storage Essentials SRM

AppStorManager-Win
AppStorManager-Unix
CIM Extension-Win
CIM Extension-Unix
Service Discovery

User Roles

HP SE SRM SPI Admin

If they are not present in the HPOM console, uninstall the HP Storage

Essentials SRM SPI (see Uninstalling HP Storage Essentials SRM SPI from
HPOM on page 64) and reinstall it (see Installing the HP Storage Essentials
SRM SPI on page 18).

Installing the HP Storage Essentials SRM SPI
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Installed File Locations

The installation process copies the necessary files on the HPOM.

Table 7 Location of the installed files on the HPOM

File Type Location on the HPOM

Binaries and Scripts <OvlInstallDir>install \ HPSESRMSPI
<HPOMSharelInstallDir>SPI-Share \ HPSESRMSP
I

Instrumentation <OvInstallDir>Data\shared \Instrumentation\Su
pported Operating Systems\ HP Storage Essentials
SRM

Documentation <OvInstallDir>install \HPSESRMSPI\doc

MofFiles <OvInstallDir>install \HPSESRMSPI\NLS\1033
\MofFiles

The following lists the directories that are used on deployment of the policies
to the HPOM managed node(s).

Table 8 List of Directories

Operating System File Location

HP-UX, Solaris, Linux, Tru64 | /var/opt/OV/bin/instrumentation

Microsoft Windows <OvAgentDir>\bin \instrumentation

AIX /var/lpp/OV/OpC/instrumentation

The HP Storage Essentials SRM SPI instrumentation scripts are copied into
these paths when the HP SE SRM instrumentation is deployed to the
managed nodes.
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3 Configuring the HP Storage Essentials
SRM SPI

Configuring the HP Storage Essentials SRM SPI requires the following tasks.

Task 1: Install the HPOM Agent on Nodes

The HPOM agent must be installed on all the nodes that needs to be managed
by the OM. Before starting, make sure that the system on which you want to
install the HPOM agent meets the installation requirements provided in
Chapter 2, Installing the HP Storage Essentials SRM SPI.

You can install the HPOM agent on a managed node by various methods. For
more information on the various installation methods, see the HP Operations
Manager for Windows Installation Guide and also the documents listed in
Chapter 2, Installing the HP Storage Essentials SRM SPI.

Task 2: Assign Nodes to the HP SE SRM Node Group

Assigning the AppStorManager Node to the Node Group

This tool assigns the node to the chosen HP SE SRM CMS node group and
deploys the HP SE SRM policy groups AppStorManager-Unix or
AppStorManager-Win (depending on your node’s operating system) and
Service Discovery policies. The service discovery policy deployment causes the
HP SE SRM discovery process to run. If an HP SE SRM service is not
discovered, the corresponding monitor policy is disabled.

25



To assign the nodes on which the SE SRM AppStorManager service is running
to the node group, follow these steps:

1 Log on to the HPOM management server, and start the HPOM Console.

2 Select Tools > HP Storage Essentials SRM > AppStorManager-Unix or
AppStorManager-Win and right-click Assign AppStorManager node to node
group.

3 Select All Tasks > Launch Tool. The Edit Parameters window opens.

T Edit Parameters
Parameters 1
E Azsign AppStorkd anager Windows node to node group

T ool Descrption:

Azsigns Storage Eszentials SEM AppStarkd anager Windows node to "HF SE_-:j
SAM CMS-wfin'" node group.

Command:
1::3n:ript.e:-:e Afnologo ““SOMIDLOEASPl-SharehHPSESRMSPINHPSESPL_ovawn

Parameters;

i

Select the nodes)services to replace $OPC parameters with:

w-[ &) HP SIM CM5-Unix -
=[S He 5TM CMS-win
= Jf=] 1M Agents-win

|:|. gufa

|:| OMIDLOS (Management Server) |

Launch... i Cancel 1 Help

4 From the Select the nodes/services to replace $OPC parameters
with, select the node on which the SE SRM AppStorManager service is
running.

Chapter 3



5 Click Launch.... The Tool Status window opens.

T Tool Status

Launched Toals:

Status I Action I StartiFirish Time | Mode 1 Commnand
Succeeded  Assign AppStar,.,  9/26/2008 11:4.,. ManagementSe... cscript.exe [inolaga “OMIDLORSPI-

« | B

Tool Qutput:

The node 'owidll7.ind.hp.com' is assigned to the nodegroup 'HP SE SREH EHS-Win_:;J

4] | M
s | T | e | b |

Configuring the HP Storage Essentials SRM SP/



This assigns the node on which the SE SRM AppStorManager process is
running to the HP SE SRM CMS-Unix or HP SE SRM CMS-Win node

group.

) When the managed node is assigned to the HP SE CMS-Win Node
group using “Assign Node to Node Group” Tool, the following
warning message is displayed on the HPOM.

Discovery command "C:\WINDOWS\system32\cmd.exe /C "perl
"C:/Documents and Settings/All Users/Application Data/HP/HP
BTO

Software/bin/instrumentation/HPSESPI_CreateHostServices.pl"""
returned with non-zero return value.

This occurs because HPSIM authentication is not provided. The
suthentication is provided when you run the Get HP SIM
Credentials tool from the HPSESRMSPI Utils tools group .

) When the new nodes are added in the HP SE SRM CMS-Unix or
HP SE SRM CMS-Win node group, the Service Discovery policy
is deployed to each new node.

Assigning the HP SE SRM CMS node to the node group also invokes
auto-deployment of HP Storage Essentials SRM SPI Service Discovery
and AppStorManager Service Monitoring policies to the node. The HP SE
SRM instrumentation gets auto-deployed along with the Service
Discovery policy to the node.

A The automatic policy deployment requires that the HPOM agent
be present on the managed nodes. If the HPOM agent is not
present on the Windows nodes, the management server deploys
the agent automatically. For UNIX nodes, the agent must be
installed manually. You can install the HPOM agent by various
methods. For more information, see HP Operations Manager for
Windows Installation Guide.

6  Assign the CIM Extension Node to the Node Group.

To assign the node on which the SE SRM CIM Extension process is running to
the node group, follow these steps:

1 Log on to the HPOM management server and start the HPOM Console.
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2 Select Tools > HP Storage Essentials SRM > CIM Extension-Unix or CIM
Extension-Win and right-click Assign CIM Extension node to node group.

3 Select All Tasks > Launch Tool. The Edit Parameters window opens.

T Edit Parameters

Parameters i

E Azzign CIM Extengion Unik node ko node graup

T ool Description:

Azzigns Storage Ezzentialz SEM CIk Estenzion Unik node to "HP SE SRk __:_j
CIk Estr-ldnis'' node group.

Command:
1CSD[iDLEHE Adnologo "WSOMIDLOZASPI-SharehHPSESRMSPISHPSESPI_ovown

Parameters:

i

Select the nodes)services to replace $OPC parameters with:

[ JEEl HP SIM CM5-win -
& JfE] M Agents-win

|:|- gufa
|:| OMIDLOS {Management Server)
[ omid)17 |
=

Launch... ’ Cancel 1 Help

4 From the Select the nodes/services to replace $OPC parameters
with, select the node on which the SE SRM CIM Extension process is

running.

5 Click Launch.... The Tool Status window opens.
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T Tool Status =

Launched Tools:

Status ] Ackion 1 SkarkFinish Time 1 Mode ] Command 1
Succeeded  Assign CIM Ext,..  9(26f2008 11:4... ManagementSe... cscript.exe ffnologo "\WOMIDLOSSPI-Share!..

Tool Qukput:

The node 'owiwintd.ind hp.com' is assigned to the nodegrowp 'HE SE SBEM CIM Ext,n—Unix'_:j

4 ]_*]:J
Save 1

Close i Help I

This assigns the node on which the SE SRM CIM Extension process is
running to the HP SE SRM CIM Extn-Unix or HP SE SRM CIM Extn-Win

node group.

’ When the new nodes are added in the HP SE SRM CIM Extn-Unix or HP SE
SRM CIM Extn-Win node group, the Service Discovery policy is deployed to
each new node.

Assigning the HP SE SRM CIM Extension node to the node group also invokes
auto-deployment of the HP SE SRM CIM Extension Service Monitoring policy
to the node.
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Task 3: Obtain HP SE SRM Credentials

To start the functionality provided with the HP Storage Essentials SRM SPI,
you must first enter the HP SIM credentials for each HP SE SRM CMS.

’ Enter the same credential that is used to log on to HP Systems Insight
Manager. The HP SIM credentials used must have the role Domain_Admin in
SE SRM CMS for the HP Storage Essentials SRM SPI to function correctly.
HP SIM credentials are stored in an encrypted format on the HPOM managed
nodes.

To obtain HP Storage Essentials SRM SPI credentials, follow these steps:
1 Log on to the HPOM management server and start the HPOM Console.

2 Select Tools > HP Storage Essentials SRM > HPSESRMSPI Utils and
right-click Get HP SIM Credentials.
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3 Select All Tasks > Launch Tool. The Edit Parameters window opens.

T Edit Parameters

Parameters i

? et HP SIM Credentialz

T ool Description:
Get uzermmame and pazsword of HP Systems Inzight kManager for HE 5164 __:_j

Inteqgration
[

Command:
1n:su:ri|:|t Afnologn ' EOvIinztallDirEinstal HPS I Inthconfig\HPS Ik Int_GetCredenti

Parameters:
j$|:|P|:_N|:|DE5

Select the nodes)services ko replace $OPC parameters with:
[ |[E HP SE SRM CMS-Unix -
=-[]E] HP SE SRM CM5-Win

(B gufa

-
1-[JF=] HP SE SRM INFRA
F-[ 1=l HP SIM CMS-Unis =

Launch... ’ Cancel i Help

4 From the Select the nodes/services to replace $OPC parameter
with option, select the node on which HP SIM CMS is running.

o

I

s

5  Click Launch. The following message is displayed if the selected node is HP
SE CMS on UNIX:

Enter the HP Systems Insight Manager username:

The following message is displayed if the selected node is HP SE CMS on
Windows:

Enter the HP Systems Insight Manager DOMAIN\username:
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6 At the prompt, enter the HP Systems Insight Manager user name for HP
SE CMS on this node and press Enter. The following message is displayed
at the prompt:

Enter the HP Systems Insight Manager password:

7 Enter the corresponding HP Systems Insight Manager password and
press Enter.

8 Re-enter the password to confirm. The following message appears:

Done creating hpsecms.conf file.
Press any key to continue .

The tool attempts to verify the user name and password. At the prompt,
press Enter to exit.

If the credentials entered are not authenticated by HP SE SRM, the
following message is displayed:

Failed to validate the HP SE CMS credentials. Possible
causes could be:

1. HP SE SRM CMS is not installed

2. HP SE SRM CMS service is not running

3. HP SE SRM CMS credentials incorrect

Press any key to continue .

9 Press Enter. The command prompt window closes.

’ After successful execution, the hpsecms.conf file is created on the
HP SE SRM CMS node.

The credentials are used for HP SE SRM service discovery.

A Service Discovery does not function correctly if the user name and
password are incorrect. If you do not know the user name and
password, contact your system administrator.
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Task 4: Import HP SE SRM Infrastructure

To get events from the HP SE SRM devices, you must import the
infrastructure for each of the HP SE SRM CMS. To import the HP SE SRM
Infrastructure, follow the below mentioned steps.

1 Log on to the HPOM Management Server and start the HPOM Console.

2 Select Tools > HP Storage Essentials SRM > HPSESRMSPI Utils
and right click Import HPSESRM Infrastructure

’ This tool can be executed only on HTTPS agent nodes.
3 Select All Tasks > Launch Tool. The Edit Paramenters window opens.

4 From the Select the nodes/services to replace $OPC parameters
with option, select the node on which the HP SE SRM CMS is running.
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T Edit Parameters

Parameters |

T Import HPSESR M InfraStructure

T ool D escription:

[uernies HPSESREM infrastructure detailz and adds hostz, switches and ;I
storage svstems to the Mode Bank

Cornmand:
I"ZEI winstallDirZinstall HPSESRMSPINS PI-SharehHPSESRMSPINHPSESPI_perl

Parameters:
I"ZEI ywlnzstallDirzinstal\HPSESRMSPINS PI-SharetHPSESRMSPIAHPSESRMSP

Select the nodes)services to replace $OPC parameters with:
=-[ = HP SE SRM CMS-Win -
—

#-[ 0= HR SIM CMS-Unix
#-[ 0= HR SIM CM5-win
#-[Jf=] 1M Agents-win

Launch... I Cancel Help
o

5 Click Launch. This will add all the Hosts, Switches and Storage Systems
to the Node Bank
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WINDOW S system32h cmd.exe
Add ing de Group HPF SE SEM HOSTS

Adding : cetus . .rose _hp.com =
Adding de hawthorn.rose.hp.com =
Add ing de 81 _voze _hp.com

Add ing de did s.rose . hp.com
Adding d ze. hp.com =
Adding de papasy hp.com =
Adding Mode owy .rose. hp.com =
Adding d rl.rosze. hp.com =
Add ing de cotopaxi.rose.hp.com =
Adding Mode Group HP SE SEM SWITCHE
Hdding MNod [ : 1T+
Add ing

Adding
g

witchl = gucceszful!
Ful?
ful?

sanmgrll
sanmyr3?
davidof
spinel

IR IR IR

: mackere
rayong
dubhi
Add ing
Adding 3 ;
Adding de = [ : Succe ult
Addin de L7 ITHCT 3 Successful?

6 Click Enter and the command prompt window closes.

Now the HP SE SRM Infrastructure (Hosts, Switches and Storage
Systems) is added to the OM Node Bank under the Node Group HP SE
SRM INFRA with the following sub groups.
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= HP Operations Manager - [Operations Manager : OMIDLOS" ... M[=]
Eﬂ' File | fckion  Mjew  Favorites  Window  Help | - |5’|_|

& *III&I#I@II@%W&@%n

|f_.,ﬂ Operations Manager : OMIDLOS
I ) Services

=- @ Modes

@ HP Defined Groups
{1 HP SE SRM CIM Extn-Uniz
{13 HP SE SRM CIM Extr-win
#-{1=] HP SE SRM CMS-Unix

- 1= HP SE SRM CMS-Win
SRVSfHF SE SRM TNFRA
. #-[=] HP 5E SRM HOSTS
&#-f=] HP 5E SRM STORAGESYSTEMS
- #-[= HP S5E SRM SWITCHES

-5 HP SIM CMS-Unix Al &

{3 HP SIM CMS-win =B [¥o

|Fi|l:er: | |

8 5

SEVErity | Cupl

— HP SE SRM HOSTS
— HP SE SRM SWITCHES
— HP SE SRM STORAGESYSTEMS

) To delete the HPSESRMSPI Infrastructure node groups and the nodes that
they contain, execute the following steps:
Open the Node Configuration Editor.

2 On the right pane, right click on HP SE SRM INFRA node group and click
on Delete.

3 A Confirm Delete window opens , click on Yes.

Configuring the HP Storage Essentials SRM SP/ 37



38

Task 5: Configure the OM Agent for a Non-root User

For information on configuring the OM agent to run as a non-root user, see the
HP Operations HTTPS Agent Concepts and Configuration Guide.

To configure non-root agents, follow these steps:

1
2

Log on to the managed node as a root user and open a terminal window.
Open the following instrumentation directory for HTTPS node:
cd /var/opt/0V/bin/instrumentation
Enter the following command at the command prompt:
./HPSESPI perl HPSESPI root.pl.
This command generates the HPSESPI.su file.

The following message is displayed on successful execution of the
command:

The script has completed successfully.

The HP Storage Essentials SRM SPI does not support a non-root HPOM agent
on AIX and Tru64 CIM Extension nodes.

Providing Access to HP Storage Essentials SRM SPI Applications

To provide access to HP Storage Essentials SRM SPI applications, follow these
steps:

1
2

Log on to the managed node as a root user, and open a terminal window.
Open the following file:

/etc/HPSESPI. su
Edit the file by uncommenting lines or by adding the following:

root:$CIMExtnPath/APPQcime/tools/start
root : $SCIMExtnPath/APPQcime/tools/stop
root : SCIMExtnPath/APPQcime/tools/status
root:/etc/init.d/appstormanager start
root:/etc/init.d/appstormanager stop

On HP-UX and Linux, the $CIMExtnPath is /opt
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On Solaris, enter the following command to get the value for §CIMExtnPath:

/usr/bin/pkginfo -r APPQcime
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4 Using the HP Storage Essentials SRM
SPI

Using the HP Storage Essentials SRM SPI Node Group

Installing the HP Storage Essentials SRM SPI creates the following node
groups (shown in the figure that follows):

e HP SE SRM CMS-Unix

e HP SE SRM CMS-Win

e HP SE SRM CIM Extn-Unix
e HP SE SRM CIM Extn-Win
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% HP Dperations Manager - [Operations Manager : OMIDLOS Nodes]

E File  Action Wiew Favorites  Window  Help

sl =gl EY ) Hﬂ&%ﬁ@%%ﬁ%ﬂm

E Operations Manager @ OMIDLOS =11 Severity 1 Duplicates 1 5 1 U 1 I 1 & 1 01 M 1 Feceived
=) @ 2ervices ¥, Minar 1 - - ¥ 5 ¥ ¥ 9fz3fzoo08
[+ Applcations € critical 15 - - % 5 C ¥ 9/z3/z008
fﬁ‘ Systems Infrastructure ¥ Minor 62 L. ¥ 5 ¥ % ofz3f2008
- % Defined Groups . et i RS R A
-] HP SE SRM CIM ExtrvLinix €3 Critical T - - ¥ o5 % 9232008
5] HP 5E SR CIM Extr-Win . Mnor 1 - - ¥ 5 ¥ W 9/23/2008
5 HP SE SRM CMS-Uix ¥, Minot 1 - - %S % ¥ 9/z3j2008
Ea HP SE SRM CMS-Win /2 Minoe ] T = T A =T v 1 e 1
Ea HF SE SRM INFRA B Critical 27 - - ¥ 5 T W 9232005
1 E‘:j HF SIM CMS-Lni €3 Critical 37 - - & 3 C ¥ 9/23/2008
Ea HP SIM CMS-'Win 5, Minor 57 - - X8 ¥ ¥ 9f23fzoo0s
fig 1M Agents-win €3 Critical 15 - - ¥ 5 % 92302008
1 qufa €3 Critical 68 - - ¥ 5 C ¥ 9j23/z008
3 [E OMIDLOS (Management Server) %, Minor 63 - - X8 W W 932005
‘ﬁfril‘iral 179 T - T S = [ practpryy )t
i ‘ .......................... j.:::::::::::::::::::::::'::::::::::::::::::::::::::

| Lrl P41 (W2 mzm A2 D44 (Bo

You can find more information about adding nodes in Task 2: Assign Nodes to
the HP SE SRM Node Group on page 25.

Node folders and tool folders are associated as follows:

Table 9 Association between nodes folder and tools folder

Nodes Folder Tools Folder

HP SE SRM CMS-Unix AppStorManager-Unix
HP SE SRM CMS-Win AppStorManager-Win
HP SE SRM CIM Extn-Unix CIM Extension-Unix
HP SE SRM CIM Extn-Win CIM Extension-Win
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Using HP Storage Essentials SRM SPI Tools

The HP Storage Essentials SRM SPI adds the top-level tools group in the

HPOM Application bank window. The HP SE SRM tools group contains the

following tools (shown in the figure that follows):
e AppStorManager-Unix

e AppStorManager-Win

e CIM Extension-Unix

e CIM Extension-Win

e HPSESRMSPI Utils

Using the HP Storage Fssentials SRM SPI
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The HP Storage Essentials SRM SPI tool folders contain a number of tools
that enable the HPOM administrator to manage HP SE SRM.

The AppStorManager-Unix or AppStorManager-Win tools group contains
tools that can be run on HP SE CMS nodes (UNIX or Windows).
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Using the AppStorManager Tools Group

The AppStorManager-Unix or AppStorManager-Win tools group includes
tools for HP SE SRM AppStorManager that are run on HP SE CMS server

nodes.

The AppStorManager tools group includes the following tools that monitor the
HP SE SRM AppStorManager process on selected UNIX or Windows nodes.

Table 10 Name of tools which monitor the HP SE SRM AppStorManager process

Tools Group Tool Name

Description

AppStorManager-Unix | AppStorManager-Unix Start

Starts the HP SE SRM
AppStorManager service on
selected Unix nodes.

AppStorManager-Unix
Status

Status of HP SE SRM
AppStorManager service on
selected Unix nodes.

AppStorManager-Unix Stop

Stops the HP SE SRM
AppStorManager service on
selected Unix nodes.

Assign AppStorManager
Unix node to node group

Assigns Storage Essentials SRM
AppStorManager Unix node to
\"HP SE SRM CMS-Unix\" node

group.

De-assign AppStorManager
Unix node from node group

De-assign AppStorManager Unix
node from node group.

Using the HP Storage Fssentials SRM SPI
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Tools Group Tool Name

Description

AppStorManager-Win AppStorManager-Win Start

Starts the HP SE SRM
AppStorManager service on
selected Windows nodes.

AppStorManager-Win Status

Status of the HP SE SRM
AppStorManager service on
selected Windows nodes.

AppStorManager-Win Stop

Stops the HP SE SRM
AppStorManager service on
selected Windows nodes.

Assign AppStorManager
Windows node to node group

Assigns the Storage Essentials
SRM AppStorManager Windows
node to \"HP SE SRM
CMS-Win\" node group.

De-assign AppStorManager
Windows node from node

group

De-assigns Storage Essentials
SRM AppStorManager Windows
node from \"HP SE SRM
CMS-Win\" node group.

Using CIM Extension Tools Group

The CIM Extension-Unix or CIM Extension-Win tools group includes the
following tools for HP SE SRM CIM Extension that are run on the HP SE
SRM CIM Extension nodes (UNIX or Windows). The CIM Extension tools
group includes the tools that monitor HP SE SRM CIM Extension services on

the selected UNIX or Windows nodes.

Table 11 Name of the tools which monitor HP SE SRM CIM Extension services
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Tools Group

Tool Name

Description

CIM
Extension-Unix

CIM Extension-Unix
Start

Starts HP SE SRM CIM
Extension on selected UNIX
nodes

CIM Extension-Unix
Status

Status of the HP SE SRM CIM
Extension on selected UNIX
nodes.

CIM Extension-Unix
Stop

Stops HP SE SRM CIM
Extension on selected UNIX
nodes.

Assign CIM Extension
Unix node to node

group

Assigns Storage Essentials
SRM CIM Extension Unix node
to \"HP SE SRM CIM
Extn-Unix\" node group.

De-assign CIM
Extension Unix node
from node group

De-assigns Storage Essentials
SRM CIM Extension Unix node
from \"HP SE SRM CIM
Extn-Unix\" node group.

Using the HP Storage Fssentials SRM SPI

47



Tools Group Tool Name

Description

CIM

CIM Extension-Win

Extension-Win Start

Starts the HP SE SRM CIM
Extension on selected Windows
nodes.

CIM Extension-Win

Gets the status of HP SE SRM

Status CIM Extension on selected
Windows nodes.

CIM Extension-Win Stops the HP SE SRM CIM

Stop Extension on selected Windows
nodes

Assign CIM Extension | Assigns Storage Essentials

Windows node to node | SRM CIM Extension Windows

group node to \"HP SE SRM CIM

Extn-Win\" node group.

De-assign CIM
Extension Windows
node from node group

De-assigns Storage Essentials
SRM CIM Extension Windows
node from \"HP SE SRM CIM
Extn-Win\" node group.

Using the HPSESRMSPI Utils Tools Group

The HPSESRMSPI Utils tools group includes the following tools for
performing administrative tasks for the HP Storage Essentials SRM SPI.

Table 12 Name of the tools used for performing administrative tasks for the HP
Storage Essentials SRM SPI

Tools Name

Description

Clean HPSESRMSPI- Deletes HP SE SRM SPI files on selected Unix managed nodes
Unix

Clean HPSESRMSPI- Deletes HP SE SRM SPI files on selected Windows managed
Win nodes

Get HP SIM Credentials

Get username and password of HP Systems Insight Manager

for HPSESRMSPI.
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Tools Name

Description

Service Discovery—Unix

Performs HP SE SRM Service Discovery on the UNIX managed
nodes.

Service Discovery—Win

Performs HP SE SRM Service Discovery on the Windows
managed nodes.

Tracing Off-Unix

Sets HPSESRMSPI tracing to OFF state on UNIX managed
nodes.

Tracing Off-Win

Sets HPSESRMSPI tracing to OFF state on Windows managed
nodes.

Tracing On—Unix

Sets HP Storage Essentials SRM SPI tracing to ON state on the
UNIX managed nodes.

Tracing On—Win

Sets HP Storage Essentials SRM SPI tracing to ON state on the
Windows managed nodes.

Version Verify Verifies the version of HP Storage Essentials SRM SPI files.
Import HPSESRM Queries the HPSESRM Infrastructure details and adds Hosts,
Infrastructure Switches and Storage Systems to the Node Bank.

Note: Get HP SIM Credentials" tool must be executed before
running this tool

Using the HP Storage Fssentials SRM SPI 49



50

Using HP Storage Essentials SRM SPI messages

Events generated by the HP Storage Essentials SRM SPI are grouped under
the HP Storage Essentials SRM SPI's HPSESRMSPI-StorageEssentials_ SRM
message group. The messages generated by the HP Storage Essentials SRM
SPI policies appear in the message browser window and contain information
that is vital for understanding the problems being reported.

Eg, Action  Yew Favoltes  Window  Help

= HrDperationsManager - [Dperations Masager : DMIDLOZ Modes' | HP SE SRH CM5-Win' MIDLOT]

The figure below shows messages for the HP Storage Essentials SRM SPI.

e > 0IE H

T v B4R IR TREEE

il [ HP SE 5 CIM Extn-bin o] [Seserity | Dup... ||| | Mode | Object | Applicalion | Group
i [l HP SE 4 CHS-Liix Oitleenal 1 - OMID. 15154 .. Systems InsghtManager  HPSZSRASA-
B [l HP SE FHCHS-Win Oitloenal 1 - OMID.. 15.154.. SystewsInsghtManager  HPSZSRASA-
* E OELOL Otlamal 1 . OMID.. 1S.154 .. SystemsInsghtiansger  HPSZSRASA-
& B QMELES Otional 1 . OMID.. 15.154 .. Systems InsghtManager
: 0= m Oihomal 1 < OMID.. 15154 .. Systems Insi
& I oMoLLe [ Joeral 1 - OMID.. 1S risi
] EE HE SIMOMS-Unix Oumnal 1 < JMID.. 15,154 .. Systems Ins
[0} Ea HE SIMOME-Win Oihornal 1 < OMID.. 15.154 .. Systems Insght Manager  HPSZSRMSA-
i [ 1M Agests-win Oloenal 1 + JMID.. 15.154 .. Systems InsghtManager  HPSZSRMSA-
W B4 ssousrd Oitlornal 1 < OMID.. 15054 .. Systems InsghtManager  HPSZSRASA-
I} OMIDLL Oihomal 1 < DMID.. 15,154 .. Systemws Insght Manager  HPSZSRYSA-
@ I3 oMIDLEZ (Managemeit Seaver)
s I osoucs (| CTRll A Y P T CoT - S{L- R T l? Tt

Filter:

The message headline describes the scope of the problem. In the HP Storage
Essentials SRM SPI context, this information can be categorized into the

following:

e Node — Name of the Event source device

e Application — Systems Insight Manager

e Text — A single line description of the event.
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¢ Object — CIM CMS Server
¢  Group - HPSESRMSPI-StorageEssentials_SRM

Using the HP Storage Fssentials SRM SPI
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Using the HP Storage Essentials SRM SPI Service Map

The HP Storage Essentials SRM SPI provides the administrator with the
additional perspective of service views. It discovers the services automatically
and uses the discovered data to generate service maps that can be viewed by
the administrator from the HPOM console.

The HP SE SRM managed hosts are discovered by querying the SE SRM CMS
for its managed hosts. Therefore, some of the nodes represented in this tree
may not be HPOM managed nodes. Status is shown only for CIM Extension
nodes that have an HPOM Agent installed and the HP Storage Essentials
SRM SPI configured.

You can decide whether these nodes must be configured as HPOM managed
nodes or not. You can also decide whether the HP Storage Essentials SRM SPI
policies must be installed or not. If the nodes in this tree are HPOM managed
nodes with the HP Storage Essentials SRM SPI policies deployed, the service
view node status changes based on the status of the CIM Extension on the
node is displayed.

The following service map shows the status of the HP SE AppStorManager
process.
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The service status implications of the service map are the following:

Table 13 Service status implications of the service map

Item Description
1 SE SRM CMS node
2 Nodes with CIM Extensions installed or running
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By default, status propagation rules for the objects in the HP SE SRM service
tree are defined such that if the HP SE SRM CIM Extension service objects is
critical (item 2 in the previous figure), the higher service objects status are
decreased by two levels to minor.

If the HP SE SRM AppStorManager service objects is critical (item 1 in the
previous figure), the higher service objects status are decreased by a level to
major.

The parent service does not change the status of a child object and, by default,
calculation rules for the HP SE SRM service trees are set to Most Critical.
Therefore, if a parent service has more than one child service, the parent
service assumes the status equal to the highest severity of its child services.

The following service map shows that the CIM Extension service on the node
highlighted in red is not running.

£= HP Dpen¥iew Operations - [Dperations Manager : BONGO'Services\Systems Infrastr... [lj=] B3
[ﬁ’ File  Ackion  ‘iew  Favorites  Window  Help | E |E|5i
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Eﬁ Applications £,
Ergf? Systems Infrastructure Iﬁ HF Starage E ssentiak
Ef’ HP Storage Essentials
=B " HF 3torage Essentials Services
Ehg% T res ﬁ HF Stora ei;s_;tials Services
@ jweshtha.india. hp. corm = g
@ nt197233,india,hp, com Y
ﬁ' revatl.uﬁudlé.hp.com Ld-g B
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L]--# HP Systerns Insight Manager o = ey
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,
=
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[Filter: [ |

The service discovered by the HP Storage Essentials SRM SPI enables
root-cause analysis of problems in crucial elements on the CIM Extension
node in an HP SE SRM network managed storage network.
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Viewing Services

The service views are created after HP SE SRM CMS node is added to the HP
SE SRM CMS-Unix or HP SE SRM CMS-Win node group, and service
discovery is invoked. For information on adding SE SRM CMS to the HP SE
SRM CMS-Unix or HP SE SRM CMS-Win node group, see Task 2: Assign
Nodes to the HP SE SRM Node Group on page 25.

Running the appropriate Service Discovery tool on the SE CMS node
generates services in the HP SE SRM service map. Make sure that you
perform the steps described in Task 3: Obtain HP SE SRM Credentials on
page 31 before performing the following steps for viewing the discovered HP
SE SRM service.

To view the discovered HP SE SRM service, follow these steps:
1 Log on to the HPOM management server, and start the HPOM console.

2 Select Services > System Infrastructure on the left pane of the HPOM
console. The HP SE SRM service map is displayed in the right pane, as
shown on page 54.

’ By default, the HP Storage Essentials SRM SPI service discovery policy is
configured to run service discovery every day at 2:00 am. You can change the
service discovery period by modifying the Service discovery policy. The
changed discovery period comes into effect only after the policies are
redeployed on the HP SE SRM CMS node.
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Importing SE Infrastructure into OM NodeBank.

In the present scenerio, all events are generated from the SE managed
Devices mapped to the SIM CMS.. To correctly map all the events to the
devices we have to add the nodes to OM Nodebank. SE managed nodes are
queried and added to the OM Node Bank as message nodes.

When the events reach the OM from SIM CMS Server, the events are mapped
to SE Managed Nodes instead of SE CMS Server.

Information about the SE Infrastructure is collected from the SE Discovery
Database. The following device types in SE are collected and added to OM
Node bank.

e Hosts
e  Switches
e Storage Systems

In OM for Windows, these mesages are added as external nodes in the OM
Node Bank.

In OM for Unix, these messages arwe added as “Message Allowed Node” in the
OM Node bank.

A new node group called HP SE SRM INFRA is added to add the all the
created nodes. These nodes are added to sub-groups which we must create.
These sub-groups are:

e HP SE SRM INFRA HOSTS,
e HP SE SRM INFRA SWITCHES
e HP SE SRM INFRA STORAGE SYSTEMS
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Using HP Storage Essentials SRM SPI User Roles

The installation of the HP Storage Essentials SRM SPI adds a new user role,
HP Storage Essentials SRM SPI Admin, to HPOM as shown in the following
figure.

i User Roles

Marme | Descripkion - ey, .,
ALx-admin Administrator For ALY nodes

Alx-operator Operator For ALY nodes Cuplicate ... i
HP 5IM Inkeqgration Admin Administrator for HP SIM Inkeqgrs

HP Storage Essentials SRM SPL Admin Adminiskrator For HP Skorage Ess Delete ’
HPI%-admin Administrator For HPUX nodes -
HPUX-operator Operator For HPUY nodes .
Lirnz-adrnin Administrator For Linux nodes %j
Linux-operatar Cperator For Linuyx nodes

Message Administrator - Sample arants rights for all message-rel:

Message Operator - Sample arants own and launch commanc

Palicy Adminiskrator - Sample arants rights For all policy-relate:

Palicy COperator - Sample Grants read-permission For policie_

Solaris-admin Administrator For Solaris nodes

Solaris-operator Operator For Solaris nodes

TruGd-admin Administrator for Trugd nodes | .

< ] _>1—l

Close 1 Help

The HPOM administrator uses user roles to simplify the process of assigning
responsibilities to HPOM users. The users associated with the role HP
Storage Essentials SRM SPI Admin can access all the HP Storage Essentials
SRM SPI tools, policies, and HPSESRMSPI-StorageEssentials_SRM message
groups assigned to them, and can manage and control the HP SE SRM CMS
and HP SE SRM CIM Extension nodes.

The HP Storage Essentials SRM SPI Admin user role assigns the following
authorizations:

e Access all messages with message group attribute
HPSESRMSPI-StorageEssentials_ SRM from HP SE SRM CMS or HP SE
SRM CIM Extension node.

Using the HP Storage Fssentials SRM SPI
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Execute any tool in the HP Storage Essentials SRM Tools groups.

Update the HPOM service map, displaying the HP SE SRM services
successfully discovered.
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5 Uninstalling the HP Storage Essentials
SRM SPI

Deleting HP Storage Essentials SRM SPI Instrumentation
from Nodes

To remove HP Storage Essentials SRM SPI instrumentation from the
managed nodes, follow these steps:

1 Open the HPSESRMSPI Utils tools group in the HP Storage Essentials
SRM SPI tools group.

2  Run the Clean HPSESRMSPI-Unix tool on the selected Unix managed
nodes.

3 Run the Clean HPSESRMSPI- Win tool on the selected Windows managed
nodes.

Removing Nodes from the Node Group

Removing a node from the node group involves the following tasks.

Task 1: Remove the AppStorManager Node from the Node Group

To remove the node on which the HP SE SRM AppStorManager service is
running from the HP SE SRM CMS-Unix or HP SE SRM CMS-Win node
group, follow these steps:

1 Log on to the HPOM management server, and start the HPOM Console.

2 Select Tools > HP Storage Essentials SRM > AppStorManager-Unix and
right-click De-assign AppStorManager node from node group.
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3 Select All Tasks > Launch Tool. The Edit Parameters window opens.

T Edit Parameters
FParameters i
E De-azzigh AppStortd anager *indaows node fram node group

T ool Description:

De-azzigns Storage Ezzentialz SAM AppStortdanager YWindows node from _:j
"HP SE SRk CMS-wfin' node group.

Command:
1CSCTiDt.EHE Adnologo "“SOMIDLOEASP-SharehHPSESRMSPISHPSESPL_ovown

Parameters:

i

Select the nodes)services ta replace $OPC parameters with:
[ @) HP SE SRM CMS-Uris -
=-[]fE] HP SE SRM CMS-Win

(B3 qufa

-
1-["]F&] HP SE SRM INFRA
1-[]F=1 HP SIM CMS-Unix -

Launch... 1 Cancel Help

4  Select the node in the HP SE SRM CMS-Win node group in the Select
the nodes/services to replace $OPC parameter with window pane.

e [

IF]-

p

5 Click Launch.... The Tool Status window opens.
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T Tool Status

Launched Toals:

Skatus i Ackion i Skart{Finish Time i Mode i Command
succeeded  De-assign AppS... 902602008 12:1... ManagementSe...  cscript.exe [inologo "\ \OMIDLOSYSPI-SharetH. .

(| | B

Tonl Qutput:

al

The node 'omidll?.ind.hp.cowm' iz de-assigned from the nodegroup 'HP SE SEM CHS-Win'

4 o
Save I

Close l Help l

6 Repeat the previous steps to remove nodes from the HP SE SRM
CMS-Win node groups using Tools > HP Storage Essentials SRM >
AppStorManager-Win > De-assign AppStorManager Win node from node group.

Task 2: Remove the CIM Extension Windows Node from the Node
Group
To remove the node on which the HP SE SRM CIM Extension service is

running, from the HP SE SRM CIM Extn-Unix or HP SE SRM CIM Extn-Win
node group, follow these steps:

1 Select Tools > HP Storage Essentials SRM > CIM Extension-Unix, and
right-click De-assign CIM Extension Windows node from node group.
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2 Select All Tasks > Launch Tool. The Edit Parameters window opens.

T Edit Parameters
Parameters i
E De-azzign CIM Extenzion Unix node fram node group

T ool Description:

De-azzighz Storage Ezsentialz SRM ClM E stenszion Unix node from "HP SE __:_j
SAM CIkM Extn-Unix'" node group.

Command:
1csu:ri|:|t. exe Afhologo "AOMIDLOZSPl-Shareb HPSESRMSPIYHPSESPL_ovown

Parameters:

i

Select the nodes)services ko replace $OPC parameters with:

=[] HP SE SRM CIM Extn-Unix -
aviwinta

1-[1EE] HP SE SRM CIM Extri-win
-[](8] HP SE SRM CMS-Unix
[ J[E] HP SE SRIM CMS-YWin
-[][8] HP SE SRM INFRA -

Launch... ’ Cancel Help
Fa

3 Select the node in the HP SE SRM CIM Extn-Unix node group in the
Select the nodes/services to replace $OPC parameters with window
pane.

e B e O e (OO

4 Click Launch.... The Tool Status window opens.
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T Tool Status WE

Launched Tools:

Status 1 Ackion 1 Start{Finish Time 1 Mode 1 Command
succeeded  De-assign CIM .., 9/26/2005 12:1... ManagementSe... cscript.exe [fnologo "\\OMIDLOZISPI-SharelHPSESRMS. .,

1 | 3]

Tool Qukput:

The node 'oviwint9 ind.hp.com' is de-assigned from the nodegroup 'HP S5E SRM CIM Extn-TUnix'

f of
Save !

Close I Help I

5 Repeat the previous steps to remove nodes from the HP SE SRM CIM
Extension-Win node groups using the Tools > HP StorageEssentials SRM >
CIM Extension-Win > De-assign CIM Extension-Win node from node group.

) The nodes in the SE INFRA Node Group are not SOM managed nodes and
hence do not have to be removed from their node groups. Uninstalling the SE
SRM SPI will automatically remove the SE INFRA Nodes and their node

groups.
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Uninstalling HP Storage Essentials SRM SPI from HPOM

To uninstall the HP Storage Essentials SRM SPI components from HPOM,
follow these steps:

’ Make sure that HPOM managed nodes are not present under the HP Storage
Essentials SRM SPI node groups. They must be moved out of their respective
groups before uninstalling the HP Storage Essentials SRM SPI. For
information on removing the HPOM managed nodes, see Removing Nodes
from the Node Group on page 59.

1 Insert the HP Operations Smart Plug-ins DVD, Installation and Upgrade
Guide.

2 Select Remove products to proceed to the product selection dialog box.

3 In the Product Selection Uninstall window, select SPI for HP SE SRM and
click Next. The Product Selection Uninstall window opens.
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ii5 HP Dperations Smart Plug-ins - InstallShield Wizard

Product Selection Uninstall
Select the products and components yiou wank ko Uninstal.

Uninstalling the HP Storage Essentials SRM SPI
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Selecting HP SIM Integration in the Product Selection Uninstall window also
uninstalls the HP Storage Essentials SRM SPI.

4  Select Remove.

5  Click Finish to complete the uninstallation procedure and exit the wizard.

This removes all the configuration files and executables of the HP Storage
Essentials SRM SPI from the HPOM server. The HP Storage Essentials SRM
SPI node groups, policies, and tools are also removed from the HPOM.

For more information on uninstalling HP Operations New and Upgraded
Smart Plug-ins, see the HP Operations Smart Plug-ins DVD, Installation and
Upgrade Guide.
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Uninstalling HP Storage Essentials SRM SPI
Components from HPOM

Most of the components of the HP Storage Essentials SRM SPI in HPOM are
automatically removed during the uninstallation of the product. However, the
HP Storage Essentials SRM SPI Admin user role must be removed manually.

Removing HP Storage Essentials SRM SPI User Roles

To remove the HP Storage Essentials SRM SPI user roles, follow these steps:

1 Select Actions > Configure > User Roles. You can also click User Roles
Configuration Editor, which is located on the menu bar of the main HPOM.
The User Roles window opens.

i User Roles

Mame | Descripkion - MleEw, ., i
AL<-admin Administrator for ALY nodes

Alx-operator Cperakor For 81X nodes Cuplicate ... !
HF SIM Integration &dmin Administrator for HP SIM Integre

HP Skorage Essentials SEM SPI Admin Administrakor for HP Storage Ess Delete 1
HPU-adrnin Administrator for HPUX nodes -
HPLI¥-operator Cperakar For HPUYK nodes :
Linuz-admin Administrator for Linux nodes .mj
Linuzx-operatar Operator For Linux nodes

Message Administrakor - Sample Grants rights for all message-rel:

Message Operator - Sample Grants own and launch commanc

Policy Administrator - Sample Grants rights for all policy-relate:

Puolicy Operator - Sample Grants read-permission For policie |

Solaris-adrin Administrator for Solaris nodes

Solaris-operakar Cperakar For Solaris nodes

Trué-admin Administrator for Trugd nodes | &

4| I _'j_j

Close 1 Help

2 Select HP Storage Essentials SRM SPI Admin, and click Delete.
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6 Troubleshooting

Start by checking the following to verify that the HP Storage Essentials SRM
SPI environment is installed and configured correctly:

e Make sure that the HP Storage Essentials SRM SPI is installed properly.
For more information, see Installing the HP Storage Essentials SRM SPI
on page 18.

e Make sure that the HP Storage Essentials SRM SPI is configured
properly. For more information, see Chapter 3, Configuring the HP
Storage Essentials SRM SPI.

If the HP Storage Essentials SRM SPI is correctly installed and configured,
the messages appearing in the HPOM message browser will be intercepted by
the HP Storage Essentials SRM SPI policies and will appear in the HPOM
message browser in the form you expect.

If the problem persists, refer to the following list of common problems and
their solutions.

Error Messages and Solutions

No HP SE SRM service monitoring events arrive on the HPOM
Message Browser console

Solution:

e Make sure that the connection between HPOM and the HP SE SRM CMS
and the CIM Extension nodes is up and running.

e Verify that the HPOM agent is correctly installed and configured on the
management server, and the HPOM agent processes (especially the
control agent and message agents) are running.
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e Make sure that HP SE SRM CMS and CIM Extension nodes are added to
the appropriate node groups (see Task 2: Assign Nodes to the HP SE SRM
Node Group on page 25).

HP SE SRM services are not visible in the HPOM console

Solution:

e Make sure that the connection between the HPOM and the HP SE SRM
CMS nodes is up and running.

e Verify that the HPOM agent is correctly installed and configured on the
management server, and the HPOM agent processes (especially the
control agent) are running.

e Ifthe HP SE SRM CMS credentials are invalid, there might be error
messages in the service discovery log at <OvAgentDir>\log\javaagent.log
on the HP SE SRM CMS node indicating authentication failures.

e Make sure that the Service Discovery policies present in Policy
Management > Policy Groups > HP Storage Essentials SRM > Service
Discovery are deployed on the HP SE SRM CMS nodes. To check whether
the policies are correctly deployed, right-click the node, select View > Policy
Inventory, and ensure that the Service Discovery policies are present. You
can also check the service discovery log at
<OvAgentDir>\log\javaagent.log on the HP SE SRM CMS node for error
messages.

Auto-deployment of policies fails on OVOW 7.50

Verify that the following registry key is set to value 0:

SOFTWARE \Hewlett-Packard\ OVEnterprise\ Management
Server \ AutoDeployment\ Disable
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SHS-related tools fail on non-root HTTPS node; says cannot open
SPI_SE.xml

Troubleshooting

When the HPOM agent is migrated from root user to non-root user, the
Version Verify tools fail with the following error.

Cannot open collector output file /tmp/SPI SE/SPI_ SE.xml for
writing.

Solution:

If the HPOM agent is migrated from root user to non-root user, delete or
rename the HP Storage Essentials SRM SPI files/directories from /tmp on the
nodes that were created by root user.
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A HP Storage Essentials SRM SPI Policy
Groups

The high-level HP Storage Essentials SRM policy groups are available in HP
Storage Essentials SRM SPI policy groups.

The policies provided with the HP Storage Essentials SRM SPI are grouped
under the HP SE SRM policy group as shown in the following figure.
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§= HP Dperations Managet - [Operations Manager : OMIDLDS! Policy management' Policy groups'HP Storage Essentials SRM]
[if Ele Acbon Wew Favorkes Window Help

«= BEspeXRR( 2B

5 Operations Maneger : OMIDLES

| Desaription verson | Latest [Type [ catar

Hame
[+ B Services | Tl AppstorManager-Unix
5 (gl Hedes [E8 apestorManager-vin
18 £ Tools [Eflcm extension-Urix
Iy, Certificske requests M Extensicawin
=1 & Palicy management @Sewicc Discovery
- Pelicy groups
) [ Herarchical hlode Groups

i
of| AppStortanager-in
-l CIM Extension-Uiix
. E_”T] CIM Extansion-Win
-[[zl Service Discavery
4] [ HPOM Salf Managemart
= fj] Micrezaft Windaws
[ Openiis_polcies
-l OpenMs_SP1_pokcies
4/ ] Saples
H @] Service Reparts Mantenance
41 [ 1 for Unbe 05
-5l Ager poliies greuped by type
) [Z0 Server policies grouped by type
& Daploymenk packages
L Deployment: jobs

Messages generated by the HP Storage Essentials SRM SPI policies are
assigned an HPOM severity level as defined in the policy groups. By default,
all messages generated by an HP Storage Essentials SRM SPI policy belong to
the HPSESRMSPI-StorageEssentials_SRM message group.

Policies in the AppStorManager and CIM Extension policy groups for the
indicated operating systems monitor the status of the AppStorManager
service running on HP SE SRM CMS nodes, and the HP SE SRM CIM
Extension service running on the HP SE SRM managed nodes. These policies
generate messages to indicate any status change in the monitored services.

Policies in the Service Discovery policy group discover the SE SRM services
when deployed on HP SE SRM CMS nodes.
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Table 14 List of policies in the Service Discovery policy group

Policy Group Policy Name Description Policy Type
AppStorManager-Unix | HPSESRMSPI-AppStor | Monitor HP Storage | Measurement
Manager-Unix Essentials SRM Threshold
AppStorManager
service on Unix.
AppStorManager-Win HPSESRMSPI-AppStor | Monitor HP Storage | Measurement
Manager-Win Essentials SRM Threshold
AppStorManager
service on Windows
CIM Extension-Unix HPSESRMSPI-CIM Monitors HP SE SRM | Measurement
Extension-Unix CIM Extension on Threshold
Unix
CIM Extension-Win HPSESRMSPI-CIM Monitors HP SE SRM | Measurement
Extension-Win CIM Extension on Threshold
Windows
Service Discovery HPSESRMSPI-Storage | Discovers services of | Service

Essentials. SRM_Servic
es

the hosts managed by
the SE SRM
AppStorManager

Auto-discovery

The CIM extension can be either an extension to the Windows WMI service or
a separate executable called AppStorWin32Agent service. The

HPSESRMSPI-CIM_Extension-Win monitor policy monitors only the
AppStorWin32Agent service. HPSESRMSPI-CIM_Extension-Win is disabled
if this service is not present or only the extension to the WMI service is

present on a Windows managed node.

HP Storage Essentials SRM SPI Policy Groups
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S
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Document title:
Version number:
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