Can't change requestor in Service Manager 7 (SM7) Service Catalog

  • KM492188
  • 28-Aug-2008
  • 28-Aug-2008

Error

In the SM 7.01 web client, using the ESS Service Catalog, the "Request For "can not be modified. When on the "svcCat.disp.item" form the fill on the Requested For does not work. The same behavior happens when selecting an item from the cart summary to modify (svcCat.edit.item). Even when one type in a new name (rather than using the fill) it won't save the change or get added to the cart with the new name.  The issue does not happen in  the eclipse client.
Server RTE: 7.01.048
Server OS: Windows 2003
Web Client: 7.01.048
Eclipse Client: 7.01.053
RDBMS: Oracle 10g

Cause

ESS users should be able to override the 'Requested for' value. The behavior you are seeing is the result of having two '$requested.for' fields on the form even though they are set up to be mutually exclusive. SCR 42008 opened for this issue.

 

Fix

SCR 42008